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Appendix: SAS Press Template Styles 

1. Project Startup 
You will best help your reader if you 

● appeal to the target audience with real-world situations;  
● devise specific and easy-to-follow chapter titles and headings;  
● introduce each new concept; 
● select data that produces the results that you intend to explain;  
● compose chapters of equal scope and length; and 
● write well-organized, efficient example code. 

To avoid extra work at the end of your project, carefully review this document, as well as the SAS Press Style 
Guide, before you begin writing. Review all contents in the startup packet your developmental editor provided. 

2. SAS and JMP Software 
Ensure that you are using the most up-to-date software and solutions. For a list of all SAS and JMP products, 
see http://www.sas.com/products/index.html.  

http://www.sas.com/products/index.html
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To request SAS software, submit the Software Request Form found here: 

http://support.sas.com/publishing/publish/authorsw_form.html  

3. Manuscript Submission 
At each phase, deliver your chapters as separate files—not one large file.  

At each phase, submit all image files, all data sets, all programs files, and an updated table of contents. 

3.1 Sample Chapters 
If your publishing agreement requires you to submit a sample chapter, or chapters, then include the following in 
your submission: 

● a current table of contents, or outline, of your entire book; 
● a separate folder containing all images saved as individual files—all original figures, all screenshots, 

and all outputs; and   
● a separate folder containing all programs and applicable data sets. 

3.2 Draft Manuscript 
Include the following items with your draft manuscript submission: 

● a current table of contents for your entire book; 
● written permission to use any copyrighted material that appears in the book; 
● a separate folder containing all images saved as individual files—all original figures, all screenshots, 

and all outputs; and   
● a separate folder containing all programs and applicable data sets. 

Your draft manuscript will be reviewed for content and structure. A copyedit will not be provided at this phase. 

3.3 Final Manuscript 
Include the following items with your final manuscript: 

● final chapter files that address your reviewers’ suggested revisions 
● all front matter 1 
● a high-resolution color photo portrait for each author of the book 
● a separate folder containing final images  
● a separate folder containing final programs and data sets 
● the final References list 
● the completed marketing questionnaire 

4. Copyright Permissions 
You must obtain written permission from the owner if you reproduce or adapt copyrighted information of any 
kind—whether text, figures, or data.  

Obtain permissions early.  

                                                           
1. Front matter includes About This Book, About the Author, and the Acknowledgments.  
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If possible, avoid using copyrighted material by using “dummy” data rather than a real data set, or use an open-
source data set. Do not assume that any data on the Internet is public domain; most is not. 

If you must incorporate copyrighted material, do the following: 

1. Review SAS Legal Support Services’ Copyright FAQs: http://legal.na.sas.com/Pages/Copyright-
FAQ%27s.aspx.  

2. Contact the copyright owner for permission to use the material. Calling the publisher first often 
expedites obtaining permission. 

3. Refer to the sample permission request form included in your startup packet.  
4. Pay any fees required; as a general rule, SAS Press does not pay permissions fees. 
5. Send a copy of all permissions correspondence to your editor; submit the completed permissions 

tracking form to your editor. We cannot begin final production of your book until all permissions are 
submitted.  

Copyedit and production cannot begin until all copyright documentation is submitted. 

5. Template 
SAS Press has developed a custom template (.dotx file) for use with Microsoft Office (MS) Word files. You 
must use Word 2010 or a later version.  

Before beginning work, update your Word options for each chapter file to turn off image compression, 
following the instructions here: https://support.office.com/en-us/article/Turn-off-picture-compression-
81a6b603-0266-4451-b08e-fc1bf58da658. 

Write within the template, and apply only the approved template styles to the elements of your chapter. The 
approved styles are all prefixed with the letter “A” for easy identification—for example, ABodyCopy is the main 
SAS-approved paragraph style.  

We cannot customize elements of our style for your book.  

5.1 Write Your Chapter in the Template 
Write your content directly into the template by simply saving the .dotx file as a .docx file. Alternatively, you 
may cut and paste. Follow these steps:  

1. Double-click the template file to open it. 
2. Select File ► Save as to rename the template file as a .docx file.  
3. Then either copy and paste or type your content directly into the .docx file.  

5.2 Always Check That the Template File Is Attached to Your Chapter 
Store your chapter files and the .dotx file in the same location on your computer. The template can easily 
become detached when the files are emailed or moved. Before you resume work on emailed or moved files, 
always check that the template is attached. 

First, enable your Developer tab on your Word Ribbon by following these instructions:  

1. Click the File tab. 
2. Click Options. 
3. Click Customize Ribbon. 
4. Under Customize the Ribbon and under Main Tabs, click the Developer check box. 

Next, complete these steps to ensure that the SAS Press template is attached: 

http://legal.na.sas.com/Pages/Copyright-FAQ%27s.aspx
http://legal.na.sas.com/Pages/Copyright-FAQ%27s.aspx
https://support.office.com/en-us/article/Turn-off-picture-compression-81a6b603-0266-4451-b08e-fc1bf58da658
https://support.office.com/en-us/article/Turn-off-picture-compression-81a6b603-0266-4451-b08e-fc1bf58da658
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1. Click the Developer tab. 
2. Click Document Template. The Templates and Add-ins window opens (Figure 1). 
3. In the Templates and Add-ins window, under Document template, click Attach. Drill down to 

where you saved the template .dotx file.  
4. Double-click the template file to add it to the field in the Templates and Add-ins window.  
5. Click the checkbox in front of Automatically update document styles. Click OK. 
6. Before emailing or moving the file, return to the Templates and Add-ins window, and uncheck 

Automatically update document styles. Click OK and save the file. 

Figure 1. The Templates and Add-Ins Window 

 

5.3 Locate Styles 
Click the Home tab on the Word ribbon. Click the down-arrow in the right-hand bottom corner of the styles 
menu (Figure 2). The Styles pane, which vertically lists all styles available, will pull down. 

Figure 2. The Word Styles Pane 
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5.4 Set the Styles Pane Options 
Click the little arrow in the lower right-hand corner of the Quick Styles window on the Word Ribbon. Then 
click “Options” in the lower right-hand corner. Set the options as appears in Figure 3. Click OK. 

 

5.5 Apply Styles 
To apply a style from the Styles pane, place your cursor in the text that you want to style. Then, in the Styles 
pane, click the style that you want to apply. For specifics on which style to use for which element of your 
chapter, see the Appendix. 

6. Graphics 
Almost all books are published both in print and as ebooks. So that your book will look its best in both formats, 
adhere to the following instructions closely. 

6.1 General Standards 
The following standards apply to graphics in general. 

6.1.1 Submit Individual Image Files  
Submit all images individually, each in the correct format for its type. See sections 6.1 to 6.3 for the correct file 
format for each image type—output, screen-captured images, and original figures.  

In addition to submitting individual image files, insert your images where they should appear in the chapter.  
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6.1.2 Size Figures Properly 
Create each image as closely as possible to the size it will be in the book, adhering to the following: 

● Prefer medium-sized figures, 4 to 5 inches wide (288 to 360 points).  
● Stay under the maximum width for a figure, 5.85 inches (421 points).  
● Print out and check the result for readability of text and symbols. 
● Do not size figures from within Word. 

6.1.3 Use Color Correctly 
Adhere to the following instructions regarding color. 

Do Not Use Color Functionally 
Do not rely on color to make distinctions or highlight a region in an image: In the print publication, all colors 
will appear only in grayscale. For figure annotation style, see the SAS Press Style Guide.  

Choose a Subdued Color Palette 
Where you have a choice, choose a subdued color palette of a few coordinated colors and use it consistently 
throughout the book. Try to coordinate colors with those of the output style. Avoid garish colors and other 
visual “noise.” 

Prefer 100% Solid Colors for Contrast 
Use solid colors to maximize contrast. Use tints or gradients no lower than 12% of the solid color. To check for 
sufficient contrast, print out color pages from a black-and-white printer.  

Submit Images in Color 
Because the print publication will be in black and white, and your ebook will be in color, submit all figures in 
color. 

6.1 Output 
Do not generate output with the older, Base SAS (CHART, PLOT, or the like) or SAS/GRAPH (GCHART, 
GPLOT, or the like). Instead, use the new SG procedures available as part of the Output Delivery System 
(ODS).  

Use the SAS Press custom style to use to generate the tables or graphs for your book. This style establishes the 
color palette, fonts, font sizes, line weights, and other elements that will yield pleasing results in print and in the 
ebook. To generate output, complete the following steps. 

Step 1: Run the Code to Create an ODS Template 
In the files your editor delivered to you, look for CustomSapphire.sas. Run CustomSapphire.sas to create a 
template that will be kept in your SAS User profile.  

Step 2: Set Your Margins 
Your editor has provided you a custom Word template in one of two trim sizes: 7.5 × 9.25 inches (small trim), 
or 8.25 × 11 inches (large trim).  

To set your margins, regardless of output type or file format, use the trim-appropriate code in Table 1. 
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Table 1. Setting Margins for Your Output 

If you are using this template trim size . . . Then use this code: 

7.5 × 9.25 inches (small) /* Set the dimensions for the page */ 
options papersize=letter  
        orientation=portrait 
        leftmargin=1.5in  
        rightmargin=1.5in  
        topmargin=1.55in  
        bottommargin=1.55in; 

/* suppress default text generated by SAS */ 
options nolabel nodate nonumber; 

8.25 × 11 inches (large) /* Set the dimensions for the page */ 
options papersize=letter  
        orientation=portrait 
        leftmargin=1.25in  
        rightmargin=1.25in  
        topmargin=1in  
        bottommargin=1in; 

/* suppress default text generated by SAS */ 
options nolabel nodate nonumber;

Step 3: “Sandwich” Your Own Code in the ODS Execution Steps 
Every time you generate an output for your book, sandwich your own code in the appropriate code for your 
output type and file format. Then insert your code in accordance with Table 2. 

Table 2. Generating and Inserting Output, by Output Type and File Format 

Results will look like Figure 4. 

If you are 
generating . . . 

Use this 
format: To generate that format, use this code: And insert this way: 

Tables only RTF ods rtf file='testImage.rtf' 
        image_dpi=300  

                style=sasuser.customSapphire; 

/* example code goes here */ 

ods rtf close; 

Copy and paste into 
Word. 

Output from 
SAS 
University 
Edition 

RTF 
or 
PDF 

1. Use RTF code for output as shown above.
2. Insert before this code: ods _all_ close;
3. Edit code to insert the ODS statements before the

code that runs for the example.
4. Use icons in output to download to Word (for

tables) or PDF (for graphics).
5. Use ODS code for multi-page output. See the SAS

documentation.

Download file from 
SAS University 
Edition to local drive. 
Insert file into Word. 

http://support.sas.com/documentation/cdl/en/webeditorug/68254/HTML/default/viewer.htm#n0lyxx45gr31pan1vmm8z5f952l3.htm
http://support.sas.com/documentation/cdl/en/webeditorug/68254/HTML/default/viewer.htm#n0lyxx45gr31pan1vmm8z5f952l3.htm
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Figure 4. Appearance of SAS Press Custom Output Style 

Model Information 

Data Set WORK.FACTORIAL 

Response Variable yield 

Response Distribution Gaussian 

Link Function Identity 

Variance Function Default 

Variance Matrix Diagonal 

Estimation Technique Restricted Maximum 
Likelihood 

Degrees of Freedom 
Method 

Residual 

Save each output as a separate file for submission to your editor; include your figure number in the file name. 

6.2 Screen-Captured Images 
Use screen captures for images only when you have to show the interface. Adhere to the following standards as 
you produce your screenshots. 

6.2.1 Use Screenshots in Appropriate Circumstances 
Consider inserting a screenshot into your chapter in the following circumstances: 

● to first orient the user to the GUI  
● to guide the user through a particularly difficult part of the interface  
● to show typical field entries (but avoid repeating images just to show different entries) 
● to show a navigation sequence (but prefer just the first GUI screen and any that present difficulties) 

Avoid using a screen capture in the following circumstances: 

● the task uses an install shield or wizard 
● text alone is unlikely to lose the reader 
● the screen shows empty fields 
● the target user is advanced 

6.2.2 Adhere to Screenshots Specifications 
Adhere to these standards in creating your screenshots: 

● In your Windows settings, turn transparency off.  
● Capture images at 96 dots per inch (DPI). Most monitors provide this resolution. Mac monitors do not.  
● Capture images with borders and drop shadow effects turned off.  
● Save your screen captures as .tif files. Include the figure number in your image file name. 
● Scale down each image just enough to place it within the margins of the chapter file. 
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6.2.3 Capture Screenshots on a Personal Computer 
Follow these steps to capture a screen on your PC: 

1. Zoom in on the region you want to capture. 
2. Press PrtScn.2  
3. Open Paint, click Edit, and then click Paste. 
4. Select the part of the image you want to keep and use the Crop tool. Don’t scale the image in Paint. 
5. Save each of your figures as a separate .tif file in a folder by chapter. Include the figure number in the 

file name. 
6. Insert copies of your figures into your chapter file. Production will finalize image sizes later.  

6.2.4 Capture Screenshots on a Mac 
Press Command (⌘)-Shift-3. The screenshot is added to your desktop as a .png file. They are automatically 
named "Screen shot (date and time).png." Save these files as .tif files before inserting them into your Word 
document. 

6.3 Original Figures 
Use one of the following applications and file formats to create any original figures your need in your book: 

● Adobe Illustrator (preferred) 
● Adobe Photoshop 
● Adobe Photoshop Elements 
● MS PowerPoint 
● MS Visio 

Save your figures as .tif or .eps (vector) images at a resolution of 300 DPI. 

Adhere to the following SAS Press standards: 

● Use 11-point Arial font for any text in the figures. 
● Avoid explanatory passages in images. For figure annotation style, see the SAS Press Style Guide.  
● Orient axis labels and text for horizontal left-to-right reading whenever possible.  
● Draw all shapes and lines with a 1-point stroke weight.  
● Do not apply a border or shadow effect. Turn effects off. 
● Strive for a consistent look-and-feel to images throughout the book. 

7. Program Code and Data 
Avoid the following in your code:  

● permanent data sets or hard-coded file references (unless these techniques are the example’s point) 
● macros (unless they are the point of the book or example) 
● CARDS statements (use DATALINES) 
● Use of the Tab key to indent code (indent by using spaces) 

                                                           
2 Fullshot users, check that size in your screen-capturing application is set to 100%, a 1:1 screen-to-image ratio. 
Check that borders and shadow effects are disabled. 
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● inconsistent indentures, spacing, and use of bold or italic 
● line numbers 

Save and submit your code and data as follows: 

● Save all programs used in your examples as separate files with a .sas extension.  
● Name each program by label and number, like so: Program_2.1.sas.  
● Place all programs, by chapter, in a folder named “SAS Programs.”  
● Assign distinct, meaningful, and consistent names to data sets used in different programs.  
● If multiple programs in your book use data sets, save each data set as a separate .dat file.  
● Check that data set names in your chapters match the individual data set file names. 
● Place all data sets, by chapter, in a folder named SAS Data Sets. 

8. Mathematical Expressions 
For all mathematical expressions throughout your book, use MathType equation builder. If you do not have a 
license for MathType, contact your editor before beginning work. If you have already written chapters with the 
use of a different equation builder, likewise contact your editor before proceeeding. 

Copyeditors at SAS will not edit math expressions; therefore, you will need to ensure accuracy of both math 
content and math style. 

Your project startup packet contains a MathType Preferences file that contains SAS Press style, font, font size, 
and spacing that reflects SAS Press style. For this file to work properly, ensure that each element of your math 
expression is tagged properly from the Style menu in MathType (Figure 4).  

Figure 4. MathType Styles Menu 

 

Then click the Preferences menu (see Figure 4). Select Equation Preferences ► Load from file. Drill to the 
location of your SASPress_MathTypePreferences_TNR10 file and select it.  

For explanations of specific style points governing math expressions throughout your book, see the SAS Press 
Style Guide. 
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Appendix: SAS Press Template Styles (7.24.2017) 

Page Layout 
Your book size will be either 7.5 x 9.25 or 8.25 x 11. Check your margins and page size as you write to ensure 
that your chapters are the correct size.  

You can change your page size using Page Layout ► Margins ► Custom Margins. 

For 7.5 x 9.25 page, margins should be Inside: 1.27 Outside: .5, Top: .63 Bottom: .5. Additional settings: Go to 
Page Layout ► Page Setup ► Layout. Set Header to .33. Footer to .5. Select Different odd and even and 
Different first page. 

For 8.25 x 11: margins should be Inside: 1, Outside: 1, Top: .99, Bottom: .75. Additional settings: Go to Page 
Layout ► Page Setup ► Layout. Set Header to .63. Footer to .5. Select Different odd and even and Different 
first page. 

Running Heads 
Running heads will include Book Title (left running head) and Chapter Title (right running head). SAS Press will 
enter these for you. Chapter Title will automatically be updated in the header if you format the chapter title using 
the AChapTitle style. 

Chapter Title  

AChapTitle 

Should appear as Chapter 1: Title 

Table of Contents  
Your editor will generate your TOC. If you wish to regenerate one, then place your cursor where you want your 
TOC. From the main toolbar, choose References ► Table of Contents. Right-click SAS Press TOC. Choose 
Insert at Current Document Position.  
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Headings  

AHeading 1 
AHeading 2 

AHeading3 

AHeading4 

Text  
ABodyCopy 

ABodyCopyInlineEquations (paragraph style to fix MathType-skewing of line spacing, added 24APR2017) 

ABodyCopyBold (This is a character style to be used with ABodyCopy.) 

ABodyCopyItalic (This is a character style to be used with ABodyCopy.) 

Code  
ACode  
ACodeLast  

ABoxedCode (Not preferred. Consult your editor before using.) 
ABoxedCodeLast (Not preferred. Consult your editor before using.) 

ACodeBold (This is a character style) 
ACodeBoldItalic (This is a character style) 
ACodeItalic (This is a character style) 
 

The caption heading style should be ACaptionHead: Program 1.2: Descriptive Title 

Unordered Lists (Bulleted Lists) 
AUnordered1List 

AUnorderedList2 

Ordered Lists (Numbered Lists) Styles 
AOrderedList1 

AOrderedList2 

Ordered Lists (Numbered Lists) Last Styles 
 

AOrderedList1Last 

AOrderedList2Last 

"Last" styles help with spacing. Production Specialists will clean up line spacing in the production phase.  
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Callout List Styles 
Use  callouts (❶) to highlight code if needed. Put the callout after the code. ❶ 

 ACalloutExplanation—This is an example of a callout explanation. 
ACalloutExplanationTextIndent. 

 ACalloutExplanationLast 

Use WingDings 2 numbers with white knockout text as shown above. Use Insert ► Symbol and then scroll to 
find WingDings 2. Set font size to 10 points. 

Term|Definition List Styles 
AHangingTerm 

AHangingDefinition 

SAS Log Styles 
Text copied and pasted from your SAS log and styled from the template as ACode (preferred) or ABoxedCode. 
Style the caption preceeding it using ACaptionHead as follows: SAS Log 1.2. Descriptive Title. 

SAS Programs 
Text copied and pasted from your programming code and styled from the template as ACode (preferred) or 
ABoxedCode. 

Equation Styles 
  

 
a b c+ =

  
Apply AEquationCenter to displayed math expressions. 

Table Styles 
ATableHead 
ATableBody 

ATableFootnote 

Table 1.1:  SASPressTable—This is your default table.** 

    

    

SASPressBasicTableShell 
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Find the SAS Press tables in the Table Tools►Design menu. Hover over the table styles until you see the name 
of the table. Alterntively, use Table ► Insert Tables►Quick Tables. Scroll to the bottom to see a list of SAS 
Press Tables.  

If you are writing a statistics-heavy book, or a book with possibly complex tables, then use the second, shadeless 
table style. Discuss which table style to use for your book with your editor before you begin working. 

Reference Styles 
ARefList 

Use this style for your References list. 

SpecialTopic Styles 
ASpecialTopic 

Use for brief passages that need to stand out. Use sparingly. 

Link Styles 
AHyperlink 

URLS should begin with http:// and can be styled using the AHyperlink character style included in the template. 

Figure Styles 

ACaptionHead 
AFigure 

Use ACaptionHead for Figures, Tables, Programs, and SAS Log headings. 

Endnotes  
Please use endnotes instead of footnotes. Use endnotes sparingly and only for content notes, not to cite sources. 

Symbols 
► In menu paths, use this solid black triangle symbol instead of arrows or >. In the Insert Symbol menu item, 
this is the Black Right-Pointing Pointer, Character code 25BA, Unicode (hex) under Geometric Shapes. 

❶ Use black callout numbers in the font Wingdings 2. Before using for any figure annotation, contact your 
editor to discuss in order to prevent rework. For SAS Press figure annotation style, see the SAS Press Style 
Guide. 
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