Support for Operating Systems and Environments in SAS® Viya® 3.4

Supported Distributions of Linux

In a multi-machine deployment, SAS recommends that all server machines have the same version of Linux, including the distribution, release, and patch level. A mixture of Linux versions is not supported. In addition, all CAS Server machines must be running the same version of Linux.

The following operating systems are supported for both physical and virtual machines:

  • Red Hat Enterprise Linux 6.7 (64-bit) and later within 6.x
  • Red Hat Enterprise Linux 7.1 and later within 7.x
  • Oracle Linux 6.7 and later within 6.x
  • Oracle Linux 7.1 and later within 7.x
  • SUSE Linux Enterprise Server 12.2 and later (Not supported for SAS Visual Investigator or SAS Intelligence and Investigation Management deployments)

Supported Distributions of Windows

For SAS Viya and SAS Event Stream Processing:

  • Windows Server 2012 R2 Datacenter, Essentials, Foundation, and Standard Edition (64-bit version)
  • Windows Server 2016 Datacenter, Essentials, and Standard Edition (64-bit version)

SAS Support for Alternative Operating Systems

See http://support.sas.com/techsup/pcn/altopsys.html for the statement of SAS’s support for operating systems other than those listed here.


Ansible

SAS requires Ansible version 2.3.x through 2.6. If you are performing a large deployment across multiple machines, SAS recommends version 2.4.3 or later.

The Ansible controller machine must be connected to the Red Hat Network. Oracle Linux machines require an Oracle Linux support subscription.

On Red Hat Enterprise Linux, the Ansible server requires a Server-Optional subscription in addition to the Base (operating-system) subscription. The managed nodes must also be registered to the Red Hat Network, but a Base subscription is sufficient.

With Oracle Linux 6 Update 5 or later, the ULN registration procedure automatically registers each host with the latest channels for the base repository and the Unbreakable Enterprise Kernel Release 3 (UEK R3).

Python

The Ansible controller requires Python 2.6 or later within 2.x. Any machines in your deployment that you plan to manage with Ansible require Python 2.4 or a later release.  If you are running Python 2.4 or an earlier release on the managed nodes, the python-simplejson encoder for JSON is required. The Ansible controller also requires the following Python modules, which are provided by the Extra Package for Enterprise Linux (EPEL) if the machine is registered:

  • paramiko
  • PyYAML
  • Jinja2 2.7

SAS Visual Investigator requires Python 2.7 and does not support Python 3. Because Python is typically preinstalled on Linux, verify that Python 2.7 is installed on all machines, and that Python 3 is not defined in the system PATH or user PATH.

SAS Deep Learning Python API (SAS DLPy) requires a later version of Python that Ansible 2.x does not support: Python 3.0 or later. Different versions of Python can coexist on the same machine. However, you must install them using different versions of PIP. One method of installing different versions of Python is to install Anaconda, which includes PIP. You then use that version of PIP to install a version of Python that supports CAS integration with JupyterHub, SAS Scripting Wrapper for Analytics Transfer (SAS SWAT), and SAS DLPy.

For more information about SAS DLPy, see: https://github.com/sassoftware/python-dlpy/blob/master/README.md.

For more information about SAS SWAT, see https://sassoftware.github.io/python-swat/index.html.

Recommended Resources


Explore our training options, including on-site classroom, live web, e-learning and one-on-one mentoring.


Validate your SAS knowledge and skills by earning a globally recognized credential from SAS.


Explore documentation on topics of interest to SAS administrators.
 

Back to Top