Oracle WebLogic Server Support and Documentation for SAS® 9.3

Oracle WebLogic Application Server Software Version Requirements

This page indicates the minimum version required for Oracle WebLogic Application Server for use with SAS 9.3. It is possible to use updated versions of Oracle WebLogic Application Server. See SAS Third-Party Software Requirements - Baseline and Higher Support for more details.

SAS 9.3 TS1M2 and Oracle WebLogic Server (64-bit) 

Version 10.3

Platform

  • Linux on x64 (x86-64)
    (Red Hat Enterprise Linux 5, 6; SUSE Linux Enterprise Server 10, 11)
  • Solaris on SPARC
    (Solaris 10)
  • AIX on Power
    (AIX 6.1, 7.1)
    Note: AIX 7.1 is only supported by WebLogic 10.3.4 and later
  • HP/UX on Itanium
    (HP-UX 11.31)
  • Solaris 10 x64
    (x86-64)
    (Solaris 10)
  • Windows x64 (x86-64)
    (Windows Server 2003 x64)
    (Windows Server 2008 x64)
    (Windows Server 2008 R2 x64)

Version 12.1

Platform

  • Linux on x64 (x86-64)
    (Red Hat Enterprise Linux 5, 6; SUSE Linux Enterprise Server 10, 11)
  • Solaris on SPARC
    (Solaris 10)
  • AIX on Power
    (AIX 6.1, 7.1)
  • Solaris 10 x64
    (x86-64)
    (Solaris 10)
  • Windows x64 (x86-64)
    (Windows Server 2008 R2 x64)
     

SAS 9.3 TS1M0 and TS1M1 and Oracle WebLogic Server (64-bit) 

Version 10.3

Platform

  • Linux on x64 (x86-64)
    (Red Hat Enterprise Linux 5, 6; SUSE Linux Enterprise Server 10, 11)
  • Solaris on SPARC
    (Solaris 10)
  • AIX on Power
    (AIX 6.1, 7.1)
    Note: AIX 7.1 is only supported by WebLogic 10.3.4 and later
  • HP/UX on Itanium
    (HP-UX 11.31)
  • Solaris 10 x64
    (x86-64)
    (Solaris 10)
  • Windows x64 (x86-64)
    (Windows Server 2003 x64)
    (Windows Server 2008 x64)
    (Windows Server 2008 R2 x64)
     

Notes:

  • The operating system and the version of WebLogic Server determines the JDK that is required. WebLogic Server supports JDKs from multiple vendors. Java Software Development Kits lists these vendor-specific JDK requirements and identifies the supported platforms for WebLogic.
  • You must use WebLogic 10.3.6 if you wish to use Java 7.
  • Before you run the SAS Deployment Wizard to install SAS software and configure Oracle WebLogic, review the Oracle WebLogic Application Server documentation for SAS 9.3 below.
  • For instructions about how to obtain and apply WebLogic Server patches, see Obtaining and Applying Patches for Oracle WebLogic Server 9.x and Later." Last Updated: October 10, 2011
  • Oracle WebLogic requires specific versions of the JDK when configured on the AIX operating environment. For this reason, the baseline and higher support policy does not apply to the JDK that is used with WebLogic under AIX. You must download one of the required versions of the JDK.

Oracle WebLogic Application Server Patches

Patches required for WebLogic Server 10.3.0

  • Patch ID: 6F8A
  • Patch ID: CJ4W
  • Patch ID: IQXV
  • Patch ID: T552
  • Patch ID: 79YU
  • Patch ID: ETR7
  • Patch ID: SYCB
  • Patch ID: GB3R

Patches required for WebLogic Server 10.3.1

  • Patch ID: BR4K
  • Patch ID: UQJZ
  • Patch ID: 36RE

Patches required for WebLogic Server 10.3.2

  • Patch ID: YQHC
  • Patch ID: JKDI
  • Patch ID: W6PT

Patches required for WebLogic Server 10.3.3

  • Patch ID: MLHC
  • Patch ID: 81UZ
Patches required for WebLogic Server 10.3.5
  • Patch ID: 6BLB

No patches are required for the following:

  • WebLogic Server 10.3.4
  • WebLogic Server 10.3.6
  • WebLogic Server 12.1.1

Recommended Resources


Explore our training options, including on-site classroom, live web, e-learning and one-on-one mentoring.


Validate your SAS knowledge and skills by earning a globally recognized credential from SAS.


Explore documentation on topics of interest to SAS administrators.
 

Back to Top