• Print  |
  • Feedback  |

Knowledge Base

System Requirements
SASĀ® IT Resource Management 3.21

Overview

In addition to these system requirements, documentation and other reference information for SAS IT Resource Management 3.21 may be found on the SAS IT Resource Management support Web site, http://support.sas.com/documentation/onlinedoc/itsv/ and in Usage Note 44002, http://support.sas.com/kb/44/002.html.

Server Tier Requirements

SAS IT Resource Management Server

Please select a target environment:

Third-Party dependencies:

  • SAS IT Resource Management requires a Java Runtime Environment (JRE) on the server tier for all operating systems. Please refer to the SAS 9.3 section of the Third-Party Software Requirements Web page, http://support.sas.com/resources/thirdpartysupport/ for
    the minimum version requirements for Java Runtime Environments.
  • SAS IT Resource Management requires MXG Software from Merrill Consultants for the processing of SMF-based data sources on the server tier for all operating systems. This software is included with SAS IT Resource Management on the z/OS operating system. Customers processing SMF data on other operating systems should contact Merrill Consultants for a license to run MXG software.
  • An X11 server is required for the installation of SAS on z/OS and UNIX. This server is required for the end-user display of the SAS Deployment Wizard (a JAVA application that performs SAS installation and configuration steps).
  • SAS IT Resource Management includes Demand Technology Performance Sentry Software for the processing of Windows system data. The Demand Technology software is included with SAS IT Resource Management on the Windows operating system and the licenses for that product are for 50 seats and are offered for a 180 day period at which time the software can be renewed with Demand Technology.

* If your SAS IT Resource Management Server is on z/OS, please note the following memory requirements:

  • Batch jobs using SAS IT Resource Management software on a z/OS server tier require a region specification of at least 1024M.
  • TSO user IDs that will be using SAS IT Resource Management software should have an ASSIZEMAX specification of at least 1024M. The installer TSO user ID requires an ASSIZEMAX of 2000M. A CPUTIMEMAX value of 20000 is also recommended for the installer TSO user ID, particularly if migrations are being performed.

SAS Metadata Server

Please select a target environment:

SAS recommends that you deploy SAS Metadata Server on a 64-bit host system. The SAS Metadata Server is multi-threaded and multi-core server hardware (typically quad core or higher) is recommended. A dedicated machine for the SAS Metadata Server is recommended to simplify tuning, management, and diagnostics, but is not required. The disk I/O performance of any server-class system should be sufficient. Memory requirements are highly dependent on the product mix and usage, but 8GB of RAM is sufficient for most large deployments. 4GB of RAM is sufficient for many deployments and should be considered a minimum unless the specific deployment is tested and verified to require less memory.

* If your SAS Metadata Server is on z/OS, please note the following memory requirements:

  • A modification of the MEMLIMIT size specified in the Metadata Server started task is recommended. By default, the value is MEM=2G, but this should be MEM=4G for use with SAS IT Resource Management.
  • The default REGION size of 1024M does not require modification.

Middle Tier Requirements

SAS IT Resource Management Mid-Tier

Please select a target environment:

SAS IT Resource Management also requires a Java Runtime Environment (JRE) and Java Development Kit (JDK) on the middle tier. Please refer to the SAS 9.2 (TS2M3) section of the Third-Party Software Requirements Web page, http://support.sas.com/resources/thirdpartysupport/ for the minimum version requirements for Java Runtime Environments and Java Development Kits.

Application Servers

The following list describes the application servers supported by SAS 9.3 and the operating systems on which they are supported.

You may select one of the following options:

  • BEA WebLogic 10.3 (10gr3): AIX 6.1 and 7.1, HP-UX 11iv3 (11.31) for the Itanium Processor Family, Red Hat Enterprise Linux 5 and 6, SuSE Linux Enterprise 10 and 11, Solaris 10, Solaris 10 for x64, Windows Server 2003 x64, Windows Server 2008 x64
  • IBM WebSphere 7.0.0.13: AIX 6.1 and 7.1, Red Hat Enterprise Linux 5 and 6, SuSE Linux Enterprise 10 and 11, Solaris 10, Solaris 10 for x64, Windows Server 2008 x64 R2, z/OS v1r10
  • JBoss 4.3 (JBoss Community 4.2.3) or higher: AIX 6.1 and 7.1, HP-UX 11iv3 (11.31) for the Itanium Processor Family, Red Hat Enterprise Linux 5 and 6, SuSE Linux Enterprise 10 and 11, Solaris 10, Solaris 10 for x64, Windows Server 2003 x64, Windows Server 2008 x64

Client Tier Requirements

SAS IT Resource Management Client

Please select a target environment:

SAS IT Resource Management also requires a Java Runtime Environment (JRE) and Java Development Kit (JDK) on the client tier. Please refer to the SAS 9.2 (TS2M3) section of the Third-Party Software Requirements Web page, http://support.sas.com/resources/thirdpartysupport/ for the minimum version requirements for Java Runtime Environments and Java Development Kits.

DataFlux Data Management Client

Please select a target environment:

DataFlux Data Management Client comes with DataFlux Data Management Quality Knowledge Base Locale of choice. If not specified, by default, Quality Knowledge Base Locale for English (USA) will be included.

Web Browsers

SAS 9.3 supports the following Web browsers:

  • Internet Explorer 7
  • Internet Explorer 8
  • Firefox 3.6

To run the SAS IT Resource Management Gallery Manager application in a Web browser, Adobe Flash Player release 10.0.32.18 or higher is required. The Adobe Flash Player may be downloaded from Adobe Systems at http://get.adobe.com/flashplayer/. If you are not sure what release of Adobe Flash Player your browser is running, you can determine your current release by going to http://kb2.adobe.com/cps/155/tn_15507.html.

Many supplied reports in SAS IT Resource Management 3.21 are based on Microsoft's ActiveX technology. To display those reports in a Web browser, you must install the SAS/Graph Control for ActiveX on the client tier. This can be installed from the installation media or manually downloaded and installed from the SAS/Graph Downloads Web site, http://support.sas.com/demosdownloads/setupcat.jsp?cat=SAS/GRAPH Software. Further information may be found in Usage Note 10102, available at http://support.sas.com/kb/10/102.html.

The SAS/Graph Control for ActiveX is only supported for Microsoft Internet Explorer.


SAS and all other SAS Institute product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. Other brand and product names are registered trademarks or trademarks of their respective companies.
© indicates USA registration.
Copyright © 2012 SAS Institute Inc., Cary, NC, USA. All rights reserved.