Resources

 Parts Database > install_doc_builder > system_requirements_document
System Requirements
SAS® Campaign Management 6.5

Overview

SAS Campaign Management 6.5 includes SAS Visual Analytics Administration and Reporting (Distributed LASR), which is required to enable the Reporting Workspace in the SAS Customer Intelligence Studio user interface. If SAS Visual Analytics Administration and Reporting is not installed, the Reporting Workspace will not be available in your system. Refer to the deployment instructions for more information.

Server-Tier Requirements

Note: Support Status: Only SAS 9.4 TS1M5 and later are supported on Windows Server 2016.

To keep pace with changes to third-party technologies, SAS has adopted a general policy of supporting one or more baseline major versions and subsequent minor updates for each officially supported operating system. For example, if the baseline for SAS x is Red Hat Enterprise Linux 6.1, SAS x will also support Red Hat Enterprise Linux 6.7 under this policy.

The full SAS Support policy that applies to third-party software can be found at https://support.sas.com/en/documentation/third-party-software-reference/baseline-and-higher.html. As part of this policy, SAS strongly encourages customers to install the latest operating-system service packs.

SAS Campaign Management Server

Select a platform:

SAS Campaign Management Server includes three SAS Metadata Bridges of choice, one standard SAS/ACCESS engine of choice for transactional data, and one of the following standard SAS/ACCESS engines of choice:

  • SAS/ACCESS Interface to Amazon Redshift
  • SAS/ACCESS Interface to DB2
  • SAS/ACCESS Interface to Greenplum
  • SAS/ACCESS Interface to Netezza
  • SAS/ACCESS Interface to ODBC
  • SAS/ACCESS Interface to OLE DB
  • SAS/ACCESS Interface to Oracle
  • SAS/ACCESS Interface to PostgreSQL
  • SAS/ACCESS Interface to SAP HANA
  • SAS/ACCESS Interface to SQL Server
  • SAS/ACCESS Interface to Teradata

SAS Visual Analytics Administration and Reporting Server

Select a platform:

SAS Visual Analytics Administration and Reporting Server includes a standard SAS/ACCESS engine of choice. It must be the same as the one you selected for the SAS Campaign Management Server. SAS recommends that you install SAS Visual Analytics Administration and Reporting Server on a separate machine from the solution software.

Inclusion of SAS Visual Analytics LASR Server

  • SAS Visual Analytics LASR Server, Non-distributed is included automatically if the deployment is for Non-distributed LASR. It is optional if deployment is for Distributed LASR.
  • SAS Visual Analytics LASR Server, Distributed is included automatically if the deployment is for Distributed LASR.

For Hadoop Support

Base SAS, SAS/ACCESS engines, and SAS Visual Analytics Administration and Reporting Server can be installed on the head node of the commodity hardware (symmetric) or on separate hardware (asymmetric). The Distributed LASR Base SAS components for SAS Visual Analytics Administration and Reporting can therefore be installed on Windows for x64 while working with the Linux for x64 LASR grid.

SAS Solution LASR Analytic Server

Select a platform:

SAS Solution LASR Analytic Server includes one standard SAS/ACCESS engine of choice for transactional data.

You can install the SAS Solution LASR Analytic Server on the same server as the Solution server, on the SAS Visual Analytics Administration and Reporting Server, or on a separate server. However, the operating system must be the same as the SAS Visual Analytics Administration and Reporting Server.

SAS LASR Analytic Server (Distributed LASR) on Linux for x64

SAS Products installed on this machine:
  • SAS High-Performance Computing Management Console 2.8
  • SAS High-Performance Node Installation 3.5
  • SAS Plug-ins for Hadoop 1.0

Disk Space Consumed by Installed Products: 1.2 GB
Supported Environments:
  • Oracle Linux 6.1 (64-bit version) on the x64 chip family
  • Oracle Linux 7.1 (64-bit version) on the x64 chip family
  • Red Hat Enterprise Linux 6.1 (64-bit version) on the x64 chip family
  • Red Hat Enterprise Linux 7.1 (64-bit version) on the x64 chip family
  • SUSE Linux Enterprise Server 11 SP1 (64-bit version) on the x64 chip family
  • SUSE Linux Enterprise Server 12 (64-bit version) on the x64 chip family

Use of a co-located Hadoop File System (HDFS) is optional, but it requires a supported Hadoop environment and SAS Plug-ins for Hadoop (which are included with your license). For information about supported Hadoop distributions, refer to https://support.sas.com/en/documentation/third-party-software-reference/9-4/support-for-hadoop.html. The plug-ins require additional configuration. For more information, see SAS High-Performance Analytics Infrastructure 3.5: Installation and Configuration Guide at http://support.sas.com/documentation/onlinedoc/hp-analytics-infrastructure/index.html.

SAS Metadata Server

Select a platform:

SAS makes the following recommendations for SAS Metadata Server deployments:

  • a 64-bit host system
  • a dedicated machine to simplify tuning, management, and diagnostics
  • multi-core server hardware because SAS Metadata Server is multi-threaded
  • four or more cores for production deployments

The disk I/O performance of any server-class system should be sufficient. Memory requirements are highly dependent on the product mix and usage, but 8 GB of RAM are sufficient for most large deployments. For many deployments, 4 GB of RAM are sufficient and should be considered a minimum, unless the specific deployment is tested and verified to require less memory.


Middle-Tier Requirements

Note: Support Status: Only SAS 9.4 TS1M5 is supported on Windows Server 2016.

SAS Campaign Management Mid-Tiers

Select a platform:

SAS Visual Analytics Administration and Reporting Mid-Tier

Select a platform:

Middle Tier Java Application Server Support

The relevant Java Software Developer Kits (JDK) and the latest information and special instructions can be found on the Third-Party Support Web site: https://support.sas.com/en/documentation/third-party-software-reference/9-4/support-for-java.html.

Web Servers

The middle tier of the SAS 9.4 Intelligence Platform includes a SAS Web Application Server and a SAS Web Server for use as an HTTP server. 

When you install your SAS solution software, SAS Deployment Manager installs and configures the required web application servers and web servers.

To install these servers, select one of the supported operating systems for the middle tier.

Note: These servers cannot be installed on the z/OS or 32-bit Windows platforms.


Client-Tier Requirements

SAS Campaign Management Clients

Select a platform:

Web Browsers

SAS Campaign Management is accessed via a supported web browser. The following page lists the browsers that are supported, including Chrome, Firefox, and Internet Explorer: https://support.sas.com/en/documentation/third-party-software-reference/9-4/support-for-9-4-web-browsers.html.

Some SAS Web applications use Adobe Flash Player to provide interactive functionality. For more information, see https://support.sas.com/en/documentation/third-party-software-reference/9-4/support-for-9-4-web-browsers.html.

Presentation Virtualization Environments

Support for presentation virtualization environments (for example, Citrix) for clients that are included with SAS Campaign Management is consistent with the SAS corporate support policy. For more information, see http://support.sas.com/techsup/pcn/virtualization.html.

SAS Visual Analytics Mobile Clients

SAS Visual Analytics Mobile Clients (SAS Mobile BI) are available for the Apple iPad and Android tablets via free downloads from app stores.


Hardware Requirements

Mid-tier Machine: Minimum Recommended

Memory

The minimum recommended memory for the SAS Campaign Management mid-tier machine is 8 GB.

Memory requirements for optimal performance may vary. SAS recommends scheduling a consultation with the SAS Enterprise Excellence Center.

Disk Space

  • SAS Campaign Management Application Server: 300 MB above your current environment
  • SAS Campaign Management Web Components: 300 MB above your current environment
  • SAS Customer Intelligence Reporting: 250 MB above your current environment

These are the amounts of disk space that the SAS Campaign Management Server setup directory requires. Additional space may also be required for new content, such as campaigns and reports.

Client Application Machine: Minimum Recommendations

  • Modern Intel or AMD processor running at 2.33GHz or faster
  • Memory:
    • 3 GB minimum
    • 128 MB graphical memory
  • SAS Campaign Management Disk Space: SAS Customer Intelligence Studio requires 350 MB above your current environment.

Database Requirements

Database Compatibility

SAS Campaign Management can connect to various databases using SAS/ACCESS. The following list describes the versions of databases with which SAS Campaign Management is compatible:

  • Amazon Redshift on AWS using the DataDirect for Redshift client version 7.1.5
  • EMC Greenplum, DataDirect ODBC driver 7.1.4, Greenplum bulk loader 4.3
  • IBM DB2/UDB versions 10.1, 10.5, and 11.1
  • IBM Netezza versions 6.0, 6.1, and 7.0
  • Microsoft SQL Server versions 2008, 2008 R2, 2012, 2014 Enterprise Edition
    • SAS/ACCESS to OLE DB; supported only on Windows
    • SAS/ACCESS to ODBC; supported only on Windows
    • SAS/ACCESS to Microsoft SQL Server on UNIX with the DataDirect branded driver 7.1.4; supported only on AIX, Linux, and Solaris
  • Microsoft SQL Server versions 2016 and 2017 Enterprise Edition
    • SAS/ACCESS to Microsoft SQL Server with the DataDirect branded driver 7.1.4; supported on Windows, AIX, Linux, and Solaris
  • Microsoft SQL Server versions 2008, 2008 R2, 2012, 2014 Standard Edition (no more than 10 million customer records)
    • SAS/ACCESS to OLE DB; supported only on Windows
    • SAS/ACCESS to ODBC; supported only on Windows
  • Microsoft SQL Server versions 2016 and 2017 Standard Edition (no more than 10 million customer records)
    • SAS/ACCESS to Microsoft SQL Server with the DataDirect branded driver 7.1.4; supported on Windows, AIX, Linux, and Solaris
  • Oracle version 11g, 11.2, 12.1, and 12.2

Notes: If your installation includes Oracle Database 12c, be aware that Oracle Multi-tenant architecture is not supported.
If your installation includes Oracle Database 12.2, this version is only supported by SAS 9.4 TS1M4 (SAS 9.4M4) and later. Oracle 12.2 on Linux requires a hot fix. For more information, see the following SAS Note: http://support.sas.com/kb/60/895.html.

  • PostgreSQL version 9.4 client, version 9.4 Bulk Loader
  • SAP HANA version 1.0.71 and later versions
  • SAS Data Sets version 9.4

Note: SAS Data Sets are not supported with use of the CI Common Reporting Data Model, and no more than 5 million customer equivalent records are supported.

  • Teradata versions 14.0, 14.1, 15.0, 15.1, and 16.xx.

Note: Mixing of databases will not perform to an acceptable level and is not recommended.


Third-Party Software

SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.

SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. Other brand and product names are trademarks of their respective companies.
® indicates USA registration.
Copyright © 2016 SAS Institute Inc., Cary, NC, USA. All rights reserved.