Support for Java Runtime Environments (JREs) in SAS® Viya® 3.3

SAS® Viya® 3.3 Support for Java Runtime Environments (JREs)

The Java Runtime Environment (JRE) must be installed on every machine in your deployment.  If you are installing SAS Common Planning Service, you also need to install the Java Development Kit (JDK). The following versions are supported:

  • Azul Zulu version 1.8.x.
  • Oracle JRE SE version 1.8.x.
  • OpenJDK version 1.8.x.

SAS recommends using the most recent releases of JRE and JDK 1.8.x in order to receive the latest security and bug fixes.

To avoid a problem with rendering that affects a selected set of fonts in Traditional Chinese, Korean and Japanese locales, use Oracle JRE instead of OpenJDK. As a workaround, you can make a change to the registry to support an alternate set of fonts with OpenJDK. You must also download and install the alternative fonts. For more information, refer to SAS Note 58855.

Recommended Resources


Explore our training options, including on-site classroom, live web, e-learning and one-on-one mentoring.


Validate your SAS knowledge and skills by earning a globally recognized credential from SAS.


Explore documentation on topics of interest to SAS administrators.
 

Back to Top