Resources

System Requirements
SASĀ® Data Quality Standard 2.9

Overview

To keep pace with changes to third-party technologies, SAS has adopted a general policy of supporting one or more baseline major versions, subsequent minor updates, and subsequent major versions for each officially supported operating system. Only the supported baseline major versions are listed in this document. The full SAS Support policy governing third-party software can be found at https://support.sas.com/resources/thirdpartysupport/baseline_plus.html.

As part of this policy, SAS strongly encourages customers to install the latest operating-system service packs.

Server-Tier Requirements

SAS Data Quality Standard Server

Select a platform:

SAS Data Quality Standard Server includes SAS Data Management Contextual Extraction Language Packs. It also includes a locales for SAS Quality Knowledge Base. 

SAS Data Management Server Remote Function Call for SAP is included on request. It includes SAS Federation Server Driver for SAP.

On Windows, OpenSSL 1.0 or later is required. The OpenSSL DLLs must be installed in the Windows system directory or in a directory that is in the system PATH.

In UNIX environments, the vendor-provided OpenSSL library associated with your host must be installed:

  • AIX: openssl.base
  • HP-UX: openssl
  • Linux: openssl or compat-openss110
  • Solaris 10: SUNWopenssl-libraries
  • Solaris 11: library/security/openssl

 

SAS Data Quality Server

Select a platform:

SAS Data Quality Server includes SAS Data Management Contextual Extraction Language Packs. It also includes locales for SAS Quality Knowledge Base. 

SAS Metadata Server

Select a platform:

SAS makes the following recommendations for SAS Metadata Server deployments:

  • a 64-bit host system
  • a dedicated machine to simplify tuning, management, and diagnostics
  • multi-core server hardware because SAS Metadata Server is multi-threaded
  • four or more cores for production deployments

The disk I/O performance of any server-class system should be sufficient. Memory requirements are highly dependent on the product mix and usage, but 8 GB of RAM are sufficient for most large deployments. For many deployments, 4 GB of RAM are sufficient and should be considered a minimum, unless the specific deployment is tested and verified to require less memory.


Middle-Tier Requirements

Starting with SAS 9.4M7, the SAS Web Server (a specific version of the Apache HTTP Server) that is delivered with the Middle-Tier cannot be configured on SUSE Linux Enterprise Server 11. Install the SAS Web Server on SUSE Linux Enterprise Server 12 or another supported operating system. As an alternative, you can choose not to install the SAS Web Server.

SAS Data Quality Standard Mid-Tier

Select a platform:

Web Application Servers

When you install your SAS solution software, SAS Deployment Manager installs and configures the required web application servers and web servers.

To install these servers, select one of the supported operating systems for the middle tier.

Note: These servers cannot be installed on the z/OS or 32-bit Windows platforms.


Client-Tier Requirements

SAS Data Quality Standard Studio

Select a platform:

SAS Data Quality Standard Studio includes SAS Data Management Contextual Extraction Language Packs. It also includes locales for SAS Quality Knowledge Base. 

SAS Data Management Server Remote Function Call for SAP is included on request. It includes SAS Federation Server Driver for SAP.

 

Web Browsers

The list of web browsers that SAS supports is updated as new software is tested and approved. For the latest information, please select the link for Web Browsers and Plug-Ins at https://support.sas.com/en/documentation/third-party-software-reference/9-4/support-for-9-4-web-browsers.html

 

 


Specific Product Requirements

Database Repository Storage

DataFlux Data Management Server and DataFlux Data Management Studio support the following databases for repository storage:

  • IBM DB2
  • Informix
  • Microsoft SQL Server
  • Oracle
  • PostgreSQL
  • SAS Web Infrastructure Platform Data Server
  • Sybase
  • Teradata

Important Upgrade Requirements

A few SAS Data Management components have been deprecated (as of July 2020). Before upgrading your SAS Data Management solution software, be sure to read the section of the SAS 9.4 Guide to Software Updates and Product Changes that is relevant for your product.

 


Third-Party Software

SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.

SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. Other brand and product names are trademarks of their respective companies.
® indicates USA registration.
Copyright © 2020 SAS Institute Inc., Cary, NC, USA. All rights reserved.