• Print  |
  • Feedback  |

Knowledge Base

System Requirements
SAS® Enterprise Case Management 3.1

Server Tier Requirements

SAS Enterprise Case Management Server

Please select a target environment:

SAS Enterprise Case Management Server includes three Metadata Bridges of choice, and two SAS/ACCESS engines of choice selected from the following list:

  • SAS/ACCESS Interface to Microsoft SQL Server
  • SAS/ACCESS Interface to ODBC
  • SAS/ACCESS Interface to Oracle

Note: When using SAS/ACCESS Interface to ODBC with the PostgreSQL ODBC driver (psqlODBC), the PostgreSQL ANSI driver should be used regardless of the database encoding.

SAS Metadata Server

Please select a target environment:

 

SAS recommends that you deploy SAS Metadata Server on a 64-bit host system. The SAS Metadata Server is multi-threaded and multi-core server hardware (typically quad core or higher) is recommended. A dedicated machine for the SAS Metadata Server is recommended to simplify tuning, management, and diagnostics, but is not required. The disk I/O performance of any server-class system should be sufficient. Memory requirements are highly dependent on the product mix and usage, but 8GB of RAM is sufficient for most large deployments. 4GB of RAM is sufficient for many deployments and should be considered a minimum unless the specific deployment is tested and verified to require less memory.


Middle Tier Requirements

SAS Enterprise Case Management Mid-Tiers

Please select a target environment:

Application Servers

The following list describes the application servers supported by SAS 9.3 and the operating systems on which they are supported.

  • JBoss 4.3 (JBoss Community 4.2.3): AIX 6.1 and 7.1, HP-UX 11iv3 (11.31) for the Itanium Processor Family, Red Hat Enterprise Linux 5 and 6, SuSE Linux Enterprise 10 and 11, Solaris 10, Solaris 10 for x64, Windows Server 2003 x64, Windows Server 2008 x64
  • JBoss 5.1.1 (JBoss Community 5.1.0): AIX 6.1 and 7.1, HP-UX 11iv3 (11.31) for the Itanium Processor Family, Red Hat Enterprise Linux 5 and 6, SuSE Linux Enterprise 10 and 11, Solaris 10, Solaris 10 for x64, Windows Server 2003 x64, Windows Server 2008 x64
  • BEA WebLogic 10.3 (10gr3): AIX 6.1 and 7.1, HP-UX 11iv3 (11.31) for the Itanium Processor Family, Red Hat Enterprise Linux 5 and 6, SuSE Linux Enterprise 10 and 11, Solaris 10, Solaris 10 for x64, Windows Server 2003 x64, Windows Server 2008 x64
  • IBM WebSphere 7.0.0.13: AIX 6.1 and 7.1, Red Hat Enterprise Linux 5 and 6, SuSE Linux Enterprise 10 and 11, Solaris 10, Solaris 10 for x64, Windows Server 2008 x64 R2, z/OS v1r10

Supported Databases

SAS Enterprise Case Management supports the following databases:

  • Oracle 10g or 11g

Note: A documented bug in Oracle requires that version v 10.2.0.3 not be used.

Note: For optimal performance and scalability, SAS recommends that you deploy SAS Enterprise Case Management on Oracle Enterprise Edition in order to leverage advanced tuning features such as bitmap indexing and data partitioning. Oracle Standard Edition is a subset of Oracle Enterprise Edition and lacks features required for tuning high-volume databases. Please consult with your Oracle licensing representative for a complete list of features available.

  • PostgreSQL 8.3, 8.4 or 9.0
  • SQLServer 2008 or 2008 R2

Recommendation for SAS Shared Services Database

SAS Enterprise Case Management 3.1 depends on SAS Shared Services for various components. For example, SAS Workflow is delivered with the SAS Intelligence Platform as a component of SAS Shared Services. In addition, SAS Enterprise Case Management uses SAS Content Server for storing files in the WebDAV repository.

CAUTION: Do not use the SAS Table Server as a database for SAS Shared Services.

You should not use the SAS Table Server as a database for SAS Shared Services. When feasible, you should configure the SAS Shared Services database on the same RDBMS that you configure for SAS Enterprise Case Management.


Client Tier Requirements

SAS Enterprise Case Management Client

Please select a target environment:

Web Browsers

SAS 9.3 supports the following Web browsers:

  • Internet Explorer 7
  • Internet Explorer 8
  • Internet Explorer 9
  • Firefox 3.6

Memory Requirements

The recommended minimum memory requirement for SAS Enterprise Case Management 3.1 is 8 GB.


SAS and all other SAS Institute product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. Other brand and product names are registered trademarks or trademarks of their respective companies.
© indicates USA registration.
Copyright © 2012 SAS Institute Inc., Cary, NC, USA. All rights reserved.