Support for Cloud and Database Variants

SAS has extended SAS/ACCESS and SAS In-Database Technologies support to selected cloud and database variants of supported data sources. The full list of supported databases for each SAS/ACCESS or SAS In-Database product can be found in the system requirements document that corresponds to your operating system.

Support for Hadoop

Refer to the SAS 9.4 Support for Hadoop page for the list of supported products.

Support for IBM Integrated Analytics System (IIAS)[2]

Starting with SAS 9.4M4, SAS/ACCESS Interface to DB2 supports connecting to IBM IIAS.

Support for MySQL

Starting with SAS 9.4M4, SAS/ACCESS Interface to MySQL supports the following:

  • Amazon RDS Aurora (version 5.6 or later) [1]
  • Amazon RDS MariaDB (version 10.1 or later)
  • Amazon RDS MySQL (version 5.6 or later) [1]
  • Azure Database for MySQL (version 5.6 or later) [1]
  • Azure Database for MariaDB (version 10.2 or later)
  • Google Cloud Platform Cloud SQL MySQL (version 5.6 or later) [1]
  • MariaDB 10.1 or later
  • MemSQL 6.0 or later
  • Oracle MySQL Database[1]

Support for Microsoft SQL Server

SAS/ACCESS Interface to Microsoft SQL Server supports the following:

Starting with SAS 9.4M4:

  • Amazon RDS Microsoft SQL Server (Microsoft SQL Server 2012 or later)
  • Microsoft Azure SQL Database
  • Microsoft Azure SQL Database managed instance

Starting with SAS 9.4M6:

  • Google Cloud Platform Cloud SQL for SQL Server (version 2017 or later)

Starting with SAS 9.4M7:

  • Microsoft Azure Synapse Analytics

Support for Oracle

Starting with SAS 9.4M4, SAS/ACCESS Interface to Oracle supports the following:

  • Amazon RDS Oracle (Oracle version 11gR2 or later)
  • Oracle Cloud Platform (Oracle version 11gR2 or later)

Starting with SAS 9.4M4, SAS Scoring Accelerator for Oracle supports the following:

  • Oracle Cloud Platform (Oracle version 11gR2 or later)

Support for PostgreSQL

SAS/ACCESS Interface to PostgreSQL supports the following:

Starting with SAS 9.4M5:

  • Amazon Aurora (PostgreSQL version 9.6 or later)
  • Amazon RDS PostgreSQL (version 9.6 or later)
  • Azure Database for PostgreSQL (version 9.6 or later)

Starting with SAS 9.4M6

  • Google Cloud Platform Cloud SQL for PostgreSQL (version 9.6 or later)
  • EnterpriseDB PostgreSQL (version 9.6 or later)

Support for Teradata

Starting with SAS 9.4M4, the following Teradata Database 15.10 or later platforms are supported by the indicated SAS products. The system requirements document that corresponds to your operating system provides specific requirements for each product:  

Teradata IntelliCloud

  • SAS/ACCESS Interface to Teradata
  • SAS Scoring Accelerator for Teradata
  • SAS Code Accelerator for Teradata
  • SAS Data Quality Accelerator for Teradata
  • SAS Analytics Accelerator

Teradata Database on Amazon Web Services

  • SAS/ACCESS Interface to Teradata
  • SAS Scoring Accelerator for Teradata
  • SAS Code Accelerator for Teradata
  • SAS Data Quality Accelerator for Teradata
  • SAS Analytics Accelerator

Teradata Database on Microsoft Azure

  • SAS/ACCESS Interface to Teradata
  • SAS Scoring Accelerator for Teradata
  • SAS Code Accelerator for Teradata
  • SAS Data Quality Accelerator for Teradata
  • SAS Analytics Accelerator

Teradata Database on VMware

  • SAS/ACCESS Interface to Teradata
  • SAS Scoring Accelerator for Teradata
  • SAS Code Accelerator for Teradata
  • SAS Data Quality Accelerator for Teradata
  • SAS Analytics Accelerator

Support by Cloud Providers

Microsoft Azure:

  • Azure Database for MySQL (version 5.6 or later) [1]
  • Azure Database for MariaDB (version 10.2 or later)
  • Azure Database for PostgreSQL (version 9.6 or later)
  • Azure SQL Database
  • Azure SQL Database managed instance
  • Azure Synapse Analytics
  • HDInsight
  • Teradata Database on Microsoft Azure

Google Cloud Platform

  • Google BigQuery
  • Google Cloud Platform Cloud SQL for MySQL (engine version 5.6 or later) [1]
  • Google Cloud Platform Cloud SQL for PostgreSQL (engine version 9.6 or later)
  • Google Cloud Platform Cloud SQL for SQL Server (SQL Server 2017)

Amazon Web Services

  • Amazon Elastic Map Reduce (EMR)
  • Amazon Aurora (MySQL engine version 5.6 or later) [1]
  • Amazon Aurora (PostgreSQL engine version 9.6 or later)
  • Amazon Redshift
  • Amazon RDS MariaDB (engine version 10.1 or later)
  • Amazon RDS MySQL (engine version 5.6 or later) [1]
  • Amazon RDS Microsoft SQL Server (Microsoft SQL Server 2012 or later)
  • Amazon RDS Oracle (Oracle version 11gR2 or later)
  • Amazon RDS PostgreSQL (engine version 9.6 or later)
  • Teradata Database on Amazon Web Services

Oracle Cloud

  • Oracle Cloud Platform (Oracle version 11gR2 or later)
  • Oracle MySQL Database [1]

 

Footnotes
[1] November 2019 release of SAS 9.4M6 or later is required to connect to MySQL 8.0 or later
[2] Connecting to IBM IIAS is only supported from Linux, UNIX, and Windows operating systems.

Recommended Resources


Explore our training options, including on-site classroom, live web, e-learning and one-on-one mentoring.


Validate your SAS knowledge and skills by earning a globally recognized credential from SAS.


Explore documentation on topics of interest to SAS administrators.
 

Back to Top