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Problem Note 70366: An HTTP 500 error occurs on locale-configured Microsoft Windows deployments on the SAS® Environment Manager Dashboard

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Summary

When SAS Environment Manager Server is deployed on a Microsoft Windows system with regional locale or language settings configured, the dashboard view page source XML might be created with invalid characters. This scenario can result in an HTTP 500 error when you attempt to access the SAS Environment Manager web console dashboard.

Cause

This issue is caused by how Microsoft Windows handles "non-unicode" applications. Some of the background tasks that run during the SAS deployment process to copy and extract files run in this mode. As a result, if the encoding configuration for the current system locale uses keycodes that are incompatible with ASCII, certain files might be extracted with additional formatting characters at the beginning. This behavior has been observed to cause problems with SAS Environment Manager's XML files that are used for dashboard rendering.

To check whether a Microsoft Windows system might be susceptible to this issue, check the set language for non-unicode programs by completing these steps:

  1. Open Control Panel ► Region ► Administrative tab.
  2. Go to the Language for non-Unicode programs section to see the current configured locale.

Note: A complete list of locales that encounter this issue is not available. However, it is most likely to occur with DBCS locales such as Japanese (Japan).

Symptoms

When the behavior occurs, the SAS Environment Manager application runs normally and does not exhibit an immediate issue in the log. The issue is surfaced only when you attempt to access the SAS Environment Manager application interactively. When you attempt to load the SAS Environment Manager dashboard (the default page after logging in) in a web browser, an error similar to the following is printed in the Environment Manager Server log:

ERROR [tomcat-http--75] [org.apache.commons.digester.Digester@1655] Parse Fatal Error at line 1 column 1: Content is not allowed in prolog.
org.xml.sax.SAXParseException: Content is not allowed in prolog.
    at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown Source) ~[xercesImpl.jar:?]

Workaround

The workaround is to remove invalid characters in deployed XML files.

These steps should be performed after you have already deployed your SAS software and are currently experiencing the problematic behavior. You must directly modify the files that SAS Environment Manager uses when rendering the dashboard pages. Taking a backup of any files before modifying them is recommended.

1. Obtain a text editor that can show formatting characters, such as Notepad++. A hex editor can also be used.

2. Open each of the following files for editing:

  • SAS-configuration-directory\Lev1\Web\SASEnvironmentManager\server-5.8.0-EE\hq-engine\hq-server\webapps\ROOT\WEB-INF\tiles2\admin-ee.xml
  • SAS-configuration-directory\Lev1\Web\SASEnvironmentManager\server-5.8.0-EE\hq-engine\hq-server\webapps\ROOT\WEB-INF\tiles2\common.xml
  • SAS-configuration-directory\Lev1\Web\SASEnvironmentManager\server-5.8.0-EE\hq-engine\hq-server\webapps\ROOT\WEB-INF\tiles2\tiles.xml
  • SAS-configuration-directory\Lev1\Web\SASEnvironmentManager\server-5.8.0-EE\hq-engine\hq-server\webapps\ROOT\WEB-INF\jsp\tiles.xml
  • SAS-configuration-directory\Lev1\Web\SASEnvironmentManager\server-5.8.0-EE\hq-engine\hq-server\webapps\ROOT\WEB-INF\jsp\layout\tiles.xml
  • SAS-configuration-directory\Lev1\Web\SASEnvironmentManager\server-5.8.0-EE\hq-engine\hq-server\webapps\ROOT\WEB-INF\jsp\admin\managers\plugin\tiles.xml

3. Modify the first line of each file and remove invalid characters.

3a. If you are using a text editor, remove any characters at the beginning of the file before this text: <?xml

Note: Your text editor might render the invalid characters as unicode placeholders, such as 0xBB.

3b. If you are using a hex editor, remove any characters at offset 0x00 before the following: 3C 3F 78 6D 6C

4. Save each modified file.

5. Attempt to load the SAS Environment Manager dashboard by logging in again or refreshing the web page in your browser. If all modifications have been made, the dashboard should load successfully. No restarts to servers or services should be required.

More Information

Click the Hot Fix tab in this note to access the hot fix for this issue.

If you have any questions about the workaround for this issue, open a case with SAS Technical Support.



Operating System and Release Information

Product FamilyProductSystemProduct ReleaseSAS Release
ReportedFixed*ReportedFixed*
SAS SystemBase SASMicrosoft Windows Server 20199.4_M89.4 TS1M8
* For software releases that are not yet generally available, the Fixed Release is the software release in which the problem is planned to be fixed.