SUPPORT / SAMPLES & SAS NOTES
 

Support

Installation Note 61529: SAS® Environment Manager Server fails with a Java version error

DetailsAboutRate It

After you update your SAS Private Java Runtime Environment (JRE), you might encounter an issue in which the SAS Environment Manager Server fails with various errors. This problem occurs when you perform any of the following actions:

  • You configure the server using SAS® Deployment Wizard.
  • You run a deployment task using SAS® Deployment Manager.
  • You manually run the hq-server script to start or stop the server.

Symptoms

In the cases where you are performing a deployment task with SAS Deployment Wizard or SAS Deployment Manager, the following error might be generated during the SAS Environment Manager Configuration step (in the Start Web Application Server stage of deployment):

Configuration Failure dialog box: An unexpected error occurred.

In addition, the following error message might appear in the vfabrchyperc_startMidtierServers_YYYY-MM-DD-TT.TT.TT.log file:

Exception: 2017-10-12 11:19:03,092 [main] ERROR com.sas.sdw.SDWExceptionHandler - java.lang.Exception:
Failed To start EV Manager Server. Java version was not found.

If you have an existing deployment and you attempt to start or stop the SAS Environment Manager Server using the hq-server script, you might see the following messages:

For UNIX operating environments:

Java version was not found

For Microsoft Windows operating environments:

C:\SAS\Config\Lev1\Web\SASEnvironmentManager\server-5.8.0-EE\bin>hq-server start
" LSS 1.6 ( was unexpected at this time.

Cause

You encounter this problem after you do one of the following:

  • Update your SAS Private JRE.
  • Install a new SAS deployment that contains an updated JRE. 

Workaround

The SAS Private JRE contains a script that modifies the hq-server script. You must modify the SAS Environment Manager hq-server script so that it uses the updated SAS Private JRE. Follow the instructions below (based on your operating environment) to run the fix for this issue. 

Instructions for UNIX Operating Environments

  1. On the machine where SAS Environment Manager is installed, navigate to the SASHOME\SASPrivateJavaRuntimeEnvironment\9.4 directory.
  2. Copy the hq_server_java_support.sh script to SAS-configuration-directory/LevN/Web/SASEnvironmentManager.
  3. Navigate to SAS-configuration-directory/LevN/Web/SASEnvironmentManager.
  4. Run the script using the Bash shell with the following syntax:
    ./hq_server_java_support.sh

    Note: If you cannot execute shell scripts, contact your UNIX administrator.

Note: The script creates a backup copy of the original hq-server.sh file named hq-server.sh.backup. This script also modifies the hq-server.sh script so that it points to the updated SAS Private JRE.

  1. If you received the SAS Environment Manager error when you were deploying SAS software using SAS Deployment Wizard or when you were administering SAS using SAS Deployment Manager, click Retry in the error dialog box shown above. If you received the SAS Environment Manager Java version not found error when you ran the hq-server.sh script, then you need to run the updated hq-server.sh file again.

Instructions for Windows Operating Environments

  1. On the machine where SAS Environment Manager is installed, log on as the SAS installer account or an account with full administrator privileges.
  2. Allow the execution of PowerShell scripts by doing the following:
    1. Open PowerShell with elevated privileges by right-clicking PowerShell and selecting Run as administrator.
    2. Submit the following command:  Set-ExecutionPolicy RemoteSigned
    3. Answer Yes to the question "Do you want to change the execution policy?"
  3. In Windows Explorer, navigate to the SASHOME\SASPrivateJavaRuntimeEnvironment\9.4 directory.
  4. Copy the hq_server_java_support.ps1 script to SAS-configuration-directory\LevN\Web\SASEnvironmentManager.

  5. In PowerShell, with elevated privileges (Run as Administrator), navigate to SAS-configuration-directory\LevN\Web\SASEnvironmentManager\.

  6. Run the following command: 
       

    .\hq_server_java_support.ps1

Note: The script creates a backup copy of the original hq-server.bat file with a date-time stamp in the filename. This script also modifies the hq-server.bat script so that it points to the updated SAS Private JRE.

  1. If you received the SAS Environment Manager error when you were deploying SAS software using SAS Deployment Wizard or when you were administering SAS using SAS Deployment Manager, click Retry in the error dialog box shown above. If you received the SAS Environment Manager LSS 1.6 ( was unexpected at this time error when you ran the hq-server.bat script, then you need to run the updated hq-server.bat file again.



Operating System and Release Information

Product FamilyProductSystemSAS Release
ReportedFixed*
SAS SystemSAS Environment ManagerSolaris for x649.4 TS1M09.4 TS1M6
Linux for x649.4 TS1M09.4 TS1M6
HP-UX IPF9.4 TS1M09.4 TS1M6
64-bit Enabled Solaris9.4 TS1M09.4 TS1M6
64-bit Enabled AIX9.4 TS1M09.4 TS1M6
Microsoft® Windows® for x649.4 TS1M09.4 TS1M6
* For software releases that are not yet generally available, the Fixed Release is the software release in which the problem is planned to be fixed.