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Problem Note 56189: Starting SAS® LASR™ Analytic Server in SAS® Visual Analytics Administrator causes the error "...specification of a host other than the local machine"

DetailsAboutRate It

When you start a SAS LASR Analytic Server in SAS Visual Analytics Administrator, you might receive the following error:

   -1
   -------------- Task Summary --------------
   SUCCESS (SASJob PreCode)
   SUCCESS (Store Process ID)
   ERRORS  (Start Server)
   ----------------------------------------------
   ERROR: You cannot combine the STARTSERVER or SERVEROPTS= syntax with the 
   specification of a host other than the local machine.
   ERROR: Invalid parameter
   ERROR: Error in the LIBNAME statement.
   ----------------------------------------------

Cause

This issue can occur if your SAS Services are not stopped and/or started in the correct order.

This issue can also occur if the host name is not set up correctly in SAS® Management Console.

Workaround

  1. Select Start ► All Programs ► SAS and select SAS Management Console to open it.
  2. Click the Plug-ins tab. Under Environment Management, expand Server Manager and select the SAS LASR Analytic Server that does not start. Note: The SAS LASR Analytic Server is listed if a licensed SAS LASR Analytic Server and associated products are successfully installed and configured.
  3. Click the server name. Then, in the Connections pane of the SAS Management Console window, highlight the entry under Name: Connection: LASR-server-name, right-click, and select Properties. The Properties dialog box appears.
  4. In the dialog box, click the Options tab, and look at the entry in the High-Performance Analytics environment host field. The field should show the fully qualified host name. Make sure this name is correct and that there are no spelling errors. (Tip: The fully qualified host name should look like the LASR authorization service location but without http:// and without :/SASLASRAuthorization.) Note: If the workspace server is load-balanced, the name should match the parent peer load-balanced server, or the one that is currently acting in that capacity.

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  1. Make any necessary changes and click OK.
  2. Close the SAS Visual Analytics browser (if it is still open). Then log on and try again.

Note: There have also been cases in which rebooting the server resolved this issue. That is especially useful if everything had been working properly until the time the error occurred.

Before You Restart the Server

Make sure that you stop SAS Services in the correct order before rebooting. Important: The servers should be stopped in the inverse (reverse) order of what you see listed under "Starting Servers in the Correct Order," documented in the SAS® 9.4 Intelligence Platform: System Administration Guide. After rebooting the server, it might take 30 minutes before all the web services are restarted.

If you continue to have problems after trying the above steps, contact SAS Technical Support and provide the following information:

  • The complete error details that you are seeing in SAS Visual Analytics Administrator. If you have already closed the SAS Visual Analytics Administrator, you can highlight the SAS LASR Analytic Server and click Last Log.
  • Your Order Number. (For help with locating your order number, see SAS Note 50493: "Determining your SAS® 9.4 release and which products are in each revision.")
  • The SAS installation data file (SID file) that was used for installation or renewal.
  • Your System Information. Open the System Information dialog box on the server where SAS Visual Analytics is installed, select File ► Save, and enter system for the name.

Note: There are different ways to locate your System Information. Here are three options:

  • Click Start and then, in the Search box, enter msinfo32.exe and press Enter.
  • In Windows 2012 Server, navigate to Server Manager, and select Tools ► System Information.
  • Search for System Information and, when found, double-click it.


Operating System and Release Information

Product FamilyProductSystemSAS Release
ReportedFixed*
SAS SystemSAS Visual AnalyticsWindows 7 Home Premium 32 bit
Microsoft® Windows® for x64
Microsoft Windows 8 Enterprise 32-bit
Microsoft Windows 8 Enterprise x64
Microsoft Windows 8 Pro 32-bit
Microsoft Windows 8 Pro x64
Microsoft Windows 8.1 Enterprise 32-bit
Microsoft Windows 8.1 Enterprise x64
Microsoft Windows 8.1 Pro
Microsoft Windows 8.1 Pro 32-bit
Microsoft Windows 95/98
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Datacenter Server
Microsoft Windows 2000 Server
Microsoft Windows 2000 Professional
Microsoft Windows NT Workstation
Microsoft Windows Server 2003 Datacenter Edition
Microsoft Windows Server 2003 Enterprise Edition
Microsoft Windows Server 2003 Standard Edition
Microsoft Windows Server 2003 for x64
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2008 for x64
Microsoft Windows Server 2012 Datacenter
Microsoft Windows Server 2012 R2 Datacenter
Microsoft Windows Server 2012 R2 Std
Microsoft Windows Server 2012 Std
Microsoft Windows XP Professional
Windows 7 Enterprise 32 bit
Windows 7 Enterprise x64
Windows 7 Professional x64
Windows 7 Professional 32 bit
Windows 7 Home Premium x64
Windows 7 Ultimate 32 bit
Windows 7 Ultimate x64
Windows Millennium Edition (Me)
Windows Vista
Windows Vista for x64
Linux for x64
Microsoft Windows Server 2019
Microsoft Windows Server 2016
Microsoft Windows 10
* For software releases that are not yet generally available, the Fixed Release is the software release in which the problem is planned to be fixed.