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Installation Note 55323: The “Install Post Processing” step of the SAS® 9.4 installation process fails when you are applying software updates

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When you are updating an existing installation of SAS 9.4 to SAS 9.4 TS1M2 in a Windows operating environment, the installation might fail during the "Install Post Processing" step.

What You Might See

Here are some examples of what you might experience. The following files contained in the C:\Users\user-ID-that-performed-installation\AppData\Local\SAS\SASDeploymentWizard directory might contain the errors indicated below.

The DeploymentSummary_datetime.html File

Completed with errors - Install Post Processing

The IT_datetime_install.log File

2015-02-02 13:31:52    BuildSASDesktopTask - Arguments: [C:\Program Files\SASHome\SASFoundation\9.4\sas.exe, 
C:\Program Files\SASHome\SASFoundation\9.4\core\sasmacro\deskdata.sas, -CONFIG, 
C:\Program Files\SASHome\SASFoundation\9.4\nls\de\sasv9.cfg, -sasuser, "C:\Program Files\SASHome\InstallMisc",
-icon, -nologo, -noterminal, -noprngetlist, -unbuflog, -noautoexec, -filesync, HOST, -log, 
C:\Program Files\SASHome\SASFoundation\9.4\nls\de\SASCFG\sasdesk.log]
2015-02-02 13:31:52    InstallationTask - Invocation of SAS returned 2
2015-02-02 13:31:52    InstallationTask - SAS log contents:
2015-02-02 13:31:52    InstallationTask - 1                                                         
 The SAS System                             13:31 Monday, February 2, 2015
2015-02-02 13:31:52    InstallationTask - 
2015-02-02 13:31:52    InstallationTask - WARNING: One or more libraries specified in the concatenated library SASHELP 
2015-02-02 13:31:52    InstallationTask - WARNING: do not exist.  These libraries were removed from the concatenation.
Caused by: com.sas.tools.installs.it.InstallException: SAS Foundation error while performing post install task 
[SAS invocation return code of 2

The deskdata.log File

This file is located in C:\Program Files\SASHome\SASFoundation\9.4\nls\language\SASCFG\sasdesk.log.

Here is an example: C:\Program Files\SASHome\SASFoundation\9.4\nls\de\SASCFG\sasdesk.log

   WARNING: One or more libraries specified in the concatenated library SASHELP 
   WARNING: do not exist.  These libraries were removed from the concatenation.
   WARNING: Library SASCFG does not exist.
   ERROR: Library SASCFG does not exist.

After the Installation Is Complete

If you attempt to run the SAS® Deployment Manager after the installation has completed and you run the SAS® Foundation Post-Install Tasks under the Repair tool, you might see the following failure notice:

image label

Cause

This issue might occur if the following steps have occurred:

  • If you previously installed some SAS client products such as SAS® Enterprise Guide® or the SAS® Add-In for Microsoft Office from a SAS 9.4 TS1M0 or SAS 9.4 TS1M1 order. And, importantly, these clients were installed with all languages selected.
  • You then installed Base SAS® and/or other SAS® Foundation products in just English. Note the discrepancy in the sets of languages installed between these two steps.
  • Then you attempted to apply software updates from a SAS 9.4 TS1M2 software order to the existing SAS software. When all languages are installed for some products but not for Base SAS, the SAS® Deployment Wizard tries to update all languages for Base SAS. If all languages are not installed for Base SAS, the buildSASDesktop task within Install Post Processing fails. The editSASConfig task creates sasv9.cfg files and only partially installs the languages. The German (de) language is the first one on the list to build and appears in the IT log as in the example above.

Workaround

To work around this issue, reinstall only Base SAS from the software order that was last used to install Base SAS. Select all languages to be installed with Base SAS. Once Base SAS for all languages has been installed, you can apply the software updates from your new software order

Fixed

This issue has been fixed in SAS 9.4 TS1M3, Revision 15w38, which shipped in August 2015



Operating System and Release Information

Product FamilyProductSystemProduct ReleaseSAS Release
ReportedFixed*ReportedFixed*
SAS SystemBase SASMicrosoft® Windows® for x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8 Enterprise 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8 Enterprise x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8 Pro 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8 Pro x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Enterprise 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Enterprise x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Pro9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Pro 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 20089.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2008 R29.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2008 for x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 Datacenter9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 R2 Datacenter9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 R2 Std9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 Std9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Enterprise 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Enterprise x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Home Premium 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Home Premium x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Professional 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Professional x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Ultimate 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Ultimate x649.4_M29.4_M39.4 TS1M29.4 TS1M3
* For software releases that are not yet generally available, the Fixed Release is the software release in which the problem is planned to be fixed.