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Usage Note 52121: SAS® Visual Analytics might fail to launch a workspace server with a "MissingCredentialsException" or "MissingIdentityException" error

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Overview

SAS Visual Analytics uses a workspace server for tasks such as registering tables, loading data, and starting or stopping the SAS® LASR™ Analytic Server. For all operating systems, the ability to launch a workspace server must be granted to your individual, external user account. Group logins and internal accounts are not supported. In addition, on Windows, the individual, external account must have the Log on as a batch job privilege.

If the ID that you used to log on to SAS Visual Analytics cannot be used to launch a workspace server, then you might see errors that are similar to these:

com.sas.svcs.serverhub.client.MissingCredentialsException: Additional Credentials required
                 at com.sas.svcs.serverhub.client.CredentialCallbackHandler.handle
                   (CredentialCallbackHandler.java:82)
                 at com.sas.services.user.UserContext.getIdentityByDomain(UserContext.java:1359)
                 at com.sas.services.user.UserContext.getIdentitiesByDomain(UserContext.java:1716)
.......
EXCEPTION (SASJob PreCode). com.sas.svcs.jobexecution.client.TaskExecutionException:
com.sas.services.connection.platform.MissingIdentityException:
The user "SAS Demo User" could not log on to the server "SASAppVA - Logical Workspace Server".
No valid identity could be found for the authentication domain "DefaultAuth".
.......
The application could not import the data.
Please contact your system administrator.
This error is often related to not having credentials
for the SAS Application Server.

Possible Causes

Most commonly, these errors occur because you have logged on to SAS Visual Analytics with one of the following:

  • an internal account
  • a group login
  • a Windows account that does not have the Log on as a batch job privilege

For more reasons why you might not be able to launch a workspace server, see the topic "Credential Gaps" in the SAS Intelligence Platform: Security Administration Guide. You can find a link to the guide on the SAS® Intelligence Platform Product Documentation page. Click the tab for your release of SAS®, and then look under "Administration Documentation".

Resolutions

If you are using a group login, then you can switch to token authentication as an alternative. For information about implementing token authentication, see "SAS Token Authentication" in the SAS Intelligence Platform: Security Administration Guide.

If you are not using a group login, an internal account, or an individual, external identity that is missing the Log on as a batch job privilege, then try the following steps:

  • Restart your object spawner.
  • Compare your user ID with another standard user (not an administrative user) who is able to import data. For example, compare information such as group memberships, password storage, and authentication domains.


Operating System and Release Information

Product FamilyProductSystemProduct ReleaseSAS Release
ReportedFixed*ReportedFixed*
SAS SystemSAS Visual AnalyticsLinux for x646.19.3 TS1M2
Microsoft® Windows® for x646.19.3 TS1M2
* For software releases that are not yet generally available, the Fixed Release is the software release in which the problem is planned to be fixed.