Problem Note 53054: SAS® Visual Data Builder displays "Cannot schedule the query. The scheduler is not connected."
Overview
When you attempt to schedule a query from SAS Visual Data Builder, you might see this message:
Cannot schedule the query. The scheduler is not connected.
Another possible message is this one:
Undetermined error while processing the flow. Operation failed.
About this Problem
These are the steps that SAS Visual Data builder takes when you schedule a query:
- Creates a job that performs the data query operations.
- Creates a deployed job from the job.
- Places the job into a new deployed flow.
- Schedules the flow on a scheduling server.
When this problem occurs, the first three steps are completed. The error occurs at step 4.
In addition, the following conditions are true:
- The logs usually do not record anything other than a failure to connect to the scheduling server.
- Tests of the Operating System Services from SAS® Management Console on the compute tier and the middle tier are successful.
- If the environment is clustered, then running on only one machine in the cluster still reproduces the issue.
- Both trigger-based schedules and Run Now schedules fail.
Causes
When the previous conditions are true, the likely cause is slow network response time. In most cases, the schedule succeeds if you wait at least 30 seconds before clicking OK in the Schedule dialog box. Sometimes, the wait is less than 30 seconds.
You can also do the following:
- Improve network performance.
- If your operating system is UNIX, check the time required for PAM authentication in your environment. This problem can occur if it is taking several seconds per user to complete authentication. The delay can be worse if the system is under heavy use.
For another possible cause for a failure to connect to the scheduling server, see SAS Note 61198.
Operating System and Release Information
SAS System | SAS Visual Analytics | Microsoft® Windows® for x64 | 6.3 | | 9.4 TS1M1 | |
Linux for x64 | 6.3 | | 9.4 TS1M1 | |
*
For software releases that are not yet generally available, the Fixed
Release is the software release in which the problem is planned to be
fixed.
Type: | Problem Note |
Priority: | high |
Date Modified: | 2018-12-06 10:20:59 |
Date Created: | 2014-05-26 21:53:33 |