Resources

System Requirements
SASĀ® Federation Server 4.2

Server-Tier Requirements

In SAS Federation Server 4.2 and higher deployments, DataFlux Authentication Server is being replaced by the SAS Metadata Server. However, in version 4.2, DataFlux Authentication Server is included to support data migration for upgrade installations.

If you are performing a migration, your deployment must include both of the following components:

  • SAS Authentication Server 4.1
  • DataFlux Authentication Server Configuration and SAS Authentication Server 4.1

Both of these component options include required software to support data migration. Having DataFlux Authentication Server Configuration 4.1M1 installed is not sufficient. If you want to migrate SAS Federation Server and believe that your deployment does not include this software, contact SAS Technical Support for assistance.

Some configuration data must be migrated from the Authentication Server to the SAS Metadata Server. SAS documentation provides specific information about data migration. See the SAS Federation Server 4.2 Migration Guide at the following location: http://support.sas.com/documentation/onlinedoc/fedserver/.

SAS Federation Server

Select a platform:

SAS Federation Server includes the following drivers for supported databases:

  • SAS Federation Server Driver for Base SAS
  • SAS Federation Server Driver for DB2 CS
  • SAS Federation Server Driver for ODBC
  • SAS Federation Server Driver for Oracle
  • SAS Federation Server Driver for PostgreSQL
  • SAS Federation Server Driver for SASHDAT

SAS Federation Server Driver for SASHDAT is inoperative unless you include SAS Secure in your order because the driver requires a secure component.

SAS Federation Server includes either a Contact Information Quality Knowledge Base Locale or a SAS Quality Knowledge Base for Product Data in the language of choice. Select one of these options when you place your order, and verify it in your plan file.

The following drivers are optional:

  • SAS Federation Server Driver for Apache Hive
  • SAS Federation Server Driver for Greenplum
  • SAS Federation Server Driver for Netezza
  • SAS Federation Server Driver for SAP
  • SAS Federation Server Driver for SAP HANA
  • SAS Federation Server Driver for Teradata

These optional drivers are not included in the server license.

Note: Use of the SAS Federation Server Driver for SAP with the NetWeaver RFC library requires NetWeaver RFC SDK 7.20, patch level 36 (or higher).

SAS Data Servers

SAS Federation Server contains a SAS data server (SAS Data Management Data Server), which requires additional configuration.

The size of the data server is medium.

Note: When you configure your software, the size of each data server must be considered.

Before you install, update, or add products and solutions that result in the deployment of one or more SAS data servers to the same machine, kernel parameter changes for shared memory and semaphores are required. For details about configuration of small, medium, and large data servers, see the section "Tuning the PostgreSQL Data Server" in the guide SAS 9.4 Web Applications: Tuning for Performance and Scalability, Second Edition. at http://support.sas.com/documentation/onlinedoc/intellplatform/tabs/admin94.html

SAS Metadata Server

Select a platform:

SAS makes the following recommendations for SAS Metadata Server deployments:

  • a 64-bit host system
  • a dedicated machine to simplify tuning, management, and diagnostics
  • multi-core server hardware because SAS Metadata Server is multi-threaded
  • four or more cores for production deployments

The disk I/O performance of any server-class system should be sufficient. Memory requirements are highly dependent on the product mix and usage, but 8 GB of RAM are sufficient for most large deployments. For many deployments, 4 GB of RAM are sufficient and should be considered a minimum, unless the specific deployment is tested and verified to require less memory.


Middle-Tier Requirements

SAS Federation Server Mid-Tier

Select a platform:

Client-Tier Requirements

SAS Federation Server Client

Select a platform:

SAS Drivers for Federation Server can be installed on a separate machine from SAS Data Management Studio Platform, which is only supported on Windows. The SAS Federation Server Client for Windows is therefore shown as a separate machine option that includes the SAS Data Management Studio Platform component (see below).

SAS Federation Server Client contains required ODBC and JDBC drivers, and they are valid for UNIX and Windows platforms.

SAS Federation Server Client for Windows

Select a platform:

Third-Party Software

SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.

SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. Other brand and product names are trademarks of their respective companies.
® indicates USA registration.
Copyright © 2016 SAS Institute Inc., Cary, NC, USA. All rights reserved.