Problem Note 46570: Rebooting your PC after a successful SAS® 9 installation restarts the SAS® Deployment Wizard
After you successfully install SAS 9.x on the Windows platform, rebooting your PC might cause the SAS Deployment Wizard to automatically restart the installation. If the installation continues to run in the background, then your applications might run slower, and it might take longer for SAS to start.
CAUSE
This can happen if your company uses a script that silently installs SAS when your system is rebooted.
To verify whether your company is using a script to silently install SAS, perform the following steps:
- Select Start ► Run or click Start and click in the Search Programs and Files command box.
- Type msinfo32.exe in the command box and press ENTER. The System Information window appears.
- In the left pane of the window, click Software Environment and then click Startup Programs.
- In the pane on the right, look for SASSystemPrep or SASSysPrep. If you see either SASSystemPrep or SASSysPrep, then your company is using a script to install SAS and can follow the solution below. If you do NOT see SASSystemPrep or SASSysPrep listed, open a track with SAS Technical Support for further investigation.
SOLUTION
Option 1: Remove SASSystemPrep or SASSysPrep from the System Configuration dialog box
- Make sure that you have Administrator privileges.
- Select Start ► Run or select Start and in the search box enter the following:
MSCONFIG.EXE
The System Configuration dialog box appears.
- Click the Startup tab in the System Configuration dialog box.
- Clear the check box for SAS Deployment Wizard, SASSystemPrep, SASSysPrep, or the entry associated with the SAS setup.exe file.
- Click Apply and OK.
- Reboot your PC.
- Verify that the changes have been made:
- Select Start ► Run or click Start and locate the Search Programs and Files command box.
- Type msinfo32.exe in the command box and press ENTER. The System Information window appears.
- In the left pane of the window, click Software Environment and then click Startup Programs.
- In the pane on the right, make sure that neither SASSystemPrep nor SASSysPrep is there.
Option 2: Remove SASSystemPrep or SASSysPrep from the Windows Registry
Warning: SAS is not responsible when you edit the Windows registry: changes in the Windows registry can render your system unusable and will require that you reinstall the operating system. Always back up your registry before you make any registry changes or before using MSCONFIG.EXE. For assistance, see Windows Help, Microsoft documentation, or the Microsoft Windows Web site.
- Click Start ► Run or click Start and locate the Search Programs and Files command box.
- Type regedit and press ENTER. The Registry Editor window appears.
- Check to see whether the following registry keys exist (for all Windows operating systems):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
Note: If SASSystemPrep or SASSysPrep is listed under either of these registry keys, select SASSystemPrep or SASSysPrep, right-click, and select Delete.
Also check to see whether the following registry keys exist for the Windows x64 operating systems:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
Note: If SASSystemPrep or SASSysPrep is listed under either of these registry keys, select SASSystemPrep or SASSysPrep, right-click, and select Delete.
Operating System and Release Information
SAS System | Base SAS | Microsoft® Windows® for x64 | 9.3 | | | |
Microsoft Windows 95/98 | 9.3 | | | |
Microsoft Windows Server 2003 Datacenter Edition | 9.3 | | | |
Microsoft Windows Server 2003 Enterprise Edition | 9.3 | | | |
Microsoft Windows Server 2003 Standard Edition | 9.3 | | | |
Microsoft Windows Server 2003 for x64 | 9.3 | | | |
Microsoft Windows Server 2008 | 9.3 | | | |
Microsoft Windows Server 2008 for x64 | 9.3 | | | |
Microsoft Windows XP Professional | 9.3 | | | |
Windows 7 Enterprise 32 bit | 9.3 | | | |
Windows 7 Enterprise x64 | 9.3 | | | |
Windows 7 Home Premium 32 bit | 9.3 | | | |
Windows 7 Home Premium x64 | 9.3 | | | |
Windows 7 Professional 32 bit | 9.3 | | | |
Windows 7 Professional x64 | 9.3 | | | |
Windows 7 Ultimate 32 bit | 9.3 | | | |
Windows 7 Ultimate x64 | 9.3 | | | |
Windows Vista | 9.3 | | | |
Windows Vista for x64 | 9.3 | | | |
*
For software releases that are not yet generally available, the Fixed
Release is the software release in which the problem is planned to be
fixed.
Type: | Problem Note |
Priority: | medium |
Date Modified: | 2012-09-30 18:18:34 |
Date Created: | 2012-05-14 12:32:31 |