Usage Note 45561: How to use the nmon command to monitor the performance of SAS® on an AIX system
When a Technical Support consultant asks you to monitor the performance of your program using the nmon command, follow these instructions:
- To enable the collection of disk I/O statistics, the value iostat=true must be set.
To display the current setting for iostat, enter this command:
lsattr -E -l sys0 -a iostat
To set the value, enter this command:
chdev -l sys0 -a iostat=true
-
To collect 12 hours' worth of data in two-minute intervals, run the nmon command as follows:
nmon -f -T -s 120 -c 360
Run the nmon command as the root user so that the output contains the kernel settings.
- While nmon is running, launch a SAS program that demonstrates the performance problems that you have reported.
Be sure to include this code at the top of the program file:
options fullstimer source source2 msglevel=i mprint notes;
options sastrace=",,,s" sastraceloc=saslog nostsuffix;
proc options;
run;
libname _all_ list;
/* your existing program goes here */
- If the monitor is still running after the SAS program ends, do not kill the nmon monitor. Allow it to run to completion. If you expect your program to require more than 12 hours to run, increase the value of the -c parameter on the nmon command above.
- The nmon command produces a .nmon file. You can zip the file to reduce its size.
Attach the file and the complete SAS log file to your existing Technical Support track.
If it is not possible to run nmon as the root user, collect output from the following AIX commands instead:
- no -L
- vmo -L
- ioo -L
- schedo -L
- nfso -L
Beginning with AIX 5.3, the nmon utility is installed by default and is integrated within the topas command.
Operating System and Release Information
SAS System | Base SAS | 64-bit Enabled AIX | 9.2 TS2M3 | |
*
For software releases that are not yet generally available, the Fixed
Release is the software release in which the problem is planned to be
fixed.
Date Modified: | 2012-02-29 14:14:02 |
Date Created: | 2012-02-01 15:15:02 |