Resources

SAS® AppDev Studio 3.0 Developer's Site

Example Template Troubleshooting

Information about many of these topics can be found in the SAS 9.1.3 Intelligence Architecture: Planning and Administration Guide (PDF). For information about templates, see Web Application Example Templates.

Java Security

Symptoms

Security exceptions or messages about permissions in the console or server log files.

Cause

When running a Java application with a security manager, a policy file is required to grant permissions to various items, such as SocketPermissions for accessing a specific host and port. If the permissions are not set up properly, then access will be denied to certain classes or resources, causing an exception.

Resolution

It helps to find out what permission has been denied. Sometimes the exception will list what permission needs to be granted. Check the policy file being used for correct configuration of hostnames. For more complete security logs, you can set the "-Djava.security.debug=failure,access" system property.

SAS Environment

Symptoms

Errors running applications that describe invalid username/password errors or other issues with connections, hosts, ports.

Cause

The application is not accessing the correct pieces of the platform.

Resolution

Check the user names, passwords, domains, host names, and port numbers in your JVM arguments that start your application server. Also check the login.config, sas_remote_metadata_source_omr.properties, sas_metadata_source_omr.properties, and web.xml files for the correct metadata information.

SAS Foundation Services

Symptoms

Exceptions or messages about certain services not being available when the application server is started or when the application is accessed.

Cause

The examples that use services will use a ContextListener class to deploy and connect to Foundation Services. If they are not accessible, then these messages will occur.

Resolution

Verify that the ADS Local Services or Remote Services software components are registered in the metadata repository. This can be done with the SAS Management Console under the Foundation Services Manager. Also, check the values in the Web applications sas_metadata_source_omr.properties and sas_remote_metadata_source_omr.properties files for the correct environment values. For more information about how templates use services, see Web Application Example Templates.

Memory Problems

Symptoms

Java OutOfMemory Error in the console or server log files

Cause

OutOfMemory error can sometimes occur when running multiple Web applications under a single server.

Resolution

Adding JVM startup arguments can help. The JVM argument, "-XX:MaxPermSize=128M", is added to the servers startup command to increase the amount of memory used to load classes. The JVM arguments, "-Xms512M" and "-Xmx1024M", are used to modify the initial and maximum Java heap size. See the Planning and Administration guide for more information or see the

SAS Web Report Viewer Template

Symptoms

Example template using SAS Web Report Viewer shows a login screen or shows services exceptions.

Cause

The SAS Web Report Viewer is a separate Web application used to view reports. If the application used to access the SAS Web Report Viewer is not set up properly, you can not pass the report along to be viewed.

Resolution

Make sure that the Services Application (remote services) has been started and the SAS Web Report Viewer Web application is running on URL specified by the "viewer" argument in the web.xml file. Another good configuration test is to verify that the Portal is able to display reports.