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ABSTRACT  
The next generation of SAS® Enterprise Guide® is here! The redefined SAS Enterprise Guide 

8.1 is both sexy and intelligent. SAS Enterprise Guide 8.1 sports a modern and attractive 

interface, tab-based organization of content, and flexible window management such as 

floating, docking, and leveraging multiple monitors. Want to view your code, log, and 

results at the same time? SAS Enterprise Guide 8.1 has you covered. Want to view four 

data sets at the same time? Sure, no problem. Want to just code, without a project? You 

got it. See these features and more at the big reveal of SAS Enterprise Guide! 

INTRODUCTION  
SAS Enterprise Guide is a popular SAS programming environment with convenient point-

and-click wizards, query building, and process flow building capabilities. 

The previous SAS Enterprise Guide interface served users well for many years, however it 

was starting to show its age. More importantly, to incorporate invaluable feedback that you, 

the users, have provided over these years, we knew it was time for a big change. 

Our goal with this redesign was to modernize SAS Enterprise Guide by making it attractive, 

flexible, and smart, yet keep the essence of SAS Enterprise Guide. We will introduce you 

to the new interface and many new enhancements we think you will enjoy using. 

ATTRACTIVE 
Visual appeal evokes powerful emotions. Even in software, an attractive, elegant, intuitive 

interface provides user confidence and a more positive user experience. You be the judge, 

as we reveal the new look of SAS Enterprise Guide! 

 

Display 1: First Look at the New SAS Enterprise Guide Interface 



2 

Now that you’ve had a first look, let’s take a tour! 

FINDING YOUR WAY AROUND 
When you first open SAS Enterprise Guide 8.1, it might seem barren - intentionally so! The 

new layout is all about maximizing the space and efficiency needed to develop code and 

build process flows, while leaving ample room to browse and access the full context of your 

files or project. The user interface is divided into five areas: 

Navigation Panes - contains different panes like the Project, Servers, and Tasks panes 

to assist you while working on your project or program. 

Content Area - provides the main work area. You can open as many tabs as you like, 

arranging them and docking them in any configuration. 

Tools Area - displays the Submission Status and Search panes below the content area 

by default. 

Profile Connection Indicator – indicates the active connection profile. 

Status Bar - shows information about the active project and item. 

 

Display 2: High-level Areas of the New User Interface  

Navigation Panes 
Project 
Want a single place to organize one or more related items? For example, you might have a 

couple queries to prepare some data and programs to analyze the data. A project is an 

excellent way to manage these related items. The Project pane is the view into your 
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project. It is also where you now access project-related operations, such as opening the 

project log. 

Open Items 
Have you ever worked with a lot of tabs and got tired of not being able to see them all at a 

glance? The new Open Items pane solves this by listing all your currently opened items. In 

addition, if you reorder the items in the Open Items pane, the corresponding tabs are also 

reordered. 

Servers 
The Servers pane contains a list of available servers based on the active profile. A few 

enhancements to note: 

• You can specify whether to see unassigned libraries.  

• You can quickly view and then drag and drop variable names into your code; just like 

you can in SAS® Studio. Saves time and avoids typos! 

• You can quickly navigate to items by entering the name. 

SAS Folders 
SAS Folders provide a central location for your stored processes, information maps, data, 

and projects defined in your SAS® Metadata Server. This allows content to be shared with 

other SAS applications. The SAS Folders pane allows you to navigate SAS Folders content 

and add items to projects and process flows. 

Tasks 
The Tasks pane contains a list of point-and-click user interfaces that guide you through a 

process. Here are a few new features: 

• The Tasks pane is the place to discover and launch tasks. 

Note: There is no longer a top-level Tasks menu. The change might take a little getting 

used to, but the pane allows you to view your recent and favorite tasks. You can also 

filter and search all the available tasks. The Tasks pane makes it easier to find tasks. 

• SAS Studio tasks appear in the list by default. 

• You can sort tasks by category or name. 

Prompt Manager 
How often do you find yourself building a project and wishing you could change certain 

options with each run? SAS prompts enable you to accomplish this. You can define a SAS 

prompt to request specific input from the user. When you associate prompts with programs, 

tasks, or queries, the user gets prompted for the input when the items are run. The Prompt 

Manager pane is where you create and edit prompts. 

Content Area 
Start Page 
The Start Page is a nice welcome into the application. It provides easy access to recent 

items and quick links to open a new program or project. There are additional links to learn 

more about SAS Enterprise Guide and to get involved in the community. Commonly used 

items can be pinned, so they always appear on the Start Page. You can hide or show the 

Start Page by selecting View > Start Page. 

If you do not want to see the Start Page whenever you open SAS Enterprise Guide, you can 

select Tools > Options > Start Up and uncheck Show Start Page. See the “Start Up 

Options” section for more details. 
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Your Content 
Any items you open are displayed in tabs in the content area. This is your primary working 

area. For example, this is where you would edit programs, create process flows, view SAS 

data sets, and work with any other content. 

Tools Area 
Submission Status 
Use the Submission Status (formerly known as the Task Status) pane to help you view 

and manage the status of submitted programs, tasks, and stored processes. For more 

details see the “Submission Status” section. 

Search 
There is now a Search pane where you can quickly search for items in a project or in the 

Open Items pane. You can launch it in two ways. 

• Click the Search icon ( ) in the top toolbar area.  

• Select View > Search to hide or show the Search pane.  

Double-click an item in the search results to navigate to that item. 

THEMES 
What? You don’t like a light theme? Good news… SAS Enterprise Guide has multiple outfits 

from which you can choose. SAS Enterprise Guide 8.1 supports common SAS themes to 

promote consistent styling with other SAS applications. 

Check out our dark theme by selecting Tools > Options > General. Then select Ignite as 

the Color theme. SAS Enterprise Guide also honors Windows High Contrast themes. The 

following screenshots highlight the three themes: 

 

Display 3: Illuminate, Ignite, and High Contrast Themes 

OK, so the new interface is attractive. I need some substance. What else is there? 
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FLEXIBLE 
The new SAS Enterprise Guide lets you choose how you want to work. With fully 

customizable window layouts, optional projects, project log settings, and start-up options, 

you have the control. You decide what you want to wear! 

LAYOUT 
Starting in SAS Enterprise Guide 8.1, content is opened in individual tabs in a tab group 

across the top of the content area. This behavior is consistent with other SAS solutions and 

an experience very familiar to web browser users. 

One of the biggest enhancements added to SAS Enterprise Guide 8.1 is the ability to fully 

customize your workspace layout. Almost any pane or document tab can be moved, docked, 

or floated to your liking. 

Display 4 shows viewing four different content tabs at the same time: 

 

Display 4: Viewing Multiple Content Tabs at the Same Time 

This also allows you to leverage multiple monitors. You are no longer confined to the SAS 

Enterprise Guide application window. You can float any pane or document tab and move it 

onto additional monitors. 

Working with Programs 
The fully flexible windowing environment provides a huge advantage when working with 

programs. Users have long wanted to ability to more easily see their code, log, results, and 

output data at the same time. We designed SAS Enterprise Guide 8.1 to address this desire. 

Program tabs have sub-tabs for displaying the code, log, results, and output data associated 

with a program. Out-of-the-box, SAS Enterprise Guide shows programs in a vertical split 

view, with code on the left, and log, results, and output data in a tab group on the right. 
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This makes it easy to work with your code and see the results of running it at the same 

time! 

Of course, you are not stuck with that layout. Like primary tabs, the layout of sub-tabs can 

be fully customized to your liking. Display 5 shows a program layout that enables working 

with code, log, and results at the same time. 

 

Display 5: Working with Code, Log, and Results at Same Time 

How to Customize Your Layout 
You can customize your layout manually or via presets. 

Manual 

To customize your layout manually, click and drag any tab. A layout guide and a drop 

preview appear when you drag the window over regions it can be docked in the application. 

Display 6 shows using the layout guide to dock a program tab to the right of the content 

area. Dropping the window in a different area floats the window. 
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Display 6: Layout Guide and Drop Preview 

Presets 

Rather than manually laying out individual program sub-tabs, you have the option to choose 

from several preset layouts. To choose a default layout for your programs, select View > 

Program tab presets, and select a desired layout. The active program and all 

subsequently opened programs appear in the specified layout. 

You can apply a primary tab layout by selecting View > Apply tab layout and selecting a 

desired layout. This has the same effect as selecting the New vertical tab group or New 

horizontal tab group menu item from the context menu on a primary tab. 

If your layout gets unwieldy, you can reset to the default layout at any time by selecting 

View > Reset to default layout. 

WORKING WITH A PROJECT, OR NOT! 
SAS Enterprise Guide 8.1 no longer requires working with a project. Projects (which you can 

think of as a folder) are a convenient way to group and organize related SAS content 

(programs, data references, process flows, results, and so on). However, you might just 

want to work with .sas files or simply open data sets for viewing, without a project. You now 

have the choice! 

By default, SAS Enterprise Guide 8.1 does not start up with a project open (see Start Up 

Options section), but there are plenty of ways to get a project started. 

Use one of these four ways to create a new project: 

• Select File > New > Project.  

• Select the new icon ( ) on the top toolbar, and then select Project. 

• On the Start Page, select Create new project. 

• From the Project pane, select Create a New Project. 

To close a project: 
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• From the Project pane, click the More options icon ( ) and select Close project.  

• Select File > Close project.  

If you have no interest in projects at all and want to declutter your environment, you can 

close the Project pane by clicking its Close icon or selecting View > Project.  

Items That Do Not Require a Project 
The following items no longer require a project in SAS Enterprise Guide 8.1: 

• programs 

• data 

• OLAP cubes 

• SAS Report results  

• SAS® Visual Analytics Reports 

• logs 

These items can be opened and edited in a project-less environment. We plan on adding 

more items, such as tasks, to the list in subsequent releases. 

Adding Items to a Project 
If you decide to work with a project, you now have two ways of adding content to your 

project. The first option is to have content automatically added to the project when opened, 

like in previous releases. (This is the default behavior.) The second option is to explicitly 

control when content is added to your project by unchecking the When an item is 

opened, automatically add to the project option in Tools > Options > Project and 

Process Flows. You can add items to your project manually by selecting Add to project 

on the context menu of the item to add. 

 

Display 7: Ways to Work With or Without a Project 

  



9 

CHOOSE HOW TO HANDLE LARGE PROJECT LOGS 
The project log keeps track of everything that is run in your project by appending every log 

that is generated. This is a convenient way to audit a project. However, as you can imagine, 

the project log can quickly grow. Since the project log is stored in your project, it can also 

bloat the size of your project file. Previous releases of SAS Enterprise Guide warn you when 

the project log reaches 5 MB in size and stops appending. Then you must manually export 

and clear the project log. 

SAS Enterprise Guide 8.1 provides options that allow you to control how to handle large 

project logs more conveniently. (See Display 8.) You can configure SAS Enterprise Guide to 

simply display a warning message, automatically remove the oldest appended logs, or 

automatically export and clear the project log when the project log reaches the size you 

specify (5 MB by default). You also have the option to automatically Clear the log when 

the project closes. 

 

Display 8: Project Log Options 

START UP OPTIONS 
As we mentioned in the Start Page section, SAS Enterprise Guide presents you with the 

Start Page by default when you first open the application. However, perhaps you prefer to 

jump right in. You now have the choice of how you want to start. 

There are several new options in Tools > Options > Start Up that allow you to control 

your start-up experience: 
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• Show Start Page. When checked (the default), the Start Page is displayed at start-up. 

• Automatically dismiss. When checked (unchecked by default), the Start Page is 

dismissed after the first Open operation. This makes the Start Page truly a starting 

point and then gets it out of your way. 

• Other items to display on start up. Choose one of the following options: 

• No project or program. Selected by default. Start with no project or program. 

• New program only. Start with a new empty program, so you can immediately 

begin coding. 

• New project only. Start with a new project. 

• New project and program. Start with a new empty program in a new project, so 

you can immediately begin coding in a new project. 

 

Attractive and flexible, what more could you want!? 

SMART 
SAS Enterprise Guide is not just pretty and friendly. It is smart too! The new SAS Enterprise 

Guide provides intelligent enhancements that allow you to be more productive. 

SUBMISSION STATUS 
SAS Enterprise Guide now provides a Submission Status pane which enhances and 

replaces the previous Task Status view. It shows the status of all your submitted 

programs, tasks, and stored processes. This is especially valuable since you can run large 

projects with many items in multiple process flows, and you can run your items with 

conditional processing or in parallel.   

Select View > Submission Status or double-click the gear icon on the status bar (

) to see a complete list of items queued to run, currently running, and completed. (See 

Display 9.) The Submission Status pane adds additional information including the 

submission time, the completion time, the run time, and the container for the item.  From 

there, you can quickly see which items have succeeded. If an item fails, double-click on the 

failed item, and it is displayed in your content area. 

 

Display 9: Submission Status 

Submissions are not automatically removed from the Submission Status pane. If the 

submission status contains too many items, you can filter the content by selecting Errors, 

Warnings, or Queued.  Or, you can select the Automatically clear successful 

submissions menu item on the More options menu ( ). 
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RECENT ITEMS AND RECENT LOCATIONS 
The File Open window now makes it much easier for you to get to recently opened content. 

When you initiate opening content (for example, File > Open), SAS Enterprise Guide 

presents you with a list of recently opened items, any of which you can quickly re-open with 

a single click. You can pin items to ensure they always appear at the top of the list. (See 

Display 10.) 

Note: This is the exact same Pinned Items and Recent Items list that appears on the 

Start Page. 

 

 

 

 

 

 

Display 10: Pinned and Recent Items and Locations 

The File Open and File Save windows also keep track of recent locations from which you 

have opened content or to which you have saved content, since there is a good chance you 

want to work with content in those locations again. Recent locations are displayed for each 

corresponding place (My Computer, Servers, and SAS Folders). For example, the Servers 

page shows recent folders and recent libraries accessed on the server. Like recent items, 

recent locations can be pinned to ensure they stay at the top of the list.  

Recent locations are extremely useful when you would otherwise have to drill several 

subfolders deep to access your content. 
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NOTIFICATIONS 
SAS Enterprise Guide now has a notification banner to alert you of important events. (See 

Display 11.) These can range from simple events such as migrating your project from a 

previous version of SAS Enterprise Guide to critical events such as a lost connection with 

your server.  

These messages are displayed in a non-intrusive banner, which allows you to continue 

working. You can review and clear the notification messages when you are ready.  

 

Display 11: Notification Banner Examples 

SMARTER DATA GRID 
The ability to fit column widths to the data and be more conservative about locking data are 

two highly requested features and have been added to the data grid in SAS Enterprise 

Guide 8.1. 

Auto-sizing Column Widths 
Previous versions of SAS Enterprise Guide opened data in fixed-width columns. This usually 

had the advantage of being able to display more columns on the screen at once, but the 

disadvantage of having to manually increase column widths to see wider values. Now you 

have a choice and a better out-of-the-box experience. 

Column widths are now auto-sized (to the column heading label and values, up to a 

maximum width) by default when you open data in the SAS Enterprise Guide 8.1 data grid.  

There is a new Auto-size column widths option (in Tools > Options > Data > 

General), which is checked by default. If you prefer the old behavior (fixed-width columns), 

you can uncheck this option. 

In addition to the global option, which controls the initial column widths, you can explicitly 

auto-size all the columns at any time by selecting the new Auto-size column widths 

menu item on the data grid's overflow menu.  As in past releases, you can still double-click 

the right side of an individual column heading to cause that column’s width to be 

immediately auto-sized. 

Conservative Locking 
When you open data in the SAS Enterprise Guide data grid, the physical data is locked from 

updating. This prevents other users or processes from updating the data while it is open in 

the data grid. Prior versions of SAS Enterprise Guide would close the data grid after 30 

minutes of inactivity (by default) to reduce the window in which this resource contention 

might occur. So, one user forgetting to close their data grid would not cause a nightly batch 

job to fail to update the data. However, we could do better. 

With the switch to a tab-based interface in SAS Enterprise Guide 8.1, the data grid remains 

visible, but releases the underlying lock after a period of inactivity (three minutes by 

default). You can change the period of inactivity via the Unlock open data after inactivity 

(minutes) option in Tools > Options > Data > Performance. The default window of 

potential resource contention has been reduced by 90% (from 30 to 3 minutes)! 
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A banner appears above the data when the data is unlocked after a period of inactivity. (See 

Display 12.) You are still able to view and scroll the data values that were already retrieved 

– a big improvement over the previous behavior! The banner has a Refresh link that will 

re-open the data (re-establishing the lock) and re-populate with the latest values. 

 

Display 12: Data Unlocked Due to Inactivity 

RUN TO SELECTED ITEM IN PROCESS FLOWS 
Prior releases of SAS Enterprise Guide allow you to run from a node in a process flow. 

However, there is not a convenient way to run to a node in a process flow. SAS Enterprise 

Guide 8.1 now supports both. Running from a node runs the selected node (inclusive) and 

all nodes downstream of it. Running to a node runs all the nodes upstream of the selected 

node but does not run the selected node itself (exclusive). 

There are two ways to run to or from a node in a process flow: 

• Select the desired node and click the down arrow on the Run button on the process flow 

toolbar and select Run to selected item or Run from selected item. 

• Right-click the desired node and select Run to selected item or Run from selected 

item.  

 

Display 13: Run Options on a Node in the Process Flow 

LOG STREAMING 
Unlike the SAS Display Manager, previous versions of SAS Enterprise Guide and SAS Studio 

were unable to stream the SAS log back while procedures were running. SAS 9.4M5 added 

support for log streaming for client/server-based clients, such as SAS Enterprise Guide and 

SAS Studio. SAS Enterprise Guide 8.1 and SAS Studio now use this support and stream SAS 

logs by default when working with a SAS 9.4M5 or later server. If you prefer the old 
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behavior, you can turn off log streaming in SAS Enterprise Guide by unchecking the Stream 

log updates while a procedure is running option in Tools > Options > Results > 

General. 

In addition, SAS Enterprise Guide 8.1 updates the log asynchronously when log events are 

received from the server. This ensures that updating the log view does not interfere with 

the execution of the job and results in some jobs running faster in SAS Enterprise Guide 

than they do in SAS Display Manager. 

SAS ENTERPRISE GUIDE AND SAS STUDIO 
If you have seen SAS Studio lately, you might have noticed that SAS Enterprise Guide 8.1 

and SAS Studio are looking a lot more similar. That is by design. SAS Enterprise Guide and 

SAS Studio serve a similar purpose – SAS programming environments with convenient 

point-and-click wizards. One is a native Windows client, one is a web client. Our goal is for 

these two clients to be able to work on more and more of the same content seamlessly. We 

also want both clients to provide a reasonably consistent user experience. The goal is not to 

make them identical, yet to leverage the strengths of their respective environments. 

Ultimately, we want users to be able to choose their preferred interface (one or both) and 

easily go between them. 

 
Display 14: SAS Enterprise Guide and SAS Studio 
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CONCLUSION 
The revamped interface in SAS Enterprise Guide 8.1 is attractive, flexible, and smart. We 

hope you will find it a pleasure to use. This redesign lays the foundation for years to come. 

Get your hands on SAS Enterprise Guide 8.1 and let us know what changes you would like 

to see next! 
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