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ABSTRACT  
There are many time-saving and headache saving tips and tricks you can use to make 
working in SAS® Enterprise Guide® a breeze. Did you know that you can change your layout 
so that you can see your code and your results at the same time? You will learn 20 tips and 
tricks for working in SAS Enterprise Guide in 20 minutes. One tip per minute, and out of the 
twenty you are guaranteed to find at least one nugget that will make your life easier.  

INTRODUCTION  
There is a difference between programming and programming efficiently. You might know 
how to get your code to run and generate results, but are you doing it as painlessly as 
possible? In this paper, you will learn 20 tips for working in SAS Enterprise Guide that will 
help you become a more efficient and happier programmer. You will learn how to make SAS 
Enterprise Guide feel more like “old school Base SAS,” or how to make it feel totally cutting 
edge. Just as there are often several ways to get the same results, there are many features 
to get the SAS Enterprise Guide experience and performance that meets your needs. The 
goal of this paper is to show you at least one feature you haven’t been using but that you 
can’t wait to implement. 

CUSTOMIZING GENERAL OPTIONS 
Regardless of whether you spend a lot of time or a little bit of time using SAS Enterprise 
Guide, you want it to be the most user-friendly experience you can have. But since your 
definition of user friendly might not be the same as another users, SAS Enterprise Guide  
has options that you can use to customize your experience.  

From the main menu, select Tools > Options.  

 
Figure 1: Options 

1. TURN OFF WELCOME WINDOW 
The General panel is where you can turn general options on or off. For example, if you 
don’t want to see the Welcome window every time you open SAS Enterprise Guide, you can 
turn it off by deselecting the Show Welcome window at start-up option.  
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      Figure 2: Welcome Window         Figure 3: General Options 

 

2. AUTOEXEC PROCESS FLOW 
Another general option that is a time saver is the Automatically run “Autoexec” process 
flow when project opens. You can create a process flow named Autoexec that defines all 
your macro variables or your LIBNAME statements, for example. Every time you open that 
project, the Autoexec process flow automatically runs, and the macro variables or libraries 
will be ready to use.  

3. RESET DEFAULT LAYOUT 
Sometimes your project might seem to be misbehaving – you have lost a window, or it 
won’t go where you want it, or your cursor is nowhere to be found. One of the first things to 
try is to use the Restore Window Layout option in the General panel.  (Note: In SAS 
Enterprise Guide 8.1, this option is on the main menu under View-> Reset to default 
layout). 

4. AUTOMATICALLY REPLACE TASK RESULTS 
We turned off the Welcome window so that it doesn’t pop up each time we open SAS 
Enterprise Guide, but what about being prompted to replace the results of a task every time 
you run it? This is the default behavior, but you can turn it off. You can do this by setting 
the Replace results option to Replace without prompting.  
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Figure 4: Automatically Replace Results 

 

5. AUTOMATICALLY SUBMIT CUSTOM SAS CODE 
There might be code that you want to run every time you open SAS Enterprise Guide, or 
every time before or after you submit code from a program node. For example, you might 
want to create certain macro variables or work tables or assign or unassign libraries. You 
can include this code and set it to automatically run by selecting the SAS code options in the 
SAS Programs panel.   

 

 

Figure 5: Automatically Run Custom Code 

WORKING WITH THE PROGRAM EDITOR 
You might have moved to SAS Enterprise Guide from another programming interface and 
prefer coding to point-and-click. The Program Editor in SAS Enterprise Guide can be 
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customized to make your coding experience easy and familiar. 

6. TURN ON LINE NUMBERS 
Line numbers are not turned on by default in the Program Editor. To turn on line numbers, 
select Tools->Options.  Open the SAS Programs panel and click Editor Options. In SAS 
Enterprise Guide 8.1, it’s even easier – just right-click in the Program Editor and select 
Show line numbers. 

 

7. AUTOMATICALLY FORMAT CODE 
Sometimes you are so “on a roll” with writing code that you don’t want to take the time to 
indent your code and make it readable. SAS Enterprise Guide can help! Right-click in the 
Program Editor and select Format code, and your code will transform into a more readable 
and structured format. You can also press Ctrl+I to format the code.  

 

8. COPY A COLUMN  
There are times when you want to copy lines of code and reuse them. But you might not 
want the whole line, just part of it. Rather than copying the lines and deleting the part you 
don’t want, press Alt+left mouse to highlight the part you want, and then copy it.  

 

 
Figure 6: Copy a Select Area 

 

9. DATA STEP DEBUGGER 
You will get a syntax error in the log when you have an error in your code, but it’s harder to 
find errors in the code logic. The code might run but it doesn’t produce the results you 
expect. You can use the DATA Step Debugger to find the logic errors in your code.  

Enable the debugger by clicking on the green bug on the toolbar in the Program 
Editor. Then activate the debugger by clicking on the bug to the left of your code. You can 
then step through your DATA step, line by line, and see the values of your variables change. 
You can even set a Watch variable to tell you specifically when the value of that variable 
changes.  



5 

 
 

Figure 7: DATA Step Debugger with “flag” Set as Watch Variable 

 

10. SYNTAX HELP WINDOW 
 Sometimes you might not remember the exact syntax for a function or a statement, and 
you need quick help. You can hover over the keyword and the syntax help window will 
appear.  

 

 
Figure 8: Syntax Help Window 

 

In addition to the at-a-glance information provided, you can also access product 
documentation, samples and SAS notes, and papers.  

Bonus tip: Keyboard shortcuts are available to make it even easier! 

Search the online syntax help for the selected keyword. Ctrl+Shift+H 

Search SAS Technical Papers for the selected keyword. Ctrl+Shift+P 

Search SAS Product Documentation for the selected keyword. Ctrl+Shift+D 

Search SAS Samples and Notes for the selected keyword. Ctrl+Shift+N 
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Open the syntax help for the appropriate argument in a SAS function when the 
cursor is positioned in the function argument list. 

Ctrl+Shift+spacebar 

Table 1: Syntax Help Keyboard Shortcuts 

11. SPLIT VIEW INTO MULTIPLE WINDOWS 
By default, SAS Enterprise Guide displays only one item at a time. But you can easily 
change this and show two items at a time using the Workspace Layout option. You might 
want to have your Program Editor open, and see the input data set you’re working with. Or 
the log and Program Editor. Or the output data set and the result – the combinations are 
endless!  

To view two windows at once, select View Workspace Layout and then select Stacked 
or Side-by-Side. To specify the window you want something to open in, click in 
the upper right corner of the workspace. 

In SAS Enterprise Guide 8.1, the workspace is extremely customizable, and you are not 
limited to two workspaces. 

WORKING WITH LOGS 

12. PROJECT LOG 
The project log is turned off by default in SAS Enterprise Guide. To turn on the project log, 
select Tools Options. In the General panel, select Enable project log for new 
project. Now that the project log is on, it will track all the tasks and code run in the entire 
project and enable you to view the logs for each in one place. In addition, you can use the 
Log Summary window to quickly see the specific log that has an error. 

 

 
Figure 9: Log Summary Window 

 

13. FINDING ERRORS 
Now you know your project has an error, so how do you find it?! You can use the Log 
Summary Window as shown in Figure 9. Click on the line with the error (or warning, or 
note), and that will highlight the corresponding line that contains that error in the log. Note 
that if you don’t want to see the notes (or the warnings), you can click on the corresponding 
tab, and they are removed from the log summary. 
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Figure 10: Using Log Summary to Find Errors 

Another way you can jump to errors or warnings in the log is to press Ctr+E.  

14. DECLUTTERING LOGS 
 You might have noticed a lot of code in the log that you didn’t write in your program – like 
%LET or ODS – and wonder where the heck it came from. This code is automatically 
generated by SAS Enterprise Guide when you run a program or task. If you don’t want this 
code written to the log, select Tools  Options. Under the Results heading, select 
Results General.  De-select Show generated wrapper code in SAS log. The verbose 
code is replaced by:  
  

1 %_eg_hidenotesandsource; 
 
 

TASKS AND QUERIES  

15. FINDING THE RIGHT TASK 
SAS Enterprise Guide has built-in tasks that you can use to harness the power of SAS 
procedures in a GUI format. Now, you don’t have to know the syntax for a procedure to be 
able to use one! However, it can be puzzling if you DO know the name of the procedure you 
want to use, but you don’t know the name of the corresponding SAS Enterprise Guide task. 
One way to find this task is to use the Tasks pane.  

   Select the Filters option to see a list of all the available procedures. Select the procedure 
you want, and you will see the task or tasks that use that procedure. You can also search on 
the procedure name.  
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 Figure 11: Task Window         

Here we see that PROC PRINT corresponds to the List Data task. And if you hover over the 
task, you will get an info window that gives further detail. Click the star to add this task to 
your list of favorites for fast access in future uses. 

16. FILTERING AND SORTING 
The Sort Data task can be used to sort your data. There is also a Filter and Sort option in 
the data grid. What’s the difference?  

 The Filter and Sort option enables you to select what columns you want, and subset the 
data – for example, if you want to see only sedans with a City MPG greater than 25 – and 
then sort the data. If you sort the data by Make, you might get rows that repeat, so the 
results aren’t quite what you had in mind. What you REALLY wanted is a list of all the Makes 
that met the criteria with no duplicate records. 

In that case, you want to use the Sort Data task.  In this task, you have all the same 
options as in Filter and Sort, but you ALSO have the option to Keep only the first record 
for each “Sort by” group, which removes any duplicate records.  
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Figure 12: Sort Data Task Results Versus Filter and Sort 

 

17. CREATING DYNAMIC QUERIES  
The Query Builder is a powerful tool that generates SQL behind the scenes enabling you to 
join and manipulate data. You can use prompts (or macro variables) to make your queries 
dynamic. 

You might want to query a data set by gender and calculate the average height. Instead of 
using the same value for gender in the filter each time, you want to select the gender when 
you run the query. Use the Prompt Manager to create a variable that lets you choose the 
value when you run the query. 

 

 
Figure 13: Creating a Prompt 
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You can now use this prompt in the filter of your query. When you run the query, you will be 
“prompted” to select the gender you want.  

 

18. CREATING TASK TEMPLATES AND SUBQUERIES 
You can take this a step further and use your query to create a subquery. You created a 
prompted query that returns the average height for a gender. You can create a task 
template from this query. Task templates are handy for when you regularly run the same 
query, and you don’t want to have to re-create it each time.  

Right-click the query and select Create Task Template. You can now reuse the template 
on other data with the same columns, OR you can use it in a subquery.  For example, you 
can create a template that calculates the average weight for a gender using the 
SASHELP.Class data set.  That template can be used as a sub-query to filter the values to 
include only observations with heights greater than or equal to the selected gender’s 
average from the SASHELP.Classfit data set.  

 

 
Figure 14: Creating a Subquery Using a Template 

 

PROCESS FLOW AND PROJECTS 
 You now have dynamic queries and subqueries that you’d like to reuse without having to 
re-create them. This is the perfect time to create a stored process! 

 

19. CREATE A STORED PROCESS FROM A PROJECT 
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You can create a stored process from your project. A stored process puts all the code 
from the project into a neat bundle and stores it in a central location where it can be 
accessed by remote clients.  

To create a stored process, right-click in the process flow and select Create Stored 
Process.  The Create New Stored Process wizard walks you through creating the 
stored process.  After you create the stored process, you can use it in other SAS 
applications, such as SAS Add-In for Microsoft Office, or other people who have 
access to the stored process can use it.  

20. SEARCH PROJECT 
You might be working on a project and need change out a data set with another one. 
This can be a big pain if you have a large project where you used the data set 
multiple places. But never fear, you can search for all the places the data set could 
be hiding using the project search. Enter the text string that you want to search for – 
in our case, the data set name. A results box will appear that contains all the places 
where the text string was found.  

 

 
Figure 15: Project Search Results 

You can search the whole project, or if you want to refine your results to just 
programs that contain the string, you can just select Program. To open the results, 
double click the search result you want to open. 
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CONCLUSION 
SAS Enterprise Guide is a powerful tool designed to make data access, analysis, and sharing 
easy. Whether you are a seasoned programmer or a novice, you can use SAS Enterprise 
Guide to harness the power of SAS. We have only scratched the surface of some of the tips 
you can use when working with SAS Enterprise Guide, but hopefully you found at least one 
new tip that you can start using next time you log on.  

    

RECOMMENDED READING 
 

For ongoing tips, see  Chris Hemedinger’s blog “The SAS Dummy” 
https://blogs.sas.com/content/sasdummy/, as well as visiting the SAS Enterprise Guide 
Communities site: https://communities.sas.com/t5/SAS-Enterprise-Guide/bd-p/sas_eg. 
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