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ABSTRACT
®

®

SAS Enterprise Guide has proven to be a very beneficial tool for both novice and experienced SAS users. Because
it is such a powerful tool, SAS Enterprise Guide has risen in popularity over the years. As a result, SAS Technical
Support consultants field many calls from users who want to know the best way to use the application to accomplish
a task or to obtain the results they want. This paper encompasses many of those tips that SAS Technical Support has
provided to customers over the years. These tips are designed to improve your proficiency with SAS Enterprise
Guide in the areas of connection and configuration, workflow preferences, logging, data source management, project
files, operating-system commands, and custom tasks.

INTRODUCTION
SAS Enterprise Guide users fall into three general categories. There are the users who are unfamiliar with both Base
®
SAS software and SAS Enterprise Guide. Then there are the users who are very experienced with Base SAS
software, but who are unfamiliar with SAS Enterprise Guide. The third type is the experienced SAS Enterprise Guide
user. Despite this difference in experience level, all three groups look at SAS Enterprise Guide and ask "What can
this product do for me?"
The answer depends on how much experience you have with SAS. Experienced Base SAS software programmers
expect SAS Enterprise Guide to be similar in appearance and behavior to the SAS windowing environment. However,
they discover that, as a GUI-based application, SAS Enterprise Guide does not work the same way as the windowing
environment. Novice users have a number of basic questions. For example, they might not be aware of all the tools
that are available in SAS Enterprise Guide to help them manipulate their data. Experienced SAS Enterprise Guide
users are very comfortable in the GUI environment but want to enhance their experience with the application.
All three groups look to SAS Technical Support to help them become more proficient in using SAS Enterprise Guide.
For novice users, SAS Technical Support consultants are a resource for showing users how to use SAS Enterprise
Guide to get the results they want. For experienced Base SAS programmers, SAS Technical Support consultants are
experts that can explain the benefits and features of SAS Enterprise Guide and how it might work best for them. For
the experienced SAS Enterprise Guide user, SAS Technical Support consultants are mentors who share the latest
features and improvements in new releases.
This paper offers time-tested tips to help all levels of users become proficient with SAS Enterprise Guide in the
following areas:


connection and configuration



workflow preferences



logging



data source management



project files



operating-system commands



custom tasks

CONNECTION AND CONFIGURATION
This section provides tips related to questions that you might have about the SAS Enterprise Guide environment,
your server connections, and which SAS products you have licensed and installed for use with SAS Enterprise Guide.
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®

ENSURE A CONNECTION TO THE SAS SERVER
It is important to understand that SAS Enterprise Guide does not function the same way that the SAS windowing
environment does. SAS Enterprise Guide is a client/server application that runs on top of a SAS server. Although it is
not obvious when you first invoke the application, SAS Enterprise Guide must connect to an instance of Base SAS
software in order to function properly. The SAS server can be on your local machine, or you can connect to multiple
remote SAS servers that run on different platforms.
Users who are just starting to use SAS Enterprise Guide often encounter a common problem. You open SAS
Enterprise Guide for the first time, but you find that you cannot connect to a SAS server. Without this connection, you
cannot use the application. To compound the problem, it might not be clear to your SAS administrator exactly what
the problem is.
®

To avoid this problem, you can use the SAS Integration Technologies configuration wizard to test your server
connections. On your machine, invoke this utility by selecting Start ► All Programs ► SAS ► Utilities ►
Integration Technologies Configuration Wizard.
1.

In the wizard, select Test SAS Servers, as shown below:

This wizard is a handy tool for checking server connections.
2.

Click Next. Then you can choose to test connections to the SAS servers by entering the server definitions
®
manually, or the utility can retrieve the server definitions from the default SAS Metadata Server.

3.

Select the type of SAS server that you want to test. For SAS Enterprise Guide, the two most important
servers are the SAS Workspace Server and the SAS Metadata Server.
SAS Enterprise Guide connects to a remote SAS server using an Integrated Object Model (IOM) bridge
protocol. The protocol listens to the workspace server through port 8591 and to the metadata server through
port 8561.
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After you enter the other details necessary for connecting to the SAS server (for example, a user ID and
password), click Test to test the connection to the server that you selected. If the test is successful, the
wizard displays a page saying that a connection is established, and it displays details for your SAS server.

REFERENCE AN EXTERNAL FILE IN YOUR PROGRAM
Many experienced SAS programmers who run their programs in the traditional SAS windowing environment often find
that their programs no longer work when they move to SAS Enterprise Guide. This problem commonly occurs when
SAS Enterprise Guide connects to a remote SAS server and you reference an external file in your program
Consider the following DATA step:

data new;
infile 'C:\sas data\testfile.txt';
input x y $ z $;
run;
This DATA step references a TXT file that resides on your local C drive. If you attempt to execute this DATA step
from SAS Enterprise Guide, the program will not execute properly if the SAS server to which SAS Enterprise Guide
connects cannot access the location that is specified in the INFILE statement. When this happens, an error similar to
the following occurs:

ERROR: Physical file does not exist, C:\sas data\testfile.txt.
NOTE: The SAS System stopped processing this step because of errors.
In this case, you need to move the file to a location that the SAS server can access.
Note: For an easy solution to this problem, see the section "The Copy Files Task," later in this paper.
If the SAS server does have a drive that is mapped to your local machine, you can use a universal naming
convention (UNC) pathname to reference the file, as shown below:

data new;
infile '\\techspt\users\user-ID\dlm files\file1.txt';
input x y $ z $;
run;

DETERMINE YOUR SERVER AND CONFIGURATION INFORMATION
When you call SAS Technical Support with a problem concerning SAS Enterprise Guide, you need to provide your
consultant with configuration information about your environment to help the troubleshooting process. Typically, the
consultant needs to know which software applications you have licensed and installed on your SAS server and on
which operating system your server is installed. However, it might not be obvious where to find the information. The
next two sections explain how to locate your configuration information and, from that, how to determine what
operating system you have as well as what applications you have licensed and installed.
Locating Your Configuration Information
To find your configuration information, follow these steps:
1.

In SAS Enterprise Guide, select Help ► About SAS Enterprise Guide.

2.

In the About SAS Enterprise Guide dialog box, click the Configuration Details link, as shown below:
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Clicking the link opens the Configuration Details dialog box, which contains SAS Enterprise Guide release
information, the SAS server release information, the directory in which SAS Enterprise Guide is installed,
and information about your operating system.

.
3.

Click the List Details link to open the Configuration Link Details dialog box.

4.

Click the Save as XML link to save the information as an XML file that you can send to SAS Technical
Support. Then click OK to exit the dialog box.

Determining Your Operating System as Well as Licensed and Installed Applications
Your SAS Technical Support consultant also needs to know on which operating system your SAS server is installed
as well as which applications you have licensed on the server.
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To determine which your operating system you are running and which applications are licensed on the SAS server:
follow these steps:
1.

In the SAS Enterprise Guide Server List window, right-click your server name and select Properties.

Selecting Properties opens the SASApp Properties dialog box.
2.

In the SASApp Properties dialog box, click the Software tab. Your release of SAS and the operating
system on which your SAS server is installed are both listed on this tab, as shown below.
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Next, click the ‘View SAS Server Products button to see a list of the applications that you have licensed
and installed on the server. Click Close to exit the dialog box.

REDIRECT YOUR TEMPORARY (TMP) DIRECTORIES
SAS Enterprise Guide connects to a SAS server, and therefore, just like Base SAS software, it uses temporary files
during processing. These temporary files are stored in a location that is defined in the SAS server's configuration file.
For example, when you import an external file, SAS Enterprise Guide sends the cleansed delimited file to a
temporary location on the SAS server. Any database tables that need to be processed on the SAS server are also
stored in this temporary location. If the temporary files are very large or if many temporary tables are generated while
users are running projects, you can run out of disk space and experience errors during processing.
To avoid this issue, your SAS administrator can redirect the location of these temporary files to a location that
contains more available space. The path that SAS Enterprise Guide chooses is dependent on the environment
variable !TEMP. You can change the location of the !TEMP environment variable by editing the SAS Enterprise Guide
configuration file. The TMP variables that are set in the SAS Enterprise Guide configuration file only affect SAS
Enterprise Guide. All other applications use the default values for the TMP and TEMP variables that are set by the
operating system. For more information about how to redirect the TMP directories that are used by SAS Enterprise
Guide, see the "Recommended Reading" section later in this paper.

WORKFLOW PREFERENCES
This section covers the most popular options to help you customize your SAS Enterprise Guide workspace and
enable you to use the application in the most efficient way.
®

®

USE OPTIONS TO CUSTOMIZE SAS ENTERPRISE GUIDE

Once you start using SAS Enterprise Guide on a daily basis and become comfortable with the application, you might
have questions about how to work more efficiently. One way to increase your efficiency with the application is to take
advantage of available options that enable you to customize SAS Enterprise Guide. To see a list of available options,
select Tools ► Options in the SAS Enterprise Guide interface. SAS Technical Support highly recommends that you
take the time to familiarize yourself with all of the options that are offered in the application.
The following sections discuss how to set a few of the options that garner the most questions from SAS Enterprise
Guide customers.
Enabling the Option to Automatically Replace Results for Resubmitted Tasks, Queries, or Programs
When you resubmit a task, query, or program in SAS Enterprise Guide, the application prompt you as to whether you
want to replace the original results. Rather than being prompted, users prefer that the application replace the results
by default. To do that, you need to set the Replace without prompting option, as follows:
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1.

In SAS Enterprise Guide, select Tools ► Options ► Results ► Results General.

2.

Under the Managing Results section, select Replace without prompting from the Replace
results list. Then click OK to Results General pane.

Disabling the Option to Automatically Open Generated Data or Results
Generating output data or results that are very large can affect performance in SAS Enterprise Guide. To avoid
performance issues, you can disable the option that automatically opens your data or results when they are
generated. To deselect this option, follow these steps:
1.

Select Tools ► Options ► Results – Results General.

2.

In the Managing Results section, deselect the option Automatically open data or results
when generated, as shown below. Then click OK to close the Results General pane.

Disabling the Option to Automatically Open Data When It Is Added to a Project
In a situation similar to the one described above, performance can be affected when you query or otherwise work
with large input data. To avoid this situation, disable the option Automatically open data when added to
project by following these steps:
1.

Select Tools ► Options ► Data ► Data General to open the Data General pane.

2.

Deselect the option Automatically open data when added to project as show below. Then click
OK to close the Data General pane.
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Disabling the Option to Obtain the Total Record Count for DBMS Tables
When you open a large database management system (DBMS) table in SAS Enterprise Guide, you might notice that
the table takes a while to open. Most likely, this slow performance occurs because SAS Enterprise Guide is
determining the total record count when you open a DBMS table.
1.

To help improve performance, disable the option Always obtain the total record count for DBMS
tables by following these steps: Select Tools ► Options ► Data ► Data General.

2.

Deselect the Always obtain the total record count for DBMS tables option, as shown below.
Then click OK to close the pane.

RUN AUTOEXEC PROCESS FLOWS
You might need to execute certain SAS statements every time you invoke SAS Enterprise Guide in order to set up
your working environment. For example, you might want to define libraries, submit ODS statements, or define custom
macros. However, running all of the programs each time you open a project can be cumbersome and time
consuming.
®

®

Running Autoexec Statements in SAS Enterprise Guide

In SAS Enterprise Guide 4.1, you can add your code to a file named called EGAuto.sas. With this file, your code is
submitted when SAS Enterprise Guide first connects to the SAS server. In SAS Enterprise Guide 4.2 and later, there
is no EGAuto.sas file. Instead, you use the option Submit SAS code when server is connected.
To enable this option, follow these steps:
1.

Select Tools ► Options ► SAS Programs.

2.

In the General section of the pane, select the option Submit SAS code when server is
connected.

3.

Then click the Edit button to open an editor window, where you can add your code statements.
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This particular option functions more like a global option in that no matter what project you are working with, all of the
statements that you add to the Submit SAS code when server is connected option are submitted whenever
SAS Enterprise Guide connects to a server.
In SAS Enterprise Guide 4.3, another method is available if you have code statements that you want to submit only
within a particular project. Projects can contain multiple process flows. Therefore, you can create another flow named
Autoexec and add any code, tasks, or macros that you want to run before to the rest of the project. To create the
flow, select File ► New ► Process Flow. By default, the new process flow is named Process Flow 1, but you can
right-click the new flow in the Project Tree and rename the flow Autoexec.

SAS Enterprise Guide recognizes this special process flow in a project, and by default, you are prompted as to
whether you want to run the flow.
®

®

Running an Autoexec Process Flow Automatically in SAS Enterprise Guide 4.3
If you have an Autoexec process flow in a project, you can set an option that runs the flow automatically. To set this
option, follow these steps:
1.

Select Tools ► Options ► General.

2.

In the General section of the pane, enable select the option Automatically run “Autoexec”
process flow when project opens. Then click OK to close the pane.

LOGGING
This section helps answer the two most common questions that SAS Technical Support consultants receive about
SAS Enterprise Guide logging.

USE A PROJECT LOG
Experienced Base SAS programmers are used to having a log file in Base SAS software that shows results in real
time as their programs run. However, logging is a different in SAS Enterprise Guide. SAS Enterprise Guide has a log
for each task, program, or query. Each time that you run a task, code, or a query, the log file is overwritten (as
opposed to appending the new information to the previous log). However, you can enable a project log that shows a
complete log of all activity for the entire project.
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To enable the project log, follow these steps:
1.

Select File ► Project Properties to open the Properties for Project dialog box.

2.

In the Project Log section, select Project Log to enable logging. You can also choose to clear or
export the project log from this location.

DECLUTTER YOUR SAS LOG
When you work in SAS Enterprise Guide, a lot of extraneous, wrapper code that is generated by the application is
written to the log file in addition to the actual code that you submit. This extra wrapper code includes ODS
statements, %LET statements, and any other code that is automatically generated by SAS. The extra code clutters
the log, making it more difficult to read.
You can choose not to show the extra code in the log by following these steps:
1.

Select Tools ► Options ► Results ► Results General to open the Results General pane.

2.

In the Managing Results section, deselect the option Show generated wrapper code in SAS log.
Then click OK to close the Results General pane.

DATA SOURCE MANAGEMENT
This section illustrates how you can best work with different data sources in a project, whether it’s an external data
file, a SAS data set, or a database table.

CHANGING THE INPUT DATA SOURCE
As you work in SAS Enterprise Guide and create your projects, you might have a process flow consisting of tasks and
queries that gives you the results you want, based on a particular input data source. But suppose that you want to
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use a new data source as input, and you do not want to re-create the entire process flow again. You can do that by
changing the data source for a query or task, as explained in the following sections.
Changing the Input Data Source for a Query
You can change your input data source from the Table and Joins window that is available from the SAS Enterprise
Guide Query Builder, as follows:
1. In the Query Builder, right-click the table header and select Properties.

2.

In the Table Properties dialog box, click the Change button next to the table name.

This selection opens the Open Data dialog box.
3.

In the Open Data dialog box, browse to the location of the new table that you want to use in the join. Then
click Open at the bottom of the dialog box.
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After you change the input data source, the Query Builder attempts, by default, to validate the query syntax, even if
you have not yet submitted the query. As a result of the data source change and validation, you might see an error
similar to the following:

You can prevent this error, as follows:
1.

Select Tools ► Options ► Query to open the Query option pane.

2.

In the pane, deselect the option Automatically validate query whenever changes are made.

Changing the Data Source for the Import Data Task
At times, you might import a Microsoft Excel file into your project and use the resulting data set to create a particular
report. But suppose you want to create the report using a new Excel file with the same structure as your original
Excel file but that contains new data. Rather than creating a new branch in the process flow, you need to change the
data source for the Import Data task, as follows:
1.

Right-click the file icon in your process flow and select Properties.to open the properties dialog box for
your file, as shown in this example:
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2.

In the dialog box, click the Change button (shown in step 1) to open the Open File dialog box.

3.

Select the new Excel file that you want to import. Then click Open to add the new file path to the File
Properties dialog box.

4.

Click OK to close the File Properties dialog box.

USE THE EXPLICIT PASS-THROUGH QUERY OPTION TO QUERY DATABASE TABLES
A common task that users perform with the Query Builder is to query data that is stored in relational databases such
as Oracle, DB2, Teradata, and Netezza. Traditional SAS programmers often use the SQL procedure to query the
®
database in order to use SAS/ACCESS software to move the data back into SAS. You can accomplish this task by
using either of two methods: implicit pass-through processing (using a LIBNAME engine that corresponds to the
relational database) and explicit pass-through processing.
When you use the LIBNAME engine (implicit pass-through processing), you write SAS programs and refer to the
database tables as if they are SAS tables. SAS builds an SQL query and passes it to the database server. When you
use implicit pass-through processing, SAS attempts to generate a query that enables the database server to do most
of the work. However, not all SAS syntax can be converted to DBMS-specific syntax. When you use syntax that is
specific to SAS, the query cannot be passed to the database. Instead, SAS Enterprise Guide copies the database
table to the SAS server for processing, which is inefficient.
To ensure that your query is always sent to the database for processing, you should use the explicit pass-through
method. Using this method, you write the DBMS-specific query in your SAS program, and the query is passed as is to
the DBMS server.
The following SQL procedure illustrates how to use the explicit pass-through method:

proc sql;
connect to odbc(dsn=data-source-name user=user-ID pw=password);
create table sasuser.test as select * from connection to odbc
(select * from....rest of query);
quit;
In releases of SAS Enterprise Guide prior to 4.3, the Query Builder always uses implicit pass-through processing.
However, SAS Enterprise Guide 4.3 offers a new option to generate explicit pass-through code in the Query Builder.
With this new option, the code is processed on the database server rather than on the SAS server.
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To access this new option, follow these steps:
1.

In the Query Builder, click the Options menu and select Options for This Query.

This action displays the Query Options dialog box.
2.

Select Pass-through. This action displays pass-through options in the right pane.

3.

Select the option Generate source for explicit pass-through. You can also enter any other
options necessary for explicit pass-through processing (for example, the database name, user ID, and
password).

Many users are interested in learning more about the new explicit pass-through option in the SAS Enterprise Guide
Query Builder. It is important to understand that the Query Builder is designed to work with many different databases,
so it does not recognize options that are specific to a particular database. When you use the Pass-through option
in the Query Builder, the builder tries to automatically detect the options from the metadata that you need for the
CONNECT TO statement. If your library is configured with information that does not work in PROC SQL, the Query
Builder cannot determine which options are valid.
In the case where the metadata does not provide sufficient or correct information for the CONNECT TO statement,
you need to specify your own connection information in the dialog box. Alternatively, administrators are encouraged
to define a library in metadata with the correct options that will be used specifically with the explicit pass-through
option.
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PROJECT FILES
This section details how to work with your projects in the most efficient manner in the following areas: organization,
layout, backups, and scheduling.

ORGANIZE YOUR PROJECTS
This section illustrates how you can better organize your SAS Enterprise Guide projects to help you work more
efficiently.
Using Multiple Process Flows in a Project
Projects can become messy very quickly. For example, in a complex project, it can become difficult to find a particular
task, query, or program in the flow without doing a lot of scrolling. You can alleviate this problem by using multiple
process flows to break up the large flow. To create new flows from a larger flow, select File ► New ► Process Flow
from the main SAS Enterprise Guide window. You can also rename each flow to something meaningful, and you can
order the process flows in the Project tree so that they run in the order that you want.
If you are already working with a complex project, you can cut and paste icons from the larger flow into the new
process flow.

From the original process flow, press and hold the Ctrl key while you click each task node that you want to copy.
Note: You cannot copy results icons.
Using Ordered Lists
In a project that contains multiple process flows, where each process flow contains many branches, you might want
certain tasks and programs to run in a particular order. However, these items might not be linked, and you do not
want to have to change their positions in the flow or their relationships to one another. The solution is to create an
ordered list, as follows:
1.

Select File ► New ► Ordered List to open the Ordered List dialog box.

2.

Click the Add button to open the Select dialog box. You can select tasks that are contained in the project to
include in your ordered list, as shown below.
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3.

Click the Open button to display the Ordered List dialog box.

4.

Click Save to save the ordered list, or click Run if you want to execute the list.

Making Your Process Flow More Descriptive
If you share projects with multiple users, you might find that the default names given to each item are not clear ad
that you have to open an item to determine its purpose. To solve this problem, ensure that the names of your process
flows, programs, and queries are sufficiently descriptive and use descriptive notes for the items. These steps make
your projects more beneficial for you and others who use your projects.
To create descriptive notes, follow these steps:
1.

Select File ► New ► Note, or right-click the process flow and select New – Note to open the Process Flow
editor.

2.

Enter your descriptive comments. The note is saved as part of the project, as shown below.

CUSTOMIZE YOUR WORKSPACE LAYOUT
In SAS Enterprise Guide, the workspace is the main area in which you can view your data, tasks, queries, and
results. By default, the workspace layout displays only one item from the project at a time. However, you can
customize the layout to suit your personal preferences. For example, you might prefer to see the contents of a data
set at the same time that you are viewing the entire process flow. Or perhaps you want to see the program code
paired with the results of that same program.
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To customize your workspace, select View ► Workspace Layout. By default, the workspace layout is defined with
the Single selection. You can then choose either Stacked or Side By Side.

Either selection results in two workspaces. You can open specific content from the process flow to separate windows.
When you open an item from the project, you can specify the particular workspace area in which to open it by clicking
the active workspace icon in the top right corner of that area, as shown below.

BACK UP YOUR PROJECTS
Unfortunately, project corruption sometimes happens quite unexpectedly. Many factors can contribute to project
corruption. For example, corruption can occur as a result of creating very large projects. A project might also be
corrupted if a server disconnects while the project is open. In such cases, it is difficult for SAS Technical Support to
replicate the cause of the corruption in order to solve the problem.
To guard against project corruption, the most important step you can take is to back up your projects
frequently. It also helps if you can create smaller projects. There are also ways to recover items in a project or even
to repair the project.
Because project files (which have an extension of .egp) are a form of ZIP file, you can use third-party software to
repair the file. You change the project extension from .egp to .zip. Then repair the file, change the extension back to
.egp, and try to open the file again in SAS Enterprise Guide.
If you are unable to repair the project file, change the file extension .egp to .zip and open the ZIP file with Microsoft
WinZip. From there, you can see individual pieces of your project; for example, code nodes, logs, results files, and
GIF files. You can recover the program files by extracting them with the WinZip tool.
Warning: While you can attempt to repair your project on your own, as described above, SAS Technical Support
does not recommend that you do so. If you do attempt your own repair, be aware that SAS is not responsible for any
problems that might occur as a result.
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SCHEDULE YOUR PROJECTS
SAS Enterprise Guide uses the Microsoft Windows Task Scheduler to schedule a project so that it runs in batch
mode. The following sections explain caveats to help ensure that your job is scheduled correctly, and it explains how
to schedule your projects.
Verifying Microsoft Windows and Metadata Credentials
Before you schedule your job, take care of the following items. Doing so will help ensure that your job is scheduled
successfully.


The Windows user ID that you use to schedule the project must have administrative rights; in particular, it
must have Log on as a batch job user permission. A Windows user needs to be able to access the
Windows Task Scheduler and to execute Visual Basic script files outside of SAS Enterprise Guide.



Metadata credentials must be cached in the user's connection profile. To verify that this is true in SAS
Enterprise Guide, follow these steps:





1.

Select Tools ► Options to open the Options pane.

2.

Under the Administration section, click the Modify button to open the Connection dialog
box.

3.

In the dialog box, select the active server, and click Modify. This action opens the Modify Profile
dialog box. Make sure that the Save login in profile selection is checked.

4.

Click Save, and then click Close to exit the dialog box.

User credentials must persist throughout the SAS Enterprise Guide session. To verify that your system is set
for credentials to persist:
1.

Select Tools ► Options to open the Options pane.

2.

Under the Security section, verify that Credentials Persistence is set to Persist
during EG session.

Because SAS is not usually installed on the same machine as SAS Enterprise Guide, you might need a
credentials.xml file. For more information about the credentials.xml file, see "Recommended Reading," later
in this paper.

Scheduling Your Project
To schedule a project, follow these steps:
1.

Select File ► Schedule to open the Schedule – Project dialog box.

2.

On the Task tab, click the Set Password button. Then enter and confirm your password in the Set
Password dialog box.

3.

Next, click the Schedule tab and enter the appropriate information. The Windows Task Scheduler uses
this information to determine when to execute the project and to create the VBS file that is necessary for
running a project.

4.

Save and close the project. The project must be closed for it to run successfully.

Note: It is recommended that you schedule a test project, keeping the caveats in the previous section in mind.

OPERATING-SYSTEM COMMANDS
Experienced SAS users are very familiar with the ability to submit statements such as X, SYSTASK, and FILENAME
PIPE in Base SAS software. These statements enable you to run system commands on the SAS server. However,
users quickly find out that these commands do not work when they are submitted in SAS Enterprise Guide.
Client applications can use system commands to perform potentially harmful operations such as file deletion.
Therefore, by default, when the SAS server is invoked, SAS Enterprise Guide submits the option -NOXCMD in order
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to prevent security risks that can occur when system commands are executed from a client application. As a result,
errors similar to the following occur when you submit statements such as X or SYSTASK in SAS Enterprise Guide:

ERROR: Insufficient authorization to access PIPE.
OR:
ERROR: Shell escape is not valid in this SAS session.
Starting with SAS 9.3, when SAS Enterprise Guide connects to a local SAS server, the –NOXCMD option is no
longer used. Therefore, the ability to submit system commands is allowed. If you run earlier releases of SAS or you
®
connect to a remote SAS server (for example, the SAS Metadata Server), there are steps that you can take to
enable the use of system commands as well. For more information about using system commands when you connect
to the metadata server, see "Recommended Reading," below.

CUSTOM TASKS AND TOOLS
In addition to the tips provided in the previous sections, this section briefly discusses some custom tasks that you can
take advantage of. Along with the wide variety of tasks from which to choose in SAS Enterprise Guide, you also have
the ability to create your own custom tasks. This capability enables you to fully customize SAS Enterprise Guide for
your needs. A number of custom tasks have been written by SAS Research and Development, and they are available
for you to download and install. A few of the most popular of these custom tasks are briefly described in the next
sections. For more information about other custom tasks that are available, see "Recommended Reading," below.

THE EXPORT TO EXCEL 2007/2010 TASK
Until SAS Enterprise Guide 5.1, you could not export your data sets to an Excel 2007 (XLSX) file. The only option
was to export your data to an Excel 2003 (XLS) file. This option presents limitations because Excel 2003 (XLS) files
have a maximum of approximately 65,000 rows. Most users have data sets that are much larger; and Microsoft Office
2007 increased the maximum to 1 million rows for an xlsx file. The custom task Export to Excel 2007/2010
takes care of this issue for files that you export to releases of Excel prior to the 2007. For more information about this
task (including download information), see "Recommended Reading," later in this paper.

THE COPY FILES TASK
As a client/server application, SAS Enterprise Guide moves external files between the SAS server and a local PC.
User-written code often fails when programs that reference external files are submitted. Failure occurs because the
SAS server cannot locate the external files.
In the past, you had to use another method (FTP) to move external files to a location that the SAS server can access.
Now, with the Copy Files task, you can move your external files between the SAS server and SAS Enterprise
Guide within a project. For more information about this task (including download information), see "Recommended
Reading," later in this paper.

THE EGPSEARCH TOOL
In large projects with multiple process flows, it can be very time-consuming to search for a particular reference or to
open every log and use the Find menu item to search for a particular phrase. As a result, customers often call
Technical Support to find out whether there is a way to determine what files or data sets are used in a project and
how they can search a log or program for a particular word. Now, however, there is a custom tool that makes these
tasks easy: the EGPSearch tool. The EGPSearch tool is available for releases 4.3 and 5.1 of SAS Enterprise
Guide. For more information about this tool (including download information), see "Recommended Reading," below.

CONCLUSION
Over the years, SAS Technical Support consultants have handled many calls from users who want to know the best
way to use SAS Enterprise Guide for everything from using the application to manipulate data to obtaining particular
results. This paper discussed some of the most common tips and techniques from SAS Technical Support to help you
become more proficient with SAS Enterprise Guide. These tips and techniques have proven to be the most applicable
across a broad spectrum of users.

19

SAS Global Forum 2013

SAS® Enterprise Guide® – Implementation and Usage

RECOMMENDED READING
®

Hemedinger, Chris. 2013. "Custom tasks for SAS Enterprise Guide." Blog post from "The SAS Dummy: A SAS blog
for the rest of us." Cary, NC: SAS Institute Inc. Available at
blogs.sas.com/content/sasdummy/?s=custom+task.
Hemedinger, Chris. 2012. Custom Tasks for SAS Enterprise Guide Using Microsoft .NET. Cary, NC: SAS Institute
Inc.
Hemedinger, Chris. 2012. "How to search your SAS Enterprise Guide project files." Blog post from "The SAS
®
Dummy: A SAS blog for the rest of us." Cary, NC: SAS Institute Inc. Available at
blogs.sas.com/content/sasdummy/2012/06/07/egp-search-tool/. (EGPSEARCH tool)
Hemedinger, Chris. 2012. "There and back again: copying files in SAS Enterprise Guide." Blog post from "The SAS
®
Dummy: A SAS blog for the rest of us." Cary, NC: SAS Institute Inc. Available at
blogs.sas.com/content/sasdummy/2012/12/06/copy-files-in-sas-eg/. (COPY FILES custom
task)
®

®

McDaniel, Stephen, and Chris Hemedinger. 2010. SAS For Dummies , 2nd Edition. Hoboken, NJ: John Wiley &
Sons Inc.
®

®

SAS Institute Inc. 2010. SAS Note 38876. "Differences between importing data in SAS Enterprise Guide 4.1 versus
SAS Enterprise Guide 4.2." Cary, NC: SAS Institute Inc. Available at support.sas.com/kb/38/876.html .
(Instructions for redirecting TMP directories)
®

®

SAS Institute Inc. 2010. SAS Note 41058. "Unable to submit X commands from SAS Enterprise Guide connecting
®
®
to a SAS Metadata Server when running SAS 9.2 or later." Cary, NC: SAS Institute Inc. Available at
support.sas.com/kb/41/058.html.
®

®

SAS Institute Inc. 2010. SAS Note 41132. "Unable to export data to an .xlsx file from SAS Enterprise Guide ." Cary,
NC: SAS Institute Inc. Available at support.sas.com/kb/41/132.html. (EXPORT TO EXCEL 2007/2010
custom task)
®

®

SAS Institute Inc. 2008. SAS Note 30917. "Scheduling projects in SAS Enterprise Guide ." Cary, NC: SAS Institute
Inc. Available at support.sas.com/kb/30/917.html. (credentials.xml file)

CONTACT INFORMATION
Your comments and questions are valued and encouraged. Contact the author at:
Jennifer Bjurstrom
SAS Technical Support
SAS Campus Drive
Cary, NC 27513:
E-mail: support@sas.com
Web: support.sas.com
SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS
Institute Inc. in the USA and other countries. ® indicates USA registration.
Other brand and product names are trademarks of their respective companies.

20

