Creating a Report in the SAS® Information Delivery Portal using SAS® Information Maps

Jenine Milum, Wells Fargo Bank, Charlotte, NC

ABSTRACT

The purpose of this task is to guide a SAS BI developer through the steps necessary to combine SAS datasets using Information Maps and create a report which becomes available in the Information Delivery Portal. The result is a professional report viewable by the Business User within their browser. The ability to use the tools listed below to create a report available in the Information Delivery Portal frees Business Users from concerning themselves with data construction, security, information updates, and collection requirements. The Business User can focus on Analysis and other tasks without needing to be a SAS Developer. SAS Versions 9.2/4.2.

- Management Console
- Information Map Studio
- Web Report Studio
- Information Delivery Portal

INTRODUCTION

This task begins using SAS datasets (class, classfit) located in the SASHELP library provided with all installations. These datasets in SASHELP were copied to a working directory that will represent our external data source. We are assuming that no library or previous tasks have been accomplished prior to this task.

Within your operating system, create a directory in which your data will reside. (A UNIX environment is used here.) The directory should be located on a tier predetermined to house SAS datasets such as an ETL, Compute, or SPDS tier. Permissions for this new directory should minimally be set open to Read at least by the developer.

This library will have to adhere to the SAS libname naming conventions regardless of the operating system being used. The libname requires it begin with a character or underscore and contains only letters, numbers and underscores with a maximum length of 8 characters.

1.1

Create a library definition in SAS MANAGEMENT CONSOLE This task is often performed by the system administrator. If Management Console is not installed along with your other SAS Business Intelligence software or you do not have access to it, contact your SAS administrator. If the files you will be using have already registered and available for use, continue with Information Map Studio, section 1.2.
Start *Management Console* based on an existing metadata profile and your user information profile as described in the introduction.

**NOTE** The role and/or permissions as a platform administrator are necessary for this task.

Once connected, select the tab *Plug-ins* to create a new library. This is done by expanding the *Data Library Manager* and right clicking on the *Libraries* folder and selecting *New Library.*
Navigate to the *SAS Base Library* by expanding the Libraries folder and then the *SAS Data* folder.

**NOTE** The exact folder and library names may vary slightly but should exist in all environments. If this library structure does not exist, ask the SAS Administrator or other person who installed the software for the proper location to assign libraries.
Using the *New Library Wizard* that will pop-up, provide a business name for the library and a description if desired.

**TIP** Use a name that is descriptive and unique. There is no need to use abbreviations. You want to clearly identify what this folder is used for and what it contains. Use the description box if more clarity is needed.

Continuing with the wizard, assign a libref name. It must be a valid SAS libname which adheres to the same rules. If the proper location of the library is not correct, select *Browse* and choose the proper directory location.

**NOTE** It will be easiest for continuity to assign it the exact name that was used in defining the folder within your operating system folder structure.
Once a library is defined, specific tables within the directory need to be selected and registered to be identifiable. For this project, we will be using and registering the tables CLASS and CLASSFIT. Either click on each of the files or Select All Tables to highlight the required tables. The location directory path should be the same as was selected in the previous step. If not, use Browse to navigate to the proper location.

Choosing Next provides the last screen of this process and acknowledges the directory and tables were assigned properly. Once Finish is selected the information is stored as metadata and the tables are registered.
You will now see the new library listed in the right-hand pane. You can check the libname and directory are correct by right clicking on the newly created library icon, selecting the *Display LIBNAME Statement* to show the libname statement associated with the directory. This is often helpful to identify a library structure for additional uses.

Useful information and additional tasks are available by right-clicking on the library icon and selecting *Properties*. 
A critical task within this selection screen is to assign permissions. This is done by selecting the *Authorization* tab. Based on the role assignments at your location, the proper authorizations may be applied at this point. Below are the defaults for the role as a Developer.

![Authorization Tab](image)

**NOTE** Users and Groups, Effective Permissions and roles are reviewed in the SAS BI Overview, Section III.
Create an Information Map using SAS INFORMATION MAP STUDIO (IMS). An Information Map provides the ability to select and combine tables using key variables, apply filters and formats, create new variables, set permissions and perform other tasks. The end result is stored in metadata which will contain the tasks and information performed within IMS. A new data set itself is not physically created; rather the results are generated on-demand when the map is used, along the same lines as the way a data set view is used.

The different tiers and libraries stored on each server are shown in the top left pane under the server icon tab. You should see the library created in Section 1.1 by Management Console.

NOTE If the library does not appear in the expected server list of libraries, return to Management Console and determine the exact location created. If the step was not completed properly it will need to be redone. Another possible cause is the permissions profile described in the introduction for the library were not properly assigned and the IMS user does not have proper access to create an Information Map. Contact your SAS Administrator if creating maps is not applicable to your role.
By clicking on the expand icon ‏ next to the library, the contents of the library are displayed.

**NOTE** If all the tables required are not viewable with the expansion of the library, return to Management Console to verify the location of the files and the appropriate permissions are set. This may require the involvement of your SAS Administrator.

For this example, we will map the two tables already registered in Management Console, CLASS and CLASSFIT.

<table>
<thead>
<tr>
<th>Name</th>
<th>Sex</th>
<th>Age</th>
<th>Height</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joyce</td>
<td>F</td>
<td>11</td>
<td>51.3</td>
<td>50.9</td>
</tr>
<tr>
<td>Lewis</td>
<td>F</td>
<td>12</td>
<td>56.3</td>
<td>77</td>
</tr>
<tr>
<td>Alice</td>
<td>F</td>
<td>13</td>
<td>56.5</td>
<td>84</td>
</tr>
<tr>
<td>Jacob</td>
<td>M</td>
<td>12</td>
<td>57.3</td>
<td>83</td>
</tr>
<tr>
<td>Thomas</td>
<td>M</td>
<td>11</td>
<td>57.5</td>
<td>85</td>
</tr>
<tr>
<td>John</td>
<td>M</td>
<td>12</td>
<td>59</td>
<td>98</td>
</tr>
<tr>
<td>Jane</td>
<td>F</td>
<td>15</td>
<td>62.5</td>
<td>112</td>
</tr>
<tr>
<td>Thomas</td>
<td>M</td>
<td>13</td>
<td>62.5</td>
<td>104</td>
</tr>
<tr>
<td>Carol</td>
<td>F</td>
<td>14</td>
<td>62.8</td>
<td>105</td>
</tr>
<tr>
<td>Henry</td>
<td>M</td>
<td>14</td>
<td>63.5</td>
<td>106</td>
</tr>
<tr>
<td>Judy</td>
<td>F</td>
<td>14</td>
<td>64.3</td>
<td>107</td>
</tr>
<tr>
<td>Robert</td>
<td>M</td>
<td>12</td>
<td>64.8</td>
<td>106</td>
</tr>
<tr>
<td>Barbara</td>
<td>F</td>
<td>13</td>
<td>65.3</td>
<td>108</td>
</tr>
<tr>
<td>Mary</td>
<td>F</td>
<td>15</td>
<td>66.5</td>
<td>112</td>
</tr>
<tr>
<td>William</td>
<td>M</td>
<td>15</td>
<td>65.5</td>
<td>112</td>
</tr>
<tr>
<td>Ronald</td>
<td>M</td>
<td>15</td>
<td>67</td>
<td>133</td>
</tr>
<tr>
<td>Ahmed</td>
<td>M</td>
<td>14</td>
<td>68</td>
<td>112</td>
</tr>
<tr>
<td>Philip</td>
<td>M</td>
<td>16</td>
<td>72</td>
<td>150</td>
</tr>
</tbody>
</table>

To start mapping the two tables, drag each table into the Design tab under Selected Resources and expand them to view their individual data items.
Select the variables from the two tables that are needed in the mapping by highlighting each and clicking on the move arrow to drop them into the Information Map Contents pane.

Switch to the Relationships tab. There we see each of the tables with the variables selected in the previous step.
For our purpose, the variable Name is the key linking the two tables. Click on Name in the box CLASS and click on the same variable Name in CLASSFIT. A join connector is automatically produced to match our desired initial matching criteria.

Key variables are not required to have the same name but do need to be defined identically as either both character or numeric data types. If they are not compatible you will receive the message below. This was assigned in Management Console when the tables were registered. If these attributes are not the same at this point, return to Management Console to assign the same formatting to each variable and re-register the tables. This may require the involvement of the SAS system administrator. Return to IMS and begin mapping the tables by refreshing the tables in the Resource – Application Servers, Server pane and remap the tables.
Double click on the join connector in the Relationships tab and the Relationship Properties window appears. This may also be opened by clicking on the icon.

We see a one to many Cardinality is initially assigned. Options to alter the Cardinality and apply an Outer join or Inner Join are available.

(Advanced criteria for the join are available by selecting the Advanced Edit button.)

Select OK to save the matching criteria or Cancel if you are not making any changes.

**Note** These tables may be combined using a different set of logic, additional tables, and alternate parameters for other purposes by simply saving it as an additional Information Map.
Test the mapping’s validity by clicking on the **Run A Test Query** icon located on the tool bar. This test uses the information we stored earlier stored in Metadata. Select all the variables from the map by clicking on the **Insert All** icon. Click **Run Test**.
The test will return a *Results* window and an opportunity to view the SQL code that generated the results.

**NOTE** Common errors are mismatching variable length and formatting. Verify you are trying to match the intended variables and that the attributes are correct. To correct attributes, use Management Console to set variables to the same value type and/or length.

Once the mapping is complete and validated save the map for future use. Select the 📦 icon from the menu bar and the following pop-up will appear. Choose an appropriate descriptive name.

**NOTE** Although it is not necessary, it is best to save *Information Maps* in the Information Maps folder. Subdirectories may be created for specific projects.
1.3

Creating a Report in Web Report Studio. Web Report Studio (WRS) is a web based application that does not require SAS to be installed on the desktop/laptop. The URL for launching this tool will be provided by the SAS Administrator. The location can be stored in the My Favorites location of your web browser so it can be easily accessed. Launching Web Report Studio opens the Log On and Getting Started screens seen below. We’re going to select New Report.

NOTE The Open widget will reveal reports and Information Maps previously saved or viewed. If selecting one of these generates an error it may be due to the map or report having been removed or the permissions were altered. Contact your SAS Administrator if you receive this error.
A new report begins with the following screen. WRS provides a section on the left to control data, a vertical tool bar in the middle to design and modify the report layout, and a horizontal tool bar to select reporting options.

For this task we will begin by opening the Information Map created in the previous section. Select File > Open from the top tool bar then navigating to the location of the Information map.
Opening the Information Map produces the following window in the View tab.

The data source needs to be chosen and associated with the Information Map. Click on Data > Select Data from the tool bar and navigate to the folder location of the table.

**NOTE** If the data source is not found it most likely because the table has not been registered or you do not have proper permissions to read the data. Return to Management Console to verify the name, location, and the permissions. Contact the SAS Administrator if necessary.
Having identified the data source, we now select the items we wish to have represented in the report. Expand each table by clicking on the next to it, enabling us to view all variables available. Highlight each variable that needs to be included in the report and then click on the icon to move the variables to the other pane. Select OK when all the variables have been copied to the Select Data Items pane.

**NOTE** In version 9.2 you can also select variables by dragging and dropping them from the left-hand pane to the right-hand pane.

Select and SAS will process the data and the mapping.
The finished report will appear under the View tab. As you can see in the screenshot below, the report and data are as we requested, although it is not in a format or layout we prefer to publish.

Return to the Edit tab to redesign our output. Right click on Table 1 to bring up the design drop down menu. There are multiple design choices available. Select Assign Data. Use the Move Items drop down to manipulate the order and grouping of the variables in the report. When you have the report variables aligned as desired, select OK.

NOTE In Version 9.2 items can be moved by dragging and dropping.
Select the View tab to see the resulting report.

To enhance the report by adding column totals, return to the Edit tab. Again, right click on the report to open the design drop down menu and this time select Total. The Total window appears and has several options. Choose Column Totals and click on . This returns us to the View tab which now shows the report which includes Column totals.
Let's add a graph to this report for a more visual representation of the data. To do this simply drag and drop one of the graphical reporting widgets on the Edit tab tool bar to an available grid square.

**NOTE** Although it is not necessary, you can eliminate unwanted cells blocks by highlighting them and clicking on the delete icon located on the vertical toolbar.

Return to the graph generic picture and right click on it. This opens the design drop down list. Select Assign Data to open the window that allows you to control the graph’s components.

As described earlier, Use the Move Items drop down list to adjust the variables to their desired components of the graph.
Select OK to return to the Edit tab and select View tab to see the resulting report and graph. These are the reports that will be viewed from the Information Delivery Portal.

To complete our work in Web Report Studio and save our reports select Files > Save As from the menu tool bar.

NOTE It is a best practice to give the report a descriptive name and state that it’s a Report such as “Chapter 2.1 Report”. This provides easier identification.
1.4

**Surfacing a Web Report Studio Report in the SAS Information Delivery Portal (IDP).** The *Information Delivery Portal*, also known as the *IDP*, is the tool that allows users access to a wide variety of information. While it has many purposes and capabilities, for our purposes, we will surface and view the report created in section 1.3.

As with *Web Report Studio*, *IDP* is a web based application. The URL to access the *Information Delivery Portal* should be provided by your SAS Administrator. Logon on to the *IDP* and to deliver a page similar to the one below.

Start with a fresh page by selecting *Options* from the top right tool bar and select *Add Page*. 
The next screen will provide you an opportunity give a name to your new page (also viewed as a tab). Provide a description and select the groups desired to view the page. Groups are created and determined by the SAS administrator. Select Add to receive Page Successfully Added. Click on Done to view our newly created Page.

![Add Pages to Profile](image)

Returning to the Portal main page, again select Options from the top right navigation bar. This time select Edit Page Content.

![Edit Page Content](image)

This will lead to a new page allowing control of the content of the new page. With IDP, all information is surfaced in individual Portlets contained within Portal Pages. We are going to create a Portlet within the newly created Portal Page to house a link to the report generated from Web Report Studio.

![Edit Page Content - Chapter 2.1](image)

Navigate to the Edit Page Content page. Select Add Portlets… You can manipulate the number of portlets and the layout of these portlets within this page.
There are 2 ways to add the WRS Report to a Portlet. Select **OK** to describe the portlet returning to the Portal Page. Next, edit Content or Search for the report while creating the portlet. For this task we will create the portlet and edit its contents.

Provide a descriptive name to the new portlet and click on the Add **Add** button to receive the message **Portlet successfully added**. Select **OK** to return to the Edit Page Contents screen.

You can see that our portlet has been included in the page content. Select **OK** to return to the Portal page.
Select on the *Edit Content* icon from the portlet menu.

The following screen will appear allowing control of the *Edit Portlet Content*. Select *Add Items*…

The *Create* tab of the *Add Items to Portlet* screen appears. For this task, select the *Search* tab.

Using the * as a wild card, check *SAS report* to search reports available for the IDP.
The following Add menu appears. A complete list of reports is listed allowing the user to select reports based on their names and descriptions. Check the Chap2_1 Report and click on Add button.

NOTE The type of item listed in the Add menu is identified by its Icon and the file name extension. In this case Chap2_1 Report is identified as a report by the .srx file extension and the icon.
The [Add] button is returned to the screen. Select [Done] from the bottom left corner of the screen.

This returns us to the Edit Portlet Content screen for Chap 2.1. The Report select will be visible in the Items menu.

Select [OK] to return to the main Portlet window.

Within the main portlet page, the individual portlet will appear as below. The report is now available any time the Portlet is accessed.

To view the report, click on the report name Chap2_1 Report.srx. This will open to Web Report Studio and the report created in section 1.4.
The report is now available as created. Accessing the WRS report from IDP allows the user to not only access the report as designed; it allows the user to interact with the report to make alterations and new reports without changing the originally saved report.

There is a link located in the top left-hand of the screen returning the user to the IDP.

ACKNOWLEDGMENTS

Thanks to SAS Publishing for encouraging me to write and submit this sample chapter for publishing consideration. Special thanks to John Bentley for his considerable editing skills and valuable input.

CONTACT INFORMATION

Your comments and questions are valued and encouraged. Contact the author at:

Name: Jenine Milum
E-mail: jeninemi@yahoo.com

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.