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ABSTRACT

Learning the basics of PROC REPORT can help the new
SAS® user avoid hours of headaches. PROC REPORT
can often be used in lieu of PROC TABULATE or DATA
_NULL_ reporting--two areas that have driven the new
SAS user crazy!!! With the added capabilities of ODS
provided in Version 7 and higher, PROC REPORT can
look as sharp as an EXCEL report. This paper will show
how to use PROC REPORT in both a windowing and non-
windowing environment using SAS Version 8.

Aside: If you are still using SAS Version 6, see my 1999
paper listed in REFERENCES. There have been a
number of changes in the keystroke sequences used in
the WINDOWING ENVIRONMENT section.

WINDOWING ENVIRONMENT

The PROC REPORT windowing environment is a great
code generator. | often have the initial code generated in
the windowing environment, and then “tweak” the code in
the non-windowing environment. You can even use the
windowing environment with a mainframe, although it is a
little easier in a GUI environment (e.g., UNIX).

To use PROC REPORT in the windowing environment,
you have several from the Menu Bar.

Solutions > Report Writing > Design Report
or
Tools = Report Editor

If you prefer to code, submit the following from the SAS
editor.

options nocenter;
proc report data=sashelp.class;
run;

Note: This paper will be using the CLASS data set
provided as an example data set when you license
SAS/ASSIST. See Appendix | for details on how to get
access to this data set.

The following screen will appear.
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This screen is the default report, which looks very similar
to “vanilla” PROC PRINT. The value of PROC REPORT
is in its grouping capabilities, which include summarizing.
The report will now be reorganized interactively to group
by Sex.

PROC REPORT works from left to right. Thus, if you want
a grouping by Sex, then you need to move Sex before
Name. To reorder the report, highlight the Sex label.
Choose the following sequence either from the Menu or by
clicking the right mouse button.

Edit > Move selected item >
to the left of the next selected item

The screen from SAS V8.2 for Windows will look like the
following.
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Nothing seems to happen. The next step is to highlight
the Name label. The Sex column should move to the left
of Name. The report should look the same, except for the
column change.

Now you decide that all of the F’s for females and M’s for
males are cluttering the report. You only want one F and
one M to designate the group. To do this, follow the next
sequence of push buttons.

Edit > Define selected item = Group = OK
Now you would like a line break between each grouping.

Edit > Summarize information > After item >
Skip line after break > OK

Now you will proceed onto a slightly more difficult change.
You would like to have the data sorted by age. Because
PROC REPORT works from left to right, you cannot sort
the Age column with Name to the left of it. To further
complicate things, you really like where Age is located.
You need to have Age have two columns on our report,
but you do not want to see the column to the left of Name.
To do this, you need to follow the next sequence after
highlighting Name:



Edit > Add item - Data column >
Left > Age - F3 key to End

The report now has two Age columns, and you do not want
that look. You will now need to sort the data and remove
the new column from the report layout. To do this,
highlight the new Age column and do the following.

Edit = Define = Order = No print 2 OK

Now you would like to get some summary statistics for the
GENDER grouping and for an overall total.

To get the summary statistics for Sex do the following:

Edit > Summarize information >
After item 2 Overline summary 2>
Summarize analysis columns > OK

The default summary statistic is the SUM calculation. The
MEAN is the preferred summary statistic. To make this
change, you will need to modify the Age, Height and
Weight columns. After highlighting Height, follow the
sequence below.

Edit > Define >
change SUM to MEAN under Statistics > OK

The screen looks like below.
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Do the same sequence for Age and Weight.

For an overall total, follow this sequence. Again this is a
SUM calculation, which will be changed later to MEAN.

Edit > Summarize information > At the bottom >
Summarize analysis columns 2> OK

To do a clean up the format by lining up the decimal
places to the right for Age, Height and Weight, follow this
sequence.

Edit > Define selected item > enter 8.2 in format 2 OK

If you forget the format you want to use enter a ? on the
format field and modify the format screen.

Keep in mind that you could have gotten a similar looking
report with PROC PRINT, but you also would have had to
sort your data first. You have achieved an ordered report
without sorting the data first—PROC TABULATE could
have done something similar too.
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Speaking of PROC TABULATE, you can have the boxed
look with PROC REPORT too. For the final interactive
option, turn on box.

Tools > Options 2> Report...

A ROPTION dialogue box will appear. From this dialogue
box, check Box and then OK.

Your report hopefully looks like the following.

-REPORT =] k3
The SAS System -
Sex  Name Age Height Weight
F Jovee .99 §1.30 50.50
Jane 12.00 59.80 84.50
Louise 12.00 56.30 TT.00
Allce 13.00 §6.50 a4.00
Barpara 13.00 B6.30 ag.00
caral 14.00 B2.80 102.50
Judy 14.00 B4.30 a0.00 [
Janat 15.00 B2.50 11z.50
Hary 15.00 BB .50 1ez.o0
F 13.22 60.53 a0.11
L] Thomas .99 §7.50 as5.00
Jamcs 12.00 57.30 83.00
John 12.00 59.00 93.50
Robert 12.00 B4 .80 128.00
Jaffray 13.00 BE.SO a4.00 o
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Now you would like to save the report statements that
were generated from of the interactive work. Following is
the sequence that will return the code.

Tools > REPORT Statements > File > Save as 2>
Write to file 2> enter file name

What if you have not finished the interactive report, but
you need to stop what you are doing? You can save your
report profile by entering the following sequence. Before
you enter this sequence, make sure that have created a
catalog in a library.

File > Save Report
A dialogue box will ask you for the Libname, Catalog,
Report Name, and Description.  After entering the
information, push the OK button to save.
To close the Report window, File = Close
To reopen the saved interactive report, start interactive
PROC REPORT with the data used to create the saved
report.  (See initial code provided under WINDOWING
ENVIRONMENT at the beginning of this paper.) Enter the
following to Open the previously saved interactive report.

File & Open Report

Locate the Libname, Catalog, and Report Name.
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"Age in years" ;

RBREAK AFTER / SUMMARIZE ;
RUN;

© PROC REPORT @®DATA=SASHELP.CLASS ©LS=80 PS=44 @OSPLIT="/" NOCENTER ©BOX ;
OCOLUMN SEX AGE NAME AGE=_A1 HEIGHT WEIGHT;

DEFINE SEX / ORDER FORMAT= $1. WIDTH=6  SPACING=2 LEFT "Gender" ;
@DEFINE AGE / ORDER FORMAT= BEST9. WIDTH=9  SPACING=2 NOPRINT RIGHT

DEFINE NAME / ORDER FORMAT= $8. WIDTH=8 SPACING=2 LEFT "First name" ;
DEFINE A1 / SUM FORMAT= BEST9. WIDTH=9 SPACING=2 RIGHT "Age in years" ;
DEFINE HEIGHT / SUM FORMAT= 8.2 WIDTH=9 SPACING=2 RIGHT

"Height in inches"
DEFINE WEIGHT / SUM FORMAT= 8.2 WIDTH=9 SPACING=2 RIGHT

"Weight in pounds"

OBREAK AFTER SEX / OL SKIP SUMMARIZE ;

Figure 1 SAS code created from windowing environment.

NON-WINDOWING ENVIRONMENT

The SAS code that was generated from the interactive
work in the windowing environment section is shown in
Figure 1. Each line of code will be explained in detail and
“tweaked” a little bit to now run in a non-windowing
environment (a.k.a., batch). The SAS code generated in
the Windowing Environment was left justified. | added the
indenting for readability.

© The first line of code generated is PROC REPORT. To
work in a non-windowing environment, the PROC
REPORT statement will need to be rewritten with the
NOWINDOWS option.

PROC REPORT DATA=SASHELP.CLASS LS=80
PS=44 SPLIT="/" NOCENTER BOX NOWINDOWS;

® Like other PROCs, you can designate the data to be
used with DATA= or default to the most recently created
data set. In this example, a permanent SAS data set was
used.

The remaining options are for formatting the overall report.

© The split="/" works the same way as PROC PRINT for
labels on specific variables. The label will be split to a new
line at the /. If you want to use / as part of your label, then
you’ll need to pick a different character for split=.

O The LS and PS are exactly the same as those used in
the global OPTION statement for linesize and pagesize,
respectively.

Note: PROC REPORT honors the first LS and PS that it
finds. When running my SAS report from Microsoft
Windows, | like to remove the LS and PS command. This
allows me to control my fonts and paper orientation from
the Menu Bar using File Print = Setup.

© The BOX option outlines the detail lines of the report,
similar to PROC TABULATE.

® The COLUMN statement describes the arrangement
of columns and headers.

VAR statement in PROC PRINT. This statement shows
the order of the SAS variables that are to be processed
and possibly printed. The AGE=_A1 is the only unclear
piece of code. _A1 is the alias for AGE. The DEFINE
statement will further clarify the need and use of an alias.

The COLUMN statement can also provide detailed header
information. You might want to have a special label across
the HEIGHT and WEIGHT variables. The do this, the
COLUMN statement needs to be rewritten as follows:

COLUMN SEX AGE NAME AGE= A1
(‘*Body Size*’ HEIGHT WEIGHT);

® The DEFINE statement specifies how to use the
specific variable that was defined in the column statement.
The variable can be either a SAS variable or a computed
variable created in PROC REPORT. The AGE and _A1
DEFINE statements will be used to explain how to use the
DEFINE statement.

Remember that _A1 variable is an alias of AGE. Because
the report has AGE sorted within GENDER, the AGE
variable needed to follow GENDER, but the report was to
keep AGE in the same location as the original report.
Thus, the DEFINE STATEMENT FOR age includes the
option NOPRINT, along with the option of ORDER.

DEFINE AGE / ORDER FORMAT= BEST9. WIDTH=9
SPACING=2 NOPRINT RIGHT "Age in years" ;

To begin a DEFINE statement, start with DEFINE followed
by the report item and then a slash (/).

DEFINE _A1 / SUM FORMAT= BEST9. WIDTH=9
SPACING=2 RIGHT "Age in years" ;

The report item for this example is _A1. The report item
can be a SAS variable, computed variable, or an alias of
either of these two variables.

After the slash, there are many options. Some of these
options are obvious, but other are better understood with a
SAS OnlineDocs.



To find out what the WIDTH option does, enter the
following sequence from the SAS OnlineDocs.

Base SAS Software = SAS Procedure Guide 2
The Report Procedure = Define Statement =
look for WIDTH explanation (at the bottom of
the documentation)

The following screen should appear.
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O The BREAK and RBREAK statement work in a simialr
manner, and so, they will be discussed together. The
BREAK statement allows for a brak at a grouped or
ordered variable. The break can be a summary line, page
break, or a line space. It can be before or after the
grouped data. The RBREAK statement is a summary line
for the completed report. It can be at the start or end of
the report.

CONCLUSION

PROC REPORT is a very powerful tool that is easy to use.
This paper has explored generating SAS code using
PROC REPORT in an interactive mode, and then later
modifying that code to work in a non-windowing
environment.

One area that was not covered in this paper that could
also increase your speed in generating PROC REPORT
code is to add PROMPT to the following code:

proc report data=sashelp.class prompt;
run;

This will open the PROMPT facility. This facility will guide
you through the report windowing procedure.

APPENDIX |

The CLASS data set used in this paper is provided with
SAS/ASSIST. To have the data saved in your SASHELP
library, click on the following sequence of icons/menus:

SETUP - Sample data sets... >
Create sample data sets... > Select CLASS - OK
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