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ABSTRACT 
For those of us who can remember running SAS programs on 
punch cards (and even for those who can't!), the new capabilities 
of SAS V8 can seem overwhelming at times.  This paper will 
present a few "tricks" to make the transition from PROC PRINT to 
ODS a little smoother, by taking advantage of the nice, juicy 
bones that the SAS Institute has tossed us.  These techniques, 
unless specifically noted as unique to a particular system, can be 
used with SAS V8 in any operating environment, including Red 
Hat LINUX, Windows and AIX/UNIX (and presumably other UNIX 
versions).  

INTRODUCTION  
Since I first started using a beta version of 
SAS on an IBM 360 at MIT to analyze data 
for a thesis more than 20 years ago, SAS has 
evolved into an amazing computing tool.  Still, 
for those of us old DOS dogs used to 
operating from the command line, changing 
our ways is a challenge.  The purpose of this 
paper is to outline a few tips for making the 
switch to SAS V8 from SAS V6 a little more 
palatable, and to give SAS users a taste of 
some of the new and improved functionality in 
SAS V8.  Some of the tips are specific to PC-
SAS; others are useful and have been tested 
on several platforms running SAS including 
Red Hat Linux 6.2. 

 "BADDEST" BATCH 
As a SAS old-timer, I’ve long preferred running from the 
command line or in “batch mode”.  When my company moved 
from DOS-based SAS V5 to MS Windows-based SAS V6, the 
first thing I did was to enable batch mode processing for PC-SAS.  
For mainframe users this is irrelevant, and it is a non-issue for 
LINUX and UNIX installations of SAS where one can run a SAS 
program from the command line simply by appending the 
program name to the invocation of SAS.  However, when SAS 
moved to Windows from DOS on the PC platform, the default 
became running from the Display Manager.  The Display 
Manager carried with it some wonderful capabilities, but my 
preference was to not have to think about saving SAS logs and 
lists.  With the advent of  PC SAS V7 and V8 (which my company 
is running concurrently with SAS V6.12 on both our UNIX system 
and our PC-based network), it became even more complicated.  
Due to the compatibility issues between SAS V6.12 and SAS V8 
files, I wanted to be able to run both versions in batch mode.  The 
dual version batch solution for systems running a version of 
Windows BELOW Windows 2000 Professional and a different 
solution for systems running Windows 2000 Professional follow 
below. 
 
To set up a single version of SAS to run batch on the PC by 
double-clicking the program name in Windows Explorer: 
 
Make sure a client install has been performed on the PC.  You 
can tell by right clicking on a SAS program in Windows Explorer 
and seeing if the batch option is available. 
 
 
 
 

 
If not, here's how to perform the client install: 
 
�� start->run    m:\winsas\setup.exe register (m:\winsas is the 

drive and directory where the current version of SAS is 
mapped on the computer) 

 
�� Supply default destination (wherever the config.sas you use 

is located, usually in the directory where the SAS system is 
resident) by typing it into the space provided. 

 
�� Supply directory where the core directory of SAS is installed. 
 
�� That will update the Windows registry, performing the client 

install. 
 
If the batch option IS available when you right-click on a SAS 
program in Windows Explorer, then a client install has already 
been performed and you can set batch up as the default action 
when you double click on a SAS program in Windows Explorer. 
 
�� Go to Windows Explorer. 
�� Select View->Options from the Menu Bar  
�� Or, for W2000PRO, Tools->Folder Options 
�� Click on File Types 
�� Scroll down until you find SAS System Program 
�� Highlight SAS System Program and click Edit 
�� Or, for W2000PRO, click Advanced instead of Edit 
�� Highlight Batch Submit and click on Set Default Button 
 
If you DON'T want Batch Submit as the default, just right- clicking 
on the program in the Windows Explorer will offer the option of 
running a program in batch once you have ensured that a client 
install of your particular version(s) of SAS has occurred. 
 
The option to run both SAS V612 and SAS V8 from Windows 
Explorer in batch mode is a little trickier.  Make sure client installs 
(see above) have been performed on both versions of SAS you 
are running.  Because you want to be able to choose which 
version of SAS to use on a given program (with the extension 
.sas) you must do a little fancy editing.  Most people in my 
company are still using SAS V612, therefore I have SAS V612 
set up as my default when I double-click on a SAS program in 
Windows Explorer.  If I want to run SAS V8 on a program in 
Windows Explorer, I right-click on the program and it gives me an 
option to run SAS V8 batch or SAS V612 batch. 
 
To do a dual-version SAS batch set up for Windows versions 
prior to Windows 2000 Professional: 
 
�� Go to Windows Explorer 
�� Select View->Options from the Menu Bar 
�� Click on File Types 
�� Scroll down until you find SAS System Program 
�� Highlight SAS System Program and click Edit 
�� Click on New 
This will bring up a screen where you can name your "action" (I 
named mine Version 8 Batch Submit) and you must supply the 
path to the application used to perform the action (in my case, 
"C:\Program Files\SAS Institute\SAS\V8\Sas.exe")  
�� Click OK and then CLOSE.  
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To do a dual-version SAS batch set up for Windows 2000 
Professional is somewhat more difficult.  Windows 2000 
becomes confused when you perform a client install for more 
than one version of SAS, and doesn’t allow you to have more 
than one file type with the same extension gracefully.   
 

 

�� Go to Windows Explorer 
�� Select Tools->Folder Options from the Menu Bar 
�� Click on File Types 
�� Scroll down until you find SAS System Program 
�� Delete the extra extension that Windows creates as a result 

of two SAS installs  
�� Find and highlight SAS System Program and click Advanced 
�� Click on New 
 
This will bring up a screen where you can name your "actions" 
(Both V6 AND V8 Batch options) and you must supply the paths 
to the application used to perform the actions (in my case, 
"C:\Program Files\SAS Institute\SAS\V8\Sas.exe" and 
“C:\Program Files\Winsas\Sas.exe”)  
Click OK and then CLOSE. 
 
You will need to right click on the SAS program to run batch in 
either version of SAS. 
 
TIP:  Should you run your PC SAS programs in "batch", any print 
formatting you may have set up in the Display Manager will not 
take effect.  You must include such items as ps and ls in your 
options statement to produce landscape versus portrait logs and 
lists.  Batch Submit processing will use the current SAS defaults.  
This also holds true for SAS/GRAPH® jobs run in batch.  You must 
specify your goptions in your program. 
 

ASK NOT WHAT ODS CAN DO FOR YOU; SEE 
FOR YOURSELF!  (WITHOUT A "TRACE" OF THE 
DISPLAY MANAGER) 
 
The ODS (Output Delivery System) is a really exciting innovation 
in the SAS system.  It is available on all platforms running SAS 
V8 and the mainframe counterpart of SAS V8.  Since I use SAS 
on UNIX, LINUX, an IBM Mainframe running TSO, and the PC, I 
wanted to be able to take advantage of the Output Delivery 
System’s capabilities on all 4 platforms.  On the PC, viewing SAS 
V8 output is fairly straightforward using the Display Manager and 
Windows’ multitasking capabilities.  However, on the mainframe 
viewing output in the form of HTML, for example, is not easy, if 
possible at all; and the SAS V8 Display Manager using 
XWINDOWS on LINUX and UNIX is pretty "busy" 
(understatement).  Even on the PC, there are times when you are 
outputting a file from a procedure using SAS V8, and what you 
get is not what you might expect.  There are also new procedures 
that can output files (i.e. PROC SURVEYMEANS) whose name 
and contents are unknown, and procedures which once did not 
produce output files which now have the capability of doing so 
(i.e. PROC TABULATE).  What is an old SAS dog to do?   
 
There are a number of commands having to do with ODS which 
can be inserted into your code, similar in style to an options 
statement, which might use to change SAS system options 
midstream.  The many ODS commands are explained in the SAS 
V8 Online Documentation as well as in SAS V8 printed 
documentation material such as "The Complete Guide to the 
SAS Output Delivery System". 
 
The command relevant here is ODS TRACE ON (and OFF).  This 
command allows you to “turn on” SAS V8’s capability of tracing 
your output from a program, which will appear in your SAS log.  
You can view the output file from a procedure you are not familiar 
with, say PROC SURVEYMEANS, then do a contents on that 
output file (all nicely and informatively labeled by the SAS 
System!), then do what you will with your output file.   Below 
follows an example of using the ODS TRACE, LISTING and 
OUTPUT commands, run using SAS V8 on AIX UNIX in batch 
mode. 
 
Example of PROC SURVEYMEANS WITH ODS TRACE ON 
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(LOG): 
 
NOTE: SAS initialization used: 
      real time           2.41 seconds 
      cpu time            0.20 seconds 
 
28          
29         ods trace on; 
30          
31         proc surveymeans data=chhld007; 
32         weight c_adjwgt; 
33         cluster stratum psu; 
34         var 
35         agecat1 
36         agecat2 
37         agecat3 . . .; 
136        run; 
 
 
Output Added: 
------------- 
Name:       Summary 
Label:      Data Summary 
Template:   Stat.SurveyMeans.Factoid 
Path:       Surveymeans.Summary 
------------- 
 
Output Added: 
------------- 
Name:       Statistics 
Label:      Statistics 
Template:   Stat.SurveyMeans.Statistics 
Path:       Surveymeans.Statistics 
------------- 
NOTE: There were 1200 observations read from the 
dataset WORK.CHHLD007. 
NOTE: The PROCEDURE SURVEYMEANS printed pages 1-
3. 
NOTE: PROCEDURE SURVEYMEANS used: 
      real time           2.31 seconds 
      cpu time            1.65 seconds 
       
 
137         
138        ods trace off; 
139         
140        endsas; 
 
NOTE: SAS Institute Inc., SAS Campus Drive, 
Cary, NC USA 27513-2414 
NOTE: The SAS System used: 
      real time           7.34 seconds 
      cpu time            2.97 seconds 
       
 
Example of PROC SURVEYMEANS WITH ODS OUTPUT & 
LISTING ON (LOG): 
 
NOTE: SAS initialization used: 
      real time           0.13 seconds 
      cpu time            0.11 seconds 
 
 
29          
30         ods listing close; 
31          
32         ods output Summary=dd.tt1_sum Statistics=dd.tt1_stat; 
33          
34         proc surveymeans data=chhld007; 
35         weight c_adjwgt; 
36         cluster stratum psu; 
37         var 
38         agecat1 
39         agecat2 
40         agecat3 . . .; 
 
NOTE: The data set DD.TT1_STAT has 1 observations and 606 
variables. 
NOTE: Compressing data set DD.TT1_STAT increased size by 50.00 
percent.  
      Compressed is 3 pages; un-compressed would require 2 pages. 
NOTE: The data set DD.TT1_SUM has 3 observations and 3 variables. 

NOTE: Compressing data set DD.TT1_SUM increased size by 100.00 
percent.  
      Compressed is 2 pages; un-compressed would require 1 pages. 
NOTE: There were 576 observations read from the dataset 
WORK.CHHLD007. 
NOTE: PROCEDURE SURVEYMEANS used: 
      real time           1.43 seconds 
      cpu time            1.37 seconds 
       
 
140         
141        ods listing; 
142         
143        proc print data=dd.tt1_sum; 
144        run; 
 
NOTE: There were 3 observations read from the dataset DD.TT1_SUM. 
NOTE: The PROCEDURE PRINT printed page 1. 
NOTE: PROCEDURE PRINT used: 
      real time           0.02 seconds 
         
146        proc print data=dd.tt1_stat; 
147        run; 
 
NOTE: There were 1 observations read from the dataset 
DD.TT1_STAT. 
NOTE: The PROCEDURE PRINT printed pages 2-14. 
NOTE: PROCEDURE PRINT used: 
      real time           0.14 seconds 
      cpu time            0.15 seconds 
       
 
148         
149        endsas; 
 
NOTE: SAS Institute Inc., SAS Campus Drive, Cary, NC USA 27513-
2414 
NOTE: The SAS System used: 
      real time           2.59 seconds 
      cpu time            2.32 seconds 
       
 
TIP:  SAS V8 output files naturally take advantage of the 
expanded space for variable names.  The files which were output 
from the example above were destined to be “transported” to the 
PC platform for further use in SAS V6.12.  It was necessary to 
rename the variables with 8 column names and transpose the file 
in order to produce a useable transport file (not shown in program 
above).  Other file types on the UNIX or other platforms may or 
may not have similar problems with this.  HTML and EXCEL files, 
for example, are fine. 
 

CHANGE IS BAD, OR IS IT?  

(OR, THE THINGS YOU CAN CODE . . .) 
 
I’ve really struggled with the recent installation of Windows 2000 
Professional in my office and all the changes it has brought, 
moving further away from the command line and my beloved 
DOS applications.  I have succeeded in finding the equivalent 
DOS prompt in the START->PROGRAMS->ACCESSORIES 
menu, and in configuring my very favorite DOS applications to 
work!    Resisting change to the bitter end. . .  However, in the 
case of SAS V8 versus SAS V6.12, there are numerous reasons 
to embrace the changes and new capabilities.  Among these 
reasons already mentioned are useful new procedures such as 
SURVEYREG, SURVEYSELECT and SURVEYMEANS, the 
Output Delivery System, added macro language capability, 
addition of output files to procedures which did not produce them 
earlier, and, BE STILL MY HEART, the addition of medians to 
many procedures which did not include them earlier.  Below 
follows an example of the many things you can do with SAS V8.  
Due to the size limitations of the paper, the example does not 
have the full impact possible in either the poster format or "on-
line", but it should serve to give the reader some idea of the 
possibilities. 
 
The map below represents a "clickable" HTML document created 
by a SAS/GRAPH program.  The resolution of the graphics suffer 
when they are compressed into a size that fits into a paper format 
and printed in black and white, but the picture is quite striking in 
its full glory on the computer screen.   I will have sample maps 
and programs available on a laptop at my poster during “Meet the 
Presenters” sessions.  Please note that the program presented 
below is incomplete (the details macro needs to be run for each 
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county) and cannot run as is. 

 
 
The idea is that one can click on any county on the map to get 
more information about that county.  In this case, I have 
suppressed the confidential data that was actually produced for a 
contract with the state of Montana, but have provided some basic 
information (below). 
 
Click on Chouteau county in the map and you get: 
 
 

 
 
The possibilities are endless! 
 
Below follows the code to produce this "clickable" map. 
 
filename odsout '.'; 
/* produce a format to associate county 
level data with its html table based on county code */ 
proc format; 
    value cntystat 
          1='href="cty1.htm"' 
          /* a value for each county to be represented */ 
; 
run; 
ods listing close; 
goptions reset=global; 
 
/* create a map of Montana from the US map */ 
proc sort data=maps.county (where=(state eq 30)) out=mt1; 
    by state county; 
run; 
proc sort data=maps.cntyname (where=(state eq 30)) out=mt2; 
    by state county; 
run; 
data county; 
    length linkme $ 80; 
    merge mt1 mt2 (keep=state county countynm); 
    by state county; 
    linkme=put(county,cntystat.); /* provide link to the HMTL tables 
*/ 
run; 
/* find the point at which to place county markers and names */ 
proc means data=county noprint; 

    var x y; 
    by state county; 
    id countynm; 
    output out=means median=;  /* note the use of median in proc 
means */ 
run; 
/* create annotate data set for markers and names */ 
data cnties; 
    length function style color $ 8 position $ 1 text $ 20; 
    retain function 'label' xsys ysys '2' hsys '1' when 'a' state 100 
        county 1000; 
    set means (drop=state county); 
    state+1; 
    county+1; 
    color='gray'; 
    size=1; 
    text='T'; 
    position='5'; 
    style='marker'; 
    output; 
    color='gray'; 
    state+1; 
    county+1; 
    size=2; 
    text=countynm; 
    position='6'; 
    style='zapfb'; 
    output; 
run; 
data all; 
    set county cnties; 
run; 
/* reproject the data after all our fussing around */ 
proc gproject data=all out=allp; 
    id state county; 
run; 
data county2 anno2; 
    set allp; 
    if state ge 100 then output anno2; 
    if state lt 100 then output county2; 
run; 
/* create the map */ 
goptions device=gif; 
goptions hsize=5 in vsize=4 in; 
ods html body='mthead.htm' path=odsout; 
pattern value=msolid; 
proc gmap data=county map=county2; 
    id state county; 
    choro countynm / discrete  html=linkme  coutline=gray 
        nolegend annotate=anno2; 
title1 f=zapfb h=1 "Montana County Data"; 
run; 
quit; 
/* create the county level detail HTML */ 
%macro details(cntynum); 
options ps=30 ls=64; 
ods html body="cty&cntynum..htm" path=odsout; 
title1 "County Information"; 
proc print data=means (where=(county=&cntynum)) noobs label 
uniform; 
    var state county countynm; 
run; 
ods html close; 
run; 
%mend details; 
%details(1); 
/* run for each county */ 
 
NOTE:  spacing and proper indents removed for inclusion of the 
code in the paper format. 
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TIP:  check for actual state/county values by running a frequency 
on your map data set, or do the formatting and linking with a sort 
and array processing. 

CONCLUSION 
SAS Version 8 provides many new and 
improved older tools to produce some 
amazing results.  It is well worth the effort 
for SAS V6 dogs to learn some new V8 
tricks.   With careful planning, the command 
line can still be a part of our lives!  We can 
have our cake and eat it, too. 
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