Successful Information Delivery: Integrate Your Data Warehouse and other SAS® Applications with Enterprise Reporter™ Software
Jens Dahl Mikkelsen, SAS Institute A/S, Copenhagen, Denmark

ABSTRACT
The value of the efforts put into developing a data warehouse, or analytical applications, first show when the users get the information they need, presented in an understandable format. This is common sense, yet the final part - delivering the information - is often a problem area.

By integrating Enterprise Reporter into your existing application or data warehouse you can
- produce and publish high quality standard reports in an automated way, be it on paper or through the web
- let users create their own ad-hoc reports on the data generated from your application in an easy to use MS-Office like environment.

This paper will focus on how to make the integration seamless for the users, and how the data warehouse administrator can manage the process from the data warehouse environment, not how to design reports. It is aimed at an audience of SAS programmers with limited knowledge of Enterprise Reporter release 2.5.

Topics covered include
- enhanced integration with SAS/Warehouse Administrator™ software version 2.0 and SAS application development tools
- the Enterprise Reporter batch language and Batch Builder
- availability of business specific sample reports (IT-service level reporting and SAP R/3 reporting)
- a look into the future enterprise reporting world.

Enterprise Reporter only runs in a Windows (or Windows NT) environment. Therefore, most of the integration techniques covered, are relevant only to data warehouses managed from a Windows (NT) platform.

INTRODUCTION: OPENING THE DATA WAREHOUSE
Your data warehouse first adds value to your organization when it is exploited! A requirement for successful exploitation is that the warehouse is structured to support the information needs of the user community, as well as being documented so the users know what information is available and where and how to access it.

Further, the exploitation tool should be easy to use for non-IT technical business users, including publishing the reports to the web.

Enterprise Reporter is designed for business users, providing an intuitive MS-Office like interface to the power of the SAS system.

Enterprise Reporter software is integrated with SAS/Warehouse Administrator software to provide an end-to-end warehouse solution, serving as the users window to the warehouse, fulfilling the information needs of the business users.

But Enterprise Reporter is also the tool to document the data warehouse – providing overview as well as detailed information of the data and the processes in the data warehouse. Further, the warehouse administrator can use SAS/Warehouse Administrator software as the single point of control to create ad-hoc reports, define and schedule batch report execution and view reports.

THE USERS WINDOW TO THE DATA WAREHOUSE
The purpose of your data warehouse is to help you make better business decisions - and Enterprise Reporter is the window to your data warehouse.

Enterprise Reporter reuses the metadata in the data warehouse and adds additional report specific metadata - such as information on how to combine data tables, and for each column, information on the allowed and default use. Enterprise Reporter encapsulates the combined technical and business metadata in InfoFolders.

By customizing the metadata in Enterprise Reporter, you create InfoFolders that are targeted for the information needs of the business users, hereby exploiting the data in the data warehouse. All that the business users have to do is paint, preview and publish their reports – rather than going through the bother of searching for the right data, combining tables the right way etc.

You can create Enterprise Reporter InfoFolders from within the SAS/Warehouse Administrator software environment. Simply select the subject area in the warehouse that you intend a group of business users to exploit, and from the right mouse button pop-up menu, you can create an Enterprise Reporter InfoFolder.

Example: Make the CRM Data base in the Marketing Campaigns subject from the Sample Data Warehouse available for reporting by Enterprise Reporter users.

First select the CRM Database detail logical table and click the right mouse button. Select Export Metadata...

In the Export Format Selection detail logical table and click the right mouse button. Select Export Metadata...

Click OK. You see a progress window, and when the metadata information is retrieved, the Create InfoFolder appears, already filled in.
The Folders box displays where the Warehouse metadata reside, as well as where the data to report on reside. You can let Enterprise Reporter automatically make relations between the tables. These will be used if a report needs to join the tables. The automatic joins will cause relations to be established between columns from different tables having same name, data type and length. This may or may not make sense with your data. In this example the automatic joins is disabled, allowing you to define your own relations as well as other customizations by clicking the Properties button.

In the All Folders box, all the tables comprising the CRM Database are listed. If you, or later on the users, are uncertain what the contents of a table or a column is, you can select it, and from the Properties selection of the right mouse button pop-up menu, you can see the description retrieved from the data warehouse.

In this case it is seen that the CRM Database detail logical table brings together the data of the other tables, so only this table should be seen by the users to avoid them having to search through lots of irrelevant data items (tables and columns).

The users view to the data is created in the Customized folders box by dragging items from the All Folders box and dropping them into the Customized Folders box. In the Customized Folders box, you may create a logical tree structure of folders and data items. This means, you can present the users for a structure, meaningful for the users – and not limited to a physical, and often complex structure.

As the users will see only the Customized Folders when they open the InfoFolder, you make data access transparent by reorganizing the data this way.

THE USERS PERSPECTIVE

To use the InfoFolder as a user, you invoke Enterprise Reporter, select Data -> Select InfoFolder and double click the desired InfoFolder. The InfoFolder is then loaded into the InfoCenter Window. Here you select the data items you want for the report by moving them to the right hand Report Data box. Optionally you can modify the attributes, create calculated columns, filter (subset) the data etc.
When you click OK, the selected data items appear in the small Report Data Window within the main Report Design window.

Here you drag report objects from the left-hand border onto the white “paper” and drag/drop data items from the Report Data window on top of the report objects. To fill in data to the report, you click the Data View button in the lower left window border.

DOCUMENTING THE DATA WAREHOUSE WITH ENTERPRISE REPORTER

Business users as well as applications developers often ask “what can I get from the data warehouse?” and “where do I find it?” With Enterprise Reporter you can answer these questions by producing richly formatted documents on paper or on the web.

An add-in to SAS/Warehouse Administrator software utilizes the metadata API to retrieve metadata in a form, optimized for reporting with Enterprise Reporter.

A report gallery for documenting your warehouse also comes with Enterprise Reporter, getting you up to speed instantly, but naturally you can easily design your own custom reports. The reports answers questions such as

- What tables and columns exist in the warehouse?
- What is the business rule behind the values of a particular column?
- Which information is available at which aggregation levels?
- Which default and user-extended attributes do tables and columns have?
- Who is responsible for the updates of which tables? – And when was the last update of the metadata?
- Which processes, and what transformations and mappings have the data been through?

The gallery of reports documenting the data warehouse can be invoked directly from the SAS/Warehouse Administrator Explorer window, or from Enterprise Reporter.

Example: Create a report on the tables and their columns in the Sample Demo data warehouse of SAS/Warehouse Administrator 2.0 software.

First create a libref to an empty folder:

```
libname dwdoc 'c:\sugi25\dwdoc';
```

Make sure this libref is available when you later create reports from Enterprise Reporter, for example by entering it in your autoexec.sas file.

Open the Sample Demo data warehouse. In the Explorer window, select any subject. Click on the right mouse button and select Export Metadata… and select Documenting the Data Warehouse. Click OK and this window will appear:

Select the DWDOC library as the destination for exported metadata.

You can optionally export process flow diagrams, which can be shown in Enterprise Reporter reports. The diagrams are generated on the basis of the SAS/Warehouse Administrator Process Editor diagrams, and can be created as bitmaps or SAS catalog entries. If the former is chosen, you can specify a path for the bitmap storage.

You can automatically create an Enterprise Reporter InfoFolder on the metadata if you leave the check box selected, and you can assign a name for the InfoFolder. The InfoFolder created will automatically have relations between the metadata tables, so they can be joined correctly and transparently, as well as have custom attributes assigned.

Click OK and the InfoFolder is created after you have entered user-id and password for Enterprise Reporter (you must authenticate yourself as an advanced user or administrator of Enterprise Reporter to be allowed to create InfoFolders).

You get a confirmation on the creation of the InfoFolder. Hureafter you can invoke Enterprise Reporter and create reports. Enterprise Reporter can for example be invoked from a SAS session using an AF command, or through calling an SCL (SAS Component Language) class. Both methods are explained in the appendix of this paper.

The report to create in this example exists as a sample report in the Report Gallery. In Enterprise Reporter, select File -> Report Gallery… and from the Warehouse Doc. tab, select the Tables and their Columns report.

To use this sample report with the InfoFolder that was just...
created, you select Data -> Select InfoFolder… and double click on the Demo Warehouse Documentation InfoFolder.

To switch the report from using its original InfoFolder to the new one, you simply click Keep in the dialog window prompting you:

Since the InfoFolder automatically has the same structure as the original InfoFolder for the report, you don’t need to make any mappings of data items.

Now you can switch the report from Design view to Data View or Print Preview from the viewer buttons in the lower left border of the Report window. Alternatively publish the report by saving it for example in HTML or PDF format or by printing it.

Here are the first three pages of the report (cover page, title section and the first report body page):

If you want to design your own reports, go to the InfoCenter by selecting Data -> InfoCenter to see all the available information in the InfoFolder:

AD-HOC REPORTING FROM THE DATA WAREHOUSE
As a data warehouse administrator you can also create appealing reports with Enterprise Reporter on the tables in the data warehouse. Simply select the table in the SAS/Warehouse Administrator Explorer window, and from the Add-ins pop-up menu select Enterprise Reporter – this will then be invoked with the selected table or view loaded.
Example: Create a report on the Prospect Response Details table.

Select the table in the SAS/Warehouse Administrator Explorer window, click **Tools** -> **Add-Ins**... If you have multiple user tool add-ins you will see a selection window. If this is the case, choose Enterprise Reporter. If Ad-Hoc Reporting with Enterprise Reporter is your only user tool add-in, you will be brought directly into Enterprise Reporter.

In Enterprise Reporter, the selected table is loaded in the Report Data Window – ready for you to drag and drop data items into the report design you create:

MANAGING AND DISTRIBUTING INFOFOLDERS AND REPORTS FROM SAS/WAREHOUSE ADMINISTRATOR SOFTWARE

You can perform many other Enterprise Reporter tasks from the Explorer Window of SAS/Warehouse Administrator software. These tasks include:

- viewing generated reports in HTML, XML or PDF format
- invoking the Enterprise Reporter Web Gallery
- executing reports interactively or in batch
- invoking the Enterprise Reporter Batch Builder to create and schedule batch report job streams and Web Gallery updates

This can be achieved by registering the appropriate commands as Information Mart Items, and select the Open action on the item in the Explorer window. The AF command to invoke Enterprise Reporter can be augmented with a number of options, causing different behaviors and actions within Enterprise Reporter.

Alternatively the SASHELP.BUSINESS.ERSTART.CLASS invokes an Enterprise Reporter session from an SCL (SAS Component Language) application (see the appendix for available methods for this class).

Example: Invoke Enterprise Reporter from SAS/Warehouse Administrator software and enter the Manage InfoFolders window.

In the SAS/Warehouse Administrator Explorer window, create an Information Mart, and within this, an Information Mart Item (Info Mart Item). This is done by clicking the right mouse button on a Data Warehouse Subject and selecting **Add Item >**

Select Properties for the Info Mart Item from the right mouse button pop-up menu.

Specify a Name, an owner, and an administrator.

In the Data Location tab, specify your PC as the host, and provide an empty (but existing) catalog entry of type SOURCE as the Information Mart Library/catalog.

In the Open Code tab, enter the command to invoke the Enterprise Reporters Manage InfoFolders window

Alternatively the Information Mart library/catalog can point to an SCL entry that uses the ERSTART class. In this case the open code should be:

```
proc display c= &loc; run;
```

See the appendix for the syntax to invoke Enterprise Reporter these ways.

Thus, the warehouse administrator can enter the Enterprise Reporter Manage InfoFolders window from the SAS Warehouse.
Administrator Explorer, by clicking the right mouse button on the Info Mart Item and select Open:

The Manage InfoFolders window is used to update, delete, copy, etc. InfoFolders. In this example, the CRM Database InfoFolder has been selected in the User tab (that is where InfoFolders you create are stored by default), copied to the clipboard and pasted to the Marketing tab. This way all users in the Marketing group can create reports based on the InfoFolder.

Similarly you could have Enterprise Reporter print reports, open the Report Gallery etc. from the SAS Warehouse Administrator Explorer window.

These integration features let you use the SAS/Warehouse Administrator software as the single point of control, easing the exploitation and documentation of the warehouse.

WHAT IS NEW ABOUT ENTERPRISE REPORTER 2.5 AND SAS/WAREHOUSE ADMINISTRATOR SOFTWARE 2.0 INTEGRATION?

1. Exploiting the Data Warehouse add-in
   - additional support for displaying business rules (descriptions) for column definitions in Enterprise Reporter defined in SAS/Warehouse Administrator.

2. Documenting the Data Warehouse add-in
   - now allows you to create InfoFolder directly from the Explorer window of SAS/Warehouse Administrator software
   - automatic customization of column attributes of the InfoFolder
   - additional metadata types retrieved to create reports on extended table and column attributes, column transformations, input/output tables and WHERE conditions
   - additional and enhanced sample reports in the Report Gallery.

3. Ad-Hoc Reporting add-in
   - new add in that invokes Enterprise Reporter and loads the table that is selected from the Explorer window of SAS/Warehouse Administrator software.

All three add-ins
- are available from the Enterprise Reporter 2.5 CD-ROM
- can be installed using the Install Shield
- are updated to support SAS Version 8
- adhere to SAS/Warehouse Administrator 2.0 add-in coding standards
- are documented. Documentation is also available on the Enterprise Reporter 2.5 CD-ROM.

The add-ins require that Enterprise Reporter 2.5 can be accessed from the current SAS/Warehouse Administrator 2.0 session. This implies running SAS Version 8 under Windows or Windows NT. Also, Enterprise Reporter must be callable from the SAS session running the SAS/Warehouse administrator software.

Note: The Documenting the Data Warehouse add-in can run in older releases of the software and in UNIX environments with some limitations. Please see the on-line help or the installation notes.

ENTERPRISE REPORTER BATCH BUILDER

WHAT IS BATCH BUILDER?
Generating reports in batch, on a regular basis, can be done using the new component of Enterprise Reporter 2.5 called Batch Builder. It is a native client interface to the Enterprise Reporter batch language.

With Batch Builder you create batch files (.ERB files) that contain the names of the desired reports, as well as the actions to perform on those reports. You can
- open and execute reports
- log on to remote servers
- dynamically specify SAS macro variables used in the reports to control data subsetting (WHERE conditions) or texts
- make report execution conditional - data dependent or system/date/time dependent
- execute SAS programs
- save and print reports in multiple formats
- create concatenated reports.

Concatenated reports allow reports with different data sources and layouts to be integrated into a single report. You can, for instance, create a concatenated report that contains data from different InfoFolders, SAS tables, MDDBs, and external files. You can also create a report that contains several list and table objects. A concatenated report can have a single cover page, consistent headers and footers, continuous page numbering, and one table of contents.

You can also create PDF and HTML documents from your report definitions and direct them to the Web Gallery.

Batch Builder can be invoked from Enterprise Reporter, by selecting Tools -> Batch Builder, from the Windows Start menu or by running the Batchb.exe file (residing in the
Batch Builder has a Scheduler interface to the Microsoft Task Scheduler (that comes with Internet Explorer).

**Example:** Create a concatenated report of some of the Documenting the Data Warehouse sample reports. Create it in PDF format and schedule the execution.

Invoke Batch Builder as described above. Click on the text in the Batch file contents box to select reports to be included in the batch file. To create a concatenated report, select the files in the Batch file contents box, and click the rightmost tool above (concatenation tool). Then the selected reports become parts of the concatenated report, and in the right side of the window, you specify the output format and destination as well as other formatting information. From the Insert menu, you can insert a Logon section. This is your Enterprise Reporter User-id and password. This is needed if the job is run from outside Enterprise Reporter. You save the batch file from the File menu as an Enterprise Reporter Batch File (.ERB).

The batch file can be executed either by double clicking on it in the Windows Explorer, by opening it in Enterprise Reporter, or by the task scheduler.

To invoke the Scheduler interface from Batch Builder, you click Tools -> Schedule Batch File.

Here you specify when, how often, and under which conditions, the batch file should be run.

As a data warehouse administrator, you can integrate Batch Builder (or other external software programs) into the SAS/Warehouse Administrator Explorer window, by creating an Information mart Item as shown above. In the Open Code tab you write code such as:

```r
options xwait;
execute:
   drive: path\batchb.exe;
options noxwait;
```

**ENTERPRISE REPORTER WEB GALLERY**

Enterprise Reporter Web Gallery is a web based report gallery where users can browse and print reports in HTML or PDF format. Optionally, you can use Enterprise Reporter user administration to control which users can see which reports.

You can feed Enterprise Reporter reports to the Web Gallery by letting Batch Builder run your reports, and create output in HTML and optionally PDF format. Batch Builder, at the same time, create set up information to the Java Applet of the Web Gallery. In addition to Enterprise Reporter reports, the Web Gallery can include any HTML or PDF output created from any application as well. For example, you can use it as a distribution tool for SAS output from the Output Delivery System in HTML format. The new Enterprise Reporter Web Gallery Update Tool (found in tbusroot\components\wgupdate.exe) is used register HTML or PDF output in the Web Gallery by updating the setup information for the applet.

As a data warehouse administrator, you can invoke the Enterprise Reporter Web Gallery from the SAS Warehouse Administrator Explorer, Use the WBROWSE command from a DM statement in the open Code of an Information Mart:

```
DM 'wbrowse "url/gallery.htm"';
```

Note that Adobe Acrobat Writer is needed to create PDF documents, whereas only an Adobe Acrobat Reader is needed to view and print PDF files (a Reader can be downloaded for free from the Internet).

**BUSINESS SPECIFIC REPORT GALLERIES**

A number of generic sample reports come with the Report Gallery of Enterprise Reporter. More business specific sample reports can be downloaded from the Enterprise Reporter homepage on the Internet (see the link in the Contacts section in the end). Some of the first business areas that is addressed are reports based on ERP data (such as SAP R/3), and IT Service Level reports that supplements SAS/IT Service Vision™ software. Some preliminary examples are shown below:
Future Directions of Enterprise Reporting

Enterprise Reporter 2.5 is the first release directed towards the next generation of enterprise reporting solutions. This includes moving Enterprise Reporter into components, taking advantage of the intelligent servers, intelligent storage and intelligent clients architecture of the Nashville releases of the SAS system. This includes:

- Builder client components
- incrementally implementing native client interfaces
- Server components
  - for executing, printing and distributing reports from where data reside and exploiting the power of the server, utilizing and integrating with the SAS system
- Viewer components
  - for browsing and printing reports in native client interfaces

The first move was to port Enterprise Reporter 2.0, which was a SAS 6.12 based SAS/AF® software application to Release 2.5, which is SAS Version 8 based. The split into SAS server components and native (C++ and Java) clients is ongoing. Batch Builder, the Web Gallery and the SAS Document Viewer are the first client components.

The SAS Document Viewer is a C++ based client viewer for browsing and printing XML (eXtended Markup Language) based documents. Enterprise Reporter 2.5 supports the XML standard so you can create reports in XML format. These can be included in the viewer. Here is an example of a report in the SAS Document Viewer:
The SAS Document Viewer can be installed from the Enterprise Reporter CD-ROM. In the future, more SAS products will be able to create output in XML format, thus opening up for even better output integration and flexibility.

CONCLUSION
Return of investment from building a data warehouse comes, when the people from your organization gets the information needed to make the right decisions. Enterprise Reporter is a tool that can help you and your colleagues achieve this, by delivering a framework for creating and publishing this information, be it on paper or the desktop.

As a data warehouse administrator, you can manage the information delivery using Enterprise Reporter from your data warehouse environment.

ACKNOWLEDGMENTS
Thanks to Wilbram Hazejager, The Netherlands, for his work on the Documenting the Data Warehouse add-in, and to Bent Reiter, Denmark, for his work on the Ad-hoc Reporting add-in.

APPENDIX
Useful methods for the SASHELP.BUSINESS.ERSTART.CLASS used to invoke Enterprise Reporter from an SCL (SAS Component Language) application:

- **SET_PRINT** name of Report to print
- **SET_HTML** name of Report to create as HTML
- **SET_PDF** name of Report to create as PDF
- **SET_OUT** output dest. for HTML/PDF output
- **SET_OPEN** name of Report to open
- **SET_COMMAND** supply commands to be processed in Enterprise Reporter
- **RUN_ER** executes your parameters
- **SET_BATCH** 'Y' - run in batch (avoid any prompting windows)
- **SET_EXITICON** 'N' - avoid iconizing when leaving Enterprise Reporter
- **ICONIZE** invoke Enterprise Reporter in iconized mode
- **SET_DATA** supply another SAS data set as input (libname.member)
- **SET_USR** user-id
- **SET_PW** password for the user

**Example:** Invoke Enterprise Reporter and display the Manage InfoFolders Window:

```sas
Init:
  inst_id=instance(loadclass('sashelp.business.erstart.class'));
  call send ( inst_id, 'SET_USR', 'ADMIN');
  call send ( inst_id, 'SET_PW', '' );
  call send ( inst_id, 'SET_COMMAND', 'MANINFO');
  call send ( inst_id, 'SET_EXITICON', 'NO' );
  call send ( inst_id, 'RUN_ER');
  call send ( inst_id, '_TERM_');
return;
```

INVOKING ENTERPRISE REPORTER WITH AN AF OR AFA COMMAND

Since Enterprise Reporter is a SAS/AF software application itself, it can be called using the SAS command AF or AFA.

```
AF C=sashelp.business.start.scl options
```

The following options apply:

- **open** = "<path>report.erf"!"report.erp"!"report.ert"
- **print** = "<path>report.erf"!"report.erp"
- **html** = "<path>report.erf"!"report.erp"
- **pdf** = "<path>report.erf"!"report.erp"
- **out** = "<path>name.htm"!"name.pdf"
- **data** = "libref.dataset"
- **user** = "userid"
- **pw** = "password"
- **command** = "command <; command>"
- **exiticon** = "NO" (avoid iconizing the SAS session when exiting Enterprise Reporter)
Some useful commands for both the SET_COMMAND method and the AF command are:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AGENT</td>
<td>opens the Infocenter window</td>
</tr>
<tr>
<td>LOADAGEN</td>
<td>opens the Select InfoFolder window</td>
</tr>
<tr>
<td>FILTER</td>
<td>opens the Filter window</td>
</tr>
<tr>
<td>DESIGNM</td>
<td>displays the report in Design View</td>
</tr>
<tr>
<td>SCREEN</td>
<td>displays the report in Data View</td>
</tr>
<tr>
<td>SPREVIEW</td>
<td>displays the report in Print Preview</td>
</tr>
<tr>
<td>MANINFO</td>
<td>displays the Manage InfoFolders window</td>
</tr>
<tr>
<td>NEW</td>
<td>clears the current report</td>
</tr>
<tr>
<td>OPEN</td>
<td>opens the Open Report dialog window</td>
</tr>
<tr>
<td>GALLERY</td>
<td>opens the Report Gallery window</td>
</tr>
<tr>
<td>SAVE</td>
<td>saves the current report</td>
</tr>
<tr>
<td>SAVEAS</td>
<td>opens the Save As dialog window</td>
</tr>
<tr>
<td>SPRINT</td>
<td>prints the current report</td>
</tr>
</tbody>
</table>

CONTACT INFORMATION

Your comments and questions are valued and encouraged.
Contact the author at:

Jens Dahl Mikkelsen
SAS Institute A/S
Koebmagergade 9
Dk-1150 Copenhagen K
Denmark
Work Phone: +45 33 96 98 98
Email: sdkjdm@sas.com
Web: http://www.sas.com/software/reporter/ (from here you can also download add-ins, sample reports and more...).

TRADEMARKS

SAS and all other SAS Institute Inc. product and service names are registered trademarks or trademarks of SAS Institute Inc. – in the USA and other countries. Other brand and product names are registered trademarks or trademarks of their respective companies.