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ABSTRACT

VARIABLE USAGE TYPES

What tools do you use to generate reports or listings?
PROC PRINT, PROC TABULATE, or DATA _NULL_?
Perhaps it is time to check out the flexibility and features
of PROC REPORT. An easy way to begin is to follow the
“80/20” rule by using the interactive REPORT windows to
get a head start on the syntax and options. After quickly
creating a program for the essential parts of a report, you
will have time left over to consider enhancements that
may require more complex features.

Every variable put into a report must be assigned to a
usage type. The assignment is made in the DEFINITION
window and in the DEFINE statement. The six types are:
GROUP, ORDER, DISPLAY, ANALYSIS, COMPUTED,
and ACROSS.

This beginning tutorial provides examples that you can
follow to learn the steps involved in building reports
interactively. The intent is to provide a starting point for
making better use of PROC REPORT, not to present an
overview of available features. Most methods apply to
Release 6.11/6.12 and Version 7/8. Although ODS and
the new STYLE options are mentioned, the focus is on
basic features of REPORT that exist in Release 6.11 or
later.

GROUP applies to “class” variables. The report can be
separated for each value of a GROUP variable with
automatic summary statistics for some or all of the other
variables. For instance, the sum can be calculated and
displayed for all ANALYSIS variables for each different
value of a GROUP variable. Sort order can be controlled
in several ways.

REPORT PROCEDURE BASICS
The REPORT procedure was designed as a flexible report
writing tool that combines features of the PRINT, MEANS,
and TABULATE procedures along with “PUT” capabilities
commonly used in the DATA step. The features have
remained stable since Release 6.11. You can use PROC
REPORT in three ways:
1)
2)
3)

windowing environment with prompting
windowing environment without prompts
batch program code

Using the windowing environment still creates program
code, you just do not have to remember the syntax. We
believe that only using the batch approach does not take
full advantage of using PROC REPORT over “traditional”
methods.
REQUIRED ELEMENTS
The fundamental elements of using PROC REPORT are
straightforward. At NESUG’99, Moriak provided a concise
description of three primary steps and four common
options. Another way to show the elements and options is
shown in Table 1.
Element
Option(s)
a) Subset data (WHERE)
1) Initiate procedure
(PROC REPORT)
b) BY processing
c) special headers
2) Assign report variables
(COLUMN list)
d) specify a statistic
e) Calculate new variables
3) Define report variables
(DEFINE statements)
f) Add summary lines
Table 1. REPORT Procedure Elements and Options

DISPLAY lists values as they appear in the data set.
DISPLAY is the default for character variables if no
ORDER or GROUP variables exist.

ORDER sorts the data and creates groups for summary
statistics.
ANALYSIS is the default type for numeric variables.
Summary statistics such as SUM or MEAN can easily be
calculated and displayed for the entire data set or each
group or sub-group.
See the SAS Guide to the Report Procedure for
explanations of COMPUTED and ACROSS.
BASIC PROGRAM
Below is an example of a program with basic elements.
NAME and SEX are character, while AGE and HEIGHT
are numeric. The report will be sorted by SEX and NAME.
AGE and HEIGHT will be usage type ANALYSIS by
default. What do you think the HEADLINE option will do?
PROC REPORT DATA=class
HEADLINE ;
COLUMN sex name age height ;
DEFINE sex / ORDER WIDTH=3 ;
DEFINE name / GROUP WIDTH=10 ;
DEFINE age / FORMAT=BEST4. ;
DEFINE height / FORMAT=4.1 WIDTH=6
RUN ;

;

FUN FEATURES
The REPORT procedure includes many features. Here
are just a few you can explore. Many are easier to learn
initially by using REPORT windows so you can
concentrate on the possibilities and results instead of the
correct syntax.
•
Summary statistics using BREAK and RBREAK on
ORDER or GROUP variables, with or without detail
lines and/or subtotals
•
COMPUTE blocks to create new variables
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•
•
•
•

COMPUTE block LINE statements (like PUT)
Fancy column headers (spanned headers)
Easy separator lines for summary statistics
BOX option (like PROC TABULATE)

We will show a few of these in the examples. The
references provide more examples and ideas.

USING THE REPORT WINDOW
There is more than one way to get into the REPORT
windowing environment. You can
1)

Submit a PROC REPORT program with the
WINDOWS option (default).

2) Use a menu selection from the main menu.
Rel. 6.12:
Globals > Present > Create Report
Ver. 8:
Tools > Report Editor
or Solutions > Reporting > Design Report
You can save the code once you have the report designed
in the REPORT window. You can save the code as a SAS
program in an ASCII text from (as demonstrated in
Example 1) or save the source code as a catalog entry.
USING PROMPT
You may want use the PROMPT option when starting a
REPORT window. To do so, start the procedure by
submitting a PROC REPORT statement instead of using
the menu. For example:
PROC REPORT DATA=libname.CLASS PROMPT; RUN;
You will start off selecting variables of interest in the order
desired. This method is a workaround to the default
strategy of only including the first few variables in the data
set that fit in the linesize available. After the REPORT
window appears, you will probably want to exit prompting
instead of continuing to modify every variable using the
prompts. The full DEFINITION window may be quicker
when making multiple modifications.
Using prompting is especially helpful in Version 8 because
the Report Layout window is no longer available. Although
you can use menu choices to add variables (see Example
2) or rearrange the order of variables, selecting all
variables in the correct order at the start can be quicker.

EXAMPLE 1: CLASS WITH MEANS
For the first example, we use the CLASS data set to
create a report sorted by SEX with means calculated for
HEIGHT, WEIGHT, AGE. See Appendix 1 for the data
used. You should work through the example with your own
SAS software at some point. Feel free to experiment.
EXAMPLE 1A: RELEASE 6.12
The steps shown in Appendix 1 create the report using
Release 6.12. Figures 1 through 5 show the work in
progress. Be sure to look at both the front window and the
interim report shown in the background in the REPORT
window. Figure 5 includes the final code.

EXAMPLE 1B: VERSION 8
The steps to create the report in Example 1a using
Version 8 are essentially the same as outlined in
Appendix 1, but the menu selections are often different.
For instance, see Figures 6a and 6b for the differences in
the Edit menu for the REPORT window.
The most significant difference to remember is moving the
variables around in Step 4. The REPORT LAYOUT
window does not exist so you must move columns
individually using the Edit menu choices such as
Edit > Move > Right of the Next Selected Item.
The other different menu selections for Version 8 are:
3a)
5a)
7b)
8b)
11e)
12a)
13a)

Tools > Report Editor
Tools > Options > Report
Edit > Summarize Information > After Item
Edit > Summarize Information > At The Bottom
View > Refresh
Tools > Report Statements
File > Close

For setting the title in Step 10, you cannot use a menu
selection to open the TITLE window. Use the command
line instead.

EXAMPLE 2: CLASS WITH RANGE LINE
For the next example, suppose you want to add a
customized summary line at the end of the report create in
Example 1 that shows the range of Age. Once you have
the core code for the main report, adding the extra code is
simple.
The trick is to calculate the minimum and maximum for
Age and then use a COMPUTE block with LINE
statements to write out the information. The added code is
in lowercase in Figure 7. The idea comes from Example 3
in the SAS Guide to the Report Procedure. Figure 8
shows the resulting report.

EXAMPLE 3: ADVERSE WITH VERSION 8
Have you had to deal with long text fields that were too
long to display without wrapping onto multiple lines? What
about having more than one record for the same
identifier? The REPORT procedure can make it easy.
Consider a data set containing adverse events from a
clinical trial. A patient is expected to provide data for
multiple visits and may have more than one event per
visit. The variables that contain descriptions of the events
are text and usually fairly long.
By following the steps in Appendix 2, it becomes a
relatively easy task to produce a readable report by
selecting variables and using the FLOW option. Choosing
the variables of interest is a point and click operation.
Repeated values of PATID or VISIT are quickly eliminated
once they are defined as GROUP variables. Using the
DEFINITION window to adjust column widths makes it
simpler to decide what will fit in the desired linesize.
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Try these ideas on any data set with long character
variables. You can accomplish the same things in
Release 6.12, but will need to adjust to the old menus for
most steps. No new Version 8 features are used.

Moriak, C. (1999), “Using the ID Options in PROC
REPORT,” Proc. of the Twelfth Annual North East SAS
Group Conference, Cary, NC: SAS Institute Inc., 328–
329. (Simple examples using ID.)

NEW FEATURES IN VERSION 7/8

Pass, R. (1999), “PROC REPORT – Land of the Missing
OBS Column,” Proc. of the Twelfth Annual North East
SAS Group Conference, Cary, NC: SAS Institute Inc.,
332–333. (How to simulate OBS numbering using
COMPUTE blocks.)

The differences between Release 6.12 and Version 8—
besides the menu changes—are mainly because of the
Output Delivery System (ODS). With ODS, styles control
colors, fonts, and other visual aspects of output. You can
override the default template for PROC REPORT output
by specifying style options for various parts of a report to
enhance the results. Of course, what looks good or bad
depends on whether you want HTML, Rich Text Format
(RTF), and perhaps even Postscript or PDF. See Kelley
and McNeill paper for HTML ideas.
Creating an HTML file is as easy as adding two ODS
statements and turning off the WINDOWS option. When
you submit the program, the Results Viewer window will
automatically display the HTML results while the standard
report will go to the Output window as always.
ODS HTML FILE=”c:/home/neat.html”;
PROC REPORT DATA=class
HEADLINE NOWD
STYLE (HEADER)={BACKGROUND=RED} ;
COLUMN sex name age height ;
RUN ;
ODS CLOSE ;

CONCLUSION
In spite of the existence of a windowing environment,
PROC REPORT has an underlying set of programming
statements to learn just like other SAS procedures.
Learning the statements, options, and syntax can be a
challenge when you are also trying to produce reports for
a deadline because of the breadth of functionality of the
procedure. By learning the procedure interactively, you
can quickly build 80% (or more) of the final report you
need. Saving the generated program code lets you
reproduce the report in the future, learn the language, and
add your own programming statements for the final 20%
of report features not available in a window.
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APPENDIX 1: CLASS EXAMPLE

b)

Follow these steps to create a report of CLASS using
Release 6.12. The data adds BIRTHDAY to the CLASS
data set shipped with Base SAS software. A DATA step to
create the data set is shown below.
1)
2)
3)

4)

5)

6)

7)

8)

Start up SAS software, Release 6.12
Establish a libname to reference the CLASS data set
(assumes CLASS exists)
Get into interactive REPORT window
a) Select Globals > Present > Create Report
b) Select library that contains CLASS
c) Select CLASS data set
d) Click on OK to get into REPORT window
Change order of variables
a) Select Edit > Layout to get into REPORT
LAYOUT window , see Figure 1
b) Move SEX to far left using click and drag
c) Move SEX down first, move NAME over, and
then drag SEX into empty space
d) Use mouse to move AGE to before BIRTHDAY
e) Click on Apply to preview results, move LAYOUT
window if necessary
f) Click on OK to close window and return to
REPORT window
Set options related to column headers
a) Select Edit > Set report options to get
ROPTIONS window
b) Click on HEADLINE and HEADSKIP buttons
c) Close window and return to REPORT window
Sort report by SEX
a) Double-click on SEX (column header) to open
DEFINITION window, see Figure 2
b) Click on ORDER button
c) Click on Apply to preview
d) Close window and return to REPORT window
(click on OK)
Set up summary by SEX
a) Check that SEX is still highlighted
b) Select Edit > Summarize information > After
detail lines to open BREAK window
c) Click on buttons to select:
Overline summary
Skip line after break
Summarize analysis columns
d) Close window and return to REPORT window
Set up overall summary
a) Select Edit > Summarize information > At
bottom of report to open BREAK window, see
Figure 3

title “Create CLASS”;
data libname.class;
input Name $ Sex $ Age Height Weight
Birthday:mmddyy10.;
format birthday mmddyy10.;
cards;
Alfred M
14
69
112.5
01/22/1984
Alice
F
13
56.5
84
06/15/1985
Barbara F
13
65.3
98
07/23/1985
Carol
F
14
62.8
102.5
02/14/1984
Henry
M
14
63.5
102.5
02/24/1984
James
M
12
57.3
83
10/15/1986
Jane
F
12
59.8
84.5
10/11/1986
Janet
F
15
62.5
112.5
04/03/1983

9)

10)

11)

12)

13)

Click on buttons to select:
Double overline summary
Skip line after break
Summarize analysis columns
c) Select a color
d) Close window and return to REPORT window
Clean up definitions for analysis variables
a) Modify Height
•
Double-click on HEIGHT (column header) to
open DEFINITION window
•
Change Format by typing 6.1 after
highlighting existing value
•
Change Statistic to MEAN after highlighting
existing value
•
Optionally, click on APPLY to preview
•
Close window
b) Modify Weight for Format: 6.1 and Statistic:
MEAN
c) Modify Age for Format: BEST4. and Statistic:
MEAN
d) Modify Birthday
•
Change Type to DISPLAY by clicking on
button (Statistic will blank out)
•
Change Format (optional)
Create TITLE
a) Select Globals > Options > Titles
b) Type in CLASS EXAMPLE as TITLE1
c) Close TITLE window
d) Select Edit > Refresh to update report display
and source code
Add a header across Height and Weight columns
a) Highlight HEIGHT (column header)
b) Select Edit > Span to next selected item
c) Click on WEIGHT, cursor should move to just
above HEIGHT
d) Type -VITAL STATISTICS- (hyphen before and
after text) starting at beginning of span area, see
Figure 4
e) Select Edit > Refresh
Look at REPORT source code and save program to a
text file
a) Select Locals > List REPORT statements (you
cannot edit these statements), see Figure 5
b) Select File > Save as > Write to file
c) Provide an appropriate destination and file name
d) Close window
Exit REPORT window
a) Select File > End (not File > Exit)
b) Click OK to confirm leaving REPORT window

Jeffrey M
13
62.5
84
08/14/1985
John
M
12
59
99.5
05/12/1986
Joyce
F
11
51.3
50.5
01/04/1987
Judy
F
14
64.3
90
03/28/1984
Louise F
12
56.3
77
03/15/1986
Mary
F
15
66.5
112
06/15/1983
Philip M
16
72
150
06/14/1982
Robert M
12
64.8
128
04/20/1986
Ronald M
15
67
133
09/11/1983
Thomas M
11
57.5
85
02/02/1987
William M
15
66.5
112
09/22/1983
run;
proc contents data=libname.class position;
run;
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a)

APPENDIX 2: ADVERSE EXAMPLE
These are the steps to follow to create the report of
ADVERSE in Figure 10. The principles apply to any data
set of adverse events from a clinical trial database or any
data set with repeating identifiers and long text fields.
Pos#
1
4
6
16
8
9
1)
2)
3)

4)
5)

6)

7)

8)

Variable
PATID
VISIT
AEDESC
ADVRS_C
ONDAT
RESDAT

Type/Len
num
num
$30
$70
$8
$8

Notes
Subject ID number
LABEL=Visit Number
AE verbatim description
AE code text
Onset Date
Resolved Date

Start up SAS software, Version 8.
Establish a LIBNAME to the data set.
Get into the interactive REPORT window.
a) Select Tools > Report Editor. (Alternatively,
Solutions > Reporting > Design Report.)
b) Select the library and the ADVERSE data set.
c) Select OK to get into the REPORT window.
Select OK to exit the message window that tells you
REPORT shows only the first few variables (because
they cannot all fit on one line).
Delete unwanted variables.
a) Select SITE by clicking on the variable.
b) Select Edit > Delete (or press DELETE key).
c) Repeat for the INVEST and AEDATE variables.
Add additional variables.
a) Select AEDESC, which is the column after which
you want to add variables to the report.
b) Select Edit > Add Item > Data Column > Right
c) In the Data Columns window, select ADVRS_C,
ONDAT, and RESDAT. The selected variables
move to the top of the list in the window, and
asterisks appear left of the variable names.
d) Select File > Accept Selection. See Figure 9.
e) Depending on linesize settings and variable
lengths, the new variables may not display on the
current page of the report. You can select View >
Next Page to confirm that the variables were
added. Select View > Previous Page to return to
the first page. In situations where the variables
should be able to display on a single page, you
may need to select View > Refresh to see the
effect of adding variables.
Set Report Options.
a) Select Tools > Options > Report.
b) In the ROPTIONS window, select HEADLINE
and HEADSKIP.
c) Select the backslash (/) used in SPLIT= and
change to insert mode using the Insert key.
d) Enter an asterisk (*).
e) Select OK.
Clean up identifiers: PATID and VISIT.
Eliminate repeated values for identification variables
by setting the usage type to GROUP. Here PATID
and VISIT are likely to have repeated values. But,
usage type is set to ANALYSIS initially for both
variables because they are numeric. Note that all
character variables to the right will change from
DISPLAY to GROUP.

9)

10)

11)

12)

13)

14)

Modify PATID.
i) Select PATID.
ii) In the Definition window, change the header
to Subject*ID.
iii) Change Usage to GROUP.
iv) Select Apply, view the results, and select
OK to close the window.
b) For VISIT, change Usage to GROUP. Note that
this variable had an assigned label in the data
set, so REPORT used the label as the column
header. If desired, you could change the label
used in the report by changing the column
header in the Definition window.
Shorten long text columns and flow the text.
a) Select AEDESC by double-clicking on the
variable name.
b) In the Definition window, change the header to
Verbatim*Term.
c) Select FLOW.
d) Change the value of WIDTH to 20.
e) Select Apply and view the results. The objective
is to get all variables to appear on a single page
assuming linesize is set for landscape printing.
f) Select OK to exit the Definition window.
g) Change ADVRS_C to also have a WIDTH of 20,
FLOW, and a header of Coded*Adverse
Event*Term. Select View > Next Page if needed.
Modify date variables: RESDAT, ONDAT.
a) Select RESDAT by double-clicking on the
variable name to get the DEFINITION window.
b) Select the header and change it to
Resolution*Date by typing in the new text.
c) Select Apply to view the results.
d) Select the Width value (default of 8) and change
it to 10.
e) Select Apply and view the results.
f) Select OK to exit the Definition window.
g) Change ONDAT using a similar process and a
header of Onset*Date.
Add a spanned header across several columns.
a) Select AEDESC (Verbatim Term) as the first
variable under the spanned header.
b) Select Edit > Span to next selected item.
c) Select RESDAT (Resolution Date), which is now
on the same page as AEDESC.
d) Locate the cursor at the beginning of the entry
field above the existing column headers. Type in
-Adverse Event Details- being sure to use a
single hyphen at each end.
e) Select View > Refresh to view spanned header.
Add a title.
a) If desired, use the Title window to enter titles.
Bring up the window using the Command box.
b) Select View > Refresh.
View and save the report code.
a) To view the code, select Tools > Report
Statements.
b) With the Source window open, select File >
Save As to save the file as a SAS program.
c) Or, to save the code as a catalog entry, select
File > Save Report and specify a libname,
catalog name, and description for the report.
Finish with REPORT.
a) Select File > Close (not File > Exit).

Beginning Tutorials

Example 1a: CLASS Report Using Release 6.12

Figure 1. REPORT LAYOUT Window - before any changes made to default report

Figure 2. DEFINITION Window - after SEX defined as an ORDER variable
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Example 1a: CLASS Report Using Release 6.12 (continued)

Figure 3. BREAK Window - summary on SEX values applied but before overall summary

Figure 4. Adding Spanned Header - report almost complete
Variables re-ordered and formatted, mean values added as summary statistics, title added
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Example 1a: CLASS Report Using Release 6.12 (continued)

Figure 5. SOURCE Window - REPORT code including spanned header

Example 1: Edit Menu Differences Between Release 6.12 and Version 8

Figure 6a. REPORT Edit Menu in Release 6.12

Figure 6b. REPORT Edit Menu in Version 8
Report Options under Tools > Options > Report
LAYOUT window no longer available
Refresh under View > Refresh
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Example 2: CLASS Report With LINE Statements Using Release 6.12

Figure 7. Enhanced Program Code - adding customized summary of Age range using LINE

Figure 8. Complete Report
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Example 3: ADVERSE Report Using Version 8

Figure 9. DATA COLUMNS Window - use File menu when done selecting variables

Figure 10. Program Code and First Screen of Report

