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ABSTRACT
If you are a SAS programmer who has avoided using SAS Enterprise Guide because you think it's only good for
point-and-click, then this paper is for you. You may be surprised to learn that SAS Enterprise Guide offers
programmers many advantages over Display Manager. We'll show you four different ways to run code, explain how
SAS Enterprise Guide can help to organize your work, and discuss issues unique to coding in SAS Enterprise Guide.
After reading this paper, you just might decide to make SAS Enterprise Guide your primary coding environment.

INTRODUCTION
Using SAS Enterprise Guide, you can manipulate data and run reports without ever writing a single line of SAS code.
So it’s not surprising that many SAS programmers believe that SAS Enterprise Guide is only useful to nonprogrammers. If you love the SAS language, why would you ever want to use SAS Enterprise Guide?
It turns out that there are several reasons why you might want to do just that. SAS Enterprise Guide offers
programmers a variety of ways to run code. You can type a program like you do in Display Manager, but you can also
use the point-and-click features of SAS Enterprise Guide to generate code that you can then modify. In addition, SAS
Enterprise Guide organizes your work into projects making it easy to find your code files, logs, and results; and the
process flow diagrams show at a glance how everything in your project fits together.
However, writing programs in SAS Enterprise Guide does require learning a new environment with new windows and
a new system for organizing your work. As with any new skill, there is a learning curve. The goal of this paper is to
ease that transition by explaining SAS Enterprise Guide from a programmer’s perspective.
This paper was written using SAS Enterprise Guide 4.1. If you are using another version of SAS Enterprise Guide,
you will find some differences in windows and options.

WRITING AND RUNNING A NEW PROGRAM IN THE CODE WINDOW
To open a Code window where you can type a program, select FileNewCode from the menu bar. The Code
window has a syntax-sensitive editor similar to the one in Display Manager.

Select
FileNewCode
and type program in
Code window
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When your code is ready to run, select CodeRun Code On Local from the menu bar. SAS Enterprise Guide will
submit your code to SAS on your local server (the same machine where you are running SAS Enterprise Guide), and
display the results.

Results display
automatically

THE PROJECT PARADIGM IN SAS ENTERPRISE GUIDE
We now have a simple project containing code, and results. In SAS Enterprise Guide, all your work is organized into
projects. You can only have one project open at a time, but you can have as many projects as you wish. Projects help
to organize your work by keeping track of your code, logs, and results.

Project
Explorer

Workspace displaying
Project Designer
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The project is displayed in the Project Explorer on the left and the Project Designer on the right. The space where the
Project Designer appears is called the workspace. The Project Designer shares the workspace with many other
windows including the Code window and results windows. You can switch between these windows by clicking their
tabs at the top of the workspace.
The Project Explorer displays your project in a tree diagram while the Project Designer displays your project in a
process flow diagram. Icons representing your code and results appear in both the Project Explorer and Project
Designer. However, by default, icons representing log files appear only in the Project Explorer.

RENAMING CODE AND SAVING A PROJECT
You can give your code a more descriptive name by right-clicking the code icon in the Project Explorer or Project
Designer and selecting Rename from the pop-up menu.
You can save your project by selecting FileSave Project As and navigating to the location where you want to save
your project. The next time you open this project, everything will be the way you left it.

Select File
Save Project As

Right-click icon
Select Rename

VIEWING THE LOG
If you see a red X on the code icon

, this indicates that the code produced errors (either error messages or data

errors such as invalid dates). A yellow caution sign on your code icon
(but no errors).

, indicates that your log contains warnings

When you run programs in Display Manager, you always see your SAS log. SAS Enterprise Guide, on the other hand,
only opens a log when there are errors. If there are no errors, the log will not open automatically. You can open a log
by right-clicking the log icon in the Project Explorer and selecting Open from the pop-up menu, or by right-clicking the
code icon in the Project Designer and selecting Open Log.
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Right-click log icon
and select Open

Logs in SAS Enterprise Guide are just the same as logs in Display Manager. They show your program along with any
error messages, warnings, and notes. In the log you will also see the housekeeping macros that SAS Enterprise
Guide runs automatically before and after every job.

SAS log

OPENING AND RUNNING AN EXISTING PROGRAM
As a SAS programmer you are sure to have lots of programs that you have already written. You can open an existing
SAS program by selecting FileOpenCode from the menu bar, and navigating to the location where your
program is stored. This window shows a program named SplitData that was written in Display Manager and then
opened in SAS Enterprise Guide.
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Select FileOpenCode
and navigate to code file

Using the Code window, you can edit programs that were written in Display Manager. To run the code, select
CodeRun Code On Local from the menu bar, or right-click the code icon in the Project Explorer or Project
Designer and select Run Code On Local from the pop-up menu.

EMBEDDED CODE VS. UNEMBEDDED CODE
At this point, this project contains two programs: RegionFreq and SplitData. Because SplitData was opened from an
external file, its icon includes a little arrow.

The arrow indicates that the project contains a shortcut to the code,
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but the code itself is not saved as part of the project. Because RegionFreq was written in SAS Enterprise Guide, its
icon does not include an arrow. RegionFreq is saved as part of the project, but SplitData is not.
Code that is saved as part of a project is called embedded code; code that is saved outside of a project is
unembedded. You can change whether or not a file is embedded. To do this right-click the code icon in the Project
Explorer or Project Designer, and select Properties from the pop-up menu. A Properties window will open for the
code file. In the General page, click the Embed button to embed an external file, or the Save As button to unembed
the code.
Whether it’s better to embed code in your project or save it as a separate file is your choice. One point to consider is
that code that is not embedded can be used by more than one project while embedded code can only be used by the
project that contains it. Either way, it’s important that you understand where your code is stored so you don’t
accidentally end up with multiple copies of a program when you only want one (or vice versa).

Click Embed
button

COPYING CODE GENERATED BY A TASK
So far we have simply used SAS Enterprise Guide as an environment for writing and running code, but you can also
use SAS Enterprise Guide’s point-and-click features to generate code for you.
In SAS Enterprise Guide, SAS procedure code is generated by tasks. Before you can use a task, you must first open
your data set. To open a data set, select FileOpenData from the menu bar, and navigate to your data set. The
data set will be displayed in a Data Grid. The following Data Grid shows a data set named World that contains data
about all the countries in the world.
When you open a task, it will use the active data set. The name of the active data set is displayed in a box on the
toolbar. You can change the active data set using that box on the toolbar, or by clicking the icon of the data set you
want to be active in the Project Explorer or the Project Designer.
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Data set displayed
in Data Grid

Active
Data box

For this example, we use the Summary Tables task, but copying code is similar for all tasks. The Summary Tables
task writes PROC TABULATE code. To open Summary Tables, select DescribeSummary Tables from the menu
bar. A Summary Tables window, like the one pictured below, will open. The first thing you do in any task is assign
variables to task roles, by dragging the variable names to the list of task roles. In this window, the variables Region
and PopGroup have been assigned to serve as classification variables.

First drag variables
to task roles

Then Click
Summary Tables

The second thing you do, in the Summary Tables task, is arrange your table. To do that click the Summary Tables
option in the selection pane on the left.
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In the Summary Tables page you drag variables from the list of available variables to the area labeled Preview. To
find out more about the Summary Tables task, you may want to read the paper, “Summary Tables Task in SAS
Enterprise Guide: PROC Tabulate Made Easy,” listed in the reference section at the end of this paper.

Drag variables
to Preview area

Once you are satisfied with the arrangement of your table, click Run. SAS Enterprise Guide will run the task and
display the results.
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Click the Project Designer tab to see the process flow diagram. At the bottom of the process flow are icons for the
World data set, Summary Tables task, and HTML output. The process flow includes icons for the two code files that
were created previously, but it does not (by default) show an icon for code generated by tasks. However, the Project
Explorer does include an icon for code generated by tasks. You can display that code by double-clicking the icon
labeled Last Submitted Code in the Project Explorer.

Double-click
Last Submitted Code

A Code window will open displaying the code generated by the task. You cannot edit the code generated by a task,
but you can make a copy of the code and edit the copy. The quickest way to do this is to type something in the Code
window. A window will open asking if you want to create a copy of the code. Click the Yes button, and SAS Enterprise
Guide will open a new Code window containing a copy of the code.
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Type something
in Code window
Then click Yes

The Project Designer now includes an icon labeled Code for Summary Tables. This is the copy of the code. You can
edit the copy of the code. You can also use this code in Display Manager by cutting and pasting, or saving this code
as an unembedded code file and opening it in Display Manager.

INSERTING CUSTOM CODE INTO THE CODE GENERATED BY A TASK
While you cannot edit the code generated by a task, it is possible to insert code into the program generated by a task.
To do that, reopen the task by double-clicking its icon in the Project Explorer or the Project Designer. Then click the
Preview code button in the lower left corner of the task window.
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Click
Preview code
button

A Code Preview window will open for that task. Click the Insert Code button.

Click
Insert code

A User Code window will open displaying the code written by SAS Enterprise Guide. This window will show all the
locations in the program where you can insert your own code. Find the place where you want to add code, and
double-click the words <double-click to insert code>.
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Double-click
<double-click to insert code>

An Enter User Code window will open. Type the code you want to insert and click OK.

In the task window, click the Run button. SAS Enterprise Guide will run the task using the code you inserted.
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LINKING ICONS IN THE PROJECT DESIGNER
Looking at the Project Designer, you can see that tasks are automatically connected to the data they use. However,
code files are not automatically connected to the data they use.

You can add links to make relationships between data sets and code files more clear. The code files in this project
use the World data set, so it would make sense to link the data to the code. To add a link, right-click the icon that you
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want at the beginning of the link, and select Link item to from the pop-up menu.

A Link window will open showing all the items to which you can link. Select one, and click OK.

To add more links, repeat the process. Here is the process flow diagram with the World data set linked to each of the
code files. Notice that links you add use a dashed line instead of a solid line.
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There is another reason why you may want to add links to your process flow. When you run a project, SAS Enterprise
Guide executes the project from upper left to lower right, following the branches of the process flow. You can use links
to explicitly control the order in which items run.

ADDING NOTES
As a programmer, you know that it is important to use comments to document your work. Notes are text files that you
can use to document a specific part of a project or an entire project. To add a note for an entire project, click the
background of the process flow diagram and select FileNewNote from the menu bar. A Note window will open.
You can type any text you want in this window.
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LIBNAMES IN SAS ENTERPRISE GUIDE
Up to this point, all the examples in this paper have referred to data sets using direct referencing such as
PROC FREQ DATA = ‘c:\EG Data\World’;
WHERE YearInd >= 1990;
TABLES Region;
When SAS Enterprise Guide sees a reference like this, it dynamically assigns a libref with a name something like
ECLIB000. That’s fine if you don’t need to use any data engines or advanced options. But if your data are more
complex, you may need more control. There are at least four ways to define a libref in SAS Enterprise Guide 4.1.
Starting with the most basic, and working to the most complex they are: put a LIBNAME statement in your code, use
options to automatically execute a LIBNAME statement, use the Assign Library task, and use the SAS Enterprise
Guide Explorer.

PUTTING A LIBNAME STATEMENT IN YOUR CODE
You can always write your own LIBNAME statements to create librefs just as you would in Display Manager. For the
PROC FREQ example, you could use this:
LIBNAME MyData ‘c:\EG Data’;
PROC FREQ DATA = MyData.World;
WHERE YearInd >= 1990;
TABLES Region;

USING OPTIONS TO AUTOMATICALLY EXECUTE A LIBNAME STATEMENT
There is an option that allows you to specify code that will be automatically executed every time you run something in
SAS Enterprise Guide. If you frequently use the same libref , then this may save you a lot of trouble. Open the
Options window by selecting ToolsOptions from the menu bar. In the selection pane on the left, click the SAS
Programs option. In the SAS Programs page, check Insert custom SAS code before submitting code, and click
the Edit button.
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In the Edit window, type the code you want to be run automatically. This could be a LIBNAME statement, an
OPTIONS statement, or any code that you want to be submitted every time you run anything in SAS Enterprise
Guide.

USING THE ASSIGN LIBRARY TASK TO DEFINE A LIBREF
To open the Assign Library task, select ToolsAssign Library from the menu bar. Then follow the directions in each
of the six windows of the Library wizard.

After you click Finish in the final window, SAS Enterprise Guide will create your libref, and add an Assign Library icon
to your project.
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When you use the Assign Library task, your libref will not be saved from one session to the next. The next time you
open this project, you will need to rerun the Assign Library task. To rerun the Assign Library task, right-click the task
icon and select Run Assign Library from the pop-up menu. To run the entire process flow, right-click the background
of the process flow and select Run Process Flow from the pop-up menu.
It’s a good idea to drag the Assign Library icon to the beginning of your process flow. This will help to remind you that
you will need to rerun it. Also, since process flows run from upper left to lower right, putting the Assign Library icon in
the top left corner assures that, if you run the entire process flow, the Assign Library task will run first.

USING THE SAS ENTERPRISE GUIDE EXPLORER TO DEFINE A LIBREF
Despite the similarity in names, the SAS Enterprise Guide Explorer is totally different from the Project Explorer. The
Project Explorer displays your project in a hierarchical tree diagram; the SAS Enterprise Guide Explorer is an
administrative tool. To Open the SAS Enterprise Guide Explorer, select ToolsSAS Enterprise Guide Explorer
from the menu bar.
If you have administrator privileges, then you can use the SAS Enterprise Guide Explorer to define new SAS data
libraries. An easy way to tell if you have administrator privileges is by looking at the SAS Enterprise Guide Explorer
window. If you see the words Admin Mode in the lower right corner, then you have administrator privileges. If you do
not have administrator privileges, you cannot use SAS Enterprise Guide Explorer to create libraries, but you can still
create libraries using the other methods described above.
Any library definitions you create in SAS Enterprise Guide Explorer will be stored on the SAS server you select. So,
unless you delete them, they will always be available for you to use. They will also be available to anyone else who
connects to that SAS server.
To create a new library select File ► New ► Library from the menu bar inside the SAS Enterprise Guide Explorer.
This opens a Library wizard which is similar to the Library wizard for the Assign Library task. Follow the directions in
each of the seven windows. When you click Finish in the final window, SAS Enterprise Guide will create your libref.
Unless you delete it, this libref will always be available to anyone using that particular SAS server. No icon will be
added to your project because you do not need to recreate the libref each time.
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ISSUES FOR PROGRAMMERS TO KEEP IN MIND
Here are a few things to keep in mind if you run code in SAS Enterprise Guide.
• Rules for Variable Names
By default, SAS Enterprise Guide uses the system option VALIDVARNAME = ANY (meaning that names must
be 32 characters or fewer in length, and can contain any character including blanks). In Display Manager the
default is VALIDVARNAME = V7 which follows the standard rules for SAS names (32 characters or fewer in
length, start with a letter or underscore, and contain only letters, numerals, or underscores). If you write a
program that produces a SAS data set (such as PROC TRANSPOSE or PROC IMPORT), then the names of
variables in that data set may be considerably different than variable names produced by the same code in
Display Manager. Adding the statement
OPTIONS VALIDVARNAME = V7;
to your code will fix this. If you use this option often, you may want to issue this statement automatically via the
Options window. The method for doing this is described in the preceding section “Using Options to Automatically
Execute a LIBNAME Statement.”
• Data Libraries for Output
If you use any tasks to create output data sets, the default library will be a permanent one—not WORK. The most
common default library for output data sets is SASUSER. However, on OS/390 and some UNIX systems,
SASUSER may be temporary. In some installations, SASUSER may be read-only. If you have more than one
SAS server, you may have a SASUSER library on each server.
EGTASK is a special library. If you define a library having this name on your system, then SAS Enterprise Guide
will use it as the default for output data sets instead of SASUSER.
You can change the default library for your output data. To do this select Tools ► Options from the menu bar,
and click Output Library in the selection pane on the left. In the Tasks > Output Library page, you can add new
libraries and move libraries up or down to change their priority. SAS Enterprise Guide will save output data sets
in the first library. If that library is not available, then SAS Enterprise Guide will go down the list until it finds a
useable library.
• Submitting Part of Your Code
As in Display Manager, it is possible to run part of your code in SAS Enterprise Guide. However, the replacing of
results can be messy. To avoid this, you may want to divide your code into smaller code files in SAS Enterprise
Guide, and then run each piece as a whole instead of running part of a code file.

MORE FEATURES TO EXPLORE
In a paper this size, we can’t cover all the special features that a programmer might want to know. Here is a brief list
of some other features you may want to learn more about.
• Running Code on a Local SAS Server vs. a Remote SAS Server
A SAS server is any machine that runs SAS software. If SAS software is running on the same machine where
you are running SAS Enterprise Guide, then it is considered a local server. If it is a different machine, then it is
considered a remote server. If your installation of SAS Enterprise Guide has been set up to access SAS software
on more than one machine, then you can easily change where code runs. To change the server that code runs
on, select Code ► Select Server from the menu bar. Then in the Select Server window, click the server where
you want to run your code, and click OK. To run your code select Code ► Run program-name On servername.
• Splitting the workspace
By default, you see only one thing at a time in the workspace (one process flow, or one code window, or one
result). You can split the workspace so that you can display two or more items at a time. Right click one of the
tabs in the workspace, and select New Horizontal Tab Group or New Vertical Tab Group from the pop-up
menu.
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• Multiple process flows
You can only have one project open at a time, but you can have multiple process flows in a single project. To
create a new process flow in a project, select File ► New ► Process Flow from the menu bar. You can give
your process flows different names by right-clicking their tabs and selecting Rename from the pop-up window.
• Scheduling Projects to Run at Another Time
You can schedule projects to run at a later time or on a regular basis (such as daily or weekly). To schedule a
project, select Tools ► Schedule Project from the menu bar. In the Schedule window, you can set your
password, create or modify a schedule, and specify other settings.
• Using Parameters to Create Dynamic Projects
Parameters are macro variables. In SAS Enterprise 4.1 you can use parameters in tasks, queries, or in SAS
code. To create a parameter, use the Parameters Manager. Select Tools ► Parameters (Macro Variable)
Manager to open the Parameters Manager. Click the Add button to create a new parameter. Then you add the
parameter to your task, query, or code. Whenever you run something that uses a parameter, SAS Enterprise
Guide will prompt you to specify a value for that parameter. To find out more about using parameters in SAS
Enterprise Guide, you may want to read the paper, “Dynamic Projects in SAS Enterprise Guide: How to Create
and Use Parameters,” listed in the reference section at the end of this paper.

CONCLUSIONS
SAS Enterprise Guide offers programmers a new way to write and run code. If you have never used SAS Enterprise
Guide, it will take you a while to get used to the new environment. But once you learn how to use it, you may well
decide to make SAS Enterprise Guide your primary SAS environment.
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