An Introduction to SAS/FSP® Software
Terry Fain, Loyola Marymount University, Los Angeles, California
Cyndie Gareleck, RAND, Santa Monica, California

ABSTRACT
SAS/FSP is a set of procedures used to perform full-screen interactive data entry, data editing, data retrieval, and data query. This tutorial provides a basic overview of SAS/FSP software under version 6.11 of the SAS® System. Topics include:

- creating a new SAS data set
- customizing data screens
- data entry
- data query
- browsing SAS data sets

The focus of this tutorial is on PROC FSEDIT although other procedures such as PROC FSBROWSE and PROC FSVIEW will be briefly discussed. Screen control language (SCL) is considered an advanced topic and will not be covered in this tutorial.

INTRODUCTION TO SAS/FSP
SAS/FSP contains five procedures: FSEDIT, FSBROWSE, FSLIST, FSVIEW, and FSLETTER. This workshop will concentrate on the first four procedures, with emphasis on FSEDIT. A description of the five procedures follows.

1. FSEDIT: Used for creating and editing SAS data sets and data views created with SAS/ACCESS as well as for data entry. May also be used for data query. Data is displayed by observation.
2. FSBROWSE: Similar to FSEDIT without the data editing features (data set is read-only). May also be used to browse data views created with SAS/ACCESS and PROC SQL.
3. FSVIEW: Similar to FSEDIT but data are displayed as a table with rows and columns instead of by observation.
4. FSLIST: Used to view external files.
5. FSLETTER: Used to create letters and other reports.

INTRODUCTION TO PROC FSEDIT
PROC FSEDIT is one of the most powerful procedures contained in SAS/FSP software. It is an interactive procedure used to create new SAS data sets, edit existing SAS data sets, enter data, and for ad hoc queries.

Syntax
FSEDIT is invoked from the Program Editor Window by a PROC statement which ends with a semicolon. 'VAR and LABEL statements may also be used, but are optional.

PROC FSEDIT [options];
VAR variables;
LABEL variable = 'label' ..
FORMAT .. ;
WHERE .. ;

PROC Statement. The PROC statement initiates the FSEDIT procedure. Frequently used options include:

1. NEW=SASdataset. Creates a new SAS data set. Optionally, can be used with LIKE=SASdataset, which copies an existing data structure when creating a new SAS data set.
2. DATA=SASdataset. Names an existing SAS data set for editing.
3. SCREEN=libref.catalog. Names the SAS catalog where customized screen information will be stored. If this option is omitted, a customized screen will not be saved.
4. Keys=keys.entry. Contains function key assignments. Ignored when the SCREEN= option is specified.
5. LABEL. Specifies that variable labels be used to identify variables. Ignored if SCREEN= specified.
6. ADD. Adds a new observation.
7. MOD. Opens FSEDIT menu window.
8. OBS=n. Specifies the number of observations. Not valid if a WHERE statement is specified.
9. PMENU. Displays a command menu instead of a command line.
10. PRINTALL. Prints the data set by observation.
11. NCol. Specifies the display column width of FSEDIT window. Not valid if SCREEN= specified.

Within SAS there are multiple ways to create a new data set. You can use a SAS data step, PROC FSVIEW, or you can use PROC FSEDIT to create a new data set.
CREATING A NEW SAS DATA SET WITH PROC FSEDIT

To create a new data set, submit statements such as the following from the Program Editor window.

---

Figure 1-Invoking PROC FSEDIT

This code will invoke PROC FSEDIT in data definition mode as shown in Figure 2. Note that the procedure and file name are indicated at the top of the window. Also note that the display may vary depending on the window manager being used.

---

Figure 2-Data Definition Mode

You create a data set by entering definition information as shown in Figure 3 below. Note the following rules for defining variables:

- Variable names must follow SAS naming conventions.
- Character variables must be assigned "type" c or $.
- Each variable should be assigned a length. Eight is the default.
- You may assign a label, format, or informat. To view the informat column, from the Locals menu, select Format/Informat.
- To copy attributes from one variable to another, use SELECT and REPEAT commands:
  - Assign these commands to function keys, select a variable, press SELECT.
  - Move the cursor to the desired line and press REPEAT. This copies all attributes, including variable name.
  - Change the new variable name so that it is unique.
  - Edit other attributes of the variables as needed.

---

Figure 3-Data Definition Mode

After you are finished entering the information, from the View menu, select End to execute. A data entry screen will appear similar to the one below.

---

Figure 4-Default Screen

Screen Customization

You may customize your screen display to, for example, resemble a survey instrument. Modifications to the screen will be stored in the screen catalog. In our example, the catalog will be saved as DEM01SCR.SCT01 in the library referenced by the LIBNAME statement.

To enter Screen Modification mode, from the Locals menu, select Modify screen... A dialog box like the one shown in Figure 5 will appear to allow you to assign a password.

---

Figure 5-Password Dialog Box

Enter a password if you wish. Click OK to close the dialog box. A screen like the one in Figure 6 will appear.
We will concentrate primarily on Options 2 (Screen Modification and Field Identification), 4 (Assign Special Attributes to Fields), and 5 (Modification of General Parameters), because that's where most of the customization features (with the exception of SCL) are to be found.

Option 2: Screen Modification and Field Identification

Select Option 2, Screen Modification and Field Identification. A screen similar to the default data entry screen will appear.

A major improvement in version 6.11 allows you to customize the display much more easily than with previous versions of SAS. Use the mouse to select, cut and paste as needed. You can write over text, add lines, delete lines, move text or delete text. You can also add comments, labels, and color. Note that each field must have a space before and after it. Use underscores to create data entry fields. Figure 7 below is an example of a screen after customization.

To exit and save your changes, from the File menu, select End. You will be asked to identify the newly moved fields to the system. When asked if you created any computational fields, respond N. These fields are created using SCL only. When prompted to identify a field, place the cursor anywhere on that field and press <CR>. When you are finished the following message will appear at the top of your screen:

NOTE: All fields are identified.

From the View menu, select End to return to the Modification Mode menu.

Option 4: Assign Special Attributes to Fields

You should now be back at the Modification Mode menu (Figure 4). Select Option 4, Assign Special Attributes to Fields. At the top center of the frame, you'll see the identifier of the type of attribute you're looking at. From the View menu, select Next Attribute (or Last Attribute) to access attribute screens. Table 1 summarizes the 13 attribute frames.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INITIAL</td>
<td>Sets initial values for fields.</td>
</tr>
<tr>
<td>MAXIMUM</td>
<td>Sets the maximum value allowed for fields.</td>
</tr>
<tr>
<td>MINIMUM</td>
<td>Sets the minimum value allowed for fields.</td>
</tr>
<tr>
<td>REQUIRED</td>
<td>Specifies fields that require a value.</td>
</tr>
<tr>
<td>CAPS</td>
<td>Specifies fields to be automatically capitalized.</td>
</tr>
<tr>
<td>FCOlor</td>
<td>Specifies the color of each entry field.</td>
</tr>
<tr>
<td>ECOLOR</td>
<td>Specifies a color for flagging erroneous data.</td>
</tr>
<tr>
<td>FATTR</td>
<td>Assigns special highlighting attributes.</td>
</tr>
<tr>
<td>EATTR</td>
<td>Assigns special highlighting attributes for flagging erroneous data.</td>
</tr>
<tr>
<td>PAD</td>
<td>Assigns pad characters for blank entry fields.</td>
</tr>
<tr>
<td>PROTECT</td>
<td>Specifies protected fields (fields that cannot be edited).</td>
</tr>
<tr>
<td>JUSTIFY</td>
<td>Specifies how the values are aligned: left, or centered.</td>
</tr>
<tr>
<td>NONDISPLAY</td>
<td>Specifies which fields should not be visible.</td>
</tr>
<tr>
<td>NOAUTO_SKIP</td>
<td>Controls whether cursor skips to next field when you type a character in the last position of a field.</td>
</tr>
<tr>
<td>NOAUTO_BLANK</td>
<td>Controls whether a field is automatically blanked out after a blank entered into a field.</td>
</tr>
</tbody>
</table>

After you have finished selecting the field attributes, from the View menu, select End to return to Screen Modification screen.

Modification of General Parameters

Select Option 5, Modification of General Parameters. Your screen will resemble Figure 8 below. Use this option to modify the screen size, color, and override options, as well as to set defaults for text searches. Changes will take effect after you exit Screen Modification mode and return to the data entry screen.
Data Entry Mode

When you enter data entry mode your customized display will appear on your screen. The file name and observation number will appear at the top of the frame.

![Figure 9-Data Entry Screen](image)

To add an observation either press the function key assigned to ADD, or from the Edit menu, select Add new record. You may also add records by duplicating an existing record and making changes as needed. To duplicate a record, press the appropriate function key, or from the Edit menu, select Duplicates record. Note the following:

- Use the <Tab> key to move to and from the fields on the data entry screen.
- If you have no data to enter into a REQUIRED field, or attempt to enter invalid data into the data field, from the Edit menu, select Override to leave the observation.

DATA QUERY

There are many ways to search for data within PROC FSEDIT. For example, if you know the observation number, from the View menu, select Go to observation number... and enter the number in the dialog box that appears.

In many cases you will want to query the data based on information other than observation number. You can do this based on:

- a set of conditions (Where... and Where also... commands from the Search dialog box).
- the value of a field (Name... and Locate... commands from the Search dialog box).
- part of the value of a field (Name... and Locate... commands).
- the value of more than one field (Find... command from the Search dialog box).
- embedded text strings*" (String... and Search... commands from the Search dialog box).

For example, to look for a record with name Cyndie and case number "1", use the FIND command, which allows you to look for the value of more than one field.

To find an embedded string, e.g., "Cyn", use the STRING and SEARCH commands.

Note also that you can specify default STRING variables when you modify general parameters.

DATA EDITING

Editing is done in "real time." Make a backup of your data before you begin the editing process.

- To edit within an observation, type in the new value over the old value.
- To cancel changes within an observation, issue the CANCEL command before moving to the next observation or issuing the SAVE command.

The DELETE command may not physically remove observations from a file. To physically remove deleted records, create a new data set with a DATA step or with any SAS procedure that updates files in place, e.g., PROC SORT.

PROC FSVIEW

PROC FSVIEW is a newer PROC similar to FSEDIT and FSBROWSE, but more flexible.

- In FSEDIT, data are displayed by observation. In FSVIEW, data are displayed as rows and columns (see Figure 10 below).
- FSVIEW can be used for either editing or browsing. The default mode is BROWSE; use the MODIFY or EDIT option in the PROC FSVIEW statement to edit.
- You must exit FSEDIT before sorting. In FSVIEW, however, you can sort in place from within the procedure. The display will be refreshed to show the newly sorted data.
- In both FSVIEW and FSEDIT, the observation number is displayed for uncompressed files. However, for compressed files, row information is only displayed in FSVIEW.
- FSVIEW also allows the creation of computational fields.²

![Figure 10-Example of FSVIEW Screen](image)

With SAS 6.11, you can also access FSVIEW through the menu system without having to write any SAS code. From the Global menu, select Manage, and from the submenu, select Open Table. You will see a dialog box (see Figure 11) listing all your previously defined files.
Figure 11-010109 Box for Using FSVIEW to Browse a Dataset

Select the libname and SAS dataset that you wish to browse, and click OK. An FSVIEW screen for that dataset will appear.

CONCLUSION

SAS/FSP is a powerful data management tool which can be used for creating new SAS data sets, data entry, and data query. It is easy to use and easy to learn. SCL can be used to enhance your application, although it is not really needed in most instances.

SAS and SAS/FSP are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

REFERENCES


Comments and questions may be sent to either of the authors:

Terry Fain
Information Services, LMU
7930 Loyola Boulevard
Los Angeles CA 90045-8360
Phone (310) 338-7537
FAX (310) 338-7717
tfain@lmu.edu

Cyndie Gareleck
RAND
1700 Main Street
Santa Monica, CA 90407-2138
Phone (310) 393-0411 x7815.
FAX (310) 393-4818.
cyndie@rand.org

1 Views created with PROC SQL are read-only and not available to FSEDIT.

2 SAS/FSP may also be accessed via SAS/ASSIST.

3 The WHERE statement is called a permanent WHERE clause. It cannot be changed without ending the procedure. We will discuss temporary WHERE clauses when we talk about data query.

4 “Length” is the number of bytes of internal storage, not screen display length.

5 This is a toggle. Repeat the process to view the format column.

6 Except fields that begin in the first column or end in the last column.

7 If your machine beeps, make sure you are not in INSERT mode.

8 Not all fields must appear on the screen. To keep a variable from appearing on the screen, enter UNWANTED on the command line when asked to identify its location.

9 To view your function key assignments, click on Help, keys. If ADD is not listed, add it. Select File, end to save the changes and exit Help.

10 Character data only.

11 This is called a temporary WHERE clause. It can be canceled by clicking on Search, Where Undo.

12 The computational fields are only available in the FSVIEW window. To save them as part of your data set, you cannot overwrite the current file; you must create a new one. To create a new data set, select Save As... from the File menu.