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Overview 

As the primary reporting component of the SAS Intelligence Platform, SAS® Web Report Studio provides an intuitive user 
interface that enables users at all technical skill levels to create, view, and explore centrally stored, Web-based reports.  

Typically, SAS Web Report Studio reports are built using SAS Information Maps, which provide a simplified layer between 
nontechnical business users and the complexities of databases and query languages. SAS® Information Map Studio 
provides a graphical user interface for building information maps.  

Using sample data that is shipped with SAS, this paper explains, step by step, how to create an information map in SAS 
Information Map Studio. It also shows you how to use that information map to build a report and demonstrates how you 
can refine the report after results are displayed. 

Intended Audience 

Because SAS Web Report Studio and SAS Information Map Studio have been redesigned, this paper is appropriate both 
for new users and for experienced users who want to quickly familiarize themselves with the new interfaces. 

Before You Begin 

By the time that you are ready to perform the tasks that are discussed in this paper, administrators at your site should 
have installed and configured all the necessary components for the SAS Intelligence Platform. This process should 
include starting the necessary servers.  

To perform all of the tasks in this paper, you must be able to start SAS Information Map Studio and log on to SAS Web 
Report Studio. In SAS Web Report Studio, you should be in the Advanced Report Creation role. As an alternative, you can 
be in the Basic Report Creation role with the Create Cascade Prompts capability specifically assigned. 

About the Sample Data 

The two sample tables used in this paper are INVOICE and PRODUCT. In Windows environments, these tables are 
located by default in C:\Program Files\SAS\SASFoundation\9.2\core\sample. In UNIX environments, the 
default location is /usr/local/SAS/samples. In order for you to follow along, these tables must be registered in the 
metadata and you must be authorized to access them.  
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Create the Information Map 

First, start SAS Information Map Studio. You should see the following main window.  

 

 

In this section, you will perform tasks mainly in the following four areas:  

• Resources pane—Provides access to existing information maps and to resources that you need for creating 
new information maps. Use this pane to select the two sample tables. 

• Design tab—Displays the currently selected resources and has two panes: Selected Resources and 
Information Map Contents. Drag the selected sample tables from the Resources pane to the 
Selected Resources pane. From the Selected Resources pane, add selected data items to the 
Information Map Contents pane. The data items that are listed in the Information Map Contents 
pane will be used in the query. 

• Relationships tab—Displays relational data sources (after you select some resources), their columns, and 
the relationships between them. Use the Relationships tab to define a relationship between your two 
selected data sources. 

• Properties pane—Displays the properties of items that are selected in the Resources pane, on the 
Design tab, and on the Relationships tab. Use the Properties pane to rename all of the selected data 
items and also to change the value-generation method for two data items.  
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After opening SAS Information Map Studio, you will perform these nine major steps:  

1. Select two relational tables as data sources. 

2. Define a relationship between the two data sources. 

3. Add data items from the data sources to the information map. 

4. Change the names of the selected data items. 

5. Change the value-generation method for two selected data items (Customer Name and Product). 

6. Create a new data item.  

7. Create a prompted filter.  

8. Run a test query.  

9. Save the information map.  

Step 1: Select Relational Tables as Data Sources 

Your first task is to select the tables that contain the data that you want to analyze in your report. After you select the 
tables, they become the data sources for your information map.  

1. Select Resources ► Application Servers in the Resources pane.  

2. From the Show drop-down list, select Tables. 

3. Navigate to the location of the INVOICE and PRODUCT tables and then select them as shown below: 

 

 

Tip: When the INVOICE and PRODUCT tables are selected, notice that their data structures appear in the Data 
Structure pane, as shown here: 
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4. Double-click INVOICE and PRODUCT, or drag them to the Selected Resources pane on the Design tab. 
Expand the data sources so that their contents are visible. The Design tab should now appear as follows: 

 

 

Tip: After you select the two tables, click the double arrows button ( ) in the upper right corner of the 
Resources pane to collapse the pane. Collapsing the pane gives you more workspace.  



5 
 

                         Build Your First Web-based Report Using the SAS® 9.2 Business Intelligence Clients

Step 2: Define a Relationship between the Data Sources 

Because you are using more than one data source, it is necessary to define a relationship between those sources so that 
they can be used together in your query. Define a relationship as follows: 

1. On the Relationships tab, click PRODNAME in the INVOICE data source and drag the mouse pointer to 
PRODNAME in the PRODUCT data source. A line is drawn between the two columns to show the relationship that 
you created, as shown in the following display: 

 
 

The default relationship returns all the rows in first data source that have one or more matching rows in the second 
data source. Also by default, one row in the first data source can be associated with one-to-many rows in the 
second data source. 

2. Select the Design tab when you are done. 

 

Step 3: Add Data Items from the Data Sources to the Information Map 

Data source columns that you select to use in the information map are called data items.1 To select data items, display the 
Design tab in the Selected Resources pane, and then double-click or use the arrow key to add the following data 
items to the Information Map Contents pane: 

• From the INVOICE data source, select CUSTNAME, INVNUM, INVPRICE, and PRODNAME. 

•  From the PRODUCT data source, select PRODCOST and PRODLIST. 

After you select the data items, the Information Map Contents pane appears as follows:  

                                                           
1 Data items also can be based on expressions that you define, as discussed in “Create a New Data Item”. 
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Step 4: Change the Names of the Data Items  

One of the advantages of using information maps is that they hide obscure and complex data structures from the report 
creators and viewers. In this sample, you will change the names of the data items to more meaningful, user-friendly 
names. 

In the Information Map Contents pane, select Custname. Notice that properties for this data item are displayed 
in the Properties pane to the right.  
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One way to change the name of a selected data item is to type a new name in the Value field for the Data item name 
property. When you select the Value field, the entire property row is highlighted. To replace the existing name, just begin 
typing. In this example, the value Custname is changed to Customer Name. 

 

The following table lists the new values that you should enter for each data item. 

Data item name property 

Original Value New Value 

Custname Customer Name 

Invnum Invoice Number 

Invprice Invoice Amount 

Prodname Product 

Prodcost Cost 

Prodlist Retail Price 

 

Step 5: Change the Value-Generation Method for Customer Name and Product 

A data item’s value-generation method determines how an application, such as SAS Web Report Studio, obtains values 
for a filter that is based on that data item. The default value-generation method does not provide a list of filter values.  

When you create the sample report, it must show a list of values for the Customer Name and Product data items. To 
show this list, change the value-generation method for these data items as follows.  

 
1. In the Information Map Contents pane, press the CTRL key and select Customer Name and Product. 

2. In the Properties pane, click in the Value-generation method field to display the Value-
Generation Method box in the Data Item Properties dialog box.  

3. Select User selects values from the dynamic list. 
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4. Click OK to return to the main window. 

 

Step 6: Create a New Data Item 

Create a new data item named Discount, so that your report can include the discount percentage, if any, for each 
invoice. 

1. Click the New Data Item icon ( ) on the toolbar to open the Data Item Properties dialog box. 

2. On the Definition tab, type Discount as the name of the new data item. 

3. Click Edit to open the Expression Editor dialog box and then create this expression: 

(<<root.Prodlist>> - <<root.Invprice>>) / <<root.Invprice>>  
You can type the expression, or you can construct the expression by selecting data items from the Business 
Data list (or the Physical Data list2) on the Data Sources tab and clicking Add to Expression to 
insert the selected data item into the Expression Text field. The following display shows Invoice Amount 
selected. 

                                                           
2 The Physical Data list displays the data sources that are used to create the information map. The Business Data list displays the data items that 
are contained in the information map. The Business Data list might include data items that only exist in the information map. For more information, see 
the SAS Information Map Studio Help. 
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4. Click OK to return to the Data Item Properties dialog box. 

5. Display the Classifications, Aggregations, Formats tab, and change the following three settings 
(accept the defaults for any settings that are not mentioned): 

a. For Aggregate functions, deselect Defined in expression (additive) and leave 
Defined in expression (non-additive) selected.  

b. For Format type, select Numeric. 

c. For Format name, select PERCENT with a width of 6. 
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When you are done, your Classifications, Aggregations, Formats tab should look like this: 

 
 

6. Click OK to finish creating your new data item, which is now listed with the other data items in the Information 
Map Contents pane. 

 

 

Step 7: Create a Prompted Filter 

The report should enable users to view results for specific products. You can create the prompt in SAS Web Report 
Studio, but for this sample, create the prompt in the information map.  

1. Click the New Filter icon ( ) on the toolbar to open the New Filter dialog box, and then specify these 
settings: 
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a. For Filter name, type Product Filter. 

b. For Data item, select Product. 

c. For Condition, select Is equal to. 

d. For Value(s), select Prompt user for value(s). 

At this point, the New Filter dialog box should look like this: 

 

 
2. Click New to open the New Prompt dialog box, and then specify the following settings on the General tab 

(accept the defaults for any settings that are not mentioned): 

a. For Name, type Prompt for Product. 

b. For Displayed text, type Select one or more products to subset the query 
results. 

The General tab should now look like this: 
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3. Click the Prompt Type and Values tab, and change the following two settings (accept the defaults for any 
settings that are not mentioned): 

a. For Method for populating prompt, select User selects values from a dynamic list. 

b. For Number of values, select Multiple values. 

The Prompt Type and Values tab should now look like this: 

 
 
 
 
 
 
 
 
 
 
 



13 
 

                         Build Your First Web-based Report Using the SAS® 9.2 Business Intelligence Clients

4. Click OK to return to the New Filter dialog box, which should now look like the following display: 

 

 

5. Click OK to finish creating the prompted filter for Product, which is then added to the Information Map 
Contents pane. 
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Step 8: Run a Test Query 

Before saving and closing an information map, you should run at least one test query to make sure that you get the results 
that you expect.  

1. Click the Run a test query icon ( ) on the toolbar to open the Test the Information Map dialog box. 

2. Move all the data items and the Product Filter into the Selected items list. 

 

 
3. Click Run Test. Because the product filter is designed to prompt for values, the Prompt Value Specification 

dialog box appears.  
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4. Select one or more of the products from the Available list, and then click OK.  

           
 

Here are the query results, which are subset to include just flippers and kayaks. Also notice that the new 
Discount column shows which invoice amounts reflect a discount from the regular retail price. 

 

 

Step 9: Save the Information Map 

When you are satisfied that the results look good, save the information map. Go back to the main SAS Information Map 
Studio window and perform these steps: 

1. Click the Save icon ( ) on the toolbar to open the Save an Information Map dialog box. 

2. Navigate to the location in which you want to save the map.  

Tip: Your administrator might have a preferred storage location for resources such as information maps. 
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3. For the Name, type Invoice Map as shown in the following display. 

 
 

4. Click Save to save the information map. 

Now, you are ready to use this information map to create a report. 

Create the Report 

Your administrator should have provided you with a URL for logging on to SAS Web Report Studio. After you log on to 
SAS Web Report Studio, click the New report link in the Getting Started box in order to access the Edit mode, 
which is shown in the next display.  
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In this section, you will perform report-building tasks in the following main areas:  

1. Section Data pane—Used to manage data. In this pane, use the Options menu to open the Select Data 
dialog box and the Section Filter dialog box. 

2. Layout grid—The area in which you place tables, graphs, geographical maps, stored processes, text, and images 
for your report. In this example, insert a list table and bar chart for the sample report. 

3. Table of Contents pane—Used to manage sections and group breaks. In this example, insert a group break 
on Product. (When the report is displayed, use Table of Contents to display results for each product.) 

After you log on to SAS Web Report Studio, you will perform these six major steps:  

1. Select data items from the Invoice Map. 

2. Create a cascading prompt. 

3. Define a group break by product. 

4. Insert a table and a graph. 

5. Save the report. 

6. View results and refine the display. 
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Step 1: Select Data Items from the Invoice Map 

Your first task is to select the data items from the information map that you just created. The selected data items are used 
to obtain results for your report.  

1. From the Section Data pane, select Options ► Select Data to open the Select Data dialog box. 

2. From the Invoice Map, select the data items so that they appear in the order shown below. 

Note: If the Invoice Map is not selected, then click the Change Source button and navigate to its location. 

 

 

Keep in mind that the order in which you select data items affects default assignments in tables and graphs. For example, 
in bar charts, the first measure is assigned to bar height and the first category is assigned to bars. All other data items are 
hidden. 
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Step 2: Create a Cascading Prompt 

When you create a set of prompts, you sometimes want the values of one prompt to depend on the value that is selected 
for another prompt. In that case, set up dependencies between the prompts.  

1. Select Options ► Section Filters to open the Section Filters dialog box. The filter that you created in the 
Invoice Map is shown in the Apply predefined filters box. By default, the filter is not selected. 
Select Product Filter now so that it can be used in the report.  

 

 

2. Click New to open the Create Custom Filter dialog box and then specify the following settings and accept the 
defaults for all other settings: 

a. For Filter name, type Customer Filter. 

b. For Data item, select Customer Name. 

3. Select the Prompt user to enter values check box. When you select this option, the fields on the 
dialog box change to enable you to specify the prompt criteria. For the prompt criteria, specify these settings 
and  accept the defaults for all other settings:  

a. For Prompt text, type Select one or more customers to subset the query results. 

b. For Prompt name, type Prompt for Customer. 

c. For the Default value, type New Waves. 

The Create Custom Filter dialog box should now look like this: 
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4. Click OK to return to the Section Filters dialog box, which should now look like this:  
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5. From the Section Filters dialog box, click Manage Prompts to open the Manage Prompts dialog box. Only 
filters that are selected for the report are available in this dialog box.  

The Dependency list contains all selected filters. The Prompt list contains only those prompts that support 
dynamic-value generation. For this exercise, the Prompt for Customer should depend on the values 
selected for the Prompt for Product, so specify these settings: 

a. From the Prompt drop-down list, select Prompt for Customer. 

b. From the Dependency list, select Product Filter. 

c. Click Add. 

The Manage Prompts dialog box should now look like this: 

 

6. Click OK to return to the Section Filters dialog box, and then click OK to return to the report layout.  

 

Step 3: Define a Group Break by Product 

Each report section can be divided by one or more group breaks. Each group break causes the data to be grouped for 
each distinct value of a selected category. This report should be grouped by product. 

1. In the Table of Contents pane, select Options ►Group Breaks. 

2. In the Group Breaks dialog box, specify these settings and accept the defaults for all other settings. 
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a. From the Break by values of list, select Product.  

b. Edit the formatting so that the font size is 14 and the text color is blue.  

3. Click OK to return to the report layout. 

Step 4: Insert a Table and a Graph 

SAS Web Report Studio provides a variety of ways in which to display results, including two types of tables and seven 
types of graphs. This sample report contains a list table and a bar chart.  

1. Select the Insert list ( ) tool and drag it into the first cell in the layout grid as the table placeholder. 

2. Right-click the table placeholder and select Assign Data from the shortcut menu. 
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3. By default, the data items are added to the table in the order in which they were selected for the report. In the 
Assign Data dialog box, drag Cost and Invoice Number to the Hidden assignment. Product is already 
hidden because it is being used as the group break category. 

 

 
4. Click OK to return to the report layout. 

5. Right-click the table placeholder again, select Properties, and on the Text tab, change the heading size to 
12 and the cell size to 10. Accept the defaults for all other settings. 

6. Click OK to return to the report layout. 

7. Select the Insert bar chart tool ( ) and drag it into the cell beneath the list table. 

8. Right-click the bar chart placeholder, select Properties, and then specify these settings (accept the defaults 
for all other settings): 

a. On the General tab, change the Graph size to Fixed size and Custom.  

Tip: This setting enables report viewers to drag and resize the bar chart. 

b. On the Axis tab, change the label and value font size to 12. 

9. Click OK to return to the report layout. 
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Step 5: Save the Report 

1. Select File ► Save to open the Save As dialog box.  

2. For Name, type Customer Invoice Report. 

3. For Type, accept Data is automatically refreshed. 

4. Navigate to the location where you want to save the report.  

Tip: Your administrator might have a preferred storage location for resources such as reports. 

 
 

5. Click Save to save the report and return to the report layout.  
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Step 6: View Results and Refine the Display  

Before putting a report into production, it is wise to view the output and make any necessary adjustments. In this section, 
you will perform these tasks after the report is displayed: 

• Add a data item to the section query. 

• Display results for each group break. 

• Hide filter information. 

• Increase the report viewing area.  

However, first you must display the Customer Invoice Report: 

1. From the report layout, click the View tab, which automatically opens to a prompt window. (Recall that the 
report has a Prompt for Customer that depends on a Prompt for Product.)  

2. Select flippers, snorkel, and surfboard, and then click Apply. Only customers who have purchased 
flippers, snorkels, and surfboards are displayed for the Prompt for Customer.  

3. Select all of the available customers, and then click View Report to see the following display.  
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Tip: To enter different prompt values after the report is displayed, select Data ► Refresh to reopen the prompt window. 
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Add a data item to the section query 

The report does not currently include the Invoice Number data item. To add the data item while viewing the report, 
select the data item in the Section Data pane and drag it to a valid location. Valid locations are highlighted as soon 
as you begin to drag the data item onto the report as shown in the following display.  

  



 

28 
 

Build Your First Web-based Report Using the SAS® 9.2 Business Intelligence Clients

Display results for each group break 

Because the report is grouped by product, use the Table of Contents pane to display results for each product. For 
example, select surfboard in the Table of Contents pane to see results for that product. 
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Hide filter information 

By default, applied filter information is displayed. To hide the filter information, select View ► Applied Filters to deselect 
the option. In the following display, the Applied Filters box is no longer visible. 
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Increase the report viewing area 

The Table of Contents and the Section Data panes are contained within a Data panel that can be collapsed 
horizontally to increase the report viewing area. To collapse the Data panel, click the horizontal double arrows ( ) or 
select View ► Data Panel.  
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Summary 

The business intelligence components of the SAS Intelligence Platform enable users with various needs and skill levels to 
create, produce, and share their own reports and analyses. Through easy-to-use interfaces, users can obtain their own 
answers to business questions. Meanwhile, the information technology staff retains control over the quality and 
consistency of the data. 

This paper introduced you to two major components of the platform: 

• SAS Information Map Studio, which enables business analysts and information architects to organize data in 
ways that are meaningful to business users, while shielding the end users from the complexities of underlying 
data structures 

• SAS Web Report Studio, which is a Web-based query and reporting tool that enables users at any skill level to 
create, view, and organize reports 

Resources  

Patillo, Sherry and Rick Styll. 2007. “What’s New in SAS® Web Report Studio 4.2”. Cary, NC: SAS Institute Inc. Available 
at support.sas.com/resources/papers/sgf2008/webreport42.pdf. 

SAS Institute Inc. 2009a. SAS® 9.2 Intelligence Overview. Cary, NC: SAS Institute Inc. Available at 
support.sas.com/documentation/cdl/en/biov/60947/HTML/default/titlepage.htm. 

SAS Institute Inc. 2009b. SAS® 9.2 Intelligence Platform Web Application Administration Guide. Cary, NC: SAS Institute 
Inc. Available at support.sas.com/documentation/cdl/en/biwaag/61238/HTML/default/titlepage.htm.  

SAS Institute Inc. 2009c. SAS® 9.2 Intelligence Platform Data Administration Guide. Cary, NC: SAS Institute Inc. Available 
at support.sas.com/documentation/cdl/en/bidsag/61236/HTML/default/titlepage.htm. 

SAS Institute Inc. 2009d. SAS® Information Map Studio 4.2 Getting Started with SAS® Information Maps. Cary, NC: SAS 
Institute Inc. Available at support.sas.com/documentation/cdl/en/imsgs/61225/HTML/default/titlepage.htm. 

SAS Institute Inc. 2009e. SAS® Web Report Studio 4.2 User’s Guide. Cary, NC: SAS Institute Inc. Available at 
support.sas.com/documentation/cdl/en/citug/61084/HTML/default/titlepage.htm.  

http://support.sas.com/resources/papers/sgf2008/webreport42.pdf
http://support.sas.com/documentation/cdl/en/biov/60947/HTML/default/titlepage.htm
http://support.sas.com/documentation/cdl/en/biwaag/61238/HTML/default/titlepage.htm
http://support.sas.com/documentation/cdl/en/bidsag/61236/HTML/default/titlepage.htm
http://support.sas.com/documentation/cdl/en/imsgs/61225/HTML/default/titlepage.htm
http://support.sas.com/documentation/cdl/en/citug/61084/HTML/default/titlepage.htm




 



 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA 
and other countries.  ® indicates USA registration.  Other brand and product names are registered trademarks or trademarks of their 
respective companies.  Copyright © 2009 SAS Institute Inc., Cary, NC, USA.  All rights reserved.   




