SAS/QC® 13.2 User’s Guide
The ISHIKAWA Procedure
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.

support.sas.com/bookstore
for additional books and resources.
# Chapter 8
The ISHIKAWA Procedure

## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>696</td>
</tr>
<tr>
<td>Overview</td>
<td>696</td>
</tr>
<tr>
<td>Terminology</td>
<td>697</td>
</tr>
<tr>
<td>Tutorial</td>
<td>699</td>
</tr>
<tr>
<td>Details of the ISHIKAWA Environment</td>
<td>708</td>
</tr>
<tr>
<td>Summary of Operations</td>
<td>708</td>
</tr>
<tr>
<td>Operations</td>
<td>711</td>
</tr>
<tr>
<td>Adding Arrows</td>
<td>711</td>
</tr>
<tr>
<td>Labeling Arrows</td>
<td>715</td>
</tr>
<tr>
<td>Moving Arrows</td>
<td>718</td>
</tr>
<tr>
<td>Deleting Arrows</td>
<td>724</td>
</tr>
<tr>
<td>Resizing Arrows</td>
<td>727</td>
</tr>
<tr>
<td>Swapping Arrows</td>
<td>729</td>
</tr>
<tr>
<td>Balancing Arrows</td>
<td>732</td>
</tr>
<tr>
<td>Notepads</td>
<td>739</td>
</tr>
<tr>
<td>Managing Complexity</td>
<td>741</td>
</tr>
<tr>
<td>Zooming Arrows</td>
<td>743</td>
</tr>
<tr>
<td>Isolating Arrows</td>
<td>744</td>
</tr>
<tr>
<td>Merging Diagrams</td>
<td>746</td>
</tr>
<tr>
<td>Creating Graphics Output Using SAS/GRAPH Software</td>
<td>749</td>
</tr>
<tr>
<td>Creating Bitmap Graphics Output</td>
<td>752</td>
</tr>
<tr>
<td>Modifying Fonts</td>
<td>754</td>
</tr>
<tr>
<td>Modifying Box Colors</td>
<td>755</td>
</tr>
<tr>
<td>Modifying Arrow Colors and Line Styles</td>
<td>755</td>
</tr>
<tr>
<td>Modifying Text Colors</td>
<td>763</td>
</tr>
<tr>
<td>Modifying Arrow Heads</td>
<td>765</td>
</tr>
<tr>
<td>Modifying Environmental Attributes</td>
<td>765</td>
</tr>
<tr>
<td>Saving an Ishikawa Diagram for Future Editing</td>
<td>766</td>
</tr>
<tr>
<td>Reading an Existing Ishikawa Diagram</td>
<td>767</td>
</tr>
<tr>
<td>Displaying Multiple Ishikawa Diagrams</td>
<td>769</td>
</tr>
<tr>
<td>Input and Output Data Sets</td>
<td>771</td>
</tr>
<tr>
<td>Syntax</td>
<td>773</td>
</tr>
<tr>
<td>Examples</td>
<td>774</td>
</tr>
<tr>
<td>Example 8.1: Quality of Air Travel Service</td>
<td>774</td>
</tr>
<tr>
<td>Example 8.2: Integrated Circuit Failures</td>
<td>775</td>
</tr>
<tr>
<td>Example 8.3: Photographic Development Process</td>
<td>776</td>
</tr>
<tr>
<td>References</td>
<td>776</td>
</tr>
</tbody>
</table>
Introduction to the ISHIKAWA Environment

Overview

The Ishikawa diagram,\(^1\) also known as a cause-and-effect diagram or fishbone diagram, is one of the seven basic tools for quality improvement in Japanese industry. It is used to display the factors that affect a particular quality characteristic or problem. For example, the following Ishikawa diagram shows factors affecting the quality of air travel service:

![Figure 8.1 Ishikawa Diagram](image)

In this example, the factors are organized into three categories of service (Pre-flight, In-flight, and Post-flight), which are represented as branches. The factors affecting each of these areas are represented as stems.

An Ishikawa diagram is typically the result of a brainstorming session to improve a product, process, or service. The main goal is represented by a main arrow or trunk, and primary factors are represented as sub-arrows or branches. Secondary factors are then added as stems, tertiary factors as leaves, and so on.

Creating the diagram stimulates discussion and often leads to an increased understanding of a complex problem. Japanese QC Circle members often post Ishikawa diagrams in a display area where they will be accessible to managers and other groups; refer to Rodriguez (1991). In the United States, Ishikawa diagrams are often included in presentations by plant personnel to management or customers.

Traditionally, Ishikawa diagrams have been prepared by hand on paper or chalk boards. This limits the amount of detail that can be added and makes it awkward to update the diagram as an understanding of the process evolves. Manual preparation also restricts the collection and display of data on the diagram, as advocated by Ishikawa (1982).

\(^1\) The Ishikawa diagram is named after its developer, Kaoru Ishikawa (1915-1989), a leader in Japanese quality control; refer to Karabatsos (1989), Kume (1985) and Sarazen (1990).
The ISHIKAWA procedure was designed to overcome these limitations by providing a highly interactive graphics environment (referred to in this section as the ISHIKAWA environment) for creating and modifying Ishikawa diagrams.

In the ISHIKAWA environment you can

- add and delete arrows with a mouse. You can also swap, copy, and so forth.
- highlight special problems or critical paths with line styles and color
- display additional data for each of the arrows in a popup notepad
- display portions of the diagram in separate windows for increasing or isolating detail. You can also divide sections of the diagram into separate Ishikawa diagrams.
- merge multiple Ishikawa diagrams into a single, master diagram
- display any number of arrows and up to ten levels of detail
- foliate and defoliate diagrams dynamically
- save diagrams for future editing
- save diagrams in graphics catalogs or export them to host clipboards or graphics files
- customize graphical features such as fonts, arrow types, and box styles
- obtain online help at any time

If you are using the ISHIKAWA procedure for the first time, the tutorial at the end of this chapter demonstrates some of the basic operations used in the ISHIKAWA procedure. A summary of these operations (and others) can be found in the section “Summary of Operations” on page 708.

For a detailed discussion of each of the operations, see “Details of the ISHIKAWA Environment” on page 708. This chapter includes many tools not presented in the tutorial.

**Terminology**

This section introduces basic operations used in the ISHIKAWA environment and defines terms used to describe the ISHIKAWA procedure. Some details depend on your host, which is the specific system of computing hardware and software you use. For example, all hosts present the ISHIKAWA environment in a system of windows on the host’s display, but the appearance of your windows may differ from the figures in this book. You can find more information in the SAS companion for your host and in your host system documentation.
**Using a Mouse**

On most hosts you can use a *mouse* to point to objects on the display. A mouse is a physical device that controls the location of a *cursor*, which is a small, movable symbol on the display. Due to the precision required, you must use a mouse to perform tasks in the ISHIKAWA environment.

Text is placed relative to the *text* cursor and not the *mouse* cursor (:\). The mouse cursor is always visible, while the text cursor is displayed only when text can be entered (for example, when an arrow is being added).

The mouse also has *buttons* that work like keys on the keyboard. On most hosts, you *select* an object by pointing to it with the mouse and clicking the left button on the mouse. To *click*, press the button down and release it quickly without moving the mouse. To *double click*, click *twice* quickly without moving the mouse. To *drag*, move the mouse while holding down the left mouse button.

*Popup* menus appear to *pop up* on the display when you press a button—usually the right mouse button. Popup menus are convenient to use, since they always appear at the cursor location. Selecting an item from the popup menu, however, is host specific.

For details about using the mouse on your system, consult the SAS companion for your host.

**Using Context-Sensitive Operations**

Basic operations such as add, edit, delete, and move are invoked by activating the mouse near various *hotspots* along the arrows rather than selecting tools from a tools palette. The hotspots are the following context-sensitive areas in the Ishikawa diagram:

- arrow heads, tails, lines, and labels
- window background

Given such evident features, and a rigidly defined structure, the hotspots are not highlighted. The hotspot areas are illustrated in the following figure:

![Figure 8.2 Context-Sensitive Locations (Hotspots)](image)

The dotted, circular region at the right end of the arrow is the arrow head hotspot. Arrows attach to other arrows at the head of the arrow. The dotted, circular region at the left end of the arrow is the arrow tail hotspot. The region that encompasses the arrow line is also hot. Every arrow in the diagram has these hotspots.
The window background is any area inside the window and outside the dotted lines. You use the window background to cancel pending operations (such as adds and moves) and to control global or environment-specific operations (such as decreasing detail and tagging arrows).

When you activate the mouse, the ISHIKAWA environment uses the mouse event (click, double click, drag, or popup) and the hotspot type (head, tail, line, label, or background) to infer the intended operation. The ISHIKAWA environment responds differently depending upon which hotspot you select and how you select it. This is often referred to as context-sensitive behavior.

Context sensitivity allows the ISHIKAWA environment to operate without modes. In a modeless environment like the ISHIKAWA environment, context-sensitive operations reduce the amount of mouse travel (the time and distance spent moving the cursor from the drawing area to the tools palette and back). For example, you do not go to a tools palette to change from add mode to delete mode. This allows you to focus on the diagram rather than on the diagramming tool.

In the ISHIKAWA environment, the primary operations such as add, edit, delete, and move are all operations associated with a specific hotspot and the mouse button. Secondary operations such as zoom, copy, highlight, and so forth operate from context-sensitive popup menus (typically activated using the right mouse button.) Other, less frequently used operations are available from the command bar.

The relationship between these context-sensitive areas, the mouse actions, and the basic ISHIKAWA tools is introduced in the tutorial that follows. A comprehensive discussion of each operation is given in “Details of the ISHIKAWA Environment” on page 708. In addition, the tables in the section “Summary of Operations” on page 708 provide a good overview of how to function inside the ISHIKAWA environment.

**Using the Command Bar**

In addition to the editing tools, the ISHIKAWA environment provides a number of file management, printing, and help facilities. These facilities are located on the pull-down menu associated with the window. The appearance and location of the command bar are host specific. On most hosts, you choose these operations by pulling down a menu from a menu bar using the mouse button. For more details about using the command bar on your system, consult the SAS companion for your host.

---

**Tutorial**

**NOTE:** See Airline Data in the SAS/QC Sample Library.

The following example is used throughout the ISHIKAWA chapters. Later examples illustrate how to add to and modify this diagram. If you are not familiar with the ISHIKAWA procedure, you may want to complete this tutorial before proceeding to “Details of the ISHIKAWA Environment” on page 708. In this tutorial you will learn to create and save a simple Ishikawa diagram.

A task force is studying ways to improve the quality of passenger service for a major airline. After a preliminary discussion, the team concludes that three major areas should be considered: pre-flight service, in-flight service, and post-flight service. This result is to be displayed with the following preliminary Ishikawa diagram:
1. To begin using the ISHIKAWA environment, submit the following SAS statements:

```sas
proc ishikawa;
run;
```

An initial menu appears on your display, as follows:

![Initial Menu](image)

---

**Figure 8.3** Preliminary Ishikawa Diagram

**Figure 8.4** Initial Menu
2. Select **Create a New Ishikawa Diagram** to open a window containing a template for a new Ishikawa diagram.

**Figure 8.5** Starting a New Ishikawa Diagram

The ISHIKAWA environment guides you through the first steps of the diagramming process by prompting you to enter the text for the central line and then the upper left branch. During each step, a message indicating the action required is displayed in the message area for this window. Once you have completed these preliminary steps, you can proceed in any order you want.
3. Initially, the text cursor is positioned inside the box for the trunk. A message is displayed directing you to enter the first line of text for the trunk. Type the word *Quality.*\(^2\)

**Figure 8.6** Labeling the Trunk

Note that the text is placed relative to the text cursor. You can correct mistakes by using any of the keyboard editing keys or cursor navigation keys (for instance, BACK SPACE and ←).

---

\(^2\)You can skip this step, in future diagrams, by pressing RETURN before entering any text.
4. Advance to the next line by pressing RETURN. Now complete the label by entering *Air Travel* and *Service* on separate lines.

**Figure 8.7** Labeling the Trunk (continued)
5. To terminate text entry, press RETURN a second time. The ISHIKAWA environment automatically moves the cursor to the upper left branch. If you made a mistake labeling the trunk, continue with the example. You cannot return to the trunk until you have finished the branch.

**Figure 8.8** Labeling the First Branch
6. Enter the label *Pre-Flight Service*. Press RETURN twice to terminate text entry for this branch. Your window should now look like this:

**Figure 8.9 Completed Branch Label**

Note that when you finish entering text for the upper left branch, the other branches are deleted. These were temporarily displayed as visual cues, and now it is up to you to decide where to add the remaining branches.

---

3You can skip this step, in future diagrams, by pressing RETURN before entering any text.
7. To add the branch labeled *In-Flight Service* to the lower half of the diagram, position the cursor slightly below the point where you want the branch to attach to the trunk and click the mouse button. The branch appears with the text cursor centered inside the box. Enter the first line of text.

*Figure 8.10* Adding a New Branch

If your branch is not positioned where you want it, move the cursor to the appropriate position along the trunk and click. Each time you click, the branch is moved to the new location.

If, on the other hand, the branch is not drawn at all, the cursor was probably too far away from the trunk to be recognized. Move the cursor closer to the trunk and try again.

Enter the label *In-Flight Service* and press RETURN twice to terminate text entry.
8. Next add the branch *Post-Flight Service* to the upper half of the diagram. Position the cursor so that it is just above the point where you want the branch to attach to the trunk and click.

![Figure 8.11 Adding the Last Branch](image)

9. Press RETURN twice to terminate text entry.

Congratulations. You have just completed your first Ishikawa diagram using the ISHIKAWA procedure. In the process you learned to add branches to a diagram using context-sensitive mouse clicks. Future examples will illustrate other context sensitive areas, tools, and popup menus.

The examples that follow will, for the most part, expand on this diagram. To save the diagram, select **File ► Save as ► Data Set** from the command bar. Use SASUSER for the library name and AIRLINE for the data set name. Then select **Save**.

To leave the ISHIKAWA environment and return to the SAS Display Manager, select **File ► Close** from the command bar.
Details of the ISHIKAWA Environment

This chapter presents detailed information about and examples of all the operations available in the ISHIKAWA environment. Some of the examples build upon the diagram created in the tutorial.

Summary of Operations

To invoke the following context-sensitive operations, apply the specified action (mouse event) to the appropriate hotspot, using the left mouse button:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Mouse Event</th>
<th>Hotspot</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Click</td>
<td>Near the intended attachment point</td>
<td>“Adding Arrows”</td>
</tr>
<tr>
<td>Edit</td>
<td>Click</td>
<td>Arrow tail</td>
<td>“Labeling Arrows”</td>
</tr>
<tr>
<td>Move</td>
<td>Click (to pick)</td>
<td>Arrow head</td>
<td>“Moving Arrows”</td>
</tr>
<tr>
<td></td>
<td>Click (to drop)</td>
<td>Near the intended attachment point</td>
<td>“Deleting Arrows”</td>
</tr>
<tr>
<td>Delete</td>
<td>Double click</td>
<td>Arrow head</td>
<td>“Resizing Arrows”</td>
</tr>
<tr>
<td>Resize</td>
<td>Drag</td>
<td>Arrow tail</td>
<td>“Notepads”</td>
</tr>
</tbody>
</table>

To invoke the following operations, make the specified selection from the appropriate context-sensitive popup menu using the right mouse button:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Menu</th>
<th>Selection</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Swap</td>
<td>Head or tail</td>
<td>Swap</td>
<td>“Swapping Arrows”</td>
</tr>
<tr>
<td>Balance</td>
<td>Head or tail</td>
<td>Balance</td>
<td>“Balancing Arrows”</td>
</tr>
<tr>
<td>Hide Detail</td>
<td>Background</td>
<td>&lt; Detail</td>
<td>“Managing Complexity”</td>
</tr>
<tr>
<td>Show Detail</td>
<td>Background</td>
<td>&gt; Detail</td>
<td>“Managing Complexity”</td>
</tr>
<tr>
<td>Zoom</td>
<td>Head or tail</td>
<td>Zoom</td>
<td>“Zooming Arrows”</td>
</tr>
<tr>
<td>Isolate</td>
<td>Head or tail</td>
<td>Isolate</td>
<td>“Isolating Arrows”</td>
</tr>
<tr>
<td>Print</td>
<td>Pull-down</td>
<td>File ▶ Save as ▶ Graph</td>
<td>“Creating Graphics Output Using SAS/GRAPH Software”</td>
</tr>
<tr>
<td>Save</td>
<td>Pull-down</td>
<td>File ▶ Save as ▶ Data Set</td>
<td>“Saving an Ishikawa Diagram for Future Editing”</td>
</tr>
<tr>
<td>Save</td>
<td>Pull-down</td>
<td>File ▶ Save as ▶ Image</td>
<td>“Modifying Arrow Colors and Line Styles”</td>
</tr>
<tr>
<td>Subset</td>
<td>Head or tail</td>
<td>Subset</td>
<td>“Merging Diagrams”</td>
</tr>
<tr>
<td>Copy</td>
<td>Head or tail</td>
<td>Copy</td>
<td>“Modifying Arrow Colors and Line Styles”</td>
</tr>
<tr>
<td>Refresh</td>
<td>Background</td>
<td>Refresh</td>
<td>“Balancing Arrows”</td>
</tr>
<tr>
<td>Unsubset</td>
<td>Background</td>
<td>Unsubset</td>
<td>“Deleting Arrows”</td>
</tr>
<tr>
<td>Unbalance</td>
<td>Background</td>
<td>Unbalance</td>
<td>”</td>
</tr>
<tr>
<td>Undelete</td>
<td>Background</td>
<td>Undelete</td>
<td>”</td>
</tr>
</tbody>
</table>
When applied to the appropriate hotspots, the following actions (mouse events) invoke these context-sensitive operations:

<table>
<thead>
<tr>
<th>Hotspot</th>
<th>Mouse Event</th>
<th>Operation</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow Head</td>
<td>Click</td>
<td>Begin move</td>
<td>“Moving Arrows”</td>
</tr>
<tr>
<td></td>
<td>Double click</td>
<td>Delete</td>
<td>“Deleting Arrows”</td>
</tr>
<tr>
<td></td>
<td>Drag</td>
<td>Resize</td>
<td>“Resizing Arrows”</td>
</tr>
<tr>
<td></td>
<td>Popup menu</td>
<td>Subset</td>
<td>“Modifying Arrow Colors and Line Styles”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Balance</td>
<td>“Balancing Arrows”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Swap</td>
<td>“Swapping Arrows”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Copy</td>
<td>“Merging Diagrams”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Zoom</td>
<td>“Zooming Arrows”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Isolate</td>
<td>“Isolating Arrows”</td>
</tr>
<tr>
<td>Arrow Tail</td>
<td>Click</td>
<td>Edit</td>
<td>“Labeling Arrows”</td>
</tr>
<tr>
<td></td>
<td>Double click</td>
<td>Notepad</td>
<td>“Notepads”</td>
</tr>
<tr>
<td></td>
<td>Drag</td>
<td>Resize</td>
<td>“Resizing Arrows”</td>
</tr>
<tr>
<td></td>
<td>Popup menu</td>
<td>Subset</td>
<td>“Modifying Arrow Colors and Line Styles”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Balance</td>
<td>“Balancing Arrows”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Swap</td>
<td>“Swapping Arrows”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Copy</td>
<td>“Merging Diagrams”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Isolate</td>
<td>“Isolating Arrows”</td>
</tr>
<tr>
<td>Arrow</td>
<td>Click</td>
<td>Add new arrow or</td>
<td>“Adding Arrows”</td>
</tr>
<tr>
<td>Window</td>
<td>Click</td>
<td>complete move operation</td>
<td>“Moving Arrows”</td>
</tr>
<tr>
<td>Background</td>
<td>Drag</td>
<td>Drop (finish) pending action</td>
<td></td>
</tr>
<tr>
<td>Window</td>
<td>Popup menu</td>
<td>Undelete</td>
<td>“Deleting Arrows”</td>
</tr>
<tr>
<td>Background</td>
<td></td>
<td>Unsubset</td>
<td>“Modifying Arrow Colors and Line Styles”</td>
</tr>
<tr>
<td>Background</td>
<td></td>
<td>Unbalance</td>
<td>“Balancing Arrows”</td>
</tr>
<tr>
<td>Background</td>
<td></td>
<td>Show Detail</td>
<td>“Managing Complexity”</td>
</tr>
<tr>
<td>Background</td>
<td></td>
<td>Hide Detail</td>
<td>“Managing Complexity”</td>
</tr>
<tr>
<td>Background</td>
<td></td>
<td>Refresh</td>
<td></td>
</tr>
</tbody>
</table>
The File menu on the command bar can be used to control the following operations:

<table>
<thead>
<tr>
<th>File ►</th>
<th>Description</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>New...</td>
<td>Start a new diagram</td>
<td>“Tutorial”</td>
</tr>
<tr>
<td>Open...</td>
<td>Open an existing diagram</td>
<td>“Reading an Existing Ishikawa Diagram”</td>
</tr>
<tr>
<td>Close</td>
<td>Close the current window</td>
<td></td>
</tr>
<tr>
<td>Merge</td>
<td>Merge in an existing diagram</td>
<td>“Merging Diagrams”</td>
</tr>
<tr>
<td>Save as ► Data Set</td>
<td>Save as a SAS data set</td>
<td>“Saving an Ishikawa Diagram for Future Editing”</td>
</tr>
<tr>
<td>Graph</td>
<td>Print using SAS/GRAPH software</td>
<td>“Creating Graphics Output Using SAS/GRAPH Software”</td>
</tr>
<tr>
<td>Image</td>
<td>Save as an IMAGE, catalog entry</td>
<td>“Save as an IMAGE”</td>
</tr>
<tr>
<td>Export as Bitmap ► File...</td>
<td>Copy to a bitmap file</td>
<td>“Creating Bitmap Graphics Output”</td>
</tr>
<tr>
<td>Customize...</td>
<td>Export options</td>
<td>”Export as Bitmap”</td>
</tr>
</tbody>
</table>

The Edit menu on the command bar can be used to control the following operations:

<table>
<thead>
<tr>
<th>Edit ►</th>
<th>Description</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copy the diagram to host clipboard</td>
<td>“Creating Bitmap Graphics Output”</td>
</tr>
<tr>
<td>Clear...</td>
<td>Clear the window</td>
<td></td>
</tr>
</tbody>
</table>

The View menu on the command bar can be used to control the following operations:
The Help menu on the command bar can be used to control the following operations:

<table>
<thead>
<tr>
<th>Help</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAS System Help</td>
<td>SAS help system</td>
</tr>
<tr>
<td>Using This Window</td>
<td>Ishikawa specific help</td>
</tr>
</tbody>
</table>

### Operations

This section provides details concerning the operations available in the ISHIKAWA environment. The order in which the topics appear is the order in which the operations are typically encountered. Some of the examples in this section build upon the diagram created in the tutorial.

#### Adding Arrows

You add an arrow by pointing with the mouse to the intended attachment point along an existing arrow and clicking the mouse. You control the direction of the new arrow by offsetting the mouse cursor a small distance away from the parent arrow on the side where the new arrow is to appear.

For example, to add upper branches, you offset the cursor slightly above the trunk. To add lower branches, you offset the cursor slightly below the trunk. Likewise, you offset the cursor to the right of the branch to add a right-hand stem and slightly left for a left-hand stem.
If a new arrow is not drawn as you intended (either positionally or directionally), you can easily move or delete it. To delete a new arrow before you have entered any text, click in the background. To move a new arrow before you have entered any text, move the cursor to a new attachment point and click.

Once an arrow is drawn, you are immediately prompted for its label (note the hint, Edit..., displayed on the message line and the appearance of the text cursor at the end of the arrow). See “Labeling Arrows” on page 715, for details on the text editing features of the ISHIKAWA environment.

A diagram can contain up to ten levels of detail, but the number of arrows is limited only by the resolution and size of your graphics display.

**Example**

Continuing with the tutorial example from “Tutorial” on page 699, suppose that you have obtained detailed information for each of the three major service areas, which you want to display by adding stems to the branches of the diagram you previously created. If you closed the ISHIKAWA environment after saving the data set, SASUSER.AIRLINE, you can easily restore the diagram by submitting:

```
proc ishikawa data=sasuser.airline;
run;
```

To add a stem to the left side of the branch labeled *In-Flight Service*, position the cursor so that it is just to the left of the point where you want the stem to attach. Click the mouse. The new arrow (pending text) appears as follows:

![Figure 8.12 Adding the Left Stem](image)
Type the label *Meals* and press RETURN twice.

To add a stem to the right side of the same branch, position the cursor so that it is just to the right of the attachment point. When you click the mouse, your window will appear as follows:

*Figure 8.13* Adding the Right Stem

Type the label *Flight attendants* on two lines and press RETURN to terminate text entry.
Complete the diagram by adding the remaining stems shown in the following window:

Figure 8.14 Stem-Level Diagram

Experiment further by adding several of the leaves shown in the following window. Don’t be concerned if some of the labels collide with each other. Later, you will learn how to move and resize arrows.
Figure 8.15 Leaf-Level Diagram

Labeling Arrows

To edit the label of an existing arrow, click on one of the following areas:

- the label
- the arrow tail (if the arrow does not have a label)
- inside the box for trunk and branch labels

Use your keyboard to enter the text.
On hosts that support direct graphical text entry, the following functions are supported:

- edit keys such as BACK SPACE, DELETE CHAR, DELETE LINE, and RETURN
- cursor navigation keys such as ↑, ↓, → and ←
- the INSERT key to toggle between insert and overstrike modes
- buffers to copy, cut, or paste text into and from external sources

Text entry is terminated whenever you press RETURN on an empty line or exceed the maximum line limit for a label. Text entry is also terminated whenever you click the mouse. This shifts focus away from the editing operation and to the new location.

Labels are restricted to 40 characters per line. The trunk label can have up to five lines, and labels for other levels are limited to two lines.

You can split a line of text into two lines by pressing the RETURN key anywhere inside the line. Likewise, flow a line with the previous line of text by pressing the BACK SPACE key at the beginning of the line.

You can copy the contents of the paste buffer into a label using the PASTE command. This can be helpful when the information for your diagram is available from another source (a flat file, for example). Use the paste buffer to copy the information from that source to your Ishikawa diagram.

Some hosts designate the right mouse button for pasting, some use control keys (like ctrl-p), while others use a designated function key. For more details about using paste buffers with the SAS System, consult the SAS companion for your host.

To paste text into a label, you must first select the label. For existing arrows, select the arrow, position the cursor where you want the text to appear, and then issue the PASTE command. For new arrows pending text entry, simply issue the PASTE command. Any text in the paste buffer that causes the label to exceed its limits is truncated.

When your mouse has a paste key defined, instead of adding an arrow and pasting the text in two operations, use the right mouse button to add the arrow. This action adds a new arrow, automatically copies the label from the paste buffer, and terminates text entry, in a single operation.

**Example**

In the following diagram, the branch labeled *In-Flight Service* has been selected by clicking on the arrow tail. The arrow is highlighted with a narrow dotted line, and the text cursor is positioned over the first character in the label.

---

4Devices such as the IBM3179 do not support the direct graphical text entry mechanism described in these examples. Instead, a text entry window pops up whenever you select an arrow for editing. You must edit the text for the arrow from the dialog box and close the text entry window before the diagram is updated.
To change the label so that the word **Service** appears on a separate line, use the → or ← key to move the cursor to the space before the word **Service**, as shown in the following:

**Figure 8.17** Using Cursor Keys
Now press RETURN to split the text into two lines.

**Figure 8.18** Splitting Text

Remember to delete the space preceding *Service* before pressing RETURN to terminate text entry.

**Moving Arrows**

You move an arrow by picking up the arrow and dropping it at a new location:

- To *pick up* an arrow, position the cursor over the arrow head and click the mouse. The arrow you selected will be highlighted with a narrow dotted line. If the arrow is not highlighted, move the cursor closer to the arrow head and repeat the click.

- To *drop* an arrow, move the cursor slightly to one side of the new attachment point and click (just as though you are adding a new arrow).

When you move an arrow, all its descendants move with it.
To cancel a move after picking up an arrow, click in the background area of the ISHIKAWA window.

**Do not try to drop the arrow back into place by clicking on the arrow head a second time.** A double click on (or near) the arrow head deletes the arrow. To move an arrow a short distance, move the cursor away from the arrow head before clicking to drop the arrow. On some systems the cursor will change shape when you have moved outside the context-sensitive area.

**Example**
As your diagrams develop, you will want to reposition arrows, either because of errors or for aesthetic reasons. The following is an example of an Ishikawa diagram that needs to be modified:

**Figure 8.19 An Inelegantly Arranged Ishikawa Diagram**

The diagram lacks balance, and some of the branches are too close, resulting in collisions and clipping.

One way to improve the diagram is to move the branch for *Pre-Flight Service* toward the center of the trunk. First select the arrow head for this branch.
Then move the cursor to a point just slightly above the trunk near the desired new attachment point.

**Figure 8.21 Locating the New Attachment Point**
Drop the arrow in place by clicking the mouse.

**Figure 8.22** Dropping an Arrow into Position

Next, you should reflect the middle branch to the lower half of the diagram to balance the diagram and eliminate the remaining collisions. Once you have selected the branch, position the cursor slightly below the trunk near the desired new attachment point.
Figure 8.23 Selecting an Arrow for Reflecting

Click the mouse to complete the reflection.

Figure 8.24 Reflecting an Arrow
Note that the stems are reflected with the branch and that their positions (relative to the trunk) are preserved. Finally, the stem labeled *Meals* is incorrectly attached to the branch labeled *Pre-Flight Service* and should be moved to the branch labeled *In-Flight Service*. Once you have selected the stem, move the cursor slightly left of the new attachment point.

**Figure 8.25 Locating the New Attachment Point**

To complete the move, click the mouse.
Apply the same principles when moving an arrow to a new level (for example, to elevate a stem to a branch) or a new diagram (when you have multiple ISHIKAWA windows open).

Deleting Arrows

You can delete an arrow (with all its descendants) by moving the cursor over the arrow head (attachment point) and double clicking. If you accidentally move the cursor while double clicking, it is possible that the arrow will be moved instead of being deleted. In that case, double click on the arrow head again.

You can undo a deletion by moving the cursor to a background area of the window and using the right mouse button to select Undelete from the background popup menu. Repeat the operation when you want to undo several deletions.
Once an arrow has been selected for deletion, you can cancel the pending operation by moving the cursor to a background area of the diagram and clicking the mouse.

The ISHIKAWA environment does not allow you to delete the trunk. To clear the window, select Edit ➤ Clear... from the command bar. Then start a new diagram by selecting File ➤ New... or File ➤ Open....

**Example**

In the following diagram, the branch labeled *Post-Flight Service* has been selected for deletion (note that the branch is highlighted):

**Figure 8.27** Selecting a Branch for Deletion

Without moving the cursor, click on the arrow head a second time to delete the branch.
To undelete the previous deletion, move the cursor to a background area of the window and use the right mouse button to select **Undelete** from the background popup menu.

**Figure 8.29** Undeleting a Branch
Resizing Arrows

You can resize an arrow by holding the mouse button down over the tail end of the arrow and dragging the mouse. As you move the mouse, the arrow is represented by a rubberband line, and a plus sign (+) is drawn to indicate the original position of the arrow tail. The new length is determined by the position of the cursor when you release the mouse.

To cancel a resize operation once you have depressed the mouse button, release the button outside the ISHIKAWA window.

All non-horizontal arrows are constrained to have the same angle. You control the angle by resizing a branch. That is to say, when you resize a leaf, its angle does not change.

Use View ► Ishikawa Settings ► Resize Method ► to control the scope of the resizing operation.

- **Local** resizes only the arrow being dragged.
- **Global** resizes all the arrows at that level to lengths that are proportional to the arrow being dragged. This is the default.
- **Uniform** resizes all arrows at that level to the length of the arrow being dragged.

When you resize an arrow, you also update the default size for all new arrows at that level.

By default, global and uniform resizing applies to all the arrows at the level of the arrow being resized. To restrict resizing to a specific subset of arrows, you can subset them as follows:

- Move the cursor over the arrow head of an arrow to subset that arrow and all its descendants.
- Move the cursor over the arrow tail of an arrow to subset only that arrow (and not its descendants).
- Use the right mouse button to activate the popup menu.
- Select **Subset**.

On some hosts, shift-clicking on the arrow head or tail also subsets an arrow.

Subsetted arrows are indicated by underlined labels. Subsetting is a toggle operation, so to unsubset an arrow, repeat the preceding steps.

To unsubset all the arrows in the diagram, do the following:

- Move the cursor to a background area of the window.
- Use the right mouse button to activate the background popup menu.
- Select **Unsubset**.

Be sure to remove all subsets after you have finished modifying the diagram, since remaining subsets can alter the focus of other operations.

See “Modifying Arrow Colors and Line Styles” on page 755, for more examples of how subsets are used.

---

5Some devices (such as the IBM3179) require you to define a drag key. For more details about dragging on your system, consult the SAS companion for your host.
Example
Arrows that are too long can cause clipping and collisions, as illustrated in the following diagram:

**Figure 8.30** Before Resizing the Diagram

To resize the stems in the upper half of the diagram, proceed as follows:

- Subset the branch for *Pre-Flight Service* by moving the cursor over its arrow head and selecting **Subset**.
- Do the same to *Post-Flight Service*.
- Shorten one of the subsetted stems by dragging its tail to the desired length.
- Remove all subsets by selecting **Unsubset**.
The results are as follows:

**Figure 8.31** After Resizing the Diagram

---

**Swapping Arrows**

Use the swap operation to interchange two arrows in a single operation instead of using two move operations. Swapping has all the flexibility of the move operation; you can swap arrows that have different parents, different levels, or arrows from different diagrams.

Like moving, the results depend upon whether you select the arrow from the arrow head or the arrow tail. When you select the arrow head, the arrow and all its descendants are moved. When you select the arrow tail, only the labels of the selected arrows are interchanged.
Swapping is a two step operation.

- Move the cursor over the arrow head (tail) of one of the arrows to be swapped and select \textit{Swap} from the context-sensitive popup menu.
- Complete the swap by using the mouse to select the comparable end (head or tail) of the second arrow.

To cancel a swap after you have selected the first arrow, click in a background area of the diagram.

\textbf{Example}

To swap the branch labeled \textit{Pre-Flight Service} (and all its descendants) with the branch labeled \textit{Post-Flight Service} in the following diagram, move your cursor over the arrow head of the \textit{Pre-Flight Service} branch and activate the popup menu using the right mouse button. Select \textit{Swap} to begin the operation.

\textbf{Figure 8.32} Swapping Two Arrows

![Swapping Two Arrows Diagram]

To complete the swap, select the arrow head of the \textit{Post-Flight Service} branch.
The completed diagram illustrates how the swap operation simplifies interchanging two arrows.

**Figure 8.34** Completing a Swap
An alternative to swapping the arrows is to move them. However, moving arrows in this situation requires more steps and tends to be more cumbersome than swapping.

**Balancing Arrows**

An Ishikawa diagram is said to be balanced if the sub-arrows attached to each arrow are equally spaced.

To balance the immediate descendants of an arrow and all its descendants, proceed as follows:

- Move the cursor over the arrow head.
- Activate the popup menu using the right mouse button.
- Select **Balance**.

To balance only the immediate descendants of an arrow, select **Balance** from the popup menu for the arrow tail.

You can restore the arrows to their original positions by doing the following:

- Activate the background popup menu using the right mouse button.
- Select **Unbalance**.

The ISHIKAWA environment provides three alternative methods for balancing arrows. Select one of the following choices from the **View » Ishikawa Setting » Balance Method** menu:

- **Preserve order/sides** maintains the order and directions of the sub-arrows but repositions them so they are evenly spaced.

- **Preserve order/alternate sides** maintains the ordering of the arrows but repositions adjacent arrows so that they appear on opposite sides. This is the default.

- **Preserve sides** maintains the side on which the sub-arrows are attached then spaces each side of the arrow independently.
Example
Consider the following unbalanced diagram:

Figure 8.35 An Unbalanced Ishikawa Diagram

To balance only the stems of the branch labeled Branch A, move the cursor over the arrow head and press the right mouse button.
Figure 8.36 Balancing a Branch

Select **Balance** from the arrow head popup menu.

**Figure 8.37 A Balanced Branch**
Note that since the stems are without leaves, selecting either the head or the tail has the same result.

To balance only the five major branches in the preceding diagram without affecting their stems, move the cursor to the tail end of the trunk and select Balance from the popup menu.

**Figure 8.38** Balancing Only the Branches

To balance the entire diagram (from head to tail, so to speak), move the cursor to the head of the trunk and select Balance from the popup menu.
Note that the balancing method used here not only changes the spacing of the stems but reflects them as needed to achieve a balanced appearance. You can control this by specifying a balancing method, as illustrated by the next example.
Example
The following diagram displays an unbalanced branch and a copy of that branch after it was balanced using the **Preserve order/alternate sides** balancing method:

**Figure 8.40** Preserving Order But Alternating Sides

Note that the stems remain in order (1-8) from tail to head, but they now alternate evenly across both sides of the branch. This is the default method used for balancing arrows.
Example
The following diagram displays an unbalanced branch and a copy of that branch after it was balanced using the Preserve order/sides method:

Figure 8.41 Preserving Order and Sides

Note that stems 4-6 remain on the left, stems 1-3 and 7-8 remain on the right, and the order from tail to head is still 1-8. However, the stems are now spaced uniformly.
Example
The following diagram displays an unbalanced branch and a copy of that branch after it was balanced using the **Preserve sides** balancing method:

*Figure 8.42* Preserving Sides

Note that the stems on the left (4-6) are spaced uniformly, and the stems on the right (1-3 and 7-8) are spaced uniformly. The two sides are spaced independently of each other.

Notepads

Ishikawa (1982) and Kume (1985) advocate the display of quantitative information with the arrows in an Ishikawa diagram.

In the ISHIKAWA environment, you can use *Notepad* windows to record or display information associated with each arrow. To open the Notepad window, move the cursor over the arrow tail and double click.
Notes are limited to four lines of text with no more than 40 characters per line. When you save your Ishikawa diagram, your notes are saved with the SAS data set. Later, when you retrieve your diagram, all the notes are restored. You must close the Notepad window before you continue working in the ISHIKAWA environment.

**Example**

In the following figure, double clicking on the *Prompt arrival* stem reveals details about prompt arrival times:
Managing Complexity

A major advantage of the ISHIKAWA environment is that you can quickly organize a highly complex diagram. However, not everyone may be interested in seeing all the details—at least initially.

To increase the level of detail by one level, do the following:

- Move the cursor to a background area of the window, and use the right mouse button to activate the background popup menu.
- Select > Detail. On some hosts, you can press the > key instead of using the popup menu (as long as you are not editing text).

Each time you select > Detail from the background popup menu, the detail increases by one level.

To reverse the process and decrease the level of detail, select < Detail from the popup menu, or press the < key.

Example

You are making an online presentation about factors that influence the quality of air travel service. The following diagram presents too many details to be a good starting point for your audience:

Figure 8.45 Highly Detailed Ishikawa Diagram

A better way to begin is by displaying only the trunk and branches.
Then, at the next stage of your presentation, dynamically foliate the branches with stems, as follows:

**Figure 8.47** Increasing the Level of Detail
The amount of detail is increased by one level.

**Figure 8.48** Increasing the Level of Detail

### Zooming Arrows

A second method for managing a highly detailed Ishikawa diagram is to work with a subsection of the diagram in a separate window. The window and the sub-arrows inside it can be resized independently of the parent window. In all other respects, the information in the two diagrams is linked dynamically. Changes in one window (for instance, moving, adding, and editing arrows) are reflected in the other window.

To zoom an arrow, proceed as follows:

- Move the cursor over the arrow head.
- Activate the popup menu using the right mouse button.
- Select **Zoom**.

To return or unzoom, select **File ▶ Close**.

You can have up to four windows open at one time.

To reduce the amount of window management, you can specify that zoomed diagrams are to be displayed in the current window rather than in new windows by setting **Zoom Window** to **Current** in the **View ▶ Ishikawa Settings ▶ Other...** dialog.
**Example**

The following figure shows a branch labeled *In-Flight Service* after it has been zoomed into a new window:

**Figure 8.49 Z**ooming a Branch

---

**Isolating Arrows**

A third method for managing a highly complex Ishikawa diagram is to view the entire diagram as a collection of smaller diagrams. Any arrow (along with its sub-arrows) can be isolated into a separate diagram in a new window. This diagram can then be easily saved in a separate file.

To isolate a branch as a separate diagram, do the following:

- Move the cursor over the head of the arrow.
- Activate the popup menu using the right mouse button.
- Select **Isolate**.

You can have up to four ISHIKAWA windows open at one time.
Example
Consider the following diagram:

**Figure 8.50** A Highly Detailed Diagram

To isolate the branch labeled *In-Flight Service* as a separate Ishikawa diagram, move your cursor over the head of the arrow. Use the right mouse button to activate the popup menu and select Isolate.

The following figure shows the main diagram in one window and the branch labeled *In-Flight Service* after it has been isolated to another window:
Figure 8.51 Promoting a Branch into a New Diagram

To return to the original diagram, select File ► Close.

Merging Diagrams

You can combine multiple Ishikawa diagrams into a master diagram by using the merge operation. To merge a stored diagram into the current diagram, proceed as follows:

- Select File ► Merge.
- Specify the name of a SAS data set that contains a saved Ishikawa diagram.

Another way to combine diagrams is to open separate ISHIKAWA windows for each sub-diagram then copy them into the master diagram. To copy all or part of an Ishikawa diagram from one window to another, do the following:
• Move the cursor over the head of the arrow.
• Activate the popup menu using the right mouse button.
• Select **Copy**.
• Position the cursor slightly to one side of the new attachment point and click (just as though you are adding a new arrow).

**Example**
Suppose you want to create the following diagram by combining information from diagrams already created by each of the major service areas (Pre-Flight, In-Flight, and Post-Flight) and stored in different SAS data sets:

*Figure 8.52* A Completed Master Diagram
First, use the ISHIKAWA environment to create the trunk for the new master diagram.

**Figure 8.53** Starting a Master Diagram

Select **File ▶ Merge** from the command bar to open the File Requestor dialog.

**Figure 8.54** Member Selector
Specify the name of the data set for *Pre-flight services* and press **Open**.

Now click on a point along the trunk where this sub-diagram is to attach.

*Figure 8.55* Constructing a Master Diagram

To complete the diagram, repeat the process for the remaining branches.

**Creating Graphics Output Using SAS/GRAF Software**

One way to create a hard copy of your Ishikawa diagram is to send it to a graphics device using SAS/GRAF software. To do this, you should submit a GOPTIONS statement to direct the graphics output to the appropriate location and control the output format *before you invoke the ISHIKAWA environment*. For example, the following GOPTIONS statement directs the output to a PostScript device:

```
goptions target=psl noprompt;
```

If you do not specify a target device before invoking the ISHIKAWA environment, you will be prompted for one before the graph is generated.

In the ISHIKAWA environment, when you are ready to route your output to a hard copy device, select **File ➤ Save as ➤ Graph**. This opens a dialog that enables you to customize various aspects of your graph.
To save the diagram to the default graphics catalog in the WORK library (WORK.GSEG), simply press **OK** and close the dialog. The default member name is ISHIKAWA.

To save the diagram to a different graphics catalog, select **Save...** and then use the Member selector window to specify a library, a SAS catalog, and a member name.

When sending a diagram directly to an output device, you can ignore the member name entirely.

To save to your own graphics catalog, select **Save...** and then use the Save a member selection window to specify a catalog and data set name. Simply select **OK** when you want to save your diagram to the default graphics catalog (WORK.GSEG). When sending a diagram directly to an output device, you can use **OK**.

You must specify two SAS/GRAPH fonts for drawing the labels in the hard copy of the diagram. The hardware fonts used in the ISHIKAWA environment cannot be used for your hard copy. The **primary** font and size are used for the first three levels of text. The **secondary** font and size are used for the remaining levels of text.

To change fonts, enter a valid SAS/GRAPH font name in the font field or click on the button to the right of the font field to display a font requestor dialog. The default font is SIMPLEX.

You can specify the height of the text directly in the height field (in screen percent units), or you can click on the button to the right of the field to request an **absolute** height or a **relative** height.
Select **Absolute** when you want the font height in the output to be the same height as the font height used in the ISHIKAWA environment even if the output window and the ISHIKAWA window differ in size. Select **Relative** to maintain the same font height to window size proportion in both the ISHIKAWA window and the output window. The numeric value entered in the height field after either choice is a screen percent unit. The default text height is **absolute**.

Use the Fill Text Boxes and Draw Shadow check boxes to suppress the box fills and box shadows from the output. They cannot be used to add these features to the hard copy if they were not present in the ISHIKAWA window.

Use the **Use background color** check box to indicate whether the background color from the ISHIKAWA environment is used in the output. This option is useful when you are sending your diagram to a color device and you want the background in your hard copy to match that of your ISHIKAWA environment.

Use the Switch Black and White check box to interchange black and white when the diagram is sent to the output device. This option is useful when you send your diagram from a white-on-black display to a black-on-white hard copy device.

Click on **OK** to generate the hard copy output or click on **Cancel** to quit.
Creating Bitmap Graphics Output

A second way to create a hard copy of your Ishikawa diagram is to export it as a bitmap to one of the following:

- the host graphical clipboard
- an external bitmap file
- a SAS/GRAPH Image catalog entry

To copy the Ishikawa diagram as a bitmap to the host clipboard, select **Edit ▶ Copy**. The results are host specific. For more details about copying to the host clipboard on your system, consult the SAS companion for your host.

To export the Ishikawa diagram to a bitmap file using SAS/GRAPH software, select **File ▶ Export as Bitmap ▶ File**.

**Figure 8.58** Export File Requestor

The appearance of this dialog will be host specific. For more details about the format of this dialog on your system, consult the SAS companion for your host.

To save the Ishikawa diagram as an IMAGE entry in a SAS catalog, select **File ▶ Save as ▶ Image**.
You must specify a SAS catalog in which to save the IMAGE entry as well as a name for the object.

When exporting your diagram to a bitmap or saving to a SAS/GRAPH IMAGE entry, you can have the colors mapped so that color diagrams are saved in black on white or white on black. You do not have to make those changes to the diagram yourself. Use File ➤ Export as Bitmap ➤ Customize... to display the following dialog:

Select **Black on white** to convert the output to a black diagram on a white background. This is useful when the diagram is being exported to a document.

Select **White on black** to convert the output to a white diagram on a black background. This is useful when the diagram is being exported for display on a black and white terminal.
Modifying Fonts

By default, the ISHIKAWA environment uses the same hardware font as the SAS windowing environment. However, you have the option of specifying two different font styles/sizes.

The *primary* font is used for labeling arrows in the first three levels of the diagram. The *secondary* font is used for labeling arrows in the remaining levels. You will typically use a smaller font in the detailed (secondary) areas of the diagram.

To change a font, select **View ► Ishikawa Settings ► Primary Fonts...** or **View ► Ishikawa Settings ► Secondary Fonts...** to display the Font Requestor window, as follows:

![Figure 8.61 Font Requestor](image)

The layout of the Font requestor window is host specific. Typically, it will contain a list of available fonts and sizes displayed in a scrollable region. Refer to your host documentation for specific information regarding the format of this dialog.

To change fonts, select a font from the list.

You must close the Font Requestor window before you can proceed. Select **OK** to apply the font or **Cancel** to cancel the dialog.

To customize your session so that these fonts are permanently associated with the ISHIKAWA environment, select **View ► Save Attributes** from the command bar.
Modifying Box Colors

By default, the box fill (background) color is empty and the shadow (outline) color is the same as the arrow color.

To modify the colors associated with trunk and branch boxes, select View ➤ Ishikawa Settings ➤ Colors… A dialog, similar to the following, is displayed:

![Figure 8.62 Colors Dialog](image)

To change the fill color of all the boxes in the Ishikawa diagram, do the following:

- Select a color from the color palette.
- Select Infill.

Once modified, the fill color is unaffected by changes in the arrow color. To return the box to an empty fill, proceed as follows:

- Select the current infill color from the color palette (if it is not already the current color).
- Select Infill.

To change the shadow color of the boxes, select Shadow and follow the same procedure.

Select OK to close the dialog or Cancel to cancel the changes.

Modifying Arrow Colors and Line Styles

The ISHIKA WA environment provides a line style palette and a color palette that you can use to customize the arrows in your Ishikawa diagram. Select View ➤ Palettes to activate both palettes.  

---

6 You cannot directly modify the colors of individual boxes from this dialog.
7 If you are working on a black-and-white terminal, you should not use the color palette.
To specify the arrows to which color and line selections apply, subset them with the subset function. To toggle an arrow in or out of the list of subsetted arrows, do the following:

- Use the right mouse button to display the arrow head or the arrow tail popup menu. To subset an arrow and all its descendants, use the arrow head popup menu. Use the arrow tail popup menu to subset an arrow without any descendants.

- Select Subset.

The labels of all subsetted arrows are underlined.

On some hosts, shift-clicking on the arrow head or tail will also subset the arrow. You can subset any combination of arrows in the diagram.

You can change the color of all the subsetted arrows by selecting the desired color in the color palette with the mouse. Likewise, use the line palette to control the style and width of the arrows.
To unsubset all the arrows in the diagram, do the following:

- Move the cursor to a *background* area of the ISHIKAWA window.
- Use the right mouse button to activate the background popup menu.
- Select **Unsubset** from the popup menu.

To unsubset a specific arrow in the diagram, select **Subset** from the context-sensitive popup menu for the arrow head or tail.

Be sure to remove all subsets once you have finished modifying the diagram, since subsets affect the focus of many other operations.

**Example**
Continuing with the diagram from the previous section, subset the trunk using the arrow tail popup menu.

*Figure 8.64* Subsetting Only the Trunk

Note that only the trunk is subsetted (as indicated by the underlined label).
Figure 8.65 Subsetting Only the Trunk (continued)

When you select a line style from the line palette, only the line style of the subsetted arrow is changed.

Figure 8.66 Modified Diagram
Alternately, if you subset the trunk using the arrow head popup menu, all of the arrows in the diagram are subsetted.

**Figure 8.67** Subsetting the Entire Diagram
Note that all of the labels in the diagram are now underlined.

**Figure 8.68** Subsetting the Entire Diagram *(continued)*

Now, when you select a new line style from the line palette, all the arrows are drawn with this line style.
To remove the subset from the Pre-Flight Service branch and all its descendants, select Subset from the arrow head popup menu.
This removes the underlines from the labels in these arrows.

**Figure 8.71** Selectively Removing Subsets (continued)

You can now use the line palette to change the line style for all the arrows in the diagram with the exception of the *Pre-Flight Service* branch and its descendants:
The same principles apply when making color changes—simply use the color palette instead of the line style palette.

**Modifying Text Colors**

By default, labels have the same color as the arrow. To modify the text color independently of the arrow color, select **View ➤ Ishikawa Settings ➤ Colors…**. The Customize Color window, similar to the following, will open:
To change the text color of all the arrows\textsuperscript{8} in the Ishikawa diagram, do the following:

- Select a color from the color palette.
- Select Text.

Once modified, the text color is unaffected by changes to the arrow color. To relink the text color to the arrow color, do the following:

- Select the current text color from the color palette (if it is not already the current color).
- Select Text.

Select OK to close the dialog window. To cancel the changes, select Cancel.

\textsuperscript{8} You cannot directly modify the text color for individual arrows from this dialog.
Modifying Arrow Heads

To modify the characteristics of the arrow heads in your diagram, select View ➤ Ishikawa Settings ➤ Arrows…. This opens the following dialog:

**Figure 8.74** Arrows Dialog

![Customize Arrows](image)

The dialog controls the characteristics of all arrow heads. Arrow heads cannot be modified individually.

Arrow heads can be tapered, flush, or empty. Use the sliders labeled Length and Width to control the length and width of the arrow heads. Move the sliders to the right to increase the length/width of the arrow head and to the left to decrease the length/width.

Removing arrow heads increases the readability of a highly detailed diagram. Use the Display slider to control the level at which arrow heads are displayed. Move the slider to the extreme left to remove all the arrow heads and to the extreme right to display all the arrow heads. Use the intermediate settings to select a threshold level of detail, above which arrow heads are not displayed. By default, arrow heads are displayed for all levels.

Select OK to close the window. To cancel the changes, select Cancel.

Modifying Environmental Attributes

You can modify other features of the ISHIKAWA environment such as zooming, mouse sensitivity, and shadow attributes by selecting View ➤ Ishikawa Settings ➤ Other… to open the following dialog:
Figure 8.75 Others Dialog

**Zoom Window** controls whether the zoom operation opens a new window or draws in the current window. Select **Current** to reduce the amount of window management required.

The **Shadow Type** button controls the type of shadow that is drawn around the trunk and branch boxes.

- **Bevel 1** draws a beveled edge box with a lower-right light source.
- **Bevel 2** draws a beveled edge box with an upper-left light source.
- **Drop** draws a box with a drop shadow. This is the default.
- **None** suppresses the shadow.

The **Shadow Width** slider controls the shadow width if the boxes have shadows or the outline width when boxes are displayed without shadows. Move the slider to the right to increase the shadow width and to the left to decrease the width.

The **Add Sensitivity** slider controls how closely you must position the cursor to an existing arrow before a mouse click results in an add arrow operation. Move the slider to the right to increase the size of the context-sensitive area and to the left to reduce the size of the context-sensitive area.

The **Select Sensitivity** slider controls how closely you must position the cursor to an existing arrow before a mouse click results in an edit, delete, move, or popup arrow operation. Operate this slider in the same manner as the **Add Sensitivity** slider.

### Saving an Ishikawa Diagram for Future Editing

You must save your Ishikawa diagram as a SAS data set if you intend to edit it in the future with the ISHIKAWA environment. The ISHIKAWA environment does not reconstruct Ishikawa diagrams by reading graphics entries (GRSEG) from SAS catalogs.

Select **File ➤ Save As ➤ Data Set** to activate the Data Set Requestor window.
A list of SAS *librefs* is displayed in the Libraries tree in the left region of the dialog. Begin by selecting a libref from the list. A libref refers to a permanent SAS data library located on your host system. For example, the default SASUSER libref (on most hosts) points to a directory called SASUSER, located under the working directory of your current SAS session. Any data sets saved with the libref SASUSER will be saved in that directory.

To direct your SAS data sets to a different directory, select the Create new library tool icon to open the New Library dialog. Use this dialog to specify the directory and assign a libref to that directory.

To select the libref SASUSER, move your cursor over that entry in the list and click. The region to the right of the Libraries tree is used to display any existing SAS data sets in that library.

To save your diagram in an existing SAS data set, use the mouse to click on an entry in the list. The member name field will be updated to reflect your choice. If you want to save your diagram in a new SAS data set, move your cursor to the member name field and type the new name (in this example, SERVICE).

Select Save to save the diagram and return to the ISHIKAWA environment or select Cancel to cancel the save.

**Reading an Existing Ishikawa Diagram**

To enter the ISHIKAWA environment and resume editing an existing diagram, you must have previously saved the diagram as a SAS data set. The ISHIKAWA environment does not allow you to modify graphs stored in SAS/GRAPH catalogs.

You can specify the name of this data set when you establish the ISHIKAWA environment with the following statements:

```sas
proc ishikawa data=libref.dataset;
run;
```

Alternatively, the ISHIKAWA environment will prompt you for a data set after you invoke the environment with the following statements:

```sas
proc ishikawa;
run;
```
When you specify a data set in the PROC statement, the ISHIKAWA environment is initialized and your diagram is displayed up to the branch level. The message area will indicate if any additional detail is hidden. You can edit your diagram even if some of the diagram is hidden. To add or remove detail one level at a time, select > Detail or < Detail from the background popup menu.

When you do not specify a data set in the PROC statement, you will see the following menu:

**Figure 8.77** Initial Menu

Since you are editing an existing diagram rather than starting a new diagram, select Edit an Existing Diagram to activate the Member Selector window.

**Figure 8.78** Input Member Selector

Use the Member Selector window to specify an input SAS data set. For information on how to specify the SAS data set name, follow the steps outlined in “Saving an Ishikawa Diagram for Future Editing” on page 766.

To establish the ISHIKAWA environment and display the diagram you have selected, select Open. The diagram is displayed up to the branch level.

To quit or start a new diagram, return to the main menu by selecting Cancel.
Displaying Multiple Ishikawa Diagrams

The ISHIKAWA environment enables you to view multiple Ishikawa diagrams simultaneously for side-by-side comparisons of different diagrams. You can also use this feature to transfer information between diagrams, since the move and copy operations function across windows. You can have up to four ISHIKAWA windows open at one time.

To open a window for another Ishikawa diagram, select File ➤ Open. This will display the Member Selector window, which you can use to specify the name of the input SAS data set for the other Ishikawa diagram.

You can also start new diagrams while displaying other Ishikawa diagrams. To open a window for a new Ishikawa diagram, select File ➤ New. This opens an ISHIKAWA window with a template for a new diagram.

**Example**

The following figure shows an Ishikawa diagram for *Quality Air Travel Service* after an initial brainstorming session:

![Ishikawa Diagram](image)

The current diagram and another Ishikawa diagram can be viewed simultaneously by selecting File ➤ Open from the command bar.
In this situation, displaying both diagrams concurrently emphasizes the improved understanding of the process. It also enables you to transfer information from one diagram to another.
The following is a complete list of the variables in output SAS data sets created by the ISHIKAWA environment:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>LEVEL</em></td>
<td>Num</td>
<td>8</td>
<td>Level of detail</td>
</tr>
<tr>
<td><em>TEXT1</em></td>
<td>Char</td>
<td>40</td>
<td>First line of label</td>
</tr>
<tr>
<td><em>TEXT2</em></td>
<td>Char</td>
<td>40</td>
<td>Second line of label</td>
</tr>
<tr>
<td><em>TEXT3</em></td>
<td>Char</td>
<td>40</td>
<td>Third line of label</td>
</tr>
<tr>
<td><em>TEXT4</em></td>
<td>Char</td>
<td>40</td>
<td>Fourth line of label</td>
</tr>
<tr>
<td><em>TEXT5</em></td>
<td>Char</td>
<td>40</td>
<td>Fifth line of label</td>
</tr>
<tr>
<td><em>NOTE1</em></td>
<td>Char</td>
<td>40</td>
<td>First line of note</td>
</tr>
<tr>
<td><em>NOTE2</em></td>
<td>Char</td>
<td>40</td>
<td>Second line of note</td>
</tr>
<tr>
<td><em>NOTE3</em></td>
<td>Char</td>
<td>40</td>
<td>Third line of note</td>
</tr>
<tr>
<td><em>NOTE4</em></td>
<td>Char</td>
<td>40</td>
<td>Fourth line of note</td>
</tr>
<tr>
<td><em>RELPOS</em></td>
<td>Num</td>
<td>8</td>
<td>Relative arrow position</td>
</tr>
<tr>
<td><em>SIDE</em></td>
<td>Char</td>
<td>1</td>
<td>Side arrow attaches to parent</td>
</tr>
<tr>
<td><em>ANGLE</em></td>
<td>Num</td>
<td>8</td>
<td>Angle (non-horizontal arrows)</td>
</tr>
<tr>
<td><em>LWIDTH</em></td>
<td>Num</td>
<td>8</td>
<td>Line width</td>
</tr>
<tr>
<td><em>LSTYLE</em></td>
<td>Num</td>
<td>8</td>
<td>Line style</td>
</tr>
<tr>
<td><em>LCOLOR</em></td>
<td>Char</td>
<td>8</td>
<td>Line color</td>
</tr>
</tbody>
</table>
Chapter 8: The ISHIKAWA Procedure

Only the variables _LEVEL_ and _TEXT1_ are required in the input data set for the ISHIKAWA procedure. Each observation in the input data set corresponds to a particular arrow in the diagram. The order of the observations is critical because it defines the relationships of the arrows.

- The trunk is always the first observation.
- The remaining observations are ordered so that leaves are nested within stems, stems are nested within branches, and branches are nested within the trunk.
- The variable _LEVEL_ is numeric and indicates the level within the diagram. The trunk has a level of 0, branches have a level of 1, stems have a level of 2, and so on.
- The first line of text in a label is stored as _TEXT1_, the second as _TEXT2_, and so on.

Example

The following is a partial listing of the SAS data set used to create the Ishikawa diagram shown in Figure 8.15:

```sas
data ishplane;
   length _text1_ _text2_ _text3_ $ 40 _side_ $ 1;
   input _level_ _text1_ & _text2_ & _text3_ & _relpos_ _side_;
   datalines;
   0 Quality Air Travel Service -1.00 .
   1 Pre-Flight Service . . 0.26 T
   2 Competitive fares . 0.68 R
   2 Convenient departure times . 0.18 R
   2 Quick ticketing . 0.43 R
   2 Frequent flier courtesies . 0.81 L
   1 In-Flight Service . . 0.61 B
   2 Prompt departures . 0.21 R
   2 Comfortable seating . 0.35 L
;
```

Note the structure of this data set:

- The trunk (always the first observation) has a _LEVEL_ value of zero.
- All subsequent observations for which _LEVEL_ is equal to one are branches that emerge from the trunk.
• Observations 4 and 5 are both leaves that emerge from the preceding stem (observation 3).
• Likewise, leaves 7 and 8 emerge from the preceding stem (observation 6).

You can use this data set as a way of extracting text and notepad information from the diagram.

---

**Syntax**

There are only three options that can be specified in the PROC ISHIKAWA statement, since the ISHIKAWA procedure is primarily a user-driven procedure.

**DATA=SAS-data-set**

identifies the name of a SAS data set that specifies an existing Ishikawa diagram. By default, the procedure will prompt you to edit an existing Ishikawa diagram or start a new one. When you specify the DATA= option, the procedure bypasses this initial menu. For example, the following statements simplify editing an existing Ishikawa diagram saved in a SAS data set:

```sas
proc ishikawa data=work.airline;
run;
```

**NEW**

starts a new Ishikawa diagram. By default, the procedure will prompt you to edit an existing Ishikawa diagram or start a new one. When you specify the NEW option, the procedure bypasses this initial menu and starts with a new diagram. Do not specify any other options when using the NEW option. For example, the following statements simplify starting a new Ishikawa diagram:

```sas
proc ishikawa new;
run;
```

**NOFS**

allows you to create hard copies of Ishikawa diagrams saved as SAS data sets without invoking the interactive features of the procedure. You must specify the DATA= option when you use the NOFS option. For example, the following statements create a hard copy of the Ishikawa diagram saved in the SAS data set `work.airline`:

```sas
goptions dev=psl noprompt;
proc ishikawa data=work.airline nofs;
run;
```
Example 8.1: Quality of Air Travel Service
Example 8.2: Integrated Circuit Failures
Example 8.3: Photographic Development Process

![Photographic Development Process diagram](image)

References


Subject Index

Ishikawa diagrams
  adding arrows, 711–715
  aligning arrows, 732–739
  arrow colors, 755, 757–763
  arrow heads, 765
  arrow line style, 755, 757–763
  arrow line width, 755, 757–763
  balancing arrows, 732–739
  box color, modifying, 755
  box shadow, 765
  clipboard graphics, 752, 753
  color, arrow, 755, 757–763
  color, box, 755
  color, palette, 755, 757–763
  color, text, 763
  context-sensitive operations, 698, 708, 709
  data collection, 739, 740
  data presentation, 739, 740
  deleting arrows, 724–727
  detail, decreasing, 741–743
  detail, increasing, 741–743
  Edit menu, 710
  editing existing diagrams, 767, 768
  editing labels, 715–718
  examples, 774
  examples, Integrated Circuit Failures, 775
  examples, Photo Development Process, 776
  examples, Quality of Air Travel Service, 774
  exporting diagrams, 752, 753
  File menu, 710
  fonts, modifying, 754
  Help menu, 711
  highlighting arrows, 755, 757–763
  history, 696
  hotspots, 698, 708, 709
  isolating arrows, 745, 746
  labeling arrows, 715–718
  line palette, 755, 757–763
  managing complexity, 741–749
  merging diagrams, 746–749
  mouse sensitivity, 765
  moving arrows, 718–724, 729–739
  multiple diagrams, displaying, 746–749, 769
  notepads, 739, 740
  output, bitmaps, 752, 753
  output, graphics, 749–751
  output, SAS data set, 766, 767, 771–773
  overview, 696

palettes, colors, 755, 757–763
palettes, fonts, 754
palettes, lines, 755, 757–763
printing, bitmaps, 752, 753
printing, SAS/GRAPH output, 749–751
resizing arrows, 727–729
SAS data set, input, 767, 768, 771–773
SAS data set, output, 766, 767, 771–773
saving, bitmaps, 752, 753
saving, clipboard graphics, 752, 753
saving, graphics, 749–751
saving, SAS data set, 766, 767
subsetting arrows, 727–729, 755, 757–763
summary of operations, 708–711
swapping arrows, 729–732
syntax, 773
tagging arrows, 727–729, 755, 757–763
terminology, 697
text entry, 715–718
tutorial, 699, 700, 702–707
undo, 724–727
View menu, 710
zooming arrows, 743–745, 765
Syntax Index

Ishikawa diagrams
  adding arrows, 711–715
  aligning arrows, 732–739
  balancing arrows, 732–739
  data collection, 739, 740
  data presentation, 739, 740
  deleting arrows, 724–727
  detail, decreasing, 741–743
  detail, increasing, 741–743
  editing existing diagrams, 767, 768
  editing labels, 715–718
  exporting diagrams, 752, 753
  fonts, modifying, 754
  highlighting arrows, 755, 757–763
  isolating arrows, 744–746
  labeling arrows, 715–718
  managing complexity, 741–749
  merging diagrams, 746–749
  moving arrows, 718–724, 729–739
  notepads, 739, 740
  output, bitmaps, 752, 753
  output, graphics, 749–751
  output, SAS data set, 766, 767, 771–773
  overview, 696
  printing, bitmaps, 752, 753
  printing, SAS/GRAPH output, 749–751
  resizing arrows, 727–729
  SAS data set, input, 767, 768, 771–773
  SAS data set, output, 766, 767, 771–773
  saving, bitmaps, 752, 753
  saving, clipboard graphics, 752, 753
  saving, graphics, 749–751
  saving, SAS data set, 766, 767
  subsetting arrows, 727–729, 755, 757–763
  summary of operations, 708–711
  swapping arrows, 729–732
  tagging arrows, 727–729, 755, 757–763
  terminology, 697
  text entry, 715–718
  undo, 724–727
  zooming arrows, 743, 744, 765

ISHIKAWA procedure, 773
  syntax, 773