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Overview: PM Procedure

The PM procedure is an interactive procedure that can be used for planning, controlling, and monitoring a
project. The syntax and the scheduling features of PROC PM are virtually the same as those of the CPM
procedure. However, because the PM procedure is interactive, there are a few extra options that are available
and a few other options that have a default behavior that is different from the CPM procedure. These
differences are noted in the section “Syntax: PM Procedure” on page 306 and the section “Summary of
Differences” on page 329. One major difference is that only the Activity-On-Node representation of the
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project is supported in PROC PM. In other words, TAILNODE and HEADNODE statements from PROC
CPM are not supported.

For a complete description of the syntax and the scheduling algorithm for the CPM procedure, see Chapter 4,
“The CPM Procedure.”

When PROC PM is invoked with the activity network representation, an interactive window is opened that
displays a Table View of the project on the left and a Gantt View of the project on the right. You can add
activities and edit the project data by using the Table View. You can also use the Gantt View to move activities,
change the durations of the activities, and add precedence constraints between the activities. These features
are described in the section “Details: PM Procedure” on page 309.

The PM procedure is designed to facilitate its inclusion in a Project Management application. Any changes that
are made to the activity network or to the activity durations, resource requirements, alignment specifications,
and other activity information need to be saved in the resulting Schedule output data set. Further, you should
be able to use this output data set as input to a future invocation of PROC PM and continue to manage
the project. Thus, there are some differences in the design of the Schedule data set (defined in Chapter 4,
“The CPM Procedure”) to enable the integration of PROC PM into a Project Management application. The
differences between the Schedule data sets in the two procedures are described in the section “Schedule Data
Set” on page 329.

Getting Started: PM Procedure

Consider the simple software development project described in the “Getting Started” section of Chapter 4,
“The CPM Procedure.” Recall that the Activity data set, SOFTWARE, contains the activity descriptions,
durations, and precedence constraints. The following statements (identical to the PROC CPM invocation)
initialize the project data and invoke the PM procedure.

data software;
input Descrpt $char20.
Duration 23-24
Activity $§ 27-34
Succesrl $ 37-44
Succesr2 $ 47-54;

datalines;
Initial Testing 20 TESTING RECODE
Prel. Documentation 15 PRELDOC DOCEDREV QATEST
Meet Marketing 1 MEETMKT RECODE
Recoding 5 RECODE DOCEDREV OQATEST
QA Test Approve 10 OQATEST PROD

Doc. Edit and Revise 10 DOCEDREV PROD
Production 1 PROD

4
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proc pm data=software
out=introl
interval=day
date='01lmar04'd;
id descrpt;
activity activity;
duration duration;
successor succesrl succesr2;
run;

When you invoke the PM procedure, the PM window appears (see Figure 5.1), consisting of the Table View
and the Gantt View of the project. The activities are listed in the order in which they are defined in the
Activity data set. The two views are separated by a dividing line that can be dragged to the left or right,
controlling the size of the two views. Further, the two views scroll together in the vertical direction but can
scroll independently in the horizontal direction.

The Table View contains several editable columns (in white) that can be used to edit the project data as well
as add new activities to the project. Some of the columns (in gray), such as the Schedule times, are not
editable. The Gantt View contains a Gantt chart of the project and displays the precedence relationships
between the activities. You can use the Gantt View to add or delete precedence constraints between activities
and to change the durations or alignment constraints of the activities by dragging the schedule bars. Details
of the interface are described in the section “Details: PM Procedure” on page 309.

Figure 5.1 Software Development Project
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Syntax: PM Procedure

The syntax for PROC PM is virtually identical to that for PROC CPM. The main difference is that you replace
the PROC CPM statement with the PROC PM statement.

The TAILNODE and HEADNODE statements from PROC CPM are not supported in PROC PM.
The form of the PROC PM statement is
PROC PM options ;

PROC PM Statement
PROC PM options ;

All the options that are available in the PROC CPM statement can also be specified in the PROC PM statement.
See Chapter 4, “The CPM Procedure,” for details. However, there are a few additional options available with
PROC PM, and some of the other PROC CPM options are not needed as they are the default behavior in
PROC PM. See “Summary of Differences” on page 329 for more details about these differences.

Options Specific to PROC PM

The following options can be specified on the PROC PM statement.

NODISPLAY
invokes the procedure in a noninteractive mode. The schedule for the project is still computed and
the requested output data sets are created and saved. However, the PM window is not displayed. This
option is useful for scheduling large projects that do not need to be updated interactively. Note that
invoking PROC PM with the NODISPLAY option is similar to invoking PROC CPM; however, because
the format of the Schedule output data set is different for the two procedures, you might see some
differences in the order and content of the observations. See “Schedule Data Set” on page 329 for
details.

PROJECT=SAS-data-set
identifies a SAS data set that can be used to save and restore preferences that control the project view.
For example, preferences such as the font, column order, column widths, filters, and so forth, can be
saved from one invocation to another. See “PROJECT Data Set” on page 325 for more details about
this data set and the preferences that can be saved in it.

PROJECTNAME-=string’
PROJNAME-=string’
NAME-=string’

specifies a descriptive string identifying the name of the project. This string is used to label the PM
window.
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SUMMARYNAME-="string’

SUMMARY="string’

PROJECTSUMMARY=string’
specifies a descriptive string identifying the summary task. By default, when there is more than one
root parent activity in a project, PROC PM creates a summary task named “Summary” (or “Project
Summary” if the input format for the activity variable is 15 or greater). So, if there is already a child
activity named “Summary” (or “Project Summary”) in the input data, the resulting schedule forms a
cycle. The SUMMARYNAME-= option enables you to override the default by specifying a different
name for the summary task, thereby avoiding the previously described problem.

Default Options for PROC PM Statement
The following options of PROC CPM are turned on by default in PROC PM.

ADDACT

ADDALLACT

EXPAND
indicates that an observation is to be added to the Schedule output data set (and the Resource Schedule
output data set) for each activity that appears as a value of the variables specified in the SUCCESSOR or
PROJECT statements without appearing as a value of the variable specified in the ACTIVITY statement.
In other words, the Schedule output data set produced by PROC PM contains one observation for every
activity that appears as a value of the ACTIVITY, SUCCESSOR, or PROJECT variables (as long as it
has not been deleted in the current invocation of the procedure). It also contains an observation for
every activity that is added to the project using the graphical user interface.

XFERVARS
indicates that all relevant variables are to be copied from the Activity data set to the Schedule data set.
The procedure carries over to the output data set all the relevant variables from the input data set. Thus,
the Schedule output data set contains all the project information that is necessary to schedule it.

Default Options for ACTUAL Statement

AUTOUPDT
requests that the procedure assume automatic completion (or start) of activities that are predecessors to
activities already completed (or in progress).

ESTIMATEPCTC
ESTPCTC
ESTPCTCOMP

ESTPROG
indicates that a variable named PCT_COMP is to be added to the Schedule output data set (and the
Resource Schedule output data set) that contains the percent completion time for each activity (for
each resource used by each activity) in the project.

SHOWFLOAT
indicates that activities that are completed or in progress have nonzero float.
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Default Options for PROJECT Statement

ADDWBS
WBSCODE

WBS
indicates that the PM procedure is to compute a WBS code for the activities in the project using the
project hierarchy structure specified. This code is computed for each activity and stored in the variable
WBS_CODE in the Schedule output data set.

DESCENDING

DESC
indicates that, in addition to the ascending sort variables (ES_ASC, LS_ASC, and SS_ASC) that are
requested by the ESORDER, LSORDER, and SSORDER options, the corresponding descending sort
variables (ES_DESC, LS_DESC, and SS_DESC, respectively) are also to be added to the Schedule
output data set.

ESORDER

ESO
indicates that a variable named ES_ASC is to be added to the Schedule output data set; this variable can
be used to order the activities in such a way that the activities within each subproject are in increasing
order of the early start time. Note that this order is not necessarily the same as the one that would be
obtained by sorting all the activities in the Schedule data set by E_START.

LSORDER

LSO
indicates that a variable named LS_ASC is to be added to the Schedule output data set; this variable can
be used to order the activities in such a way that the activities within each subproject are in increasing
order of the late start time.

ORDERALL

ALL
is equivalent to specifying the ESORDER and LSORDER options (and the SSORDER option when
resource constrained scheduling is performed).

SSORDER

SSO
indicates that a variable named SS_ASC is to be added to the Schedule output data set; this variable can
be used to order the activities in such a way that the activities within each subproject are in increasing
order of the resource-constrained start time.
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Details: PM Procedure

Figure 5.2 LAN Selection Project
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The PM window provides the standard editing and viewing functions of a typical project management tool. It
can be displayed by invoking the PM procedure. For an existing project, the PM window is populated with
the activities in the project. For a new project, the PM window is empty. Figure 5.2 displays the PM window
for a sample project.

After you have finished editing the project, you can close the PM window to save the new project data in the
Schedule output data set that was specified in the invocation of the PM procedure.

User Interface Features

This section describes some of the typical features of the PM window’s graphical user interface. The PM
window provides both a Gantt View and a Table View of the project. The size of each view can be changed
by pointing to the dividing line between the two views until the pointer changes to a double arrow and then
dragging it to the right or left.

Only part of the project may be visible in the PM window; horizontal and vertical scroll bars enable you to
scroll the project data in both directions. Note that the Gantt and the Table Views are attached to each other
so that they scroll together vertically. Each view can be scrolled horizontally, independently of the other.
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The menu associated with the PM window provides access to several project management functions under
the Edit, View, and Project menus. For example, the Project menu is shown in Figure 5.3. The commands
available through the menus are described in detail in the appropriate sections.

Figure 5.3 Project Menu

Preferences L4
Sart L4

Fontz

Renumber

In addition to the drop-down menus, context-sensitive pop-up menus are available in the Table and Gantt
Views, the time axis, along the arcs, and from select columns in the Table View. You open a pop-up menu by
right-clicking on a particular object. For example, right-clicking on an arc in the Gantt View displays the arc
pop-up menu shown in Figure 5.4.

Figure 5.4 Arc Pop-up Menu
Lelete
EditLag...

In some situations, the pop-up menu selection can lead to a dialog box that requires you to type a value in
one or more of the fields in the box. For example, selecting Edit Lag from the arc pop-up menu leads to the
dialog box displayed in Figure 5.5. (See “Create Nonstandard Precedence Relationships” on page 323 for a
discussion of nonstandard precedence constraints.)

Figure 5.5 Edit Lag Dialog Box

Arc from 1 to 2

Lag Value: 3
Lag Type: FS (FS, SS, SF, FF)

oK Cancel

The Table View displays project data in a tabular format. Some of the columns are editable (white background)
while other columns, which are computed by the procedure, are not editable (gray background). The Gantt
View always displays the early start schedule of the project. In addition, it also displays the resource-
constrained schedule (if resources are present), the actual schedule (if the project has started and is in
progress), and the baseline schedule (if a baseline schedule is saved for the project). The display of all the
schedule bars (except the Early Schedule bar) can be toggled on or off using the pop-up menu from the Gantt
View.

Note that each row of the combined Table View and Gantt View represents one activity (also referred to as
task in this chapter). Any change in data or movement of a row in one view is also reflected in the other.
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In addition to the drop-down and pop-up menu actions, several drag-and-drop actions are available within
the PM window. You can move the columns and rows of the Table View by selecting a row or column and
dragging it to the desired position. You can also change the width of the columns by dragging the column
dividers in the Table header region.

You can manipulate the durations of the tasks using the Task Information dialog box (see Figure 5.6) by
right-clicking on the bar shown in the Gantt View or by changing the length of the Early Schedule bar in the
Gantt View. You can also move the task in time by dragging the Early Schedule bar to a new position. This
affects the Target Date for the associated task.

Figure 5.6 Task Information Dialog Box

Task Information E3
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Any of the preceding actions may result in a change to the project schedule that is immediately reflected in
the Table and Gantt Views. All editing abilities and the corresponding changes to the schedule are described
in detail in the following sections.

Project Hierarchy

The PM procedure displays a hierarchical project structure if it is invoked with the PROJECT statement.
If the procedure is invoked without a PROJECT statement, the supertask and subtask relationship is not
supported, and all the activities are considered to be at the same level, belonging to a single project.

If the PROJECT statement is used, then a task’s level in the project hierarchy is indicated in the Table View
by small square boxes to the left of the activity number in the Job Nbr. column. Empty boxes indicate that
the activity does not have any subtasks (it is a leaf activity), while filled boxes indicate that the activity is a
supertask. Further, a Project Summary task is included to represent the root task (or Summary Task) of the
project. This task is positioned at the top of the list of activities, and its display can be toggled on or off by
selecting Display Summary Task from the View menu (see Figure 5.7).
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Figure 5.7 View Menu
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Scale. .

In the Gantt View, supertasks are indicated by vertical cones at the end of their corresponding schedule bars.

Note that the durations of the supertasks are determined by the overall duration of their subtasks. Thus, you
cannot change the duration of a supertask.

If there is no PROJECT statement, all menu selections that correspond to the multi-project structure are
unavailable for selection. For example, the Display Summary Task selection in Figure 5.7 will appear
dimmed.

Table View

The Table View displays information about a project in tabular form. It displays activities along with their
descriptions, various activity schedules, resource requirements, calendars, and target dates. The hierarchical
information about an activity is provided in the Job Nbr. column by a number of small square boxes to the
left of the activity number. The number of square boxes corresponds to the level of the activity in the project
hierarchy. Empty boxes indicate that the activity does not have any subtasks (it is a leaf activity), while filled
boxes indicate that the activity is a supertask. Some columns in the Table View are editable while others are
write-protected. The editable columns are lighter in color than the noneditable ones. In general, you can type
into all columns that provide input to the project, while all other columns that contain output values from
PROC PM are write-protected. For example, in Figure 5.2, the WBS Code column cannot be edited, while
the activity and Duration columns can be edited.

In the Table View, you can add or delete activities, add subtasks, change the order of the columns or the
activities, edit activity information, and so on. These tasks are described in the following sections.

Add/Copy/Delete Tasks

Right-clicking any task in the Table View displays the pop-up menu shown in Figure 5.8. From this pop-up
menu, you can Add/Copy/Delete the selected task. If you select the Add Task menu item, the new task is
added immediately following the selected task. You can also add a subtask to the selected task by selecting
the Add Subtask menu item. If you select the Copy Task menu item, a copy of the selected task is added to
the bottom of the Table View. The new task has the same duration and calendar as the selected task. If the
selected task is a supertask, all its subtasks (and any internal precedence constraints) are also copied.
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Figure 5.8 Table View Pop-up Menu

Add Tazk
Add Subtazk
LCopy Task
Delete Tazk
Hide

Change Column Width

The width of a column in the Table View can be increased or decreased by dragging (with the left mouse
button) the column dividers in the Table Header region of the Table View. When the pointer is positioned on

the column divider, it changes to a double arrow. Dragging it to the right or left increases or decreases the
width of the column.

Change the Order of the Columns

The display order of columns in the Table View can be changed in several ways:

e Drag the column in the header row to the destination.

e Select View from the menu and then select Move Columns to Left (see Figure 5.9). Choosing any of
the available options moves the corresponding columns to the leftmost portion of the Table View.

Figure 5.9 Move Columns Menu

Move Columng to Left Activity
Eiters 5 Eazeline
1D
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Level 2 Tasks Schedule
Lewel 3 Tasks IV_Iarget Dates
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Edit Durations

To change the duration of an activity, edit the Duration column in the Table View. Note that changing an
activity’s duration to 0 changes the activity into a Milestone. Activity durations can also be changed in the
Gantt View.

Edit Alignment Constraints

Scroll to columns named Target Date and Target Type. Enter one of the values SGE, SLE, MS, MF, FGE,
or FLE in the Target Type column. You can either type the values or select them from the pop-up menu
displayed by right-clicking the Target Type column (see Figure 5.10). Enter the appropriate date in the Target
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Date column. You can also view these columns by selecting View »Move Columns to Left »Target Dates
from the menu (Figure 5.9). You can also change an activity’s alignment constraints in the Gantt View.

Figure 5.10 Target Type Pop-up Menu
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Edit Calendars

To change an activity’s calendar, you can enter the calendar number in the Activity Calendar column or
the calendar description in the Calendar Name column. The calendars that can be assigned to an activity
are predefined in the Calendar data set. To see a list of the calendars, you can right-click in one of the
calendar columns. This will pop up a list of calendars, from which you can select the activity’s calendar. See
Figure 5.11 for an example of a calendar pop-up menu with two calendars.

Figure 5.11 Calendar Pop-up Menu
Default
Sinday

Edit Resource Requirements

You can change the amount of resources required for an activity by editing the Resource columns in the
Table View. Changing the resource requirement causes the project to be rescheduled using the new resource
specifications. See “Edit Resource Requirements” on page 324 for more details.

Edit Progress Information

You can edit the actual start, actual finish, percent complete, or remaining duration for an activity by editing
one of the Progress Information columns in the Table View. Note that by changing one of these columns, all
the other related progress columns might also be affected. For example, entering 100 in the Percent Complete
column for an activity that is in progress updates the Remaining Duration column to 0, and the Actual Finish
column is filled in appropriately. You can also modify the progress information of an activity in the Gantt
View.

Expand/Collapse Supertasks

Double-clicking on a supertask in the Table View toggles the expand/collapse switch. This action enables
you to either view or hide all the subtasks of the supertask.
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Hide Tasks

An individual task can be hidden by right-clicking the task in the Table View and selecting Hide from the
menu shown in Figure 5.8. Tasks can also be hidden from view using several filters described in the section
“Setting Activity Filters” on page 324.

Move Tasks

Starting anywhere in the row corresponding to an activity you want to move, drag it to the destination.

Gantt View

In the Gantt View, activity schedules are depicted by horizontal bars. There is one bar for each of the early,
resource, actual, and baseline schedules. For the Early Schedule bar, critical activities are marked in different
colors from the noncritical activities. Weekends are marked by shaded vertical rectangles running through
the chart. Supertasks are differentiated from leaf activities by anchoring vertical cones at the ends of their
Early Schedule bars.

The Gantt View is displayed with a rectangular grid that can be turned on or off by selecting Grid from the
pop-up menu (see Figure 5.12) that is displayed by right-clicking anywhere outside of the schedule bars in
the Gantt View.

Figure 5.12 Gantt View Pop-up Menu

Sotia Sehedule
Besource Schedule
Baseline Schedile
Grid

The pop-up menu in the Gantt View also enables you to toggle the display of the Actual, Resource, or
Baseline Schedule bars. Note that these bars can be displayed in the Gantt View only if the project data
contain the actual, resource-constrained, or baseline schedules, respectively.

In addition to displaying the activity schedules in an easy-to-view format, the Gantt View in the PM window
can also be used to change the durations of the activities, add or delete precedence constraints, set activity
alignment constraints, set progress information, and provide access to calendar, precedence, and resource
information.

You can also change several of the display attributes of the Gantt View by using the Time Axis pop-up menu
(see Figure 5.13) to set the scale of the axis, format the time axis labels, set the units of display, and so forth.
All of these tasks are described in the following sections.

Figure 5.13 Time Axis Pop-up Menu
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Change the Format of the Time Axis

The format of the major axis can be changed by right-clicking on the header row of the Gantt View and
selecting Format for the major axis. For the minor axis, select Format Minor. Some example selections
available for the formats are shown in Figure 5.14 and Figure 5.15. In addition to the formats explicitly listed
for the major axis, you can specify any valid numeric format by selecting Other and filling in the appropriate
fields in the dialog box that is opened as a result.

Figure 5.14 Major Axis Format Pop-up Menu

0ESep
0E5ep56
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03/36
03-36
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Other...

Figure 5.15 Minor Axis Format Pop-up Menu

Change Increments

Increments in the Gantt View define the number of tick marks on the minor axis per tick mark on the major
axis. They can be changed by right-clicking on the header area and selecting Increment from the pop-up
menu. The available selections are shown in Figure 5.16.

Figure 5.16 Increment Pop-up Menu
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Change the Scale of the Time Axis

Move the pointer to a tick mark on the major axis in Gantt View. The pointer changes to a double arrow.
Drag the tick mark horizontally to change the scale. You can also change the scale by using the Scale pop-up
menu (see Figure 5.17) from the Time Axis pop-up menu.

Figure 5.17 Scale Pop-up Menu

One
Twao
Three
Four
Five
Ten
Other...

Change Units

The Time Axis Units in the Gantt View can be changed by right-clicking on the header bar in the Gantt
View and selecting Units (see Figure 5.18). The default value of the units used for display is based on the
specification of the INTERVAL= parameter in the invocation of the PM procedure.

Figure 5.18 Units Pop-up Menu
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Display/Hide Selected Schedules

A display/hide switch for a given schedule can be toggled by right-clicking in the main panel of the Gantt
View and selecting the desired schedule (see Figure 5.19).

Figure 5.19 Gantt View Pop-up Menu

Sotia Sehedule
Besource Schedule
Baseline Schedile
Grid

Display Task Information

You can display detailed information for an activity by right-clicking any of its schedule bars and selecting
Task Information from the resulting pop-up menu (see Figure 5.20).
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Figure 5.20 Schedule Bar Pop-up Menu

Tazk Infarmation... |

The ensuing Task Information dialog box (see Figure 5.21) displays the job number, duration, duration units,
a list of predecessor activities, and a list of successor activities, as well as applicable calendar and resource
information for the selected activity. You can also edit the activity duration from the Task Information
dialog box.

Figure 5.21 Task Information Dialog Box
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If any calendars have been defined to the project, the activity calendar is also displayed. If the project utilizes
any resources, there is a list box that lists the resources required by the activity (see Figure 5.22). Selecting a
resource from this list box displays the quantity required by the activity in the Req field. Furthermore, if the
selected resource drives the duration of the activity, then the appropriate work value is also displayed in the
Work field.

Figure 5.22 Task Information Dialog Box (Calendar and Resources)
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Modify Activity Alignment Constraints

An activity’s Early Schedule bar can be moved using the left mouse button. When the pointer is positioned
over the activity bar, it changes to a cross-hair type. You can then drag the bar horizontally to a new position.
This sets an alignment constraint of type ‘SGE’ for the selected activity with the align date corresponding
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to the one at the left edge of the bar’s new position. Other types of alignment constraints can be entered by
editing the Target Date and Target Type columns as described in “Edit Alignment Constraints” on page 313.

Modify Durations

You can modify the duration of an activity in several ways. In the Gantt View, you can enter it directly by
using the Task Information dialog box as described in “Display Task Information” on page 317, or change
it indirectly by altering the width of the schedule bar. To change the duration of an activity, point to the right
edge of the activity’s Early Schedule bar, and drag to the left or the right depending on whether you want to
decrease or increase the duration. You can also edit activity durations in the Table View.

Modify Precedence Information

You can add precedence constraints by depressing the left mouse button at either end of the predecessor
activity bar and releasing it at either end of the successor activity bar. The type of constraint (FS, FF, SS, or
SF) depends on which end of the bars the constraints are drawn from.

You can delete precedence constraints by right-clicking on the arc and selecting Delete (see Figure 5.23).
Figure 5.23 Arc Pop-up Menu
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You can modify the type of the precedence constraint or the lag value associated with the precedence constraint
by right-clicking on the arc and selecting Edit Lag. The ensuing dialog box is shown in Figure 5.24. Enter
the value of the lag duration in the first field and the type of the lag in the second field. Valid values of lag are
Finish-to-Start (FS), Start-to-Start (SS), Start-to-Finish (SF), and Finish-to-Finish (FF).

Figure 5.24 Edit Lag Dialog Box
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If calendars are defined in the project, the Edit Lag dialog box includes the lag calendar associated with
the selected precedence constraint. You can change the lag calendar by selecting from the list of available
calendars that is displayed within the Edit Lag dialog box shown in Figure 5.25.
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Figure 5.25 Edit Lag Dialog Box (Multiple Calendars)
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Modify Progress Information

To modify the Progress using the Gantt View, you must include the Actual Schedule in the view. You can
drag the actual schedule bar for the activity to change the amount of progress on the activity; you can also
move the activity’s actual bar to change the Actual Start of the activity.

When the project contains progress information, a Timenow line is drawn in the Gantt View, indicating the
TIMENOW date. You can move the Timenow line by dragging it. When you change the value of TIMENOW,
the progress information changes for all the activities. A confirmation window requires you to confirm that
you do want to change the progress information for all the activities. (See also “Macro Variable TIMENOW”
on page 328.)

You can also edit the progress columns in the Table View.

Creating and Editing Projects

The PM window provides an easy-to-use interface to enter basic project information such as a list of activities,
their durations, order of precedence, resource requirements, and so forth. You can also use the Edit menu
(see Figure 5.26) to add or delete progress, baseline, and other information. These functions are described in
the following sections.

Figure 5.26 Edit Menu
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Add Activities

An activity (or task) can be added to the Project in the PM window by right-clicking in the Table View. If
Add Task is selected from the pop-up menu, then an activity is added at the same level as the selected activity.
Subtasks of an activity can be added by selecting Add Subtask. These actions are also available from the
Edit menu (Figure 5.26) whenever an activity is selected in the Table View. Note that the selected activity is
highlighted.

To add a new task at the topmost level of the project hierarchy, select New Task from the Edit menu.

Add Precedence Constraints

To add precedence constraints in the Gantt view, point at the right edge of the predecessor activity until the
pointer changes to a cross-hair and drag it vertically up or down to the left edge of the successor activity. By
starting and dropping at different ends of the activity bar, you can create nonstandard precedence relationships
between the activities. You can view the predecessor and successor tasks for an activity from the Task
Information dialog box.

Add Baseline Information

Baseline information is saved in a project so that the current status of a project can be measured against some
base schedule. The baseline information can be set in several different ways; most of the actions relating to
the Baseline schedule can be performed using the selections available from the Edit menu (see Figure 5.26).

o If the project data include a Baseline schedule, saved in the variables B_START and B_FINISH, the
PM window displays the Baseline schedule when it is first invoked. This schedule can be replaced
by selecting Replace Baseline from the Edit menu. This selection can be used to reset the Baseline
schedule to a new schedule corresponding to one of the current schedules.

e If the project data do not include a Baseline schedule, the Baseline schedule can be set in the PM
window by selecting Set Baseline from the Edit pull-down menu (see Example 5.3). This selection can
be used to set the Baseline schedule to one of the current schedules (see Figure 5.27). Thus, selecting
Resource from the Set Baseline menu sets the baseline schedule to the current resource-constrained
schedule. By saving the current resource-constrained schedule, you can perform some what-if analysis
by changing some of the resource requirements or other parameters of the project and comparing the
resulting schedule with the saved baseline schedule.
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Figure 5.27 Set Baseline Pull-down Menu
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e The individual Baseline values can also be edited in the Table View by changing the values in the
Baseline Start and Baseline Finish columns.

o If new activities are added to the project, the Baseline values for the new tasks are missing. These can
be set to correspond to the current schedule values by selecting Fill Missing Baseline from the Edit
menu.

o If you want to delete the Baseline information from the project data, you can select Delete Baseline
from the Edit menu.

Add Progress Information

Progress information can be included by using the ACTUAL statement, which is similar to the one for PROC
CPM. If the PM window is invoked without the ACTUAL statement, then progress information can be added
to the Project from the Edit menu (Figure 5.26) by selecting Add Progress.

Progress information is updated by dragging the actual schedule bars horizontally (in a manner similar to the
one for changing durations) in the Gantt View or by modifying the values in the Progress columns in the
Table View. See “Modify Progress Information” on page 320 and “Edit Progress Information” on page 314.

For details about how the progress information is used to update the project schedule, see “Progress Updating”
on page 109. See also Example 5.6.

Change Duration

The duration of an activity can be changed directly from the Duration column of the Table View or the Task
Information dialog box of the Gantt View. It can also be changed indirectly by dragging the activity bar at
the right edge in the Gantt View.

Copy Activities

An activity (or task) can be copied in the PM window by right-clicking in the Table View. If Copy Task is
selected from the pop-up menu, then a copy of the selected activity is added at the end of the activities listed
in the Table View. The new task has the same duration and calendar as the selected task. If the selected task
is a supertask, all its subtasks (and any internal precedence constraints) are also copied.
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Create Milestones

You can create milestones by adding an activity and assigning it zero duration.

Create Nonstandard Precedence Relationships

A Finish-to-Start relationship between two activities is considered to be a standard precedence constraint.
You can create it in Gantt view by dragging the precedence constraint from the right end of the predecessor
activity bar to the left end of the successor activity bar. Nonstandard precedence constraints are created by
starting and ending at different ends of the two activity bars. For example, a Start-to-Finish relationship is
created by dragging from the left end of the predecessor activity bar to the right end of the successor activity
bar.

In addition to specifying the type of the precedence constraint, you can also specify a lag or lead time between
the two activities. This lag value can be edited from the Gantt View. See “Modify Precedence Information”
on page 319 for more details.

Create Subtasks

Subtasks can be created only if the PM procedure is invoked with the PROJECT statement. To create a
subtask, right-click on the parent activity in the Table View. Then select Add Subtask from the background
menu. The newly created subtask has one more little square box than the parent task in the Job Nbr. column
in the Table View. The empty square boxes denote that it is a leaf activity (a task with no subtasks). The
number of boxes denote a task’s level in the project hierarchy, starting with level O for the Project Summary
task.

Delete Activities

An activity can be deleted in the Table View by right-clicking anywhere in the task row and selecting Delete
Task. If the selected task is a supertask, all its subtasks are also deleted. Note that, in this case, a confirmation
dialog box confirms the Delete Supertask action.

Delete Precedence Constraints

To delete a precedence constraint, right-click anywhere on the arc and select Delete from the pop-up menu.
You can view the predecessor and successor tasks for an activity from the task information window.

Edit Activity Alignment Constraints

Activity alignment constraints can be added/modified as described in “Edit Alignment Constraints” on
page 313and “Modify Activity Alignment Constraints” on page 318, respectively.

Edit Baseline Information

To edit the baseline schedule, scroll to the Baseline Start and Baseline Finish columns and type in the new
values of the baseline start and finish times. Note that you cannot change the baseline values by moving the
Baseline Schedule bars. See “Add Baseline Information” on page 321 for more details.
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Edit Calendar Specifications

Calendars are defined by the CALEDATA= option in the PROC PM statement. This option is similar to the
corresponding option in PROC CPM. After calendars are defined in the Project, an activity’s calendar can be
changed or set in the Table View by editing the Activity Calendar or Calendar Name columns. You can either
type the values or select them from the menu displayed by right-clicking in either of the Calendar columns.
See “Edit Calendars” on page 314. You can also view the activity calendar from the task information window.

Edit Resource Requirements

The resource requirement information for each activity is displayed and can be edited in the Table View. A
column for a resource is created in the Table View when it is specified in the RESOURCE statement of the
PROC PM invocation. For details about the RESOURCE statement, the Resource data set, and Resource
Allocation, see Chapter 4, “The CPM Procedure.” Changing the resource requirement causes the project to
be rescheduled to use the new resources. You can also view the resource requirements for an activity from
the task information window.

If alternate resources are used by the scheduling algorithm, an extra set of columns is added to the Table
View. These columns (one for every resource in the project) display the resources that were actually used.
These Usage columns for the resources cannot be edited.

Setting Activity Filters

Activity filters can be set by using the project hierarchy or by selecting from a list of activity attributes, as
described in this section.

Figure 5.28 View Menu
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Activities at different levels in the hierarchy can be viewed by selecting View from the menu (Figure 5.28)
and selecting the appropriate level of the project hierarchy to filter out the higher level tasks. For example,
selecting Level 2 Tasks displays only the tasks that are at Level 2 or lower. All activities can be viewed by
selecting Tasks at All Levels from the View menu.

Activities can also be filtered using different criteria by selecting View »Filters from the View menu (see
Figure 5.28). The available filters are shown in Figure 5.29. By default, no filter is in effect (the selection
is None); you can save the filter of your choice in the Preference data set (see “Saving and Restoring
Preferences” on page 325).
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Figure 5.29 Filters Pull-down Menu
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Saving and Restoring Preferences

When the PM window is displayed for the first time for a given project, the order and width of the columns in
the Table View, the font used for the display, the size of the window, the boundary between the Table and
the Gantt Views, and several other attributes of the display are determined by the procedure. As you add
activities and edit the Table View, you can change some of these attributes according to your preference.
You can also select a different level of display or set some activity filters (see “Setting Activity Filters” on
page 324).

PROJECT Data Set

PROC PM enables you to save the attributes of the display in an indexed data set that is specified in the
PROC PM statement by using the PROJECT= option. The following preferences can be saved from one
invocation to another:

o text font

e time increment

e time units

e major time axis format

e minor time axis format

e schedule bars displayed (for example, Actual, Baseline, and so forth)

e chart grid

e chart scale

e table column widths

e table column order

e Table View-Gantt View dividing line

e activity filters
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e activity level

e project summary

e window dimensions
The Project data set uses three variables to save the preference information:

e PROJATTR—contains a keyword identifying the project attribute. Each attribute has either a numeric

value or a character value. The length of this variable is 8.

o PRATNVAL—used for numeric data corresponding to the attribute.

o PRATCVAL—used for character data corresponding to the attribute. The length of this variable is 200.
You can save and restore the preferences from the Project menu, which contains the Preferences submenu
(Figure 5.30). Note that you have to explicitly save the project preferences using the Save selection from this

menu. Closing the PM window saves only the activity data of the project; it does not automatically save the

project preferences. When you restore preferences, the state used is the one that was last saved for the project
in the specified preference data set.

Figure 5.30 Preferences Menu
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Sorting Activities

Activities can be sorted by activity number, early start, late start, and resource start by selecting Project
»Sort from the Project pull-down menu (see Figure 5.31). Once the activities are sorted, the Schedule
output data set contains the activities in the new sorted order. See “Renumbering the Activities” on page 327.

Figure 5.31 Sort Menu
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Setting the Project Font

When the PM window is first displayed, the font used in all the text areas of the window is the same as
the SAS font used in other windows. You can use the Fonts selection in the Project menu (Figure 5.32)
to change the font used in the PM window. You can select the various fonts and their sizes from the font
manager thus obtained. This font can also be saved (and restored) in the Project data set.

Figure 5.32 Project Menu
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Renumbering the Activities

When the PM window is first displayed for the specified project, the activities are listed in the order in which
they are defined in the Activity data set. The activity numbers displayed in the Job Nbr. column correspond
to this same order. Even if the activities are rearranged, either by moving selected activities or by sorting,
these numbers do not change. Likewise, no renumbering takes place automatically if activities are deleted
from the project.

You can use the Renumber selection in the Project menu (Figure 5.32) to reassign consecutive numbers to
the activities, starting from the first activity displayed.

When you close the PM window, saving all the activity information to the Schedule data set, the activities
are numbered according to the order in which they were displayed at the end of the editing session. In other
words, the Close action implicitly invokes the Renumber command on the project activities. These activity
numbers are, in fact, saved as the values of the ACTID variable (see “Schedule Data Set” on page 329).

Printing

The PM window provides functionality to print the Gantt View, the Table View, or both, provided that a
printer has been selected and the correct information has been set in the Printer Setup window. Print Preview
can be used to view the information before printing, and the printed output can be saved to a file. All the
printing functions are available from the File menu (Figure 5.33).
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Figure 5.33 File Menu
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Preview the Printed Output on the Screen
You can view the printed output on screen before actually printing it by selecting Print Preview from the
File menu.

Print Options

Select Print Options from the File menu. There are options for selecting time and activity axis range and
scaling of the printed output. See Figure 5.34.

Figure 5.34 Print Options Dialog Box
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Save the Printed Output to a File

The printed output can be saved to a file by selecting File »Print »Print to File.

Macro Variable TIMENOW

The PM window can be used to add and edit progress information to a project. When progress information is
added, the Schedule data set contains all the progress variables; see “Progress Updating” on page 109.

However, all the values of the progress variables are reconciled and revised on the basis of the value of
the TIMENOW parameter. Since the PM procedure enables you to move the TIMENOW line as well as
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implicitly change the value of TIMENOW by updating the Actual Start or Finish times of the activities, the
value of TIMENOW at the end of the editing session is an important parameter of the project. This value
is saved in a macro variable called TIMENOW and can be used in subsequent editing sessions of the same
project. See Example 5.6 for an example of the use of the TIMENOW macro variable.

Summary of Differences

The computation of the schedule, the resource-constrained scheduling algorithm, the resource usage informa-
tion, and all other aspects of the scheduling engine for PROC PM are the same as the ones for PROC CPM.
Refer to Chapter 4, “The CPM Procedure,” for details. Some minor differences that pertain to the Schedule
Data set and ALIGNTYPE statement are explained in the following sections.

Schedule Data Set

The Schedule data set produced by PROC PM is very similar to the Schedule data set produced by PROC
CPM. See “OUT= Schedule Data Set” on page 99.

However, unlike PROC CPM, the PM procedure is interactive in nature; it enables you to add activities, set
precedence constraints, reorder the activities, and so on. Thus, the output data set produced by PROC PM
is designed to capture the original project data as well as all the changes that are made to the project in the
course of the interactive session.

There are several differences between the forms of the Schedule output data sets produced by the PM and
CPM procedures:

e The PM procedure automatically includes all relevant variables that are needed to define the project.
Thus, the ACTIVITY, SUCCESSOR, LAG, DURATION, ALIGNDATE, and ALIGNTYPE variables are
included in the output data set by default. If the RESOURCE statement is used, all the resource
variables are also included. Likewise, if actual progress is entered for the project during the course of
the interactive session, all the progress-related variables are added to the output data set.

e The PM procedure contains three sets of observations, identified by three different values of a new
variable, OBS_TYPE. The first set of observations contains one observation for every activity in
the project. The value of the OBS_TYPE variable for these observations is ' SCHEDULE. ' These
observations contain all the activity information such as the duration, the start and finish times and the
resource requirements. The second set of observations contains one observation for every precedence
constraint in the project. The value of the OBS_TYPE variable for these observations is ' LOGIC. '
These observations contain all the precedence information such as the activity, successor, and lag
information.

The third set of observations is present only if the project has resource-driven durations. The value of
the OBS_TYPE variable for these observations is 'WORK. ' These observations specify the WORK
value for each resource used by each activity in the project.

e The order of the activities in the Schedule data set produced by PROC PM corresponds to the order
in which the activities appear in the Table View at the end of the interactive session. Likewise, when
the procedure is first invoked, the order of the activities in the Table View corresponds to the order in
which the activities are defined in the Activity input data set. If, during the course of the session, some
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of the activities are reordered or deleted, or if some new activities are added, the Schedule output data
set contains all the activities that are defined in the Table View at the end of the session.

e The PM procedure also assigns a numeric identifier for each activity. These values are assigned by
PROC PM consecutively in the order of the activities in the Table View and are saved in a variable
called ACTID (see “Renumbering the Activities” on page 327). In addition to the ACTID variable,
the Schedule data set also contains a numeric variable called SUCCID, which contains the numeric
identifier for the successor activities in the observations for which OBS_TYPE='1L0GIC. "' If the
PROJECT statement is used in the invocation of the PM procedure, a numeric variable called PNTID is
added to the Schedule data set; this variable identifies the parent task for each activity.

NOTE: If the ACTIVITY variable in the Activity input data set is a character variable, the ACTID,
SUCCID, and PNTID variables are added to the Schedule data set in addition to the ACTIVITY,
SUCCESSOR, and PROJECT variables. On the other hand, if the ACTIVITY variable in the Activity
input data set is numeric, the new ACTID, SUCCID, and PNTID variables replace the numeric ACTIVITY,
SUCCESSOR, and PROJECT variables, respectively.

ALIGNTYPE Statement

In PROC PM, if an ALIGNTYPE variable is specified but no ALIGNDATE variable is specified, then no
error message is generated; PROC PM ignores the ALIGNTYPE variable and generates a schedule. However,
in PROC CPM, this results in an error message with no schedule generated.

RESOURCE Statement

In PROC CPM, the NORESOURCEVARS option in the RESOURCE statement requests that the variables
specified in the RESOURCE statement be dropped from the Schedule data set. However in PROC PM, this
has no effect.

Examples: PM Procedure

This section illustrates some of the interactive features of PROC PM by using a few simple examples that
lead you through different stages of entering and editing project data. A simple software development project
is used in all the examples. The output data set from one example is used as input to the next example. Where
necessary, additional data sets are created, or the input data set is modified using simple DATA step code.
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Example 5.1: Defining a New Project

In this example, a simple software development project is built from scratch, starting with an empty Activity
data set. PROC PM is invoked with an Activity data set that has no observations and just a few variables that
are required to start the procedure. In addition to the Activity data set, a Project data set is also defined that
is used to save the display attributes of the PM window to be used between successive invocations of the
procedure. The following program invokes PROC PM and opens a PM window that enables you to enter
project data. The initial window is shown in Output 5.1.1.

Note that the PROJNAME-= option is used in the PROC PM statement. This value is used to label the PM
window. Also specified in the PROC PM statement is the PROJECT= option that identifies the project
attribute data set. The activities in the project follow a weekday calendar which is indicated to PROC PM by
specifying the INTERVAL=WEEKDAY option. In the PM window, the weekends are shaded gray in the
Gantt View.

/* Initialize the Activity data set =*/

data software;
length activity $20.;
input activity $ actid succid pntid duration;
datalines;

4

data softattr;
length projattr $8. pratcval $200.;
input projattr pratnval pratcval;
datalines;

’

proc pm data=software project=softattr

date='lmar04'd interval=weekday
projname='Software Project'
out=softoutl;

act actid;

succ succid;

project pntid;

duration duration;

id activity;

run;
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As each task is entered, the Schedule columns in the Table View are updated with the early and late start

times, and the Early Schedule bars appear in the Gantt View. Output 5.1.2 shows the PM window after the
five tasks have been entered. To view the Schedule columns, you can scroll the Table View to the right or use

In the PM window, enter the following tasks with the corresponding durations in the Table View:
the View menu (Figure 5.7) to move the Schedule columns to the left.
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Output 5.1.2 List of Tasks in the Software Project

Job MBS | Duration|P7FEB04 |01MAR04 [|04maR04 |o7mARo4 |1
Nbr. | activity | Code | Weekdays|f [S [S M [T W [T |F |8 [5 [m [T [
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O3 Document | 0.2 8 -"E""E- ------------------------------------------
04 | Test 0.3 |
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To enter precedence constraints between two activities, such as ‘Design’ and ‘Develop,” draw an arc, using
the left mouse button, from the end of the predecessor task to the beginning of the successor task. Use the
Gantt View to enter the following precedence constraints:

Design —--> Develop
Design --> Document
Develop —--> Test
Test —--> Ship

Output 5.1.3 shows the Software Project as the last precedence constraint is being drawn. Note that, in this
view of the PM window, the Schedule columns have been moved to the left, the grid lines in the Gantt View
have been turned off (using the menu in Figure 5.12), and the Gantt View has been scrolled to the right to
bring the end of the schedule bar for “Test’ into view.
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Output 5.1.3 Drawing Precedence Constraints
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«| | Kl (v 1]

To check the overall project status, you can bring the Project Summary task into view by selecting Display
Summary Task from the View menu (Figure 5.7). Note that the project duration is 23 days. The critical
activities are shown in red while the noncritical ones are green. The Summary Task is indicated by vertical
cones at the end of its schedule bar.

For the next few examples, the units used in the Gantt View are changed to “Weeks” by using the Axis pop-up
menu shown in Figure 5.13, the Summary Task is displayed at the top of the list of activities, and the Activity
description columns are shown in the Table View. To save these window settings in the Project data set,
select Project »Preferences »Save from the Project menu. The view of the project corresponding to these
settings is shown in Output 5.1.4. You can end the interactive editing session by closing the window. All the
activity and precedence information is saved in the output data set, SOFTOUT1, displayed in Output 5.1.5.
Note the two sets of observations in this data set: the first contains all the schedule information for all the
activities, and the second lists all the precedence relationships between activities.
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Output 5.1.4 Project Schedule

Software Project

(B8

'

'
1
1
1

'
1
1
1

R

cecsdeccslcccbeacchecclecccdeccadac=

cecslcccbeaccheacclecccdeccdeee

m ' ' ' ' ' ' '

' ' ' ' ' ' '

M ' ' ' ' ' ' '
—— - - -l - -l - - R I I S ) - - --

' ' ' ' ' ' '

' ' ' ' ' ' '

" ' ' ' ' ' ' '
e L I i I e S - - --

' ' ' ' ' ' '

' ' ' ' ' ' '

M ' ' ' ' ' ' '
= - & - B I A - - --

' ' ' ' ' '

| ' ' ' ' '

M ' ' ' ' '
et N . - wle = - - - - Bl -k - - --

' ' ' ' '

' ' ' ' '

M 1 ' ' ' '
— -k - - --

' ' ' '

' ' ' '

M ' ' ' '
- — E L I ) -l - -

' ' '

' ' '

M ' ' '
— 3 R -l - -

' '

' '

= I

=
=

ceslcccbeccheacclecccdeccdeee

A g o SO R U S
' ' ' ' '

23

Kl

WBS | Duration|p9FEB04 [01MAR04 [22MAR04 |12aPR(-

0.0
0.

0.2
0

.3

0.4

activity | Code | Heekdays

Project S| 0

Design

Develop

Document

Test

Ship

Job

Nbr-.

m |

02

03

(ml

05

|




336 4 Chapter 5: The PM Procedure

Output 5.1.5 Schedule Data Set
Schedule Data Set

Obs OBS_TYPE PNTID PROJ_DUR PROJ_LEV WBS_CODE ACTID SUCCID duration

1 SCHEDULE . 23 00 0 . 23
2 SCHEDULE 0 1 0.0 1 5
3 SCHEDULE 0 10.1 2 10
4 SCHEDULE 0 102 3 8
5 SCHEDULE 0 103 4 8
6 SCHEDULE 0 104 5 . 0
7 LOGIC 1 2 5
8 LOGIC 1 3 5
9 LOGIC 2 4 10
10 LOGIC 4 5 8

Obs PARENT activity SUCCESSR LAG ALGNDATE ALGNTYPE E_START E_FINISH
1 Project Summary . 01MARO04 31MARO04
2 Project Summary Design . 01MAR04 05MAR04
3 Project Summary Develop . 08MAR04 19MAR04
4 Project Summary Document . 08MAR04 17MAR04
5 Project Summary Test . 22MAR04 31MAR04
6 Project Summary Ship . 01APR04 01APRO0O4
7 Design Develop
8 Design Document
9 Develop Test
10 Test Ship

Obs L_START L_FINISH T_FLOAT F_FLOAT ES_ASC ES_DESC LS_ASC LS_DESC

1 01MARO04 31MARO04 0 0 0 0 0 0
2 01MAR04 05MARO04 0 0 1 5 1 5
3 08MAR04 19MARO04 0 0 2 4 2 4
4 22MARO04 31MAR04 10 10 3 3 3 3
5 22MAR04 31MARO04 0 0 4 2 4 2
6 01APR04 01APRO4 0 0 5 1 5 1
7
8
9
10

Example 5.2: Adding Subtasks to a Project

In this example, the output data set from Example 5.1 is used as input to PROC PM. The following statements
bring up the saved view of the project as shown in Output 5.2.1. Note that this view is identical to the view
saved in Output 5.1.4.

proc pm data=softoutl project=softattr
date='1lmar04'd interval=weekday
projname='Software Project'
out=softoutl;



Example 5.2: Adding Subtasks to a Project 4 337

act actid;

succ succid;
project pntid;
duration duration;
id activity;

run;

Output 5.2.1 Project Schedule

Job WUBS Duration%bSFEBO‘% loimaro4 |22mAR04 |12~
Nbr. | activity | Code | Heekdays| St |M |M |I‘I II‘I |I‘I |M |M |M |M
0 Project S| 0 23 0"1 Er Er e Er Er
o1 | Desion | 0.0 | NENNNNS |om| | |
o2 | Develop | 0.1 1o |oed[ @ : ¢ Um0 ¢
03 Document | 0.2 084---?-"?"-? EL-"EL"
04 | Test 0.3 o[ iU
o5 | Ship 0.4 ot L v
| | Db

In the invocation of PROC PM, the output data set name is the same as the input data set. Thus, it is possible
to make changes to the Activity data set using PROC PM and then save the results back to the original data
set.

In the current view of the Software Project, you want to add some subtasks to the ‘Design’ and ‘Develop’
tasks. Suppose that these two tasks are broken into two subtasks each: one for ‘Module 1’ and the other
for ‘Module 2.” Further, you want to remove the precedence constraint between the ‘Design’ and ‘Develop’
phases and add constraints between the respective modules. You can accomplish these tasks by making the
following editing changes in the PM window.

1. Use the Table View pop-up menu to add the following subtasks to ‘Design’:

Module 1: 5 days
Module 2: 3 days

2. Add a link from ‘Module 1’ to ‘Module 2.’

3. Use the Table View pop-up menu to add the following subtasks to ‘Develop’:
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Module 1: 6 days
Module 2: 5 days

4. Add a link from ‘Module 1’ to ‘Module 2.

5. Remove the link between the supertasks ‘Design’ and ‘Develop’ by clicking on the arc and selecting
Delete from the pop-up menu.

6. Add a link from ‘Module 1’ under ‘Design’ to ‘Module 1’ under ‘Develop.’
7. Add a link from ‘Module 2’ under ‘Design’ to ‘Module 2’ under ‘Develop.’

The resulting project schedule is displayed in Output 5.2.2 and saved in the data set SOFTOUT1. Note that
the new project duration is 24 days.

Output 5.2.2 Project Schedule

A ———— _[Ofx
Job WBS | Duration| Early |PSFEB04 |01MARO4 |22MAR04 |1~
Nbr. | activity | Code Weekdays| Start |M |M IM II‘I |M |M IM |M M
0 |Project 8| 0 24 [oimaRo4 |[ | DI
mi | Desion | 0.0 g |omaRo4 || |
D06 | Module 1 | 0.0.0 5 |ommARo4 || : ¢
OO7 | Module 2 | 0.0.1 3 |osmamoa || T
m2 | Develop | 0.1 11 |osmamoa || | |
Oo8 | Module 1 | 0.1.0 6 |osmaRo4 || | |
009 | Module 2 | 0.1.1 5 [16mARo4 |[ | i
03 | Document | 0.2 g [1imaRo4 || | 1
04 | Test 0.3 8 |2amamoa | 1 1 i
o5 | Ship 0.4 0 |02APRO4
«| >|4|' e I

Example 5.3: Saving and Comparing Baseline Schedules

This example shows you how to save a baseline schedule and use it for comparing new schedules. Recall that
in Example 5.2 the Schedule data are saved in the data set SOFTOUT1. Thus, the following invocation of
PROC PM displays the Software project in its last saved state (as in Output 5.2.2, but with the WBS codes
filled in). At the end of the editing session, the schedule is saved in the data set SOFTOUTS3.
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proc pm data=softoutl project=softattr
date='lmar04'd interval=weekday
projname='Software Project'
out=softout3;
act actid;
succ succid;
project pntid;
duration duration;
id activity;
run;
Use the Edit »Set Baseline pull-down menu (Figure 5.27) to save the current Early Schedule as a Baseline
Schedule. The resulting display is shown in Output 5.3.1. Note that the Gantt View now shows the Baseline

Schedule in addition to the Early Schedule. Also, the activities have been numbered to be sequential in the
current view (see the section “Renumbering the Activities” on page 327).

Output 5.3.1 Using Baseline Schedules

Software Project N =]

Job MBS | Duration| EarlspoFEBO4 |01mAR04 [22MAR04 |12aPR0A
Nbr. | activity | Code | Weekdays| Stardft M M M M [m [m M M M |

+

0 Project S| 0 24 | 01MAFK

mi Design 0.0 8 | 01MAK L i
002 | Module 1 | 0.0.0 5 | 01MAK i i
003 | Module 2 | 0.0.1 3 | 08MAK i i
m4 Develop 0.1 11 08MAK i -

oo5 | Module 1 | 0.1.0 | IS | oshar

eqeecccqeccccqeccccqe s s s e e e e e e e e e e e e e e e e g ...
eqeccccqeccccqeccccqece e e qe e e ——
B R TR T L Lk L T e

1

[

1
eqececeqeccccqeccceqescceqe e e e e e e e e e e ey =—--—

0O0O6 | Module 2 | 0.1.1 5 | 16MAR b
o7 Document | 0.2 8 1 1MAF
<| | SRR N4

The baseline schedule is useful in determining the effect of changes to the project on the schedule. For
example, suppose there is a directive from the director of your division that all the developers are required to
attend a User Interface Standards Meeting before starting the development of Module 2. This meeting has
been scheduled to start on March 15, 2004, and is expected to take 3 days. What is the effect of this directive
on your project schedule?
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To see the effect, you can make the following changes in the PM window:

1. Add a new task to the project by selecting New Task from the Edit pull-down menu.

2. To edit the newly entered task, you may need to scroll down.

3. Type in the name of the task: ‘Ul Meeting.” Set its duration to 3.

4. In the Gantt View, draw a link from this new task to Task 6 (‘Module 2’ under ‘Develop.”)

5. Also in the Gantt View, drag the task, ‘Ul Meeting,” to the tick mark corresponding to 15Mar(4.

The resulting view is shown in Output 5.3.2. Note that the view may differ depending on the display
parameters of your device. It is easy to see that, due to the 3-day meeting that is mandated, there is a delay in
the project schedule (the project duration is now 26 days).

Output 5.3.2 Effect of Ul Meeting on Schedule

'Job | | uBS | Duration| EarlsporEBo4 [oimaRo4 |22mAR04 [12aPRo-
Nbr. | activity | Code | Weekdays| Startfl M M M M m M M M M [n
003 | Module 2 | 0.0.1 3 osnﬁFmirmirmi"

m4 Develop 0.1 13 OBMﬁF_ugr"-irn_ir-

OoO5 | Module 1 | 0.1.0 6 osnﬁrmirmirmir-

006 | Module 2 | 0.1.1 5 IBMﬁF

oy Document | 0.2 8 IIMﬁF-“?“-?"-?-

o8 | Test 0.3 8 25MﬁF

o9 | Ship 0.4 0 osaPFmirmirmir-

010 | Ul Meetin| 0.5 3 ISMﬁF

4| | = ;'l'."".'"'.'"'.'"'.'"'.'"'.'"'!'"'!'"'!'")'v

You can get a complete picture of the effect on the schedule by examining all the Schedule columns that are
shown in the Table View. Output 5.3.3 shows the Schedule columns, the Baseline columns, and the Target
Date and Type columns in the Table View. To obtain this view, some of the columns have been moved and
the Baseline Schedule bars (in the Gantt View) have been hidden from the display.
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Output 5.3.3 Table View Showing All Schedules

Software Project = [=] B3

Job Dura| Early Early Late Late Basel in| Basel in| Target
Nbr. [ activ| Heek| Start Finish | Start Finish | Start Finish | Date
0 Proje| 26 |01MAR0O4 |05APR04 |03MAR04 |05APR04 (01MAR04 |01APR04

. Desig 8 [01MAR04 (10MARO04 |03MARO4 |17MAR04 |01MARO4 (10MAR04

002 | Modul 5 |01MARO4 |05MAR04 |03MAR04 |09MARO04 (01MARO4 |0SMAR04 B
003 | Modul 3 |08MARO4 |10MARO4 |15MAR04 |17MARO4 (08MARO4 |10MARO4 N
u4 Devel 13 |08MARO4 (24MAR04 (10MARO04 |24MAR04 (08MARO4 |22MAR04 B
005 | Modul 6 |08MARO4 |15MAR04 |10MAR04 |17MARO4 (08MARO4 |15MAR04 B
006 | Modul 5 |18MAR04 |24MAR04 |18MAR04 |24MARO04 (16MAR04 |22MAR04 N
o7 Docum 8 [11MAR04 (22MAR04 |25MAR04 |05APR04 |11MAR04 (22MAR04 B
m} Test 8 |25MAR04 |05APR04 |25MAR04 |05APR04 (23MAR04 |01APR04 N
09 Ship 0 [06APR04 (06APR04 |06APR04 |06APR04 |02APR04 (02APR04 B
010 | Ul Me 3 [15MAR04 (17MAR04 |15MARO4 |17MAR04 . . [15MAR04 | SGE B

| | H'I'Ll

If the project delay resulting from the UI Meeting is of concern, you may want to schedule the meeting on an
earlier date. Suppose the revised start date of the meeting is March 10, 2004. To see the effect of the change,
you can do the following:

1. Revert to the saved project preferences so that both the Table and the Gantt Views are visible.
2. Use the View menu to move the Target Date column to the left in the Table View.
3. Scroll down, if necessary, to bring the task ‘Ul Meeting’ into view.

4. Change the Target Date column for this task to ' 10Mar04."

The resulting view is displayed in Output 5.3.4. Note that, as a result of this change, all the activities are back
on schedule as the new schedule coincides with the saved baseline schedule. The last activity was defined
after the baseline schedule had been saved in Example 5.2; hence, there is no baseline schedule bar for this
activity. You can use the Fill Missing Baseline selection from the menu shown in Figure 5.26 to set the
baseline schedule for the ‘Ul Meeting’ to be the current early schedule.
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Output 5.3.4 Editing Target Date

'Job | Target | Target | uBS |p9FEBo4 [oimARo4 [22MAR04 [12aPRA
Nbr. | Date Type | activity [Code | M M M [m M M M M m |n
oo . Module 2 [0.0.1) ¢ & ¢ PHi i oG oG i
u4 . Develop 0.1 "'g'"'é""i" é'"'i""i'"
oos : Module 1 | 0.1.0
oo6 : Module 2 | 0.1.1
oy . Document | 0.2 '"i""é""i" 5 é'"'i""i'"
o8 . Test o3 || i ¢ i i | .S
o9 : Ship 0.4
010 |10MAR04 | SGE Ul Meetin| 0.5 : _
4' I ’l;'|'.’"'.""!'"'5'"'.’"'.’"'!‘"'.'"'.'"'!'"}LI

Example 5.4: Effect of Calendars

Continuing with the project scenario in the preceding examples, you want to explore other ways of shortening
the project duration. One possible alternative is to work overtime. As the project manager, you would like to
see the effect on the schedule if you change the calendar for all the development tasks to a six-day calendar.

Calendars are defined using the Calendar data set, as in the CPM procedure. This example defines a Calendar
data set and invokes PROC PM as follows. Note that, in order to use calendars, the Activity data set needs to
have a CALID variable, which is added in a simple DATA step.

* Define a Calendar data set identifying ;
* Saturday as a workday ;
data calendar;

input calid calname $ _sat_ §;

datalines;
1 Sixday WORKDAY

* Add the CALID variable to the Activity data set ;
* saved in the preceding example ;
data softout3;

set softout3;

calid=.;

run;
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* Use softout3 as the Activity data set and specify ;
* the preceding calendar data set ;
proc pm data=softout3 project=softattr
calendar=calendar
date='lmar04'd interval=weekday
projname='Software Project'
out=softout4;
act actid;
succ succid;
project pntid;
duration duration;
id activity;
calid calid;
run;

When the PM procedure initializes the PM window, it attempts to restore all the display settings using
the values in the Project data set, SOFTATTR. However, the new Activity data set has an extra variable,
calid, which leads to two new columns in the Table View, one for the Activity Calendar (which displays the
Calendar ID) and the other for the Calendar Name. These columns are added at the right end of the Table
View and can be seen by scrolling to the right. The resulting view is displayed in Output 5.4.1.

Output 5.4.1 Calendar Columns

Software Project M =1k
Basel ine| Basel ine| Activity| Calendar|pSFEB04 [01MAR04 |22MAR04 |12aPE~
Start Finish Calendar | Name |M |M [M |I1 |M |I'| |M |M |l1 |M
01MARO4 | 01APRO4
01MARO4 | 10MARO4
01MARO4 | O5MARO4
08MARO4 | 10MARO4
08MARO4 | 22MARO4
08MARO4 | 15MAR04
16MARO4 | 22MAR04
11MAR04 | 22MAR04

el R R

«| | v 4| Shd |

By default, all the activities are assumed to follow the standard five-day calendar. Now, you want to change
the calendar for the supertask ‘Develop’ and all its subtasks to be the six-day calendar defined in the data
set CALENDAR. Note that, in the calendar definition, it is sufficient to specify that Saturday is a working
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day. All the other days of the week default to the default calendar’s work pattern; see “Default Calendar” on
page 102 in Chapter 4, “The CPM Procedure.”

To facilitate the editing of the calendar values and to see the effect on the project duration, reorder the
columns (drag the columns in the Table Header) to display the activity, Activity Calendar, Calendar Name,
and Duration columns in the Table View. You may need to move the dividing line between the Table and
Gantt Views.

You can enter the Calendar values by typing the number 1 in the Activity Calendar column or the value
'Sixday"' in the Calendar Name column. You can also use the Calendar pop-up menu in one of the calendar
columns to select the desired calendar (see Output 5.4.2). Note that the project duration has reduced to 22
days as a result of the six-day calendar.

Output 5.4.2 Effect of Six-Day Calendar

Software Project - O] x|
Job Activity | Calendar | Duration||p9FEB04 |01MAR04 |22MAR04~
Nbr. | activity | Calendar | Name Heekdays |I‘I |I‘I |I'| |M |M M |M IM
0 Project S . 22 b ;
mi Design . 8 E 3 E E E E
002 | Module 1 . 5 b A
o003 | Module 2 . 3
m4 Develop 1 | Sixday 11 A E
005 | Module 1 1 | Sixday 6 AR ;
006 | Module 2 1 | Sixday 5 R ;
o7 Document . w 8 é § g i

«| | Sixday ,‘ | | >

To see the effect on the individual activities, change the units to “Days” in the Gantt View and enlarge the
Gantt View, as shown in Output 5.4.3.
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Output 5.4.3 Gantt View of Calendar Effect

" Job | Ill1omaro4 |13mAR04 |16MARO4 |19MARO4 |22MAR04 [25MAR04 ]
Nbr. | activity |[W [T F [s B M [T M T F 88 m [T M [T e
— il i :
-4 Develop {---:r---;---;---ir---?--- ---g.-
D06 | Module 2 :.

(m g Document ""i'-"é' ér
o8 | Test i o . —
s |sni  |li P BEEEE BEEEE
@10 |l neevin(MENNNE (G L 0 L L
4' | ’i‘.'i""""'"'".'"'.""."".'"‘."".'"‘.’"'.""."".'"'l.'"""‘.'"'."‘z

Example 5.5: Defining Resources

In all the preceding examples, it was assumed that you had enough resources to work on the different tasks.
Unfortunately, as a project manager you need to schedule your project using the limited set of resources
available to you. In this example, you will assign some project resources and schedule the project subject to

resource constraints.

In order to assign resources to the tasks, you need to add resource variables to the Activity data set as well as

define a resource availability (Resource) data set.

Suppose that the resources that you are interested in are Tester and Programmer. The following statements
set up the project data needed to perform resource-constrained scheduling with PROC PM using the output

data produced in Example 5.4.

* Define a Resource data set specifying
* 1 Tester and 1 Programmer as the
* available resources

data resources;
input _date_ date7.
datalines;

0ljan04 1 1

Tester

’

*

* Programmer to the Activity data set

Add the resource variables Tester and

r

Programmer;



346 4 Chapter 5: The PM Procedure

* (the output data set saved in last example) ;
data softout4;

set softout4;

Tester=.;

Programmer=. ;

run;

* Use softout4 as the Activity data set and ;
* specify the preceding Resource data set. ;
* Save the schedule in softout5. ;
proc pm data=softout4 project=softattr
calendar=calendar
resourcein=resources
date='1lmar04'd interval=weekday
projname='Software Project'
out=softout5;
act actid;
succ succid;
project pntid;
duration duration;
id activity;
calid calid;
resource Tester Programmer / per=_date_;
run;

Output 5.5.1 Adding Resources to the Project

Software Project

i Software Project =10 x|

Job WUBS boreBo4 [o1mAR04 |22MAR04 4.
Nbr. | activity | Code | Tester | Programmer |I‘I |I‘I IM |I‘I |I‘I IM |I‘I |I‘I

0 Project S| 0 . .

mi Design 0.0

- - - coecbheacscsbeacdleace

002 | Module 1 0.0. .

003 | Module 2 | 0.0.

m4 Develop 0.1

005 | Module 1 0.1. .

«| |
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Output 5.5.1 shows the Table and Gantt Views of the project after rearranging some of the columns and
moving the dividing line to show the resource columns. The Resource Schedule bars are also brought
into display by right-clicking on the background in the Gantt View and selecting Resource Schedule. The
Resource Schedule bar is shown (in blue) between the Early Schedule bar and the Baseline Schedule bar.
Note that the resource schedule coincides with the early schedule because no resource requirements have
been specified for either of the two resources.

You can now use the Table View to enter the resource requirements for each task. Set the requirement for the
resource Tester to '1 ' for the tasks ‘Document’ and “Test,” and the requirement for the resource Programmer
to ‘1’ for the tasks numbered ‘2, ‘3, ‘5,” and ‘6.” The resulting schedule is displayed in Output 5.5.2. In
this view, the baseline schedule is not displayed. You can see that several of the tasks have been delayed,
resulting in lengthening the project duration to 29 weekdays.

Output 5.5.2 Editing Resource Requirements

:gg 0 Pro - 10l X
Job WBS Durat ||pSFEB04 [01MAR0O4 [22MARA.
Nbr. | activity | Code | Tester | Progr| Heekd h |I'| |I'| [M |I'| |I'| [M |I'|
mi Design 0.0 13
oo Module 1 0.0 1 5
([ Module 2 | 0.0 1 3
m4 Develop 0.1 15
oos Module 1 0.1 1 b
(] Module 2 | 0.1 1 5
o7 Document | 0.2 1 8
o8 Test 0.3 1 8

<| | 3
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You can set the resource-constrained schedule as a baseline to do some “what-if”” analysis. For example,
suppose you would like to determine the effect of adding another programmer to the project. In order to
change the resource availability, you need to save the current project, edit the Resource availability data set to
add another programmer, and then reinvoke the PM procedure.

First, in the PM window displayed in Output 5.5.2, do the following:

1. Display the Baseline Schedule bar again.

2. Use the Replace Baseline selection from the Edit menu to select the Resource Schedule as the new
baseline schedule.

3. Save the project preferences.

4. Close the PM window.

Use the following statements to reinvoke PROC PM after defining a new resource availability:

* Change the resource availability for Programmer to 2
data resources;

input _date_ date7. Tester Programmer;

datalines;
0ljan04 1 2

4

4

* Use softoutd4 as the Activity data set and specify ;
* the preceding Resource data set.
* Save the schedule in softout5.
proc pm data=softout4 project=softattr
calendar=calendar
resourcein=resources
date='lmar04'd interval=weekday
projname='Software Project'
out=softout5;
act actid;
succ succid;
project pntid;
duration duration;
id activity;
calid calid;
resource Tester Programmer / per=_date_;
run;

V

4

Using the new resource availability, you reduced the project duration by five days. The resulting schedule

is displayed in Output 5.5.3, which also shows the baseline schedule corresponding to the earlier resource
availability data set.
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Output 5.5.3 Comparison of Two Resource Schedules

Job WBS Durat ||p9FEB04 [01MAR0O4 [22MA~.
Nbr. | activity | Code | Tester | Progr| Weekd ||f |M |M |M |M II‘I |M |M
0 Project S| 0 24 b

mi Design 0.0 8 b R
oo2 | Module 1 | 0.0 1 5 b ! B
o003 | Module 2 | 0.0 1 3 o I
m4 Develop | 0.1 1 Lo

Oo5 | Module 1 | 0.1 1 6 ||| i i

4| | 4|

Example 5.6: Editing Progress

Once a project plan has been established and the project is under way, a major part of a project manager’s
responsibility is to monitor the project as it progresses. This example uses the PM window to add progress
information to the project and discusses some of the related editing functions.

In the final window of Example 5.5 (shown in Output 5.5.3), do the following:

1. Delete the baseline schedule using the Edit menu.

2. From the Edit menu, select Add Progress.

The resulting display is shown in Output 5.6.1. The Gantt View now shows the Actual Schedule bar between
the Early Schedule bar and the Resource Schedule bar. It also displays a Timenow Line. Since no progress
information has been entered, the Timenow Line is drawn at the beginning of the project and all the Actual
Schedule bars show only a handle that can be used to drag progress for a particular task.
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Output 5.6.1 Adding Progress Information to Project

Software Project - O] x|
Job WBS Durat ||p9FEB04 [01MAR0O4 [22MA~.
Nbr. | activity | Code | Tester | Progr| Weekd ||f |M |M |M |M IM |M |M
0 Project S| 0 24 N
mi Design 0.0 8 b
oo2 | Module 1 | 0.0 1 5 b
Oo03 | Module 2 | 0.0 1 3 o
m4 Develop | 0.1 1 Lo
mm] Module 1 | 0.1 1 6 E 5
< I <

You can enter progress information in several ways:

e Drag the Timenow Line to update progress information for several tasks at once. The actual start and
finish times (until the Timenow date) are set assuming that the tasks follow the resource-constrained
schedule. (If there are no resource constraints, the tasks are assumed to follow the early schedule.)

e Use the handle on the Actual Schedule bar for a given task to drag the progress bar.

e Bring the Progress columns into view in the Table View and edit one of the Progress columns.

As an example, drag the Timenow Line to the tick mark corresponding to 15SMARO4. The resulting window
(after reordering and resizing some columns and scrolling the Gantt View) is shown in Output 5.6.2.
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Output 5.6.2 Moving the Timenow Line

Software Project _ (o] x]
Job Actual | Actual | Perc| Rem.| ActBo4 |o1MARO4 |22MAROA.
Nbr. [ activi| Start Finish Comp | Dura| Dur] IM |M IN IM M I
0 Projec| 01MAR04 | a2 | 14 5 = 5
. Design|01MAR04 | 10MAR04 | 100 o| 8| : | A
Oo2 | Module| 01MARO4 | 0SMARO4 | 100 o| 5 : A
OoO3 | Module|08MARO4 |10MARO4 | 100 o| 3| : b
m4 | Develo| 06MAR0O4 .| 64 4
OO5 | Module| 06MARO4 [12MAR04 | 100 | o | 6 | !
<| | » 4-Ir |)'

Note that some of the activities are completed while others are still in progress. If the project data are saved
at this point, the Schedule data set will have all the Progress variables (A_START, A_FINISH, PCT_COMP,
and REM_DUR). However, for the PM procedure to be able to recapture the exact state of the schedule as
it was saved, it also needs to know the value of TIMENOW when the project data was last saved. This
value (' 15Mar04 ' for the current example) is saved as a macro variable named TIMENOW (see the section
“Macro Variable TIMENOW” on page 328).

To see how the Actual information can be used from one invocation of PROC PM to the other, save the project
as displayed in Output 5.6.2 and then reinvoke PROC PM to continue editing the progress information.

Recall from the last invocation of PROC PM that the data are saved in the data set SOFTOUT5. To use the
saved progress information, invoke PROC PM as follows:

* Use softout5 as the Activity data set and specify ;
* the Resource data set defined in the last example. ;
* Save the schedule in softouté6. ;
proc pm data=softout5 project=softattr
calendar=calendar
resourcein=resources
date='lmar04'd interval=weekday
projname='Software Project'
out=softout6;
act actid;
succ succid;
project pntid;
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duration duration;
id activity;
calid calid;
* Use the ACTUAL statement to specify the Progress variables ;
* and the value of TIMENOW saved from the previous invocation ;
actual / as=a_start af=a_ finish
remdur=rem dur pctcomp=pct_comp
timenow=&timenow;
resource Tester Programmer / per=_date_;
run;

The preceding program displays the PM window for the updated Software project. Now use the Table View
to edit some of the Progress columns. To do so, you can either scroll to the Progress Columns or move these
columns to the left in the Table View using the appropriate selection from the View menu (Figure 5.9).

Task number 6 (‘Module 2’ under ‘Develop’) has a Remaining Duration value of 4. Now, you may notice
that you have misjudged the amount of work involved and that you need only one more day to finish the task.
Enter 1 in the Remaining Duration column. This editing change immediately causes the Percent Complete
column to update to 50, indicating that 50% of the work is completed. The resulting effect on the project
schedule is shown in Output 5.6.3 (the window has been scrolled down so that the second half of the project is
visible). Note that reducing the duration of the ‘Module’ task did not affect the project end date; the duration
of the project is still 24 days. Studying the schedule of the ‘Document’ and ‘Test’ tasks, you notice that the
delay to the project is caused by the fact that the resource-constrained schedule of the task ‘“Test’ is delayed
due to resource constraints.

Output 5.6.3 Editing the Remaining Duration Column

Software Project

Job Actual | Actual | Perc bareBo4 |o1mAR04 |22MAR04 4
Nbr. | activi| Start | Finish | Comp I G O GO O O I

005 | Module| 06MARO4 | 12MARO4 | 100,

006 | Module| 13MAR04 . | 50.0
of Docume| 1 1MAR04 . | 25.0
08 Test
09 Ship
m) 1] Ul Mee|10MAR0O4 | 12MARO4 | 100.

| |
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In addition to revising the progress information for ‘Module 2,” you also realize that the ‘Document’ task is
50% complete as of the Timenow date. Edit the Percent Complete column in the Table View, changing the
value from 25.0 to 50.0. Immediately, the Remaining Duration column changes to 2. The resulting window
is shown in Output 5.6.4. The project end date (for the resource-constrained schedule) is 28Mar(04. Thus, the
project duration is now reduced to 20 days.

Output 5.6.4 Editing the Percent Complete Column

Software Project _ O] x|

Job Actual | Actual | Perc| Rem.| Actlp4 |o1MAR04 |22mAR(~
Nbr. | activi| Start Finish | Comp | Dura| Dur IM |M |M |M |M |M

005 | Module| 06MAR04 | 12MAR04 | 100. 0 6

{mm] 3 Module| 13MAR04 . | 50.0 1

oy Docume| 1 1MAR04 . | 50.0 2

B T

Freeeccceye e ey -——-—--

08 Test . . |18

o9 Ship

e e mmm e e EE e EE— .. — .- ——y e m—————— -

B e e e SR

ot

o190 Ul Mee|10MAR04 |12MARO4 | 100. 0 3 E

e ———————
e ——————
- —————
e ——————-

| | 3Kl [»~]




Subject Index

ACTID variable

Schedule data set (PM), 330

activity numbers
PM procedure, 327
PM window, 327

alignment constraints, Table View, 313

calendars, Table View, 314
durations, Gantt View, 319
durations, PM window, 322
durations, Table View, 313

add activities lag, Gantt View, 320
PM procedure, 321 project, PM procedure, 320

PM window, 321 expand supertasks
add subtasks Table View, 314
PM window, 323
add tasks filters, 324

Table View (PM), 312

alignment constraints Gantt YleW, 315 '
Gantt View, 318 alignment constraints, 318

PM window, 323 display schedule bar, 317
display task information, 317
edit durations, 319
baseline schedule edit lag, 320
PM window, 321, 323 hide schedule bar, 317
lag calendar, 320
nonstandard precedence relationships, 319, 321,

pop-up menu, 314

calendar information

lag dialog box, 320 323
PM window, 324 PM procedure, 315
pop-up menu, 314 PM window, 315
Table View, 314 progress information, 320
collapse supertasks time axis format, 316
Table View, 314 time axis units, 317
column, change order time increment, 316
Table View, 313 time scale, 317
column, change width
Table View, 313 hide
copy activities schedule bar, Gantt View, 317
PM window, 322 tasks, Table View, 315
delete activities lag calendar, 320
PM window, 323 lag dialog box, 310, 320
delete precedence constraints lag types, 320

PM window, 323

delete tasks macro variable

Table View (PM), 312 TIMENOW, 328
dialog box menu

edit lag, 310, 320 . edit, 320

edit lag calendar, 320 milestones

task information, 311 PM window, 323
display move tasks .

schedule bar, Gantt View, 317 Table View, 315

task information, Gantt View, 317 . .
nonstandard precedence relationships

edit Gantt View, 319, 321, 323



overview increment, 316

PM procedure, 303 major axis, 316
minor axis, 316
PM examples scale, 317
adding subtasks, 336 schedule bar, 318
baseline schedules, 338 Table View, 313
new project, 331 target type, 314
PM procedure task information, 318
activity numbers, 327 Time Axis, 315
add activities, 321 units, 317
edit project, 320 PRATCVAL variable
Gantt View, 315 PROJECT data set (PM), 326
overview, 303 PRATNVAL variable
PM window, 309 PROJECT data set (PM), 326
progress updating, 328 print options
progress variables, 328 PM window, 328
project hierarchy, 311 print preview
Schedule data set, 329 PM window, 328
Summary of Differences, 329 printing
Table View, 312 PM window, 327
TIMENOW macro variable, 328 progress information
PM window, 309 Gantt View, 320
activity numbers, 327 PM window, 322
add activities, 321 Table View, 314
add subtasks, 323 progress updating
alignment constraints, 323 automatic updating of progress information, 307
baseline schedule, 321, 323 estimate percent completion time, 307
calendar information, 324 PM procedure, 328
copy activities, 322 progress variables
delete activities, 323 PM procedure, 328
delete precedence constraints, 323 PROJATTR variable
edit durations, 322 PROJECT data set (PM), 326
filters, 324 PROJECT data set (PM)
Gantt View, 315 PRATCVAL variable, 326
milestones, 323 PRATNVAL variable, 326
PM procedure, 309 PROJATTR variable, 326
print options, 328 project font
print preview, 328 PM window, 327
printing, 327 project hierarchy
progress information, 322 PM procedure, 311
project font, 327 project preferences
project preferences, 325 PM window, 325
resource requirements, 324 pull-down menu, 326, 327
saving printed output, 328 pull-down menu
sorting activities, 326 file, 328
Table View, 312 filters, 325
user interface features, 309 move column, 313
PNTID variable preferences, 326, 327
Schedule data set (PM), 330 project, 310
pop-up menu project preferences, 326, 327
alignment constraints, 314 set baseline, 322
arc, 310, 319 sort, 326
calendar, 314 View, 312, 324

Gantt View, 315, 317



resource requirements
PM window, 324
Table View, 314

saving printed output
PM window, 328
Schedule data set
PM procedure, 329
progress variables, 328
sorting activities
PM window, 326
SUCCID variable
Schedule data set (PM), 330

Table View, 312
add tasks, 312
collapse supertasks, 314
column, change order, 313
column, change width, 313
delete tasks, 312
edit alignment constraints, 313
edit calendars, 314
edit durations, 313
expand supertasks, 314
hide tasks, 315
move tasks, 315
PM procedure, 312
PM window, 312
pop-up menu, 313
progress information, 314
resource requirements, 314
target date, 313
target type, 313
time constraints, 313
target date
Table View, 313
target type
Table View, 313
task information dialog box, 311
time axis
format (Gantt View), 316
units (Gantt View), 317
time constraints
activity align dates (PM), 313
activity align types (PM), 313
Table View, 313
time increment
Gantt View, 316
time scale
Gantt View, 317
TIMENOW
macro variable (PM), 328

user interface features
PM window, 309

View pull-down menu, 312






Syntax Index

ADDACT option

PROC PM statement, 307
AUTOUPDT option

ACTUAL statement (PM), 307

ESTIMATEPCTC option
ACTUAL statement (PM), 307

NAME-= option, see PROJECTNAME= option
NODISPLAY option
PROC PM statement, 306

PM procedure
PROC PM statement, 306
PROC PM statement, see PM procedure
statement options, 306
PROJECT= option
PROC PM statement, 306
PROJECTNAME= option
PROC PM statement, 306
PROJECTSUMMARY= option, see
SUMMARYNAME-= option
PROJNAME-= option, see PROJECTNAME-= option

SHOWFLOAT option

ACTUAL statement (PM), 307
SUMMARY= option, see SUMMARYNAME-= option
SUMMARYNAME-= option

PROC PM statement, 307

XFERVARS option
PROC PM statement, 307
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