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Introducing SAS IT Service Level Management

SAS IT Service Level Management is a member of the SAS IT Management
Solutions family. SAS IT Service Level Management supports service level management
(SLM) efforts by providing the following:

O the capability to represent every element of your IT contracts to which
performance measures can be applied
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O the ability to assign service level objectives and select various methods of
measurement for each component, service, service level agreement (SLA), and
contract

0 a database where diverse SLM data can be stored and easily accessed

o0 methods of interpreting the SLM data in terms of established service level
objectives for availability, response time, throughput, custom objectives, and
composite objectives

O an easy-to-use graphical user interface (GUI) that makes vital information more
accessible to all users

0 several methods of reporting on the data, including text-based and graphic reports
that include Baseline reports, Service Level reports, and SAS Enterprise Guide
reports.

Note: This document supports the software for SAS IT Service Level Management
2.1 and later. A

What Is Service Level Management?

Service level management is a paradigm of IT service delivery that focuses on these
goals:

O discovering and outlining the IT services that are needed to fulfill business
requirements

O establishing measurable goals for each IT component and service that is needed to
meet established business needs

O evaluating the quality of IT services based on how business customers experience
those services

O producing user-oriented reports that communicate whether the delivered services
have met established objectives and fulfilled business needs

Why Is Service Level Management Needed?

Over the last two decades, the business world has become increasingly dependent on
a supporting structure of IT services. During the boom years of the last decade, many
businesses were happy to spend freely on IT services; however, few fully understood
what the IT budget was buying. The atmosphere has changed considerably in this new
millennium. In an era of declining budgets and an increasing need for expanded IT
services, every budget dollar must be watched carefully and allocated effectively and
efficiently. The IT budget is no exception. SAS IT Service Level Management enables
IT providers and customers to verify that the quality of service that is delivered
justifies the cost.

Increasing Demands, Fierce Competition

IT customers today are often more familiar with the vast potential of current
technologies than they were in the past; therefore, they often demand more from the IT
providers that support their lines of business. Customers who are not familiar with the
technology can also be demanding. An incomplete understanding of the IT
infrastructure can lead to unrealistic demands and a failure to acknowledge outstanding
service. To further complicate matters, the IT customer has a wide range of options
when selecting an IT provider. Both technology and highly skilled IT professionals are
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widely available, and the competition is fierce. If a customer is not satisfied with the
levels of IT service provided, other IT providers stand ready to offer alternatives.

Proving the Value of IT Services

Of course, good customer service should always be a goal. Today, more than ever, it is
to the advantage of IT providers—both internal IT departments and external IT
companies—to go above and beyond providing merely satisfactory basic services.
Providers need to demonstrate to their customers that the IT services that they offer
have the following qualities:

0 They are dependable, efficient, and economically reasonable.
O They are closely aligned to the needs of the lines of business.
O They are likely to result in a clear return on investment.

Continuous Improvement of IT Services

Many IT providers are turning to SLM to help them increase the quality of their
services, ensure a positive experience for business customers, and improve
communication and understanding between providers and customers. The following
sections explain how SLM can help IT service providers to accomplish the following
goals:

0 evaluate and understand IT services from the customer’s perspective

O develop service level measurement and reporting that are meaningful for
customers

O plan future upgrades
O discover trends
o forestall developing problems

Subsequent chapters demonstrate how SAS IT Service Level Management software
addresses some of the common problems of SLM implementation and practice.

Note: For the remainder of the book, the term customer refers to the recipient of IT
services and the term provider or contract provider refers to the provider of those
services, whether the provider is part of the same organization as the customer or is an
external, third-party provider. When the discussion warrants a distinction between an
internal IT department and an external IT provider, this fact will be clearly noted in
the text. 2

The Goals of Service Level Management

Understanding and Meeting Business Needs

The concept of service level management was born out of the mutual need of IT
providers and their customers to fully understand the business needs for IT services
and to ensure that those needs are met. If providers and customers do not communicate
effectively, inappropriate service goals might be established.

For example, if a provider gauges effectiveness of service based only on the
availability of each IT component, overall service rates could be well above 99.9%, and
the provider might be very proud of an excellent record of availability. At the same time
that the IT department is congratulating itself on superior service, customers could be
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experiencing unacceptable service outages due to slow system response time. It is
possible that the repeated failure of a single component, though brief in duration, could
lead to the loss of massive amounts of data. It could also be that a 45-minute outage
that still results in an availability score of 99.9% results in a much longer outage for
the customer.

In reality, no single component functions in isolation. The outage of a major system
component might require additional time to re-establish lost connections and reconfigure
dependent systems. Imagine, for example, the effects of a server outage on an online
catalog ordering system—especially if the outage occurs during a prime ordering time!
A company that experiences such difficulties will probably not be impressed with that
99.9% figure. Focusing on equipment performance rather than on service delivery and
the customer experience often provides a skewed view of service quality.

When SLM is implemented properly, providers and customers work together to
establish IT service delivery goals that are directly correlated to the way that business
customers actually use and experience IT services. When IT services are evaluated with
the customer’s perspective at the forefront, the focus changes from a disconnected
overview of all underlying components and services to a more detailed view of the
collective components and services as they directly affect the applications and functions
most vital to the business.

Steps for Implementing Service Level Management

Some of the most important steps in the process of implementing SLM include the
following:

o Identify business needs. For example, 99.9% availability of catalog ordering
system on a daily basis between the hours of 7:00 a.m. and 10:00 p.m., with
scheduled maintenance outages between the hours of 2 a.m. and 4 a.m., if possible.

o0 Establish measurable service goals for each of the specified components and
services.

0 Specify the IT resources that are required to support the business needs.

Ongoing Service Level Management Activities

After implementation is complete, the ongoing processes of monitoring, documenting,
reporting, and reviewing can begin, enabling you to do the following:

0 Monitor IT resources with a focus on ensuring that business customers experience
the best possible levels of service.

0 Document IT performance and report back to customers in a way that is
meaningful and understandable to them.

0 Review results regularly with the customer and adjust service level goals if needed.

0 Quickly adjust your SLM processes to accommodate hardware and software
changes and other IT changes.

Moving Beyond Good Intentions

By implementing SLM, IT providers gain increased sensitivity to customers’ IT
needs. Such providers are better able to anticipate customer requests and exceed
customer expectations. SLM also helps customers to better understand their own IT
requirements and to have more realistic expectations. Such customers are aware of the
real successes and failures of the IT providers, and they are able to recognize superior
service. But how can IT providers and their customers move beyond good intentions
and ensure that SLM is effectively implemented? How can they put their IT service
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information to work to continually improve the quality of the IT services? The
establishment of effective, quantifiable contracts is part of the solution.

Effective Contracts

SLAs specify service level objectives for one or more IT services that the customer
receives from the provider. A single contract can contain SLAs for several major
services, such as e-mail, an online catalog ordering system, an intranet, a wide area
network, and an internal telephone system. Formalizing service level goals in SLAs
enables providers and customers to use the IT service information that they collect to
precisely describe the services and how they will be provided, measured, monitored, and
reported on.

Establishing baselines and goals for service levels accomplishes the following:

O helps ensure that IT services are aligned with business goals

0 helps customers to gauge their service level expectations

O delineates clear pathways for improvement of service delivery

O provides all parties to the SLA with a basis for judging quality of service

Delineating Business Needs

SLAs focus on a required service as the customer uses and experiences it. In other
words, an effective SLA takes into account all of the components and contributory
services that must be available and functioning in order to deliver the final service that
the business customer requires.

Establishing Measurable Service Goals

Service level objectives are specified for the delivered service. The focus, once again,
is on the quality of service that the customer experiences. Some common types of
service level objectives that are addressed in SLAs are availability, or the percentage of
time that a system is available to respond to the requests of its users; response time, or
the amount of time between the submission of a request for service and the user’s
receipt of the system’s reply to that request; throughput, or the rate at which requests
for work are processed by a computer system; a custom objective, or an objective that
meets your unique business needs; and a composite objective, or an objective that
combines two or more objectives.

Specifying Measurement Techniques

After service level objectives are specified, meaningful measurement techniques must
be adopted. Judgments about how well service level objectives have been met are based
on these measurements. The SLA specifies what aspect of each component and service
will be measured and how those measurements will be calculated, reported, and used
over time.

Defining Appropriate Reporting Periods and Methods

The IT provider and the customer should agree on what types of reports will be
prepared, how frequently they will be prepared, and how they will be presented. The
most effective reports provide clear, easy-to-understand information about the overall
quality of service that is provided to the customer, even though the data that is
presented might come from disparate sources and be related to diverse equipment,
functions, and service components.
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By agreeing on and recording the service level objectives and the specifics of how
progress toward these objectives will be monitored, measured, and reported on, IT
providers and their business customers improve both the services and the perceptions of
service success. This understanding accomplishes two objectives:

0 It enables providers and customers to work together to fine-tune the alignment of
IT services to the lines of business.

o It facilitates the continued exploration of options and opportunities for continually
improving IT services.

Common Problems with Contracts

Even after they have completed all the required legwork to create well-structured
contracts, IT providers and their customers face additional difficulties in implementing
the SLAs that are included in their contracts. They often lack the necessary
substantiating data. Sometimes, they find that it takes so much time to produce and
maintain the necessary reports that reporting is finally dismissed as unfeasible by both
the customer and the provider. The problem is not really lack of data, however. There
could actually be an excess of data!

The delivery of a specific business capability to a customer is made possible by a
chain of hardware, software, personnel, information, and other resources. Each of these
foundational IT components and services contributes to the success or failure of the
service that is covered in the SLA. Among other problems, the complexity of the data is
increased because IT data has the following characteristics:

0 It is collected by many different tools and for many different purposes.
o It is not typically stored in a central location.
0 It is dissimilar in measurement type and format.

Yet IT providers and customers must access, filter, manage, analyze, and report on
vast amounts of this complex data in order to establish service level objectives and
monitor IT service levels.

The following paragraphs present a closer look at some of these common problems.

Data Collected by Many Different Tools and for Many Different Purposes

There are almost as many tools for collecting IT information as there are hardware
and software manufacturers. But the tools that are created to monitor one device often
will not work for devices that are made by a different manufacturer or for different kinds
of devices. Also, IT providers must incorporate and interpret data from third-party
providers such as AT&T, BellSouth, and Cisco. Sifting through so much disparate data
and trying to determine what is “meaningful” is difficult and time-consuming.

Data Not Typically Stored in a Central Location

In order to access, filter, manage, analyze, and report on data, you have to find it.
After you have decided which data you need in order to calculate service level
performance, SAS IT Service Level Management enables you to extract the data from
remote or local sources and store it in a contract database.

Data Dissimilar in Measurement Type and Format

The data that is collected from different components and services is not always
comparable. How does the data from one device really compare to the data from a
different device, when both are required to deliver a particular service to the customer
and the performance of both must be measured for the same purpose?
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SAS IT Service Level Management can help you address these and many other
problems.

SAS IT Service Level Management Software Overview

SAS IT Service Level Management is an easy-to-use, highly scalable, and flexible
SLM solution. Working with SAS IT Resource Management, SAS IT Service Level
Management enables you to do the following:

O Access IT performance data, no matter how it is collected or where it is located
and store the data in data source performance databases (PDBs).

0 Create a description of your contract and of each component, service, and SLA that
is covered by your contract, including instructions for analyzing the performance
data.

0 Simplify the complicated processes of applying service level objectives to the data
and storing the results in contract databases on the SLM server.

O Generate a variety of reports on service level performance as well as contract and
service delivery status.

The client/server architecture of SAS IT Service Level Management (see Figure 1.1
on page 7) ensures that you are able to access information from your desktop, while
most of the processing takes place on the SLM server.

Figure 1.1 The SAS IT Service Level Management Client/Server Architecture

Client Server Data Source
Platform Platform Platform
SAS IT Service Level PEY 8 8 8
Management Server Software
(includes SAS IT Remote PDB
Resource Management) data sources

Performance 8 8 8

data Local PDB
(contract
databases) data sources

environment
database

When you use SAS IT Service Level Management to define a contract and all the
SLAs, services, and components that belong to the contract, you also configure
information for accessing and analyzing the IT data in the data source PDBs. This
information is stored in the environment database. During the SLM extract, transform,
and load (ETL) process, illustrated in Figure 1.2 on page 8, SAS IT Service Level
Management uses the information in the environment database to do the following:

0 Make disparate data easily accessible.
0 Transform data and store it in a contract database.
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o Calculate service level indicators.

Figure 1.2 SAS IT Service Level Management ETL Process
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Makes Disparate Data Easily Accessible

SAS IT Service Level Management uses the flexibility and power of SAS IT Resource
Management. This enables you to access and analyze IT performance data from any IT
service process, no matter where the data resides.

Transforms Data and Stores It in a Contract Datahase

Using the power of the SAS IT Resource Management batch ETL processes, SAS IT
Service Level Management simplifies the process of extracting the disparate IT data,
transforming it, and loading it into the contract database on the SLM server.

Calculates Indicators for Service Level Performance Even with
Disparate Data

SAS IT Service Level Management enables you to construct a representation of your
contract. Using the GUI and detailed information about the IT services and components
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that are covered by your contract, you create a description of your contract and of each
component, service, and SLA that is covered by your contract. These descriptions of
each element of the contract and the graphical representations of these elements are
called nodes. Your original contract has a hierarchical structure; that is, there is an
overall contract that can contain one or more SLAs. The SLAs cover the specific
services that you offer. Those services are, in turn, a combination of other services or
components (or both). The structure of this contract hierarchy is duplicated within SAS
IT Service Level Management.

SAS IT Service Level Management calculates and reports on service level objectives
for availability, response time, throughput, custom objectives, and composites of these
objectives.

A more detailed overview of the contract hierarchy and how values are calculated
and applied throughout the hierarchy is provided in Chapter 2, “Transforming IT Data
into SLM Intelligence,” on page 11.

Generates Reports That Are Meaningful to Providers and Customers

SAS IT Service Level Management uses the relevant data about IT services to
generate reports that clearly communicate to providers and customers how well service
level objectives are being met. Baseline reports, Service Level reports, and SAS
Enterprise Guide reports are provided for comprehensive reporting capabilities.

Baseline Reporting

SAS IT Service Level Management generates Baseline reports that display all of the
data that exists in a contract database for a specified contract within the current
environment. These graphic reports provide guidance for establishing initial service
level targets based on supplied network data.

The Baseline reports are generated in a Web gallery. The gallery enables you to view
hourly, daily, and monthly data in a graphic report. These reports enable you to see
trends for the objectives that are defined in your contract database.

Service Level Reporting

SAS IT Service Level Management also generates an interlinked set of Web-based
reports that enable you to view the compliance of service level indicators to their
respective targets. These reports provide information on all levels of a contract
hierarchy and can help you quickly assess compliance by determining whether service
level targets have been met. You can drill down from one level of the contract to the
next level and switch from daily to weekly to monthly to yearly reports. Both text-based
and graphic reports are provided.

Enterprise Guide Reporting

SAS IT Service Level Management also provides a SAS Enterprise Guide project that
can be used as a template for accessing your data and creating new reports
interactively. SAS Enterprise Guide reports can be directed to a Web browser, to the
Enterprise Guide viewer, or to a viewer of your choice.

Additional information about SAS IT Service Level Management reporting is
provided in Chapter 4, “Reporting on Your SLM Data,” on page 69.
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Provides a User-Friendly Graphical User Interface

The GUI enables you to navigate quickly and easily through even the most complex
contracts. In addition to the familiar menu bar, toolbar, and pop-up menus, you will
find a workspaces list and a task list that provide instant access to common tasks.
These tasks are carefully organized into related groups and presented in the five main
workspaces. The other windows that are associated with each of the workspaces enable
you to fine-tune SAS IT Service Level Management to accommodate your existing
contracts.

Using SAS IT Service Level Management does not require an in-depth
understanding of SAS programming. The flexible GUI enables you to do the following:

O

O 0o o oo o d

Define the contract and each SLA, service, and component node in the contract
hierarchy.

Select metrics and calculations.

Define service level objectives.

Set targets.

Define range sets and range descriptions for purposes of scoring and reporting.
Adjust data to accommodate both scheduled and unscheduled outages.
Designate customer and provider contacts.

Generate reports.

Other SAS IT Management Solutions

Besides SAS IT Service Level Management, there are several other SAS IT
Management Solutions.

O

O

SAS IT Resource Management. Brings your disparate data into a customized
warehouse where it can be used for IT resource management across your
enterprise from your desktop.

SAS IT Charge Management. Combines IT subscription and transaction-based
charge information to allocate, audit, and invoice IT usage in specific business cost
centers.

For additional information about SAS IT Management Solutions, visit the Web site:
http://www.sas.com/solutions/itsysmgmt/.
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Overview of IT Service Level GCalculations

In Chapter 1, “Introduction to SAS IT Service Level Management,” on page 1, you
learned that SAS IT Service Level Management enables you to construct a
software-based contract that mirrors your established IT contract. You also learned that
SAS IT Service Level Management enables you to define service level objectives for
every node in your contract hierarchy and to specify how the performance data will be
accessed and how service level indicators will be calculated. In this chapter, you will
first learn more about the structure of a contract hierarchy. Next, you will learn more
about service level objectives. Finally, you will learn about how SAS IT Service Level
Management performs service level calculations based on the service level objectives
and applies them to each node in the contract during the ETL process.

The information in this chapter will help you to understand the SAS IT Service Level
Management GUI as depicted in Chapter 3, “Using the SAS IT Service Level
Management GUL” on page 29. That chapter introduces the GUI and illustrates the
main steps for creating a new service contract and automating the data evaluation
processes for that contract.
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Understanding the Structure of Your Contract

Before you create a contract in SAS IT Service Level Management, you might
already have a written contract. At the very least, you need to formulate a plan that
specifies the services that you intend to provide to customers and how you will measure
those services. SAS IT Service Level Management can help you develop a contract and
set reasonable targets for services by providing Baseline reports that show baseline
data in a contract database.

When you create the contract by using SAS IT Service Level Management, you create
a separate node for the contract itself and for each SLA, service, and component that
the contract covers. This contract mirrors your written contract or plan. If your plan
contains multiple levels of complexity, then the contract that you create in SAS IT
Service Level Management duplicates this level of complexity.

The Structure of the Contract Hierarchy

There are four kinds of nodes in the contract hierarchy. These include the component
nodes, the service nodes, the SLA nodes, and the contract nodes. When you create a
contract in SAS IT Service Level Management, you create all the nodes that you need
to represent all the SLAs, services, and components that your contract covers, and you
enter information that clearly establishes the relationships between the nodes.

The contract hierarchy can be visualized as a pyramid, with the contract node,
representing your whole contract, at the highest level. The contract node can have any
combination of zero, one, or more SLA, service, and component nodes as its immediate
child nodes. SLA nodes represent the various service level agreements that are covered
by your contract. There can be multiple SLA nodes, and an SLA node can have any
combination of zero, one, or more service and component child nodes. The service nodes
represent the services that are covered by each SLA. There can be multiple service
nodes, and a service node can have multiple child nodes, which can be services and
components. The component nodes represent the various software, hardware, or other
entities that make the delivery of an IT service possible. There can be multiple
component nodes, and a component node cannot have child nodes.

Note: See SAS IT Service Level Management: User’s Guide for more detailed
information about the structure of the contract hierarchy. A

Figure 2.1 on page 13 represents a simple contract hierarchy.
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Figure 2.1 Example Contract Hierarchy

Contract
Sales and shipping system

SLA SLA
Sales and shipping system Network
| |
| | | | |
Service Component Service Service Service
Billing Federal Order entry LAN WAN
Express

- - - - - - - - -

3 g 6| |8% §Z5 § @ & x gz gz
c 2 c o= c c c= c 3 c o €5 <& =<§( c<
0 = 0L g o © 0% o o5 o =2 o o=
o c o= Q 2o 858 2o o 3 8 =5 o o
Ex Em o £ = Ec 2 £ = € E%w £ €0
o o 3 og 05% og o o olg: oS
(8] (8] (8] (8] (8] (8] (8] o (&)

Contracts can be far more complex than the one shown in Figure 2.1 on page 13, and
SAS IT Service Level Management is flexible enough to adapt to your contract, no
matter how many SLAs, components, and services are included. However, as you learn
more about the contract hierarchy and the four kinds of nodes, this simple depiction can
help you to understand how the nodes in the contract hierarchy relate to each other.

Contract Nodes

The contract node is the highest-level node in the contract hierarchy. It represents
the complete contract.

SLA Nodes

An SLA node represents an agreement between an IT provider and a customer that
defines the services that are provided, the metrics that are associated with these
services, and acceptable and unacceptable service levels. Typically, an SLA covers one
or more business services. For example, an SLA for a sales and shipping system might
cover an order-entry service, a billing service, and an inventory service. While contracts
contain basic, high-level information about the customer and provider, the SLAs that
are contained within the contract usually contain more specific, detailed information
about the covered services.

Service Nodes

A service node represents one or more of the IT systems that typically enable a
business process to function. Services can be simple and low-level, such as offering a
service for disk space. They can also be high-level and more complex, such as offering a
Web application hosting service that is composed of numerous subsidiary services, like
a disk space service, Web server service, network service, and help desk service.



14

Component Nodes and Resources A Chapter 2

Component Nodes and Resources

Component nodes usually represent tangible IT hardware and software assets, such
as a Web server or disk farm. Components can be low-level, such as an individual
router, or high-level, such as an entire LAN/WAN.

For each component node that you define, you must create a list of resources. The
resource list is used to subset the data from the data source PDBs. For example, a Web
server component would have a resource list that identifies the servers in the Web
server farm.

Service Level Objectives

Service level objectives measure the service that the provider delivers to the
customer. The type of objective indicates what aspect of service is measured in order to
determine a value for the service level indicator. The type of objective is tied to the type
of data measurements that are available to you. Each node can have the following
types of objectives, which are based on the data from the child nodes:

Availability the percentage of time that a node is available to respond to the
requests of its users.

Response time the amount of time that a node takes to complete a request.

Throughput the volume of work that can be processed by a node within a
specified time.

Custom objective a user-defined objective that measures data that doesn’t typically fit
within the scope of availability, response time, or throughput, such
as customer satisfaction or mean time between failures (MTBF).

Composite an overall service level measurement, based on scores from any
combination of availability, response time, throughput, and custom
objective for the same node.

As you create the nodes for your contract, you also create the service level objectives
for each node. The service level objectives specify the following:

O calculation methods that are used for the indicator
O range set that is used to determine a score (when scores are used)

O service level target for the objective

Note: Indicators are always calculated for each objective of each node in the
contract, based on the selected objective and calculation methods. An indicator is
compared to a range set in order to obtain a score for each objective of a node. See
“Scores” on page 17 for more information about scores, indicators, and ranges. A

Indicators

An indicator is a value that represents the performance of a given objective for a
node. For a contract node, an SLA node, or a service node, the value for the indicator is
derived from the indicators or scores of the child nodes. For a component node, the
value for the indicator is derived from input measures that are extracted from the data
source PDB by means of the component node’s resource list.
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Ihput metrics from resources: Thiz Ohjective's Indicatar:

Meazures LI Code | Mean calculation of the

Availabilty Meazures far the
ESOUFCES,

Calculation Method:

IMean hd I

U=zed to roll-up the input metrics
la create this node's indicator.

Several calculation methods have been built into the software for each type of
objective. An appropriate method is set as the default; however, SAS IT Service Level
Management enables you to select a suitable alternative method to calculate the
indicator for each type of objective at each node. You can also specify code for a custom
calculation method for any indicator.

Note: More detailed information about appropriate calculation methods is provided
in SAS IT Service Level Management: User’s Guide. A

Range Descriptions

Range descriptions enable you to associate common descriptors with range sets for
various objectives types, resulting in a standard display of colors and labels within your
reports. Before creating and defining ranges that will classify the indicator values of an
objective, you will want to create your organization’s set of common range descriptions
to best represent all types of performance values. For example, you might define a
range description for objective indicators and scores that exceed expectations. In this
case, you might name the range description “Exceeded” and designate that the objective
indicators and scores that exceed your expectations will appear in your reports as blue
and be labeled “Exceeded.”

The following is an example of range descriptions that a user might create and
modify.

Current range descriptions from the catalog

arme Text Report Lakel
Excesded Sky Blue Excesded
flet Hanesydewy flet
hizzed Pale Yellow hizzed
Miszing Walue Ligght Grary Miszing Walue
COwt-of-bounds High Plum COwt-of-bounds High
Ct-of-bounds Low Plutn Ct-of-bounds Low
Pocr Misty Rose Pocr

There are six supplied range descriptions (Exceeded, Met, Missed, Missing Value,
Out-of-bounds High, and Out-of-bounds Low). Three of the supplied range descriptions
(Missing Value, Out-of-bounds High, and Out-of-bounds Low) cannot be deleted because
they classify unexpected values that might be outside of the user-defined ranges in a
range set.
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Range descriptions are also customizable when defining reports. You can override the
definitions of range descriptions for specific report specifications, thereby affecting the
colors and labels displayed in reports for the associated contracts. For example, you
might use a range description for all of your reports to display poor performance data in
red. However, one of your customers might have a unique requirement or cultural
preference that associates positive values to the color red. You can modify the range
description colors for the report specification showing red wherever indicators exceed
expectations, and this change will apply only to contracts within this report
specification. All report specifications that do not reference that unique customization
will continue to use the definitions of the original range description that displays poor
performance in red.

Note: For information about how to create and define range descriptions, see “Range
Descriptions” on page 48. More detailed information about range descriptions is also
available in SAS IT Service Level Management: User’s Guide. For more information
about ranges and range sets, see “Ranges and Range Sets” on page 16. A

Ranges and Range Sets

Ranges and range sets enable you to associate ranges of indicator values with scores
and range descriptions. Ranges help you to categorize service level indicators. Several
ranges are grouped to form a single range set. If ranges in a range set have defined
scores, then the appropriate score is assigned to the associated objective based on the
value of the service level indicator.

Range / Score | Mame | Text Report | Lahel |
97 ==x =958 3 et Horneydesns hiet

08 ==x ==09 2 Exceeded Sky Blue Exceeded

High 1 ot-of-bouncds High Plurn Out-of-houncds High
Loy 4

Foor Misty Rose Foor

A range set specifies the following properties for each individual range:
low value of the range

high value of the range

comparison operators for the high and low values

score

name of associated range description

report color of associated range description

O 0O o o o o o

report label of associated range description

Note: The missing, high, and low ranges are special ranges that are always present
in every range set. The purpose of these ranges is to capture data that falls outside the
user-defined ranges. Missing captures data where the indicator has a missing value.
High captures data where the indicator is above the user-defined ranges. Low captures
data where the indicator is below the user-defined ranges. By default, each of these
ranges assigns a score of missing; however, the score of these special ranges can be
modified. A

If a range set is selected for an objective, the value of the indicator is compared to a
series of ranges. For example, suppose that you use the range set that is depicted in the
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sample above. An availability indicator with a value of 99 would receive a score of 2,
while an indicator value of 93 would receive a score of 4.

Note: See “Range Sets” on page 49 for information about using the GUI to create
range sets. More detailed information about ranges and range sets is available in SAS
IT Service Level Management: User’s Guide. »

Scores

A range set can be used to assign a score based on the value of the indicator for the
objective. The score is determined by matching the indicator to the range that includes
the value of the indicator.

Scores simplify the process of calculating values for service level objectives when the
child nodes represent unlike entities. For example, to calculate a value for a response
time objective for a contract, you might need to combine data on response time for a
help desk operation with data on response time for a hard drive. The help desk
response time is measured in minutes, while response time for a hard drive is
measured in milliseconds. An excellent response time for a help desk would be very
poor for a hard drive. As Figure 2.2 on page 17 indicates, combining the service level
indicators for these would not produce a meaningful indicator for the contract.

Figure 2.2 Using the Indicators of Child Nodes to Calculate an Indicator for the
Parent Node

SLA
Troubleshooting

Response time indicator
Response time indicator Response time indicator

10 ms. 2 min.

Component Component
Hard drive Help desk

However, if you create a range set for the help desk and another range set for the
hard drive, as shown in Figure 2.3 on page 18, you can assign similar scores to the
unlike indicators.
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Figure 2.3 Using Range Sets to Assign Scores Based on the Indicators

Response time indicator Range Score
P Low (lower than 1 ms.) 1
10 ms 1 ms. < indicator < 50 ms. 2  t»lscore =2]
Component 50 ms. < indicator < 100 ms. 3
Hard drive High (higher than 100 ms.) 4
Response time indicator Range - Score
Low (lower than 0.5 min.) 1
2 min.|—— | 0.5 min. < indicator <5 min. 2 l»lscore=2|
Component 5 min. < indicator < 10 min. 3
Help desk High (higher than 10 min.) 4

Then you can use the scores to calculate the indicator for the parent node, as shown
in Figure 2.4 on page 18.

Figure 2.4 Using the Scores of the Child Nodes to Produce a Meaningful Result
for the Parent Node

SLA
Troubleshooting

Response time indicator
Response time score Response time score

Component Component
Hard drive Help desk

Note: See “Ranges and Range Sets” on page 16 for more information. More detailed
information about scoring is available in SAS IT Service Level Management: User’s
Guide. »~

Targets

The service level target represents the goal for service level performance that the
provider agrees to meet within a specified compliance period or time frame (daily,
weekly, monthly, yearly). Targets for service levels are agreed upon by the IT provider
and customer.

You can select the compliance period, target statistic (for indicators only), comparison
operator, and threshold value for the target. You can also indicate whether the indicator
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or the score for a particular node is compared to the threshold value to determine
whether the goal for that node has been met.

Target Definition
Compliance Period:  Target Statistic: Comparizon Yalue: Operator:  Target Walue: Lakel:

IMomhly j IMean LI Ilndica‘tor ﬂ |>= LI I 99.9) %

Compliance reports display lists of contracts and their compliance with the target
settings. IT providers and customers can use these reports to view the compliance of
service level performance across all objective types within contracts. See “Service Level
Reports” on page 77 for more information about compliance reports.

Note: More detailed information about targets is available in SAS IT Service Level
Management: User’s Guide. A

Data Adjustments for Outages

SAS IT Service Level Management provides methods for adjusting service level data
to exclude planned and excused outages from calculations of indicators. An outage is an
event during which contracted services are not available for a period of time. Some
outages are necessary or unavoidable, and these outages should not count against the
provider. Necessary outages typically include scheduled outages for required systems
maintenance or for holidays. These outages are planned in advance, and the provider
should not be held responsible for the service interruptions that result. Unavoidable
outages are beyond the control of the provider. These include outages that are caused by
natural disasters such as hurricanes and ice storms. These kinds of unplanned outages
are considered “excused outages,” and the provider is not held accountable for them.

SAS IT Service Level Management enables you to specify the start time and end time
of an outage and the type of outage (scheduled or excused).
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x
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Outage Mame: Iz this outage in effect?

|Just Befare Midriht fres =l
Reason far the Outage: Outage Type:

[+

Fossible Meirtenance [schecules =]
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f—]— j Expenze Accourting
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= Finance HUEs
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El—ﬂrgjemal Switch
Swvitch 9322 Cotnpotent

,&, Expense Application
—1.53 League Application
1 PHILLIP &pplication
1 cORP3 Application
=14 Payral

H:‘—A Firanmro hlatunsmwl L ;I

Selection: Finance Department

Mote: Any children of the selected node will inherit this outage.

Ok I Cancel Help

During the period of an outage, data that is related to the affected nodes can be
missing or invalid, or the data can simply reflect very unsatisfactory performance.
During ETL, SAS IT Service Level Management notes the scheduled and excused
outage periods and excludes the related data from all calculations.

Information about outages can be entered into SAS IT Service Level Management at
any time. If you enter the outage details after the outage has already occurred, then
the next time ETL runs, SAS IT Service Level Management adjusts the service level
data to exclude the data from the outage period.

Extract, Transform, Load (ETL)

During the ETL processing, SAS IT Service Level Management performs data
extraction and service level calculations throughout the hierarchy. As you have already
learned, instructions in each contract node, SLA node, and service node specify how the
data from the child nodes will be used to calculate indicators and scores. For component
nodes, data is extracted from data source PDBs.

Downward Flow of Instructions for Data Extraction and Service Level
Calculations
One way to think about ETL is to visualize the instructions for data extraction and

service level calculations, beginning at the highest level of the contract hierarchy and
moving down.
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Figure 2.5 on page 21 shows that instructions in the contract node’s objectives specify
which data is extracted from the SLA child nodes and how the indicator is calculated
for each objective.

Figure 2.5 Example of Contract Node Instructions for Data Extraction

Contract
Sales and shipping
system
‘// \\*
SLA
Sales and shipping SLA
system Network

Figure 2.6 on page 21 shows that instructions in the SLA node’s objectives specify
which data is extracted from the service and component child nodes and how the
indicator is calculated for each of the SLA’s objectives.

Figure 2.6 Example of SLA Node Instructions for Data Extraction

SLA
Sales and shipping
system
' 1 ~
// 1 \\
//// : \\\\
x° v Y
Service Service
Billing - 3 Order entry
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ouw
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Figure 2.7 on page 22 shows that instructions in the service node’s objectives specify
which data is extracted from the service and component child nodes and how the
indicator is calculated for each of the service node’s objectives.
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Figure 2.7 Example of Service Node Instructions for Data Extraction
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Instructions in the component node’s objectives and in the associated resource list
specify which data is extracted from the data source PDBs and how the indicator is
calculated for each of the component node’s objectives (see Figure 2.8 on page 23). For
example, the data that is retrieved from the data source PDBs for the printing
component is filtered by the resource list. The data source PDBs can contain data from
many printers and other devices; however, data is retrieved only for the three printers
that are specified in the resource list and only for the types of objectives that are
activated for the component.
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Figure 2.8 Example of Component Node Instructions for Data Extraction

Component
Printing

Resource List

= Printer 1
= Printer 2
= Printer 3
, : The printing component node
ot ! does not have a throughput
e : objective, so data will not be
7 : extracted from the throughput
- ! data source PDB.
5 v
Availability Response time Throughput
data source data source data source
PDB PDB PDB

Upward Flow of Data and Service Level Calculations

The instructions for data extraction come down from the parent nodes; however, the
data enters the hierarchy through the component nodes and moves upward. When the
previously specified calculations of indicators and scores are completed for a node, the
data is available to be extracted by the parent node.

For example, in Figure 2.9 on page 24, the printing component node has an
availability objective, a response time objective, and a composite objective. Based on
information in the resource list, the printing component node extracts availability and
response time data for three printers from the data source PDB. The availability
objective specifies that the availability indicator is the mean of the availability
indicators from Printer 1, Printer 2, and Printer 3. The response time objective specifies
that the response time indicator is the mean of the response time indicators from those
same three resources. The composite objective specifies how the composite indicator will
be calculated from the indicators of the other two objectives for the node.
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Figure 2.9 Example of Data Entering the Contract Hierarchy through a Component

Node
Component
Printing
»  Availability indicator
Response time indicator |«
Composite indicator
A A
Note: Figure 2.10 illustrates
calculation of the
composite indicator
. Printing component
L | Printing component 9 p ]
AL response time
availability indicator N
indicator
y A
Resource | | Resource | | Resource Resource | [ Resource | | Resource
Printer 1 Printer 2 Printer 3 Printer 1 Printer 2 Printer 3
response | | response | [ response
availability| |availability| [availability time time time
indicator indicator indicator indicator indicator indicator
A
Availability Response time
data source data source
PDB PDB

Throughput
data source

No throughput data

is required because
there is no throughput
objective for the
printing component.

Figure 2.10 on page 25 illustrates in more detail how the composite indicator for the
printing component node is calculated.
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Figure 2.10 Example of Calculating the Indicator for the Composite Objective
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After indicators are calculated for the component nodes, the data is extracted by
service and SLA parent nodes and then by their parent nodes on up through the
hierarchy. Based on the previously specified instructions in the service level objectives
of the parent nodes, indicators and scores for parent nodes are calculated as the data
becomes available for extraction from the child nodes. Indicators are automatically
calculated for every node in the contract. Some nodes might also have scores calculated
for them. Scores are particularly useful when the data from the child nodes is dissimilar.

Figure 2.11 on page 26 is an overview of how the data moves back up through the
hierarchy. You can look at this figure and visualize how those instructions might be
implemented when the data becomes available for extraction. For example, the billing
service node extracts data from the printing component, the billing application
component, and the database 1 component to calculate indicators for the billing service
node. A billing service might have availability and response time objectives, and these
components seem likely to have response time and availability data that is associated
with them. Because these components are likely to have very different indicators, the
objectives for the billing service node probably specify that range sets will be used to
calculate scores, and the scores will be used to calculate meaningful indicators for the
billing service node.
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Similarly, the sales and shipping SLA node could extract availability and response
time indicators from its child nodes, which include a billing service, an order entry
service, and a Federal Express component. The SLA node would also be likely to use
range sets to assign scores in order to calculate meaningful indicators for its objectives.

Finally, at the top of the hierarchy, the sales and shipping contract node could have an
availability objective, a response time objective, a throughput objective, and a composite
objective. A different calculation method could be used for each objective. For example,
the contract node might simply extract availability indicators from each SLA node and
calculate an indicator from the mean of the child nodes’ indicators. The response time
objective might require the use of scores to calculate an indicator. The indicator for the
throughput objective might be based on data from the network SLA node only.

Note: See “Service Level Objectives” on page 14 to review the definitions of
objectives, indicators, scores, and range sets. More detailed information about data

extraction and calculations of scores and indicators is provided in SAS IT Service Level
Management: User’s Guide. »

Figure 2.11 Example Flow of Indicator and Score Calculations Up Through the

Contract Hierarchy
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Summary

When the ETL process runs, instructions in each parent contract, SLA, and service
node, beginning at the contract node, specify the following:

O whether indicators or scores will be extracted from the child nodes and for which

objectives

0 what method(s) will be used to combine the indicators or scores that are extracted

from the child nodes and calculate an indicator for each objective that has been set
in the parent node
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0 whether scores will also be calculated for the parent node and for which objectives

Data enters the contract hierarchy through the component nodes. The resource list of
each component specifies exactly which data is imported and filters out all the rest.
Instructions in the objectives of the component node specify how an indicator is
calculated for the node and whether scores will also be calculated and for which
objectives.



28



CHAPTER

Using the SAS IT Service Level
Management GUI

Overview: Getting Ready to Run SAS IT Service Level Management

Starting the GUI 30
Exploring the GUI 33
Navigation 34
Menu Bar 34
Toolbar 34
Workspaces List 35
Hierarchy Tree Pop-up Menus 35
Task List 35
Tabs 35
Workspaces 35
Contract Workspace 35
Catalog Workspace 36
Participants Workspace 37
Data Workspace 37
Reports Workspace 38
Using the GUI to Construct a Contract 38
Defining Server Connections and Data Sources
Server Connections 40
Data Sources 42
Adding Participants 42
Contacts 43
Customers 44
Providers 46
Creating Catalog Items 47
Range Descriptions 48
Range Sets 49
Components 52
Services 59
SLAs 60
Creating a Contract 61
The Contract Workspace 61
The Contract Window 62
Running ETL 68
Closing SAS IT Service Level Management 68

39

29




30 Overview: Getting Ready to Run SAS IT Service Level Management A Chapter 3

Overview: Getting Ready to Run SAS IT Service Level Management

In previous chapters, you learned how SAS IT Service Level Management can help
you manage your service level contracts. This chapter describes how to use the GUI to
do the following:

O Access IT performance data.

0 Define all the measurable nodes—components, services, and SLAs—that make up
a contract.

o Designate service level objectives for each node.
0 Select your preferred methods of processing and evaluating the data.
Note: Many of the screen images in this chapter show sample data and settings to

help you understand how data might appear in your SAS IT Service Level Management
application. A

Starting the GUI

The first time you log on to SAS IT Service Level Management, you must select the
existing environment that you want to use or edit properties to define an appropriate
environment for your needs.

The SLM environment contains the SLM environmental data for a contract.
Environmental data describes the software objects that you define and use to create the
contract—that is, the SLAs, services, components, customers, providers, and more.
Typically, you need only a single SLM environment. You can have multiple
environments; however, you cannot open more than one environment at a time.

To start SAS IT Service Level Management, you can use either of these methods:

0 Select the SAS IT Service Level Management icon on your desktop.
0 From the Windows taskbar, select Start » Programs » SAS IT Service Level
Management.

The Log On Info dialog box opens.
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SAS IT Service Level Management

SAS

IT Management Solutions
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A Starting the GUI

X

~Log On Infa

Environtment:
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}“IEWLISEI’ - I

8],1

Cancel

Help

The Log On Info dialog box permits only authorized users to access your data (SAS IT
Service Level Management observes the default authorization for the operating

environment).

To log on to SAS IT Service Level Management, do the following:

1 Click the arrow to the right of the Environment field and select the environment

that you want to use.

2 Enter your user name and password.

3 Click ok.

If you need to edit your environment, complete the following steps:

1 Click Edit.

31

The Environment List dialog box opens. This is the starting point for adding or
removing an environment or for editing the properties of the environment that you

have selected.
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Environment List

localhost
localhost
localhost

Select the environment that you want to edit.

Click Properties to display the Environment Properties dialog box and enter or

edit the environment details.

Note:

Detailed instructions for editing environment properties are provided in

SAS IT Service Level Management: User’s Guide. A

Environment Properties

General Ervvironment Mame:

Sample Environment

Description:

Default

Cannection Infa Hosthatne:

localhost

Fort:

2323

SErver OS5

Windowes

Spawner:

Connection reguires authertication:

SAS Command:

=83 -dinr -comamid top -hoterinal - ...

Path to Enviranment Database:

ciElmignyironment

Path to Software:

Path to WX G Format Library:

Enahle SASSSHARE:

r

SASShare Service ar Port:

Acvanced Server 0% Lizet Marme Prormgt;

Lsernarme:

Uzer Marme Prompt Timeout (sec):

20

Paszword Prompt:

Paszword:

FPazzword Promgt Timeout (sec:

5

Comtnand Prormpt:

Hello=

Carmtnand Prompt Titneout (sec):

20

Fart Prormpt:

PORT=

e ea il =]

4 Use the Environment Properties dialog box to enter the properties for your SLM

environment. The Category column lists groups of properties. The Attribute
column lists the names of the individual properties. The Value column lists the
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values of the properties. The environment data is stored on the SLM server
platform and is accessed by means of the connection to the SLM server. The
environmental data is saved and is automatically opened as the default
environment the next time you start SAS IT Service Level Management.

5 Click oK in the Environment Properties dialog box and on the Environment List
dialog box to return to the Log On Info dialog box.

6 Click oK in the Log On Info dialog box to finish logging on.

When you log on, the main window opens with the Contract workspace displayed.

}F, SAS IT Service Level Management - 5amplesT 2205 - EI|5|
File Edt “iew Tools Help

DES|X Bl#mi g ?

Wiotkspaces X = : Ilame Custamer Endl Date | Status Task List x I
External Custamers |7 Exernal Customers Hew
a Irterrial Customers [ irternal Customers aCraa{e pp—

Contra

&

Cataloy

3

Participants

Data

Reports

2

E]Craaha a Folder

K2} || Refresh this wiew

|User Hame: mabnma

Exploring the GUI

The GUI is designed for functionality and ease of use. There are several methods of
navigating to almost every window or dialog box. The SAS IT Service Level
Management main window (Display 3.1 on page 34) contains the following interface
components:

0 Menu bar

Toolbar

Workspaces list

Hierarchy tree pop-up menus

O
O
O
O Task list
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Display 3.1 Interface Components of the Main Window
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In addition to the familiar menu bar, you’ll find shortcut icons on the toolbar, the
Workspaces list, and the Task list that take you to windows and dialog boxes where
you can complete specific tasks. Pop-up menus are also available by right-clicking any
item in the hierarchy tree to display the pop-up menu for that item. Keyboard shortcuts
are also available for many common tasks.

When logging on and using the GUI, you might also notice that some commands take
a few moments to display a result because of the amount of data retrieval and
processing that the GUI must perform. These instances are marked with progress
indicators such as an hourglass or dialog box to inform you that SAS IT Service Level
Management is working.

Navigation

Menu Bar

The menu bar is available in each of the workspaces—Contract, Catalog,
Participants, Data, and Reports. The menu bar contains five standard commands:
File, Edit, View, Tools, and Help. Select one of these commands to display a
drop-down list of options. The options that are available on a given drop-down list are
determined by which workspace or window is currently open.

Toolbar

The toolbar is located just below the menu bar at the top of the SAS IT Service Level
Management main window. The icons are shortcuts to common tasks. Accessibility of
the tools is determined by the current workspace and task. Hold the mouse pointer over
a tool icon to display a tool tip that explains the purpose of the tool.
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Workspaces List

On the left side of each of the main SAS IT Service Level Management workspaces,
you will find a vertical workspaces list. Each of the icons on this list is a shortcut to
one of the five main workspaces.

Hierarchy Tree Pop-up Menus

Many functions can also be accessed by using pop-up menus. When you select a
workspace to display, you’ll see a hierarchy tree. You can right-click an item on the tree

to display a pop-up menu. The pop-up menu provides quick and easy access to common
tasks for the selected item.

Task List

The Task list is another easy way to access common tasks quickly and easily. Each
workspace displays a list of the tasks that can be accomplished within that workspace.

Tabs

Navigation tabs appear on the dialog boxes that open after you select a task from a
workspace. Each dialog box contains a unique set of tabs. For example, the Component
dialog box displays the following tabs: General, Date Filter, Objectives, Data,
History, and Notes. By entering information in the fields on these tabs, you complete
the task of creating a component.

Workspaces

SAS IT Service Level Management simplifies the creation and maintenance of
contracts by providing five main workspaces—Contract, Catalog, Participants, Data,
and Reports. These workspaces represent collections of dialog boxes where the tasks of
creating, modifying, deleting, and reporting on the building blocks of contracts take
place.

Contract Workspace
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The purpose of the Contract workspace is to facilitate management of contracts. From
this workspace, you can access the dialog boxes where you perform the following tasks:

o Create a new contract.
o0 Define, manage, and organize lists of current contracts.
O Modify or remove an existing contract.

Catalog Workspace
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The purpose of the Catalog workspace is to provide easy access to the nodes that are
used to create contracts. From this workspace, you can access the dialog boxes that are
used to complete the following tasks:

O View predefined catalog items.

Create, modify, or remove a single catalog item.

Define, manage, and organize lists of predefined services.
Define, manage, and organize lists of predefined components.
Define, manage, and organize lists of predefined SLAs.
Define, manage, and organize range sets.

O oo o o

Define, manage, and organize range descriptions.
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Participants Workspace
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The purpose of the Participants workspace is to facilitate the creation and
management of the contact, provider, and customer descriptions that you need to build
a contract in SAS IT Service Level Management. From this workspace, you can access
the dialog boxes that are used to complete the following tasks:

0 View and manage lists of contacts.

0 View predefined contacts, customers, and providers.

o Create, modify, or remove a single contact, customer, or provider.

0 Indicate which contacts are related to a customer or provider.

Data Workspace
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The purpose of the Data workspace is to provide easy access to the data items that
are used in creating contracts. From this workspace, you can access the dialog boxes
that are used to complete the following tasks:

0 Define, modify, or remove a connection to a data source server.
o Connect to and disconnect from a data source server connection.
O Define data sources.

O View data sources and related tables.

O View contract databases and their tables.

Reports Workspace
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The purpose of the Reports workspace is to facilitate the creation and management of
specifications for defining, generating, and viewing Service Level reports. From this
workspace, you can access the dialog boxes where you perform the following tasks:

o0 Define report global settings such as report output locations and style sheet
parameters.

o Create, modify, or delete report specifications for contract providers and customers.

o Organize and manage report specifications into contract provider folders and
customer folders.

0 Create report job codes for processing in a batch environment.
0 Generate and view report results.

Using the GUI to Construct a Contract

Before you can create a contract within SAS IT Service Level Management, you must
create or define data sources, participants, range descriptions, range sets, components,
services, and SLAs that you will later select to create your service level contract. As
explained in Chapter 1, “Introduction to SAS IT Service Level Management,” on page 1,
you must have all the information about your service level contract readily available
before you begin to set up your software to monitor and report on your SLAs.
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Note: SAS IT Service Level Management software is a means of capturing the work
that you completed during the negotiation phase of the service level management
process as laid out in the IT Infrastructure Library (ITIL) SLM process that is
described in the book Service Delivery (IT Infrastructure Library Series). A

This section describes the logical steps in creating a contract. For the purposes of
this overview, we’ll briefly discuss the windows and dialog boxes that you will use to
create a contract. Detailed instructions for these steps are provided in SAS IT Service
Level Management: User’s Guide.

SAS IT Service Level Management enables you to use a bottom-up approach to
create all the nodes and describe all the server connections, data sources, participants,
and range sets that you will ultimately select when you create the contract itself. The
elements that compose the foundation of the contract hierarchy include the following:

server connections
data sources
participants
range descriptions
range sets
components
services

SLAs

contract

© 00 N O O B W N =

The following sections present an overview of the workspaces and dialog boxes that
are used to define or create each of the elements in the creation of a new contract.

Note: See “Understanding the Structure of Your Contract” on page 12 for additional
information about the contract hierarchy. A

Defining Server Connections and Data Sources

The Data workspace is a logical starting point for defining the data sources that will
be used in creating a contract. Use the Data workspace to do the following:

0 Define data source server connections.
0 Define data sources.

All performance data enters the hierarchy through the components. The data that is
feeding into the objectives that are selected for each component comes from a data
source that is designated for that component’s objectives. No processing can take place
until SAS IT Service Level Management can access the data source. Therefore it is
logical to begin the process of creating a contract by defining data server connections
and data sources.

Either of the following actions displays the Data workspace:

O Select the pata icon from the Workspaces list.
0 From the menu bar, select View » Data.
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Server Connections

When you define the server connections, you are enabling SAS IT Service Level
Management to find the server(s) where your data source is located.
To define a server connection, complete the following steps.

1 Display the Server Connection dialog box by completing one of the following
actions:

0 From the menu bar, select File » Define » Server Connection.

0 Right-click server Connections in the hierarchy tree, and from the pop-up
menus select Define » Server Connection.

O Select Define a Server Connection from the Task list.

E Server Connection: Untitled

2 In the Sserver Connection Name field, type the name of the server connection
that you want to create.

3 Click the pefinition tab.
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E Server Connection: Untitled
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4 Type a hostname in the value column cell that corresponds to the Hostname row.
This cell must be complete in order for SAS IT Service Level Management to
connect to the requested server.

Complete the other fields as necessary.
6 Click the Notes tab.

E Server Connection: Untitled

his iz where you can type notes for this server connection.

7 Type any additional information that you want to include about the server
connection that you are creating.

8 Click ok.
The new server connection is now defined.

Note: The Notes tab is the last tab in most dialog boxes. The purpose of the Notes
tab is to display an area where users can add notes and attachments to a component,
service, SLA, contract, range set, customer, provider, data source, contract database, or
server connection. Because the Notes tab appears and functions the same throughout
each workspace, no further illustrations are provided in this documentation. A
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Data Sources

Defining a data source tells SAS IT Service Level Management how to find a SAS IT
Resource Management (ITRM) performance database (PDB) where performance data is
stored. SAS IT Service Level Management uses this data to calculate service level
indicators.

To define a data source, complete the following steps:

1 Display the bata Source PDB dialog box by completing one of the following
actions:

0 From the menu bar in the Data workspace, select File » Define » Data
Source PDB.

0 Right-click bata Source PDBs in the hierarchy tree and from the pop-up
menus select Define » Data Source PDB.

O Click pefine a Data Source PDB in the Task list.

E Data Source PDB: Untitled

2 In the pata Source PDB Name field, type the name that you want to use for the
data source that you are defining.

3 In the Path to Data Source PDB field, type the path to the location of the data
source.

4 In the Server Connection Name field, select the correct server connection for the
data source that you are defining.

5 If you want to add notes, click the Notes tab.
6 Click ok.

Adding Participants

Contracts typically involve two parties, a customer and a provider. The Participants
workspace enables you to enter contact information for all the people who are parties to
a contract, whether they are customers, providers, or other types of contacts.
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Either of the following actions displays the Participants workspace:
0 Select the Participants icon from the Workspaces list.
0 From the menu bar, select View » Participants.
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Use the Contact dialog box to add or modify contact names, addresses, and other
useful contact information for the list of participants that you will use when you create
a contract. You can check boxes to indicate whether the contact that you are creating
will appear in drop-down lists as a customer, a provider, or a servicing contact for a
contract, SLA, service, or component.

To add a contact, complete the following steps:

1 Open the Contacts dialog box in any of the following ways:

0 From the menu bar in the Participants workspace, select File » New »
Contact.

0 Right-click contacts in the hierarchy tree and from the pop-up menu select
New » Contact.

O Click create a Contact in the Task list.
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E Contact: Untitled

Contact Mame:
First Marme:
Last Marne:
Matne 3

Marne 4:
Jok Title:
Department:

Telephane:

Pager:
F Ao
E-triil:

Address 1.
Address 2

2 Type the contact information in the appropriate fields.

3 Select the appropriate check boxes (Customer, Provider, Servicing Contact) to
indicate the drop-down lists where you want the new contact to appear.

4 If you select the Sservicing Contact check box, indicate if the contact will receive
e-mail notification for any targets missed during the current compliance period.

5 Click OK.
The contact is added to the lists that you selected.

Customers

From the Customer dialog box, you can complete the following tasks:

0 Create or update a customer to be used in a contract.

O Add existing contact names and address information for that customer.
O Add new contacts.

To create a customer, complete the following steps:

1 Open the Customer dialog box in any of the following ways:
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0 From the menu bar in the Participants workspace, select File » New »
Customer.

0 Right-click Customers in the hierarchy tree and from the pop-up menus
select New » Customer.

O Click create a Customer in the Task list.

E Customer: Unhitled

2 Type the name of the customer in the Customer Name field.
3 Type the name of the customer’s company in the Company field.
4 Click the contacts tab.

&, Customer: Untitled

5 Add a contact in either of the following ways:

0 If you have previously created contacts by using the Contacts dialog box, you
can select a contact from the Add Existing Contact drop-down list. Click add
to the right of the list to add the contact that you select.
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o If the contact that you want to add is not in the drop-down list, click New
Contact to access the Contacts dialog box, where you can create the contact.

o If you want to add notes about this customer, click the Notes tab.
o Click ok.

Providers

The Provider dialog box enables you to create a provider to be used in the contract.
From this dialog box, you can complete the following tasks:

0 Create or update a provider.

O Add existing contact names with address information.

O Add new contacts.

To create a provider, complete the following steps:
1 Open the Provider dialog box in any of the following ways:

0 From the menu bar in the Participants workspace, select File » New »
Provider.

0 Right-click Providers in the hierarchy tree and from the pop-up menus
select New » Provider.

O Click create a Provider in the Task list.

E Provider: Untitled

2 Type the name of the provider in the Provider Name field.
3 Type the name of the provider’s company in the Company field.
4 Click the contacts tab.
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5 Add a contact in either of the following ways:

o0 If you have previously created contacts by using the Contacts dialog box, you
can select a contact from the Add Existing Contact drop-down list. Click add
to the right of the list to add the contact that you select.

o If the contact that you want to add is not in the drop-down list, click New
Contact to access the Contacts dialog box, where you can create the contact.

6 If you want to add notes about this provider, click the Notes tab.
7 Click ok.

Creating Catalog Items

So far, you have seen how to create the necessary server connections and define data
sources so that SAS IT Service Level Management can access your SLM-related data.
You have seen how to define providers and customers and how to define contacts for
them. There are still a few more tasks to complete before a contract can be created.
Using the Catalog workspace, you can complete the following sequence to manage the
catalog items that are needed to build a contract:

1 Create and edit range descriptions that contain range set colors and labels for
reports.

2 Create the range sets to apply to the components, services, SLAs, and contracts
that you want to track.

3 Define your SLM components and services.

4 Select components, services, and range sets to create your SLAs within SAS IT
Service Level Management.

You can display the Catalog workspace in either of the following ways:

O Select the catalog icon from the Workspaces list.

0 From the menu bar, select View » Catalog.

The Catalog workspace opens.
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Range Descriptions

Range descriptions associate report colors and labels with ranges within a range set.
These descriptors help you identify range classifications within range sets for contract
and catalog nodes. For example, a range description might define all ranges that exceed
expectations to appear in reports as green and be labeled “Exceeded.”

Six predefined range descriptions (Exceeded, Met, Missed, Missing Value,
Out-of-bounds High, and Out-of-bounds Low) are supplied. Three of these supplied
range descriptions (Missing Value, Out-of-bounds High, and Out-of-bounds Low) cannot
be renamed or deleted. You can also create additional range descriptions that meet your
specific business needs.

From the Range Description dialog box, you can complete the following tasks:

0 Modify the report color and report label for predefined range descriptions.

O Assign a name to a new range description that will appear for selection in range
sets and report specifications.

o0 Define a report color and report label for a new range description.

To create a range description, complete the following steps:

1 From the Catalog workspace, open the Range Description dialog box in one of the
following ways:

0 From the menu bar in the Catalog workspace, select File » New » Range
Description.

0 Right-click Range Descriptions in the hierarchy tree and from the pop-up
menus select New » Range Description.

0 Cllick create a Range Description in the Task list.
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Range Dezcnption: Untitled
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2 Use the Range Description dialog box to name the new range description and
specify the report color and label that you want to associate with the description.

3 Click ok to save your changes. The new range description will appear in the Range
Descriptions folder in the hierarchy tree.

Note: If you attempt to delete a range description that is linked to a range already in
use by the catalog, contract, or report programs, a dialog box will prompt you to choose
another existing range description to replace the description that you want to delete. A

Note: For more information, see “Range Descriptions” on page 15. In addition, SAS
IT Service Level Management: User’s Guide provides more detailed information about
managing range descriptions. A

Range Sets

The Range Set dialog box enables you to define service level objectives for all of the
components, services, and SLAs that will be included in your contract. Ranges and
range sets enable you to designate scores and description associations to help interpret
actual performance measurements. From the Range Set dialog box in the Catalog
workspace, you can complete the following tasks:

0 Define a set of ranges to compare against the actual values or input metrics.

0 Define a score for each range.

O Associate ranges with predefined range descriptions that determine report output

parameters such as descriptors, colors, and labels.

To create and edit a range set, complete the following steps:

1 From the Catalog workspace, open the Range Set dialog box in any of the following
ways:
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0 From the menu bar, select File » New » Range Set.

o0 Right-click Range Sets on the hierarchy tree and from the pop-up menus select
New » Range Set.

O Click Create a Range Set in the Task list.

E Hange Set: Untitled

2 Type the name of the range set that you want to define.
3 Click the Range Set tab.

E Hange Set: Untitled
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4 To edit existing ranges in the range set, complete the following steps:
a Display the Edit Range dialog box in any of the following ways:
0 Select a range and click Edit.

0 Right-click a range and select Edit from the pop-up menu.
0 Double-click a range.
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Edit Range
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b Use the Edit Range dialog box to specify or change the value limits of the

range and the score, descriptor, report color, and report label that you want to
associate with the range.

¢ Click OK to save your changes.

5 To add a new range in the range set, complete the following steps:

a Click Add Range at the bottom left of the Range Set tab.
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Add Range
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b In the Add Range dialog box, set the lower and upper limits for the range and
enter a value in the Score field.

¢ From the list on the bottom left of the dialog box, select the range description
that you want to correspond with the new range. The report color and report
label associated with the range description will appear in the preview fields to
the right.

d Click oK to add the new range.

6 Select the Notes tab if you want to add notes about the range set.

Note: See “Ranges and Range Sets” on page 16 for more information. In addition,
SAS IT Service Level Management: User’s Guide provides more detailed information
about using ranges and range sets. A

Components

A component in SAS IT Service Level Management usually represents software or
hardware resources (such as a router or a server). It can also represent a single
resource or multiple resources (such as a Web server farm). A component can also
represent a person or a business process (such as the help desk).

The Component dialog box enables you to define a component, designate how the
data related to that component will be collected, and specify the desired objectives for
the component.

From this dialog box, you can complete the following tasks:

0 Create or modify a component.
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Establish or modify date filter parameters that determine how and when to collect
data or process indicators for a component.

View predefined service level objectives of a component.
Determine how to measure the component in order to score and meet the objective.
Create, activate, remove, and modify component objectives.

Assign a servicing contact to a component and determine if the contact will receive
e-mail notifications for missed targets.

To create a component, complete the following steps:

1

From the Catalog workspace, open the Component dialog box in one of the
following ways:

0 From the menu bar, select File » New » Component.

0 Right-click Components on the hierarchy tree and from the pop-up menus select
New » Component.

O Click create a Component in the Task list. The Component window will
display with the General tab active.

E Response Time - Component: Untitled

0 Use the General tab to name the component and assign a servicing contact who
will be responsible for monitoring the component’s success in achieving its
targets.

O Click the pate Filter tab.

E Response Time - Component: Untitled
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2 Use the pate Filter tab to specify how to filter incoming data based on the
datetime stamp of the data.

3 Click the objectives tab.

E Applications - Component: Untitled
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4 From the Component Objectives list on the Objectives tab, select and label the
objectives you would like to activate for the component that you are creating. A
corresponding tab for each active objective will appear in the bottom half of the
window.

The Availability, Response Time, Throughput, and Custom Objective tabs
provide identical parameter options. These options enable you to do the following
for each active objective of the component you are creating:

0 Select the input metric and calculation method that you want to use to

calculate the indicator.

0 Select the range set that you want to use.
O Select whether the target is based on the indicator or score for the given
objective.

O Specify the summary statistic for comparison to the target value. This option
is for indicator-based targets only.

The composite tab enables you to designate which combination of availability,
response time, throughput, and custom objective scores that SAS IT Service Level
Management will use to generate a composite indicator for the component that you
are creating.
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Note: SAS IT Service Level Management: User’s Guide provides more detailed
information about setting availability, response time, throughput, custom
objectives, and composite objectives. A

5 Click the pata tab.

55
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The Data tab enables you to enter locations for the data source that is used to
calculate objectives and to create resource associations for the component.
Identifying a component’s resources includes defining resource data, indicating
which columns to use, and identifying the rows of resources.

6 Click pefine Data to create and modify data definitions. A Data Definition
Wizard will guide you through the steps that are required to establish the data for
an activated objective.



Using the SAS IT Service Level Management GUI /A Creating Catalog ltems 57

& Define Data

Which Objective?
Zelect the service level objective intended for data definition.

Custom Ohjective

7 After completing the steps in the Data Definition Wizard, click Columns in the
Data tab to display the Resource Columns dialog box.

Key Wariahles |—

| coumnmame |  vsetywe | vesorten |

8 Use the Resource Columns dialog box to designate the columns from the data
source PDB that uniquely identify resources. This dialog box shows which resource
columns are available and if they have already been selected. You can add or
remove a resource column by selecting or deselecting its corresponding check box.
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Note: To display this list of columns, you must be connected to the server where
the data source PDB is located. A

9 Click oK to save your changes and return to the Components dialog box.
10 Click Rows in the Data tab to open the Resource Rows dialog box.

E Resource Rows: Firewall 1x9321 Component
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Hub35100
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Switch3322: SPA

The Resource Rows dialog box enables you to designate which resources are
related to a particular component. This dialog box shows available resources and if
they have already been selected. You can enable or disable a resource row by
selecting or deselecting its corresponding check box.

Note: To display this list of rows, you must be connected to the server where the
data source PDB is located. A

11 Click OK to save your changes and return to the Components dialog box.
12 Click the History tab.
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The History tab displays a record of all actions that are performed, the user
name of the person who performed the actions, and the date and time of each
action. This is a display-only dialog box.

13 Click the Notes tab if you want to add notes about the component that you are
creating.

14 Click oK to add the new component.

Note: See “Component Nodes and Resources” on page 14 for more information about
components. SAS IT Service Level Management: User’s Guide provides more detailed
information about creating components and services. A

Services

A service in SAS IT Service Level Management represents one or more IT systems
that enable a business process to function. Services are defined in the Catalog
workspace and are associated with one or more components or child services. Service
level data for these components and services is compiled to produce indicators for the
service. A service can also contain other services.

The Service dialog box enables you to define a service and to determine the desired
objectives for use in a contract.

From this dialog box, you can complete the following tasks:

O

Create or modify a service.
0 View predefined service level objectives.

o0 Establish associations between service level objectives and components or services.
0 Determine how to calculate the indicator for objectives.

0 Determine how to calculate the score for objectives.

To create a service, complete the following steps:

1 From the Catalog workspace, open the Service dialog box in any of the following
ways:
0 From the menu bar, select File » New » Service.

0 Right-click services in the hierarchy tree and from the pop-up menu select
New » Service.

O Click create a Service in the Task list.
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Firewall 09321 Componert  Availakili: Measures Mean Premium Availabilty ==99.5 Morthl

Fireweall 139321 Componert  Availakili: Measures Mean Premium Availabilty ==99.5 Morthl
ték to Internet Service Aoailabilt Indicators Redundart Premium Availabilty == 935 Morthl

Link 75141 Component Aoailabilt Measures Mean Premium Availabilty == 935 Morthl

Link 79319 Component Axailabilit Measures Mean Premium Availabilty ==99.5 Morthl

The Hierarchy tab displays a summary of parameters for the selected service
and its child nodes. The service hierarchy shows what appears (or will appear) in
the catalog tree, along with the specific attributes for each node.

Note: See “Service Nodes” on page 13 for more information about services. SAS IT
Service Level Management: User’s Guide provides more detailed information about
creating services. A

SLAs

A service level agreement (SLA) is a part of a contract between a provider of services
and the recipient of those services, or the customer. SLAs are defined in the Catalog
workspace. SLAs, as defined within SAS IT Service Level Management, are associated
with one or more services or components. An SLA can contain associations with
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components and services. The services within the SLA can also contain associations to
components and other services.

Use the SLA dialog box to define an SLA and outline its desired objectives for use in
a contract. From the SLA dialog box, you can complete the following tasks:

Create or modify an SLA.

View predefined service level objectives.

Define, manage, and organize a list of service level objectives for the SLA.
Determine how to calculate the indicator for objectives.

Determine how to calculate the score for objectives.

O

O
O
O
O
To create an SLA, complete the following steps:

1 From the Catalog workspace, open the SLA dialog box in one of the following ways:
0 From the menu bar, select File » New » Service Level Agreement.

0 Right-click sLAs in the hierarchy tree and from the pop-up menu select New »
Service Level Agreement.

O Click the Create a Service Level Agreement icon in the Task list.

& 5LA: Untitled x|

General | Date Fiter | Obisctives | Hierarchy | History | Notes |

SLA Mame: Wersion:

Servicing Contact

Select a contact:

Contact Telephone: E-mail:

[

I~ This cortact should ke visible on Custarmer Reports

I~ E-trzil this cortact for vy missed target definitions:

Upddated by: Updated:

oK I Canicel Help

The tabs on the SLA dialog box are identical to the tabs on the Service dialog
box.

2 Click each tab and complete the necessary fields to define each of the SLAs that
you want to include in the contract.

Note: See “SLA Nodes” on page 13 for more information about SLAs. SAS IT
Service Level Management: User’s Guide provides more detailed information about
creating SLAs. »

Creating a Contract

A service contract is a contract between a provider of services and the recipient of
those services, the customer. Within SAS IT Service Level Management, a contract can
be composed of zero, one, or more SLAs, services, and components.

The Contract Workspace

The Contract workspace displays the list of current contracts and provides quick
access to individual contracts.
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You can display the Contract workspace in either of the following ways:
O Click the Contract icon from the Workspaces list.
O From the menu bar, select View » Contract.

" 5AS IT Service Level Management - SamplesT 2205 i |||
File Edt View Tools Help

O3 X A2 2|

E Contract

Workspaces X G| Contracts: Marme Customer Encl Date | Status Task List X I
Edernal Custamers =l Firance Department  Relisble Networks Finance 12031005 Active Hew
E Zl  Sales Department Relizble Networks Sales 12/3105  Inactive a T

[ |Creste & Folder

g Selected item

Catalog Properties

@ Rename
X Delete

Participants

Data

Reports

Refresh this view

|User Name: mabnma

The Contract Window

The purpose of the Contract window is to document the service level objectives for all
the nodes in the contract. The information that is entered in the Contract window
initiates the roll-up of data and also provides a means of documenting contractual
information that is not used in measuring data but that might be significant to the
management of the contract.

Some of the tasks that you can accomplish from the Contract window include the
following:

o0 Define, manage, and organize a list of service level objectives.
o0 Define groupings of service level objectives.

o0 Define penalties for missing service level objectives and rewards for meeting
service level objectives.

Define outages that are associated with nodes in the contract hierarchy.
View the history of changes for all the nodes in a contract.

Associate customers with the contract.

Specify the provider of the contract.

Establish the status and important dates for the contract.

O 0o o oo d

Assign a servicing contact to a contract node and determine if the contact will
receive e-mail notification for missed targets.

0 Specify the output location and job code location of Baseline reports for
components in the contract.

To create a contract, complete the following steps:
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1 From the Contract workspace, open the Contract window in one of the following
ways:

0 From the menu bar, select File » New » Contract.

0 Right-click Contracts in the hierarchy tree and from the pop-up menus
select New » Contract.

O Click create a Contract in the Task list.

The Contract window is displayed, with the General tab active.

E Contract: Untitled
e

raciive x|

The fields on the General tab of the Contract window are similar to the
fields on the General tab of the Component, Service, and SLA dialog boxes.
Several additional fields — the Path to Contract Database field, the
Contract Start Date field, the Contract End Date field, and the status
field — also appear on the Contract window General tab.

2 Use the Path to Contract Database field to specify the full path to the location
of your contract.

Note: For additional information about creating new contract databases and
completing the Path to Contract Database field, see SAS IT Service Level
Management: User’s Guide. A

3 Use the contract Start Date and Contract End Date fields to specify the start
and end date of the contract. These fields are for documentation purposes only.

4 Use the status field to change the status of the contract. The default status is
Inactive. You must change the status of a new contract to Active in order to run
the ETL process and validate or synchronize the contract.

5 The pate Filter tab is identical to the one on the Component, Service, and SLA
dialog boxes. Use the Date Filter tab to specify how to filter incoming data
based on the datetime stamp of the data.

6 Click the parties tab.
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B Contract: Finance Department : ASP Finance

ASP Finance ASP I,

ASP Finance i AP Inc.

Finance i it: Contracts

Jetfrey Berkley i " Jim Swviss
919-555-1112 1 919-555-3333

jeff herkley@asp.com -zl jim.swissi@asp.com
Jetfrey Berkley Jim Swviss
919-555-1112 1 919-555-3333

Jeff berkley@asp.com -triail: Jir EwissEasn com

7 Use the Parties tab to complete the following tasks:
0 Create a new contact, customer, or provider from within the contract and add
it to the Participants workspace.
Copy an existing contact, customer, or provider to the contract.
0 View and edit all customer and provider information in the contract.
O Assign or change the primary contact or primary approver for each customer
or provider.

8 Click the objectives tab.

B Contract: Finance Department : Reliable Networks Finance

U A S Y B

T

: 100 <= x == 100
jserial 7| 995 <= x < 100
99 == x = 99.5

ey =] prean o] fracar =l b= =l | ses |
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Use the objectives tab to define and manage the service level objectives for
the entire contract. Select and activate the appropriate contract objectives to
define contract-wide availability, response time, throughput, custom objective, and
composite objectives. The fields on this tab are similar to the fields on the
Objectives tab of the Component, Service, and SLA dialog boxes.

9 Click the Hierarchy tab.

E Contract: Finance Department : Reliable Networks Finance

\

vailakility =]

= E Expense Accourting Aveailahilit Inclicators  Serial Standard Av... Morthl:
1=~ Finance Metwork Availahilt Indicators  Serial Prefmiumn Avai.. Morth:
Finance HUB= Avvailabilit Indicators  Redundart  Premium Svai.. Morithl:
HUB35100 Component  &vailabilit Measures  Mean Premium Avai Morthl
HUBS58321 Companert  Swvailabilit Measures  Mean Premium Aval Morthl:
tlrvtc&;mal Switch Availahilt Indicators  Mesn Premium &yvai... orth:

Switch 9322 Component  Awailsbilit Messures  Mean Premiutn Aval.. Moithl:

(=8 Expense Application Avvailabilit Indicators  Redundart  Standard Av... Morithl:
League Application Availabilit Measures  Mean Standard Av Morithl:

PHILLIP &pplication Aveailabilit Measures  Mean Standard Av Mot

CORP3 Application Availabilit Messures  Mean Standard Av... Morthl:
E Payrol Availabilit Inclicators Serial Premiutn Aval.. Morthl:

ﬁ—iﬁnan:e Metwark Avalabiit Indicalors _ Serial Premium Avai.. Worthl

HUB35100 Componert  Availabilit Messures  Mean Premiumn Avai Morithl:

E%ﬂnc& HUBS Avaibiit Indicators _ Redundant__Premium Avai Wortht

HUB59321 Componert  Availsbilit Messures  Mean Premiurn Aval.. Morthl:
tlrvt{a;mal Switch Availahilt Incicators  Mean Premium Avai.. Morth:
Switch 9322 Component  Availabilit Measures  hean Premium Ayvai... Morithl:
=g Payroll Application Availabilit Indicators Redundart _ Premium Avai Morthl
CORP Application Availabilit Measures  Mean Premium Avai Morthl
OLGUY Application Availabilit Messures  Mean Premiurn Aval.. Morthl:

The Hierarchy tab displays a summary of attributes for the current contract
and for any of the child nodes, enabling you to make comparisons. The contract
hierarchy reflects all objective associations for this contract.

10 Click the outages tab.

E Contract: Finance Department : Reliable Networks Finance

Just Before Micni... Scheduled Finance Departimert  Daily 1022005 3 Possible Mairtenance
Just After Midnight Scheduled Finance Departmert  Daily 1122005 k Poszible Maintenance
Doean Ungcheduled  HUE35100 Componert Once 21905

Do Excused Internal Switch Once 305 2 Severe Wind Storm
Down Unscheduled League Application  Once  2/1905

Dowery Unzcheduled  PHILLIP Apglication once 30s

Down Unscheduled  PHILLIP Application Once 3r22i05

OV Unscheduled  PHILLIP Application Once 312205
Doty Unscheduled  CORP3 Application once 3Ma0s
Down Unscheduled  HUB35100 Component Once 21805
Dovwen Unscheduled CORP Applicetion  Once 348105 3 Wating for replacement
Doty Unzcheduled  OLGUY Application  Once 21803

Delete:

11 Use the outages tab to view information about current service outages that might
affect the evaluation of the services that are provided under the contract.

12 To create a new outage, complete the following steps:

a Click New to access the Outage Properties dialog box.
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B Outage Properties

st Betore Midright fres  |x)
Fossible Maintenance = Scheduled =

-

epartment
f—]—u Expense Accourting
Finance Metwarik
= Finance HUEs
HUB35100 Cotnpatert
HUES9321 Component

El—tlg:mal Swritch
Switch 9322 Component

,i Expenze Application

iy League Application
0 PHILLIP & pplication
"% CORPI Application

b Use the General, Schedules, Scheduled Exceptions, and Notes tabs in
the Outage Properties dialog box to enter the details of the new outage.
¢ Click OK to save your changes and return to the outages tab.

13 Click the contractual Data tab.



Using the SAS IT Service Level Management GUI /A Creating a Contract

E Contract: Finance Department : Reliable Networks Finance

Cortract Price: 5,000

Payment Term: forthly

Currency (3-char |SC code): Lsa,

Provider Approval Date: 07 /01 /2005

Customer Approval Date: 07 /01 12005

Reviewy Cycle: Glarterly

Mext Scheduled Review: 10001 72003

Cortract Database Info Start of Yeek: RACMDAY

Penafty Info Penalty Identifier: P01

Pernafty LAmaount: S00

Penalty Currency (3-char |50 code) |USD

Peraty Term: Glarterly

Penalty Motes: Penalty confirmed by customer and provider
Credit Idertifier: Co2

Credit Amount: 500

Credit Currency (3-char IS0 codey.  |USD

Credit Term: ciarterly

Credit Motes: Credit confirmed by customer and provider

The Contractual Data tab enables you to gather, document, and view the
generally agreed upon terms and conditions of the contract.

14 Click the History tab to display details about changes to the contract over time.

E Contract: Finance Department : Reliable Networks Finance

—

I 1020 update | mabnma O01JULDS:1 50551 3 Finance Department | COMTRACT

1032 update | mabnma 01 JULDS1 5:07:42 3 Finance Department | COMTRACT

15 Click the Notes tab if you want to enter notes about this contract.

67
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Running ETL

After you create a contract and define service level objectives for all the nodes, you
are ready to begin processing the SLM data for your contract.
To begin processing, complete the following steps:

1 From the Contract window menu bar, select Tools » Initiate ETL.

B Contract: Finance D epartment : ASP Finance B201205 373930 PN 00 20 =0 0 0 [ =] B9

SslmisarmplesiCDBEFinance

11105 | [12631008 | factive 7

s

2 Click Yes to continue processing.

Note: Running ETL from the IT Service Level Management GUI might take a long
time. Running ETL in a batch environment is recommended. SAS IT Service Level
Management: User’s Guide provides more information about running ETL in a batch
environment. A

Closing SAS IT Service Level Management

From any of the workspace windows, you can close SAS IT Service Level
Management in any of the following ways:

0 From the menu bar, you can select File » Exit. Then, click Yes to exit.
o Click x in the top-right corner of the main window. Then, click Yes to exit.
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Overview of Reporting

Reporting is an important part of the service level management concept. IT providers
need frequent reports to help them identify problem areas quickly and easily so that
they can resolve issues early. Customers need regular reports that demonstrate the
value that is received for their investment in IT services. And both providers and
customers need reports that illustrate clearly that the service level objectives that were
specified in the contract are feasible and being met.
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SAS IT Service Level Management provides three high-level categories of reports to
meet the various needs of contract providers and customers and to facilitate report
management.

Baseline reports provide guidance for establishing reasonable service level targets
based on resource data. These reports are helpful for contract
providers who are setting up a contract.

Service Level compare performance statistics with objective targets to
reports communicate how well service level objectives are being met.

SAS Enterprise  provide various ways to represent SAS IT Service Level
Guide reports Management data in graphical or tabular formats. SAS Enterprise
Guide enables you to create interactive or ad hoc reports.

This chapter provides instructions for managing these reports and provides descriptions
and illustrations of the reporting capabilities of SAS IT Service Level Management.

Baseline Reports

Baseline reports are graphs that display data that exists in a contract database for a
specified contract within the current environment. The graphs in the baseline gallery
are prepared from the summary tables in the contract database. You can use these
baseline views of contract components to determine reasonable targets for the objectives
that you specify for the components.

Baseline reports are divided into three main groups based on scope of the data: daily,
weekly, and monthly data reports. Each of these groups is further divided based on the
calculation methods performed on all of the data: mean, minimum, maximum, and sum.

Note: More detailed information about Baseline reports and how to access them is
available in SAS IT Service Level Management: User’s Guide. »

Generating Baseline Reports

A SAS job code file must be run in batch mode to schedule the generation of Baseline
reports. You can use the GUI to create this job code file, designate the location of the
file, and designate the location of the report output.

To create the baseline gallery job code and designate the appropriate file and output
locations, complete the following steps:

1 In the Contract workspace, open the contract for which you want to create the
baseline gallery job code.

2 From the menu bar in the Contract window, select Tools » Create Baseline
Gallery Job Code.
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E Create Baseline Gallery Job Code: Finance Department X|

Szimsamples\BazelineReparts'Finance

SziimzamplesiJobCode FinanceBaszeline sas

3 Use the Create Baseline Gallery Job Code dialog box to enter the location of the
output for the Baseline gallery reports and the location of the job code file.

4 Click oK to return to the Contract window.
Note: The IT Service Level Management GUI does not directly generate Baseline

reports. The job code file that generates the Baseline reports must run in a SAS session
on your SLM Server platform. 2o

Viewing Baseline Reports

Baseline report graphs are available for the activated availability, response time,
throughput, and custom objectives of a component that supports a contract. These
reports are available for viewing after the baseline gallery job code runs. You can view
the graphs from the welcome.htm file that is in the location that you designated when
creating the baseline gallery job code.

To access the Baseline reports, complete the following steps:

1 Enter the gallery Web page address or file path location in a Web browser to
access the starting page from which you can access the baseline graphs.
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SAS IT Management Solutions eferences | Help Ssas
SAS IT Please select a folder or report from the tree on the left.
Management

Solutions Reports

|1 Baceline Reports

This directory was cleared on 06/16/2005 12:51:20

i [T T e ecdinanet

2 Click Baseline Reports to access the gallery of Baseline reports.

SAS IT Management Solutions UserPreferences | Help Ssaﬁ

Baseline Reports
For futive Qhjectimes
i~ Doadly
5 Mean
S Minimum
S Maitnum
S Sum
(= we ekly
S Mean
S Minimum
4 Mazirnum
S Sum
= Tonthly
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S Minumum
S Masitrim

S S

Map Retumn

[ ] Dore [ T S loslinteret

3 Use the navigation pane on the left side of the window to select a group of reports
based on scope of the data (daily, weekly, monthly) and statistic (mean, min, max,
sum).

4 Use the select a value for Node or Select a value for Table menus (or
both) to refine the group of thumbnail graphs by a specific node or table.

5 Click a thumbnail graph to enlarge the image.
6 After viewing the report, click Back at the top right of the page to return to the
report thumbnails.

Note: The Back option in your Web browser will return to the main page, not
the last report group that you selected. A
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Daily Data Report

The gallery of Baseline reports includes graphs that show daily data for activated
availability, response time, throughput, and custom objectives of a component in a
specified contract. For example, you could select Daily » Mean in the navigation pane
of the gallery to see the mean statistic of daily data for the contract components. Then
you could select a specific component node from the Select a value for Node menu
to view reports that show results for the specified component.

SAS IT Management Solutions

Mean
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For Active Objectives

™ Daly Node=HUB35100 component
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S ez
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iﬂ Magmmum Node = HUB35100 component Node = HUB35100 component Node = HUB35100 component
= Sum Table = C000431 Table = (000431 Table = C000437

-

Daily Resporme Tme:
Percenties of Daly Means

Mlap Return

Select a value for Node

Select a value for Table
P

o 0 raw ez Gom r@: e
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Node = HUB35100 component
Table = CO00437

|&] Done [ [ [ [%JLocalintanet 4

The following example displays mean indicator values in a Daily Data report. This
sample graph shows that the mean indicator values of daily availability data for the
HUB35100 Component generally reaches 100, with few exceptions. Using this
information, you might determine that a reasonable performance target for this
component is a mean value of 99.
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Weekly Data Report

Graphs that show weekly data for activated availability, response time, throughput,
and customer objectives of a component in a specified contract are also available. These
reports display data as it is summarized on a weekly basis. For example, you could
select Weekly » Max in the navigation pane of the gallery to see the maximum
indicator values of weekly data for components in a given contract.
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The following example displays maximum indicator values in a Weekly Data report.
This graph shows that the response time weekly maximums for component Switch 9322
has a median of 110.0 with most values above 90.0.
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Monthly Data Report

Baseline reports also include graphs that show monthly data for all activated
availability, response time, throughput, and customer objectives of a component. For
example, you could select Monthly » Sum in the navigation pane of the gallery to see
the sum values of monthly data for components in a contract.

SAS IT Management Solutions
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The following example displays sum indicator values in a Monthly Data report. This
sample graph shows a 10th, 50th, and 90th percentile for the data during a
three-month time frame.
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Service Level Reports

Service Level reports include a variety of text-based reports and graphic reports.
These reports present your service level data in formats that enable you to quickly
determine whether service level targets have been met on several different levels. You
can use these reports to check the performance of a contract and view the compliance of
a node’s performance. In addition, contract providers can view more detailed
information about the compliance of specific resources and data sources with just a few
mouse clicks that drill down into the reports.

Service Level reports are displayed on a Web page in a Web browser. The Web page
can include up to three tabs (as determined by report specifications) that correspond
and link to various Service Level reports and information.

Contracts tab displays a list of contracts and a high level view of their
performance. After you select a specific contract, you can view its
service level performance across daily, weekly, monthly, and yearly
time periods by using a calendar to specify the time period. This tab
also provides access to supporting information about contracts such
as report specification details and outage information.

Compliance tab  displays a static view or snapshot of compliance to defined targets.
The reports that are accessible from this tab enable you to view
multiple contracts, view contracts by customer name, see compliance
across all objective types, and filter a list of contracts to view only
the missed targets.
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Servicing enables a servicing contact to view compliance information for all
Contacts tab the nodes for which he or she is responsible. The servicing contact
can also filter this information by target to view missed targets only.

Note: More information about the types of Service Level reports and how to access
them is available in SAS IT Service Level Management: User’s Guide. A

Reports for Contract Providers and Customers

SAS IT Service Level Management enables you to use report specifications to
indicate if the Service Level reports that you are generating are for contract providers
or customers. Contract provider report specifications can generate all of the available
Service Level report types for one or more contracts. Customer report specifications can
only generate a select set of Service Level reports that do not contain sensitive
information that is possibly proprietary to the contract provider. For example, Resource
Analysis reports are not available to customers because these reports show performance
data that is too detailed for a customer’s needs.

The report options, tabs, and information columns that display in a set of Service
Level reports are based on the type of report specification that defines the reports
(contract provider or customer) and the report options that are designated within that
specification. The following table shows some of the possible tabs, reports, and options
that are available for contract providers and customers.

Table 4.1 Availability of Report Options for Contract Providers and Customers

Report Option/ Available to Contract Available to Customers?
Report Name Providers?
Contracts Tab Yes Yes
Compliance Tab Yes Yes
Servicing Contacts Tab Yes No
Resource Analysis Reports Yes No
5-Minute Interval Table Yes No

Reports

Reports Workspace

The Reports workspace in SAS IT Service Level Management provides an easy
interface to create and manage report specifications for defining Service Level reports.
Report specifications provide the definitions or parameter settings that are used to
generate Service Level reports. The Reports workspace and report specifications enable
you to define the report content without requiring manual edits to program code. The
Reports workspace also enables you to generate reports and view the report output
interactively.

Either of the following actions displays the Reports workspace:

o Click the Reports icon in the Workspaces list.
0 From the menu bar, select View » Reports.
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:?, SAS IT Service Level Management - 5amplesT 2205 - EI|5|
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Finance Dept Contract Selected fem
Sales Dept Contract
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Refresh this wigwe
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The Reports workspace is where you can complete the following tasks:

0 Create and manage global parameters that identify the default locations of your
output and style sheets for Service Level reports.

0 Establish decimal placement conventions in a style sheet to designate how text
reports display indicator, score, and target values of objectives.

o Create and manage report specifications for contract providers and for customers.
0 Create and manage folders that can be used to group your report specifications.

Generating Service Level Reports

SAS IT Service Level Management enables you to generate several kinds of Service
Level reports. These various reports present your SLM data in different ways. To
generate the various Service Level reports and manage their parameters effectively,
complete the following tasks:

1 Assign report global settings to designate the defaults for report specifications.

2 Create report specifications for the contract provider reports and customer reports
that you want to generate.

3 Generate the reports interactively from the report specification window or execute
the generated report job code in a batch environment.

Report Global Settings

You can create report global settings to define the default parameters that apply to
all report specifications. The global settings dialog box enables you to specify report
output locations of contract provider reports and customer reports. You can also use
style sheet parameters to specify decimal placements in the reported data values and
modify graphics or branding information in the reports.

Note: Most report global settings can be overridden for individual report
specifications if necessary. Decimal values set in the style sheet cannot be overridden
for individual report specifications. A
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Either of the following actions displays the Report Global Settings dialog box:
0 Double-click Report Global Settings in the hierarchy tree.

0 Right-click Report Global Settings in the hierarchy tree and from the pop-up
menu click Open.

E Report Global Settings

T

NizimizamplestSLReport s Provider|

NzimizanplesiSLReports\Provider

From the Report Global Settings dialog box, you can complete the following tasks:
0 Define report output locations for contract provider reports and customer reports.
0 Designate a customized style sheet for reports.

0 Define the decimal placement for indicator, score, and target values for objectives
in the Service Level reports.

Report Specifications

You must create report specifications for the Service Level reports that you would
like to generate. Report specifications are report definition files that contain the many
parameter options that you set for generating Service Level reports. There are two
types of Service Level reports (contract provider and customer) based on who will read
and use them. Both types of reports contain a specialized set of reporting options.
Contract provider report specifications and customer report specifications define the
necessary parameters for the designated report type.

The Reports workspace provides the capability to create, modify, and save report
specifications so that you can maintain specific report configurations without
re-entering settings each time that you’d like to generate a routine report. Once you
create a provider or customer report specification, it is automatically organized into the
Contract Provider Folder or the Customer Folder for easy management. You can
also create additional sub-folders to manage the report specifications further.

SAS IT Service Level Management provides a Reports Specification Wizard that
helps you set the initial report parameters for each report. The Wizard provides
step-by-step instructions for naming the report specification and assigning the
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associated contracts, choosing report options, entering a report output location,
designating range settings, and generating the report.
To create a contract provider or customer report specification, complete the following
steps:
1 Click create a Provider Report Spec or Create a Customer Report Spec in
the Task list in the Reports workspace. A Reports Specification Wizard will appear.

“E New Contract Provider Report Sp iy X

Identify the Report Specification e
Enter the specification name.

Repott Specification Mame:

= Back | Mext = Cancel | Help |

2 Follow the step-by-step instructions for the Reports Specification Wizard to enter
the various parameters required for generating reports. Once the report
specification is complete, it is automatically placed in the appropriate Contract
Provider Folder or Customer Folder in the Reports workspace.

3 To modify the report specification after it is created, double-click the report
specification name in the appropriate folder to open the Report Specification
window and modify settings as needed.

Generate Service Level Reports

You can generate Service Level reports interactively or by creating job code to run in
batch mode. To run a report specification interactively, complete the following steps:

1 From the hierarchy tree in the Reports workspace, highlight the report
specification for the report that you want to run.

2 Click cenerate Report in the Task list.
3 Click Yes to continue if prompted.

4 Ensure that the output location that you specified in the report specification is
accessible from the SLM server. A progress indicator will open in the dialog box to
show that the system is processing the task that you requested.

5 When the generation of the reports is completed, the Report Results dialog box
opens and displays the status of the report generation. Depending on your
specifications for the location of report output, the reports will display in your
browser or you will need to locate the index.html file in the text directory at the
report output location.

6 Click close to exit the Report Results dialog box and return to the Reports
workspace.

You can also generate Service Level reports by creating a report job code and
executing in a batch environment. The report job code is a SAS program that invokes
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the software that generates the reports. More detailed information about report job
codes is available in SAS IT Service Level Management: User’s Guide.

Viewing Service Level Reports

After creating a report specification and running the Service Level reports, you can
access and view the reports in a Web browser. These HTML reports are accessible from
the URL that is designated in the corresponding report specification. The designated
URL might be a file path on an internal network or it might reference links on managed
Web servers so that the final report output can be distributed to a wide audience.

Each Service Level report provides tabs and links that help you view service level
data in various report formats. These report formats are grouped and accessed from
three possible tabs (Contracts, Compliance, and Servicing Contacts). You can use
these tabs and links to drill down into text-based and graphic reports that offer several
methods of displaying additional details or switching to a different type of report or
objective. The availability of these tabs varies based on whether the reports are for
contract providers or customers. In addition, the Compliance tab and Servicing
Contacts tab must be enabled in the report specification in order to be available in the
corresponding reports.

To view the Service Level reports, enter the URL in your Web browser or locate the
index.html file that is in the text directory of the report output location. You designate
the Web address and report output location when creating the report specification.

The reports that are presented below are a sampling of the Service Level reports that
are available in SAS IT Service Level Management.
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Contract List Report

The Contract List report is available from the Contracts tab. This report provides
an overview of service levels for all contracts selected in the report specification. From
this report, you can see an overview of how each selected contract performs at various
summary levels such as daily, weekly, monthly, and yearly. You can also drill down into
each summary level to explore more detailed reports about each contract. For example,
if a data cell in the Contract List report is shaded in a color that indicates poor
performance, you can drill down for more details about that data for each time period.
The Contract List report also enables contract providers to sort data by customer name
to help organize and sort the report information.

This report enables you to identify the overall health of the contract, discover
problem areas by drilling down to more detailed reports, view the notes about a
contract, and view the performance of a contract on a daily, weekly, monthly,
year-by-week, or year-by-month basis

The following is an example of a Contract List report:



84

Viewing Service Level Reports A Chapter 4

Service Level Reports * Contract List

|@Cuntracts|

|%~Cumpliance|

|@Servicing Contacts

Contract List

Feport Run Date:

Sort by

Report Specification: All Provider Contracts
2102005 10:54:29

ICuntract Mame 'I

Active Contracts = Legend
N N Year- Manth-  Wweek- Latest . Current
Contract Objective  Objective , Compliance
. Customer S Label to-date to-date to-date  Daily Motes Period Target
P Actuals Actuals Actuals Actuals [statist
E g tean
g
Dollar Bank  Big Dollar Availability  Duration 99.20 97,89 10000 10000 E  wieekly Indicate
Lid. »= 1995
Response Score <
1.00 1.00 1.00 1.00 eekl
Time B 200
. Scare €
Composite 2.00 3.00 1.00 1.00 Wieekly e
E!
ASP Score <
i Ay ailabili 1.00 1.00 1.00 1.00 hanthl
Finance e | ORI = A 2.00
Department
Response . Scorg €
1.00 1.00 1.00 1.00 Daik
Time Y 2.00
Inactive Contracts £ Legend
C P Year-  Month- wieek- Latest , Current
Contract Objective  Objective - , Compliance
Narme Custormer TuDe Label to-date to-date date Daily Motes Pariod Target
P Actuals  Actuals Actuals [statisti
Actuals
Mo targe
H sales g .
ASP Zales Availability 9910 97.64 9959 9944 [E  Monthly value
Department .
o | snemﬁ'e

From the Contract List report, you can click various items and links to drill down to
other reports such as the Report Specification Details reports, the Notes reports, and
the Contract Hierarchy reports.
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Contract Hierarchy Report

The Contract Hierarchy report provides a comprehensive overview of how a specific
contract is performing. This report displays actual values and targets for each
component, service, and SLA of a selected contract, including the data for the contract
itself. This report enables providers and customers to view this information across all
summarization levels of the contract hierarchy and across all activated objectives for
each node.

The following is an example of a Contract Hierarchy report:

Service Level Reports * Big Dollar Bank Ltd.

[Fcontracts E&compliance 4 Servicing Contacts
T Contract List =
| m S| Contract Hierarchy
Yearly  Monthly  Weekly  Daily  Contract Mame: Big Dollar Bank Ltd.
Customer Mame: Big Dollar
4 2005 » Report Run Date: 21Jul2005 09:57:55
4 March » 2= Legend
WK S M T W T F 5 Modes in Contract Objective Type Objective Label Year-to-date Month-to-da
0927 28 1 2 3 4 5 = Big Dollar Bank Ltd. &vailability Duration 99,20 97,
10 6 7 8 910 11 12 Response Time 1.00 10
11 13 14 15 16 17 18 19 Compasite 2.00 3
1220 21 22 13 & online tartage SLA Availability Duration 99,20 97,
Response Time 206,00 208,
Today: Thursday, September 22, 2005 & Eyternal Customer Network Service Availability Duration 99,20 97,
Response Time 15.67 14,7
Report Views * Link to Internet Service Availability Duration Q9,20 aF,
Response Time 15.01 14,
I B S W Link 79319 Component Availability Duration 89,28 97
40 host recent monthly report Respanse Time 18.27 15,
® ost recent weekly report ¥ Link 75141 Companent Availability  Duration 39,16 97.
45 Most recent daily report Response Time 12,32 12,
Ty Contract Details & Firewall service &vailability Duration 100,00 100,
T‘—D Outages Response Time 10,00 100
# Firewall 0x9321 Component Availability Duration 100,00 100,
Response Time 100,01 100
# Firewall 1x9321 Companent Availability Duration 100,001 10011
i Fncnnncn Timea 111 N 1%

From the Contract Hierarchy report, you can click various items and links to view
other reports. These other reports can show data by various time periods (Daily,
Weekly, Monthly, Year-by-Week, and Year-by-Month reports) or provide more detailed
information about the contract (such as the Contract Details report and Outages
report). Contract providers can also click a component in this report to access a
Resource Analysis report that shows detailed information about the performance of the
component’s resources.
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Daily, Weekly, Monthly, and Yearly Reports

Time-based reports such as the Daily, Weekly, Monthly, and Yearly reports display
target and actual values, enabling you to view how all of the nodes of a contract are
performing for a specified date. Each of these reports presents similar information,
differing only in the increments of time over which data is reported. The Daily report
also displays a graph view of the hourly results for missed targets or outages.

These time-based reports enable you to identify the objectives that are out of
compliance and drill down to discover the specific dates and times during which targets
were missed. These reports provide several ways to navigate to different levels of
summary. You can filter these reports by objective type, use the calendar links to select
specific summary levels, and use the previous and next arrow icons to navigate to a
different time period at the same summary level. You can also click a graph icon to
view a graphic report of the data for the corresponding node. You can then click the
report graph to enlarge the image.

The following is an example of a Daily report:

Service Level Reports » Big Dollar Bank Ltd.

[Eicontracts Ekcompliance
Calendar

BH B
Yearly  Monthly Weekly  Daily
4 2005 »
4 March »
WK s M TW T F S

092728 1 2 3 4 5
10 6 7 8 91011 12
11 13 1415 16 17 18 19
12 20 21 22 23

Today: Tuesday, July 28, 2005

Report Views

45 Most recent yearly report
#9) Most recent monthly report
#5 Most recent weekly report
#9 Most recent daily report
% Contract Details

T Outages

E4servicing Contacts

Contract List
Daily

Contract Name:
Customer Name:
Feport Run Date:

23Mar2005 (@
Big Dallar Bank Ltd.
Big Dallar
21Jul2005 09:45:56

Objective Type: I.&.\raﬂablllt\,r j.

Wigy

Modes in Contract Graphs

E Big Dollar Bank Ltd.
& online tortage SLA
&b Eyternal Customer Network Service
& Link to Internet Service
& Link 79312 Component
W Link 75141 Component
* Firewall Service
& Firewall 0x9321 Campanent
& Firewall 1x9321 Campanent
‘i- Extarnal Customer Switch Service
& switch 5100 Companent
& switch 9321 Companent
& tortgage Application Service
& walftan Application
# q21¢1 application

EEEEEEEEEEEEEEE

Graphs & Range Set - Big Dollar Bank Ltd. Availability

Dzakion Velnen for the Doy
1o 0m

s

.

iy

) | e—

Objectiv

Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration
Duration

= Legend
Actual Camp
g Label  Daily Motes :
value Perio
100,00 & wieek
100,00 e ek
100, 00 Waek
100,00 Wieek
100,00 Wieek
100,00 Wieek
100,00 Wieek
100,00 Wieek
100,00 Week
100,00 Week
100,00 ek
100,00 Week
100,00 Week
100,00 ek
100, 00 ek

Targets aad Otages £ Dmsatio

1o i0m

[ . s ua an am

Ermuid = 3 4 mCu

Tig Tole Tok He
Taud 1 Tma
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From the time-based reports, contract providers can click a component to access a

Resource Analysis report that shows detailed information about the performance of the
component’s resources.

Resource Analysis Report

Resource Analysis reports enable contract providers to view the performance of all of
the resources of a component on a daily basis. A flag icon in the Potential Problem
column appears when there might be a problem with the resource because the daily
indicator value does not meet the target value that was set for the component.

The following is an example of a Resource Analysis report:

Service Level Reports * Big Dollar Bank Ltd.

[Fcontracts E&compliance Bservicing Contacts

Contract List > Contract Hierarchy =
Resource Analysis 23Mar2005 (4

Contract Mame: Big Daollar Bank Ltd.

Customer Mame: Big Dallar

Latest dateftime for data:  23Mard5:23:55

Eeport Run Date: 21Jul2008 095710

Objective Type: IAva1lab1l1ty :I'

Component Marne: Winlftdan Application
Objective Label: Duration
Latest Daily Indicatar: 100,00
Component's Target: The weekly mean of the availability indicator »= 99,50,
Resource Resource Availability

. . . Resource Potential
Konitor narme Wiew Daily Table )

Indicatar Problem

WOLFM&NZ url i 99,469 ¥
Fesource Indicators do not reflect cutages or date filters set at the component level, [
Top of Page

Resource Analysis reports are only available to contract providers and are accessible
from the Contracts, Compliance, and Servicing Contacts tabs. From the Resource
Analysis report, you can drill down to 5-Minute Interval Table reports that provide
more information about resources.
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5-Minute Interval Table Report

The 5-Minute Interval Table report details numeric values from the resource data
before they are interpreted with a calculation method for an objective. This information
shows contract providers when (during the day) the performance of a resource complied
or failed to comply with a component’s target for an objective.

The following is an example of a 5—~Minute Interval table:

Resource Duration =
5 Minute Interval Table
WolfMan Application
Date  Time Indicator  MOMNITOR

2IMARZ005 | 0:00:00 | 20.6666REEET | WWOLFMANZ url
2IMARZO05 | 0:05:00 100 WOLFR&NZ url
2IMBRZO05 | 0:10:00 100 WOLFR&NZ url
2IMARZO05 | 0:15:00 100 WOLFRANZ url
2IMARZO05 | 0:20:00 100 WOLFRANZ url
2IMARZ005 | 0:25:00 100 WOLFRANZ url
23MARZ005 | 0:30:00 100 WOLFAMENZ url
2IMARZO05 | 0:35:00 100 WOLFR&NZ url
2IMGRZO05 | 0:40:00 100 WOLFR&NZ url
2IMARZO0S | 0:45:00 100 WOLFR&NZ url
2IMARZO05 | 0:50:00 100 WOLFRANZ url
2IMARZ005 | 0:55:00 100 WOLFRANZ url
DARAN PR A e 17 WAL ERAARITD il ;I

The 5—Minute Interval Table reports are only available to contract providers and are
accessible from Resource Analysis reports.
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Contract Details Report

The Contract Details report enables you to view all the settings that are associated
with the contract, including detailed information about the customer and provider,
calculation methods, range sets, and date filter information used for activated objectives
of a specified contract.

The following is an example of a Contract Details report:

Service Level Reports * Big Dollar Bank Ltd.

|@Cnntract5| |%Cnmpliance| |@Servicing€nntact5|

Contract List » Contract Hierarchy j

Contract Details

Contract Mame: Big Dollar Bank. Ltd.
Customer Mame:  Big Dollar

Report Run Date:  21Jul2005 09:57:44

Big Dollar Bank Ltd

Category Attribute Walue

General Contract Mame ElBiz Dollar Bank Ltd.
Wersion
Path to Contract Database ciislmisamplesiCDBBigDollar
Contract Start Date 01.1an2005
Contract End Date 31 Dec2005
Status Active
Updated by Sampleldser
Updated 14JUL2005:12:19:46
Contract PDE Table NGOG0

Date Filter Pattern all

Farties Customer Mame Big Dollar
Provider Mame ASPInc,

Cost Info Contract Price 10,000

| Davrmeant Tarm rAdnnthly | _l;l
] 3

From the Contract Details report, you can drill down for more information about the
terms of the contract by accessing the Customer, Provider, and Range Set Details
reports.
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Customer Report

The Customer report enables you to view the customer and contact information for a
selected contract.

The following is an example of a Customer report:

Service Level Reports * Big Dollar Bank Lid.

|%’§Cuntracts| |E$Cumpliance| |@Servicing Cuntacts|

Contract List » Contract Hierarchy » =
Contract Details

Custormner

Contract Name:  Big Dollar Bank Ltd.
Report Run Date: 14Jul2005 13:10:26

Attribute Walue
Customer Name Big Dollar
Company Big Dollar Bank Ltd
Business Entity Banking
Motes
Primary Contact
Contact Hame Samuel Jordan
First Mame Sarnuel
Last Mame Jordan
Job Title Finance Manager
Department Finance
Mumbers/Telephone 919-5585-2222
Pager 919-505-2223
Fax 919-655-2224
E-rail sarn. jordan@bigbank. com
Address 1 123 Kepley Road
City/ Community Cary
State/Province NC _
Country Code usa
IipsPostal Code 27513

Primary Approver

Contact Mame susan Jordan
First Mame Susan

Last Marme Jordan

Job Title Finance Manager

Fianarteraant Cinanen X
| | _'l—I
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Provider Report

The Provider report displays information about the provider for a selected contract.
The layout of the Provider report is identical to that of the Customer report.
The following is an example of a Provider report:

Service Level Reports * Big Dollar Ban

|@Cuntracts| |%C0mpliance| |@Servicing€nntacts|

|+

Contract List » Contract Hierarchy =
Contract Details

Provider

Contract Mame:  Big Dollar Bank Ltd.
Report Run Date: 21Jul2005 0957 144

Attribute Yalue
Provider Mame ASP Inc.
Company A5PInc.
Business Entity Contracts
Motes

Primary Contact

Contact Name Jim Swiss

First Name Jim

Last Marme Swiss

Job Title Metwark tanager
Department Metwarks
Mumbers/Telephone 319-555-3333
Pager 919-565-3334

Fax 919-565-3335
E-mail jim, swiss@asp.com
&ddress 1 123 Farrington Road
City/ Community Cary
StatesProvince KC |
Country Code usa

ZipfPostal Code 27513

Primary Approver

Contact Name Jirn Swiss

First Name Jimn

Last Mame Swiss

Job Title Metwark Manager

Nanartrmant R e ele o =
4] | *
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Range Set Details Report

The Range Set Details report enables you to see all of the details for the range set
that is associated with a selected objective in a contract. This report displays the
ranges that make up the range set as well as their range descriptions so that you can
review the colors and boundary conditions that are assigned to each range.

The following is an example of a Range Set Details report:

Service Level Reports * Big Dollar Bank Ltd.

|@Contracts| |E$Compliance| |@Servicing€ontacts|

Contract List > Contract Hierarchy >
Contract Details
Range Set Details

Contract Mame: Big Dollar Banlk Ltd.

Customer Mame: Big Dallar
Mode in contract:

Motes:

Objective Type: Availability
Objective Label: Duration

Report Run Date: 14Jul2005 13:10:27

Premium Availability

Range Description Name Color Label Ranges Scare
Poor Poor 0<=y%<99 4
tizsed Missed 99 ¢=x €995 3
tet et 995 <= ¥ <100 2
Exceeded Exceeded 100 <= % <= 100 1
Out-of-bounds High OQut-of-bounds High high

COut-of-bounds Low Out-of-bounds Low | low

Mizsing Walue Missing Value mizsing

"' stands for indicator




Outages Report
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The Outages report enables you to view all of the outages for every node (and its
child nodes) in a selected contract. Contract providers might use this report to view the
outages that have been entered for their nodes. Customers might use this report to
view all the outages that have been entered for their contract(s).

The following is an example of an Outages report:

Service Level Reports * Big Dollar Bank Ltd.

In

Effect

¥es

Yes

¥es

Yes

Yes

Yes

[FContracts

Outage type:

Outage Name

Dowen

Down

Dowen

Down

Diowen

Down

Ekcompliance

Contract List = Contract Hierarchy
Outages
Contract Mame:
Customer Mame:
Feport Fun Date:

Big Dollar Bank Ltd.
Biz Dollar
14002008 13:10:18

&l u

Outage Type

Unscheduled

Unscheduled

Unscheduled

Unscheduled

Unscheduled

Unscheduled

B4Servicing Contacts

Modes in Contract

Link to Internet
Service

Link 79319 Caomponent

Link 79319 Component

Link 79319 Caomponent

Link 79319 Component

Link 79319 Caomponent

Cutages

Pattern

ane
tirme
only
one
time
only
ane
tirme
onlby
one
time
only
ane
tirme
onlby
one
time
only

(1T}

Start Date

DERMar2005

221anz2005

27 1anz005

28JanzZ005

FJan2005

01 kar2005

Start
Tirme

12120000
00:00:00
14:45:00
00:00:00
17:15:00

1003000

o

From the Outages report, you can also drill down for more information about outages
by accessing the Outage Details report.
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Outage Details Report

The Outage Details report enables you to view all of the details, including the
exceptions, for a selected outage. This information includes a display of the date and
reason for all the exceptions to the outage.

The following is an example of an Outage Details report:

Service Level Reports * Big Dollar Bank Ltd.

||’§§Contrau:ts| |§$Cumpliance| |@Serv1’c1’ng€nntacts|

Contract List » Contract Hierarchy > Outage List
Outage Details

Contract Mame: Big Dollar Bank Ltd.
Customer Mame: Big Dollar

Report Run Date: 14Jul2005 13:10:18
Attributes Walue

In Effect Yes

Outage Name Down

Outage Type Unscheduled

Owning Mode Link to Internet Service
Pattern one time only

Start Date OErar200s

End Date OB Mar2005

Outage Start Time 12:20:00

Outage End Time  23:45:00

Reason Severe Wwind Storm

hotes

Cutage Exceptions

Exception Date Reason
Mo exceptions defined for this outage.

Top of Page
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Compliance List Report

The Compliance List report is available from the compliance tab. This report
enables you to determine if contracts are meeting their targets during the compliance
period for each active objective. You can also filter this report by customer, all targets,
missed targets for the current period, and missed targets for the previous period.

The following is an example of a Compliance List report:

Service Level Reports * Compliance List

[Fcontracts

Customer list
Cmall Contracts
CmASP FINANCE
CmASP SALES
CmBIG DOLLAR

K1 I—

Ecompliance

-
3 4|

EServicing Cantacts

Compliance List

Report Run Date:  21Jul2005 10:56:23

ALT t -
Target Filter: I argets J
Active Contracts
Contract Objective Objective Compliance
Customer ,
Mame Type Label Period
= Big
Dollar Bank  Big Dollar Availability Duration | Wieekly
Ltd.
Response
Time Wigekly
Composite Wi elkly
Fligmes A2 availability wonithly
Department Finance
Response ,
Time REH;
Inactive Contracts
Contract Objective  Objective Compliance
Custamer .
Narne Type Label Period
El sales
Departrment ASP Sales Availability tanthly

== Legend

Actual Value

Previous Current Motes

Period  Period

100.00 100,00 [E

1.00 1,00
1.00 1,00
1.00  1.00 =
1.00 1,00

== Legend

Actual value

Previous Current Motes Target

Period Period

99,98 97.64 =

Current
Target
[statistic)
[Mean)
Indicatar
>= 99,80
Score <=
2.00
Score <=
2,00

Latest

23Man

Score <=
208 23khan

Score <=
2.00

Current
Latest
[statistic)
Mo target
value

qnnnifim‘l

23kan

ol

From the Compliance List report, you can drill down to view the compliance data of
specific contracts and their respective nodes by accessing the Compliance Details report.
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Compliance Details Report

The Compliance Details report enables you to determine if nodes within a specific
contract are meeting their targets during the compliance period for each active
objective. This report also enables contract providers to view the details for the
individual components in order to uncover any problems with resources. You can filter
this report by contract, all targets, missed targets for the current period, and missed

targets for the previous period.

The following is an example of a Compliance Details report:

Service Level Reports * Big Dollar Bank Ltd.

[FContracts Ecaompliance Eservicing Contacts

Contract List =| Compliance List

Target Filter:

Nodes in - Objective  Objective Compliance
Contract  Type Label Period

Bl mig  Availability Duration  \weekly
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Ltd.
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& Online Awailability Duration  \weekly

fortage
SLA
Response e ekly
Tirne
= A& Availability Duration \Weekly

=| |External
4 | » 4|

‘ElBig Dollar Bank Ltd. Compliance Details
ElFinance Departrent Contract Marme: Big Dollar Bank Ltd.
Elsales Departrment Customer Mame: Big Dollar
Report Run Date: 21.Jul2005 09:57:52
All Targets j

E= Legend

Actual Value

Previous Current Motes

Period
100,00

1.00

1.00

100,00

205,57

100,00

Period
100,00

100,00
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100,00

El

Current
Target
[statistic]
[Mean)
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Score <=
2.00
[Mean)
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»= 99,50
[Mean)
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o=
1500.00
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Latest Da

23Mards:

23Mar0s:
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Servicing Contacts Report

The Servicing Contacts report is available from the Servicing Contacts tab. This
report lists servicing contacts and the compliance data of the contracts for which the
servicing contacts have responsibility. The data in this report provides a snapshot of
the current and previous compliance period, enabling you to view the compliance
information for contracts that are serviced by a selected contact person or business
entity. You can also filter this report by contact, all targets, missed targets for the
current period, and missed targets for the previous period.

The following is an example of a Servicing Contacts report:

Service Level Reports * Compliance for Jim Swiss

[Ficontracts Excompliance E4Servicing Contacts
Contact List B Compliance for Jim Swiss =
‘L_?&_”M SWISS Feport Run Date: 21Jul2005 10:56:27
FAJOHNM TALLER . alT t: ™
2 Target Filter: Argets J
Finance Department E= legend
; _— N , Actual Value C t
Nodes in Objective  Objective Compliance : Lrren
f Previous Current Motes Target Latest Data
Contract Type Label Period X ) o
Period  Period [statistic)
= Fi e Maonthl 1.00 1.00 E 5 <= 23Mar05:23:55
=l Finance availability onthly core a
Department 2.00
Response Daily 1.00 1.00 Soore <=
Time 2.00
Monthly 100,00 100,00 [Mean) 23Mart5:23:55
|4 Expense N .
Py Ayailability Indicator >=
g 99,00
Dail 216,64 211,89 i
Response aty [ e.an]
Time Indicator <=
500000 ms
. tanthly 100,00 100,00 [Mean) 23Mari5:23:55
& Finance Availability Indicator ==
Hetwarik, 59,50
Dail 10.38 11.24 i
Response i [ e.an]
Time Indicator <=
150,00 ms
, fanthly 100,00 100,00 [Mean) 23Mard5:23:55
.l, Finance o rals q
T Availability Indicator »=
99,50
[ Dail 10.00 10.01 by
Fesponse al [ e.an]
= _. Indicator <= hd
4 3 1] | »

SAS Enterprise Guide Reports

SAS Enterprise Guide is a point-and-click Windows application that is packaged with
SAS IT Service Level Management. SAS Enterprise Guide provides the following
features:

O an intuitive, visual, customizable interface

O transparent access to data

O ready-to-use tasks for analysis and reporting
o

a code editing facility
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SAS Enterprise Guide uses projects to manage a collection of related data, tasks, code,
and results. With projects, you can run multiple tasks on the same group of data files
and create interactive or ad hoc reports. The predefined SAS Enterprise Guide project
that is provided with SAS IT Service Level Management consists of query tasks that
filter your SLM data and report tasks that generate reports.

Use one of the following methods to start SAS Enterprise Guide:

0 From the Windows Start menu, select Programs » SAS Enterprise Guide.
Then select the Enterprise Guide project file.

0 Click the SAS Enterprise Guide icon on your desktop and select the SAS
Enterprise Guide project file.

0 Locate the supplied Enterprise Guide project file and double-click it. SAS
Enterprise Guide opens the project.

The Project window displays the active project and its associated notes, code, data, and
results. To view one of the predefined reports, double-click the description of the HTML
icon in the project list. You can also use the SAS Enterprise Guide GUI to create more
specialized reports to meet your specific needs. The following is an example of a SAS
Enterprise Guide graphic report. This detail report shows the availability target and
outage durations of the OLGUY Application (C000280) component.

1=
© file Edt View Code Data Desoibe fGraph  Analee  OLAP  Addin  Took Window Help
"GrHEGAvpaX|(pald 0B RraBE Al .
S b 0 . Resouce Repots DY) =L oeeg E) ] &) .
Project 3 % || Task List L
-E] Log 21| Tasks by Category ITasks by Name |
L g S st fa s = ot omtom mpigor =
T&] Code &) Create Code
E] Log 155 Create Data using Dats Grid
I e ey El|| B oot
——— ) 5y Create Quer using Active Data
Bog Piooess Flow (% Project g Create Engly Dusey
2] HTML - Availabiity Targets and Outages 2] HTML - Availability T arget and O utage Durations * deg Create Empty Process Flow
=
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Note: Additional information about using the reporting capabilities of SAS IT
Service Level Management is provided in SAS IT Service Level Management: User’s
Guide. »
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APPENDIX

1

Recommended Reading

Recommended Reading 101

Recommended Reading

Here is the recommended reading list for this title:
0O Getting Started with Enterprise Guide
Getting Started with SAS IT Resource Management
SAS IT Resource Management: User’s Guide
SAS IT Resource Management: Macro Reference
SAS IT Resource Management: Administration and Batch Reporting Course Notes
SAS IT Resource Management: Interactive Reporting Course Notes
SAS IT Service Level Management: User’s Guide
For a complete list of SAS publications, see the current SAS Publishing Catalog. To

order the most current publications or to receive a free copy of the catalog, contact a
SAS representative at the following address:

O o o oo o

SAS Publishing Sales

SAS Campus Drive

Cary, NC 27513

Telephone: (800) 727-3228*

Fax: (919) 677-8166

E-mail: sasbook@sas.com

Web address: support.sas.com/pubs

* For other SAS Institute business, call (919) 677-8000.

Customers outside the United States should contact their local SAS office.
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Glossary

availability
the percentage of time that a system is available to respond to the requests of its
users.

catalog
a group of SLAs, services, components, range sets, and range descriptions that are
used to create a contract. These items are stored in five supplied folders (SLAs,
Services, Components, Range Sets, and Range Descriptions) that are accessed from
the Catalog workspace.

component
software, hardware, or any other entity that makes the delivery of an IT service
possible. A component is also the lowest-level node in the contract hierarchy. See
also resource, resource list.

composite objective
an objective that combines two or more of the other objective values to determine how
well a particular node is performing. The indicator is calculated from the combined
scores for availability, response time, throughput, and/or custom objective of the node.

contact
a person who is designated as having responsibility for some aspect of a contract, an
SLA, a service, or a component. See also participant.

contract
a collection of data that represents the business relationship between an IT service
provider and a customer. The contract contains one or more SLAs, which present
specific, detailed information about the services that are to be provided. A contract is
also the highest-level node in the contract hierarchy.

contract database
a container that stores time series data that has been through the SAS IT Service
Level Management ETL process. This data is used to evaluate whether the objectives
in a contract have been met. See also ETL (extract, transform, load) process.

custom objective
an objective that measures data that doesn’t typically fit within the scope of
availability, response time, or throughput, such as customer satisfaction or mean
time between failures. SAS IT Service Level Management accommodates only one
custom objective per node.
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data source PDB (performance database)
a data warehouse that stores time series data that is provided by SAS IT Resource
Management. This data is used as input to the SAS IT Service Level Management
ETL process. See also ETL (extract, transform, and load) process.

environment
the server, the environment database, and a set of objects and processes that
facilitate the server operations of SAS IT Service Level Management. For the SAS IT
Service Level Management client, the property-value pairs for an environment
describe how to connect to the server and access the database. For example, the
property- value pairs specify information such as the host name, the port, and
connection methods. See also environment database.

environment database
a database that contains objects that are defined in, and used by, SAS IT Service
Level Management. The objects include contracts, service level agreements, services,
components, customers, and providers. Some of these objects have pointers to other
databases. For example, a contract object has a pointer to a contract database, and a
component object has pointers to as many as three data source PDBs. See also
environment.

ETL (extract, transform, load) process
the process of extracting IT performance data from a data source, transforming the
data, and loading it into a contract database.

excused outage
a time period, such as during a power outage, when a node (and its child nodes) in
the contract hierarchy was unavailable without fault from the service provider. An
excused outage reduces the amount of time that a service provider is accountable for
providing service. Corresponding service level indicators during this time period are
displayed as missing and are ignored. See also scheduled outage, unscheduled outage.

hierarchy
an arrangement of nodes into levels that are based on parent-child relationships.
Members of a hierarchy are arranged from more general to more specific. For
example, in SAS IT Service Level Management, a simple contract hierarchy might
consist of nodes that represent the contract at the highest level, the SLAs as child
nodes of the contract, the services and components covered by each SLA as child
nodes of the SLAs, and the components and contributory services that comprise each
service as child nodes of those services.

indicator
a representation of the performance of an objective that is being measured, expressed
as a numeric value.

metric
any standard of measurement that is used as a basis for evaluation or comparison.
For example, bytes per second throughput is a common service level or performance
metric.

node
a collection of data that describes one of the software objects that form the structure
of an IT service contract. A graphic representation of one of these objects is also
referred to as a node. The four types of measurable nodes in the contract hierarchy
include components, services, service level agreements, and the contract itself.

objective
any of several aspects of service that are measured in order to arrive at one or more
values for one or more indicators. Each node can have the following types of
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objectives, which are based on the data from the node’s child nodes or peer objectives:
availability, response time, throughput, custom objective, and composite.

outage
a time period during which a node in the contract hierarchy is not available.

outage exception
a deviation in an outage pattern. For example, if an outage is defined to recur every
Friday, an outage exception is set for the last Friday in the month if no outage is
expected to occur on that day. See outage.

participant
a provider, customer, or other contact who is specified as being involved in a contract.
Participants are defined in the Participants workspace.

range
a defined interval with distinct lower and upper boundaries that serve to collect or
distinguish data values. Ranges are combined to form range sets. See also range set.

range description
a descriptor that assigns a report color and label to a range classification within a
range set. For example, a range description might define all ranges that exceed
expectations to appear in reports as green and be labeled "Exceeded." There are six
supplied range descriptions (Exceeded, Met, Missed, Missing Value, Out-of-bounds
High, and Out-of-bounds Low). Three of the supplied range descriptions (Missing
Value, Out-of-bounds High, and Out-of-bounds Low) are fixed and cannot be deleted.

range set
a table that contains two or more ranges of probable service level measurements for
a node, along with scores, colors, and/or descriptions for each of the ranges. See also
range, score.

report specification
a report definition file that contains the many configuration options that the contract
provider sets for generating a specific report.

resource
an item of hardware or software or any other entity for which data is collected and
which, alone or with other resources, makes up a component. See also resource list,
component.

resource list
a list of all the entities that comprise a component. The resource list also specifies
which data is extracted from the data source PDB to calculate indicators for a
component node’s objectives. (By contrast, all other nodes extract data from child
nodes.) See also resource, component.

response time
the amount of time to service a request.

scheduled outage
a predetermined and accepted time period, such as during a routine maintenance
event, when a node (and its child nodes) in the contract hierarchy is expected to be
unavailable. A scheduled outage reduces the amount of time that a service provider
is accountable for providing service. Corresponding service level indicators during
this time period are displayed as missing and are ignored. See also excused outage,
unscheduled outage.

score
a numeric value that is derived by comparing a service level indicator to previously
defined range sets. Scores are useful for comparing unlike measurements. For



106 Glossary

example, response time for a help desk is measured in minutes, and response time
for a hard drive is measured in milliseconds. If you combine these response times in
a calculation of response time for a service, an SLA, or a contract, the result is
meaningless. Using range sets to transform the dissimilar measurements into
compatible scores facilitates such calculations and leads to useful and accurate
results. See also range set.

service
a service that an IT organization provides to customers. IT services can include
support for computer systems, networks, applications, telephones, fax machines, and
Web pages, as well as other types of software and hardware services. A service is
also a node in the contract hierarchy that organizes other service nodes and
component nodes in the hierarchy.

service level agreement
See SLA (service level agreement).

service level contract
See contract.

service level management
See SLM (service level management).

servicing contact
a person or entity who is assigned the responsibility for a given node in the contract.
Additionally, the servicing contact might receive e-mail notifications about missed
targets. See contact.

SLA (service level agreement)
an agreement between an IT provider and a customer. The SLA specifies the
performance goals for each service that the provider delivers. For example, goals for
availability, response time, throughput, and a custom objective are often included in
SLAs. An SLA is also a node in the contract hierarchy that organizes component
nodes, service nodes, and other SLA nodes in the hierarchy.

SLI (service level indicator)
See indicator.

SLM (service level management)
a concept of IT service delivery that emphasizes the close alignment of IT services to
the needs of customers. Clear definitions of service level objectives, frequent
measurements of service levels, and meaningful reports help to ensure that IT
customers experience high levels of service.

SLO (service level objective)
See objective.

target
a numeric value that represents the performance goal for a node that is being
measured.

throughput
the rate at which requests for work are serviced by a computer system.

unscheduled outage
a time period, such as during a server failure, when a node in the contract hierarchy
is not available. This type of outage incurs a penalty value of zero for the availability
objective of the affected nodes during the outage time period. See also excused
outage, scheduled outage.
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Numbers

5-Minute Interval Table report

A

adjusting data
availability [5}[14]

B
Baseline reports [} [70]

Daily Data report

generating

Monthly Data report

viewing

Weekly Data report
business needs [ 5

Cc

catalog items
components
creating

range descriptions
range sets

service level agreements (SLAs)

services
Catalog workspace
client/server architecture ]

Compliance Details report

Compliance List report
Compliance tab
component nodes
components

composite objectives [5} [14]
contacts

Servicing Contacts report

Servicing Contacts tab
contract database
Contract Details report
contract hierarchy
Contract Hierarchy report
Contract List report
contract nodes
Contract Provider reports
contract providers [

Contract window
Contract workspace
contracts
adding participants
business needs [
catalog items
constructing
creating
data collection tools [g
data sources
data storage location [g
format g
measurable service goals
measurement techniques
measurement type E
problems with g
reporting periods and methods
representations of
server connections
Contracts tab
custom objectives 5} [14]
Customer reports
customers 3] [44]

D

Daily Data report
Daily report

data adjustments
data collection tools [g
data extraction
data format [g

data sources
data storage location [g
Data workspace
disparate data

E

Enterprise Guide reporting E
environment

editing

properties for
environment database []
environmental data
ETL

running

ETL process E],
data extraction
downward flow of instructions
service level calculations

summary of
upward flow of instructions

extract, transform, and load process
See ETL process
extracting data

F

Five-Minute Interval Table report
format of data [f

G

global settings

goals
measurable service goals
SLM goals J3

GUI

constructing contracts
navigation

starting
workspaces

H

hierarchy tree pop-up menus

indicators
categorizing
ranges of values
IT services
continuous improvement of
value of

L
logging on
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M report global settings Customer reports
report job code Daily report

measurable service goals report specifications generating

measurement techniques reporting 9} [69)] generating interactively

measurement type E
menu bar

menus

Monthly Data report

Baseline reports [9]
Enterprise Guide reporting B,
methods

Service Level reports [0

generating with code
Monthly report
Outage Details report
Outages report

Monthly report reporting periods Provider report
Reports workspace Range Set Details report
Resource Analysis report report global settings

N resource lists report specifications
response time El, Reports workspace

navigation

nodes § Servicing Contact report

component nodes S Servicing Contacts tab
contract nodes -
) ) viewing
service level objectives for SAS Enterprise Guide reports [0} Weekly report
service nodes SAS IT Charge Management Yearly report

SLA nodes 222 g Il\z/lanagemizt Solutloni service nodes
esource Managemen services

SAS IT Service Level Management @ Servicing Contact report

0 closm Servicing Contacts tab
scores
SLA nodes

Resource Analysis report

objectives i
Jcomposite El zzz::;z;icnns SLAs (service level agreements) El,
custom El, service level agreements (SLAs) El, SIM .
service level service level calculations See service level management (SLM)
Outage Details report downward flow of ETL instructions
outages upward flow of ETL instructions
data adjustments for service level management (SLM) T
Outages report business needs and [3 tabs
contract problems E targets
contracts Task list
P goals of B throughput El,
implementing @ toolbar
participants need for
adding ongoing activities @
contacts service level objectives w
customers indicators
providers range descriptions Weekly Data report
Participants workspace ranges and range sets Weekly report
pop-up menus scores workspaces
Provider report targets Catalog
providers [ Service Level reports [} Contract
Contract Provider reports 5-Minute Interval Table report Data
Compliance Details report Participants
Compliance List report Reports
R Compliance tab Workspaces list

Contract Details report
Contract Hierarchy report

range descriptions

Range Set Details report Contract List report Y
range sets Contract Provider reports

ranges Contracts tab Yearly report
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