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Using This Book

Audience

This book covers the basics of how to explore data and build reports using SAS Visual 
Analytics. The emphasis is on introductory instructions, how-to hints, and quick 
reference information.

Requirements

Prerequisites

If you choose to perform the tasks in this book, you need the following software, 
information, and privileges:

n a link to a working deployment of SAS Visual Analytics 6.1

n a supported web browser (for example, Firefox 3.6 or Internet Explorer 9)

n a supported version of the Adobe Flash Player (11.1 or newer)

n an account that can log on to the working deployment

n the ReadMetadata and Read permissions for at least one LASR table (without the 
necessary permissions, you cannot select a data source or access data)

n data exploration and reporting capabilities (without the necessary capabilities, you 
cannot see certain user interface elements)
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System Requirements

Detailed system requirements, including support for additional web browsers, are 
available on the SAS support site.
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Accessibility

Accessibility Features of SAS Visual 
Analytics

For information about the accessibility of SAS Visual Analytics, see the SAS Visual 
Analytics: User's Guide.

Please contact accessibility@sas.com if you need this document in an alternative digital 
format.

vii
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About Exploration

Data exploration involves getting to know a data source and then using it to inform your 
decisions. In exploration, the emphasis is on discovery and ad hoc visualization. 
Exploration is driven by predefined questions, curiosity, logic, intuition, creativity, and 
experimentation.

The SAS Visual Analytics Explorer (the explorer) is well suited to the task.

n The explorer provides fast, highly visual responses so that you can use an iterative 
approach to exploring the data.

n The explorer’s clean interface and natural interactions minimize distractions so that 
you can keep your concentration on the data.

n The explorer supports a range of visualization and discovery activities so that you 
can adapt your tactics as insights emerge.

n The explorer includes advanced analytical tools (such as forecasting, correlations, 
and fit lines) to further guide and refine the exploration process.
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About Reporting

In reporting, the emphasis is on clear, compelling, and widespread communication. 
Reporting encompasses design, data selection, interactions by viewers (such as 
brushing and filtering), and viewing (in web and native mobile device formats).

Like the explorer, the reporting interfaces are intuitive and responsive, even for 
extremely large data sources. Here are the interfaces that you use for reporting:

n The SAS Visual Analytics Designer (the designer) is for creating and enhancing 
reports and dashboards.

n The SAS Visual Analytics Viewer (the web viewer) is for viewing and interacting with 
reports in a web browser.

n SAS Mobile BI is for viewing and interacting with reports on mobile devices.
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Introduction

This chapter provides step-by-step instructions to guide you through basic tasks. The 
purpose is to provide a brief, hands-on orientation to a few of the many possible 
workflows for exploration and reporting.

Explore a Data Source

To explore a data source:

1 In a web browser, open the SAS Visual Analytics home page (at your equivalent of 
http://server01.abc.com:8080/SASVisualAnalyticsHub).

2 In the Create Content area, click Explore Data.
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3 In the SAS Visual Analytics Explorer window, click Select a Data Source.

TIP Each data exploration is saved in its own project, which is called an 
exploration.

4 In the Open Data Source window, select a data source. Click Open. 

5 Drag any data item from the left pane onto the center of the screen. The explorer 
assigns the data item to a role and displays an initial chart as the new exploration’s 
first visualization. 

TIP Each exploration consists of one or more visualizations.

6 Extend, enhance, and refine the exploration (as little or as much as you like). For 
ideas, see “Cheat Sheet for Explorations” on page 10.

TIP In exploration and reporting, access to data is always Read-Only, so feel free 
to experiment—you will not break anything.

7 To save the exploration, select File  Save from the main menu. In the Save As 
window, select My Folder, and enter a name. Click Save.

8 In the upper left corner of the explorer, click Home.

9 On the home page, notice that the new exploration is in the Recent list in the My 
Content area.

Share an Exploration

Although the primary purpose of exploration is ad hoc visualization, you might want to 
share your findings. For that reason, exploration is never a dead end.

One way to share the contents of an exploration is to export some or all of its 
visualizations as a report.
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To export an exploration as a report:

1 On the SAS Visual Analytics home page, double-click an exploration to open it.

2 Select File  Export  Exploration as Report from the explorer’s main menu.

3 In the Export as Report window, clear the check box of any visualization that you do 
not want to export. Click OK.

TIP A few types of content (animated bubble plot, treemap that displays 
additional levels, and correlation data from a scatter plot or heat map) cannot be 
exported. To share such content, export it as a PDF or save it as an image.

4 In the Save As window, select My Folder, and accept the default name. Click Save.

5 In the upper left corner of the explorer, click Home.

6 In the My Content area of the home page, notice that the new report is not in the 
Recent list. Only objects that you create or open are in the Recent list. If you want 
to navigate to the new report, click Browse.

The preceding steps export content to SAS metadata as a report. Here are some other 
ways to share the contents of an exploration:

Table 2.1 Additional Methods for Sharing Exploration Content

Task How to Initiate

E-mail as a link From the explorer’s main menu, select File  E-mail.

Export as a PDF From the explorer’s main menu, select File  Export  
Exploration as PDF.

Save as an image In a visualization’s toolbar, click , and select Export Image.

Share an Exploration 5



Create a Report

1 On the SAS Visual Analytics home page, click Create Report. The designer opens 
with a new, empty report.

2 Drag a Bar Chart from the left pane onto the center of the screen.

3 To add data:

a On the Data tab (in the lower left pane), click Select a data source. In the Add 
Data Source window, select a data source, and click Add.

b Drag a category  from the Data tab onto the Category label (at the bottom of 
the bar chart).

TIP A category has alphanumeric values that can be used as discrete 
groupings (for example, the values in a product category might include shoes 
and belts).

c Drag a measure  from the Data tab onto the bar chart.

TIP A measure has numeric values that can be used as numbers (for 
example, the values in a sales measure might specify the quantity of units 
sold).

4 Extend, enhance, and refine the report (as little or as much as you like). For ideas, 
see “Cheat Sheet for Reports” on page 12.

TIP If your session times out due to inactivity, any unsaved changes are lost. It is 
a good idea to save your work frequently.

5 To save the report, select File  Save from the main menu. In the Save As window, 
select My Folder, and enter a name. Click Save.
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6 In the upper left corner of the designer, click Home.

7 On the home page, notice that the new report is in the My Content area.

View a Report

To open a report in the web viewer, right-click on the report on the home page, and then 
click View in the pop-up window.

To open a report in a mobile viewer, launch a SAS Mobile BI app, connect to a server, 
navigate to the report, and open it. Instructions vary by device. See Chapter 39, 
“Viewing Reports on a Mobile Device,” in SAS Visual Analytics: User's Guide, and 
videos on the SAS support site.

TIP The SAS Mobile BI app for iPad is available in the iTunes App Store. The 
Android app is available from Google play.

View a Report 7
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Introduction

This chapter highlights core functionality in the explorer and designer. The idea is that 
once you know what is possible, it is usually not difficult to find a particular action in the 
interface.

For most tasks, there are multiple ways to begin. Here, one way to initiate each task is 
documented. If you ever get stuck or have questions, some of the text right inside the 
interface might help.

TIP For comprehensive instructions, access the SAS Visual Analytics: User's Guide 
from the Help menu or the SAS support site.
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Cheat Sheet for Explorations

Task How to Initiate in the Explorer

Add variables to a visualization. Drag the data items onto the visualization in the center 
of the screen (from the Data pane on the left).

Switch to a different visualization 
type.

From the main menu, select Visualization  type.

Subset data for the entire 
exploration.

Right-click on a data item, and select Add as Global 
Filter.

Subset data for one visualization. Select the visualization, right-click on a data item, and 
select Add as Local Filter.

Subset data in a chart by inclusion 
or exclusion.

Select a data value (for example, a bar in a bar chart), 
right-click, and select either Include Only Selection or 
Exclude Selection. (For a line chart, Show markers 
must be selected on the Properties tab.)

Sort elements within a chart or 
table.

Right-click on a data item in a chart axis or table, and 
select Sort.

View a visualization’s data. Right-click on the visualization, and select Show Table 
View.

Use a different aggregation 
method.

Right-click on a measure in a chart axis or table, and 
select Aggregation.

Use a distinct count as a measure. In the Data pane, right-click on a category (or date), 
and select Derive Distinct Count.

Apply a correlation and fit line. Right-click on a scatter plot or heat map, and select Fit 
Line  type. (For a scatter plot, there must be at least 
two measures and no grouping categories. For a heat 
map, both the X and Y axes must be measures.)
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Task How to Initiate in the Explorer

Predict future values. In a line chart where a date or time data item is 
assigned to the category role (and no other category 
roles are used), right-click, and select Show Forecast.

Find the correlation between a 
group of measures.

From the main menu, select Analysis  Correlate 
Measures.

Create multiple visualizations. From the main menu, select Visualization  New.

Organize your visualizations. From the main menu, select View  Manage 
Visualizations.

See how selected data in one 
visualization corresponds to other 
visualizations.

From the main menu, select View  Data Brushing. 
(Not all visualizations support cross-visualization 
highlighting.)

Create a column from an 
expression.

From the main menu, select Data  New Calculated 
Item. (Calculations use unaggregated data.)

Set up drill-down functionality. From the main menu, select Data  New Hierarchy.

Display a geographic map with a 
bubble plot overlay.

Drag a geographic data item  onto an empty 
visualization.

Set up a geographic data item. In the Data pane, right-click on a data item that contains 
geographic information, select Geography, and assign 
a geographic role.

Delete an exploration. Click Home, and then click Manage (next to My 
Content or Other Content).

Open a different data source. From the main menu, select File  New Exploration.

Add or view exploration-level 
comments.

From the main menu, select File  Exploration 
Comments.

Add or view comments for the 
selected visualization.

From the main menu, select Visualization  
Comment. The Comments tab is in the right pane.

Cheat Sheet for Explorations 11



Cheat Sheet for Reports

Data Task How to Initiate in the Designer

Add another data source. On the Data tab, click .

Insert a data display object (such 
as a table, graph, or gauge).

Drag the object (from the Objects tab) onto the report 
in the center of the screen.

Use a distinct count as a measure. On the Data tab, right-click on a category (or date) data 
item, and select Derive Distinct Count.

Change a measure’s format. On the Data tab, select the measure, and then click the 
triangle at the end of the Format row (below the list of 
data items).

Create a column from an 
expression.

On the Data tab, click , and select New Calculated 
Item. (Calculations use unaggregated data.)

Set up drill-down functionality. On the Data tab, click , and select New Hierarchy.

Exclude a data item. On the Data tab, click , and select Show or Hide 
Items.

Exclude a subset of data. Right-click on a data item, and select New Data Item 
Filter.

Incorporate a stored process. From the main menu, select Insert  Other  Stored 
Process.

Get basic statistics about all 
measures.

On the Data tab, click , and select Measure Details.

Get additional statistics about a 
measure.

On the Data tab, click , select Measure Details, and 
select the measure (in the Measure Details window).

Replace a data source with an 
identically structured data source.

On the Data tab, click , and select Change Data 
Source.
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Data Task How to Initiate in the Designer

Show multiple aggregations (or 
multiple formats) for a data item.

Right-click on the data item, select Duplicate Data 
Item, and then change the aggregation (or format) of 
the new data item.

Reuse an existing visualization or 
report object.

In the upper left pane, select the Imports tab.

Display a geographic map with a 
bubble plot overlay.

From the Other list on the Objects tab, drag Geo Map 
onto a report in the center of the screen. From the Data 
tab, drag a geographic data item  onto the report.

Set up a geographic data item. On the Data tab, right-click on an item that contains 
geographic information, select Geography, and assign 
measures that contain location information. (For 
example, you might assign Region_Lat and 
Region_Long as the respective measures for a Region 
category.)

Delete a report. Click Home, and then click Manage (next to My 
Content or Other Content).

Presentation Task How to Initiate in the Designer

Edit a report’s description. At the top of the Properties tab, select the report from 
the drop-down list.

Format a chart’s title. Select the chart, and then make changes in the 
General section on its Properties tab.

Add a trend line to a table. In a table, right-click on a column, and select Add 
Sparkline. (The data source must include a date data 
item.)

Change a bar chart’s orientation. Select the bar chart, and then make changes on its 
Properties tab.

Change a chart’s colors or styles. Select the chart, and then make changes on its Styles 
tab.

Cheat Sheet for Reports 13



Presentation Task How to Initiate in the Designer

Set up report-level conditional 
highlighting.

On the Display Rules tab, select the report.

Set up section-level (or object-level) 
conditional highlighting.

On the Display Rules tab, select a section (or report 
object).

Create a reusable pattern of gauge 
intervals and colors.

On the Shared Rules tab (in the lower left pane), click 
.

Apply a shared display rule to a 
new gauge.

From the Shared Rules tab (in the lower left pane), 
drag the rule onto the gauge.

Add a new section (tab) to a report. At the top of the report, click .

Create a scrollable area. From the main menu, select Insert  Other  Vertical 
Container (or Horizontal Container).

Use a different canvas size. In the toolbar, click , , or .

Change your default canvas size. From the main menu, select File  Preferences.

Overlap one report object on top of 
another.

On a section’s Properties tab, select Precision from 
the Layout drop-down list.

Set up view-time filters (prompts). From the Objects tab, drag a control object onto the 
drop zone at the top of a report or section.

Set up view-time interactions 
(where an action on one object 
affects other objects).

On the upper right edge of the report, click  to switch 
to the interaction view. (Not all objects support 
interactions.)

Add or view comments. From the main menu, select View  Comments. The 
Comments tab is in the right pane. (Only report-level 
comments are supported.)

TIP In general, data-related tasks are initiated from the leftmost panes, and 
presentation-related tasks are initiated from the rightmost pane.
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About the Availability of Actions

The following factors affect the availability of actions:

n Your capabilities (for example, if you do not have export capabilities, the export 
options in the explorer’s File menu are not available to you). 

n The interface that you are using (for example, text styling properties are available 
only in the designer).

n The currently selected object (for example, list tables do not have ranges).

n Whether data has been defined (for example, you must add a data source before 
you can define filters).

n Whether a data item is already in use (for example, you cannot change a data item’s 
role while it is incorporated in a bar chart as a category). 

About the Availability of Actions 15
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Gallery

This is an illustrated guide to displaying data and results. Many of the features are 
available in two contexts:

n as visualizations (the building blocks of explorations) in the explorer

n as report objects (the building blocks of reports) in the designer and viewers

Any differences in availability are driven by the purpose of each interface. Explorations 
emphasize discovery. Reports and dashboards emphasize presentation.
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TIP Use the following images for orientation. Actual appearance and functionality are 
affected by the underlying data, any styles that you apply, and the interface that you 
are using. (Some of the following images are from the explorer, others are from the 
designer).

Table 4.1 Displaying Data and Results

A table (also known as a list table) is a two-
dimensional representation of data. Values are 
arranged in unlabeled rows and labeled columns. 
A table cannot use a hierarchy.
In the designer, tables contain aggregated data. 
You can add sparklines to a column (if the data 
source contains a date data item). In the explorer, 
tables contain raw data.
Availability:

 Supported in the explorer.
 Supported in the designer and viewers.

A crosstab (also known as a crosstabulation table) 
shows an aggregate metric for the intersections of 
two or more categories. In a crosstab, categories 
are typically displayed in both the columns and the 
rows. Each cell value represents the aggregated 
measure from the intersection of the categories in 
the cell’s row and column. A crosstab uses less 
space than a traditional table and is easier to read 
because data is grouped both horizontally and 
vertically. A crosstab can use a hierarchy. 
Frequency is displayed only when there are no 
measures in the crosstab.
Availability:

 Supported in the explorer.
 Supported in the designer and viewers.
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A bar chart consists of vertical or horizontal bars 
that represent quantitative data. Use bar charts to 
compare data that is aggregated by the distinct 
values of a category.
You can apply grouping and create lattices.
Availability:

 Supported in the explorer.
 Supported in the designer and viewers.

A line chart shows the relationship of one variable 
to another, often as movements or trends in the 
data over a period of time. Line charts summarize 
source data, and typically are used to show how 
values change over time. You can apply grouping 
and create lattices.
In the explorer, line charts support time series. 
From a time series, you can generate a forecast 
analysis that enables you to predict future values 
for the series and visualize the probability range 
for those values.
Availability:

 Supported in the explorer.
 Supported in the designer and viewers.
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A scatter plot is a two-dimensional plot that shows 
the joint variation of two data items. Each marker 
(represented by symbols such as dots, squares, or 
plus signs) represents an observation. The marker 
position indicates the value for each observation. 
Use a scatter plot to examine the relationship 
between numeric data items. You can apply 
grouping. (In the designer, grouping is called 
"color.")
In the explorer, you can apply statistical analysis 
with correlation and fit lines. When you apply more 
than two measures to a scatter plot, a scatter plot 
matrix compares each pairing of measures.
Availability:

 Supported in the explorer.
 Supported in the designer and viewers.

A bubble plot displays the relationships among at 
least three measures. Two measures are 
represented by the plot axes, and the third 
measure is represented by the size of the plot 
markers. Each bubble represents an observation. 
A bubble plot is useful for data sets with dozens to 
hundreds of values. You can apply grouping and 
create lattices.
In the explorer, you can use color to represent an 
additional measure and animate the bubbles to 
display changes in the data over time.
Availability:

 Supported in the explorer.
 Supported in the designer and viewers.
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A geo map is a bubble plot that is overlaid on a 
geographic map. Each bubble is located at a 
geographic location or at the center of a 
geographical region. A geo map requires a data 
item that contains geographical information and is 
assigned to a geography role.
If you create a geo map in the designer, you must 
assign measures for longitude and latitude. 
Automatic mapping of columns (such as country or 
state) is available only in the explorer. Certain 
exported geo maps (for example, geo maps that 
use custom roles or data sets that have centroids) 
cannot be fully modified in the designer.
Availability:

 Supported in the explorer.
Supported in the designer and viewers.

A histogram displays the distribution of values for 
a single measure.
In the explorer, you can select the bar orientation. 
You can select whether the values are displayed 
as a percentage or as a count.
To add a histogram to a report, create it in the 
explorer, and export it as a report object.
Availability:

 Supported in the explorer.
 Limited support in the designer and viewers.
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A box plot displays the distribution of values for a 
single measure using a box and whiskers. The 
size and location of the box indicate the range of 
values that are between the 25th and 75th 
percentile. Additional statistical information is 
represented by other visual features.
In the explorer, you can create lattices and specify 
whether the average (mean) value and outliers are 
displayed for each box.
To add a box plot to a report, create it in the 
explorer, and export it as a report object.
Availability:

 Supported in the explorer.
 Limited support in the designer and viewers.

A heat map displays the distribution of values for 
two data items using a table with colored cells. If 
you do not assign a measure to the color data role, 
then a cell’s color represents the frequency of 
each intersection of values. If you assign a 
measure to the color data role, then a cell’s color 
represents the measure value of each intersection 
of values.
To add a heat map to a report, create it in the 
explorer, and export it as a report object.
Availability:

 Supported in the explorer.
 Limited support in the designer and viewers.

22 Chapter 4 / Quick Reference



A treemap displays your data as a set of 
rectangles (called tiles). Each tile represents a 
category or a hierarchy node. The color of each 
tile represents the value of the first measure. The 
size of each tile represents the value of the second 
measure. For example, a sales data treemap 
might have tile sizes that represent the number of 
orders and tile colors that are derived from color 
gradients that represent sales.
Availability:

 Supported in the explorer.
 Supported in the designer and viewers.

A correlation matrix displays the degree of 
correlation between measures as a series of 
colored rectangles. The color of each rectangle 
indicates the strength of the correlation.
Availability:

 Supported in the explorer.
 Not supported in the designer or viewers.
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A targeted bar chart is a bar chart that has 
pointers to target values. In this example, the 
pointers appear above each bar.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

A waterfall chart (also known as a progressive bar 
chart) shows how the initial value of a measure 
increases or decreases during a series of 
operations or transactions. The first bar begins at 
the initial value, and each subsequent bar begins 
where the previous bar ends. The length and 
direction of a bar indicate the magnitude and type 
(positive or negative, for example) of the operation 
or transaction. The resulting chart is a stepped 
cascade that shows how the operations or 
transactions lead to the final value of the measure.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.
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A pie chart is a circular chart that is divided into 
slices by radial lines. Each slice represents the 
relative contribution of each part to the whole.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

A time series plot shows an ordered sequence of 
values that are observed at equally spaced time 
intervals. A time series plot requires a date or date 
time category data item that is continuous.
Availability:

 Supported in the explorer as a line chart.
 Supported in the designer and viewers.
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A dual axis bar chart is a variation of the bar chart 
that has two measures. A measure is on each 
axis.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

A dual axis line chart is a variation of the line chart 
that has two measures. A measure is on each 
axis.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.
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A dual axis bar-line chart is a variation of the bar 
chart that has two measures. A measure is on 
each axis, and the bar chart is overlaid by a line 
chart.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

A dual axis time series plot is a variation of the 
time series plot that has two measures. A measure 
is on each axis.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.
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A bullet gauge is a horizontal dashboard indicator 
(also known as a KPI chart) that compares an 
actual value to a target value and compares them 
in intervals. This example displays three bullet 
gauges. The actual value is indicated by an inset 
horizontal bar.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

A slider gauge is a horizontal dashboard indicator 
(also known as a KPI chart) that compares an 
actual value to a target value and compares them 
in intervals. This example displays three slider 
gauges. The actual value is indicated by a 
downward-facing arrow.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

28 Chapter 4 / Quick Reference



A thermometer gauge is a vertical dashboard 
indicator (also known as a KPI chart) that 
compares an actual value to a target value and 
compares them in intervals. This example displays 
three thermometer gauges. The actual value is 
indicated by a vertical bar.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

A dial gauge is an arc-shaped dashboard indicator 
(also known as a KPI chart) that compares an 
actual value to a target value and compares them 
in intervals. The actual value is indicated by an 
arrow that points outward from the inner circle.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.
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A speedometer gauge is a circular dashboard 
indicator (also known as a KPI chart) that 
compares an actual value to a target value and 
compares them in intervals. The actual value is 
indicated by the larger pointer.
Availability:

 Not supported in the explorer.
 Supported in the designer and viewers.

Data Sources

Each exploration can have only one data source.

Each report (and each section within a report) can have multiple data sources.

Data that is used for explorations and reports must be loaded into memory on the SAS 
LASR Analytic Server. In addition to loading SAS data sets, an administrator can load 
other data that is accessible to a SAS/ACCESS engine and import local Excel or 
delimited (CSV) files.

TIP An administrator can perform ETL and aggregation functions before loading 
data. For more information, see the data preparation chapters in the SAS Visual 
Analytics: User's Guide.
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Anatomy of a Report

A report’s content can include the following types of objects:

n Objects that display data or results, including tables, graphs, geo maps, gauges, and 
stored processes.

n Objects that provide static content, including images (for example, a logo) and text 
(for example, a link to a web page).

n Objects that enable viewers to interact with a report (these objects are called 
controls).

A report’s structure is provided by sections and containers:

n Sections separate content onto different tabs or pages. Designers and viewers can 
see the contents of only one section at a time.

n Vertical and horizontal containers group objects within a section. A container has a 
scrollable space, enabling the container to hold more content than what fits on the 
screen. Designers and viewers can scroll in the report to see additional content.
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The Home Page

1 The menu bar offers common tasks and search functionality.

2 The Create Content area has icons for creating new explorations and reports.

3 The My Content area provides several ways to navigate to certain types of content.

4 The Other Content area displays predefined lists of content.

5 The Common Actions pane is an alternate initiation point for certain actions.

6 The Links pane lists an introductory video and any pages that you have 
bookmarked.

7 The SAS Resources pane has links to the SAS website and social media.
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The Explorer

1 The application bar provides access to the home page and recent explorations.

2 The menu bar offers common tasks, such as creating a new exploration.

3 The toolbar enables you to manage your explorations and visualizations.

4 The data pane enables you to manage the data that is used in your visualizations.

5 The data properties table enables you to set data item properties.

6 The workspace displays one or more visualizations.
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7 The right pane’s tabs enable you to set properties and data roles, subset data, and 
use comments.

8 The dock contains any minimized visualizations.

The Designer

1 The application bar provides access to the home page and recent objects.

2 The menu bar offers common tasks for the current report or section.

3 The toolbar enables you to expand the workspace and change a report’s canvas 
size.
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4 The Objects tab enables you to add new report objects. The Imports tab enables 
you to import and reuse content from other reports.

5 The Data tab enables you to select data. You can add, refresh, or remove a data 
source using the icons above the list of data items. Using the local menu ( ), you 
can change the data source, define a hierarchy, define a calculated item, or show or 
hide data items. You can also access the details for the measures in the data set.

The Shared Rules tab enables you to create and manage display rules that are 
used by multiple gauges (for example, a display rule can designate range intervals 
and colors).

6 The data item table provides information about a selected data item, including the 
name, role, format, and aggregation. If you modify any of these data item properties, 
all report objects that use that data item are affected.

7 The canvas is the workspace for building a report. There is an area at the top of the 
canvas where you can drop filter controls and then categories to create section 
prompts.

8 The right pane’s tabs enable you to work with details about a report and its report 
objects. To access additional tabs or to display icons instead of tab names, click 
after the last tab name.
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The Viewers

Here is an example of a report in the web viewer:

36 Chapter 4 / Quick Reference



The mobile viewers are native to each device. For example, here is a screen capture 
from the SAS Mobile BI app for iPad:

Where to Find Additional 
Documentation

The most current technical resources for SAS Visual Analytics are available on the SAS 
support site.

Your experience with SAS software should be as smooth as possible. Please submit 
your feedback.
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http://support.sas.com/software/products/va/index.html
http://support.sas.com/software/products/va/index.html
http://support.sas.com/feedback/form?http://support.sas.com/techsup/index.html
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