Contents

About This Book ................................................................. ix
Accessibility Features of SAS Visual Analytics ............................... xi

PART 1 Introduction to SAS Visual Analytics 1

Chapter 1 • About SAS Visual Analytics .................................................. 3
  What Is SAS Visual Analytics? .......................................................... 3
  Benefits of Using SAS Visual Analytics ............................................. 3
  How Does SAS Visual Analytics Work? .............................................. 4

Chapter 2 • Manage Access to SAS Visual Analytics .................................. 5
  Access to SAS Visual Analytics Capabilities ...................................... 5
  Log On to SAS Visual Analytics ....................................................... 5
  Log Off from SAS Visual Analytics .................................................. 6

Chapter 3 • SAS Visual Analytics Interface ................................................. 9
  Your First Look at the SAS Visual Analytics Home Page ............... 9
  About the Availability of Menus and Menu Selections in SAS Visual Analytics ......................................................... 11
  Managing Your Content on the Home Page ..................................... 11
  Specifying Your Preferences ......................................................... 12
  Discovering Details about Objects on the Home Page .................... 15
  Adding Comments to Reports and Explorations on the Home Page .... 16

PART 2 Preparing Data 19

Chapter 4 • Overview of the Data Preparation Interface ............................. 21
  About the SAS Visual Analytics Data Preparation Interface ........... 21
  Specifying Your Preferences for the Data Preparation Interface ....... 22
  About Exporting Code .............................................................. 22

Chapter 5 • Creating Prepared Data ............................................................. 25
  Features in Data Preparation ......................................................... 25
  Concepts in Data Preparation ....................................................... 25
  Prepare Data .............................................................................. 26
  Joining Tables ............................................................................. 28
  Adding Calculated Columns ......................................................... 28

Chapter 6 • Loading Data ........................................................................ 31
  Concepts in Loading Data ............................................................. 31
  Load from HDFS ......................................................................... 32
  Load from Table .......................................................................... 32
  Unload a Table ............................................................................ 33

Chapter 7 • Server Management ............................................................... 35
  Features in Server Management ...................................................... 35
PART 3 Exploring Data 39

Chapter 8 • Overview of SAS Visual Analytics Explorer ..................................................... 41
  What Is the SAS Visual Analytics Explorer Interface? .................................................... 41
  Accessing the SAS Visual Analytics Explorer Interface ............................................... 41
  The Welcome Dialog Box ................................................................................................. 42
  Overview of SAS Visual Analytics Explorer Interface .................................................. 43

Chapter 9 • Opening a Data Source ................................................................................. 45
  Overview of Opening a Data Source ................................................................................ 45
  Select a Data Source ........................................................................................................ 45
  Select Columns ................................................................................................................ 45
  Reduce Your Data ............................................................................................................ 46

Chapter 10 • Managing Data .............................................................................................. 49
  Refresh Your Data Source ................................................................................................ 49
  Change the Data Source for Your Visual Exploration ..................................................... 49
  Managing Data Properties ............................................................................................... 50
  Define a Geography Data Item ....................................................................................... 52

Chapter 11 • Working with Visualizations ....................................................................... 55
  Overview of Visualizations .............................................................................................. 56
  Working with Visualizations ........................................................................................... 60
  Managing Visualization Data Roles .............................................................................. 63
  Working with Filters ....................................................................................................... 65
  Working with Automatic Charts .................................................................................... 65
  Working with Bar Charts ................................................................................................. 65
  Working with Line Charts ............................................................................................... 67
  Working with Tables ....................................................................................................... 69
  Working with Scatter Plots .............................................................................................. 70
  Working with Bubble Plots .............................................................................................. 71
  Working with Histograms ............................................................................................... 73
  Working with Box Plots ................................................................................................. 74
  Working with Heat Maps ................................................................................................. 76
  Working with Geo Maps ................................................................................................. 78
  Working with Correlation Matrices .............................................................................. 79

Chapter 12 • Working with Visualization Filters .............................................................. 81
  About Filters .................................................................................................................... 81
  Create a Filter .................................................................................................................. 82
  Edit a Filter by Using Visual Filter Controls ................................................................ 82
  Edit a Filter by Using the Edit Filter Dialog Box ......................................................... 83
  Set the Scope of a Filter (Global or Local) .................................................................... 85
  Remove a Filter ............................................................................................................... 85
  Reset a Filter .................................................................................................................. 85

Chapter 13 • Exporting Data .............................................................................................. 87
  Overview of Exporting Data ........................................................................................... 87
  Export a Visual Exploration as a Report ......................................................................... 87
Export a Visual Exploration as a PDF .......................................................... 88  
Save a Visualization as an Image File ......................................................... 88  
E-mail a Visual Exploration as a Link ......................................................... 89  

**Chapter 14 • Managing Hierarchies** ......................................................... 91  
Overview of Hierarchies in the SAS Visual Analytics Explorer Interface .... 91  
Create a New Hierarchy .............................................................................. 92  
Edit a Hierarchy .............................................................................................. 92  
Delete a Hierarchy .......................................................................................... 92  

**Chapter 15 • Managing Visual Explorations** ............................................. 93  
What Is a Visual Exploration? ...................................................................... 93  
Create a New Visual Exploration ................................................................. 93  
Saving Your Visual Exploration ................................................................. 93  
Deleting Visual Explorations ...................................................................... 93  

**Chapter 16 • Performing Data Analysis** .................................................. 95  
Overview of Analyzing Your Data ................................................................. 95  
Add Analysis to an Existing Visualization .................................................. 97  
Correlate Multiple Measures as a New Visualization ................................. 97  

**Chapter 17 • Specifying Your Preferences** ................................................ 99  
Specifying Global Preferences ..................................................................... 99  
Specify Preferences That Are Specific to the Explorer Interface .................. 99  

PART 4  Designing Reports  ............................................................................ 101  

**Chapter 18 • Overview of the Designer Interface** ...................................... 103  
About the SAS Visual Analytics Designer Interface .................................... 103  
Your First Look at the Designer Interface .................................................... 103  
Open Dialog Box ............................................................................................ 105  
Search Dialog Box ......................................................................................... 106  

**Chapter 19 • Opening Reports** ................................................................. 109  
Opening Reports Created in the Designer Interface ...................................... 109  
An Example Report ....................................................................................... 109  

**Chapter 20 • Creating and Saving Reports** ............................................... 111  
Creating a New Report .................................................................................. 111  
Basing a New Report on Report Objects Imported from One or More Existing Reports .................................................................................. 112  
Saving a Report ............................................................................................. 113  

**Chapter 21 • Selecting Data** ..................................................................... 115  
Overview of Queries Based on Data Items .................................................. 115  
Using Data Items in a Query .......................................................................... 115  
Removing Data Assignments from Report Objects ...................................... 118  

**Chapter 22 • Displaying Results in a Table, Graph, or Gauge** .................... 121  
Using Tables, Graphs, and Gauges ............................................................... 121  
Using Tables to Display Results ................................................................... 122  
Using Graphs to Display Results .................................................................. 124  
Using Gauges to Display Results ................................................................. 133
**PART 7  SAS High-Performance Computing Management**

**Console  173**

**Chapter 31 • Overview of the Console** ................................................................. 175
   About the Console ........................................................................ 175
   Accessing the Console .................................................................. 175
   Specifying Console Preferences ................................................... 176
   Configuring Console Network Settings ....................................... 177
   Configuring Console Logging ..................................................... 178

**Chapter 32 • Managing Console Users and Groups** ........................................... 181
   Managing Console Users and Groups ......................................... 181
   Force Off Console Sessions ....................................................... 187

**Chapter 33 • Viewing Console Logs** ................................................................. 189
   View Logs for an Active Session ................................................. 189
   Search Console Logs .................................................................... 190
   Understanding Log Details .......................................................... 190

**Chapter 34 • Managing Users and Groups** ......................................................... 193
   About Managing Users and Groups ........................................... 193
   Managing Users and Groups ..................................................... 194
   Managing User Sessions ............................................................. 200
   Perform an SSH Lockout ........................................................... 201

**Chapter 35 • Gridhosts File Management** ......................................................... 205
   What Is the Gridhosts File? ......................................................... 205
   Managing the Gridhosts File ...................................................... 205

**Glossary** .............................................................................................................. 209

**Index** ................................................................................................................ 213
About This Book

Audience

The features of SAS Visual Analytics are designed for the following users:

- Persons responsible for managing SAS servers and managing the SAS Visual Analytics environment.
- Persons needing to explore data in support of ad hoc business questions.
- Persons responsible for designing and creating reports for their enterprise.
- Persons responsible for analyzing report data and making decisions based on that data.

Prerequisites

Here are the prerequisites for using SAS Visual Analytics:

- A user ID and password for logging on to SAS Visual Analytics.
- A supported browser installed on your desktop client.
- Access to data sources that can be used to obtain data for exploration or reports.

If you have questions about whether you are ready to use SAS Visual Analytics, contact your system administrator.
About This Book
Overview

SAS Visual Analytics has been tested with assistive technology tools. It includes accessibility and compatibility features that improve the usability of the product for users with disabilities, with exceptions noted below. These features are related to accessibility standards for electronic information technology that were adopted by the U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973 (2008 draft proposal initiative update). Applications are also tested against Web Content Accessibility Guidelines (WCAG) 2.0, part of the Web Accessibility Initiative (WAI) of the Worldwide Web Consortium (W3C). For detailed information about the accessibility of this product, send e-mail to accessibility@sas.com or call SAS Technical Support.

User Interface Layout

SAS Visual Analytics contains the following interfaces:

- The SAS Visual Analytics home page contains three main sections:
  - The top of the home page contains the Home bar, the menu bar, and the toolbar. The Home bar contains a Home button that enables you to return to the SAS Visual Analytics home page. The menu bar contains menus and a Log Off button.
  - The center of the home page contains the workspace, where you can create content, view your content, or view content created by other users.
  - The right side of the home page contains a Common Actions panel, which provides an alternate way to create reports, explore data, and manage your environment or favorites. The Videos panel links you to a video for SAS Visual Analytics. The SAS Resources panel links you to resources on the SAS Web site and to social media.
  - The data preparation interface in SAS Visual Analytics enables you to perform data preparation operations and to manage the environment. The application window contains four main sections:
    - The top of the window contains the application name and an application bar that includes a menu bar and a Log Off button.
    - The left side of the window contains a collapsible navigation pane. This pane contains a view of the SAS Folders tree. You can navigate the tree to select
tables (one at a time) for use in data preparation, loading into a SAS LASR Analytic Server instance, or adding data to HDFS.

- The center of the window (the work area) contains tabs that you use for preparing data and managing the environment. Each data preparation activity is performed on a tab. A tab is also opened for working with HDFS, for monitoring resources and processes, and for managing mobile devices. The work area can be split (either vertically or horizontally) into two groups of tabs.

- The bottom of the window contains a status bar that displays information about your connection to the metadata server.

- The explorer interface in SAS Visual Analytics enables you to explore data. The application window contains four main sections:
  - The top of the window contains the Home bar, the menu bar, and the toolbar. The Home bar contains a Home button that enables you to return to the SAS Visual Analytics home page. The menu bar contains menus and a Log Off button.
  - The left side of the window contains the data panel. The data panel contains all of the data items in your visual exploration. A table at the bottom of the data panel enables you to modify the properties of the data item that is currently selected.
  - The center of the window contains the workspace. The workspace contains the visualizations (charts, tables, histograms, and maps) for your visual exploration. A dock bar at the bottom of the workspace enables you to manage your visualizations.
  - The right side of the window is a panel that contains the Roles, Filters, and Properties tabs. The Roles tab enables you to manage data roles for the current visualization. The Filters tab enables you to create filters for the current visualization. The Properties tab enables you to manage properties for the current visualization.

- The designer interface in SAS Visual Analytics provides a framework for working with data and reports. The application window contains four main sections:
  - The top of the window contains the Home bar, the menu bar, and the toolbar. The Home bar contains a Home button that enables you to return to the SAS Visual Analytics home page. The menu bar contains menus and a Log Off button.
  - The left side of the window contains the data panel. The data panel contains all of the data items in your visual exploration. A table at the bottom of the data panel enables you to modify the properties of the data item that is currently selected.
  - The center of the window is the canvas (or workspace) where you design reports.
  - The right side of the window contains a panel for the Properties tab, which lists the properties for the currently selected report object. The Styles tab enables you to specify styles for the data, frame, and text, as well as colors for the data. The Display Rules tab enables you to specify a range for report objects that support this feature.

To customize the application window and its features, select File ➔ Preferences. On the SAS Visual Analytics home page, click either £ or Edit Preferences to open the Preferences dialog box. For more information about the layout and features of SAS Visual Analytics, see “Your First Look at the SAS Visual Analytics Home Page” on page 9.
Themes

An application’s theme is the collection of colors, graphics, and fonts that appear in the application. The following themes are provided with this application: SAS Corporate, SAS Blue Steel, SAS Light, and SAS Dark. To change the theme for the application, select File ⇒ Preferences and go to the Global Preferences page.

You can also use keyboard shortcuts to magnify the contents of the browser window or to invert the application colors. For more information, see “Keyboard Shortcuts” on page xiii.

Note: If you have special requirements for your themes, then contact your system administrator or visual designer about using the SAS Theme Designer for Flex application to build custom themes. SAS Theme Designer for Flex is installed with SAS themes. For more information about this tool, see SAS Theme Designer for Flex: User’s Guide.

Keyboard Shortcuts

The following table contains the keyboard shortcuts for the application. In the user interface, the shortcuts are displayed within parentheses in tooltips and menu labels.

Note: Some application-level keyboard shortcuts do not work when you first open an application. When that happens, press Tab to place the focus on the application, and then try the keyboard shortcut again.

Note: When you use a keyboard shortcut to activate a button, first give the focus to the field or section that the button is associated with before you use the keyboard shortcut. For example, if a table has an associated button, you must first move the focus to the table before you press Ctrl+.?

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a Help pop-up window from the button.</td>
<td>Ctrl+?</td>
</tr>
<tr>
<td>Note: This shortcut does not work on some keyboards (for example, the Italian keyboard).</td>
<td></td>
</tr>
<tr>
<td>Zoom in.</td>
<td>Ctrl++</td>
</tr>
<tr>
<td>Zoom out.</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td>Reset the zoom state.</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Hide or show the application bar (includes the menu bar and the workspace bar), category pane, and tile pane.</td>
<td>Ctrl+Alt+Shift+M</td>
</tr>
<tr>
<td>Open a pop-up menu.</td>
<td>Shift+F9 (if a menu is available in that context)</td>
</tr>
<tr>
<td>Note: If you use Shift+F9 to display the pop-up menu, then it is always displayed in the top left corner of the user interface control that you are using.</td>
<td></td>
</tr>
<tr>
<td>Task</td>
<td>Keyboard Shortcut</td>
</tr>
<tr>
<td>---------------------------------------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Open the Landmarks window and move focus to the list of landmarks. Each landmark represents an area of the application window. You can quickly navigate to that area of the application by selecting a landmark.</td>
<td>Ctrl+F6 and then tab once.</td>
</tr>
<tr>
<td>Temporarily invert or revert application colors (for the current session only).</td>
<td>Ctrl+~</td>
</tr>
<tr>
<td>Note: You can set the Invert application colors preference in the Preferences window if you want the color change to persist across sessions.</td>
<td></td>
</tr>
<tr>
<td>Rename the selected tab.</td>
<td>Make sure that focus is on the tab. Press F2 and specify the new name. To commit your changes, press Enter. To cancel your changes, press Esc.</td>
</tr>
<tr>
<td>Close the selected tab.</td>
<td>Make sure that focus is on the tab, and then press Delete. Note: Some tabs cannot be closed.</td>
</tr>
<tr>
<td>Navigate to the column headings in a table.</td>
<td>For a two-dimensional table, first make sure that focus is on the table. Press Ctrl+F8 to move the focus to the column headings, and then use the arrow keys to navigate from heading to heading. For a multidimensional table, first make sure that focus is on the table. Press Tab to move the focus to the column headings, and then use the arrow keys to navigate from heading to heading.</td>
</tr>
<tr>
<td>Sort columns in a table.</td>
<td>To sort a single column, navigate to the column heading of the column that you want to sort. Press spacebar to sort the column. To sort additional columns, navigate to the column heading of each additional column that you want to sort. Press Ctrl+spacebar.</td>
</tr>
</tbody>
</table>

**Exceptions to Accessibility Standards**

These exceptions are known to occur when using the application with Internet Explorer.

<table>
<thead>
<tr>
<th>Accessibility Issue</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using JAWS with this application can sometimes cause Internet Explorer to stop responding.</td>
<td>Using JAWS 13 or later might resolve the issue.</td>
</tr>
<tr>
<td>Accessibility Issue</td>
<td>Workaround</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>JAWS cannot read some of the controls in the application, such as images, icons, and buttons.</td>
<td></td>
</tr>
<tr>
<td>JAWS cannot read the tooltips of items in trees and lists.</td>
<td></td>
</tr>
<tr>
<td>JAWS refers to table controls as list boxes.</td>
<td>When JAWS reports that a control is a list box, keep in mind that it might actually be a table.</td>
</tr>
<tr>
<td>The keyboard shortcuts that are used to interact with editable tables can conflict with keyboard shortcuts for JAWS' forms mode.</td>
<td>As a best practice, disable the JAWS virtual PC cursor when you work with tables. Tab to the table and press Insert+Z to disable the JAWS virtual PC cursor. When you finish interacting with the table, press Insert+Z to re-enable the JAWS virtual PC cursor.</td>
</tr>
<tr>
<td>JAWS cannot read two-column property tables.</td>
<td></td>
</tr>
<tr>
<td>JAWS does not correctly read the information in a table:</td>
<td></td>
</tr>
<tr>
<td>• JAWS cannot read the column headings of a table.</td>
<td></td>
</tr>
<tr>
<td>• When table cells are not editable and focus is on the body of the table, JAWS reads an entire row at a time instead of cell by cell.</td>
<td></td>
</tr>
<tr>
<td>• When table cells are editable, and focus is on the body of the table, JAWS reads only the first row of the table. If you use the arrow keys to select a cell or row, then JAWS does not read anything. If you press Enter to edit a cell, then JAWS reads the row that contains the edited cell.</td>
<td></td>
</tr>
<tr>
<td>When you are in a table cell, if you press Home, End, Page Up, or Page Down, the selected cell will change to be one in the first column of the currently displayed columns for the table.</td>
<td>Use the arrow keys to navigate through the cells of the table.</td>
</tr>
<tr>
<td>You cannot use the keyboard to activate the links within how-to topics and Help pop-up windows.</td>
<td>Use the Help menu to access the linked documents.</td>
</tr>
<tr>
<td>You cannot use Shift+F10 to open a pop-up menu.</td>
<td>Use Shift+F9 to open pop-up menus that are created for the SAS application. The generic menu that is provided by the Flash player cannot be opened by Shift+F9.</td>
</tr>
<tr>
<td>You cannot use the keyboard to access the close (x) button that is in the top right corner of a tab.</td>
<td>Make sure that focus is on the tab, and then press Delete to close the tab.</td>
</tr>
</tbody>
</table>
## Accessibility Workarounds for the SAS Mobile BI App

These are workarounds for the SAS Mobile BI app:

<table>
<thead>
<tr>
<th>Accessibility Issue</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual focus for the menu bar is indicated with an outline around the entire menu</td>
<td>To select individual menus, use the left or right arrow key.</td>
</tr>
<tr>
<td>bar.</td>
<td></td>
</tr>
<tr>
<td>You cannot use the keyboard to navigate to all of the items in a drop-down list</td>
<td></td>
</tr>
<tr>
<td>if the list is a hierarchical structure (a tree, for example).</td>
<td></td>
</tr>
<tr>
<td>Sometimes, after the focus leaves the application (Flash player) area of the Web</td>
<td></td>
</tr>
<tr>
<td>browser, you will not be able to use the keyboard to return focus to the application.</td>
<td></td>
</tr>
<tr>
<td>In a table-style report object, voice over reads the entire row instead of only the</td>
<td>No workaround.</td>
</tr>
<tr>
<td>currently selected cell.</td>
<td></td>
</tr>
<tr>
<td>In Folder view of the Library, tab to any folder and tap on it. Tab to a sub-folder</td>
<td>You must roll over the sub-folder area in order for the sub-folder contents</td>
</tr>
<tr>
<td>The tab list ends at the bottom of the current folder list.</td>
<td>to appear in the tab list.</td>
</tr>
<tr>
<td>The contents of the My Portfolio screen appear to be a disjointed set of controls.</td>
<td>Voice-over users should drag their finger around the screen to find the</td>
</tr>
<tr>
<td>However, the screen actually contains the reports that have been downloaded.</td>
<td>name of each report and then split tap or double tap to open each report.</td>
</tr>
<tr>
<td>When deleting a report, there is a visual indicator that a specific report has been</td>
<td>To delete reports, voice-over users must first select the report to delete</td>
</tr>
<tr>
<td>selected for deletion. However, that selected state is not communicated to voice-over</td>
<td>and then examine the state of the <strong>Delete</strong> button. If the <strong>Delete</strong> button</td>
</tr>
<tr>
<td>users.</td>
<td>is active, a report is selected and it will be deleted when the <strong>Delete</strong></td>
</tr>
<tr>
<td>button is activated. However, it is not possible to confirm which report will be</td>
<td>button is activated.</td>
</tr>
<tr>
<td>deleted using voice over.</td>
<td></td>
</tr>
</tbody>
</table>
Part 1

Introduction to SAS Visual Analytics

Chapter 1
About SAS Visual Analytics ........................................ 3

Chapter 2
Manage Access to SAS Visual Analytics .......................... 5

Chapter 3
SAS Visual Analytics Interface .................................... 9
Chapter 1
About SAS Visual Analytics

What Is SAS Visual Analytics?
SAS Visual Analytics is an easy to use, Web-based product that leverages SAS high performance analytic technologies and empowers organizations to explore huge volumes of data very quickly in order to see patterns and trends, and to identify opportunities for further analysis. The highly visual, drag and drop data exploration interface combined with the SAS in-memory server technology to accelerate analytic computations, enable organizations to derive value from massive amounts of data. This creates an unprecedented ability to solve difficult problems, improve business performance, and mitigate risk rapidly and confidently.

SAS Visual Analytics empowers business users, business analysts, and IT administrators to accomplish tasks from an integrated suite of applications that are accessed from a home page. The central entry point for SAS Visual Analytics enables users to perform a wide variety of tasks such as preparing data sources, exploring data, designing reports, as well as analyzing and interpreting data. Most importantly, reports can be displayed on a mobile device or in a Web viewer.

Benefits of Using SAS Visual Analytics
Using SAS Visual Analytics, users can explore new data sources, investigate them, and create visualizations to uncover relevant patterns, and then easily share those visualizations in reports. Traditional reporting is prescriptive. That is, you know what you are looking at and what you need to convey. However, data discovery invites you to plumb the data, its characteristics, and relationships. Then, when useful visualizations are achieved, you can incorporate those visualizations into reports that are available on a mobile device or in a Web viewer.

SAS Visual Analytics provides users with the following benefits:
• enables users to apply the power of SAS analytics to massive amounts of data
empowers users to visually explore data, based on any variety of measures, at amazingly fast speeds

enables users to share insights with anyone, anywhere, via the Web or a mobile device

How Does SAS Visual Analytics Work?

You can use SAS Visual Analytics to explore and view data, interact with and create reports, and display reports on a mobile device or in a Web viewer. You can explore your data by using interactive visualizations such as charts, histograms, and tables. Report authors can easily point and click to query central sources of data. You can add filters and design the layout using tables, graphs, and gauges using drag and drop to create a well-formatted report.

The following figure illustrates how the different pieces of SAS Visual Analytics work together. It also shows how users interact with the different interfaces.

Figure 1.1 Overview of SAS Visual Analytics
Chapter 2

Manage Access to SAS Visual Analytics

Access to SAS Visual Analytics Capabilities

Users might have access to different functionality, depending on their assigned roles. Roles are mapped to capabilities. A capability, also known as an application action, defines the operations a user can perform.

SAS Visual Analytics is shipped with three predefined roles—Report Viewing, Analysis, and Administration. A predefined set of capabilities is available for each role. A system administrator can modify these roles and specify the capabilities that meet the guidelines for your company. They can also define new roles. If you have questions about your assigned role, contact your system administrator.

For more information about the roles and capabilities that are available, see the SAS Visual Analytics: Administration Guide.

Note: This user's guide discusses tasks that you might be able to perform, depending on your role.

Log On to SAS Visual Analytics

SAS Web Visual Analytics uses the standard logon window for SAS applications.

To log on to SAS Visual Analytics:

1. To display the SAS Visual Analytics logon window, click on the URL that is supplied by your system administrator or paste it into the address field of your browser. For example, you might enter http://server01.abc.com:8080/SASVisualAnalyticsHub/
2. To log on to SAS Visual Analytics:
   a. In the **User ID** field, type your user ID.
   b. In the **Password** field, type the password for the user ID that you just entered.
   c. Click **Log On**.

   The SAS Visual Analytics home page appears.

   *Note:* Your password is case-sensitive. Your user ID might be case-sensitive, depending on the operating system that is used to host the Web application server. If you need assistance, contact your system administrator.

---

### Log Off from SAS Visual Analytics

To log off from SAS Visual Analytics, click **Log Off** in the upper right corner of the user interface.

*Note:* When you select **Log Off**, you will be logged off from all environments.

If you are prompted about unsaved changes, click **Log Off** to exit without saving or click **Continue** to return to SAS Visual Analytics and keep working. Here is an example of the time-out warning message:

*Display 2.2  Session Time-out Warning Message*
If you lose your connection to SAS Visual Analytics (for example, your session times out), then you must begin again at the point where you last saved your work. By default, if there is no activity for 30 minutes, then SAS Visual Analytics automatically logs you off and displays the logon window. Your system administrator can change the inactivity period and whether the **Log On** button is available. As a best practice, save your work frequently.

The following example shows the message that appears after your session has timed out:

**Display 2.3  Session Timed Out Message for SAS Visual Analytics**
Your First Look at the SAS Visual Analytics Home Page

After you log on to SAS Visual Analytics using the standard window for SAS applications, you will see the home page. The home page enables you to create new content in SAS Visual Analytics and enables you to access content that you and others have created.
Here are the features of the SAS Visual Analytics home page:

**Figure 3.1  SAS Visual Analytics Home Page**

1. The menu bar enables you to access task options, such as creating reports, exploring data, managing your environment or favorites, and getting help on using SAS Visual Analytics. You can also search all SAS content from the menu bar, and you can log off from SAS Visual Analytics.

2. The **Create Content** area provides icons to let you quickly create a new report or to explore data.

3. The **My Content** area lists any explorations or reports that you have opened or created recently. It also lists any content that you have marked as a favorite. Click **Browse** to explore folders to find a report or an exploration.

4. The **Other Content** area displays lists of explorations or reports that your administrator has added for you. If your administrator has not created any lists, then you will not see this content area. If you have an Administration role, then you will also see a **Manage** link that enables you to manage lists.

5. The **Common Actions** panel provides an alternate way for you to create reports, explore data, and manage your environment or favorites. If you have an Administration role, then you will also see a link for preparing data.

6. The **Videos** panel links you to a video for SAS Visual Analytics.

7. The **SAS Resources** panel links you to resources on the SAS Web site and to social media.

Once you start using the home page, thumbnails enable you to open explorations or reports that you have created. You can mark content as favorites, and you can search for content on the home page.

For more information about other parts of the SAS Visual Analytics interface, see the following topics:

- “Overview of SAS Visual Analytics Explorer Interface” on page 43.
- “Your First Look at the Designer Interface” on page 103.
About the Availability of Menus and Menu Selections in SAS Visual Analytics

All of the following conditions influence whether a SAS Visual Analytics menu or menu selection is available to use:

- your role and the associated capabilities. For example, you must have an Administration role to prepare data.

- your location in SAS Visual Analytics. For example, some tasks are available only if you are designing a report.

- the currently selected report object. For example, ranges are not available for list tables.

- whether the data for a report has been defined. For example, if the data has not been selected, then you cannot create a filter.

For more information about roles and capabilities, see the *SAS Visual Analytics: Administration Guide*.

Managing Your Content on the Home Page

The home page displays recent reports and explorations, as well as favorites, under the My Content heading on the home page. To manage your content, click Manage to the right of the My Content heading. This displays the Manage My Content dialog box.

*Display 3.1  Manage My Content Dialog Box*
The icons in the Manage My Content dialog box let you create a new favorites group, add a favorite, or select options.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🍀</td>
<td>Creates a new folder for your reports and explorations.</td>
</tr>
<tr>
<td>🌈</td>
<td>Adds a report or exploration to your list of favorites.</td>
</tr>
<tr>
<td>Options</td>
<td>Enables you to select either <strong>Clear Recent History</strong> or <strong>Clear Favorites</strong>.</td>
</tr>
<tr>
<td>✗</td>
<td>Enables you to delete a favorites folder, a report, an exploration, or recent content one at a time. You can delete multiple favorite items by pressing the Ctrl key.</td>
</tr>
<tr>
<td>🔄</td>
<td>Enables you to move favorites folders, reports, and explorations up in the list to change what is displayed under the <strong>My Content</strong> heading on the home page.</td>
</tr>
<tr>
<td>🔽</td>
<td>Enables you to move favorites folders, reports, and explorations down in the list to change what is displayed under the <strong>My Content</strong> heading on the home page.</td>
</tr>
</tbody>
</table>

When you select a report or exploration in the Manage My Content dialog box, the details such as the name and location of that report are displayed. If you select a favorite group, the details include information about how many favorites the folder contains and its location.

---

### Specifying Your Preferences

#### Specifying Global Preferences

You can specify global preferences that are applied to all SAS Web applications that are displayed with the Adobe Flash player. These preferences are set by each user.

To specify global preferences:

1. Click either 🎨 or **Edit Preferences** to open the Preferences dialog box.
   
   *Note:* If you are in the data preparation, exploration, or designing environments, then select **File > Preferences** to open the Preferences dialog box.

2. Make sure that **Global Preferences** is selected in the left panel.

3. Select a **User locale** to specify your language and geographic region.

   Select a **Theme** to change the color scheme and other visual settings for all of your SAS Web applications.

   Select **Invert application colors** to invert all of the colors in your SAS Web applications.

   Select **Override setting for focus indicator** to change the color, thickness, and opacity of the focus in your SAS Web applications.
4. Click **OK** to apply your changes.

*Note:* To restore all of the Global Preferences options, click **Reset to Defaults**.

**Specifying the SAS Visual Analytics General Preferences**

Using the SAS Visual Analytics home page, you can specify your general preferences for SAS Visual Analytics.

To specify your general preferences:

1. Click either **Preferences** or **Edit Preferences** to open the Preferences dialog box.

2. Click **General** in the left panel.

3. Specify your preference for **Show this number of recent items**. The default setting is 9 items.
   
   Click **Clear History** to reset your history.
4. Click OK to apply your changes.

Note: To restore the SAS Visual Analytics general preference, click Reset to Defaults.

**Specifying the SAS Visual Analytics Initial Page Preference**

Using the SAS Visual Analytics home page, you can specify your preference for the initial screen that you want to see after you log on to SAS Visual Analytics.

To specify your initial page preference:

1. Click either P or Edit Preferences to open the Preferences dialog box.
2. Click Home in the left panel.
3. Select one of the options from the Initial screen after log in drop-down list.

   The following options are available:
   
   • Home
   • Where user logged off most recently
   • A specific report or exploration
   • New report
   • New exploration

**Display 3.3 Preferences Dialog Box for SAS Visual Analytics General Preferences**
4. Click **OK** to apply your changes.

   *Note:* To restore the SAS Visual Analytics option, click **Reset to Defaults**.

### Specifying Preferences for the Data Preparation Interface

See “Specifying Your Preferences for the Data Preparation Interface” on page 22.

### Specifying Preferences for the Explorer Interface

See “Specify Preferences That Are Specific to the Explorer Interface” on page 99.

---

### Discovering Details about Objects on the Home Page

The home page provides a feature that enables you to quickly find more information about an object when you click it. You can see a description of the report or exploration, where the report or exploration is saved, who the author is, and when the report or exploration was modified. A small toolbar lets you add the report or exploration to your favorites or set it as your preferred starting page. Note that when you set a favorite, the icon turns yellow (🌟).

Your role determines the availability of other actions on the toolbar (such as viewing, editing, or opening) in the object inspector. Here is an example of what you might see for a report:
If you have the Report Viewing role, then the toolbar enables you to open a report in the Web viewer by clicking **Open**.

If you have the Analysis or Administration roles, then the toolbar in the object inspector enables you to do the following:

- **Edit** a report, which opens the report in the designer interface so that you can edit or change the objects in the report.
- **View** a report, which opens the report in the SAS Visual Analytics Viewer.
- **Explore data** for an exploration, which opens the data for the report in the explorer interface.
- Click ✯ to add the report or exploration to your list of favorites. When the icon is yellow (✯) click to remove the object from your list of favorites.
- Click ✦ to set the report or exploration as the initial screen when you start SAS Visual Analytics.

All users can add **Comments** to a report or view existing comments about the report using the link in the lower right of the object inspector.

---

### Adding Comments to Reports and Explorations on the Home Page

You can use the object inspector on the home page to add comments to a report or to respond to existing comments for a report or an exploration.

To add a comment:

1. Click a report to open the object inspector.
2. Click **Comments** in the lower right corner to expand the dialog box.
3. Click **New Topic** to open the New Topic dialog box.
4. Enter a topic name and a comment. Here is an example:
5. (Optional) Set a priority for the comment using the drop-down list. You can select **Normal**, **High**, or **Low**. If you set the priority to **High**, then a visual flag will be added to the comment.

6. (Optional) Click **Attachment** to add a file or image to your comment.

7. Click **Save**. The comment link in the object inspector will update to show that there is a comment.

To respond to an existing comment:
1. Click a report to open the object inspector.
2. Click **Comments** in the lower right corner to expand the dialog box.
3. Click **Reply** to open the comment dialog box.
4. Enter a comment. Here is an example:

**Display 3.7**  **Dialog Box for Replying to a Comment**

![Image of comment dialog box]

5. (Optional) Set a priority for the reply using the drop-down list. You can select **Normal**, **High**, or **Low**.
6. (Optional) Click **Attachment** to add a file or image to your reply.

7. Click **Save**. The comment link in the object inspector will update to show the number of comments.
Part 2

Preparing Data

Chapter 4
Overview of the Data Preparation Interface ........................................... 21

Chapter 5
Creating Prepared Data ................................................................. 25

Chapter 6
Loading Data ................................................................................. 31

Chapter 7
Server Management ................................................................. 35
Chapter 4
Overview of the Data Preparation Interface

About the SAS Visual Analytics Data Preparation Interface

The data preparation interface enables an administrator to prepare data by performing joins, adding calculated columns, subsetting data, and sorting. Once the data preparation operations are entered, administrators can load tables to the SAS LASR Analytic Server. In addition, for large data sets, the prepared data can be transferred to the machines in the grid and stored in the Hadoop Distributed File System (HDFS). HDFS enables the SAS LASR Analytic Server to read large data sets in parallel to memory and it also provides data redundancy.

The data preparation interface is also used to start and stop server instances, as well as to load and unload tables from the server instances. Once a server is started, administrators can view information about the server instance. This includes the user account that was used to start the server and the tables that are resident in memory. The information about tables includes the number of rows and columns for an at-a-glance evaluation of the number of server instances and tables available for use.

Navigating files in HDFS is also available from the data preparation interface. The HDFS content explorer enables administrators to browse the tables that were prepared and added to HDFS. Tables that are already prepared for analytics can be added to HDFS directly. Once stored in HDFS, tables can be loaded into memory in a server instance from the HDFS content explorer. Because SAS uses a special file format for the data that is stored in HDFS, the HDFS content explorer also provides information about the columns and row count for the prepared data.

Resource and process monitors are provided so that administrators can view real-time statistics and visualizations of resource use like central processing unit (CPU) utilization, memory utilization, and input/output (I/O) rates. A line plot of resource utilization against time is provided. In addition, the grid view creates a visualization for each blade that is used in the grid and each CPU on a blade. If resource utilization exceeds a configured threshold, the icon for the CPU or blade can draw the attention of the administrator by lighting up in yellow or red.
Controlling access by mobile devices to data is enabled with the mobile device administration user interface. This enables administrators to easily manage access to data through SAS Visual Analytics applications by mobile devices. Information about the mobile devices in your organization is available to administrators. The information includes user ID, device information, and timestamp of last access.

---

### Specifying Your Preferences for the Data Preparation Interface

The data preparation interface stores the parameters for performance monitoring in user preferences. To set the performance monitoring parameters:

1. Select **File → Preferences** to open the Preferences dialog box.
2. Select **SAS Visual Analytics → Application Server**.
   
   Select a SAS Application Server to use from the menu. If you have added SAS Application Server instances to your deployment, make sure that Job Execution Services has been configured to use the application server. For more information, see *SAS Intelligence Platform: Middle-Tier Administration Guide*.
3. Select **SAS Visual Analytics → Manage Environment**. Enter values for the following preferences:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Sample Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource monitor sample rate (ms)</td>
<td>1000</td>
<td>Specify the sampling rate that the resource monitor uses for polling the machines in the grid.</td>
</tr>
<tr>
<td>Process monitor sample rate (ms)</td>
<td>6000</td>
<td>Specify the sampling rate that the performance monitor uses for polling application instances.</td>
</tr>
<tr>
<td>Show the processes that measure performance</td>
<td>Selected</td>
<td>By default, the processes that measure performance are filtered from the graphs in the Process monitor. However, if several instances of the processes that measure performance are running, they can reduce performance. By selecting the check box, you can view and monitor the processes that measure performance.</td>
</tr>
</tbody>
</table>

4. Click **OK** to apply your changes.

---

### About Exporting Code

There are many opportunities to export code to a file when you use the data preparation interface. This feature enables administrators to review the SAS statements for a task.
Some of these tasks are starting and stopping a SAS LASR Analytic Server instance, loading and unloading tables, and adding files to HDFS. The statements in the file can be modified and scheduled. For more information about the OLIPHANT and LASR procedures, see the *SAS LASR Analytic Server: Administration Guide*.

Operations that enable saving the SAS statements have an **Export Code** button. Click the **Export Code** button to view the Export Code dialog box. On the dialog box, the **Export** button saves the SAS statements to the file that is specified in the **Location** field but does not submit the SAS statements for execution.

**Note:** The SAS statements are saved to a file with the credentials of the user account that is used to run the JBoss Application Server. This user account must have Write access to the location, and the location must be accessible from the machine that is running JBoss.

It is also possible to configure logging so that SAS statements are stored to a log file. Only the SAS statements that are generated by the data preparation interface are available to be logged. For information about enabling this feature, see *SAS Visual Analytics: Administration Guide*.
Chapter 5
Creating Prepared Data

Features in Data Preparation

The chapter describes the data preparation activities that can be performed with the data preparation interface. The following list identifies the available actions:

- select a source table and join tables based on join conditions
- add calculated columns and drop columns from source and joined tables
- control the sort order for the output data and apply row filters to subset the data
- preview the output data
- add the prepared data to HDFS

With this feature set, the data preparation interface enables administrators to access data from the variety of data sources that SAS and the SAS/ACCESS interfaces can read and then operate on the data. Administrators can control the variables needed for analytics and make the data available to the SAS LASR Analytic Server for in-memory analytic processing.

Concepts in Data Preparation

Input Data

The data preparation interface enables administrators to access a wide variety of data sources for input to the data preparation process. The SAS/ACCESS interfaces can be used to interact with database management systems (DBMS). SAS data sets and SAS
Scalable Performance Data Server can be used to construct a data warehouse. These data sources are available as input data for the analytic processing that can then be performed by the SAS LASR Analytic Server. The input data must be registered in SAS metadata as libraries and tables. For information about registering libraries and tables, see *SAS Intelligence Platform: Data Administration Guide*.

**Data Output**

The unique value of the data preparation interface is that it enables administrators to add data to the Hadoop Distributed File System (HDFS) that is co-located with the SAS LASR Analytic Server on the machines in the grid. The purpose of adding the data to HDFS is that the server can read data in parallel at very impressive rates from a co-located data provider such as HDFS.

In addition to the performance advantage of using co-located data, HDFS provides data redundancy. By default, two copies of the data are stored in HDFS. If a machine in the grid becomes unavailable, another machine in the grid retrieves the data from a redundant block and loads the data into memory.

The blocks are distributed evenly so that all the machines acting as the server have an even workload. The block size is also optimized based on the number of machines in the grid and the size of the data that is being stored. Before the data is transferred to HDFS, SAS software determines the number of machines in the grid, row length, and the number of rows in the data. Using this information, SAS software calculates an optimal block size to provide an even distribution of data. However, the block size is bounded by a minimum size of 1 KB and a maximum size of 64 MB.

For very small data sets, the data is not distributed evenly. It is transferred to the root node of the grid and then inserted into SAS Visual Analytics Hadoop. SAS Visual Analytics Hadoop then distributes the data in blocks according to the default block distribution algorithm.

**Prepare Data**

To prepare data:

1. Select a source table from the navigation pane, right-click, and select **Prepare Data**. If the table is a SAS data set, you can click **Preview Data**. The preview enables you to confirm that you have Read access to the data as well as to filter, sort, and so on, before you begin the data preparation.

2. On the Source Columns page, deselect the check boxes for any columns that you do not want to include in the prepared data.

3. On the Joined Tables page, click ➕ to select a table to join. For more information about how to use this page, see “Joining Tables” on page 28.

4. On the Calculated Columns page, click ➕ to add new columns to the prepared data. For more information about how to use this page, see “Adding Calculated Columns” on page 28.

5. On the Output Columns page, remove, reorder, or edit the output column information. You can specify the output column name, description, format, and length.
6. On the Row Filters page, add filters to subset the input data. Click \(\text{+}\) to add a new filter. Select the column name to filter on, select the filter criteria, and enter the filter value. If more than one filter is added, the filters are applied using AND logic.

7. On the Sort Order page, select the column that you want to sort by. The default sort order is ascending. Use the menu to beside the selected column name to set the sort order to descending.

8. On the Data Output page, set the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Sample Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output table</td>
<td>tablename</td>
<td>The output table name is populated automatically with the source table name. Click <strong>Browse</strong> to select a different table or type the table name that you want to use.</td>
</tr>
<tr>
<td>Location</td>
<td>/SharedData</td>
<td>Click <strong>Browse</strong> to specify a folder for the output table. The button becomes active when the <strong>Library</strong> value is changed from <strong>WORK</strong> to another library.</td>
</tr>
<tr>
<td>Library</td>
<td>WORK</td>
<td>Click <strong>Browse</strong> to specify a library for the output table.</td>
</tr>
<tr>
<td>Type of output</td>
<td>Table</td>
<td>If you select <strong>Table</strong>, then the size of the data is calculated and distributed evenly in HDFS with an optimal block size. If you select <strong>View</strong>, then the calculation for an optimal block size and even distribution is not possible.</td>
</tr>
<tr>
<td>HDFS output path</td>
<td>/user/</td>
<td>Enter the fully qualified path in HDFS to use for storing the prepared data.</td>
</tr>
<tr>
<td>HDFS filename</td>
<td>tablename</td>
<td>The filename for the table is automatically populated. It must match the name of the output table.</td>
</tr>
<tr>
<td>Description</td>
<td>Prepared data for tablename</td>
<td>Specify a description to associate with the prepared data. The description is displayed beside the table name in the explorer interface.</td>
</tr>
</tbody>
</table>

9. Click **Submit**.
Joining Tables

On the Join Tables page, you can add multiple tables to join with the source table that you have selected. The source table can also be joined to itself. When a table is added to the Join tables list, the application scans the column names in the join table and attempts to find a matching column name and type. If a match is found, then the Source table column and Join table column menus are set to the column name. If no match is found or you prefer a different join condition, set the menus appropriately. The join is performed with an INNER JOIN syntax. You can specify one join condition for each table that is joined with the source table.

In the Available items and Selected items lists, make sure that you select the columns that you want to include in the prepared data and move them to the Selected items list.

Adding Calculated Columns

Variables can be added to the prepared data. The values can be based on variables from the source table, a joined table, or even a constant value. The added variable can even be calculated from a variable that is dropped from a joined table or the source table.

The following fields are available on the Calculated Columns Drill-In page after + is clicked:

*Table 5.1 Calculated Columns Drill-In Fields*

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specify a name for the calculated column to add to the prepared data. A default name of DataItem is provided.</td>
</tr>
<tr>
<td>Description</td>
<td>Specify a description for the column. This value is used as a column label.</td>
</tr>
<tr>
<td>Type</td>
<td>Select a value from the menu.</td>
</tr>
<tr>
<td>Functions tab</td>
<td>Select a value from the Category menu to reduce the list of functions to those associated with the category. When you select a function from the list, the function description is provided in the area below the function list. Click Insert or double-click the function name to use the function for the calculated column.</td>
</tr>
<tr>
<td>Columns tab</td>
<td>Click the Columns tab to select a column from the source or joined tables to use in the calculated column. Click Insert or double-click the column name to use it for the calculated column. Constant values, whether numeric or character, can be specified directly into the expression instead of calculating the column based on a value in the input data.</td>
</tr>
<tr>
<td>Field Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Arithmetic and logic operators</td>
<td>Click the button for the arithmetic or logic operator to insert. Buttons for inserting a concatenation operator and enclosing expressions in quotation marks and parenthesis are also available.</td>
</tr>
</tbody>
</table>

**TIP** Once the expression for the calculated column is complete, click the Data Preparation: `column-name` button near the top of the page to return to the Calculated Columns page.
Chapter 6
Loading Data

Concepts in Loading Data

SAS Visual Analytics can load data from registered tables or from SASHDAT files stored in HDFS to the SAS LASR Analytic Server. The following table identifies some of the advantages and disadvantages of each method:

Table 6.1  Comparison of Registered Tables and HDFS Data Sources

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Advantages</th>
<th>Disadvantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Registered table</td>
<td>Provides a rapid method for loading tables.</td>
<td>Appropriate for smaller data sets because the data must be transferred over the network.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the table is unloaded or the server stops, the data must be transferred over the network again.</td>
</tr>
<tr>
<td>SASHDAT file in HDFS</td>
<td>Impressive performance for loading very large data sets in parallel.</td>
<td>Requires a separate step to add the data to HDFS and then load it before the data is available to SAS clients.</td>
</tr>
<tr>
<td></td>
<td>If a SAS LASR Analytic Server is stopped or the table is unloaded from the server, loading it again is also very fast.</td>
<td></td>
</tr>
</tbody>
</table>
Load from HDFS

SAS LASR Analytic Server can load data from the Hadoop Distributed File System (HDFS) that is co-located on the machines in the grid. Before loading the data, you must add the data to HDFS. To load from HDFS:

1. Navigate to the SASHDAT file to use in the HDFS content explorer. Select the file and click 
2. Specify the SAS LASR Analytic Server and data parameters:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration directory</td>
<td>This field specifies the location of the server description files.</td>
</tr>
<tr>
<td>Server description file</td>
<td>Use the menu to select the server instance to use or to specify the name of the server description file.</td>
</tr>
<tr>
<td>HDFS file</td>
<td>This path to the SASHDAT file is populated automatically.</td>
</tr>
<tr>
<td>Description</td>
<td>Specify a description for the data. This description overrides the description that was associated with the data set before it was added to HDFS. The description is displayed beside the table name in the explorer interface.</td>
</tr>
</tbody>
</table>

3. Click **Load**.

The following items provide additional information about loading from HDFS:

- Before the data can be loaded from HDFS, it must be added to HDFS. For more information, see “Prepare Data” on page 26.
- The data can also be added to HDFS with the OLIPHANT procedure from a SAS session.
- SAS LASR Analytic Server reads SASHDAT files from HDFS only. It does not read any other data that is stored in HDFS such as the output of MapReduce jobs.

Load from Table

SAS Visual Analytics can transfer tables to the SAS LASR Analytic Server and have it load the table to memory. The table is read from the data source, transferred to the root node on the grid, distributed to the machines on the grid, and then it is loaded into memory. To load from a table:

1. Locate the table using the SAS Folders view or by searching. Right-click the table icon and select **Load from Table**.
2. Specify the SAS LASR Analytic Server and data parameters:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration directory</td>
<td>This field specifies the location of the server description files.</td>
</tr>
<tr>
<td>Server description file</td>
<td>Use the menu to select the server instance to use or to specify the name of the server description file.</td>
</tr>
<tr>
<td>Table</td>
<td>The table name is populated automatically.</td>
</tr>
<tr>
<td>Description</td>
<td>Specify a description for the data. This description overrides the description that is associated with the data set. The description is displayed beside the table name in the explorer interface.</td>
</tr>
</tbody>
</table>

3. Click **Load**.

The following items provide additional information about loading from a table:

- The table to use as the data source must be registered in metadata before you can perform this procedure.
- When the data is loaded, it is transferred to the root node of the server, distributed evenly among the machines in the grid, and then loaded into memory.

---

**Unload a Table**

To unload a table:

1. Navigate on the In-Memory Data page to the table to unload.

2. Select the table and click **Unload**.

Specify the following parameters:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration directory</td>
<td>This field specifies the location of the server description files.</td>
</tr>
<tr>
<td>Server description file</td>
<td>Use the menu to select the server instance to use or to specify the name of the server description file.</td>
</tr>
<tr>
<td>Table</td>
<td>Specify the table name as it is shown in the table.</td>
</tr>
</tbody>
</table>

3. Click **Unload** on the confirmation dialog box.
If the dropped table was read from HDFS, then it can be loaded again very quickly. If the dropped table was read from a registered table, then loading it again requires distributing the rows to the SAS LASR Analytic Server again.
Chapter 7
Server Management

Features in Server Management

SAS LASR Analytic Server Concepts

Server Process Run Time

Server Description Files

Best Practices for Starting Servers and Loading Tables

Start a Server

Stop a Server

Features in Server Management

This chapter addresses the use of the SAS Visual Analytics data preparation interface to manage the SAS LASR Analytic Server. The server management functions include the following:

• starting and stopping SAS LASR Analytic Server instances
• listing the tables that are loaded into memory on a server instance

SAS LASR Analytic Server Concepts

Server Process Run Time

When a SAS LASR Analytic Server is started with the data preparation interface, the server is subject to a maximum run time that was set when the SAS software was installed on the machines in the grid. A typical value is 7200 seconds (2 hours). The maximum run-time setting acts as an inactivity time out. Whenever a SAS client initiates an action with the server, the run time is reset.

Server Description Files

When a server is started, a server description file is written to disk. The file describes the SAS LASR Analytic Server instance that was started. This file is not intended to be read by any application other than SAS clients. The SAS client applications read the file to
determine how to connect to the server instance. These files are located in a specific
directory so that the SAS clients can coordinate management of server instances being
started and stopped.

When a server is stopped with SAS Visual Analytics, the server description file is
removed as the server instance is stopped. If a server instance stops because it reached
its maximum run time, the server description file is not removed.

---

**Best Practices for Starting Servers and Loading Tables**

The following items summarize some best practices for using SAS Visual Analytics and
SAS LASR Analytic Server in your environment:

- **Start as few server instances as possible.** You can load many tables into a server
  instance.

- **Start additional servers when you need to limit access to data that is loaded into
  memory.** Start an additional server instance and load the data for the group of users
  that are authorized to view the data. Information about implementing group-level
  security is provided in the *SAS Visual Analytics: Administration Guide*.

- **Because a server description file represents a server instance, use descriptive
  filenames for them.** For example, if data analysis is being performed by a team in a
  marketing organization and the group wants to limit access to the data, then start a
  separate server instance for the team and use a server description filename like
  marketingTeam1.

- **Whenever a group, such as the marketing team, needs additional data for analysis,
  use the same server description file so that you load it into the same server instance.**
  If the server instance must be restarted for the group, use the same server description
  file.

- **Once explorations or reports are created using a particular data source, do not change
  the name of the server description file or the data source.** If either of these are
  changed, then the exploration or report will not work.

---

**Start a Server**

To start a server:

1. Click the **In-Memory Data** button and then click 🎄.

2. Specify the SAS LASR Analytic Server parameters:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration directory</td>
<td>This field specifies the path to the server description files.</td>
</tr>
</tbody>
</table>
3. Click Start.

The following items provide additional information about starting a server instance:

- If a server instance is running and you attempt to start a second server instance using the same server description file, the second server instance is not started. An error message is provided to let you know that a server instance might be running. If you select the **Override if server description file exists** check box and retry, an attempt is made to stop the server instance that is described in the file, and then the second server instance is started.

- If a server instance stops because it reached its maximum run time, then the server description file for the server is not removed. In this case, attempting to start the server again, but not selecting the **Override if server description file exists** check box, results in an error.

### Stop a Server

To stop a server:

1. Click the **In-Memory Data** button, select the server instance to stop, and click ■.

2. On the Stop SAS LASR Analytic Server dialog box, select the server description file for the server to stop and click **Stop**.

The following items provide additional information about stopping a server instance:
• When a server is stopped, the server description file is removed. The server description filename remains listed in the menu so it can be started again without retyping the filename.

• The tables that were loaded in memory on the server are no longer available for selection in the SAS Visual Analytics explorer interface.
Part 3

Exploring Data

Chapter 8
Overview of SAS Visual Analytics Explorer .................................................. 41

Chapter 9
Opening a Data Source ..................................................................................... 45

Chapter 10
Managing Data .................................................................................................. 49

Chapter 11
Working with Visualizations ............................................................................ 55

Chapter 12
Working with Visualization Filters .................................................................. 81

Chapter 13
Exporting Data .................................................................................................. 87

Chapter 14
Managing Hierarchies ....................................................................................... 91

Chapter 15
Managing Visual Explorations ......................................................................... 93

Chapter 16
Performing Data Analysis ................................................................................ 95

Chapter 17
Specifying Your Preferences ............................................................................ 99
Chapter 8
Overview of SAS Visual Analytics Explorer

What Is the SAS Visual Analytics Explorer Interface?

The SAS Visual Analytics explorer interface is a component of SAS Visual Analytics that enables you to explore your data sources. You can explore your data by using interactive visualizations such as charts, histograms, and tables.

You can use the explorer interface to open saved visual exploration objects or it can explore in-memory tables from the SAS LASR Analytics Server.

You can export your exploration results as reports, which can be refined in the designer interface or viewed directly. Reports can be viewed on a mobile device or in the SAS Visual Analytics Web viewer.

You can also share your saved visual explorations via e-mail and export your visualizations as image files.

Accessing the SAS Visual Analytics Explorer Interface

You can access the SAS Visual Analytics explorer interface by using any of the following methods:

- On the Visual Analytics Home page, click Explore Data to open the explorer interface.
  
  You can select a data source by using the Welcome dialog box.

- On the Visual Analytics Home page, double-click a visual exploration to open that visual exploration in the explorer interface.
Follow a Web link or enter the URL to access the explorer interface directly. For example, you might enter http://server.abc.com/SASVisualAnalyticsExplorer. After you have logged in to SAS Visual Analytics, you can choose a data source from the Welcome dialog box.

From an e-mail, follow a link directly to a specific visual exploration. After you have logged in to SAS Visual Analytics, the visual exploration opens in the explorer interface automatically.

The Welcome Dialog Box

If you enter the Visual Analytics explorer interface without a reference to a specific visual exploration, then the Welcome dialog box appears.

The Welcome dialog box enables you perform the following tasks:

- Create a new visual exploration by clicking Select a data source. See “Opening a Data Source” on page 45 for more information about creating a new visual exploration.
- Open a recently used visual exploration by double-clicking the visual exploration name in the Recent explorations list.
- Select an existing visual exploration by clicking Browse.
Overview of SAS Visual Analytics Explorer Interface

The SAS Visual Analytics explorer interface contains the following elements:

1. The home bar enables you to return to the SAS Visual Analytics Home page and to select from your recent visual explorations.
2. The menu bar contains menus that enable you to perform tasks.
3. The toolbar contains icons that enable you to manage your visual explorations and visualizations.
4. The data panel enables you to manage the data that is used in your visualizations.
5. The data properties table enables you to manage the properties of the data item that is selected in the data panel.
6. The workspace displays your visualizations.
7. The right panel contains tabs that enable you to change the properties of your visualizations, subset the data that is currently being used, and set the data roles for your visualizations.
8. The dock panel contains any visualizations that you have minimized and enables you to manage your visualizations.
Chapter 9
Opening a Data Source

Overview of Opening a Data Source

When you open a data source, you can perform the following tasks:

• “Select a Data Source”
• “Select Columns”
• “Reduce Your Data”

After you have opened a data source, you can specify properties for the data items such as data formats and default aggregation types. See “Managing Data Properties” on page 50.

Select a Data Source

In step 1 of the Select Data wizard, select the table that you want to import.

Click Next to proceed to the next step of the wizard, or select Finish to accept the default import settings for the remaining steps.

Select Columns

In step 2 of the Select Data wizard, select the columns that you want to import from the source data.

To select or deselect all of the columns, select the All check box.

To select or deselect individual columns, select the check box beside the column name.
A summary at the bottom of the dialog box displays the number of columns that will be imported.

Click **Next** to proceed to the next page of the wizard, or click **Finish** to accept the default import settings for the remaining steps.

---

**Reduce Your Data**

In step 3 of the Select Data wizard, create filters to reduce the data that you will import.

To create a filter:

1. Select the column that you want to filter from the **Choose column** drop-down list. If you want to filter on a column that you excluded in step 2, then select **Include hidden columns**.

2. Select the operator for the filter from the **Choose operator** drop-down list.

**Table 9.1 Operators for Datetime Data**

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is</td>
<td>Specifies that a matching value must match the filter value exactly.</td>
</tr>
<tr>
<td>Is not</td>
<td>Specifies that a matching value must not match the filter value exactly.</td>
</tr>
<tr>
<td>Ends before</td>
<td>Specifies that a matching value must be before the filter value.</td>
</tr>
<tr>
<td>Ends on or before</td>
<td>Specifies that a matching value must be before or equal to the filter value.</td>
</tr>
<tr>
<td>Starts after</td>
<td>Specifies that a matching value must be after the filter value.</td>
</tr>
<tr>
<td>Starts on or after</td>
<td>Specifies that a matching value must be after or equal to the filter value.</td>
</tr>
</tbody>
</table>

**Table 9.2 Operators for Character Data**

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is</td>
<td>Specifies that a matching value must match the filter value exactly.</td>
</tr>
<tr>
<td>Is not</td>
<td>Specifies that a matching value must not match the filter value exactly.</td>
</tr>
<tr>
<td>Begins with</td>
<td>Specifies that a matching value must contain the filter value at the start of the value.</td>
</tr>
<tr>
<td>Ends with</td>
<td>Specifies that a matching value must contain the filter value at the end of the value.</td>
</tr>
<tr>
<td>Contains</td>
<td>Specifies that a matching value must contain the filter value.</td>
</tr>
<tr>
<td>Does not contain</td>
<td>Specifies that a matching value must not contain the filter value.</td>
</tr>
<tr>
<td>Is missing</td>
<td>Specifies that a missing value matches the filter.</td>
</tr>
</tbody>
</table>
Is not missing  Specifies that any nonmissing value matches the filter.

Table 9.3  Operators for Numeric Data

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is</td>
<td>Specifies that a matching value must match the filter value exactly.</td>
</tr>
<tr>
<td>Is not</td>
<td>Specifies that a matching value must not match the filter value exactly.</td>
</tr>
<tr>
<td>Between</td>
<td>Specifies that a matching value must be greater than or equal to the first filter value and less than or equal to the second filter value.</td>
</tr>
<tr>
<td>Less than</td>
<td>Specifies that a matching value must be less than the filter value.</td>
</tr>
<tr>
<td>Less than or equal</td>
<td>Specifies that a matching value must be less than or equal to the filter value.</td>
</tr>
<tr>
<td>Greater than</td>
<td>Specifies that a matching value must be greater than the filter value.</td>
</tr>
<tr>
<td>Greater than or equal</td>
<td>Specifies that a matching value must be greater than or equal to the filter value.</td>
</tr>
<tr>
<td>Is missing</td>
<td>Specifies that a missing value matches the filter.</td>
</tr>
<tr>
<td>Is not missing</td>
<td>Specifies that any nonmissing value matches the filter.</td>
</tr>
</tbody>
</table>

3. Depending on the operator that you specified, select or specify a filter value:

Is, Is not
For character data, select the filter value from a drop-down list. For numeric data, enter the filter value in the text field.

Is missing, Is not missing
No filter value is needed.

(All date operators)
For all date filters, click and then select a date from the calendar.

(All datetime operators)
For all datetime filters, click and then select a date and time from the calendar.

(All time operators)
For all time filters, click and then select a time.

Between
Enter the lower value in the first text field and the higher value in the second text field.

For all other operators, enter the filter value in the text field.

4. Click Apply to create the filter.

5. (Optional) To delete a filter, click the icon next to the filter that you want to delete.
6. (Optional) To preview your filter results, click **Preview Data**. To close the preview, click **Hide Data**.

7. When you are finished managing your filters, click **Finish** to import your data.
Chapter 10
Managing Data

Refresh Your Data Source

At any time, you can refresh your data source to read the latest changes.

To refresh your data, select Data ➤ Refresh Data.

Your visualizations are automatically updated with the new data.

Change the Data Source for Your Visual Exploration

To change the data source for your visual exploration:

1. Select Data ➤ Change Data.

2. From the Change Data dialog box, select the data source that you want to use.

   Note: The new data source must contain all of the data items from the current data source.

3. Click Open to open the new data source.
Managing Data Properties

Overview of Managing Data Properties

At any time after you have loaded a data source for your visual exploration, you can modify the properties of the data items. The changes that you make are stored as part of the visual exploration, but do not affect the original data source.

You can manage the data properties for all of your data items by using the Data Properties dialog box.

You can manage the data properties for individual data items by using the Data panel.

Manage Data Properties by Using the Data Properties Dialog Box

To access the Data Properties dialog box, select Data ➤ Data Properties from the menu bar.

For each of your data items, you can specify the following properties:

Name
specifies the name of the data item

Role
specifies whether the data item is a category, a measure, or a geography data item.

Model Type
specifies the data model for a measure or for a category with datetime data. Select whether the data model is continuous or discrete.

The model type that you specify determines the type of data filters that you can create for the data item.

Format
specifies the data format for the data item.

See “Select a Numeric Format” on page 51 and “Select a Datetime Format” on page 52 for details about specifying formats.

Aggregation (measures only)
specifies the method that is used to aggregate values for the measure. Select one of the following aggregation types:

Sum
provides the sum of the values in the measure.

Average
provides the average of the values in the measure.

Maximum
provides the maximum value in the measure.

Minimum
provides the minimum value in the measure.
Manage Data Properties by Using the Data Panel

You can manage data properties for a specific data item by selecting the data item in the Data panel and then interacting with the properties table at the bottom of the Data panel.

For the selected data item, you can specify the following properties:

Name
specifies the name of the data item

Role
specifies whether the data item is a category, a measure, or a geography data item.

Model Type
specifies the data model for a measure or for a category with datetime data. Select whether the data model is continuous or discrete.

The model type that you specify determines the type of data filters that you can create for the data item.

Format
specifies the data format for the data item.

See “Select a Numeric Format” on page 51 and “Select a Datetime Format” on page 52 for details about specifying formats.

Aggregation (measures only)
specifies the method that is used to aggregate values for the measure. Select one of the following aggregation types:

Sum
provides the sum of the values in the measure.

Average
provides the average of the values in the measure.

Maximum
provides the maximum value in the measure.

Minimum
provides the minimum value in the measure.

Select a Numeric Format

To select a numeric format:

1. In the Data Properties dialog box or the property table in the Data panel, click the format for the data item that you want to manage. A dialog box appears.

2. Select the basic format type from the Format Type list.

3. For the Numeric and Float formats, specify the Width parameter for the format. The width of the format specifies the maximum number of characters that a value can contain, including decimal points.

   A preview of your format appears in the Sample field.

4. Specify the number of Decimals for the format. The decimals value specifies the number of digits that appear to the right of the decimal place.

   A preview of your format appears in the Sample field.

5. Click OK to apply your format.
Select a Datetime Format

To select a datetime format:

1. In the Data Properties dialog box or the property table in the Data panel, click the format for the data item that you want to manage. A dialog box appears.
2. Select the basic format type from the Format Type list.
3. If necessary, select a more specific format from the Format list. The format names also represent sample values for the format.
4. Click OK to apply your format.

Define a Geography Data Item

About Geography Data Items

A geography data item is a category whose values are mapped to geographical locations or regions. Geography data items can be used with geo map visualizations to visualize your data on a geographic map.

For example, if your data source contains a CountryName column that identifies countries, then you might create a geography data item for CountryName by using the predefined geographic role, Countries. See “Define a Geography Data Item by Using a Predefined Role” on page 52.

You might also create a customized geography data item to identify geographic information that is specific to your organization. For example, sales regions, warehouse locations, oil platforms, and so on. See “Define a Geography with a Custom Role” on page 53.

Define a Geography Data Item by Using a Predefined Role

To define a geography data item by using a predefined geographic role:

1. In the data panel or in the Data Properties dialog box, locate a category that contains geographic information.
2. Change the data role for the category to Geography. The Geography Role dialog box appears.
3. Select the predefined geographic role for your category:
   - Countries specifies country names.
   - US States specifies the names of states and territories in the United States.
   - US States Abbreviated specifies the two-letter postal codes for states and territories in the United States.
   - US ZIP Codes specifies five-digit ZIP codes for the United States.
4. Click OK to apply your changes.
Define a Geography with a Custom Role

To define a geography data item by using a custom geographic role:

1. In the data panel or in the Data Properties dialog box, locate a category that contains geographic information.

2. Change the data role for the category to Geography. The Geography Role dialog box appears.

3. Select Custom, and then specify the following:

   **Latitude**
   specifies a measure from your current data source that contains the latitude (Y) coordinate values for the geographic role that you want to define.

   **Longitude**
   specifies a measure from your current data source that contains the longitude (X) coordinate values for the geographic role that you want to define.

   **Coordinate Space**
   specifies the coordinate space (coordinate system) that is used to project the longitude and latitude coordinates.

4. Click OK to apply your changes.
# Chapter 11
Working with Visualizations

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview of Visualizations</td>
<td>56</td>
</tr>
<tr>
<td>About Visualizations</td>
<td>56</td>
</tr>
<tr>
<td>Visualization Types</td>
<td>56</td>
</tr>
<tr>
<td>Working with Visualizations</td>
<td>60</td>
</tr>
<tr>
<td>Create a New Visualization</td>
<td>60</td>
</tr>
<tr>
<td>Manage Visualizations</td>
<td>60</td>
</tr>
<tr>
<td>Arrange the Visualizations in the Workspace</td>
<td>61</td>
</tr>
<tr>
<td>Managing Visualization Data Roles</td>
<td>63</td>
</tr>
<tr>
<td>Add a Data Item</td>
<td>63</td>
</tr>
<tr>
<td>Replace a Data Item</td>
<td>64</td>
</tr>
<tr>
<td>Remove a Data Item</td>
<td>64</td>
</tr>
<tr>
<td>Switch Data Roles</td>
<td>64</td>
</tr>
<tr>
<td>Working with Filters</td>
<td>65</td>
</tr>
<tr>
<td>Working with Automatic Charts</td>
<td>65</td>
</tr>
<tr>
<td>Working with Bar Charts</td>
<td>65</td>
</tr>
<tr>
<td>About Bar Charts</td>
<td>65</td>
</tr>
<tr>
<td>Specify Properties for a Bar Chart</td>
<td>66</td>
</tr>
<tr>
<td>Data Roles for a Bar Chart</td>
<td>67</td>
</tr>
<tr>
<td>Sort Data Values</td>
<td>67</td>
</tr>
<tr>
<td>Working with Line Charts</td>
<td>67</td>
</tr>
<tr>
<td>About Line Charts</td>
<td>67</td>
</tr>
<tr>
<td>Specify Properties for a Line Chart</td>
<td>67</td>
</tr>
<tr>
<td>Data Roles for a Line Chart</td>
<td>68</td>
</tr>
<tr>
<td>Sort Data Values</td>
<td>69</td>
</tr>
<tr>
<td>Working with Tables</td>
<td>69</td>
</tr>
<tr>
<td>About Tables</td>
<td>69</td>
</tr>
<tr>
<td>Specify Properties for a Table</td>
<td>69</td>
</tr>
<tr>
<td>Managing Columns</td>
<td>69</td>
</tr>
<tr>
<td>Working with Scatter Plots</td>
<td>70</td>
</tr>
<tr>
<td>About Scatter Plots</td>
<td>70</td>
</tr>
<tr>
<td>Specify Properties for a Scatter Plot</td>
<td>70</td>
</tr>
<tr>
<td>Data Roles for a Scatter Plot</td>
<td>70</td>
</tr>
<tr>
<td>Applying Data Analysis</td>
<td>70</td>
</tr>
<tr>
<td>Working with Bubble Plots</td>
<td>71</td>
</tr>
<tr>
<td>About Bubble Plots</td>
<td>71</td>
</tr>
<tr>
<td>Specify Properties for a Bubble Plot</td>
<td>71</td>
</tr>
<tr>
<td>Data Roles for a Bubble Plot</td>
<td>71</td>
</tr>
</tbody>
</table>
Overview of Visualizations

About Visualizations

The SAS Visual Analytics explorer interface displays data by using visualizations. A visualization is an interactive visual representation of your data. A visualization can be a table, a chart, a histogram, or a geographic map.

Visualization Types

You can assign any of the following types to your visualizations:
Autochart

Automatically selects the chart type according to the data that is assigned to the visualization. When you are first exploring a new data set, autocharts are useful to give you a quick view of the data.

For more information, see “Working with Automatic Charts” on page 65.

Table

Displays the data as a table. Tables enable you to examine the raw data for each observation in the data source. You can rearrange the data columns and apply sorting.

For more information, see “Working with Tables” on page 69.

Bar Chart

Displays the data as a bar chart. Bar charts are especially useful for comparing data according to each discrete value of a category.

You can configure a bar chart with either vertical bars or horizontal bars. You can also assign grouping to the bars and create series.

For more information, see “Working with Bar Charts” on page 65.
Line Chart
Displays the data as a line chart. A line chart is most useful for data trends over time.
You can apply grouping, and create series.
For more information, see “Working with Line Charts” on page 67.

Scatter Plot
Displays the data as a scatter plot. Scatter plots are most useful to examine the relationship between variables.
In a scatter plot, you can apply statistical analysis with correlation and regression. Scatter plots also support grouping.
When you apply more than two measures to a scatter plot, the visualization automatically displays a scatter plot matrix to compare each pairing of measures.
For more information, see “Working with Scatter Plots” on page 70.

Bubble Plot
Displays the data as a bubble plot. A bubble plot displays the relationship between three measures, where two measures are represented by the plot axes and the third measure is represented by the size of the plot markers.
You can apply grouping and create series for a bubble plot. By assigning a datetime data item to the plot, you can animate the bubbles to display changes in the data over time.
For more information, see “Working with Bubble Plots” on page 71.
Histogram
Displays the data as a histogram. A histogram displays the distribution of values for a single measure.
You can select the bar orientation, and select whether the distribution values are displayed as a percentage or as the row number of values.
For more information, see “Working with Histograms” on page 73.

Box Plot
Displays the data as a box plot. A box plot displays the distribution of values for a measure by using a box. The size and location of the box indicate the range of values that are between the 25th and 75th percentile. Additional statistical information is represented by other visual features.
You can create series, and select whether the average (mean) value and outliers are displayed for each box.
For more information, see “Working with Box Plots” on page 74.

Heat Map
Displays the data as a heat map. A heat map displays the distribution of values for two data items by using a table with colored cells. If you do not assign a measure to the color data role, then the cell colors represent the frequency of each intersection of values. If you assign a measure to the color data role, then the cell colors represent the measure value for each intersection of values.
For more information, see “Working with Heat Maps” on page 76.
Geo Map

Displays the data as a geo map. A geo map displays your data as a bubble plot that is overlaid on a geographic map. Each bubble is located at a geographic location or at the center of a geographical region.

For more information, see “Working with Geo Maps” on page 78.

Working with Visualizations

Create a New Visualization

To create a new visualization, click on the toolbar, or select View ⇒ New Visualization from the menu bar.

Manage Visualizations

Delete a Visualization

To delete a visualization, click the button on the visualization or select View ⇒ Delete Visualization to delete the selected visualization.

You can delete all of your visualizations by selecting View ⇒ Delete All Visualizations.

Duplicate a Visualization

To duplicate a visualization, select View ⇒ Duplicate Visualization from the main menu or select Options ⇒ Duplicate Visualization from the visualization toolbar.

The new visualization is named “Copy of visualization-name”. You can assign a new name on the Properties tab.

Show and Hide Visualizations

To hide a visualization, click for the visualization that you want to hide. The visualization appears on the dock panel at the bottom of the workspace.

To restore a visualization, click the name of the visualization on the dock panel.
You can also select which visualizations are visible by using the button on the dock panel. The button opens a menu that enables you to perform the following tasks:

Show all of the visualizations
Select **Show all visualizations**.

Hide all of the visualizations
Select **Minimize all visualizations**.

Show or hide individual visualizations
Select the name of the visualization that you want to show or hide. A check mark appears beside the visualizations that are currently shown.

**Maximize a Visualization**
To maximize a visualization to fill the entire workspace, click for the visualization that you want to maximize. To return the visualization to its normal size, click .

**Arrange the Visualizations in the Workspace**

**Move the Position of a Visualization**
To move a visualization, drag the title bar of the visualization to the location where you want to place the visualization.

When you drag a visualization onto another visualization, the placement of the visualization is determined by the edge that is closest to the drop point.

For example: Your workspace contains two visualizations named “A” and “B”. If you drag A to the left edge of B, then A is placed to the left of visualization B. If you drag A to the bottom edge of B, then A is placed below B.

Display 11.1 shows an example layout with four visualizations.

**Display 11.1  Example Layout with Four Visualizations**
Display 11.2 shows the effect of moving a visualization to the right edge of another visualization.

**Display 11.2  Example Layout After Moving 4 to the Right Edge of 1**

When your workspace contains visualization in multiple rows, if you drag to the bottom or top edge of a visualization then the target visualization and the moved visualization split the space that was previously occupied by the target visualization.
Display 11.3 on page 63 shows the effect of moving a visualization to the bottom edge of another visualization.

**Display 11.3 Example Layout After Moving 4 to the Bottom Edge of 1**

**Resize a Visualization**
To resize a visualization in your workspace, drag the resizing tab at the bottom edge or the right edge of the visualization that you want to resize.

---

**Managing Visualization Data Roles**

**Add a Data Item**

In order for a visualization to display data, you must assign data items to it. You can assign data items to a visualization by performing any of the following actions:

- Drag the data item onto the center of the visualization. The data item is assigned to a role automatically. If the visualization already has data items assigned to the required roles, then you can choose how to assign the new data item.
- Drag the data item onto a **Measure** or **Category** button in the visualization to assign the new data item to a specific data role.
- From the visualization toolbar, select Options ⇒ Add Category or Options ⇒ Add Measure.
- Use the Roles tab in the right pane. Either drag data item to a role, or select a data item from the drop-down list.
Each visualization requires a minimum number of each type of data item. The following table lists the requirements for each visualization.

**Table 11.1 Required Data Items for Visualizations**

<table>
<thead>
<tr>
<th>Visualization Type</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autochart</td>
<td>one data item of any type</td>
</tr>
<tr>
<td>Table</td>
<td>one measure or category</td>
</tr>
<tr>
<td>Bar Chart</td>
<td>one category or hierarchy</td>
</tr>
<tr>
<td>Line Chart</td>
<td>one measure and one category or hierarchy</td>
</tr>
<tr>
<td>Scatter Plot</td>
<td>two measures</td>
</tr>
<tr>
<td>Bubble Plot</td>
<td>three measures</td>
</tr>
<tr>
<td>Histogram</td>
<td>one measure</td>
</tr>
<tr>
<td>Box Plot</td>
<td>one measure and one category</td>
</tr>
<tr>
<td>Heat Map</td>
<td>two data items (measures, categories, or hierarchies)</td>
</tr>
<tr>
<td>Geo Map</td>
<td>one geography</td>
</tr>
</tbody>
</table>

**Replace a Data Item**

You can replace a data item by using any of the following methods:

- Drag the new data item from the Data Items pane to the data item in the visualization that you want to replace.

- Right-click the data item that you want to replace from either the visualization or the Roles tab and then select Replace item-name new-item-name.

**Remove a Data Item**

You can remove a data item by using any of the following methods:

- Drag the data item from the visualization to the Data Items pane.

- Select Options Remove item-name from the visualization toolbar.

- Right-click the data item in the visualization or in the Roles tab and then select Remove item-name.

**Switch Data Roles**

To switch the data items that are assigned to two roles, drag one item onto another either by using the buttons in the visualization or by using the fields on the Roles tab.

For example, you can switch the axes of a scatter plot by dragging the measure on the X axis to the measure on the Y axis.
Working with Filters

You can use the Filters tab to subset the data in your visualizations. See Chapter 12, “Working with Visualization Filters,” on page 81.

Working with Automatic Charts

Automatic charts (autocharts) display different types of charts automatically based on the number of category and measure data items that are assigned to the chart.

The type of chart can be any of the following:

**Table 11.2 Automatic Chart Types**

<table>
<thead>
<tr>
<th>Data Items</th>
<th>Chart Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>One measure or category</td>
<td>Bar chart</td>
</tr>
<tr>
<td>One datetime category and any number of other categories or measures</td>
<td>Line chart</td>
</tr>
<tr>
<td>One geography and zero to two measures</td>
<td>Geo map</td>
</tr>
<tr>
<td>Two measures</td>
<td>Scatter plot or heat map</td>
</tr>
<tr>
<td>Three or more measures</td>
<td>Scatter plot matrix or correlation matrix</td>
</tr>
<tr>
<td>One geography and three or more measures</td>
<td>Bar chart</td>
</tr>
<tr>
<td>One or more categories and any number of measures and geographies</td>
<td>Bar chart</td>
</tr>
</tbody>
</table>

*Note:* The Roles tab for an automatic chart always contains Categories and Measures. To set advanced data roles such as grouping and series, change the visualization type to select the specific chart type that you want. For example, if your automatic chart shows a bar chart, then change the type to **Bar Chart** to enable advanced data role settings.

Working with Bar Charts

**About Bar Charts**

A bar chart represents the values of category data by using bars. The height of each bar represents the value.
Specify Properties for a Bar Chart

On the Properties tab, you can specify the following options:

Name
specifies the name of the visualization.

Graph title
specifies the title that appears above the graph.

*Note:* The Graph title is disabled if you select Generate graph titles.

Generate graph titles
specifies that the graph title is generated automatically based on the data items in the visualization.

Show grid lines
displays grid lines for each tick on the response axis.

Bar direction
specifies whether the bars are vertical or horizontal.

Grouping style
specifies how grouped data are displayed. If you select Stacks, then the values of the grouping variable are displayed as segments of each bar. If you select Colors, then each value of the grouping variable is displayed as a separate bar.

*Note:* This option is disabled if no data item is assigned to the grouping role.

Measure layout
specifies whether the measures share a single response axis (Shared axis) or have separate response axes for each measure (Separate axes).

*Note:* The Measure layout option is disabled if your visualization contains exactly one measure.

Overview
specifies whether the chart overview is enabled.

Show data values
shows the data values as text in the visualization.

*Note:* You can always view the data values as data tips when you move the cursor over the graph.

Category label policy
specifies how the values for the category axis are displayed when there is not enough space. Select one of the following options:

Automatic
specifies that the visualization will select the best label policy according to your data and the space requirements.

Stagger
places the labels with an alternating vertical offset.

Thin
displays a subset of the labels.

Rotate
displays the labels at an angle

*Note:* The Category label policy option has no effect when you select a horizontal bar orientation.
Data Roles for a Bar Chart

The basic data roles for a bar chart are categories and measures. You can assign one category only, and the values of the category are plotted on the category axis. You can assign many measures, and the measure values are plotted on the response axis. If a bar chart contains no measures, then the frequency of the category values is plotted on the response axis.

In addition to the basic data roles, you can assign additional roles:

Grouping
- groups the data according to the values of the category data item that you assign. Depending on the value that you selected for the Grouping style property, the group values are either shown as individual bars or as segments of each bar.

Note: Grouping is not available if you assign multiple measures to the visualization.

Horizontal series
- creates a horizontal series of charts for each value of the category data item that you assign.

Vertical series
- creates a vertical series of charts for each value of the category data item that you assign.

Sort Data Values

By default, a bar chart is sorted alphabetically by the values of the category data item. To change the sorting, right-click the data item that you want to sort on, and then select Sort ➪ [sort-method].

Working with Line Charts

About Line Charts

A line chart represents the values of category data by using a line that connects the data values. If you assign multiple measures to a line plot, then you can create separate Y axes for each measure.

Specify Properties for a Line Chart

On the Properties tab, you can specify the following options:

Name
- specifies the name of the visualization.

Graph title
- specifies the title that appears above the graph.

Note: The Graph title is disabled if you select Generate graph titles.

Generate graph titles
- specifies that the graph title is generated automatically based on the data items in the visualization.
Show grid lines
displays grid lines for each tick on the response axis.

Overview
specifies whether the chart overview is enabled.

Measure layout
specifies whether the measures share a single response axis (Shared axis) or have separate response axes for each measure (Separate axes).

Note: The Measure layout option is disabled if your visualization contains exactly one measure.

Show markers
shows markers for the data points in the visualization.

Show data values
shows the data values as text in the visualization.

Note: You can always view the data values as data tips when you move the cursor over the graph.

Category label policy
specifies how the values for the category axis are displayed when there is not enough space. Select one of the following options:

Automatic
specifies that the visualization will select the best label policy according to your data and the space requirements.

Stagger
places the labels with an alternating vertical offset.

Thin
displays a subset of the labels.

Rotate
displays the labels at an angle

Data Roles for a Line Chart

The basic data roles for a line chart are categories and measures. You can assign one category only, and the values of the category are plotted on the category axis. You can assign many measures, and the measure values are plotted on the response axis.

In addition to the basic data roles, you can assign additional roles:

Grouping
groups the data according to the values of the category data item that you assign. A separate line is created for each value.

Note: Grouping is not available if you assign multiple measures to the visualization.

Horizontal series
creates a horizontal series of charts for each value of the category data item that you assign.

Vertical series
creates a vertical series of charts for each value of the category data item that you assign.
Sort Data Values

By default, a line chart is sorted alphabetically by the values of the category data item. To change the sorting, right-click the data item that you want to sort on, and then select Sort ⇒ [sort-method].

Note: Sorting is not available if a datetime data item is assigned to the Category role.

Working with Tables

About Tables

A table shows data values as text. The values for each measure or category that is assigned to the table are displayed as columns.

Note: For very large data sources, the table visualization displays only the first two billion (2,147,483,647) rows.

Note: If you sort the table, then the table displays only the first 5,000 sorted rows.

Specify Properties for a Table

On the Properties tab, you can specify the following option:

Name specifies the name of the visualization.

Managing Columns

Sort Columns
To sort the table by a column, click the column heading. An arrow appears in the column heading to indicate the sorting. If the arrow points upward, the sort is ascending. If the arrow points downward, then the sort is descending.

Note: If you sort the table, then the table displays only the first 5,000 sorted rows.

Rearrange Columns
To rearrange your columns, drag and drop the column headings.

Resize Columns
To resize your columns, click and drag the left or right edge of the column headings.
Working with Scatter Plots

About Scatter Plots

A scatter plot represents the values of measures by using markers. When you assign more than two measures, the visualization displays a scatter plot matrix. A scatter plot matrix is a series of scatter plots that displays every possible pairing of the measures that are assigned to the visualization.

If you create a scatter plot that has a very large number of points, then the plot is rendered either as a heat map (for two measures) or as a correlation matrix for three or more measures.

Specify Properties for a Scatter Plot

On the Properties tab, you can specify the following options:

Name
specifies the name of the visualization.

Graph title
specifies the title that appears above the graph.

Note: The Graph title is disabled if you select Generate graph titles.

Generate graph titles
specifies that the graph title is generated automatically based on the data items in the visualization.

Show grid lines
displays grid lines for each tick on the plot axes.

Marker size
specifies the size of each marker in pixels.

Note: Sizes below 4 pixels are not supported when your scatter plot is grouped.

Data Roles for a Scatter Plot

The basic data role for a scatter plot is the measures. You can assign any number of measures.

In addition to the measures, you can assign a Grouping variable. The grouping variable groups the data according to the values of the category data item that you assign. A separate set of scatter points is created for each value of the grouping variable.

Applying Data Analysis

About Data Analysis

For scatter plots, you can apply the following data analyses:

Correlation
identifies the degree of statistical correlation between the variables in the scatter plot.
Regression plots a model of the relationship between the variables in the scatter plot.

Both correlation and regression analysis are applied together when you enable correlation analysis.

**Enable Data Analysis**
To apply data analysis, select **Options ⇴ Show Correlation** or click **Correlation** from the visualization toolbar.

For a single scatter plot, the degree of correlation is indicated by a text label in the legend below the plot. To see additional information about the correlation results, click 📊.

For a grouped scatter plot, the degree of correlation for each plot is indicated by the color of the border around the plot. To see additional information about the correlation results for all of the plots, click 📊.

By default, a regression fit is applied to your plot when you enable correlation analysis. The regression fit appears as a red line. To see additional information about the regression results, click 📊 in the legend.

---

### Working with Bubble Plots

**About Bubble Plots**

A bubble plot represents the values of three measures by using differently sized markers (bubbles) in a scatter plot. The values of two measures are represented by the position on the graph axes, and the value of the third measure is represented by the marker size.

You can also create animated bubble plots to display changing data over time.

**Specify Properties for a Bubble Plot**

On the **Properties** tab, you can specify the following options:

**Name**
specifies the name of the visualization.

**Graph title**
specifies the title that appears above the graph.

*Note:* The **Graph title** is disabled if you select **Generate graph titles**.

**Generate graph titles**
specifies that the graph title is generated automatically based on the data items in the visualization.

**Show grid lines**
displays grid lines for each tick on the response axis.

**Data Roles for a Bubble Plot**

The basic data roles for a bubble plot are:
**X Axis**
- specifies the measure that is assigned to the X axis.

**Y Axis**
- specifies the measure that is assigned to the Y axis.

**Bubble Size**
- specifies the measure that determines the marker size.

In addition to the basic data roles, you can assign additional roles:

**Grouping**
- groups the data according to the values of the category data item that you assign. A separate set of points is created for each value.

*Note:* You cannot assign both the **Grouping** and the **Color** roles as the same time.

**Color**
- specifies a data item that determines the color of the bubbles. If you specify a category, then each value of the category is represented by a different bubble color. If you specify a measure, then the bubble color represents the measure value.

*Note:* You cannot assign both the **Grouping** and the **Color** roles as the same time.

**Horizontal series**
- creates a horizontal series of charts for each value of the category data item that you assign.

**Vertical series**
- creates a vertical series of charts for each value of the category data item that you assign.

**Animation**
- specifies a datetime data item that is used to animate the bubble plot.

*Note:* The **Animation** role is enabled only if you set assign a data item to the **Grouping** role.

---

**Using Animated Bubble Plots**

**About Animated Bubble Plots**
An animated bubble plot displays the changes in your data values over time. Each frame of the animation represents a value of the datetime data item that is assigned to the **Animation** data role.

For example, if you assign a category with the YEAR format to the **Animation** data role, then each frame of the animation displays a bubble plot of your data for a specific year.

**Create an Animated Bubble Plot**
To create an animated bubble plot:

1. Select an existing bubble plot, or create a new bubble plot.
2. Assign a data item to the **Grouping** data role.
3. Assign a data item with a datetime format to the **Animation** data role.

**Display an Animated Bubble Plot**
For an animated bubble plot, a set of animation controls appears at the bottom of the visualization.
### Table 11.3 Animation Control Tasks

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start the animation</td>
<td>Click  ▶️.</td>
</tr>
<tr>
<td>Go to the previous animation frame</td>
<td>Click  ◀️.</td>
</tr>
<tr>
<td>Go to the next animation frame</td>
<td>Click  ▶️.</td>
</tr>
<tr>
<td>Jump to a specific animation frame</td>
<td>Use the slider.</td>
</tr>
<tr>
<td>Specify whether to repeat the animation</td>
<td>Select or deselect Loop.</td>
</tr>
<tr>
<td>Select the animation speed</td>
<td>Use the Speed slider.</td>
</tr>
<tr>
<td>Track the movement of a specific bubble</td>
<td>Click the bubble that you want to track.</td>
</tr>
</tbody>
</table>

---

### Working with Histograms

#### About Histograms

A histogram represents the distribution of values for a single measure. A series of bars represents the number of observations in the measure that match a specific value or value range. The bar height can represent either the exact number of observations or the percentage of all observations for each value range.

*Note:* The minimum and maximum values on the histogram axis might not match the actual extent of your data values.

#### Specify Properties for a Histogram

On the **Properties** tab, you can specify the following options:

**Name**
- specifies the name of the visualization.

**Graph title**
- specifies the title that appears above the graph.

*Note:* The **Graph title** is disabled if you select **Generate graph titles**.

**Generate graph titles**
- specifies that the graph title is generated automatically based on the data items in the visualization.

**Show grid lines**
- displays grid lines for each tick on the response axis.

**Bar direction**
- specifies whether the bars are vertical or horizontal.
Scale
specifies the statistic that is used on the response axis. Select Count to show the data frequency, or select Percent to show a percentage.

Use default bin count
Specifies whether to use the default number of bins (value ranges) for the histogram. The default number of bins is determined by the number of data values in your histogram.

Bin count
Specifies the number of bins (value ranges) for the histogram.

Note: In order to create bins at a useful interval, the histogram might create additional bins beyond the number that you specify.

Data Roles for a Histogram
The basic data role for a histogram is a measure. You can assign only one measure to a histogram.

Working with Box Plots

About Box Plots
A box plot represents the distribution of data values by using rectangular box and lines called whiskers.

Figure 11.1 Parts of a Box Plot

Figure 11.1 on page 74 shows a diagram of a box plot. The bottom and top edges of the box indicate the interquartile range (IQR). That is, the range of values that are between the first and third quartiles (the 25th and 75th percentiles). The marker inside the box indicates the mean value. The line inside the box indicates the median value.

The whiskers (lines protruding from the box) indicate the range of values that are outside of the interquartile range but are close enough not to be considered outliers.
Outliers are data points whose distance from the interquartile range is greater than 1.5 times the size of the interquartile range.

*Note:* If there are a large number of outlier points, then the outliers are represented by a bar. The data tip for the bar displays additional information about the outlier points.

**Specify Properties for a Box Plot**

On the Properties tab, you can specify the following options:

**Name**
specifies the name of the visualization.

**Graph title**
specifies the title that appears above the graph.

*Note:* The Graph title is disabled if you select Generate graph titles.

**Generate graph titles**
specifies that the graph title is generated automatically based on the data items in the visualization.

**Show grid lines**
displays grid lines for each tick on the response axis.

**Box direction**
specifies whether the boxes are vertical or horizontal.

**Overview**
specifies whether the chart overview is enabled.

**Measure layout**
specifies whether the measures share a single response axis (Shared axis) or have separate response axes for each measure (Separate axes).

*Note:* The Measure layout option is disabled if your visualization contains exactly one measure.

**Show averages**
displays the mean value as a marker inside the box.

**Show outliers**
shows outlier points outside of the whiskers. Outliers are data points whose distance from the interquartile range is greater than 1.5 times the size of the interquartile range.

**Category label policy**
specifies how the values for the category axis are displayed when there is not enough space. Select one of the following options:

**Automatic**
specifies that the visualization will select the best label policy according to your data and the space requirements.

**Stagger**
places the labels with an alternating vertical offset.

**Thin**
displays a subset of the labels.

**Rotate**
displays the labels at an angle
Note: The **Category label policy** option has no effect when you select a horizontal box orientation.

**Data Roles for a Box Plot**

The basic data roles for a box plot are categories and measures. You can assign one category only, and the values of the category are plotted on the category axis. You can assign many measures, and the measure values are plotted on the response axis. At least one measure is required.

In addition to the basic data roles, you can assign additional roles:

- **Horizontal series**: creates a horizontal series of charts for each value of the category data item that you assign.
- **Vertical series**: creates a vertical series of charts for each value of the category data item that you assign.

---

**Working with Heat Maps**

**About Heat Maps**

A heat map displays the distribution of values for two data items by using a table with colored cells. If you do not assign a measure to the **Color** data role, then the cell colors represent the frequency of each intersection of values. If you assign a measure to the **Color** data role, then the cell colors represent the measure value for each intersection of values.

**Specify Properties for a Heat Map**

On the **Properties** tab, you can specify the following options:

- **Name**: specifies the name of the visualization.
- **Graph title**: specifies the title that appears above the graph.
  
  *Note:* The **Graph title** is disabled if you select **Generate graph titles**.

- **Generate graph titles**: specifies that the graph title is generated automatically based on the data items in the visualization.

- **Bin count**: specifies the number of value ranges that are represented as cells. **Bin count** only affects measures.

- **Show borders**: specifies that the borders between cells are visible.

- **Category label policy**: specifies how the values for the category axis are displayed when there is not enough space. Select one of the following options:
**Automatic**
 specifies that the visualization will select the best label policy according to your data and the space requirements.

**Stagger**
 places the labels with an alternating vertical offset.

**Thin**
 displays a subset of the labels.

**Rotate**
 displays the labels at an angle

*Note:* The Category label policy option has no effect if the heat map contains no categories.

---

**Data Roles for a Heat Map**

The basic data roles for a heat map are:

**X Axis**
 specifies the data item that is assigned to the X axis.

**Y Axis**
 specifies the data item that is assigned to the Y axis.

**Color**
 specifies a measure that determines the cell color. If you do not assign the Color data role, then the cell color indicates frequency.

---

**Applying Data Analysis**

**About Data Analysis**
 For heat maps, you can apply the following data analyses:

**Correlation**
 identifies the degree of statistical correlation between the variables in the heat map.

**Regression**
 plots a model of the relationship between the variables in the heat map.

Both correlation and regression analysis are applied together when you enable correlation analysis.

**Enable Data Analysis**
 To apply data analysis, select Options ⇒ Show Correlation or click Correlation from the visualization toolbar.

The degree of correlation is indicated by a text label in the legend below the heat map. To see additional information about the correlation results, click 🔎.

By default, a regression fit is applied to your plot when you enable correlation analysis. The regression fit appears as a red line. To see additional information about the regression results, click 🔎 in the legend.
Working with Geo Maps

About Geo Maps

A geo map displays your data as a bubble plot that is overlaid on a geographic map. Each bubble is located either at the center of geographic region or at the coordinates of a location.

In order to display a geo map, you must define one or more of your categories as a geography data item. For more information, see “Define a Geography Data Item” on page 52.

Specify Properties for a Geo Map

On the Properties tab, you can specify the following options:

Name
specifies the name of the visualization.

Graph title
specifies the title that appears above the graph.

Note: The Graph title is disabled if you select Generate graph titles.

Generate graph titles
specifies that the graph title is generated automatically based on the data items in the visualization.

Show map controller
specifies whether the map zoom and pan controls are visible.

Note: This option does not affect your ability to zoom and pan by using the mouse or keyboard.

Data Roles for a Geo Map

The basic data roles for a bubble plot are:

Geographic Role
specifies the geography data item that identifies geographic regions for your map.

Bubble Size
specifies the measure that determines the marker size.

In addition to the basic data roles, you can assign additional roles:

Color
specifies a measure that determines the bubble color.

Zoom a Geo Map

You can zoom the map by using any of the following controls:

• scroll the mouse scroll wheel
• click the zoom bar to select your zoom level
• press the + and – keys
• double-click and double right-click

Pan (Scroll) a Geo Map

You can pan (scroll) the map by using any of the following controls:
• click and drag the map
• click the arrows on the pan control
• use the keyboard arrow keys

Working with Correlation Matrices

About Correlation Matrices

A correlation matrix displays the degree of correlation between multiple intersections of measures as a matrix of rectangular cells. Each cell in the matrix represents the intersection of two measures, and the color of the cell indicates the degree of correlation between those two measures.

You cannot create a correlation matrix directly. Instead, a correlation matrix is created when you assign high-cardinality data to a scatter plot matrix.

Note: If you reduce your data by using filters, the visualization type might change to a scatter plot matrix.

Specify Properties for a Correlation Matrix

On the Properties tab, you can specify the following options:

Name
specifies the name of the visualization.

Graph title
specifies the title that appears above the graph.

Note: The Graph title is disabled if you select Generate graph titles.

Generate graph titles
specifies that the graph title is generated automatically based on the data items in the visualization.

Show grid lines
displays grid lines for each tick on the plot axes.

Marker size
specifies the size of each marker.
**Data Roles for a Correlation Matrix**

The basic data role for a correlation matrix is the measures. You can assign any number of measures.

If you reduce the number of measures to two, then the visualization type changes to a heat map.
Chapter 12
Working with Visualization Filters

About Filters

For all visualization types, you can subset your data by using the Filters tab in the right panel. You can base your filters on any data item, regardless of whether the data item is assigned to the current visualization.

Your filters can be either local filters that apply only to the current visualization, or global filters that apply to all of the visualizations in the current visual exploration. For more information, see “Set the Scope of a Filter (Global or Local)” on page 85.

You can perform the following tasks to manage your filters:

• “Create a Filter”
• “Edit a Filter by Using Visual Filter Controls”
• “Edit a Filter by Using the Edit Filter Dialog Box”
• “Set the Scope of a Filter (Global or Local)”
• “Remove a Filter”
• “Reset a Filter”
Create a Filter

To create a filter:

1. Select the data item that you want to use as the base of the filter. You can select any data item, regardless of whether it is assigned to the current visualization.

2. For a local filter, either right-click the data item and select Add as local filter, or drag the data item onto the Local Filters area of the Filters tab.

   For a global filter that is applied to all of your visualizations, either right-click the data item and select Add as global filter or drag the data item to the Global Filters area of the Filters tab.

3. Set the parameters for your filter. You can either create a basic filter by using visual controls or create an advanced filter by using the Edit Filter dialog box.

   Note: By default, your filter changes are applied automatically to the active visualization. To apply multiple changes together, deselect Auto and then click Apply when you are ready to apply your filter changes.

Edit a Filter by Using Visual Filter Controls

About Visual Filter Controls

Visual filter controls are accessible directly from the Filters tab. The visual filter controls are different depending on the model type of the filter data item.

Filtering Discrete Data

Display 12.1 A Visual Filter for Discrete Data

Note: If your data contains a large number of discrete values, then visual filtering is not available. Use the Edit Filter dialog box instead.

For data items that use the discrete data model, the filter displays all of the distinct values for the data item. To the right of each value, a bar indicates the frequency of each value.
Use the check boxes next to each value to select the values for the filter. You can search for a value by clicking 📚. The search locates values that begin with your search string.

Click **Select All** to select or deselect all of the values. To invert your selection, open the ⬇️ drop-down list and then select **Invert Selection**.

By default, your filter changes are applied automatically to the active visualization. To apply multiple changes together, deselect **Auto** and then click **Apply** when you are ready to apply your filter changes.

**Filtering Continuous Data**

**Display 12.2  A Visual Filter for Continuous Data**

![Display 12.2  A Visual Filter for Continuous Data](image)

For measures that use the continuous data model, the filter shows the range of data values as a histogram. Sliders at each side of the histogram enable you to select the upper and lower limits of the data range that is selected by the filter.

You can also enter the limit values explicitly:

- For numeric data, click a limit values and then enter the value in the text field.
- For datetime data, click 🕒 and then select a date or time.

To exclude observations where the filter measure has a missing value, deselect **Include missing values**.

By default, your filter changes are applied automatically to the active visualization. To apply multiple changes together, deselect **Auto** and then click **Apply** when you are ready to apply your filter changes.

---

**Edit a Filter by Using the Edit Filter Dialog Box**

To edit a filter by using the Edit Filter dialog box:

1. On the **Filters** tab, open the ⬇️ drop-down list for the filter that you want to edit and then select **Edit Filter**. The Edit Filter dialog box appears.

   Note: The **Edit Filter** dialog box is not available for datetime data. See “Edit a Filter by Using Visual Filter Controls” on page 82 for details about using visual filter controls for a datetime data item.

2. Select the operator for the filter from the **Choose operator** drop-down list.

**Table 12.1  Operators for Character Data**

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is</td>
<td>Specifies that a matching value must match one of the filter values exactly.</td>
</tr>
</tbody>
</table>
Is not
Specifies that a matching value must not match any of the filter values exactly.

Begins with
Specifies that a matching value must contain the filter value at the start of the value.

Ends with
Specifies that a matching value must contain the filter value at the end of the value.

Contains
Specifies that a matching value must contain the filter value.

Does not contain
Specifies that a matching value must not contain the filter value.

Is missing
Specifies that a missing value matches the filter.

Is not missing
Specifies that any nonmissing value matches the filter.

Table 12.2 Operators for Numeric Data

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is</td>
<td>Specifies that a matching value must match the filter value exactly.</td>
</tr>
<tr>
<td>Is not</td>
<td>Specifies that a matching value must not match the filter value exactly.</td>
</tr>
<tr>
<td>Between</td>
<td>Specifies that a matching value must be greater than or equal to the first filter value and less than or equal to the second filter value.</td>
</tr>
<tr>
<td>Less than</td>
<td>Specifies that a matching value must be less than the filter value.</td>
</tr>
<tr>
<td>Less than or equal</td>
<td>Specifies that a matching value must be less than or equal to the filter value.</td>
</tr>
<tr>
<td>Greater than</td>
<td>Specifies that a matching value must be greater than the filter value.</td>
</tr>
<tr>
<td>Greater than or equal</td>
<td>Specifies that a matching value must be greater than or equal to the filter value.</td>
</tr>
<tr>
<td>Is missing</td>
<td>Specifies that a missing value matches the filter.</td>
</tr>
<tr>
<td>Is not missing</td>
<td>Specifies that any nonmissing value matches the filter.</td>
</tr>
</tbody>
</table>

3. Depending on the operator that you specified, select or specify a filter value:

**Is, Is not**
For character data, select one or more filter values from a drop-down list. For numeric data, enter the filter value in the text field.

*Note:* For character data, if the number of distinct values is very large then the enter a value in the text field.

**Is missing, Is not missing**
No filter value is needed.
Between
   Enter the lower value in the first text field and the higher value in the second text field.

   For all other operators, enter the filter value in the text field.

4. Click **Apply** to create the filter condition.

5. If you create multiple filter conditions, select whether a matching value must meet all of the conditions (**All**) or if a matching value can meet only some of the conditions (**Any**.)

6. (Optional) To delete a filter condition, click the icon next to the condition that you want to delete.

7. (Optional) To preview your filter results, click **Preview Results**.

8. For discrete data, select whether to display the visual filter controls on the **Filters** tab for this filter (**Show results in a list of check boxes**) or to show a text description of the filter syntax (**Apply results as a dynamic rule**.)

   **Note:** If your data contains a large number of discrete values, then visual filtering is not available.

9. When you are finished editing your filter, click **OK** to apply the filter.

---

**Set the Scope of a Filter (Global or Local)**

Your filters can be either local (specific to the current visualization) or global (applied to all visualizations in the visual exploration.)

To set the scope of a filter, open the drop-down list and then select **Global Filter** or **Local Filter**.

**Note:** If you change a global filter’s scope to local, then a local filter is created for all of your visualizations.

**Note:** A global filter replaces any local filters that use the same data item. The local filters are replaced in all of your visualizations.

---

**Remove a Filter**

To remove a filter, click **X** on the filter on the **Filters** tab.

**Note:** If you remove a global filter, then the filter is removed from all of your visualizations.

---

**Reset a Filter**

To restore a filter to its initial state, open the drop-down list for the filter on the **Filters** tab and then select **Reset Filter**.
Chapter 13
Exporting Data

Overview of Exporting Data

You can export your data and your visualizations from the SAS Visual Analytics explorer interface by using the following tasks:

- “Export a Visual Exploration as a Report”
- “Export a Visual Exploration as a PDF”
- “Save a Visualization as an Image File”
- “E-mail a Visual Exploration as a Link”

Export a Visual Exploration as a Report

You can export your visualization as a report, which can be refined in the designer interface or viewed directly on a mobile device or in the Web viewer.

To export your current visual exploration as a report:

1. Select File → Export → Exploration as report.
2. In the Export as Report dialog box, select the visualizations that you want to include in the report.
   
   Note: Visualizations that do not contain data are not available to include in your report.

   Click OK.
3. Select the location where you want to save the report and then click Save.
Export a Visual Exploration as a PDF

To export your current visual exploration as a PDF:

1. Select File → Export → Exploration as PDF.

2. In the Export as PDF wizard, enter a Title and a Description for the PDF document. Then, select the following options:

   - **Page numbers**
     specifies the PDF document contains page numbers.

   - **Summary data**
     specifies whether the PDF document contains summary data tables for each visualization.

   - **Filter descriptions**
     specifies whether each visualization includes a description of its active filters.

   Click Next.

3. Select the visualizations that you want to include in the PDF document.

   **Note:** Visualizations that do not contain data are not available to include in your PDF output.

   Click Next.

4. Click Finish to open a download dialog box for your browser.

5. Select the location where you want to save the PDF document.

   **Note:** If the legend for a visualization is too large, then it will not be included in the PDF document.

---

Save a Visualization as an Image File

To save a visualization as an image file:

1. Select the visualization that you want to save as an image.

2. If your visualization contains hierarchies, drill to the hierarchy levels that you want to show in the image.

3. Select Options → Export Image from the visualization toolbar.

4. If necessary, scroll the visualization to show the data items that you want to include in the image. If your visualization contains filters, legends, or hierarchy breadcrumbs, select whether to include these elements.

5. Click Save to open a download dialog box for your browser.

6. Select the location where you want to save the image.
E-mail a Visual Exploration as a Link

To e-mail a link to your visual exploration:

1. Select File ➪ Email. The Email dialog box appears.
2. Enter the following information:

   **To**
   
   specifies the e-mail destination. To enter multiple addresses, separate the addresses by using commas, semicolons, or spaces.

   **From**
   
   specifies the e-mail address that is shown as the sender of the e-mail. This e-mail address is also used for notifications if the e-mail cannot be delivered to the addresses in the **To** field.

   **Subject**
   
   specifies the subject line of the e-mail.

   **Message**
   
   specifies text for the e-mail message body. This field is optional.

   *Note:* The message body of the e-mail automatically includes a link to the current visual exploration. If you specify text for the **Message** field, then your text appears before the link in the e-mail.

3. Click **OK** to send the e-mail.
Chapter 14
Managing Hierarchies

Overview of Hierarchies in the SAS Visual Analytics Explorer Interface

What Is a Hierarchy? ................................................................. 91
Hierarchy Management Tasks ............................................. 91

Create a New Hierarchy ....................................................... 92
Edit a Hierarchy ................................................................. 92
Delete a Hierarchy .............................................................. 92

Overview of Hierarchies in the SAS Visual Analytics Explorer Interface

What Is a Hierarchy?
A hierarchy is an arrangement of category columns that is based on parent-child relationships. The levels of a hierarchy are arranged with more general information at the top and more specific information at the bottom.

For example, you might create a hierarchy of date-time columns with Year as the top level, Month as the next level, and Day as the bottom level.

Creating hierarchies enables you to add drill-down functionality to your visualizations. For example, if you use a date-time hierarchy, you can drill down to the data for a specific year. Then, drill down to the data for a specific month.

When you drill down a hierarchy, a set of breadcrumb links at the top of your visualization enables you to drill back up the hierarchy.

Hierarchy Management Tasks
In the SAS Visual Analytics explorer interface, you can perform the following tasks to manage hierarchies:

• “Create a New Hierarchy”
• “Edit a Hierarchy”
• “Delete a Hierarchy”
Create a New Hierarchy

To create a new hierarchy:
2. Enter a Name for the hierarchy.
3. Select the categories that you want to include in the hierarchy, and then click ➔ to add them to the hierarchy.
   Note: You can also drag and drop categories.
   To change the order of the categories in your hierarchy, select the category that you want to move. Then, click ↑ to move the category up, or click ↓ to move the category down.
   To remove a category from the hierarchy, select the hierarchy that you want to remove. Then, click ⬅.
4. Click OK to finish creating the hierarchy.

Edit a Hierarchy

To edit an existing hierarchy:
1. From the Data Items pane, right-click the hierarchy that you want to edit, and then select Edit. The Edit Hierarchy dialog box appears.
2. Enter a Name for the hierarchy.
3. To add a category to the hierarchy, select the category and then click ➔. 
   Note: You can also drag and drop categories.
   To change the order of the categories in your hierarchy, select the category that you want to move. Then, click ↑ to move the category up or ↓ to move the category down.
   To remove a category from the hierarchy, select the hierarchy that you want to remove. Then, click ⬅.
4. Click OK to save the changes to your hierarchy.

Delete a Hierarchy

To delete a hierarchy:

From the Data items pane, right-click the hierarchy that you want to delete and then select Delete. Click Yes to confirm that you want to delete the hierarchy.
Chapter 15
Managing Visual Explorations

What Is a Visual Exploration?

A visual exploration is a metadata object that contains all of the visualizations and data settings from a SAS Visual Analytics explorer interface session. You can use visual explorations to save your session for later and to share it with others.

Create a New Visual Exploration

To create a new visual exploration, select File ⇒ New Exploration from the menu bar. The Select Data wizard appears. See Chapter 9, “Opening a Data Source,” on page 45 for more information about opening a data source for a new visual exploration.

Saving Your Visual Exploration

To save your current visual exploration, select File ⇒ Save as and then select a location and a name.

Deleting Visual Explorations

To delete a visual exploration, select File ⇒ Manage explorations to open the Manage explorations dialog box. Locate and select the visual exploration that you want to delete, and then click ✗.
Overview of Analyzing Your Data

SAS Visual Analytics enables you to perform two basic types of data analysis:

Correlation
identifies the degree of statistical correlation between measures.

Regression
plots a model of the relationship between measures.

Both correlation and regression analysis are applied together when you enable correlation analysis.

For visualizations that contain a single plot, the correlation is identified by a text label in the legend and the regression is identified by a red line.
Display 16.1 displays a scatter plot with analysis enabled.

**Display 16.1  A Basic Scatter Plot with Analysis Enabled**

For visualizations that contain a plot matrix, the correlation for plot is identified by a colored border around the plot. The regression is identified by a red line in each plot.

Display 16.2 displays a scatter plot matrix with analysis enabled.

**Display 16.2  A Scatter Plot Matrix with Analysis Enabled**
Add Analysis to an Existing Visualization

To add data analysis to a scatter plot or heat map, click Correlation on the visualization toolbar or select Options → Show Correlation from the visualization toolbar.

Correlate Multiple Measures as a New Visualization

To create a new visualization that correlates multiple measures together, select Analysis → Correlate Measures. The Correlate Measures dialog box appears. Select the measures that you want to include in the new visualization, and then click OK to create the new visualization.

If you selected exactly two measures, then the new visualization is either a scatter plot or a heat map (for high-cardinality data). Correlation and regression analyses are automatically applied to the visualization.

If you selected three or more measures, then the new visualization is either a scatter plot matrix or a correlation matrix (for high-cardinality data). Correlation and regression analyses are automatically applied to the visualization.
Chapter 17
Specifying Your Preferences

Specifying Global Preferences

See “Specifying Global Preferences” on page 12 for details about global preferences for SAS Visual Analytics.

Specify Preferences That Are Specific to the Explorer Interface

To specify preferences that are specific to the SAS Visual Analytics explorer interface:

1. Select File ➤ Preferences to open the Preferences dialog box.
3. Select a Graph skin to change the visual effects that are applied to your graphs. For example, many of the Graph skin settings apply lighting effects to the features of your graph to create a 3-D appearance.
4. Select Visualization data threshold to specify the amount of data values that your visualizations can process. The precise amount of data that is supported varies depending on the visualization type.
   
   Note: A large value for Visualization data threshold might degrade your application performance or lead to time-out errors.
5. To return to the default settings, select Reset to defaults.
6. Click OK to apply your changes.
Part 4
Designing Reports

Chapter 18
Overview of the Designer Interface ........................................ 103

Chapter 19
Opening Reports ................................................................. 109

Chapter 20
Creating and Saving Reports .................................................. 111

Chapter 21
Selecting Data ................................................................. 115

Chapter 22
Displaying Results in a Table, Graph, or Gauge ......................... 121

Chapter 23
Working with Interactions .................................................... 139

Chapter 24
Maintaining Multi-Section Reports ........................................ 145
Chapter 18
Overview of the Designer Interface

About the SAS Visual Analytics Designer Interface

The designer interface enables users to easily create reports or dashboards that can be saved and viewed on either a mobile device or in a Web viewer that is provided with SAS Visual Analytics. The designer interface is part of the SAS Visual Analytics product that enables someone with either the Analysis or Administration role to view, interact with, and create reports. Simply open an existing report and interact with the information based on your current needs. Report authors can easily point and click to query central sources of data. You can drag-and-drop tables, graphs, and gauges to create a well-designed report. All of this is accomplished by using the designer interface, which runs in a Web browser. You do not need to understand a programming language.

Report authors can easily create basic queries and reports based on data sources that have been provided by an administrator. They can also update reports that were created from visual explorations. You can also create reports by importing objects or visual explorations from other reports. Report authors can also define interactions (either filtering or brushing) for report objects and include SAS analytical results into a single report.

Your First Look at the Designer Interface

When you are designing reports in SAS Visual Analytics, you see the designer interface. Here are the features of the designer interface:
1 The application bar enables you to return to the SAS Visual Analytics home page and access your recent created or viewed reports. You can also access recently used visual explorations in your recent history. When you select a visual exploration, the application takes you to the explorer interface.

2 The menu bar provides menu items that apply to the entire report or to the currently displayed report section. Actions include creating a new report, adding a new section, inserting new report objects, and adding interactions. You can also log off from SAS Visual Analytics.

3 The toolbar contains icons that enable you to manage your reports. You can click [ ] to hide the left and right panels. Or, you can click [ ] to display the side panels.

4 The Objects and Imports tabs are in the left panel. The Objects tab provides a list of the tables, graphs, and gauges that can be used in a report or dashboard. The Imports tab provides a list of reports and report objects that have been created in the designer interface or exported from the explorer interface. This enables you to create reports from multiple sources and create full-featured reports. You can choose objects or sections in these reports to include in either a new or an existing report.

5 The Data and Display Rules tabs are in the left panel. The Data tab enables you to select a data source and data items for your report. The Display Rules tab enables you to create a new display rule, which is used by a gauge to designate intervals and colors for ranges. You can also edit or delete an exiting display rule for report objects, like gauges.

6 The data item table provides information about a selected data item, including the name, role, format, and aggregation. These data item properties can also be modified, which impacts all the report objects that use the data item.
The canvas is the workspace for building a report. Each report section has its own canvas, which can contain a single or multiple report objects. A report can have multiple sections, which can be accessed by using the tabs at the top of the canvas. There is also an area at the top of the canvas where you can drop categories to create section filters.

The right panel enables you to work with details about the report and report objects. The Properties tab lists the properties for the currently selected report object. The object’s name, title, and description are listed. Information that is specific to the report object type, such as the axes and legend are also included. If a report object is not selected, then the properties are for the section and the report. The Styles tab enables you to specify the data styling, frame styling, text styling, and data colors for a selected report object. The Display Rule tab enables you to populate or add intervals for report objects, like gauges. You can also edit or delete a display rule for a report object.

---

Open Dialog Box

About the Open Dialog Box

Click on the menu bar or select File ⇒ Open to display the Open dialog box.

The Open dialog box enables you to search for and open saved reports. However, the Open dialog box also enables you to create new folders and perform many other tasks on selected reports and folders.

Display 18.1  Open Dialog Box

Working with Folders in the Open Dialog Box

You can work with folders in the Open dialog box. The icons for folders are located to the right of the drop-down list of folder names, as shown in Display 18.1 on page 105.
<table>
<thead>
<tr>
<th>Icon</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>←</td>
<td>Navigates back one level.</td>
</tr>
<tr>
<td>↑</td>
<td>Moves up one level.</td>
</tr>
<tr>
<td>⚛</td>
<td>Refreshes the items in the current location.</td>
</tr>
<tr>
<td>✗</td>
<td>Deletes the selected item.</td>
</tr>
<tr>
<td>📄</td>
<td>Creates a new folder.</td>
</tr>
<tr>
<td>☑</td>
<td>Specifies either details or a list.</td>
</tr>
<tr>
<td>🔍</td>
<td>Opens the Search dialog box.</td>
</tr>
</tbody>
</table>

You can also create a new folder when you copy a report, move a report, or save a report.

---

**Search Dialog Box**

The Search dialog box in the designer interface enables you to navigate to find the report or exploration that you need. For example, you might need to navigate through multiple folders to find a report. In the Open dialog box, click 🔍 to open the Search dialog box.

**Display 18.2  Search Dialog Box**

To search for files:

1. In the **Name** field, type text for which you want to search.
2. (Optional) You can select **Include description and keywords** for your search.
3. Select a **Location**. If you want to search multiple folders, make sure that **Search all subfolders** check box is selected.
4. (Optional) To limit your search by time, select a **Date range**. You can also specify either **Date created** or **Date modified**.

5. Click **Search**.

*Note:* After a search, the list of report or exploration files also includes the path information for each located report.
Chapter 19
Opening Reports

Opening Reports Created in the Designer Interface

Opening Reports Created in the Designer Interface

Reports in the designer interface are saved when you use either the Save As or the Save As dialog box. A saved report contains at least one section. Typically, that section uses a query method of data items from a data source. The section has at least one report object (a table, a graph, or a gauge) to display the results of the query.

To open a saved report:

• On the SAS Visual Analytics home page, select a report. In the details view, click Edit. Or you can double-click the report to open it in the designer interface.
• In the designer interface:
  • Select File ⇴ Recent and then select a report name.
  • Click beside the recent content drop-down list, and then select a report name.
  • Select File ⇴ Open to display the Open dialog box.
  • Click to navigate to a report and then select it.

An Example Report

The following display shows a report in the designer interface with a pie chart, a bubble plot, a scatter plot, a bar chart, a dual axis bar chart, and a targeted bar chart.
Display 19.1  An Example Report with Six Report Objects
Creating a New Report

To create a new report in the SAS Visual Analytics designer interface:

1. Choose your data source and data items. For information about selecting data, see “Selecting Data” on page 115.
2. Select the report object (or objects) that you want to use in the report. For information about selecting report objects, see “Displaying Results in a Table, Graph, or Gauge” on page 121.
3. Drag and drop the report object (or objects) on the canvas.
4. Update the properties for the report and the report objects. For more information, see “Specify Table Styles” on page 124, “Specify Graph Styles” on page 132, or “Specify General Gauge Properties” on page 135.
5. Update the styles for the report objects. For more information, see “Specify General Table Properties” on page 123, “Specify General Graph Properties” on page 131, or “Specify Gauge Styles” on page 136.
6. If there is a gauge in the report, create or modify the display rule. For more information, see “Specify a Gauge Display Rule” on page 136.
7. (Optional) Add interactions between the report objects. For more information, see “Overview of Interactions” on page 139.
8. (Optional) Add a new section (or sections) to the report. For more information, see “Overview of Report Sections” on page 145.
9. Save your report.

You can also create a new report based on an existing report or on report objects from a report that you have imported.
Basing a New Report on Report Objects Imported from One or More Existing Reports

If there is an existing saved report that closely matches the report that you want to create, then you can open the report that contains report objects that you want to reuse. The report objects can be from either a report that has been saved in the designer interface or from a report that has been exported from the explorer interface. You can save the report under a new name or you can edit the report to make some customizations and then save it.

To base a new report on report objects imported from one or more existing reports:

1. Open or import the existing report by doing one of the following:
   - On the SAS Visual Analytics home page, double-click the report that you want to open.
   - In the designer interface:
     - Select File ⇒ Recent and then select the report name.
     - Click beside the recent content drop-down list, and then select a report name.
     - Select File ⇒ Open to display the Open dialog box.
     - Click to navigate to a report and then select it.
     - Click Imports in the left panel. Select a report name or click Import another report to display the Open dialog box, where you can select a report. In the tree view on the left, a list of sections and report objects appears. Drag the single report object, multiple report objects, or entire section that you want to include in the new report and drop it onto the canvas.
2. (Optional) Modify the report objects, properties, and styles. If you have a gauge (or gauges) in your report, then you can also update the display rules.

3. Select **File** ⇒ **Save As** and complete the Save As dialog box, giving the report a new name.

---

**Saving a Report**

To save a report:

1. Select **File** ⇒ **Save** or click . If you are saving a new report, then the Save As dialog box is displayed.
2. For new reports, type a **Name**. Names cannot use these characters: / \.

If you are saving an existing report, then the name of that report is listed here. You can either leave the name as it is and overwrite the existing report, or you can change the name to create a new report.

3. Click **Save**.
Overview of Queries Based on Data Items

Data sources are created by a data source administrator in a centrally managed location so that you can easily define a report. Authorized users who have an Administrative role can access tables directly. All data sources contain data items, which can refer to calculations or physical data (tables). Reports can include query results from more than one data source.

Each data source includes one or more data items. For example, a data source named Order Information might include standard data items such as Order ID, Product ID, Unit Cost, Order Date, and Order Amount. You decide which data items to use. You can select all of the data items in the data source or a subset of data items.

Using Data Items in a Query

About Data Items

Each data source includes one or more standard data items. You decide which data items to use to define a query for a report section. You can use all the data items in the data source or a subset of data items. Each data item is classified as either a category or a measure.

Category

A data item whose distinct values are used to group and aggregate measures. There are four types of categories: alphanumeric, date, timestamp, and time. Alphanumeric categories can be made up of all letters, all digits, or a combination of the two.

Categories that have values that are all digits might be physically stored as character...
or numeric data. The data type affects how values are handled in relation to some functionality, such as filtering, sorting, and formatting.

Examples of alphanumeric categories include data items such as Product ID, Country, Employee Number, and Employee Name.

Date and Time
A data item whose distinct values are used to group and aggregate measures. There are three types of date categories: date, timestamp, and time.

Examples of date, timestamp, and time categories are Order Year, Date of Sale, and Delivery Time.

Measure
A data item whose values can be used in computations. Usually, these values are numeric. Examples of measures include Sales Revenue, Units Sold, and Salary.

Every measure has a default aggregation method, which is specified by the data source that contains it. In some cases, you can change the method. However, if you use a measure as part of a custom data item, then the measure is always calculated by using the default aggregation method.

Note: Report objects that are imported from the explorer interface use embedded data. Therefore, you have a very limited ability to make changes to these data items in the designer interface.

Select Data Items
To select data items to use in the query for the current report section:

1. On the Data tab in the left panel, click the down arrow to display a list of available data sources. Select a data source and the Data tab is populated with a list of all of the data items that are in the data source.

   If the data source that you want is not in the list, select Add another data source, which displays the Add Data Source dialog box. Select the data source that you want, and then click Add. The Data tab is populated with a list of all of the data items that are in the data source.

   If you do not want to use the data source that you originally selected, click Remove data source. A message box asks you to confirm that you want to remove the data source. Click Yes.

2. (Optional) To see more information about a particular data item, select it in the list. The Name, Role, Format, and Aggregation are displayed in the table below the list of data items. Here is an example of the details for a data item called Engine Size:
Modifying Data Item Properties

Rename a Data Item
To rename a data item:

1. Select a data item on the Data tab.
2. In the table, select the existing name for the data item and then enter a new name. Your change is saved automatically.

Modify a Data Item’s Role
To modify a data item’s role:

1. Select a data item on the Data tab.
2. In the table, select the existing role name for the data item. In the drop-down menu, select either Measure or Category. Select one and your change is saved automatically.

Modify the Format of a Measure Data Item
To change the format of a measure data item:

1. Select a measure data item in the Data tab.
2. In the table, select the existing format. A list is displayed with the Format type, Width, and Decimals. Make your selections. A sample of your selection (or selections) is displayed under the list. Here is an example of the list:
3. Click OK to save your changes.

**Modify How a Measure Is Aggregated**
To change the aggregation method of a measure in a data source:

1. Select a measure data item on the Data tab.

2. In the table, select the existing aggregation. A drop-down list is displayed with aggregations. **Sum**, **Average**, **Minimum**, and **Maximum** are examples of aggregations. Select one, and your change is saved automatically.

   *Note:* You need to understand your data, because some aggregation methods are not always appropriate. For example, an average of an average is not valid.

---

**Removing Data Assignments from Report Objects**

To remove data items from their assigned roles in a specific report object:

1. Right-click the report object in the canvas. A menu is displayed. Here is an example of a pie chart with the object menu:

   **Display 21.3  Report Object Menu**
2. Select **Remove All Data Assignments**. All data items are removed from the assigned roles and the report object turns gray. The status icon appears in the lower right corner to let you know that the required data roles are not assigned. Here is an example of what a pie chart looks like after all the data items have been removed from their assigned roles:

*Display 21.4  A Pie Chart with Missing Data Assignments*
Chapter 22
Displaying Results in a Table, Graph, or Gauge

Using Tables, Graphs, and Gauges ........................................ 121

Using Tables to Display Results ........................................ 122
  Overview of the Table Types ...................................... 122
  Insert a Table into a Report ...................................... 123
  Specify General Table Properties .............................. 123
  Specify Table Styles ............................................... 124

Using Graphs to Display Results .................................... 124
  Overview of the Graph Types .................................. 124
  Insert a Graph into a Report .................................. 131
  Specify General Graph Properties .......................... 131
  Specify Graph Styles ........................................... 132

Using Gauges to Display Results .................................... 133
  Overview of the Gauge Types .................................. 133
  Inserting a Gauge into a Report ............................... 135
  Specify General Gauge Properties .......................... 135
  Specify Gauge Styles ........................................... 136
  Specify a Gauge Display Rule ................................. 136

Using Tables, Graphs, and Gauges

After selecting your data source and data items, add one or more report objects to display the results. SAS Visual Analytics designer interface provides tables, graphs, and gauges for all of your reports. You can select these table types for reports:
  • list tables
  • crosstabs

Multiple graph types are available in the designer interface:
  • bar charts
  • targeted bar charts
  • waterfall charts
  • line charts
  • pie charts
  • scatter plots
Using Tables to Display Results

Overview of the Table Types

**About List Tables**

A *list table* is a two-dimensional representation of data in which the data values are arranged in unlabeled rows and labeled columns. List tables are applicable when you select data items from a data source.

**Display 22.1  A List Table**

<table>
<thead>
<tr>
<th>Make</th>
<th>GDP</th>
<th>Income</th>
<th>GDP (G)</th>
<th>Income (G)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acme</td>
<td>$429,839</td>
<td>$38,598</td>
<td>19,428,57</td>
<td>26,142,95</td>
</tr>
<tr>
<td>Audi</td>
<td>$42,329</td>
<td>$38,500</td>
<td>19,478,46</td>
<td>25,668,47</td>
</tr>
<tr>
<td>BMW</td>
<td>$42,985</td>
<td>$38,601</td>
<td>19,7</td>
<td>27</td>
</tr>
<tr>
<td>Benz</td>
<td>$20,334</td>
<td>$77,000</td>
<td>18,998,03</td>
<td>22,777,02</td>
</tr>
<tr>
<td>Cadillac</td>
<td>$40,474</td>
<td>$98,437</td>
<td>15,5</td>
<td>23</td>
</tr>
<tr>
<td>Celber</td>
<td>$26,597</td>
<td>$44,901</td>
<td>19,569,67</td>
<td>26,651,05</td>
</tr>
<tr>
<td>Chrysler</td>
<td>$27,202</td>
<td>$55,270</td>
<td>19,666,92</td>
<td>27,333,00</td>
</tr>
<tr>
<td>Dodge</td>
<td>$26,254</td>
<td>$42,160</td>
<td>18,564,62</td>
<td>26,232,37</td>
</tr>
<tr>
<td>Ford</td>
<td>$46,175</td>
<td>$33,403</td>
<td>18,218,37</td>
<td>25,730,53</td>
</tr>
<tr>
<td>GMC</td>
<td>$39,015</td>
<td>$30,989</td>
<td>15,375</td>
<td>19,605</td>
</tr>
<tr>
<td>Honda</td>
<td>$21,435</td>
<td>$66,513</td>
<td>27,823,53</td>
<td>34</td>
</tr>
<tr>
<td>Hummer</td>
<td>$48,995</td>
<td>$45,815</td>
<td>10</td>
<td>12</td>
</tr>
<tr>
<td>Hyundai</td>
<td>$47,477</td>
<td>$61,036</td>
<td>23</td>
<td>25,918,67</td>
</tr>
</tbody>
</table>

**About Crosstabs**

A *crosstab* (also known as a crosstabulation table) shows an aggregate metric for the intersections of two or more categories. In a crosstab, categories are typically displayed on both the columns and the rows, and each cell value represents the aggregated measure from the intersection of the categories on the specific row and column. This type of table
uses less space than a list table and is easier to read because data is grouped both horizontally and vertically.

Display 22.2  A Crosstab

<table>
<thead>
<tr>
<th>Make</th>
<th>MSRP</th>
<th>Invoice</th>
<th>MPG (STD)</th>
<th>MPG (Highway)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audi</td>
<td>$40,919</td>
<td>$38,591</td>
<td>19.2</td>
<td>26.1</td>
</tr>
<tr>
<td>Audi</td>
<td>$43,308</td>
<td>$39,330</td>
<td>18.47</td>
<td>25.79</td>
</tr>
<tr>
<td>BMW</td>
<td>$43,285</td>
<td>$39,621</td>
<td>18.7</td>
<td>27</td>
</tr>
<tr>
<td>Buick</td>
<td>$30,530</td>
<td>$27,665</td>
<td>18.88</td>
<td>27.77</td>
</tr>
<tr>
<td>Cadilac</td>
<td>$10,474</td>
<td>$9,457</td>
<td>18.5</td>
<td>23</td>
</tr>
<tr>
<td>Chevrolet</td>
<td>$20,887</td>
<td>$18,091</td>
<td>18.68</td>
<td>25.81</td>
</tr>
<tr>
<td>Chrysler</td>
<td>$27,250</td>
<td>$24,270</td>
<td>18.66</td>
<td>27.33</td>
</tr>
<tr>
<td>Dodge</td>
<td>$26,254</td>
<td>$24,160</td>
<td>18.34</td>
<td>26.23</td>
</tr>
<tr>
<td>Ford</td>
<td>$24,016</td>
<td>$21,951</td>
<td>18.26</td>
<td>25.73</td>
</tr>
<tr>
<td>GMC</td>
<td>$29,561</td>
<td>$26,389</td>
<td>15.37</td>
<td>19.8</td>
</tr>
<tr>
<td>Honda</td>
<td>$21,436</td>
<td>$19,513</td>
<td>27.92</td>
<td>23.93</td>
</tr>
<tr>
<td>Hummer</td>
<td>$40,085</td>
<td>$34,815</td>
<td>10</td>
<td>12</td>
</tr>
<tr>
<td>Hummer</td>
<td>$17,477</td>
<td>$15,035</td>
<td>23</td>
<td>29.1</td>
</tr>
</tbody>
</table>

Insert a Table into a Report

To insert a table into a report:

1. Drag the table icon from the **Objects** tab in the left panel and drop it onto the report canvas.
2. Select **Insert** ➔ **Tables** and then select the menu item for the table object that you want to insert. The table is automatically placed in the report canvas. If you want the table to appear in a different place, then drag and drop it in a new location.

The following table lists the available table objects:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Table Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="List Table Icon" /></td>
<td>list table</td>
</tr>
<tr>
<td><img src="image" alt="Crosstab Icon" /></td>
<td>crosstab</td>
</tr>
</tbody>
</table>

Specify General Table Properties

To specify general properties for tables:

1. In the right panel, click the **Properties** tab.
2. Update the general properties for the table. Your choices are **Name**, **Title**, and **Description**. Here is an example of the properties for crosstabs:
Specify Table Styles

To specify styles for tables:

1. If not already selected, select the table that you want to update.
2. In the right panel, click the Styles tab.
3. Update the styles for the table. For a list table, you can customize the colors of Cells and Column headers. For crosstabs, you can customize the colors of Cells, Row headers, Column headers, and Measure headers. Here is an example of the styles for crosstabs:

Using Graphs to Display Results

Overview of the Graph Types

About Bar Charts

A bar chart consists of a grid and some vertical or horizontal bars. Each bar represents quantitative data.
**Display 22.5  A Bar Chart**

![Bar Chart](image)

**About Targeted Bar Charts**

A targeted bar chart is a variation of the bar chart that has pointers to target values.

**Display 22.6  A Targeted Bar Chart**

![Targeted Bar Chart](image)

**About Waterfall Charts**

A waterfall chart shows how the initial value of a measure increases or decreases during a series of operations or transactions. (This chart is also called a progressive bar chart.) The first bar begins at the initial value, and each subsequent bar begins where the previous bar ends. The length and direction of a bar indicates the magnitude and type (positive or negative, for example) of the operation or transaction. The resulting chart is a stepped cascade that shows how the transactions or operations lead to the final value of the measure.
About Line Charts
A line chart shows the relationship of one variable to another, often as movements or trends in the data over a period of time. Line graphs summarize source data and typically are used to chart response values against discrete categorical values.

About Pie Charts
A pie chart is a circular chart that is divided into slices by radial lines. Each slice represents the relative contribution of each part to the whole.
### About Scatter Plots

A scatter plot is a two-dimensional plot that shows the joint variation of two data items. In a scatter plot, each marker (represented by symbols such as dots, squares, and plus signs) represents an observation. The marker position indicates the value for each observation.

### About Time Series Plot

A time series plot shows an ordered sequence of values of a variable that are observed at equally spaced time intervals.
About Bubble Plots

A *bubble plot* is a variation of a scatter plot in which the markers are replaced with bubbles. In a bubble plot, each bubble represents an observation. The location of the bubble represents the value for the two measure axes; the size of the bubble represents the value for the third measure. A bubble plot is useful for data sets with dozens to represent large data or when the values differ by several orders of magnitude. You can also use a bubble plot when you want specific values to be more visually represented by different bubble sizes.

About Treemaps

A *treemap* is divided into rectangular areas called tiles. The color of each tile represents the value of the first measure in the query. The size of each tile represents the value of the second measure in the query. For example, a treemap might be used to represent sales data where the tile sizes vary according to the number of orders invoiced and the tile colors are derived from a color gradient that represents low to high sales figures.
A dual axis bar chart is a variation of the bar chart that has two measures, one on each axis. There can be one measure per axis for a total of two measures.

A dual axis line chart is a variation of the line chart that has two measures, one on each axis. There can be one measure per axis for a total of two measures.
**Display 22.15 A Dual Axis Line Chart**

**About Dual Axis Bar-Line Charts**

A *dual axis bar-line chart* is a bar chart that has two measures, one on each axis, and is overlaid by a line chart. There can be one measure per axis for a total of two measures.

**Display 22.16 A Dual Axis Bar-Line Chart**

**About Dual Axis Time Series Plots**

A *dual axis time series plot* is a variation of the time series plot that has two measures, one on each axis. There can be one measure per axis for a total of two measures.

**Display 22.17 A Dual Axis Time Series Plot**
**Insert a Graph into a Report**

To insert a graph into a report:

- Drag the graph icon from the **Objects** tab in the left panel and drop it onto the report canvas.
- Select **Insert** ⇒ **Graphs** and then select the menu item for the graph object that you want to insert. The graph is automatically placed in the report canvas. If you want the graph to appear in a different place, then drag and drop it in a new location.

The following table lists the available graph objects:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Graph Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="bar chart" /></td>
<td>bar chart</td>
</tr>
<tr>
<td><img src="image" alt="targeted bar chart" /></td>
<td>targeted bar chart</td>
</tr>
<tr>
<td><img src="image" alt="waterfall chart" /></td>
<td>waterfall chart</td>
</tr>
<tr>
<td><img src="image" alt="line chart" /></td>
<td>line chart</td>
</tr>
<tr>
<td><img src="image" alt="pie chart" /></td>
<td>pie chart</td>
</tr>
<tr>
<td><img src="image" alt="scatter plot" /></td>
<td>scatter plot</td>
</tr>
<tr>
<td><img src="image" alt="time series plot" /></td>
<td>time series plot</td>
</tr>
<tr>
<td><img src="image" alt="bubble plot" /></td>
<td>bubble plot</td>
</tr>
<tr>
<td><img src="image" alt="treemap" /></td>
<td>treemap</td>
</tr>
<tr>
<td><img src="image" alt="dual axis bar chart" /></td>
<td>dual axis bar chart</td>
</tr>
<tr>
<td><img src="image" alt="dual axis line chart" /></td>
<td>dual axis line chart</td>
</tr>
<tr>
<td><img src="image" alt="dual axis bar-line chart" /></td>
<td>dual axis bar-line chart</td>
</tr>
<tr>
<td><img src="image" alt="dual axis time series plot" /></td>
<td>dual axis time series plot</td>
</tr>
</tbody>
</table>

**Specify General Graph Properties**

To specify general properties for graphs:

1. If not already selected, select the graph that you want to update.
2. In the right panel, click the **Properties** tab.
3. Update the general properties for the graph. The available properties depend on the selected graph type. For example, for a pie chart, you can specify **General**, **Pie**, and **Legend** properties. Here is an example of the properties for a pie chart:
Display 22.18 Properties for a Pie Chart

Specify Graph Styles

To specify styles for graphs:

1. If not already selected, select the graph that you want to update.
2. In the right panel, click the Styles tab.
3. Update the styles for the graph. The available styles depend on the selected graph type. For example, for a pie chart, you can specify Data Styling, Frame Styling, Text Styling, and Data Colors styles. Here is an example of the styles for a pie chart:
Using Gauges to Display Results

Overview of the Gauge Types

A gauge displays the status or measure of a variable or variables in relation to a target, goal, or interval. Gauges are designed to achieve this goal in a way that is familiar to users. Many gauges can be found in real-life objects such as cars or machines. Gauges can be used to display a quantity, range, variable, or status.

The following gauges are available in the designer interface:

Display 22.20 A Bullet Gauge
Display 22.21  A Slider Gauge

Display 22.22  A Thermometer Gauge

Display 22.23  A Dial Gauge

Display 22.24  A Speedometer Gauge
Inserting a Gauge into a Report

To insert a gauge into a report:

- Drag the gauge icon from the Objects tab in the left panel and drop it onto the report canvas.
- Select Insert → Gauges and then select the menu item for the gauge object that you want to insert. The gauge is automatically placed in the report canvas. If you want the gauge to appear in a different place, then drag and drop it in a new location.

The following table lists the available gauge objects:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Gauge Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>•</td>
<td>bullet</td>
</tr>
<tr>
<td>•</td>
<td>slider</td>
</tr>
<tr>
<td>•</td>
<td>thermometer</td>
</tr>
<tr>
<td>•</td>
<td>dial</td>
</tr>
<tr>
<td>•</td>
<td>speedometer</td>
</tr>
</tbody>
</table>

Specify General Gauge Properties

To specify general properties for gauges:

1. If not already selected, select the gauge that you want to update.
2. In the right panel, click the Properties tab.
3. Update the general properties for the gauge. The available properties depend on the selected gauge type. For example, for a dial gauge, you can specify General and KPI Chart properties. Here is an example of the properties for a dial gauge:

   **Display 22.25  Properties for a Dial Gauge**
Specify Gauge Styles

To specify styles for gauges:

1. If not already selected, select the gauge that you want to update.
2. In the right panel, click the Styles tab.
3. Update the styles for the gauge. The available styles depend on the selected gauge type. For example, for a pie chart, you can specify Data Styling, Frame Styling, and Text Styling. Here is an example of the styles for a dial gauge:

   ![Display 22.26 Styles for a Dial Gauge]

Specify a Gauge Display Rule

A display rule is used by a gauge to designate intervals and colors for ranges. To specify the display rule for gauges:

1. If not already selected, select the gauge that you want to update.
2. In the right panel, click the Display Rule tab.
3. Update the display rules for the gauge. You can populate intervals, edit the display rule, and specify the Type. Here is an example of the display for a dial gauge:

   ![Display 22.27 Display Rule for a Dial Gauge]

To populate the intervals:

a. Click to display the Populate Intervals dialog box.
Display 22.28  Populate Intervals Dialog Box

b. Enter a number for Target value.
c. Click OK.

To edit the display rule:

a. Click to display the Edit Display Rule dialog box.

Display 22.29  Edit Display Rule Dialog Box

b. Select a Type. Your choices are either Use a Shared Display Rule or Specify Intervals.

If you select Specify Intervals, then the dialog box contents change so that you can add intervals. Here is an example:

Display 22.30  Specifying Intervals in the Edit Display Rules Dialog Box

Update the conditions for the values, the intervals, and the color for the range. Select a color to open the color picker. To add new intervals to the display rule, enter a number and click Add. Select the Save as a shared Display Rule check box and specify a Name if you want to save the display rule.
c. Click OK.
Overview of Interactions

Interactions are used to direct a report viewer’s attention to specific results in a report. The interaction view in the designer interface enables report authors to specify which interactions they would like to add to tables, graphs, and gauges in a report.

There are two types of interactions:

- **filter**
  - is used to restrict the data that is returned from a query to a data source. Filters are simply a set of rules, or conditions, that you specify to subset the data that is displayed in a table or graph. The goal is to display only the data that you need to see to perform your analysis.

- **brush**
  - is short for *data brushing*, which enables you to show the same data selected simultaneously in two or more tables, graphs, or both. The brushed data has the same appearance in each object, which makes the data easily apparent to report viewers.

Typically, graphs are the source of an interaction, with the exception of scatter plots. Tables, graphs, and gauges can be the target for an interaction. However, tables, gauges, and scatter plots cannot be the source of an interaction.

Creating Interactions

Creating a Filter Interaction

To create a filter interaction:

1. Add the report objects that you want to use to the report canvas. For example, you might have a bar chart, a pie chart, and a crosstab.
2. Click above the canvas to switch to interaction mode.

3. In the interaction view, draw a connection between the source and target report objects. When you have created an interaction, the icon is displayed between the report objects. Here is an example of an interaction between a bar chart (the source) and a crosstab (the target):

**Display 23.1 Creating a Filter Interaction between a Bar Chart and a Crosstab**

4. Right-click . Then select **Interaction Type ➔ Filter**.

**Display 23.2 Interaction Type Menu**

5. (Optional) Add other filtering interactions.

6. Click to switch to the layout view. Select data in the source report object to filter data in the target report object (or objects). In the following example, a car dealer was selected in the bar chart. Simultaneously, the pie chart and the crosstab show the same filter.
Creating a Data Brushing Interaction

To create an interaction using data brushing:

1. Add the report objects that you want to use to the canvas. For example, you might have a bar chart, a pie chart, and a crosstab.

2. Click above the canvas to switch to interaction mode.

3. In the interaction view, draw a connection between the source and target report objects. When you have created an interaction, the is displayed between the report objects. Here is an example of a data brushing interaction between a bar chart (the source) and a crosstab (the target):
4. Right-click 🔄. Then select **Interaction Type** ⇒ **Brush**.

**Display 23.5 Interaction Type Menu**

The filter icon changes to 🔄.

5. (Optional) Add other data brushing interactions.

6. Click 🗄 to switch to the layout view. Select data in the target report object to brush data in the connected report object (or objects). In the following example, the Smith car dealership was selected in the bar chart. Simultaneously, the pie chart and the crosstab show the same data brushing.
Deleting Interactions

To delete either a filter or data brushing interaction:

1. Click above the canvas to switch to interaction mode.
2. Right-click . Then select Delete.

3. (Optional) Remove other interactions.
4. Click to switch to the layout view.
Overview of Report Sections

Any report can have multiple sections. Multiple sections can be used to present different views of the data to the person who views the report. Each section has one data source. There is no limit to the number of sections that can be included in a report. Once you have created sections in a report, you can choose to independently view a specific report section.

Adding a Section to a Report

You can add sections to any report, including reports that were created in the exploration environment. To add a new section to a report, click in the tab to the right of the first section in the report. Here is an example of what the first section tab looks like.

Display 24.1  Section Tabs

![Section Tabs](Image)

The new tab appears to the right of the existing tab (or tabs). Here is an example:

Display 24.2  Section Tabs

![Section Tabs](Image)
Renaming a Report Section

To rename a report section:

1. Right-click the section tab that you want to rename. A menu is displayed.

   ![Display 24.3 The Menu Option for Renaming a Section](image)

   2. Select Rename. The name of the tab is highlighted.
   3. Type a new name, and then press Enter. The new name also appears on the Properties tab in the right panel.

Deleting a Section from a Report

To delete a section from a report, right-click the section tab that you want to remove. When the menu is displayed, select Delete.

*Note:* The Delete option is not available if the report has only one section.

Moving or Dragging a Report Object to Another Section

To move a report object from one section in a report to another section, right-click the report object and select Move to. Then, select the name of the other section. You can also drag an object from one section and drop it onto the tab for another section to place it in that section.
Part 5

Viewing Reports

Chapter 25
Viewing Reports on a Mobile Device ........................................ 149

Chapter 26
Viewing Reports in the Web Viewer ................................. 151
Chapter 25
Viewing Reports on a Mobile Device

Opening the App for the First Time

You can use the SAS Mobile BI for iPad app to view SAS Visual Analytics reports on your mobile device. The SAS Mobile BI app is available in the iTunes App store.

When you open the app for the first time, the following tutorials are available in My Portfolio:

- Introduction
- Explore the Portfolio
- Explore the Library

Tap each tutorial to view information about the features provided by the app and how to use the app. Additional tutorials are available in the Library.

The app also provides help that you can view in My Portfolio. Tap Help ⇒ Get Help to learn how to access more tutorials in the Library.

Connecting to Your Library Server for the First Time

To connect to a new server:

1. Tap Library in My Portfolio.
2. Tap Configure and Connect in the Welcome window.
3. Tap the User ID field and enter your user ID.
   
   Note: Contact your SAS Visual Analytics administrator for your user ID, password, and server information.
4. Tap the Password field and enter your password.
5. Tap the Server field and enter the new server.
6. Tap the **Description** field and enter a description for the new connection.

7. Tap **Next** to verify the connection.

8. Tap **Save**. The connection is saved and the Connections window closes.

   *Note:* If the connection fails, swipe the Connections window to scroll up. Make sure that the connection settings are correct. Your SAS Visual Analytics administrator can confirm these settings for you.

Information about available reports is automatically downloaded and appears in the Library.
Chapter 26

Viewing Reports in the Web Viewer

Overview of Viewing Reports in the Web Viewer

As an alternative to viewing reports on a mobile device, you can use the Web viewer. For users with a Report Viewing role, the Web viewer enables them to view report content.

Opening a Report in the Web Viewer

To open a report in the Web viewer:

• Double-click a report on the SAS Visual Analytics home page.

• Use the object inspector on the home page to view details about the report and then click View.

Display 26.1  The Object Inspector on the Home Page

Here is an example of a report in the Web viewer:
Adding Comments to a Report in the Web Viewer

You cannot make or save changes to reports in the Web viewer. However, you can add comments to a report. The comments that you add are automatically saved with the report.

To add a comment:
1. Click the **Comments** tab in the right panel.
2. Click **New Topic** to open the New Topic dialog box.
3. Enter a topic name and a comment. Here is an example:
Adding Comments to a Report in the Web Viewer

Display 26.3  New Topic Dialog Box for Adding Comments in the Web Viewer

4. (Optional) Set a priority for the comment using the drop-down list. You can select Normal, High, or Low.

5. (Optional) Click Attachment to add a file or image to your comment.

6. Click Save. Your comment will be added to the Comments dialog box.

To respond to an existing comment:

1. Click the Comments tab in the right panel.

2. Click Reply to open the Comments dialog box.

3. Enter a comment. Here is an example:

   Display 26.4  Dialog Box for Replying to a Comment

4. (Optional) Set a priority for the reply using the drop-down list. You can select Normal, High, or Low.

5. (Optional) Click Attachment to add a file or image to your reply.

6. Click Save. Your reply will be added to the Comments dialog box.
Chapter 26 • Viewing Reports in the Web Viewer
Part 6

Managing the Environment

Chapter 27

Working with HDFS .................................................. 157

Chapter 28

Monitoring Resources .............................................. 167

Chapter 29

Monitoring Processes .............................................. 169

Chapter 30

Managing Mobile Devices ........................................ 171
Chapter 27
Working with HDFS

What Is the HDFS Content Explorer?
The HDFS content explorer is used to navigate through HDFS folders and to manage prepared data that is stored in HDFS. It provides a tree-based view of the HDFS folder...
structure and a table-based view of the details for the prepared data. The HDFS content explorer is shown in the following display:

**Display 27.1  HDFS Content Explorer**

The following sections provide more information about using the HDFS content explorer. It is launched from the data preparation interface by clicking **HDFS** from the toolbar.

*Note:* If the HDFS content explorer does not work and does not permit navigating HDFS, then contact your system administrator to make sure the SAS LASR Analytic Server Monitor is running.

---

**What Can I Do with the HDFS Content Explorer?**

A key feature of the data preparation interfaces is to prepare data for analysis. The last stage of the data preparation activity is to add the prepared data to HDFS so that it can be loaded into memory on the SAS LASR Analytic Server. Analysts can then explore the data from the SAS Visual Analytics explorer interface. For deployments that have data that is already prepared for analysis, the HDFS content explorer enables administrators to add that data to HDFS directly. The HDFS content explorer also enables administrators to view information about the prepared data such as the row count, columns, and column information.

When tables are added to HDFS with the data preparation interface, they are stored with a SASHDAT file suffix. This is a special file format used by the SAS LASR Analytic Server. This special file format and the data redundancy provided by SAS Visual Analytics Hadoop enable the SAS LASR Analytic Server to read the data in parallel at very impressive rates. The data that is stored in HDFS is stored in blocks. The HDFS content explorer enables an administrator to view the block distribution, block redundancy, and measures of block utilization.
Navigating HDFS Folders

The HDFS content explorer provides a familiar and easy to use interface for navigating the files and folders in HDFS. You can navigate by clicking the folder icons in the folder tree and by using the following navigation buttons:

**Back**
- Click this button to return to the previously used folder.

**Up one level**
- Click this button to navigate to the parent folder.

Adding a Table to HDFS

To add a table to HDFS:

1. Click **HDFS** in the toolbar to access the HDFS content explorer.
2. Click ✉, select a table, and click **OK**.
3. On the Add to HDFS dialog box, specify the **HDFS output path** and **Label** and then click **Add**.

*Note:* If you refresh your view as a table is added to HDFS, the HDFS content explorer might show many files in the directory for the table. The filenames follow a `tablename-ip-address.sashdat` pattern. This is temporary and when the table is completely added to HDFS, the additional files do not appear.

Deleting a Table from HDFS

To delete a table from HDFS:

1. Click **HDFS** in the toolbar to access the HDFS content explorer.
2. Select the file to delete and click ✗.
3. Review the confirmation prompt and then click **Delete**.

Files that are not SASHDAT files are listed in the HDFS content explorer, but they cannot be deleted.

Viewing HDFS System Properties

To view the HDFS system properties:

1. Click **HDFS** in the toolbar to access the HDFS content explorer.
2. Click **Properties**.

The following table describes the fields:

**Table 27.1  HDFS System Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command for setting permissions</td>
<td>Specifies the path to the setperm command. This command is used to enable security for files stored in HDFS by setting access permission.</td>
</tr>
<tr>
<td>Set permissions as root?</td>
<td>Specifies whether access permissions are enabled. For a SAS Visual Analytics deployment, the value is <strong>Yes</strong>.</td>
</tr>
<tr>
<td>Command for getting file information</td>
<td>Specifies the list command and options. For a SAS Visual Analytics deployment, the value is <code>ls -l {0}</code>.</td>
</tr>
<tr>
<td>Data directories</td>
<td>Specifies the directory that is used to store blocks.</td>
</tr>
<tr>
<td>NameNode</td>
<td>Specifies the host name of the machine that is used as the SAS Visual Analytics Hadoop NameNode.</td>
</tr>
<tr>
<td>Live DataNodes</td>
<td>Specifies the number of SAS Visual Analytics Hadoop DataNodes that are reachable and the number that are not available.</td>
</tr>
<tr>
<td>Dead DataNodes</td>
<td></td>
</tr>
</tbody>
</table>
Viewing Basic File Information

To view basic file information, select a file in the HDFS content explorer. The following display shows an example:

**Display 27.2  Basic File Information**

The following information about a file is provided:

**Table 27.2  Basic File Information**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the file.</td>
</tr>
<tr>
<td>Size</td>
<td>Specifies the number of bytes that are used to store the file. This value includes the disk space required to store the data in blocks and metadata about the file.</td>
</tr>
<tr>
<td>Date Modified</td>
<td>Specifies the date that the file was created or replaced.</td>
</tr>
<tr>
<td>Path</td>
<td>Specifies the HDFS directory.</td>
</tr>
<tr>
<td>Number of copies</td>
<td>Specifies the number of redundant copies of the data.</td>
</tr>
<tr>
<td>Block size</td>
<td>Specifies the number of bytes that are used to store each block of data.</td>
</tr>
<tr>
<td>Owner</td>
<td>Specifies the user account that added the data to HDFS.</td>
</tr>
<tr>
<td>Group</td>
<td>Specifies the primary UNIX group for the user account.</td>
</tr>
</tbody>
</table>
### Viewing Table Information

#### View Columns

To view column information, select a table in HDFS and then click on the table view button. The following display shows an example:

**Display 27.3 Column Information**

![Column Information](image)

The following information about each column is provided:

**Table 27.3 Column Information**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Name</td>
<td>Specifies the column name from the source table.</td>
</tr>
<tr>
<td>Label</td>
<td>Specifies the label for the data set column when the table was added to HDFS.</td>
</tr>
<tr>
<td>Type</td>
<td>Numeric or Character. Numeric variables are encoded as <code>1</code>.</td>
</tr>
<tr>
<td>Offset</td>
<td>Specifies the starting position for the variable in the SASHDAT file.</td>
</tr>
<tr>
<td>Length</td>
<td>Specifies the storage used by the variable.</td>
</tr>
</tbody>
</table>
### Field | Description
---|---
**Format** | Specifies the format associated with the variable.
**Format length** | Specifies the format length of the format that existed on the variable when it was added to HDFS. This value is zero if the variable did not have a format when it was added to HDFS.
**Precision** | Specifies the precision portion of the format for number formats.
**Length (Formatted)** | Specifies the length of the variable when formatting is applied.

---

**View Row Count**

To view the row count, select a table in HDFS and then click [here].

![Row Count: /department/orsales.sashdat](image)

The following information is provided:

**Table 27.4  Row Count Information**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rows</td>
<td>Specifies the number of rows in the data.</td>
</tr>
<tr>
<td>Blocks</td>
<td>Specifies the number of HDFS blocks that are used to store the data.</td>
</tr>
<tr>
<td>Allocated</td>
<td>Specifies the number of bytes allocated to store the data. It is a multiple of the block size and the number of blocks. This value is smaller than the file size because it does not include the space needed for the SASHDAT file header.</td>
</tr>
<tr>
<td>Used</td>
<td>Specifies the number of bytes within the allocated blocks that are used for storing rows of data.</td>
</tr>
</tbody>
</table>
### Viewing Block Information

#### View Block Details

To view block details, select a file in HDFS and click **View Block Details**.

The following information about each block is provided:

**Table 27.5  Block Details Information**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host Name</td>
<td>Specifies the machine in the grid that stores the block of data.</td>
</tr>
<tr>
<td>Block Name</td>
<td>Specifies the filename for the block.</td>
</tr>
<tr>
<td>Path</td>
<td>Specifies the directory to the block.</td>
</tr>
<tr>
<td>Record Length</td>
<td>Specifies the sum of the column lengths for the variables in the data.</td>
</tr>
<tr>
<td>Records</td>
<td>Specifies the number of rows stored in the block. Because redundant blocks are listed in the table, the sum of the records listed does not equal the number of rows in the data.</td>
</tr>
<tr>
<td>Owner</td>
<td>Specifies the user account that added the data to HDFS.</td>
</tr>
<tr>
<td>Group</td>
<td>Specifies the primary UNIX group for the user account that stored the data.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Specifies the Read, Write, and Execute access permissions for owner, group, and other.</td>
</tr>
</tbody>
</table>
You can sort by the column headings to identify anomalies. It is normal for several blocks to be stored on the same machine. However, it is not normal for the values of **Record Length**, **Owner**, **Group**, or **Permissions** to be different from row to row.

**View Block Distribution**

The files added to HDFS are stored as blocks. One block is the preferred block, and additional copies of the blocks are used to provide data redundancy. The Block Distribution dialog box offers two ways to view this information. The **Block Detail View** tab enables you to select a block number and view the host names that store the original or redundant blocks. The **Node Detail View** enables you to select a host name and view the block numbers that are stored on the machine.

To view the block distribution, select a table in HDFS and then click ![view button].

The following information about the block distribution is provided:

**Table 27.6  Block Distribution Information**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File size</td>
<td>Specifies the size of the file in bytes.</td>
</tr>
<tr>
<td>Block size</td>
<td>Specifies the block size for the file.</td>
</tr>
<tr>
<td>Blocks</td>
<td>Specifies the number of blocks used to store the original copy of the data.</td>
</tr>
<tr>
<td>Copies</td>
<td>Specifies the number of redundant block copies of the data.</td>
</tr>
<tr>
<td>Nodes used</td>
<td>Specifies the number of machines in the grid that have original or redundant blocks for the file.</td>
</tr>
</tbody>
</table>

On the **Block Detail View** tab, you can select a block number to view how many copies of the block exist and the host names for the machines that store the blocks. The value in the **Total Copies** column equals the number of redundant copies of the block plus the
original block. You can select the column heading to sort the rows. In an ideal
distribution, the number of total copies is equal for all blocks.

On the **Node Detail View** tab, you can expand a host name node and then view the block
numbers that are stored on that machine. When you select the block number, this host
name and any additional machines with copies of the block are identified in the host
name list. The following display shows an example:
Chapter 28
Monitoring Resources

Utilization History

Information about the resource utilization is available in the Resource Monitor. The resource utilization is displayed in two graphs, the Utilization History and the Real-Time View. The graphs are updated according to a sampling rate. The sampling rate is set in the application preferences.

The Utilization History graph plots the utilization for the following resources against time:

- CPU
- memory
- network input/output (I/O)

The CPU and memory utilization are plotted as a percentage of 100% capacity, though the graph scales automatically. Under periods of high demand, the upper bound can reach 100%. Under periods of low demand, the upper bound can drop below 10%.

The network I/O utilization is shown as one line plot for input and one line plot for output. The plot shows the transfer rate in units of megabytes per second.

To view the resource utilization for one sampling period, place your pointer over a line. You can also click on a line to select the same sampling period for all the resource line
plots that are shown. This way, you can place your pointer over each of the selected sampling periods to view the utilization for each resource in the same sampling period.

**Figure 28.1 Resource Monitor**

- **Utilization History**
  - Each column of icons represents a machine in the grid. The three horizontal sections of icons represent CPU, memory, and network I/O. To view the real-time resource utilization for a resource type, position your pointer over one of the icons.
  - For the row of CPU icons, the tooltip shows the host name, CPU number, and the CPU utilization. For the row of memory icons, the tooltip shows the host name and memory utilization. Both of these icons have a range of zero to 100. The icon color changes to represent the work load.
  - For the two rows of network I/O icons, the top row shows the transfer rate for output and the bottom row shows the transfer rate for input. The tooltip shows the host name, the direction, and the rate. The color for the icons depends on the transfer rate between 0 and 25 megabytes per second. If the transfer rate exceeds 25 MB per second, then the icon color changes to purple.

- **Real-Time View**
  - The Real-Time View of resource utilization is provided below the Utilization History. Each column of icons represents a machine in the grid. The three horizontal sections of icons represent CPU, memory, and network I/O. To view the real-time resource utilization for a resource type, position your pointer over one of the icons.
  - For the row of CPU icons, the tooltip shows the host name, CPU number, and the CPU utilization. For the row of memory icons, the tooltip shows the host name and memory utilization. Both of these icons have a range of zero to 100. The icon color changes to represent the work load.
  - For the two rows of network I/O icons, the top row shows the transfer rate for output and the bottom row shows the transfer rate for input. The tooltip shows the host name, the direction, and the rate. The color for the icons depends on the transfer rate between 0 and 25 megabytes per second. If the transfer rate exceeds 25 MB per second, then the icon color changes to purple.

---

**Note:** If the Resource monitor does not display the line plot or the Real-Time View, then contact your system administrator to make sure the SAS LASR Analytic Server Monitor is running.
Chapter 29
Monitoring Processes

Viewing Memory and CPU Utilization

Information about the per-process resource utilization is available in the Process Monitor. The resource utilization for memory and CPU are displayed in two graphs, the Memory Utilization versus CPU Utilization and CPU and Memory Utilization by Instance. The graphs are updated according to a sampling rate. The sampling rate is set in the application preferences.

The Selection menu enables you to filter the display of application instances in the graphs for top resources consumers.

Each application instance is represented by a bubble in the bubble plot. The size of the bubble represents the number of processes used for the application instance. If an instance has one process for each machine in the grid, then that ensures ideal resource utilization and performance.

The location of the bubble indicates the resource utilization for the application instance on the machines in the grid. Place your pointer over a bubble to view information about the application instance. Select a bubble to view the detailed resource consumption for each machine that is used by the application instance.

Note: If no application instances appear in the process monitor, then contact your system administrator to make sure the SAS LASR Analytic Server Monitor is running.

CPU and Memory Utilization by Instance

The CPU and Memory Utilization by Instance graph shows a bar chart. Each application instance is represented by a bar. The lower part of the bar shows the CPU utilization for the application instance. The upper part of the bar shows the memory utilization for the application instance.
Place your pointer over a bar to view information about the application instance. Select a bar to view the detailed resource consumption for each machine that is used by the application instance.
Chapter 30
Managing Mobile Devices

Features in Mobile Device Administration

This chapter addresses the use of the SAS Visual Analytics mobile device administration interface to manage mobile device users who use the SAS Visual Analytics suite of applications. This application interface includes the following administration features for managing mobile devices:

- View data about mobile devices that are set up for users to view reports or explorations that were created in SAS Visual Analytics. The displayed data includes user ID, device type, device model, device ID, OS version, application version, and timestamp of last access.
- Sort the data for mobile devices in ascending or descending order.
- Filter data for mobile devices. For example, you can filter data by the mobile device type or by the mobile device model.
- Blacklist lost or stolen mobile devices.
- Remove blacklisted mobile devices from the blacklist.

Managing Mobile Devices

The SAS Visual Analytics mobile device administration interface is easy to use. To perform tasks such as viewing, sorting, filtering, or blacklisting a mobile device:

1. Log on to SAS Visual Analytics.
2. Click the Prepare Data icon.
3. Click Mobile Devices.
4. On the main page for SAS Mobile Device Administration, select Logon History.
5. To sort the items in the columns in either ascending or descending order, click the column heading for any column on this page.
6. To filter and view selected data about mobile devices:
   a. From the **Filter** menu, select an item (for example, Device Type). Then, enter a valid value in the field (for example, iPad), and click **Apply**.

      The value that you specified for the filter determines the type of data that is displayed.

   b. To view the entire history of events (for example, various application versions that were used by devices) associated with the item that you specified in the **Filter** field, select the **Include Device History** check box.

7. To add a mobile device to the blacklist:
   a. Click the device in the **Device ID** field on the Logon History page.

      You are prompted by a dialog box with a question asking if you are sure that you want to blacklist this device.

   b. Click **Yes**.

      The mobile device is added to the list of blacklisted devices on the Manage Blacklist page. The **Action** column indicates the status of this device (whether it as blacklisted or not), and the **Result** column indicates whether your action was successful. Blacklisted mobile devices cannot be used to access the SAS Visual Analytics suite of applications.

8. To remove a mobile device from the blacklist, select the device on the Manage Blacklist page. Then, click the X icon.

     You are prompted by dialog box asking you to confirm your action. Click **Yes**.

9. To view blacklisted mobile devices or confirm that a device was blacklisted, click **Blacklist History**.

     In the table on this page:

     - The **Admin ID** column displays the user name of the administrator who blacklisted the device.
     - The **Device ID** column displays the name of the blacklisted device.
     - The **Action** column displays the type of action that was performed for the mobile device.
     - The **Result** column indicates whether the attempt to blacklist a mobile device was successful.
     - The **Timestamp** column displays the date and time when a specific mobile device was blacklisted.

10. To search for a blacklisted mobile device either by the device ID or the administrator ID, click **Manage Blacklist**. Then, select **Admin ID** or **Device ID** from the drop-down menu for **Filter**. Click **Apply**.

    The mobile devices that meet the criteria that you specified are displayed.
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>31</td>
<td>Overview of the Console</td>
<td>175</td>
</tr>
<tr>
<td>32</td>
<td>Managing Console Users and Groups</td>
<td>181</td>
</tr>
<tr>
<td>33</td>
<td>Viewing Console Logs</td>
<td>189</td>
</tr>
<tr>
<td>34</td>
<td>Managing Users and Groups</td>
<td>193</td>
</tr>
<tr>
<td>35</td>
<td>Gridhosts File Management</td>
<td>205</td>
</tr>
</tbody>
</table>
About the Console

The SAS High-Performance Computing Management Console is a Web application that is used by system administrators to manage high-performance computing environments that use SAS software. Maintaining high-performance computing (HPC) environments is challenging because of the large number of machines that are used in the distributed computing environment. In order to ensure peak performance and reliability, whatever action is taken on one machine must be performed on all the machines. Tasks that might be simple on a single machine, such as adding a user or changing a system configuration option, become more challenging in a distributed computing environment. Most changes must be propagated to the other machines and this can be labor intensive and time consuming. The console is used to ease the administration of the environment.

The console includes its own embedded Web server. When administrators log on to the console, where authentication occurs is determined by the user name provided. If the user name matches an operating system user account, then the operating system performs authentication. If the user name does not match an operating system user account, then the console performs authentication. In either case, the console does not perform any interaction with the SAS Metadata Server.

Accessing the Console

You can access the console interface by selecting **Tools ➝ SAS HPC Management Console** from the SAS Visual Analytics data preparation interface. Log on with a console user account. For more information about console user accounts, see “Managing Console Users and Groups” on page 181.
Specifying Console Preferences

To specify your preferences:

1. Click **Console Management** from the toolbar.

2. Click **Console Configuration** and then click **User Interface**.

3. The most important setting for a SAS Visual Analytics deployment is to make sure that the **HPC Environment being managed menu** is set to **SAS High Performance Business Intelligence**.

The following table identifies the options that are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page background</td>
<td>Specify the color to use for each of these options as the RGB hexadecimal code for a color.</td>
</tr>
<tr>
<td>Normal text</td>
<td></td>
</tr>
<tr>
<td>Table background</td>
<td></td>
</tr>
<tr>
<td>Table header</td>
<td></td>
</tr>
<tr>
<td>Link text</td>
<td></td>
</tr>
<tr>
<td>Display titles as text?</td>
<td>Specifies whether any title is displayed as text in the console. The default value is No.</td>
</tr>
<tr>
<td>Display login and hostname (for non-framed themes)</td>
<td>Specify the location of the client login and host name when non-framed themes are used. Use the menu to select a choice. The default value is At bottom of browser.</td>
</tr>
<tr>
<td>Hostname to display in the Management Console</td>
<td>This option enables you to specify the how the host name for the SAS High-Performance Computing Management Console is displayed to clients. Use the menu to select a choice. The default value is Real hostname.</td>
</tr>
<tr>
<td>Prepend username to page titles?</td>
<td>Specify whether the user name or host name of the connected user appears in the page title bar of the Web browser.</td>
</tr>
<tr>
<td>Prepend hostname to page titles?</td>
<td></td>
</tr>
<tr>
<td>Format for displayed dates</td>
<td>Specify how the date is displayed in the console. Use the menu to select a choice. The default value is dd-mon-yyyy.</td>
</tr>
</tbody>
</table>
Configure SAS High-Performance Computing Management Console Network Settings

By default, the server process for the SAS High-Performance Computing Management Console listens on port 10020 and on all IP addresses for the machine on which it is installed. However, the port and address settings are configurable.

Note: In a SAS Visual Analytics deployment, do not change the port number.

To specify the port and address settings:

1. Click **Console Management** from the toolbar.
2. Click **Console Configuration** and then click **Ports and Addresses**.
3. The following table identifies the options that are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Listen on IPs and ports</td>
<td>Select the <strong>Only Address</strong> option and specify an IP address to restrict the console to listen for connections on the specified IP address only. The default value is <strong>Any Address</strong>. Specify a port number in the <strong>Listen on port</strong> field. The default value is 10020.</td>
</tr>
<tr>
<td>Accept IPv6 connections?</td>
<td>Specifies whether the console accepts IPv6 connections. The default value is <strong>No</strong>.</td>
</tr>
<tr>
<td>Listen for broadcasts on UDP port</td>
<td>Specify whether to listen for UDP broadcasts from other console installations. Available options are <strong>Don’t Listen</strong> or a specified port. The default value is to listen on port 10020. This option is not used at this time.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Web server hostname</td>
<td>Specify how the console server determines its host name. Available options are Work out from browser or specifying a host name. The default value is to determine it from the Web browser.</td>
</tr>
<tr>
<td>Reverse-resolve connected IP address?</td>
<td>Specify whether the IP addresses of the client machines are resolved to host names. The default value is Yes.</td>
</tr>
</tbody>
</table>

4. Click Save.

### Configuring Console Logging

To configure logging settings:

1. Click **Console Management** from the toolbar.
2. Click **Console Configuration** and then click **Logging**.
3. The following table identifies the options that are available:

*Table 31.3 SAS High-Performance Computing Management Console Logging Options*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logging active?</td>
<td>Select Disable logging or Enable logging. The default value is Enable logging.</td>
</tr>
<tr>
<td>Log resolved hostnames?</td>
<td>Specifies whether to log host names in the logs. The default value is No.</td>
</tr>
<tr>
<td>Use combined log format (including referrer and user agent)?</td>
<td>Specifies whether a combined log format is used. The default value is No.</td>
</tr>
<tr>
<td>Periodically clear log files?</td>
<td>Specify the interval to use for clearing log files. The default value is not to clear log files.</td>
</tr>
<tr>
<td>Users to log</td>
<td>Specify the user accounts to record in log reports. The default is Log actions by all users.</td>
</tr>
<tr>
<td>Modules to log</td>
<td>Specify the modules to log. The default is Log actions in all modules.</td>
</tr>
<tr>
<td>Include Console logins and logouts in actions log?</td>
<td>Specifies whether logon to and logoff actions from the console are logged. The default value is No.</td>
</tr>
<tr>
<td>Log changes made to files by each action?</td>
<td>Specify whether changes that are made to files are logged. The default value is No.</td>
</tr>
</tbody>
</table>
4. Click Save.

## Configuring Console Logging

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Record all modified files before actions,</strong></td>
<td>Specify whether modified file changes are recorded for possible rollback. The default value is <strong>No</strong>.</td>
</tr>
<tr>
<td><strong>for rollbacks?</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Permissions for log files</strong></td>
<td>Specify the mode permissions for the log files. The default setting is 600 and owned by root.</td>
</tr>
<tr>
<td><strong>Add log to syslog?</strong></td>
<td>Specify whether actions are logged to syslog in addition to log files. The default value is <strong>No</strong>.</td>
</tr>
</tbody>
</table>
Chapter 32
Managing Console Users and Groups

Managing Console Users and Groups

Understanding Console Users and Groups

An important concept to understand is that the SAS High-Performance Computing Management Console manages two types of users and groups. The first type is for console users and groups. This provides access control for the user accounts that can use the SAS High-Performance Computing Management Console. The second type of users and groups are the operating system users and groups. The console does assist with managing these users and groups. For information about managing operating system users and groups with the console, see “Managing Users and Groups” on page 193.
The following display shows the interface for managing console users and groups. The links for creating new console users and new console groups are highlighted.

Display 32.1  Console Users and Groups Management

Create a Console User

Be aware that a console user is not the same as a user that is created in the HPC Management section of the console. Console users are created strictly for using the console. The Users and Groups module in the HPC Management section manages the operating system users and groups.

TIP  If the site security policy does not permit logging on the console with the root account to create the first console user, see “Creating a Console User from the Command Line” on page 185.

To create a console user:

1. Click Console Management from the toolbar.
2. Click Console Users and Groups.
3. Click Create a new console user.
The following display shows the Create console user screen.

**Display 32.2 Create Console User**

The following table describes the additional fields on the Create console user screen. They become available after clicking Security and limits options or Available console modules.

**Table 32.1 Create Console User Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Specify the user account.</td>
</tr>
<tr>
<td>Member of group</td>
<td>Use the menu to select a group.</td>
</tr>
<tr>
<td>Password</td>
<td>Specify the password for the console user. The menu offers the following choices:</td>
</tr>
<tr>
<td></td>
<td><strong>Set to</strong> sets the password to the value entered into the text field.</td>
</tr>
<tr>
<td></td>
<td><strong>UNIX authentication</strong> passes the authentication request to the operating system. This is the most commonly used choice.</td>
</tr>
<tr>
<td></td>
<td><strong>No password accepted</strong> locks the user out of the system.</td>
</tr>
<tr>
<td>Real name</td>
<td>(Optional) Specify an alternative description for the console user.</td>
</tr>
</tbody>
</table>

4. Click **Create**.
The follow table describes the additional options for creating a user.

**Table 32.2 Create Console User Options**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inactivity logout time</td>
<td>Specify an inactivity time-out. The default is no time-out.</td>
</tr>
<tr>
<td>Minimum password length</td>
<td>Specify the minimum number of characters for the user’s password. The default is no minimum length.</td>
</tr>
<tr>
<td>IP access control</td>
<td>Select the option that meets the security requirements for the environment. If <strong>Deny from listed addresses</strong> is selected, then be aware that the console user can log on from any IP address that is not listed. The default value is <strong>Allow from all addresses</strong>.</td>
</tr>
<tr>
<td>Allowed days of the week</td>
<td>Specify the days of the week that the console user is permitted to log on. The default value is <strong>Every day</strong>.</td>
</tr>
<tr>
<td>Allowed times of the day</td>
<td>Specify the range of hours that the console user can log on. The default value is <strong>Any time</strong>.</td>
</tr>
<tr>
<td>Console Configuration</td>
<td>Select this check box to enable the console user to configure console settings such as the user interface, network settings, and console logging.</td>
</tr>
<tr>
<td>Console Users and Groups</td>
<td>Select this check box to enable the console user to configure console users and groups. A best practice is to limit access to this feature. For more information, see “<strong>Best Practices for Managing Console Users and Groups</strong>” on page 187.</td>
</tr>
<tr>
<td>Console Logs</td>
<td>Select this check box to enable the console user to view and search the console logs. The console logs contain information about the actions performed with the console.</td>
</tr>
<tr>
<td>Gridhosts File Management</td>
<td>Select this check box to enable the console user to modify the <strong>/etc/gridhosts</strong> file. This file is used to identify the machines in the HPC environment and is very important to the operation of SAS High-Performance Analytics software and the console itself.</td>
</tr>
<tr>
<td>Users and Groups</td>
<td>Select this check box to enable the console user to manage the operating system user accounts in the HPC environment.</td>
</tr>
<tr>
<td>SSH Lockout</td>
<td>Select this check box to enable the console user to use the SSH lockout feature.</td>
</tr>
</tbody>
</table>
Creating a Console User from the Command Line

The root user account has access to log on to the console as soon as the console is installed and started. Typically, the root user account logs on to the console and creates a console administrator account that is then used to perform the administrative tasks. However, the security policy at some sites might not permit sharing the password for the root user account. In these environments, it is possible to add a console user from the command line if you have permission to use the `sudo` command. The files to modify are owned by root and only the root user account can restart a service. The console user to add must have a user account on the system.

To add a console user from the command line:

1. Use the `sudo` command to edit the miniserv.users file:
   ```
   sudo vi /opt/webmin/etc/miniserv.users
   ```
2. Add a line that is similar to the following example:
   ```
   username:x:0:::0:0
   ```
   Save and close the file.
3. Use the `sudo` command to edit the webmin.acl file:
   ```
   sudo vi /opt/webmin/etc/webmin.acl
   ```
4. Add a line that is similar to the following example:
   ```
   username: webmin webminlog init cron inittab proc acl
   webmincron net initsetup system-status useradmin tmptblmaint
   theme-xpstyle mscstyle3 actpsgqrys sshlock gridhosts
   ```
   *Note:* Enter this all on one line. It is split onto more than one line for display purposes only.
   Save and close the file.
5. Restart the SAS High-Performance Computing Management Console:
   ```
   sudo service sashpcmc restart
   ```
6. Log on to the console with the user name.

Create a Console Group

To create a console group:

1. Click **Console Management** from the toolbar.
2. Click **Console Users and Groups**.
3. Click **Create a new console group**.
The following display shows the Create Console Group screen.

**Display 32.3  Create Console Group**

The following table describes the fields on the Create Console Group screen.

**Table 32.3  Create Console Group Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group name</td>
<td>Specifies the console group name.</td>
</tr>
<tr>
<td>Group description</td>
<td>Specifies a description for the console group.</td>
</tr>
<tr>
<td>Member of users and groups</td>
<td>When a console group that has members is edited, this field lists the members of the group.</td>
</tr>
<tr>
<td>Console Configuration</td>
<td>Select this check box to enable the members of the group to configure console settings such as the user interface, network settings, and console logging.</td>
</tr>
<tr>
<td>Console Users and Groups</td>
<td>Select this check box to enable members of the group to configure console users and groups. A best practice is to limit access to this feature. For more information, see “Best Practices for Managing Console Users and Groups” on page 187.</td>
</tr>
<tr>
<td>Console Logs</td>
<td>Select this check box to enable members of the group to view and search the console logs. The console logs contain information about the actions performed with the console.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Gridhosts File Management</td>
<td>Select this check box to enable members of the group to modify the /etc/gridhosts file. This file is used to identify the machines in the HPC environment and is very important to the operation of SAS High-Performance Analytics software and the console itself.</td>
</tr>
<tr>
<td>Users and Groups</td>
<td>Select this check box to enable members of the group to manage the operating system user accounts in the HPC environment.</td>
</tr>
<tr>
<td>SSH Lockout</td>
<td>Select this check box to enable members of the group to use the SSH lockout feature.</td>
</tr>
</tbody>
</table>

4. Click Create.

**Best Practices for Managing Console Users and Groups**

Console groups can be used to grant identical access rights to groups of users share the same administration responsibilities. The Console Users and Groups module enables an administrator to manage the access permissions for console users. Limit access to this module because a user can change his access permissions and dilute the security of the SAS High-Performance Computing Management Console.

**Force Off Console Sessions**

The console enables administrators to force off other console users. To force off a console user:

1. Click Console Management from the toolbar.
2. Click Console Users and Groups.
3. Click View Login Sessions near the bottom of the page.
4. Select the session ID from the table to force off the console user. There is no confirmation prompt.
Your session ID is shown in bold text.
Chapter 33
Viewing Console Logs

View Logs for an Active Session

Follow the steps described in “Force Off Console Sessions” on page 187. Instead of selecting the session ID, select View logs for the console user to monitor. The console uses the session ID to perform a search of the console logs. The following display shows an example of the search results:

Display 33.1 Console Logs by User and Session ID

Select the action to review and then review the details. For information about the details, see “Understanding Log Details” on page 190.
Search Console Logs

To search console logs:

1. Click **Console Management** from the toolbar.
2. Click **Console Logs**.
3. Specify the search criteria in the **Search the console log for actions** fields and click **Search**.
   
   **Note:** The **By non-console user** option does not work in a SAS Visual Analytics deployment.

4. Select the action to review and then review the details. For information about the details, see “Understanding Log Details” on page 190.

Understanding Log Details

The console logs record information such as the action that was performed, the module that was used, the data and time, and the parameters associated with the action. The information in these logs is valuable when reviewing the actions that were performed by a console user. In addition to viewing logs, the console enables an administrator to annotate the log record with comments.

The following display shows a console log example for generating and distributing SSH keys. This type of console log can be recorded when an operating system user account is created. The information that the console shows in most of the fields, and especially in the **Raw log data** section, differs according to which action is performed.

*Display 33.2 Console Log Action Details*
The Details of logged action section includes the following information:

**Table 33.1  Console Log Details of Logged Action**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Specifies the action that was performed.</td>
</tr>
<tr>
<td>Console module</td>
<td>Specifies the console module that was used to perform the action.</td>
</tr>
<tr>
<td>Console user</td>
<td>Specifies the user name that performed the action.</td>
</tr>
<tr>
<td>Session ID</td>
<td>Specifies the Web session that was used when the action was performed. You can select the link to view the console logs for all actions performed during the Web session.</td>
</tr>
<tr>
<td>Generated by script</td>
<td>Specifies the console script that was used to perform the action.</td>
</tr>
<tr>
<td>Client IP or hostname</td>
<td>Specifies the IP address or host name that was used by the console user to perform the action.</td>
</tr>
<tr>
<td>Date and time</td>
<td>Specifies the date and time for when the action was performed. The date and time format can be changed by specifying a different format for displayed dates as described in “Specifying Console Preferences” on page 176.</td>
</tr>
</tbody>
</table>

The Log entry annotation section enables an administrator to save a comment about the action. Click Save after adding a comment.

The information in the Raw log data section differs according to the action that was performed. The information is shown as a two-column table of parameter names and parameter values. Most of the parameters are related to the descriptions provided in the previous table. However, the appearance of some fields is different. The following list describes those fields:

- **sid**
  This is the value for the Web session ID that was in use when the action was performed.

- **time**
  This value is a UNIX time representation for when the action was performed. When the data and time are shown in the Details of logged action section, the time is formatted for display from this value.

- **id**
  This value is the identifier for the log record.

The Files changed and commands run section shows the operating system commands that were executed to perform the action and the files that were used. This section is populated when the console is configured to log such information. By default, the console is not configured to log commands and files because the list of commands can be large and can contribute to a full system disk.
About Managing Users and Groups

The SAS High-Performance Computing Management Console enables two types of user and group management. The first type, for console users and groups, is described in “Managing Console Users and Groups” on page 181. This section describes the second type of user and group management, system users and groups. This management is performed with the High-Performance Computing (HPC) management section of the interface. It is also used to perform an SSH lockout. A lockout is used to limit access to machines in the grid.

The management operations that are described in the previous paragraph apply to a deployment that configures the console to manage a SAS High-Performance Business Intelligence environment. For information about configuring the console environment, see “Specifying Console Preferences” on page 176.

The following figure shows the interface that is seen by an administrator that is granted the ability to perform HPC management only. The options that are used to perform
console management are not available for this administrator. SAS High-Performance Computing Management Console

**Display 34.1  HPC Management Interface**

Managing Users and Groups

*Understanding Users and Groups*

The users and groups module is used to create, manage, and propagate operating system user accounts and groups throughout the machines in the grid. It also enables an administrator to generate and distribute SSH keys for each user account as the account is propagated to the machines in the grid.

An important requirement for SAS Visual Analytics deployments is to append the SSH public key for the user account that runs JBoss to the authorized_keys files for operating system user accounts. This task can be performed automatically when creating user accounts with the HPC management interface.
The following display shows the interface for managing operating system users and groups.

**Display 34.2  Managing Users and Groups**

The **HPC Users** tab shows the following information for each user account:

**Table 34.1  User Accounts Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Specifies the user account name.</td>
</tr>
<tr>
<td>User ID</td>
<td>Specifies the UID for the user account.</td>
</tr>
<tr>
<td>Group</td>
<td>Specifies the primary group for the user account.</td>
</tr>
<tr>
<td>Real name</td>
<td>Specifies details about the user that make the user account more identifiable.</td>
</tr>
<tr>
<td>Home directory</td>
<td>Specifies the home directory for the user account.</td>
</tr>
<tr>
<td>Shell</td>
<td>Specifies the UNIX shell to use for the user account.</td>
</tr>
<tr>
<td>SSH Keys?</td>
<td>This field is set to Yes if the <code>$HOME/.ssh/id_rsa</code> file exists.</td>
</tr>
<tr>
<td></td>
<td>For environments that use Network File System (NFS) to manage home directories, this field is set to NFS. The console does not attempt to detect the existence of the id_rsa file.</td>
</tr>
<tr>
<td>Last login</td>
<td>Specifies the date of the last logon.</td>
</tr>
</tbody>
</table>
Configuring the Middle-Tier Shared Key

SAS Visual Analytics deployments require appending the SSH public key for the user account that runs JBoss to the authorized_keys files for user accounts that use the explorer and designer interfaces. Perform this step before you create users.

To configure the middle-tier shared key:

1. Access the `.ssh/id_rsa.pub` file for the user account that is used to run JBoss. This file contains the SSH public key. Copy the contents of the file to your clipboard.
2. Click HPC Management from the toolbar.
3. Click Users and Groups.
4. Click Midtier Shared Key and specify values for the following fields:

   **Table 34.2 Middle-Tier Shared Key Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TKlasrkey location</td>
<td>Specify the fully qualified path to the tklasrkey file. The default location is <code>/opt/TKGrid/bin/tklasrkey</code>.</td>
</tr>
<tr>
<td>Shared Public Key</td>
<td>Paste the contents of the id_rsa.pub file from your clipboard.</td>
</tr>
<tr>
<td>Mid Tier Hostname</td>
<td>(Optional) If you specify the host name for the machine that is used to run JBoss, then the host name is included in the authorized_keys file. This provides an additional measure of security.</td>
</tr>
</tbody>
</table>

5. Click Save.

Create a User

To create a user:

1. Click HPC Management from the toolbar.
2. Click Users and Groups.
3. Click Create a new user and specify values for the following fields:

   **Table 34.3 Create User Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Specify the user account name, such as madapr or team1usr.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| User ID       | Select an option:  
  **Automatic**  
  the operating system will select an unused UID.  
  **Calculated** (rarely used) the UID is created based on a Berkeley CRC and mkuid. The mkuid command assumes a standard naming convention for user names.  
  **Specified**  
  specify the UID to use. By default, this field shows the UID that will be assigned if the Automatic option is used.  
  The default option is **Automatic**. |
| Real name     | Specify details about the user that make the user account more identifiable. |
| Home directory| Select an option:  
  **Automatic**  
  */home/*/username is the home directory value.  
  **Directory**  
  specify the fully qualified path to use as the home directory or click the Browse button to select a location.  
  The default is **Automatic**. |
| Shell         | This field is not selectable or configurable.  
  The default is **/bin/ksh**. |
| Password      | Select an option:  
  **No password required**  
  sets the password to null.  
  **Normal password**  
  enter the plain-text password in the field.  
  **Pre-encrypted password**  
  enter a password in encrypted form. |
<p>| Password changed | Specifies the last time the password was changed. |
| Expiry date   | Specify the date on which the password should expire. You can type the date or use the calendar. The default is no date. |
| Minimum days  | Specifies the minimum number of days between password changes. The default is zero. |
| Maximum days  | Specifies the maximum number of days between password changes. The default is 99999. |</p>
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Warning days</td>
<td>Specifies the number of days that a password expiration warning is generated before a password expires. The default is zero.</td>
</tr>
<tr>
<td>Inactive days</td>
<td>Specifies the number of days that a user must be inactive before the user account is locked. The default is zero.</td>
</tr>
<tr>
<td>Force change at next login?</td>
<td>Select <strong>Yes</strong> to force the user to change the password after the next logon. The default is <strong>No</strong>.</td>
</tr>
<tr>
<td></td>
<td><em>Note:</em> This option is not available for deployments that use SUSE Linux Enterprise Server. In this case, edit the user account after it is created to force the change.</td>
</tr>
<tr>
<td>Primary group</td>
<td>Select a group name from the menu. This list is filtered to show GID values that are greater than or equal to 100.</td>
</tr>
<tr>
<td>Propagate User</td>
<td>Select <strong>Yes</strong> to add the user to each machine in the environment. The default is <strong>No</strong>.</td>
</tr>
<tr>
<td>Generate and Propagate SSH Keys</td>
<td>Select <strong>Yes</strong> to generate SSH keys and propagate them when the user is created. The default is <strong>No</strong>.</td>
</tr>
<tr>
<td>Add Shared Midtier Key</td>
<td>Select <strong>Yes</strong> to include the information from the <strong>Midtier Shared Key</strong> tab in the authorized keys file for the user. The default is <strong>No</strong>.</td>
</tr>
<tr>
<td>Create home directory?</td>
<td>Select <strong>Yes</strong> to create the user’s home directory. Select <strong>No</strong> if the directory already exists. The default is <strong>Yes</strong>.</td>
</tr>
<tr>
<td>Copy template files to home directory?</td>
<td>Select <strong>Yes</strong> to copy standard environment files to the user’s home directory at creation time. The default is <strong>Yes</strong>.</td>
</tr>
</tbody>
</table>

4. Click **Create**.

If **Propagate User** was set to **Yes**, then the progress of adding the user to the machines in the environment is shown.

If a mismatch is detected on a machine, such as a UID already in use, then the change fails and the mismatch is reported.

**About Editing and Deleting Users**

You can edit a user by selecting the user name on the **HPC Users** tab. Unlike creating a user account, very few fields are available for edit. The following list identifies the fields that can be changed:
• Password
• Expiry date
• Minimum days
• Maximum days
• Warning days
• Inactive days
• Force change at next login?

The field descriptions for these options are provided in Table 34.3 on page 196.

You can also delete users individually or in groups by selecting the check box for the user on the HPC Users tab and then clicking Delete Selected Users.

Create a Group

To create a group:

1. Click HPC Management from the toolbar.
2. Click Users and Groups.
3. Select the HPC Groups tab and then click Create a new user. Specify values for the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group name</td>
<td>Specify the name for the group, such as finance or team1.</td>
</tr>
<tr>
<td>Group ID</td>
<td>Select an option:</td>
</tr>
<tr>
<td></td>
<td>Automatic: the operating system will select an unused GID.</td>
</tr>
<tr>
<td></td>
<td>Calculated: (rarely used) the GID is created based on a Berkeley CRC and mkgid.</td>
</tr>
<tr>
<td></td>
<td>Specified: specify the GID to use. By default, this field shows the GID that will be assigned if the Automatic option is used. The default option is Automatic.</td>
</tr>
<tr>
<td>Members</td>
<td>Select users from the list and use the buttons to specify the members of the group.</td>
</tr>
</tbody>
</table>

4. Click Create.

If a mismatch is detected on a machine, such as a GID already in use, then the change fails and the mismatch is reported.
About Editing and Deleting Groups

You can edit a group by selecting the group name on the HPC Groups tab. Users can be added as members of the group. This action sets secondary group membership for the user account.

You cannot delete a group if it is used as the primary group for any user accounts.

Managing User Sessions

Features in User Session Management

The HPC management interface of the SAS High-Performance Computing Management Console enables administrators to monitor and manage user logon sessions. The following features are available to administrators:

• review recent SSH log on activity for one user or all users
• display a list of users currently logged on through SSH
• limit SSH logon actions by performing an SSH lockout

Review Recent SSH Logon Activity

To review recent SSH logon activity:

1. Click HPC Management from the toolbar.
2. Click Users and Groups.
3. Scroll to the bottom of the table of user accounts and then select either All users or Only user. If you select Only user, then enter the user account to review or click the button to select the user account from a list.
4. Click Display Logins By.

The recent logon activity is listed in the Recorded Logins table.

Display 34.3 Recent SSH Logon Activity
The **Login From** field is used to show the IP address or host name that was used for the logon session.

**Show Currently Logged On Users**

To show the users that are currently logged on with SSH:

1. Click **HPC Management** from the toolbar.
2. Click **Users and Groups**.
3. Scroll to the bottom of the table of user accounts and click **Show Logged In Users**.

The currently logged on users are listed **Logged In Users** table. You can select the user name to review the recent SSH logon activity for the user account.

**Display 34.4  Logged In Users**

The **Logged in from** field is used to show the IP address or host name that was used for the logon session.

---

**Perform an SSH Lockout**

**Understanding the SSH Lockout Feature**

The SSH Lockout module enables an administrator to limit SSH logon access to the environment. This feature provides a mechanism for ensuring that processing resources are available for high-priority tasks as well as to assist with managing scheduled maintenance. Be aware that existing SSH logons are not affected by a lockout. A lockout prevents new SSH logons only. Access to software that does not rely on SSH is unaffected.

The feature provides user-level controls for denying SSH logons broadly while permitting SSH logons from specific user accounts. This level of control is available
based on how you set the lockout controls. The following figure shows the fields that are available on the **Lockout Whitelist** tab.

*Display 34.5  SSH Lockout*

The following table provides a description for each of the fields on the **Lockout Whitelist** tab and describes how the settings interact with each other. The lockout status is not changed until the **Commit** button is clicked.

*Table 34.5  Lockout Whitelist Field Descriptions*

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Lockout Status</strong></td>
<td>This field shows the current lockout status and is used to set the lockout status:</td>
</tr>
</tbody>
</table>
|                  | **Enabled**  
only the user accounts listed in the **Admin Users** and **Regular Users** are permitted SSH logon access.                                |
|                  | **Disabled**  
all users, except the users listed in the **Disabled Users** are permitted SSH logon access.                                              |
|                  | **Note:**  
User accounts in the **Disabled Users** are denied SSH logon access at all times.                                                      |
| **Admin Users**  | Specifies the user accounts that are permitted SSH logon access when the lockout is active.                                             |
Perform an SSH Lockout

To perform an SSH lockout:

1. Click HPC Management from the toolbar.
2. Click SSH Lockout.
4. Review the Admin Users, Regular Users, and Disabled Users lists.
   For information about the lists, see Table 34.5 on page 202.
5. Click Commit.

To disable an SSH lockout, set the Lockout Status to Disabled and then click Commit.
Chapter 35
Gridhosts File Management

What Is the Gridhosts File?

Identifying all the machines in the environment is critical to ensuring that the SAS High-Performance Computing Management Console can perform operations in parallel or serially on the machines in the grid. The /etc/gridhosts file is used to identify the machines. It is a list of the machines, with one host name on each line. The /etc/gridhosts file is not the same as the /etc/hosts file.

The /etc/gridhosts file is created immediately after installing SAS High-Performance Computing Management Console. If the /etc/gridhosts file has not been created already, then follow the steps described in “Creating the File” on page 205. The console is also used to manage the host names that are listed in the file. The following sections provide more detail.

Managing the Gridhosts File

Creating the File

The contents of the file (host names) are typically created in a text editor or with shell scripting to avoid repetitive typing. If the file is not present on the machine that is
hosting the console, then the following page is seen after accessing the Gridhosts File Management module of the console.

**Display 35.1** Generate Gridhosts File

![Image of Gridhosts File Management interface]

*Note:* The **Use /etc/hosts** button cannot be used in a SAS Visual Analytics deployment to create the `/etc/gridhosts` file.

If you can access the file, then you can upload it to the machine that is hosting the console. To upload a file:

1. Click **Upload a file**.
2. Click **Browse** and then navigate to the file that contains the host name of the machines in the grid.
   
   Click **Upload**.
3. Review the host names that are listed in the table. Click **Select all** at the top of the table if the list of host names is accurate. Click **Submit**.

After the **Submit** button is clicked, the `/etc/gridhosts` file is created on the machine that is hosting the console.
**Editing Host Names in the Gridhosts File**

You can use the console to add and delete host names from the `/etc/gridhosts` file. The following display shows the link for adding host names and the button for deleting them.

Display 35.2  Gridhosts File

To add a host name:
1. Click **Add Host**.
2. Enter the host name in the **Hostname** field and click **Add**.

   *Note:* The console does not check to make sure that the specified machine is reachable.

To delete a host name:
1. Select the check box beside the host name to remove.
2. Click **Delete**.
Apache Hadoop
a framework that allows for the distributed processing of large data sets across clusters of computers using a simple programming model.

bar chart
a chart that consists of a grid and some vertical or horizontal columns (bars). Each column represents quantitative data.

box plot
See box-and-whisker plot

box-and-whisker plot
a graphical display of five statistics (the minimum, lower quartile, median, upper quartile, and maximum) that summarize the distribution of a set of data. The lower quartile (25th percentile) is represented by the lower edge of the box, and the upper quartile (75th percentile) is represented by the upper edge of the box. The median (50th percentile) is represented by a central line that divides the box into sections. The extreme values are represented by whiskers that extend out from the edges of the box.

capability
an application feature that is under role-based management. Typically, a capability corresponds to a menu item or button. For example, a Report Creation capability might correspond to a New Report menu item in a reporting application. Capabilities are assigned to roles.

crosstab
See crosstabulation table

crosstabulation table
a two-dimensional table that shows frequency distributions or other aggregate statistics for the intersections of two or more category data items. In a crosstabulation table, categories are displayed on both the columns and rows, and each cell value represents the data result from the intersection of the categories on the specific row and column.

data item
an item in a data source that is either a logical view of a data field or a calculation. The author of a report decides which data items to use in a particular section of a report. There are three types of data items: hierarchies, categories, and measures.
**data source**
A table, view, or file from which you will extract information. Sources can be in any format that SAS can access, on any supported hardware platform. The metadata for a source is typically an input to a job.

**filter**
Specified criteria that are applied to data in order to identify the subset of data for a subsequent operation, such as continued processing.

**heat map**
A graphical representation of data where the values taken by a variable in a two-dimensional map are represented as colors.

**list table**
A two-dimensional representation of data, in which the data values are arranged in rows and columns.

**pie chart**
A circular chart that is divided into slices by radial lines. Each slice represents the relative contribution of each part to the whole.

**progressive chart**
See waterfall chart

**report**
Output that is generated by running custom SAS code against the data in your project.

**role**
A set of capabilities. In some applications, certain actions are available only to users or groups that have a particular role.

**scatter plot**
A two- or three-dimensional plot that shows the joint variation of two (or three) variables from a group of table rows. The coordinates of each point in the plot correspond to the data values for a single table row (observation).

**scatter plot matrix**
A grid of scatter plots showing pairwise combinations of multiple numeric variables.

**source**
See data source

**time series**
An ordered sequence of values of a variable that are observed at equally spaced time intervals.

**treemap**
A graph that represents the relative values of data by using rectangular areas. The color of each area represents the value of one measure in the query. The size of each area represents the value of the another measure in the query. (In SAS/GRAPH a treemap is created with the GTILE procedure.)

**user role**
See role
visual exploration
  a metadata object that contains visualizations and data settings that are saved from a session of the SAS Visual Analytics explorer.

visualization
  an interactive visual representation of data. A visualization can be a table, a chart, or a geographic map.

waterfall chart
  a form of data visualization that is used to understand or explain the cumulative effect on an initial value of sequentially introduced positive or negative values. Usually the initial and the final values are represented by whole columns, while the intermediate values are denoted by floating columns.
## Index

### A
- aggregation, modifying for measures 118
- aggregations 50
- alphanumeric categories 115
- autocharting 65
- automatic charts 65

### B
- bar charts 65, 124
- box plots 74
- bubble plots 71, 128
- bullet gauges 133

### C
- capabilities, access to 5
- category data items 115
- charts
  - See also bar charts
  - dual axis bar charts 129
  - dual axis bar-line charts 130
  - dual axis line charts 129
  - line charts 126
  - pie charts 126
  - targeted bar 125
  - waterfall charts 125
- comments
  - adding in Web viewer 152
  - connecting to library server for mobile viewer 149
  - correlation matrix 79
  - creating reports 111
  - crosstabs 122

### D
- data formats 50
- data items
  - See also standard data items
  - category data items 115
  - data items in queries 115
  - measure data items 116
  - modifying format 117
  - modifying role 117
  - queries based on 115
  - renaming 117
  - selecting 116
- data properties 50
- data sources
  - modifying measure aggregation 118
- date categories 115
- deleting
  - report sections 146
- designer interface 103
  - an example report 109
  - gauges 133
  - graphs 124
  - Open dialog box 105
  - opening reports 109
  - Search dialog box 106
  - tables 122
  - tables, graphs, and gauges 121
- dial gauges 133
- display rule
  - gauges 136
- dual axis bar chart 129
- dual axis bar-line charts 130
- dual axis line chart 129
- dual axis time series plot 130

### E
- exporting code
  - permissions 22

### F
- files, searching for 106
- filtering
  - continuous data 83
  - discrete data 82
in Select Data wizard 46
filters 81, 139
creating 82
Edit Filter dialog box 83
folders
in Open dialog box 105
formats
modifying for data items 117

removing data brushing 143
removing filtering 143
interface 9

joining tables
inner join 28

line charts 67, 126
list tables 122
logging off 6
logging on 5

measuring data items 116
measures
modifying aggregation of 118
missing values, excluding 83
mobile devices
blacklisting 171
managing 171
sorting 171
viewing 171
mobile viewer 149
connecting to library server 149
opening the app 149
modifying role
data items 117

object inspector 15
adding comments 16
discovering details 15
Open dialog box 105
folders in 105
opening
reports 109
opening the mobile viewer 149

passwords 6
pie charts 126
plots
bubble plots 128
dual axis time series plots 130
scatter plots 127
time series plots 127
preferences 12
general 13
global for all SAS applications 12
Index  215

initial page 14
process monitoring 169
resource utilization 169
properties
  gauges 135
  graphs 131
  tables 123

Q
queries
  based on data items 115
  data items in 115
query results
  displaying in tables 122

R
renaming
  data items 117
  report sections 146
report sections 145
  adding 145
  deleting 146
  renaming 146
reports
  adding comments 16
  adding sections 145
  an example 109
  basing on existing report 112
  creating 111
  deleting sections 146
  importing 112
  inserting gauges 135
  inserting graphs 131
  inserting tables 123
  naming 113
  opening 109
  replying to comments 16
  saving 113
  viewing in the Web viewer 151
resource utilization
  by process 169
  monitoring 167
results
  displaying in graphs 124
  roles 5

S
SAS statements
  logging 23
SAS Visual Analytics 3
  access to capabilities 5
  benefits of 3
  home page 9
how it works 4
logging off 6
logging on 5
preferences 12
roles 5
  Web viewer 151
saved reports 109
saving reports 113
scatter plots 70, 127
Search dialog box 106
searching
  for descriptions 106
  for files 106
  for keywords 106
  for report names 106
security
  limit logon access 201
  select data items 116
Server configuration files 35
Server run time 35
slider gauges 133
speedometer gauges 133
SSH keys 195
  generating and propagating 198
SSH lockout 201, 203
standard data items 201, 203
styles
  gauges 136
  graphs 132
  tables 124

T
table types 122
tables 69
  See also crosstabs
    inserting query results in 122
    inserting into a report 123
    list tables 122
    properties 123
    styles 124
targeted bar chart 125
thermometer gauges 133
time categories 115
time series plot 127
timestamp categories 115
treemaps 128
troubleshooting
  HDFS content explorer 158
  Process monitor 169
  Resource monitor 168

U
UNIX groups
  creating 199
members 200
UNIX user accounts
  creating 196
  deleting 199
  secondary group membership 200
user interface 9
user management
  audit SSH logon activity 200
  creating users 196
  deleting users 199
  group membership 200
  prevent SSH logons 201
  show logged on users 201

V
visual filters 82

visualizations 56
  arranging 61
  creating 60
  managing 60
  overview 56
  types of 56

W
waterfall charts 125
Web viewer
  adding comments 152
  opening reports 151
  overview 151