SAS® 9.3
ODS Graphics Editor
User’s Guide
Contents

What's New in the SAS 9.3 ODS Graphics Editor ........................................... vii

PART 1  Introduction to the ODS Graphics Editor  1

Chapter 1 • Overview of the ODS Graphics Editor ........................................ 3
  What Is the SAS ODS Graphics Editor? ....................................................... 3
  Why Use the ODS Graphics Editor? ......................................................... 3
  Key Features of the ODS Graphics Editor .................................................. 4
  Types of Files That Can Be Edited ........................................................... 4
  Components of a Graph .............................................................................. 5
  General Editing and Annotation Concepts .................................................. 6
  Use of Locale ............................................................................................... 6

Chapter 2 • Getting Started with the ODS Graphics Editor ............................. 7
  Using a Stand-Alone ODS Graphics Editor ................................................. 7
  Creating Editable Graphics ......................................................................... 8
  Open an ODS Graph for Editing ................................................................ 9
  About SGE Files Generated on z/OS Systems ............................................. 9
  About the Graph Toolbar .......................................................................... 10
  Save Graph Output ...................................................................................... 11
  Print Graph Output .................................................................................... 11
  Copy and Paste a Graph ............................................................................ 12
  Create a New Blank Window ...................................................................... 12

PART 2  Editing Graphs  13

Chapter 3 • Modifying General Graph Properties .......................................... 15
  Specify a Style for a Graph ........................................................................ 15
  Resize a Graph .......................................................................................... 16
  Change the Background Color of a Graph .................................................. 17

Chapter 4 • Working with Titles and Footnotes .............................................. 19
  About Titles and Footnotes ....................................................................... 19
  Add a Title or Footnote to a Graph ........................................................... 19
  Edit or Format a Title or Footnote ............................................................ 20
  Using the Formatting Toolbar .................................................................... 21
  Using the Color List Box .......................................................................... 22
  Aligning a Title or Footnote in a Graph ..................................................... 23
  Move a Title or Footnote in a Graph ......................................................... 24
  Delete a Title or Footnote from a Graph .................................................... 25
  Use of Alternate Short Text in Graph Elements ....................................... 25

Chapter 5 • Working with Legends .................................................................. 27
  Add or Edit a Legend Title ......................................................................... 27
  Change the Outline and Background Color of a Legend ............................ 27
Chapter 6 • Modifying Plot and Axis Properties ........................................... 31
  Working with Plot Properties ......................................................... 31
  Working with Axis Properties .......................................................... 36
  Working with Axis Labels ............................................................... 36
  Edit an Existing Axis Label .............................................................. 37
  Add an Axis Label ........................................................................... 37
  Show or Hide an Axis Label ............................................................... 37
  Delete an Axis Label ........................................................................ 38

Chapter 7 • Working with Data Labels and Multi-Cell Graphs ...................... 39
  Display or Hide Data Labels ............................................................... 39
  Working with Multi-Cell Graphs ........................................................ 40

PART 3  Annotating Graphs  43

Chapter 8 • Annotation Overview .......................................................... 45
  About Annotation Objects .................................................................... 45
  Understanding Annotation Objects and Data ....................................... 45
  Data Attachment Examples for Annotations ...................................... 47
  Change the Data Attachment Properties of an Annotation .................. 57

Chapter 9 • Using Annotations in a Graph .............................................. 61
  About Text Annotations ....................................................................... 61
  Add a Text Annotation to a Graph .................................................... 62
  Edit a Text Annotation ....................................................................... 62
  About Lines and Arrows ..................................................................... 62
  Add a Line to a Graph ........................................................................ 63
  Add an Arrow to a Graph .................................................................... 63
  About Ovals and Rectangles .............................................................. 64
  Add an Oval to a Graph ...................................................................... 65
  Add a Rectangle to a Graph ............................................................... 65
  About Markers .................................................................................. 65
  Add a Marker to a Graph .................................................................... 66
  About Images .................................................................................... 66
  Add and Position an Image in a Graph ............................................... 67

Chapter 10 • Changing the Visual Properties of Annotations ....................... 69
  Format a Text Annotation .................................................................... 69
  Change the Color, Pattern, and Thickness of a Line or Arrow ............... 69
  Change the Color, Transparency, and Outline Properties of an Oval or Rectangle ................................................................. 70
  Change the Color, Symbol, and Size of a Marker .................................. 71
  Format an Outline Around an Image .................................................... 72

Chapter 11 • Adding Text to Annotations ................................................ 75
  Overview of Adding Text to Annotations ............................................ 75
  Add Text to an Annotation ................................................................... 75
  Edit Text That Has Been Added to an Annotation ............................... 76
  Format Text That Has Been Added to an Annotation ......................... 76
  Move Text That Has Been Added to an Annotation .............................. 77

Chapter 12 • Modifying Annotations ....................................................... 79
  Resize an Annotation .......................................................................... 79
<table>
<thead>
<tr>
<th>Rotate an Annotation</th>
<th>81</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move an Annotation</td>
<td>83</td>
</tr>
<tr>
<td>Copy and Paste an Annotation Object</td>
<td>83</td>
</tr>
<tr>
<td>Delete an Annotation</td>
<td>84</td>
</tr>
<tr>
<td>Working with Groups of Annotation Objects</td>
<td>84</td>
</tr>
<tr>
<td>Change the Order of Annotation Objects</td>
<td>84</td>
</tr>
<tr>
<td>Align Multiple Annotation Objects</td>
<td>85</td>
</tr>
</tbody>
</table>

**PART 4  Examples  87**

**Chapter 13 • Editing and Annotating a Simple Graph by Example** 89
- About the Simple Graph 89
- Code for the Simple Graph Example 90
- Editing the Graph 90
- Annotating the Graph 93

**Chapter 14 • Showing and Hiding Labels By Example** 97
- About the Linear Regression for Sports Cars Example 97
- Code for the Linear Regression Example 98
- Show and Hide Labels 99

**Chapter 15 • Modifying a Multi-Cell Graph By Example** 101
- Modifying a Multi-Cell Graph That Uses a Single Data Set 101
- Modifying Individual Plots in a Diagnostic Panel 104

**Chapter 16 • Editing and Annotating a SAS/STAT Graph By Example** 109
- About the Economy Growth Example 109
- Code for the Economy Example 110
- Editing the Graph 112
- Adding Annotations to Highlight Outlier Data 114
- Preparing The Graph for Presentation 115
- Viewing and Saving the Results of Your Changes 116

**Glossary** 119

**Index** 121
What's New in the SAS 9.3 ODS Graphics Editor

Overview

The ODS Graphics Editor has the following changes and enhancements:

- inclusion with Base SAS
- stand-alone editor is no longer required
- ODS enhancements
- enhancements for editing a graph
- additional rendering option for SGE files

Editor Is Included with Base SAS

The ODS Graphics Editor is now available with Base SAS software. SAS/GRAPH software is not required in order to use the editor. The documentation has also moved to the Base SAS node in SAS Help and Documentation.

Stand-Alone Editor Is No Longer Required

In previous releases on Windows and Linux operating systems, you had to install the stand-alone editor even when you invoked the editor from SAS. You could not open ODS Graphics Editor SGE files without the stand-alone editor.

Starting with the 9.3 release, the stand-alone editor is no longer required to open SGE files from SAS. However, the stand-alone editor is still available. You would install the stand-alone editor when you need to open SGE files but do not have SAS installed on the system.

ODS Changes and Enhancements

The editor supports a new ODS style: HTMLBlueCML (Color, Marker, Line).
In Windows and UNIX operating environments, when editable graphs are created in the SAS Windowing environment, the default ODS behavior has changed as follows:

- HTML is the default ODS destination. If you close the HTML destination and do not open another destination, then no destinations are open.
- HTMLBlue is the default style for the ODS HTML destination. ODS Graphics Editor (SGE) files that were created with the HTML destination appear different from those that were created with the previous release of SAS.

The editor does not support the HTMLBlue style, but instead supports the similar HTMLBlueCML style. To produce the same output as HTMLBlue in the editor, specify the HTMLBlueCML style, and then change the line style or markers as appropriate.


---

**Enhancements for Editing a Graph**

The following enhancements apply to editing a graph:

- You can edit any GTL annotations (DRAW statements) that are part of the graph as well as annotations that were created with the ODS Graphics procedures.
- As with single-cell graphs, the editor supports edits to secondary axes for graphs with a layout of Datalattice, Datapanel, and Lattice. The secondary axes are now independent from the primary axes for these multi-cell graphs.
- You can select **File ➔ New** to create a blank page. You can then add annotations to the page.

---

**Additional Rendering Option for SGE Files**

SGE files can be rendered to any ODS destination using the SGRENDER procedure. This enables you to render your edited and annotated graphs in a vector graphics format. You can render graphs on platforms, such as z/OS, that do not support running the editor. For more information, see *SAS ODS Graphics: Procedures Guide*. 
Part 1

Introduction to the ODS Graphics Editor

Chapter 1
Overview of the ODS Graphics Editor ......................... 3

Chapter 2
Getting Started with the ODS Graphics Editor ................. 7
Chapter 1
Overview of the ODS Graphics Editor

What Is the SAS ODS Graphics Editor?

The SAS ODS Graphics Editor is a complementary tool in the ODS graphics system. It is an interactive graphical application used to edit and annotate ODS graphics that are created by a wide variety of SAS procedures. You can save the results as an image for inclusion in a report or as an SGE file that you can edit in the future.

Note: SGE files can be rendered to any ODS destination on any platform using the SGRENDER procedure. For more information, see *SAS ODS Graphics: Procedures Guide*.

You can launch the editor from a SAS session. When you edit a graph from the Results window in SAS, changes that you make do not affect the original graph in the Results window.

On Windows and Linux operating systems, you can also download a stand-alone version of the ODS Graphics Editor that runs apart from SAS.

Why Use the ODS Graphics Editor?

Many SAS analytical procedures now produce graphical output automatically using the ODS Graphics system. These graphics are produced using predefined templates that are shipped with SAS. The templates define the structure of the graph, including the plots, titles, footnotes, legends, and other attributes of the graph. You can customize the output graphs by editing the predefined template. However, such customization requires
detailed knowledge of the Template procedure and the Graph Template Language (GTL).

You might want to make small changes to a graph without having to work with templates and GTL. For example, you might want to add, edit, or remove a title or a footnote. Or, you might want to change the size, shape, and color of graphical elements such as the markers and lines. The ODS Graphics Editor provides a graphical user interface for making these changes easily without knowing the details of templates and GTL.

The ODS Graphics Editor enables you to edit the various elements in the output graph while keeping the underlying data unchanged. In addition, you can annotate a graph by inserting text, lines, arrows, images, and other items in a layer above the graph. You can save the results of your customization as an ODS Graphics Editor (SGE) file and make incremental changes to the file. You can also save the results as a Portable Network Graphics (PNG) image file for inclusion in other documents.

---

Key Features of the ODS Graphics Editor

Here are some of the tasks that you can perform with the ODS Graphics Editor:

- add, delete, or modify title and footnotes. You can add special symbols, superscripts, and subscripts to titles and footnotes.
- change the visual appearance of the entire graph by changing the applied style.
- edit axis labels and legend titles.
- resize the graph.
- change the appearance of individual plot elements such as markers and lines.
- show or hide data labels for selected data points in order to reduce clutter.
- add annotation such as text, lines, circles, images, and markers.
- copy the resulting graph to the system clipboard.

---

Types of Files That Can Be Edited

You can edit the following types of files:

- ODS Graphics Editor (SGE) files. You can edit SGE files from the SAS Results window or by opening the SGE file in the editor.

  In this file format, all of the graphical elements (titles, footnotes, and so on) are available for individual editing. You can edit any GTL annotations (DRAW statements) that are part of the graph as well as annotations that were created with the ODS Graphics procedures. Finally, you can add annotations on top of the graph.

- Image files in PNG format.

  In this file format, all of the graph elements, including annotations, are flattened into an image and cannot be edited. However, you can add new annotations on top of the image.
Components of a Graph

The ODS Graphics output is called a graph. In general, a graph is made up of the following parts:

- titles and footnotes
- one or more cells that contain a composite of one or more plots
- legends, which can reside inside or outside the cell or plot

The following figure shows the different parts of a graph:

Figure 1.1 Components of a Graph
General Editing and Annotation Concepts

You can edit and annotate graphs. Editing and annotating tasks differ from each other in the following ways:

• When you edit a graph, you edit elements of the graph such as the title, footnote, or legend.

  You can also change the visual characteristics of the plots, such as the colors of markers and lines. You can change the style applied to a graph, and you can resize the graph.

  Some of these edits can cause the layout of the graph to change.

• When you annotate a graph, you add objects on top of the original graph. You can add text, lines, arrows, ovals, rectangles, images, and markers. Annotation objects are rendered in a separate layer on top of the graphical elements and do not cause any changes to the layout of the graph.

  Annotation objects can be attached to graph data so that, if the graph is resized, the annotations move with the data. For more information, “Understanding Annotation Objects and Data” on page 45.

• You can edit Graph Template Language (GTL) annotations (DRAW statements) that are part of the original graph, as well as annotations that were created with the ODS Graphics procedures. These edits do not cause any changes to the layout of the graph.

Use of Locale

The ODS Graphics Editor uses the system locale, but the graph itself uses the SAS locale. For example, if the axis label is present, the label is shown in the language that SAS uses.
Chapter 2
Getting Started with the ODS Graphics Editor

Using a Stand-Alone ODS Graphics Editor

Download and Install the Stand-Alone ODS Graphics Editor ........................................... 7
Start the Stand-Alone ODS Graphics Editor ................................................................. 8

Creating Editable Graphics ................................................................................................. 8
Open an ODS Graph for Editing ......................................................................................... 9
About SGE Files Generated on z/OS Systems ................................................................. 9
About the Graph Toolbar .................................................................................................. 10
Save Graph Output ............................................................................................................. 11
Print Graph Output ............................................................................................................ 11
Copy and Paste a Graph ..................................................................................................... 12
Create a New Blank Window ............................................................................................. 12

Using a Stand-Alone ODS Graphics Editor

Download and Install the Stand-Alone ODS Graphics Editor

On Windows and Linux operating systems, you can run the ODS Graphics Editor as a
stand-alone product without invoking SAS. You can download the stand-alone editor for
free from SAS.

To download the stand-alone ODS Graphics Editor:

1. Go to the Base SAS download site:


2. Click the ODS Graphics Editor from the list. The ODS Graphics Editor Download
   Packages page appears.

3. View the README file for the appropriate platform. You might print the file so that
   you can refer to it later.

   Note: Verify that you have the correct Java Runtime Environment installed, as
   specified in the README file.

4. Select Request Download.
5. Read the license agreement and then click **I Accept**. The Download page appears.

6. Click the **Download** button next to the file that you want to download. The compressed file is downloaded to your system.

7. Follow the instructions in the README file to unpack the files, start the SAS Deployment Wizard, and install the editor.

---

**Start the Stand-Alone ODS Graphics Editor**

On a Windows system, start the editor from the Windows **Start** menu.

To start the editor on Linux systems, follow the instructions in the editor's README file.

After you start the editor, you can select **File ⇒ Open** from the main menu and select an SGE file that you want to edit.

---

**Creating Editable Graphics**

You must create editable graph output before you can use the ODS Graphics Editor to edit the graph output. You can create editable graph output with a wide variety of SAS procedures.

To enable the creation of an editable graph, do the following in your SAS program:

- Make sure either the LISTING or the HTML ODS destination is open. If both are closed, no editable graph can be produced. Both can be open. Other destinations can be open as well.
- Add the SGE=ON option to the ODS destination statement.

Here is the general form of the SGE option:

\[
\text{sge = on|off|yes|no}
\]

Here is an example of its usage in an ODS LISTING statement:

\[
\text{ods listing sge = on;}
\]

- If needed, activate the ODS Graphics environment with the ODS GRAPHICS ON statement. This is not required for the SAS ODS Graphics procedures (SGDESIGN, SGPLOT, SGPANEL, SGSCATTER, or SGRENDER). In addition, SAS procedures that support ODS produce ODS Graphics output by default when they are executed in the SAS Windowing Environment.

For more information, see “Procedures That Support ODS Graphics” in *SAS/STAT 9.3 User’s Guide*.

When you execute the SAS program, SAS creates an ODS Graphics Editor (SGE) file along with the graph image file. You can then open the SGE file from the Results window. For details, see “Open an ODS Graph for Editing” on page 9.

**Note:** You cannot open an SGE file on z/OS systems. For more information, see “About SGE Files Generated on z/OS Systems” on page 9.

If you later change and rerun the SAS program, SAS creates a new SGE file. The original SGE file remains in the SAS Results window.
You can create editable graphs for multiple ODS destinations. Each editable graph has a unique name based on the name of the corresponding PNG file. For example, if you specify SGE=ON for the LISTING, PDF, and HTML destinations, your editable graphs would have names such as SGPlot.sge, SGPlot_PDF.sge, and SGPlot_HTML.sge.

To disable the creation of editable graphs, add the SGE=OFF option to the ODS destination. For example, you might submit the following code in your program:

```ods listing sge = off;```

Alternatively, you can close and then reopen the ODS destination.

---

**Open an ODS Graph for Editing**

From the SAS Results window, you can open an editable graph that has been created from a SAS program. For more information about editable graphs, see “Creating Editable Graphics” on page 8.

*Note:* You cannot edit an ODS graph on z/OS systems.

To open an editable graph from the SAS Results window:

1. Click the expansion icon in the SAS Results window to expand the list of graphs that you created.

2. Double-click the SGE file, which is identified by the icon.

   The ODS Graphics Editor opens and displays the graph for editing. You can now edit the graph using the various interactive tools.

Once the ODS Graphics Editor is open, you can open an editable graph by selecting **File** ⇒ **Open** from the main menu.

You can open and edit any SGE graph file. See “Types of Files That Can Be Edited” on page 4. This includes SGE files that were created on z/OS systems, which do not support running the ODS Graphics Editor. For more information, see “About SGE Files Generated on z/OS Systems” on page 9.

You can also select **File** ⇒ **New** to create a blank window. You can then add annotations to the window.

---

**About SGE Files Generated on z/OS Systems**

The ODS Graphics Editor is a graphical application and, therefore, does not run on z/OS systems. You cannot edit graphs on z/OS, either from the SAS Results window or in the stand-alone editor. However, you can generate SGE files on z/OS, and then move the files to another system on which you can run the editor (Windows, Linux, or UNIX). Then you can start the editor and edit the SGE files that you moved. For more information about generating SGE files, see “Creating Editable Graphics” on page 8.

When you generate SGE files on z/OS, SAS always writes the SGE files to the UNIX file system (UFS). The z/OS `FILESYSTEM=` setting is ignored for writing SGE files. You must be authorized to create UFS files in your environment in order to generate the SGE files.
About the Graph Toolbar

In addition to the Standard and Formatting toolbars that are commonly used in applications, the ODS Graphics Editor has a Graph toolbar. The Graph toolbar contains icons that you can click to select graph objects or to insert items into a graph. (In addition to using the toolbar, you can also insert items by selecting them from the Insert menu.)

The following display shows the Graph toolbar:

To display the Graph toolbar, select View ⇒ Toolbars ⇒ Graph from the main menu. Be sure Graph is checked.

You can use the following editing icons to edit your graph:

- adds a title field to an ODS graph in which you can write a title. Selecting this icon again adds another title.
- adds a footnote field to an ODS graph in which you can write a footnote. Selecting this icon again adds another footnote.

You can use the following selection icons:

- enables you to select data and then show or hide labels for the selected data. This icon is available only when the graph contains labels.
- enables you to select an object on your graph for editing.

You can use the following annotation icons to annotate your graph:

- enables you to draw a text box on your graph, to which you can add text.
- enables you to draw a line on your graph.
- enables you to draw an arrow on your graph.
- enables you to draw a rectangle or a square on your graph.
- enables you to draw an oval or a circle on your graph.
- enables you to select an image to insert into the graph.
places a marker at a place that you select on your graph. As shown here, the current marker setting displays as a star. The icon in your operating environment might be different.

---

**Save Graph Output**

To save graph output:

1. Select **File** ⇒ **Save As** from the menu.

2. Select the directory where you want the graph to be saved. The default location is the current directory for the SAS program that generated the SGE file.

3. Select the type of file to save.
   - If you save the file in SGE format, then you can later reopen and edit the file.
   - If you save the file in PNG format, then the graph is saved as a flat image. The graph in this format cannot be edited, though it can be annotated.

   You can change the resolution by modifying the dots per inches (DPI). Changing the DPI affects only the image. The actual graph continues to display with 100 DPI.

   If you specify a DPI larger than 100, the graph image is resized. Any annotation that is not attached to the data retains its original position after the layout changes. For an example that illustrates this behavior, see “Example: Annotation Positioned Over a Legend in a Graph That Is Resized” on page 55. (For more information about attachment to data, see “Understanding Annotation Objects and Data” on page 45.)

   The maximum value that you can specify is 300 DPI. If you want to obtain a higher resolution, you can render the SGE file using the SGRENDER procedure and specify a DPI value in an ODS statement. For more information about the SGRENDER procedure, see *SAS ODS Graphics: Procedures Guide*.

4. Enter the name of the graph in the **File name** field.

5. Click **Save**.

The Save operation does not affect the graph output in the Results window in SAS.

---

**Print Graph Output**

You can print SGE and PNG files from the ODS Graphics Editor. You can also include a PNG file in a PDF document and then print the PDF document.

To print a graph from the ODS Graphics Editor:

1. Select **File** ⇒ **Print** from the menu.

2. Select print options from the Print window.

3. Click **OK**.
You can select **File ⇒ Print Preview** to preview your graph before you print it.

---

**Copy and Paste a Graph**

Graph output can be copied to the system clipboard to use in another document.

To copy and paste a graph:

1. Open the graph that you want to copy.
2. Select **Edit ⇒ Copy View** from the main menu.

You can paste the graph into the target application using that application's paste command.

---

**Create a New Blank Window**

You can select **File ⇒ New** to create a blank window. You can then add annotations to the window.
Part 2

Editing Graphs

Chapter 3
  Modifying General Graph Properties .................................. 15

Chapter 4
  Working with Titles and Footnotes ...................................... 19

Chapter 5
  Working with Legends ...................................................... 27

Chapter 6
  Modifying Plot and Axis Properties .................................... 31

Chapter 7
  Working with Data Labels and Multi-Cell Graphs .................. 39
Specify a Style for a Graph

Styles control the overall visual appearance of graphs. Styles specify colors, fonts, line styles, and other attributes of graph elements. You can change the appearance of your graph by selecting one of the styles that are provided. For example, you can change the style of a graph from the Default style to the Journal style if the graph is intended for gray-scale publications.

By default, graph SGE files use the active ODS destination style that is specified in the SAS program. For example, you can specify the Analysis style using the following statement in the program:

```sas
ods listing sge=on style=Analysis;
```

To select a style:

1. With your graph displayed, select **Format ⇒ Style** from the main menu.
2. From the cascading menu, select a graph style.

You can select one of the following styles:

- **Analysis**: a color style recommended for output in Web pages or for color print media. This style might not display well in gray-scale output.
- **Default**: a color style intended for general-purpose work. This style is designed to discriminate among groups in both color and gray-scale output.
- **HTMLBlueCML**: a color style recommended for output in Web pages or for color print media. This style has a white background and has been optimized for HTML output.
- **Journal**: a gray-scale style recommended for journal articles and other publications that are printed in gray scale.
Listing
is similar to Default but has a white background. This style is used by SAS for listing output.

Statistical
is a color style recommended for output in Web pages or for color print media. This style might not display well on devices that produce gray-scale output.

StatGraphScheme
is the default style for all SGE files. This style inherits attributes from the style that was used when the graph was created.

Various elements of the graph derive their visual attributes, such as color, from specific style elements. Individual property settings override the style elements. For example, if you have assigned an overriding color to an object in the graph, then selecting a different style retains the overriding value that has been assigned.

Resize a Graph

When you resize a graph, you can then print or save the graph in its new size.

If you resize a graph and there is not enough space to display entire titles, footnotes, or axis labels, then an alternate short label is displayed. For details, see “Use of Alternate Short Text in Graph Elements” on page 25.

To resize a graph:
1. Select Format ➔ Graph Properties. The Graph Properties dialog box appears.

You can also right-click anywhere in the graph and select Graph Properties from the menu.

2. In the Size section of the dialog box, click the up and down arrows in the Width and Height fields. The width and height are measured in inches. Clicking an arrow changes the value by 0.01 inch (which is equivalent to one pixel). Your graph becomes larger or smaller depending on which values you select.

Alternatively, you can type the values in the fields.
3. Click OK.

Note: You can also enlarge or reduce the view of a graph by using the Zoom tool. The Zoom tool does not resize the graph. To zoom in or out, select View ⇒ Zoom from the menu, and then select the zoom value that you want.

---

**Change the Background Color of a Graph**

To change the background color of a graph:

1. Select Format ⇒ Graph Properties. The Graph Properties dialog box appears.

   ![Graph Properties dialog box]

You can also right-click anywhere in the graph and select Graph Properties from the menu.

2. In the Background section, select a color from the Fill list box. For details about setting the color, see “Using the Color List Box” on page 22.

   The outside of the plot area changes to the color that you selected.

   Note: The value of Auto indicates that the background color is from the original graph.

3. Check or clear the Outline check box to turn the graph border on or off.

4. Click OK.
Chapter 4
Working with Titles and Footnotes

About Titles and Footnotes

You can add multiple titles and footnotes to a graph. The limit to the number of titles or footnotes that you can add depends on the size of your graph. As you add more titles or footnotes, the Y axis of the graph shrinks proportionally to the point where the graph is no longer visible.

When you add a long title or footnote to a graph, the text automatically wraps to the next line. If you move a title or footnote to a different location in the graph, all of the lines of a single title or footnote move as one unit.

Both titles and footnotes support rich text editing.

Note: In addition to titles and footnotes, some graphs might have been created with other text entries. You can edit any text entry that was defined as editable in the graph.

Add a Title or Footnote to a Graph

To add a title or footnote to a graph:
1. Select one of the following options:
   - To add a title, select Insert \( \Rightarrow \) Title. Alternatively, click the Title icon in the Graph toolbar. The Insert Title text box displays at the top of the graph.
   - To add a footnote, select Insert \( \Rightarrow \) Footnote. Alternatively, click the Footnote icon in the Graph toolbar. The Insert Footnote text box displays at the bottom of the graph.

2. Enter your text in the text box. A title or footnote cannot exceed 256 characters.

3. (Optional) Repeat the previous steps to add another title or footnote. For more information about adding multiple titles and footnotes, see “About Titles and Footnotes” on page 19.

To format the text, see “Edit or Format a Title or Footnote” on page 20.

### Edit or Format a Title or Footnote

When you edit a title or footnote, you can change the text and the font properties. You can also use subscript or superscript values, and you can enter Unicode characters.

*Note:* Once you edit a title or footnote, then the alternate short text is not used. See “Use of Alternate Short Text in Graph Elements” on page 25.

To change a title or footnote:
1. Right-click the title or footnote that you want to change.
3. Select all or part of the text in the Text box and enter your changes.

4. You can format the selected text in the following ways:
   - Select a different font from the font list box
   - Select a different font size from the size list box
   - Click a button to make the text boldface or italic.
   - Select a different font color from the color list box. For details, see “Using the Color List Box” on page 22.
   - Click a button to change the text to superscript or subscript.
   - In the Insert Characters From section of the dialog box, select a character to insert it in your text. You can change the displayed characters by picking a different selection from the list box.

5. Click OK.

As an alternative to this procedure, you can double-click the title or footnote and type the new text. You can also change the font characteristics by using the Formatting toolbar. For details, see “Using the Formatting Toolbar” on page 21.

---

Using the Formatting Toolbar

The Formatting toolbar is active only if you have text selected in your graph. The text element that you select might be a title, footnote, an axis label, an annotation object, or a legend.

The following display shows the Formatting toolbar:

To display the Formatting toolbar, select View ⇒ Toolbars from the main menu. Make sure that the Formatting toolbar is checked.

The Formatting toolbar enables you to format the text in the following ways:
   - Select a different font from the font list box
   - Select a different font size from the size list box
   - Click a button to make the text boldface or italic.
   - Click an alignment button to change the text alignment (left-aligned, centered, right-aligned).
   - Select a different font color from the color list box. For details, see “Using the Color List Box” on page 22.
Using the Color List Box

When you specify different graph, plot, or annotation properties, you might have the option to select a color from a color list box. The color list box contains predefined colors to choose from and the option to define your own color. You can also pick an existing color from the graph.

The color list box contains the following items:

Auto
   Restore the default color. This field is useful when you have changed a color and want to restore the original color.

Palette of colors
   Select a predefined color from the palette.

Row of recently used custom colors
   Select a custom color. This row is populated with colors that you choose by using either the More Colors or the Pick color from graph option.

More colors
   Locate a custom color. This option opens the More Colors dialog box, which contains two tabs:
In the **Swatches** tab, select a color from the palette.

In the **Custom** tab, choose a color by dragging the slider and then picking a point in the color preview box. Alternatively, you can specify the HSB, RGB, or hexadecimal color value.

Pick color from graph
After you click this link, the color list box closes. You can then select any of the colors currently displayed in the graph by clicking the desired color.

### Aligning a Title or Footnote in a Graph

#### Alignment of Titles and Footnotes

You can left-align, right-align, or center titles or footnotes in a graph. If you have multiple titles or footnotes in a graph, each title or footnote can have a different alignment.

Titles and footnotes can have multiple lines. When this occurs, the text wraps to the next line. If you change the alignment for this type of title or footnote, all of the lines that belong to the title or footnote move together as a whole.

Graphs that SAS produces can have one-part, two-part, or three-part titles or footnotes. Each part can occupy one of the alignment positions in the graph. You can change the alignment of a one-part title or footnote. For a two-part title or footnote, you can change either of the parts, one at a time. A three-part title or footnote occupies all three alignment positions in the graph, and no alignment changes are possible.

The following figure contains a three-part title.
Align a Title or Footnote

To change the alignment of a title or footnote:

1. Right-click the title or footnote that you want to align. For a two-part title or footnote, right-click the part that you want to align.

2. Select Align from the pop-up menu, and then select an alignment option.

   The title or footnote immediately moves to the area that you selected.

Alternatively, you can click the title or footnote that you want to align (or a part of a two-part title or footnote). Then select one of the alignment buttons in the Formatting toolbar.

Move a Title or Footnote in a Graph

If you have multiple titles or footnotes in a graph, you can move a title or footnote up or down to reposition it. For example, the second title can be moved to become the first title, or the fifth footnote can be moved to become the second footnote.

If you have a single title or footnote, the alignment choices are dimmed.

To move a title or footnote in a graph:

1. Right-click the title or footnote that you want to move.

2. Select Move from the pop-up menu, and then choose Up, Down, To Top, or To Bottom.

   You can also select Arrange $\Rightarrow$ Move from the main menu, and then specify how you want the item moved.
Titles and footnotes can have up to three parts, one for each alignment position (left, center, right). You cannot move the individual part of multi-part title or footnote. The whole title or footnote moves together. (For more information about alignment, see “Aligning a Title or Footnote in a Graph” on page 23.)

Delete a Title or Footnote from a Graph

To delete a title or footnote in a graph:
1. Right-click the title or footnote that you want to delete.
2. Select Delete from the pop-up menu.

Note: To undo the change, select Edit ⇔ Undo from the menu.

For multi-part titles and footnotes, you can delete one part at a time.

Use of Alternate Short Text in Graph Elements

In addition to the standard text that is displayed, titles, footnotes, and axis labels have alternate short text. This short text is specified as a GTL option in the SAS program that defines the graph.

If there is not enough space to display the standard text, then the short text is displayed. For example, if you resize a graph and there is not enough space to display the whole axis label, then the short axis label is displayed. If you later enlarge the graph so that enough space is made available, then the long label is displayed.

You can override the short text by changing the text of the title, footnote, or axis label. Once you change the text, then only the new modified text is displayed regardless of the size of the graph.
Chapter 5
Working with Legends

Add or Edit a Legend Title

You cannot add or delete a legend. You also cannot edit the labels in the legend. You can, however, add or edit the title of the legend.

To add or edit a legend title:
1. Right-click the legend and select Add (Edit) Title from the pop-up menu. A Legend text box appears next to the legend.
2. In the text box, enter the text that you want for the title. The title cannot exceed 256 characters.
3. To change the font characteristics, select the title text and use the Formatting toolbar. For details, see “Using the Formatting Toolbar” on page 21.

Change the Outline and Background Color of a Legend

To change the outline and fill color of a legend:
1. Right-click the legend and select Legend Properties from the pop-up menu. The Legend Properties dialog box appears.
2. To change the background color, select the Fill check box. Then click the down arrow in the fill color list box to select a color. For details about setting the color, see “Using the Color List Box” on page 22.

Note: If Auto appears in the list box, then the color of the legend is the same as the color selected when the graph was created. If you select another color, you can always go back to the original color by selecting the Fill check box and selecting Auto.

3. To change the outline color of the legend, select the Outline check box. Then use the down arrow to select an outline color.

4. Click OK.

---

Move a Legend Inside or Outside a Plot

You can move a legend to the inside or outside of a plot. You can also position the legend in different areas inside or outside of the plot.

To move a legend:

1. Right-click the legend and select Legend Properties from the pop-up menu. The Legend Properties dialog box appears.
2. To move the legend inside the plot area, complete these steps:
   a. Select the **Inside Plot Area** radio button.
   b. Select the new position from the list box. You can position the legend along an edge, in a corner, or in the center of the plot. The list box has the following options:
      • Top
      • Bottom
      • Left
      • Right
      • Center
      • Top Left
      • Top Right
      • Bottom Left
      • Bottom Right

3. To move the legend outside of the plot area, complete these steps:
   a. Select the **Outside Plot Area** radio button.
   b. Select the new position from the list box. The list box has the following options:
      • Top
      • Bottom
      • Left
      • Right

4. Click **OK**.
Chapter 6
Modifying Plot and Axis Properties

Working with Plot Properties

The Plot Properties Dialog Box

You can modify all of the properties of the plots and axes that are in a cell by using the Plot Properties dialog box.
To open the Plot Properties dialog box, right-click in a plot and select **Plot Properties**. You can also click in the plot area and then select **Format ➔ Plot Properties** from the main menu.

The Plot Properties dialog box contains the following tabs:

---

**Table 6.1  Tabs in the Plot Properties Dialog Box**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>used to edit the general properties of the plot or the cell containing plots</td>
</tr>
<tr>
<td>Plots</td>
<td>used to edit the properties of individual plots</td>
</tr>
<tr>
<td>Axes</td>
<td>used to edit the properties of one or more axes</td>
</tr>
</tbody>
</table>

---

**General Properties**

In the **General** tab, you can modify the wall color and border of the cell.

You can select or clear the **Fill** and **Outline** check boxes to toggle on and off the fill color and outline of the plot area. When the **Fill** check box is selected, you can select a fill color from the list box.

---

**Plot Properties**

**About Plot Properties**

In the **Plots** tab, you can modify the properties of individual plots. If more than one plot is open, then you can select the plot that you want to modify from the **Plot** list box.
The types of properties that you see vary depending on the type of plot that you are modifying.

*Note:* Based on plot settings, the initial value for a property might be shown as *Auto* or *Group*. This means that the value is derived from the original plot setting or from the group variable. You can later revert back to the original *Auto* or *Group* setting if desired.

If you change the properties, the settings that you specify override any style that has been applied to the graph.

**Marker and Line Properties**

You can specify the color, pattern, and thickness of a plot's lines from the list boxes.

You can specify the color, shape, and size of a plot's markers from the list boxes.
For markers, in addition to `Auto` or `Group` value, the initial value for any of the properties might be as follows:

- If the MarkerColorGradient variable is defined, then `Gradient` is displayed as the current color value. The color list is dimmed, and you cannot change the color.
- If the MarkerCharacter variable is defined, then `Character` is displayed as the current shape. The shape and size are dimmed, and you cannot change them.

**Fill and Outline Properties**

Plots such as bar charts and histograms use graphical elements that have a fill color. The **Fill** check box is selected by default. If you specify an outline for the plot, then you can clear the **Fill** check box.

When the **Fill** check box is selected, then you can specify the fill color and the transparency. Moving the slider to the right makes the fill color more transparent. (The other part of the plots, such as its outline, do not change.) The default value for transparency is obtained from the plot definition.

*Note:* The editor modifies graphics elements that have fill attributes, but does not manipulate data transparency. Therefore, transparency is not applied to lines, text, and markers. In addition, if data transparency has been defined in the graph, then specifying a fill transparency causes the data transparency to be ignored.

You can toggle the plot's outline on and off. If the **Outline** check box is selected, then you can specify a color for the outline.

![Plot Properties](image)

**Contour Properties**

Contour has different graphical elements, such as lines, labels, fill, and gradient based on the contour type. You can change the contour type.

If the contour plot includes an area, such as a fill or gradient, then the color can be reversed by selecting the **Reverse Gradient** check box.

If the contour plot contains lines or labeled lines, then the line properties are enabled and can be edited.
Surface Properties
For surface plots, you can edit the surface type, color, and transparency. Moving the slider to the right makes the fill color more transparent.

If the Gradient variable is defined, then Gradient is displayed as the current color value. You can change the value for the color. If you change the color from Gradient to some other color, then that single color is used for the entire surface.

Axis Properties
On the Axes tab, you can modify the properties of labels for all the axes in a plot.
For more information, see “Working with Axis Properties” on page 36.
Working with Axis Properties

Axis properties reside in the Plot Properties dialog box. To open the Axes tab of the Plot Properties dialog box, right-click an axis and select Axis Properties.

On the Axes tab, you can modify the properties of labels for all the axes in a plot. You can select the axis that you want to modify from the Axis list box.

Note: You can edit secondary axes in single-cell and multi-cell graphs.

Select or clear the Label check box to toggle the label on and off for the selected axis.

Select or clear the Grid check box to toggle the grid lines on and off for the selected axis. If the Grid check box is selected, then you can modify the color, the pattern (such as dotted or dashed), and the thickness of the grid lines.

For changes that can be made to axis labels, see “Working with Axis Labels” on page 36.

Working with Axis Labels

You can change the appearance of a graph by adding labels to the graph's axes. For instructions on working with axis labels, see the following topics:

- “Edit an Existing Axis Label” on page 37
- “Add an Axis Label” on page 37
- “Show or Hide an Axis Label” on page 37
- “Delete an Axis Label” on page 38
You can also show grid lines for an axis and specify the visual properties of the grid lines. For more information, see “Axis Properties” on page 35.

---

**Edit an Existing Axis Label**

You can edit an existing X or Y axis label (or X,Y, and Z labels for three-dimensional graphs). If the same axis is displayed on both sides of the graph (right and left or top and bottom), then your edits apply to both of the axis labels.

*Note:* Once you edit a label, then the alternate short text is no longer used for the label. For more information, see “Use of Alternate Short Text in Graph Elements” on page 25.

To edit an axis label:
1. Double-click the axis label that you want to edit.
2. Enter or delete text in the axis label.
3. To change the font characteristics, select the label text and then use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 21.

---

**Add an Axis Label**

To add a label to an axis:
1. Right-click along the axis where you want to add a label.
2. Select Add ('Edit') Label from the pop-up menu. A text box appears.
3. Enter the label for your axis in the text box. The label cannot exceed 256 characters.
4. To change the font characteristics, select the text and then use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 21.

---

**Show or Hide an Axis Label**

To show or hide an axis label:
1. Right-click the axis label and select **Axis Properties**. The Plot Properties dialog box appears with the **Axes** tab displayed.
2. In the Axis list box, select the axis whose label you want to show or hide.
3. Check or uncheck the Label box to show or hide the label.
4. Click OK.

Delete an Axis Label

To delete an axis label permanently from a graph:
1. Click the axis label that you want to delete.
2. Select Edit \(\Rightarrow\) Delete. Alternatively, you can press the DELETE key. The label is permanently deleted.

*Note:* To undo the change, select Edit \(\Rightarrow\) Undo from the main menu.
Chapter 7
Working with Data Labels and Multi-Cell Graphs

Display or Hide Data Labels

Some plots might display data labels for each observation in the plot. If there are a lot of observations, then the plot can become cluttered. You can limit the display to those data labels that are important to the analysis.

To display or hide data labels:

1. Click the data label icon in the Graph toolbar.
2. Select the observations for data label management in any of the following ways:
   • Click an observation to select it. If you press CTRL and click an observation, you can toggle the observation on and off. Pressing CTRL also enables you to select multiple observations.
   • Click on the data label of an observation to select it.
   • Click and drag to select an area within the plot. All the observations in this area are selected. You can add more items to the selection list by pressing CTRL while you click and drag to select another area containing additional observations.
3. Right-click and select one of the following label options:
   • **Show Only Selected** shows labels only for those data points that are currently selected. This option first turns off all the data labels and then displays the labels only for the selected data points.
   • **Show Selected** shows labels for the data points that are selected. This option leaves unchanged the data labels for all other data points that are not currently selected. For example, if you previously selected data points and set them to show, with this option, they remain selected.
   • **Hide Selected** hides labels for those data points that are selected.
   • **Show All** shows labels for all the data points.
   • **Hide All** hides labels for all the data points.
All items in the selection list are displayed with the selection color. If the selected item is in a scatter overlay and a marker is selected, then the marker displays with the selection color. For a line overlay, if the marker is not turned on, then a temporary circle is created and displayed with the selection color.

The layout of a plot refreshes when labels are turned off or on. If some labels are located away from their data points, the labels move closer to the data points if space is made available by hiding other labels.

**Working with Multi-Cell Graphs**

A graph can contain multiple cells, each cell with one or more plots. For a visual description of graphs and cells, see “Components of a Graph” on page 5.

Multi-cell graphs can be created in different ways:

- A multi-cell graph can be defined using a GRIDDED or LATTICE layout. Each cell is defined independently and can contain different types of plots.

- A multi-cell graph can be defined using a DATALATTICE or DATAPANEL layout. Both layouts are data-driven layouts that create a grid of cells based on a graph prototype and one or more classification variables. The number of the cells is determined by the values of the classification variables.

You can modify plot properties separately for each cell.

- A multi-cell graph can be defined using a DATALATTICE or DATAPANEL layout. Both layouts are data-driven layouts that create a grid of cells based on a graph prototype and one or more classification variables. The number of the cells is determined by the values of the classification variables.
When you change the plot properties for one cell, the change is applied to all the cells of the graph.

- A multi-cell graph can be created by using a SCATTERPLOTMATRIX layout.
Each non-diagonal cell contains the same plot types, but for a different crossing of the variables. When you change the plot properties for one of these cells, the change is applied to all non-diagonal cells. (The wall and outline properties apply to all cells.)

You cannot change the properties of the following:

- the diagonal cells
- the axes
Part 3

Annotating Graphs

Chapter 8  
Annotation Overview .................................................. 45

Chapter 9  
Using Annotations in a Graph ...................................... 61

Chapter 10  
Changing the Visual Properties of Annotations ............... 69

Chapter 11  
Adding Text to Annotations ......................................... 75

Chapter 12  
Modifying Annotations ................................................. 79
Chapter 8
Annotation Overview

About Annotation Objects

You can use ODS Graphics Editor to add the following annotation objects to a graph:

- text annotations
- lines and arrows
- ovals (and circles)
- rectangles (and squares)
- markers
- images

The annotation objects are rendered on top of the graph. Unlike titles and footnotes, annotation objects do not cause a graph to be resized or rearranged.

Annotation objects can be attached to a graph data points. If the graph is resized, the annotations move with the data point. For more information, see “Understanding Annotation Objects and Data” on page 45.

Understanding Annotation Objects and Data

You can add free-form annotations (such as text, lines, circles, images, and markers) to a graph. The annotation objects are rendered on top of the graph. Unlike titles and
footnotes, annotation objects do not cause a graph to rearrange. However, annotation objects can be attached to data points in the plot area. If the graph is resized, the annotations move with the data points.

Whether an annotation is attached to the data depends on where the annotation was created in the graph, as described in the following table:

### Table 8.1 Location Determines Default Data Attachment

<table>
<thead>
<tr>
<th>Annotation Location</th>
<th>Behaviors</th>
</tr>
</thead>
</table>
| Created totally within in the plot area | By default, the annotation object is attached to the data markers, lines, and so on, in the plot area. For example, suppose that you create a rectangle in the plot area next to a data marker. Suppose also that the graph changes due to the addition or removal of titles or footnotes. The location of the rectangle changes along with the location of the data marker even though the plot area might change in size. In other words, the rectangle location remains synchronized with the data location. There are three exceptions:  
• Plots with a DATALATTICE or DATAPANEL layout do not support this data synchronization feature. Annotations that are added to these plots cannot be attached to data points.  
• Three-dimensional plots, such as surface plots, also do not support the data synchronization feature.  
• Image annotations cannot be attached to data points. They always behave as if they were created outside the plot area. By default, if you move an annotation object that was created in the plot area beyond the plot area border, the annotation is cropped at the plot area boundary. For most annotation objects, you can specify that annotations created inside the plot area act like annotations created outside the plot area (that is, they lose their data synchronization). For details, see “Change the Data Attachment Properties of an Annotation” on page 57. |
| Created totally outside plot area     | By default, annotation objects created outside the plot area are positioned relative to the overall size of the graph. These annotation objects are not attached to the data in the plot area. If the graph is resized, the annotation object maintains its position relative to the entire graph. For example, suppose you add a marker annotation to the bottom center of a graph (outside the plot area). If you resize the graph, the marker stays in the bottom center. Annotation objects that are created outside the plot area and then moved inside the plot area do not become attached to the data. |
Behaviors

Created both inside and outside the plot area

You can create a line or arrow that has one end inside the plot area and the other end outside the plot area. Only the end that was created within the plot area is attached to the data. If the graph is resized, the attached end stays with the data point. Moving either end does not change the original data synchronization behavior. If you want the entire line to be synchronized with the data, you must create a new line that is entirely within the plot area.

All non-line annotation objects are attached to the data only if the starting position is in the data area. Unlike lines and arrows, the other annotation objects are either entirely attached to the data or not attached to the data.

Data Attachment Examples for Annotations

Example: Text Annotation

This example shows how text annotations behave when the plot area is resized. The behavior varies depending on whether the annotation is attached to the data.

The following display shows a text annotation in the upper left corner within a plot. In the example, the text annotation has a red circle around it:

Display 8.1 Example Text Annotation in a Plot

By default, the annotation is attached to data in the upper left corner.

The following display shows the same graph with titles added. The titles cause the plot to get smaller. The annotation stays with the data when the graph is resized.
The next display shows the result when you add titles to the graph but change the properties of the text annotation. The annotation is not attached to the data.

**Display 8.3  Text Annotation That is Not Attached to the Data**

The text remains in place when the plot is resized because the text is not attached to the data.

**Example: Oval Annotation Around a Data Point**

This example shows the behavior of ovals that are created around data points when the plot area is resized. The behavior varies depending on whether the oval is attached to the data point.

The following display shows an oval annotation around a data point in a plot:
By default, the annotation is attached to the data point.
The following display shows the same graph with more titles added. The titles cause the plot to get smaller. The oval stays around the data point when the graph is resized.
The next display shows the result when you add titles to the graph but have changed the properties of the oval so that it is not attached to the data.
The oval does not move when the plot is resized because the oval is not attached to the data point.

**Example: Arrow Annotation Partially Attached to Data**

This example shows the behavior of arrow annotations when the plot area is resized. One end of the arrow is attached to the data and the other end is not.

The following display shows an arrow with one end in a plot and the other end outside the plot:
Only the end that resides within the plot is attached to the data.

The following display shows the same graph with another title added. When the plot is resized, the end of the arrow that is attached to the data moves, while the other end stays in place.

**Display 8.8 Arrow in a Resized Plot**

---

**Example: Marker Annotation with Text That Is Cropped**

This example shows the behavior of marker annotations that have text when the text is moved off the edge of the plot.
By default, the marker and its text are attached to the data.

The next display shows the marker after it has been moved downward so that the text moves outside the plot. The text disappears (is cropped). By default, when the annotation is attached to the data, any part of the annotation that resides outside the plot is cropped.
The next display shows the result when you change the properties of the marker so that cropping is disabled. The marker text appears outside the plot.
**Display 8.11  Marker Annotation with Text That Is Not Cropped**

*Note:* Another way to make the marker text appear is to reposition the text above the marker. You can also change the properties of the marker so that it is not attached to the data.

**Example: Annotation Positioned Over a Legend in a Graph That Is Resized**

This example shows the behavior of an annotation that is positioned over a legend. Because it is created outside the plot area, the annotation is not attached to the data. When the graph is resized, the annotation stays in place.

The following display shows a graph that has a legend, with an oval created around part of the legend:
By default, the annotation is not attached to the data because it was created outside of the plot area.

The next display shows the same graph when it is reduced in size. The oval moves with the graph, but is no longer around the same portion of the legend.
Note: The same behavior occurs when you save the graph as a PNG file and specify a DPI larger than 100. When you close and then reopen the PNG, you see that the graph size has changed. However, the oval that was positioned over the legend is no longer around the same portion of the legend.

Change the Data Attachment Properties of an Annotation

Depending on where you create an annotation object, the object might be attached to the data inside the plot area. For more information about data attachment, see “Understanding Annotation Objects and Data” on page 45.

You can change the data attachment behavior of an annotation object. You can control whether the object is attached to data and whether to crop any portion of the object that resides outside of the plot.

To change the data attachment behavior for an annotation object:

1. Right-click the annotation object whose behavior you want to change and select Annotation Properties from the pop-up menu.
2. Select the Position tab.
3. If you are modifying a line or arrow, then make the following changes:
   a. In the **Line Point** list box, select which end of the line or arrow you want to change.

   ![Annotation Properties dialog box]

   b. Select or clear **Attach to data in underlying Plot area**. If this option is selected, then the corresponding end of the line is attached to data and is not visible outside the plot area. If you clear this option, then the corresponding end of the line is not attached to the data and becomes visible outside the plot area.

   If the line or arrow was created outside the plot area, then this check box is dimmed.

   You can also change the vertical or horizontal placement of the selected end point. For more information, see “Resize by Using the Annotation Properties Dialog Box ” on page 80 and “Rotate by Using the Annotation Properties Dialog Box ” on page 82.

4. If you are modifying an oval, rectangle, or marker, then make the following changes:
   a. Select or clear **Attach to data in underlying Plot area**. If this option is selected, then the annotation object is attached to the data.
b. If the annotation object is attached to data (Attach to data in underlying Plot area is selected), then you can crop the part of the object that is outside of the plot. To toggle cropping on or off, select or clear Crop the part outside Plot area.

If the annotation was created outside the plot area, then both of these check boxes are dimmed.

You can also rotate the annotation. For more information, see “Rotate by Using the Annotation Properties Dialog Box ” on page 82.

5. Click OK.

If the original graph is a data panel or data lattice that contains an annotation, the editor preserves the cropping that was performed by SAS when the graph was created. As a result, the Crop the part outside Plot area check box is dimmed. In addition, annotations that are added to these plots cannot be attached to data points. For annotations that you add, both the Crop the part outside Plot area and the Attach to data in underlying Plot area check boxes are dimmed.
About Text Annotations

You can change the appearance of a graph by adding text annotations. For instructions on working with text annotations, see the following topics:

- “Add a Text Annotation to a Graph” on page 62
- “Edit a Text Annotation” on page 62
- “Format a Text Annotation” on page 69

You can also make the following changes:

- Change the size of a text annotation. For instructions, see “Resize an Annotation” on page 79.
- Rotate a text annotation. For instructions, see “Rotate an Annotation” on page 81.
- Move a text annotation. For instructions, see “Move an Annotation” on page 83.
- Change the data attachment properties of a text annotation. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 57.
Add a Text Annotation to a Graph

To add a text annotation to a graph:

1. Click the text icon \( \text{ abl} \) in the Graph toolbar, or select Insert \( \Rightarrow \) Text from the main menu.
2. Click the area of the graph where you want to position your text. A text box appears.
3. Enter the text in the box.
   The width of the text box determines the maximum width of the text line. If a line exceeds the width of the text box, then the text wraps to the next line.
   If needed, drag one of the circles on the border of the text box to the right or left to widen the text box.
4. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format a Text Annotation” on page 69.

By default, if the text object was created in the data area then it is attached to the data, and any part that is outside the data area gets cropped. For more information, see “Understanding Annotation Objects and Data” on page 45.

Edit a Text Annotation

To edit a text annotation:

1. Double-click the text annotation that you want to change.
2. Enter your textual changes.
3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format a Text Annotation” on page 69.

About Lines and Arrows

You can change the appearance of a graph by adding lines and arrows. You can also add text to the lines and arrows. For instructions on working with lines and arrows, see the following topics:
Add a Line to a Graph

To add a line to a graph:

1. Click the line icon in the Graph toolbar, or select Insert Line from the main menu.
2. Position your cursor at a starting position in the graph.
3. Click and drag to create the line in the graph.

You can control the line as follows:

- If you press the CTRL key and then click and drag, the line is created from the center and moves outward.
- If you press SHIFT and then click and drag, then the line's orientation stays in multiples of 15 degrees. You can create a perfect horizontal or vertical line this way. You can also rotate the line in 15 degree increments to create a diagonal line.
- If you press CTRL+SHIFT and then click and drag, the line is created from the center, moves outward, and can be rotated in 15 degree increments.

You can add text to the line. For instructions, see “Add Text to an Annotation” on page 75.

Add an Arrow to a Graph

You can add an arrow to a graph to point out specific information. To add an arrow to a graph:

1. Click the arrow icon in the Graph toolbar, or select Insert Arrow from the main menu.
2. Position your cursor at a starting position in the graph.
3. Click and drag to create the arrow in the graph.

You can control the arrow as follows:

- If you press the ALT key and then click and drag, the arrow is created from the center and moves outward.
- If you press SHIF and then click and drag, then the arrow's orientation stays in multiples of 15 degrees. You can create a perfect horizontal or vertical line this way. You can also rotate the arrow in 15 degree increments to create a diagonal line.
- If you press ALT+SHIFT and then click and drag, the arrow is created from the center, moves outward, and can be rotated in 15 degree increments.

You can add text to the arrow. For instructions, see “Add Text to an Annotation” on page 75.
1. Click the arrow icon in the Graph toolbar, or select Insert \(\Rightarrow\) Arrow from the main menu.

2. Position your cursor at a starting position in the graph.

3. Click and drag to create the arrow. By default, the arrow is drawn from the tail to the head.

You can control the arrow as follows:

- If you press the CTRL key and then click and drag, the arrow is created from the head to the tail.
- If you press SHIFT and then click and drag, then the arrow's orientation stays in multiples of 15 degrees. You can create a perfect horizontal or vertical arrow this way. You can also rotate the arrow in 15 degree increments to create a diagonal arrow.
- If you press CTRL+SHIFT and then click and drag, the arrow is created from the head to the tail, and can be positioned in 15 degree increments.

After you create the arrow, you can add text to the tail end of the arrow. For instructions, see “Add Text to an Annotation” on page 75.

### About Ovals and Rectangles

You can change the appearance of a graph by adding ovals (or circles) and rectangles (or squares). You can also add text to the ovals and rectangles. For instructions on working with ovals and rectangles, see the following topics:

- “Add an Oval to a Graph” on page 65
- “Add a Rectangle to a Graph” on page 65
- “Change the Color, Transparency, and Outline Properties of an Oval or Rectangle” on page 70

You can also make the following changes:

- Add text to an oval or rectangle. For instructions, see “Add Text to an Annotation” on page 75.
- Change the size of an oval or rectangle. For instructions, see “Resize an Annotation” on page 79.
- Rotate an oval or rectangle. For instructions, see “Rotate an Annotation” on page 81.
- Move an oval or rectangle. For instructions, see “Move an Annotation” on page 83.
- Change the data attachment properties of an oval or rectangle. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 57.
- Copy and paste an oval or rectangle. For instructions, see “Copy and Paste an Annotation Object” on page 83.
- Delete an oval or rectangle. For instructions, see “Delete an Annotation” on page 84.
Add an Oval to a Graph

To add an oval (or a circle) to a graph:

1. Click the oval icon in the Graph toolbar, or select Insert Oval from the menu.
2. Place your cursor at the top left position in the graph where you want your oval to begin.
3. Click and drag your cursor to the right to create an oval.

You can control the oval as follows:

• If you press the CTRL key and then click and drag, the oval expands from the center.
• If you press the SHIFT key and then click and drag, you can draw a perfect circle.
• If you press SHIFT + CTRL and then click and drag, you draw a circle that expands from the center.

You can add text to the oval. For instructions, see “Add Text to an Annotation” on page 75.

Add a Rectangle to a Graph

To add a rectangle (or a square) to a graph:

1. Click the rectangle icon in the Graph toolbar, or select Insert Rectangle from the menu.
2. Place your cursor at the top left position in the graph where you want your rectangle to begin.
3. Click and drag your cursor to the right to create a rectangle.

You can control the rectangle as follows:

• If you press the CTRL key and then click and drag, the rectangle expands from the center.
• If you press the SHIFT key and then click and drag, you can draw a perfect square.
• If you press SHIFT + CTRL and then click and drag, you draw a square that expands from the center.

You can add text to the rectangle or square. For instructions, see “Add Text to an Annotation” on page 75.

About Markers
You can change the appearance of a graph by adding markers to the graph. For instructions on working with markers, see the following topics:

- “Add a Marker to a Graph” on page 66
- “Change the Color, Symbol, and Size of a Marker” on page 71

You can also make the following changes:

- Add text to a marker. For instructions, see “Add Text to an Annotation” on page 75.
- Rotate a marker. For instructions, see “Rotate an Annotation” on page 81.
- Move a marker. For instructions, see “Move an Annotation” on page 83.
- Change the data attachment properties of a marker. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 57.
- Copy and paste a marker. For instructions, see “Copy and Paste an Annotation Object” on page 83.
- Delete a marker. For instructions, see “Delete an Annotation” on page 84.

---

**Add a Marker to a Graph**

You can use a marker to identify or accentuate key data elements in a graph, such as data points that are outliers.

To add a marker to a graph:

1. Click the marker icon ⭐ in the Graph toolbar, or select Insert ➞ Marker from the main menu.

   *Note:* As shown here, the marker icon is a star. The icon in your operating environment might be different. In addition, you can change the symbol that is used for the icon. For instructions, see “Change the Color, Symbol, and Size of a Marker” on page 71.

2. Click the area of the graph where you want to place the marker.

You can add text to the marker. For instructions, see “Add Text to an Annotation” on page 75.

---

**About Images**

You can add images to a graph. For instructions on working with images, see the following topics:

- “Add and Position an Image in a Graph” on page 67
- “Format an Outline Around an Image” on page 72

You can also make the following changes:

- Add text to an image. For instructions, see “Add Text to an Annotation” on page 75.
Add and Position an Image in a Graph

You can add an image, such as a logo, to a graph. When you add an image to a graph, the image appears in the center of the graph. You can reposition and resize the image if necessary.

To add, resize, and reposition an image:

1. Click from the Graph toolbar, or select Insert → Image from the main menu.

2. From the Image dialog box that displays, select and open the image that you want to insert.

   The image appears in the center of the graph.

3. To resize the image, select the image and drag one of the circles that appear around the image. You can maintain the ratio of width to length. Position your cursor on a corner circle, press SHIFT, and drag the corner circle.

4. To move the image to a different position, click and drag the image to another position in the graph.

Note: Images are not attached to the data. For more information about data attachment, see “Understanding Annotation Objects and Data” on page 45.
Chapter 10
Changing the Visual Properties of Annotations

Format a Text Annotation

You can change the font, size, style (for example, bold or italicized), alignment, or color of the text in a text annotation.

To format a text annotation:
1. Click the text annotation.
2. Use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 21.

Text format changes that you make here remain in effect for new annotations that you add.

As an alternative to this procedure, you can right-click the text annotation, select Annotation Properties, and make your changes in the Text tab. You can change the font, size, style, and color.

Change the Color, Pattern, and Thickness of a Line or Arrow

To change the color, pattern (such as dotted or dashed), or thickness of a line or arrow:
1. Right-click the line or arrow and select Annotation Properties from the menu. The Annotation Properties dialog box appears.
2. Make sure that the **Appearance** tab is selected.

3. Click the down arrows to select the line's color, pattern, and thickness. The line or arrow changes appearance.

4. Click **OK**.

Line format changes that you make remain in effect for new annotations that you add.

---

**Change the Color, Transparency, and Outline Properties of an Oval or Rectangle**

You can change various format properties of an oval or a rectangle.

To format ovals and rectangles:

1. Right-click the oval or rectangle and select **Annotation Properties** from the menu. The Annotation Properties dialog box appears.
2. Make sure that the **Appearance** tab is selected.

3. You can specify a fill color for the oval or rectangle as follows:
   a. Select the **Fill** check box and then select a color from list box. For details, see “Using the Color List Box” on page 22.
   b. Change the fill transparency of the oval or rectangle by sliding the arrow in the **Transparency** field. Moving the slider to the right makes the fill more transparent.

4. In the **Outline** section of the dialog box, you can change the outline of the oval or rectangle as follows:
   - Select a color for the outline from the **Color** list box.
   - Select a different pattern (such as dotted or dashed) for the outline from the **Pattern** list box.
   - Select a different thickness for the outline from the **Thickness** list box.
   - If the **Fill** check box is selected, then you can remove the outline. Select or clear the **Outline** check box to toggle the outline on and off.

5. Click **OK**.

Outline and fill format changes that you make remain in effect for new annotations that you add.

---

**Change the Color, Symbol, and Size of a Marker**

To change the color, symbol, and size of a marker:

1. Right-click the marker and select **Annotation Properties**. The Annotation Properties dialog box appears.
2. Make sure that the Appearance tab is selected.

3. To specify a color, symbol, or size, click the arrows in the fields and make a selection.
   You can also change the marker's size using a click-and-drag method. For details, see “Resize an Annotation” on page 79.

4. Click OK.

Format an Outline Around an Image

You can add an outline to an image and then specify the color, pattern, and thickness of the outline.

To add and format an outline:

1. Right-click the image and select Annotation Properties. The Annotation Properties dialog box appears.
2. Make sure that the **Appearance** tab is selected.

3. Select the **Outline** check box to add an outline to the image.

4. To specify the outline's color, pattern, and thickness, click the arrows in the fields and make a selection.

5. Click **OK**.
Chapter 11
Adding Text to Annotations

Overview of Adding Text to Annotations
In addition to adding text annotations to a graph, you can add text to lines, arrows, ovals, rectangles, images, and markers.

Note: When you create an arrow in your graph, a text box appears. The text box disappears if you click outside the arrow without entering text. You can later add text to the arrow.

For instructions on working with annotations and text, see the following topics:
- “Add Text to an Annotation” on page 75
- “Edit Text That Has Been Added to an Annotation” on page 76
- “Format Text That Has Been Added to an Annotation” on page 76
- “Move Text That Has Been Added to an Annotation” on page 77

Add Text to an Annotation
To add text to an annotation:
1. Right-click the annotation object and select Add (‘Edit’) Text from the pop-up menu.

   A text box appears. The location of the text box depends on the type of annotation.
   • For ovals and rectangles, the text box appears inside the oval or rectangle.
• For lines, the text box appears within the line. The following display shows a text box within a line.

• For arrows, the text box appears at the tail end of the arrow.

• For markers and images, the text box appears beneath the marker or image.

2. Enter text in the box.

3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format Text That Has Been Added to an Annotation” on page 76.

For an oval or rectangle, the text is placed inside the oval or rectangle by default. The text wraps when it reaches the boundary of the annotation object. If there is insufficient space for the text that wraps, then the oval or rectangle increases its size to make space.

---

**Edit Text That Has Been Added to an Annotation**

To edit text that has been added to an annotation:

1. Right-click the annotation object and select Add ('Edit') Text from the pop-up menu.

   A text box surrounds the text.

2. Edit text in the box.

3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format Text That Has Been Added to an Annotation” on page 76.

---

**Format Text That Has Been Added to an Annotation**

To format text that has been added to an annotation:
Move Text That Has Been Added to an Annotation

To move text that has been added to an annotation:

1. Right-click the annotation object and select **Annotation Properties** from the pop-up menu.

2. Select the **Text** tab.

3. Select the desired position for the text as follows:
   - For lines and arrows, select the **Through**, **Above**, **Below**, **Start**, or **End** radio button to position the text with respect to the line or arrow.
   - For all other annotation objects, select the **Inside**, **Above**, or **Below** radio button to position the text with respect to the object.

4. Click **OK**.

For all annotations other than images, if your selection places the text outside of the plot, then the text might be cropped. For more information, see “Understanding Annotation Objects and Data” on page 45. To turn cropping off, see “Change the Data Attachment Properties of an Annotation” on page 57.
Chapter 12
Modifying Annotations

Resize an Annotation

Resize by Dragging

To change the size of an annotation:

1. Click the annotation object that you want to resize.
   
   Small circles surround the object. If you click a line or arrow, a circle appears at each end of the line or arrow.

2. Click and drag a circle to change the size of the annotation as follows:
   
   • To change the length of a line or arrow, drag an end circle backward or forward.

   Press SHIFT and drag to keep the line or arrow perfectly horizontal, vertical, or diagonal in 15 degree increments.

   • To resize all other annotations, drag one of the circles to expand or reduce the annotation. To change the width and length of the annotation simultaneously, position the cursor in a circle at one of the corners.
You can maintain the ratio of width to length. Position the cursor in a corner circle, press SHIFT, and drag the corner circle.

The following display shows the cursor positioned on a corner circle of a marker.

Note: For text annotations, this procedure changes the size of the text block, not the size of the font. To change the font, see “Format a Text Annotation” on page 69.

**Resize by Using the Annotation Properties Dialog Box**

You can use the Annotation Properties dialog box to resize markers and change the length of lines and arrows. This method provides more granular control of the size.

1. Right-click the line, arrow, or marker and select **Annotation Properties** from the pop-up menu. The Annotation Properties dialog box appears.

2. To resize a marker, complete these steps:
   a. Select the **Appearance** tab.
   b. Select the size that you want from the **Size** list box.

3. To change the length of a line or arrow, complete these steps:
   a. Select the **Position** tab.
b. Select one end of the line from the **Line Point** list box. You select either the start or the end point of the line.

If the selected end point is attached to the data, then the **Horizontal** and **Vertical** values correspond to a point along the X and Y axis, respectively.

If the end point is not attached to the data, then the **Horizontal** and **Vertical** values are measured in inches from the top left corner of the graph.

c. From the **Horizontal** list box, select the new start or end point (whichever you have selected) in order to extend or shrink the length of the line or arrow. Only one end of the line or arrow moves. The other end remains fixed.

d. (Optional) Repeat steps b and c to extend or shrink the other end of the line.

4. Click **OK**.

---

**Rotate an Annotation**

**Rotate by Dragging the Annotation**

To rotate an annotation:

1. Select the annotation object that you want to rotate.

   Small circles surround the object, and a handle appears at the top of the object. If you select a line or arrow, a circle appears at each end of the line or arrow.

2. To rotate a line or arrow, drag an end circle up or down.

   If you press SHIFT and then drag, you can rotate the line in 15 degree increments.

3. To rotate all other annotations, complete these steps:

   a. Place your cursor in the circle at the top of the handle. The cursor changes to a rotated arrow.
b. Click and drag the handle to the right or left to rotate the annotation object.

**Rotate by Using the Annotation Properties Dialog Box**

You can use the Annotation Properties dialog box to rotate annotation objects. This method provides more granular control of the angle of rotation.

1. Right-click the annotation object and select **Annotation Properties** from the pop-up menu. The Annotation Properties dialog box appears.

2. Select the **Position** tab.

3. To rotate a line or arrow, complete these steps:
   a. Select one end of the line from the **Line Point** list box. You select either the start or the end point of the line.

   If the selected end point is attached to the data, then the **Horizontal** and **Vertical** values correspond to a point along the X and Y axis, respectively.

   If the end point is not attached to the data, then the **Horizontal** and **Vertical** values are measured in inches from the top left corner of the graph.

   b. From the **Vertical** list box, select the new start or end point (whichever you have selected) in order to move the end point up or down. Increasing the value of **Vertical** moves the end point down. Only one end of the line or arrow moves. The other end remains fixed.

4. To rotate all other annotation objects, select or enter the angle of rotation in the **Rotation** list box. Specify an integer between zero and 359. (If you enter a non-integer value, the number is truncated to an integer.) The object rotates clockwise.
5. Click **OK**.

---

**Move an Annotation**

To move an annotation:

1. Position your cursor on the annotation that you want to move.

   A double arrow appears. ➩

2. Click and drag the annotation to a new location in the graph.

---

**Copy and Paste an Annotation Object**

You can copy and paste an annotation object to a new location in the graph.

To copy and paste an annotation object:

1. Right-click the object and select **Copy** from the pop-up menu.

2. Right-click again and select **Paste**. The new object is pasted on top of the original, offset a little.

3. Move the pasted object to a new position in the graph.

Copy (or cut) and paste commands that are applied to annotation objects do not use the system clipboard. Instead, you copy and paste annotations between the graph and an
Delete an Annotation

To delete an annotation permanently from a graph:
1. Select the annotation that you want to delete.
2. Select Edit \(\Rightarrow\) Delete. Alternatively, you can press the DELETE key.

Note: To undo the change, select Edit \(\Rightarrow\) Undo.

Working with Groups of Annotation Objects

When you group annotation objects, you can easily move all items in the group as one object.

You cannot work on an individual object if it is part of a group. For example, in order to modify the text of a member object, you must first ungroup the objects.

To create and work with groups:
1. To create a group:
   a. Press and hold the CTRL key while you click on the annotation objects that you want to group.
   b. Right-click and select Grouping \(\Rightarrow\) Group from the pop-up menu.

      You can also select Arrange \(\Rightarrow\) Grouping \(\Rightarrow\) Group from the main menu.

2. To move a group, click the group and drag it to a new location.
3. To ungroup the objects, right-click the group and select Grouping \(\Rightarrow\) Ungroup from the pop-up menu.

Change the Order of Annotation Objects

When you annotate a graph, annotation objects are placed in the top layer of the graph. Annotations are placed in the order in which they are created, with the last object on top. For example, if you create a rectangle and then create an oval on the rectangle, the oval is on top. You can change the order so that the rectangle is on top.

Note: GTL DRAW objects that are part of the original graph can be either in the back layer behind the graph or in the top layer. The editor adds annotations only in the top layer. You can change the ordering of annotation objects only within that top layer. If a DRAW object was added to the back layer of the original graph, then you cannot bring it in front of the objects in the top layer. For example, if an image was added
using DrawImage(layer=back), then the image cannot be moved in front of objects in the top layer.

To change the order of an annotation object:

1. Right-click the object and select **Order** from the pop-up menu.
   
   You can also select **Arrange ⇒ Order** from the main menu.

2. From the cascading menu, select one of the following options:
   
   - **Bring to Front** moves the selected object forward to the top of the stack.
   - **Bring Forward** moves the selected object forward one layer in the stack.
   - **Send to Back** moves the selected object to the bottom of the stack.
   - **Send Backward** moves the selected object back one layer in the stack.

---

**Align Multiple Annotation Objects**

You can specify that a group of annotations be left-aligned, centered, right-aligned, and so on.

To align multiple annotation objects:

1. Press and hold the CTRL Key while you click on the objects to be aligned. The first object clicked is used as a reference object. The reference object stays in its place, and the other objects are moved to align with it.

2. From the main menu, select **Arrange ⇒ Align**.
   
   You can also select **Arrange ⇒ Align** from the main menu.

3. From the cascading menu, select your alignment:
   
   - **Top** aligns all selected objects with the top edge of the reference object.
   - **Bottom** aligns all selected objects with the bottom edge of the reference object.
   - **Left** aligns all selected objects with the left edge of the reference object.
   - **Right** aligns all selected objects with the right edge of the reference object.
   - **Center** aligns all selected objects around the center of the reference object.
Part 4

Examples

Chapter 13
  Editing and Annotating a Simple Graph by Example ............... 89

Chapter 14
  Showing and Hiding Labels By Example ............................. 97

Chapter 15
  Modifying a Multi-Cell Graph By Example ......................... 101

Chapter 16
  Editing and Annotating a SAS/STAT Graph By Example .......... 109
Chapter 13
Editing and Annotating a Simple Graph by Example

About the Simple Graph

This example uses the Class data set in the SAS Help library. The example provides the height and weight of individual students in a class and uses the SGPLOT procedure to produce a scatter plot.

In this example, you edit the graph by adding a title and changing the axis labels. You also change the scatter plot markers, the graph style, and the graph size.
Display 13.1  Edited and Annotated Simple Graph

Code for the Simple Graph Example

```r
ods html sge=on;
proc sgplot data=sashelp.class;
    scatter x=weight y=height;
run;
```

Editing the Graph

Add a Title to the Graph

To add a title to the graph:

1. Click the title icon in the Graph toolbar. A text box appears at the bottom of the graph and displays the highlighted text Insert Title.

2. Type Student Height.

Change the Axis Labels for the Graph

Change the axis labels to make them more informative.
To change the axis labels:
1. Double-click the Y axis label (Height) and change the text to **Height in Inches**.
2. Double-click the X axis label (Weight) and change the text to **Weight in Pounds**.

**Change the Marker Symbol and Size**

When you change the marker for the data points, you modify plot properties.

To change the markers:
1. Right-click inside the plot and select **Plot Properties**. The Plot Properties dialog box appears.
2. On the **Plots** tab, select the unfilled star marker (☆) from the **Symbol** list box.
3. Select 9 from the **Size** list box.
4. Click **OK**.

**Change the Graph Style**

The default style for the graph is StatGraphScheme, which inherits attributes from the style that was used when the graph was created (in this example, HTMLBlue). In this step, you change the style to Analysis.

1. Select **Format ➔ Style** from the main menu.
2. From the cascading menu, select **Analysis**.

Notice that the color of the markers has changed, but the marker symbol and size remain the same as they were. The reason is that you explicitly changed the marker symbol and size. The marker attributes that you specified override the settings that are associated with the new style.

**Change the Size of the Graph**

In this example, you want the graph to be five inches by approximately three inches in order to fit in a color presentation.

To change the size:
1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.
2. Change the width of the graph to 5.

Keep Aspect Ratio is currently selected. Changing the width to 5 also changes the height to 3.75 to maintain the current aspect ratio.

3. Click OK.

View Your Changes

Here are the results of the editing changes that you have made so far to the graph.

Display 13.2 Edits Made to the Simple Graph
Annotating the Graph

Add a Line Annotation to the Graph

You can annotate the graph that you edited in “Editing the Graph” on page 90.

In this step, you draw a red line to represent the approximate average height.

To draw a line:

1. Click the line icon in the Graph toolbar.
2. Position your cursor at a starting position along the Y axis and drag the line horizontally across the plot to the alternate Y axis.
3. Right-click the line and select Annotation Properties. The Annotation Properties dialog box appears.
4. On the Appearance tab, select the red color from the Color list box.

5. Do the following.
   a. Select the Position tab.
   b. Make sure Start is selected in the Line Point list box, and enter 62 in the Vertical list box.
6. Click **OK**.

**Add Text to the Graph**

To add a text annotation:

1. Click the text icon  in the Graph toolbar, or select **Insert**  **Text** from the main menu.
2. Click the area of the graph where you want to position your text. A text box appears.
3. Drag one of the circles on the border of the text box to the right or left to widen the text box.

4. Enter the following text in the box: *Approximate average height: 62 inches*

   The width of the text box determines the maximum width of the text line. If a line exceeds the width of the text box, then the text wraps to the next line.

5. Select the entire text string and use the Formatting toolbar to change the color of the font. Select a red color from the color list box . For details, see “Using the Color List Box” on page 22.

**View Your Annotation Changes**

Here are the results of the annotations that you have added to the graph.
Display 13.3  Annotations Made to the Simple Graph

Approximate average height: 62 inches
Chapter 14
Showing and Hiding Labels By Example

About the Linear Regression for Sports Cars Example

The linear regression example shows the relationship between miles per gallon and horsepower for a number of sports cars. In this example, you are interested in the cars that fall outside of the confidence band. However, the labels in the middle portion of the graph are cluttered together. It is not clear which label belongs to which observation.

Display 14.1  Linear Regression Example with Many Labels
Your strategy is to show only a few of the data labels and hide the others. When you hide data labels, ODS Graphics Editor redraws the labels on the graph. This time, there is more space for the data labels of interest.

The code uses the REG procedure to create the linear regression and the SGPLOT procedure to create the graph.

---

**Code for the Linear Regression Example**

SAS/STAT must be installed on the system in order to successfully run this code.

```sas
data sportscars;
  set sashelp.cars;
  if type = "Sports";
  run;
proc print data=sportscars;run;

data sportscars2 (keep= horsepower mpg_city shortname);
  set sportscars;
  id=find(strip(model), " ");
  put model id;
  if (id > 0) then shortname=substr(model, 1, id);
  run;
proc print data=sportscars2;run;

proc sort data=sportscars2;
  by shortname;
  run;
proc means data=sportscars2;
  by shortname;
  var horsepower mpg_city;
  output out=sasuser.sportsCarsMean
    mean = HP MPG;
  run;
proc print data=sasuser.sportsCarsMean;run;

title 'Linear Regression';
proc reg data=sasuser.sportsCarsMean outest=sportscarfit_est;
  model hp=mpg;
  output out=sasuser.sportsCarMeanFit
    lcl=lower
    ucl=upper
    lclm=lowermean
    uclm=uppermean
    predicted=predict;
  run;
proc sort data=sasuser.sportsCarMeanFit;
  by mpg;
  run;
proc print data=sasuser.sportsCarMeanFit; run;
```
Show and Hide Labels

For this example, select all the observations that lie outside the confidence band:

1. Select the data label icon in the Graph toolbar.
2. Right-click the plot and select Hide All. Hiding the labels makes it easier to see which data points to select.
3. Press CTRL and click the observations that lie outside the confidence band. The selected data points display in the selection color.
4. Right-click and choose Show Only Selected from the menu. Labels appear next to the data points that you selected.
5. Click inside the graph again. The data points and their labels display in the normal graph color. Only the data points that lie outside the confidence band have labels.
6. Select Format ⇒ Style ⇒ Listing from the main menu.

The revised example is shown here:
Display 14.2  Labels Show Only for Observations Outside the Confidence Band
Modifying a Multi-Cell Graph That Uses a Single Data Set

About the Classification Panel Example

This example uses the Heart data set in the SAS Help library. The example provides the cholesterol distribution for a group of men and women. The code uses the SGPANEL procedure to create a classification panel with two cells. Both cells are driven by the same data set.
Display 15.1  Classification Panel Example

Code for the Classification Panel Example

```sas
ods listing sge=on;
proc sgpanel data=sashelp.heart noautolegend;
title "Cholesterol Distribution in Heart Study";
panelby sex;
histogram cholesterol;
density cholesterol;
run;
title;
ods listing close;
```

Modify the Classification Panel Example

Change the Background Color
When you change the background fill color, you modify the graph’s properties.
1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.
2. In the Background section, select a gray color from the Fill list box. For details about setting the color, see “Using the Color List Box” on page 22.

The outside of the plot area changes to the color that you selected.

3. Click OK.

**Change the Color of the Density Curve**

When you change the color of the density curve in the cells, you modify plot properties. For the type of multi-celled graph used in this example, any change that you make to plot properties in one cell affects all cells in the graph.

1. Right-click inside either cell and select Plot Properties. The Plot Properties dialog box appears.

2. In the Plots tab, select DENSITY from the Plot list box.

3. Select an orange color from the Color list box.

4. Click OK.

**Add an Arrow Annotation to One of the Cells**

You can annotate an individual cell in a multi-cell graph. In this step, you draw a green arrow in one of the cells.

To draw an arrow:

1. Click the arrow icon in the Graph toolbar.

2. Position your cursor at a starting position in the graph and drag the arrow toward a data point of interest.

3. Right-click the arrow and select Annotation Properties. The Annotation Properties dialog box appears.

4. In the Appearance tab, select the green color from the Color list box.

5. Click OK.

**Results of Your Changes**

Your changes look similar to the following:
**Display 15.2** Modified Classification Panel

### Modifying Individual Plots in a Diagnostic Panel

**About the Fitness Example**

This example analyzes the resting and active pulse rates for participants in a physical fitness study. As part of the study, individuals of various ages and weights run for a variable amount of time, and their pulse rates are measured before and after the run. The code uses the REG procedure to create a graph with paneled diagnostic plots. The running time (RUNTIME) is a response variable in the study.
Display 15.3  Fitness Example

**Fit Diagnostics for runtime**

- Residual vs. Predicted Value
- Residual vs. Quantile
- Residual vs. Percent
- Residual vs. Observation
- Leverage
- Cook's D

### Code for the Fitness Example

SAS/STAT must be installed on the system in order to successfully run this code.

```sas
ods listing sget=on;
ods listing sget=on;
data fitness;
   input age weight oxy runtime rstpulse runpulse maxpulse;
datalines;
44 89.47 44.609 11.37 62 178 182
40 75.07 45.313 10.07 62 185 185
44 85.84 54.297 8.65 45 156 168
42 68.15 59.571 8.17 40 166 172
38 89.02 49.874 9.22 55 178 180
47 77.45 44.811 11.63 58 176 176
40 75.98 45.681 11.95 70 176 180
43 81.19 49.094 10.85 64 162 170
44 81.42 39.442 13.08 63 174 176
38 81.87 60.055 8.63 48 170 186
44 73.03 50.541 10.13 45 168 168
45 87.66 37.388 14.03 56 186 192
45 66.45 44.754 11.12 51 176 176
47 79.15 47.273 10.60 47 162 164
54 83.12 51.855 10.33 50 166 170
49 81.42 49.156 8.95 44 180 185
```

Modify the Fitness Example

**Change the Graph’s Title**

By default, the graph's title contains the RUNTIME variable. Change the graph's title to make it more meaningful.

1. Double-click the title (Fit Diagnostics for runtime).
2. Select all of the text and type the new title *Model Fit Diagnostics for Regression Analysis of Running Time.*

**Change the Axis Label for a Cell**

In this example, each cell has its own set of axis labels.

To change an axis label:

1. Double-click the Y axis label for the middle cell. (The label contains the text *runtime*.) A box appears around the text.
2. Change *runtime* to Run Time with a capital R and T.

**Change the Color of a Plot**

For the type of graph used in this example, you can modify plot properties separately for each cell.

To change plot properties:
1. Right-click inside the middle cell and select **Plot Properties**. The Plot Properties dialog box appears.

2. On the **Plots** tab, select **lineparm2** from the **Plot** list box.

3. Select a blue color from the **Color** list box.

4. Click **OK**. The diagonal plot in the middle cell becomes blue.

**Change the Graph's Background Color**

To change the graph's background color:

1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.

2. Select a gray color from the **Fill** list box.

3. Click **OK**.

**Results of Your Changes**

The revised example is shown here:

*Display 15.4  Modified Fitness Example*
Chapter 16
Editing and Annotating a SAS/STAT Graph By Example

About the Economy Growth Example .................................................. 109
Code for the Economy Example .......................................................... 110
Editing the Graph .................................................................................. 112
  Change the Graph’s Title ................................................................. 112
  Add a Footnote to the Graph .............................................................. 112
  Move the Legend ............................................................................. 112
  Change the Line Pattern ................................................................. 113
Adding Annotations to Highlight Outlier Data ...................................... 114
  Add an Oval to the Outlier ............................................................... 114
  Change the Color of the Oval .......................................................... 114
  Draw an Arrow That Points to the Outlier ........................................ 115
  Add Text to the Arrow ................................................................... 115
Preparing The Graph for Presentation ................................................ 115
  Change the Graph’s Style ............................................................... 115
  Change the Size of the Graph ........................................................ 115
Viewing and Saving the Results of Your Changes ............................. 116
  Results of Your Changes to the Graph .............................................. 116
  Save Your Changes ...................................................................... 117

About the Economy Growth Example

The Economy Growth example uses the Distance by Distance graph, which is generated using the ROBUSTREG procedure. The main purpose of robust regression is to detect outliers and leverage points and to provide stable results in the presence of such influential points.
This graph identifies leverage points for economic growth data for different countries. The distances displayed are appropriately scaled. They measure the distance from the center of the data to the observation. The vertical axis distance is a robust version of the classical distance measure on the horizontal axis. Observations with large discrepancies between these two distances have high leverage. The diagonal reference line helps to identify these observations. Such observations also have large ROBUST MCD distance; those observations that are above the horizontal leverage cutoff line are considered leverage points.

The data used in this example was obtained from a national growth study conducted by De Long and Summers in 1991. ¹

**Code for the Economy Example**

SAS/STAT must be installed on the system in order to successfully run this code.

```sas
data growth;
  input country$ GDP LFG EQP NEQ GAP @@;
  datalines;
  Argentina  0.0089 0.0118 0.0214 0.2286 0.6079
  Austria    0.0332 0.0014 0.0991 0.1349 0.5809
  Belgium    0.0256 0.0061 0.0684 0.1653 0.4109
  Bolivia    0.0124 0.0209 0.0167 0.1133 0.8634
  Botswana   0.0676 0.0239 0.1310 0.1490 0.9474
  Brazil     0.0437 0.0306 0.0646 0.1588 0.8498
  Cameroon   0.0458 0.0169 0.0415 0.0885 0.9333
  Canada     0.0169 0.0261 0.0771 0.1529 0.1783
  Chile      0.0021 0.0216 0.0154 0.2846 0.5402
```

Colombia  0.0239  0.0266  0.0229  0.1553  0.7695
CostaRica  0.0121  0.0354  0.0433  0.1067  0.7043
Denmark   0.0187  0.0115  0.0688  0.1834  0.4079
Dominica  0.0199  0.0280  0.0321  0.1379  0.8293
Ecuador   0.0283  0.0274  0.0303  0.2097  0.8205
ElSalvador 0.0046  0.0316  0.0223  0.0577  0.8414
Ethiopia  0.0094  0.0206  0.0212  0.0288  0.9805
Finland   0.0292  0.0089  0.0879  0.1767  0.4708
France    0.0259  0.0047  0.0890  0.1885  0.4585
Germany   0.0446  0.0044  0.0655  0.2245  0.7924
Guatemala 0.0149  0.0242  0.0384  0.1379  0.8293
Honduras  0.0148  0.0303  0.0446  0.0954  0.8850
HongKong  0.0484  0.0359  0.0767  0.1233  0.7471
India     0.0115  0.0170  0.0278  0.1448  0.9356
Indonesia 0.0345  0.0213  0.0221  0.1179  0.9143
Ireland   0.0288  0.0081  0.0814  0.1879  0.6457
Israel    0.0452  0.0305  0.1112  0.1788  0.6816
Italy     0.0362  0.0038  0.0683  0.1790  0.5441
IvoryCoast0.0278  0.0274  0.0243  0.0957  0.9207
Jamaica   0.0055  0.0201  0.0609  0.1455  0.8229
Japan     0.0535  0.0117  0.1223  0.2464  0.7484
Kenya     0.0146  0.0346  0.0462  0.1268  0.9415
Korea     0.0479  0.0282  0.0557  0.1842  0.8807
Luxembourg0.0236  0.0064  0.0711  0.1944  0.2863
Madagascar-0.0102  0.0203  0.0219  0.0481  0.9127
Malawi    0.0153  0.0226  0.0361  0.0935  0.9287
Malaysia  0.0332  0.0316  0.0446  0.1878  0.7853
Mali      0.0044  0.0184  0.0433  0.0267  0.9478
Mexico    0.0198  0.0349  0.0273  0.1687  0.5921
Morocco   0.0243  0.0281  0.0260  0.0540  0.8405
Netherlands0.0231  0.0146  0.0778  0.1781  0.3605
Nigeria   -0.0047  0.0283  0.0358  0.0842  0.8579
Norway    0.0260  0.0150  0.0701  0.2199  0.3755
Pakistan  0.0295  0.0258  0.0263  0.0880  0.9180
Panama    0.0295  0.0279  0.0388  0.2212  0.8015
Paraguay  0.0261  0.0299  0.0189  0.1011  0.8458
Peru      0.0107  0.0271  0.0267  0.0933  0.7406
Philipines0.0179  0.0253  0.0445  0.0974  0.8747
Portugal  0.0318  0.0118  0.0729  0.1571  0.8033
Senegal   -0.0011  0.0274  0.0193  0.0807  0.8884
Spain     0.0373  0.0069  0.0397  0.1305  0.6613
SriLanka  0.0137  0.0207  0.0138  0.1352  0.8555
Tanzania  0.0184  0.0276  0.0860  0.0940  0.9762
Thailand  0.0341  0.0278  0.0395  0.1412  0.9174
Tunisia   0.0279  0.0256  0.0428  0.0972  0.7838
U.K.      0.0189  0.0048  0.0694  0.1132  0.4307
U.S.      0.0133  0.0189  0.0762  0.1356  0.0000
Uruguay   0.0041  0.0052  0.0155  0.1154  0.5782
Venezuela0.0120  0.0378  0.0340  0.0760  0.4974
Zambia    -0.0110  0.0275  0.0702  0.2012  0.8695
Zimbabwe  0.0110  0.0309  0.0843  0.1257  0.8875

ods listing sge=on;
ods select "Distance by Distance";

proc robustreg data=growth plot=all method=lts;
   model GDP = LFG GAP EQP  NEQ / diagnostics(all);
run;

ods listing close;
title;

---

Editing the Graph

*Change the Graph’s Title*

Change the graph's title to make it more meaningful to your target audience.

1. Double-click the title (Leverage Diagnostics).
2. Select all of the text and type the new title *Analysis of Economy Growth*.

*Add a Footnote to the Graph*

Add a footnote that shows the respective year for the data.

1. Click the footnote icon in the Graph toolbar. A text box appears at the bottom of the graph and displays the highlighted text **Insert Footnote**.
2. Type *Data source: De Long and Summers (1991)*.

*Move the Legend*

Once the footnote has been added, the bottom of the graph looks crowded. Because there is ample space available inside the plot area, move the legend into the plot in the lower right corner.

1. Right-click the legend and select **Legend Properties** from the pop-up menu. The Legend Properties dialog box appears.
2. Select the **Inside Plot Area** button.

3. Select **Bottom Right** from the list box.

4. Click **OK**. The legend appears within the plot area.

---

**Change the Line Pattern**

Change the horizontal reference line so that it is a dashed line.

1. Right-click the line and select **Plot Properties** from the pop-up menu.

2. Select the **Plots** tab if it is not already selected.

3. Make sure that **ReferenceLine1** is selected in the **Plot** list box.

4. From the **Pattern** list box, select the third pattern (dashed line) in the list. The reference line changes to a dashed pattern.

5. Click **OK**.
Adding Annotations to Highlight Outlier Data

The observation in the middle of the plot denoted by a red plus sign is an outlier. You can label it with the name of the country that it represents in order to draw attention to the outlier. To do this, use the oval and arrow annotation tools in the Graph toolbar.

Add an Oval to the Outlier

To add an oval:

1. Select the oval icon 🔄 in the Graph toolbar.
2. Press CTRL, click the observation, and drag the cursor to create an oval around the observation. Click and drag the circles along the border of the oval to change the size of the annotation.

Change the Color of the Oval

Change the color of the oval in order to make the oval stand out from the rest of the graph.

1. Right-click the circle and select Annotation Properties from the pop-up menu. The Annotation Properties dialog box appears.
2. In the Outline area of the dialog box, select the red color from the Color list box.
3. Click **OK**.

**Draw an Arrow That Points to the Outlier**

To draw an arrow:

1. Click the arrow icon → in the Graph toolbar.
2. Position your cursor at a starting position in the graph and drag the arrow toward the circle annotation.

**Add Text to the Arrow**

To add text to the arrow:

1. Right-click the arrow and select **Add (’Edit’) Text** from the pop-up menu. A text box appears at the tail end of the arrow.
2. In the text box, type **Zambia**.
3. Right-click the arrow and select **Annotation Properties**. The Annotation Properties dialog box appears.
4. On the **Text** tab, select the red color from the **Color** list box. Then click **OK**. The annotations all display in red.

---

**Preparing The Graph for Presentation**

**Change the Graph’s Style**

Change the style that is applied to the graph in order to make the graph more suitable for printing with a black-and-white printer. Select **Format ⇒ Style ⇒ Journal** from the main menu.

*Note:* When you apply the Journal style, all of the objects in the graph change to shades of gray. However, the annotations (oval and arrow) are red because you explicitly set their color.

**Change the Size of the Graph**

To change the size:
1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.

![Graph Properties dialog box](image)

2. Change the width of the graph to 6. **Keep Aspect Ratio** is currently selected. Changing the width to 6 also changes the height to 4.5 to maintain the current aspect ratio.

3. Click **OK**.

---

**Viewing and Saving the Results of Your Changes**

**Results of Your Changes to the Graph**

Here are the results of the changes that you made to the graph.
Because you have applied the Journal style, all of the objects in the graph are in shades of gray. However, the annotations (oval and arrow) are red because you explicitly set their color. If you want the annotation color to be consistent with the style’s colors, you can restore the annotations to their default color.

For a description of the graph, see “About the Economy Growth Example” on page 109.

**Save Your Changes**

To save the changes that you made to the graph:

1. Select **File ➤ Save As** from the main menu.

2. Specify the directory, filename, and file type. For more information, see “Save Graph Output ” on page 11.
annotation
a label, marker, or note that is not obtained from the data but is placed on a graph independently. Such annotations might or might not be linked to data values in the plot.

cell
in ODS graphics, a distinct rectangular subregion of a graph that can contain plots, text, or legends.

classification panel
a multi-cell graph in which the cell data is driven by the values of one or more classification variables. The number of the cells is determined by the unique values of the classification variables. Each cell of the panel has the same types of plots.

classification variable
da variable whose values are used to group (or classify) the observations in a data set into different groups that are meaningful for analysis. A classification variable can have either character or numeric values. Classification variables include group, subgroup, category, and BY variables.

Graph Template Language
an extension to the Output Delivery System (ODS) that enables users to create sophisticated analytical graphs. Short form: GTL.

GTL
See Graph Template Language.

locale
a setting that reflects the language, local conventions, and culture for a geographic region. Local conventions can include specific formatting rules for paper sizes, dates, times, and numbers, and a currency symbol for the country or region. Some examples of locale values are French_Canada, Portuguese_Brazil, and Chinese_Singapore.

marker
a symbol such as a diamond, a circle, or a triangle that is used to indicate the location of, or annotate, a data point in a plot or graph.

ODS
See Output Delivery System.
ODS Graphics
an extension to ODS that is used to create analytical graphs using the Graph Template Language.

ODS style
a template that specifies instructions for the presentation aspects (color, font face, font size, and so on) of your SAS output. This template determines the overall appearance of the documents that use it. Each style definition consists of style elements.

ODS template
a description of how output should appear when it is formatted. ODS templates are stored as compiled entries in a template store (item store). Common template types include STATGRAPH, STYLE, CROSSTABS, TAGSET, and TABLE.

outlier
a data point that differs from the general trend of the data by more than is expected by chance alone. An outlier might be an erroneous data point or one that is not from the same sampling model as the rest of the data.

Output Delivery System
a component of SAS software that can produce output in a variety of formats such as markup languages (HTML, XML), PDF, listing, RTF, PostScript, other formats, and SAS data sets.

panel
a graph with multiple cells.

plot
a visual representation of data such as a scatter plot, a series line, or a histogram. Multiple plots can be overlaid in a cell to create a graph.

scatter plot matrix
a grid of scatter plots showing pairwise combinations of multiple numeric variables.

SGE file
a file created in the ODS Graphics environment that contains an editable graph. Such files have a .SGE file extension and can be edited only with the ODS Graphics Editor. You can edit SGE files from the SAS Results window or by opening the SGE file from within the ODS Graphics Editor.
Index

A
about ODS Graphics Editor 3
aligning annotations 85
alternate short text 25
annotating graphs
  add text to objects 75
  align objects 85
  annotation concepts 45
  change data attachment properties 57
  copy and paste objects 83
delete objects 84
group objects 84
GTL annotations 6
images 66
lines and arrows 62
markers 65
move objects 83
order objects in layers 84
ovals (and circles) 64
rectangles (and squares) 64
resize objects 79
rotate objects 81
text annotations 61
annotation concepts 45
annotation objects 45
arrows 62
axis labels 36
grid lines 36
turn on and off 36

C
cell 5
circles
  See ovals
color, changing
data 32
  graph background 17
  plot background 32
colors, specifying 22
components of a graph 5

D
data attachment
  change properties 57
  concepts 45
data labels, show or hide 39
delete an annotation 84

e
edit a graph 9
editable graphs 8
editing concepts 6
editing graphs
  change background color 17
  plot properties 31
  resize a graph 16
  show or hide data labels 39
  specify a style 15
  working with axis labels 36
  working with footnotes 19
  working with titles 19

F
features of the editor 4
file types that can be edited 4
footnotes 19
Formatting toolbar 21

G
graph components 5
Graph Template Language (GTL) 3
Graph toolbar 10
  graphics
    See images
  grid lines 36
  grouping annotations 84

I
  images 66

L
  labels on data points
    show or hide 39
  lines 62
  locale setting 6

M
  markers 65
  move an annotation 83
  multi-cell graphs 40

O
  open a graph 9
  order of annotations 84
  ovals 64

P
  plot area 5
  plot properties 31
  PNG files 4
  print a graph 11

properties of a plot 31

R
  rectangles 64
  resize
    annotation 79
    graph 16
  rotate an annotation 81

S
  save a graph 11
  SGE files 4
  SGRENDER procedure 11
  short text 25
  size
    resize a graph 16
    resize an annotation 79
  size of an annotation 79
  squares
    See rectangles
  stand-alone editor
    downloading 7
    using 8
  style of a graph 15

T
  text, add to annotations 75
  text annotations 61
  titles 19
  toolbar, Formatting 21
  toolbar, Graph 10