## Contents


### PART 1  Introduction to the ODS Graphics Editor  1

**Chapter 1 • Overview of the ODS Graphics Editor** ................................. 3  
What Is the SAS/GRAPH ODS Graphics Editor? ........................................... 3  
Why Use the ODS Graphics Editor? ......................................................... 3  
Key Features of the ODS Graphics Editor ............................................... 4  
Types of Files That Can Be Edited ......................................................... 4  
Components of a Graph ........................................................................... 5  
General Editing Concepts ....................................................................... 5  
Use of Locale .......................................................................................... 6

**Chapter 2 • Getting Started with the ODS Graphics Editor** .................. 7  
Using a Stand-Alone ODS Graphics Editor ............................................... 7  
Creating Editable Graphics ..................................................................... 8  
Methods Used to Edit ODS Graphs ....................................................... 9  
About SGE Files Generated on z/OS Systems ..................................... 10  
About the Graph Toolbar ....................................................................... 10  
Save Graph Output ................................................................................ 11  
Print Graph Output ............................................................................... 12  
Copy and Paste a Graph ...................................................................... 12

### PART 2  Editing Graphs  13

**Chapter 3 • Modifying General Graph Properties** ................................. 15  
Specify a Style for a Graph ................................................................... 15  
Resize a Graph ....................................................................................... 16  
Change the Background Color of a Graph ........................................... 17

**Chapter 4 • Working with Titles and Footnotes** ................................... 19  
About Titles and Footnotes .................................................................. 19  
Add a Title or Footnote to a Graph ....................................................... 19  
Edit or Format a Title or Footnote ...................................................... 20  
Using the Formatting Toolbar ............................................................... 21  
Using the Color List Box .................................................................... 22  
Aligning a Title or Footnote in a Graph ............................................... 23  
Move a Title or Footnote in a Graph .................................................... 24  
Delete a Title or Footnote from a Graph ............................................. 25  
Use of Alternate Short Text in Graph Elements .................................. 25

**Chapter 5 • Working with Legends** ..................................................... 27  
Add or Edit a Legend Title .................................................................. 27  
Change the Outline and Background Color of a Legend ...................... 27  
Move a Legend Inside or Outside a Plot .............................................. 28
What's New in SAS/GRAPH 9.2: ODS Graphics Editor

Overview

The following changes are new for the SAS 9.2 Phase 2 release:

- enhancements to the behavior of graph annotations
- changes to the editing process

Annotation Enhancements

Here are several enhancements to graph annotations:

- You can draw an arrow annotation head-to-tail.
- After you create a line or arrow, you can rotate the line or arrow in 15-degree increments.
- After you create an oval or rectangle, you can resize the oval or rectangle while maintaining the aspect ratio of the original annotation.
- If a line or arrow annotation is attached to the data, then you can specify data values to position the line or arrow.

Editing Process Changes

A new SGE=ON option added to the ODS LISTING statement is used to create editable ODS graphs. When you run a graph procedure with this option, the ODS Graphics Editor generates an ODS Graphics Editor file (with the extension .sge). SGE files can be opened from the Results window or from an installed stand-alone ODS Graphics Editor (Windows and Linux hosts only). If you later change and rerun the SAS program, SAS creates a new SGE file. The original SGE file remains in the SAS Results window.

This change results in the following benefits:

- Editable graphics can be created in batch mode.
- SGE files can be created on z/OS systems. Though you cannot run the editor on z/OS systems, you can generate files on z/OS and then move those files to another system on which you can run the editor.
- SAS performance is improved because SGE files are created only when you use the SGE=ON option. When the ODS LISTING destination is closed or when SGE=OFF, SGE files are no longer created. (In the past, you issued an SGEDIT ON command in the SAS Results window to configure SAS to create editable graphs. This setting persisted across SAS sessions, so SGE files were always created until you issued an SGEDIT OFF command.)
Note: For backward compatibility, ODS Graphics Editor continues to honor the SGEDIT ON and SGEDIT OFF commands.

- SGE files are easy to identify because they are associated with a specific new icon.

On Windows and Linux systems, the stand-alone editor must be installed even when you plan to invoke the editor from SAS. You cannot open SGE files without the stand-alone editor on Windows and Linux systems.
Part 1

Introduction to the ODS Graphics Editor

Chapter 1
Overview of the ODS Graphics Editor ........................................... 3

Chapter 2
Getting Started with the ODS Graphics Editor .............................. 7
Chapter 1
Overview of the ODS Graphics Editor

What Is the SAS/GRAPH ODS Graphics Editor? .............................................. 3
Why Use the ODS Graphics Editor? ............................................................... 3
Key Features of the ODS Graphics Editor ..................................................... 4
Types of Files That Can Be Edited ............................................................... 4
Components of a Graph ............................................................................. 5
General Editing Concepts ....................................................................... 5
Use of Locale .............................................................................................. 6

What Is the SAS/GRAPH ODS Graphics Editor?

The SAS/GRAPH ODS Graphics Editor is a complementary tool in the ODS graphics system. It is an interactive graphical application used to edit and annotate ODS graphics that are created by a wide variety of SAS procedures. You can save the results as an image for inclusion in a report or as an SGE file that you can edit in the future.

You can launch the editor from a SAS session. You can also download a stand-alone version of the ODS Graphics Editor that runs apart from SAS. When you edit a graph from the Results window in SAS, changes that you make do not affect the original graph in the Results window.

Why Use the ODS Graphics Editor?

Many SAS analytical procedures now produce graphical output automatically using the ODS Graphics system. These graphics are produced using predefined templates that are shipped with SAS. The templates define the structure of the graph, including the plots, titles, footnotes, legends, and other attributes of the graph. You can customize the output graphs by editing the predefined template. However, such customization requires detailed knowledge of the Template procedure and the graph template language (GTL).

You might want to make small changes to a graph without having to work with templates and GTL. For example, you might want to add, edit, or remove a title or a footnote. Or, you might want to change the size, shape, and color of graphical elements such as the markers and lines. The ODS Graphics Editor provides a graphical user interface for making these changes easily without knowing the details of templates and GTL.
The ODS Graphics Editor enables you to edit the various elements in the output graph while keeping the underlying data unchanged. In addition, you can annotate a graph by inserting text, lines, arrows, images, and other items in a layer above the graph. You can save the results of your customization as an ODS Graphics Editor (SGE) file and make incremental changes to the file. You can also save the results as a Portable Network Graphics (PNG) image file for inclusion in other documents.

Key Features of the ODS Graphics Editor

Here are some of the tasks that you can perform with the ODS Graphics Editor:

- add, delete, or modify title and footnotes. You can add special symbols, superscripts, and subscripts to titles and footnotes.
- change the visual appearance of the entire graph by changing the applied style.
- resize the graph.
- change the appearance of individual plot elements such as markers and lines.
- show or hide data labels for selected data points in order to reduce clutter.
- add annotation such as text, lines, circles, images, and markers.
- copy the resulting graph to the system clipboard.

Types of Files That Can Be Edited

You can edit the following types of files:

- ODS Graphics Editor (SGE) files. You can edit SGE files from the SAS Results window or by opening the SGE file in the editor.
  
  In this file format, all of the graphical elements (titles, footnotes, and so on) are available for individual editing. In addition, you can add annotations on top of the graph.

  Note: If you are using SAS 9.2 Phase 1, you edit ODS graphics output (not SGE files) from the SAS Results window. When you edit a graph, the ODS Graphics Editor creates a file with the extension .sge, and then displays the file.

- Image files in PNG format.
  
  In this file format, all of the graph elements, including annotations, are flattened into an image and cannot be edited. However, you can add new annotations on top of the image.

See Also

- “Methods Used to Edit ODS Graphs” on page 9
- “Creating Editable Graphics ” on page 8
- “About SGE Files Generated on z/OS Systems” on page 10
Components of a Graph

The ODS Graphics output is called a graph. In general, a graph is made of up of the following parts:

- titles and footnotes
- one or more cells that contain a composite of one or more plots
- legends, which can reside inside or outside the cell or plot

The following figure shows the different parts of a graph:

Figure 1.1 Components of a Graph

General Editing Concepts

You can edit and annotate graphs. Editing and annotating tasks differ from each other in the following ways:
• When you edit a graph, you edit elements of the graph such as the title, footnote, or legend. You can also change the visual characteristics of the plots, such as the colors of markers and lines. You can change the style applied to a graph, and you can resize the graph.

Some of these edits can cause the layout of the graph to change.

• When you annotate a graph, you add objects on top of the original graph. You can add text, lines, arrows, ovals, rectangles, images, and markers. Annotation objects are rendered in a separate layer on top of the graphical elements and do not cause any changes to the layout of the graph.

Annotation objects can be attached to graph data so that, if the graph is resized, the annotations move with the data. For more information, “Understanding Annotation Objects and Data” on page 45.

Use of Locale

The ODS Graphics Editor uses the system locale, but the graph itself uses the SAS locale. For example, if the axis label is present, the label is shown in the language that SAS uses.
Chapter 2
Getting Started with the ODS Graphics Editor

Using a Stand-Alone ODS Graphics Editor

Download and Install the Stand-Alone ODS Graphics Editor

Start the Stand-Alone ODS Graphics Editor

Creating Editable Graphics

Methods Used to Edit ODS Graphs

Edit an ODS Graph from the SAS Results Window

Open a Graph in the ODS Graphics Editor

About SGE Files Generated on z/OS Systems

About the Graph Toolbar

Save Graph Output

Print Graph Output

Copy and Paste a Graph

Using a Stand-Alone ODS Graphics Editor

Download and Install the Stand-Alone ODS Graphics Editor

On Windows and Linux operating systems, you can run the ODS Graphics Editor as a stand-alone product without invoking SAS. You can download the stand-alone editor for free from SAS.

Note: Starting with SAS 9.2 Phase 2, on Windows and Linux operating systems, you must install the stand-alone editor even when you plan to invoke the editor from SAS. You cannot open the ODS Graphics Editor SGE files without the stand-alone editor. If you haven't already installed the stand-alone editor, you can download and install it using the following instructions.

To download the stand-alone ODS Graphics Editor:

1. Go to the SAS/GRAPH Web site:


2. Click the ODS Graphics Editor from the list. The ODS Graphics Editor Download Packages page appears.
3. View the README file for the appropriate platform. You might print the file so that you can refer to it later.  
   Note: Verify that you have the correct Java Runtime Environment installed, as specified in the README file.

4. Select Request Download.

5. Read the license agreement and then click I Accept. The Download page appears.

6. Click the Download button next to the file that you want to download. The compressed file is downloaded to your system.

7. Follow the instructions in the README file to unpack the files, start the SAS Deployment Wizard, and install the editor.

**Start the Stand-Alone ODS Graphics Editor**

Start the editor from your Windows Start menu.

To start the editor on Linux systems, follow the instructions in the editor's README file.

After you start the editor, you can select File ⇒ Open from the main menu and select an SGE file that you want to edit.

---

**Creating Editable Graphics**

You must create editable graph output before you can use the ODS Graphics Editor to edit the graph output.

To enable the creation of an editable graph, do the following in your SAS program:

- Open the LISTING destination. If LISTING is closed, no editable graph is produced. Other destinations can be open as well.
- Add the SGE=ON option to the LISTING destination.

   Here is the general form of the SGE option:

   ```sas
   sge = on|off|yes|no
   ```

   Here is an example of its usage in an ODS LISTING statement:

   ```sas
   ods listing sge = on;
   ```

- If needed, activate the ODS Graphics environment with the ODS GRAPHICS ON statement. This is not required for SAS/GRAPH procedures that produce only ODS Graphics output (SGPLOT, SGPANEL, SGSCATTER, or SGRENDER).

When you execute the SAS program, SAS creates an ODS Graphics Editor (SGE) file along with the graph image file. You can then open the SGE file from the Results window. For details, see “Edit an ODS Graph from the SAS Results Window” on page 9.

Note: You cannot open an SGE file on z/OS systems. For more information, see “About SGE Files Generated on z/OS Systems” on page 10.

If you later change and rerun the SAS program, SAS creates a new SGE file. The original SGE file remains in the SAS Results window.
Note: This feature is for SAS 9.2 Phase 2 and later. In SAS 9.2 Phase 1, rerunning the same program overwrites the output in the Results window.

To disable the creation of editable graphs, submit the following code in your program:

```sas
ods listing sge = off;
```

Alternatively, you can close and then reopen the LISTING destination.

Note: For backward-compatibility with SAS 9.2 Phase 1 programs, there is an alternative to the SGE=ON option. With the Results window active, enter SGERIT ON in the SAS command line. You can then execute a SAS program to create a graph that can be edited. The graph doesn't require the SGE option in its LISTING statement, though the LISTING destination must be active. The SGERIT ON command remains enabled for future SAS sessions. To turn off the editing option, enter SGERIT OFF in the command line. If you are using the SAS 9.2 Phase 1 editor, then you must use the SGERIT ON command. The Results window must be active in order to successfully issue the command. Otherwise, SAS doesn't recognize the command.

---

### Methods Used to Edit ODS Graphs

#### Edit an ODS Graph from the SAS Results Window

From the SAS Results window, you can edit an ODS graph that you create from a SAS program.

Before you attempt to edit a graph, make sure you have done the following:

- (Windows and Linux operating systems only) Installed the stand-alone ODS Graphics Editor if it's not already installed on the system. You cannot open ODS Graphics Editor files without the stand-alone editor. See “Using a Stand-Alone ODS Graphics Editor” on page 7.

- Created an editable graph. See “Creating Editable Graphics” on page 8.

Note: You cannot edit an ODS graph on z/OS systems.

To edit a graph from the SAS Results window:

1. Click the expansion icon in the SAS Results window to expand the list of graphs that you created.

2. Double-click the SGE file, which is identified by the icon.

   The ODS Graphics Editor opens and displays the graph for editing. You can now edit the graph using the various interactive tools.

   Note: If you are using SAS 9.2 Phase 1, you should instead right-click a graph image, and select Edit from the menu. The ODS Graphics Editor creates and opens a file with an .sge extension.

#### Open a Graph in the ODS Graphics Editor

You can open and edit a graph that has previously been saved in the ODS Graphics Editor. See “Types of Files That Can Be Edited” on page 4. In addition, you can open any SGE file that has been generated by using the SGE=ON option in the LISTING destination. This includes SGE files that were created on z/OS systems, which do not support running the
ODS Graphics Editor. For more information, see “About SGE Files Generated on z/OS Systems” on page 10.

To edit an existing graph:

1. Start the ODS Graphics Editor by opening an editable graph from the SAS Results window.

   *Note:* Alternatively, on Windows or Linux, you can start the stand-alone editor from your system Start menu.

2. In the ODS Graphics Editor, select **File** ⇒ **Open** from the main menu.

3. Select a file from the file system, and then select **Open**.

   If you selected an SGE file, you can edit and annotate the graph using the various interactive tools. If you selected a PNG file, then you can only annotate the graph.

---

**About SGE Files Generated on z/OS Systems**

The ODS Graphics Editor is a graphical application and, therefore, does not run on z/OS systems. You cannot edit graphs on z/OS, either from the SAS Results window or in the stand-alone editor. However, you can generate SGE files on z/OS, and then move the files to another system on which you can run the editor (Windows, Linux, or UNIX). Then you can start the editor and edit the SGE files that you moved. For more information about generating SGE files, see “Creating Editable Graphics” on page 8.

When you generate SGE files on z/OS, SAS always writes the SGE files to the UNIX file system (UFS). The z/OS `FILESYSTEM=` setting is ignored for writing SGE files. You must be authorized to create UFS files in your environment in order to generate the SGE files.

---

**About the Graph Toolbar**

In addition to the Standard and Formatting toolbars that are commonly used in applications, the ODS Graphics Editor has a Graph toolbar. The Graph toolbar contains icons that you can click to select graph objects or to insert items into a graph. (In addition to using the toolbar, you can also insert items by selecting them from the **Insert** menu.)

The following display shows the Graph toolbar:

![Graph Toolbar Icons](image)

To display the Graph toolbar, select **View** ⇒ **Toolbars** ⇒ **Graph** from the main menu. Be sure **Graph** is checked.

*Note:* If you are using SAS 9.2 Phase 1, you should instead select **View** ⇒ **Toolbars** ⇒ **Annotation** from the main menu.

You can use the following editing icons to edit your graph:

- **T** adds a title field to an ODS graph in which you can write a title. Selecting this icon again adds another title.
adds a footnote field to an ODS graph in which you can write a footnote. Selecting this icon again adds another footnote.

You can use the following selection icons:

enables you to select data and then show or hide labels for the selected data. This icon is available only when the graph contains labels.

enables you to select an object on your graph for editing.

You can use the following annotation icons to annotate your graph:

enables you to draw a text box on your graph, to which you can add text.

enables you to draw a line on your graph.

enables you to draw an arrow on your graph.

enables you to draw a rectangle or a square on your graph.

enables you to draw an oval or a circle on your graph.

enables you to select an image to insert into the graph.

places a marker at a place you select on your graph. As shown here, the current marker setting displays as a star. The icon in your operating environment might be different.

---

**Save Graph Output**

To save graph output:

1. Select File ➔ Save As from the menu.
2. Select the directory where you want the graph to be saved. The default location is the current directory for the SAS program that generated the SGE file.
3. Select the type of file to save.
   - If you save the file in SGE format, then you can later reopen and edit the file.
   - If you save the file in PNG format, then the graph is saved as a flat image. The graph in this format cannot be edited, though it can be annotated.

You can change the resolution by modifying the dots per inches (DPI). Changing the DPI affects only the image. The actual graph continues to display with 100 DPI.
Note: If you specify a DPI larger than 100, the graph image is resized. Any annotation that is not attached to the data retains its original position after the layout changes. For an example that illustrates this behavior, see “Example: Annotation Positioned Over a Legend in a Graph That Is Resized” on page 55. For more information about attachment to data, see “Understanding Annotation Objects and Data” on page 45.

4. Enter the name of the graph in the **File name** field.
5. Click **Save**.

The Save operation does not affect the graph output in the Results window in SAS.

---

**Print Graph Output**

You can print SGE and PNG files from the ODS Graphics Editor. You can also include a PNG file in a PDF document and then print the PDF document.

To print a graph from the ODS Graphics Editor:

1. Select **File ⇒ Print** from the menu.
2. Select print options from the Print window.
3. Click **OK**.

You can select **File ⇒ Print Preview** to preview your graph before you print it.

---

**Copy and Paste a Graph**

Graph output can be copied to the system clipboard to use in another document.

To copy and paste a graph:

1. Open the graph you want to copy.
2. Select **Edit ⇒ Copy View** from the main menu.

You can paste the graph into the target application using that application's paste command.
Part 2

Editing Graphs

Chapter 3
Modifying General Graph Properties

Chapter 4
Working with Titles and Footnotes

Chapter 5
Working with Legends

Chapter 6
Modifying Plot Properties and Axis Labels

Chapter 7
Working with Data Labels and Multi-Cell Graphs
Chapter 3
Modifying General Graph Properties

Specify a Style for a Graph

Styles control the overall visual appearance of graphs. Styles specify colors, fonts, line styles, and other attributes of graph elements. You can change the appearance of your graph by selecting one of the styles that are provided. For example, you can change the style of a graph from the Default style to the Journal style if the graph is intended for gray-scale publications.

By default, graph SGE files use the active ODS Listing destination style that is specified in the SAS program. For example, you can specify the Analysis style using the following statement in the program:

```
ods listing sge=on style=Analysis;
```

To select a style:

1. With your graph displayed, select Format ⇒ Style from the main menu.
2. From the cascading menu, select a graph style.

You can select one of the following styles:

**Analysis**
- A color style recommended for output in Web pages or for color print media. This style might not display well in gray-scale output.

**Default**
- A color style intended for general-purpose work. This style is designed to discriminate among groups in both color and gray-scale output.

**Journal**
- A gray-scale style recommended for journal articles and other publications that are printed in gray scale.

**Listing**
- Similar to Default but has a white background. This style is used by SAS for listing output.
Statistical

is a color style recommended for output in Web pages or for color print media. This style might not display well on devices that produce gray-scale output.

StatGraphScheme

is the style that was used when the graph was created. This style is selected by default.

Various elements of the graph derive their visual attributes, such as color, from specific style elements. Individual property settings override the style elements. For example, if you have assigned an overriding color to an object in the graph, then selecting a different style retains the overriding value that has been assigned.

Resize a Graph

When you resize a graph, you can then print or save the graph in its new size.

If you resize a graph and there is not enough space to display entire titles, footnotes, or axis labels, then an alternate short label is displayed. For details, see “Use of Alternate Short Text in Graph Elements” on page 25.

To resize a graph:

1. Select Format ⇒ Graph Properties. The Graph Properties dialog box opens.

2. In the Size section of the dialog box, click the up and down arrows in the Width and Height fields. The width and height are measured in inches. Clicking an arrow changes the value by 0.01 inch (which is equivalent to one pixel). Your graph becomes larger or smaller depending on the values you select.

   Alternatively, you can type the values in the fields.

   Note: To resize the graph proportionally, make sure the Keep Aspect Ratio check box is checked. If you want to specify the width and height independently without retaining the current aspect ratio, then clear the check box.

3. Click OK.
Change the Background Color of a Graph

To change the background color of a graph:

1. Select Format ⇒ Graph Properties. The Graph Properties dialog box opens.

   ![Graph Properties dialog box](image)

   You can also right-click anywhere in the graph and select Graph Properties from the menu.

2. In the Background section, select a color from the Fill list box. For details about setting the color, see “Using the Color List Box” on page 22.

   The outside of the plot area changes to the color you selected.

   Note: The value of Auto indicates that the background color is from the original graph.

3. Check or clear the Outline check box to turn the graph border on or off.

4. Click OK.
Chapter 4
Working with Titles and Footnotes

About Titles and Footnotes

You can add multiple titles and footnotes to a graph. The limit to the number of titles or footnotes that you can add depends on the size of your graph. As you add more titles or footnotes, the Y axis of the graph shrinks proportionally to the point where the graph is no longer visible.

When you add a long title or footnote to a graph, the text automatically wraps to the next line. If you move a title or footnote to a different location in the graph, all of the lines of a single title or footnote move as one unit.

Both titles and footnotes support rich text editing.

Note: In addition to titles and footnotes, some graphs might have been created with other text entries. You can edit any text entry that was defined as editable in the graph.

Add a Title or Footnote to a Graph

To add a title or footnote to a graph:

1. Select one of the following options:
• To add a title, select Insert ⇒ Title. Alternatively, click the Title icon in the Graph toolbar. The Insert Title text box displays at the top of the graph.

• To add a footnote, select Insert ⇒ Footnote. Alternatively, click the Footnote icon in the Graph toolbar. The Insert Footnote text box displays at the bottom of the graph.

2. Enter your text in the text box. A title or footnote cannot exceed 256 characters.

3. (Optional) Repeat the previous steps to add another title or footnote. For more information about adding multiple titles and footnotes, see “About Titles and Footnotes” on page 19.

To format the text, see “Edit or Format a Title or Footnote” on page 20.

Edit or Format a Title or Footnote

When you edit a title or footnote, you can change the text and the font properties. You can also use subscript or superscript values, and you can enter Unicode characters.

Note: Once you edit a title or footnote, then the alternate short text is not used. See “Use of Alternate Short Text in Graph Elements” on page 25.

To change a title or footnote:

1. Right-click the title or footnote that you want to change.


3. Select all or part of the text in the Text box and enter your changes.

4. You can format the selected text in the following ways:
• Select a different font from the font list box Arial.

• Select a different font size from the size list box 10.

• Click a button B I to make the text boldface or italic.

• Select a different font color from the color list box. For details, see “Using the Color List Box” on page 22.

• Click a button to change the text to superscript or subscript.

Note: If you are using SAS 9.2 Phase 1, you should instead select Superscript or Subscript from the top right list box.

• In the Insert Characters From section of the dialog box, select a character to insert it in your text. You can change the displayed characters by picking a different selection from the list box.

5. Click OK.

As an alternative to this procedure, you can double-click the title or footnote and type the new text. You can also change the font characteristics by using the Formatting toolbar. For details, see “Using the Formatting Toolbar” on page 21.

Using the Formatting Toolbar

The Formatting toolbar is active only if you have text selected in your graph. The text element that you select might be a title, footnote, an axis label, an annotation object, or a legend.

The following display shows the Formatting toolbar:

To display the Formatting toolbar, select View Toolbars Graph from the main menu. Make sure that the Formatting toolbar is checked.

The Formatting toolbar enables you to format the text in the following ways:

• Select a different font from the font list box Arial.

• Select a different font size from the size list box 10.

• Click a button B I to make the text boldface or italic.

• Click an alignment button to change the text alignment (left-aligned, centered, right-aligned).

• Select a different font color from the color list box. For details, see “Using the Color List Box” on page 22.
Using the Color List Box

When you specify different graph, plot, or annotation properties, you might have the option to select a color from a color list box. The color list box contains predefined colors to choose from and the option to define your own color. You can also pick an existing color from the graph.

The color list box contains the following items:

Auto
Restore the default color. This field is useful when you have changed a color and want to restore the original color.

Palette of colors
Select a predefined color from the palette.

Row of recently used custom colors
Select a custom color. This row is populated with colors that you choose by using either the More Colors or the Pick color from graph option.

More colors
Locate a custom color. This option opens the More Colors dialog box, which contains two tabs:
In the Swatches tab, select a color from the palette.

In the Custom tab, choose a color by dragging the slider and then picking a point in the color preview box. Alternatively, you can specify the HSB, RBG, or hexadecimal color value.

Pick color from graph
After you click this link, the color list box closes. You can then select any of the colors currently displayed in the graph by clicking the desired color.

Aligning a Title or Footnote in a Graph

Alignment of Titles and Footnotes

You can left-align, right-align, or center titles or footnotes in a graph. If you have multiple titles or footnotes in a graph, each title or footnote can have a different alignment.

Titles and footnotes can have multiple lines. When this occurs, the text wraps to the next line. If you change the alignment for this type of title or footnote, all of the lines that belong to the title or footnote move together as a whole.

Graphs that SAS produces can have one-part, two-part, or three-part titles or footnotes. Each part can occupy one of the alignment positions in the graph. You can change the alignment of a one-part title or footnote. For a two-part title or footnote, you can change either of the parts, one at a time. A three-part title or footnote occupies all three alignment positions in the graph, and no alignment changes are possible.

The following figure contains a three-part title.
**Align a Title or Footnote**

To change the alignment of a title or footnote:

1. Right-click the title or footnote that you want to align. For a two-part title or footnote, right-click the part that you want to align.

2. Select **Align** from the pop-up menu, and then select an alignment option. The title or footnote immediately moves to the area you selected.

Alternatively, you can click the title or footnote that you want to align (or a part of a two-part title or footnote). Then select one of the alignment buttons in the Formatting toolbar.

**Move a Title or Footnote in a Graph**

If you have multiple titles or footnotes in a graph, you can move a title or footnote up or down to reposition it. For example, the second title can be moved to become the first title, or the fifth footnote can be moved to become the second footnote.

If you have a single title or footnote, the alignment choices are dimmed.

To move a title or footnote in a graph:

1. Right-click the title or footnote that you want to move.

2. Select **Move** from the pop-up menu, and then choose **Up**, **Down**, **To Top**, or **To Bottom**.

Titles and footnotes can have up to three parts, one for each alignment position (left, center, right). You cannot move the individual part of multi-part title or footnote. The whole title or footnote moves together. (For more information about alignment, see “Aligning a Title or Footnote in a Graph” on page 23.)
Delete a Title or Footnote from a Graph

To delete a title or footnote in a graph:

1. Right-click the title or footnote that you want to delete.
2. Select Delete from the pop-up menu.

*Note:* To undo the change, select Edit ⇒ Undo from the menu.

For multi-part titles and footnotes, you can delete one part at a time.

Use of Alternate Short Text in Graph Elements

In addition to the standard text that is displayed, titles, footnotes, and axis labels have alternate short text. This short text is specified as a GTL option in the SAS program that defines the graph.

If there is not enough space to display the standard text, then the short text is displayed. For example, if you resize a graph and there is not enough space to display the whole axis label, then the short axis label is displayed. If you later enlarge the graph so that enough space is made available, then the long label is displayed.

You can override the short text by changing the text of the title, footnote, or axis label. Once you change the text, then only the new modified text is displayed regardless of the size of the graph.
Chapter 5
Working with Legends

Add or Edit a Legend Title ............................................ 27
Change the Outline and Background Color of a Legend ............. 27
Move a Legend Inside or Outside a Plot ................................ 28

Add or Edit a Legend Title

You cannot add or delete a legend. You also cannot edit the labels in the legend. You can, however, add or edit the title of the legend.

To add or edit a legend title:

1. Right-click the legend and select Add (Edit) Title from the pop-up menu. A Legend text box appears next to the legend.
2. In the text box, enter the text you want for the title. The title cannot exceed 256 characters.
3. To change the font characteristics, select the title text and use the Formatting toolbar. For details, see “Using the Formatting Toolbar” on page 21.

Change the Outline and Background Color of a Legend

To change the outline and fill color of a legend:

1. Right-click the legend and select Legend Properties from the pop-up menu. The Legend Properties dialog box opens.
2. To change the background color, select the Fill check box. Then click the down arrow in the fill color list box to select a color. For details about setting the color, see “Using the Color List Box” on page 22.

Note: If Auto appears in the list box, then the color of the legend is the same as the color selected when the graph was created. If you select another color, you can always go back to the original color by selecting the Fill check box and selecting Auto.

3. To change the outline color of the legend, select the Outline check box. Then use the down arrow to select an outline color.

4. Click OK.

---

**Move a Legend Inside or Outside a Plot**

You can move a legend to the inside or outside of a plot. You can also position the legend in different areas inside or outside of the plot.

To move a legend:

1. Right-click the legend and select Legend Properties from the pop-up menu. The Legend Properties dialog box opens.
2. To move the legend inside the plot area, complete these steps:
   a. Select the **Inside Plot Area** radio button.
   b. Select the new position from the list box. You can position the legend along an edge, in a corner, or in the center of the plot. The list box has the following options:
      - Top
      - Bottom
      - Left
      - Right
      - Center
      - Top Left
      - Top Right
      - Bottom Left
      - Bottom Right

3. To move the legend outside of the plot area, complete these steps:
   a. Select the **Outside Plot Area** radio button.
   b. Select the new position from the list box. The list box has the following options:
      - Top
      - Bottom
      - Left
      - Right

4. Click **OK**.
Chapter 6
Modifying Plot Properties and Axis Labels

Working with Plot Properties

The Plot Properties Dialog Box

You can modify all of the properties of the plots and axes that are in a cell by using the Plot Properties dialog box.
To open the Plot Properties dialog box, right-click in a plot and select Plot Properties. You can also click in the plot area and then select Format ➪ Plot Properties from the main menu.

The Plot Properties dialog box contains the following tabs:

**Table 6.1  Tabs in the Plot Properties Dialog Box**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>used to edit the general properties of the plot or the cell containing plots</td>
</tr>
<tr>
<td>Plots</td>
<td>used to edit the properties of individual plots</td>
</tr>
<tr>
<td>Axes</td>
<td>used to edit the properties of one or more axes</td>
</tr>
</tbody>
</table>

**General Properties**

In the General tab, you can modify the wall color and border of the cell.

You can select or clear the Fill and Outline check boxes to toggle on and off the fill color and outline of the plot area. When the Fill check box is selected, you can select a fill color from the list box.

**Plot Properties**

**About Plot Properties**

In the Plots tab, you can modify the properties of individual plots. If more than one plot is open, then you can select the plot that you want to modify from the Plot list box.
The types of properties that you see vary depending on the type of plot that you are modifying.

Note: Based on plot settings, the initial value for a property might be shown as Auto or Group. This means that the value is derived from the original plot setting or from the group variable. You can later revert back to the original Auto or Group setting if desired.

If you change the properties, the settings that you specify override any style that has been applied to the graph.

**Marker and Line Properties**

You can specify the color, pattern, and thickness of a plot's lines from the list boxes.

You can specify the color, shape, and size of a plot's markers from the list boxes.
For markers, in addition to Auto or Group value, the initial value for any of the properties might be as follows:

- If the MarkerColorGradient variable is defined, then Gradient is displayed as the current color value. The color list is dimmed, and you cannot change the color.
- If the MarkerCharacter variable is defined, then Character is displayed as the current shape. The shape and size are dimmed, and you cannot change them.

**Fill and Outline Properties**

Plots such as bar charts and histograms use graphical elements that have a fill color. The Fill check box is selected by default. If you specify an outline for the plot, then you can clear the Fill check box.

When the Fill check box is selected, then you can specify the fill color and the transparency. Moving the slider to the right makes the fill color more transparent. (The other part of the plots, such as its outline, do not change.) The default value for transparency is obtained from the plot definition.

You can toggle the plot's outline on and off. If the Outline check box is selected, then you can specify a color for the outline.

![Plot Properties](image)

**Contour Properties**

Contour has different graphical elements, such as lines, labels, fill, and gradient based on the contour type. You can change the contour type.

If the contour plot includes an area, such as a fill or gradient, then the color can be reversed by selecting the Reverse Gradient check box.

If the contour plot contains lines or labeled lines, then the line properties are enabled and can be edited.
Surface Properties

For surface plots, you can edit the surface type, color, and transparency. Moving the slider to the right makes the fill color more transparent.

If the Gradient variable is defined, then Gradient is displayed as the current color value. You can change the value for the color. If you change the color from Gradient to some other color, then that single color is used for the entire surface.

Axis Properties

In the Axes tab, you can modify the properties of labels for all the axes in a plot. You can select the axis you want to modify from the Axis list box.

Select or clear the Label check box to toggle the label on and off for the selected axis.
Select or clear the Grid check box to toggle the grid lines on and off for the selected axis. If the Grid check box is selected, then you can modify the color, the pattern (such as dotted or dashed), and the thickness of the grid lines.

For changes that can be made to axis labels, see “Edit an Existing Axis Label” on page 36.

---

**Working with Axis Labels**

You can change the appearance of a graph by adding labels to the graph's axes. For instructions on working with axis labels, see the following topics:

- “Edit an Existing Axis Label” on page 36
- “Add an Axis Label” on page 37
- “Show or Hide an Axis Label” on page 37
- “Delete an Axis Label” on page 38

You can also show grid lines for an axis and specify the visual properties of the grid lines. For more information, see “Axis Properties ” on page 35.

---

**Edit an Existing Axis Label**

You can edit an existing X or Y axis label (or X,Y, and Z labels for three-dimensional graphs). If the same axis is displayed on both sides of the graph (right and left or top and bottom), then your edits apply to both of the axis labels.

*Note:* Once you edit a label, then the alternate short text is no longer used for the label. For more information, see “Use of Alternate Short Text in Graph Elements ” on page 25.
To edit an axis label:
1. Double-click the axis label that you want to edit.
2. Enter or delete text in the axis label.
3. To change the font characteristics, select the label text and then use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 21.

---

### Add an Axis Label

To add a label to an axis:
1. Right-click along the axis where you want to add a label.
2. Select **Add ('Edit') Label** from the pop-up menu. A text box appears.
3. Enter the label for your axis in the text box. The label cannot exceed 256 characters.
4. To change the font characteristics, select the text and then use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 21.

---

### Show or Hide an Axis Label

To show or hide an axis label:
1. Right-click the axis label and select **Axis Properties**. The Plot Properties dialog box opens with the **Axes** tab displayed.

![Plot Properties dialog box](PlotPropertiesDialog.png)

2. In the **Axis** list box, select the axis whose label you want to show or hide.
3. Check or uncheck the **Label** box to show or hide the label.
Delete an Axis Label

To delete an axis label permanently from a graph:

1. Click the axis label that you want to delete.
2. Select **Edit ⇨ Delete**. Alternatively, you can press the DELETE key.
   The label is permanently deleted.

   *Note:* To undo the change, select **Edit ⇨ Undo** from the main menu.
Chapter 7
Working with Data Labels and Multi-Cell Graphs

Working with Data Labels

Some plots might display data labels for each observation in the plot. If there are a lot of observations, then the plot can become cluttered. You can limit the display to those data labels that are important to the analysis.

To display or hide data labels:

1. Click the data label icon \( \text{\textbullet} \) in the Graph toolbar.

2. Select the observations for data label management in any of the following ways:
   - Click an observation to select it. If you press CTRL and click an observation, you can toggle the observation on and off. Pressing CTRL also enables you to select multiple observations.
   - Click on the data label of an observation to select it.
   - Click and drag to select an area within the plot. All the observations in this area are selected. You can add more items to the selection list by pressing CTRL while you click and drag to select another area containing additional observations.

3. Right-click and select one of the following label options:
   - **Show Only Selected** shows labels only for those data points that are currently selected. This option first turns off all the data labels and then displays the labels only for the selected data points.
   - **Show Selected** shows labels for the data points that are selected. This option leaves unchanged the data labels for all other data points that are not currently selected. For example, if you previously selected data points and set them to show, with this option they remain selected.
   - **Hide Selected** hides labels for those data points that are selected.
   - **Show All** shows labels for all the data points.
   - **Hide All** hides labels for all the data points.
All items in the selection list are displayed with the selection color. If the selected item is in a scatter overlay and a marker is selected, then the marker displays with the selection color. For a line overlay, if the marker is not turned on, then a temporary circle is created and displayed with the selection color.

The layout of a plot refreshes when labels are turned off or on. If some labels are located away from their data points, the labels move closer to the data points if space is made available by hiding other labels.

### Working with Multi-Cell Graphs

A graph can contain multiple cells, each cell with one or more plots. For a visual description of graphs and cells, see “Components of a Graph” on page 5.

Multi-cell graphs can be created in different ways:

- A multi-cell graph can be defined using a GRIDDED or LATTICE layout. Each cell is defined independently and can contain different types of plots.

A multi-cell graph can be defined using a DATALATTICE or DATAPANEL layout. Both layouts are data-driven layouts that create a grid of cells based on a graph prototype and one or more classification variables. The number of the cells is determined by the values of the classification variables.

You can modify plot properties separately for each cell.

- A multi-cell graph can be defined using a DATALATTICE or DATAPANEL layout. Both layouts are data-driven layouts that create a grid of cells based on a graph prototype and one or more classification variables. The number of the cells is determined by the values of the classification variables.
When you change the plot properties for one cell, the change is applied to all the cells of the graph.

- A multi-cell graph can be created by using a SCATTERPLOTMATRIX layout.
Each non-diagonal cell contains the same plot types, but for a different crossing of the variables. When you change the plot properties for one of these cells, the change is applied to all non-diagonal cells. (The wall and outline properties apply to all cells.)

You cannot change the properties of the following:

- the diagonal cells
- the axes
Part 3

Annotating Graphs

Chapter 8
Annotation Overview .................................................. 45

Chapter 9
Using Annotations in a Graph ...................................... 61

Chapter 10
Changing the Visual Properties of Annotations .............. 69

Chapter 11
Adding Text to Annotations ......................................... 75

Chapter 12
Modifying Annotations ............................................... 79
Chapter 8
Annotation Overview

About Annotation Objects

You can use ODS Graphics Editor to add the following annotation objects to a graph:

- text annotations
- lines and arrows
- ovals (and circles)
- rectangles (and squares)
- markers
- images

The annotation objects are rendered on top of the graph. Unlike titles and footnotes, annotation objects do not cause a graph to be resized or rearranged.

Annotation objects can be attached to a graph data points. If the graph is resized, the annotations move with the data point. For more information, see “Understanding Annotation Objects and Data” on page 45.

Understanding Annotation Objects and Data

You can add free-form annotations (such as text, lines, circles, images, and markers) to a graph. The annotation objects are rendered on top of the graph. Unlike titles and footnotes,
annotation objects do not cause a graph to rearrange. However, annotation objects can be
attached to data points in the plot area. If the graph is resized, the annotations move with
the data points.

Whether an annotation is attached to the data depends on where the annotation was created
in the graph, as described in the following table:

Table 8.1 Location Determines Default Data Attachment

<table>
<thead>
<tr>
<th>Annotation Location</th>
<th>Behaviors</th>
</tr>
</thead>
</table>
| Created totally within in the plot area | By default, the annotation object is attached to the data markers, lines, and so on, in the plot area. For example, suppose that you create a rectangle in the plot area next to a data marker. Suppose also that the graph changes due to the addition or removal of titles or footnotes. The location of the rectangle changes along with the location of the data marker even though the plot area might change in size. In other words, the rectangle location remains synchronized with the data location. There are two exceptions:
  • Three-dimensional plots, such as surface plots, do not support this data synchronization feature. Annotations on these plots cannot be attached to data points.
  • Image annotations cannot be attached to data points. They always behave as though they were created outside the plot area.

By default, if you move an annotation object that was created in the plot area beyond the plot area border, the annotation is cropped at the plot area boundary.

For most annotation objects, you can specify that annotations created inside the plot area act like annotations created outside the plot area (that is, they lose their data synchronization). For details, see “Change the Data Attachment Properties of an Annotation” on page 57. |
| Created totally outside plot area | By default, annotation objects created outside the plot area are positioned relative to the overall size of the graph. These annotation objects are not attached to the data in the plot area. If the graph is resized, the annotation object maintains its position relative to the entire graph. For example, suppose you add a marker annotation to the bottom center of a graph (outside the plot area). If you resize the graph, the marker stays in the bottom center.

Annotation objects that are created outside the plot area and then moved inside the plot area do not become attached to the data. |
### Data Attachment Examples for Annotations

**Example: Text Annotation**

This example shows how text annotations behave when the plot area is resized. The behavior varies depending on whether the annotation is attached to the data.

The following display shows a text annotation in the upper left corner within a plot. In the example, the text annotation has a red circle around it:

*Display 8.1  Example Text Annotation in a Plot*

By default, the annotation is attached to data in the upper left corner.

The following display shows the same graph with titles added. The titles cause the plot to get smaller. The annotation stays with the data when the graph is resized.
The next display shows the result when you add titles to the graph but have changed the properties of the text annotation so that the annotation is not attached to the data.

**Display 8.3 Text Annotation That is Not Attached to the Data**

The text remains in place when the plot is resized because the text is not attached to the data.

**Example: Oval Annotation Around a Data Point**

This example shows the behavior of ovals that are created around data points when the plot area is resized. The behavior varies depending on whether the oval is attached to the data point.

The following display shows an oval annotation around a data point in a plot:
By default, the annotation is attached to the data point.

The following display shows the same graph with more titles added. The titles cause the plot to get smaller. The oval stays around the data point when the graph is resized.
The next display shows the result when you add titles to the graph but have changed the properties of the oval so that it is not attached to the data.
Display 8.6 Oval Annotation That is Not Attached to the Data

The oval does not move when the plot is resized because the oval is not attached to the data point.

Example: Arrow Annotation Partially Attached to Data

This example shows the behavior of arrow annotations when the plot area is resized. One end of the arrow is attached to the data and the other end isn't.

The following display shows an arrow with one end in a plot and the other end outside the plot:
Display 8.7  Arrow That Is Partially in a Plot

Only the end that resides within the plot is attached to the data.

The following display shows the same graph with another title added. When the plot is resized, the end of the arrow that is attached to the data moves, while the other end stays in place.

Display 8.8  Arrow in a Resized Plot

Example: Marker Annotation with Text That Is Cropped

This example shows the behavior of marker annotations that have text when the text is moved off the edge of the plot.

The following display shows a marker annotation with text (toward the bottom of the plot):
By default, the marker and its text are attached to the data.

The next display show the marker after it has been moved downward so that the text moves outside the plot. The text disappears (is cropped). By default, when the annotation is attached to the data, any part of the annotation that resides outside the plot is cropped.
The next display shows the result when you change the properties of the marker so that cropping is disabled. The marker text appears outside the plot.
Note: Another way to make the marker text appear is to reposition the text above the marker. You can also change the properties of the marker so that it is not attached to the data.

**Example: Annotation Positioned Over a Legend in a Graph That Is Resized**

This example shows the behavior of an annotation that is positioned over a legend. Because it is created outside the plot area, the annotation is not attached to the data. When the graph is resized, the annotation stays in place.

The following display shows a graph that has a legend, with an oval created around part of the legend:
By default, the annotation is not attached to the data because it was created outside of the plot area.

The next display shows the same graph when it is reduced in size. The oval moves with the graph, but is no longer around the same portion of the legend.
Note: The same behavior occurs when you save the graph as a PNG file and specify a DPI larger than 100. When you close and then reopen the PNG, you see that the graph size has changed. However, the oval that was positioned over the legend is no longer around the same portion of the legend.

Change the Data Attachment Properties of an Annotation

Depending on where in a graph you create an annotation object, the object might be attached to the data inside the plot area. For more information about data attachment, see “Understanding Annotation Objects and Data” on page 43.

You can change the data attachment behavior of an annotation object. You can control whether the object is attached to data and whether to crop any portion of the object that resides outside of the plot.

To change the data attachment behavior for an annotation object:

1. Right-click the annotation object whose behavior you want to change and select Annotation Properties from the pop-up menu.

2. Select the Position tab.
3. If you are modifying a line or arrow, then make the following changes:
   a. In the **Line Point** list box, select which end of the line or arrow you want to change.

   ![Annotation Properties Dialog Box]

   b. Select or clear **Attach to data in underlying Plot area**. If this option is selected, then the corresponding end of the line is attached to data and is not visible outside the plot area. If you clear this option, then the corresponding end of the line is not attached to the data and becomes visible outside the plot area.

   If the line or arrow was created outside the plot area, then this check box is dimmed.

   You can also change the vertical or horizontal placement of the selected end point. For more information, see “Resize by Using the Annotation Properties Dialog Box” on page 80 and “Rotate by Using the Annotation Properties Dialog Box” on page 82.

4. If you are modifying an oval, rectangle, or marker, then make the following changes:
   a. Select or clear **Attach to data in underlying Plot area**. If this option is selected, then the annotation object is attached to the data.
b. If the annotation object is attached to data (Attach to data in underlying Plot area is selected), then you can crop the part of the object that is outside of the plot. To toggle cropping on or off, select or clear Crop the part outside Plot area.

If the annotation was created outside the plot area, then both of these check boxes are dimmed.

You can also rotate the annotation. For more information, see “Rotate by Using the Annotation Properties Dialog Box ” on page 82.

5. Click **OK**.
## Chapter 9
Using Annotations in a Graph

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Text Annotations</td>
<td>61</td>
</tr>
<tr>
<td>Add a Text Annotation to a Graph</td>
<td>62</td>
</tr>
<tr>
<td>Edit a Text Annotation</td>
<td>62</td>
</tr>
<tr>
<td>About Lines and Arrows</td>
<td>62</td>
</tr>
<tr>
<td>Add a Line to a Graph</td>
<td>63</td>
</tr>
<tr>
<td>Add an Arrow to a Graph</td>
<td>63</td>
</tr>
<tr>
<td>About Ovals and Rectangles</td>
<td>64</td>
</tr>
<tr>
<td>Add an Oval to a Graph</td>
<td>64</td>
</tr>
<tr>
<td>Add a Rectangle to a Graph</td>
<td>65</td>
</tr>
<tr>
<td>About Markers</td>
<td>65</td>
</tr>
<tr>
<td>Add a Marker to a Graph</td>
<td>66</td>
</tr>
<tr>
<td>About Images</td>
<td>66</td>
</tr>
<tr>
<td>Add and Position an Image in a Graph</td>
<td>67</td>
</tr>
</tbody>
</table>

## About Text Annotations

You can change the appearance of a graph by adding text annotations. For instructions on working with text annotations, see the following topics:

- “Add a Text Annotation to a Graph” on page 62
- “Edit a Text Annotation” on page 62
- “Format a Text Annotation” on page 69

You can also make the following changes:

- Change the size of a text annotation. For instructions, see “Resize an Annotation” on page 79.
- Rotate a text annotation. For instructions, see “Rotate an Annotation” on page 81.
- Move a text annotation. For instructions, see “Move an Annotation” on page 83.
- Change the data attachment properties of a text annotation. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 57.
Add a Text Annotation to a Graph

To add a text annotation to a graph:

1. Click the text icon in the Graph toolbar, or select Insert \( \rightarrow \) Text from the main menu.
2. Click the area of the graph where you want to position your text. A text box appears.
3. Enter the text in the box.
   
   The width of the text box determines the maximum width of the text line. If a line exceeds the width of the text box, then the text wraps to the next line.
4. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format a Text Annotation” on page 69.

By default, if the text object was created in the data area then it is attached to the data, and any part that is outside the data area gets cropped. For more information, see “Understanding Annotation Objects and Data” on page 45.

Edit a Text Annotation

To edit a text annotation:

1. Double-click the text annotation that you want to change.
2. Enter your textual changes.
3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format a Text Annotation” on page 69.

About Lines and Arrows

You can change the appearance of a graph by adding lines and arrows. You can also add text to the lines and arrows. For instructions on working with lines and arrows, see the following topics:

- “Add a Line to a Graph” on page 63
- “Add an Arrow to a Graph” on page 63
- “Change the Color, Pattern, and Thickness of a Line or Arrow” on page 69

You can also make the following changes:
Add a Line to a Graph

To add a line to a graph:

1. Click the line icon in the Graph toolbar, or select **Insert** ⇒ **Line** from the main menu.
2. Position your cursor at a starting position in the graph.
3. Click and drag to create the line in the graph.

You can control the line as follows:

- If you press the CTRL key and then click and drag, the line is created from the center and moves outward.
- If you press SHIFT and then click and drag, then the line's orientation stays in multiples of 15 degrees. You can create a perfect horizontal or vertical line this way. You can also rotate the line in 15 degree increments to create a diagonal line.
- If you press CTRL+SHIFT and then click and drag, the line is created from the center, moves outward, and can be rotated in 15 degree increments.

You can add text to the line. For instructions, see “Add Text to an Annotation” on page 75.

Add an Arrow to a Graph

You can add an arrow to a graph to point out specific information. To add an arrow to a graph:

1. Click the arrow icon in the Graph toolbar, or select **Insert** ⇒ **Arrow** from the main menu.
2. Position your cursor at a starting position in the graph.
3. Click and drag to create the arrow. By default, the arrow is drawn from the tail to the head.

You can control the arrow as follows:
• If you press the CTRL key and then click and drag, the arrow is created from the head to the tail.

• If you press SHIFT and then click and drag, then the arrow's orientation stays in multiples of 15 degrees. You can create a perfect horizontal or vertical arrow this way. You can also rotate the arrow in 15 degree increments to create a diagonal arrow.

• If you press CTRL+SHIFT and then click and drag, the arrow is created from the head to the tail, and can be positioned in 15 degree increments.

When you create your arrow, a text box appears at the end of the arrow.

4. (Optional) Enter text in the text box that appears at the tail end of the arrow.

If you don't add text now, you can do so later. For instructions, see “Add Text to an Annotation” on page 75.

---

**About Ovals and Rectangles**

You can change the appearance of a graph by adding ovals (or circles) and rectangles (or squares). You can also add text to the ovals and rectangles. For instructions on working with ovals and rectangles, see the following topics:

• “Add an Oval to a Graph” on page 64
• “Add a Rectangle to a Graph” on page 65
• “Change the Color, Transparency, and Outline Properties of an Oval or Rectangle” on page 70

You can also make the following changes:

• Add text to an oval or rectangle. For instructions, see “Add Text to an Annotation” on page 75.

• Change the size of an oval or rectangle. For instructions, see “Resize an Annotation” on page 79.

• Rotate an oval or rectangle. For instructions, see “Rotate an Annotation” on page 81.

• Move an oval or rectangle. For instructions, see “Move an Annotation” on page 83.

• Change the data attachment properties of an oval or rectangle. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 57.

• Copy and paste an oval or rectangle. For instructions, see “Copy and Paste an Annotation Object” on page 83.

• Delete an oval or rectangle. For instructions, see “Delete an Annotation” on page 84.

---

**Add an Oval to a Graph**

To add an oval (or a circle) to a graph:
1. Click the oval icon 🍊 in the Graph toolbar, or select Insert ➼ Oval from the menu.
2. Place your cursor at the top left position in the graph where you want your oval to begin.
3. Click and drag your cursor to the right to create an oval.
   
   You can control the oval as follows:
   - If you press the CTRL key and then click and drag, the oval expands from the center.
   - If you press the SHIFT key and then click and drag, you can draw a perfect circle.
   - If you press SHIFT + CTRL and then click and drag, you draw a circle that expands from the center.

   You can add text to the oval. For instructions, see “Add Text to an Annotation” on page 75.

---

### Add a Rectangle to a Graph

To add a rectangle (or a square) to a graph:

1. Click the rectangle icon 💎 in the Graph toolbar, or select Insert ➼ Rectangle from the menu.
2. Place your cursor at the top left position in the graph where you want your rectangle to begin.
3. Click and drag your cursor to the right to create a rectangle.

   You can control the rectangle as follows:
   - If you press the CTRL key and then click and drag, the rectangle expands from the center.
   - If you press the SHIFT key and then click and drag, you can draw a perfect square.
   - If you press SHIFT + CTRL and then click and drag, you draw a square that expands from the center.

   You can add text to the rectangle or square. For instructions, see “Add Text to an Annotation” on page 75.

---

### About Markers

You can change the appearance of a graph by adding markers to the graph. For instructions on working with markers, see the following topics:
- “Add a Marker to a Graph” on page 66
- “Change the Color, Symbol, and Size of a Marker” on page 71

You can also make the following changes:
- Add text to a marker. For instructions, see “Add Text to an Annotation” on page 75.
- Rotate a marker. For instructions, see “Rotate an Annotation” on page 81.
- Move a marker. For instructions, see “Move an Annotation” on page 83.
• Change the data attachment properties of a marker. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 57.

• Copy and paste a marker. For instructions, see “Copy and Paste an Annotation Object” on page 83.

• Delete a marker. For instructions, see “Delete an Annotation” on page 84.

Add a Marker to a Graph

You can use a marker to identify or accentuate key data elements in a graph, such as data points that are outliers.

To add a marker to a graph:

1. Click the marker icon ★ in the Graph toolbar, or select Insert ➔ Marker from the main menu.

   **Note:** As shown here, the marker icon is a star. The icon in your operating environment might be different. In addition, you can change the symbol that is used for the icon. For instructions, see “Change the Color, Symbol, and Size of a Marker” on page 71.

2. Click the area of the graph where you want to place the marker.

   You can add text to the marker. For instructions, see “Add Text to an Annotation” on page 75.

About Images

You can add images to a graph. For instructions on working with images, see the following topics:

• “Add and Position an Image in a Graph” on page 67

• “Format an Outline Around an Image” on page 72

You can also make the following changes:

• Add text to an image. For instructions, see “Add Text to an Annotation” on page 75.

• Change the size of an image. For instructions, see “Resize an Annotation” on page 79.

• Rotate an image. For instructions, see “Rotate an Annotation” on page 81.

• Move an image. For instructions, see “Move an Annotation” on page 83.

• Copy and paste an image. For instructions, see “Copy and Paste an Annotation Object” on page 83.

• Delete an image from a graph. For instructions, see “Delete an Annotation” on page 84.
Add and Position an Image in a Graph

You can add an image, such as a logo, to a graph. When you add an image to a graph, the image appears in the center of the graph. You can reposition and resize the image if necessary.

To add, resize, and reposition an image:

1. Click from the Graph toolbar, or select Insert \( \Rightarrow \) Image from the main menu.

2. From the Image dialog box that displays, select and open the image that you want to insert.
   
   The image appears in the center of the graph.

3. To resize the image, select the image and drag one of the circles that appear around the image. You can maintain the ratio of width to length. Position your cursor on a corner circle, press SHIFT, and drag the corner circle.

4. To move the image to a different position, click and drag the image to another position in the graph.

Note: Images are not attached to the data. For more information about data attachment, see “Understanding Annotation Objects and Data” on page 45.
Chapter 10
Changing the Visual Properties of Annotations

Format a Text Annotation

You can change the font, size, style (for example, bold or italicized), alignment, or color of the text in a text annotation.

To format a text annotation:

1. Click the text annotation.
2. Use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 21.

Text format changes that you make here remain in effect for new annotations that you add.

As an alternative to this procedure, you can right-click the text annotation, select Annotation Properties, and make your changes in the Text tab. You can change the font, size, style, and color.

Change the Color, Pattern, and Thickness of a Line or Arrow

To change the color, pattern (such as dotted or dashed), or thickness of a line or arrow:

1. Right-click the line or arrow and select Annotation Properties from the menu. The Annotation Properties dialog box opens.
2. Make sure that the Appearance tab is selected.

3. Click the down arrows to select the line's color, pattern, and thickness. The line or arrow changes appearance.

4. Click OK.

Line format changes that you make remain in effect for new annotations that you add.

---

**Change the Color, Transparency, and Outline Properties of an Oval or Rectangle**

You can change various format properties of an oval or a rectangle.

To format ovals and rectangles:

1. Right-click the oval or rectangle and select **Annotation Properties** from the menu. The Annotation Properties dialog box opens.
2. Make sure that the **Appearance** tab is selected.

3. You can specify a fill color for the oval or rectangle as follows:
   a. Select the **Fill** check box and then select a color from list box. For details, see “Using the Color List Box” on page 22.
   b. Change the fill transparency of the oval or rectangle by sliding the arrow in the **Transparency** field. Moving the slider to the right makes the fill more transparent.

4. In the **Outline** section of the dialog box, you can change the outline of the oval or rectangle as follows:
   • Select a color for the outline from the **Color** list box.
   • Select a different pattern (such as dotted or dashed) for the outline from the **Pattern** list box.
   • Select a different thickness for the outline from the **Thickness** list box.
   • If the **Fill** check box is selected, then you can remove the outline. Select or clear the **Outline** check box to toggle the outline on and off.

5. Click **OK**.

Outline and fill format changes that you make remain in effect for new annotations that you add.

---

**Change the Color, Symbol, and Size of a Marker**

To change the color, symbol, and size of a marker:

1. Right-click the marker and select **Annotation Properties**. The Annotation Properties dialog box opens.
2. Make sure that the **Appearance** tab is selected.

3. To specify a color, symbol, or size, click the arrows in the fields and make a selection. You can also change the marker's size using a click-and-drag method. For details, see “Resize an Annotation” on page 79.

4. Click **OK**.

---

**Format an Outline Around an Image**

You can add an outline to an image and then specify the color, pattern, and thickness of the outline.

To add and format an outline:

1. Right-click the image and select **Annotation Properties**. The Annotation Properties dialog box opens.
2. Make sure that the **Appearance** tab is selected.

3. Select the **Outline** check box to add an outline to the image.

4. To specify the outline's color, pattern, and thickness, click the arrows in the fields and make a selection.

5. Click **OK**.
Chapter 11
Adding Text to Annotations

Overview of Adding Text to Annotations
In addition to adding text annotations to a graph, you can add text to lines, arrows, ovals, rectangles, images, and markers.

Note: When you create an arrow in your graph, a text box appears. The text box disappears if you click outside the arrow without entering text. You can later add text to the arrow.

For instructions on working with annotations and text, see the following topics:
- “Add Text to an Annotation” on page 75
- “Edit Text That Has Been Added to an Annotation” on page 76
- “Format Text That Has Been Added to an Annotation” on page 76
- “Move Text That Has Been Added to an Annotation” on page 77

Add Text to an Annotation
To add text to an annotation:
1. Right-click the annotation object and select Add ('Edit') Text from the pop-up menu.
   A text box appears. The location of the text box depends on the type of annotation.
   - For ovals and rectangles, the text box appears inside the oval or rectangle.
• For lines, the text box appears within the line. For arrows, the text box appears at the tail end of the arrow. The following display shows a text box within a line.

• For markers and images, the text box appears beneath the marker or image. The following display shows a text box beneath a marker.

2. Enter text in the box.

3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format Text That Has Been Added to an Annotation” on page 76.

For an oval or rectangle, the text is placed inside the oval or rectangle by default. The text wraps when it reaches the boundary of the annotation object. If there is insufficient space for the text that wraps, then the oval or rectangle increases its size to make space.

---

**Edit Text That Has Been Added to an Annotation**

To edit text that has been added to an annotation:

1. Right-click the annotation object and select Add ('Edit') Text from the pop-up menu.
   
   A text box surrounds the text.

2. Edit text in the box.

3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format Text That Has Been Added to an Annotation” on page 76.

---

**Format Text That Has Been Added to an Annotation**

To format text that has been added to an annotation:

1. Right-click the annotation object and select Add ('Edit') Text from the pop-up menu.
   
   A text box surrounds the text.

2. Select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For details, see “Using the Formatting Toolbar” on page 21.
Changes that you make remain in effect for any new annotations that you add.

As an alternative to this procedure, you can right-click the text annotation, select **Annotation Properties**, and make your changes in the **Text** tab. You can change the font, size, style (for example, bold or italicized), and color.

---

**Move Text That Has Been Added to an Annotation**

To move text that has been added to an annotation:

1. Right-click the annotation object and select **Annotation Properties** from the pop-up menu.
2. Select the **Text** tab.
3. Select the desired position for the text as follows:
   - For lines and arrows, select the **Through**, **Above**, **Below**, **Start**, or **End** radio button to position the text with respect to the line or arrow.
   - For all other annotation objects, select the **Inside**, **Above**, or **Below** radio button to position the text with respect to the object.
4. Click **OK**.

For all annotations other than images, if your selection places the text outside of the plot, then the text might be cropped. For more information, see “Understanding Annotation Objects and Data” on page 45. To turn cropping off, see “Change the Data Attachment Properties of an Annotation” on page 57.
Resize an Annotation

Resize by Dragging

To change the size of an annotation:

1. Click the annotation object that you want to resize.
   Small circles surround the object. If you click a line or arrow, a circle appears at each end of the line or arrow.

2. Click and drag a circle to change the size of the annotation as follows:
   • To change the length of a line or arrow, drag an end circle backward or forward.
     
     Press SHIFT and drag to keep the line or arrow perfectly horizontal, vertical, or diagonal in 15 degree increments.
   • To resize all other annotations, drag one of the circles to expand or reduce the annotation. To change the width and length of the annotation simultaneously, position the cursor in a circle at one of the corners.
You can maintain the ratio of width to length. Position the cursor in a corner circle, press SHIFT, and drag the corner circle.

The following display shows the cursor positioned on a corner circle of a marker.

Note: For text annotations, this procedure changes the size of the text block, not the size of the font. To change the font, see “Format a Text Annotation” on page 69.

**Resize by Using the Annotation Properties Dialog Box**

You can use the Annotation Properties dialog box to resize markers and change the length of lines and arrows. This method provides more granular control of the size.

1. Right-click the line, arrow, or marker and select *Annotation Properties* from the pop-up menu. The Annotation Properties dialog box opens.

2. To resize a marker, complete these steps:
   a. Select the *Appearance* tab.

   ![Annotation Properties Dialog Box](image)

   b. Select the size you want from the *Size* list box.

3. To change the length of a line or arrow, complete these steps:
   a. Select the *Position* tab.

   ![Annotation Properties Dialog Box](image)
b. Select one end of the line from the **Line Point** list box. You select either the start or the end point of the line.

If the selected end point is attached to the data, then the **Horizontal** and **Vertical** values correspond to a point along the X and Y axis, respectively.

If the end point is not attached to the data, then the **Horizontal** and **Vertical** values are measured in inches from the top left corner of the graph.

c. From the **Horizontal** list box, select the new start or end point (whichever you have selected) in order to extend or shrink the length of the line or arrow. Only one end of the line or arrow moves. The other end remains fixed.

d. (Optional) Repeat steps b and c to extend or shrink the other end of the line.

4. Click **OK**.

---

**Rotate an Annotation**

**Rotate by Dragging the Annotation**

To rotate an annotation:

1. Select the annotation object that you want to rotate.

   Small circles surround the object, and a handle appears at the top of the object. If you select a line or arrow, a circle appears at each end of the line or arrow.

2. To rotate a line or arrow, drag an end circle up or down.

   If you press SHIFT and then drag, you can rotate the line in 15 degree increments.

3. To rotate all other annotations, complete these steps:

   a. Place your cursor in the circle at the top of the handle. The cursor changes to a rotated arrow.
b. Click and drag the handle to the right or left to rotate the annotation object.

**Rotate by Using the Annotation Properties Dialog Box**

You can use the Annotation Properties dialog box to rotate annotation objects. This method provides more granular control of the angle of rotation.

1. Right-click the annotation object and select **Annotation Properties** from the pop-up menu. The Annotation Properties dialog box opens.

2. Select the **Position** tab.

3. To rotate a line or arrow, complete these steps:
   a. Select one end of the line from the **Line Point** list box. You select either the start or the end point of the line.

   If the selected end point is attached to the data, then the **Horizontal** and **Vertical** values correspond to a point along the X and Y axis, respectively.

   If the end point is not attached to the data, then the **Horizontal** and **Vertical** values are measured in inches from the top left corner of the graph.

   b. From the **Vertical** list box, select the new start or end point (whichever you have selected) in order to move the end point up or down. Increasing the value of **Vertical** moves the end point down. Only one end of the line or arrow moves. The other end remains fixed.

4. To rotate all other annotation objects, select or enter the angle of rotation in the **Rotation** list box. Specify an integer between zero and 359. (If you enter a non-integer value, the number is truncated to an integer.) The object rotates clockwise.
5. Click **OK**.

---

### Move an Annotation

To move an annotation:

1. Position your cursor on the annotation that you want to move.

   A double arrow appears. 🔄

2. Click and drag the annotation to a new location in the graph.

---

### Copy and Paste an Annotation Object

You can copy and paste an annotation object to a new location in the graph.

To copy and paste an annotation object:

1. Right-click the object and select **Copy** from the pop-up menu.

2. Right-click again and select **Paste**. The new object is pasted on top of the original, offset a little.

3. Move the pasted object to a new position in the graph.

Copy (or cut) and paste commands that are applied to annotation objects do not use the system clipboard. Instead, you copy and paste annotations between the graph and an
internal editor stack. The copy and paste commands used for annotations are not affected by the contents of the system clipboard.

---

**Delete an Annotation**

To delete an annotation permanently from a graph:

1. Select the annotation that you want to delete.

2. Select **Edit → Delete**. Alternatively, you can press the DELETE key.

   *Note:* To undo the change, select **Edit → Undo**.

---

**Working with Groups of Annotation Objects**

When you group annotation objects, you can easily move all items in the group as one object. Groups also make it easy to modify the common visual properties of the annotation objects.

You cannot work on an individual object if it is part of a group. For example, in order to modify the text of a member object, you must first ungroup the objects.

To create and work with groups:

1. To create a group:
   
   a. Press and hold the CTRL key while you click on the annotation objects that you want to group.
   
   b. Right-click and select **Grouping → Group** from the pop-up menu.

2. To move a group, click the group and drag it to a new location.

3. To change the common properties of objects in the group, right-click the group, select **Group Properties**, and make your changes.

   The Group Properties dialog box has two tabs: **Appearance** and **Text**. Any change you make is applied to all members of the group whenever possible. For example, suppose that you have grouped a marker, a rectangle, and a line. If you change the area fill color, then only the rectangle is changed. However, a change to the line pattern applies to both the line and the outline of the rectangle. A change to the text properties applies to all members that have text.

4. To ungroup the objects, right-click the group and select **Grouping → Ungroup** from the pop-up menu.

---

**Change the Order of Annotation Objects**

Annotation objects are placed on the layer in the order in which they are created, with the last object placed on top. For example, if you create a rectangle and then create an oval on the rectangle, the oval is on top. You can change the order so that the rectangle is on top.
To change the order of an annotation object:

1. Right-click the object and select **Order** from the pop-up menu.
2. From the cascading menu, select one of the following options:
   - **Bring to Front** moves the selected object forward to the top of the stack.
   - **Bring Forward** moves the selected object forward one layer in the stack.
   - **Send to Back** moves the selected object to the bottom of the stack.
   - **Send Backward** moves the selected object back one layer in the stack.

### Align Multiple Annotation Objects

You can specify that a group of annotations be left-aligned, centered, right-aligned, and so on.

To align multiple annotation objects:

1. Press and hold the CTRL Key while you click on the objects to be aligned. The first object clicked is used as a reference object. The reference object stays in its place, and the other objects are moved to align with it.
2. From the main menu, select **Arrange ⇒ Align**.
3. From the cascading menu, select your alignment:
   - **Top** aligns all selected objects with the top edge of the reference object.
   - **Bottom** aligns all selected objects with the bottom edge of the reference object.
   - **Left** aligns all selected objects with the left edge of the reference object.
   - **Right** aligns all selected objects with the right edge of the reference object.
   - **Center** aligns all selected objects around the center of the reference object.
Part 4

Examples

Chapter 13

Editing and Annotating Graphs By Example ....................... 89

Chapter 14

Showing and Hiding Labels By Example ........................ 99

Chapter 15

Modifying a Multi-Cell Graph By Example ....................... 103
Chapter 13
Editing and Annotating Graphs By Example

About the Economy Growth Example
The Economy Growth example uses the Distance by Distance graph, which is generated using the ROBUSTREG procedure. The main purpose of robust regression is to detect outliers and leverage points and to provide stable results in the presence of such influential points.
This graph identifies leverage points for economic growth data for different countries. The distances displayed are appropriately scaled. They measure the distance from the center of the data to the observation. The vertical axis distance is a robust version of the classical distance measure on the horizontal axis. Observations with large discrepancies between these two distances have high leverage. The diagonal reference line helps to identify these observations. Such observations also have large ROBUST MCD distance; those observations that are above the horizontal leverage cutoff line are considered leverage points.

The data used in this example was obtained from a national growth study conducted by De Long and Summers in 1991.  

---

**Code for the Economy Example**

SAS/STAT must be installed on the system in order to successfully run this code.

```sas
data growth;
  input country$ GDP LFG EQP NEQ GAP @@;
datalines;
Argentin 0.0089 0.0118 0.0214 0.2286 0.6079
Austria  0.0332 0.0014 0.0991 0.1349 0.5809
Belgium  0.0256 0.0061 0.0684 0.1653 0.4109
Bolivia  0.0124 0.0209 0.0167 0.1133 0.8634
Botswana 0.0676 0.0239 0.1310 0.1490 0.9474
Brazil   0.0437 0.0306 0.0646 0.1588 0.8498
Cameroon 0.0458 0.0169 0.0415 0.0885 0.9333
Canada   0.0169 0.0261 0.0771 0.1529 0.1783
Chile    0.0021 0.0216 0.0154 0.2846 0.5402
Colombia 0.0239 0.0266 0.0229 0.1553 0.7695
```

---

<table>
<thead>
<tr>
<th>Country</th>
<th>0.00121</th>
<th>0.00354</th>
<th>0.00433</th>
<th>0.01067</th>
<th>0.07043</th>
</tr>
</thead>
<tbody>
<tr>
<td>Costa Rica</td>
<td>0.0187</td>
<td>0.0115</td>
<td>0.0688</td>
<td>0.1834</td>
<td>0.4079</td>
</tr>
<tr>
<td>Denmark</td>
<td>0.0199</td>
<td>0.0280</td>
<td>0.0321</td>
<td>0.1379</td>
<td>0.8293</td>
</tr>
<tr>
<td>Dominica</td>
<td>0.0283</td>
<td>0.0274</td>
<td>0.0303</td>
<td>0.2097</td>
<td>0.8205</td>
</tr>
<tr>
<td>Ecuador</td>
<td>0.0046</td>
<td>0.0316</td>
<td>0.0223</td>
<td>0.0577</td>
<td>0.8414</td>
</tr>
<tr>
<td>El Salvador</td>
<td>0.0301</td>
<td>0.0083</td>
<td>0.1206</td>
<td>0.2494</td>
<td>0.5589</td>
</tr>
<tr>
<td>Ethiopia</td>
<td>0.0094</td>
<td>0.0206</td>
<td>0.0212</td>
<td>0.0288</td>
<td>0.9805</td>
</tr>
<tr>
<td>Finland</td>
<td>0.0091</td>
<td>0.0081</td>
<td>0.0814</td>
<td>0.1879</td>
<td>0.6457</td>
</tr>
<tr>
<td>France</td>
<td>0.0092</td>
<td>0.0089</td>
<td>0.0797</td>
<td>0.1767</td>
<td>0.4708</td>
</tr>
<tr>
<td>Germany</td>
<td>0.0055</td>
<td>0.0201</td>
<td>0.0609</td>
<td>0.1455</td>
<td>0.8229</td>
</tr>
<tr>
<td>Greece</td>
<td>0.0044</td>
<td>0.0242</td>
<td>0.0384</td>
<td>0.0516</td>
<td>0.7885</td>
</tr>
<tr>
<td>Guatemala</td>
<td>0.0048</td>
<td>0.0179</td>
<td>0.0445</td>
<td>0.0974</td>
<td>0.8747</td>
</tr>
<tr>
<td>Iceland</td>
<td>0.0041</td>
<td>0.0052</td>
<td>0.0155</td>
<td>0.1154</td>
<td>0.5782</td>
</tr>
<tr>
<td>India</td>
<td>0.0011</td>
<td>0.0052</td>
<td>0.0402</td>
<td>0.0760</td>
<td>0.4974</td>
</tr>
<tr>
<td>Indonesia</td>
<td>0.0110</td>
<td>0.0309</td>
<td>0.0843</td>
<td>0.1257</td>
<td>0.8875</td>
</tr>
<tr>
<td>Ireland</td>
<td>0.0055</td>
<td>0.0201</td>
<td>0.0609</td>
<td>0.1455</td>
<td>0.8229</td>
</tr>
<tr>
<td>Israel</td>
<td>-0.0102</td>
<td>0.0203</td>
<td>0.0219</td>
<td>0.0481</td>
<td>0.9217</td>
</tr>
<tr>
<td>Italy</td>
<td>0.0015</td>
<td>0.0226</td>
<td>0.0361</td>
<td>0.0935</td>
<td>0.9628</td>
</tr>
<tr>
<td>Ivory Coast</td>
<td>0.0332</td>
<td>0.0316</td>
<td>0.0446</td>
<td>0.1878</td>
<td>0.7853</td>
</tr>
<tr>
<td>Japan</td>
<td>0.0044</td>
<td>0.0184</td>
<td>0.0433</td>
<td>0.0267</td>
<td>0.9478</td>
</tr>
<tr>
<td>Korea</td>
<td>0.0048</td>
<td>0.0242</td>
<td>0.0340</td>
<td>0.0760</td>
<td>0.4974</td>
</tr>
<tr>
<td>Luxembourg</td>
<td>0.0236</td>
<td>0.0064</td>
<td>0.0711</td>
<td>0.1944</td>
<td>0.2863</td>
</tr>
<tr>
<td>Madagascar</td>
<td>-0.0002</td>
<td>0.0203</td>
<td>0.0219</td>
<td>0.0481</td>
<td>0.9217</td>
</tr>
<tr>
<td>Mauritius</td>
<td>0.0055</td>
<td>0.0201</td>
<td>0.0609</td>
<td>0.1455</td>
<td>0.8229</td>
</tr>
<tr>
<td>Malaysia</td>
<td>0.0044</td>
<td>0.0184</td>
<td>0.0433</td>
<td>0.0267</td>
<td>0.9478</td>
</tr>
<tr>
<td>Mali</td>
<td>0.0018</td>
<td>0.0048</td>
<td>0.0694</td>
<td>0.1132</td>
<td>0.4307</td>
</tr>
<tr>
<td>Morocco</td>
<td>0.0041</td>
<td>0.0052</td>
<td>0.0155</td>
<td>0.1154</td>
<td>0.5782</td>
</tr>
<tr>
<td>Namibia</td>
<td>0.0048</td>
<td>0.0242</td>
<td>0.0340</td>
<td>0.0760</td>
<td>0.4974</td>
</tr>
<tr>
<td>Netherlands</td>
<td>0.0031</td>
<td>0.0146</td>
<td>0.0778</td>
<td>0.1781</td>
<td>0.3605</td>
</tr>
<tr>
<td>Nigeria</td>
<td>-0.0047</td>
<td>0.0283</td>
<td>0.0358</td>
<td>0.0842</td>
<td>0.8579</td>
</tr>
<tr>
<td>Norway</td>
<td>0.0026</td>
<td>0.0150</td>
<td>0.0701</td>
<td>0.2199</td>
<td>0.3755</td>
</tr>
<tr>
<td>Pakistan</td>
<td>0.0029</td>
<td>0.0258</td>
<td>0.0263</td>
<td>0.0880</td>
<td>0.9180</td>
</tr>
<tr>
<td>Panama</td>
<td>0.0029</td>
<td>0.0279</td>
<td>0.0388</td>
<td>0.2212</td>
<td>0.8015</td>
</tr>
<tr>
<td>Paraguay</td>
<td>0.0026</td>
<td>0.0299</td>
<td>0.0189</td>
<td>0.1011</td>
<td>0.8458</td>
</tr>
<tr>
<td>Peru</td>
<td>0.0017</td>
<td>0.0253</td>
<td>0.0445</td>
<td>0.0974</td>
<td>0.8747</td>
</tr>
<tr>
<td>Philippines</td>
<td>0.0318</td>
<td>0.0118</td>
<td>0.0729</td>
<td>0.1571</td>
<td>0.8033</td>
</tr>
<tr>
<td>Senegal</td>
<td>-0.0011</td>
<td>0.0274</td>
<td>0.0193</td>
<td>0.0807</td>
<td>0.8884</td>
</tr>
<tr>
<td>Spain</td>
<td>0.0037</td>
<td>0.0069</td>
<td>0.0397</td>
<td>0.1305</td>
<td>0.6613</td>
</tr>
<tr>
<td>Sri Lanka</td>
<td>0.0013</td>
<td>0.0207</td>
<td>0.0138</td>
<td>0.1352</td>
<td>0.8555</td>
</tr>
<tr>
<td>Tanzania</td>
<td>0.0018</td>
<td>0.0276</td>
<td>0.0860</td>
<td>0.0940</td>
<td>0.9762</td>
</tr>
<tr>
<td>Thailand</td>
<td>0.0318</td>
<td>0.0274</td>
<td>0.0395</td>
<td>0.1412</td>
<td>0.9174</td>
</tr>
<tr>
<td>Tunisia</td>
<td>0.0027</td>
<td>0.0256</td>
<td>0.0428</td>
<td>0.0972</td>
<td>0.7838</td>
</tr>
<tr>
<td>U.K.</td>
<td>0.0018</td>
<td>0.0048</td>
<td>0.0694</td>
<td>0.1132</td>
<td>0.4307</td>
</tr>
<tr>
<td>U.S.</td>
<td>0.0013</td>
<td>0.0189</td>
<td>0.0762</td>
<td>0.1356</td>
<td>0.0000</td>
</tr>
<tr>
<td>Uruguay</td>
<td>0.0041</td>
<td>0.0052</td>
<td>0.0155</td>
<td>0.1154</td>
<td>0.5782</td>
</tr>
<tr>
<td>Venezuela</td>
<td>0.0120</td>
<td>0.0378</td>
<td>0.0340</td>
<td>0.0760</td>
<td>0.4974</td>
</tr>
<tr>
<td>Zambia</td>
<td>-0.0110</td>
<td>0.0275</td>
<td>0.0702</td>
<td>0.2012</td>
<td>0.8695</td>
</tr>
<tr>
<td>Zimbabwe</td>
<td>0.0110</td>
<td>0.0309</td>
<td>0.0843</td>
<td>0.1257</td>
<td>0.8875</td>
</tr>
</tbody>
</table>

*ods trace on;
ods listing sge=on;
ods graphics on / reset imagefmt=png;
ods select "Distance by Distance";

   proc robustreg data=growth plot=all method=lts;
      model GDP = LFG GAP EQP NEQ / diagnostics(all);
   run;

   ods graphics off;

---

**Editing the Graph**

**Change the Graph's Title**

Change the graph's title to make it more meaningful to your target audience.

1. Double-click the title (Leverage Diagnostics).
2. Select all of the text and type the new title *Analysis of Economy Growth*.

**Add a Footnote to the Graph**

Add a footnote that shows the respective year for the data.

1. Click the footnote icon in the Graph toolbar. A text box appears at the bottom of the graph and displays the highlighted text **Insert Footnote**.
2. Type *Data source: De Long and Summers (1991)*.

**Move the Legend**

Once the footnote has been added, the bottom of the graph looks crowded. Because there is ample space available inside the plot area, move the legend into the plot in the lower-right corner.

1. Right-click the legend and select **Legend Properties** from the pop-up menu. The Legend Properties dialog box opens.
2. Select the **Inside Plot Area** button.
3. Select **Bottom Right** from the list box.
4. Click **OK**. The legend appears within the plot area.

---

**Change the Line Pattern**

Change the horizontal reference line so that it is a dashed line.

1. Right-click the line and select **Plot Properties** from the pop-up menu.
2. Select the **Plots** tab if it's not already selected.
3. Make sure that **ReferenceLine1** is selected in the **Plot** list box.
4. From the **Pattern** list box, select the third pattern (dashed line) in the list. The reference line changes to a dashed pattern.
5. Click **OK**.
Adding Annotations to Highlight Outlier Data

The observation in the middle of the plot denoted by a red plus sign is an outlier. You can label it with the name of the country it represents in order draw attention to the outlier. To do this, use the oval and arrow annotation tools in the Graph toolbar.

Add an Oval to the Outlier

To add an oval:

1. Select the oval icon in the Graph toolbar.
2. Press CTRL, click the observation, and drag the cursor to create an oval around the observation. If you press SHIFT + CTRL and then click and drag, you draw a circle around the observation.

Change the Color of the Oval

Change the color of the oval in order to make the oval stand out from the rest of the graph.

1. Right-click the circle and select Annotation Properties from the pop-up menu. The Annotation Properties dialog box opens.
2. In the Outline area of the dialog box, select the red color from the Color list box.
3. Click OK.
Draw an Arrow That Points to the Outlier

To draw an arrow:

1. Click the arrow icon \( \rightarrow \) in the Graph toolbar.
2. Position your cursor at a starting position in the graph and drag the arrow toward the circle annotation.
3. In the text box at the tail end of the arrow, type Zambia.
4. Right-click the arrow and select Annotation Properties. The Annotation Properties dialog box opens.
5. On the Text tab, select the red color from the Color list box. Then click OK. The annotations all display in red.

Preparing The Graph for Presentation

Change the Graph’s Style

Change the style that is applied to the graph in order to make the graph more suitable for printing with a black-and-white printer. Select Format \( \Rightarrow \) Style \( \Rightarrow \) Journal from the main menu.

Note: When you apply the Journal style, all of the objects in the graph change to shades of gray. However, the annotations (oval and arrow) are red because you explicitly set their color.

Change the Size of the Graph

To change the size:

1. Right-click the graph and select Graph Properties. The Graph Properties dialog box opens.
2. Change the width of the graph to 600.

Keep Aspect Ratio is currently selected. Changing the width to 600 also changes the height to 450 to maintain the current aspect ratio.

3. Click OK.

---

Viewing and Saving the Results of Your Changes

Results of Your Changes to the Graph

Here are the results of the changes you made to the graph.

Data source: De Long and Summers (1991)
Because you have applied the Journal style, all of the objects in the graph are in shades of gray. However, the annotations (oval and arrow) are red because you explicitly set their color. If you want the annotation color to be consistent with the style’s colors, you can restore the annotations to their default color.

For a description of the graph, see “About the Economy Growth Example” on page 89.

**Save Your Changes**

To save the changes you made to the graph:

1. Select **File ➔ Save As** from the main menu.

2. Specify the directory, filename, and file type. For more information, see “Save Graph Output” on page 11.
Chapter 14
Showing and Hiding Labels By Example

About the Linear Regression for Sports Cars Example
The linear regression example shows the relationship between miles per gallon and horsepower for a number of sports cars. In this example, you are interested in the cars that fall outside of the confidence band. However, the labels in the middle portion of the graph are cluttered together. It is not clear which label belongs to which observation.

Your strategy is to show only a few of the data labels and hide the others. When you hide data labels, ODS Graphics Editor redraws the labels on the graph. This time, there is more space for the data labels of interest.
**Display 14.1**  
Car Linear Regression Example

---

**Code for the Linear Regression Example**

```sas
data sportscars;
set sashelp.cars;
if type = "Sports";
run;
proc print data=sportscars;run;

data sportscars2 (keep= horsepower mpg_city shortname);
set sportscars;
id=find(strip(model), " ");
put model id;
if (id > 0) then shortname=substr(model, 1, id);
run;
proc print data=sportscars2;run;

proc sort data=sportscars2;
by shortname;
run;

proc means data=sportscars2;
by shortname;
var horsepower mpg_city;
output out=sasuser.sportsCarsMean
   mean = HP MPG;
run;
proc print data=sasuser.sportsCarsMean;run;
```
title 'Linear Regression';
proc reg data=sasuser.sportsCarsMean outest=sportscarfit_est;
    model hp=mpg;
    output out=sasuser.sportsCarMeanFit
        lcl=lower
        ucl=upper
        lclm=lowermean
        uclm=uppermean
        predicted=predict;
run;
proc sort data=sasuser.sportsCarMeanFit;
    by mpg;
run;
proc print data=sasuser.sportsCarMeanFit; run;
/* */
ods listing sge=on style=Default;
ods graphics on / reset width=400px imagename='CarsLabels';
proc sgplot data=sasuser.sportsCarMeanFit;
    band x=mpg upper=uppermean lower=lowermean / name='band'
        legendlabel='Confidence';
    scatter x=mpg y=hp / dataLabel=shortname name='plot';
    series x=mpg y=predict / name='predict' legendlabel='Predicted';
    xaxis grid;
    yaxis grid;
    keylegend 'predict' 'band' / across=1 location=inside
        position=TOPRIGHT;
run;

---

**Show and Hide Labels**

For this example, select all the observations that lie outside the confidence band:

1. Select the data label icon in the Graph toolbar.
2. Right-click the plot and select **Hide All**. Hiding the labels makes it easier to see which data points to select.
3. Press CTRL and click the observations that lie outside the confidence band. The selected data points display in the selection color.
4. Right-click and choose **Show Only Selected** from the menu. Labels appear next to the data points that you selected.
5. Click inside the graph again. The data points and their labels display in the normal graph color. Only the data points that lie outside the confidence band have labels.

The revised example is shown here:
Display 14.2  Labels Show Only for Observations Outside the Confidence Band
Chapter 15
Modifying a Multi-Cell Graph By Example

Modifying a Multi-Cell Graph That Uses a Single Data Set

About the Class Example
This example uses the Class data set in the SAS Help library. The example provides the height and weight of individual students, who are then grouped by gender. The code uses the SGPANEL procedure to create a graph with two cells, or panels: one cell for females and another cell for males. Both cells are driven by the same data set.
**Display 15.1** Class Example Created as a Paneled Graph

![Graph showing a scatter plot with sex as panels, where x-axis is height and y-axis is weight.]

**Code for the Class Example**

```sas
ods listing sge=on;
proc sgpanel data=sashelp.class;
panelby sex;
scatter x=height y=weight;
run;
```

**Modify the Class Example**

**Change the Axis Labels for the Graph**
In this example, there is one set of axis labels for both cells.

To change the axis labels:

1. Double-click the X axis label (Height) and change the text to **Height in Inches**.
2. Double-click the Y axis label (Weight) and change the text to **Weight in Pounds**.

**Change the Color of the Data Points**
When you change the color of the data points in the cells, you modify plot properties. For the type of multi-celled graph used in this example, any change you make to plot properties in one cell affects all cells in the graph.

To change the color of the data points:

1. Right-click inside either cell and select **Plot Properties**. The Plot Properties dialog box opens.
2. In the **Plots** tab, select a color from the **Color** list box.
3. Select **Diamond Filled** from the **Shape** list box.
4. Select 9 from the **Size** list box.
5. Click **OK**.

The data points in both cells have the same color, shape, and size.

**Add an Arrow Annotation to One of the Cells**

You can annotate an individual cell in a multi-cell graph. In this step, you draw a red arrow in one of the cells.

To draw a red arrow:

1. Click the arrow icon in the Graph toolbar.
2. Position your cursor at a starting position in the graph and drag the arrow toward a data point of interest.
3. Right-click the arrow and select **Annotation Properties**. The Annotation Properties dialog box opens.
4. In the **Appearance** tab, select the red color from the **Color** list box.
5. Click **OK**.

**Results of Your Changes**

Your changes look similar to the following:

**Display 15.2  Modified Class Example**
Modifying Individual Plots in a Diagnostic Panel

About the Fitness Example

This example analyzes the resting and active pulse rates for participants in a physical fitness study. As part of the study, individuals of various ages and weights run for a variable amount of time, and their pulse rates are measured before and after the run. The code uses the REG procedure to create a graph with paneled diagnostic plots. The running time (RUNTIME) is a response variable in the study.

Display 15.3  Fitness Example

[Image: Diagnostic plots showing various graphs for runtime diagnostics, including residual plots, RStudent plots, leverage plots, quantile plots, percent plots, fit-means residual plots, and proportion less plots.]

Code for the Fitness Example

SAS/STAT must be installed on the system in order to successfully run this code.

```sas
OPTIONS NODATE NOSTIMER LS=78 PS=60;
ods listing sge=on;
ods graphics on;
data fitness;
    input age weight oxy runtime rstpulse runpulse maxpulse;
datalines;

```

[Continues with the rest of the code listing.]
Modify the Fitness Example

Change the Graph's Title
By default, the graph's title contains the RUNTIME variable. Change the graph's title to make it more meaningful.

1. Double-click the title (Fit Diagnostics for runtime).
2. Select all of the text and type the new title Model Fit Diagnostics for Regression Analysis of Running Time.
**Change the Axis Label for a Cell**
In this example, each cell has its own set of axis labels.

To change an axis label:
1. Double-click the Y axis label for the middle cell. (The label contains the text `runtime`.) A box appears around the text.
2. Change `runtime` to `Run Time` with a capital R and T.

**Change the Color of a Plot**
For the type of graph used in this example, you can modify plot properties separately for each cell.

To change plot properties:
1. Right-click inside the middle cell and select **Plot Properties**. The Plot Properties dialog box opens.
2. On the **Plots** tab, select `lineparm2` from the **Plot** list box.
3. Select a blue color from the **Color** list box.
4. Click **OK**. The diagonal plot in the middle cell becomes blue.

**Change the Graph’s Background Color**
To change the graph's background color:
1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box opens.
2. Select a gray color from the **Fill** list box.
3. Click **OK**.

**Results of Your Changes**
The revised example is shown here:
annotation
labels, markers, or notes that are not obtained from the data but are placed on graphs independently. Such annotations may or may not be linked to data values in the graph. Annotations provide additional information about the data.

cell
in graphs that contain columns and rows, the area enclosed by the intersection of a column with a row.

classification panel
a multi-cell graph in which the cell data is driven by the values of one or more classification variables. The number of the cells is determined by the unique values of the classification variables.

classification variable
a variable that is used to group (or classify) data. Classification variables can have either character values or numeric values. Classification variables can have continuous values, but they typically have a few discrete values that define the classifications of the variable.

graph
a visual representation of data showing the variation of a variable in comparison to one or more other variables.

Graph Template Language
an extension to the Output Delivery System (ODS) that enables users to create sophisticated analytical graphics.

GTL
See Graph Template Language.

legend
In SAS/GRAPH software, legend refers collectively to the legend value, the legend value description, the legend label, and the legend frame.

locale
a value that reflects the language, local conventions, and culture for a geographic region. Local conventions can include specific formatting rules for dates, times, and numbers, and a currency symbol for the country or region. Some examples of locale values are French_Canada, Portuguese_Brazil, and Chinese_Singapore.
marker
a symbol such as a dot, a cross, or a diamond, that is used to indicate the location of a data point on a plot or graph.

ODS
See Output Delivery System.

ODS Graphics template
a file created by the Template procedure that contains the definition of a plot or a panel of plots. When this file is associated with an input data source, the file is used to create an output graph.

outlier
a data point that differs from the general trend of the data by more than is expected by chance alone. An outlier might be an erroneous data point or one that is not from the same sampling model as the rest of the data.

Output Delivery System
a component of SAS software that can produce output (tables and graphs) in a variety of formats such as markup languages (HTML, XML), PDF, listing, RTF, PostScript, and SAS data sets. Short form: ODS.

plot
a graph in which graphical elements such as markers or lines represent a view of the data.

SGE file
a SAS/GRAPH ODS Graphics Editor file. You can edit SGE files from the SAS Results window or by opening the SGE file in the editor.
Index

A
about ODS Graphics Editor 3
aligning annotations 85
alternate short text 25
annotating graphs
  add text to objects 75
  align objects 85
annotation concepts 45
change data attachment properties 57
copy and paste objects 83
delete objects 84
group objects 84
images 66
lines and arrows 62
markers 65
move objects 83
order objects in layers 84
ovals (and circles) 64
rectangles (and squares) 64
resize objects 79
rotate objects 81
text annotations 61
annotation concepts 45
annotation objects 45
arrows 62
axis labels 36
grid lines 35
turn on and off 35

C
cell 5
circles
  See ovals
color, changing
  data 32
graph background 17
plot background 32
colors, specifying 22
components of a graph 5
concepts
  annotation 45
  editing 5
copy and paste
  annotation object 83
  graph 12

data attachment
  change properties 57
  concepts 45
data labels, show or hide 39
delete an annotation 84

edit a graph, main ways 9
editable graphs 8
editing concepts 5
editing graphs
  change background color 17
  plot properties 31
  resize a graph 16
  show or hide data labels 39
  specify a style 15
  working with axis labels 36
  working with footnotes 19
  working with titles 19

features of the editor 4
file types that can be edited 4
footnotes 19
Formatting toolbar 21

G
graph components 5
Graph toolbar 10
graphics
  See images
grid lines 35
grouping annotations 84

I
images 66

L
labels on data points
  show or hide 39
lines 62
locale setting 6

M
markers 65
move an annotation 83
multi-cell graphs 40

O
order of annotations 84
ovals 64

P
plot area 5
plot properties 31
PNG files 4
print a graph 12
properties of a plot 31

R
rectangles 64
resize
  annotation 79
  graph 16
  rotate an annotation 81

S
save a graph 11
SGE files 4
short text 25
size
  resize a graph 16
  resize an annotation 79
  size of an annotation 79
squares
  See rectangles
stand-alone editor
    downloading 7
    using 8
style of a graph 15

T
text, add to annotations 75
text annotations 61
titles 19
toolbar, Formatting 21
toolbar, Graph 10
Your Turn

We welcome your feedback.

• If you have comments about this book, please send them to yourturn@sas.com. Include the full title and page numbers (if applicable).

• If you have comments about the software, please send them to suggest@sas.com.
Whether you are new to the work force or an experienced professional, you need to distinguish yourself in this rapidly changing and competitive job market. SAS® Publishing provides you with a wide range of resources to help you set yourself apart. Visit us online at support.sas.com/bookstore.

**SAS® Press**

Need to learn the basics? Struggling with a programming problem? You’ll find the expert answers that you need in example-rich books from SAS Press. Written by experienced SAS professionals from around the world, SAS Press books deliver real-world insights on a broad range of topics for all skill levels.

**support.sas.com/saspress**

**SAS® Documentation**

To successfully implement applications using SAS software, companies in every industry and on every continent all turn to the one source for accurate, timely, and reliable information: SAS documentation. We currently produce the following types of reference documentation to improve your work experience:

- Online help that is built into the software.
- Tutorials that are integrated into the product.
- Reference documentation delivered in HTML and PDF – free on the Web.
- Hard-copy books.

**support.sas.com/publishing**

**SAS® Publishing News**

Subscribe to SAS Publishing News to receive up-to-date information about all new SAS titles, author podcasts, and new Web site features via e-mail. Complete instructions on how to subscribe, as well as access to past issues, are available at our Web site.

**support.sas.com/spn**