Contents

About This Book ................................................................. v
What’s New in SAS Theme Designer 4.1 for Flex ......................... vii
Accessibility Features of SAS Theme Designer 4.1 for Flex ............ ix

Chapter 1 • Overview of the SAS Theme Designer 4.1 for Flex ....... 1
What Is the SAS Theme Designer 4.1 for Flex? ........................ 1
Benefits of Using the SAS Theme Designer 4.1 for Flex ............... 2
How to Access the SAS Theme Designer 4.1 for Flex ................. 2
Who Can Use the SAS Theme Designer 4.1 for Flex? ................. 2
Prerequisite for Logon Access to the SAS Theme Designer 4.1 for Flex 3
Migrate and Update Custom Themes Automatically ..................... 3

Chapter 2 • Selected Tasks in the SAS Theme Designer 4.1 for Flex .... 5
About This Chapter .............................................................. 5
Create and Deploy a Custom Theme .................................... 6
Replace the Logo ............................................................... 8
Deploy a Custom Theme ..................................................... 8
Delete a Custom Theme ...................................................... 8
Undeploy a Custom Theme .................................................. 9
Disable All Custom Themes ................................................ 9
Change the Default Theme for Users .................................... 9
Export a Custom Theme ..................................................... 10
Import a Custom Theme ..................................................... 10
Apply a Theme for Flex Applications Used by the Administrator .... 11
Accessing SAS Theme Designer for Flex from the SAS Visual
    Analytics Home Page .................................................. 11
Creating Report Themes from Imported Custom Themes .............. 12

Chapter 3 • Reference for the SAS Theme Designer 4.1 for Flex ....... 13
About SAS Application Themes for Flex .................................. 13
About the Predefined Base Themes ...................................... 14
Inheritance of Styles among Components ............................... 14
Report Themes for SAS Visual Analytics ............................... 15
Limitations of the SAS Theme Designer 4.1 for Flex .................. 15
Where to Find More Information ........................................ 15

Glossary ............................................................................. 17
Index .................................................................................. 19
Contents
About This Book

Audience

The intended audience for this document is an administrator or visual designer who wants to change the appearance of SAS web applications that are deployed with the Adobe Flash player at their site.
What’s New in SAS Theme Designer 4.1 for Flex

Overview

Here are the new functions and features for SAS Theme Designer 4.1 for Flex:

• The SAS Corporate theme is now the default theme.

• The SAS Corporate theme has been updated with a new color palette. Colors for the theme are now based on a navy blue palette and include fewer border lines and greater font contrast. The selection color is now a lighter green as well.

• For the themes SAS Light, SAS Dark, and SAS High Contrast you can now change the top level text color for the Menu component in the User Interface Components panel.

• You can now access SAS Theme Designer for Flex from SAS Visual Analytics Hub to create custom themes.

• A custom report theme is now automatically created when a corresponding custom application theme is created in SAS Theme Designer for Flex. These custom report themes can then be used in SAS Visual Analytics reports.
Accessibility Features of SAS Theme Designer 4.1 for Flex

Overview

SAS Theme Designer 4.1 for Flex has been tested with assistive technology tools. It includes accessibility and compatibility features that improve the usability of the product for users with disabilities, with exceptions noted below. These features are related to accessibility standards for electronic information technology that were adopted by the U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973 (2008 draft proposal initiative update). Applications are also tested against Web Content Accessibility Guidelines (WCAG) 2.0, part of the Web Accessibility Initiative (WAI) of the Worldwide Web Consortium (W3C). For detailed information about the accessibility of this product, send e-mail to accessibility@sas.com or call SAS Technical Support.

User Interface Layout

The SAS Theme Designer 4.1 for Flex application window contains these main sections:

- The top of the window contains the application name and an application bar that includes a menu bar and a Log Off button.

- The left side of the window contains a navigation pane. The pane contains a User Interface Components list at the top. When a component is selected, a properties pane at the bottom is populated with controls that are relevant to the selected component. When changes are made to controls in the property pane, the view on the right side of the application is updated.

Themes

An application’s theme is the collection of colors, graphics, and fonts that appear in the application. The following themes are provided with this application: SAS Corporate, SAS Blue Steel, SAS Light, SAS Dark, and SAS High Contrast.

You can also use keyboard shortcuts to magnify the contents of the browser window or to invert the application colors. For more information see “Keyboard Shortcuts” on page ix.

Note: If you have special requirements for your themes, then contact your system administrator or visual designer about using the SAS Theme Designer for Flex application to build custom themes.
Keyboard Shortcuts

The following table contains the keyboard shortcuts for the application. In the user interface, the shortcuts are displayed within parentheses in tooltips and menu labels.

Note: Some application-level keyboard shortcuts do not work when you first open an application. When that happens, press Tab to place the focus on the application and then try the keyboard shortcut again.

Note: When you use a keyboard shortcut to activate a button, first give the focus to the field or section that the button is associated with before you use the keyboard shortcut. For example, if a table has an associated button, you must first move the focus to the table near that button before you press Ctrl+?.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Ctrl++</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td>Reset zoom state</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Temporarily invert or revert application colors (for the current session only)</td>
<td>Ctrl+~</td>
</tr>
<tr>
<td>Navigate to the column headings in a table</td>
<td>For a two-dimensional table, first ensure that the table is in focus. Press Ctrl+F8 to move the focus to the column headings and then use the arrow keys to navigate from heading to heading. For a multidimensional table, first ensure that the table is in focus. Press Tab to move the focus to the column headings and then use the arrow keys to navigate from heading to heading.</td>
</tr>
<tr>
<td>Sort columns in a table</td>
<td>To sort a single column, navigate to the column heading of the column that you want to sort. Press the spacebar to sort the column. To sort additional columns, navigate to the column heading of each additional column that you want to sort. Press Ctrl+spacebar.</td>
</tr>
</tbody>
</table>

Exceptions to Accessibility Standards

These exceptions are known to occur when using the application with Internet Explorer.
<table>
<thead>
<tr>
<th>Accessibility Issue</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using JAWS with this application can sometimes cause Internet Explorer to stop responding.</td>
<td>Using JAWS 13 or later might resolve the issue.</td>
</tr>
<tr>
<td>JAWS cannot read some of the controls in the application, such as images, icons, and buttons.</td>
<td></td>
</tr>
<tr>
<td>JAWS cannot read the tooltips of items in trees and lists.</td>
<td></td>
</tr>
<tr>
<td>JAWS refers to table controls as list boxes.</td>
<td>When JAWS reports that a control is a list box, keep in mind that it might actually be a table.</td>
</tr>
<tr>
<td>JAWS does not correctly read the information in a table:</td>
<td></td>
</tr>
<tr>
<td>• JAWS cannot read the column headings of a table.</td>
<td></td>
</tr>
<tr>
<td>• When table cells are not editable and the focus is in the body of the table, JAWS reads an entire row at a time instead of cell by cell.</td>
<td></td>
</tr>
<tr>
<td>• When the table cells are editable, and focus is in the body of the table, JAWS reads only the first row of the table. If you use the arrow keys to select a cell or row, then JAWS does not read anything. If you press Enter to edit a cell, then JAWS reads the row that contains the edited cell.</td>
<td></td>
</tr>
<tr>
<td>When you are in a table cell, if you press Home, End, Page Up, or Page Down, a cell in the first column of the currently displayed columns for the table is selected.</td>
<td>Use the arrow keys to navigate through the cells of the table.</td>
</tr>
<tr>
<td>If you can tab to the bottom of a table to add a row, then you cannot use the Tab key by itself to exit the table.</td>
<td>Press Shift+Tab to navigate to the top of the table and to then exit the table.</td>
</tr>
<tr>
<td>This application does not contain how-to topics and Help pop-up windows.</td>
<td>Use the Help menu to access the linked documents.</td>
</tr>
<tr>
<td>You cannot use Shift+F10 to open a pop-up menu.</td>
<td>Use Shift+F9 to open pop-up menus that are created for the SAS application. The generic menu that is provided by the Flash player cannot be opened by Shift+F9.</td>
</tr>
<tr>
<td>You cannot use the keyboard to change a tab label.</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 1
Overview of the SAS Theme Designer 4.1 for Flex

What Is the SAS Theme Designer 4.1 for Flex?
The SAS Theme Designer 4.1 for Flex enables you to easily customize the appearance of SAS web applications that are displayed with the Adobe Flash Player. The SAS Theme Designer 4.1 for Flex is, itself, a Flex web application. You use SAS Theme Designer 4.1 for Flex to create and deploy simple, visually appealing, customized themes.

A theme defines the overall look and feel of an application. It is designed using colors and graphics that are applied to common user interface components and layout containers. A well-designed theme can create a strong visual identity across a product or set of products. SAS recognizes that you might not want to view your SAS applications in the default corporate theme. You might instead want to apply your own branding and customization to help the SAS applications fit in with the rest of your software environment. SAS also recognizes that users at your site often use more than one SAS application in their daily work. Having a consistent look and feel ensures that the user’s transition from one application to the next is as seamless as possible.

The SAS Theme Designer 4.1 for Flex affects only applications that use release 2.4 (or later) of SAS Application Themes for Flex. The work that you do in the SAS Theme Designer 4.1 for Flex has no effect on web applications that are not Flex applications (for example, SAS Web Report Studio 4.3).

See Also

- SAS Intelligence Platform: Middle-Tier Administration Guide
- SAS Intelligence Platform: Web Application Administration Guide
Benefits of Using the SAS Theme Designer 4.1 for Flex

The SAS Theme Designer 4.1 for Flex enables you to customize the SAS product line to meet your branding needs and to ensure a unified look across all eligible applications.

SAS Theme Designer 4.1 for Flex includes the following key features:

- A complete graphical user interface (GUI). All tasks can be done with simple point-and-click actions. You do not have to modify configuration files manually or edit the XML content.
- The implementation and deployment of custom themes are entirely within the designer’s control. You do not need to redeploy applications or restart web application servers. With a single click, you can make a new or updated custom theme available to all users in all eligible applications.
- A site can implement multiple custom themes. All deployed themes are available to all end users in all eligible applications.
- You can change the default theme. This is a single setting that applies to all eligible applications and affects all users (except those users who have specified a personal default theme).
- Custom themes that you create in the SAS Theme Designer 4.1 for Flex are retained and available after deployment-related activities such as software upgrades.
- Custom themes that were designed with previous versions of the application are easily migrated and updated.
- Custom themes can be easily exported or imported between environments.

How to Access the SAS Theme Designer 4.1 for Flex

The SAS Theme Designer 4.1 for Flex is a web application, so you access it from within a web browser. The address for the SAS Theme Designer 4.1 for Flex is: \texttt{http://machine:port/SASThemeDesignerForFlex}.

\textit{Note:} If your site has configured web authentication, you cannot log on using a SAS internal account (such as sasadm@saspw). If your site is using SAS authentication, you can log on with an internal account.

Who Can Use the SAS Theme Designer 4.1 for Flex?

Anyone who can log on to SAS Theme Designer 4.1 for Flex can perform all of the tasks that this application offers. However, creating custom themes is a highly specialized and infrequent task that should be performed only by an experienced administrator or...
designated visual designer. To be able to access this application, you must be assigned to the Theme Designer for Flex: Administration role.

---

**Prerequisite for Logon Access to the SAS Theme Designer 4.1 for Flex**

SAS Theme Designer 4.1 for Flex includes a predefined role known as Theme Designer for Flex: Administration. In SAS Management Console, you can view this role, and assign groups or users to this role.

By default, the SAS Administrators group belongs to this role as the default set of authorized users that can access SAS Theme Designer 4.1 for Flex and use the application to design, manage, and deploy custom themes. Other users who are assigned to this role have a similar capability to access the application, design, and manage themes. If a user who does not belong to this role attempts to log on to this application, all logon attempts to the application are rejected and an error message is displayed.

In addition to the SAS Administrators group, if other users need access to SAS Theme Designer 4.1 for Flex, add these users to the **Theme Designer for Flex: Administration** role in SAS Management Console. You should exercise caution in giving users access to SAS Theme Designer 4.1 for Flex, because any changes made to deployment of themes can have a global impact on your users.

To view the Theme Designer for Flex: Administration role, go to SAS Management Console and navigate to **Environment Management ➔ User Manager**. In the panel on the right, double-click **Theme Designer for Flex: Administration**.

**See Also**

*SAS Intelligence Platform: System Administration Guide*

---

**Migrate and Update Custom Themes Automatically**

SAS Theme Designer 4.1 for Flex is designed to easily migrate and update custom themes that were created with earlier versions of the application. All custom themes that were created and deployed with earlier versions of this application are automatically updated when you first log on to SAS Theme Designer 4.1 for Flex after a migration. If you have custom themes that were created with earlier versions of SAS Theme Designer for Flex and were not deployed, you can manually deploy them by using SAS Theme Designer 4.1 for Flex. At the time of deployment, these custom themes are automatically updated and then deployed.
Chapter 2
Selected Tasks in the SAS Theme Designer 4.1 for Flex

About This Chapter

The first task topic in this chapter provides a complete procedure for implementing a custom theme.

The simple user interface and instant preview feature offered by the SAS Theme Designer 4.1 for Flex facilitates an iterative and exploratory design process. For this reason, this document does not provide step-by-step instructions for individual design modifications.

This chapter does provide detailed instructions for selected tasks, to help avoid confusion, optimize your work flow, and minimize the risk of inadvertent disruption of your end users.
Create and Deploy a Custom Theme

You can use predefined base themes to create custom themes in SAS Theme Designer for Flex.

1. Log on to SAS Theme Designer 4.1 for Flex. The address for the application is: http://machine:port/SASThemeDesignerForFlex.

2. When prompted by the application to choose a task, select Create a Theme.

3. In the New Theme window, enter a name for your custom theme and select one of the predefined base themes. Click OK.

   Note: Most special characters are not allowed in the theme name. The theme name can include alphabetic letters, digits, an underscore, and spaces.

In the right pane, notice that a sample application that uses the selected base theme is displayed. The right pane provides an automatic, instant preview as you work.

Here are the predefined base themes that are available to choose from:

**SAS Blue Steel**

The SAS Blue Steel theme enables you to modify the Application banner and Splash screen components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

**SAS Corporate**

The SAS Corporate theme is the default theme for SAS Theme Designer for Flex. Colors for this theme are based on a navy blue palette. The SAS Corporate theme enables you to modify the Application banner and Splash screen components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

**SAS Dark**

The SAS Dark theme is implemented in a minimal way, without custom graphical skins. The SAS Dark theme is based on darker, charcoal gray tones and should be used if a company’s theme contains a dark palette. The SAS Dark theme can be customized extensively. The full range of components on the User Interface Components panel are available for customization.

**SAS High Contrast**

The SAS High Contrast theme improves the accessibility of the text and interface for visually impaired users. The SAS High Contrast theme uses a black background, with white outlines, text, and icons. A currently selected (active) item is aqua color and previously selected items are purple. The full range of components on the User Interface Components panel are available for customization.

**SAS Light**

The SAS Light theme is implemented in a minimal way, without custom graphical skins. The SAS Light theme uses shades of light gray, beige, and white for its color palette. It should be used if a company’s theme contains an overall light palette. The SAS Light theme can be customized extensively. The full range of components on the User Interface Components panel are available for customization.

After you create and deploy a custom theme, you can use that theme as a basis for future themes. Such dependent relationships among themes are dynamic. For
example, if you change Theme A, that change affects all themes that are based on Theme A (except for any design elements that are explicitly specified in the dependent themes).

4. In the upper left portion of the **User Interface Components** panel, select a component. Use the controls in the lower left pane to make changes to the selected interface component. The impact of each change is instantly shown in the sample application in the right pane.

All of the customizable design elements are listed in the **User Interface Components** panel. The sample application on the right contains examples of all of the available components. Changes that you make to certain user interface components affect other components. For example, if you change the color for **Button**, the colors for **Tabs** and **Accordion** change.

5. Repeat step 4 for each interface component whose appearance you want to alter. To save your work at any time, select **File** ⇒ **Save** from the main menu.

**TIP** To revert the settings for a particular interface component (undoing all of your unsaved changes to that component in the current session), select the component in the **User Interface Components** pane and then click **Reset to Defaults** in the lower left pane. As a result, the settings that were initially loaded for this session are reapplied.

6. When you are ready to deploy the new theme, select **File** ⇒ **Save and deploy** from the main menu. In the confirmation message box, click **OK**.

**Note:** At run time, both the target theme and its base theme must be available. Each custom theme contains only information about how it differs from its base theme. The base theme is deployed simultaneously with the custom theme; both themes must be available to the consuming applications. If you have additional layers of nesting (for example, a custom theme that depends on another custom theme that in turn depends on a base theme), then all dependent themes must be available. If you deploy a theme whose base theme is not deployed, the application auto-deploys the base theme.

**Note:** You cannot deploy a theme for only a particular application, or for only a particular set of users. All deployed themes are available to all eligible applications, and to all users.

7. To verify the results:
   a. In a separate browser, launch an eligible application.
   b. Access the application’s preferences settings (for example, select **File** ⇒ **Preferences** from the application’s main menu).
   c. On the **Global Preferences** page in the Preferences window, select the new custom theme from the **Theme** drop-down list. Click **OK**.
   d. If the appearance of the consuming application does not change immediately, log off and log on to the application to view the application with the new theme.

**TIP** You can work iteratively and view results in the consuming application. In the SAS Theme Designer 4.1 for Flex, make changes to the custom theme, and then save and deploy the theme. On your desktop, switch to the browser window where a consuming application is running and simply refresh the page. It is not necessary to relaunch the consuming application.

**TIP** It is a good practice to thoroughly review the effects of the custom theme on each consuming application.
Replace the Logo

To replace the SAS logo (on the right edge of the application banner) with a different image, follow these steps:

1. In the list for the User Interface Components panel, select **Application banner**.
2. Below the list of components, in the **Logo** group box, click **Browse**. Locate and select the image that you want to use from your local hard drive.
3. Save and deploy the custom theme.

Deploy a Custom Theme

As an alternative to the one-step save-and-deploy feature, you can deploy a custom theme that has already been saved. The result is identical to the one-step approach.

1. From the main menu of the SAS Theme Designer 4.1 for Flex, select **Tools ⇒ Deploy**.
2. In the Deploy Theme window, select the theme. Note that the predefined themes are not listed because they are always deployed.

   Click **OK**. A new theme becomes available when an end user relaunches an eligible application. Modifications to an existing theme become available when an end user relaunches or refreshes an eligible application.

   **TIP** Deploying a theme makes the most-recently saved version of the theme available to end users. If you modify a custom theme, be sure to save the changes before deploying the theme.

Delete a Custom Theme

To permanently delete a custom theme from the system:

1. From the main menu of the SAS Theme Designer 4.1 for Flex, select **Tools ⇒ Delete**.
2. In the Delete Themes window, select the theme.

   **TIP** The predefined themes are not listed because you cannot delete those themes. To avoid unintended results, use caution in deleting themes. Consider theme dependencies. If you delete a theme that serves as a default theme (either globally or for an individual user), the SAS Blue Steel theme is used as the default.

   Click **OK**. The change takes effect when a user refreshes or relaunches an eligible application.
Note: If you want to make a theme unavailable for selection by an end user in the application preferences area, you do not have to delete the theme. You can instead undeploy the theme.

Undeploy a Custom Theme

If you want to remove a custom theme from the list of themes that is offered to end users in the application preferences area, undeploy that theme.

1. From the main menu of the SAS Theme Designer 4.1 for Flex, select Tools ⇨ Undeploy.
2. In the Undeploy Theme window, select the theme.

   Tip: The predefined themes are not listed because you cannot undeploy those themes. To avoid unintended results, use caution in undeploying themes. Consider theme dependencies. If you undeploy a theme that serves as a default theme (either globally or for an individual user), the SAS Blue Steel theme is used as the default.

   Click OK. The change takes effect when a user relaunches an eligible application. Note that undeploying a theme does not delete the theme. It just makes the theme unavailable for selection by a user in the application preferences area.

Disable All Custom Themes

In the initial configuration, custom themes are disabled (because no custom themes exist). When you create your first custom theme, custom themes are automatically enabled.

In the unusual circumstance in which you need to disable all custom themes, globally, complete the following steps:

1. From the main menu of the SAS Theme Designer 4.1 for Flex, select Tools ⇨ Disable Custom Themes.
2. In the confirmation message box, click OK.

   When custom themes are disabled, no custom theme information is loaded into eligible applications. The change takes effect when a user relaunches or refreshes an eligible application.

Change the Default Theme for Users

In the initial configuration, the SAS Corporate theme is the default theme. A user can select a different, personal default theme from the preferences area in any eligible application. For that user, the personal default theme selection overrides the default theme. For that user, all applications are displayed using the selected personal default theme.
An administrator can set a theme other than the SAS Corporate theme as the default theme. This change affects only those users who have not already selected a personal default theme. This change does not make other themes unavailable or prevent a user from selecting a different, personal default theme.

To change the default theme for users:

1. From the main menu of the SAS Theme Designer 4.1 for Flex, select **Tools ➤ Set Default Theme**.
2. Select the theme that you want to be the default theme. Click **OK**.
   
   The change takes effect when a user relaunches or refreshes an eligible application. The change does not affect users who have already specified a personal default theme.

---

### Export a Custom Theme

SAS Theme Designer 4.1 for Flex enables you to export a theme. You can export a custom theme from SAS Theme Designer 4.1 for Flex to a specific folder.

To export a custom theme, follow these steps:

1. From the main menu of the SAS Theme Designer 4.1 for Flex, select **Tools ➤ Export Theme**.
2. Select the theme that you want to export. Click **OK**.
3. Navigate to the folder where you want the theme to be exported.
4. If desired, modify the filename for the theme, and click **OK**.
   
   The theme is exported and saved with a .tdf file extension.

---

### Import a Custom Theme

SAS Theme Designer 4.1 for Flex enables you to import a custom theme. You can import a custom theme from a specific folder to SAS Theme Designer 4.1 for Flex.

To import a custom theme, follow these steps:

1. From the main menu of the SAS Theme Designer 4.1 for Flex, select **Tools ➤ Import Theme**.
2. In the dialog box that is displayed, select the TDF theme file that you want to import from your local hard drive. Click **Open**.
3. The theme is imported and is available within SAS Theme Designer 4.1 for Flex.

   **Note:** If a theme with the same name already exists within SAS Theme Designer 4.1 for Flex, it cannot be imported. Any valid theme that is in the correct format can be imported, including themes that were exported without a .tdf extension.
Apply a Theme for Flex Applications Used by the Administrator

SAS Theme Designer for Flex supports the selection of a different theme within the application, and the display of this theme for all Flex applications that are used by the administrator. As an administrator, you might be using several Flex applications in the SAS environment. If you want to use a theme other than the default theme for all of these applications, you can log on to each application, select File ➪ Preferences, and then select the theme that you want for that application. Alternatively, you can select a different theme from within SAS Theme Designer for Flex, and this change is applied to all Flex applications that you use.

To apply a different theme to all of the Flex applications that you use, follow these steps:

1. From the main menu of SAS Theme Designer 4.1 for Flex, select File ➪ Preferences.
2. In the Global Preferences dialog box, select the theme from the drop-down menu for Theme, and click OK.

The selected theme is applied to SAS Theme Designer for Flex and all other Flex applications that you use.

Accessing SAS Theme Designer for Flex from the SAS Visual Analytics Home Page

Beginning in release 6.2 of SAS Visual Analytics, you can access SAS Theme Designer for Flex while working on the SAS Visual Analytics home page. This provides the opportunity to create and modify themes that are used in SAS Visual Analytics. When you create a theme in SAS Theme Designer for Flex, an application theme is created. Beginning in release 6.2 of SAS Visual Analytics, a report theme is also automatically generated for use in SAS Visual Analytics. Here are the steps to access the SAS Theme Designer for Flex from the SAS Visual Analytics home page:

1. Log on to the SAS Visual Analytics home page.
2. On the Common Actions panel, select the option Customize Themes. This opens the SAS Theme Designer for Flex. You can now create and modify custom themes for use in SAS Visual Analytics. Once you deploy the theme, it is available for use in SAS Visual Analytics.

   Note: The Customize Themes function is also available for selection from the More Actions drop-down menu on the SAS Visual Analytics home page.
3. Once you have finished your modifications to a theme, you can return to the SAS Visual Analytics home page by selecting the Home button that is now available on the top left banner.
Creating Report Themes from Imported Custom Themes

When a custom application theme is created in SAS Theme Designer 4.1 for Flex, a coordinating custom report theme is automatically created. For custom application themes that are imported from previous releases of SAS Theme Designer for Flex, coordinating report themes are also now automatically created.

In order to create the report theme, custom application themes from previous releases must be exported and then imported. Custom application themes created with a release prior to release 4.1 can be exported for use in one of two scenarios:

1. A custom application theme that is created in SAS Theme Designer 3.5 for Flex is exported from one server and then is imported to SAS Theme Designer 4.1 for Flex on a different server.
2. A server is being updated (in place) from release 3.5 to 4.1 on the same machine. Custom application themes are exported as 3.5 themes and then imported and deployed as 4.1 themes.

With either scenario, the custom application theme is exported, imported, and deployed. To promote custom application themes that were created in previous releases, follow these steps:

1. In the previous release of SAS Theme Designer for Flex, export all custom themes using the **Export Theme** function. SAS Theme Designer for Flex creates a single .tdf file that contains all exported themes. You can choose a specific folder to save the file. See “Export a Custom Theme” on page 10 for additional details.
2. If you are exporting and importing themes on a server that was updated (in place) from release 3.5 to 4.1 on the same machine, you must delete all custom themes that are available in SAS Theme Designer for Flex after you have exported the themes. This is because the **Import Theme** function does not overwrite an existing theme. See “Delete a Custom Theme” on page 8 for additional details.
3. Using SAS Theme Designer 4.1 for Flex on the destination server, import the .tdf file that was generated with the **Import Theme** function. See “Import a Custom Theme” on page 10 for additional details.
4. You can now deploy the themes that you want to be available for use in other applications. Custom application themes must be deployed for use in SAS Visual Analytics Designer. Use the **Deploy** function in SAS Theme Designer 4.1 for Flex. See “Deploy a Custom Theme” on page 8 for additional details.

For each of the custom application themes that were imported and deployed, a corresponding report theme is now available for use in SAS Visual Analytics Designer.

**Note:** This process applies only to custom application themes that are created in previous releases. You cannot promote base themes from previous releases.
Chapter 3
Reference for the SAS Theme Designer 4.1 for Flex

About SAS Application Themes for Flex

Introduction to SAS Application Themes for Flex

SAS applications are displayed with the Flex interface that is provided by a particular version of SAS Application Themes for Flex. At start-up time, Flex applications load Flex themes automatically. A theme consists of SWF files that include cascading style sheets (CSS) files. The theme content is downloaded to the client, and is cached by the user's web browser. As a result, during subsequent uses of the web application, the theme content loads quicker than when it is initially loaded. The SAS Corporate theme is the default theme for SAS applications that use Flex themes.

Benefits of SAS Application Themes for Flex

Flex applications require SAS Application Themes for Flex, and the themes are downloaded as SWF files to the client's web browser. Flex theme content runs within the Adobe Flash player and offers the following benefits:

- SAS Application Themes for Flex coexist with SAS Web Application Themes. For example, SAS Information Delivery Portal 4.4 uses the default web theme, but it displays SAS BI Portlets with SAS Application Themes for Flex.
- Applications that use SAS Application Themes for Flex offer more visual impact and interactivity.
- Improved visual impact and greater perceived depth are achieved through the use of skins. Skins are graphics that are applied to common user interface components in order to change their appearance. For example, the Corporate theme provides skins
with a color palette that reflects the SAS visual identity. Skins also include some
stylized graphics in the user interface.

About the Predefined Base Themes

When you choose a base theme, select the theme that is most similar to your desired
color palette. You can then modify the theme as needed and save as a new, custom
theme. There are five predefined base themes that override the Flex standard styles:

SAS Blue Steel
The SAS Blue Steel theme enables you to modify the Application banner and
Splash screen components. You can replace the banner logo with a customized logo.
In release 3.5 and later, you can customize the two splash screens.

SAS Corporate
The SAS Corporate theme is the default theme for SAS Theme Designer for Flex.
Colors for this theme are based on a navy blue palette. The SAS Corporate theme
enables you to modify the Application banner and Splash screen components. You
can replace the banner logo with a customized logo. In release 3.5 and later, you can
customize the two splash screens.

SAS Dark
The SAS Dark theme is implemented in a minimal way, without custom graphical
skins. The SAS Dark theme is based on darker, charcoal gray tones and should be
used if a company’s theme contains a dark palette. The SAS Dark theme can be
customized extensively. The full range of components on the User Interface
Components panel are available for customization.

SAS High Contrast
The SAS High Contrast theme improves the accessibility of the text and interface
for visually impaired users. The SAS High Contrast theme uses a black
background, with white outlines, text, and icons. A currently selected (active) item is
aqua color and previously selected items are purple. The full range of components on
the User Interface Components panel are available for customization.

SAS Light
The SAS Light theme is implemented in a minimal way, without custom graphical
skins. The SAS Light theme uses shades of light gray, beige, and white for its color
palette. It should be used if a company’s theme contains an overall light palette. The
SAS Light theme can be customized extensively. The full range of components on
the User Interface Components panel are available for customization.

Inheritance of Styles among Components

Styles for certain design components in the User Interface Components panel are
determined by other components and their customized styles. For example, you can
customize the style for Button by selecting the desired background color, text, and
opacity. The styles that you select for Button are automatically inherited by the tab
headers and the accordion headers.

When you modify the color for List, the same color is applied to the menu and rows in a
table. When elements in a list are modified, the modifications are inherited and displayed
by trees, menus, and tables.
Report Themes for SAS Visual Analytics

Beginning in release 4.1 of SAS Theme Designer for Flex, custom report themes are now automatically created when a coordinating custom application theme is created in SAS Theme Designer for Flex. These custom report themes can then be used in SAS Visual Analytics reports.

Limitations of the SAS Theme Designer 4.1 for Flex

When you use the SAS Theme Designer 4.1 for Flex, it is important to understand the following points:

- Not all aspects of an application’s appearance are customizable. The SAS Theme Designer 4.1 for Flex enables you to modify a rich, carefully selected subset of design elements. The intent is to offer maximum visual impact with minimal effort and minimal risk of unintended results.
- This application is not optimized for large numbers of themes or deeply nested hierarchies. It is intended for occasional, highly targeted use.
- This application does not offer manual editing of a theme or direct interaction with configuration files. For SAS Application Themes for Flex, SAS does not support direct interaction with source files. All work should be performed from within the SAS Theme Designer 4.1 for Flex.
- This application does not offer a step-by-step "undo" function.
- This application does not offer history or versioning of files.
- You cannot alter, delete, or undeploy any of the predefined themes provided by SAS.
- You cannot hide a deployed theme from anyone. All deployed themes are available to all end users in all eligible applications.
- You cannot preload a custom color palette into the SAS Theme Designer 4.1 for Flex.

Where to Find More Information

The most recent version of this document is available from the SAS BI Server product documentation page on the SAS support site http://support.sas.com/documentation/onlinedoc/biserver
Glossary

**SAS authentication**

a form of authentication in which the target SAS server is responsible for requesting or performing the authentication check. SAS servers usually meet this responsibility by asking another component (such as the server's host operating system, an LDAP provider, or the SAS Metadata Server) to perform the check. In a few cases (such as SAS internal authentication to the metadata server), the SAS server performs the check for itself. A configuration in which a SAS server trusts that another component has pre-authenticated users (for example, web authentication) is not part of SAS authentication.

**theme**

a collection of specifications (for example, colors, fonts, and font styles) and graphics that control the appearance of an application.

**web authentication**

a configuration in which users of web applications and web services are verified at the web perimeter and the metadata server trusts that verification.
A
accessing from SAS Visual Analytics 11
applying a theme
   administrator 11

B
base theme
   SAS blue steel 6
   SAS corporate 6
   SAS dark 6
   SAS high contrast 6
   SAS light 6
base themes
   availability at run time 7
   selecting 6

C
custom report themes 15
custom themes
   create and deploy 6
deleting 8
deploying 8
disabling 9
exporting 10
implementing multiple 2
importing 10
purpose of 1
replace the logo 8
setting as the global default 9
undeploying 9

D
deleting themes 8
deploying themes 8
disabling custom themes 9

L
limitations of SAS theme designer for flex 15

S
SAS application themes for flex 13
   benefits 13
   predefined base themes 14
SAS theme designer 4.1 for flex
   benefits of using 2
   how to access 2
   logon prerequisites 3
   migrate and update custom themes 3
   what is the theme designer 1
   who can use 2
scope of the SAS Theme Designer 4.1 for Flex 1
setting a global default theme 9

U
undeploying themes 9
user interface components
   inheritance of styles 14