Getting Started with SAS/ASSIST® 9.1
Overview of Sorting Data 93
Sorting Data 94

Chapter 9 △ Defining a New Column 101
Overview of Defining a New Column 101
Defining a New Column 101

Chapter 10 △ Saving Source Code for Editing and Re-execution 111
Overview of Saving and Using Source Code 111
Working with Source Code 111

Chapter 11 △ Setting Up SAS Files 117
Overview of Setting Up SAS Files 117
SAS Files 117
Setting Up SAS Files 121

Chapter 12 △ Entering Data Interactively 125
Overview of Entering Data 125
Entering Data 125

Chapter 13 △ Importing and Exporting External Data 131
Overview of Importing and Exporting Data 131
Exporting a File 131
Importing Data from a Flat File 134

Chapter 14 △ Analyzing Data 141
Overview of Data Analysis 141
Analyzing Data 142

Chapter 15 △ Using the Report Engine 145
Overview of the Report Engine 145
Creating and Modifying a Simple List Report 145
Creating a Dynamic Report 151

Chapter 16 △ Using Remote Connect 159
Overview of Remote Connect 159
Establishing a Remote Connection 159
Transferring Data 162
Executing a SAS/ASSIST Task Using Remote Data 166
Terminating a Connection 167

Appendix 1 △ Frequently Asked SAS/ASSIST Software Questions 169
Overview of Frequently Asked Questions 169
Licensing, Hardware, and Software Requirements 169
Platforms and Operating Environments 171
Tables and Files 172
SAS/ASSIST Tasks 173

Appendix 2 △ SAS/ASSIST Software Setup 175
What Is SAS?

SAS is a modular, integrated, hardware-independent system of software for enterprise-wide information delivery. What distinguishes the software is its ability to

- make enterprise data a generalized resource available to any user or application that requires it, regardless of the source of the data.
- transform enterprise data into meaningful information for a broad range of applications.
deliver critical information through a variety of interfaces that are tailored to the needs and experience of the individual user.

- perform consistently across a broad range of hardware environments while exploiting the particular advantages of each environment.

SAS integrates all of these elements into a powerful software system. SAS views virtually any application as a collection of data-driven tasks or processes that can be generally classified as described in the following sections.

### Data Access

Data access is the process of accessing the data required by the application. SAS treats enterprise data as an available resource by providing transparent access to:

- popular database management systems such as DB2, IMS, INGRES, SYBASE, ORACLE, and DEC Rdb.
- flat files, system-specific files, and other historical or “legacy” data types
- SAS’ own relational data structure.

Through SAS’ Multiple Engine Architecture (MEA), these data sources can be combined to provide an enterprise Data Warehouse that gives end users the information they need to do their jobs without jeopardizing the security and integrity of data assets or negatively affecting the performance of production databases.

### Data Management

Data management is the process of shaping data into a form required by the application. You can manage your data by entering, editing, retrieving, formatting, and converting your data.

### Data Analysis

Data analysis is the process of transforming raw data into meaningful and useful information. You can analyze your data using descriptive statistics, multivariate techniques, forecasting and modeling, and linear programming.

### Data Presentation

Data presentation is the process of communicating information in ways that clearly demonstrate its significance. You can present your data by using reports, business and analytical graphics, and business correspondence.

### SAS/ASSIST Software

SAS/ASSIST software is a menu-driven, task-oriented interface to the SAS System. It enables users of all experience levels to access the power of the SAS System without having to learn SAS programming statements. SAS/ASSIST software enables you to perform tasks efficiently by using templates and menus. The way each task works within SAS/ASSIST software is similar. After you master one task, other tasks are easy to complete.
SAS/ASSIST software helps you complete tasks easily by providing features that, for example, identify required fields and display selection lists to prevent user errors. Once you have set up a task, you can save task window selections and run the same task again in a later session. In the background, SAS/ASSIST software automatically generates SAS code with descriptive comments as it performs many of your tasks. You can save, edit, and re-execute this code. The SAS/ASSIST Result Manager enables you to manage your saved tasks and code.

With SAS/ASSIST software, you have a single tool to help you complete many different types of tasks, including end-user reporting, presentation graphics, query and reporting, and decision support. The data access capabilities of SAS enable you to use data stored in almost any format or location, ranging from flat files to PC files and database management systems such as DB2, ORACLE, and IMS-DL/I. After you have accessed your data, SAS/ASSIST software gives you a variety of ways to store, manipulate, and transfer data. Additionally, you can combine code that is generated by SAS/ASSIST software with predefined objects and SAS Component Language (SCL) to create applications.

SAS/ASSIST software also enables you to customize your environment to accommodate individual and group preferences by setting options in Master, Group, and User profiles. For example, you can use a private menu to add or remove direct access to saved SAS/ASSIST tasks and to specific windows.

SAS/ASSIST software includes an online tutorial, which contains instructions for performing commonly used SAS/ASSIST tasks. You can access the tutorial by selecting Help from the menu bar and then selecting Getting Started with SAS/ASSIST. The tutorial appears in a separate window, so you can follow the directions in the tutorial window while you perform the tasks in the SAS/ASSIST window.

---

**The SAS/ASSIST WorkPlace Environment**

The user interface to SAS/ASSIST software is called the SAS/ASSIST WorkPlace. The SAS/ASSIST WorkPlace integrates all SAS/ASSIST tasks together into one easy-to-use interface. The main menu in the SAS/ASSIST WorkPlace is called the WorkPlace menu. The WorkPlace menu consists of buttons, which can be used to invoke task windows, and a menu bar, which also can be used to invoke task windows and to perform other SAS/ASSIST functions. The menu bar is also available on all SAS/ASSIST task windows.

Descriptions of the buttons on the SAS/ASSIST WorkPlace menu and items on the menu bar follow the picture of the WorkPlace menu shown in the following display.
Buttons on the WorkPlace Menu

Note that most of the tasks that are available by selecting the buttons on the WorkPlace menu are also available under the Tasks menu. The Tasks menu is available on all SAS/ASSIST task windows as well as the WorkPlace menu. In this document, tasks will be accessed by using the Tasks menu.

Data Management

Data Management enables you to enter new data; look at and change existing data; import data from and export data to an external file; access data from external databases; design data formats and informats; and subset, copy, combine, and sort data. In addition, you can query both SAS tables and data from different databases.

Report Writing

Report Writing enables you to create a variety of reports including simple lists of data; tables that summarize data; tables of frequencies of data; and line printer bar charts, pie charts, and plots. In addition, you can create or modify a report interactively or use the Report Engine window to build different types of reports that are based on SAS tables or views of tables in other formats.

Graphics

Graphics enables you to produce high- and low-resolution graphics including vertical, horizontal, stacked, and grouped bar charts; pie charts; line plots of Y by X values; and maps. To produce high-resolution graphics and maps, you must have SAS/GRAPH software licensed, and you must have high-resolution, graphics-capable hardware.

Data Analysis

Data Analysis offers several analysis tools. With data analysis tools, you can produce frequency tables or compute summary statistics, correlations, or confidence intervals about the mean.
- calculate linear regression, logistic regression, or regression with correction for autocorrelation
- calculate analysis of variance, nonparametric ANOVA, or t-tests
- compute principal components or canonical correlations and calculate seasonal adjustment of time series
- produce control charts and perform capability analysis
- perform guided data analysis
- compute percentiles, standardize or rank data, create time-series data, and convert frequency of time-series data.

Many of the data analysis functions require that you have SAS/STAT software, SAS/ETS software, SAS/QC software, SAS/LAB software, or SAS/INSIGHT software licensed.

**Planning Tools**

[Planning Tools] helps you to analyze and compare loans, design and analyze experiments, manage projects, and forecast time series. Some of the planning tools require that you have SAS/ETS software, SAS/QC software, or SAS/OR software licensed.

**Enterprise Information System**

The Enterprise Information System ([EIS]) item on the SAS/ASSIST WorkPlace menu is a gateway to SAS/EIS software, a menu-driven system that lets you develop and run enterprise information systems. SAS/EIS software helps you create and access your own applications, effectively extending the tasks that are already built into SAS/EIS software. You can build menu-driven applications that include graphs, reports, executable programs, host commands, and desktop applications. Additionally, you can use several desktop applications that are supplied by SAS in your enterprise information systems. You must have SAS/EIS software licensed to use this feature.

**Remote Connect**

[Remote Connect] enables you to establish a SAS session on a remote computer, communicate between that remote session and a local SAS session, run saved programs on the remote computer, and transfer data between the local and remote SAS sessions. You must have SAS/CONNECT software licensed to use the remote connect functionality.

**Results**

[Results] enables you to manage your saved SAS/ASSIST tasks, output, and program code by using the Result Manager window. The Result Manager lets you recall, delete, or rename a program or output; edit or execute a program; redisplay a graph; and print all entry types except types of MANAGER or PROFILE.

**Setup**

[Setup] enables you to control certain aspects of your SAS session, including associating reference names with data libraries or files, managing device drivers and printing forms, sorting data, and reviewing your current function key settings. This item also enables you to set up Master, Group, and User profile options to customize a user’s SAS/ASSIST environment.
Index

Index provides you with an alphabetic list of tasks that can be performed with SAS/ASSIST software. To access one of the tasks, select it from the Index list. The software takes you directly to the task. When you exit the task, the software returns you to the Index. This item is useful when you cannot find a task you want to perform.

Exit

Exit lets you exit SAS/ASSIST software.

WorkPlace Menu Bar Items

File

File contains such file-management functions as opening, closing, saving, importing, and exporting files.

Edit

Edit contains items that allow you to add titles and footnotes to reports, set page dimensions, and specify page headers.

View

View contains items that allow you to view tables, output, and source code, and to open other SAS System windows.

Tools

Tools contains SAS/ASSIST tools, such as the Setup tools and the Result Manager; SAS tools, such as the Table Editor and Graphics Editor; and SAS system options.

Run

Run contains commands to run a task locally or remotely and to establish or terminate a connection to a remote host.

Tasks

Tasks contains all the items on the WorkPlace menu buttons except Index and Exit. This menu is convenient because you can access one task directly from another without having to return to the main menu first.

Help

Help contains various help items, including the SAS/ASSIST tutorial, SAS System help, and SAS/ASSIST window-specific help.

Conventions Used in This Document

Following is a description of the conventions that are used in this document:
Introducing SAS and SAS/ASSIST Software △ Quick Start 7

- This typeface is used for new terms.
- This typeface is used to indicate items in windows or on menus, or items that the user types into the system.

A boxed word is used to indicate a button on a window or dialog box.

Performing the tasks in this document occasionally requires you to make a series of window and menu selections. Where appropriate, these series are indicated with a selection path. For example,

**Tasks** ▶ **Graphics** ▶ **Maps**

In this case, you would select **Tasks** from the menu bar in the current window, then select **Graphics** from the resulting pull-down menu, and then select **Maps** from the resulting cascading menu. See “Using Menus” on page 13 for details about using menus.

In this document the word task refers to anything you can do with SAS/ASSIST that involves manipulating, reporting, analyzing, and presenting data. SAS/ASSIST tasks can be saved and recalled. These tasks are distinguished from other things you can do with SAS/ASSIST software, such as set-up actions and utility actions. Thus, creating a listing report is a SAS/ASSIST task, but generating the graphics test pattern is not. A task window is a SAS/ASSIST window that is the starting point for performing a task. Examples of task windows include the List a Table window and the Bar Charts window.

---

**Quick Start**

If you are anxious to get started and to see how easy it is to perform tasks using SAS/ASSIST software, follow the steps below to produce a simple listing report. If you prefer a slower pace with more explanation, skip this section and go on to Chapter 2, “Familiarizing Yourself with SAS and SAS/ASSIST Software,” on page 11.

1. Log on to your operating environment and invoke SAS. See the SAS Support Consultant at your site if you need assistance logging on or invoking SAS.

2. Invoke SAS/ASSIST software as follows: From any SAS window, follow this selection path:

   **Solutions** ▶ **ASSIST**

3. If you have not previously invoked SAS/ASSIST software, the SAS/ASSIST Welcome Screen appears. Select **Continue**, then select **Continue** from the list of data sources that appears. The Start Menu appears.

4. From the Start Menu, select **Continue**; the WorkPlace menu appears.

5. If you have not already done so, you will need to create the sample tables. Refer to “Creating the Sample Tables” on page 21 for instructions on creating the sample tables.

6. From the SAS/ASSIST WorkPlace menu, follow this selection path:

   **Tasks** ▶ **Report Writing** ▶ **Listing**

   The List a Table window appears.

7. Select **Table**. The Select table window appears with a list of available SAS data libraries and tables.

8. Select **SASUSER** from the list of libraries. Then select the **HOUSES** table from the list of tables.

9. Select **OK**. The List a Table window reappears.
From the List a Table window, follow this selection path:

Run ➤ Submit

The table appears in the Output window. Use the scroll bars to view other parts of the table.

When you are finished looking at the table listing, return to the List a Table window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
Click on the SAS/ASSIST window.
Select SAS/ASSIST on the SAS task bar.

Follow this selection path from the List a Table window to return to the WorkPlace menu:

File ➤ Close

The WorkPlace menu reappears.

For more details on report writing, see Chapter 3, “Report Writing,” on page 31.
In this chapter you learn how to

- invoke SAS and SAS/ASSIST software
- access and move around SAS/ASSIST software using menus, function keys, the index, Help, and buttons
- delete and re-create sample tables
- perform frequently used SAS/ASSIST operations
- exit SAS/ASSIST software and SAS.
Note: The illustrations and examples used in this document were created with SAS/ASSIST 9.1 under the UNIX and Microsoft Windows operating environments. Your screens may look somewhat different from the illustrations in this document.

The SAS User Interface

Invoking SAS

To invoke SAS, follow these steps:

1. Log on to your operating environment.

2. Enter the command (for example, `SAS`) or use the mouse to access SAS. Contact the SAS Support Consultant at your site for the specific command or selection path that is used at your site to access SAS.

   Depending on your operating environment and the SAS system configuration at your site, some or all of the following windows appear:

   - Output window
   - Log window
   - Editor window
   - Program Editor window
   - SAS Explorer window
   - Results window
   - ToolBox (or tool bar)

Display 2.1 SAS Windowing Environment

Note that some windows may be “hidden” beneath others. To see the other windows, use one of the following methods, depending on your operating environment:

- Use the View menu to select other windows by name.
- Use the PREVWIND and NEXT function keys to bring windows into view.
Familiarizing Yourself with SAS and SAS/ASSIST Software

Using Menus

Selecting Items

When instructions in this document direct you to “select” an item, use any of the methods listed below according to your operating environment:

- Use your mouse to click on the desired window.
- Select the window’s button on the SAS task bar.

To get more information about any of these windows, select Help from the window’s menu bar, and then select Using This Window.

Entering Commands

You can enter commands within SAS by using one of three methods:

- selecting from menus
- using function keys
- typing the commands at the Command ==> prompt or in the ToolBox command window.

Menus and function keys are described in the following sections. Typing commands at the Command ==> prompt or in the ToolBox command window is not discussed in this document. Contact the SAS Support Consultant at your site for further information about using SAS commands.

Note: This document uses menus for all examples.

Using Menus

A menu is a list of functions, actions, or commands. Pull-down menus appear below items that you select in the menu bar at the top of a screen. Pop-up menus can appear anywhere in a screen. In SAS/ASSIST software, you activate pop-up menus by selecting the buttons in the WorkPlace menu. Each menu has items that you can select to perform certain actions.

Note: Some actions are also available through the function keys. You can use either the menus or the function keys to perform these actions, whichever you prefer. Performing an action using function keys often requires fewer keystrokes than performing the same action using menus. See “Using Function Keys” on page 15 for further information about function keys.

1 To use menus, do one of the following:

- If you have a menu bar at the top of your SAS windows, continue to the next step.

- If you have a Command ==> prompt at the top of your SAS windows, you need to invoke the menu bar to follow the examples in this document. To invoke the menu bar, type pmenus on at the Command ==> prompt and press ENTER. The menu bar replaces the command line.

- You can also use a function key defined as COMMAND or PMENU to switch back and forth between a command line and menus.
Note: For Microsoft Windows users, your menu bar is at the top of the main SAS window. The menu bar changes according to which SAS window (Editor, Log, Output, and so on) is active. Click on the Editor window or the Editor button on the SAS task bar to activate the Editor window.

2 To use an item on the menu bar, select it. For example, select **File** from the Program Editor menu bar. The **File** menu appears.

**Display 2.2** File Menu

3 Select the action you want to perform. If an action has dots next to it, then when you select the action, another window appears. For example, select **Save As** from the **File** menu. The **Save As** window appears.

**Display 2.3** Save As Window
4 To exit a window, select the appropriate button, for example, [Cancel], [OK], [Close], or [Goback]. For this example, select [Cancel].

5 If an action has a triangle or an arrow next to it, then when you select the action, another menu appears. This feature is called cascading menus. For example, select Solutions and then Analysis. A menu of various analysis applications appears.

Display 2.4  Cascading Menus

6 To exit a menu, use a mouse to point to a location outside the menu box, and then click the mouse button; or, use the arrow keys to position the cursor anywhere outside the menu box, and press ENTER. Make sure the cursor is not on another item on the menu bar or on an item on the window, or else that item will be selected when you click the mouse button or press ENTER.

If you want to return to a command line from the menu bar, follow this selection path:

Tools ▶ Options ▶ Turn Command Line On

The menu bar is replaced by a Command ===> prompt.

Using Function Keys

Function keys are keyboard keys that you can define to perform different actions. When you are using SAS/ASSIST software, the function keys help you to perform certain actions quickly.

Note: Some actions are also available through the menus. You can use either the menus or the function keys to perform these actions, whichever you prefer. Performing an action with function keys often requires fewer keystrokes than does performing the same action with menus. While the examples in this document use menus, you can use function keys instead. △
1 To see how each key is defined when you first access the SAS System, follow this selection path from any SAS window:

Tools ➤ Options ➤ Keys

A list of function keys and their corresponding actions appears.

Display 2.5 KEYS Window

Note: The default function key assignments vary among different operating environments. Your KEYS window may look different from the one pictured here.

2 If some function keys are not visible in the window, use the scroll bars or the FORWARD and BACKWARD function keys to view all the key settings. Note which keys correspond to certain actions. Actions that you need to perform often include

- END, which closes the window. Using a key defined as the END command can be faster than selecting Close from a menu.
- FORWARD, which shows the next screen of data in the current window.
- BACKWARD, which shows the previous screen of data in the current window.
- RIGHT, which shows the data to the right of the current window.
- LEFT, which shows the data to the left of the current window.
- PREVWIND, which shows the previously viewed SAS window.
- NEXT, which shows the next SAS window. You can use PREVWIND and NEXT to view the various SAS windows.
- PMENU (or COMMAND), which toggles between the menu bar and the command line. If the menu bar is being used, this function key invokes the command line. If the command line is being used, this function key invokes the menu bar. Note that if SAS/ASSIST software is active, the PMENU command is not valid. COMMAND is always valid.

Note: Depending on your operating environment, some of the keys listed above may not already be defined in the KEYS window.

3 To assign a command to a function key, place the cursor in the Definition column for the desired function key and type the command. For a description of
SAS System commands, see the online SAS System Help. Some additional commands that you can use in SAS/ASSIST software include
- **RUN**, which executes the task in the current task window.
- **NEW**, which clears task window selections except for the active table and any Subset Data selections.
- **GOBACK**, which does the same thing as selecting **Goback**.
- **RESULTMAN**, which invokes the Result Manager.
- **MMENU**, which returns you to the WorkPlace menu.

4 To exit the KEYS window, use one of the following methods:
- Follow this selection path:
  - **File** ➤ **Close**
- Use the END function key.

If you have made changes, then a dialog box appears, asking you if you want to save the changes. Select **Yes** to save the changes or **No** to exit without saving. The KEYS window disappears.

*Note:* You can also access the KEYS window from SAS/ASSIST software using the same method that is described earlier in this section.

---

**The SAS/ASSIST User Interface**

**Invoking SAS/ASSIST Software**

To invoke SAS/ASSIST software, follow these steps:

1 From any SAS window, follow this selection path:
   - **Solutions** ➤ **ASSIST**

If you have previously invoked SAS/ASSIST software, then the Start window appears; proceed to step 4. If this is the first time that you have run SAS/ASSIST software, then the Welcome window appears.

![SAS/ASSIST Welcome Window](image)

2 Select **Continue**. The Data Sources window appears.
Display 2.7  Data Sources Window

The Data Sources window lists all SAS data libraries that are known to your current SAS session. See “SAS Data Libraries” on page 119 for more information on SAS data libraries. The Data Sources window enables you to select the SAS data libraries that are available to you when you perform SAS/ASSIST tasks.

3 For now, leave the default SAS data libraries selected and select Continue.

4 The SAS/ASSIST Start window appears.

Display 2.8  SAS/ASSIST Start Window

5 The Start window gives you several options:

- You can choose to use the Cascading menus environment, or you can use the menu system (Block menus) from Version 6 of SAS/ASSIST software.
- You can choose to go directly to the last SAS/ASSIST task that you performed, or you can choose to go directly to the Result Manager to perform one of your saved tasks, or you can choose neither of these options. See Chapter 6, “Using the Result Manager,” on page 71 for details about using the Result Manager.
- You can choose to view your data sources. (After the first time you invoke SAS/ASSIST software, the Data Sources window does not appear unless you select this option.)
You can choose to suppress the Start window the next time you invoke SAS/ASSIST software by deselecting *Show this window at startup*. For now, leave these options as they are and select *Continue*.

6 If any tables in your selected data sources are password-protected, then the Table Passwords window appears.

**Display 2.9** Table Passwords Window

Because none of the examples in this document make use of password-protected tables, you can select *Cancel* to omit any password-protected tables from use in this SAS/ASSIST session.

7 The SAS/ASSIST WorkPlace menu appears.

**Display 2.10** SAS/ASSIST WorkPlace Menu
Using Buttons

A button is a graphical shape in a window that, when selected, results in an action. [OK] and [Cancel] are examples of buttons. The most commonly used buttons in SAS/ASSIST software are described here:

[OK] accepts what you have entered in the window and takes you to additional windows to continue the task. In some cases, [OK] performs the task.

[Cancel] cancels what you have entered in the window and returns to the previous window.

[Goback] returns to the previous window.

[Help] displays help for the feature that is in use.

Finding Items

If you cannot find the item that you want to use in SAS/ASSIST software, you have two guides to help you:

- Use the Tasks menu and its cascading menus to explore the different capabilities of SAS/ASSIST software.
- Select [Index] from the WorkPlace menu to display an alphabetic list of all the tasks and functions that can be performed with SAS/ASSIST software. To access one of the tasks, select it from the Index list. The software takes you directly to the task.

Getting Help

SAS has extensive online help. You can get help for a particular window or general SAS software product help. To access the general SAS help, follow this selection path:

Help ➤ SAS Help and Documentation

Help topics are formatted in Hypertext Markup Language (HTML) and appear in a Help browser or in an HTML browser (for example, Microsoft Internet Explorer or Netscape Navigator). Various items in the Help browser window are highlighted, underlined, or otherwise emphasized. You can select these items to get more information about them. To access general SAS/ASSIST software help, follow this selection path from the main SAS help screen:

SAS Products ➤ SAS/ASSIST ➤ SAS/ASSIST Online Help

To get help for a particular window, follow this selection path from that window’s menu bar:

Help ➤ Using This Window

Help for that window appears.

Using SAS/ASSIST Software with This Document

In creating the examples and illustrations in this document, we removed the date and time stamp from all output and disabled the Save Changes dialog box that appears when you exit a task window. We recommend you do the same so that your experience
with SAS/ASSIST software will match the descriptions in this document. This section describes how to apply these conditions.

**Removing the Date and Time Stamp from Your Output**

To remove the date and time from your output, follow this selection path from the SAS/ASSIST WorkPlace menu bar or any task window menu bar:

**Edit** ➤ **Page Headers** ➤ **Print current date**

*Note:* You must reset this option each time you restart your SAS session. This option is not applicable to graphics output and is not available on graphics task windows.

**Disabling the Save Changes Dialog Box**

To disable the Save Changes dialog box, the SAS/ASSIST user profile option **Confirm changes** is set to **No**. To set this option, do the following:

1. Follow this selection path from the WorkPlace menu bar or any task window menu bar:
   
   **Tasks** ➤ **Setup** ➤ **Profiles** ➤ **User**

   The User Profile window appears.

2. In the Value field for the **Confirm changes** option, type **no** and press ENTER.

3. Follow this selection path to return to the WorkPlace menu:
   
   **File** ➤ **Close**

If you do not set this option to **No**, then you will be presented with a Save Changes dialog box every time you exit a task window.

**Creating the Sample Tables**

In order to perform the exercises in this document, you must create the sample tables. These sample tables are used throughout this document and can be used to learn to use the software. When you are using these sample tables, you can try any of the options in SAS/ASSIST software. You do not need to be concerned about harming the sample data. You can easily re-create the sample tables if, for example, you have altered them so that they no longer correspond to the SAS/ASSIST software documentation and tutorial examples.

1. To create or re-create the sample tables, follow this selection path from the WorkPlace menu:

   **Tasks** ➤ **Setup** ➤ **File Management** ➤ **Sample tables**

   The Sample Tables window appears.
2 Select **Create sample tables** from the Sample Tables window. The Create Sample Tables window appears.

3 Select the tables you want to create. For the exercises in this document, select all the tables.

   *Note:* If you are re-creating sample tables (rather than creating them for the first time), and you attempt to re-create a table that is the currently active table in one or more SAS/ASSIST tasks, you get an error message because SAS/ASSIST software does not let you re-create an active table. To remove a table from active status, follow the directions in “De-Selecting an Active Table” on page 28.

4 Select **OK**. The sample tables are created. When the process is complete, a message appears that indicates that all the tables were created.
Deleting the Sample Tables

If you no longer want to use the sample tables, you can delete them.

1. To delete the sample tables, follow this selection path from the WorkPlace menu:

   Tasks ➤ Setup ➤ File Management ➤ Sample tables

   The Sample Tables window appears as in Display 2.11 on page 22.

2. Select **Delete sample tables** from the Sample Tables window. The Delete Sample Tables window appears.

   Display 2.14  Delete Sample Tables Window

3. Select the tables that you want to delete.

   **Note:** You cannot delete a table that is currently the active table in one or more SAS/ASSIST tasks. To remove a table from active status, follow the directions in “De-Selecting an Active Table” on page 28.
4 Select [OK]. A message appears that indicates that the selected tables were deleted.

**Display 2.15**  Deleted Sample Tables Message

5 Select [Goback] twice to return to the WorkPlace menu.

---

**Frequently Used SAS/ASSIST Operations**

This section describes how to perform operations that are common to most SAS/ASSIST tasks. The task examples in this document refer you to this section when these operations are required.

**Selecting a Table**

When a task example instructs you to select a table, follow these steps:

1. If you have not already done so, select [Table] in the task window. The Select Table window appears.

**Display 2.16**  Select Table Window
Familiarizing Yourself with SAS and SAS/ASSIST Software

The Select Table window contains a list of SAS data libraries on the left side and a list of SAS tables on the right. If there is an active table, the table name appears in the Table field as a two-level name. See “SAS Files” on page 117 for details about SAS naming conventions.

2 Use one of the following methods to select a table:
   - Type the two-level table name in the Table field.
   - Select [Table/Column Search]. The Table/Column Search window appears, enabling you to locate a table from an alphabetic list of all known tables, or from an alphabetical list of columns in the known tables.

   ![Display 2.17 Table/Column Search Window]

   You can narrow the search by entering the first few characters of the table or column name in the Search Criterion field. Note that wildcard searches are not supported.

   - Select the SAS data library name from the Libraries list, and then select the table name from the Tables list. The sample tables used in the examples in this document are all located in the SASUSER library.

   If the desired table does not appear in the list of tables, then one of the following conditions is true: the table does not exist, it is not in a library that is known to the current SAS session, or it was added to a library after SAS/ASSIST software was invoked.

   - For sample tables, see “Creating the Sample Tables” on page 21.
   - For tables in undeclared libraries, see “Using SAS/ASSIST Software to Assign a New Libref” on page 121 for details about declaring libraries.
   - For newly added tables or libraries, select [Refresh] to open the Data Sources window. See “Selecting Data Sources” on page 25 for more information.

3 After you have selected the desired table, select [OK]. The Select table window disappears and the table name appears as the active table in your task.

Selecting Data Sources

To enhance performance, SAS/ASSIST software stores information about only those SAS data libraries that you specify, rather than all SAS data libraries that are known to your SAS session. As a result, the software is required to look in fewer places to find information about tables.

If you declare a new library, or add or modify tables in an existing library, then you must refresh the data sources so that your SAS/ASSIST session will know about the additions or modifications. To refresh the data sources, perform the following steps:
1 Open the Data Sources window by either
   - selecting **Refresh** from the Select Table window
   - selecting **Tools** ▶ **Examine Data Sources**
   from any SAS/ASSIST window.

**Display 2.18** Data Sources Window

The Data Sources window consists of the following columns:
- Library: lists the known SAS data libraries.
- Type: indicates the type of each library. A type of ASSIST indicates that the library has been prepared for use with SAS/ASSIST software by an administrator; sources of this type cannot be deselected. A type of REMOTE indicates that the library resides on a remote server. Any other type indicates that the library is on the local machine and that the libref is declared with the indicated library engine (for example, V8).
- Path: indicates the physical path to the library.
- No. of Tables: when selected, indicates the number of tables in each library.

2 Use the check boxes next to the Libraries column in order to select or deselect data sources (libraries) as desired.

3 To estimate the effect that selecting a library will have on SAS/ASSIST performance, select the **No. of Tables** check box. The number of tables in each library appears. The fewer tables there are, the better the performance will be.

4 To deselect all libraries, select **Deselect Libraries**.

5 When you are finished selecting libraries, select **Continue**. SAS/ASSIST software then examines the data sources to collect information about each table.

6 If any tables are password-protected, then the Table Passwords window appears with a list of password-protected tables. See “Specifying Table Passwords” on page 26 for details.

**Specifying Table Passwords**

If SAS/ASSIST software attempts to access password-protected tables while it is examining data sources, then the Table Passwords window appears.
In the Table Passwords window, you can do the following:

- Enter the password in the Password field for each table. Contact your system administrator or your site's SAS Support Consultant if you do not know the passwords.
- Omit a table from use in this SAS/ASSIST session by clearing the Selected check box for that table.
- Omit all password-protected tables from use in this SAS/ASSIST session by selecting Cancel.
- Store the passwords and use them whenever you refresh the data sources by selecting the Store and reuse passwords check box. The passwords are stored in an encrypted file. Note that if you make this selection, then the Table Passwords window does not appear again unless new, password-protected tables are added, or the passwords for the existing tables change.
- Bypass the attempt to read password-protected tables for all future SAS/ASSIST sessions by selecting the Skip read-protected data check box.

When you are finished making selections in this window, select OK.

**Selecting a Column**

When a task example instructs you to select a column, follow these steps:

1. If you have not already done so, select the appropriate button (for example, Columns, Chart column, or Analysis column) in the task window. The Select Table Variables window appears with the available columns in the Available list. (Note that “variable” is another word for “column.”)
Display 2.20  Select Table Variables Window

The number of columns that you can select is indicated above the Available list. In certain contexts, not all of the active table’s columns are listed. For instance, when the software performs an action that requires numerical data, only numerical columns are listed.

2 Select the desired column name from the Available list.

3 Select the right arrow. The column name disappears from the Available list and appears in the Selected list.

Note: In certain tasks, you can select more than one column at a time; in others, you can select only one column. If you can select only one column, then the Select Table Variables window disappears when you select the right arrow, and the column name appears in the task window. In this case, you do not need to go any further in this procedure.

To de-select a column, select it in the Selected list and select the left-arrow button to move it back to the Available list.

4 Repeat Steps 2 and 3 for each desired column.

Note: If you want to select all of the available columns, then you can select the double right arrow to select them all at once instead of selecting them one at a time. If selecting all columns would select more columns than the task allows, then the double right arrow is disabled.

5 Select OK. The Select Table Variables window disappears.

De-Selecting an Active Table

You can clear task window selections by selecting

File ➤ New

However, this action does not clear the Active Table selection or the Subset Data selection. The reason for this feature is that many users want to use the same subset of the same data for multiple tasks. To clear the Active Table and Subset Data selections, follow these steps. To clear only the Subset Data selection, see the instructions in “Clearing a Subset Data Selection” on page 29.

1 Use the Tasks menu to go to the desired task window.

2 Select Table. The Select table window appears.
3 Erase the table name in the Table field, and then select OK. The task window reappears with the Table field cleared.

*Note:* These steps also clear the other window selections.

### Clearing a Subset Data Selection

You can clear task window selections by selecting

File ➤ New

However, this action does not clear the Active Table selection or the Subset Data selection. To clear only the Subset Data selection, follow the steps in this section. The reason for this feature is that many users wish to use the same subset of the same data for multiple tasks. To clear both the Subset Data selection and Active Table, see the instructions in “De-Selecting an Active Table” on page 28.

1 Use the Tasks menu to go to the desired task window.
2 Select Subset data. The Subset Data window appears.
3 Select the subsetting method you want to clear (BY columns, WHERE clause, or Restrict rows). The selection window for that method appears.
4 Select Reset. The default value for that method is restored.
5 Select OK. The Subset Data window reappears.
6 Repeat steps 3 through 5 for each desired subsetting method.
7 Select Go back. The Subset Data window disappears.

### Exiting a Task

When you are finished with a task, you can either return to the WorkPlace menu or go on to another task:

- To return to the WorkPlace menu, follow this selection path:
  
  File ➤ Close

- To go on to another task, select Tasks, and then select the desired task.

### Exiting SAS/ASSIST Software

To exit SAS/ASSIST software, return to the WorkPlace menu and select Exit. The SAS/ASSIST window disappears.

### Exiting SAS

To exit SAS, use one of the following methods:

- From the SAS Explorer window, Editor window, Results window, or SAS Environment window, select
  
  File ➤ Exit

A prompt confirms that you want to exit.
Select **OK** to exit SAS.

- In the SAS ToolBox command window, or at a **Command ====>** prompt, type **BYE** and press ENTER. The SAS session terminates without further prompting.
Overview of Report Writing

In this chapter you will learn how to produce a listing report, a tabular report, and a
frequency report. The SAS/ASSIST report writing tasks enable you to produce reports
of many different styles quickly and to customize your reports. For example, you can
subset the data for the report; select the variables for the report; specify labels,
subtotals, and page breaks; and add titles and footnotes, change the page dimensions,
and select headings.

Additional Information

For additional information about writing reports, refer to Chapter 15, “Using the
Report Engine,” on page 145 in this document. For additional information about the
TABULATE procedure, refer to the SAS Guide to TABULATE Processing. For
additional information about the PRINT and FREQ procedures, refer to Base SAS
Procedures Guide.
Producing a Listing Report

A listing report displays data from a table. Using the Listing Report task, you can display all the data from a table, or a portion of the data, based on criteria that you specify. By following the instructions in this section, you can produce a report that shows the information for ranch-style homes from the HOUSES table. A listing report displays one line for each observation in the table.

Display 3.1  Information on Ranch Style Houses Report

A table is a collection of information arranged in columns and rows. A column is a set of data values that represents a particular type of data; for example, the price of all the houses. A row is a set of data values for the same item; for example, all the information about one house, such as price, style, square footage, and so on. Refer to Chapter 11, “Setting Up SAS Files,” on page 117 for more information about tables, rows, and columns.

Setting Up the Report

1 To create a listing report, you first set up the report by following this selection path:

   Tasks ▶ Report Writing ▶ Listing

   The List a Table window appears.
2 If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select [Table], and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

3 If there is an active Subset Data selection (indicated with **BY**, **WHERE**, or **ROWS** next to [Subset data]), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.

4 If other report selections exist (for example, [Columns] is not **-ALL-**), then select

   [File] – [New]

   to clear these selections.

5 To produce a report that lists all the data in the HOUSES table, select

   [Run] – [Submit]

   The Listing Report appears in the Output window.
Display 3.3 Listing of HOUSES Table

The listing report is a quick way to get a list of all the data in your table. Note the different styles of the houses. For the sample report shown in Display 3.1 on page 32, only the RANCH style houses are selected.

If the report is wider or longer than the window, use the scroll bars or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to look at the rest of the report. Refer to “Using Function Keys” on page 15 for further information on function keys.

After you have finished looking at the report, return to the List a Table window by using one of the following methods, depending on your operating environment:

- Use the PREVWND function key.
- Click on the SAS/ASSIST window.

Note: Under some operating environments, if you are using the Output window and the report is longer than one display, the last display of the report is shown after you select Close once. In this case, select File and then Close again. The task window reappears.

Subsetting the Data

To produce the report shown in Display 3.1 on page 32, you need to subset and customize the report. Subset the data as follows:

1. Select [Subset data] in the List a Table window. The Subset Data window appears.

...
You subset the data if you want to produce a report that uses only some of the data in the table. For example, to produce the sample report shown in Display 3.1 on page 32, you need to subset the data so that only data for ranch-style houses are used.

2 Select [WHERE clause]. The Build a WHERE Clause to Subset the Current Data window appears.

This window enables you to create a WHERE clause that specifies criteria for selecting rows. The rows that match the criteria in the WHERE clause are used in the report. For this example, you build a WHERE clause that selects only the houses for which the STYLE is RANCH.
You subset the data by using one of the following methods:

- You can type the WHERE clause directly by selecting [Edit the WHERE clause] and typing `STYLE='RANCH'` under [Edit the current WHERE clause].
- You can build the WHERE clause by making selections from this window. The items that are available for selection are highlighted while you build the WHERE clause. For example, when the Build a WHERE Clause window appears, only the Column, Constant, Function, NOT, and Opening parenthesis items are highlighted because these are the only items that can begin a WHERE clause.

3 To build the WHERE clause using the items in the window, select Column from the Build a WHERE Clause window, and then select the STYLE column. For more information, see “Selecting a Column” on page 27.

4 Select Comparison operator from the Build a WHERE Clause window. A window with a list of valid comparison operators appears.

**Display 3.6  Select Data Window (Comparison Operators)**

5 Select the equal operator from the Select Data window. The Build a WHERE Clause window reappears.

6 There are two ways to specify a constant value. Use one of the following methods:

   - Select Look up constants. SAS/ASSIST software searches the column and presents a list of unique values in the Select Data window.
Select **RANCH** and then select **OK**.

*Note:* Using **Look up constants** prevents you from making typing errors. However, it is more useful when the number of possible values is small than when the number of possible values is large. △

Select **Constant** from the Build a WHERE Clause window. The Enter a Character Constant window appears.

To select the ranch-style houses, type **RANCH** in the **Value** field. Make sure **RANCH** is in uppercase because all of the style values are in uppercase in this sample data.
Any time you use a character string for a constant value in a WHERE or BY clause, you need to make sure you use the exact case of the character string in the table. If the word *ranch* had been in lowercase in the HOUSES table, you would type *ranch*.

7 Select [OK]. The Build a WHERE Clause window reappears. The WHERE clause that you built is shown under the **WHERE clause being built** item as shown in the following display.

**Display 3.9 Completed WHERE Clause**

To make changes to the WHERE clause, select [Edit the WHERE clause]. You can then make changes to the column, comparison operator, and constant.

Note that in certain operating environments, there is an additional option to **Verify where clause against data**. If you select this option, then SAS checks to see if there are any rows that meet the conditions of your WHERE clause. If your table is very large, then this verification can take a long time.

8 Select [OK] and then [Goback] to return to the List a Table window. Notice that the value in the Subset data field is WHERE. This value indicates that a WHERE clause is being used to subset your data.

---

**Adding Titles**

You can customize the report by adding titles and footnotes, changing the page dimensions, and selecting headings. Follow these directions to add a title to your report:

1 Follow this selection path:
   
   ![Edit Titles]

   The Titles window appears.
2 Select [Title 1] from the Titles window. The Title 1 window appears.

3 In the Title 1 field, type the title exactly as you want it to appear on the report. For this report, type the title **Information on Ranch Style Houses**. Select **OK** twice to return to the List a Table window.

*Note:* Because the same set of titles and footnotes is used for all SAS/ASSIST tasks, the titles and footnotes that you specified most recently in your SAS/ASSIST session are used unless you change or reset them. If a title already exists when you open the Titles window, then type the new title over the old title.
Running the Report

After you have finished setting up the report, you can run the report.

1. Follow this selection path:

   Run ➤ Submit

   The report appears in the Output window.

Display 3.12  Information on Ranch Style Houses Report

<table>
<thead>
<tr>
<th>Style of homes</th>
<th>Square footage</th>
<th>Number of bedrooms</th>
<th>Number of bathrooms</th>
<th>Street address</th>
<th>Asking price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ranch</td>
<td>1250</td>
<td>2</td>
<td>1</td>
<td>Sheppard Avenue</td>
<td>$65,000</td>
</tr>
<tr>
<td>Ranch</td>
<td>1500</td>
<td>3</td>
<td>3</td>
<td>Kemble Avenue</td>
<td>$86,650</td>
</tr>
<tr>
<td>Ranch</td>
<td>1353</td>
<td>3</td>
<td>3</td>
<td>State Highway</td>
<td>$89,100</td>
</tr>
<tr>
<td>Ranch</td>
<td>1200</td>
<td>1</td>
<td>1</td>
<td>Nicholson Drive</td>
<td>$34,530</td>
</tr>
</tbody>
</table>

This report shows all the data for the ranch-style houses in the HOUSES table.

2. If the report is wider or longer than the window, use the scroll bars or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to look at the report.

Printing the Report

If you do not want to print the report, go to the next section. To print the report, follow these instructions.

1. Follow this selection path from the Output window:

   File ➤ Print

   Depending on your operating environment, the output may be sent directly to your default printer, or you may see the Print window, where you can select printing options.
2 Make sure the name of your default printer (or some other printer of your choosing) appears in the Default Printer field in the Print window. If it does not, then select Setup and choose your printer from the list that appears. If you do not know which printer to choose, then contact the SAS Support Consultant at your site.

3 To print the current report, select Print in the Print window. The report is sent to your printer, and a message appears in the Output window that indicates how many lines were printed.

**Exiting This Task**

When you have finished viewing or printing your report, return to the List a Table window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.

**Producing a Tabular Report**

A tabular report displays descriptive statistics in a table format. A tabular report lets you place data into classes or categories for analysis and calculate statistics, such as counts, sums, means, and percentages on these classes. By following the instructions in this section, you can produce a tabular report that shows the mean, minimum, and maximum prices of the houses classified by style.
Setting Up the Report

1. To produce a tabular report like the one shown in the previous display, follow this selection path:

   Tasks ➤ Report Writing ➤ Tabular reports ➤ All tabular reports

   The Select a Tabular Report window appears.

   **Display 3.14** Select a Tabular Report Window

   The Select a Tabular Report window shows the layout for four types of tabular reports: Statistics, Simple Group 1, Simple Group 2, and 2-D Group. To see the
Multiple Group and Advanced types, select Additional Reports. To return to the first four types, select Goback at the bottom of the display.

2 Select Simple Group 1 from the Select a Tabular Report window. The Simple group 1 window appears.

Display 3.15 Simple Group 1 Window

3 If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

4 If there is an active Subset Data selection (indicated with BY, WHERE, or ROWS next to Subset data), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.

5 If other report selections exist (for example, a column name is listed under Class), then select File ▶ New to clear these selections.

6 Select Column from the Simple group 1 window, and then select the PRICE column. For more information, see “Selecting a Column” on page 27.

7 Select Statistics from the Second Report Style window. A list of statistics that you can choose for the report appears.
The number of statistics that you can select is listed at the top of the statistics list. Each time you select a statistic, an asterisk (*) appears next to the statistic to indicate that the statistic has been selected. As each statistic is selected, it moves to the top of the list. The order of the chosen statistics in the list is the order in which the statistics appear on the report.

To de-select a statistic, select it again; the asterisk disappears.

8 Select the **MEAN**, **MIN**, and **MAX** statistics from the Select Statistics window. Select **OK**. The Simple Group 1 window reappears.

9 Select **Class** from the Simple group 1 window, and then select the STYLE column as your classification column. A *classification column* is a column you want to use to classify the data into groups or categories of information.

### Adding Titles

You can customize the report by adding titles and footnotes, changing the page dimensions, and selecting headings. Refer to “Adding Titles” on page 38 for instructions on adding titles to the report. Add the title **Mean, Min, and Max Price of Houses by Style** as Title 1 to this report.

Because the same set of titles and footnotes is used for all SAS/ASSIST tasks, the titles and footnotes most recently used in your SAS/ASSIST session are used unless you change or reset them in the Titles and Footnotes windows.

### Running the Report

After you have finished setting up the report, run the report.

1 Follow this selection path:

   Run ➤ Submit

   The report appears in the Output window.
Display 3.17  Tabular Report of Houses by Style

![Tabular Report of Houses by Style](image)

This report shows the mean, minimum, and maximum price for the different styles of houses in the HOUSES table.

2 If the report is wider or longer than one display, use the scroll bars or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to look at the report.

Printing the Report

If you do not want to print the report, then go to the next section. To print the report, follow the directions in “Printing the Report” on page 40.

Exiting This Task

When you have finished viewing or printing your report, return to the Simple group 1 window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.

Producing a Frequency Report

A frequency report summarizes data by showing how it falls into different categories. By following the instructions in this section, you can produce a crosstabulation frequency report that shows how many, and what percentage, of each style of house has one, two, three, and four bedrooms.
Setting Up the Report

1. To produce a frequency report like the one shown in the previous display, follow this selection path:

   Tasks ➤ Report Writing ➤ Counts

   The Select a Style of Report window appears.

Display 3.19  Select a Style of Report Window

2. Select [Crosstabulation]. The Two-Way Crosstabulation window appears.
3 If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select [Table], and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

4 If there is an active Subset Data selection (indicated with BY, WHERE, or ROWS next to [Subset data]), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.

5 If other report selections exist (for example, column names exist for [Row specification] or [Column specification]), then select File ▶ New to clear these selections.

6 Select [Row specification] from the Two-Way Crosstabulation window, and then select the STYLE column. For more information, see “Selecting a Column” on page 27.

7 Select [Column specification], and then select the BEDROOMS column.

---

**Adding Titles**

You can customize the report by adding titles and footnotes, changing the page dimensions, and selecting headings. Refer to “Adding Titles” on page 38 for instructions on adding titles to the report. Add the title *Style of House vs. Number of Bedrooms Frequency Report* as Title 1 to this report.

---

**Running the Report**

After you have finished setting up the report, run the report.

1 Follow this selection path:

   Run ▶ Submit

   The report appears in the Output window.
Display 3.21  Style of House vs. Number of Bedrooms Frequency Report

This report shows the frequency of one, two, three, and four bedroom houses in each style.

2  If the report is wider or longer than the window, then use the scroll bars or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to look at the report.

Printing the Report

If you do not want to print the report, then go to the next section. To print the report, follow the directions in “Printing the Report” on page 40.

Exiting This Task

When you have finished viewing or printing your report, return to the Two-Way Crosstabulation window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.
Overview of Graphics

In this chapter you learn how to create bar charts, pie charts, plots, and maps. You can access all of the SAS/ASSIST graphics tasks by selecting [Graphics] from the WorkPlace menu, or by selecting

Tasks ➤ Graphics

from any task window.

The menu that appears depends on your hardware and software. If you are using a graphics terminal or hardcopy device, and you have SAS/GRAPH software licensed, then a menu for high-resolution graphics appears. If you are using a nongraphics terminal,
then a window appears that asks you to choose high-resolution or low-resolution graphics. Select low resolution; a menu for low resolution graphics appears.

The output for the low-resolution graphs is built using characters. The output for the high-resolution graphs uses graphics. The difference between the two menus is that the high-resolution graphics menu also has an item for maps.

Note: The examples in this chapter use high-resolution graphics. △

Additional Information

For additional information about creating high-resolution graphics, refer to SAS/GRAPH Reference, Volumes 1 and 2. For additional information about creating low-resolution graphics, refer to the Base SAS Procedures Guide.

Producing a Bar Chart

This section shows you how to produce a vertical bar chart that shows the average number of square feet by the style of houses. The procedure for producing a horizontal bar chart is similar to this one.

Display 4.1  Average Square Footage by Style Bar Chart

Instructions

1 To create a bar chart like the one shown in the previous display, select Tasks ➤ Graphics ➤ Bar Charts

The Bar Charts window appears.
2 Select **Vertical** on the Bar Charts window if it is not already selected.

3 If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select **Table** and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

4 If there is an active Subset Data selection (indicated with **BY**, **WHERE**, or **ROWS** next to **Subset data**), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.

5 If other task selections exist (for example, a column name is listed for **Chart Column**), then select

   ![File](File) ![New](New)

   to clear these selections.

6 To indicate that you want the bars of the chart to represent the mean of the square footage for each house, select **Bar values** from the Bar Charts window. The Bar/Slice Values window appears.
7 Select **Mean** as the statistic from the Bar/Slice Values window.
8 Select **Analysis column** from the Bar/Slice Values window, and then select the SQFEET column. For more information, see “Selecting a Column” on page 27.
9 Select **OK**. The Bar/Slice Values window disappears.
10 Select **Chart column**. Then select the STYLE column.

---

**Adding Titles**

You can customize the graph by adding titles and footnotes, changing the page dimensions, and selecting headings. Refer to “Adding Titles” on page 38 for instructions on adding titles to the graph.

Add the title **Average Square Footage by Style** as Title 1 for this graph.

Because the same set of titles and footnotes is used for all SAS/ASSIST tasks, the titles and footnotes most recently used in your SAS/ASSIST session are used unless you change or reset them in the Titles and Footnotes windows.

---

**Running the Graph**

After you have finished setting up the graph, run it by following this selection path:

[Run] ➤ [Submit]

The graph appears in the Graph window.
Display 4.4  Average Square Footage by Style Bar Graph

![Average Square Footage by Style Bar Graph](image)

**Printing the Graph**

For most operating environments, you can print your graph by following this selection path from the Graph window:

```
File ➤ Print
```

However, some operating environments and hardware may require some set-up prior to printing graphics. If you have trouble printing graphics, then see the SAS companion for your operating environment or contact the SAS Support Consultant at your site for further instructions.

**Exiting This Task**

When you have finished viewing or printing your graph, return to the Bar Charts window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.

**Producing a Pie Chart**

This section shows you how to generate a pie chart that shows how many houses are in each style.
Instructions

1. To produce a pie chart graph like the one in the previous display, follow this selection path:

   Tasks ➤ Graphics ➤ Pie Chart

   The Pie Chart window appears.

Display 4.5  Houses for Sale by Style Pie Chart

Display 4.6  Pie Chart Window
2 If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

3 If there is an active Subset Data selection (indicated with BY, WHERE, or ROWS next to Subset data), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.

4 If other task selections exist (for example, a column name is listed for Chart column), then select File ▶ New to clear these selections.

5 To indicate that you want the pie slices to represent the numbers of each style of house in the HOUSES table, select Chart column, and then select the STYLE column. For more information, see “Selecting a Column” on page 27.

Adding Titles

You can customize the graph by adding titles and footnotes, changing the page dimensions, and selecting headings. Refer to “Adding Titles” on page 38 for instructions on adding titles to the graph. Add the title Houses for Sale by Style as Title 1 for this graph.

Because the same set of titles and footnotes is used for all SAS/ASSIST tasks, the titles and footnotes most recently used in your SAS/ASSIST session are used unless you change or reset them in the Titles and Footnotes windows.

Running the Graph

After you have finished setting up the graph, run it by following this selection path: Run ▶ Submit

The graph appears in the Graph window.

Display 4.7 Houses for Sale by Style Pie Chart
Printing the Graph

For most operating environments, you can print your graph by following this selection path from the Graph window:

File ➤ Print

However, some operating environments and hardware may require some set-up prior to printing graphics. If you have trouble printing graphics, then see the SAS companion for your operating environment or contact the SAS Support Consultant at your site for further instructions.

Exiting This Task

When you are finished viewing or printing your graph, return to the Pie Chart window by using one of the following methods, depending on your operating environment:

- Use the PREVWND function key.
- Click on the SAS/ASSIST window.

To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.

Producing a Plot

This section shows you how to produce a plot of housing starts over time.

Display 4.8  Plot of Housing Starts by Quarter

Instructions

To produce a plot like the one shown in the previous display, follow these instructions:
1. Follow this selection path:

Tasks ➤ Graphics ➤ Plots ➤ Simple X * Y Plot

The Simple X * Y Plot window appears.

Display 4.9 Simple X * Y Plot Window

2. If the active table is SASUSER.BUILD, then continue to the next step. Otherwise, select Table, and then select the SASUSER.BUILD table. For more information on selecting tables, see “Selecting a Table” on page 24.

3. If there is an active Subset Data selection (indicated with BY, WHERE, or ROWS next to Subset data), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.

4. If other task selections exist (for example, a column name is listed for Vertical axis or Horizontal axis), then select File ➤ New to clear these selections.

5. Select Vertical axis, and then select the STARTS column. For more information, see “Selecting a Column” on page 27.

6. Select Horizontal axis, and then select the DATE column.

Adding Titles

You can customize the graph by adding titles and footnotes, changing the page dimensions, and selecting headings. Refer to “Adding Titles” on page 38 for instructions on adding titles to the graph. Add the title Housing Starts by Quarter as Title 1 for this graph.

Because the same set of titles and footnotes is used for all SAS/ASSIST tasks, the titles and footnotes most recently used in your SAS/ASSIST session are used unless you change or reset them in the Titles and Footnotes windows.
Running the Graph

After you have finished setting up the graph, run it by following this selection path:

Run ➤ Submit

The graph appears in the Graph window.

Display 4.10  Plot of Housing Starts by Quarter

Notice that the dates are listed along the horizontal axis by year and quarter. For more information on SAS dates and date formats, see SAS Language Reference: Concepts.

Printing the Graph

For most operating environments, you can print your graph by following this selection path from the Graph window:

File ➤ Print

However, some operating environments and hardware may require some set-up prior to printing graphics. If you have trouble printing graphics, see the SAS companion for your operating environment or contact the SAS Support Consultant at your site for further instructions.

Exiting This Task

When you are done viewing or printing your graph, return to the Simple X * Y Plot window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.
To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.

## Producing a Map

A map is a specialized graphic that shows a geographical area with data superimposed on it. A map report is useful for conveying information that varies by geographical area. By following the instructions in this section, you can produce a graphic showing robbery statistics on a United States map, as shown below. You must have SAS/GRAPH software installed to produce a map.

**Display 4.11** United States Robbery Statistics Map

![United States Robbery Statistics Map](image)

### Instructions

1. To create a map like the one shown in the previous display, follow this selection path:

   ![Tasks] ➤ ![Graphics] ➤ ![Maps]

   The Maps window appears.
2 If task selections exist (for example, a country name is listed for Map), then select File > New to clear these selections.

3 Select Map. The Select Continent window appears.

4 Select North America, and then select COUNTRY. The Select Country window appears with a list of countries in North America.
5 Scroll down the list and select **UNITED STATES (US)**. The Maps window reappears with UNITED STATES (US) listed for **Map**.

6 Select **Area Identifier**, and then select the STATE column. For more information, see “Selecting a Column” on page 27.

   *Note:* Some maps require two columns (for example, STATE and COUNTY) to uniquely identify each area. △

7 Select **Response Table**. The Response Table in the Maps task is equivalent to the Active Table in other SAS/ASSIST tasks. Select SASUSER.CRIME as the response table. For more information, see “Selecting a Table” on page 24.

8 Select **Column to map**, and then select the ROBBERY column.

9 Select **2-D** as the type of map that you want to create, if it has not already been selected.

**Adding Titles**

You can customize the graph by adding titles and footnotes, changing the page dimensions, and selecting headings. Refer to “Adding Titles” on page 38 for instructions on adding titles to the graph. Add the title **United States Robbery Statistics** as Title 1 for this graph.

Because the same set of titles and footnotes is used for all SAS/ASSIST tasks, the titles and footnotes most recently used in your SAS/ASSIST session are used unless you change or reset them in the Titles and Footnotes windows.

**Running the Map**

After you have finished setting up the graph, run it by following this selection path:

[Run] ➤ [Submit]

The graph appears in the Graph window.
Printing the Map

For most operating environments, you can print your graph by following this selection path from the Graph window:

File ➾ Print

However, some operating environments and hardware may require some set-up prior to printing graphics. If you have trouble printing graphics, see the SAS companion for your operating environment or contact the SAS Support Consultant at your site for further instructions.

Exiting This Task

When you are done viewing or printing your graph, return to the Maps window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.
Overview of Saving and Using Task Window Selections

Saving your task window selections enables you to run the same task multiple times. Rather than choosing the same selections each time you need them, you can make selections for the task once and then save the selections. Then, when you need to run the task again, you can access the saved task selections and simply re-execute them. The task is already set up for you, and it uses the latest data.

Note that SAS/ASSIST software always “remembers” the selections you used the last time you performed a task. Do not confuse this feature with saving task window selections as described in this chapter. Task window selections are only “remembered” until you perform the task again or manually clear the selections; in contrast, saved task selections are stored permanently, and must be accessed using the methods in this chapter.

This chapter shows you how to save the selections that you have made in a main task window, list your saved tasks and choose a task from the list, and clear the selections from the window to start a new task.

Task Window Selections

Saving Task Window Selections

1 The following steps instruct you to generate a simple listing report and then save the selections you have made for that listing report. For more detailed instructions on how to produce a listing report, refer to “Producing a Listing Report” on page 32.
a Follow this selection path:

Tasks ➤ Report Writing ➤ Listing

The List a Table window appears.
b If the active table is SASUSER.HOUSES, then continue to the next step.
Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.
c If there is an active Subset Data selection (indicated with BY, WHERE, or ROWS next to Subset data), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.
d If other report selections exist (for example, column names are listed for Columns), then select

File ➤ New

to clear these selections.
e If desired, run the report by selecting

Run ➤ Submit

The listing report appears in the Output window. Note that it is not necessary to run a task before saving it.
f To return to the List a Table window, use one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

2 From the List a Table window, select

File ➤ Save

The Save As window appears.

Display 5.1  Save As Window

3 In the Name field, type the name you want to call your report selections. For this example, type HOUSRPT.
A saved task name can be one to eight characters long; start with a letter (A through Z) or an underscore (_); and contain any combination of letters, numbers, and underscores.

4 In the Description field, type a description of the task. For this example, type **Houses Table Report**.

A description can be one to 32 characters in length and contain any combination of letters, numbers, and special characters.

The default catalog for saved tasks is SASUSER.PRIVATE. If you want to save the selections in a different catalog, type the catalog name in the **Catalog** field. Or, enter a question mark (?) in the Catalog field to obtain a list of available catalogs, and select one of them.

A **SAS catalog** is a SAS file that stores many different kinds of information in smaller units called catalog entries. A saved SAS/ASSIST task is stored as a catalog entry of type ASSIST.

The Type field is automatically filled in with **ASSIST (LISTING)** because all saved listing report tasks are of member type ASSIST. You cannot edit or change this field.

5 Select **OK**. The List a Table window reappears with a note in the message area that indicates that your task was successfully saved.

**Display 5.2** List a Table Window with Successful Save Message

---

**Note:** After you have saved the selections, you can select **Save** from the **File** menu again to save any additional changes to that task. △

If you want to save the selections using a different name, description, or catalog, select

```
File ▶ Save As
```

and repeat steps 3 through 5.
Clearing Selections

SAS/ASSIST software stores the last report you created in a particular window and automatically displays the selections for it in that window. To clear the selections from a window, follow this selection path:

File ➤ New

All of the task window selections are cleared except for the active table and Subset Data selections, if any. To clear all task window selections, including the active table and Subset Data selections, follow the directions in “De-Selecting an Active Table” on page 28. To clear only the Subset Data selections, follow the directions in “Clearing a Subset Data Selection” on page 29.

Listing and Choosing Saved Tasks

After you have saved a task in a window, you can display a list of the saved tasks and choose one for the current window.

1 To display a list of saved listing report tasks, follow this selection path from the List a Table window:

File ➤ Open

The Open window appears with your saved listing report tasks.

Note: The tasks listed in the Open window are applicable only to the current task window. In this example, only listing report tasks are shown. You can obtain a list of all saved tasks by using the Result Manager. See Chapter 6, “Using the Result Manager,” on page 71 for details on the Result Manager.

2 Type S (for Select) in the Cmd field next to the saved task that you want to use, and press ENTER. The saved task is loaded into the current window.

Note: If your saved task includes titles or footnotes, those titles or footnotes will be loaded along with the other task selections and will override any previously defined title or footnotes.
Setting Up and Using a Private Menu

If you find that you perform certain SAS/ASSIST tasks frequently using the same data, you may benefit from creating a private menu containing these tasks. A private menu enables you to access your saved SAS/ASSIST tasks without having to go through multiple menus or through the Result Manager. This section describes how to create, activate, and use a private menu.

Setting Up a Private Menu

The SAS/ASSIST private menu facility uses the saved SAS/ASSIST tasks in the SASUSER.PRIVATE (default) catalog, or a SAS catalog that you designate. To add a task to the private menu, make the task window selections, including the active table, and select Save As from the File menu. Save the task to the default SASUSER.PRIVATE catalog or to another catalog as described earlier in this chapter.

Activating the Private Menu

To activate the Private Menu, follow these steps:

1. Follow this selection path:
   
   Tasks ➤ Setup ➤ Profiles ➤ User

   The User Profile window appears.

   Display 5.3  User Profile  Window

   ![User Profile Window]

   The User Profile window allows you to control aspects of your SAS/ASSIST environment and customize it to your tastes.

2. In the Type field, type **PRIVATE MENU** and then press ENTER. A list of options for the Private Menu appears.
For information on each option, type \texttt{I} in the Cmd field for the option and then press ENTER. An information screen describing the option appears. Select \texttt{Close} to return to the User Profile window.

3 Change the values of the following options by typing over the existing values:

- **Catalog for private menu**
  Leave as SASUSER.PRIVATE, or enter another catalog in which you have saved SAS/ASSIST tasks.

- **Use private menu**
  Enter \texttt{Yes}

4 Leave the rest of the options as is. To save these options, follow this selection path:

\begin{verbatim}
File \rightarrow Close
\end{verbatim}

### Using the Private Menu

To use the Private menu, select

\begin{verbatim}
Tasks \rightarrow My Tasks
\end{verbatim}

A menu with your saved tasks appears.
Select the one you want to use. Another menu appears with a list of available actions (Browse Source, Edit, or Execute).

- **Browse Source** enables you to examine the source code for the saved task.
- **Edit** opens the task window and loads the task window selections for the saved task.
- **Execute** runs the saved task.

Select the action that you want to take for that task.

**Going Back or Moving On**

When you are finished with your saved task, you can either return to the WorkPlace menu or go on to another task:

- To return to the WorkPlace menu, select
  
  File ▶ Close

- To go on to another task, select **Tasks**, and then select the desired task.
Overview of the Result Manager

The Result Manager is a powerful tool for managing your saved results, such as SAS/ASSIST tasks, SAS output, programming code, logs, reports, and Structured Query Language (SQL) code and queries. This chapter describes some of the SAS/ASSIST Result Manager’s capabilities.

Accessing the Result Manager Window

To access the Result Manager, follow this selection path:

```
Tools ▶ Result Manager
```

The Result Manager window appears with a list of all the entries you have named and saved to your default catalog.
Organizing the Entries in the Result Manager Window

There are two ways to organize the entries in the Result Manager window: searching and sorting.

Searching for Entries

You can search for particular saved entries by editing the Name field and, as shown in the following examples, using pattern-matching characters %, *, and _. Note that the percent sign (%) and the asterisk (*) can be used to indicate one or more characters. The underscore (_) indicates only one character.

- Type AI% for one or more entries that start with AI of the type displayed.
- Type *NE for one or more entries that end with NE of the type displayed.
- Type %IR% for one or more entries that contain IR of the type displayed.
- Type T____N for a seven-letter entry name that starts with T and ends with N. (Note that there are five underscores between the first letter and the last letter.)
- Type ____ (four underscores) to list only those entries whose names contain four characters or fewer.

To restore the display to a full listing of saved entries, type % or * in the Name field.

Sorting Entries

You can sort the contents of the Result Manager window by Name, Description, Date, or Type. To sort the entries, select...
A menu of available sorting parameters appears. Select the parameter by which you wish to sort the entries. Note that if you sort by **Date**, the most recent entries appear at the top of the list.

---

**Using Commands to Manipulate Entries**

You can process a Result Manager entry by entering the following commands in the field to the left of each entry in the Result Manager window and then pressing ENTER. Each command enables you to perform an action. Because entries in the Result Manager window can be of several different types, not all commands are available for all entries.

- `?` displays a list of available commands. You can then select a command from the list to execute the command.
- `E` or `S` opens the program for editing, allowing you to make any necessary changes.
- `B` browses the entry.
- `X` executes the program.
- `D` deletes the entry.
- `V` verifies deletion of the entry (use after you have entered `D` to delete the entry).
- `R` renames the entry.
- `P` prints the entry.
- `C` makes a copy of the entry.
- `F` files or saves the entry to an external file that you specify.
- `L` submits the program for batch execution — available under z/OS only.

---

**Exiting the Result Manager**

When you are finished using the Result Manager, follow this selection path to return to the window from which you invoked the Result Manager:

`File ➤ Close`
Overview of Editing and Browsing Data

This chapter shows you how to edit and browse your data. Editing your data enables you to make changes to your data. When you are browsing your data, you can only look at the data; you cannot change the data. You can edit or browse multiple rows of your data at one time in a tabular format, or each row separately, one row at a time. To browse your data, follow the instructions in this chapter, but choose Browse Data instead of Edit Data.

Additional Information

For more information on editing and browsing data, refer to the online help for the FSEDIT and FSVIEW windows.
Editing Data in a Tabular Format

1. To edit or browse data, select

   **Tasks** ➔ **Data management** ➔ **Edit/Browse** ➔ **Edit Data**

   The Edit Data window appears.

   **Note:** For this example you will edit the data, but if you wanted only to browse
   the data, you would select **Browse Data** instead of **Edit Data**. △

   Display 7.1  Edit Data Window

2. Select [Tabular format]. The Edit Data in Tabular Format window appears.

   Display 7.2  Edit Data in Tabular Format Window

3. If the active table is SASUSER.HOUSES, then continue to the next step.
   Otherwise, select [Table], and then select the SASUSER.HOUSES table. For more
   information on selecting tables, see “Selecting a Table” on page 24.
4 Select [Run] at the bottom of the Edit Data in Tabular Form window. The data from the SASUSER.HOUSES table appears in the FSVIEW window. Disregard any notes in the message area about a formula.

Display 7.3 HOUSES Table Data

When you edit data in a tabular format, multiple rows are shown in one window.

5 To see the rest of the columns to the right of the window, use the scroll bars or the RIGHT and LEFT function keys. You can also use your FORWARD and BACKWARD function keys to move to the next and previous windows of rows if you have more rows than will fit in one window.

Setting the Update Mode

You can edit data in tabular format in one of two update modes: record-locking or member-locking. If you edit data in record-locking mode, then you must first select a row before you can edit it. This method prevents you from accidentally editing the wrong row. If you edit data in member-locking mode, then you can edit any row in the window without selecting it first. The default update mode is record-locking.

1 To set the update mode, select Edit from the menu bar, and then select Update or Set modification mode, depending on your operating environment. The Update or Set modification mode dialog box appears.
Display 7.4  Update Window

2  Select the update mode you want to use: RECORD (to edit one row at a time only after you have selected it) or MEMBER (to edit any row on the window). The Update window remains displayed.

   For this example, select RECORD if it is not already selected, and then select OK. The FSVIEW window reappears.

---

**Editing by Row**

Use the following process to make changes to existing data. When record-locking is turned on, you must first select a row before you can edit it.

1  If you have not already done so, turn record-locking on by following the directions in the previous section.

2  To edit a row, select the row you want to edit. The row of data is highlighted to indicate that it is selected.

   For this example, select row 15 (or the last row).

3  To edit the data, press TAB or use the right and left arrow keys to move the cursor to the data you want to change, and then type the new data over the old data. To edit another row, repeat these steps.

   For this example, position the cursor on the CONDO style of row 15 (or the last row) and type SPLIT over CONDO (or over the existing style).

---

**Editing by Member**

Use this process to make changes to existing data. When member-locking is on, you can edit any row in the window without first selecting the row. To turn member-locking on, follow the directions in “Setting the Update Mode” on page 77, except select MEMBER in the Update window.

To edit a row, use the arrow keys to position the cursor on the data you want to change and type the new data over the old data.
Adding Data

Use this process when you want to add new information to the table. For example, you might want to add new houses for sale to the HOUSES table. Follow these same instructions to add data whether record-locking or member-locking is on:

1. To add data, select Edit ▶ Autoadd

A NEW row appears at the bottom of the window.

**Display 7.5 Adding a New Row**

When the AUTOADD feature is turned on, a new row is automatically displayed at the bottom of the table. This row is not added to the table until you enter values in it. After you enter values and press ENTER, the row is added to the table and another new row is displayed.

2. Type data in each column, and press TAB to move from column to column.

Type the data where the cursor is placed within each column after you press TAB. After you type all the data for each column in the row, press ENTER. The numeric data align to the right of each column. The dollar sign and decimal are also added to the price after you press ENTER.

After you type the number of baths, you can use the scroll bars or the RIGHT and LEFT function keys to display additional columns.

For this example, type the data as follows:

<table>
<thead>
<tr>
<th>STYLE</th>
<th>CONDO</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQFEET</td>
<td>1420</td>
</tr>
<tr>
<td>BEDROOMS</td>
<td>3</td>
</tr>
<tr>
<td>BATHS</td>
<td>2</td>
</tr>
<tr>
<td>STREET</td>
<td>Oak Street</td>
</tr>
<tr>
<td>PRICE</td>
<td>85000</td>
</tr>
</tbody>
</table>
When you have typed one row of data and pressed ENTER, another NEW row appears at the bottom of the window. This feature is a result of having Autoadd turned on.

**Display 7.6  New Row**

![](image)

3 When you have finished entering new rows, select

![Edit](image) ![Autoadd](image)

to turn off the Autoadd feature.

**Duplicating Data**

If some rows are similar, then you can duplicate a row and type in the data for the columns that are different. Follow the same instructions for duplicating rows whether record-locking or member-locking is on.

1 To duplicate a row, select

![Edit](image) ![Duplicate](image)

The Duplicate window appears.
2 Type the number of copies you want to make and the number of the row you want to duplicate.

For this example, make two copies of row number 16 (or the last row), and then select **OK**. The duplicated rows appear at the bottom of the list of rows.

3 Edit the duplicated rows as necessary with the new data. For this example, select row number 18 and change the style to **SPLIT**.
Deleting by Row

If record-locking is on, then you must first select a row before you can delete it. You can turn record-locking on by following the directions in “Setting the Update Mode” on page 77.

1. To delete a row, select the row that you want to delete. The row is highlighted to indicate that it is selected. For this example, select row 18 (or the last row).

2. Select

   ![Edit](image) ![Delete](image)

   The Delete window appears.

Display 7.9  Delete Window

![Delete Window Image]

3. Type the number of the row you want to delete (the row that is highlighted). For this example, type **18**, and then select **[OK]**. The highlighted row is deleted and the FSVIEW window appears.

4. Also delete rows 16 and 17.

Deleting by Member

If member-locking is on, then you can delete any row without selecting it. To turn member-locking on, follow the directions in “Setting the Update Mode” on page 77, except select **MEMBER** in the Update window.

1. To delete a row, select

   ![Edit](image) ![Delete](image)

   The Delete window appears.

2. Type the row(s) you want to delete. Select **[OK]**. If you want to delete more than one row, then type the row numbers separated by spaces. For example, type **1 3 5** to delete rows 1, 3, and 5. If you want to delete a range of rows, then type the
beginning and ending row numbers separated by a hyphen. For example, type 12-15 to delete rows 12 through 15.

Select OK. The rows are deleted, and the FSVIEW window appears.

---

**Creating a Subset of Your Data**

If you want to see only a part of the data (for example, if you want to see only the houses for sale that are larger than 1,500 square feet with three bathrooms), you can create a subset of the data with a WHERE clause. The WHERE clause selects a subset of rows by comparing the values of the columns to the value you specify in the clause.

1. To create a subset of the data, select Search ▶ Where

The Where window appears.

**Display 7.10  Where Window**

2. To look at only the houses that are larger than 1,500 square feet, type the clause sqfeet>1500, and then select OK. The HOUSES data in the window includes only houses with more than 1,500 square feet. The word Where appears at the top of the window to indicate that a WHERE clause is in effect.
To create a further subset of the data so that you see only the houses with more than 1,500 square feet that have three bathrooms, select Search ➤ Where also

The Where also window appears. Type **baths=3** to select only the houses with three bathrooms.

Select [OK]. The HOUSES data in the window includes only houses with three bathrooms and that are larger than 1,500 square feet.

Display 7.12  Houses with More Than 1,500 Square Feet and Three Baths
The following is a list of some of the comparison operators that you can use in a WHERE clause (arithmetic, logical, and other operators are also available):

- **LT or <** less than
- **GT or >** greater than
- **EQ or =** equal to
- **LE or <=** less than or equal to
- **GE or >=** greater than or equal to
- **NE or <>** not equal to
- **IN** equal to one in a list

If you use character strings in the clauses, they must be enclosed in double or single quotes and must be in the correct case. For example, if you only want to see the ranch-style houses, you would type `style='RANCH'`. The word RANCH needs to be in all capital letters because all of the styles in the HOUSES table are in uppercase.

5 To undo the last WHERE clause (the restriction of three bathrooms in this example), select **Search** ▶ **Undo last where**

The last WHERE clause that selected the houses with three bathrooms is removed, and all the houses with more than 1,500 square feet appear.

Continue to select **Undo last where** to undo each previous WHERE clause.

---

**Saving**

Periodically, you may want to save any changes and additions you have made to the data so that they are stored permanently. The autosave feature saves the changes for you after 25 row modifications. You can change the autosave feature so that it saves data after any number of row modifications you specify. You also can save data at any time.

☐ To save changes, select

[**File** ▶ **Save**]

Any additions or changes to the data are saved.

☐ To change the autosave feature, select

[**Edit** ▶ **Autosave**]

The Autosave window appears. Type the number of row modifications after which you want to save your changes and additions. Select [OK]; the FSVIEW window reappears. Changes you make to the table are saved automatically after the number of row modifications you specified.
Exiting the FSVIEW Window

When you have finished editing the data, exit as follows:

1. Select **File** ➤ **Close**

   The Edit Data in Tabular Format window reappears.

2. Select [Goback] twice to return to the WorkPlace menu.

Editing Data One Row at a Time

When you edit data one row at a time, only one row is shown per window.

1. To edit data one row at a time, follow this selection path:

   **Tasks** ➤ **Data Management** ➤ **Edit/Browse** ➤ **Edit Data**

   The Edit Data window appears.

2. Select **Single row**. The Edit Data One Record at a Time window appears.

3. If the active table is SASUSER.HOUSES, then continue to the next step.
   Otherwise, select **Table**, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

4. Select **Run**. The first row of the HOUSES table appears.

   **Display 7.13** First Row of HOUSES Table

   The row number is located in the top of the window. Each window presents one row in the HOUSES table. Each window is called a record or a row. Each field in the window represents a column.
Moving Around

To move to different rows, select View from the menu bar. From the View menu, you can

- select Next Observation to move forward to the next row (“observation” is another word for “row”)
- select Previous Observation to move backward to the previous row
- select Observation Number to move to a specific row. The Observation number window appears. Type the number of the row you want to display, and then select OK. The row that you requested appears.

If there are more columns than will fit on one screen, each row has as many screens as necessary to display all the columns for the row. Use Next screen and Previous screen from the View menu to move from screen to screen within a row. The HOUSES table has only one screen per row.

You can also use the FORWARD, BACKWARD, RIGHT, and LEFT function keys to move from row to row and screen to screen.

Editing Data

To edit a row, position the cursor on the data you want to change, and type the new data over the old data.

For this example, display row 15 using the items from the View menu or the function keys. Change the style to CONDO.

Adding Data

Use this process when you want to add new information to the table. For example, you might want to add new houses for sale to the HOUSES table.

1 Select

   Edit ▶ Add New Record

A blank row appears as the last row, and the word New appears at the top of the window.
Duplicating Data

If some rows are similar, then you can duplicate a row and type in the data for the columns that are different.

1. To duplicate data, display the row you want to duplicate by using the items from the View menu or the function keys.

   For this example, display row number 1.

2. Select

   Edit ➤ Duplicate Record
The row displayed (row 1) is duplicated and added to the end of the rows in the table. The word New appears in the top of the window to indicate that this is a new (duplicated) row.

Display 7.15  Duplicated Record

3 Make any changes to the row as necessary. After you move to another row, the new row is assigned a row number.

For this example, change the style to CONDO.

Deleting Data

1 Display the row you want to delete by following this selection path:

   View ▶ Observation Number

   For this example, display the last row by entering a number that is higher than that of the last row, for example, 99.

2 Select

   Edit ▶ Delete Record

   The data in the row’s fields is deleted.

3 Follow this selection path to view the previous row:

   View ▶ Previous Observation

   Repeat step 2 to delete this row.

Canceling Changes

If you make any changes to a row, then you can cancel the changes as long as you have not moved to another row, saved the row, or ended the editing session.
Creating a Subset of Your Data

If you want to see only a part of the data (for example, if you want to see only the houses for sale that are larger than 1,500 square feet with three baths), you can create a subset of the data with a WHERE clause. The WHERE clause selects a subset of rows by comparing the values of the columns to the value you specify in the clause.

1. To create a subset of the data, select
   ![Search](search_icon) ![Where](where_icon)
   The Where window appears.

2. To look at only the houses that have more than 1,500 square feet, type the clause `sqfeet>1500`.
   Select ![OK](ok_icon). As you move from row to row, only houses with more than 1,500 square feet appear. The word Where appears at the top of the window to indicate a WHERE clause is in effect.

3. To create a further subset of the data so that you see only the houses with more than 1,500 square feet that have three bathrooms, select
   ![Search](search_icon) ![Where also](where_also_icon)
   The Where Also window appears. Type `baths=3` to select only the houses with three bathrooms.

4. Select ![OK](ok_icon). As you move from row to row, only houses with three bathrooms that have more than 1,500 square feet appear.

The following is a list of some of the comparison operators that you can use in a WHERE clause (arithmetic, logical, and other operators are also available):

- LT or `<` less than
- GT or `>` greater than
- EQ or `=` equal to
- LE or `<=` less than or equal to
- GE or `>=` greater than or equal to
- NE or `<>` not equal to
- IN equal to one in a list

If you use character strings in the clauses, make sure they are enclosed in double or single quotes and are in the correct case. For example, if you wanted to see only the ranch-style houses, you would type `style='RANCH'`. The word RANCH needs to be in all capital letters because all the styles in the HOUSES table are in uppercase.

5. To undo the last WHERE clause (the restriction of three bathrooms in this example), select
Search ► Undo last where

The last WHERE clause that selected the houses with three bathrooms is removed, and all the houses with more than 1,500 square feet appear. Continue to select undo last where to undo each previous WHERE clause.

Saving

Periodically, you may want to save any changes and additions you have made to the data so that they are stored permanently. The autosave feature saves the changes for you after 25 row modifications. You can change the autosave feature so that it saves data after any number of row modifications you specify. You can also save data at any time.

☐ To save changes, select
File ► Save

Any additions or changes to the data are saved.

☐ To change the autosave feature, select
Edit ► Autosave

The Autosave window appears. Type the number of row modifications after which you want to save your changes and additions. Select OK; the FSEDIT window reappears. Changes you make to the table are saved automatically after the number of row modifications you specified.

Exiting the FSEDIT Window

When you have finished editing the data, exit by following this selection path:

File ► Close

Select Goback twice to return to the WorkPlace menu.
Overview of Sorting Data

Sorting data enables you to categorize your data and arrange it in a particular order. For example, if you are sorting data on houses for sale, you can sort the data by a particular value, such as by the number of square feet. You can arrange the data in ascending or descending order, such as from the smallest house to the largest house. You can sort by a number such as by the price of a house, or by a characteristic such as in alphabetical order by the style of the house.

In this chapter you learn how to sort the data in the HOUSES table in ascending order by style and then descending order by square footage. The sorted data are stored in a temporary table called WORK.STYLE. When sorted, the houses are in order alphabetically by style. If more than one house has the same style, then the largest house is listed first.

The original order of the houses in the HOUSES table is shown in the following display as viewed using Edit/Browse on the Data Management menu.
Display 8.1  Unsorted Houses Table

Refer to Chapter 7, “Editing and Browsing Data,” on page 75 for information about editing and browsing.

Additional Information

For additional information about sorting data, refer to the SORT Procedure chapter in the Base SAS Procedures Guide.

Sorting Data

Instructions

1  To sort your data, follow this selection path:

Tasks ► Data Management ► Sort

The Sort a Table window appears.
2 If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

3 If other report selections exist (for example, column name is listed for Sort by columns), then select File ➤ New to clear these selections.

4 Select Output table from the Sort a Table window. The Specify Output Table window appears.

Display 8.3 Specify Output Table Window
An output table enables you to store the sorted table separately from the original table. If you do not select an output table, the sorted table overwrites the original table.

5 In the Table field, type **STYLE** as the name of the output table in which you want to store the sorted data. See “SAS Tables” on page 117 for details on assigning names to tables.

*Note:* **Replace if existing** enables you to replace the data in an existing table with the newly sorted data. If the STYLE table already exists, then you can use this item to store the newly sorted data in place of whatever was currently stored in the STYLE table. Otherwise, you get an error message that states that the STYLE table already exists. You can either enter another name for the table or select **Replace if existing** to replace the existing data.

6 You can store the data temporarily or permanently. For this example, store the data temporarily.

- To store the sorted data only for the length of the SAS session, select **Temporary**. The sorted data are stored in a temporary table called WORK.STYLE, which is deleted when you end the SAS session.
- To store the sorted data permanently, select **Permanent**. A list of existing librefs appears.

Select the libref for the location where you want to store the data, for example, the SASUSER libref. The table STYLE is stored in the library whose libref is SASUSER, and remains there until you delete it.

A **libref** specifies the SAS data library in which you want to store the sorted data. Refer to “SAS Data Libraries” on page 119 for more information about librefs.

7 Select [OK] at the bottom of the window. The Sort a Table window reappears.

8 Select [Sort by columns] from the Sort a Table window. Select the STYLE column first and the SQFEET column second. For more information on selecting columns, refer to “Selecting a Column” on page 27.

9 Select [Ordering of columns] from the Sort a Table window. The Select the Ordering of Columns window appears.

**Display 8.4** Select the Ordering of Columns Window
You can choose to order the data in ascending, descending, or mixed order.

10 Select **Mixed ascending and descending order**. The BY Column Sort Order window appears.

**Display 8.5**  BY Column Sort Order Window

11 For the STYLE column, select **Ascending order**. For the SQFEET column, select **Descending order**.

12 Select [OK]. The Sort a Table window reappears.

13 Select **Run** ➤ **Submit**

The table is sorted according to the specifications that you indicated. A message appears that indicates that the table was successfully sorted.
14 Select [Goback] to return to the Sort a Table window.

15 To see how the table has been sorted, edit or browse the WORK.STYLE table in a tabular format. The sorted table is shown in the following display.

Refer to Chapter 7, “Editing and Browsing Data,” on page 75 for more information about editing and browsing data.

The styles of houses are listed alphabetically. Houses with a style of CONDO are first in the table. Within each style, the houses are listed from largest to smallest.
Exiting This Task

When you are finished looking at your sorted table, select

File ➤ Close

When you are ready to return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.
Overview of Defining a New Column

You can create new columns from existing data. For example, you may want to know the cost per square foot for each house in the HOUSES table. This information does not exist in the HOUSES table. However, by using SAS/ASSIST software, you can create a new column that contains this data in a new table. New columns cannot be added to existing tables.

This chapter shows you how to determine the cost per square foot for each house in the HOUSES table, and how to store that information in a new column in a new table.

Additional Information

For additional information about defining columns, refer to the SAS Language Reference: Concepts.

Defining a New Column

Instructions

1. To define a new column, select

   Tasks ➤ Data Management ➤ Subset/Copy

   The Subset or Copy a Table window appears.
When you define a new column, you use **Subset/Copy** because the existing table is copied and the newly defined column is created to generate the output table.

2 If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select **Table**, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

3 If other report selections exist (for example, column names are listed for **Define new columns**), then select **File** ▶️ **New**

   to clear these selections.

4 Select **Output data** from the Subset or Copy a Table window. The Output Table or View window appears.
An output table enables you to store the data with the new column separate from the original data.

5 In the Table/View field, type **HOUSCOST** as the name of the output table in which you want to store the data with the new column. See “SAS Tables” on page 117 for details on naming SAS tables.

*Note:* Use **Replace if existing** to replace the data in a table or view of the same name. Otherwise, you get an error message that the table already exists and you must enter a new table name. △

6 You can store the data temporarily or permanently. For this example, store the data temporarily.

   - If you want to store the data only for the length of the SAS session, select **Temporary**. The data is stored in a temporary table called WORK.HOUSCOST, which is deleted when you end the SAS session.

   - If you want to store the data permanently, select **Permanent**. A list of existing librefs appears. Select the libref for the location where you want to store the data, for example, the SASUSER libref. The table HOUSCOST is stored in SASUSER, and remains there until you delete it.

7 You can store the data with the new column either as a table or as a view. For this example, store the data as a table.

8 Select **OK**. The Subset or Copy a Table window reappears.

9 Select **Define new columns** from the Subset or Copy a Table window. The Define or Modify a Column window appears.
In the Column field, type **FOOTCOST** as the name of the new column. See “SAS Tables” on page 117 for details on naming columns.

Select **Numeric** as the type of the column.

A column can be character or numeric. If a column is defined as character, then it can contain letters, numbers, special characters, and symbols, but it cannot be used in arithmetic calculations. If a column is defined as numeric, then it can contain only numbers, decimal points, plus signs, and minus signs, and it can be used in arithmetic calculations.

In the Label field, type **Cost per Square Foot**. A label can be up to 40 characters, and it can be printed instead of, or in addition to, the column name in certain tasks.

Select [Format]. The Select Numeric Format window appears.
Defining a New Column

Display 9.4 Select Numeric Format Window

A format is a pattern that SAS uses to determine how a column value should be displayed. SAS provides a set of standard formats and also enables you to define your own custom formats. For example, the DOLLARw.d default format displays the amount 1200 as $1,200. For more information on formats, refer to SAS Language Reference: Dictionary.

14 Select the DOLLARw.d format. The Specify Format Widths window appears with the default definition for the selected format.
15 Select **OK** to accept the defaults of 10 for the format width and 0 for the number of digits to the right of the decimal point. The Define or Modify a Column window reappears.

16 Select **Initialize** from the Define or Modify a Column window. The Enter Numeric Expression window appears. This window enables you to define (initialize) the new column.
For this example, you can determine the cost per square foot by building the arithmetic expression of price divided by square feet (PRICE/SQFEET). The cost per square foot is calculated for each house and stored in the new column called FOOTCOST. You can build the expression by using one of the methods listed below.

- You can type the expression directly by using [EDIT THE EXPRESSION].
- You can build the expression by using items in the window. If you use the items in this window, then the items that are available for selection are highlighted while you are building the expression.

17 To build the expression by using the items in the window, select COLUMN from the Enter Numeric Expression window. Select the PRICE column. For more information on selecting columns, refer to “Selecting a Column” on page 27.

18 Select the division symbol (/).

19 Select Column again, and then select the SQFEET column the same way you selected the PRICE column in step 17. The Enter Numeric Expression window reappears.

20 Select OK. The Define or Modify a Column window reappears with the new column defined.
Display 9.7   Definition of the FOOTCOST Column

Select [OK]. The Define New Columns window appears with information about the new column.

Display 9.8   Define New Columns Window

Select [OK] again. The Subset or Copy a Table window reappears.

To copy the data into the new table and generate the new column, select

Run [Submit]

The data from the HOUSES table is copied into the HOUSCOST table, and the new column FOOTCOST is created. The new table is shown in a tabular format.
Display 9.9  HOUSCOST Table

22 When you finish looking at the new table, follow this selection path to return to the Subset or Copy a Data Set window:

File ➤ Close

Exiting This Task

When you are ready to return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.
Overview of Saving and Using Source Code

When you perform a task with SAS/ASSIST software, you generate SAS program code that is executed in the background. You can save this code, called source code in this document, for editing and re-execution.

By viewing, editing, and re-executing the source code, new users receive an introduction to the SAS programming language. Saving source code is also useful for experienced users who want to use the programs that SAS/ASSIST software creates as a basis for customized applications.

This chapter shows you how to save and access the source code from a listing report.

Creating Source Code

The following steps instruct you to generate a listing report and then save the programming statements that are generated for that listing report. For more detailed instructions on how to produce a listing report, refer to Chapter 3, “Report Writing,” on page 31.

1 Select

Tasks ▶ Report Writing ▶ Listing

The List a Table window appears.

2 If the active table is SASUSER.HOUSES, then continue to the next step.
   Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.
If there is an active Subset Data selection (indicated by BY, WHERE, or ROWS next to Subset data), then follow the directions in “Clearing a Subset Data Selection” on page 29.

If other report selections exist (for example, column names are listed for Columns), then select File ▶ New to clear these selections.

If desired, run the report by selecting Run ▶ Submit.

The Listing Report appears in the Output window. Note that it is not necessary to run a task before saving its source code.

Return to the List a Table window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

### Viewing Source Code

The steps in this section enable you to look at the program that was created by SAS/ASSIST software when you produced the listing report.

1. From the List a Table window, select View ▶ View source.

The program that was created when you made the listing report task window selections appears.

Display 10.1 Program for Creating Listing Report

Use the scroll bars or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to view the program.
3 When you finish looking at the program, select File ▶ Close to return to the List a Table window.

---

**Saving Source Code**

The steps in this section enable you to save the program that produced the listing report so that you can edit it or re-execute it at a later time.

1 Follow this selection path from the List a Table window:
   File ▶ Save as source

   The Save As window appears.

   **Display 10.2  Save As Window**

   ![Save As Window]

   2 In the Name field, type the name you want to call the program. For this example, type **Houserpt** as the program name.

   A program name can be one to eight characters in length. It must start with a letter (A through Z) or an underscore (_), but it can otherwise contain any combination of letters, numbers, and underscores.

   3 In the Description field, type a description of the program. The Description can be up to 32 characters in length and contain any combination of letters, numbers, and other characters. For this example, type **Listing of the Houses Table**.

   4 The default catalog for saved source code is called SASUSER.PRIVATE, as shown in the previous display. If you want to save the source code in a different catalog, type the catalog name in the Catalog field. For a list of available catalogs, type a question mark (?) in the Catalog field and press ENTER to display a list of available catalogs. You can select one from this list.

   5 Select **OK** to return to the List a Table window. A note appears in the message area to indicate that the program has been successfully saved.
Editing and Re-executing Source Code

You can use the Result Manager to edit and re-execute the program that you saved in the previous section. For more information on the Result Manager, see Chapter 6, “Using the Result Manager,” on page 71.

1. Select `Tools` ➤ `Result Manager` to invoke the Result Manager. The Result Manager window appears with a list of your saved tasks, output, and programs.

2. Position the cursor in the space to the left of `HOUSREPT`. Type `E` (or `S`) and press `ENTER`. The Edit window appears with your program.

Display 10.3  Edit Window

3. Position the cursor over the semicolon (`;`) in the line with the `footnote` statement. Add a footnote by pressing the SPACE BAR, and then typing

```
SASUSER.HOUSES.DATA;
```

as shown in the following display.
4 Select **File ▶ Close**

to save the edited program and return to the Result Manager window. A prompt appears asking if you want to save the changes to the program. Select **Yes**.

5 In the Cmd field for `HOUSREP`, type `X` and press ENTER to re-execute the program and view the footnote you added.

Display 10.5  Modified Listing Report Output
To return to the Result Manager window from the Output window, use one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

From the Result Manager window, select File ➤ Close to return to the List a Table window.

**Exiting This Task**

When you are ready to return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.
Overview of Setting Up SAS Files

In this chapter you learn about SAS file conventions and structures and how to set up SAS files for use with SAS.

Additional Information

For additional information about SAS files, refer to SAS Language Reference: Concepts.

SAS Files

SAS Tables

A table is a collection of information, as shown in the sample table in the following figure. A SAS table stores data in a form that the SAS System can use.
This diagram shows part of the HOUSES sample table that contains information on houses for sale including the house style, square footage, number of bedrooms, and number of bathrooms. The HOUSES table is one of the SAS/ASSIST sample tables; see “Creating the Sample Tables” on page 21 for details on creating the sample tables.

A table name can be one to 32 characters in length. It must start with an uppercase or lowercase letter (A through Z, a through z) or an underscore (_), but it can otherwise contain any combination of uppercase and lowercase letters, numbers, and underscores. Note, however, that the mixed-case capability of table names is for display purposes only; SAS software does not distinguish between, for example, the names “Dog,” “DOG,” and “dog.” Also, due to window space considerations, some table name entry fields in SAS/ASSIST software do not allow you to enter more than eight characters.

A table consists of the following components:

- **Data Values**
  - A data value is a single unit of information, such as the square footage for one house.

- **Columns**
  - A column is a set of data values that represents a particular type of data, for example, the price of all the houses.

  - A column can be character or numeric. A character column contains data values that can consist of any combination of letters, numbers, and special characters. A numeric column contains values that consist only of numbers and related symbols such as decimal points, plus signs, and minus signs. If you are going to perform arithmetic calculations on a column, then the column must be numeric.

  - A column name can be one to 32 characters in length. It must start with an uppercase or lowercase letter (A through Z, a through z) or an underscore (_), but it can otherwise contain any combination of uppercase and lowercase letters, numbers, and underscores. Note, however, that the mixed-case capability of column names is for display purposes only; SAS software does not distinguish between, for example, the names “Dog,” “DOG,” and “dog.” Also, due to window...
Setting Up SAS Files

Temporary and Permanent Tables

space considerations, some column name entry fields in SAS/ASSIST software do not allow you to enter more than eight characters.

rows

A *row* is a set of data values for the same item, for example, all the information about one house, such as price, style, square footage, and so on.

Older versions of SAS/ASSIST software use the terms *data set*, *observation*, and *variable* for table, row, and column, respectively. You may encounter these terms in other SAS products and documentation.

### SAS Data Libraries

A *SAS data library* is used to store and manage data in SAS files. It is a collection of one or more SAS files, such as a SAS table, that is recognized by SAS. Each file is a *member* of the library.

A *libref* is the name you associate with the SAS data library. You assign a libref to each SAS data library that you need to access. Then you reference files in the library by using the corresponding libref in your SAS task. A libref can be one to eight characters in length. It must start with a letter (A through Z) or an underscore (_), but it can otherwise contain any combination of letters, numbers, and underscores.

After you establish a libref for a SAS data library, you use the libref throughout your SAS session so that SAS knows where to look for SAS files that already exist or where to store new SAS files that you create.

### Data Files and Data Views

A SAS table can be one of two member types: DATA or VIEW. A SAS table of type DATA contains descriptor information and data values and is called a *SAS data file*. A SAS table of type VIEW is called a *SAS data view* and contains descriptor information that points to the data values, but it does not contain the actual data values. A SAS data view differs from a SAS data file in that it only contains a description of data that is stored elsewhere. The data itself is stored in other SAS data files, in another software vendor’s database management system (DBMS), or in external files. For more information on creating and using SAS data views, see *SAS Language Reference: Concepts* and *SAS/ACCESS for Relational Databases: Reference*.

Both data files and data views can be used in the same way, and in most cases it does not matter whether the data comes from a data file or from a data view.

All examples in this document use SAS data files.

### Temporary and Permanent Tables

SAS creates two types of tables: temporary tables and permanent tables. A *temporary SAS table* exists only for the duration of the current SAS session. A *permanent SAS table* exists after the end of the current SAS session and until you delete it.

Temporary SAS tables are automatically assigned to a library called WORK, which is deleted when you exit SAS software. Permanent SAS tables are members of a previously defined SAS data library.

Both types of SAS tables have two-level names in the form of *libref.table-name*. When you create or refer to a permanent SAS table, you must specify both the libref and the table name. When you create or refer to a temporary SAS table, you may either specify the WORK libref or specify the table name only; if you specify the table name only, then SAS uses the WORK libref.
SAS Catalogs

A SAS catalog is a SAS file that stores many different kinds of information in smaller units called catalog entries. Catalog entries are identified by name and type. For example, a saved SAS/ASSIST task is a catalog entry of type ASSIST, and has a name that is one to eight characters long. Like a SAS table, a SAS catalog must be associated with a SAS library, and is identified with a two-level name in the form of libref.catalog-name.

Operating Environment Specific Information

The following sections discuss some of the operating environment specifics for SAS data libraries. For more information about SAS libraries, refer to the SAS companion documentation for your operating environment.

Directory-based Operating Environments (Microsoft Windows, UNIX, OpenVMS Alpha)

In a directory-based operating environment such as Microsoft Windows, UNIX, or OpenVMS Alpha, a SAS data library is a group of SAS files in one or more directories. Any directory can become a SAS data library when SAS files are stored in that directory. However, since the SAS data library is a logical grouping of tables, and not an actual physical grouping, external files stored in the same directory are unaffected by the SAS data library.

The form of the SAS table name under a directory-based operating environment is libref.filename.

You use the Assign a New Libref action in SAS/ASSIST software to associate a libref with a SAS data library. You will find instructions for assigning a libref later in this chapter.

z/OS Operating Environment

Under the z/OS (formerly known as MVS) operating environment, a SAS data library is implemented both logically and physically as a specially formatted operating environment table that contains only SAS files. Each SAS file is a member of the library, and each member has a member type that identifies the type of SAS file that it represents, such as data, catalog, or access.

The form of the SAS table name under z/OS is libref.member.

You use the Assign a New Libref action in SAS/ASSIST software to associate a libref with a SAS data library. You will find instructions for assigning a libref later in this chapter.

If you are referencing or creating an OE-data-set-name that has not been allocated by the z/OS operating environment, then SAS prompts you about whether you want to allocate the file and then allocates it for you.
Using SAS/ASSIST Software to Assign a New Libref

SAS automatically assigns the libref SASUSER to a SAS data library under your operating environment so that you can permanently store your work without assigning another libref.

1. To assign a new libref, follow this selection path:

   Tasks ▶ Setup ▶ File Management ▶ SAS data libraries

   The SAS Data Libraries window appears.

   Display 11.1 SAS Data Libraries Window

   Note that under z/OS, there is an additional option for Table information. This option provides information about the operating environment and a list of allocated DDNames.

2. Select List current librefs. The Select a Library window appears with a list of the currently assigned librefs. The purpose of this step is just to view the current list of librefs.
Display 11.2  Library Selector Window

Note:  The preceding display shows the Select a Library window for the UNIX operating environment. Other operating environments may have different formats for the Host Path Name.

3 Select [Cancel] to return to the SAS Data Libraries window.
4 Select assign a new libref from the SAS Data Libraries window. The Assign a New Libref window appears.

Display 11.3  Assign a New Libref Window

Note:  Under z/OS, the [Host Options] button in the Assign a New Libref window is used to specify operating environment-specific parameters such as disposition and space.

5 In the Libref field, type the libref you want to use. Follow the naming conventions described previously. For this example, type MYDATA.

   In the Name of the SAS data library field, type the name you want to use according to the naming conventions described below.

   □ Under z/OS, type a fully qualified operating environment table name, for example, USERID.SAS.DATA.
Setting Up SAS Files

- Under UNIX, type the name of an existing directory or subdirectory, for example, MYDATA.
- Under Windows, type the name of an existing directory or subdirectory, for example, C:\SASDATA.
- Under OpenVMS Alpha, type the name of an existing directory or subdirectory, for example, \[MYDATA\].

6 Select [OK]. A message appears that indicates that the libref was successfully assigned. Select [Goback].

7 Under z/OS only, if the file is not allocated, the software will prompt you to allocate the file and then allocate it for you. The SAS Data Libraries window reappears.

8 Select List current librefs again. This time the libref you just assigned is listed.

Display 11.4 Library Selector Window with New Libref

9 To return to the WorkPlace menu, select Cancel ➤ Goback

Deleting a SAS Table

1 To delete a SAS table, follow this selection path:

Tasks ➤ Data Management ➤ Dbms Access

A SAS Explorer window appears with a list of all the SAS files allocated to your SAS session. If you already have a SAS Explorer window open, then this SAS Explorer window is designated with a (2) on the window’s title bar.
2 In the left pane of the SAS Explorer window, select the data library that contains
the table that you want to delete.

3 In the right pane of the SAS Explorer window, select the table that you want to
delete. (If you have a mouse, single-click the table name.)

4 Select

   Edit ▶ Delete

   A prompt appears, asking you if you are sure that you want to delete the table.
   Select OK to delete the table or Cancel to cancel the delete.

   Note: If the table that you select for deletion is an active table in one or more
   SAS/ASSIST tasks, then you cannot delete it. If you want to delete an active table,
   then remove the table from active status by following the directions in
   “De-Selecting an Active Table” on page 28.

5 To exit the SAS Explorer window, select

   File ▶ Close

6 When you are ready to return to the WorkPlace menu or move on to another task,
   follow the directions in “Exiting a Task” on page 29.
Overview of Entering Data

In this chapter you learn how to create and enter new data both in a tabular format and one row (record) at a time. The Edit/Browse functions described in Chapter 7, “Editing and Browsing Data,” on page 75 show how to add new data to an existing table, whereas this task enables you to enter new data in a newly created table.

This chapter shows you how to create a table called SALES and how to enter the first five months of gross sales data.

Additional Information

For more information on the FSVIEW and FSEDIT windows, see the online help for those windows.

Entering Data

Instructions

To enter data interactively, select

Tasks ➤ Data Management ➤ Create data ➤ Interactively

The Enter Data Interactively window appears.
Display 12.1  Enter Data Interactively Window

Display 12.2  Select a New Table to Create Window

Entering Data in a Tabular Format

1 Select **Enter data in tabular form**. The Select a New SAS Table to Create window appears.

2 In the Table field, type **SALES** as the name of the table that you want to create for the new data. Refer to “SAS Tables” on page 117 for information about table naming conventions.

3 You can store the table temporarily or permanently. For this example, store the table temporarily.
   - If you want to store the data only for the duration of the SAS session, then select **Temporary**. The data is stored in a temporary table called WORK.SALES, which is deleted when you end the SAS session.
If you want to store the data permanently, then select **Permanent**. A list of existing librefs appears. Select the libref for the location where you want to store the data, for example, the SASUSER libref. The table SALES is stored in the SASUSER library and remains there until you delete it.

4 Select **OK**. The Define a New SAS table window appears.

**Note:** **Replace if existing** enables you to replace the existing table with a new table of the same name. If the SALES table already exists, then you get an error message stating this. You may either enter another name for the table or select **Replace if existing** to replace the existing table.

**Display 12.3** Define a New SAS Table Window

5 In the Name field, type **MONTH** as the name of the first new column.

6 In the Type field, type a $ or a C to indicate that the column is a character column.

A column can be character or numeric. If a column is defined as character, then it can contain letters, numbers, special characters, and symbols, but it cannot be used in arithmetic calculations. A character column is indicated by a $ or a C in the Type field.

If a column is defined as numeric, then it can contain only numbers, decimal points, plus signs, and minus signs, and it can be used in arithmetic calculations. A numeric column is indicated by a blank or an N in the Type field.

7 For the length, type 3. Each character uses one byte. The length indicates the number of bytes used to store each of a column’s values in a SAS table. A character column can have a length from 1 to 32767.

8 For the label, type **Sales Month**. The label is a description of up to 40 characters that can be printed by certain tasks instead of, or in addition to, the column name.

9 In the second row of the Name field, type **GSALES** as the name of the second new column.

10 Leave the Type field blank to indicate that the column is numeric.

11 For the length, type 8. A numeric column can have a length of 2 to 8 bytes or 3 to 8 bytes, depending on your operating environment. If you leave this field blank, then it will use a length of 8 by default.

12 For the label, type **Gross Sales**.

13 In the Format field, type **dollar8.2** and press ENTER. A format is a pattern that SAS uses to determine how a column value should be displayed. SAS provides a
set of standard formats and also enables you to define your own custom formats. The dollar8.2 format inserts a dollar sign before each entry, inserts commas for numbers greater than 999, and writes a decimal point and two decimal digits.

14 Select **File ➤ Close**

A prompt appears to ask you if you want to save changes to the WORK.SALES table. Select **Yes**. The FSVIEW window opens to let you type new data for the columns you just defined.

**Display 12.4  Typing Data into WORK.SALES**

```

  JAN  3051.20  
  FEB  2813.50  
  MAR  3214.80  
  APR  3471.00  
  MAY  3943.70  
```

Each row in the window represents information for each sale. Each column represents a particular type of data for the sales. When you type data in a tabular format, multiple rows are shown in one window.

15 Type data in each field, and press TAB to move from field to field if necessary. For example, type **JAN** for the month and **3051.20** for the first GSALES entry.

When you have typed one row of data, press ENTER and another NEW row appears. The format you just specified also adds the dollar sign and comma to the amount of sales when the data appears. Type the rest of the data as shown here:

```
  FEB  2813.50  
  MAR  3214.80  
  APR  3471.00  
  MAY  3943.70  
```

Use the scroll bars or the BACKWARD, FORWARD, LEFT, and RIGHT function keys to see all the columns and rows.

**Note:** If you make an error while typing the data, then position the cursor on the row you want to edit and press ENTER. The row of data is highlighted to indicate that it is selected. To edit the data, press TAB to move the cursor to the data you want to change, and type the new data over the old data. To edit another row, repeat these steps. △
Refer to Chapter 7, “Editing and Browsing Data,” on page 75 for more information about editing data.

16 When you have finished entering rows, select

File ➤ Close

to exit the FSVIEW window.

Refer to Chapter 7, “Editing and Browsing Data,” on page 75 for instructions on editing and browsing the data you just entered.

---

**Entering Data One Row at a Time**

Select

Tasks ➤ Data Management ➤ Create data ➤ Interactively

Follow steps 1 through 14 in “Entering Data in a Tabular Format” on page 126 except, in step 1, select **Enter data one record at a time** from the Enter Data Interactively window. In step 2, name the table **SALES2**.

After you have defined your columns, select **Close** from the **File** menu, and then select **Yes** to save the changes to the table. The FSEDIT window appears for the first row with the word New at the top of the window.

**Display 12.5** Entering Data into WORK.SALES2

1 Type the following data in each field, and press TAB to move from field to field if necessary:

```
JAN  4339.20
```

When you have typed in one row of data, press ENTER, and the dollar sign and comma are added to the amount of sales.

2 To add the next new row, follow this selection path:

Edit ➤ Add New Record
A blank row appears with the word New in the upper right corner of the window. Continue to add new rows to add the following data:

<table>
<thead>
<tr>
<th>Month</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>FEB</td>
<td>3482.50</td>
</tr>
<tr>
<td>MAR</td>
<td>4238.80</td>
</tr>
<tr>
<td>APR</td>
<td>3529.00</td>
</tr>
<tr>
<td>MAY</td>
<td>3433.70</td>
</tr>
</tbody>
</table>

To view other rows you have already added, select **View** from the menu bar and use the items as described here:

- Select **Next Observation** to move forward to the next row.
- Select **Previous Observation** to move backward to the previous row.
- Select **Observation Number** to move to a specific row. The Observation Number window appears. Type the number of the row you want to display and select **OK**. The row you requested appears.
- If there are more columns that will fit on one screen, then each row has as many screens as necessary to display all of the columns for the row. Use **Next Screen** and **Previous Screen** from the View menu to move from screen to screen within a row.

3 When you have finished entering data, select **File** ➤ **Close** to exit the FSEDIT window.

Refer to Chapter 7, “Editing and Browsing Data,” on page 75 for instructions on viewing and editing the data you just entered.
Overview of Importing and Exporting Data

In this chapter you learn how to create an external text file from a SAS table. You also learn how to take data that exists outside of SAS and bring it into the SAS to be processed.

An external file contains data that resides in a file outside the SAS system. In this task, an external file is also called a flat file.

There are two ways to export to and import from external files:

- Use the Import and Export Wizards provided by SAS
- Use the import and export capabilities provided by SAS/ASSIST software.

The Import and Export Wizards are generally easier to use, but are not available in mainframe operating environments. If you are using a desktop operating environment, then it is recommended that you use them. From any SAS window (including SAS/ASSIST task windows and the WorkPlace menu), select

![File ➤ Import Data](image)

or

![File ➤ Export Data](image)

Both wizards have extensive online help available.

If you are using a mainframe operating environment, or are interested in SAS/ASSIST software's import and export capabilities, continue with this chapter.

Exporting a File

This section shows you how to export a file using SAS/ASSIST software's export feature.
Instructions

1. To export data to an external file, follow this selection path:
   Tasks ▶ Data management ▶ Export data

   The Export data to flat file window appears.

   Display 13.1 Export Data to Flat File Window

2. If the active table is SASUSER.HOUSES, then continue to the next step.
   Otherwise, select [Table], and then select the SASUSER.HOUSES table. For more
   information on selecting tables, see “Selecting a Table” on page 24.

3. If other task selections exist (for example, a filename is listed for [Export to file]),
   then select
   File ▶ New

   to clear these selections.

4. In the Export to file field, type the complete physical pathname of the external
   file named [HOUSDATA], into which you will export the SAS table. This file is created
   for you during the export process. Use the following table as a guide to naming the
   file. Note that USERID represents your userid.

   Table 13.1 Examples of Operating Environment-Specific Physical Pathnames

<table>
<thead>
<tr>
<th>Operating environment</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>z/OS</td>
<td>USERID.HOUSDATA.EXPORT</td>
</tr>
<tr>
<td>OpenVMS Alpha</td>
<td>DEVICE:[EXPORT] HOUSDATA</td>
</tr>
</tbody>
</table>
Operating environment | Example
---|---
UNIX | /u/userid/export/housdata
Windows | C:\export\housdata

5 You can export the data in fixed columns or with a separator that you specify. For this example, select **Fixed columns**.

6 Select **Run** then **Submit**.

A window appears with a message that your file was successfully created, and with a prompt to browse the file.

**Display 13.2** File Successfully Created Message

7 Select **Yes** to browse the exported file in the FSLIST window, as shown in the following display.
Exiting This Task

When you are ready to return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.

Importing Data from a Flat File

Importing data enables you to read data from an existing external file and create a SAS table from it. In this section, you import the file that was created in the previous section. Note that when you import a file using SAS/ASSIST software, the file must be in fixed column format.

Instructions

1. To import data from an external file, select

   **Tasks ➤ Data Management ➤ Import Data**

   The Import Data from Flat File window appears.
2 Select [Data file to import]. The Select External File Name window appears.

3 In the External file name field, type the name of the external file that you created in “Exporting a File” on page 131. Use the operating environment guidelines shown in Table 13.1 on page 132 (where USERID represents your userid). For this example, use the external file HOUSDATA.

4 Select Filename to indicate that you typed the physical file name of the file.

5 Select [OK]. The Import Data from Flat File window reappears.

6 Select [Output table]. The Specify Output Table window appears.
7 Type the name of the SAS table that you want to create using the data from the external file. For this example, type **EXTHOUSE**. Refer to “SAS Tables” on page 117 for information about table naming.

You can store the data temporarily or permanently. For this example, store the data temporarily.

- If you want to store the data only for the length of the SAS session, then select **Temporary**. The data are stored in a temporary table called WORK.EXTHOUSE, which is deleted when you end the SAS session.
- If you want to store the data permanently, then select **Permanent**. A list of existing SAS librefs appears.

Select the libref for the location where you want to store the data, for example, the SASUSER libref. Once the import is complete, the table EXTHOUSE is stored in the SASUSER libref and remains there until you delete it.

8 Select **OK**. The Import Data from Flat File window reappears.

9 Select **OK**. The Define Fields window appears.
The first line of the external file appears below the rule line. Notice that there is no space between the number of bathrooms (1) and the address (Sheppard Avenue). In fact, there are no spaces between any of the columns because you saved this file with fixed column widths rather than with delimiters between data values. Because numeric columns are right-justified, while character columns are left-justified, the data values in the bathrooms column appear to be directly adjacent to the data values in the address column. Be careful not to mark them as one data value.

10 In the Define Fields window, use angle brackets (< and >) to mark the width of each field as shown in the following display. If a field has a length of only 1, then use the vertical bar (|) to mark it.

Make sure that you allow for the greatest width possible for each field value so that you do not inadvertently truncate some of your data.
11 Select [OK]. The Import window appears.

12 Type the following information for each column at the bottom of the window. Press TAB to move among the fields. To move to the next or previous column at the bottom of the window, use the scroll bar in the lower right corner of the window.

- Type a name for each column. For this example, type Style for the name of the first column. Type over the existing name (V1). See “SAS Tables” on page 117 for information on column naming.
- You can change the column type, if needed. A column may be either numeric or character. Move the cursor to the type you want and press ENTER to select it. For this example, leave the type as CHAR.
- You can type a format in the Format field, if needed. A format determines how the values appear when they are displayed by SAS software. For a list of...
Importing and Exporting External Data

For this example, leave the format blank.

- You can type an informat in the Informat field, if needed. An informat determines how the values are read from the external file into the SAS table. For a list of informats, type a ? in the Informat field and press ENTER. Move the cursor to the informat you want and press ENTER to select it. For this example, leave the informat blank.

  See SAS Language Reference: Concepts for more information on formats and informats.

- Type a label for each column. For this example, type Style of House. SAS software displays the column label you assign instead of the column name. A label can contain from 1 to 40 characters.

- Type the information for the remaining five columns as shown in the following table. Use the scroll bar in the lower right corner of the window to access the next column.

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Format</th>
<th>Informat</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQFEET</td>
<td>NUM</td>
<td></td>
<td></td>
<td>Square Feet</td>
</tr>
<tr>
<td>BEDROOMS</td>
<td>NUM</td>
<td></td>
<td></td>
<td>Number of Bedrooms</td>
</tr>
<tr>
<td>BATHS</td>
<td>NUM</td>
<td></td>
<td></td>
<td>Number of Bathrooms</td>
</tr>
<tr>
<td>ADDRESS</td>
<td>CHAR</td>
<td></td>
<td></td>
<td>Street Address</td>
</tr>
</tbody>
</table>

13 After you finish typing the information for all the columns, select Data ➤ Create Data Set

(“Data set” is another term for “table.”) The Create Data Set window appears with a prompt that asks whether you want to be prompted to enter new values for bad values or whether you want a report sent to the log. For this example, select VERIFY so that you will be prompted to correct any errors in the data as they are imported.

14 Select OK. A message appears at the bottom of the window with the statistics of the number of records processed.
15 Press ENTER to clear the statistics. The Import window reappears. A note appears in the message area stating the number of observations (rows) and variables (columns) in the table.

You can Edit created data set or Browse created data set from the Data menu on the menu bar.

16 When you finish browsing or editing your table, select

File ➤ Close

to close the FSBROWSE or FSEDIT window. Then, from the Import window, select

File ➤ Close

to return to the WorkPlace menu.
Overview of Data Analysis

In this chapter you learn how to calculate statistics on your data. With data analysis, you can

- produce frequency tables or compute summary statistics, correlations, or confidence intervals about the mean
- calculate linear regression, logistic regression, or regression with correction for autocorrelation
- calculate analysis of variance, nonparametric ANOVA, or $t$-tests
- produce control charts and perform capability analysis
- compute principal components or canonical correlations and calculate seasonal adjustment of time series
- compute percentiles, standardize or rank data, create time-series data, and convert frequency of time-series data.

This chapter describes only the Summary statistics item of the Elementary task from the Data Analysis menu. The other tasks are similar.

The example in this chapter produces a report, as shown in the following display, that shows some summary statistics for the price and square footage of houses for sale.
Display 14.1  Summary Statistics Report

![Summary Statistics Report]

Additional Information
For additional information about analyzing data, refer to SAS/STAT User's Guide.

Analyzing Data

Instructions

1. Select

   Tasks ➤ Data Analysis ➤ Elementary ➤ Summary Statistics

   The Summary Statistics window appears.
If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

If there is an active Subset Data selection (indicated with BY, WHERE, or ROWS next to Subset Data), then clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.

If other report selections exist (for example, column names are listed for Columns), then select File New to clear these selections.

Select Columns, and then select the SQFEET column for analysis. For more information, see “Selecting a Column” on page 27.

Select the desired statistics from the Summary Statistics window. For this example, select Minimum, Maximum, Range, and Mean.

You can customize the report by adding titles and footnotes, changing the page dimensions, and selecting headings. Refer to “Adding Titles” on page 38 for instructions on adding titles to the report.

Add the title Summary Statistics of Price and Square Footage as Title 1 to this report.

Because the same set of titles and footnotes is used for all SAS/ASSIST tasks, the titles and footnotes most recently used in your SAS/ASSIST session are used unless you change or reset them in the Titles and Footnotes windows.

To run the report, follow this selection path:

Run Submit

The report appears in the Output window.
Display 14.3  Summary Statistics Report

The report shows the minimum, maximum, range, and mean for the price and square footage for the houses in the HOUSES table.

9  If the report is larger than one window, use the scroll bars or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to look at the report.

10 To print the report, refer to “Printing the Report” on page 40.

11 After you have finished looking at or printing the report, return to the Summary Statistics window by using one of the following methods, depending on your operating environment:
   □ Use the PREVWIND function key.
   □ Click on the SAS/ASSIST window.

   To return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.
Overview of the Report Engine

In the “Report Writing” chapter in this document, you learned to produce listing, tabular, and counts reports. In this chapter you learn how to use the SAS/ASSIST Report Engine, which is a more advanced, more powerful tool for producing reports. Using the Report Engine, you can create lists; tables; graphics, including bar charts, pie charts, and plots; and dynamic reports with drill-down features. You can easily change from one report style to another using the Report Engine.

Additional Information

For more information on producing reports, refer to Chapter 3, “Report Writing,” on page 31 in this document; Chapter 4, “Graphics,” on page 49 in this document; and the PROC REPORT chapter in Base SAS Procedures Guide.

Creating and Modifying a Simple List Report

The Report Engine enables you to generate reports quickly and gives you several ways to modify and customize different aspects of your report. This section shows you how to create a simple listing report and use the Report Engine’s customizing tools to make some modifications to the report.
Creating the Report

1. Follow this selection path:


   The Report Engine window appears.

2. Display 15.1 Report Engine Window

3. If you have previously run a Report Engine report, then the selections for that report appear automatically in the Report Engine window. If report selections exist in the Report Engine window, then select

   File ➤ New

   to clear all selections from the window.

4. Ensure that the value in the Type field is SAS. If it is not, type SAS over the value in the Type field. Note that the Type field must be filled in before you select a table.

5. Use one of the following methods to select the SASUSER.HOUSES table:

   □ Type SASUSER.HOUSES in the Data field and press ENTER.
   □ Type a question mark (?) in the Data field, and then select the SASUSER.HOUSES table from the Select Table window. For more information on the Select Table window, see “Selecting a Table” on page 24.

   When the SASUSER.HOUSES table is loaded into the Report Engine window, SASUSER.HOUSES appears in the Data field. The table’s columns are listed in the window.
Using the Report Engine  △  Creating the Report  147

Display 15.2  Report Engine Window with HOUSES Table

5 Type **LIST** in the Report field in the Report Engine window, if it does not already appear there.

6 Select

![Submit button]

[Run ![Submit button]]

to generate the report. The report appears in the Report Output window.

Display 15.3  Report Output Window

If the report is wider or longer than one display, then use the scroll bars, the **View** menu, or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to look at the report.
Modifying the Report

The Report Engine offers you a number of ways to modify and customize your report. This section shows you some of them.

1. You can delete columns from the report output. For this example, position the cursor in the Cmd field of the Number of bathrooms row, type D, and press ENTER. The Number of bathrooms row disappears from the Report Engine window, and the column will not appear in the report. The column does remain, however, in the HOUSES table.

2. You can modify the column headers. Position the cursor in the Column Header field of the Number of bedrooms row. Type Bedrooms over the existing column header text. You may need to delete or type blanks over the remaining column header text. Press ENTER; the column header will be renamed Bedrooms in the report.

3. You can rearrange the order in which the columns appear in the report. The values of the No (for Number) field determine where the columns appear, with 1 representing the left edge. Position the cursor in the No field of the Street address row. Type a 5, and then move the cursor to the No field of the Asking price row. Type a 4 and press ENTER. The Asking Price column will appear to the left of the Street Address column in the report.

Note: If you want to undo your modifications, select Edit ► Reset Columns

This action restores the original columns, including their ordering and column headers, and it also restores any deleted columns.

Adding Titles to a Report Engine Report

Adding titles to a Report Engine report is slightly different from adding titles in the other SAS/ASSIST report-generating functions. Unlike the titles specified in other report-writing tasks, the titles you specify in the Report Engine are used in Report Engine reports only and do not carry over into other report writing tasks. Similarly, titles that are defined in other report writing tasks are not used in Report Engine reports.

1. To add titles to your Report Engine report, follow this selection path from the Report Engine window:

Edit ► Titles

The TITLES window appears.
Using the Report Engine  △ Adding Titles to a Report Engine Report  149

Display 15.4  Report Engine Titles Window

2 Each numbered line in the Titles window represents a title line. A Report Engine report can have up to 10 title lines. For this example, type Houses for Sale in the Value field for title number 1, and then type By Style in the Value field for title number 2.

3 Return to the Report Engine window by selecting

   File ▶ Close

   A prompt appears, asking if you want to save your changes. Select Yes.

4 Titles appear flush left by default in Report Engine reports. To center the titles, select

   Edit ▶ Page Layout

   The Page Layout window appears.

Display 15.5  Page Layout Window
5 In the Center field, type **YES** and press ENTER.
6 Select **OK**. The Page Layout window disappears.

---

**Running the Modified Report**

1 Run the report with your titles by selecting

```
Run ➤ Submit
```

Your report appears in the Report Output window, with the modifications and titles.

**Display 15.6 Modified Report Output**

```
Houses for Sale
By Style

<table>
<thead>
<tr>
<th>Style of homes</th>
<th>Square footage</th>
<th>Bedrooms</th>
<th>Asking price</th>
<th>Street address</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONDO</td>
<td>1400</td>
<td>2</td>
<td>$80,050</td>
<td>Market Street</td>
</tr>
<tr>
<td></td>
<td>1390</td>
<td>3</td>
<td>$79,350</td>
<td>Hampshire Avenue</td>
</tr>
<tr>
<td></td>
<td>2105</td>
<td>4</td>
<td>$127,130</td>
<td>Jeans Avenue</td>
</tr>
<tr>
<td>RANGE</td>
<td>1860</td>
<td>2</td>
<td>$110,700</td>
<td>Arcata Avenue</td>
</tr>
<tr>
<td></td>
<td>1300</td>
<td>3</td>
<td>$64,000</td>
<td>Sheppard Avenue</td>
</tr>
<tr>
<td></td>
<td>1535</td>
<td>3</td>
<td>$86,650</td>
<td>Kembie Avenue</td>
</tr>
<tr>
<td>SPLIT</td>
<td>1615</td>
<td>4</td>
<td>$94,430</td>
<td>West Drive</td>
</tr>
<tr>
<td></td>
<td>1305</td>
<td>3</td>
<td>$73,650</td>
<td>Graham Avenue</td>
</tr>
<tr>
<td>TWO STORY</td>
<td>1810</td>
<td>4</td>
<td>$107,250</td>
<td>Garris Street</td>
</tr>
<tr>
<td></td>
<td>1040</td>
<td>2</td>
<td>$55,850</td>
<td>Sanders Road</td>
</tr>
</tbody>
</table>
```

2 To return to the Report Engine window, select

```
File ➤ Close
```

---

**Saving a Report to a SAS Catalog**

To save a report for future use, follow these steps:

1 From the Report Engine window, select

```
File ➤ Save As
```

The Save As window appears.
Type a name for the report in the Name field. The name must be no longer than eight characters. For this example, type the name LSTHOUSE.

3 You can type a description of the report in the Description field. The description must be no longer than 32 characters. For this example, type Houses for Sale (Report Engine).

4 Select OK to save the report. If the report name exists, then you are prompted to select OK again to write over the existing report, or you can type a new name for the report.

5 The Report Engine window reappears. If you modify the report further and want to save it again, then follow this selection path from the Report Engine window:

   File ▶ Save

   Note: For a list of existing reports, type a question mark (?) in the Name field of the Save As window. You can type S (for Select) in the Cmd field to select a report from the resulting selection list. For a list of available catalogs, type a ? in the Catalog field. Select the catalog from the resulting selection list. △

Creating a Dynamic Report

Dynamic reports enable you to set up a report and then drill down to view more details of the report.

Creating the AIRLINE Sample Tables

To appreciate the power of the dynamic report, you should use large and complex tables. This section shows you how to create the AIRLINE sample tables, a set of tables for a fictitious airline company called International Airways. The AIRLINE sample tables are more complex than the SAS/ASSIST sample tables. There are tables with
employee information as well as tables with information about flights, delays, boarding numbers, and so on. To create the AIRLINE tables, follow these steps:

1. If you are using the z/OS operating environment, continue to step 2. Otherwise, create a library, directory, or folder, depending on your operating environment, where you want the AIRLINE sample tables to reside. You may name this library or directory anything you want, but these examples use the name sampatab. See the SAS companion for your operating environment, or contact the SAS Support Consultant at your site if you do not know how to perform this step.

   Note: The name sampatab that is used in these examples is the physical file or directory name. Do not confuse this name with the libname, which you will specify in a later step.

2. Go to the Editor or Program Editor window by using the PREVWIND function key or by clicking on the window, depending on your operating environment. Then select

   File Open object

   The Select an Entry or Open window appears with a list of available libraries in the left pane.

3. Select the symbol next to the Sashelp library. The contents of the Sashelp library appear in the left pane.

4. Scroll down in the left pane until you see the Qassist catalog. Select the Qassist catalog. A list of entries in the Qassist catalog appears in the right pane.

5. Scroll down in the right pane until you see the Samplsas source entry. Select the Samplsas source entry.

6. Select OK. The Samplsas program appears in the Editor or Program Editor window.

7. Scroll down in the window (or use the DOWN function key) until you find the “Supply parameters” section, as shown in the following display.

   Display 15.8  SAMPLSAS Source Code

8. Find the line that reads

   * libname &library "&sysjobid..sas.assist.sampltab";

   You may need to scroll further down to find this line. This line is the LIBNAME statement that SAS uses to assign a libref to a physical file or directory. For more information on librefs, see “SAS Data Libraries” on page 119.

9. Remove the * by placing the cursor over it and pressing the SPACE BAR or DELETE key.
10 If you are using z/OS, continue to the next step. Otherwise, replace the information between the quotation marks (""') with the name of the library or directory you created in step 1. Use the following table as a guide. Ensure that the name is enclosed in quotation marks and that a semicolon (;) is at the end of the line.

Table 15.1  Examples of LIBNAME Statements

<table>
<thead>
<tr>
<th>Operating Environment</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>z/OS</td>
<td>libname &amp;library &quot;userid.assist.sampltab&quot;;</td>
</tr>
<tr>
<td>OpenVMS Alpha</td>
<td>libname &amp;library &quot;DEVICE:[SAMPLTAB]&quot;;</td>
</tr>
<tr>
<td>UNIX</td>
<td>libname &amp;library &quot;/userid/assist/sampltab&quot;;</td>
</tr>
<tr>
<td>Windows</td>
<td>libname &amp;library &quot;C:\assist\sampltab&quot;;</td>
</tr>
</tbody>
</table>

11 To run the program, select

Run  Submit

After the program finishes, information about the created tables appears in the Output window.

Display 15.9  AIRLINE Sample Table Information

Note: The Airline libref is assigned for the duration of your current SAS session only. The next time you invoke SAS and SAS/ASSIST software, you will need to assign the libref again by following the directions in “Using SAS/ASSIST Software to Assign a New Libref” on page 121. Alternatively, you can specify that the Airline libref be automatically defined, each time you invoke SAS, by assigning the libref in the SAS Explorer window. See the online help for the SAS Explorer window for details.

12 Return to the Report Engine window by using the PREVWIND or NEXT function keys, or by clicking on the SAS/ASSIST window, depending on your operating environment.
Creating the Report

To create a dynamic report, you must add usages to the Usage column. Usages determine what a column represents and change the appearance of a report. For dynamic reports, usages determine the columns on which you can drill down.

1. Type `AIRLINE.MARCH` and then press ENTER in the Report Engine window’s Data field.

2. For each column, enter the usage and column header indicated in the following table. Use the TAB key to move from field to field.

<table>
<thead>
<tr>
<th>Column No.</th>
<th>Usage</th>
<th>Column Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>GROUP</td>
<td>Flight</td>
</tr>
<tr>
<td>2</td>
<td>ACROSS</td>
<td>Date</td>
</tr>
<tr>
<td>3</td>
<td>GROUP</td>
<td>Time</td>
</tr>
<tr>
<td>4</td>
<td>SUM</td>
<td>Mail</td>
</tr>
<tr>
<td>5</td>
<td>SUM</td>
<td>Freight</td>
</tr>
<tr>
<td>6</td>
<td>SUM</td>
<td>Boarded</td>
</tr>
<tr>
<td>7</td>
<td>SUM</td>
<td>Transfer</td>
</tr>
<tr>
<td>8</td>
<td>SUM</td>
<td>Non-pay</td>
</tr>
<tr>
<td>9</td>
<td>SUM</td>
<td>Deplane</td>
</tr>
<tr>
<td>10</td>
<td>GROUP</td>
<td>Capacity</td>
</tr>
</tbody>
</table>

The usages for the columns create a drill-down report that shows the sum of the mail, freight, number of passengers boarded, number of passengers transferred, number of nonpaying passengers, and the number of disembarked passengers. Each of the columns can be shown by flight number, departure time, capacity, and date. The column headers have been shortened so that they fit in the Dynamic Report window buttons.

3. Type `DRILL` in the Report field, and then press ENTER.

4. To run the report, select `Run` or `Submit`.

The Dynamic Report window appears, with eight buttons for columns that are defined with GROUP, ACROSS, BREAK, or PAGE usages.
5 Select [Flight] to obtain a list of all the flights along with the figures for mail, freight, boarded passengers, transferred passengers, nonpaying passengers, and deplaned passengers.

The figures for nonpaying passengers and deplaned passengers do not initially appear. If the report has more columns than can be displayed in the window, then the scroll buttons (the small buttons below the eight analysis buttons) contain arrows to indicate the availability of additional columns. Select the right arrow to see columns to the right. Each time you select a scroll button, one new column appears.
6 Drill down on Flight 202 by selecting 202 in the table, and then selecting Date. The figures for Flight 202 for each date appear.

**Display 15.12**  Information by Date for Flight 202

![Image of SAS: ASSIST window showing data for Flight 202 by date]

7 Drill down on 05MAR94 and select Capacity to display the capacity figures for Flight 202 on March 5, 1994.

**Display 15.13**  Capacity Information for Flight 202 on March 5, 1994

![Image of SAS: ASSIST window showing capacity data for Flight 202 on March 5, 1994]

8 To return to the Report Engine window, select File ▶ Close.
Exiting This Task

When you are ready to return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 29.
In this chapter you learn how to use the Remote Connect feature of SAS/ASSIST software. With Remote Connect, you can
- upload and download data and programs
- run programs on remote computers
- execute a SAS/ASSIST task on remote data using Remote submit from any SAS/ASSIST task window
- run a saved local program using remote data.

This chapter shows you how to establish a connection with a remote SAS session, transfer data to a remote location, execute a SAS/ASSIST task on remote data, and terminate a remote connection. You must have SAS/CONNECT software licensed to complete tasks using Remote Connect.

### Additional Information

For additional information about working with remote SAS sessions, see the SAS/CONNECT User’s Guide.

### Establishing a Remote Connection

You must establish a connection to a remote host before you can do any remote processing with Remote Connect. The example in this section establishes a connection between a SAS session under UNIX and a remote SAS session under z/OS. Throughout this example, you should use information specific to the platforms you are using.
Instructions

1 Use one of the following methods to establish a remote connection:

   - From the WorkPlace menu or any task window, follow this selection path:
     
     Tasks ➤ Remote ➤ Establish connection

   - From the WorkPlace menu or any task window, follow this selection path:
     
     Run ➤ Signon

   The window that appears depends on how many remote configurations are available. A remote configuration is a set of instructions that SAS/CONNECT software uses to connect to a specific remote host.

   - If you do not have any remote configurations saved, then the Create New Configuration window appears, which enables you to create a configuration. See “Setting Up Remote Connect Configurations” on page 177 for instructions on how to set up a remote configuration, or contact your site’s SAS Support Consultant for assistance.

   - If you have one remote configuration saved, then that configuration is invoked and the remote connection that is described in the configuration is established.

   - If you have more than one remote configuration saved, then the Select Description window appears and asks you to select the configuration that you want to use to establish a remote connection. Select the configuration that you want to use, and then select OK; the connection is established.

   This section illustrates a situation where you have one remote configuration saved. In this example, a connection to an z/OS host is established.

2 When the connection is made, the TYPE window appears, which prompts you for your userid.

Display 16.1 TYPE Window for Userid Entry

Type your userid for the remote host and press ENTER.
Note: If your userid is hard coded into the remote configuration that script you are using, then you are not prompted for your userid. △

3 Another TYPE window appears, which prompts you for your password.

**Display 16.2**  TYPE Window for Password Entry

Type your password for your remote host userid and press ENTER.

**Note:** If your password is hard coded into the script that you are using, then you are not prompted for your password. △

4 A window appears, indicating that the signon to the remote host completed successfully.

**Display 16.3**  Successful Signon Message

Select [Goback] to return to the WorkPlace menu or task window.

Use the connection that you just established to complete the rest of the activities in this chapter. This connection remains established until you terminate the connection as described in “Terminating a Connection” on page 167 or until you end the SAS session.
Transferring Data

You can use **Transfer data** on the **Remote Connect** menu to **upload** (transfer from a local to a remote session) or **download** (transfer from a remote to a local session) SAS tables, SAS catalogs, external files, or members of a SAS data library, from one SAS session to another. Additionally, you can download graphics output from a remote session to a local session. To assist you with uploading and downloading data, you can assign librefs and filerefs in the local or remote session, view the contents of a remote table, or view a remote library listing from within the WorkPlace menu’s **Remote Connect** item. Make sure you are connected to the remote session before you transfer the data.

In this section, you transfer the HOUSES table from the local SAS session to a remote table called HOUSES. You also view the contents of the remote HOUSES table and view the contents of the remote SASUSER library.

**Instructions**

1. Select **Tasks** ➤ **Remote** ➤ **Transfer data** ➤ **Upload** ➤ **Upload a SAS Table**

   The Upload SAS Table window appears.

   **Display 16.4**  Upload SAS Table Window

2. Select the remote session from the list that is shown at the bottom of the Upload SAS Table window. For this example, **z/OS Connection** is selected. If you have only one remote session, then you do not need to perform this step.

3. Select [**Table to upload**], and then select the SASUSER.HOUSES table. For information on selecting tables, see “Selecting a Table” on page 24.

4. Select [**Remote table**]. The Specify Remote Table window appears.
5 In the Table field, type **HOUSES** as the name of the remote table. Select **Permanent**. In the field next to **Permanent**, type **SASUSER** as the permanent remote library in which you want to store the new HOUSES table. By creating a permanent table of SASUSER.HOUSES, you can remotely run the program that you create and save in the next section.

6 Select **OK** to return to the Upload SAS Table window.

7 Select **Run**. The HOUSES table is uploaded from the local host to the remote host into a permanent table called SASUSER.HOUSES. A window appears showing the progress of the upload. When the upload is complete, a message appears indicating that the upload completed successfully.

*Note:* If the table being uploaded is small, then the window that shows the progress of the upload appears only briefly on the display.

8 Select **Goback** to return to the WorkPlace Menu.

9 To view the contents of the table that you just uploaded to the remote system, select

```
Tasks ➤ Remote ➤ Transfer data ➤ Utilities ➤ Remote table contents
```

The Remote Table Contents window appears.
In the Table name field, type **SASUSER.HOUSES** as the name of the table whose contents you want to view.

Select the remote session that you want to use from the list in the window. For this example, **z/OS Connection** is selected.

Select **OK**. The contents of the SASUSER.HOUSES table that is on the remote host appear in the Output window.

Use the scroll bars or the UP and DOWN function keys, depending on your operating environment, to display the rest of the contents.

Depending on your operating environment, when you are in the Output window, you may need to continue using the DOWN function key until all of the output is viewed before returning to the SAS/ASSIST window. You do this step to ensure that any procedures that are running in the Output window are completed.
13 To return to the WorkPlace menu, use one of the following methods, according to your operating environment:
   □ Use the PREVWIND function key.
   □ Click on the SAS/ASSIST window.

14 If you want to view the contents of a SAS data library on a remote host, follow this selection path:

   Tasks ➤ Remote ➤ Transfer data ➤ Utilities ➤ Remote library listing

The Remote Library Listing window appears.

**Display 16.8** Remote Library Listing Window

15 In the Libref field, type **SASUSER** as the libref of the remote library that you want to list.

16 Select the remote session that you want to use from the list in the window. For this example, **z/OS Connection** is selected. If you have only one remote session, then you do not need to perform this step.

17 Select **OK**. The contents of the SASUSER library appear in the Output window.
Use the scroll bars or the UP and DOWN function keys, depending on your operating environment, to display the rest of the contents.

Depending on your operating environment, when you are in the Output window, you may need to continue using the DOWN function key until all of the output is viewed before you return to the SAS/ASSIST window. You do this step to ensure that any procedures that are running in the Output window are completed.

To return to the WorkPlace menu, use one of the following methods, according to your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

### Executing a SAS/ASSIST Task Using Remote Data

In this section, you will make task window selections to run a listing report on the table that you uploaded in “Transferring Data” on page 162. You will then run the task using the Remote Submit menu item. For details on creating listing reports, refer to “Producing a Listing Report” on page 32. Make sure you are connected to the remote session before you run the task remotely.

1. Follow this selection path:

   Tasks ▶ Report Writing ▶ Listing

   The List a Table window appears.

2. If the active table is SASUSER.HOUSES, then continue to the next step. Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 24.

3. If there is an active Subset Data selection (indicated with BY, WHERE, or ROWS next to Subset data), clear the selection. For more information, see “Clearing a Subset Data Selection” on page 29.
4 If other report selections exist (for example, **Columns** is not **ALL**), then select **File** ➤ **New** to clear these selections.

5 Select **Run** ➤ **Remote Submit**

A listing of the remote SASUSER.HOUSES table appears in the Output window.

**Display 16.10**  Listing of HOUSES Table

![SAS Output Window](image)

**Note:** This operation works because there is a SASUSER.HOUSES table available for both the local and remote sessions. To run a task on a remote table that is not also available for the local session, you first must use the **Select Remote data** item on the **Run** menu to select the table. △

6 Return to the List a Table window by using one of the following methods, depending on your operating environment:

- Use the PREVWIND function key.
- Click on the SAS/ASSIST window.

---

**Terminating a Connection**

When you have finished processing using the remote SAS session, you can terminate the connection with the remote session. Remote connections remain established until you terminate them or end the SAS session.

In this section, you terminate the remote connection that you established in “Establishing a Remote Connection” on page 159.
Instructions

1 To terminate the connection, follow one of these selection paths:

- Tasks ➤ Remote ➤ Terminate connection
- Run ➤ Signoff

A message appears, indicating that the signoff was completed successfully.

Display 16.11  Successful Signoff Message

Note: The window that appears when you select Terminate connection from the Remote Connect Menu depends on which of the following situations exists:

- If you have only one remote connection established, then this connection is terminated.
- If you have more than one remote connection established, then the Select Description window appears for you to select the connection that you want to terminate.

2 Select Goback to return to the Workplace Menu.
Overview of Frequently Asked Questions

This appendix contains both general and specific questions about SAS/ASSIST software. The more specific questions usually direct you to other documentation for detailed instructions.

Licensing, Hardware, and Software Requirements

How can I find out if I have SAS/ASSIST software licensed at my site?

To determine if you have SAS/ASSIST software at your site, attempt to invoke it using the instructions in “The SAS/ASSIST User Interface” on page 17. If you do not have SAS/ASSIST software licensed, then an error message appears.

To get full functionality of SAS/ASSIST software, what SAS System products do I need to license?

To use SAS/ASSIST software, you need to license base SAS software and SAS/ASSIST software. However, for full functionality of SAS/ASSIST software, you need additional SAS products. See “The SAS/ASSIST WorkPlace Environment” on page 3 to determine what software you need to license to complete various tasks using SAS/ASSIST software.

Why can I not create graphics with SAS/ASSIST software even though I have a GRAPHICS item on my WorkPlace menu?

To create high-resolution graphics with SAS/ASSIST software, you must have SAS/GRAF software licensed and must have a graphics device to display or print the
Can I use SAS/ASSIST software with a nongraphics terminal on a mainframe?

Yes; however, you can create only low-resolution graphics. You cannot create high-resolution graphics with a nongraphics mainframe terminal. In some cases, you may be able to produce graphics in hardcopy form even if your terminal does not support graphics; see the SAS Support Consultant at your site for details.

Does SAS/ASSIST software serve as a front-end to all SAS products? Which products can I not access through SAS/ASSIST software?

No, SAS/ASSIST software does not serve as a front-end to all SAS products. Many of the more highly specialized SAS products, such as SAS/GIS software, SAS/GEO software, SAS/AF software, and SAS/SPECTRAVIEW software, are not accessible via SAS/ASSIST software.

Additionally, software products from SAS that are not part of the SAS System are not accessible via SAS/ASSIST software. Examples of these software products include the SAS/C Compiler and Library Products, the SAS/C Development System for AmigaDOS microcomputer C compilers, JMP software, and SYSTEM 2000 Data Management Software.

What is the relationship between SAS/EIS software and SAS/ASSIST software?

When you license SAS/EIS software, you can access it through the EIS item on the SAS/ASSIST WorkPlace menu. SAS/EIS software can be used to build and access custom applications and enterprise information systems (EISs). SAS/ASSIST software can be used to generate the SAS code, reports, and graphics to be used in your custom applications.

SAS/ASSIST software pull-down menus have many layers. Is there a way that I can bypass the menus and go directly to the item I need?

Yes, there are two ways:

- You can use the Index feature to go directly to the item that you want to use. From the WorkPlace menu, select Index. The Index window appears with a list of SAS/ASSIST tasks and functions.
- You can also create a private menu that contains your frequently used tasks. See “Setting Up and Using a Private Menu” on page 67 for details on private menus.
Can I use SAS/ASSIST software without a mouse?

It depends on your operating environment. In certain operating environments, you can press TAB or BACKTAB or use arrow keys to position the cursor on the desired item. Then, you can press ENTER to select it. Other operating environments require that you have a mouse to use SAS/ASSIST software. See the SAS documentation for your operating environment or the SAS Support Consultant at your site for details.

How do I take advantage of a mouse while using SAS/ASSIST software?

A mouse enables you to point and click to select items in SAS/ASSIST software. This method eliminates the keystrokes necessary to position the cursor on an item and then to select the item. Refer to the SAS documentation for your operating environment for more information about using a mouse.

Where do I find information about accessing, moving around, and exiting SAS/ASSIST software?

Refer to Chapter 2, “Familiarizing Yourself with SAS and SAS/ASSIST Software,” on page 11.

Can I add a SAS/ASSIST button to my ToolBox?

Yes. If you have a ToolBox or tool bar in your operating environment’s version of SAS, then you can add a SAS/ASSIST button to the ToolBox or tool bar. See “Adding a SAS/ASSIST Button to Your Toolbox” on page 178 for details.

Platforms and Operating Environments

Does SAS/ASSIST software look the same in all operating environments?

SAS/ASSIST software works the same in each operating environment. However, there may be differences in the appearance of SAS/ASSIST software among different operating environments. For example, if the operating environment you are using does not support icons, the WorkPlace menu appears with text that describes each item, but no icons are displayed. These differences do not affect the performance of SAS/ASSIST software.

Does SAS/ASSIST software run in all operating environments?

SAS/ASSIST software runs in the following operating environments:

- z/OS
- Microsoft Windows NT, Windows 2000, Windows XP
- Linux on Intel
- Digital UNIX
Tables and Files

Why doesn’t the table that I want to use appear in the Select Table window?

You probably did not assign a libref to the data library that you want to use, or the table was added after you started SAS/ASSIST software. The Select table window displays any tables that are known to SAS at the time that SAS/ASSIST software was started. To update this list, select Tools ▸ Examine Data Sources from any SAS/ASSIST window. If the table is in a library that is not known to SAS, see Chapter 11, “Setting Up SAS Files,” on page 117 for instructions on assigning librefs. Refer to the SAS documentation for your operating environment for specific information about using librefs.

Can I type in the table name next to Table instead of using the Select Table window?

Because SAS/ASSIST software is designed to minimize user errors, selection lists are implemented in place of keyboard entry fields wherever possible. For this reason, the Select Table window is always used to select active tables. However, the Select Table window gives you the option of either typing in the table name or using the selection list. The advantage of having both options is that the selection list lets you know immediately if the table that you want to use is associated with a libref and is available.

How do I know when to use a filename and when to use a libname in SAS/ASSIST software?

Using filenames and libnames in SAS/ASSIST software is the same as using them anywhere else in SAS: you use a filename to refer to an external file and a libname to refer to a SAS data library. Refer to Chapter 11, “Setting Up SAS Files,” on page 117 or the SAS documentation for your operating environment.
Can I create SAS tables using SAS/ASSIST software?
Yes, you can create SAS tables and enter new data in a SAS table using the Create data or Import data items on the Data Management menu. Refer to Chapter 12, “Entering Data Interactively,” on page 125 for further instructions.

Can I enter data into an existing table using SAS/ASSIST software?
Yes, you can use the Edit/Browse item on the Data Management menu to enter data into an existing table. Refer to Chapter 7, “Editing and Browsing Data,” on page 75 for further instructions.

Can I subset my data using SAS/ASSIST software?
Yes, many SAS/ASSIST task windows have a Subset data item to allow you to subset your data. Refer to “Subsetting the Data” on page 34.

Can I sort my data using SAS/ASSIST software?
Yes, you can use the Sort item in the Data Management menu to sort your data. Refer to Chapter 8, “Sorting Data,” on page 93 for instructions on sorting your data.

SAS/ASSIST Tasks

When I use the Results item, how do I return from any of the Results windows?
To exit any Results window, select File ➤ Close.

Can I use a WHERE statement when creating a report using SAS/ASSIST software?
Yes, when you create reports using SAS/ASSIST software, you can select the Subset data item to build a WHERE statement in your report. See “Subsetting the Data” on page 34 for an example.

Where can I find more information about creating reports and graphics using SAS/ASSIST software?
How can I create a hardcopy version of my SAS/ASSIST output?

You can create a hardcopy version of your SAS/ASSIST output by selecting File from the Output window’s menu bar, and then selecting Print. See “Printing the Report” on page 40 for more information. Alternatively, you can save your output and print it using the Result Manager.

What data analysis tasks can I perform with SAS/ASSIST software?

Select the Data Analysis button on the WorkPlace menu to see a list of data analysis items. Refer to Chapter 14, “Analyzing Data,” on page 141 for instructions on generating a summary statistics report for the active table. You must have SAS/STAT software licensed to use some of the items on the Data Analysis menu.

Can I save the code that is created by a task for use in a future session?

Yes, you can use the Save as source item to save the programs that SAS/ASSIST software creates and documents each time you perform a task. You can view, edit, and re-execute the saved programs. See Chapter 10, “Saving Source Code for Editing and Re-execution,” on page 111 for more information.

Can I use SAS/ASSIST software with batch processing?

Yes, you can use Batch submit from the Results item on the WorkPlace menu to submit any SAS/ASSIST generated programs directly to your batch system. This enables you to use SAS/ASSIST software as an interface to SAS to create applications and then batch submit them without needing to know about batch syntax (such as JCL). Batch processing is available only on z/OS.

Can I edit and execute SAS/ASSIST programs that are stored in a SAS/ASSIST catalog using the SAS Program Editor window?

Yes, you can use the COPY command in the Program Editor window to copy a catalog entry of type SOURCE into the Program Editor window. See SAS Language Reference: Concepts for more information on the COPY command.

Can I import external files into SAS/ASSIST software?

Yes, see Chapter 13, “Importing and Exporting External Data,” on page 131 for instructions.
Overview of SAS/ASSIST Software Setup

This appendix contains procedures for setting up various aspects of SAS/ASSIST software. In many cases, these procedures will already have been done for you. If you have questions about them, then contact your site’s SAS Support Consultant.

Setting Up Graphics Devices

The graphics device driver software used in your SAS session is assigned by default, based on the hardware and operating environment on which you installed SAS. You may, however, need to assign a different graphics device driver for your SAS/ASSIST sessions. You can use the following procedure to assign a different graphics device driver. The change you make with this procedure will be in effect for all graphics tasks in all SAS/ASSIST sessions until you change it again. Before using this procedure, ensure that you have SAS/GRAPH software licensed and installed.

Note: You do not need to select a graphics device driver with low-resolution graphics.

1. From the WorkPlace menu or any task window, follow this selection path:
   - Tasks ➤ Setup ➤ Environment ➤ Graphics options
   - Active graphics device

   The Active Graphics Device window appears.
Display A2.1  Active Graphics Device Window

This window lets you select which monitor and hardcopy device you want to use.

2 Select **Monitor** if it is not already selected.

3 Select **Display device**. A list of display devices appears.

Display A2.2  Graphics Devices List Window

4 Select the correct display device for your terminal. Use the scroll bars or the FORWARD and BACKWARD function keys to find your device. When you select a display device, the Active Graphics Device window reappears.

If you are not sure which display device to select, then contact the SAS Support Consultant at your site.

5 Select **OK**.

*Note:* **Hardcopy** is selected in the same manner as **Monitor** and is used when you want to send your graph to a hardcopy device such as a printer, plotter, or camera, or to a file with a graphics format such as GIF, JPEG, or PostScript.

6 When you are ready to return to the WorkPlace menu or go on to another task, follow the directions in “Exiting a Task” on page 29.
Setting Up Remote Connect Configurations

You use this procedure to set up a configuration to connect with a remote computer. Before using this procedure, ensure that you have SAS/CONNECT software licensed and installed. For more information on remote connections, refer to SAS/CONNECT User’s Guide.

1. Follow this selection path:

   **Tasks** ▶ **Remote** ▶ **Edit remote connection**

   The Edit Remote Configuration window appears.

   ![Display A2.3 Edit Remote Configuration Window]

2. Select **Add**. The Create New Configuration window appears.

   ![Display A2.4 Create New Configuration Window]

3. In the Description field, type a description of the connection that this configuration establishes, for example, *z/OS Connection*. 
4 In the Remote field, type the name or Internet Protocol (IP) address of the remote host to which you want to connect.

5 In the Script field, type the full pathname and location of the script that this configuration uses.

   The script file contains statements that connect you to the remote host. To display a list of available scripts, type ? in the first position of the Script field, and then press ENTER. If a list of scripts does not appear, or you do not know which script to use, then contact your site’s SAS Support Consultant for assistance.

6 Select Comamid. The Method ID window appears.

   ![Method ID Window](image)

7 Select the communications access method that you want to use to establish the link between your local and remote session. If you do not know which access method to use, then contact your site’s SAS Support Consultant.

8 If desired, select Assign libref to assign a libref for a SAS data library on the remote system. The Assign Libref on Remote Host window appears, enabling you to specify the libname, physical path, and options. Select File ➤ OK when finished.

9 Select OK to return to the Create New Configuration window.

10 Select OK to return to the Edit Remote Configuration window.

11 Repeat this procedure if you want to make other remote configurations; otherwise, select Goback to return.

---

**Adding a SAS/ASSIST Button to Your Toolbox**

If your SAS windowing environment includes a ToolBox or tool bar, then you can add a SAS/ASSIST software icon to it. The ToolBox or tool bar varies depending on which window is currently active. The SAS Explorer and Results windows share the same set of ToolBox/toolbar definitions; the Output, Log, and Program Editor windows share a
different set of ToolBox/toolbar definitions. Click on the various windows to see how the ToolBox or toolbar changes.

To add a SAS/ASSIST software icon to both sets of ToolBox/toolbar definitions, you must perform the procedure twice: once starting from the SAS Explorer, SAS Environment, or Results window, and once starting from the Output, Log, or Program Editor window.

The procedure for adding an icon to your ToolBox or toolbar varies by operating environment. See the SAS companion for your operating environment for the specific procedure you should use. You can use any of the icons that are supplied by SAS, but the icon that is normally associated with SAS/ASSIST software looks like this:
Recommended Reading

Here is the recommended reading list for this title:

- *Doing More with SAS/ASSIST*
- *SAS/ASSIST Administrator's Guide*
- *The Little SAS Book: A Primer*
- *SAS Language Reference: Dictionary*
- *SAS Language Reference: Concepts*
- *Base SAS Procedures Guide*
- *SAS/CONNECT User's Guide*
- *SAS/GRAPH Software: Reference, Volumes 1 and 2*
- *SAS/STAT User's Guide, Volumes 1, 2, and 3*
- *The SAS Companion for your operating system.*

For a complete list of SAS publications, go to [support.sas.com/bookstore](http://support.sas.com/bookstore). If you have questions about which titles you need, please contact a SAS Publishing Sales Representative at:

SAS Publishing Sales
SAS Campus Drive
Cary, NC 27513
Telephone: 1–800–727–3228
Fax: 1–919–531–9439
E-mail: sasbook@sas.com
Web address: [support.sas.com/bookstore](http://support.sas.com/bookstore)

Customers outside the United States and Canada, please contact your local SAS office for assistance.
Glossary

active table
in SAS/ASSIST software, a SAS table that has been specified for a particular task.

analysis variable
a numeric variable that is used to calculate statistics. An analysis variable usually contains quantitative or continuous values, but this is not required.

arithmetic operator
in SAS software, any of the symbols (+, -, /, *, and **) that are used to perform addition, subtraction, division, multiplication, and exponentiation in SAS expressions.

base SAS software
software that includes a programming language that manages your data, procedures for data analysis and reporting, procedures for managing SAS files, a macro facility, help menus, and a windowing environment for text editing and file management.

batch mode
a method of executing SAS programs in which a file that contains SAS statements plus any necessary operating environment commands is submitted to the computer’s batch queue. After you submit the program, control returns to your terminal or workstation, where you can perform other tasks. Batch mode is sometimes referred to as running in the background. The program output can be written to files or printed on an output device.

button
a component of a graphical user interface. A button is usually in the form of a rectangle or square that contains a label. The button is programmed to execute a command, to open a window, or to perform some other function when a user selects it. For example, many graphical user interfaces include buttons that have labels such as OK, Cancel, and Help.

BY variable
a variable named in a BY statement whose values define groups of observations to process.

character variable
a variable whose values can consist of alphabetic and special characters as well as numeric characters.
chart variable
the variable whose values you are charting.

check box
an item in a window that you can select without affecting any other items. You can deactivate a check box by selecting it again.

class variable
a variable that is used to group, or classify, data. Class variables can be either character or numeric. Class variables can have continuous values, but they typically have a few discrete values that define the classifications of the variable.

column
in relational databases, a vertical component of a table. Each column has a unique name, contains data of a specific type, and has certain attributes. A column is analogous to a variable in SAS terminology.

crosstabulation table
a frequency table that shows combined frequency distributions or other descriptive statistics for two or more variables. These tables are also referred to as two-, three-, or n-way tables; contingency tables; and stub-and-banner tables. See also frequency table.

cumulative frequency
the total number of observations in all ranges up to and including a given range.

cumulative percent
the percentage of observations in all ranges up to and including a given range.

DATA step
a group of statements in a SAS program that begins with a DATA statement and ends with either a RUN statement, another DATA statement, a PROC statement, or the end of the job. The DATA step enables you to read raw data or other SAS data sets and to create SAS data sets.

data value
a unit of character or numeric information in a SAS data set. A data value represents one variable in an observation.

dependent column
See response variable.

dialog box
a type of window that opens to prompt you for additional information or to ask you to confirm a request.

engine
a component of SAS software that reads from or writes to a file. Each engine enables SAS to access files that are in a particular format.

explanatory variable
a variable that is included in a regression model in order to explain the variation in the dependent (or response) variable. Explanatory variables, which are also called independent, input, predictor, or regressor variables, can be deterministic or probabilistic.

external file
a file that is created and maintained by a host operating system or by another vendor's software application. SAS can read data from and route output to external files. External files can contain raw data, SAS programming statements, procedure output, or output that was created by the PUT statement. An external file is not a SAS data set. See also fileref.
fileref
a name that is temporarily assigned to an external file or to an aggregate storage location such as a directory or folder. The fileref identifies the file or the storage location to SAS. In SAS/ASSIST software, you assign a fileref with the Setup task.

format
a pattern or set of instructions that SAS uses to determine how the values of a variable (or column) should be written or displayed. SAS provides a set of standard formats and also enables you to define your own formats.

frequency chart
a graphic illustration of the number of times a value or range of values for a given variable occurs.

frequency count
the number of times a value or range of values for a given variable occurs.

frequency table
a table that lists the values of a variable and the number of observations with each value. See also crosstabulation table, frequency count.

function key
a keyboard key that can be defined to have a specific action in a specific software environment.

independent column
See explanatory variable.

index
in SAS software, a component of a SAS data set that enables SAS to access observations in the SAS data set quickly and efficiently. The purpose of SAS indexes is to optimize WHERE-clause processing and to facilitate BY-group processing.

informat
a pattern or set of instructions that SAS uses to determine how data values in an input file should be interpreted. SAS provides a set of standard informats and also enables you to define your own informats.

interactive line mode
a method of running SAS programs in which you enter one line of a SAS program at a time at the SAS session prompt. SAS processes each line immediately after you press the ENTER or RETURN key. Procedure output and informative messages are returned directly to your display device.

label, variable
a descriptive label of up to 40 characters that can be printed in the output by certain procedures instead of, or in addition to, the variable name.

length, variable
the number of bytes used to store each of a variable’s values in a SAS data set.

libref
a name that is temporarily associated with a SAS data library. The complete name of a SAS file consists of two words, separated by a period. The libref, which is the first word, indicates the library. The second word is the name of the specific SAS file. For example, in VLIB.NEWBDAY, the libref VLIB tells SAS which library contains the file NEWBDAY. You assign a libref with a LIBNAME statement or with an operating system command.

local session
a SAS session running on the local host. The local session accepts SAS statements and passes those that are remote-submitted to the remote host for processing. The
local session manages the output and messages from both the local session and the remote session.

**Logical operator**
an operator used in expressions to link sequences of comparisons. The logical operators are AND, OR, and NOT.

**Menu bar**
the primary list of items at the top of a window which represent the actions or classes of actions that can be executed. Selecting an item executes an action, opens a pull-down menu, or opens a dialog box that requests additional information. See also pop-up menu, pull-down menu.

**Message area**
the area immediately beneath a window’s command line or menu bar which displays messages from SAS.

**Metadata**
a description or definition of data or information.

**Midpoint**
a value that represents one data value or the middle of a range of data values. When a midpoint represents a range of values, the algorithm used to calculate it depends on the procedure.

**Missing value**
in SAS, a term that describes the contents of a variable that contains no data for a particular row or observation. By default, SAS prints or displays a missing numeric value as a single period, and it prints or displays a missing character value as a blank space.

**Numeric variable**
a variable that contains only numeric values and related symbols, such as decimal points, plus signs, and minus signs.

**Observation**
a row in a SAS data set. All of the data values in an observation are associated with a single entity such as a customer or a state. Each observation contains one data value for each variable.

**Permanent SAS data set**
a data set that remains after the current program or interactive SAS session terminates. Permanent SAS data sets are available for future SAS sessions.

**Pop-up menu**
a menu that appears when it is requested. These menus are context-specific, depending on which window is active and on the cursor location. See also pull-down menu.

**PROC SQL view**
a SAS data set (of type VIEW) that is created by the SQL procedure. A PROC SQL view contains no data. Instead, it stores information that enables it to read data values from other files, which can include SAS data files, SAS/ACCESS views, DATA step views, or other PROC SQL views. A PROC SQL view’s output can be either a subset or a superset of one or more files. See also view.

**Pull-down menu**
the list of menu items or choices that appears when you choose an item from a menu bar or from another menu. See also pop-up menu.
raw data
data that has not been read into a SAS data set.

remote session
a SAS session running in a special mode on the remote host. No output or log messages are displayed on the remote host; instead, the results of a remote SAS session are transmitted back to the log and output files on the local host.

response variable
in regression analysis, the variable that you are interested in modeling for the purpose of seeing how it changes as a function of the factors. The response variable is also referred to as the dependent variable.

row
in relational database management systems, the horizontal component of a table. It is analogous to a SAS observation.

SAS catalog
a SAS file that stores many different kinds of information in smaller units called catalog entries. A single SAS catalog can contain several different types of catalog entries. See also SAS catalog entry.

SAS catalog entry
a separate storage unit within a SAS catalog. Each entry has an entry type that identifies its purpose to SAS. Some catalog entries contain system information such as key definitions. Other catalog entries contain application information such as window definitions, Help windows, formats, informats, macros, or graphics output.

SAS data file
a SAS data set that contains data values as well as descriptor information that is associated with the data. The descriptor information includes information such as the data types and lengths of the variables, as well as which engine was used to create the data. SAS data files are of member type DATA. See also SAS data set, SAS data view.

SAS data library
a collection of one or more SAS files that are recognized by SAS and which are referenced and stored as a unit. Each file is a member of the library.

SAS data set
a file whose contents are in one of the native SAS file formats. There are two types of SAS data sets: SAS data files and SAS data views. SAS data files contain data values in addition to descriptor information that is associated with the data. SAS data views contain only the descriptor information plus other information that is required for retrieving data values from other SAS data sets or from files whose contents are in other software vendors’ file formats.

SAS data view
a type of SAS data set that retrieves data values from other files. A SAS data view contains only descriptor information such as the data types and lengths of the variables (columns), plus other information that is required for retrieving data values from other SAS data sets or from files that are stored in other software vendors’ file formats. SAS data views are of member type VIEW.

SAS log
a file that contains a record of the SAS statements that you enter as well as messages about the execution of your program.

SAS name
a name whose construction follows certain rules and that can appear in a SAS statement (for example, names of variables and SAS data sets).
SAS procedure
a program that produces reports, manages files, or analyzes data and which is accessed with a PROC statement. Many procedures are included in SAS software.

SAS program
a group of SAS statements that guide SAS through a process or series of processes.

SAS statement
a string of SAS keywords, SAS names, and special characters and operators that instructs SAS to perform an operation or that gives information to SAS. Each SAS statement ends with a semicolon.

SAS Support Consultant
an individual at your computing installation who is designated as a support person for SAS software users at the installation. The consultant can help you with questions about using SAS software.

SAS table
another term for SAS data set. See SAS data set.

SAS windowing environment
an interactive windowing interface to SAS software. In this environment you can issue commands by typing them on the command line, by pressing function keys, or by selecting items from menus or menu bars. Within one session, you can perform many different tasks, including preparing and submitting programs, viewing and printing results, and debugging and resubmitting programs.

Sasuser library
a default, permanent SAS data library that is created at the beginning of your first SAS session. The Sasuser library contains a Profile catalog that stores the customized features or settings that you specify for SAS. You can also store other SAS files in this library.

scroll bar
a graphical window element that is used to bring the undisplayed contents of an associated object (such as a text box or a list box) into view. A scroll bar is shaped like a horizontal or vertical bar and has a scroll arrow at each end. If the associated object contains text that is not in view, the scroll bar contains a box that you can drag in order to move up or down in the viewing area. Alternatively, you can click on the arrows to move up or down in smaller increments.

selection field
the portion of a window (shown on the display as an underscore) where you can enter a short command to perform an action, such as B for browse.

selection-field command
a command that enables you to perform actions from a selection field in a SAS windowing environment. For example, entering D in the selection field beside the name of a SAS data set in the DIRECTORY window enables you to delete that SAS data set.

SQL (Structured Query Language)
a standardized, high-level query language that is used in relational database management systems to create and manipulate database management system objects. SAS implements SQL through the SQL procedure.

table
in general, a two-dimensional system of representing data in rows and columns.
**temporary SAS data set**
a data set that exists only for the duration of the current program or interactive SAS session. Temporary SAS data sets are not available for future SAS sessions.

**variable**
a column in a SAS data set or in a SAS data view. The data values for each variable describe a single characteristic for all observations.

**view**
a definition of a virtual data set. The definition is named and stored for later use. A view contains no data; it merely describes or defines data that is stored elsewhere. SAS data views can be created by the ACCESS and SQL procedures.

**WHERE expression**
a type of SAS expression that specifies a condition for selecting observations for processing by a DATA step or a PROC step. WHERE expressions can contain special operators that are not available in other SAS expressions. WHERE expressions can appear in a WHERE statement, a WHERE= data set option, a WHERE clause, or a WHERE command.

**WHERE processing**
a method of conditionally selecting observations for processing in a DATA or PROC step. WHERE processing involves using a WHERE expression in a WHERE statement, a WHERE= data set option, a WHERE clause, or a WHERE command. See also WHERE expression.

**Work data library**
a SAS data library that is automatically defined by SAS at the beginning of each SAS session or SAS job. The Work library contains SAS files that are temporary by default. When the libref User is not defined, SAS uses Work as the default library for SAS files that are created with one-level names.
Index

### A

- Adding data one row at a time 87
- Tabular format 79
- AIRLINE sample tables, creating 151
- Alphabetizing data 94
- Analyzing data
  - See data analysis
- Angle brackets (< >), cell-width markers 137
- Asterisk (*), pattern-matching character 72
- B, Result Manager command 73
- Bar charts
  - Creating 50
  - Footnotes 52
  - Headings 52
  - Page dimensions 52
  - Printing 53
  - Running 52
  - Titles 52
- Bar Charts window 50
- Bar/Slice Values window 51
- Batch processing 174
- Browsing data
  - Buttons, SAS/ASSIST Software
    - Adding to a Toolbox 178
    - Definition 20
- Case sensitivity 118
- Column names 118
- Table names 118
- Character columns
  - See columns, character column names
    - Naming conventions 118
    - Columns 32
    - De nition 32
    - In SAS tables 20
    - Selecting columns, character allowed content format 104
    - Versus numeric columns, de ning
      - Character versus numeric format 104
      - Column label, specifying 104
      - Column name, specifying formats (SAS) 105
      - Initialization 106
      - Numeric expressions 106
      - Storing the data 103
      - Table name, specifying columns, imported data labels, specifying names, specifying type, changing columns, numeric allowed content comma, inserting decimal point, inserting dollar sign, inserting format length versus character
        - Comma (.), inserting in numeric columns commands
          - Assigning to function keys 13
          - Entering 16
          - Create New Con guration window 177
- Decimal point (.), inserting in numeric columns
  - Deleting SAS tables 122
  - Deleting data
    - By member 82
    - By row 82
    - One row at a time 89
  - Dollar sign ($) column-type indicator
    - Inserting in numeric columns 127
  - Downloading data
    - One row at a time 88
    - Tabular format 80
- E, Result Manager command 73
- Edit Data in Tabular Format window 76
- Edit Data window
  - Editing data, one row at a time 86
  - Editing data, tabular format 76
- Edit menu item
  - SAS/ASSIST WorkPlace 3
  - Edit Remote Con guration window 177
- D, Result Manager command
  - Data access de nition 9
  - Data analysis de nition 9
  - Data analysis, displaying
    - See Frequency reports
    - See Tabular reports
  - Data Analysis button
    - SAS/ASSIST WorkPlace 3
  - Data management de nition 9
  - Data Management button
    - SAS/ASSIST WorkPlace 3
  - Data presentation de nition 9
  - Data sets 119
  - DATA type 119
  - Date and time stamps, removing 21
- E, Result Manager command
  - Edit Data in Tabular Format window 76
  - Edit Data window
    - Editing data, one row at a time 86
    - Editing data, tabular format 76
  - Edit menu item
    - SAS/ASSIST WorkPlace 3
  - Edit Remote Con guration window 177
  - Editing data, tabular format
    - Adding data 87
    - Canceling changes 89
    - Deleting data 89
    - Duplicating data 88
    - Edit Data window
      - Editing a row 87
      - Moving among rows 87
      - Saving changes 91
    - WHERE clauses
      - Editing data, tabular format
        - Adding data 87
        - By member 78
        - By row 78
        - Deleting data
          - By member 82
          - By row 82
          - Duplicating data 80
  - Edit Data window
    - Member-locking mode 76
    - Record-locking mode 77
    - Saving changes 88

Index

setting update mode 77
subsetting data 83
WHERE clauses 85

Enter a Character Constant window 37
Enter Data Interactively window 125

entering data interactively, one row at a time 129
entering data interactively, tabular format 125
character columns, allowed content 127
comma, inserting in numeric columns 127
custom formats (SAS) 127
decimal point, inserting in numeric columns 127
dollar sign, inserting in numeric columns 127
Enter Data Interactively window 125
error correction 128
numeric columns, allowed content 127
numeric columns, length 127
Select a New Table to Create window 126
Enterprise Information System button SAS/ASSIST WorkPlace 5
Exit button SAS/ASSIST WorkPlace 6
Export Data to Flat File window 132
exporting data 131
external files, exporting to 131
external files, importing from

importing data

F
F, Result Manager command 73
FAQs
See frequently asked questions (FAQs)
File menu item
SAS/ASSIST WorkPlace 8
lenames versus libnames 172
les, exporting to 131
les, importing from

See importing data

footnotes
bar charts 52
in saved tasks 66
maps 61
pie charts 55
plots 57
formats 127
creating 127
specifying for imported data 133
frequency reports 45
See also Report Engine
printing 48
running 47
setting up 46
frequently asked questions (FAQs) 160
batch processing 174
buttons, adding to a Toolbox 171
data analysis 174
lenames versus libnames 172
graphics, unable to create hardcopy output 174
importing external files 174
license verification 169
mouse 173
navigating SAS/ASSIST Software nongraphics terminals 170
platforms supporting SAS/ASSIST Software 171
programs, editing/executing from Program Editor 174
pull-down menus, bypassing results windows, exiting from SAS/ASSIST Software as a front end to SAS System 170
SAS/EIS software versus SAS/ASSIST Software 170
SAS System product requirements 169
SAS tables, creating 173
sorting data 173
subsetting data 173
tables, entering data into tables, selecting 173
tables not in Select Table window 172
WHERE statements 173
function keys 15

G

graphics
See also bar charts
See also maps
See also pie charts
See also plots
accessing 49
and terminal resolution 49
on nongraphic terminals unable to create 169
Graphics button SAS/ASSIST WorkPlace 8

graphics devices, setting up 175

H

hardcopy output
headings 174
bar charts 52
maps 61
pie charts 55
plots 57
help 20
Help menu item SAS/ASSIST WorkPlace 8

I

Import Data from Flat File window 134
importing data 131
angle brackets, eld-width markers 137
column labels, specifying 139
column names, specifying 138
column type, changing 136
de ning elds 136
formats (SAS), specifying 138
Import Data from Flat File window 134
informats (SAS), specifying 137
vertical bar, eld-width marker 137
Index button SAS/ASSIST WorkPlace 8
informats, specifying for imported data 139

L

L, Result Manager command 73
libname statements, examples 153
librefs assigning 121
de nition 119
license verification 169
List a Table window 131
list reports 32
See also Report Engine
adding titles 148
creating 146
displaying a list of modifying 148
printing 40
running 45
saving 150
setting up 32
subsetting data for 32
titles 38
Listing Report task 32

M

maps 59
creating footnotes 59
headings 61
page dimensions 61
printing 62
running 61
titles 61
Maps window 59
member-locking mode 77
menu bar items SAS/ASSIST WorkPlace 8
menu bars, SAS System menu buttons SAS/ASSIST WorkPlace 8
menus, SAS System menus, SAS System See Private menu
Method ID window 178

N

naming conventions
column names 118
SAS catalogs 120
table names 118	nongraphics terminals 170
numeric columns
See columns, numeric
O
observations 119
OpenVMS Alpha operating environment, and SAS data libraries 120
P
P, Result Manager command page dimensions 52
bar charts 61
pie charts 55
plots 57
Page Layout window 149
pie charts 54
creating 54
footnotes 55
headings 55
page dimensions 55
printing 56
running 56
titles 55
Planning Tools button
SAS/ASSIST WorkPlace 5
platforms supporting SAS/ASSIST Software 171
plots 57
creating 57
footnotes 57
headings 57
page dimensions 57
printing 58
running 58
titles 57
pop-up menus, SAS System 13
Print window
printing frequency reports 40
list reports 40
tabular reports 45
Private menu
activating definition 69
setting up using 69
programs editing 73
executing 72
pull-down menus, bypassing 170
R
R, Result Manager command record-locking mode 77
remote configurations 160
Remote Connect button
SAS/ASSIST WorkPlace 5
remote connections configuring 173
establishing 159
S
S, Result Manager commands SAS definition 77
SAS/ASSIST software as front end to SAS System definition 29
executing invoking quick start 29
SAS System product requirements 169
versus SAS/EIS software 170
SAS/ASSIST WorkPlace
Data Analysis button 5
Data Management button 5
Edit menu item 5
Enterprise Information System button 5
Exit button 5
File menu item 5
Graphics button 5
Help menu item 5
Index button 5
menu bar items 5
menu buttons 5
Planning Tools button 5
Remote Connect button 5
Report Writing button 5
Results button 5
Run menu item 5
Setup button 5
Tasks menu item 5
Tools menu item 5
View menu item 5
SAS/ASSIST WorkPlace menu
SAS catalogs
definition naming conventions 120
SAS data libraries
SAS data libraries definition 119
librefs, assigning 121
deinition 119
librefs, deinition 119
OpenVMS Alpha operating environment 120
UNIX operating environment 120
viewing on a remote host 165
Windows operating environment 120
z/OS operating environment 120
SAS data views 119
SAS formats See formats
SAS System exiting 29
invoking 12
SAS tables See also tables
columns components of creating data les data sets 119
DATA type 119
data values 118
deinition 117
deleting 123
exporting data from member types 119
numeric columns 118
observations 119
permanent rows 119
table names, syntax 118
temporary 119
uploading to a remote host 162
variables 119
VIEW type 119
SAS tables, importing data into...
See importing data
Save Changes dialog box, disabling 21, 126
Select a New Table to Create window 21
Select Table window 24
Select Tables window 24
selected data, clearing 29
selecting items 13
Setup button
SAS/ASSIST WorkPlace 5
Simple X * Y Plot window 57
Sort a Table window 94
sorting data 94
source code
creating 111
editing 114
re-executing 114
saving 113
viewing 112
Specify Output Table window 95
Specify Remote Table window 162
statistical analysis
See data analysis
Subset Data window 84
Subset or Copy Table window 101
subsetting data
editing data 83, 90
list reports 54
Summary Statistics window 142

T

table columns
See columns

tables 52
See also SAS tables
creating 21
de-selecting 28
definition 52
deleting 23
not in Select Table window 172
selecting tables 24, 172
See entering data interactively, one row at a time
tables, adding data to
See adding data
tables, browsing data 76
tables, deleting data
See deleting data
tables, displaying data from
See list reports
tables, sorting 64
tabular reports 41
See also Report Engine
printing 45
running 44
setting up titles 44
task window selections
clearing 66
saved, choosing 66
saved, listing 66
task window selections, saving 63
task description 65
task naming conventions 65
tasks, exiting 29
tasks, running multiple times
See task window selections, saving tasks, saving
tasks, running multiple times
See task window selections, saving
Tasks menu item
SAS/ASSIST WorkPlace 4
titles
bar charts 52
frequency reports 43
in saved tasks 66
list reports 58
maps 61
pie charts 55
plots 57
tabular reports 44
Titles window 38
Tools menu item
SAS/ASSIST WorkPlace 4
transferring data to and from remote hosts 162

U

underscore (_) 72
in column names 118
in librefs 119
in SAS table names 118
in saved task names 65
pattern-matching character 72
UNIX operating environment, and SAS data libraries 130
Update window 77
Upload SAS Table window 162
uploading data 162
User Profile window 67

V

V, Result Manager command 73
vertical bar, field-width marker 137
View menu item
SAS/ASSIST WorkPlace 6
VIEW type 119

W

WHERE clauses
editing data, one row at a time 90
editing data, tabular format 85
wildcards 72
Windows operating environment, and SAS data libraries 120
WorkPlace
See SAS/ASSIST WorkPlace

X

X, Result Manager command 73

Z

z/OS operating environment, and SAS data libraries 130
Your Turn

We want your feedback.

- If you have comments about this book, please send them to yourturn@sas.com. Include the full title and page numbers (if applicable).
- If you have comments about the software, please send them to suggest@sas.com.
SAS® Publishing gives you the tools to flourish in any environment with SAS!

Whether you are new to the workforce or an experienced professional, you need to distinguish yourself in this rapidly changing and competitive job market. SAS® Publishing provides you with a wide range of resources to help you set yourself apart.

SAS® Press Series
Need to learn the basics? Struggling with a programming problem? You’ll find the expert answers that you need in example-rich books from the SAS Press Series. Written by experienced SAS professionals from around the world, these books deliver real-world insights on a broad range of topics for all skill levels.

support.sas.com/saspress

SAS® Documentation
To successfully implement applications using SAS software, companies in every industry and on every continent all turn to the one source for accurate, timely, and reliable information—SAS documentation. We currently produce the following types of reference documentation: online help that is built into the software, tutorials that are integrated into the product, reference documentation delivered in HTML and PDF—free on the Web, and hard-copy books.

support.sas.com/publishing

SAS® Learning Edition 4.1
Get a workplace advantage, perform analytics in less time, and prepare for the SAS Base Programming exam and SAS Advanced Programming exam with SAS® Learning Edition 4.1. This inexpensive, intuitive personal learning version of SAS includes Base SAS® 9.1.3, SAS/STAT®, SAS/GRAPH®, SAS/QC®, SAS/ETS®, and SAS® Enterprise Guide® 4.1. Whether you are a professor, student, or business professional, this is a great way to learn SAS.

support.sas.com/LE