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Overview

This document extends the concepts presented in Getting Started with SAS/ASSIST,
providing additional details on the features and capabilities of SAS/ASSIST software.
Additionally, features of SAS/ASSIST software not covered in Getting Started with
SAS/ASSIST are introduced in this document.

Readers of this document should be familiar with the concepts presented in Getting
Started with SAS/ASSIST, and should have installed, at minimum, base SAS software,
SAS/ASSIST software, and SAS/FSP software. To perform the graphics tasks, users
should have SAS/GRAPH software installed. To perform tasks that access or create
DB2 files, or files from other database management system (DBMS) vendors, users
should have installed SAS/ACCESS software and the SAS/ACCESS interface to their
desired DBMS.

The illustrations and examples from this document were taken from SAS/ASSIST 9.1
under the Microsoft Windows operating environment. Your screens might look different
from the illustrations in this document.

Typographical Conventions

Following is a description of the typographical conventions used in this document:
italic

Used for new terms.
monospace

Used to indicate items in windows or on menus, or items that the user types into
the system.

Performing the tasks in this document occasionally requires you to make a series of
window and menu selections. Where appropriate, these series are indicated with a
selection path. For example,
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Tasks » Graphics » Maps

In this case, you would select Tasks from the current window, then select Graphics
from the resulting pull-down menu, and then select Maps from the resulting cascading
menu.

In this document the word task refers to anything you can do with SAS/ASSIST that
involves manipulating, reporting, analyzing, and presenting data. SAS/ASSIST tasks
can be saved and recalled. These tasks are distinguished from other things you can do
with SAS/ASSIST software, such as setup actions and utility actions. Thus, creating a
listing report is a SAS/ASSIST task, but generating the graphics test pattern is not. A
task window is a SAS/ASSIST window that is the starting point for performing a task.
Examples of task windows include the List a Table window and the Bar Charts window.

Using SAS/ASSIST Software with This Document

For the examples in this document, we disabled the date and time stamp from all
output, and we disabled the Save Changes dialog box that appears by default when you
exit a task window. We also use the same sample tables that were used in Getting
Started with SAS/ASSIST. For convenience, we have reprinted here the instructions
for disabling the date and time stamp, disabling the Save Changes dialog box, and
creating the SAS/ASSIST sample tables and the AIRLINE sample tables.

Removing the Date and Time Stamp from Your Output

To remove the date and time stamp from your output, follow this selection path from
the SAS/ASSIST WorkPlace menu or any task window menu bar:Edit » Page Headers
Deselect Print current date.

Note: This option is not applicable to graphics output and is not available on
graphics task windows. Also, the date and time stamp are disabled for the duration of
the current SAS session; they will be enabled the next time you invoke SAS. A

Disabling the Save Changes Dialog Box
To disable the Save Changes dialog box, the SAS/ASSIST user profile option Confirm
changes is set to No. To set this option, do the following:

1 Follow this selection path:Tasks » Setup » Profiles » UserThe User Profile
window appears.

2 In the value field for the Confirm changes option, type

no

and press ENTER.
3 Follow this selection path to save the profile change:File » Close

If you do not set this option to No, you are presented with a Save Changes dialog box
every time you exit a task window.

Creating the SAS/ASSIST Sample Tables
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To create or re-create the sample tables, follow this selection path: Tasks » Setup
» File Management » Sample tables...The Sample Tables window appears.

Select Create sample tables from the Sample Tables window. The Create
Sample Tables window appears.

Select the tables you want to create. For the exercises in this document, select all
of the tables.

Select ok. The sample tables are created. Depending on your hardware and
operating environment, this may take several minutes. When the process is
complete, a message appears that indicates that all the tables were created.

Select Goback twice to return to the WorkPlace menu.

Note: If you are re-creating sample tables (rather than creating them for the first
time), and you attempt to re-create a table that is the currently active table in one or
more SAS/ASSIST tasks, you get an error message. SAS/ASSIST software does not let
you re-create an active table. To remove a table from active status, follow these steps:

1 Use the Tasks menu to go to the desired task window.

2 Select Table. The Select Table window appears.

3 Select Refresh, and then select ok. The task window reappears with the Table

field cleared.

Creating the AIRLINE Sample Tables

If you are using the z/OS operating environment, continue to step 2. Otherwise,
create a library, directory, or folder, depending on your operating environment,
where you want the AIRLINE sample tables to reside. You may name this library
or directory anything you want, but the name sampltab is used in these examples.
See the SAS companion for your operating environment, or contact the SAS
Software Consultant at your site if you do not know how to perform this step.

Note: The name sampltab that is used in these examples is the physical file or
directory name. Do not confuse this name with the libname, which you will specify
in a later step. A

Go to the Program Editor window by using the PREVWIND function key or by
clicking on the window, depending on your operating environment. From the
Program Editor window, follow this selection path:File » Open object...The Open
window appears with a list of available libraries in the left pane.

Select the symbol next to the sashelp library. The contents of the Sashelp
library appear in the left pane.

Scroll down in the left pane until you see the gassist catalog. Select the gassist
catalog. A list of entries in the Qassist catalog appears in the right pane.

Scroll down in the right pane until you see the samplsas source entry. Select the
Samplsas source entry.

Select open. The Samplsas program appears in the Program Editor window.

Scroll down in the Program Editor window (or use the DOWN function key) until
you find the “Supply parameters” section, as shown in the following display.
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Display 1.1 SAMPLSAS Source Code

8 Find the line that reads
* libname &library ‘‘&sysjobid..sas.assist.sampltab’’;
You might need to scroll further down to find this line. This line is the LIBNAME
statement that SAS software uses to assign a libref to a physical file or directory.

9 Remove the * by placing the cursor over it and pressing the SPACE BAR or
DELETE key.

10 If you are using z/OS, continue to the next step. Otherwise, replace the information
between the quotation marks (") with the name of the library or directory you
created in step 1. Use the following table as a guide. Ensure that the name is
enclosed in quotation marks and that a semicolon (;) is at the end of the line.

Table 1.1 Examples of LIBNAME Statements

Operating

Environment Example

z/OS libname &library "userid.assist.sampltab";
Open VMS libname &library'DEVICE:[SAMPLTAB]";

UNIX libname &library "/u/userid/assist/sampltab";
Windows libname &library "C:\assist\sampltab";

11 To run the program, follow this selection path:Run » SubmitAfter the program
finishes, statistics about the created tables appear in the Output window.
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Note: The Airline libref is assigned for the duration of your current SAS session
only. The next time you invoke SAS and SAS/ASSIST software, you will need to
assign the libref again. Alternatively, you can specify that the Airline libref be
automatically defined, each time you invoke SAS, by assigning the libref in the SAS
Explorer window. See the online help for the SAS Explorer window for details. A

12 Return to the SAS/ASSIST window by selecting ASSIST from the Solutions menu.
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Introduction

This chapter describes features in SAS/ASSIST software that help you use the SAS/
ASSIST interface. Included in this chapter is a discussion of the structure of SAS/
ASSIST software, information about backing out and exiting, and information on other
useful features of the SAS/ASSIST interface.

SAS/ASSIST Software Structure

SAS/ASSIST software is designed to enable you to locate the part of SAS that you
need. The windows that first appear when you perform a task contain only the most
important information associated with that task. However, you can also access
additional features to perform more sophisticated tasks. This structure enables novice
users to complete a task quickly without becoming overwhelmed, while enabling expert
users to complete their tasks with greater sophistication.

The following items are consistent throughout SAS/ASSIST software and should help
you use the product’s interface.

0 The menu bar is the same for all SAS/ASSIST windows. From any window in
SAS/ASSIST software that has a menu bar, you can access any task from the
Tasks menu.

0 Items that are shaded, or “grayed out,” are not available for the task you are
performing. Note that in some operating environments, unavailable items might
be indicated by a different color, for example, yellow.
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Backing Out and Exiting SAS/ASSIST Software

Depending on which SAS/ASSIST window you are in, you can use the cancel,
Goback, or OK buttons; Cancel or Close on the File menu; or the END function key to
help you to back out of tasks in SAS/ASSIST software.

O The cancel button and cancel from the File menu ignore any information that
you specified in the canceled window and return you to the previous window.

O Goback processes the information you specified in the window and returns you to
the previous window.

O OK processes what you specified in a window and either returns you to the
previous window or continues with the task.

0 The END function key processes the information specified in the window and
enables you to exit most windows in SAS/ASSIST software.

To exit SAS/ASSIST software, use the Goback or Cancel buttons, or Cancel or Close
on the File menu until you return to the WorkPlace menu. Then select Exit.

If you exit SAS/ASSIST software incorrectly, for example, if your computer “crashes,”
then the SASPARM table may become damaged. The SASPARM table is a SAS table,
normally stored in the SASUSER library, which stores information about your SAS/
ASSIST session, such as the active table and graphics options values. The next time
you access SAS/ASSIST software, a message appears to indicate your SASPARM table
has been damaged. To repair the SASPARM table, type ¥ and press ENTER. The table
is repaired, and the SAS/ASSIST session begins.

Moving Between SAS/ASSIST Windows and SAS Windows

It is occasionally necessary to move between a SAS/ASSIST window and other SAS
windows, such as the Program Editor and Log windows. You can easily move from a
SAS/ASSIST window to other SAS windows by using items on the View menu, listed
below.

Note: In most desktop operating environments, if a desired window is open, you can
access it by using the view menu or simply clicking on the window. If a window is not
already open, you must use the view menu to access it. A

Program Editor
raises the Program Editor window.

Log
raises the Log window.

Output
raises the Output window.

Graph
raises the Graph window. This window is empty unless you have performed
graphics tasks in the current SAS session.

Results
raises the Results window.

Explorer
raises the Explorer window.

Contents Only
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raises the Explorer window without the detail pane on the right.

For more information on these windows, follow this selection path from the window
of interest:Help » Using This Window

To return to the SAS/ASSIST window, follow this selection path from any
window:Solutions » ASSISTThe following section contains instructions on returning
from the Output window.

Returning to SAS/ASSIST Windows from the Output Window

The method of returning to a SAS/ASSIST window from the Output window varies
by operating environment.

Mainframe operating environments

In mainframe operating environments, SAS procedures that generate output are
suspended after the first page of output appears in the Output window. This situation
is indicated by a note in the message area stating that “PROC procedure-name has
created 1 page(s) of output so far” or “PROC procedure-name suspended.” Before you
can perform any more tasks in SAS/ASSIST software, the running procedure must be
completed. Use one of the following methods to complete the running procedure:

0 Use the END command or function key to end the procedure.
o Use the DOWN command or function key to scroll down through subsequent
windows until the procedure is complete.

After the procedure is complete, use one of the following methods to return to the
SAS/ASSIST task window:

0 Follow this selection path:Solutions » ASSIST

0 Use the END command or function key.

0 Use the NEXT or PREVWIND keys to display the SAS/ASSIST task window.

Note: 1If you return to SAS/ASSIST before all procedures have finished running and
you try to execute another SAS/ASSIST task, a message appears which indicates that a

procedure is still in progress. Select End Procedure to terminate the running
procedure.
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Display 2.1 Running Procedure Message (Mainframes)

Desktop Operating Environments

In desktop or windows-based operating environments, procedures that generate
output run to completion without user intervention. Use one of the following methods
to return to the SAS/ASSIST task window:

0 For Microsoft Windows, select the SAS/ASSIST button in the SAS window bar or

follow this selection path:Window » SAS/ASSIST

0 For any operating environment, click on the SAS/ASSIST window or follow this

selection path:Solutions » ASSIST

Using the Command Line in SAS/ASSIST Software

Some users might prefer to use a command line instead of the menu bar to type

commands in SAS/ASSIST software.

o If you have a toolbox or toolbar as shown in the following display, you can type
commands in the command window at the left end of the toolbar. To repeat a
command, select the down arrow and select the command from the list of
recently-executed commands that appears. Select the check mark or press ENTER
to execute the command.

Display 2.2 SAS Toolbar
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0 If you do not have a toolbox or toolbar, follow this selection path:Tools » Options
» Preferences

Select the view tab. Select the Command line checkbox.

The menu bar for that window is replaced with a Command ===> prompt.

Note: Menu bars are the default for SAS/ASSIST software. If you use the PMENUS
OFF command to turn the menu bars off for all SAS windows, a message appears in the

message line which indicates that you cannot disable the pull-down menus while using
SAS/ASSIST software. A

To return to the menu bar, type COMMAND at the Command ===> prompt and press
ENTER.

Using ? to Display Choices

If you are not sure of the valid choices that you can type in a field, type ? in the first
position of the field and press ENTER. A list of valid choices appears. For example, if
you type ? in a field to request a format, a list of valid formats appears, and you can
select the format that you want.

Display 2.3 Using a Selection List to Display Choices

Using ? also displays a list of valid commands for fields. For example, if you type ?
in the selection field next to any of the saved tasks in the Result Manager window, a
list appears which shows the valid selection-field commands.



12 Additional Interface ltems A Chapter 2

Display 2.4 Using a Selection List to Enter Commands

Note: In windows that are called by SAS/ASSIST software, but are not actually part
of the SAS/ASSIST product, the ? command is not available. A

Additional Interface Items

There are additional items throughout SAS/ASSIST software that help you use the
product. These interface items are used in the same way throughout SAS/ASSIST
software, and are described below.

Select Tahle Window

The Select Table window is the interface that SAS/ASSIST software uses to select
tables for tasks. Use of this window is described in Geiting Started with SAS/ASSIST.
Some additional features are described below.

0 When you select a library in the left pane, the list in the right pane automatically

adjusts itself to include only those tables in the selected library.

0 You can use the Find button to search for tables by table name, or to find a table

containing a column with a given name.

Select Tahle Variables Window

The Select Table Variables window is the interface that SAS/ASSIST software uses to
select columns from tables (“variable” is another word for “column”). Use of this window
is described in Getting Started with SAS/ASSIST.
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Utilities Menu

Most of the submenus on the Tasks menu contain a Utilities item. The
Utilities menus are specific to the task menus in which they appear and contain
items to help you manage data and perform tasks.

Additional Options

The Additional Options item on a task window enables you to access detailed
features of a task. This item is specific to the window from which it is selected. For
example, when you select Additional Options from the List a table window under
Report Writing, the Additional Options window that appears enables you to format
the report listing you are creating. However, if you select Additional Options from
the Summary Statistics window by using Elementary on the Data Analysis menu, the
Additional Options window displays information that enables you to manipulate the
columns for which you are creating statistics.
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Introduction

This chapter provides instructions on performing advanced data management tasks.

Converting a Character column to a Numeric column

Sometimes numeric data is stored in columns that have character data types. In
order to do calculations with this numeric data, you must convert the character
columns to numeric. You can use Subset/Copy on the Data Management menu to
change a column from a character to a numeric format. In this section, you convert the
character column DAY, which is found in the ORANGES table, to a numeric column.
The value in the character column DAY is a (character) number from 1 to 6.
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Additional Information

For additional information on changing columns from character to numeric and vice
versa, refer to the PUT and INPUT functions and formats and informats in SAS
Language Reference: Dictionary.

Instructions

1 Follow this selection path:Tasks » Data Management » Subset/CopyThe Subset
or Copy a Table window appears.

Display 3.1 Subset or Copy A Table Window

2 Use the Table button to select the SASUSER.ORANGES table.
3 Select output Table. The Output Table or View window appears.
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Display 3.2 Output Table or View Window

4 Type ORANGNUM in the Table/View field.

ORANGNUM is a new table that you create to contain the new numeric column
DAYNUM. By leaving the defaults of Temporary and Table selected, you create a
temporary table in the WORK library, which is deleted when you exit SAS. An
indicator next to Temporary and Table shows that these items are selected.

5 Select 0K to return to the Subset or Copy a Table window.
6 Select Define new columns. The Define New Columns window appears.
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Display 3.3 Define or Modify a Column Window

You use this window to define the new columns that you are adding to the
output table.

7 In the column field, type DAYNUM as the name of the column.
8 Leave the Length as 8.
Leave the Type as Numeric.
9 Select Initialize. The Enter Numeric Expression window appears.
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Display 3.4 Enter Numeric Expression Window

You use this window to build an expression that is used to define the new
column.

10 Select Function. The Select the Type of Function window appears.
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Display 3.5 Select Type of Function Window

11 Select character functions. The Select Data window for character functions
appears.

Display 3.6 Select Character Function Window
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12 Select INPUT (c,ifmt). The Specify Arguments to a Function window appears.

Display 3.7 Specify Arguments to a Function Window

You select INPUT (c, ifmt) because the source column DAY is character.
13 In the Value for parameter field next to CHAR, type DAY.

In the value for parameter field next to INFORM, type 2.1.

You type DAY in the CHAR parameter field because you want to use the values of
the DAY column in the ORANGES table as the source for the DAYNUM column
that you are creating.

The informat 2.1 is used in this example so you can check to see that this task
completed correctly. However, you can use any valid informat. In this example, if
you select a format such as 1., the only indication that the new column is numeric
is that it is right justified when displayed in the FSVIEW window. However, if you
use 2.1 as an informat, the new column DAYNUM is right justified and converted
to display tenths.

14 Select oK four times until you return to the Subset or Copy a table window.

Follow this selection path:Run » SubmitWhen prompted, select oK, then
Goback to view the new table.

The new DAYNUM column is created, and the data is copied to the output
table. An FSVIEW window appears with the data in the output table.

15 Scroll to the right or use the RIGHT command or function key to see the new
column DAYNUM.
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Display 3.8 New DAYNUM Column

To confirm that the column is numeric, browse the properties of the table. See
“Altering the Properties of a SAS Table” on page 30 for more information.

16 To exit theFSVIEW window, follow this selection path:File » Close

Converting Character Dates and Times to SAS Date and Time Values

You can use the above procedure to convert character dates and times to SAS date
and time values. In the Specify Arguments to a Function window, specify an
appropriate date, time, or datetime informat for INFORM. For example, if you have a
column of character dates in the form 056MAR1999, use the DATE9. informat. In the
Define or Modify a Column window, you might want to specify an appropriate date,
time, or datetime format by selecting Format.

Combining Data Using a Cartesian Product Match Merge

You can use Combine on the Data Management menu to combine your data in several
ways. You can concatenate, interleave, merge, or match merge your data. The Match
Merge item enables you to perform a SAS match merge or Cartesian product match
merge.

In this section, you use Combine on the Data Management menu to perform a
Cartesian product match merge using the AIRLINE.SCHEDULE and AIRLINE.STAFF
sample tables. If you have not created the AIRLINE sample tables, see “Creating the
AIRLINE Sample Tables” on page 3.

The AIRLINE.STAFTF table contains data on each employee, such as first name, last
name, and employee number. The AIRLINE.SCHEDULE table includes information
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about what personnel are assigned to each flight during the first week of March,
including flight number, date, and employee number. This Cartesian product matches
the first name and last name of each employee to the flights to which they are assigned.
The employee and the schedule information are matched using the employee number
found in both tables. You create a new table, WORK.STAFSKED, that contains the
merged data.

The following displays show listing reports of the AIRLINE.STAFF and
AIRLINE.SCHEDULE tables before they are merged.

Display 3.9 AIRLINE.STAFF Table
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Display 3.10 AIRLINE.SCHEDULE Table

Additional Information

For additional information about concatenating, interleaving, merging, or match
merging your data, refer to the information on the SET and MERGE statements in SAS
Language Reference: Dictionary.

Instructions

1 To display the Match Merge SAS Tables window, follow this selection path starting
from the WorkPlace menu:Tasks » Data Management » Combine » Match
merge » Second MethodThe Match Merge SAS Tables window appears.
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Display 3.11 Match Merge SAS Tables Window

Use the First table button to select the AIRLINE.SCHEDULE table.
Use the second table button to select the AIRLINE.STAFF table.

Select output Table. The Output Table or View window appears. The Output
Table or View window is identical to that shown in Display 3.2 on page 17.

Type STAFSKED in the Table/View field as the name of the output table.
Select Ok to return to the Match Merge SAS Tables window.

By leaving the defaults of Temporary and Table, a temporary table is created
in the WORK library. The WORK.STAFSKED table is deleted when you exit SAS.
An indicator next to Temporary shows that this item is selected.

Select Type of column used to match merge the tables. The Select a Merge
Method window appears.

Select Combine by columns common to both tables because the employee
number column has the same name in both tables.

You combine the columns unique to each table when each table has columns
with the same values but different names, for example, if the employee number is
named EMPNUM in one table and IDNUM in the other. You combine the columns
common to both tables when each table has a column with the same name and the
same values, for example, if each table has a column called EMPNUM with the
same employee number values.

The Match Merge by Common Columns window appears with a list of columns
common to both tables, that is, having the same name and same data type. The
only column common to both tables is IDNUM.
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Display 3.12 Match Merge By Common Columns Window

9 Select I1DNUM, and then select OK to return to the Match Merge SAS Tables window.

10 Choose Select unique existing columns. The Select Existing columns window
appears.
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Display 3.13 Select Existing Columns Window

11 Select, in this order, FLIGHT, DATE, FNAME, and LNAME as the columns to be
included in the new table WORK.STAFSKED. The order in which you select these
columns determines the order in which they appear in the new table.

12 Select OK to return to the Match Merge SAS Tables window.

13 Follow this selection path:Run » SubmitWhen prompted, select 0K, and then select
Goback to view the new table. The new table appears in an FSVIEW window.
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Display 3.14 Match Merge Output

14 To exit the FSVIEW window, follow this selection path: File » Close

Creating a Format

SAS uses formats and informats to interpret your data. Formats determine how a
column value should be displayed, and informats determine how values entered in
column fields should be interpreted. You can design your own formats and informats by
using Design Format on the Data Management menu. Once you create the formats
and informats, you can use them whenever you are prompted for a format or informat
for a column.

In this section, you create a numeric format, COSTRNGE., that determines whether
the cost of a house in the HOUSES table is low, medium, or high depending on the
range in the format. You use this format in the following section, “Altering the
Properties of a SAS Table” on page 30.

Additional Information

For additional information about creating formats and informats, refer to “The
FORMAT Procedure” chapter in the Base SAS Procedures Guide.

Instructions
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1 To display the Create Formats window, follow this selection path:Tasks » Data
Management » Design Format » Create formatsThe Create Formats window
appears.

Display 3.15 Create Formats Window

2 In the The format name field, type COSTRNGE as the name of the format.
3 Select Numeric as the type of format.

4 Type 3 in The number of groups required field. The number of groups
indicates how many values or ranges you want to use for the format.

5 Select Ranges. The Specify Format Ranges window appears.
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Display 3.16 Specify Format Ranges Window

You select Ranges because low, medium, and high cover a range of prices, not
specific values.
For Group 1, type 1 as the From Value, 50000 as the To Value, and Low as the
Formatted Value.

For Group 2, type 50001, 100000, and Medium for the From Value, To Value,
and Formatted Value, respectively.

For Group 3, type 100001, 999999, and High for the From Value, To Value,
and Formatted Value, respectively.
By leaving the default of Temporary, a temporary format is created in the
WORK.FORMATS catalog. The WORK.FORMATS catalog is deleted when you exit
SAS. An indicator next to Temporary shows that this item is selected. If you select
Permanent, the format is permanently stored in the SASUSER.FORMATS catalog.
Select OK twice to create the format. A message appears, indicating that the

format was created. Note that a period was appended to the end of the
COSTRNGE. format.

9 To return to the WorkPlace menu from the message window, select Goback twice.

You can now use this format in the HOUSES table. In the following section, you use
the Properties window to apply the COSTRNGE. format to the HOUSES table.

Altering the Properties of a SAS Tahle

The properties of a SAS table describe information about the table. Using utilities
on the Data Management menu, you can access the Properties window to browse or
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alter a table’s properties. The properties of a table include the table name, engine, date
created, date last modified, and number of rows, along with additional information. Of
the table attributes, you can edit the table type and label. In addition, the Properties
window displays information about each column, including the name, type, length,
position, label, format, and informat, and whether or not the column serves as an index
for the table. The name, label, format, and informat for each column can be edited.

In this section, you change the format of the PRICE column in the HOUSES table,
the label for the BEDROOMS column, and the label of the table. This process uses the
COSTRNGE. format that you created in the previous section. After you change the
table, you run the following listing report to view your changes.

The following listing report shows the unaltered HOUSES table.

Display 3.17 Listing of Unaltered HOUSES Table

Additional Information

For additional information on altering the properties of a SAS table, see “The
DATASETS Procedure” in Base SAS Procedures Guide.

Instructions

1 To edit the properties of a SAS table, follow this selection path:Tasks » Data
Management » Utilities » Contents of a table » Edit SAS table contentsThe
Select Table window appears.

2 Select the SASUSER.HOUSES table and select OK.
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The Properties window opens with information about the HOUSES table.

Display 3.18 Properties Window for HOUSES table

3 Select the down arrow at the top of the window, and then select Columns. A list of
columns in the HOUSES table appears.

4 For mainframes: In the command field for the PRICE column, type s (for Select)
and press ENTER. Then, type s in the command field for Format and press
ENTER. For desktops: Right-click the Pricecolumn and select Modify Format.

The Modify window appears for the Format attribute.
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Display 3.19 Modify Window

5 Type COSTRNGE. over DOLLAR12.and select oK. The Properties window reappears
with the new format.

6 Repeat the previous two steps to change the label of the BEDROOMS column to
Bedrooms. (If necessary, type blanks over any leftover letters from the old label.)

7 Select the down arrow at the top of the window, and then select General
Properties.

8 For mainframes: Type M in the command field for Label and press ENTER. For
desktops: Double-click the Label attribute.

9 Type Houses for sale over the existing label. Type blanks over any leftover
letters from the old label.

10 Follow this selection path to return to the WorkPlace menu:OK » OK » Goback

11 To display a listing report for the modified HOUSES table, follow this selection
path: Tasks » Report Writing » Listinglf SASUSER.HOUSES is not the active
table, use the Table button to select the SASUSER.HOUSES table. Follow this
selection path to view the table:Run » Submit

33
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Display 3.20 Listing of Altered Houses Table

Notice the changes in the formats and labels.

12 Follow the directions in “Returning to SAS/ASSIST Windows from the Output
Window” on page 9 to return to SAS/ASSIST software.

Transporting SAS Files Across Operating Environments

You can use SAS/ASSIST software to prepare SAS files for transport to another
operating environment. Utilities on the Data Management menu enables you to
convert a SAS file into transport format, and to convert a transport file to a SAS file. In
this section, you convert the SASUSER.VENEER table into transport format. A file
that is in transport format can be transported to a different operating environment, for
example, across a network using File Transfer Protocol (FTP). In addition to SAS
tables, you can also convert SAS libraries and catalogs to transport format.

Additional Information

For additional information about converting SAS files from one format to another,
refer to “The CPORT Procedure” and “The CIMPORT Procedure” in the Base SAS
Procedures Guide.

Instructions

1 Follow this selection path:Tasks » Data Management » Utilities » Convert to
CPORT format » TableThe Convert a SAS Table window appears.
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Display 3.21 Convert a SAS Table Window

2 Use the Input SAS table name button to select the SASUSER.VENEER table.

3 If desired, select output file name; the Select External File Name window
appears. Alternatively, you can accept the default output file name. See the
following table for a list of default file names.
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Display 3.22 Select External File Name Window

4 In the External file name field, type the name of the file as is appropriate for
your operating environment to transport the VENEER table. Use the following
table as a guide.

Operating

Environ- Transport File

ment What You Type Example Default

z/0S an operating system data set USERID.DATA. USERID.SASCAT.DATA
name, and if a partitioned SASDATA
data set is used, a member (VENEER)

OpenVMS the name of a device, directory, DEVICE:[SASDATA] SASCAT.DAT in the
and filename VENEER.DAT default directory

UNIX the name of a directory or lu/userid/sasdata/ sascat.dat in the
subdirectory and a filename veneer working directory

Windows the name of a drive, directory C:\SASDATA\ SASCAT.DAT in the
or subdirectory, and a filename yENEER.DAT working directory

and extension

5 Select Filename because you typed a filename and not a fileref.

6 Select OK to return to the Convert a SAS Table window.

7 Follow this selection path to create the transport file:Run » SubmitThe Log
window appears, displaying information to indicate that the table was converted

successfully.
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Display 3.23 Log Window with Conversion Results

Note: Under some operating environments, such as z/OS, if the external file does
not exist, a message appears asking if you want to create it. Under other
operating environments, you need to create the external file before you can output
a transport table to it. See the SAS companion documentation for your operating
environment for more information. A

8 To return to SAS/ASSIST software from the Log window, follow this selection path:
Solutions » ASSIST

You can now transport your file to another operating environment. To convert the file
back to SAS file format on the other operating environment, follow this selection
path:Tasks » Data Management » Utilities » Convert from CPORT format »
TableUse the buttons in the Convert a Transport File window to specify the input file
name and output table name.

Transposing a Table

You can use Transpose table under Utilities on the Data Management menu to
invert a table. Transposing a table turns the rows of a table into columns and vice versa.

In this section, you first sort the ORANGES table in order of the store number
because you group the transposed rows by store. Then you transpose the sorted table so
that the price for the first variety of oranges becomes a row with a separate column for
each day’s price.

The following display shows a listing report of the ORANGES table before it is
transposed.



38 Additional Information A Chapter 3

Display 3.24 Listing of ORANGES Table Before Transposing

Additional Information

For additional information, refer to “The TRANSPOSE Procedure” in the Base SAS
Procedures Guide.

Instructions

1 To display the Sort a Table window, follow this selection path:Tasks » Data
Management » Sort
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Display 3.25 Sort a Table Window

2 Use the Table button to select the SASUSER.ORANGES table.
3 Select output table. The Specify Output Table window appears. The Specify

o N o o

9

Output Table is identical to the window shown in Display 3.2 on page 17.
In the Table field, type ORGSORT as the name of the output table.

By leaving the default of Temporary, a temporary table is created in the WORK
library. The WORK.ORGSORT table is deleted when you exit SAS. An indicator
next to Temporary shows that this item is selected.

Select OK to return to the Sort a Table window.
Use the sort by columns button to select the STORE column.
Select OK to return to the Sort a Table window.

To sort the table, follow this selection path:Run » SubmitA message appears to
indicate that the table was successfully sorted.

Select Goback.

10 Follow this selection path to open the Transpose a Table window:Tasks » Data

Management » Utilities » Transpose TableThe Transpose a table window
appears.
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Display 3.26 Transpose a Table Window

11 The WORK.ORGSORT table should already be listed for Table. If not, use the
Table button to select the WORK.ORGSORT table.

12 Select output table. The Specify Output Table window appears.

13 In the Table field, type ORGTRANS as the name of the output table, then select ok
to return to the Transpose a Table window.

By leaving the default of Temporary, a temporary table is created in the WORK
library. The WORK.ORGTRANS table is deleted when you exit SAS. An indicator
next to Temporary shows that this item is selected.

14 Use the Columns to be transposed button to select the PRICE1 column as the
column to be transposed (that is, changed to a row).

15 Select Additional options. The Additional Transpose Options window appears.
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Display 3.27 Additional Transpose Options Window

16 Use the Group the transposed rows button to select the STORE column as the
column you want to use as a grouping column.

17 Use the column to be used to label transposed columns button to select
the DAY column as the label you want to use to label the columns of the transposed
data in the ORGTRANS output table.

SAS generates a row for each column that is being transposed for each group.

18 In the Additional Transpose Options window, position the cursor in the Prefix
field and type Day as the prefix to each number that represents a day of the week.
Make sure each formatted value of the DAY column occurs only once in each

group of the active table. Duplicate values produce a warning message in the LOG
window and stop the procedure.

19 Select OK to return to the Transpose a Table window.

20 To transpose the table, follow this selection path:Run » SubmitA message appears
asking if you want to view the transposed table. Select OK, then Goback. The
transposed table appears in an FSVIEW window.
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Display 3.28 Transposed Table

Use the scroll bars or the RIGHT command or function key to display the rest of
the transposed data.

21 To exit the FSVIEW window, follow this selection path:File » Close
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Introduction

This chapter shows you how to limit the number of rows for a report, add more than
four titles to a report, and create tables using the TABULATE procedure.

Limiting the Number of Rows for a Report

When you create a report, you can select Subset data in the report windows to limit
the number of rows that are processed to create the report. This feature is especially
useful when your final report is very long, and you want to use a limited number of
rows for testing before producing the final report.

In this section, you limit the number of rows to five for a listing report of the CLASS
table.
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Additional Information

For additional information on writing reports, refer to the “Report Writing” and
“Using the Report Engine” chapters in Getting Started with SAS/ASSIST, and Chapter
5, “Doing More with the Report Engine,” on page 61.

Instructions

1 To display the List a Table window, follow this selection path:Tasks » Report
Writing » Listing

Display 4.1 List a Table Window

2 Use the Table button to select the SASUSER.CLASS table.
3 Select subset data. The Subset Data window appears.
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Display 4.2 Subset Data Window

4 Select Restrict Rows. The Restrict Rows window appears.

Display 4.3 Restrict Rows Window
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5 In the Number of rows to process field, type 5 as the number of rows you want
to use for the listing report.

The default for the Number of rows to process field is MAX, which includes
all the rows in the table. To reset the field to its default value, select Reset.

6 Select OK, then Goback to return to the List a Table window.

7 To run the report, follow this selection path:Run » SubmitThe listing report
appears with only five rows.

Display 4.4 CLASS Listing Report with Restricted Rows

8 Return to SAS/ASSIST software from the OUTPUT window. See “Returning to
SAS/ASSIST Windows from the Output Window” on page 9 for more information.

9 Follow this selection path from the List a Table window to save the source code for
the report. You use the saved source code in the next section.File » Save as
sourceThe Save As window appears.

10 In the Name field, type CLASSRST and press TAB.

11 In the Description field, type CLASS report - restricted rows and select OK.
A message appears to inform you that the source code was successfully saved.

For more information on saving and editing source code, refer to the “Saving Source
Code for Editing and Re-execution” chapter in Getting Started with SAS/ASSIST.

Adding More than Four Titles to a Report

When you create a report and select Edit in a report window to add titles to your
report, you can add only four titles to your report. However, if you save the report source
code, you can edit the report program using the Result Manager to add additional titles.
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In this section, you access the source code you saved in the previous section, edit the
program, add five titles to the report, and re-execute the program.

Additional Information

For additional information on writing reports, refer to the “Report Writing” and
“Using the Report Engine” chapters in Getting Started with SAS/ASSIST. For more
information on the Result Manager, see the “Using the Result Manager” chapter in
Getting Started with SAS/ASSIST and Chapter 9, “Doing More with Results,” on page
143.

Instructions

1 Follow this selection path to display the Result Manager window:Tools » Result
Manager

Display 4.5 Result Manager Window

2 In the cmd field for the CLASSRST source entry, type E (for Edit) and press ENTER.
The Edit window appears with the source code for the listing report.

3 Place the cursor in the line number for the title statement. Type I 5 and press
ENTER. Five blank rows are inserted between the title statement and the
footnote statement.

4 Type the following code in the five blank lines you created in the previous step:

titlel "SASUSER.CLASS Listing Report";
title2 "For Mr. Smith’s class";
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title3 "Including age, height, weight,";
title4 "and gender data";
title5 "(first five rows only)";

Your program should now resemble the following display.

Display 4.6 Edited Listing Report Program

5 Follow this selection path to save your modified program:File » SaveA message
appears, warning you that the program already exists. Select R, then OK to
overwrite the program. A message appears, indicating the number of lines in the
program that were saved to a catalog entry.

6 Follow this selection path to return to the Result Manager window:File » Close

7 Type X in the cmd field for the CLASSRST program and press ENTER to execute the
program. The report with five titles appears in the OUTPUT window.
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Display 4.7 CLASS Listing Report with Five Titles

8 Return to SAS/ASSIST software from the Output window. See “Returning to SAS/
ASSIST Windows from the Output Window” on page 9 for more information.

9 To exit the Result Manager window, follow this selection path:File » Close

Doing More with Tabular Reports

The Tabular Report item on the Report Writing menu enables you to create tables
in one of six styles. A tabular report presents descriptive statistics in tabular format.
The value in each table cell is calculated from the columns and statistics that define the
pages, rows, and columns of the table. The statistic associated with each cell is
calculated on values from all rows in that category.

In the “Report Writing” chapter of Getting Started with SAS/ASSIST, you learned to
create a tabular report using the Simple Group 1 style. This chapter describes the
different tabular report styles and shows sample output for each style. The techniques
for selecting columns and statistics and for generating output are the same for all
styles. Additionally, this chapter provides information on the Summarize option and
Additional Options.

Additional Information

For additional information on creating tabular reports, refer to the “Report Writing”
chapter in Getting Started with SAS/ASSIST and to the SAS Guide to TABULATE
Processing.
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Defining Terms

Before creating a tabular report, there is some terminology you should understand.

An analysis column is a numeric column whose values are used to calculate statistics.

A classification column is any column, numeric or character, that you want to use to
classify your data into groups or categories of information. Classification columns can
have character, integer, or even decimal values, but the number of unique values should
be limited. Frequently, columns in a table have discrete values, but there are so many
different values that any breakdown by these values is meaningless. You can reduce the
number of classes by formatting ranges of values. See “Creating a Format” on page 28
for information on formatting ranges of values.

Statistics Style

The Statistics style of tabular report is the simplest. This style allows you to display
statistics of your choice on any or all of the numeric columns in your table. The
following display shows a table containing the MEAN, MIN, and MAX statistics for all
the numeric variables in the HOUSES table.

Display 4.8 Statistics Report OQutput

Simple Group 1 Style

The Simple Group 1 style of tabular report is similar to the Statistics style, except
that the calculated statistics are broken down by one or more classification variables.
The analysis variables are arranged across the tabular report; each one is subdivided
into the selected statistics. The classification variables are arranged down the tabular
report, with one row of the tabular report for each value of the classification variable.
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The following display shows a Simple Group 1 style of tabular report on the HOUSES
table:

Display 4.9 Simple Group 1 Report Qutput

Simple Group 2 Style

The Simple Group 2 style of tabular report is similar to the Simple Group 1 style,
except that you select statistics that go across the tabular report and are subdivided by
the analysis columns. With this style of report, it is easier to compare the same statistic
for different analysis columns.



52 2-D Group Style A Chapter 4

Display 4.10 Simple Group 2 Report Output

2-D Group Style

The 2-D Group style of tabular report enables you to create frequency tables, such as
the one shown in the following display:



Doing More with Report Writing /A Multiple Group Style 53

Display 4.11 2-D Group Report Output

Multiple Group Style

The Multiple Group style of tabular report is similar to the Simple Group 1 style,
except that you specify an additional classification column to be arranged across the
tabular report:
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Display 4.12 Multiple Group Report Qutput

Advanced Style

The Advanced style of tabular report is the most flexible. You can create any of the
other report styles with the Advanced style. You build your tabular report with up to
five across levels and five down levels; each level can contain one or more classification
columns, analysis columns, or statistics.
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Display 4.13 Advanced Report Output

When you select Across items or Down items in the Advanced window, the Across
Items or Down Items window opens, enabling you to select items for the different levels.
Selecting a Level button opens the Define Level window, which allows you to choose
the type of item (classification column, analysis column, or statistic). The types
available for a given level depend on how other levels have been defined:

0 You cannot have two levels of analysis columns, one under the other.
0 You cannot have two levels of statistics, one under the other.

If you select brop level in the Define Level window for a previously defined level,
the definition for that level is deleted, and lower levels are moved up.

Summarize Option

You can add a summary to the report for all report styles except the Statistics style.
A summary provides statistics calculated for all members of each classification column,
as well as statistics for the table as a whole, as in the following display:
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Display 4.14 Summarized Report Qutput

To add a summary to a report:
1 Select Summary. The Summarize window opens.
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Display 4.15 Summarize Window

2 Select Summarize.

3 If desired, select Specify label to label the row with the summarized statistics.
The Label Summary window appears.
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Display 4.16 Label Summary Window

4 Type a label and select oK. If you do not specify a label, the default label “Total” is
used.

5 Select OK to exit the Summarize window.

Additional Options

Each report style has an Additional Options button, enabling you to further
customize your report. The number of options that are available vary from style to
style. The following is a description of all the possible options:

0O Format columns: Use this option to assign formats to the tabular report columns.

O Data order: Use this option to specify the order in which the classification
column values are displayed.

O Row title space: Use this option to specify the width of the column containing
the row titles. This number includes the vertical lines on the left and right.

O Label statistics: Use this option to specify an alternative label for each
statistic.

0O Include missing values: Use this option to include missing values as a member
of the classification column(s). If this option is set to NO, only nonmissing values
are used as classification members.

O Missing value text: If Include missing values is set to YES, use this option
to specify text to use to identify the missing-value classification member.

O Label columns: Use this option to assign alternative labels to the classification
and analysis columns.
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Default format: Use this option to specify a default format for all values in the
table. This format is overridden on a per-column basis by any formats specified in
Format columns.

Form characters: Use this option to specify alternative symbols to use as vertical
and horizontal lines, corners, etc.

Use separator lines: Use this option to specify whether to display lines
between the rows of the tabular report.

Maximum depth: Use this option to specify the maximum number of levels for
across or down items.
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Introduction

You can use the Report Engine to build different types of reports that are based on
SAS tables. You also can create reports based on queries that were created by using the
Query window or the SQL Editor window. (See Chapter 10, “Query and Reporting,” on
page 155 and Chapter 11, “Using the SQL Editor,” on page 201 for information on the
Query window and the SQL Editor window.) By using the Report Engine, you can
create lists; tables; graphics, including horizontal and vertical bar charts, pie charts,
and plots; and dynamic reports with drill-down features. You can easily change from
one report style to another using the Report Engine.

The “Using the Report Engine” chapter in Getting Started with SAS/ASSIST
introduced the Report Engine and showed you how to create a simple listing report and
a drill-down report. This chapter explores the Report Engine in more depth.



62 Opening and Using the Report Engine Window A Chapter 5

Opening and Using the Report Engine Window

To open the Report Engine window, follow this selection path:Tasks » Report
Writing » Design Report » Report EngineYou also can open the Report Engine
window by following this selection path:Tasks » Data Management » Query » Query
and Reporting » Report EngineThe Report Engine window appears.

Display 5.1 Report Engine Window

When you open the Report Engine window, the last report that you created appears.
Select New from the File menu to clear the window. You can use New to clear the
Report Engine window at any time.

You use commands and make choices from selection lists to produce reports in the
Report Engine window. When you press TAB, your cursor moves to any field that
contains text that you can edit. The fields in the Report Engine window are described
in the following table. Type a ? in any field and press ENTER to list possible selections
for that field.
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Table 5.1 Fields in the Report Engine Window

Field Description

Data lists the name of the data source. Fill in the Type field before you select
the data source.

Type lists the type of data, such as a SAS table or query, or a query on a DB2
table that you saved from the SQL Editor or the Query window. The
default value is SAS.

Report controls the type of report you want to generate. The default value is LIST.

To produce a report, first select the type of data in the Type field. You can select SAS
tables or views (type SAS), a query that was created by using the Query window (type
QUERY), or a query that was created by using the SQL Editor window (type SQL).
Queries do not contain any data but rather point to one or more tables.

After you select the type of report, type the name of the data source in the Data field.
If you type a ? in the pata field and press ENTER, the window that appears depends
on what is in the Type field:

o If the type is SQL or QUERY, the Open window appears showing your SQL or
QUERY entries. To sort the queries, select Sort By from the Edit menu and
select Name, Description, or Date to reorder the queries listed. Type S in the cmd
field to select a query.

o If the type is sas, the Select Table window appears. Select a table and select oK.

After you select the data source, type of data, and report, the Report Engine window
shows you the columns for the data you selected. For example, the following display
shows the columns for the AIRLINE.MARCH SAS table. See “Creating the AIRLINE
Sample Tables” on page 3 for more information on the AIRLINE sample tables.

Display 5.2 Report Engine With AIRLINE.MARCH Table
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To customize your report, you make modifications as described in the rest of this
chapter. To run the report, follow this selection path:Run » SubmitThe report appears
in the Report Output window. To return to the Report Engine window after viewing
your report, follow this selection path:File » Close

You can use the fields described in the following table to manipulate your report in
the Report Engine window.

Table 5.2 Fields in the Report Engine Window

Field Description

Row indicates the number of the first line of column information shown in the
window. If the table has more columns than will fit in the window, the
row number is in a different color, and you can type a new number in the
Row field to begin the display at the specified row number.

to indicates the column number of the last column shown in the window.
of indicates the total number of columns in the data source.
Cmd enables you to specify commands to manipulate the columns in the report.

Type a ? and press ENTER to list all of the commands, which are
described in Table 5.3 on page 65.

No indicates the order of the columns. (No is an abbreviation for Number).
You can change the column order by typing a new order number over the
old order number. To drop a column from the report, delete (or type
blanks over) the number in this field. The column header and length
remain in the window. See the D command in Table 5.3 on page 65 for an
alternate method of dropping columns from the report.

Order sorts the column data in the specified order. Type A to sort the column data
in ascending order. Type D to sort the column data in descending order.

Usage defines what a column represents. Usages change the appearance of the
report. You can type the usage into this field or type a ? for a list of the
possible usages. To produce reports other than lists, you must define at
least one usage such as GROUP, ACROSS, BREAK, or PAGE. See Table
5.4 on page 68 for a list and description of the usages.

Column Header indicates the column label. You can change the column label by typing
over the existing label. To reset the label to its original value, type an I in
the Cmd field to display the Column Information window. In the Column
Information window, select Reset and OK to return to the original
column label value.

Length indicates both the SAS format and data type of a specific column. You can
use any SAS format in this field. The format changes how the column
looks on your report. Type a ? to list SAS formats. A C to the right of the
column length indicates a character column, whereas an N indicates a
numeric column.

Modifying a Report Using the Cmd Field

You can use commands in the Report Engine window cmd field to modify your report.
Type a ? in the cmd field to list the commands described in the following table.
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Table 5.3 Cmd Field Commands

65

Command Name Description
I Column displays detailed information about a column. See “Using the
Information Column Information Window” on page 70 for more information.

R Repeat repeats a column.

D Delete deletes a column from the report only. To restore deleted columns,
select Reset Columns from the Edit menu. When you delete a
column using D, all information for that column is removed from the
Report Engine window. See the No field in Table 5.2 on page 64 for
an alternate method of dropping columns from a report.

T Subtotal computes a subtotal on the column for each group defined by a

GROUP, PAGE, or BREAK usage. See Table 5.4 on page 68 for more
information on usages.

The following display shows the Report Engine window with the command to repeat

the No. of boarded passengers column. This display also shows that the number

in the No field for the No.

list, and the other columns are renumbered. Any columns used to create subtotals are

indicated with a T.

of transfer passengers column has been erased to drop
the column from the report. After you press ENTER, repeated fields are indicated with
an R between the ¢md and No fields; dropped columns are moved to the bottom of the

Display 5.3 Using the Cmd Field
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Modifying a Report’s Column Order, Headers, and Formats

You can use fields in the Report Engine window to modify the report’s column order,
headers, and formats as follows:

O

O

O

Rearrange the report’s columns by changing the numbers of the No (Number) field.
change the column headers by typing a new column header over the existing one.

Change the presentation of the column in your report by selecting a new format in
the Length field.

After you make your changes and press ENTER, the columns are reordered in the
Report Engine window and are renumbered to account for any dropped columns. Also,
the new formats are listed in the Length field.

Note: If the table has been sorted, you can set the User Profile option Column
Order to automatically put the BY column or columns at the top of the list in the
Report Engine window. See Appendix 2, “Customizing SAS/ASSIST Software,” on page
237 for information. A

The following display shows the Report Engine window with the AIRLINE.MARCH
data file with the following modifications:

O

The Wweight of mail (kg), Weight of freight (kg), No. of transfer
passengers, and No. of disembarked pass. columns have been dropped from
the report by erasing their position numbers in the No field.

0 The order of the Departure date and Flight number columns has been reversed.

0 The column header for the No. of non-revenue pass. column has been

changed to No. of non-paying passengers..
The format for the Departure date column has been changed to WEEKDATE17.

using the Column Information window (see “Using the Column Information
Window” on page 70 for details).

0 The peparture Date column has been sorted in ascending order.

0 The width for all columns has been changed to 10, except for the width for F1light

number, which has been changed to 6, and the Departure Date column, which
has been changed to 17 to accommodate its new format. Column widths do not
appear in the Report Engine window; you view and change the column width in
the Column Information window. See “Using the Column Information Window” on
page 70 for more information.

The title “Passenger Information for March” has been added by selecting Titles
from the Edit menu, and centered by selecting Page Layout from the Edit menu.
Title information does not appear on the Report Engine window.

The repeated No. of boarded passengers column has been assigned a usage of
MAX, the column header has been changed to Max. No. of boarded
passengers, and the width has been changed to 10. For information on changing
usages, see “Modifying a Report with Usages” on page 68.

The pDeparture date column has been assigned a usage of BREAK so that the
report breaks on each new date value.
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Display 5.4 Report Engine Window with Modifications to AIRLINE.MARCH Table

The following display shows the modified list report for the passenger data in the
AIRLINE.MARCH table. The report has been scrolled forward to show that the
maximum number of boarded passengers for a single flight for each day is given at the
bottom of the data for each day.
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Display 5.5 AIRLINE.MARCH Listing Report With Modifications

Modifying a Report with Usages

The values of Usage define what a column represents and change the appearance of
the report. The following table describes the different values of usage. Note that SUM,
MEAN, MIN, MAX, AVG, COUNT, N, and NMISS are aggregate (summary) functions.

Table 5.4 Usages

Usage Description

PAGE creates a new page at each new column value. PAGE is used with the
ACROSS, GROUP, or BREAK usages. PAGE is valid only with a report of
type TABLE. With other types of reports, PAGE is used like a GROUP
usage. The corresponding SAS/GRAPH option for this usage is BY, which
creates a new page for each BY value.

GROUP groups data by the values in the column. The corresponding SAS/GRAPH
option for this usage is GROUP, which organizes bars and pies into groups
by different values of the GROUP variable.

ACROSS groups the report into subgroups across the report. The corresponding
SAS/GRAPH option for this usage is ACROSS, which is used to place
multiple pies "across" on a page and also is used by the LEGEND
statement.

BREAK computes one summary for each column in a LIST report. With other
types of reports, BREAK is used like a GROUP usage.
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Usage Description

SUM computes the sum of the values. The corresponding SAS/GRAPH option for
this usage is SUM, which prints the value of the sum statistic above bars.

MEAN computes the mean of the values. The corresponding SAS/GRAPH option
for this usage is MEAN, which is the value of the statistic for the variable
being used for calculations.

MIN computes the smallest value

MAX computes the largest value

AVG computes the average of the values (equal to mean)

COUNT computes the number of nonmissing values

N computes the number of nonmissing values

NMISS computes the number of missing values

The following display shows the AIRLINE.MARCH table in the Report Engine
window. All of the modifications made in the previous section are in effect; in addition,
the report has been further modified so that the report shows totals (SUM usage) for
the number of boarded and nonpaying passengers. A forward slash (/) has been
inserted in the column header for the Max No. of boarded passengers so the
header breaks after the word Max.

Display 5.6 Report Engine Window with AIRLINE.MARCH Table and More Modifications

The following display shows the passenger information report grouped by date with
the sum of the boarded passengers, the maximum number of boarded passengers, and
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the sum of the nonpaying passengers. The report has been scrolled forward to show the
sums for the boarded and nonpaying columns.

Display 5.7 AIRLINE.MARCH Listing Report with More Modifications

Using the Column Information Window

To display information about a column, type I in the cmd field for the desired column
and press ENTER. The following display shows the information for the Departure
Date column, as modified in the previous sections.
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Display 5.8 Column Information Window

When you press TAB in this window, your cursor moves to any field that you can
select or that contains text that you can edit to update the information in this window.
The information in this window varies according to the type of usage associated with a

column.

To reset the Report Header and Report Format to their original values, select
Reset from the Edit menu.
The fields on the Column information window are described in the following table.

Table 5.5 Fields in the Column Information Window

Field

Description

Column

Report Header
Format

Report format
Column width
Type

Sort order

Column Usage

indicates the column label stored with the source table.

indicates the column label to be used in the report.

indicates the column format stored with the source table.

indicates the column format to be used in the report.

indicates the width of the column in the report.

indicates the type of column data, C for character data, N for numeric data.

specifies how the column data are sorted in the report. A specifies that the
column data is sorted in ascending order in the report. D specifies that the
column data is sorted in descending order in the report.

indicates the usage for the column. To produce reports other than lists,
you must define at least one of the following usages: GROUP, ACROSS,
BREAK, or PAGE. See Table 5.4 on page 68 for more information.
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Field

Description

Report Width

Flow values

Subtotal

Display
subtotal text

indicates the total width of the report.

specifies that character columns longer than the width indicated in the
wWidth field are flowed to multiple lines.

writes a summary line (a line containing summaries of statistics and
computed variables) for each group defined by a BREAK, GROUP, or
PAGE usage. This parameter is available only on columns with a BREAK,
GROUP, or PAGE usage.

prints the value of the group to the left of the subtotals. This parameter is
available only on columns with a BREAK, GROUP, or PAGE usage for
which the Subtotal parameter has been selected.

The following parameters are available only on columns with BREAK or PAGE

usages.

Table 5.6 Additional Fields in the Column Information Window for Columns with

BREAK or PAGE Usages

Field Description

Show as Column displays the value of each group in a column to the left of the
other columns. Rows displays the value of each group in a line above the
data for each group. Selecting Rows activates the other BREAK and
PAGE fields.

Position indicates where the group value appears, in spaces from the left margin.

Display text

Text

Insert line

determines whether the group value appears in the report.

If Display text is checked, the text you supply in the Text field is
used instead of the group value. Leave this field blank to display the
group value.

determines whether to insert blank lines above and below the group value.

Choosing a Different Report Type

You can use the Report Engine window to create several types of reports. You can
change from one type of report to another in one of two ways:

0 within the Report Engine window, type a new value in the Report field before
running the report. Alternatively, type ? in the field and press ENTER to list the
types of reports; then select the type of report.

O after you run one type of report, select a new type of report from the Run menu in
the Report Output window.

You can select the following types of reports:

O LIST creates a list report

o o o d

TABLE creates a tabular report
DRILL creates a dynamic report
HBAR creates a horizontal bar chart
VBAR creates a vertical bar chart
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O PIE creates a pie chart
O PLOT creates an X by Y plot.

For any type of report other than LIST, you must assign a usage of BREAK, ACROSS,
GROUP, or PAGE to at least one column, which becomes the classification column for
tabular reports or the chart column for graphical reports.

To see the passenger information report as a table, type TABLE in the Report field in
the Report Engine window. Select Submit from the Run menu. The following display
shows the passenger information report as a table.

Display 5.9 Tabular Report Output

To see the passenger information report as a vertical bar chart, select Vertical Bar
Chart from the Run menu of the Report Output window. Alternatively, type VBAR in the
Report Engine window Report field. The following display shows the passenger
information report as a vertical bar chart. Note that the format for the DATE column
has been changed to DATE9. to make more room for the bars.
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Display 5.10 Vertical Bar Chart Output

Inserting Date and Time Stamps in Titles and Footnotes

As discussed in the “Using the Report Engine” chapter of Getting Started with
SAS/ASSIST, you can add titles and footnotes to your report by selecting Titles or
Footnotes from the Edit menu of the Report Engine window. You can use the macros
&CURDATE, &CURTIME, and &CURDT to automatically generate the current date,
the current time, or both the current date and time, respectively, for your output.

In the value field for each line of the title, type the text and the macro you want to
use. An example of an edited TITLES window is shown in the following display.
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Display 5.11 Edited TITLES Window

Select close from the File menu. When prompted, select Yes to save the changes.
When you run your report, the &CURDT macro automatically generates both the
current date and time. You can assign a format to the macros &CURDATE,
&CURTIME, and &CURDT in your user profile by using the Date format, Time format,
and Datetime format options for a profile type of REPORT ENGINE. See “Setting User
Profile Options” on page 237 for additional information about user profile options.

You can also edit titles and footnotes by selecting Report Output Manager from the
View menu. In the cmd field next to the report you want to change, type E and press
ENTER. The code for your report appears in the Edit window where you can edit your
titles and footnotes as well as the rest of your report.

Note: Any changes that you make to your report in the Edit window are saved only
if you save your output to an external file or a SAS file. When you save your report in
the Report Engine window, changes made in the Edit window are not saved with your
report. A

Additional Report Engine Options

The Edit menu contains additional options that enable you to customize your report.
This section describes items on the Edit menu that are not discussed elsewhere in this
chapter.
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Grand Totals

The Grand Totals item enables you to display overall totals for the report. You can
display column grand totals or row grand totals.
Follow these directions to display column grand totals.

1 For LIST reports, specify a usage of BREAK, GROUP, or PAGE for a column. For
TABLE reports, specify a usage of GROUP for a column.

2 Specify a statistics usage (such as MIN, MAX, MEAN, and so on) on at least one
column. This statistic will be calculated on that column in each BREAK, GROUP,
or PAGE value and for the overall report.

3 Follow this selection path:Edit » Grand TotalsThe Grand Totals window appears.

Display 5.12 Grand Totals Window

4 Type some identifying text (for example, Overall) in the Column Total field.
Select Text if it is not already selected.

5 Select oK. Run the report.

To display row grand totals, follow the above directions, except use an ACROSS
usage instead of BREAK, PAGE, or GROUP. Also, use the Row Total field to enter your
identifying text.

Note: Sometimes the grand total identifying text does not appear in the report
output. Usually this happens because the line size is not large enough to accommodate
the text. To solve this problem, select Page Layout from the Edit menu and specify a
larger value for Line Size. 2
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Subset Data

The Subset Data item opens the Build a WHERE Clause to Subset Your Data
window, enabling you to apply a WHERE clause to your data when creating your
report. For details on this window, see the “Report Writing” chapter in Getting Started
with SAS/ASSIST.

Limit Output Rows

The Limit Output Rows item opens the Limit Number of Output Rows window,
enabling you to limit the report output to the number of rows you specify. The default is
MAX, or all rows.

Row Title Space

The Row Title Space item is used only for the TABLE report style. Selecting this
item opens a dialog box which enables you to set the width of the row title, that is, the
left column or columns which identify the contents of the row.

Saving Reports

Saving a Report to a SAS Catalog

To save Report Engine window selections for future use, select save As from the
File menu in the Report Engine window. The Save As window appears.

Type a name and, optionally, a description for the report and the catalog where you
want to save the report. Select OK to save the report or Cancel to cancel the save. If
the report name exists, you are prompted to select OK again to write over the existing
report, or you can type a new name for the report. After you name the report, you can
use Save from the File menu to save the report again.

For a list of existing reports, type a ? in the Name field of the Save As window. You
can type S in the c¢md field to select a report from the resulting selection list. For a list
of available catalogs, type a ? in the catalog field. Select the catalog from the
resulting selection list.

Report Engine window selections are saved as type REPORT.

Saving Report Output to a SAS Catalog

To save a report output to a SAS catalog for future use, select Save As from the File
menu in the Report Output window. The Save As window appears.

Type a name and, optionally, a description for the report output and the catalog
where you want to save the report output. Select OK to save the report output or
cancel to cancel the save. If the report output name exists, you are prompted to type a
new name or to select OK again to write over the existing report output.

CAUTION:
If a new entry has the same name as an existing ASSIST entry, you might not receive a
prompt that warns about overwriting an existing entry. If you last saved from one of the
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three windows that has a different type than the one you are currently saving, you
might not receive the warning prompt and your entry will be overwritten. 2

You can view a selection list of existing OUTPUT entries and catalogs in the same
manner as described for reports in the previous section.

Report output is saved as type OUTPUT. You can access your saved output using the
Result Manager or the Report Output Manager. Refer to Chapter 9, “Doing More with
Results,” on page 143 for additional information.

Saving a Report to an External File

Before you save your report to an external file, make sure that the value for the
output window User Profile option is set to Report in your user profile. See Appendix
2, “Customizing SAS/ASSIST Software,” on page 237 for more information.

To save the report to an external file, follow this path from the Report Engine
Window or the Report Output Window:

View » Report Output ManagerThe Report Output Manager window appears as
shown in the following display.

Display 5.13 Report Output Manager Window

Type F (for File) in the cmd field next to the report you want to save and press
ENTER. The Save Task to External File window appears as shown in the following
display.
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Display 5.14 Save Task to External File Window

In the save file to field, type the name of the external file where you want to
store the report and select ok. Select close from the File menu to return to the Report
Engine window.

Saving a Dynamic Report as a SAS Tahle

Dynamic (or drilldown) reports are described in detail in the “Using the Report
Engine” chapter of Getting Started with SAS/ASSIST. You can save the information for
a column in a dynamic report to a SAS table or view. For example, if you select Flight
to see the column values for the aggregation level as shown in the following display, you
can save the data in the report to a SAS table or view.
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Display 5.15 Dynamic Report With Flight Information

To save information from a dynamic report to a SAS table, follow these instructions:

1 Select save As SAS Table... from the File menu. The Create SAS Table/View
window appears.



Doing More with the Report Engine /A Saving a Dynamic Report as a SAS Table 81

Display 5.16 Create SAS Table/View Window

2 In the Name field, type the two-level name of the SAS table or view that you want
to create. If you omit the libname, the table is placed in the temporary WORK
library.

3 Select Table or View for the Type.

4 Select ok. The SAS Table/View Creation Status window appears, as shown in the
following display, indicating that the table or view was created.
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Display 5.17 SAS Table/View Creation Status Window

5 Select view to browse the table or view that you just created. After you have
finished browsing the table or view, select Close from the File menu to return to
the SAS Table/View Creation Status window. Select Goback to return to the
Dynamic Report window.

Opening an Existing Report

To open an existing report from the Report Engine window, select Open from the
File menu. The Open window appears, as shown in the following display.
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Display 5.18 Open Window for Reports

You can type S in the cmd field and press ENTER to select and open a report in the
Report Engine window. To sort the reports, select Sort By from the Vview menu and
select Name, Description, or Date to reorder the reports listed.

Selecting

Other Data

In the Report Engine window, you can select new tables and queries and retain
modified column information. For example, you may have a query that is based on the
AIRLINE.MARCH data file. If you change the format for the Departure date column
from DATE7. to DATEO. for the report and then select another query with a Departure
date column, the new report also uses the DATE9. format.

To select another query or table, fill in the Data and Type fields as described in
“Opening and Using the Report Engine Window” on page 62.

Editing a Graph Interactively

If you create a graph, you can edit the graph interactively. From the Report Output
window, select Edit Report from the Edit menu to invoke the SAS/GRAPH software
interactive graphics editor, as shown in the following display. You must have
SAS/GRAPH software installed to edit a graph interactively. Refer to the online help for
this window for more information.
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Display 5.19 Editing a Graph Interactively

To return to the Report Output window, select Close from the File menu.
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Introduction

This chapter extends the concepts introduced in the “Graphics” chapter of Getting
Started with SAS/ASSIST. Included are discussions of advanced options for bar charts,
pie charts, plots, and maps, and how to change the background color of a graphic.

For most of the tasks presented here, you must have SAS/GRAPH software licensed
and installed. If you do not have SAS/GRAPH software licensed, you can perform some
of the tasks using low-resolution graphics, but many of the advanced options are not
available.

You are encouraged to explore and experiment with the different options. See the
online help for additional information.

Additional Information

For additional information on creating high-resolution graphics, refer to
SAS/GRAPH Software: Reference, Volumes 1 and 2. For additional information on
creating low-resolution graphics, refer to the Base SAS Procedures Guide.

Doing More with Bar Charts

You can use Bar Charts on the Graphics menu to create horizontal or vertical
simple bar charts, stacked bar charts, grouped bar charts, and grouped and stacked bar
charts. In the “Graphics” chapter of Getting Started with SAS/ASSIST, you learned
how to create a bar chart. This section describes some of the more advanced options
available when generating bar charts.

Generating a Bar Chart with the Mean Displayed

In this section you create a vertical bar chart showing the mean weight by age in
the CLASS data set. You choose to have the mean of each bar displayed above the bar,
adjust the fill patterns of the bars, add a title to the chart, and change the font of the
title.

Setting Up the Bar Chart

1 To display the Bar Charts window, follow this selection path:Tasks » Graphics »
Bar ChartsThe Bar Charts window appears.
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Display 6.1 Bar Charts Window

2 Select vertical and 2D.
3 Use the Table button to select the SASUSER.CLASS table.
4 Select Bar values. The Bar/Slice Values window appears.
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Display 6.2 Bar/Slice Values Window

5 Select Mean as the statistic you want the bars to represent. By selecting Mean,
each bar represents the mean of the analysis variable. You must select an analysis
column if you select Sum or Mean as the bar value.

Use the Analysis column button to select the WEIGHT column.
Select OK to return to the Bar Charts window.

Use the chart column button to select the AGE column.

Select OK to return to the Bar Charts window.

O 0 N o

Customizing the Bar Chart with Additional Options and Titles

1 Select Additional options. The Additional Options window appears.
2 Select General options. The General Options window appears.
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Display 6.3 General Options Window

3 Select Mean as the statistic to display above the bars for the vertical bar chart.
4 Select OK to return to the Additional Options window.

5 Select Color and pattern options. The Color and Pattern Options window
appears.
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Display 6.4 Color and Pattern Options Window

6 For the 1ST and 4TH areas, select Cross as the pattern.
For the 2ND and 5TH areas, leave the pattern as Solid.
For the 3RD and 6TH areas, select Empty as the pattern.
The pattern selected by default for the bars is Solid.

If you print a color graphic, you can use colors to distinguish one bar from
another. To display a list of valid colors, type ? in the first position of the Color
field and press ENTER. Select the color you want to use.

7 Select OK to return to the Additional Options window.
8 Select Number of bars. The Midpoint Values window appears.
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Display 6.5 Midpoint Values Window

9 Select Use each discrete chart variable value. The Additional Options
window reappears.

You select Use each discrete chart variable value to display one bar for
each age represented in the CLASS data set (11, 12, 13, 14, 15, and 16). The
default for the number of bars is Let the number of midpoints default,
which lets the procedure determine the number of midpoints (bars) for the chart
column. Each midpoint represents a median of a range of values. In this example,
if you use Let the number of midpoints default, the bars represent the
midpoints of the AGE variable (11.4, 12.6, 13.8, 15, and 16.2).

The window that appears when you select Number of bars is different for
numeric and character chart columns.

10 Select Goback to return to the Bar Charts window.

11 To display the Title 1 window, follow this selection path starting from the Bar
Charts window:Edit » Titles » Title 1
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Display 6.6 Title 1 Window

12 Type Mean Weight by Age as the title for the plot.

Note: Titles carry over from one report or graphic to another. If you do not type a
title and a title was selected previously in the current SAS/ASSIST session, the
previous title automatically appears on your graphic. A
13 Select Font from the Title 1 window.
The Font List window appears.
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Display 6.7 Font List Window

14 Select Italic as the font for Title 1; the Title 1 window reappears.
Select OK twice to return to the Bar Charts window.

Running the Bar Chart

1 Select Submit from the Run menu. The bar chart appears in the GRAPH window.
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Display 6.8 Bar Chart Output

2 To return to the Bar Charts window from the GRAPH window, follow this selection
path: File » Close

Other Bar Chart Options

Three-dimensional Bar Charts

By selecting 3D in the Bar Charts window, you can create three-dimensional bar
charts, as shown in the following example.
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Display 6.9 Three-dimensional Bar Chart Output

Grouping and Stacking

By assigning a column to Stacking column or Grouping column, you can create bar
charts that show more interesting relationship in your data. For example, if you assign
the SEX column to Grouping column in the previous example, you create a bar graph
that separates the data for males and females:
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Display 6.10 Grouped Bar Chart Qutput

Similarly, if you assign the SEX column to Stacking column and use frequency for
Bar values, you can create a bar chart with males and females distinguished in the
same bar for each age:
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Display 6.11 Stacked Bar Chart Output

You can also combine stacking and grouping to create grouped stacked bar charts.

Horizontal Bar Charts

By selecting Horizontal on the Bar Charts window, you can create bar charts with
the bars running horizontally rather than vertically. Grouping and stacking options are
also available for horizontal bar charts. Instead of being able to display a particular
statistic for each bar (as in the vertical bar chart example earlier in this section), you
can select Display statistics on the General Options window (found on the
Additional Options window), which causes statistics to be displayed to the right of the
bar chart.
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Display 6.12 Horizontal Bar Chart Output

Other Options

By choosing items from the Additional Options menu, you can add a reference line to
your bar chart; change the color, size, and font of the label text; change the appearance
of the axes; and change the appearance of the legend.

Doing More with Pie Charts

In the “Graphics” chapter of Getting Started with SAS/ASSIST, you learned how to
create a simple pie chart. This section describes some of the more advanced options
available when generating pie charts.

Creating a Pie Chart

In this section you create a pie chart that shows what portion of the CLASS table
falls into each age group. You select the pattern, labeling, and header options, and
explode a slice.

Setting Up the Pie Chart

1 To display the Pie Chart window, follow this selection path starting from the
WorkPlace menu:Tasks » Graphics » Pie chartThe Pie Chart window appears.
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Display 6.13 Pie Chart Window

2 Use the Table button to select the CLASS table.

3 Use the chart column button to select AGE as the column you want the pie to
represent.

4 Select 2D if it is not already selected.

5 Select Number of slices. The Midpoint Values window appears. The Midpoint
Values window is the same for pie charts and bar charts.

The sizes of the slices are determined by the values of the chart column. If you
have any slices that represent four percent or less of the total pie, these slices are
grouped together automatically into one slice labeled OTHER.

6 Select Use each discrete chart column value; the Pie Chart window
reappears.

You select Use discrete chart column value to display one slice of pie for
each age represented in the CLASS table, that is 11, 12, 13, 14, 15, and 16. The
default for the number of bars is Let the number of midpoints default,
which lets the procedure determine the number of midpoints (pie slices) for the
chart column. Each midpoint represents a median of a range of values. In this
example, if you use Let the number of midpoints default, the pie slices
represent the midpoints of the AGE column, that is 11.4, 12.6, 13.8, 15, and 16.2.

The window that appears when you select Number of slices is different for
numeric and character chart columns.

Setting Additional Options

1 Select Additional options; the Additional Options window appears.
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2 Select color and pattern options. The Color and Pattern Options window

appears. The Color and Pattern Options window is the same for pie charts and bar
charts.

For the 1ST and 4TH areas, select Cross as the pattern.
For the 2ND and 5TH areas, leave the pattern as Solid.
For the 3RD and 6TH areas, select Empty as the pattern.
The pattern selected by default for the pie slices is Solid.

If you print a color graphic, you can use colors for the various pie slices to
distinguish one pie slice from another. To display a list of valid colors, type ? in the
first position of the Color field and press ENTER. Select the color you want to use.

Select Ok to return to the Additional Options window.

Select Labeling options. The Labeling Options window appears.

Display 6.14 Labeling Options Window

6 Select Label slice with percentage of pie, and de-select Label slice with

value of each slice.

You choose the label selections as indicated so that the percent of students in
each age group is shown on the pie. If you leave Label slice with value of
each slice selected, the number of students in each age group (rather than the
percentage) is shown on the pie.

7 Select OK to return to the Additional Options window.

8 Select General slice options. The General Slice Options window appears.
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Display 6.15 General Slice Options Window

9 Select Use automatic heading to generate an automatic title for the chart.

10 To emphasize the slice representing 13-year-olds from the rest of the slices, select
Explode a Pie Slice. The Explode a Pie Slice window appears.
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Display 6.16 Explode a Pie Slice

11 In the Midpoint value field, type
13

and select OK.
12 Select ok and then Goback to return to the Pie Chart window.

Running the Pie Chart

1 Follow this selection path:Run » SubmitThe pie chart appears in the GRAPH
window.
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Display 6.17 Pie Chart Output

Note: Titles carry over from one report or graphic to another. If you do not type a
title and a title was previously selected in the current SAS/ASSIST session, the
previous title automatically appears on this graphic.

If the title Mean Weight by Age appears at the top of the chart, this title
carried over from the bar chart created in the previous section. To delete the title,
from the Pie Chart window select Edit, Titles, and then Reset. A

2 To return to SAS/ASSIST software from the GRAPH window, follow this selection
path: File » Close

Other Pie Chart Options

Pie Chart Display Options

By default, pie charts are two dimensional. However, you can select 3D, Donut, or
Star to produce pie charts as shown in the following examples.
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Display 6.18 Three-dimensional Pie Chart Output
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Display 6.19 Donut Pie Chart Output

Display 6.20 Star Pie Chart Output



106

Doing More with Plots A Chapter 6

Slice Values

By default, pie slices represent the frequency of each value of the chart column. By
selecting Slice values, however, you can make the slices represent one of several
statistics on analysis column for each value of the chart column. For example, using the
CLASS table, you could select the WEIGHT column as an analysis column and Sum as a
statistic; the slices would then represent the total weight of the children of each age as
a percentage of the total weight of all the children.

Additional Options

By Selecting Additional Options, you can
specify the angle of the first pie slice

specify the color used to outline the pie slices
specify the size of the slice assigned to OTHER
specify the color, size, and font of the labels
match the label color with the slice color

o o o o o g

include missing values as a legitimate value for generating a slice.

Doing More with Plots

You can use Plots on the Graphics menu to create simple X * Y plots, X * Y plots by
category, or multiple plots on one set of axes. In the “Graphics” chapter of Getting
Started with SAS/ASSIST, you learned how to produce a simple line plot. This section
describes some of the more advanced plotting options.

Creating a Scatter Plot with the Regression Line Superimposed

In this section you create a plot showing the relationship between the height and the
age of students in the CLASS table, and you leave the points on the plot unconnected.
Additionally, you plot the fitted regression line and upper and lower 95% confidence
limits for an individual prediction.

Setting Up the Plot

1 To display the Simple X * Y Plot window, follow this selection path starting from
the WorkPlace menu:Tasks » Graphics » Plots » Simple X * Y plot
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Display 6.21 Simple X * Y Plot Window

2 Use the Table button to select the SASUSER.CLASS table.
3 Use the vertical axis button to select HEIGHT as the vertical axis column.

The default label associated with the vertical axis column, Height in inches,
is used as the vertical axis label.

4 Use the Horizontal axis button to select AGE as the horizontal axis column.

The default label associated with the horizontal axis column, Age in years, is
used as the horizontal axis label.

Adding a Regression Line and a Title

1 Follow this selection path to display the Regression Method window:Additional
options » Line and symbol options » Interpolation method » Use regression
analysis to plot
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Display 6.22 Regression Method Window

The Additional options item displays different windows depending on the
type of plot you select.

Leave the Type of regression as Linear.

Select Individual for the Confidence limits, and leave the Confidence level
as 95.

Select Ok to return to the Line and Symbol Options dialog box.
Select Plot Symbol.

In the Symbols List dialog box, select a symbol. For this example, Empty circle
is selected.

Select OK, then Goback.
Follow this selection path to display the Title 1 window:Edit » Titles » Title 1
Type Height by Age as the title for the plot.

Note: Titles carry over from one report or graphic to another. If you do not type a
title and a title was previously selected in the current SAS/ASSIST session, then
the previous title automatically appears on this graphic. A

10 Select ok twice to return to the Simple X * Y Plot window.

Running the Plot
1 Follow this selection path:Run » SubmitThe plot of the regression line with the

actual data points and the upper and lower 95% confidence limits for an individual
prediction appears in the GRAPH window.
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Display 6.23 X * Y Plot Output

2 To return to the SAS/ASSIST software from the GRAPH window, follow this
selection path: File » Close

Additional Plot Options

X * Y Plot hy Category

By choosing X * Y Plot by Category instead of Simple X * ¥ Plot, you can add
an extra dimension to your plot. For example, using the SASUSER.CLASS table, and
plotting HEIGHT versus WEIGHT, you can choose AGE as a category column. Each
point on the plot is a different color depending on the age of the child represented by
the data point. You can choose different line and symbol options for each value of the
category column.

Multiple Plots Per Axes

By choosing Multiple Plots Per Axes instead of Simple X * ¥ Plot, you can
specify up to four columns for the vertical axis. For example, using the
SASUSER.CLASS table, you can plot both HEIGHT and WEIGHT versus AGE. For
each plot, you can specify different line and symbol options.

Other Plot Options

By selecting Additional Options, you can

0 Change the color, width, length, style, label, and tick marks for each axis
o Change the range of values for each axis

o Change the symbol, line style, and color of each plot

o Fill in the area under the curve
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Add vertical and horizontal reference lines
Change the color, size, and font of the text
Change the plot frame style and fill color

o o o d

Change the placement and configuration of the legend (Multiple Plots and
Category Plots)

0 Add a second vertical axis.

Doing More with Maps

By using the Maps item on Graphics menu, you can produce two-dimensional maps,
three-dimensional block and prism maps, and surface maps. The “Graphics” chapter in
Getting Started with SAS/ASSIST showed how to create a two-dimensional map. This
chapter describes in more detail the different types of maps and the available advanced
options. You must have SAS/GRAPH software licensed to create maps; there is no
low-resolution equivalent.

Note: Under some operating systems, such as UNIX, the maps in the SAS data
library are in a compressed format and need to be decompressed before you use them.
See the SAS Software Consultant at your site for more information. 2

Types of Maps

Two-dimensional Maps

Two-dimensional maps are flat maps. The analysis column is divided into ranges,
and each region of the map is colored according to what range its value falls into.
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Display 6.24 Two-dimensional Map Output

Block Maps

Block maps are like flat maps, except that blocks are superimposed on each region of
the map. Each block’s height and color represents the range in which the value of the
analysis column for that region falls.
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Display 6.25 Block Map Output

Prism Maps

Prism maps are three-dimensional maps. Each region is colored and “raised” above
“sea level” to a height representing the range in which the value of the analysis column
for that region falls.
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Display 6.26 Prism Map Output

Surface Maps

Surface maps are another type of three-dimensional map. The values of the analysis
column are not divided into ranges; instead, a “spike” is placed on each region of the
map. The height of each spike represents the value of the analysis column for that
region.
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Display 6.27 Surface Map Output

Number of Levels

For two-dimensional, block, and prism maps, the analysis column is divided into
ranges or levels. By default, these levels are calculated automatically. However, by
selecting Number of levels, you can specify how levels are calculated. The three
options are Default number of levels (as described above), Discrete number of
levels, and Enter number of levels (1-12).

0 When you select Discrete number of levels, the analysis column is not divided
into ranges. Each region on the map has its own color, and the height of each
region’s prism or block is determined by the value of the analysis column for that
region.

0 When you select Enter number of levels (1-12), you type a whole number
from 1 to 12; SAS/ASSIST software divides the analysis column into that number
of ranges.

Additional Map Options

Each type of map has a slightly different set of additional options. Select
Additional Options to access the Additional Options menu.
Pattern and Legend Options

For two-dimensional, block, and prism maps, you can specify the pattern and color
for each level, and determine the placement and configuration of the legend.
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2-D and Prism Options

For two-dimensional and prism maps, you can specify the text and boundary colors,
the vertical and horizontal size of the map, treat missing values as a valid level for the
analysis column, and exclude internal political boundaries.

Block Options

For block maps, you can specify the color and pattern of the map surface and blocks,
the size of the blocks (thin, medium, or wide), and all of the options listed for “2-D and
Prism Options.”

Surface Options

For surface maps, you can specify the surface color, the angle of rotation and tilt of
the map, and the vertical and horizontal size of the map.

Changing the Background Color for Graphs

To change the background color and add various other features to graphs, you use
prefix and suffix commands as described in these steps.

1 To display the Device Driver Prefix Commands window, follow this selection
path:Tasks » Setup » Environment » Graphics options » Active graphics
device

The Active Graphics Device window appears.

2 Select briver Management from the Active Graphics Device window. The Device
Driver Management window appears.

3 Select supplemental commands from the Device Driver Management window. The
Device Driver Supplemental Commands window appears.

4 Select Prefix commands from the Device Driver Supplemental Commands
window. The Prefix Commands window appears.
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Display 6.28 Prefix Commands Window

5 Type
goptions cback=color;

where color is one of the following:

black lilac
blue lime
brown magenta
charcoal maroon
cream olive
cyan orange
gold pink
gray purple
green red

rose
salmon
steel
tan
violet
white

yellow

In the Prefix Commands window, you type the SAS statements or system-specific
commands that you want to use. In this step, you use a prefix command to change
the background color of your graphic. In the next step, you use a suffix command
to reset the color to the default after the chart has been displayed and printed.

The prefix and suffix commands remain in effect and are associated with the
active graphics device until you change them, even after you end your SAS
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session. Therefore, if you change the background color for a graph, each graph you
create with that driver uses the new background color until you change the prefix
command.

When you set up prefix and suffix commands, a catalog entry of dev.SOURCE is
created for prefix commands, and a catalog entry of dev.OUTPUT is created for
suffix commands, where dev is the device driver. If the GDEVICEO libref has been
assigned to your personal device driver catalog, the catalog entries are created in
your SASUSER.PROFILE catalog and the catalog is referenced by GDEVICEOQ. If
GDEVICEO has not been assigned, the entries are created only in your
SASUSER.PROFILE catalog.

6 Follow this selection path: File » CloseA prompt appears asking if you want to
save the changes; select Yes.

7 Select suffix commands; the Device Driver Suffix Commands window appears.
8 Type
goptions cback=;

to reset the background color to the default. Resetting the background color
ensures that when you select different drivers in the same SAS session, the prefix
commands of any previously selected drivers are not in effect.

9 Follow this selection path: File » CloseA prompt appears asking if you want to
save the changes; select Yes.

10 Select Goback twice, then OK to return to the WorkPlace menu.

Note: To clear the prefix and suffix commands, access the Device Driver Prefix
Commands window and Device Driver Suffix Commands window as described
above. Delete the commands, then select close from the File menu for each
window. A
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Introduction

This chapter shows you how to use Data Analysis to generate a one-way frequency
table, perform a linear regression, and perform an analysis of variance. You must have
SAS/STAT software licensed to complete most of the tasks that use bata Analysis.

There are many more analyses that you can perform with Data Analysis, but there
is not sufficient space to describe them all in detail here. However, the techniques for
performing data analysis tasks are similar for all tasks. When you have mastered the
techniques described in this chapter, you should have no trouble performing any of the
other analyses.

For more information on using SAS software for statistical analysis, see the
SAS/STAT User’s Guide, Volumes 1, 2, and 3 and the Base SAS Procedures Guide.

Generating a One-way Frequency Table

You can use the Elementary item on the Data Analysis menu to generate frequency
tables. Frequency tables show the distribution of column values and can include
frequencies, cumulative frequencies, percentages of the total frequency, and cumulative
percentages for each level, or distinct value, of the analysis column. In this section you
create a one-way frequency table showing the frequency of use of a seat belt in the
automotive accidents recorded in the HIGHWAY table.
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The one-way frequency table task can generate tables for both numeric and character
columns. However, if you have a numeric column with many distinct values, the
resulting table may not be informative.

Note:  SAS/STAT software is not required to complete this task. A

Additional Information

For additional information on creating frequency tables, refer to “The FREQ
Procedure” in the Base SAS Procedures Guide.

Instructions

1 Follow this selection path:Tasks » Data analysis » Elementary » Frequency
Tables » Generate One-Way Frequency TableThe One-Way Frequency Table
window appears.

Display 7.1 One-way Frequency Table Window

2 Use the Table button to select the SASUSER.HIGHWAY table.
3 Use the Analysis columns button to select SEATBELT as the analysis column.
4 Follow this selection path:Run » Submit
Note: You can select as many analysis columns as you want, up to the number
of numeric columns in the table. A frequency table is generated for each analysis

column. Any columns selected as BY or weight columns are not displayed in the
Select Table Variables window. A
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The frequency table appears showing how often a seat belt was worn in the
automotive accidents recorded in the HIGHWAY table.

Display 7.2 One-way Frequency Table Output

5 Return to SAS/ASSIST software from the Output window. See “Returning to SAS/
ASSIST Windows from the Output Window” on page 9 for more information.

Performing a Linear Regression

Regression analysis is an analysis of the relationship between one dependent column
and one or more independent columns. You can use Regression on the Data Analysis
menu to perform linear regression, logistic regression, and regression for correction
with autocorrelation. When you use the Linear Regression item, you fit linear
regression models by the method of least-squares. In addition, you can use Linear
Regression to generate scatter plots and various diagnostic measures. You must have
SAS/STAT software licensed to complete this task.

In this section, you perform a linear regression showing the relationship between the
oxygen consumption rate of subjects while they run and the time it took for the subjects
in the FITNESS table to run 1.5 miles. You use the 95% individual confidence interval
option to display the 95% upper- and lower-confidence limits for an individual value.

To superimpose a regression line on a plot, refer to “Doing More with Plots” on page
106.

Additional Information

For additional information on performing linear regressions, refer to “The REG
Procedure” chapter in the SAS/STAT User’s Guide, Volumes 1, 2, and 3.
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You can perform other types of regressions, in addition to the linear regression, with
SAS/ASSIST software. For more information on logistic regression, which requires SAS/
STAT software, refer to “The LOGISTIC Procedure” in SAS/STAT User’s Guide,
Volumes 1, 2, and 3. For information on regression with correction for autocorrelation,
which requires SAS/ETS software, refer to “The AUTOREG Procedure” in SAS/ETS
User’s Guide.

Instructions

1 To display the Regression Analysis window, follow this selection path:Tasks »
Data Analysis » Regression » Linear

Display 7.3 Regression Analysis Window

2 Use the Table button to then select the SASUSER.FITNESS table.
3 Use the pependent button to select OXYGEN as the dependent column.

The dependent columns contain the observed values that the regression
equation attempts to predict. The Select Table Variables window displays all the
numeric columns in the FITNESS table except for any columns selected as BY or
independent columns. A separate regression analysis is generated for each
dependent column that you select.

4 Use the Independent button to select RUNTIME as the independent column.

The independent columns contain the values used to predict the dependent
columns. The Select Columns window displays all the numeric columns in the
FITNESS table except for any columns selected as BY or dependent columns.

5 Select Additional options, then Displayed statistics. The Displayed
Statistics window appears.
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Display 7.4 Displayed Statistics Window

6 Select Print 95% individual confidence interval, then select OK to return to
the Additional Options window.
You use the 95% individual confidence interval to display the 95% upper- and
lower-confidence limits for an individual value to reflect not only the variability in
the predicted mean value, but also the variability in a single future observation.

7 Select Regression plots. The Regression Plots window appears.



124 Instructions A Chapter 7

Display 7.5 Regression Plots Window

8 Select Plots of dependent by independent columns.

By choosing to generate a plot for each dependent column with each
independent column, you can detect a nonlinear relationship between columns in
the regression model.

9 Select ok and then Goback to return to the Regression Analysis window.

10 Follow this selection path:Run » SubmitThe analysis appears in the Output
window.
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Display 7.6 Regression Analysis Output

11 Use the scroll bars or the FORWARD command or function key to display the page
of the analysis that shows the 95% individual confidence interval in the 95% CL
Predict columns.
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Display 7.7 Regression Analysis Output (continued)

Individual confidence intervals are referred to as prediction intervals, hence the
word Predict in the output.

12 Access the GRAPH window to see the plot of the dependent by independent
column.
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Display 7.8 Regression Plot Output

13 Return to SAS/ASSIST software from the Output window. See “Returning to SAS/
ASSIST Windows from the Output Window” on page 9 for more information.

Performing an Analysis of Variance

You can use the Anova item on the Data Analysis menu to perform an analysis of
variance (ANOVA). You can construct a simple analysis of variance, analysis of
covariance (ANCOVA), multivariate analysis of variance (MANOVA), and repeated
measures ANOVA. You must have SAS/STAT software licensed to complete this task.

In this section, you perform an analysis of variance on the VENEER table to show
the relationship between the brand of veneer and the amount of veneer that was worn
away during testing.

Additional Information

For additional information on performing an analysis of variance, refer to the GLM
and ANOVA procedures in the SAS/STAT User’s Guide, Volumes 1, 2, and 3.

Instructions

1 To display the Analysis of Variance window, follow this selection path:Tasks »
Data Analysis » Anova » Analysis of Variance
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Display 7.9 Analysis of Variance Window

2 Use the Table button to select the SASUSER.VENEER table.
3 Use the Dependent button to select WEAR as the dependent column.

The dependent column contains the measurements to be analyzed. The Select
Table Variables window displays all the numeric columns in the VENEER table
except any columns selected as BY or classification columns. If you have more
than one dependent column, you can generate a separate ANOVA model for each
dependent column or one multivariate model for the set of dependent columns.

Use the classification button to select BRAND as the classification column.

The classification columns identify analysis groups. The variation in the
dependent column values is analyzed within and across the classification groups to
determine whether or not the classification columns are significant sources of
variation. The Select Table Variables window displays all the columns in the
VENEER table except for any columns selected as BY or dependent columns.

Each classification column is treated as a main effect in the model. You can
modify the ANOVA model to add interactions, nested effects, covariates, and
random effects by using the Additional options item in the Analysis of
Variance window.

Follow this selection path:Run » SubmitThe first page of the analysis appears
showing the class level information.
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Display 7.10 Analysis of Variance Output

6 Use the scroll bars or the FORWARD command or function key to display the next
page of the analysis.
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Display 7.11 Analysis of Variance Output (continued)

Refer to the GLM and ANOVA procedures in the SAS/STAT User’s Guide,
Volumes 1, 2, and 3 for information about interpreting the statistics in this report.

7 Return to SAS/ASSIST software from the Output window. See “Returning to SAS/
ASSIST Windows from the Output Window” on page 9 for more information.

Performing a Repeated Measures ANOVA

Repeated measures designs are characterized by recording several measurements
over time or space on the same experimental unit. This section shows how to perform a
repeated measures ANOVA with SAS/ASSIST software. The first part of the process is
data entry. For this particular example, you apply a logarithmic function to the data
and then you perform the repeated measures ANOVA.

This example uses the data from Example 7 in “The GLM Procedure” chapter of
SAS/STAT User’s Guide, Volumes 1, 2, and 3.

Entering the Data

In this section, you enter the raw data using the Create Data task. For more
information on this task, refer to the “Entering Data Interactively” chapter in Getting
Started with SAS/ASSIST.

1 Follow this selection path:Tasks » Data Management » Create data »
Interactively » Enter data in tabular form The Select a New SAS Table to
Create window appears.

2 In the Table field, type GLMEX7. If desired, select Permanent, select a library in
which to store the table, and select 0K twice. The Define a New SAS Table window
appears.
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3 Define the columns in the new table by editing this window so that it looks like
the following display.

Display 7.12 Define a New SAS Table Window With Columns Defined

You might need to resize the window to see all six rows.

4 Follow this selection path: File » Cloself prompted, select Yes to save the
changes. The FSEDIT window appears.

5 Type the following data into the table. Note that the hist5 column has a missing
value for row 6 (drug=Morphine, depl=N).

Table 7.1 Data for Repeated Measures ANOVA Example

Row drug depl hist0 histl hist3 hist5
(Obs)

1 Morphine N 0.04 0.20 0.10 0.08
2 Morphine N 0.02 0.06 0.02 0.02
3 Morphine N 0.07 1.40 0.48 0.24
4 Morphine N 0.17 0.57 0.35 0.24
5 Morphine Y 0.10 0.09 0.13 0.14
6 Morphine Y 0.12 0.11 0.10

7 Morphine Y 0.07 0.07 0.06 0.07
8 Morphine Y 0.05 0.07 0.06 0.07
9 Trimethaphan N 0.03 0.62 0.31 0.22
10 Trimethaphan N 0.03 1.05 0.73 0.60
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6

Row drug depl hist0 histl hist3 hist5
(Obs)

11 Trimethaphan N 0.07 0.83 1.07 0.80
12 Trimethaphan N 0.09 3.13 2.06 1.23
13 Trimethaphan Y 0.10 0.09 0.09 0.08
14 Trimethaphan Y 0.08 0.09 0.09 0.10
15 Trimethaphan Y 0.13 0.10 0.12 0.12
16 Trimethaphan Y 0.06 0.05 0.05 0.05

Follow this selection path to exit the FSEDIT window:File » Cloself prompted,
select Yes to save the changes.

Calculating Logarithms

In order to minimize correlation between the mean and the variance of the data, the
logarithm of the data needs to be calculated.

1

Follow this selection path:Tasks » Data management » Subset/Copy The Subset
or Copy a Table window appears.

If the active table is not GLMEX7, use the Table button to select it from the
WORK library, or, if you chose to save the table permanently, the permanent
library where you saved the table.

Use the output Table button. In the Output Table or View window, specify

GLM70UT as the name of the output table. Select Temporary or Permanent, as
desired, before selecting oK.

4 Select Define new columns. The Define or Modify a Column window appears.
5 In the Column field, type LHISTO.

6 Select Initialize. The Enter Numeric Expression window appears. Select

17
8
9

Function, then Mathematical functions. The Select Data window appears.
Select LOG(n). The Specify Arguments to a Function window appears.
In the value for parameter field, type HISTO and select OK,

Select Ok twice. The Define New Columns window appears.

10 Select Add new column.

Repeat steps 5 through 10 to create the LHIST1, LHIST3, and LHIST5
columns, using the HIST1, HIST3, and HIST5 columns, respectively, as
parameters. When finished, select Ok (instead of Add New Column) from the
Define New Column to return to the Subset or Copy a Table window.

11 Select Submit from the Run menu. If desired, select OK, then Goback to view the

table; otherwise, select cancel, then Goback.

Performing the Analysis

You are now ready to perform the repeated measures ANOVA.

1

Follow this selection path:Tasks » Data Analysis » Anova » Analysis of
Variance The Analysis of Variance window appears.

If the active table is not GLM70OUT, use the Table button to select the GLM70UT
table.

Use the Dependent button to select the LHISTO, LHIST1, LHIST3, and LHIST5
columns.
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4 Use the classification button to select the DRUG and DEPL columns.

5 Follow this selection path: Additional options » Model effects » Interactions
The Interactions window appears.

6 Select DRUG, then *, then DEPL to construct the DRUG*DEPL interaction. Select OK,
then Goback.

7 Select Analysis type, then Repeated measures, then Factor names and
levels. The Repeated measures Factors window appears.

8 In this window, you specify the repeated factor and the number of levels associated
with that factor. In the first row, type TIME for Factor Name and 4 for Number of
Levels. Select OK.

9 Select Factor Values. The Repeated measures Factor Levels window appears.

10 In this window, you specify the intervals for the repeated factor. In the four active
spaces under Level Values, type 0, 1, 3, and 5. Select OK.

11 Select Factor Transformations. The Repeated Measures Transformations
window appears. In this window, you specify a single-degree-of-freedom contrast.
For descriptions of each transformation, select Help.

12 Select Polynomial, then OK.
13 Select options. The Repeated Measures Options window appears.

14 Select Test within-subject effects to produce an analysis-of-variance table
for each contrast defined by the within-subject factors. Select OK.

15 Select Goback three times to return to the Analysis of Variance window.

16 Select Submit from the Run menu. The results of the analysis appear in the
Output window.

17 If desired, compare these results to those in Example 7 in “The GLM Procedure”
chapter of SAS/STAT User’s Guide, Volumes 1, 2, and 3.
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Introduction

In the “Using Remote Connect” chapter of Getting Started with SAS/ASSIST, you
learned how use SAS/ASSIST software to establish and terminate a remote connection,
upload and download files, and run a SAS/ASSIST task on a remote host. The “SAS/
ASSIST Software Setup” appendix in the same book contains instructions on setting up
a remote configuration. This chapter describes some more capabilities of Remote
Connect.

Additional Information

For additional information on using the Remote Connect capabilities of SAS, refer to
SAS/CONNECT User’s Guide.

Assigning Librefs on Remote SAS Sessions

When you establish a connection to a remote host, the remote host invokes a SAS
session. The remote SAS session has the automatically-defined libraries associated with
it (WORK, SASUSER, and so on), as well as any libraries and options that are defined
by the SAS session’s AUTOEXEC file. See the SAS companion documentation for your
operating environment for more information on AUTOEXEC files.

You might want to assign librefs to libraries on the remote host other than the ones
automatically assigned. You can assign librefs on a remote host using SAS/ASSIST
software by following these directions.

1 Establish the remote connection.

2 Follow this selection path:Tasks » Remote Connect » Transfer Data » Utilities
» Assign librefThe Assign a New Libref window appears.
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Display 8.1 Assign a New Libref Window

3 In the Libref field, type the libref you want to use to reference the library.

4 In the Name of the SAS data library field, type the path to the library, using
the naming conventions of the remote operating environment.

5 Select Remote. If more than one remote connection is open, select the remote
connection to the host on which you want to assign this libref.

6 Select OK.

7 If the libref assignment is successful, a message appears to inform you of this fact;
select Goback to return to the WorkPlace menu. If the assignment is not
successful, select view the log to read the error messages and diagnose the
problem. If you do not understand the error messages, contact the SAS Support
Consultant at your site.

If you find that you are frequently using this method to access the same library, or if
assigning librefs on your remote host requires special options, you should consider
having that library automatically assigned upon startup of the remote SAS session by
adding appropriate LIBNAME statements to the remote host’s AUTOEXEC file.
Contact your SAS Support Consultant for details.

If you are going to download table information (as in the following section) to set up
SAS/ASSIST tasks for remote execution, you must have a library on your local SAS
session that has the same libref as the remote library containing the desired table. You
can assign a libref on the local SAS session by following this selection path:Tasks »
Setup » File Management » SAS Data Libraries » Assign a new libref Give your
new library the same libref as the remote library, and assign it to any library on the
local host.

Note that SAS/ASSIST software will not download table information for a remote
libref.table-name if a table with the same libref.table-name already exists on the local
host. This feature prevents overwriting an existing table. If you need to download table
information for a remote table that has the same libref and table name as an existing
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table on the local host, you can temporarily clear the libref on the local host and then
re-assign it when you are finished. To clear a local libref, follow this selection
path:Tasks » Setup » File Management » SAS Data Libraries » Clear a librefSelect
the libref to be cleared in the Select a Library window and select oK. Alternatively, you
can use the Explorer to change the libref or rename the table.

Setting Up SAS/ASSIST Tasks On Remote Data

The “Using Remote Connect” chapter of Getting Started with SAS/ASSIST showed
you how to use task window selections in a local SAS/ASSIST session and run the task
on a remote host using remote data. However, that process works only if you have a
copy of the remote table on the local host because you need information about the table
stored locally in order to make task window selections. If the table you wish to use is
very large, it may not be practical to download a copy to your local host.

The process described in this section addresses this problem. Using this process, you
can download information about the table (such as column names, types, and formats),
without downloading any data, so that you can make task window selections.
Alternatively, you can download a small portion of the data (a few rows or a subset
based on a WHERE clause) to test the task. Then you can run the task on the remote
host using Remote submit on the Run menu.

Instructions

1 Ensure that you have a remote connection established.
2 Use the Tasks menu to access the desired SAS/ASSIST task window.

3 Instead of using the Table button to select a table, follow this selection path:Run
» Select Remote DataThe Get Remote Data window appears.

4 Select Table. A list of tables on the remote host appears.
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Display 8.2 Select Remote Table Window

This list includes all tables on all libraries which are assigned on startup of the
remote SAS session. If a particular library you are looking for does not appear, the
library is not assigned in the remote SAS session. To assign a libref on a remote
host, follow the instructions in “Assigning Librefs on Remote SAS Sessions” on
page 135, then begin this procedure again from step 1.

Note: 1If you have more than one remote connection open, the Remote Data
window displays only the libraries from the connection most recently established.
If you want to select data from a different remote host, terminate and then
re-establish a connection with the desired remote host. A

Select the desired table. The Get Remote Data window reappears.

By default, this process downloads information about the table only, without
downloading any rows. If you want to download some rows, perform one of these
steps:

0 Select Number of Rows. The Get remote data OBS window appears. Select
All to download all rows, or select Or type number and type a number of
rows to download. Select OK.

0 Select Ssubset Data. The Build a WHERE Clause to Subset the Current
Data window appears. Use this window to construct a WHERE clause. This
window is described in detail in the “Report Writing” chapter in Getting
Started with SAS/ASSIST.

Select oK. The table information and rows, if any, are downloaded and the table
name appears as the active table.

Proceed with the task window selections and run the task by following this
selection path:Run » Remote submit
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Behind the Scenes: Anatomy of a Remote Connect Session

The following table provides a look at what is going on when you establish a Remote

Connect session, set up and submit a task for remote execution, and terminate the
session. Included are technical details on the statements being passed from the local
SAS/ASSIST session to the remote SAS session.

Table 8.1 Anatomy of a Remote Connect Session

Local SAS/ASSIST session
actions: What you do

Remote SAS session
actions: What the remote
host does

Technical details

1  Invoke SAS/ASSIST
software

2  Establish remote connection
(Establish
Connection under
Remote on the Tasks
menu)

3  Open task window with
Tasks menu

4 Select Remote Data from
the Remote menu.

Note: See
“Assigning Librefs on
Remote SAS Sessions”
on page 135 for details
on remote and local
library requirements. A

5  Select Table in Get
Remote Data window; list of
tables appears

6  Select desired table, then
select desired number of
rows and OK in Get Remote
Data window

7 Make task window
selections

n/a

Invokes SAS session

n/a

Sends information on
contents of all tables in all
libraries to local SAS/
ASSIST session

n/a

Downloads table with
user-selected number of
rows (default is 0 rows) or
subset

n/a

n/a

SAS/ASSIST software submits a
SIGNON statement using SAS/
CONNECT script

n/a

SAS/ASSIST software submits a
program in an RSUBMIT block
to the remote SAS session. The
program creates a table
containing information on tables
in libraries assigned on the
remote session (except
SASHELP, LIBRARY, MAPS,
and WORK). Table is
downloaded to local SAS session.

n/a

SAS/ASSIST software submits a
PROC DOWNLOAD statement
with appropriate options in an
RSUBMIT block to the remote
host.

n/a
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Local SAS/ASSIST session Remote SAS session

Technical details

actions: What you do actions: What the remote
host does
8  Select Remote Submit Executes task and returns SAS/ASSIST software submits
from the Run menu any output or messages to task code to remote host in an

the local SAS session

9  Select Terminate Terminates SAS session
Connection under and closes connection
Remote on the Tasks
menu

RSUBMIT block.

SAS/ASSIST software submits a
SIGNOFF statement.

Remote Configuration Management

This section describes how to make changes to an existing remote configuration, how

to delete a remote configuration you no longer need, and how to set the SASSCRIPT

system option.

Adding, Editing, and Deleting Remote Configurations

To add, edit, or delete a remote configuration, follow this selection path:Tasks »
Remote Connect » Edit Remote ConfigurationThe Edit Remote Configuration

window appears.

Display 8.3 Edit Remote Configuration Window
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0 To add a new configuration, select Add; the Create a New Configuration window
appears. Follow the instructions earlier in the “SAS/ASSIST Software Setup”
appendix in Getting Started with SAS/ASSIST to create a new configuration.

0 To edit an existing configuration, type E next to the configuration you want to edit
and press ENTER.

0 To delete an existing configuration, type D next to the configuration you want to
delete and press ENTER. When prompted, select Ok to delete the configuration.

Select Goback to exit the Edit Remote Configuration window.

Setting the SASSCRIPT System Option

When you create or edit a remote configuration, you are asked to select a SAS/
CONNECT script file. SAS/CONNECT script files are normally stored in a location
(directory, folder or data set, depending on the operating environment) specified by the
SASSCRIPT SAS system option. If you have SAS/CONNECT script files stored in a
different location, you might want SAS to search there for SAS/CONNECT scripts. To
set or change the SASSCRIPT system option, follow these directions:

1 Follow this selection path:Tools » Options » SystemThe SAS System Options

window appears

2 Select the symbol next to Communications in the left pane, then select

Networking and encryption. A list of communication-related options appears in
the right pane.

Display 8.4 SAS System Options Window With Networking and Encryption Options

Look in the value field for the Sasscript option to see where the option points.

3 To assign a new value, select Sasscript. (For desktop operating environments,
double-click the sasscript name.) The Modify Value window appears. Type a new
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value in the New value field and select OK. If you do not know the value to enter,
contact your SAS Software Consultant.

4 Select OK to exit the SAS System Options window. Select ASSIST from the
Solutions menu to return to SAS/ASSIST software.
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Chapter Overview

In the “Using the Result Manager” chapter of Getting Started with SAS/ASSIST, you
learned how to use the Result Manager to access, edit, and execute saved tasks. This
chapter goes into more detail on the things you can accomplish with the Result Manager.
In addition, this chapter describes how to save a program to an external file, browse an
external file, and use a script file to execute multiple saved tasks in succession.

By using the Result Manager, you can view saved programs that are generated by
SAS/ASSIST software and learn how SAS statements are used to create programs. You
can edit these programs to customize them for your needs. You can also save multiple
programs in the history file and edit the programs to create applications.

Additional Information

For additional information on saving programs and using the Result Manager, refer
to the “Saving Source Code for Editing and Re-execution” and “Using the Result
Manager” chapters in Getting Started with SAS/ASSIST.

Doing More with the Result Manager

The “Using the Result Manager” chapter in Getting Started with SAS/ASSIST
introduced some of the capabilities of the Result Manager. This section describes the
Result Manager in more depth. You can use the Result Manager window to display and
manage your saved results, such as SAS/ASSIST tasks, SAS output, programming code,
logs, and reports, and SQL code and queries. For example, you can customize the order
and type of entries displayed in the Result Manager window, and you can edit, rename,
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print, copy, file, and delete entries. You can browse and execute program code. You can
build scripts to combine a series of SAS/ASSIST tasks into a single job stream for
processing.

Opening and Using the Result Manager Window

To open the Result Manager window, follow one of these selection paths:Tasks »
Results » Result ManagerTools » Result ManagerThe Result Manager window
appears, as shown in the following display. It lists all of the entries that you have
named and saved to your default catalog.

Display 9.1 Result Manager Window

Note: On some operating environments, the SASUSER.PRIVATE catalog is not
created until a task, source code, output, or other entry is saved. In this case, instead of
the Result Manager window, the Select Member window appears. Select Cancel (twice,
if necessary) and select Goback to exit any warning messages. Perform a task and save
it by selecting save from the File menu before starting this procedure again from step
1. A

The fields in the Result Manager window are described in the following table.
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Table 9.1 Fields in the Result Manager Window
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Field

Description

Catalog

Name

Type

Row

Cmd

Name

Description

Type

Date

Specifies the current catalog name. To change it, type a two-level name.
Alternatively, type a ? to list all possible catalogs, then make a selection from
the resulting Select a Member window.

By default, this field at the top of the display is empty. To search for and limit
the listing to certain entries, type the complete name of an entry or type a
portion of a name with the pattern-matching character %, *, or _. See the
"Using the Result Manager" chapter in Getting Started with SAS/ASSIST for
details on using the pattern-matching characters.

Lists the type of the entry. The default value is ALL. Type a ? to list all
possible selections or type a value directly in the field to limit the display to
certain types of entries.

You can specify any particular type, such as OUTPUT, which shows all the
entries of type OUTPUT. Valid types include QUERY, REPORT, SCRIPT, SQL,
ASSIST, OUTPUT, LOG, SOURCE, MANAGER, GRSEG, PROFILE, and ALL.

Specifies the starting and ending rows of the total rows displayed. You can edit
the value of the starting number to specify which row will be the first row in the
display.

Enables you to manage your entries. Type a ? to list all possible commands that
you can enter in this field. For further details on the commands, see the next
section.

In the window’s listing, Name displays the names of your entries. You can edit
these values using the Rename command as described in the next section.

Describes your entries. You can edit these values using the Rename command as
described in the next section.

Lists the entry type.

Lists the date when the entry was created.

Using Commands to Manipulate Entries

To use the following commands, type the appropriate letter in the cmd field next to
the entry you want to manipulate and press ENTER.

?

displays a list of commands for the cmd field. You can then select from the list to
issue a command.

E (Edit)

opens an entry for editing. The results of this command depend on the type of
entry. For example, selecting the entry FLY, which has the type QUERY, opens the
Query window with the FLY query loaded. Selecting the entry BONUS, which has
the type REPORT, opens the Report Engine window with the report BONUS
loaded. An entry type of ASSIST can be modified and executed within the edit.
Entries of type MANAGER or PROFILE cannot be edited.

B (Browse)

displays the generated source code or the output of the entry for browsing. The
type of entry determines what you browse. Entries of type of MANAGER or
PROFILE cannot be browsed.
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X (Execute)
executes a saved task entry interactively. X is not valid with entries of type LOG,

MANAGER, OUTPUT, PROFILE, or GRSEG. The results vary with the type of
task executed.

D (Delete)
deletes an entry. When you press ENTER, <=== V to Verify DELETE appears in
the Description field as shown in the following display.

Display 9.2 Marking an Entry for Deletion

Type v and press ENTER again to verify that you want to proceed with the
deletion. If you want to cancel the delete operation, press ENTER without typing v.

v (Verify delete)
verifies that you want to delete the entry. When you press ENTER, the DELETE
operation proceeds and the entry is deleted.

R Rename
highlights the name and description fields of an entry for editing, as shown in the
following display.
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Display 9.3 Renaming an Entry

After the fields are highlighted, you can type a new name, a new description, or
both. The name must be no more than eight characters long and must begin with
a letter or underscore (_). To change only the description, move the cursor to the
Description field and begin typing. A description can be up to 32 characters long
and can contain any combination of characters, numbers, and symbols.

Note: Entries of type PROFILE cannot be edited from the Result Manager. A

L (Batch execution)
under z/OS, submits a job for batch processing. Entries of type LOG, MANAGER,
OUTPUT, PROFILE, or GRSEG cannot be executed in batch. For further
information on batch processing, see Appendix 3, “Batch Processing with the
Result Manager (z/OS Only),” on page 243.

F (File)
saves an entry to an external file. Entry types of GRSEG, MANAGER, or
PROFILE cannot be saved to an external file. When you press ENTER, the Save
Task to External File window appears with the name and the description of the
selected entry already filled in, as shown in the following display.
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Display 9.4 Save Task to External File Window

Type a complete pathname in the save file to field. Then select OK to process
the operation or select cancel to cancel it.

P (Print)
prints an entry. Entry types of MANAGER or PROFILE cannot be printed.

¢ (Copy)
copies an entry to the catalog entry you specify, using the description from the
Result Manager window, as shown in the following display. You cannot copy an
entry of type GRSEG or PROFILE.
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Display 9.5 Copying an Entry

s (Select)
opens an entry for editing. The functionality of Select is the same as that for Edit.

Saving Source Code to an External File

SAS/ASSIST software creates source code, with descriptive comments, each time you
perform a task. In the “Saving Source Code for Editing and Re-execution” chapter of
Getting Started with SAS/ASSIST, you learned how to save source code to a SAS
catalog. This section describes how to save source code to an external file.

Instructions

Use the Tasks window to access the desired SAS/ASSIST task.

2 Make task window selections. You do not need to run the task in order to save the
source code.

3 Follow this selection path:View » View sourceThe View SAS Program window
appears with the source code for the report.

4 Follow this selection path to save the source code to an external file:File » Save
As FileThe Save As window appears.

5 If appropriate to your operating environment, select a folder or directory in which
to save the file. Type the filename in accordance with the conventions of your
operating environment.

6 Select ok. If the external file already exists, a message appears prompting you to
type R to replace the existing file with the new file, to type A to append the new file
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to the existing file, or to type ¢ to cancel and not save the program to the external
file. Type the letter corresponding to the desired action and press ENTER.

7 The View SAS Program window reappears with a message indicating the number
of lines written to the external file.

Note: If you have saved a task (catalog type ASSIST) using Save from the task
window’s File menu, you can write the saved program to an external file by typing F in
the cmd field to left of the task in the Result Manager window and pressing ENTER. A

Browsing an External File

This section describes how to browse external files using Edit/Browse on the Data
Management menu. You can browse external files by specifying the filename or fileref of
the external file. To browse the external file, you must have SAS/FSP software installed.

Instructions

1 To display the Browse Data window, follow this selection path:Tasks » Data
Management » Edit/Browse » Browse data

Display 9.6 Browse Data Window

2 Select Browse external file. The Browse an External File window appears.
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Display 9.7 Browse an External File Window

3 In the object to browse field, type the full name, according to your operating
environment specifications, of the external file that you want to browse.

If you have previously associated a fileref with the desired file or directory, you
can type the fileref in the object to browse field instead of the complete
pathname. If you type a directory name in the Object to browse field, a list of
files and subdirectories in the directory appears. You can then select the external
file you want to browse or select a subdirectory to display files in the subdirectory.

You can select carriage-control options to display the external file with
carriage-control characters assumed in the first position of each record and
overprinting options as described.

O Select Nocc to treat carriage-control characters as regular text.

O Select cc to use the native carriage-control characters of the operating
environment.

0 Select FORTCC to use FORTRAN-style carriage control.
0 Select ovP to indicate that the carriage-control code for overprinting is to be
honored.
4 Press ENTER. The external file appears in the FSLIST window.
5 When you are finished browsing the file, follow this selection path to return to the
WorkPlace menu:File » Close » Goback » Goback

Note: You can also access the Browse an External File window by following this
selection path:Tasks » Setup » File management » External files » Browse an
external file ~
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Creating and Executing a Script File

You may want to execute two or more saved SAS/ASSIST tasks in succession. For
example, you may want to run a query and then generate one or more reports. The
Result Manager offers you this convenience.

Use a script file to execute several entries in one jobstream. Scripts can be executed
interactively or, under z/OS, in batch. A script describes what entries you process and
the order of the processing. A script file can be used to execute entries of the types
QUERY, SQL, REPORT, SOURCE, and ASSIST.

To create a new script, use the Create Script window to specify the entry names in
the following form. The entry names are preceded by the entry types as labels.

ASSIST: name
QUERY: name
SQL: name
REPORT: name
SOURCE: name

1 From the Result Manager window, follow this selection path:Tools » Create
seriptThe Create Script dialog box appears.

Display 9.8 Create Script Dialog Box

2 Type the name of the script in the text field. The first character must be alphabetic.

3 Select OK to open the script editor. Type the name of the entries you want to
execute, preceded by their types. The example in the following display specifies
that the entry QMARCH1 of type QUERY is to be executed first, followed by the
entry TEST4 of type ASSIST.
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Display 9.9 Typing the Contents of a Script

Note that the above display is for example purposes only; use your own saved
tasks in your script file.

4 Select close from the File menu. A prompt appears, asking if you want to save
the changes. Select Yes to save the entry and return to the Result Manager
window. The script appears listed in the Result Manager window.

5 To execute the script, type X in the c¢md field next to the script entry.
Note: For z/OS only, you can use the L. command to execute the script in batch. See

Appendix 3, “Batch Processing with the Result Manager (z/OS Only),” on page 243 for
additional information. A
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Introduction to Query and Reporting

This chapter introduces Query and Reporting, a menu-driven interface that is part of
SAS/ASSIST software. You use this interface to query and report on both SAS data and
DB2 data from SAS. Query and Reporting (Q & R) consists of these windows:

Query window, which includes an intelligent Query Manager
SQL Editor window

Report Engine window

Result Manager window

o 0o o o d

Setup window.

Note: The Setup window is titled Query and Reporting: Setup when you access it
through Query and Reporting. It is titled Setup when you access it from the WorkPlace
menu or a task window. The two Setup windows contain different options. A

The Report Engine and the Result Manager are discussed elsewhere in this
document and in Getting Started with SAS/ASSIST. This chapter and the next chapter
describe the capabilities of the other windows.

Additional Information

For more information on performing queries with SQL, refer to “The SQL Procedure”
in Base SAS Procedures Guide.

Query and Reporting provides access to DB2, IBM’s relational database management
system. You must license SAS/ACCESS software and the SAS/ACCESS interface to
DB2 to use this feature. For more information on DB2, refer to either SAS/ACCESS
Supplement for DB2 under z/OS (SAS/ACCESS for Relational Databases) or
SAS/ACCESS Supplement for DB2 under UNIX and PC Hosts, depending on your
operating environment. For general information on relational databases, see
SAS/ACCESS for Relational Databases: Reference.

Querying Data

The Query and Reporting Query window is a menu-driven interface that enables you
to query SAS or DB2 data. You can create queries that access one or more tables or
views. It is not necessary to know your system’s SQL syntax. In the Query window you
can

O create queries on one or more tables or views that you select
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O view, browse, and save the SQL statements that are automatically generated by
the queries

0 save and run the queries

O create SAS tables, DB2 tables, tables from other DBMSs, or flat files from the
queries’ output

o perform inner and outer (left, right, and full) joins that retrieve matching and
non-matching rows from the contributing tables.

The Query window supports subsetting data, arithmetic expressions, and column
functions, as well as group processing and ordering. Queries can contain an unlimited
number of prompts. A prompt displays a window that asks users for values when the
query is executed.

The output from queries can be saved as SAS tables (that is, SAS data files or data
views), as DB2 tables, as tables in any other database for which you have SAS/ACCESS
software licensed, or as external files. The generated SQL code can be browsed, and
queries can be saved for editing in the SQL Editor window.

To select data for your queries, you use the Select window, which is accessed from the
Query window. You select the tables, views, and columns that you use to create your
queries. Then in the Query window, you can customize your queries further. The
following figure illustrates this process.

Figure 10.1 The Query Process

QUERY Window select data Select Window

Use tables to build Select libranes, tables, columns.

queries by using: retum Get information on tables, eolumns.
Browse/edit data.

inner and outer joins
subsets,

expressions,
prompts,
and so on.

Opening the Query Window

To open the Query window, follow this selection path:
Tasks » Data Management » Query » Query and Reporting... » Query
The following display shows the Query window.
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Display 10.1 Query Window

The Query window may contain columns and tables that you selected the previous
time that you used the Select window. To clear the window for selecting different tables
or columns, select New from the File menu.

The data that is available to you from the Query window and that is presented in the
Select window is based on which Query Manager has been chosen and how that Query
Manager is set up, as described in the next section.

Selecting a Query Manager

A Query Manager controls access to your databases. Different Query Managers can
be used to access different databases or different parts of the databases. For example,
different Query Managers can be used to access different SAS libraries or different DB2
subsystems. A Query Manager defines a group of tables or views (SAS or DB2). The
Query Manager maintains information such as the table and column names, indexes,
column types, and relationships. The Query Manager also determines which tables,
views, and columns you can use to build a query in the Select window.

By default, a personal SAS Query Manager, SASQM, is created the first time you
enter the Query window. The default personal Query Manager uses all available SAS
data libraries in the current SAS session except SASHELP and MAPS.

To choose a Query Manager, follow this path from the Query window to display a list
of available Query Managers.

Tools » Select Query Manager

The following display shows a list of Query Managers.
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Display 10.2 Query Manager List

Select the Query Manager you want to choose. For this chapter, the SASQM Default
SAS Query Manager is used. The list of Query Managers shows the Query Manager
name, description, and type. The type of Query Manager can be M for Master, G for
Group, or U for User. In the title of the Query window, the pBMS field shows the type of
Query Manager in use, SAS or DB2, and the name of the Query Manager, for example,
SASQM.

Opening and Using the Select Window

The Select window is part of theQuery window. In this window, you can select the
tables and columns that you want to use to build queries. You can get more information
about the tables and columns in this window, including

O table and column attributes (column labels, lengths, and so on)
0 indexes and key columns

O relations between database tables.

This information is gathered from database systems and additional sources (for
example, third-party vendor data dictionaries) and stored in SAS files for fast access.
This information is used to generate selection lists and to provide additional
information about table and column descriptions, indexes, relations, and so on, between
database tables. These relations are used to join tables in the Query window.
Furthermore, you can browse or edit data interactively.

To open the Select window from the Query window, choose Select. The following
display shows the Select window. In this window, you specify the SAS data libraries or
DB2 authorization identifiers (called creators), tables, and columns that you use to
create your queries.
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Display 10.3 Select Window

The data presented in the Select window is based on which Query Manager has been
chosen and how that Query Manager is set up, as described in the previous section.

You can list your libraries (in DB2, creators), tables, and columns in this window
using one of the following methods:

1 Type names or use pattern-matching characters in fields at the top of the window.
2 Manipulate a vertical listing of libraries, tables, and columns with commands.

Typing Names into the Fields

The Select window has three fields where you can type names or pattern-matching
characters: Library, Table, and Column.

The pattern-matching character (%) appears in Library by default and causes the
library names to be listed below the fields. You can use the following pattern-matching
characters as shown in the following display:

_ (underscore)
matches any single character

% (percent)
matches any sequence of zero or more characters.

You can use pattern-matching characters before or after the characters that you want
to match. You can use one or more pattern-matching characters in a field.



Query and Reporting /\ Typing Names into the Fields 161

Table 10.1 Pattern-Matching Examples

Field Entry

Displays

2
°

AIRLINE
AI%

3NE

$IR%

AIR_INE

all the libraries, tables, or columns, depending on the field where it is
typed

one specific library

one or more libraries that start with Al
one or more libraries that end with NE
one or more libraries that contain IR

a seven-letter library name that starts with AIR and ends with INE and
can have any value in the fourth position.

Searches for the names of the libraries, tables, and columns are fast because this
information is stored in the Select window.

In the following display, AIRLINE is typed in the Library field and a % is typed in the
Table field, so that all the tables for the AIRLINE library are shown.

Display 10.4 Select Window With Pattern-Matching Character

The following table shows other ways to combine the pattern-matching characters

and object names.

Table 10.2 Examples of Ways to Use the Fields

Action

Results

Type the name of a library

The library name is listed.

Type the names of a library and table Both the library and table names are listed.
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Action Results

Type the name of a library and % in Table The library name and all the tables in that library
are listed.

Type the name of a library and % in Table The library name, all the tables, and all of the

and Column columns in those tables are listed.

Type % in all three fields All the library, table, and column names are listed.

Type % in Library and a table name in Table The library name(s) for the table are listed, and
duplicates of the tables are listed.

Type % in Library and a column name in All library and table names for that column are
Column listed.

Using Commands to Manipulate the Listings

Specifying commands in the cmd field next to the listed libraries, tables, and columns
enables you to

0 expand or collapse the list of libraries, tables, and columns

O display more information about the tables and columns

O browse or edit the data

O select or deselect tables and columns for your queries.

The following table summarizes the Select window commands that give you more
information about your objects. Examples and more information follow this table.

Table 10.3 Select Window Commands

Cmd Action Description
? List commands Lists all possible commands.
+ Expand Shows the tables of a specific library or the columns of a specific

table. When columns are listed, any indexes defined on those
columns are indicated in the Index field.

- Collapse Returns to the previous level; for example, returns from listing the
columns to listing just the table names.

S Select For a table or column, selects it for inclusion in a query. Specify S to
select individual columns in a table (rather than selecting the entire
table and then deselecting columns that you do not want).

D Deselect Removes a table or column from the query; it has no effect on the
table itself.

I Info Provides detailed information about a table or column, including its
indexes, relations, and so on.

EL Edit List Edits multiple rows in a table by using the SAS FSVIEW procedure
in edit mode. EL requires UPDATE privileges and SAS/FSP software.

E Edit Rows Edits a table one row at a time by using the SAS FSEDIT procedure.
E requires UPDATE privileges and SAS/FSP software.
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Cmd Action Description

BL Browse List Browses multiple rows of data in a table by using the SAS FSVIEW
procedure. BL requires SAS/FSP software.

B Browse Rows Browses the data in a table one row at a time by using the SAS
FSBROWSE procedure. B requires SAS/FSP software.

Note: You can type as many commands as you want before you press ENTER. For
example, you can type ten S commands to select ten columns and then submit all of
them by pressing ENTER once. 2

Expanding a List to Get More Information

To expand the AIRLINE.MARCH table shown in Display 10.4 on page 161 to list the
columns, type + in the cmd field next to MARCH and press ENTER. The following display
shows the expanded table. Notice that the fields at the top of the display change, and
that columns with composite indexes are indicated.

Display 10.5 Select Window With Expanded List

Type I next to the FLIGHT column to open the Column information window, as
shown in the following display. I can also be used with tables or columns listed in the
Query window and its subwindows.
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Display 10.6 Column Information Window

In this example, the Column Information window displays the full column name, its
label, and other column attributes.

The following table gives more information about each field in the Column
information window:

Table 10.4 Column Information Fields

Field Description

Column Fully qualified name for the column.

Label Label for the column.

Type Data type for the column.

Length Width of the column.

Format (SAS only.) Column format.

Nulls (DB2 only.) N means that the column cannot contain NULL values. ¥

means that the column can contain NULL values.

Description Additional information about the column.
Index Name(s) of the index(es).
Usage (SAS only.) simple means an index based on a single column.

Composite means an index based on two or more columns.

Cluster (DB2 only.) ¥ means that the index is a cluster index. N means that
the index is not a cluster index.
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Field Description
Unique Whether the index is unique.

Yes (SAS only) means that the index is unique.

D (DB2 only) means that duplicates are allowed.

U (DB2 only) means that the index is unique.

P means that the index is primary key and unique.
Order (DB2 only.) A means ascending, D means descending.
Columns Columns that contribute to the index.

If information does not apply to a field, the field is left blank. Some fields do not
apply to views. If a > sign appears in a field, select it to see additional information.
Select Close from the File menu to return to the Select window.

From the Select window, type I next to a table name to open the Table information
window. This opens a window that is similar to Display 10.6 on page 164. The following
table lists information about each field in the Table information window.

Table 10.5 Table Information Fields

Field Description

Table Name of the table or view.

Label Description of the contents of the table.

Created (SAS only.) Date when the table was created.
Modified (SAS only.) Date when the table was last modified.

Primary Key

Description
Database

Tablespace

Columns

Pages

Rows

Type
Relation

References

Foreign key(s)

(DB2 only.) Column(s) that make up the table’s primary key, if the key
is defined.

Additional information about the table.
(DB2 only.) Name of the DB2 database where the table resides.

(DB2 only.) Name of the DB2 table space within the database where
the table resides.

(SAS only.) Number of columns in the table.

(DB2 only.) Number of pages (typically of 4Kb) that the table uses. This
value is -1 if no statistics have been gathered or if it is a DB2 view.

Number of rows in the table. For DB2 only, Rows is -1 if no statistics
have been gathered using the DB2 RUNSTATS utility.

For SAS, DATA or VIEW. For DB2, T means table, V means view.
Names of referential constraint(s) in the table.

Column(s) in the current table that reference the columns of the
referenced table.

(DB2 only.) Column(s) in the current table that reference the primary
key of the referenced table.

If information does not apply to a field, the field is left blank. Some fields do not
apply to views. If a > sign appears in a field, select it to see additional information.

Note: The Information windows are data specific and may vary depending on the

data being queried. A
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Depending on the setup at your site, you may be able to access additional
information about a column or table by selecting Additional Information from the
View menu. Select Goback to return to the Column Information or Table
Informationwindow from the Additional Information window. The ability to retrieve
additional information is controlled by the Additional Information User Profile
option. See Appendix 2, “Customizing SAS/ASSIST Software,” on page 237 for details.

Select close from the File menu to return to the Select window.

Selecting Tables and Columns for Queries

To select tables and columns for inclusion in your queries, type S next to the table or
column name or names in the Select window. You can type as many commands as you
want before you press ENTER.

When you select a table name, you automatically select all of the columns in that
table. Asterisks (*) appear next to the table name and all of the columns.

If you want only a subset of the columns, type D (for deselect) next to the previously
selected columns that you want to omit. The asterisk next to the name is removed. You
can also use D to deselect a table. Or you can specify S to select individual columns in a
table (rather than selecting the entire table and then deselecting columns that you do
not want).

The following display shows the AIRLINE.MARCH table after it has been selected
and some of its columns have been deselected.

Display 10.7 Columns Selected for the Query

Using the View Menu to Manipulate Columns

You can use the items on the view menu in the Select window to display all the
columns or just selected columns, and to deselect columns. You can also use this menu
to display the column names or column labels. You can use these menu items instead of
the commands.
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Show » All
Displays all the columns in the table(s).

Show » Selected
Displays only selected columns in the table(s).

Deselect All Columns
deselects the table(s) and all the columns.

Show Column » Labels
Displays the columns’ labels instead of the names.

Show Column » Names
Displays the columns’ names instead of the labels.

The show item has two choices that act as a toggle. If you choose Selected, only the
columns you have selected are displayed. The search fields are shown in another color
or are “grayed out.” Choose A1l to show all columns and to be able to type names in the
Library and other fields at the top of the window.

Browsing or Editing the Selected Tahle

If you have SAS/FSP software installed at your site, the Select window also enables
you to display the data that you have selected. To browse the data, in the cmd field next
to a table name, type B (to browse one row at a time) or BL (to browse multiple rows).
The following table shows the AIRLINE.MARCH table that is displayed by using B. All
of the table’s columns are displayed, not just the columns selected for the query.

Display 10.8 Browsing the AIRLINE.MARCH Table

Note: For z/OS only, settings of the Table Browse and Table Edit options in your
User Profile can affect your ability to browse or edit DB2 tables in the Select window
(see Appendix 2, “Customizing SAS/ASSIST Software,” on page 237) . A
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To display a subset of the data, from the Browse window, select Where from the
Search menu, specify a WHERE clause, and select oK. Select where again and Ok
without a where clause in the Where window to clear the clause. To edit or update the
data in a table that you have selected, type E (to edit one row) or EL (to edit multiple
rows) beside the table name in the Select window. You must have UPDATE access to
the table to open it with these commands. Select close from the File menu to exit the
EDIT or BROWSE window.

After you have selected the tables and columns for queries, you can build your
queries, customize them, and run the queries.

Updating a Query Manager

A Query Manager can be static or dynamic. A static Query Manager gives you quick
access to information about the structure of your SAS or DB2 tables. However, a static
Query Manager requires that you update the Query Manager tables when the structure
of the tables changes, for example, when new tables are added to your SAS data
libraries or when new columns are added to the tables.

A dynamic Query Manager always reflects the most current structure of the SAS or
DB2 tables to which you have access in your SAS session. For example, if you add new
tables (SAS data sets) to your SAS data libraries or add new columns to your tables,
these changes are automatically reflected by the dynamic Query Manager. However,
information about the structure of the tables is displayed more slowly when you use a
dynamic Query Manager.

If you use a static Query Manager, you should update your Query Manager
periodically to reflect the most current structure of your tables. The time stamp in the
title line of the Select window shows when the static Query Manager tables were last
updated.

To update the Query Manager, select Update Query Manager from the Tools menu
of the Select window. The Create/Update Query Manager Tables window appears.

Display 10.9 Create/Update Query Manager Tables Window
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If a Query Manager creation program has been defined, you can select Create to
execute this program. The program updates your Query Manager to reflect the current
structure of your tables. The name of the program that is used to update the Query
Manager tables is shown in the Create/Update Query Manager Tables window.

The decision to make a Query Manager static or dynamic is normally made by the
designer of the Query Manager, usually a system administrator. Contact your SAS
Support Consultant for details.

Building a Query

To build a query on the table that you have selected, you must first return to the
Query window; from the Select window, choose Close from the File menu. Any tables
that you have selected in the Select window are displayed in theQuery window, as shown
in the following display. <UNTITLED> appears in the Query window name because you
have not given your query a name yet (you do so later in “Saving a Query” on page 181).

Display 10.10 Query Window With AIRLINE.MARCH Table

The Query window assigns aliases to the tables and columns. An alias is a
temporary, alternate name for a table. If you select two tables that have columns with
the same name, the aliases are used so that you can distinguish them. In the previous
display, the AIRLINE.MARCH table is assigned an alias of A.

If you chose one table in the Select window, Subset and Expression are displayed.
If you select multiple tables, Join is also displayed in the window.

If your query has many columns or several tables so that the list of columns extends
beyond one display of this window, you can see the other columns in one of two ways:

0 Scroll forward (down) or backward (up) by using the View menu items.

o Change the numbers in the ranges above the listed columns and tables. For
example, the AIRLINE.MARCH table in the previous display shows this range:
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1 to 7 of 7 l1tolofl

The range on the left refers to the columns in the table. This example shows
selected columns for the query on AIRLINE.MARCH. However, if you had many
columns in your table, you could specify the first number of the range in the first
field. For example, if you have 27 columns in the table, and you change the first
number in the left range to 5 and press ENTER, the range changes to 5 to 20 of
27. Columns 5 to 20 are displayed in the window. The total number of columns in
the table does not change.

The range on the right refers to the number of tables in the query. Again, you
can specify the first number of the range that you want to see. The total number
of tables does not change.

To see the SQL that has been created by selecting columns from the
AIRLINE.MARCH table, select Show SQL from the view menu. The first page of the
SQL code is shown in the following display.

Display 10.11 Show SQL Window

This window also has a range so that you can scroll to a particular line of code.
Select close from the File menu to return to the Query window.

To run this query, within the Query window, select Submit from the Run menu. The
following display shows the results.
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Display 10.12 Query Results

When you return to the Query window, a message indicates how many rows were
retrieved.

Note: You can use the Report Engine window to enhance the report, as described in
Chapter 5, “Doing More with the Report Engine,” on page 61. Select Report Engine
from the view menu to go directly to the Report Engine window. A

Customizing Your Query

You can customize your query by re-ordering the columns, applying aggregate
(summary) functions to the columns, retrieving a subset of the data, setting up a prompt
for queries, or adding fields that include arithmetic expressions to the selection list.

Using the Cmd Field

The cmd field accepts these commands:

I Displays information about the column, as described in “Expanding
a List to Get More Information” on page 163.

D Permanently deselects (excludes) one or more columns from your
query.

R Repeats the row, adding the duplicate after the row to be repeated.

? Displays a list of available commands.

Using the No Field

Although the No field (abbreviated from “Number”) does not accept commands, you
can use it to perform these actions:
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1 Blanking out or “erasing” a number in this field omits the column temporarily
from the query. The omitted column moves to the bottom of the column list. You
can retype the number to select the column again.

2 Typing a new number over a current number reorganizes the column order
accordingly. For example, if you want A.NONREV to be the first column in Display
10.10 on page 169, type 1 in the No field next to A.NONREV and a different number
for A.FLIGHT (the previous Column 1). When you press ENTER, the columns are
reordered.

Using the Order Field

The order field accepts these commands:

A Organizes the data within each column in ascending order, that is,
in numeric order or alphabetic order from A to Z.

D Organizes the data within each column in descending (reverse) order,
such as the highest miles traveled to the lowest miles traveled.

? Displays a list of available commands.

You can designate one column as A and another as D within the same query. If you
want the sorting order (ascending or descending) to be different from the column order,
you can combine a letter (A or D) with a number in the order field. This affects only the
query’s output and not the ordering of any columns in the Query window.

For example, to list the dates and departure times in the AIRLINE.MARCH table in
ascending order, you specify Al next to the A.DATE and A2 next to A.DEPART. This
would have the same effect as if you wrote the following SQL query:

select a.depart, a.date
from airline.march a
order by a.date asc, a.depart asc;

Using the Usage Field

The Usage field accepts several commands that apply summary (aggregate) functions
on the values in the designated column as shown in the following table.

Table 10.6

Command Function

GROUP Groups data by the values in the column

SUM Computes the sum of values in the column

MIN Lists the lowest value (minimum)

MAX Lists the highest value (maximum)

MEAN Averages or finds the mean of values in the column; equivalent to AVG
AVG Averages or finds the mean of values in the column
COUNT Counts the number of distinct, nonmissing values
N Counts the number of distinct, nonmissing values
css Reports the corrected sum of squares

cv Returns the coefficient of variation (percent)



Query and Reporting A Customizing Your Query 173

Command Function

NMISS Reports the number of missing values

PRT Reports the probability of a greater absolute value of Student’s ¢
RANGE Reports a range of values

STD Shows the standard deviation

STDERR Returns the standard error of the mean

SUMWGT Returns the weighted sum

T Returns the Student’s ¢

uss Returns the uncorrected sum of squares

VAR Returns the variance

When you use summary functions in queries, columns with no usage are treated as if
they have GROUP usage. With SAS data, use the Grouping in summary User Profile
option to specify which action to take when using summary functions in queries. If you
set this option to Pop-up, you are prompted whether or not to apply the GROUP usage
to all columns. If you set this option to Yes, the GROUP usage is automatically applied
to all columns. If you set this option to No, the GROUP usage is not applied to any
columns. See Chapter 9, “Doing More with Results,” on page 143 and Appendix 2,
“Customizing SAS/ASSIST Software,” on page 237 for additional information. Note that
in DB2 queries, the GROUP usage is always applied to all columns.

Retrieving a Subset of Data

To retrieve some but not all rows of data in a query, apply subsetting criteria to the
data. In this example, you apply a subsetting criterion that retrieves information about
flights that were filled to at least three-quarters capacity.

1 Select Subset from the Query window to open the Subset Rows window. In this
window, you specify your subsetting criteria (also called WHERE predicates). Do
not include the word WHERE.

2 On the first line, type the following:
(boarded+transfer+nonrev)>=(0.75*capacity)

The following display shows the edited Subset Rows window.
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Display 10.13 Subset Rows Window

Note that if only one table is selected for the query, the alias is not required for
identifying columns in the Subset Rows window.

3 Follow this selection path to save your subset criteria and return to the Query
window:File » CloseThe word Specified appears under Subset, so you know
that selection criteria have been applied to this query.

If you do not remember the name of a column, you can choose it from a selection list.
Position your cursor in your subsetting criteria where you want the column name.
Select Add Column Name from the Edit menu. A list of columns in the current tables
appears. First select a table from the list, and then select a column name. The column
name is added to your subsetting criteria.

Using the Prompt Facility

You can use prompts to run the same query several times on different subsets of
data. When you run a query with a prompt, a window opens where you type a subset
value. The rest of the query is then run with this value. Prompts give you more
flexibility in customizing your program.

The following steps show you how to create a prompt window. In this example, you
create a prompt that asks for a time value. The prompt is used to return only rows with
a departure time of or earlier than the user-supplied time value.

1 Re-open the Subset Rows window.
2 On the second line, type the following:

and depart<=&promptn

O and is a logical operator that specifies that both of the criteria must be met for
the row to be included in the output. Other logical operators are or and not.

O &promptn is the name of the prompt. The prompt name must be seven
characters or fewer and must be preceded by an ampersand (&).
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The following display shows the edited Subset Rows window.

Display 10.14 Adding a Prompt to the Subset Rows Window

3 Select Prompt from the Run menu. The Query Prompt Design window appears.
4 Fill in the fields as shown in the following display.



176 Customizing Your Query A Chapter 10

Display 10.15 Query Prompt Design Window

The pefault value field is optional; if used, this value appears in the prompt
window for the user to either accept or overwrite.

5 Select OK to return to the Subset Rows window.
6 Select close from the File menu to return to the Query window.

You can create an unlimited number of prompts for a query. You can use a prompt to
substitute any part of the subsetting criteria, such as a logical operator (AND, OR,
NOT), and you can use SAS macro functions.

Note: The prompt facility is also available from the SQL Editor window and from
the Query Expression window. A

Defining an Expression

An expression uses column names, functions, or constants to compute a result. The
expression creates a new column in the query. In this example, you create a column
that contains the number of paying customers on each flight.

1 Select Expression from the Query window. The Query Expression window
appears.

2 The expression is called EXP_nnn by default. If desired, change it by typing over
the name in the Expression field. You can change the data type in the Column
type field by typing over the default value or by typing a ? in the field to display a
selection list of data types. You can also supply values for the Format and Label
fields.

Add your expression below the Label field as shown in the following display.
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Display 10.16 Query Expression Window

Note that if only one table is selected for the query, the alias is not required
when identifying columns in the Query Expression window.

The previous display shows the Query Expression window filled in, with the
name changed to PAY_CUST, the column type as NUMERIC, a LENGTH of 8, and
the label “PAYING CUSTOMERS” assigned. An expression to calculate the
number of paying customers is added after the label.

If you do not remember the name of a column, you can choose it from a selection
list. Position your cursor in your expression where you want the column name.
Select Add Column Name from the Edit menu. A list of columns in the current
tables appears. First select a table from the list and then select a column name.
The column name is added to the expression.

3 Select close from the File menu to return to the Query window. The word
Specified appears under Expression to indicate that an expression has been
applied to this query, and the new column, PAY_CUST, appears in the list of
columns.

The next time you select Expression from the Query window, a list of expressions
appears; select an expression to modify or select <NEW> to create a new expression.
Alternatively, you can edit an expression by typing I in the cmd field next to the
expression name.

You can add unlimited expressions to a query. To delete an expression, select
Expression from the Query window and select the expression to be selected. From the
Query Expression window, select Clear from the Edit menu. Alternatively, delete the
column in the Query window by typing D in the cmd field next to the expression name.
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Viewing the SQL Code, Running the Query, and Refining the Output
Viewing the SQL Code

As you make changes to a query, the SQL code changes. You can browse the code by
selecting Show SQL from the View menu in the Query window, the Subset Rows window,
the Query Expression window, or the Join Manager window.

The SQL code in the following display is based on the query on the AIRLINE.MARCH
table constructed in the previous sections. Scroll down to see the changes.

Display 10.17 Show SQL Window

Select close from the File menu to return to the Query window.

Running the Query

1 To run the query, follow this selection path from the Query window: Run »
SubmitThe Prompt window appears.
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Display 10.18 Prompt Window

For this report, specify '9:00't, Make sure to use single quotation marks ()
around the date value, and include the t after the closing quote to convert the
time to a SAS time value.

2 Press ENTER. The query returns your output.

Display 10.19 Query Results
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Refining the Qutput

To enhance the appearance of your report, make the following changes:

1 From the Report Output window, select Titles from the Edit menu. Add the title
Information on Early Morning Flights. Select Close from the File menu;
when prompted, select Yes to save the changes to the Titles window.

2 Select page Layout from the Edit menu. If the Date value is YES, set it to NO to
remove the date and time listing in your report. Set the center value to YES,
which centers the title. Select OK.

Select close from the File menu to return to the Query window, then re-run the
query by selecting Submit from the Run menu. The following display shows the
modified report output.

Display 10.20 Query Results With Refinements

Select close from the File menu to return to theQuery window.
To save your output as a SAS or DB2 table, see “Creating New Tables” on page 182

Limiting the Report’s Output

If you anticipate that your report may have many rows of output and you need to see
only some of them, you can limit the number of rows processed. Doing so might also
shorten the time the query runs, unless you have used summary (aggregate) functions
that must be computed on every row in the query.

To limit the number of rows in your output before you run the query, select Limit
Output Rows from the Edit menu of the Query window. The Limit Number of Output
Rows window appears.
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Display 10.21 Limit Number of Output Rows Window

The default value is MAX. Type the number of rows that you want to display and select
OK.

When you exit the window, be aware that the specified limit always limits the
number of rows displayed in the Report Output window. It also limits SAS or DB2
processing unless the query contains summary functions that force processing of all
rows of the table(s) before returning the output to SAS.

If a limit has been placed on the number of output rows in your User Profile, you
might be prompted when a query is run. A prompt window appears, verifying that you
want to limit the number of rows to be output when this option has been selected in
your profile. Type s to stop at the specified number of rows, or ¢ to ignore the limit, and
press ENTER. This feature is controlled by the User Profile options Limit output
rows and Limit Rows Pop-up Window (see Appendix 2, “Customizing SAS/ASSIST
Software,” on page 237).

Saving a Query

The Query window remains untitled until you save a query by using Save or Save
As from the File menu. When you save a query, you give it a name and, optionally, a
description. After the query is named, its name appears as part of the Query window
title. To save and name your query, select Save As from the File menu in the Query
window. The Save As window opens. Type the name of the query and a short
description. Change the default catalog if you want and select ok. When you return to
the Query window, the name of your query is displayed after the window title.

Saved queries can be used to create reports with the Report Engine. See Chapter 5,
“Doing More with the Report Engine,” on page 61 for more information.
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Resetting the Query Window

To reset the Query window in order to build another query, select New from the File
menu. Doing so clears all existing data and specifications from the Query window. To
start another query, choose select to open the Select window.

Performing a COUNT(*) on a Table

In order to display the number of rows returned by a query (that is, to perform a
COUNT(*) on the table), follow these instructions:

1 Use the Select window to select tables and columns for the query.

2 Modify the query with subsets, expressions, repeated and deleted columns, and
usages as desired.

3 Follow this selection path:Edit » Count(*)Query and Reporting creates an
expression called COUNT (*) with a usage of *. This expression appears in the
Query window.

4 Select Submit from the Run menu. If you have not applied a usage to all columns,
a prompt appears asking you if you want to apply a GROUP usage to all columns.
Select Yes or No. The output includes a count of the returned rows.

5 Select close from the File menu to return to the Query window.

To perform a COUNT DISTINCT(*) on a table:
1 Use the Select window to select table for the query.

2 From the Query window, select Expression and specify * as your expression. Give
the expression a name and select Close from the File menu to return to the
Query window.

3 Delete the numbers in the No column for all columns, except the new expression,
to remove them from the output.

4 Select submit from the Run menu. The output shows the number of distinct
nonmissing rows for the entire table.

5 Select close from the File menu to return to the Query window.

To perform a COUNT(*) within a group:
1 Use the Select window to select tables and columns for the query.

2 From the Query window, select Expression and specify * as your expression. Give
the expression a name and select close form the File menu to return to the
Query window.

3 Specify the GROUP usage for the column of interest. Delete the numbers in the No
column for all columns except the new expression and the column of interest.

4 Select submit from the Run menu to run your query. The output shows the
number of distinct values (groups) in the column of interest.

5 Select close from the File menu to return to the Query window.

See Chapter 5, “Doing More with the Report Engine,” on page 61 for more
information on the Usage field.

Creating New Tables

You can create a table from a query using the SQL Editor window or the Query
window.
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In all operating environments, you can create SAS tables and views. In z/OS, you can
also create DB2 tables. In some cases you must be granted certain access or privileges
to create new tables. If you do not have these privileges, contact your SAS Support
Consultant or database administrator.

To create a table from your query results, run your query, then return to the Query
window by selecting Close from the File menu. Follow the instructions in one of the
following two sections, depending on which type of table you want to create.

Creating a New SAS Table or View

Follow these steps to create a new SAS table or view from your query results:

1 Follow this selection path from the Query window:Tools » Create Table »
SASThe Create SAS Table/View window appears.

2 In the Name field, type the name of the table or view. Use a two-level name in the
form libref.table-name if you want to store the table or view permanently.

3 Select Table or View. Table creates a SAS data file; view creates a PROC SQL
view.

4 When you select OK, the query is processed and a window verifies the SAS table’s
creation, as shown in the following display.

Display 10.22 SAS Table/View Creation Status Window

5 Select view to display the new SAS table, or select Goback to return to the Query
window.

Creating a New DB2 Tabhle (z/0S Only)

In z/OS, to save the results of your query to a DB2 table, do the following:
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1 Follow this selection path from the Query window:Tools » Create Table »
DB2The Create DB2 Table window appears.

2 In the Name of DB2 table field, type the name of the table.

3 Select ok SAS/ASSIST software verifies whether or not the table exists; if it does,
you are prompted to append or replace it. The new table is created, and its
authorization ID is automatically set to your userid.

Note: If you plan to use DB2 data in several SAS programs, you usually get better
SAS performance if you save the DB2 data to a SAS table or SAS view. 2

Joining Tables

You often need data that are stored in separate tables. For example, you may want
to produce a report that gets information about flight delays from one table and
boarding capacity from another. Information from separate tables can be combined by
matching values in columns that relate the tables. This is called joining tables. You can
join a maximum of 32 tables (including views) in one query. Note that some limitations
apply when you join DB2 tables. For more information, see “Additional Considerations
for Joining DB2 Tables” on page 198.

Introducing Table Joins

A join combines two or more tables side by side. If you do not specify how to join the
tables, you get a Cartesian product. This means that SQL combines each row from the
first table with every row from the second table, the second row of the first table is then
matched with every row of the second table, and so on. Therefore, two tables with 100
rows each produce 100 * 100, or 10,000, rows. You seldom want all this information,
and it often causes you to exceed the available disk space.

To avoid a Cartesian product, you must specify how the tables should be combined.
Typically, you want to pair rows based on matching values in one or more key columns
of each table. The following example uses the tables in the following figure to illustrate
a join.

Figure 10.2 Joining Two Tables

Pair the SALARY information in Table B with the NAME of the person in Table A by
matching the values in the ID columns. Therefore, your join criterion is A.ID=B.ID. In
SQL, the code is:
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select name, salary
from a, b
where a.id = b.id;

Only rows with matching values of ID are output. This is known as an inner join.
The following figure shows the results of this query.

Figure 10.3 Output from Joined Tables

You can also join tables that have missing values. For example, ID 3 is missing from
Table B. A left join outputs all the names in Table A (the left table) and matches them
to the available salary information in Table B. If a row in Table B is missing, missing
values are supplied in the joined output. In this case, Michael from Table A is output
with a missing value for SALARY next to his name. The following figure shows the
results of this query.

Figure 10.4 Output from Left Joined Tables

ouUTPuUT
NAME SALARY
Elizsheth 2000
Jens a4}
Michael .
Marie K144

A right join works similarly. All the rows from Table B (the right table) are output,
and any missing rows from table A are output as missing values (or blanks, if the
values are character data). The following figure shows the results of this query.
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Figure 10.5 Output from Right Joined Tables

CouUTPUT
NAME SALARY
Elizabeth 2000
Jens 204
Marie 3000
500
TS50

If you join two tables that both have missing rows, you can combine the effect of a left
and a right join by using a full join. The following figure shows the results of this query.

Figure 10.6 Output from Fully Joined Tables

ouUTPuUT

NAME SALARY
Elizaheth 2000
Jens a4}
Michael .
Marie K144

500

TS0

Inner joins can be performed on up to 32 tables or views at a time, whereas outer
joins (left, right, full) work on only two tables at a time.

Joining Tables Manually

If tables selected for joining have a relation defined between them, Query and
Reporting joins them automatically; see “Joining Tables Automatically” on page 195 for
more information. If the tables do not have a relation defined between them, or if they
have more than one such relation defined, you have to join the tables manually. The
following sections show examples of how to join tables manually in both cases, as well
as an example of performing outer joins, which must be done manually.

Joining Tables Without Defined Relations

Follow these instructions to join two tables manually:
1 Choose Sselect to open the Select window.
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2 Select the AIRLINE.JOBCODES and AIRLINE.PAYROLL tables.
3 Select close from the File menu to return to the Query window.

The Incomplete Inner join message appears under Join. The warning Not
all tables are joined appears because the tables do not contain a relation
defined on them. Therefore, Query and Reporting has not automatically joined the
tables. The following display shows the Query window with the two tables to be
joined.

Note: To clear previously-defined subsets or expressions, select subset or
Expression. Select Clear from the Edit menu, then select Close from the File
menu. A

Display 10.23 Query Window with Tables for Manual Join

CAUTION:
Interrupting Processing If you run a query with an incomplete join, you create a
Cartesian product, as described in “Introducing Table Joins” on page 184.
Depending on the setup at your site, either the query is rejected or a WARNING
window appears, verifying whether or not you really want to run this query. If
you select Yes to run the query, your query may take a long time to process,
depending on the size of the tables. A

4 Select Join to open the Join Manager window. The Join Manager window shows
the selected tables and all of their columns. Before the tables are joined, their
names are highlighted.

Note: If you are joining more than five tables, not all of the table names
appear in the Join window; overwrite the first number in the Tables field to see
more tables. A

The following display shows the Join Manager window with
AIRLINE.JOBCODES and AIRLINE.PAYROLL before they are joined. The Group
field indicates whether groups of tables are joined. 1,2 indicates that this group is
not joined.
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Display 10.24 Join Manager Window With Two Tables To Be Joined

5 Type 1 next to A.JOBCODE and 1 next to B.JOBCODE and press ENTER. Note that
the column names for the two tables are the same in this example. The column
names do not have to be the same, but their data types and values must match.
You can select Sort by from the Edit menu to reorder columns in the tables by
their names, join number, index, or matching names.

After you press ENTER and the tables are joined, the highlighting of the table
names is removed, the Group field changes to 1,1 (indicating one group), and a
message appears saying All tables are joined. The following display shows
the Join Manager window after the tables have been joined.
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Display 10.25 Join Manager Window With Two Joined Tables

Select close from the File menu to return to the Query window. Note that the
message under the Join button says Complete inner join.

Joining Three Tables

To add a third table to the joined AIRLINE.JOBCODES and AIRLINE.PAYROLL
tables, follow these instructions:

1
2
3

Return to the Select window by choosing Select from the Query window.
Select one more table, AIRLINE.SCHEDULE

Select Close from the File menu to return to the Query window. The message
Incomplete Inner join appears again.

Select Join to open the Join Manager window.

The table names are displayed at the top of the Join Manager window.
AIRLINE.SCHEDULE is highlighted because it is not yet joined with another
table. AIRLINE.SCHEDULE has no table alias under the JOINS/relations field
for the same reason. This table is also listed as a separate group in the Group field.

The following display shows the Join Manager window before the third table
AIRLINE.SCHEDULE is joined with AIRLINE.JOBCODES and
AIRLINE.PAYROLL.
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Display 10.26 Join Manager Window With Third Table Before Joining

5 Because the columns from only two tables can be listed at the same time in this
window, the Alias fields are blank and no columns are listed. AIRLINE.PAYROLL
and AIRLINE.SCHEDULE have a common column, IDNUM. Type the alias B in
the first Alias field and the alias ¢ in the second Alias field. When you press
ENTER, the tables’ columns are listed. Type 1 next to B. IDNUM and C.IDNUM,
respectively, and press ENTER.

When the three tables are joined, the highlighting is removed, the Group field

changes to 1,1,1 (indicating one group), and a message appears saying All
tables are joined, as shown in the following display.
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Display 10.27 Join Manager Table With Three Joined Tables

Select close from the File menu to return to the Query window. Save or run
your query. After you run your query, you can save your output to a table. See
“Creating a New SAS Table or View” on page 183 for more information.

Joining Tables with Quter Joins

When you join tables, Query and Reporting uses an inner join by default. However,
you can choose another type of join if you are joining only two tables. In DB2, outer
joins are allowed on only two tables. Note that there may be other restrictions under
DB2; for further information, see “Additional Considerations for Joining DB2 Tables” on
page 198. Outer joins must be performed manually.

1
2
3

9

If desired, save the previous query using Save from the File menu.

Reset the Query window by selecting New from the File menu

Open the Select window and choose the AIRLINE.SCHEDULE and
AIRLINE.SUPERYV tables. These tables do not have a relation defined on them.

Return to the Query window, and note that the Incomplete Inner Join message
appears under Join.

To change this query to a right join, select Join Type from the Edit menu.

Select Right join from the list of join types and Goback. When you return to the
Query window, the Incomplete Right join message appears under the Join
button.

Select Join to open the Join Manager window.

Type 1 in the A.IDNUM column and 1 in the B.SUPID column and press ENTER.
(These steps are described earlier in “Joining Tables Without Defined Relations”
on page 186.)

Return to the Query window.

10 If desired, reorder the columns of the query and then select Show SQL from the

view menu. The following display shows the second display of the SQL for the
right join query.
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Display 10.28 Show SQL Window for Right Join

Exit the Show SQL window.

11 Select Submit from the Run menu to run the query. The following display shows
the results. This query creates a list of supervisors who have been assigned to
flights as well as supervisors who have not been assigned to flights.
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Display 10.29 Results of Right Join

Defining Relations on Tables

When you query SAS tables, relations provide a way to identify rows and to relate (or
join) rows in one table to rows in another table. You define a relation on one or more
columns in a table. Relations are based on the database concept of primary and foreign
keys; see SAS/ACCESS for Relational Databases: Reference for more information.

You define a relation on tables based on one or more columns that tables contain. For
example, the SAS ATRLINE.PAYROLL table has a column named IDNUM that has the
same attributes as the IDNUM column in AIRLINE.STAFF. Therefore, you would
define and name a relation for IDNUM on the two tables.

Defining a relation between or among tables enables you to build intelligence into
your query creation process. When one relation is defined on tables that you join in a
query, Query and Reporting automatically generates a WHERE or ON clause for that
query. This saves you from defining a WHERE predicate for each join query. (See
“Joining Tables Automatically” on page 195 for more information.) You can, of course,
still select subset from the Query window to add other predicates to your WHERE
clause; see “Retrieving a Subset of Data” on page 173 for more information.

If no relations are defined or if more than one relation is defined for the tables in the
join, you must join the tables manually, as described in “Joining Tables Manually” on
page 186 and “Joining Tables with Multiple Relations” on page 196.

The examples in this section are used to demonstrate joining tables automatically
and joining tables with multiple relations later in this chapter.

1 If desired, save the previous query by selecting Save from the File menu in the
Query window.

2 Reset the Query window by selecting New from the File menu.
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3 Go to the Select window and select the AIRLINE.MARCH and AIRLINE.FLINFO
tables. Return to the Query window.

4 Select Join to open the Join Manager window.

5 Type a 1 next to the A.FLIGHT and B.FLIGHT columns and press ENTER. A
message indicates that the tables are joined.

6 Follow this selection path to open the Relations for Current Tables window:View »
Relations » Current Tables

Display 10.30 Relations for Current Tables Window

7 In the Relation name field, type MARFLT. A relation name can be up to eight
characters long.

8 In the Description field, type March - Flight Info Relation. A description
can be up to 32 characters long.

9 Select save to save the relation, then Goback to return to the Join Manager
window.

10 Return to the Query window.

Repeat steps 2 through 9 above to define a relation on the AIRLINE.DEST and
AIRLINE.FLINFO tables. Define your relation on the A.DEST and B.DEST columns.
Name this relation FLDEST and give it a description of Destination Name Join. Then,
repeat steps 5 through 9 to define a second relation on the AIRLINE.DEST and
AIRLINE.FLINFO tables. By typing 2 (instead of 1) next to the columns, define this
relation on the A.DEST and B.ORIG columns. Name this relation FLORIG and give it a
description of Origin Name Join.

Modifying and Deleting Relations

In order to add, edit, or delete a relation, you must have the correct permissions to do
so. Permission to modify relations is determined by the Query Manager in effect.
Contact your SAS Support Consultant for details.
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To modify a relation, follow these instructions:
1 Select the tables associated with that relation in the Select window
2 Select Join to open the Join Manager window.

3 If you want only to change the name or description of the relation, proceed to the
next step. Otherwise, modify the join as desired.

4 Follow this selection path:View » Relations » Current TablesThe Relations for
Current Tables window appears, as shown in the previous display.

5 Type the name of the relation in the Relation name field. You can also type a ?
in the Relation name field and select the relation from the resulting list.

6 Select save. When prompted, select Yes to overwrite the existing relation.

To delete a relation, follow these instuctions:
1 Select the tables associated with that relation in the Select window.
2 Select Join to open the Join Manager window.

3 Follow this selection path:View » Relations » Current TablesThe Relations for
Current Tables window appears, as shown in the previous display.

4 Type the name of the relation in the Relation name field. You can also type a ?
in the Relation name field and select the relation from the resulting list.

5 Select Delete, then Goback to return to the Join Manager window.

Joining Tables Automatically

The Query window can join tables automatically if a relation is defined on the tables.
In addition, as already discussed, relations can be defined either by a DBA or by a user.
(Note that for DB2, if any referential constraints are defined, these constraints are used
by the Query Manager to join tables automatically.)

Query and Reporting automatically joins tables that have exactly one relation
defined on them. The default action is to create an inner join. (See “Joining Tables
Manually” on page 186 for information on joining tables without a defined relation and
for performing outer joins.)

In this section you join the AIRLINE.MARCH and AIRLINE.FLINFO tables on
which you defined a relation in the previous section.

1 Reset the Query window by selecting New from the File window.

2 Open the Select window and select the AIRLINE.MARCH and AIRLINE.FLINFO
tables. Return to the Query window.

3 By convention, relations are a property of the second of the two tables joined, in
this case, AIRLINE.MARCH. To see this property, type I next to the table name in
the Select window. The Table Information window appears, as shown in the
following display.
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Display 10.31 Table Information Window

4 Select close from the File menu twice to return to the Query window. The

message All tables are joined appears in the Query window, and the message
Complete Inner join appears under the Join button.

At this point, you can customize your query, run it, and save it as described in
“Saving a Query” on page 181. Alternatively, you can save the query’s output to a table,
as described in “Creating New Tables” on page 182. If you intend to access the joined
data frequently, it is often more efficient to save the output to a SAS table and then
specify the new SAS table in your SAS code.

Joining Tables with Multiple Relations

Tables with multiple relations must be joined manually because you have to decide
which columns to use to join the tables. This example uses the relations you defined on
the AIRLINE.DEST and AIRLINE.FLINFO tables in “Defining Relations on Tables” on
page 193.

1
2
3

Reset the Query window by selecting New from the File menu.
Open the Select window and select AIRLINE.DEST and AIRLINE.FLINFO.

Open the Table Information window for the AIRLINE.FLINFO table to see the two
relations defined on it.

Exit the Table information window and the Select window to return to the Query
window. The Not all tables are joined message is displayed because you
have not yet selected a relation.

Select Join to open the Join Manager window. The Join Manager window appears
much as it does in Display 10.24 on page 188. The table aliases under the JOINS/
relations field are in lowercase letters. The aliases are lowercase to indicate that
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a relation exists between the tables but that it is not used yet. The following
display shows the tables before they are joined.

Display 10.32 Join Manager Window With Multiple Relations

6 Choose select Relation from the Edit menu, or select one of the lowercase
aliases under the JOINS/relations field to select a relation with which to join.
The relations for your tables are listed. Select Destination Name Join. The
tables are joined and the lowercase aliases in JOINS/relations change to
uppercase. Notice in the following display that a 1 automatically appeared in the
A.DEST and B.DEST fields and the Group field changes to 1, 1.
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Display 10.33 Join Manager Window With Multiple Relations After Joining

Return to the Query window to customize, save, or run your query.

Additional Considerations for Joining DB2 Tahles

When you use the Query window, you can perform inner joins or outer joins (left,
right, and full) on DB2 tables. If one primary key/foreign key relation is defined
between the tables, Query and Reporting joins the related tables automatically. It
generates a WHERE or ON clause that is based on the related column(s) in the tables,
such as where payroll.idnum=staff.idnum.

If no primary key/foreign key relation is defined or if more than one relation exists
between the contributing tables, you must specify manually which columns are used to
join the tables (see “Joining Tables Manually” on page 186).

Versions 4 and later of DB2 includes outer join operators. Therefore, when you use
the Query window and specify a left, right, or full join, Query and Reporting generates
the WHERE or ON clause automatically.

DB2 versions prior to Version 4 lack outer join operators. You can still specify an
outer join type in Query and Reporting. If relations are defined on the tables, a
WHERE or ON clause is automatically generated. If no relations are defined, you have
to join the tables manually. When you review your SQL code (by selecting Show SQL
from the view menu), you see that DB2 SQL has used set operators (such as UNION)
to produce an outer join result, instead of using outer join operators.

Because earlier versions of DB2 SQL do not have outer join operators, certain
limitations apply to outer joins in Query and Reporting:

0 Because you generate a WHERE or ON clause when you join the tables, you
cannot specify additional WHERE predicates or expressions in the SELECT
clause. For example, if you select Subset in the Query window, type a WHERE
predicate, and exit the window, the Messages window appears with Subset is
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disabled due to outer join. Then Disabled appears under Subset. It works
the same way with Expression.

O Arithmetic expressions (such as those in a SELECT clause) are ignored.

0 Results from outer joins cannot be stored in a new DB2 table. (However, you can
save the results to a SAS table.)

The following table shows the default values in outer joins.

Table 10.7 Default Values for Data Types in Outer Joins

Data Type Default Value

Character data blank ()

Numeric Data 0

Date January 1, 0001

Time Midnight

Timestamp January 1, 0001, midnight

Referential Integrity

Referential integrity is implemented in the DB2 database management systems by
specifying conditions where all references from one database column to another column
must be validated.

These referential constraints are established by defining primary keys and foreign
keys for the columns in the relationship. A primary key defines a unique identifier for
the rows of a table. A foreign key is a column where each value contains a value in the
primary key of another defined table. After the relationship between a primary key and
a foreign key has been established, DB2 enforces the referential integrity for you
according to both the rules that DB2 has established and the referential constraints
that you have specified.

If referential constraints have been established, the Select window uses them to
generate automatic joins between tables. In the Query, Select, or Report Engine
windows, you can type the I command next to a table or column name to open the
Select Table information or Column information window. These windows display
information on referential constraints for your convenience.

Query and Reporting Setup Options

This section describes the options available in the Query and Reporting: Setup
window. To access this window, follow this selection path:Tasks » Data Management »
Query » Query and Reporting » Setup
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Display 10.34 Query and Reporting Setup Window

The items under File management, Profiles, Catalogs, and Environment have
the same functions in the Query and Reporting: Setup window that they do in the main
SAS/ASSIST Setup window. For details on these items, see Chapter 12, “Doing More
with Setup,” on page 215.

Query migration

The Query migration item opens the Query Migration window, which enables you
to import QMF queries to Query and Reporting. For more information, see Appendix 4,
“Migrating from QMF to SAS/ASSIST Software,” on page 251.

Forms migration

The Forms migration item enables you to migrate QMF forms to SAS under the z/
OS operating environment. You must have the forms migration utility installed to use
this item. For more information, contact SAS Technical Support.

Administration

The Administration item opens the Query Manager Administration window, which
enables you to define and edit static and dynamic Query Managers.
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Overview

This chapter describes how you use Structured Query Language (SQL) and the SQL
Editor window to perform queries for both the SAS SQL procedure and DB2 SQL. This
chapter is intended for users who are familiar with SQL statements and syntax, and
who have worked with SQL programs.

This chapter shows examples based on SAS AIRLINE sample tables. See “Returning
to SAS/ASSIST Windows from the Output Window” on page 9 for information on how to
create these sample tables

The SQL Editor window enables you to code and submit SQL SELECT statements
(also called queries). You can also code and submit non-query SQL statements, such as
CREATE or DROP. The SQL Editor window uses the Query Manager to get information
about tables and views. Templates of SQL code are then generated based on these
Query Manager selections.

You can also use the SQL Editor window to include queries that are generated from
the Query window, queries that are stored in external files, or IBM QMF queries that
have been migrated to Query and Reporting. Query results can be saved as SAS tables
(that is, SAS data files or data views) or DB2 tables. For more information on
migrating from QMF to Query and Reporting, see Appendix 4, “Migrating from QMF to
SAS/ASSIST Software,” on page 251.
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Opening the SQL Editor Window
To open the SQL Editor window, follow this path:
Tasks » Data Management » Query » Query and Reporting » SQL Editor
The SQL Editor window appears.

Display 11.1 SQL Editor Window

If the window is filled when you open it, it contains a last query that was loaded into
this window. To clear the window, select New from the File menu.

Entering SQL Statements Directly

Entering an SQL Query

The SQL you use in the SQL Editor window depends on the kind of Query Manager
that you are using. If you have a SAS Query Manager, you use SAS’s SQL procedure in
the SQL Editor window. If you have a DB2 Query Manager, you use IBM’s DB2 SQL.

A message appears at the top of the SQL Editor window to indicate which SQL is
being used. If you need to use a different set of tables, you can create a new Query
Manager or talk to your SAS Support Consultant or database administrator (DBA).
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You can type an SQL query in the SQL Editor window if you already know the libref
or creator, table, and column names that you want to use.* The SQL Editor window is a
complete editor with the following rules:

0 Type and submit only one SQL query at a time

o Type one or more non-SELECT statements at a time, separating them with
semicolons (;)

0 Do not submit both SQL queries and non-SELECT statements at the same time.
You can insert or delete lines in the window by using items in the Edit menu.

The query in the following display retrieves the average number of delayed flights
each day.

Display 11.2 SQL Editor Window With Query

You can now edit the query further or run it by selecting Submit from the Run menu.
If you run the query, you can save your output to a SAS or DB2 table, as described in
“Creating New Tables” on page 182.

Entering Non-SELECT SQL Code

Occasionally you might want to submit SQL statements that are not queries, such as
statements that drop tables or create indexes. These non-query, non-SELECT
statements do not produce output.

You can type several non-SELECT SQL statements at one time, separated by
semicolons. Do not end the final statement with a semicolon.

*  For brevity, table means table or view unless otherwise noted. The “creator” refers to the SAS libname or your DB2
authorization identifier.
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Note: Using more than one statement and semicolons applies only to non-SELECT
SQL statements and not to SQL queries. A

Select New from the File menu to clear the SQL Editor window. Then type your SQL
code into the window. For example,

create index jobcode on airline.jobcde2|jobcode);

drop table airline.temp

Select submit from the Run menu to submit the code to SAS or to DB2.
The following list includes some non-Select SQL statements that you might want to
submit to your database.

CREATE creates a table, view, index, or other objects, depending on how the
statement is specified.

DELETE deletes one or more rows from a table.

DROP deletes a table, view, index, or other objects, depending on how the
statement is specified.

INSERT adds one or more rows to a table.

UPDATE modifies the data in columns of a row in a table.

GRANT gives users the authority to access or modify objects such as tables

or views. (DB2 SQL only)

REVOKE revokes the privileges that were given to users by the GRANT
statement. (DB2 SQL only)

For more information and restrictions on these and other SQL statements, see your
SQL documentation.

You can use the prompt facility to display a prompt window when non-SELECT SQL
statements are submitted. See “Using the Prompt Facility” on page 174 for more
information. Non-SELECT SQL statements can be saved to and executed from the
Result Manager window. See “Saving SQL Code or Output” on page 213 and Chapter 9,
“Doing More with Results,” on page 143 for information.

Creating Template SQL Programs

Many times you might want to begin a new program by using part of another
program. Or, you might want to begin a new program by using the tools that Query and
Reporting offers to create a template program. The following sections show you how to
use these tools to create a template that you can edit and customize for your purposes.

Using a Stored Query or Statement

You can include a query that you have previously created in the Query window or
include a query or non-SELECT statement that you previously created in the SQL
Editor window. From the SQL Editor window, select open from the File menu. The
Open window appears with a list of your saved queries or non-SELECT statements (of
types QUERY and SQL). Type an s (for Select) next to the query or statement that you
want to include.

The Open window has the fields shown in the following table.
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Table 11.1 Fields in the Open Window

Field Description

catalog Specifies the current catalog name. To change it, type a two-level name or
? to list all possible catalogs. Then make a selection from the resulting
Select a Member window.

Name At the top of the display, the Name field is empty, by default. To search for
and limit the listing to certain entries, type the complete name of an entry,
or type a portion of a name with a pattern-matching character (such as %
or _). For example, specifying JOB% retrieves all of the queries that begin
with JoB. Type % for a list of all the saved entries.

Cmd Type S or an asterisk (*) to select the query or non-SELECT statement.

Row Displays the number of queries and non-SELECT statements. You can
edit the value of the starting number to change the number of the rows
displayed.

Name In the window’s listing, Name displays the names of your queries or

non-SELECT statements.
Description Describes your queries or non-SELECT statements.

Type Lists whether the entry was saved from the SQL Editor window (SQL) or
from the Query window (QUERY).

Date Lists the date when the query or non-SELECT statement was created or
last edited.

You can also sort the contents of the window by Name, Description, Date, or Type
by selecting Sort By from the view menu.

After you type S in the cmd field and press ENTER, the query or non-SELECT
statement is loaded into the SQL Editor window and a message is displayed to indicate
that the query has been loaded. Select Goback to return to the SQL Editor window.

If you load a query of type QUERY, changes that you make to your SQL code in the
SQL Editor window are not reflected in the query that you display with the Query
window. However, you can save your changed SQL code, as described in “Saving SQL
Code or Output” on page 213.

You can now edit or run your SQL code. You can edit it in the SQL Editor window or
select Enhanced Editor from the Edit menu. The Enhanced Editor enables you to
make more significant changes to your code. See “Using the Enhanced SQL Editor” on
page 207 for more information.

Selecting Tables with the Select Window

You can use the Query and Reporting Select window to include tables in the SQL
Editor. Select Query Manager from the Tools menu to open the Query and Reporting
Select window. Choose one or more tables and columns, as described in “Selecting
Tables and Columns for Queries” on page 166.

Note: Selections made from the Query and Reporting Select window replace
non-SELECT SQL statements in the SQL Editor window and append SQL queries in
the SQL Query window. If you want to append table selections to non-SELECT SQL
code, or want to replace SQL queries, do not use the Query and Reporting Select
window; instead, use the SQL Select Table window as described in the next section. A
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After you select your columns and select Close from the File menu, you return
automatically to the SQL Editor window. SQL code that is based on your selections is
displayed in the SQL Editor window.

Under DB2 SQL, if a column name has special or national characters (such as
FLIGHT#), the column automatically appears in quotation marks.

If relations are defined on the tables, the tables are joined automatically; a WHERE
clause is automatically generated in the SQL code. If relations are not defined, edit the
SQL code to add a WHERE clause to complete the join.

Choosing Tables with Select Table

Another way to begin a template program is to follow these instructions:

1 Choose Select Table from the Edit menu. The SQL Select Table window
appears.

Display 11.3 SQL Select Table Window

2 Type the two-level name of a table that you want as the basis of your query.

3 Select Append to append the table to the query currently in the SQL Editor
window, or select Replace to replace it.

4 Select oK. The SQL template program appears in the SQL Editor window. In this
example, all the columns are selected from the AIRLINE.DELAY table, as shown
in the following display. Table and column aliases, formats, labels, and lengths are
automatically generated for the table(s) that you include.



Using the SQL Editor /A Using the Enhanced SQL Editor 207

Display 11.4 SQL Editor Window With AIRLINE.DELAY Table Selected

5 To join the AIRLINE.DELAY with the AIRLINE.FLINFO table, choose select
Table again and type the table name AIRLINE.FLINFO. Select Append to append
the two tables. Select ok. If relations are defined on the tables, a WHERE clause
is automatically generated in the SQL code and the join is complete.

In this example, no relations are defined on the AIRLINE.DELAY and
AIRLINE.FLINFO tables. For a join to work efficiently, it must have a WHERE (or ON)
clause, and so you must edit the SQL code.

You can do minor editing in the SQL Editor window by using the Edit menu’s
Insert Line and Delete Line items. For more substantial editing, use the SQL
Enhanced Editor, as described in the following section.

Note: If you decide that you do not want to join AIRLINE.DELAY with
AIRLINE.FLINFO and instead want only AIRLINE.FLINFO, choose Select Table
again. Type the name AIRLINE.DELAY and select Replace. The SQL template
program for the join is then replaced by a template program for AIRLINE.FLINFO. A

Using the Enhanced SQL Editor

The Enhanced Editor window is useful when you want to make changes in the SQL
code. You can open the Enhanced Editor window from the SQL Editor window at any
time. Any code in the SQL Editor appears in the Enhanced Editor window. In this
example, you edit the join between the AIRLINE.DELAY and AIRLINE.FLINFO tables
that you selected in the previous section.

1 Follow this selection path:Edit » Enhanced Editor The Enhanced Editor window
appears with the SQL statements from the SQL Editor window.
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Display 11.5 Enhanced Editor Window

2 Edit the SQL code as follows. For a complete explanation of commands for using
the Enhanced Editor, refer to the window’s online help.

0 Add a WHERE clause (WHERE A.FLIGHT=B.FLIGHT) at the end of the SQL
code to complete the join.

o Edit the SELECT clause to remove the duplicate B.FLIGHT column along
with its format, length, and label.

0 Delete the comma after length=3 at the end of the B.ORIG column
description.

The edited query is shown in the following display. The display is scrolled
forward so that you can see the WHERE clause.
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Display 11.6 Edited SQL Query

3 Select close from the File menu to return to the SQL Editor window. You can
perform further modifications to your query, run your query, or save it.

Note: You can also run your query from the Enhanced Editor window by selecting
Run from the RUN menu. A

Including and Writing SQL Code to External Files

In the Enhanced Editor window, you can include an external file that contains SQL
code. Select Include from the File menu. The Include... window appears and prompts
you to type a filename, as shown in the following display.

Display 11.7 Include Window
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Type an external file name and select 0K to copy the SQL code into the SQL Editor
window.

To write your SQL code to an external file, select Store SQL from the File menu.
The Store SQL...window prompts you for the external file name, as shown in the
following display.

Display 11.8 Store SQL Window

Type an external file name and select Ok to write the SQL code to your external file.

Note: You can include IBM QMF queries in the SQL Editor window if you convert
them for use in Query and Reporting. See Appendix 4, “Migrating from QMF to SAS/
ASSIST Software,” on page 251 for more information. A

Correcting Errors in SQL Code

It is usually difficult to create perfectly correct SQL code the first time. If you run
incorrect SQL code, you will get errors. The SQL Editor window has a SAS log for you
to review so that you can correct your code.

Using the example from earlier in this chapter, if you incorrectly type the A.FLIGHT
column name as A.FLIGHTT in the WHERE clause and you run the program, the
Report Log window appears, informing you that an error has occurred.

Select view SAS Log from the Run menu to open a SAS log that is customized for
SAS/ASSIST software. The following display indicates that the A.FLIGHTT column
was not found in the AIRLINE.DELAY table.
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Display 11.9 SAS Log Window

Select Close from the File menu twice to return to the SQL Editor window. Correct
your code and run it again.

When you run your SQL code successfully, your output appears in the Report Output
window (or in the output window that is defined for your system). From the SQL Editor
window, you can select Report Log from the View menu to see the most recent SAS log
for your output.

Running an SQL Query and Customizing the Output

When your SQL query is ready, you can run the query immediately or you can add a
title, change its options, limit its output, and so on, to make the report look better. See
“Viewing the SQL Code, Running the Query, and Refining the Output” on page 178 for
more information.

To run your report immediately, select Submit from the SQL Editor window’s Run
menu. Your output is displayed in the Report Output window (or in the output window
that is defined for your system).

In some cases, you might want to edit your output to make your report look better or
to correct minor errors, such as a mistyped name. It is more efficient to change the
output for a report rather than to run the query again, especially if the tables used to
create the report are very large.

To edit your output directly, select Report Output Manager from the View menu.
The Report Output Manager window opens, as shown in the following display.
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Display 11.10 Report Output Manager Window

The Report Output Manager lists every run of your queries in a temporary catalog,
WORK.CURSTAT (current status). Type E or S in the cmd field next to the output that
you want to edit. This opens a window with the same text editing capabilities and
commands as the Enhanced Editor window. You can edit any of the data or text in the
output.

To save your changes, you must save the edited output either to an external file or to
a SAS catalog entry.

0 To save the edited output temporarily in the WORK.CURSTAT catalog, select save
from the File menu. When prompted, select R to overwrite the original OUTPUT
entry in the WORK.CURSTAT catalog.

0 To save your edited output permanently, select save As from the File menu.
Specify a name, description, and catalog and select OK.

CAUTION:
If a new entry has the same name as an existing ASSIST entry, you might not receive
a prompt that warns about overwriting an existing entry. If you last saved from one
of the three windows that has a different type than the one you are currently
saving, you might not receive the warning prompt and your entry will be
overwritten. A

0 To save your output to an external file, select save As File from the File menu.
Specify an external file name in the Save As window and select OK.

From the Edit window, select Close from the File menu to return to the Report
Output Manager window.

When you exit from the Report Output Manager and return to the Report Output
window, you see that the changes you made are not shown in your output. The Report
Output window does not automatically update to include your changes.
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Note: If you do not save your changes to a permanent catalog or external file, the

changes will be lost when you exit from SAS because WORK.CURSTAT is a temporary
catalog. 2

Select close from File to return to the SQL Editor window.

Saving SQL Code or Output

The previous section describes how to run your query and to make minor editing
changes to the output. After you have run your query, you have several options for
saving your work.

o0 You can create a new SAS, DB2, or other database management system table from

your output; see “Creating New Tables” on page 182 for details

0 You can save the SQL query to a catalog entry of type SQL.

0 You can save the output to a catalog entry or external file, as described in the
previous section.

O save non-Select SQL statements to a catalog entry. From the SQL Editor window,
select save from the File menu.

Your saved SQL queries (type SQL) can be used to make reports with the Report
Engine. See Chapter 5, “Doing More with the Report Engine,” on page 61.
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Introduction

This chapter describes in detail the setup options in SAS/ASSIST software. There
are two sets of setup options associated with SAS/ASSIST software: the main setup
options and the Query and Reporting setup options. The Query and Reporting setup
options are discussed in “Query and Reporting Setup Options” on page 199.
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There are three ways of accessing the main SAS/ASSIST setup options: The setup
button on the WorkPlace menu or by following either of these selection paths:Tasks »
SetupTools » SetupThe first selection path presents the options in a cascading menu.
The second selection path opens the Setup window, containing all the setup options, as
shown in the following display.

Display 12.1 Setup Window

This chapter describes how to use Setup to create a new library, delete and create
the sample SAS/ASSIST tables, use the SAS windowing environment in SAS/ASSIST
software, change the catalog search path, and use logon and logoff exits and an
alternate main menu.

File Management Items

SAS data libraries

The sAs data libraries setup item enables you to assign, list, and de-assign
librefs. For more information, see the “Setting Up SAS Files” chapter in Getting Started
with SAS/ASSIST.

Assign maps

The Assign maps setup item opens the Map Data Set Libref window, enabling you to
assign the MAPS libref to a SAS data library of your choosing. The Maps task searches
this library for SAS/GRAPH map tables to generate map reports.
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Assign format libref

The Assign format libref setup item opens the Assign Libref window, which
enables you to assign the LIBRARY libref to a SAS data library of your choosing. SAS
searches this library for permanently-stored user-defined formats. For more
information on defining and storing formats, refer to “Creating a Format” on page 28
and “The FORMAT Procedure in Base SAS Procedures Guide.

External files

The External files setup item enables you to assign, list, and de-assign filerefs,
and to browse external files. For more information, see “Browsing an External File” on
page 150. External files is also described in Appendix 3, “Batch Processing with the
Result Manager (z/OS Only),” on page 243.

Sort a table

The sort a table setup item opens the SAS/ASSIST Sort a Table window. For more
information on the Sort a Table window, see the “Sorting Data” chapter in Getting
Started with SAS/ASSIST.

Sample tables

The sample tables setup item enables you to create, delete, edit, and browse the
SAS/ASSIST sample tables. For more information, see the “Familiarizing Yourself with
SAS and SAS/ASSIST Software “chapter in Getting Started with SAS/ASSIST.

Environment ltems

Primary and Secondary menu colors

The Primary menu colors and Secondary menu colors items enable you to
customize the color scheme of the Version 6 block-style SAS/ASSIST menus. They have
no effect on the WorkPlace menu.

Forms management

The Forms management setup item enables you to create and edit printer forms and
select the catalog for storing and retrieving saved printer forms. Printer forms
determine how hardcopy output appears. For more information on how printer forms
are used, refer to the SAS companion documentation for your operating environment.
To create or edit a printer form, type the name of the form in the Form name filed and
press ENTER. See the online help for information on the various forms windows.
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Graphics options

The Graphics options setup item enables you to select and customize graphics
device drivers for display, hardcopy, and file output. You can also specify other graphics
options such as font style, size, and color. Graphics Options is also used in “Changing
the Background Color for Graphs” on page 115.

Enter host command

The Enter host command setup item enables you to send a command to your
operating environment without exiting your SAS session.

Batch processing

The Batch processing setup item enables you to set up files and commands for
batch processing. For more information, see Appendix 3, “Batch Processing with the
Result Manager (z/OS Only),” on page 243.

Use SAS program editor

The Use SAS program editor item raises the Program Editor window. This option
has the same effect as selecting Program Editor from the View menu.

Catalogs for results

The catalogs for results item is used with the Version 6.06 interface style of
SAS/ASSIST software (User Profile option SAS/ASSIST Style set to Block, Menu
Style set to 01d). In the Version 6.06 interface, you can use Catalogs for Results to
specify a separate catalog for saved tasks, output and logs, graphics and forms. All
results are now saved to the SASUSER.PRIVATE catalog by default.

Catalog search path

The catalog search path item enables you to specify up to four catalogs in which
to search for catalog entries before searching the default catalogs. For more
information, see “Using the Catalog Search Path” on page 220.

Private/public applications

The Private/public applications item is used to specify what applications are
run from the Run public applications and Run private applications items on
the EIS task menu

Logon/logoff exits

Logon and logoff exits are programs that run automatically when you invoke and exit
SAS/ASSIST software. You can also set up an alternate main menu. For more



Doing More with Setup /A Master/group 219

information, see “Using Logon and Logoff Exits and an Alternate Main Menu” on page
221.

History file

The History File item is used in the Release 6.06 SAS/ASSIST interface to collect
the source code from the SAS/ASSIST tasks into one file. While this function can still
be used in later releases, using a script file is generally more useful. For more
information on script files, see “Creating and Executing a Script File” on page 152.

Information items

Browse catalog contents

The Browse catalog contents item enables you to browse the contents of a catalog
of your choosing. For more information, see “Browsing an External File” on page 150.

Review function keys

The Review function keys item opens the KEYS window. For more information,
refer to the “Familiarizing Yourself with SAS and SAS/ASSIST Software” chapter in
Getting Started with SAS/ASSIST.

SAS System help

The sAs system help setup item invokes the SAS online help system.

Profiles items

User

The User item opens the User Profile window. For more information, see Appendix 2,
“Customizing SAS/ASSIST Software,” on page 237.

Master/group

The Master/group item opens the Master/Group Profile window. Master and Group
Profiles are used to set SAS/ASSIST software options for entire sites or groups within
sites. Master and Group Profiles are usually set up by system administrators.
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Using the Catalog Search Path

If you have programs, FRAME entries, or other SAS/AF catalog entries that you
want SAS/ASSIST software to use, you can use the Catalog search path item to
specify the names of the catalogs you want SAS/ASSIST software to search. SAS/
ASSIST software searches the specified catalogs first whenever it is called on to run a
SAS/AF program, FRAME entry, or other catalog entries. If SAS/ASSIST software does
not find the requested entry, SAS/ASSIST software then searches its default catalogs.

Use the following instructions to set up a catalog search path.

1 Follow this selection path:Tasks » Setup » Environment » Catalog search
pathThe Catalog Search Path window appears.

Display 12.2 Catalog Search Path Window

2 In the numbered fields, type the names of the catalogs that you want SAS/ASSIST
software to search first for programs, FRAME entries, and other catalog entries,
before searching the default catalogs. Use two-level catalog names in the form of
libref.catalog. SAS/ASSIST software searches the catalogs you indicate in the
order you type them (from the top down). To display a list of available catalogs,
type ? in the first position of the catalog field and press ENTER. Select the catalog
you want to use.

3 To enable the search path, select Use search path. This feature allows you to
turn the search path on and off without having to retype the catalogs each time.

4 Select OK.
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Using Logon and Logoff Exits and an Alternate Main Menu

When you access SAS/ASSIST software, you can use the Logon exit item to specify
an application that you want to initiate when you enter SAS/ASSIST software.
Additionally, by using Alternate main menu, you can specify that you want to display
an alternate menu instead of, or in addition to, the WorkPlace menu or the Version 6
block-style menu. When you exit SAS/ASSIST software, you can specify an application
you want to invoke upon exiting by using Logoff exit.

This section discusses the use of Logon/logoff exits, including using Alternate
main menu. As an alternative to using these windows, you can set the SAS/ASSIST
start program, Type of start program, SAS/ASSIST stop program, and Type of
stop program User Profile options. See “Setting User Profile Options” on page 237.

Specifying a Logon Application

1 To display the Set Logon Application window, follow this selection path:Tasks »
Setup » Logon/logoff exits » Logon Exit

Display 12.3 Set Logon Application Window

2 In the Library field, type the name of the library that contains the applications
database, for example, SASUSER.

3 In the Applications Database field, specify the applications database that
contains the desired application. The applications database must reside in the
library specified in the Library field and must be of type SASAPPL. The default
applications database is SASUSER.SASAPPL.

4 In the Name field, type the name of the application.
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5 Select the type of application from the list shown in the window.
6 To bypass SAS/ASSIST software, select Do not enter SAS/ASSIST.
7 Select OK to return to the WorkPlace menu window.

The next time you invoke SAS/ASSIST software, your logon exit application is
initiated first. When you exit the logon exit application, the WorkPlace menu appears.

You also can invoke a logon exit with the LOGON= command-line option. The syntax
of this command is

ASSIST LOGON-="libref.applds.applname.appltype’

The libref.applds.applname.appltype argument specifies a four-level name for the
application. The default application database is SASUSER.SASAPPL. The LOGON=
command-line option overrides Logon exit.

To disable the Do not enter SAS/ASSIST selection, bypass your logon exit
application, and access SAS/ASSIST software, type ASSIST LOGON=NO on a command
line or command window and press ENTER.

Specifying a Logoff Application

1 To open the Set Logoff Application window, follow this selection path:Tasks »
Setup » Environment » Logon/Logoff Exits » Logoff ExitThe Set Logoff
Application window is similar to the Set Logon Application window, except that
there is no Do not enter SAS/ASSIST option. Instead, there is an Exit the SAS
System option.

2 Type information in the window using the guidelines given previously for the Set
Logon Application window. If desired, select Exit the SAS System to specify that
you want to end your SAS session when you exit SAS/ASSIST software.

3 Select oK to return to the WorkPlace menu.

When you exit SAS/ASSIST software, your logoff exit application is initiated. When
you exit the logoff exit application, you return to the point from which you invoked SAS/
ASSIST software, or exit SAS, depending on your selection for the Exit the SAS
System option.

You can also initiate a logoff exit with the LOGOFF= command-line option. The
syntax for this command is

ASSIST LOGOFF="libref.applds.applname.appltype’

The libref.applds.applname.appltype argument specifies a four-level name of the
application. The default application database is SASUSER.SASAPPL.

To disable the Exit the SAS System selection and bypass your logoff exit
application, type ASSIST LOGON=NO on a command line or command window and press
ENTER.

The LOGOFF= command line option overrides Logoff exit.

Specifying an Alternate Main Menu

1 To open the Set Alternate Main Menu window, follow this selection path:Tasks »
Setup » Environment » Logon/logoff exits » Alternate main menu The Set
Alternate Main Menu window is similar to the Set Logon Application window.

2 Type information in the window using the guidelines given previously for the Set
Logon Application window.
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3 If desired, deselect Do not enter SAS/ASSIST to enter SAS/ASSIST software
when you exit the alternate main menu. This item, which is selected by default,
enables you to bypass SAS/ASSIST software.

4 Select OK to return to the WorkPlace menu.

The next time you access SAS/ASSIST software or return to the WorkPlace menu
from a task window, your alternate menu appears instead. When you exit the alternate
main menu, the SAS/ASSIST WorkPlace menu appears (if you have deselected bo not
enter SAS/ASSIST).

If you have specified an alternate main menu application, and you want to disable
the alternate main menu feature, access SAS/ASSIST software by typing ASSIST
PRIMARY=NO on a command line or command window. This bypasses the specified
alternate main menu application and displays the WorkPlace menu.

You can also invoke an alternate main menu with the PRIMARY= command line
option. The syntax for this command is

ASSIST PRIMARY="libref.applds.applname.appltype’

The libref.applds.applname.appltype argument specifies a four-level name for the
application. The default application database is SASUSER.SASAPPL.
The PRIMARY= command-line option overrides Alternate main menu.
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Introduction

This chapter gives a complete picture of the items available on the SAS/ASSIST
software Tasks menu. For each submenu of the Tasks menu, there is a short description

of the item, the required software product, and a cross-reference to more information.

The following abbreviations are used in the “See” column:
0 GS refers to Getting Started with SAS/ASSIST.

o o g

PG@G refers to Base SAS Procedures Guide.
SAS/ETS UG refers to SAS/ETS User’s Guide
SAS/STAT UG refers to SAS/STAT User’s Guide, Volumes 1, 2, and 3.

Data Management

Table A1.1 Data Management Menu Items

Item Sub-item Description Required See
product
Query SQL Query Opens SQL Query window Base SAS SQL Query Window
software online help
Query and Accesses SAS/ASSIST Base SAS Chapter 10, “Query
Reporting Query and Reporting software and Reporting,” on

system

page 155 and Chapter
11, “Using the SQL
Editor,” on page 201
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Item Sub-item Description Required See
product
Edit/Browse  Edit Data Enables editing of a SAS SAS/FSP “Editing and Browsing
table software Data” chapter in GS;
Browse Enables browsing of a SAS ~ SAS/FSP SAI_S’F ShPISOftware
Data table software onihe help
Import Data n/a Enables import of an Base SAS “Importing and
external file to a SAS table software Exporting Data”
Export Data n/a Enables export of a SAS Base SAS chapter in GS
table to an external file software
Create Data  Interactively Data entry in single-line or =~ SAS/FSP “Entering Data
table format software Interactively” chapter
in GS
For X-Y Data entry for creating an SAS/FSP SAS/ASSIST software
Plots X-Y plot software online help
For Charts Data entry for creating bar  SAS/FSP SAS/ASSIST software
or pie charts software online help
For Data entry for creating SAS/FSP SAS/ASSIST software
Mapping maps software online help
For Data entry for creating a SAS/FSP SAS/ASSIST software
Calendar calendar software online help
For Time Data entry for time-series SAS/FSP SAS/ASSIST software
Series analysis software online help
Using SQL Opens SQL Query window Base SAS SQL Query Window
software online help
DBMS n/a Opens Explorer window Base SAS Explorer online help
Access software
Subset/Copy n/a Subset or copy a SAS table Base SAS “Defining a New
software Column” chapter in
GS
Combine All methods  Opens Combine Tables Base SAS For all of these
window software methods, see
Concatenate  Combine tables by Base SAS C(?mbmmg Da'ta
. Using a Cartesian
concatenation software
Product Match Merge”
Merge Combine tables by merging  Base SAS on page 22
software
Interleave Combine tables by Base SAS
interleaving software
Match Combine tables by match Base SAS
Merge merging software
Design n/a Create formats and Base SAS “Creating a Format”
Format informats software on page 28
Sort n/a Sort a SAS table Base SAS “Sorting Data”
software chapter in GS



Tasks Menu Reference /A Report Writing 227

Item Sub-item Description Required See
product
Utilities Contents of  Browse or edit SAS table Base SAS “Altering the
a Table properties software Properties of a SAS
Table” on page 30
Table Select an active table with n/a “Select Table Window”
the Select Table window on page 12
Convert to Prepare a SAS table for Base SAS “Transporting SAS
CPORT transport to another software Files Across Operating
Format operating environment Environments” on
page 34
Convert Convert a transport file to Base SAS “Transporting SAS
from SAS format software Files Across Operating
CPORT Environments” on
Format page 34
Convert Edit time series data SAS/ETS SAS/ASSIST software
Frequency software online help
of Time
Series Data
Rearrange Expand repeated measures Base SAS SAS/ASSIST software
Repeated data into one measure per software online help
Measures row
Table
Transpose Make rows into columns Base SAS “Transposing a Table”
Table software on page 37
Report Writing
Table A1.2 Report Writing Menu Items
Item Sub-item Description Required See
Software
Listing n/a List Data task Base SAS “Report Writing®
software chapter in GS
Tabular All styles, Create tabular reports Base SAS “Report Writing”
Report Statistics, software chapter in GS; “Doing
Simple More with Tabular
Group 1, Reports” on page 49
Simple
Group 2,
Two-
dimensional
Group,
Multiple
Group,

Advanced
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Item Sub-item Description Required See
Software
Report Use Report Base SAS software “Using the
Engine Engine Report
facility Engine“
chapter in
GS; Chapter
5, “Doing
More with
the Report
Engine,” on
page 61
Utilities Create Design printed labels Base SAS SAS/ASSIST software
Labels software online help
Create Design printed banners Base SAS SAS/ASSIST software
banner software online help
Produce Create a calendar Base SAS SAS/ASSIST software
Calendar application software online help
Create Data entry for calendars Base SAS SAS/ASSIST software
Calendar software online help
Data
Summary Generate summary Base SAS “Data Analysis”
Statistics statistics on a SAS table software chapter of GS;

Chapter 7, “Doing
More with Data
Analysis,” on page 119

Contents of  Browse or edit SAS table Base SAS “Altering the
a Table properties software Properties of a SAS
Table” on page 30

Design Create formats and Base SAS “Creating a Format”
Formats informats software on page 28

High Resolution Graphics

For all bar charts, pie charts, plots, and maps, see the “Graphics” chapter in GS and
Chapter 6, “Doing More with Graphics,” on page 85. SAS/GRAPH software is required
for all High Resolution Graphics tasks.

Table A1.3
Item Sub-item Description Required See
Product
Bar Chart n/a Create vertical and SAS/
horizontal bar charts GRAPH
software
Pie Chart n/a Create pie charts SAS/
GRAPH

software
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Item Sub-item Description Required See
Product
Plots Simple X * Create simple plots SAS/
Y Plot GRAPH
software
X *Y Plots Create categorical plots SAS/
by Category GRAPH
software
Multiple Create advanced plots SAS/
Plots per GRAPH
Axes software
Maps n/a Create maps SAS/
GRAPH
software
Utilities Replay Redisplay saved graphics SAS/ SAS/ASSIST software
graphs GRAPH online help
software
Generate Test graphics display SAS/ SAS/ASSIST software
Test GRAPH online help
Patterns software
Create Data  Data entry for plots SAS/FSP SAS/FSP software
for X *Y software online help
Plots
Create Data  Data entry for charts SAS/FSP SAS/FSP software
for Charts software online help
Create Data Data entry for maps SAS/ SAS/FSP software
for Mapping GRAPH online help
software,
SAS/FSP
software

Low Resolution Graphics

Low-resolution graphics are available only if you are using the Version 6 block-style
menu or if you are using a non-graphics terminal device. No additional products are
required to use low-resolution graphics. For more information on low-resolution
graphics, refer to the SAS/ASSIST software online help.

Data Analysis

For general information on performing data analysis, see the “Data Analysis” chapter
in Getting Started with SAS/ASSIST and Chapter 7, “Doing More with Data Analysis,”
on page 119.
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Table A1.4
Item Sub-item Description Required See
Product
Elementary Summary Generate summary Base SAS “Data Analysis”
Statistics statistics on a SAS table software chapter in GS;
Chapter 7, “Doing
More with Data
Analysis,” on page 119
Correlation Compute correlations Base SAS “The CORR
software Procedure” in PG
Confidence Compute confidence Base SAS “The MEANS
Intervals for intervals software Procedure” in PG
Means
Frequency Generate or analyze Base SAS “The FREQ
Tables frequency tables software Procedure” in PG
Regression Linear Perform linear regression SAS/STAT “The REG Procedure”
analysis software in SAS/STAT UG
Logistic Perform logistic regression =~ SAS/STAT “The LOGREG
analysis software Procedure” in SAS/
STAT UG
With Perform regression with SAS/ETS SAS/ETS software
Correction correction for software online help
for Auto- autocorrelation
correlation
Anova Analysis of Perform analysis of SAS/STAT “The ANOVA
Variance variance software Procedure” in SAS/
STAT UG
Nonpara- Perform nonparametric SAS/STAT “The NPAR1WAY
metric ANOVA software Procedure” in SAS/
ANOVA STAT UG
T-tests Perform ¢-tests SAS/STAT “The TTEST
software Procedure” in SAS/
STAT UG
Multivariate  Principal Perform principal SAS/STAT “The PRINCOMP
Components components analysis software Procedure” in SAS/
STAT UG
Canonical Perform canonical SAS/STAT “The CANCORR
Correlation correlation analysis software Procedure” in SAS/
STAT UG
Quality Ctrl n/a Access quality control SAS/QC SAS/QC software
analysis functions software online help
Interactive Guided Interactively analyze data SAS/LAB SAS/LAB software
Data software online help
Analysis
Data Graphically analyze and SAS/ SAS/INSIGHT
Exploration  display data INSIGHT software online help

software
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Item Sub-item Description Required See
Product
Time Series Seasonal Perform seasonal SAS/ETS “The X11 Procedure”
Adjustment  adjustment of time series software in SAS/ETS UG
data
Regression Perform regression with SAS/ETS “The AUTOREG
correction for software Procedure” in SAS/
autocorrelation ETS UG
Utilities Compute Perform univariate Base SAS “The UNIVARIATE
Percentiles analysis software Procedure”in PG
Compute Perform rank analysis Base SAS “The RANK
Ranks software Procedure” in PG
Standardize  Standardize data Base SAS “The STANDARD
Columns software Procedure” in PG
Convert Expand repeated measures  SAS/ETS “The EXPAND
Frequency data into one measure per software Procedure” in SAS/
of Time row ETS UG
Series Data
Create Time Data entry for time series SAS/FSP SAS/FSP software
Series Data analysis software online help
Planning Tools
Table A1.5
Item Sub-item Description Required See
Product
Loan n/a Loan calculator SAS/ETS SAS/ETS software
Analysis software online help
Design of n/a Experiment designer SAS/QC SAS/QC software
Exp software online help
Project n/a Project management SAS/OR SAS/OR software
Mgmt software online help
Spreadsheet  n/a Spreadsheet application SAS/CALC SAS/CALC software
software online help
Forecasting n/a Financial forecasting SAS/ETS SAS/ETS software
application software online help
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Item Sub-item Description Required See
Product
Utilities Produce a Calendar creation n/a SAS/ASSIST software
Calendar application online help
Create Data entry for calendar SAS/FSP SAS/FSP software
Calendar creation software online help
Data
Convert Edit time series data SAS/ETS SAS/ETS software
frequency of software online help
time series
data
Create time  Data entry for time series SAS/FSP SAS/FSP software
series data analysis software online help
Table A1.6
Item Sub-item Description Required See
Product
Run 6.06 n/a Access private applications n/a SAS/ASSIST software
private from Release 6.06 SAS/EIS online help
applications software
Run 6.06 n/a Run public applications n/a SAS/ASSIST software
public from Release 6.06 SAS/EIS online help
applications software
SAS/EIS n/a Invoke SAS/EIS software SAS/EIS SAS/EIS software
software online help

Remote Connect
All Remote Connect items require SAS/CONNECT software.

Table A1.7

Item Sub-item Description See

Establish n/a Establish remote connection “Using Remote Connect” chapter

Connection in GS

Run n/a Run a saved program locally or SAS/ASSIST software online
remotely help



Tasks Menu Reference /A Results

233

Item Sub-item Description See
Transfer Upload Send data to remote host “Using Remote Connect” chapter
Data in GS
Download Get data from remote host SAS/ASSIST software online
help
Download Get graphics output files from SAS/ASSIST software online
Graphics remote host help
Output
Utilities Access utility functions SAS/ASSIST software online
help
Terminate n/a Terminate connection to remote “Using Remote Connect” chapter
connection host in GS
Edit remote n/a Edit remote connect configuration “Adding, Editing, and Deleting
connection Remote Configurations” on page
140
Results Result Access Result Manager window “Using the Result Manager”
Manager chapter in GS
Access
saved
programs,
output,
logs, graphs
Batch Submit a batch job locally or Appendix 3, “Batch Processing
Submit remotely with the Result Manager (z/0S
Only),” on page 243
Results

No further products are required for the Results items.
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Table A1.8

Item

Description

See

Result Manager

Access saved programs,
output, logs, graphs

Batch submit

Opens Result Manager window

The “Access saved...”items are
not used in SAS/ASSIST software
Release 6.08 and later. They are
retained for compatibility with
earlier releases.

Submit a batch job locally or
remotely

“Using the Result Manager”
chapter in GS; “Doing More with
the Result Manager” on page 143

SAS/ASSIST software online
help for all “Access saved...”
items

Appendix 3, “Batch Processing
with the Result Manager (z/0S
Only),” on page 243

Setup

Table A1.9
Item Sub-item Description Required See
product
File SAS Data Manage librefs Base SAS “Setting Up SAS
Management libraries software Files” chapter in GS
Assign Assign MAPS libref Base SAS SAS/ASSIST software
maps software online help
Assign Assign LIBRARY libref Base SAS SAS/ASSIST software
format software online help
libref
External Manage filerefs Base SAS SAS/ASSIST software
files software online help
Sort a table  Sort data in a SAS table Base SAS “Sorting Data” chapter
software in GS
Sample Create, browse, edit, or SAS/FSP “Using the SAS
tables delete SAS/ASSIST sample  software (to System and SAS/
tables edit and ASSIST Software”
browse) chapter in GS
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Item Sub-item Description Required See
product
Environment Primary Change color scheme for Base SAS SAS/ASSIST software
menu colors  Version 6 block-style menu  software online help
Secondary Change color scheme for Base SAS SAS/ASSIST software
menu colors  Version 6 block-style menu  software online help
Forms Create an edit printer Base SAS SAS/ASSIST software
management forms software online help
Graphics Select and customize SAS/ SAS/ASSIST software
options graphics device drivers and GRAPH online help
other graphics options software
Enter host Send a command to Base SAS SAS/ASSIST software
command operating environment software online help
Batch Set up batch jobs Base SAS Appendix 3, “Batch
processing software Processing with the
Result Manager (z/OS
Only),” on page 243
Use SAS Opens Program Editor Base SAS SAS/ASSIST software
program window software online help
editor
Catalogs for  This option is used only in n/a SAS/ASSIST software
results the Release 6.06 SAS/ online help
ASSIST software interface
style. It is not used with
the interfaces for later
releases.
Catalog Specify catalog to search Base SAS “Using the Catalog
search path  for programs an FRAME software Search Path” on page
entries 220
Private/ Specify private and public Base SAS SAS/ASSIST software
public applications for use with software online help
applications  EIS task menu
Logon/logoff ~ Specify applications to run ~ Base SAS “Using Logon and
exits before and after running software Logoff Exits and an
SAS/ASSIST software Alternate Main Menu”
on page 221
History file Create history file (Release n/a SAS/ASSIST software

6.06 interface style)

online help
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Item Sub-item Description Required See
product
Information Browse Browse contents of a SAS Base SAS SAS/ASSIST software
catalog catalog software online help
contents
Review Open KEYS window Base SAS “Using the SAS
function software System and SAS/
keys ASSIST Software”
chapter in GS
SAS System  Invoke SAS online help Base SAS “Using the SAS
help system software System and SAS/
ASSIST Software”
chapter in GS
Profiles User Open User Profile window Base SAS “Setting User Profile
software Options” on page 237
Master/ Open Master/Group Profile  Base SAS SAS/ASSIST software
Group window software online help
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Introduction

This appendix describes how you can customize your SAS/ASSIST sessions. The
main method for customizing aspects of your SAS/ASSIST environment is by
manipulating the User Profile options as described in the following section. This
appendix also describes how to create an alternate menu bar.

Setting User Profile Options

The User Profile window contains a set of options that is available for your personal
use in SAS/ASSIST software. The user profile is automatically created the first time
you access SAS/ASSIST software. Individual User Profiles are stored in the SAS
catalog entry SASUSER.PROFILE.PASSIST.SLIST. You can use SAS/ASSIST software
with the personal User Profile and the personal Query Manager that are set up for you
by default. See “Selecting a Query Manager” on page 158 for more information about
Query Managers.

To open the User Profile window, follow this selection path:Tasks » Setup » Profiles
» User

The following display shows the User Profile window.
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Display A2.1 User Profile Window

The User Profile window contains all of the possible profile options. However, it
displays only a subset of the available options when the Type field has any value other
than A11l. The default value for the Type field is General.

To see other subsets of options, type a ? in the Type field, press ENTER, and select a
type from the list. Alternatively, you can type a different type in the Type field. The
types of options include the following:

All
Displays all possible options

Access to DB2 data
Displays options related to DB2 access in Query and Reporting (z/OS only).

Access to SAS data
Displays options related to SAS data access.

Batch
Displays options related to batch processing (z/OS only).

General
Displays general SAS/ASSIST software options.

Private menu
Displays options related to the private menu.

Query
Displays options related to Query and Reporting.

Query Manager
Displays options related to Query Managers.

Report Engine
Displays options related to the Report Engine.
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Scroll the window forward as needed to see additional options. Most options have a
default value. Type a ? in the value field for an option to list all of the possible values
for that option. To change the value, select a new value from the list or type over the
current value. You can also type I or S in the cmd field to open the Option Information
window and update values in that window. The following table lists the commands you
can use in the cmd field next to an option.

Table A2.1 Commands for the User Profile Window

Cmd Action Description

? Lists commands Displays a list of commands for the Cmd field.

I Information Opens the Option Information window, which provides information
about the current option, including a description, a value, and the
date altered. You can edit the value in this window by typing a new
value in the Value field. Alternatively, you can type a ? in the
Value field to list all possible values for the option. Select a value
from the list.

R Resets value Returns the option to the last saved option value.

S Information Is identical to the I command.

The User profile is controlled by a Master profile, if one exists, and may also be
controlled by a Group profile. User profile options might be restricted by an
administrator. When options are restricted, you cannot change the values for these
options in your User profile. (If option values have been changed in a Master or Group
profile, you may see a prompt indicating that changes have been made when you invoke
SAS/ASSIST software.) Master and Group Profiles are usually set up by system
administrators.

Creating an Alternate Menu Bar

You can use the PMENU procedure to create an alternate menu bar for your SAS/
ASSIST session. For example, submitting the following SAS program in the Program
Editor window creates a menu bar called CUSTMENU in a catalog called
SASUSER.MENUS:

proc pmenu cat=sasuser.menus;
menu custmenu;
item 'File’ menu=file;
item ’'Locals’ menu=locals;

menu file;
item ’'End’;

item 'Bye’;

menu locals;
item ’'RESULTMAN’;
item ’'ACCESS’;

run;

quit;
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After you have submitted this program, invoke SAS/ASSIST software if it is not
already running. Open the User Profile window as described earlier in this chapter.
Change the following options:

0 Change the Menu style value to ALTERNATE.

0 Change the Alternate menu bar value to the location of the alternate menu bar;
in this example,
SASUSER.MENUS . CUSTMENU . PMENU

0 Change the SAS/ASSIST Style value to Block menu

Select close from the File menu to save your changes. Exit SAS/ASSIST software,
then re-invoke it. When you open a task window, your alternate menu bar appears as
shown in the following display.

Display A2.2 Alternate Menu Bar

To find the SAS/ASSIST commands that you can use when building an alternate
menu, follow this selection path from the WorkPlace menu:Help » Using This
WindowSelect Menu Bar from the Help window for a list of menu bar items; select a
menu bar item to find its associated command. Here are some additional useful
commands:

COMMAND
toggles between the menu bar and the Command ===> prompt.

PREVWIND
raises the previous window.

NEXT
raises the next window.

POPCMD
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lists the available commands for that window.

EXPORT
opens the Export Data to External File window after a query has been run. Used
in the Query window only.

END ALL
closes all open Query and Reporting windows. Used in Query and Reporting
windows only.

For more information on the PMENU procedure, refer to the Base SAS Procedures
Guide.
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Introduction

This appendix provides information about submitting batch jobs from SAS/ASSIST
software. When you invoke SAS/ASSIST software under z/OS, you can use the Result
Manager to execute saved queries, reports, and so on, in batch. To execute an entry in
batch mode, you need a site-dependent Job Control Language (JCL) program. The JCL
program can reside as a sequential file, a Partitioned Data Set (PDS) member, or as a
source entry in a SAS catalog.

Note: This section describes basic information for batch processing using the Result
Manger under the z/OS operating environment. Batch processing and JCL are specific
for each site. Check with your z/OS system administrator for additional information. A

Additional Information

For additional information on submitting batch jobs under z/OS, see the SAS
Companion for z/OS.

General Batch Processing Information Under z/0S

When you use the L command in the Result Manager window to batch submit an
entry, the default JCL program in SASHELP.QASSIST.BATCHJOB.SOURCE is used
for the batch submission. This program uses the prompt feature. That is, the user is
asked to type the userid for batch processing. You can change this behavior to prompt
the user for other JCL parameters (such as job class, time, and so on). See the next
section for more information.

The site-dependent command for executing a batch job is specified in the User,
Group, or Master profile’s Batch command field. The default value is SUBMIT. If the
profile’s Generate libnames field is set to Yes, the user’s SAS session is examined for
allocated SAS libraries (librefs), and LIBNAME statements are inserted into the batch
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job. This may be useful if the JCL does not allocate all of the SAS data libraries that
are necessary to execute the programs. To view or change these profile options, open
the User Profile window or the Master/Group Profile window and set the Type to Batch.
See Appendix 2, “Customizing SAS/ASSIST Software,” on page 237 for details.

Note: 1If the batch job starts executing while the SAS data libraries are still
allocated to your session or to another user’s session in update mode, the batch job ends
abnormally (abend) if the LIBNAME statements fail. To avoid this, you can delay the
start of the batch job’s execution until the other users have finished using the necessary
SAS libraries. Or, make sure you de-allocate the libraries from interactive sessions. A

Submitting Batch Jobhs

Follow these instructions to submit a SAS/ASSIST task as a batch job.
1 Open the desired task window and make the desired task window selections.

2 Save the task by selecting save from the File menu. Type a name and description
and select OK in the Save window.

3 Open the Result Manager window by following this selection path:Tasks »
Results » Result Manager

4 Type an L in the cmd field for the saved task and press ENTER. The BATCH1
window appears.

Display A3.1 BATCH1 Window

5 After you verify or change the values in the BATCH1 window, press ENTER. The
Submit for Batch Processing window appears.
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Display A3.2 Submit for Batch Processing Window

6 If desired, select Edit to edit the JCL generated after the

have been resolved, as shown in the following display.

Display A3.3 Edit Batch Job Window

symbolic parameters

HOTE: Edit hatch job: HOUSLIST.ASSIST
File Edit V¥iew Tools Solutions Help

/ fUSERIDA JOB (USERID,GD01) ,USERID,
i1 USER=USEFRID,

MSGLEVEL=(0,0) ,M5GCLASS=H
’fiiiiiiiitiiiiiiiiiiiiitiiiiiiiitiiiiiiiiiiiiitiiiii

ff*** Sample JCL: SASHELP.QASSIST.BATCHITOB.SOURCE *#**
,liiiiiiiitiiiiiiiiiiiiitiiiiiiiitiiiiiiiiiiiiitiiiii
Fisns EXEC SAS

FFSYSIH DD *

| Summary:

| This program creates a listing of columns using the
| table SASUSER.HOUSES.

Generated: 10MAR1999 10:48:27

¥

The OPTIDHS statement specifies the dimensions of the printed
output in characters per line and lines per page and whether oxr
not the current date and page number are printed.

The TITLE and FOOTHOTE statements clear any previously defined

titles or footnotes.

options linesize=76 pagesize=28 date number pageno=1;
title;
footnote;
proc print data=SASUSER.HOUSES
noohs label
;
run;

After making your changes, select Close from the File menu. When prompted,

select Yes to save the changes and return to the Submit for Batch Processing

window.

245



246 Customizing the JCL Program A Appendix 3

7 Select OK to submit the job for batch processing.

Customizing the JCL Program

The following sample JCL is found in SASHELP.QASSIST.BATCHJOB.SOURCE.

//&userid("Enter Userid","&sysjobid","8")A JOB (&userid,G001),
// suserid, USER=g&userid,
// MSGLEVEL=(0,0) ,MSGCLASS=H

//***************************************************

//*** Sample JCL: SASHELP.QASSIST.BATCHJOB.SOURCE ***

//***************************************************

//SAS EXEC SAS
//SYSIN DD *

This JCL executes when you submit a batch job by typing L in the c¢md field next to
an entry in the Result Manager window. The JCL opens the BATCH1 window, enabling
the user to type information as prompted. You can customize the prompts in the
BATCH1 window by customizing a copy of the JCL program as follows:

1 If it is not already open, open the Result Manager window by following this

selection path:Tasks » Results » Result Manager

2 Type SASHELP.QASSIST in the Catalog field and press ENTER. A list of entries in
the SASHELP.QASSIST catalog appears.

3 Type B% in the Name field and press ENTER to display only those entries that start
with the letter B.

4 Type a ¢ next to BATCHIJOB SOURCE entry and press ENTER. The Copy window
appears.

Display A3.4 Copy Window

Because you cannot edit entries in the SASHELP.QASSIST catalog, you must copy
this entry to a location in which you have WRITE access. Later, you will change
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the Batch file User or Master/Group Profile option to point to the copy of the
JCL program.

5 In the copy to field, type the name you want to assign to the copy and press TAB.

6 In the catalog field, type the name of the desired catalog (in which you have
WRITE access) over the existing value.

7 Select oK. The program is copied to the new location.

8 In the catalog field of the Result Manager window, type the name of the catalog
in which the copy was placed and press ENTER.

9 In the cmd field for the copy of the program, type an E and press ENTER. The
program appears in the Edit window.

You can use the prompt feature in your JCL in the same way as you would use the
prompt feature in a query (see “Using the Prompt Facility” on page 174 for more
information). For example, if you want to prompt the user to change the TIME for the
batch job, you would put in a prompt for the TIME in the JCL. In the following JCL,
the third line creates an “Enter Time” prompt with an eight-character field that
contains the default time of (,5).

//&userid("Enter Userid","&sysjobid","8")A JOB (&userid,G001),

// suserid, USER=&userid,
// TIME=&time("Enter Time","(,5)","8"),
// MSGLEVEL=(0,0) ,MSGCLASS=H

//***************************************************

//*** Sample JCL: SASHELP.QASSIST.BATCHJOB.SOURCE ***

//***************************************************

//SAS EXEC SAS
//SYSIN DD *

In the edited code,
USER=

is the JCL parameter that is added to your JCL source code.

&userid
is the macro variable that contains the USER parameter value.

"Enter Userid","&sysjobid","8"
are the parameters that are used to build the statement displayed in the BATCH
window.

"Enter Userid"
is the descriptive text displayed in the window.

"&sysjobid"
is the macro variable for system job ID. It provides the default value for the
macro variable (& userid).

n 8 n
is the length, in bytes, of the userid macro variable field.

TIME=
is the JCL parameter that you want added to your JCL source code.

&time
is the macro variable that contains the TIME parameter value.

"Enter Time", n ( ,5) n , "8")

is the parameter that contains the components that are used to build the
statement displayed in the BATCH window.
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"Enter Time"
is the descriptive text displayed in the window.

(,5)
is the default value for the macro variable &time.

n 8 n
is the length, in bytes, of the time macro variable field.

When you are done editing the JCL, select Close from the File menu. When
prompted, select Yes to save the changes. Select Close from the File menu to exit the
Result Manager.

To use the new JCL program, you must change the Batch file User Profile option
as follows:

1 Follow this selection path to open the User Profile window:Tasks » Setup »
Profiles » Userlf you are an administrator and you want to set up this option for
a group or for all users at a site, open the Master/Group Profile window instead of
the User Profile window.

2 In the Type field, type BATCH and press ENTER.

3 For the Batch file option, change the value to the location of the new JCL
program. Use a four-level name in the form libname.catalog.filename.type.

4 If you have included prompts in the JCL, ensure that the Batch prompt option is
set to YES. When the Batch prompt option is Yes, the batch file is scanned for
prompts which start with ampersands (&). If the Batch prompt option is No, the
batch file is submitted without being scanned for prompts. However, if you use
ampersands in your JCL that are not intended to be prompts, make sure that the
Batch prompt option is No. Otherwise, the ampersands are interpreted as
prompts.

5 Save you changes by selecting Close from the File menu.

The next time you submit a saved task for batch processing, the BATCH1 window
appears with your changes.

Customizing the Batch Program Window

After you verify the values in the BATCH1 window and press ENTER, the Submit
for batch processing window appears. You can customize this window by editing a copy
of the SASHELP.QASSIST.SAMPBATC.PROGRAM. Customizing the Batch Program
window involves SAS Component Language (SCL) programming. You should not
customize the Batch Program window unless you are a SAS administrator. To edit the
batch program, you must have SAS/AF software licensed at your site.

1 The sample SCL program for customizing the Batch window is stored in
SASHELP.QASSIST.SAMP_SCL.SOURCE. The only portion of the code in this
entry that applies to this customization is the section labeled
SASHELP.QASSIST.SAMPBATC.PROGRAM. Since you cannot directly copy the
SOURCE entry into the SOURCE window of the PROGRAM entry, view the
SOURCE entry, and use the FILE command to write the SOURCE entry to an
external file.

2 Create a PROGRAM entry in a location where you have WRITE access. Use the
INCLUDE command to include the SCL code into the SOURCE window of the
PROGRAM entry. Delete the irrelevant portions of the SCL code. Design the
display of the PROGRAM entry to your specifications.

3 Edit, compile, and save the associated SCL program.
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See SAS Component Language: Reference for more information on customizing
PROGRAM entries and SCL code.

In order to have SAS/ASSIST software use your customized window, change the
value of the Batch Window option in the User, Group, or Master profile to point to the
new program for the Submit for batch processing window.
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Introduction

This appendix describes how to migrate IBM QMF queries to Query and Reporting.
With the query migration tool, you can export your QMF queries and move them to
Query and Reporting through a three-step process. You then can use the SQL queries
in Query and Reporting just as you would use your other queries. Individual users or a
system administrator can perform this migration process, depending on each site’s
setup. The migration process consists of three stages:

1 Generate an export procedure in SAS that can be run in QMF.
2 Run the export procedure in QMF.
3 Import the queries into SAS/ASSIST Query and Reporting.

Each of these steps can be executed independently.

Generating a QMF Export Procedure

To generate a QMF export procedure, you need READ access to the DB2 table
Q.OBJECT_DIRECTORY (or a view of it).* QMF stores information about stored
objects in Q.OBJECT_DIRECTORY. Because system or database administrators have
access to this file, they usually complete this stage. Users can complete the other steps
themselves.

To generate an export procedure, follow these steps.

1 Follow this selection path:Tasks » Data Management » Query » Query and
Reporting » SetupFrom the Query and Reporting: Setup window, select Query
Migration. The following display shows the Query Migration main menu.

* If you create a DB2 SQL view of the Q. OBJECT_DIRECTORY table to export the QMF queries, make a source entry in the
SASUSER.PROFILE catalog named QMFTABLE.SOURCE. On the first line of QMFTABLE.SOURCE, type the name of the
new DB2 view that you created (such as SASQR.QMFOBJECT).
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Display A4.1 Query Migration Window

2 Select gMF Export to generate an export procedure. The following display shows
the Query Export window.

Display A4.2 Query Export Window
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Queries are exported from one owner at a time. In the Export queries owned
by field, type the user ID of the owner from whom you are exporting queries. Type
? and press ENTER to list the available user IDs.

The Select Queries window opens with a list of all of the queries owned by the
specified user ID. You can select all or some of the queries to export. Select END to
return to the Query Export window.

In the External file to hold exported queries field, type the name of the
external file that you want to hold your QMF export procedure and the exported
queries.

The external file does not need to be previously allocated. If the external file
does not exist, you are prompted to allocate it. This is the recommended method to
allocate the external file because it ensures that the external file has the correct
format.

If the external file exists and has the correct format but is not empty, you are
prompted to choose whether to delete all of the external file’s members or to
specify another external file name.

Select Run to write the export procedure to the specified external file. A message
appears that indicates the procedure has been successfully written. The message
also indicates the procedure name, which is stored in the external file that you just
specified.

Query and Reporting actually writes two members to this external file. One
member is the export procedure. The other member is used internally by Query
and Reporting.

When the two members have been written, exit your SAS session (if necessary)
and invoke QMF to export the queries.

Exporting Queries from QMF

To export queries from QMF, follow these steps.

1
2

Invoke QMF.

Import the export procedure that you created by issuing this command from the
PROGRAM EDITOR window:

IMPORT PROC FROM ' external file name(QMF2SAS)’

where external_file_name is the name of the external file that you specified in
the Query Export window, as described in the previous section.

3 Run the export procedure and exit QMF.
4 If necessary, invoke SAS and SAS/ASSIST software, and return to the Query and

Reporting Setup window and the Query Migration tool.

Importing QMF Queries into Query and Reporting

You have now written an export procedure and exported your QMF queries. In this
stage, you import the queries for use in Query and Reporting.
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1 Select SAS Import from the Query Migration main menu to open the Import
Queries window, as shown in the following display.

Display A4.3 Import Queries Window

2 Type the name of the external file that contains the exported queries.

3 Query and Reporting has a default catalog (SASUSER.IMPORT) to hold the
imported queries. The first time you use this default catalog, it is automatically
created. However, you can type the name of your own SAS catalog over the default
catalog name.

If the catalog does not exist, it is created. If queries with the same name
already exist in the catalog, they are replaced by the imported queries.

4 Select Import to start importing the QMF queries into SAS. An Importing window
appears to show the progress of the importing process.

After the importing process has been completed, you can access the SQL queries from
either the Result Manager window or from the SQL Editor window (by selecting Open
from the File menu). Notice that the queries are of type SQL, which indicates that they
are SQL queries.

You can use any of the Result Manager window commands to select, edit, browse, or
print the queries. You can then edit the DB2 SQL queries, save them, or create reports
from them, just like any other query in Query and Reporting.
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Alternate Method to Import Queries

If you want to import just a few queries, you can use the Enhanced Editor in the
SQL Editor window instead of the Import Queries window. To open the Enhanced
Editor, follow this selection path:

Tasks » Data Management » Query » Query and Reporting » SQL Editor » Edit
» Enhanced Editor When you select Include from the File menu, the Include window
opens and prompts you for the name of an external file. Type the name of the external
file and query that you want to import. Enclose the external file in quotes if necessary.

Select OK to include the query in the Enhanced Editor. The query is “imported.”
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Recommended Reading

Here is the recommended reading list for this title:

Getting Started with SAS/ASSIST

SAS/ASSIST Administrator’s Guide

The Little SAS Book: A Primer

SAS Language Reference: Dictionary

SAS Language Reference: Concepts

Base SAS Procedures Guide

The SAS Companion for your operating enviornment.

o o o o o o g

For a complete list of SAS publications, see the current SAS Publishing Catalog. To
order the most current publications or to receive a free copy of the catalog, contact a
SAS representative at

SAS Publishing Sales

SAS Campus Drive

Cary, NC 27513

Telephone: (800) 727-3228*
Fax: (919) 677-8166
E-mail: sasbook@sas.com

Web address: support.sas.com/publishing
* For other SAS Institute business, call (919) 677-8000.

Customers outside the United States should contact their local SAS office.
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active table
in SAS/ASSIST software, a SAS table that has been specified for a particular task.

analysis variable
a numeric variable that is used to calculate statistics. An analysis variable usually
contains quantitative or continuous values, but this is not required.

arithmetic operator
in SAS software, any of the symbols (+, -, /, *, and **) that are used to perform
addition, subtraction, division, multiplication, and exponentiation in SAS expressions.

base SAS software
software that includes a programming language that manages your data, procedures
for data analysis and reporting, procedures for managing SAS files, a macro facility,
help menus, and a windowing environment for text editing and file management.

batch mode
a method of executing SAS programs in which a file that contains SAS statements
plus any necessary operating environment commands is submitted to the computer’s
batch queue. After you submit the program, control returns to your terminal or
workstation, where you can perform other tasks. Batch mode is sometimes referred
to as running in the background. The program output can be written to files or
printed on an output device.

button
a component of a graphical user interface. A button is usually in the form of a
rectangle or square that contains a label. The button is programmed to execute a
command, to open a window, or to perform some other function when a user selects
it. For example, many graphical user interfaces include buttons that have labels
such as OK, Cancel, and Help.

BY variable
a variable named in a BY statement whose values define groups of observations to
process.

character variable
a variable whose values can consist of alphabetic and special characters as well as
numeric characters.

chart variable
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the variable whose values you are charting.

check box
an item in a window that you can select without affecting any other items. You can
deactivate a check box by selecting it again.

class variable
a variable that is used to group, or classify, data. Class variables can be either
character or numeric. Class variables can have continuous values, but they typically
have a few discrete values that define the classifications of the variable.

column
in relational databases, a vertical component of a table. Each column has a unique
name, contains data of a specific type, and has certain attributes. A column is
analogous to a variable in SAS terminology.

crosstabulation table
a frequency table that shows combined frequency distributions or other descriptive
statistics for two or more variables. These tables are also referred to as two-, three-,
or n - way tables; contingency tables; and stub-and-banner tables. See also frequency
table.

cumulative frequency
the total number of observations in all ranges up to and including a given range.

cumulative percent
the percentage of observations in all ranges up to and including a given range.

DATA step
a group of statements in a SAS program that begins with a DATA statement and
ends with either a RUN statement, another DATA statement, a PROC statement, or
the end of the job. The DATA step enables you to read raw data or other SAS data
sets and to create SAS data sets.

data value
a unit of character or numeric information in a SAS data set. A data value
represents one variable in an observation.

dependent column
See response variable.

dialog box
a type of window that opens to prompt you for additional information or to ask you to
confirm a request.

engine
a component of SAS software that reads from or writes to a file. Each engine enables
SAS to access files that are in a particular format.

explanatory variable
a variable that is included in a regression model in order to explain the variation in
the dependent (or response) variable. Explanatory variables, which are also called
independent, input, predictor, or regressor variables, can be deterministic or
probabilistic.

external file
a file that is created and maintained by a host operating system or by another
vendor’s software application. SAS can read data from and route output to external
files. External files can contain raw data, SAS programming statements, procedure
output, or output that was created by the PUT statement. An external file is not a
SAS data set. See also fileref.
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fileref
a name that is temporarily assigned to an external file or to an aggregate storage
location such as a directory or folder. The fileref identifies the file or the storage
location to SAS. In SAS/ASSIST software, you assign a fileref with the Setup task.

format
a pattern or set of instructions that SAS uses to determine how the values of a
variable (or column) should be written or displayed. SAS provides a set of standard
formats and also enables you to define your own formats.

frequency chart
a graphic illustration of the number of times a value or range of values for a given
variable occurs.

frequency count
the number of times a value or range of values for a given variable occurs.

frequency table
a table that lists the values of a variable and the number of observations with each
value. See also crosstabulation table, frequency count.

function key
a keyboard key that can be defined to have a specific action in a specific software
environment.

independent column
See explanatory variable.

index
in SAS software, a component of a SAS data set that enables SAS to access
observations in the SAS data set quickly and efficiently. The purpose of SAS indexes
is to optimize WHERE-clause processing and to facilitate BY-group processing.

informat
a pattern or set of instructions that SAS uses to determine how data values in an
input file should be interpreted. SAS provides a set of standard informats and also
enables you to define your own informats.

interactive line mode
a method of running SAS programs in which you enter one line of a SAS program at
a time at the SAS session prompt. SAS processes each line immediately after you
press the ENTER or RETURN key. Procedure output and informative messages are
returned directly to your display device.

label, variable
a descriptive label of up to 40 characters that can be printed in the output by certain
procedures instead of, or in addition to, the variable name.

length, variable
the number of bytes used to store each of a variable’s values in a SAS data set.

libref
a name that is temporarily associated with a SAS data library. The complete name of
a SAS file consists of two words, separated by a period. The libref, which is the first
word, indicates the library. The second word is the name of the specific SAS file. For
example, in VLIB.NEWBDAY, the libref VLIB tells SAS which library contains the
file NEWBDAY. You assign a libref with a LIBNAME statement or with an operating
system command.

local session
a SAS session running on the local host. The local session accepts SAS statements
and passes those that are remote-submitted to the remote host for processing. The
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local session manages the output and messages from both the local session and the
remote session.

logical operator
an operator used in expressions to link sequences of comparisons. The logical
operators are AND, OR, and NOT.

menu bar
the primary list of items at the top of a window which represent the actions or
classes of actions that can be executed. Selecting an item executes an action, opens a
pull-down menu, or opens a dialog box that requests additional information. See also
pop-up menu, pull-down menu.

message area
the area immediately beneath a window’s command line or menu bar which displays
messages from SAS.

metadata
a description or definition of data or information.

midpoint
a value that represents one data value or the middle of a range of data values. When
a midpoint represents a range of values, the algorithm used to calculate it depends
on the procedure.

missing value
in SAS, a term that describes the contents of a variable that contains no data for a
particular row or observation. By default, SAS prints or displays a missing numeric
value as a single period, and it prints or displays a missing character value as a
blank space.

numeric variable
a variable that contains only numeric values and related symbols, such as decimal
points, plus signs, and minus signs.

observation
a row in a SAS data set. All of the data values in an observation are associated with
a single entity such as a customer or a state. Each observation contains one data
value for each variable.

permanent SAS data set
a data set that remains after the current program or interactive SAS session
terminates. Permanent SAS data sets are available for future SAS sessions.

pop-up menu
a menu that appears when it is requested. These menus are context- specific,
depending on which window is active and on the cursor location. See also pull-down
menu.

PROC SQL view
a SAS data set (of type VIEW) that is created by the SQL procedure. A PROC SQL
view contains no data. Instead, it stores information that enables it to read data
values from other files, which can include SAS data files, SAS/ACCESS views, DATA
step views, or other PROC SQL views. A PROC SQL view’s output can be either a
subset or a superset of one or more files. See also view.

pull-down menu
the list of menu items or choices that appears when you choose an item from a menu
bar or from another menu. See also pop-up menu.

raw data
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data that has not been read into a SAS data set.

remote session
a SAS session running in a special mode on the remote host. No output or log
messages are displayed on the remote host; instead, the results of a remote SAS
session are transmitted back to the log and output files on the local host.

response variable
in regression analysis, the variable that you are interested in modeling for the
purpose of seeing how it changes as a function of the factors. The response variable
is also referred to as the dependent variable.

row
in relational database management systems, the horizontal component of a table. It
is analogous to a SAS observation.

SAS catalog
a SAS file that stores many different kinds of information in smaller units called
catalog entries. A single SAS catalog can contain several different types of catalog
entries. See also SAS catalog entry.

SAS catalog entry
a separate storage unit within a SAS catalog. Each entry has an entry type that
identifies its purpose to SAS. Some catalog entries contain system information such
as key definitions. Other catalog entries contain application information such as
window definitions, Help windows, formats, informats, macros, or graphics output.

SAS data file
a SAS data set that contains data values as well as descriptor information that is
associated with the data. The descriptor information includes information such as
the data types and lengths of the variables, as well as which engine was used to
create the data. SAS data files are of member type DATA. See also SAS data set,
SAS data view.

SAS data library
a collection of one or more SAS files that are recognized by SAS and which are
referenced and stored as a unit. Each file is a member of the library.

SAS data set
a file whose contents are in one of the native SAS file formats. There are two types of
SAS data sets: SAS data files and SAS data views. SAS data files contain data
values in addition to descriptor information that is associated with the data. SAS
data views contain only the descriptor information plus other information that is
required for retrieving data values from other SAS data sets or from files whose
contents are in other software vendors’ file formats.

SAS data view
a type of SAS data set that retrieves data values from other files. A SAS data view
contains only descriptor information such as the data types and lengths of the
variables (columns), plus other information that is required for retrieving data values
from other SAS data sets or from files that are stored in other software vendors’ file
formats. SAS data views can be created by the SAS DATA step and by the SAS SQL
procedure.

SAS log
a file that contains a record of the SAS statements that you enter as well as
messages about the execution of your program.

SAS name
a name whose construction follows certain rules and that can appear in a SAS
statement (for example, names of variables and SAS data sets).
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SAS procedure
a program that produces reports, manages files, or analyzes data and which is
accessed with a PROC statement. Many procedures are included in SAS software.

SAS program
a group of SAS statements that guide SAS through a process or series of processes.

SAS statement
a string of SAS keywords, SAS names, and special characters and operators that
instructs SAS to perform an operation or that gives information to SAS. Each SAS
statement ends with a semicolon.

SAS Support Consultant
an individual at your computing installation who is designated as a support person
for SAS software users at the installation. The consultant can help you with
questions about using SAS software.

SAS table
another term for SAS data set. See SAS data set.

SAS windowing environment
an interactive windowing interface to SAS software. In this environment you can
issue commands by typing them on the command line, by pressing function keys, or
by selecting items from menus or menu bars. Within one session, you can perform
many different tasks, including preparing and submitting programs, viewing and
printing results, and debugging and resubmitting programs.

Sasuser library
a default, permanent SAS data library that is created at the beginning of your first
SAS session. The Sasuser library contains a Profile catalog that stores the
customized features or settings that you specify for SAS. You can also store other
SAS files in this library.

scroll bar
a graphical window element that is used to bring the undisplayed contents of an
associated object (such as a text box or a list box) into view. A scroll bar is shaped
like a horizontal or vertical bar and has a scroll arrow at each end. If the associated
object contains text that is not in view, the scroll bar contains a box that you can
drag in order to move up or down in the viewing area. Alternatively, you can click on
the arrows to move up or down in smaller increments.

selection field
the portion of a window (shown on the display as an underscore) where you can enter
a short command to perform an action, such as B for browse.

selection-field command
a command that enables you to perform actions from a selection field in a SAS
windowing environment. For example, entering D in the selection field beside the
name of a SAS data set in the DIRECTORY window enables you to delete that SAS
data set.

SQL (Structured Query Language)
a standardized, high-level query language that is used in relational database
management systems to create and manipulate database management system
objects. SAS implements SQL through the SQL procedure.

table
in general, a two-dimensional system of representing data in rows and columns.

temporary SAS data set
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a data set that exists only for the duration of the current program or interactive SAS
session. Temporary SAS data sets are not available for future SAS sessions.

variable
a column in a SAS data set or in a SAS data view. The data values for each variable
describe a single characteristic for all observations.

view
a generic term (used by many software vendors) for a definition of a virtual data set
(or table). The definition is named and stored for later use. A view contains no data;
it merely describes or defines data that is stored elsewhere.

WHERE expression
a type of SAS expression that specifies a condition for selecting observations for
processing by a DATA step or a PROC step. WHERE expressions can contain special
operators that are not available in other SAS expressions. WHERE expressions can
appear in a WHERE statement, a WHERE= data set option, a WHERE clause, or a
WHERE command.

WHERE processing
a method of conditionally selecting observations for processing in a DATA or PROC
step. WHERE processing involves using a WHERE expression in a WHERE
statement, a WHERE= data set option, a WHERE clause, or a WHERE command.
See also WHERE expression.

Work data library
a SAS data library that is automatically defined by SAS at the beginning of each SAS
session or SAS job. The Work library contains SAS files that are temporary by
default. When the libref User is not defined, SAS uses Work as the default library for
SAS files that are created with one-level names.
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Numbers

2-D Group 2 style, tabular reports

A

Additional Options item

Advanced style, tabular reports

AIRLINE sample tables [3
analysis columns

ANOVA (analysis of variance)

entering data m

repeated measures ANOVA

applications
logoff applications
logon applications |221
private versus public
Assign format, setup item
Assign maps, setup item [216]

backing out of tasks E

bar charts
customizing
grouping with
horizontal
mean displayed on
running
setting up
stacking with
three-dimensional
titles

batch processing m
Batch Program window
JCL code for |246

with Result Manager (z/OS)

block maps |111J115

Browse catalog contents, setup item m

browsing

catalogs [219
external files |150
tables |167

C

Cartesian product |184
Cartesian product match merge
Catalog search path, setup item

218220

267

catalogs
browsing [219
saving reports to
Catalogs for results, setup item m
character columns, converting to numeric
character dates and times, converting to SAS date and time
values
charts
See graphics
choices, displaying
classification columns
Cmd field
commands for Report Engine window
customizing queries m
Column Information window 164
columns
analysis columns
classification columns
converting character to numeric
information about
manipulating with View menu [166|
modifying, in reports
order of
selecting, for queries
selecting, from tables
usages
combining data, with Cartesian product match merge
command line
commands
Cmd field, Report Engine window
entering host commands |218
for Result Manager entries |145
Select window m

COUNT(*)

data analysis [119
analysis of variance (ANOVA)
linear regression [121
one-way frequency tables [119
Tasks menu m
data management
combining data, with Cartesian product match merge
converting character columns to numeric columns
formats, creating
tables, altering properties of
tables, transposing
Tasks menu m
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transporting files across operating environments
date and time stamps
inserting into titles and footnotes
removing from output
DB2 tables
creating (z/OS)
joining
desktop environments, returning to SAS/ASSIST win-
dows
donut pie charts [103
drilldown reports
dynamic reports, saving as SAS tables

E

editing
graphs
tables [167

EIS, Tasks menu m
Enhanced Editor window
correcting SQL code errors 210
including and writing SQL code to external files |209
Enter host command, setup item
environment setup items
exiting SAS/ASSIST software [
expressions m
external files
browsing |150
including and writing SQL code to (209
saving reports to
saving source code to |149
setup item

F

file management setup items

footnotes, inserting date and time stamps
foreign keys [199|

formats

creating

modifying [66]
forms managemen#
forms migration
frequency tables, one-way |119
function keys [219

G

grand totals
graphics
background color [115
bar charts
editing graphs interactively
high resolution
low resolution m
maps |110
options for
pie charts 98]
plots [106
grouping, with bar charts

H

headers |66
help

high resolution graphics (228

history files |219
horizontal bar charts
host commands, entering |218

information setup items
informats, creating
inner joins
interface E
Additional Options item
backing out of tasks
choices, displaying
command line
exiting SAS/ASSIST software E
moving between SAS/ASSIST windows and SAS System
windows E
returning to SAS/ASSIST windows from Output win-
dow
SAS/ASSIST software structure and E
Select Table Variables window
Select Table window
Utilities menu

J

JCL code, for batch processing [246)

joining tables |184

automatically [195

DB2 tables

inner joins |185

interrupting processing |187
manually

outer joins [191f199
referential integrity [199
relations on tables [193
relations on tables, modifying and deleting [194
three tables [189)

with multiple relations
without defined relations [186

L

librefs
assigning on remote SAS sessions
setup item m

linear regression [121

logoff applications [222

logoff exits [218)]221

logon applications |[221

logon exits d

low resolution graphics (229

M
main menu, alternate to [221]222]

mainframe environments, returning to SAS/ASSIST win-
dows

maps [110
Additional Options |114
block maps [111]115
legends |114
levels of |[114
patterns 114
prism maps 115

setup item m




surface maps |[113
two-dimensional [110] 115]
types of
Master/Group Profile window m
match merge
mean, displayed on bar charts
menu bar, alternate
menu bars
menu colors [217
Multiple Group style, tabular reports

No (Number) field, customizing queries |171
numeric columns, converting to character

0

one-way frequency tables [119

Open window

Order field, customizing queries
outer joins [191f199

output

for queries

for queries, customizi
for queries, limiting |180
removing date and time stamp E

saving report output to SAS catalogs
SQL, saving m

Output window, returning to SAS/ASSIST windows from E

P

pie charts
Additional Options [99] 106
colors m
creating
display options m
donut pie charts [103
labeling 100
patterns  |100|
running |102
setting up [98]
slice values |106
slices  [100]
star pie charts [103
three-dimensional [103
planning tools [231
plots [106
Aditional Options
multiple plots per axes
scatter plots m
X *Y by category
primary keys |199
Primary menu colors, setup item m
prism maps 115
Private/public applications, setup item m
profiles setup items m
Program Editor window m
Prompt Facility [174]
properties of tables, altering

Q

QMF
exporting queries from m

importing queries, alternate method
importing queries, into Query and Reporting
migrating to SAS/ASSIST software [251
QMF export procedure [251
queries
See also SQL Editor
building |169
COUNT(*), on tables |182
customizing [171
entering [202]
exporting, from QMF m
expressions, defining [176
importing, alternate QMF method |255
importing, into Query and Reporting [253
migrating 251
output |180,
output, customizing
output, limiting [180]
prompts for |174
rows, number returned
running |178
saving |[181
selecting tables and columns for [166
SQL code, viewing |178
subsetting data [173
Query and Reporting [156
administration of 200
forms migration m
importing queries into [253
query building |169
query migration m
Query window
querying data
Select window 205
setup options
tables, creating [182
tables, joining
Query Manager Administration window m
Query Managers |158)168
Query Migration window m
Query window [157
resetting [182
Select window 159
selecting a Query Manager

R

referential integrity |199
regression analysis [121
regression lines |107
relations, on tables |193
remote configurations [140)
adding m
deleting
editing [140]
SASSCRIPT system option, setting
script files |141
Remote Connect
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253

librefs, assigning on remote SAS sessions

remote configuration management

SAS/ASSIST tasks, setting up on remote data

session anatomy

Tasks menu m
Remote Connect sessions |139
repeated measures ANOVA (130

137
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Report Engine Save Changes dialog box, disabling E
Column Information window saving reports
column order dynamic reports, saving as SAS tables
columns, modifying saving output to SAS catalogs
date and time stamps, inserting in titles and footnotes to external files
formats, modifying to SAS catalogs
grand totals scatter plots [106
graphs, editing interactively regression lines
headers, modifying running m
opening existing reports setting up [106
options titles [107
output rows, limiting script files |141)]152
Report Engine window Secondary menu colors, setup item m
report types Select Table Variables window
reports, modifying Select Table window
reports, modifying with usages Select window
row title space column manipulation
saving reports commands for [162]
selecting other data expanding lists
subsetting data Query Manager
Report Engine window selecting tables and columns for queries
Cmd field commands tables, browsing or editing |167
fields typing names into fields [160
opening View menu |166
report types setup items
report writing Tasks menu |234
rows, limiting number of setup options |215
tabular reports @I accessing  |216
Tasks menu m Catalog search path item [218
titles, adding more than four @I environment items
Result Manager file management items
batch processing with (z/OS) information items
browsing external files |150) logoff exits
commands, for manipulating entries logon exits
Result Manager window main menu alternate |221
script files [152] profiles items
source code, saving to external files |149 Simple Group style, tabular reports
Tasks menu m Simple Group style, tabular reports
Result Manager window |144 Sort a Table window
Review function keys, setup item m source code, saving to external files [149
row title space SQL code
rows, limiting number of changing (207
rows, number returned by queries correcting errors in  |210
including and writing to external files [209
s non-SELECT, entering
saving
sample tables Bf 217] viewing [178
SAS/ASSIST interface SQL Editor [201
See interface Enhanced Editor window m
SAS/ASSIST software [1][2 non-SELECT SQL code, entering [203
customizing output, saving
exiting E queries, customizing output [211
setup options queries, entering 202
structure of E queries, running
SAS catalogs SQL code, saving
saving reports to SQL Editor window m
SAS data libraries, setup item m SQL statements, entering |202
SAS date and time values, converting character dates and template SQL programs
times to SQL Editor window [202]
SAS System help SQL output, saving
SAS tables [183 SQL Select Table window
See also tables SQL statements, entering |202
creating |183 stacking, with bar charts
saving dynamic reports as star pie charts [103
SAS views, creating Statistics style, tabular reports

SASSCRIPT system option Structured Query Language (SQL)



See SQL Editor

subsetting data

43]77] 173]

summaries, for tabular reports
surface maps [113]115

T

Table Information window

table joins

See joining tables

tables [182]

See also joining tables
See also SAS tables
altering properties of
browsing |167

creating |182
editing [167
relations on
sample tables

193
B 217

saving dynamic reports as

selecting, for queries
selecting, for tasks

selecting columns from

sorting |217

transposing

tabular reports

2-D Group style
Advanced style

Multiple Grou

p style

options for

Simple Group
Simple Group
Statistics style
summaries for

style

Bl style

terminology
task windows, defined [

tasks

backing out of E

defined E

selecting tables for
setting up on remote data
Tasks menu m

data analysis
EIS |232

229

Remote Connect |232]

report writing

227

165

137
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Result Manager
template SQL programs
choosing tables with Select Table [206
selecting tables with Select window m
stored queries or statements
three-dimensional bar charts
three-dimensional pie charts [103
titles
adding more than four to a report @
bar charts
inserting date and time stamps
row title space
scatter plots |107
transport format
transporting files
transposing tables
typographical conventions

u

Usage field, customizing queries [172
usages, modifying reports with
Use SAS program editor, setup item

User Profile window
Utilities menu

v

View menu, Select window [166
views, creating |[183

w

windows
Additional Options item
moving between SAS/ASSIST windows and SAS System
windows

returning to SAS/ASSIST windows from Output win-
dow

z

z/OS environment
batch processing (243
creating DB2 tables |[183]
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