SAS® Add-In 4.3 for Microsoft Office: Adding SAS Content to Your Microsoft Office Documents
## Contents

*About This Book* ........................................... v  
*Accessibility Features of the SAS Add-In for Microsoft Office* ............... ix  
*Recommended Reading* ..................................... xi  

### Chapter 1 • Introduction to the SAS Add-In for Microsoft Office

- What Is the SAS Add-In for Microsoft Office? ........................................ 1  
- Benefits to Using the SAS Add-In for Microsoft Office .......................... 2  
- How to Use the SAS Add-In for Microsoft Office ................................... 3  

### Chapter 2 • Adding SAS Content to a Microsoft Excel Workbook

- About the Tasks That You Will Perform .............................................. 5  
- How to Access the Input Data Source ................................................... 5  
- Generate the Summary Statistics for the Federal Reserve Data ................. 6  
- Apply a Style to the Summary Statistics Results ..................................... 7  
- Apply the Same Style to All Future Results ......................................... 8  
- Adding Results to an Existing Worksheet ............................................ 9  
- Calculate the Federal Reserve Rate ...................................................... 11  
- Display the Historical and Predicted Rate Values in a Line Plot .............. 12  
- Recalculate the Federal Reserve Rates with the Click of a Button .......... 16  
- Plot the Federal Reserve Rates over Time .......................................... 20  

### Chapter 3 • Adding SAS Content to a Microsoft Word Document

- About the Tasks That You Will Perform .............................................. 25  
- Access to the Input Data Source .......................................................... 25  
- Sort the Soccer Teams by Number of Wins and Conference ..................... 26  
- Generate a Report .............................................................................. 31  
- Apply a Style to the Results ................................................................. 34  
- Specify the Contents of the Report with a Click of a Button .................. 38  

### Chapter 4 • Sending SAS Content from Microsoft Excel to Microsoft PowerPoint

- About the Tasks That You Will Perform .............................................. 49  
- How to Access the Input Data Source ................................................... 49  
- Drop Columns from the Input Data Source .......................................... 50  
- Plot the Total Criminal Offenses over Time .......................................... 53  
- Preview and Select the Results ............................................................. 57  
- Determine the Correlation between Population and Violent Crime ........ 58  
- Determine the Number of Violent Crimes by Year ................................ 60  
- Send Results to a Microsoft PowerPoint Presentation ............................ 62  
- Refresh Results in the PowerPoint Presentation ................................... 64  

### Chapter 5 • Editing and Refreshing SAS Content in Microsoft Word

- About the Tasks That You Will Perform .............................................. 67  
- Access to the Input Data Source .......................................................... 67  
- Save the College Sample to a Local Directory ..................................... 67  
- Edit the Tuition Costs in Microsoft Excel ............................................ 68  
- Refresh the Tuition Data in the Pamphlet .......................................... 70  

*Glossary* ......................................................................................... 73  
*Index* ......................................................................................... 75
About This Book

Audience

This book is intended for users of Microsoft Office 2007 or 2010. Each chapter in this book explains how to re-create a sample that is available from http://support.sas.com/software/products/addin. Samples are available for Microsoft Excel, Microsoft Word, and Microsoft PowerPoint. By re-creating these samples, you will learn how to perform these tasks using the SAS Add-In for Microsoft Office:

- run a SAS analysis and include the results in an Excel worksheet, Word document, or PowerPoint presentation
- use Visual Basic code to refresh your content
- preview the results from a SAS analysis and select the results that you want to include in the output
- apply a custom style to your results
- edit SAS data in Microsoft Excel
- send content from one Microsoft Office application to another

If you are using Microsoft Office 2003, you can still complete the tasks in this book. However, the user interface for the SAS add-in is different between Microsoft Office 2003 and Microsoft Office 2007. For example, in Microsoft Office 2003, the SAS options are located on the SAS menu rather than the SAS tab.

Prerequisites for This Scenario

Software and Configuration Requirements

When you are ready to perform the tasks in this book, administrators at your site should have installed and configured all necessary components of the SAS Enterprise Intelligence Platform. You must also have the following software and permissions set up:

- Microsoft Office 2007 or 2010 installed on your desktop.
- permissions to access the SAS Metadata Server. SAS support personnel at your site set these permissions and provide the name and location of the SAS Metadata Server.
• a metadata configuration file to specify which SAS Metadata Server you will connect to by default. This file enables you to access SAS data sources on remote servers. For more information about setting up a metadata configuration file, see the online Help for the SAS Add-In for Microsoft Office.

Enable the SAS Add-In in Microsoft Excel, Word, and PowerPoint

To create the examples in this document, the SAS Add-In 4.3 for Microsoft Office must be available in Excel, Word, and PowerPoint. If the SAS add-in is enabled in a specific Microsoft Office application, a SAS tab appears in the Ribbon for that Microsoft Office application. If the SAS tab is not available, contact the SAS support personnel at your site. An administrator might need to load the SAS add-in in a Microsoft Office application or use the SAS Add-In for Microsoft Office Utility to enable the SAS add-in in a Microsoft Office application.

For more information about loading the SAS add-in or the SAS Add-In for Microsoft Office Utility, see the online Help for the SAS Add-In for Microsoft Office.

Set Your Microsoft Office Documents to Support Macro-Enabled Content

The samples that you create in this book include macro-enabled content. When you save your Microsoft Office documents, you must use the file extensions for macro-enabled content. These file extensions are .x7m in Excel, .docm in Word, and .pptm in PowerPoint. When you open a Microsoft Office document that includes macro-enabled content, you want to be notified that this content is disabled.

To receive these notifications when you open macro-enabled content in Microsoft Excel, Word, or PowerPoint:

1. In Microsoft Office 2010, select File ⇒ Options.
2. In the selection pane, click Trust Center. The Trust Center panel appears.
3. Click Trust Center Settings. The Trust Center dialog box appears.
4. In the selection pane, click Macro Settings. The Macro Settings panel appears.
5. Select Disable all macros with notification, and then click OK.
6. Click OK to close the product-name Options dialog box.
7. Close and restart Microsoft Excel, Word, or PowerPoint to activate this option.

Now, when you open a Microsoft Office document that contains macro-enabled content, you are warned that some active content has been disabled. To enable the content in your Microsoft Office document:

1. In the warning message, click Options. The Microsoft Office Security Options dialog box appears.
2. Select Enable this content, and then click OK.
Trust Access to the Object Model for a Visual Basic Project

Many dialog boxes in the SAS Add-In for Microsoft Office include a range selection tool. This tool enables you to select a range of data in Microsoft Excel. To use this tool, your Microsoft Office application must be able to access the Visual Basic Model.

To trust access to the Visual Basic Model:
1. In Microsoft Office 2010, select File ➔ Options.
2. In the selection pane, click Trust Center. The Trust Center panel appears.
3. Click Trust Center Settings. The Trust Center dialog box appears.
4. In the selection pane, click Macro Settings. The Macro Settings panel appears.
5. Select Trust access to the VBA project object model, and then click OK.
6. Click OK to close the product-name Options dialog box.
7. Close and restart Microsoft Excel, Word, or PowerPoint to activate this option.

Configure Your Server Connection

You must configure the connection between the SAS Add-In for Microsoft Office and a SAS Metadata Server in order to copy the data for the Word and PowerPoint examples in this book. This connection is called a profile.

To configure your server connection:
1. In the Ribbon, click the SAS tab. In the Tools group, click Tools, and then select Connections.
2. In the selection pane, click Profiles to open the Profiles panel. From this panel, select a profile and click Set Active.
3. In the selection pane, click Servers to open the Servers panel. From the drop-down list, select the default server for the active profile.

**Tip:** To complete the Word and PowerPoint tasks, you will copy data from an Excel workbook to your default server. To access these data sources, you need to know the default server for your active profile. This book assumes that your default server is SASApp.

4. Click Close to close the Connections window.
Access to Samples and Input Data Sources

The samples that are used in this book are available from Product Page for the SAS Add-In for Microsoft Office.

For the Microsoft Excel samples, the input data for the SAS content is included in the Excel workbook. Because data sources cannot be saved in Word or PowerPoint, the data for these samples is saved in the RunFirst.xslm workbook. You must copy this data to a SAS server. After a data source is copied to a SAS server, the data source becomes a SAS data set, and you can use it like any other SAS data source.

To copy the data for the Word and PowerPoint samples to your SAS server:

1. Open Microsoft Excel and verify that the SAS tab is available in the Ribbon. The SAS add-in must be available in Microsoft Excel for you to copy the Excel data to the SAS server. If the SAS tab is not available, see “Enable the SAS Add-In in Microsoft Excel, Word, and PowerPoint” on page vi.

2. Open the RunFirst.xlsm workbook.

   Note: The RunFirst.xlsm workbook contains some macro-enabled content. To copy the data from the workbook to a SAS server, you must enable the document for macro-enabled content. For more information, see “Set Your Microsoft Office Documents to Support Macro-Enabled Content” on page vi.

3. In the Run First! worksheet, click Copy to Server. By default, the SAS Status for Microsoft Excel window appears.

   TIP The appearance of this window is controlled by the Show status window check box on the Results tab of the SAS Options dialog box. If you have deselected this check box, a dialog box still appears so you can monitor the progress of the job.

4. To verify that all of the data was copied to your SAS server, select Manage Content on the SAS tab. The Manage Content window appears and lists the seven data sets that were created on the SAS server.

   TIP The names of these data sets use the following format: server-name:library-name_data_set_name. For the examples in this book, the default server is SASApp and the library is SASDATA. When you see SASApp:SASDATA_data_set-name in this book, you might need to change this path to match the default server and library at your site.

5. Click Close to close the Manage Content window.

6. Close the RunFirst.xlsm workbook in Microsoft Excel.
The SAS Add-In for Microsoft Office includes accessibility and compatibility features that improve the usability of the product for users with disabilities, with some exceptions. These features are related to accessibility standards for electronic information technology adopted by the U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973, as amended. For more information about the accessibility of this product, see the online Help.

If you have questions or concerns about the accessibility of SAS products, send e-mail to accessibility@sas.com.
Accessibility Features of the SAS Add-In for Microsoft Office
Recommended Reading

- the online Help for the SAS Add-In 4.3 for Microsoft Office
- “Administering the SAS Add-In for Microsoft Office” in the *SAS 9.2 Intelligence Platform: Desktop Application Administration Guide*
- SAS offers instructor-led training and self-paced e-learning courses to help you get started with the SAS add-in, learn how the SAS add-in works with other products in the SAS Enterprise Intelligence Platform, and learn how to run stored processes in the SAS add-in. For more information about the courses available, see [support.sas.com/training](http://support.sas.com/training).

For a complete list of SAS publications, go to support.sas.com/bookstore. If you have questions about which titles you need, please contact a SAS Publishing Sales Representative:

SAS Publishing Sales  
SAS Campus Drive  
Cary, NC 27513-2414  
Phone: 1-800-727-3228  
Fax: 1-919-677-8166  
E-mail: sasbook@sas.com  
Web address: support.sas.com/bookstore
Chapter 1

Introduction to the SAS Add-In for Microsoft Office

What Is the SAS Add-In for Microsoft Office?

The SAS Add-In for Microsoft Office extends the functionality of Microsoft Excel, Microsoft Word, Microsoft PowerPoint, and Microsoft Outlook by enabling you to access SAS analytics and SAS reporting functionality without any SAS programming experience. The SAS add-in is designed for users who are familiar with these Microsoft Office applications but who might be new to SAS.

In general, the functionality of the SAS add-in is the same for Excel, Word, and PowerPoint. In all of these applications, you can run analyses, generate reports, and share this SAS content with other users at your site. Additional functionality is available in Microsoft Excel. For example, in Excel you can open and edit data sources.

Note: The functionality in Microsoft Outlook is unique. Using the native functionality in Outlook, you can monitor reports and dashboards and share this information with other users at your site. However, you cannot create new reports or run a SAS task in Outlook. Therefore, the functionality in Outlook is not covered in this documentation. For more information, see the online Help for the SAS add-in that is available in Microsoft Outlook.

The SAS add-in includes approximately 80 SAS tasks that enable you to perform a variety of analyses. Examples of analyses include linear and nonlinear regressions, multivariate analyses, time series analyses, one-way frequencies, and summary statistics. The SAS add-in enables you to refresh these analyses so that your results include the most up-to-date information. You can also easily share the results with other users at your site.

Using the SAS add-in, you can also open reports or stored processes that were created in other SAS applications, such as SAS Enterprise Guide or SAS Web Report Studio. These reports are saved in a common repository, which enables all SAS users at your site to get the most up-to-date information.

When the SAS add-in is installed on your computer, a SAS tab is automatically integrated into the Ribbon in Excel, Word, and PowerPoint 2007 and 2010. The SAS tab enables you to access the SAS analytics and reporting functionality directly from these
Microsoft Office applications without opening a separate SAS interface. The instructions in this documentation were written for Microsoft Office 2007 or Microsoft Office 2010.

Note: If you are using Microsoft Office 2003, you can still complete the tasks in this documentation. However, the user interface for the SAS add-in is different between Microsoft Office 2003 and Microsoft 2007. For example, in Microsoft Office 2003, the SAS options are located on the SAS menu rather than the SAS tab.

Benefits to Using the SAS Add-In for Microsoft Office

Most of the SAS add-in functionality is identical in Excel, Word, and PowerPoint. For example, you can run analyses and reports in all three applications.

The SAS add-in extends the functionality in Excel, Word, and PowerPoint by enabling you to perform these tasks:

- Access SAS data sources as the input data for your analysis. You can use any SAS data source or any data source that is available from your SAS server (including databases such as Oracle, Teradata, and DB2) as the input data for an analysis.
- Perform more complex analyses and computations than what is available in Microsoft Excel. For example, one of the complex analyses that SAS provides is the Canonical Correlation task. This task enables you to examine the relationship between a linear combination of a set of X variables and a linear combination of a set of Y variables. You might run a canonical correlation analysis to determine the degree of correspondence between a set of job characteristics and a set of measures of employee satisfaction. This SAS task extends the correlation analysis that is available in Excel. You can run these complex analyses and computations in Excel, Word, or PowerPoint.
- Run custom analyses that were developed by other users at your company. Using the SAS add-in, you can also open reports that were developed by SAS Enterprise Guide or SAS Web Report Studio users at your site. Some of these reports might run programs called SAS Stored Processes. These programs are customized SAS code that is developed by business analysts or your IT department. Running these programs enables you to quickly generate a custom report without writing any SAS code.
- Refresh the content in the Excel worksheet, Word document, or PowerPoint presentation on demand or automatically at a specified time. Scheduling when the content is refreshed enables you to have the most up-to-date data and reports when you need them.
- Send the SAS content to another Microsoft Office application. For example, you ran an analysis of your company's sales for this year, and now you need to present the results. Using this functionality in Excel, you can select which results to include in a PowerPoint presentation. This saves you time because you run the analysis only once.
- Save the results to a central repository. When you save a document to a central repository, you can share this information with other users without e-mailing it. If you save the document to a metadata repository (such as SAS Folders), you can also perform an impact analysis on the document. Impact analysis enables you to know the location of the data source and the items that are dependent on this source. This
analysis enables you to know how changing a data source might affect other documents.

Additional functionality is available in Excel. In Microsoft Excel, you can also complete these tasks:

- Access and view data sources that exceed the record limitation in Microsoft Excel. The SAS add-in does its processing on the server, which enables the SAS add-in to bypass the record limitation in Excel.
- Copy data to a SAS server. You can copy an Excel data source or a SAS data source to a SAS server. After a data source is copied to a SAS server, the data source becomes a SAS data set. This enables you to share Excel data with Word and PowerPoint users at your site. This functionality also enables Excel users to update information in a SAS data source and upload the updated data source to the SAS server.
- Edit any data source that is accessible from a SAS server. You open the data set in edit mode in Excel. While the data set is in edit mode, the data set is locked and cannot be opened by other users at your site. After you edit the data, you commit your changes to the SAS server and update the existing data set.
- Use the OLAP Viewer to view data that is stored in an OLAP (online analytical processing) cube. In Microsoft Excel 2007 and 2010, you can use the OLAP Viewer to create table and graph views of your data. You can also drill down through the data, create bookmarks, add calculated measures and calculated members, filter the OLAP data, and view ESRI maps.

This documentation explores some of the basic tasks that you can perform in Excel, Word, and PowerPoint.

---

**How to Use the SAS Add-In for Microsoft Office**

In Microsoft Office 2010 and Microsoft Office 2007, the SAS add-in is available from the SAS tab in the Ribbon. You access the SAS add-in from the menu options on this tab.

*Note:* If you do not see a SAS tab, then you might not have the SAS add-in installed. For help, contact the SAS support personnel at your site.

You can perform a variety of tasks using the SAS add-in. The following process briefly explains how you would run a SAS analysis:

1. Open Microsoft Excel, Word, or PowerPoint.
2. Select the analysis that you want to perform.

   *Note:* After you select the analysis, you might be prompted to log on to the SAS server. You must be connected to a SAS server to run an analysis or to access a SAS data source.
3. Select the data source that you want to use in the analysis. In Excel, you can use data in an existing Excel worksheet or in a SAS data source. If you select a SAS data source, you can filter and sort the data before the analysis.

4. Select the options in the analysis that you want to use, and then run the analysis.

5. Specify the location of the output. For example, in Excel you can include the results in the existing worksheet, in a new worksheet, or in a new workbook.

The results open in the Microsoft Office document.
Chapter 2
Adding SAS Content to a Microsoft Excel Workbook

About the Tasks That You Will Perform
- How to Access the Input Data Source
- Generate the Summary Statistics for the Federal Reserve Data
- Apply a Style to the Summary Statistics Results
- Apply the Same Style to All Future Results
- Adding Results to an Existing Worksheet
- Calculate the Federal Reserve Rate
- Display the Historical and Predicted Rate Values in a Line Plot
- Recalculate the Federal Reserve Rates with the Click of a Button
- Plot the Federal Reserve Rates over Time

About the Tasks That You Will Perform

For this example, you are researching the trend of the Federal Reserve rate from January 1962 to May 2010. The data is publicly available from http://www.federalreserve.gov, which is the Web site for the Board of Governors of the Federal Reserve System.

After completing this example, you will know how to perform these tasks:
- run a SAS analysis (specifically, the Summary Statistics, Linear Regression, and Line Plot tasks) in Microsoft Excel
- specify Excel data as the input data source for a SAS task
- select the location of the output from a SAS task
- change the properties of the generated output
- quickly refresh your results by including Visual Basic code in your Excel worksheet

How to Access the Input Data Source

Before you can run any analysis, you need access to the input data source.
To copy the data for the Federal Reserve sample:

1. Open the FedReserveRate.xlsm sample.
2. In the Original Data worksheet, select the data in range A15:B12638.
3. Copy the data from the Original Data worksheet and paste the data into Sheet1 in a new workbook.
4. Change the name of this worksheet to **Original Data**.
5. Save the new workbook on your computer as **FedReserveRate.xlsm**.

---

**Generate the Summary Statistics for the Federal Reserve Data**

Now that you have access to the input data source, you can start your analysis.

1. On the **SAS** tab, click **Tasks** and select **Describe ➔ Summary Statistics Wizard**. The Choose Data dialog box appears.
2. For the input data, select **Excel Data** and specify the range of the Excel data in the Original Data worksheet.
   
   **TIP** If your input data source is selected in Excel, then the SAS add-in automatically lists this range in the **Excel Data** box.

3. For the location of the results, select **New worksheet**. Change the name of this worksheet to **Summary Statistics**.

   ![Choose Data Dialog Box]

   Click **OK**. The Summary Statistics Wizard appears.

4. In step 1 of the wizard, verify that you have selected the data source that you want to use. Click **Next**.
5. In step 2 of the wizard, assign the VALUE variable to the **Summary statistics of (Analysis variable)** role.
Click Next.

6. In step 3 of the wizard, click Next to generate the default summary statistics. In step 4 of the wizard, delete the text for the footnote, and then click Finish. The results open in a new worksheet called Summary Statistics.

Notice that the style of the results does not match your corporate style.

### Apply a Style to the Summary Statistics Results

To apply a style to the results from the Summary Statistics Wizard:

1. Select the summary statistics results in the worksheet, and on the SAS tab, click Properties. The Summary Statistics Wizard Properties dialog box appears.

2. Click the Appearance tab, and select the Apply style check box. By default, the SAS Add-In for Microsoft Office uses the AMODefault style for any results. In this example, Seaside is selected from the list.
3. Select the **Refresh** check box to refresh the results after you close the Summary Statistics Wizard Properties dialog box. Click **OK**.

The SAS add-in refreshes the results and applies the newly selected style.

---

**Apply the Same Style to All Future Results**

These steps apply the Seaside style only to the results from the Summary Statistics Wizard. However, you want to use your company’s style for all results in this workbook. To globally apply a style to the results:

1. On the **SAS** tab, click **Tools**, and then select **Options**. The SAS Options dialog box appears.
2. Click the Results tab.

3. In the Format area, select Apply style, and then from the list, select the style that you want to apply. In this example, Seaside is selected.

![Image of SAS Options window with Format and Apply style settings]

Click OK.

Now, any future results will use the style that you selected.

---

**Adding Results to an Existing Worksheet**

Next, you want to perform a linear regression analysis and add the results to the Summary Statistics worksheet. To run a linear regression analysis:

1. In the Original Data worksheet, select the Excel data.

2. On the SAS tab, click Tasks and select Regression → Linear Regression. The Choose Data dialog box appears.

3. For the input data source, select Excel data. By default, the input data source is the range of Excel data on the Original Data worksheet. You can also use to select the input data.

4. For the location of the results, select Existing worksheet, and then click . In the Summary Statistics worksheet, select cell G1. In the Choose Location dialog box, click OK.

*Note: If the button is not available, then see “Trust Access to the Object Model for a Visual Basic Project” on page vii.*

After completing these steps, the content in your Choose Data dialog box should look similar to the following display:
Click **OK**. The Linear Regression task appears.

5. In the **Data** panel, assign the **VALUE** variable to the **Dependent variable** role.

![Image of the Choose Data window]

In the selection pane, click **Titles**.

6. In the **Titles** panel, select **Footnote**, and then deselect the **Use default text** check box. Delete the text in the **Text for section: Footnote** box.

Click **Run**.

The results from the linear regression analysis open in the Summary Statistics worksheet. Because Seaside was selected as the style for the results in the SAS Options dialog box, the results from the Linear Regression task automatically use the Seaside style.
Calculate the Federal Reserve Rate

Next, use the functionality in Microsoft Excel to predict the Federal Reserve rate over the next six days. You want these calculated values to appear in a table and in a line plot.

To calculate the Federal Reserve rate for the next six days:

1. Create a new worksheet called **Basic Forecasting**.
2. In the new worksheet, specify Date and Rate as column headings.
3. From the Original Data worksheet, copy the data from 2010-04-27 through 2010-05-20, and paste it into the Basic Forecasting worksheet.
5. In the Rate column, specify the following formula for the new dates:

   \[
   \text{yesterday's rate} + \frac{(\text{RANDBETWEEN(-100, 100)})}{100}/2
   \]

   In this example, the formula for the B23 cell is B22+(RANDBETWEEN(-100,100)/100)/2.

Although the calculated values could vary, your results should appear similar to this display:
Display the Historical and Predicted Rate Values in a Line Plot

Now, you want to create a line plot of the historical data and the calculated values.

1. In the Basic Forecasting worksheet, select the Excel data.

2. On the SAS tab, click Tasks and select Graph ➔ Line Plot. The Choose Data dialog box appears.

3. For the input data source, select Excel Data. Because you previously selected the data, the range of data appears in the Excel Data box. In this example, the range of the Excel data is A4:B28.

4. For the location of the results, select Existing worksheet. Then click and select the location of the output. In this example, the output is placed in cell A3.

After completing these steps, the content in your Choose Data dialog box should look similar to this display:
The Line Plot task appears.

5. In the **Line Plot** panel, select **Line Plot**.

In the selection pane, click **Data**.

6. In the **Data** panel, assign Date to the **Horizontal** role, and assign Rate to the **Vertical** role.
7. In the **Chart Area** panel, select gray as the background color of the chart.

8. In the **Titles** panel, change the title of the line plot and remove the generated footnote.

   To change the title of the line plot:
   a. In the **Section** box, select **Graph**.
   b. In the **Text for section: Title** area, deselect the **Use default text** check box.

   Replace **Line Plot** with **Simulated Federal Reserve Rate**.

   To remove the footnote:
   a. In the **Section** box, select **Footnote**.
b. In the **Text for section: Footnote** area, deselect the **Use default text** check box. Delete the generated text that appears in the text box.

Click **Run.**

The new line plot appears in the Basic Forecasting worksheet. The output from the Line Plot task is larger than the single cell that you specified in the Choose Data dialog box. Therefore, the SAS add-in shifted the Excel data to the right to make room for the line plot.
Recalculate the Federal Reserve Rates with the Click of a Button

Using Visual Basic code, you can add a button to the Basic Forecasting worksheet. Now, with the click of that button, you can recalculate the Federal Reserve rate and update the contents of the table and the line plot.

1. In the Ribbon, click the Developer tab.
2. In the Controls group, click Insert, and under ActiveX Controls, select the icon for the command button.
3. In the Excel worksheet, select the region where you want the button to appear.
4. To change the text on this button, select **Properties** on the **Developer** tab. The Properties dialog box appears.

5. In the **Caption** field, type **Simulate**.

Close the Properties dialog box. In the worksheet, the button text now reads **Simulate**.
6. Double-click **Simulate** to open the Visual Basic Editor. The code for the CommandButton1_Click is created for you.

Next, it is important that you add a reference to the SAS Add-In 4.3 for Microsoft Office in your Visual Basic code.

7. In the Visual Basic Editor, select **Tools ⇒ References**. The References - VBAProject dialog box appears.

8. Select the **SAS Add-In 4.3 for Microsoft Office** check box.
Click OK.

9. To access the automation interface for the SAS Add-In for Microsoft Office, enter the following lines of code:

```vba
Dim sas As SASExcelAddIn
Set sas = Application.COMAddIns.Item("SAS.ExcelAddIn").Object
```

10. For Excel to recalculate the forecasts by using the formulas that you specified, add this code:

```
Application.Calculate
```

11. To refresh the line plot to reflect the recalculated forecasts, add this code:

```vba
sas.Refresh ("Line_Plot")
```

*Note*: The object name for your line plot might be different. To verify the object name for your line plot, select the line plot in the Basic Forecasting worksheet, and on the SAS tab, select **Properties**. The object name is available from the **General** tab in the Line Plot Properties dialog box.

After adding these additional lines of code, the code in your Visual Basic Editor should appear similar to the following display:

12. Save your changes and close the Visual Basic Editor.

13. On the **Developer** tab, deselect **Design Mode**.

14. In the Basic Forecasting worksheet, click **Simulate**. The forecasts in the table are recalculated, and the line plot is updated to show the recalculated rates.
Plot the Federal Reserve Rates over Time

Finally, you want to observe how the Federal Reserve rate has changed over time. To quickly determine any trends, you decide to create a line plot of the Federal Reserve rates from January 2, 1962, to May 20, 2010.

1. In the Original Data worksheet, select the Excel data.

2. On the SAS tab, click Tasks and select Graph ⇒ Line Plot. The Choose Data dialog box appears.

3. For the input data, select Excel Data. Because you previously selected the data in the Original Data worksheet, the range of the data appears in the Excel Data box.

4. For the location of the results, select New worksheet. By default, the name of this worksheet is Line Plot.

   Click OK. The Line Plot task appears.

5. In the Data panel, assign DATE to the Horizontal role and VALUE to the Vertical role.

   In the selection pane, select Appearance ⇒ Plots.
6. In the **Appearance > Plots** panel, specify blue as the line color.

![Image of Appearance > Plots panel]

In the selection pane, select **Appearance ⇒ Axes ⇒ General**.

7. In the **Appearance > Axes > General** panel, select the **Display Grid Lines** check box.

![Image of Appearance > Axes > General panel]

In the selection pane, select **Appearance ⇒ Axes ⇒ Horizontal Axis ⇒ Major Ticks**.

8. In the **Appearance > Axes > Horizontal Axis > Major Ticks** panel, select **Specify**, and then add the following values for the major tick marks:

- 02JAN1962
- 25JAN1970
- 17FEB1978
- 12MAR1986
- 04APR1994
- 27APR2002
- 20MAY2010
In the selection pane, select **Appearance > Axes > Vertical Axis > Axis**.

9. In the **Appearance > Axes > Vertical Axis > Axis** panel, enter **Federal Reserve Rate** in the **Label** field.

In the selection pane, select **Chart Area**.

10. In the **Chart Area** panel, select gray as the background color for the chart.
In the selection pane, click Titles.

11. In the Titles panel, change the title of the line plot and remove the generated footnote.

To change the title of the line plot:

a. In the Section box, select Graph.

b. In the Text for section: Title area, deselect the Use default text check box. Replace Line Plot with Federal Reserve Rate over Time.

To remove the footnote:

a. In the Section box, select Footnote.

b. In the Text for section: Footnote area, deselect the Use default text check box. Delete the generated text that appears in the text box.
Click **Run**.

The results appear in the new Line Plot worksheet.
Chapter 3
Adding SAS Content to a Microsoft Word Document

About the Tasks That You Will Perform ................................................. 25
Access to the Input Data Source ......................................................... 25
Sort the Soccer Teams by Number of Wins and Conference ............... 26
  Step 1: Run the Sort Data Task on All of the Data .................. 26
  Step 2: Run the Sort Data Task on Teams in the Eastern Conference ... 28
  Step 3: Run the Sort Data Task on the Teams in the Western Conference ... 30
Generate a Report .............................................................. 31
Apply a Style to the Results ..................................................... 34
Specify the Contents of the Report with a Click of a Button ............. 38

About the Tasks That You Will Perform

For this example, you are the organizer of a local soccer league. This league has several teams that are divided into two conferences. It is the end of the season, and you need to seed the teams for the upcoming tournament.

After completing this example, you will know how to perform these tasks:
  • run a SAS analysis (specifically, the List Data task) in Microsoft Word
  • use a SAS data source as the input data source for the task
  • select the location of the output
  • quickly subset and rank data by including Visual Basic code in your Microsoft Word document

Access to the Input Data Source

Before you can analyze the soccer data in Microsoft Word, you must copy the necessary data to your SAS server. For more information, “Access to Samples and Input Data Sources” on page viii.

When this copy operation completes, the _SoccerClub data set should be available from the SASData library on your default server. In this example, the location of this data set is the SASApp:SASApp - SASDATA directory.
Sort the Soccer Teams by Number of Wins and Conference

To complete this example, you must run the Sort Data task three times: once to sort all of the soccer teams by number of wins; once to sort the teams in the Eastern Conference; and once to sort the teams in the Western Conference. The Sort Data task generates an output SAS data set that is saved to your default server. This data set is used later as the input data source for the List Data task. The contents of the data set change depending on which Sort Data task you run.

Step 1: Run the Sort Data Task on All of the Data

Create a Temporary Data Set
First, create a temporary data set that lists all of the soccer teams in the league by number of wins.

1. Open Microsoft Word.
2. On the SAS tab, click Tasks, and then select Data ⇒ Sort Data. The Choose Data dialog box appears.
3. Click Browse. The Open Data Source dialog box appears.
4. To open the _SoccerClub data set:
   a. In the selection pane, select Servers.
   b. From the list of servers, select your default server. In this example, the default server is SASApp.
   c. From your default server, select the SASDATA library and click Open. In this example, the library name is SASApp - SASDATA.
   d. In the SASDATA library, select the _SOCCERCLUB data set.

Click Open. Now, the contents of the Choose Data dialog box should appear similar to the following display:
Click OK. The Sort Data task appears.

5. In the Data panel, assign the W variable to the Sort by role. From the W sort order drop-down list, select Descending.

In the selection pane, click Results.

6. In the Results panel, change the directory path in the Location to save output data field to default-server:WORK.SOCERCLUB. This path is where the temporary data set will be saved. You will need this information to run the List Data task later.

For this example, the default location is SASApp:WORK.SOCERCLUB.

Click Run.

The Sort Data task generates the SoccerClub data set in the Work library. However, there is no visual output for this task, so when the task completes, you see the following message:

Click OK.
Determine the Object Name for the Sort Data Task
To run this Sort Data task by using Visual Basic code, you need the object name that the SAS add-in assigned to this task. To determine this object name:

1. On the SAS tab, click Manage Content. The Manage Content window appears. The Sort Data task is listed in this window.

2. Select the Sort Data task and click . The Sort Data Properties dialog box appears.

3. On the General tab, remember the object name for this task. In this example, the object name is Sort_Data. You will use this object name later in this chapter.

4. Close the Sort Data Properties dialog box and the Manage Content window.

Step 2: Run the Sort Data Task on Teams in the Eastern Conference

Create a Temporary Data Set for the Eastern Conference
Now, you need to create a temporary data set for the teams in the Eastern Conference.

1. On the SAS tab, click Tasks, and then select Data ⇒ Sort Data. The Choose Data dialog box appears.

2. Select the _SOCCERCLUB data set as your input data source. In this example, the path to the input data source is SASApp:SASApp — SASDATA_SОСCERCLUB.

3. Click Filter & Sort. The Modify Data Source window appears.

4. Click the Filter tab.

5. To create this filter:
   a. In the first drop-down list, select Conference.
   b. In the second drop-down list, select Equal to.
   c. In the text box, enter EC. You can also click to select this value.
6. In the Choose Data dialog box, click Details. These details show that the filter is applied to your input data source.

Click OK to apply this filter.

7. In the Data panel, assign the W variable to the Sort by role. From the W sort order drop-down list, select Descending.

In the selection pane, click Results.

8. In the Results panel, change the directory path in the Location to save output data field to default-server:WORK.SOCERCLUB. This path is where the temporary data set will be saved. You will need this information to run the List Data task later.

For this example, the default location is SASapp:WORK.SOCERCLUB.

9. Click Run. If you are prompted to replace an existing data set, click Yes.

The Sort Data task overwrites the SoccerClub data set in the Work library. Now, this data set contains only the teams in the Eastern Conference.

**Determine the Object Name for the Second Sort Data Task**

To run this Sort Data task by using Visual Basic code, you need the object name that the SAS add-in assigned to this task. To determine this object name:

1. On the SAS tab, click Manage Content. The Manage Content window appears. Now, there are two Sort Data tasks listed in this window.
2. Select the second Sort Data task and click \[ \text{Sort Data} \] The Sort Data Properties dialog box appears.

3. On the **General** tab, remember the object name for this task. In this example, the object name is \text{Sort\_Data\_2}. You will use this object name later in this chapter.

4. Close the Sort Data Properties dialog box and the Manage Content window.

**Step 3: Run the Sort Data Task on the Teams in the Western Conference**

**Create a Temporary Data Set for the Western Conference**

Now, you need to create a temporary data set for the teams in the Western Conference.

1. On the **SAS** tab, click **Tasks**, and then select **Data** \( \Rightarrow \text{Sort Data} \). The Choose Data dialog box appears.

2. For the input data source, select the \_SOCCKERCLUB data set. In this example, the path to the input data source is \text{SASApp:SASApp \rightarrow SASDATA\_SOCCKERCLUB}.

3. Click **Filter & Sort**. The Modify Data Source window appears.

4. Click the **Filter** tab.

5. To create the filter:
   a. In the first drop-down list, select **Conference**.
   b. In the second drop-down list, select **Equal to**.
   c. In the text box, enter **WC**. You can also click \( \text{\&} \) to select this value.

   Click **OK** to apply this filter.

6. In the Choose Data dialog box, click **Details**. These details show that the filter is applied to your input data source.

   ![Choose Data Window]

   Click **OK**. The Sort Data task appears.

7. In the Sort Data task, select **Data** in the selection pane. In the **Data** panel, assign the \( W \) variable to the **Sort by** role. From the **W sort order** drop-down list, select **Descending**.

8. In the selection pane, click **Results**. In the **Results** panel, the **Location to save output data** field lists the directory path where this temporary data set will be saved. You will need this information to run the List Data task later. For this example, change the default location to \text{SASApp:WORK\_SOCCKERCLUB}.

   Click **Run**. If you are prompted to replace an existing data set, click **Yes**.
Determine the Object Name for the Third Sort Data Task

To run this Sort Data task by using Visual Basic code, you need the object name that the SAS add-in assigned to this task. To determine this object name:

1. On the SAS tab, click Manage Content. The Manage Content window appears. Now, there are three Sort Data tasks listed in this window.

   ![Manage Content Window]

2. Select the third Sort Data task and click ![Sort Data Properties Dialog Box]. The Sort Data Properties dialog box appears.

3. On the General tab, remember the object name for this task. In this example, it is Sort_Data_3. You will use this object name later in this chapter.

4. Close the Sort Data Properties dialog box and the Manage Content window.

---

Generate a Report

Now that you have created the data for this example, you want to generate a report that lists all the teams by number of wins.

1. On the SAS tab, click Manage Content. The Manage Content window appears.

2. Select the check box for the first Sort Data task and click Refresh. When the refresh is complete, the date-and-timestamp in the Date Modified column is updated.

   ![Manage Content Window with Refresh]

   With this refresh, the Work.SoccerClub data set contains all of the teams in the soccer league. Click Close to exit the Manage Content dialog box.

3. On the SAS tab, click Tasks, and then select Describe ➔ List Data. The Choose Data dialog box appears.

4. Select the Work.SoccerClub data set as your input data source. In this example, the path to the input data source is SASApp:WORK.SOCGERCLUB.
Click **OK**. The List Data task appears.

5. In the **Data** panel, assign all variables to the **List variables** role.

In the selection pane, click **Options**.

6. In the **Options** pane, deselect the **Print row number** check box.

In the selection pane, click **Titles**.

7. In the **Titles** pane, remove the default title and footnote.
   a. In the **Section** box, select **Report Titles**.
   b. In the **Text for section: Report Titles** area deselect the **Use default text** check box. Delete the generated text that appears in the text box.

Repeat these steps to remove the default text for the footnote. Then click **Run**.

The results from the List Data task open in your Microsoft Word document.
<table>
<thead>
<tr>
<th>Club</th>
<th>PTS</th>
<th>GP</th>
<th>W</th>
<th>L</th>
<th>T</th>
<th>GF</th>
<th>GA</th>
<th>GD</th>
<th>Conference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles Milky-Way</td>
<td>26</td>
<td>10</td>
<td>8</td>
<td>0</td>
<td>2</td>
<td>16</td>
<td>2</td>
<td>14</td>
<td>WC</td>
</tr>
<tr>
<td>Columbus Crazies</td>
<td>20</td>
<td>8</td>
<td>6</td>
<td>0</td>
<td>2</td>
<td>14</td>
<td>6</td>
<td>8</td>
<td>EC</td>
</tr>
<tr>
<td>New York Raging Rhinos</td>
<td>15</td>
<td>9</td>
<td>5</td>
<td>4</td>
<td>0</td>
<td>9</td>
<td>12</td>
<td>-3</td>
<td>EC</td>
</tr>
<tr>
<td>San Jose Tremors</td>
<td>16</td>
<td>8</td>
<td>5</td>
<td>2</td>
<td>1</td>
<td>12</td>
<td>7</td>
<td>5</td>
<td>WC</td>
</tr>
<tr>
<td>Salt Lake Fire</td>
<td>16</td>
<td>9</td>
<td>5</td>
<td>3</td>
<td>1</td>
<td>17</td>
<td>10</td>
<td>7</td>
<td>WC</td>
</tr>
<tr>
<td>Houston Dynamite</td>
<td>16</td>
<td>10</td>
<td>5</td>
<td>4</td>
<td>1</td>
<td>14</td>
<td>10</td>
<td>4</td>
<td>WC</td>
</tr>
<tr>
<td>Toronto Tundra</td>
<td>13</td>
<td>9</td>
<td>4</td>
<td>4</td>
<td>1</td>
<td>12</td>
<td>13</td>
<td>-1</td>
<td>EC</td>
</tr>
<tr>
<td>Colorado Canyons</td>
<td>13</td>
<td>8</td>
<td>4</td>
<td>3</td>
<td>1</td>
<td>9</td>
<td>7</td>
<td>2</td>
<td>WC</td>
</tr>
<tr>
<td>Seattle Snakes</td>
<td>12</td>
<td>10</td>
<td>3</td>
<td>4</td>
<td>3</td>
<td>9</td>
<td>13</td>
<td>-4</td>
<td>WC</td>
</tr>
<tr>
<td>Galloping Goats</td>
<td>10</td>
<td>10</td>
<td>3</td>
<td>6</td>
<td>1</td>
<td>11</td>
<td>14</td>
<td>-3</td>
<td>WC</td>
</tr>
<tr>
<td>Chicago FC</td>
<td>10</td>
<td>9</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>12</td>
<td>13</td>
<td>-1</td>
<td>EC</td>
</tr>
<tr>
<td>New England Reds</td>
<td>8</td>
<td>10</td>
<td>2</td>
<td>6</td>
<td>2</td>
<td>10</td>
<td>15</td>
<td>-5</td>
<td>EC</td>
</tr>
<tr>
<td>Kansas City Commodores</td>
<td>8</td>
<td>8</td>
<td>2</td>
<td>4</td>
<td>2</td>
<td>8</td>
<td>9</td>
<td>-1</td>
<td>EC</td>
</tr>
<tr>
<td>Dallas Cowpokes</td>
<td>12</td>
<td>10</td>
<td>2</td>
<td>2</td>
<td>6</td>
<td>11</td>
<td>11</td>
<td>0</td>
<td>WC</td>
</tr>
<tr>
<td>Philadelphia Quakes</td>
<td>4</td>
<td>7</td>
<td>1</td>
<td>5</td>
<td>1</td>
<td>17</td>
<td>15</td>
<td>-8</td>
<td>EC</td>
</tr>
<tr>
<td>D.C. FC</td>
<td>3</td>
<td>9</td>
<td>1</td>
<td>8</td>
<td>0</td>
<td>4</td>
<td>18</td>
<td>-14</td>
<td>EC</td>
</tr>
</tbody>
</table>
Apply a Style to the Results

By default, any generated results use the AMODefault style. However, you can change the style of the results by using a style that ships with the SAS add-in or by creating your own style. For this example, you want to apply a custom style to the results.

To create a custom style:

1. In the document, select the results from the List Data task, and on the SAS tab, click Properties. The List Data Properties dialog box appears.
2. In the List Data Properties dialog box, click the Appearance tab.
3. On the Appearance tab, select the Apply style check box.

Click Manage Styles. The Style Manager appears.

4. In the Style Manager, click Add. The Add New Style dialog box appears.
5. To create a new style based on an existing style:
   a. Select Add new based on existing style.
   b. Enter SoccerClub as the name of the new style.
   c. From the Based on drop-down list, select AMODefault.
   d. Click OK.

The new SoccerClub style is now available from the Style Manager.
Currently, the SoccerClub style is identical to the AMODefault style. To customize the new SoccerClub style, you must edit it.

6. In the Style Manager, select the **SoccerClub** style and click **Edit**. The Style Editor appears.

7. To customize the text in the body of your results:
   a. From the **Selected element** drop-down list, select **Body**.
   b. Click the **Text** tab and change the following options:
      - Select Arial as the font.
      - Set the text size to 8 point font.
      - Change the background color to a shade of light blue.
8. To apply these text attributes to the column headings, click **Apply to Other Elements**. The Apply To Other Elements dialog box appears. From the list of style elements, select the check box for **Header** and click **OK** to return to the Style Editor.

9. To specify the attributes for the borders in the Style Editor, click the **Borders** tab, and specify the following options:
   - From the **Line Style** drop-down list, select **Solid**.
   - From the **Line Width** drop-down list, select **Thin**.

   Click **OK** in the Style Editor and in the Style Manager to return to the List Data Properties dialog box.

10. In the List Data Properties dialog box, verify that SoccerClub is the selected style. Select the **Refresh** check box and click **OK**.

Because you selected the **Refresh** check box, the content is immediately refreshed and the style is applied to the results.
<table>
<thead>
<tr>
<th>Club</th>
<th>PTS</th>
<th>GP</th>
<th>W</th>
<th>L</th>
<th>T</th>
<th>GF</th>
<th>GA</th>
<th>GD</th>
<th>Conference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles Milky-Way</td>
<td>26</td>
<td>10</td>
<td>8</td>
<td>0</td>
<td>2</td>
<td>16</td>
<td>2</td>
<td>14</td>
<td>WC</td>
</tr>
<tr>
<td>Columbus Crazies</td>
<td>20</td>
<td>8</td>
<td>6</td>
<td>0</td>
<td>2</td>
<td>14</td>
<td>6</td>
<td>8</td>
<td>EC</td>
</tr>
<tr>
<td>New York Raging Rhinos</td>
<td>15</td>
<td>9</td>
<td>5</td>
<td>0</td>
<td>9</td>
<td>12</td>
<td>6</td>
<td>-3</td>
<td>EC</td>
</tr>
<tr>
<td>San Jose Tremors</td>
<td>16</td>
<td>8</td>
<td>5</td>
<td>2</td>
<td>1</td>
<td>12</td>
<td>7</td>
<td>5</td>
<td>WC</td>
</tr>
<tr>
<td>Salt Lake Fire</td>
<td>16</td>
<td>9</td>
<td>5</td>
<td>3</td>
<td>1</td>
<td>17</td>
<td>10</td>
<td>7</td>
<td>WC</td>
</tr>
<tr>
<td>Houston Dynamite</td>
<td>16</td>
<td>10</td>
<td>5</td>
<td>4</td>
<td>1</td>
<td>14</td>
<td>10</td>
<td>4</td>
<td>WC</td>
</tr>
<tr>
<td>Toronto Tundra</td>
<td>13</td>
<td>9</td>
<td>4</td>
<td>4</td>
<td>1</td>
<td>12</td>
<td>13</td>
<td>-1</td>
<td>EC</td>
</tr>
<tr>
<td>Colorado Canyons</td>
<td>13</td>
<td>8</td>
<td>4</td>
<td>3</td>
<td>1</td>
<td>9</td>
<td>7</td>
<td>2</td>
<td>WC</td>
</tr>
<tr>
<td>Seattle Snakes</td>
<td>12</td>
<td>10</td>
<td>3</td>
<td>4</td>
<td>3</td>
<td>9</td>
<td>13</td>
<td>-4</td>
<td>WC</td>
</tr>
<tr>
<td>Galloping Goats</td>
<td>10</td>
<td>10</td>
<td>3</td>
<td>6</td>
<td>1</td>
<td>11</td>
<td>14</td>
<td>-3</td>
<td>WC</td>
</tr>
<tr>
<td>Chicago FC</td>
<td>10</td>
<td>9</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>12</td>
<td>13</td>
<td>-1</td>
<td>EC</td>
</tr>
<tr>
<td>New England Reds</td>
<td>6</td>
<td>10</td>
<td>2</td>
<td>6</td>
<td>2</td>
<td>10</td>
<td>15</td>
<td>-5</td>
<td>EC</td>
</tr>
<tr>
<td>Kansas City Commodores</td>
<td>8</td>
<td>8</td>
<td>2</td>
<td>4</td>
<td>2</td>
<td>8</td>
<td>9</td>
<td>-1</td>
<td>EC</td>
</tr>
<tr>
<td>Dallas Cowpokes</td>
<td>12</td>
<td>10</td>
<td>2</td>
<td>2</td>
<td>6</td>
<td>11</td>
<td>11</td>
<td>0</td>
<td>WC</td>
</tr>
<tr>
<td>Philadelphia Quakes</td>
<td>4</td>
<td>7</td>
<td>1</td>
<td>5</td>
<td>1</td>
<td>7</td>
<td>15</td>
<td>-5</td>
<td>EC</td>
</tr>
<tr>
<td>D.C. FC</td>
<td>3</td>
<td>9</td>
<td>1</td>
<td>8</td>
<td>0</td>
<td>4</td>
<td>18</td>
<td>-14</td>
<td>EC</td>
</tr>
</tbody>
</table>
Specify the Contents of the Report with a Click of a Button

Next, you want to create reports that display the teams for a specific conference or all of the teams in both conferences. By adding Visual Basic Code to your document, you can quickly create these reports with the click of a button.

1. In the Word document, select the location for the button.
2. In the Ribbon, click the Developer tab.
3. In the Controls group, click , and under the ActiveX Controls heading, click the icon for the command button.

The button appears at the location that you selected.
4. To change the text on this button, select **Properties** on the **Developer** tab. The **Properties** dialog box appears.

5. In the **Caption** field, type **All**.
6. Select the **Font** field. Click ![Font](image) The Font dialog box appears. Specify the font size for the button text and click **OK**. In this example, the font size is 7 points.

Close the Properties dialog box. In the document, the button is now labeled “All” and appears in the specified font.
7. Create the buttons for the eastern and western conferences.
   
a. Select the location for the button for the eastern conference and repeat steps 2–5.
   
   The caption for this button is **Eastern Conference**.

b. Select the location for the button for the western conference and repeat steps 2–5.

   The caption for this button is **Western Conference**.

When you are finished, you should have three buttons in your document, as shown in the following display.
8. Double-click **All** to open the Visual Basic Editor. The command button code for this button is created for you.

Next, it is important that you add a reference to the SAS Add-In 4.3 for Microsoft Office in your Visual Basic code.

9. In the Visual Basic Editor, select **Tools** ⇒ **References**. The References - Project dialog box appears.
10. Select the **SAS Add-In 4.3 for Microsoft Office** check box.

Click **OK**.

11. To access the automation interface for the SAS Add-In for Microsoft Office, add the following lines of code:

```vba
Dim sas As SASWordAddIn
Set sas = Application.COMAddIns.Item("SAS.WordAddIn").Object
```

12. To run the Sort Data and List Data task when you click the **All** button, add the following lines of code:

```vba
sas.Refresh("Sort_Data") 'output: SASApp:WORK.SOCCECLUB
sas.Refresh("List_Data")
```

The first line of code runs the Sort Data task, so that the generated Work.SoccerClub data set will have all of the soccer teams. Now, you need the object name (Sort_Data) for this task. For more information, see “Determine the Object Name for the Sort Data Task” on page 28.

The second line of code runs the List Data task to create a report that includes all of the teams.
13. In the Visual Basic Editor, select **CommandButton2** from the drop-down list. The commandbutton code for this button is added to the Visual Basic editor.

14. Add the following code for the second command button, which is the button labeled Eastern Conference:

   ```vba
   Dim sas As SASWordAddIn
   Set sas = Application.COMAddIns.Item("SAS.WordAddIn").Object

   sas.Refresh "Sort_Data_2" 'output: SASApp:WORK.SOCCERCLUB
   sas.Refresh "List_Data"
   
   The first line of code runs the Sort Data task, so that the generated WORK.SOCCERCLUB data set contains the data only for teams in the Eastern Conference. Now, you need the object name (Sort_Data_2) for the task. For more information, see “Determine the Object Name for the Second Sort Data Task” on page 29.
   
   The second line of code runs the List Data task to create a report that ranks only the teams in the Eastern Conference.
   ```

15. In the Visual Basic Editor, select **CommandButton3** from the drop-down list. The commandbutton code for this button is added to the Visual Basic editor.

16. Add the following code for the third command button, which is the button labeled Western Conference:

   ```vba
   Dim sas As SASWordAddIn
   Set sas = Application.COMAddIns.Item("SAS.WordAddIn").Object

   sas.Refresh "Sort_Data_3" 'output: SASApp:WORK.SOCCERCLUB
   sas.Refresh "List_Data"
   
   The first line of code runs the Sort Data task, so that the generated WORK.SOCCERCLUB data set contains the data only for teams in the Western Conference. Now, you need the object name (Sort_Data_3) for the task. For more information, see “Create a Temporary Data Set for the Western Conference” on page 30.
   
   The second line of code runs the List Data task to create a report that ranks only the teams in the Western Conference.
17. Save your changes and close the Visual Basic Editor.

18. On the **Developer** tab, deselect **Design Mode**.

19. In the document, click **All**. Your results should appear similar to the following display:
### Chapter 3 • Adding SAS Content to a Microsoft Word Document

#### SoccerClub.com - Microsoft Word

![Microsoft Word interface](image)

<table>
<thead>
<tr>
<th>Club</th>
<th>PTS</th>
<th>GW</th>
<th>GL</th>
<th>GD</th>
<th>GF</th>
<th>GA</th>
<th>Conference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles Milky-Way</td>
<td>25</td>
<td>8</td>
<td>0</td>
<td>2</td>
<td>10</td>
<td>14</td>
<td>WC</td>
</tr>
<tr>
<td>Columbus Crazias</td>
<td>20</td>
<td>8</td>
<td>6</td>
<td>0</td>
<td>2</td>
<td>14</td>
<td>8 EC</td>
</tr>
<tr>
<td>New York Raging Rhinos</td>
<td>15</td>
<td>9</td>
<td>5</td>
<td>4</td>
<td>0</td>
<td>9</td>
<td>-3 EC</td>
</tr>
<tr>
<td>San Jose Tremors</td>
<td>15</td>
<td>8</td>
<td>5</td>
<td>2</td>
<td>2</td>
<td>12</td>
<td>7 5 WC</td>
</tr>
<tr>
<td>Salt Lake Fire</td>
<td>16</td>
<td>9</td>
<td>5</td>
<td>3</td>
<td>2</td>
<td>17</td>
<td>10 7 WC</td>
</tr>
<tr>
<td>Houston Dynamite</td>
<td>16</td>
<td>9</td>
<td>5</td>
<td>4</td>
<td>1</td>
<td>14</td>
<td>10 4 WC</td>
</tr>
<tr>
<td>Toronto Tundra</td>
<td>13</td>
<td>9</td>
<td>4</td>
<td>4</td>
<td>1</td>
<td>12</td>
<td>-1 EC</td>
</tr>
<tr>
<td>Colorado Canyons</td>
<td>13</td>
<td>8</td>
<td>4</td>
<td>3</td>
<td>1</td>
<td>9</td>
<td>7 2 WC</td>
</tr>
<tr>
<td>Seattle Snakes</td>
<td>12</td>
<td>10</td>
<td>3</td>
<td>4</td>
<td>3</td>
<td>9</td>
<td>-4 WC</td>
</tr>
<tr>
<td>Galloping Goats</td>
<td>10</td>
<td>10</td>
<td>3</td>
<td>6</td>
<td>1</td>
<td>11</td>
<td>14 -3 WC</td>
</tr>
<tr>
<td>Chicago FC</td>
<td>10</td>
<td>9</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>12</td>
<td>-1 EC</td>
</tr>
</tbody>
</table>
When you click **Eastern Conference**, your results should appear similar to the following display:
When you click **Western Conference**, your results should appear similar to the following display:
Chapter 4
Sending SAS Content from Microsoft Excel to Microsoft PowerPoint

About the Tasks That You Will Perform
49
How to Access the Input Data Source
49
Drop Columns from the Input Data Source
50
Plot the Total Criminal Offenses over Time
53
Preview and Select the Results
57
Determine the Correlation between Population and Violent Crime
58
Determine the Number of Violent Crimes by Year
60
Send Results to a Microsoft PowerPoint Presentation
62
Refresh Results in the PowerPoint Presentation
64

About the Tasks That You Will Perform

For this example, you are an analyst for a home security company. You want to determine how violent crime has changed over time. The FBI Crime Data sample demonstrates how you can include SAS content in your Microsoft Excel worksheet, and the Crime Analysis sample demonstrates how you can include SAS content in your Microsoft PowerPoint presentation.

After completing this example, you will know how to perform these tasks:
• run a SAS analysis in Microsoft Excel
• send SAS content from Microsoft Excel to Microsoft PowerPoint
• refresh SAS content in Microsoft PowerPoint

How to Access the Input Data Source

Before you can run an analysis, you must access the input data source. You can download the crime data directly from the FBI Web site, or you can copy the data from the FBI Crime Data sample. Open FBI Crime data.xlsm, and copy the data in the Original Data worksheet. Paste this data into a new workbook.
To copy the data for the Crime Analysis sample:

1. Open the FBI Crime data.xlsm sample.
2. In the Original Data worksheet, select the data in range A13:T23.
3. Copy the data from the Original Data worksheet and paste the data into the Sheet1 worksheet in a new workbook.
4. Rename this worksheet **Original Data**.
5. Save the new workbook on your computer as **FBI Crime data.xlsm**.

---

**Drop Columns from the Input Data Source**

The original data source includes the number of offenses and rate for each type of violent crime. For your analysis, you want the data to include the number of offenses for murder and nonnegligent manslaughter, robbery, aggravated assault, and burglary only.

To select the columns to include in your analysis:

1. In the Original Data worksheet, select a cell in the Excel data.
2. On the **SAS** tab, click **Tasks**, and then select **Data** > **Sort Data**. The Choose Data dialog box appears.
3. For the input data, select **Excel Data**. By default, the input data source is the range of Excel data in the Original Data worksheet. In this example, the range of the Excel data is A3:T23. You can also use ![Excel Data](image)

   *Note:* If the ![Excel Data](image) button is not available, see “Trust Access to the Object Model for a Visual Basic Project” on page vii.

4. For the location of the results, select **New worksheet**. By default, the name of this new worksheet is Sort Data. Rename this worksheet to **Sorted data**.

   ![Choose Data](image)

   Click **OK**. The Sort Data task appears.

5. In the **Data** panel, complete these steps:
   a. Assign the Year column to the **Sort by** role.
   b. Assign these columns to the **Columns to be dropped** role:
• Violent crime rate
• Murder and nonnegligent manslaughter rate
• Forcible rape
• Forcible rape rate
• Robbery rate
• Aggravated assault rate
• Property crime
• Property crime rate
• Burglary rate
• Larceny-theft
• Larceny-theft rate
• Motor Vehicle theft
• Motor Vehicle theft rate

In the selection pane, click Results.

6. In the Results panel, specify the location for the output data set. Because you need access to this data source to refresh the SAS content in Microsoft PowerPoint, save this output data to a permanent library rather than the temporary Work library. In this example, the default location is **SASApp:SASDATA.Sorted_Crime_Data**.
Click Run.

When the Sort Data task finishes, two new worksheets appear in Microsoft Excel.

- In the Sorted Data worksheet, a placeholder appears. This placeholder displays the date and time that the Sort Data task ran.

- In the SASDATA.SORTED_CRIME_DATA worksheet, you see a copy of the output data set that the Sort Data task generated. In this example, the name of the worksheet is SASDATA.SORTED_CRIME_DATA. In your workbook, the actual name of this worksheet is the name of the output data set that you specified in the Results panel in the Sort Data task.

  *Note:* This data set is also saved to the location that you specified in the Results panel.
Plot the Total Criminal Offenses over Time

To show the trend of each criminal offense from 1989 to 2008, use a line plot.

1. On the SAS tab, click Tasks, and then select Graph $\Rightarrow$ Line Plot. The Choose Data dialog box appears.

2. To use the sorted data as your input data source, select SAS Data in Excel. This option uses the output data set that was generated by the Sort Data task and saved to the SAS server. The data set on the server is the same as the data in the SASDATA.SORTED_CRIME_DATA worksheet.

3. For the location of the results, select New worksheet. By default, the name of the new worksheet is Line Plot.
4. In the Line Plot panel, select *Multiple vertical column line plots using overlay.*

5. In the Data panel, complete these steps:
   a. Assign the Year column to the **Horizontal** role.
   b. Assign the Murder and nonnegligent manslaughter, Robbery, Aggravated assault, and Burglary columns to the **Vertical** role.
In the selection pane, click **General** under the Appearance > Axes heading.

6. In the Appearance > Axes > General panel, select the **Display Grid Lines** check box.

   In the selection pane, click **Axis** under the Vertical Axis heading.

7. In the Appearance > Axes > Vertical Axis > Axis panel, enter **Number of Offenses** in the Label field.

   ![Image of the Appearance > Axes > General panel]

   ![Image of the Appearance > Axes > Vertical Axis > Axis panel]

   In the selection pane, click **Titles**.

8. In the Titles pane, modify the title and the footnote for the line plot.

   To change the title:
   
   a. In the Section area, select **Graph**. In the Text for section: Graph area, deselect the Use default text check box.
   
   b. Delete the default text and enter **Total Criminal Offenses over Time**.

   To change the footnote:
   
   a. In the Section area, select **Footnote**. In the Text for section: Footnote area, deselect the Use default text check box.
b. Modify the text of the footnote to read **Updated**
\%
\text{TRIM(%QSYSFUNC(DATE(), NLDATE20.))} \text{ at}
\%
\text{TRIM(%SYSFUNC(TIME(), NLTIMAP20.))}.

Click **Run**. The generated line plot appears in the new Line Plot worksheet. Your results could look similar to the following display:
You can customize the title of the plot and the footnote by using the formatting tools in Excel.

**Preview and Select the Results**

Next, you want to analyze the correlation between population and violent crime. Depending on the options that you select, the Correlations task can generate multiple types of output, and you might not want all of this output included in an Excel worksheet. In the SAS Add-In for Microsoft Office, you can preview the results of a task or SAS job. Then you can select the output that you want to display in the Excel worksheet.

The preview functionality that is available with the SAS add-in is not turned on by default. To enable the preview functionality:

1. On the **SAS** tab, click **Tools**, and then select **Options**. The SAS Options dialog box appears.
2. Click the **Results** tab.
3. In the **General** area, select the **Show Preview Changes dialog box** check box.

![SAS Options dialog box]

Click **OK**.

Now whenever you run a task, you can preview the results of the task before the results open in a Microsoft Excel worksheet.
Determine the Correlation between Population and Violent Crime

To determine whether there is a correlation between population and the number of violent crimes, use the Correlations task.

1. On the SAS tab, click Tasks, and then select Multivariate $\Rightarrow$ Correlations. The Choose Data dialog box appears.

2. To use the sorted data as your input data source, select SAS Data in Excel. In this example, the location is SASApp:SASDATA.SORTED_CRIME_DATA!A1:H21.

3. For the location of the results, select New worksheet. By default, the name of the new worksheet is Correlations.

   Click OK. The Correlations task appears.

4. In the Data panel, assign Population to the Analysis variables role and assign Violent crime to the Correlate with role.

   In the selection pane, click Results.

5. In the Results panel, select the Create a scatter plot for each correlation pair check box.

   Click Run. The results open in the Preview dialog box.

6. In the Preview dialog box, select the Scatter Plot Matrix and click Insert Selected Items.
Determine the Correlation between Population and Violent Crime
The scatter plot matrix appears in the new Correlations worksheet.

---

Determine the Number of Violent Crimes by Year

To determine the number of violent crimes by year, create a bar chart.

1. On the SAS tab, click Tasks, and then select Graph ➔ Bar Chart Wizard. The Choose Data dialog box appears.

2. To use the sorted data as your input data source, select SAS Data in Excel. In this example, the location is `SASApp:SASDATA.SORTED_CRIME_DATA`.

3. For the location of the results, select New worksheet. By default, the name of the new worksheet is Bar Chart Wizard. Rename this worksheet Bar Chart. Click OK. The Bar Chart Wizard appears.

4. In the Verify Data step, verify that SORTED_CRIME_DATA is the input data source, and then click Next.

5. In the Assign variables to roles step, select Violent crime from the Bar height list, and then click Next.
6. In the Specify appearance step, click Axis Labels. The Axis Labels dialog box appears. In the Bar height field, change the label to Total Number of Offenses.

![Axis Labels dialog box]

Click OK.

7. In the Specify appearance step, select the Use reference lines check box, and then click Next.

8. In the Provide a title and footnote step, enter Number of Violent Crimes by Year as the title of the graph. Change the footnote to Updated %TRIM(%QSYSFUNC(DATE(),NLDATE20.)) at %TRIM(%SYSFUNC(TIME(),NLTIMAP20.)).

![Provide title and footnote]

Click Finish.

When the Preview dialog box appears, click Insert All. All of the results that were generated by the Bar Chart Wizard appear in the new Bar Chart worksheet.
Send Results to a Microsoft PowerPoint Presentation

Your manager wants to present your findings in an upcoming management meeting, so he asks you to incorporate the line plot and bar chart in a PowerPoint presentation. Using the SAS add-in, you can send SAS content from an Excel worksheet to a PowerPoint presentation.

To send the line plot and bar chart to a PowerPoint presentation:

1. On the SAS tab, click Manage Content. The Manage Content window appears.
2. Select the check boxes for Line Plot and Bar Chart Wizard.
Click **Send to**. The Send to Microsoft Office dialog box appears.

3. Select the **Send to Microsoft PowerPoint** check box. By default, the results are sent to a new PowerPoint presentation and all of the results are included in the same presentation.

Click **OK**.

If Microsoft PowerPoint is not already running, PowerPoint opens and includes the results in a new presentation. If PowerPoint is already running, the results are added to a new presentation. Each result appears on a new slide.
In Microsoft Excel, click Close in the Manage Content window and save your Excel worksheet.

---

**Refresh Results in the PowerPoint Presentation**

The data source for the Line Plot task and the Bar Chart Wizard is saved to a permanent location on the SAS server. Now, this data source is accessible from both Excel and PowerPoint. Therefore, you can refresh the results of the Line Plot task and Bar Chart Wizard in PowerPoint to reflect any changes that were made to the data. You can also modify these tasks to change your visual output.

To modify the results of the Line Plot task in PowerPoint:

1. If ActiveX is the graph format for your results, then you must use the graph settings that are generated by SAS to update the visual output in PowerPoint.

To determine the format of your results:

   a. In PowerPoint, select the line plot, and on the SAS tab, click Properties. The Line Plot Properties dialog box appears.

   b. Click the Appearance tab.

   c. If the graph format is ActiveX, select the Use graph settings generated by SAS check box.
Click **OK**.

2. On the **SAS** tab, click **Modify**. The Line Plot task appears. In the selection pane, select **Data**.

3. In the **Data** panel, assign the Violent Crime column to the **Vertical (Right)** role.

   ![Image](image1)

   Click **Run**.

   The updated results appear in the PowerPoint presentation.
Total Criminal Offenses over Time
Chapter 5
Editing and Refreshing SAS Content in Microsoft Word

About the Tasks That You Will Perform

For this example, you need to update an informational pamphlet for a local university. This pamphlet was last updated in 2009, and you need to update the college tuition to reflect the 2010–2011 prices.

After completing this example, you will know how to perform these tasks:

• edit a data source that is available on the SAS server
• refresh the SAS content in an existing Microsoft Word document

Access to the Input Data Source

Before you can analyze the data in Microsoft Word, you must copy the necessary data to your SAS server. For more information, see “Access to Samples and Input Data Sources” on page viii.

When this copy operation completes, the College_Demo and College_Cost data sets should be available from the SASApp:SASApp - SASDATA directory.

Save the College Sample to a Local Directory

In this example, you will use the current College sample as your starting point. Open the College.docx in Microsoft Word, and save this file to a local directory.
Edit the Tuition Costs in Microsoft Excel

You cannot open data sources in Microsoft Word. However, you can open and edit SAS data sources in Microsoft Excel.

To edit the College_Cost data set:

1. Open Microsoft Excel.
2. On the SAS tab, click SAS Data. The View SAS Data dialog box appears.
3. Click Browse. The Open Data Source dialog box appears.
4. Navigate to the library where you saved the sample data and select _COLLEGE_COST. The path to this data set is SASApp:SASApp - SASDATA._COLLEGE_COST.

Click Open. The _College_Cost data set is now selected in the View SAS Data dialog box.

5. In the View SAS Data dialog box, select Worksheet as the view.
6. For the location, select New worksheet and enter COLLEGE_COST as the name of the new worksheet.

**TIP** If you are opening a new workbook, select New workbook.
Click **OK**. The _College_Cost data set opens in Excel.

7. To edit the data source, select a cell that contains the 8,640 value.

   **TIP** The SAS tab now includes an **External Data** group that contains the editing options that are available in the SAS Add-In for Microsoft Office.

8. On the **SAS** tab, click **Begin Edit**. Click **Yes** to confirm that you want to begin edit mode.

   The data source opens in edit mode and is locked to you. Other users at your site cannot edit this data source while you have it in edit mode.

9. In the data source, update the costs for out-of-state tuition.
   - Change the value of Our Tuition (out of state) to **22,320**.
   - Change the value of Average Tuition (out of state) to **38,230**.

   **Note:** Do not press ENTER after you enter the last value in the table. Pressing ENTER could move you to a blank cell in the Excel worksheet. If a blank cell is selected, then the commit functionality is not available. You must select a value in the data source to commit your changes to the SAS server.

10. On the **SAS** tab, click **Commit** to save these changes. Committing your changes updates the existing data source on the server.

11. To exit edit mode, click **End Edit**. The data set is unlocked, so it is now available to other users at your site.
Refresh the Tuition Data in the Pamphlet

Now that the data source has been updated to include the 2010–2011 data, you can refresh the comparison bar chart in the College.docx document.

1. Open your local copy of the College.docx document.
2. Select the bar chart, and on the SAS tab, click Refresh.
You can also refresh this content by right-clicking on the bar chart and selecting **Refresh** from the pop-up menu.

After the bar chart is refreshed, the bars for out-of-state tuition show a significant increase. Now you can edit the text below the bar chart to show the new out-of-state tuition for CCSU.
CCSU has a proud tradition of excellence. Students who graduate from CCSU are sought by top companies from around the world.

Demographics:

Student Population by Continent

Courses:

CCSU is primarily an engineering college, but we also have top-rated medical, law, and art programs. Many CEOs of Fortune 500 companies as well as ground-breaking scientists have walked our halls. Trust us. The next leaders will be taught at CCSU.

Costs:

The in-state and out-of-state tuitions for CCSU are less than the national average.

Comparison of CCSU Tuition and the Average College Tuition

In-State Tuition: $0,640
Out-of-State Tuition: $30,320

Faculty and Staff:

Our culture of excellence attracts the most qualified and dedicated faculty and staff in the world. Award-winning experts in every field provide you with the best education possible. With guidance from our faculty and staff, you perform cutting-edge research and develop the newest technologies in CCSU labs. You also develop the skills you that need after college.
add-in
a program that adds additional commands and features to other programs or applications.

default metadata server
the metadata server that you are automatically connected to when you start Microsoft Word, Microsoft Excel, or Microsoft PowerPoint.

metadata
descriptive data about data that is stored and managed in a database, in order to facilitate access to captured and archived data for further use.

metadata configuration file
a file that enables users to specify which SAS metadata server they want to connect to by default. The connection to the metadata server enables users to access and run stored processes and to access SAS data sources on remote computers.

metadata repository
a collection of related metadata objects, such as the metadata for a set of tables and columns that are maintained by an application. A SAS Metadata Repository is an example.

SAS data source
a data file that contains SAS data.

SAS Enterprise Guide
a software application with a point-and-click interface that gives users access to the functionality of many components of SAS software. Interactive dialog boxes guide users through data analysis tasks and reporting tasks, and users can easily export the results of those tasks to other Windows applications or servers. SAS Enterprise Guide provides access not only to SAS data files, but also to data that is in a wide variety of other software vendors' formats and in other operating system formats.

SAS library
one or more files that are defined, recognized, and accessible by SAS and that are referenced and stored as a unit. Each file is a member of the library.

SAS Stored Process
a SAS program that is stored on a server and defined in metadata, and which can be executed by client applications. Short form: stored process.
SAS task
a logical process that is executed by a SAS session. A task can be a procedure, a DATA step, a window, or a supervisor process.

SAS variable
a column in a SAS data set or in a SAS data view. The data values for each variable describe a single characteristic for all observations (rows).

stored process
See SAS Stored Process.

variable
See SAS variable.

Visual Basic for Applications
a software application that is written in or can run Visual Basic code. You can use Visual Basic scripts in Microsoft Office to schedule or catch events. Short form: VBA.
Index

A
analyses running 3
analyzing data 2, 3
  in Microsoft Excel 6, 9, 11, 58
  in Microsoft Word 25

B
Bar Chart Wizard 60
bar charts 60

C
Canonical Correlation task 2
central repository
  saving results to 2
columns
  removing from data sources 50
Correlations task 58

D
data analysis 2, 3
  in Microsoft Excel 6, 9, 11, 58
  in Microsoft Word 25
data sources
  accessing 2, 5, 25, 49, 67
  copying 3
  creating 26
  editing 3, 68
  filtering 28, 30
  removing columns 50
dropping columns 50

E
editing SAS content
  in Microsoft Word 67

F
FBI Crime Data sample 49
Federal Reserve rate 5
  calculating 11
  plotting over time 20
  recalculating 16
  filters 28, 30

H
historical data 12

I
impact analysis 2
input data 2
  adding SAS content to Excel workbooks 5
  adding SAS content to Word documents 25
  editing and refreshing SAS content in Word 67
  sending SAS content from Excel to PowerPoint 49

L
line plots 12, 20, 53
linear regression analysis 9
List Data task 31

M
Microsoft Excel 3
  adding SAS content to workbooks 5
  additional functionality 3
  data analysis in 6, 9, 11, 58
  record limitations 3
  sending SAS content to PowerPoint 49
Microsoft Office 2000-2003 2
Microsoft Outlook 1
Microsoft PowerPoint
refreshing results 64
sending results to 62
sending SAS content from Excel to 49
Microsoft Word
adding SAS content to documents 25
data analysis in 25
editing and refreshing SAS content 67
refreshing results 70

N
naming objects 28, 29, 31

O
object names 28, 29, 31
OLAP Viewer 3

P
predicted rate values 12
previewing results 57
properties 7

R
record limitations
Microsoft Excel 3
refreshing results 2, 64
in Microsoft PowerPoint 64
in Microsoft Word 70
refreshing SAS content
in Microsoft Word 67
reports 2, 31
specifying contents of 38
results
adding to Summary Statistics worksheet 9
applying a style 7, 8, 34
previewing 57
properties 7
saving to a central repository 2
sending to Microsoft PowerPoint 62
sending to other Microsoft Office applications 2

S
SAS Add-In for Microsoft Office 1
benefits 2
how to use 3
SAS content
adding to Microsoft Excel workbooks 5
adding to Microsoft Word documents 25
editing and refreshing in Word 67
sending from Excel to PowerPoint 49
SAS Enterprise Guide 2
SAS Folders 2
SAS menu 2
SAS Stored Processes 2
SAS tab 1, 3
SAS tasks 1
SAS Web Report Studio 2
sending results 2, 62
sending SAS content 49
Sort Data task 26, 27, 29, 30, 50
object name for 28, 29, 31
Style Manager 34
styles
adding to summary statistics results 7
applying same style to all future results 8
applying to results 7, 8, 34
summary statistics 6
adding a style to results 7
adding results to worksheet 9

V
Visual Basic code 16, 38
Visual Basic Editor 42