JMP Essentials
An Illustrated Guide for New Users
Third Edition

Curt Hinrichs
Chuck Boiler
Susan Walsh


Copyright © 2020, SAS Institute Inc., Cary, NC, USA

ISBN 978-1-64295-391-6 (epub)
ISBN 978-1-64295-392-3 (kindle)

All Rights Reserved. Produced in the United States of America.

**For a hard copy book:** No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, or otherwise, without the prior written permission of the publisher, SAS Institute Inc.

**For a web download or e-book:** Your use of this publication shall be governed by the terms established by the vendor at the time you acquire this publication.

The scanning, uploading, and distribution of this book via the Internet or any other means without the permission of the publisher is illegal and punishable by law. Please purchase only authorized electronic editions and do not participate in or encourage electronic piracy of copyrighted materials. Your support of others’ rights is appreciated.

**U.S. Government License Rights; Restricted Rights:** The Software and its documentation is commercial computer software developed at private expense and is provided with RESTRICTED RIGHTS to the United States Government. Use, duplication, or disclosure of the Software by the United States Government is subject to the license terms of this Agreement pursuant to, as applicable, FAR 12.212, DFAR 227.7202-1(a), DFAR 227.7202-3(a), and DFAR 227.7202-4, and, to the extent required under U.S. federal law, the minimum restricted rights as set out in FAR 52.227-19 (DEC 2007). If FAR 52.227-19 is applicable, this provision serves as notice under clause (e) thereof and no other notice is required to be affixed to the Software or documentation. The Government’s rights in Software and documentation shall be only those set forth in this Agreement.

SAS Institute Inc., SAS Campus Drive, Cary, NC 27513-2414

March 2020

SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.

SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to [http://support.sas.com/thirdpartylicenses](http://support.sas.com/thirdpartylicenses).
About the Book

*JMP Essentials* was written for the new user of JMP software who needs to get the best results right away. If you have data and problems to solve, JMP helps you make sense of them to gain understanding and arrive at a good decision. It is the goal of this book to help you with this task.

We often find new users of JMP simply trying to complete a specific task with their data. Perhaps you just need to generate a certain graph for a Microsoft PowerPoint presentation or to quickly see how patterns in your data will lead you to an important discovery. If these scenarios sound close to home, you have come to the right place. This book is task-oriented and will help you access your data, identify that graph or statistic you need, and quickly and easily create and share it with others.

JMP software is built around the workflow of the problem solver. One of its outstanding features is that it consistently provides the correct graphs and statistics for the data that you are working with (something we refer to as the JMP smart interface). JMP leads you down the path to the best result, provided your data is properly classified and you have an idea of what questions you are trying to answer.

JMP is easy to use. In most cases, generating a graph or result will take you seconds, maybe minutes, to complete but never hours or days. Much of this efficiency is due not only to the small number of steps required but to the ability to navigate intuitively toward the right solution quickly, rather than through repetitive and time-consuming trial-and-error. This book provides you with the essential knowledge to get to your solution even faster.

Though JMP contains state-of-the-art visualization and advanced statistical and data mining tools, we also believe it is the right tool for the user who might be less confident in his or her analytic abilities. While there is a time and place for every feature in JMP, we have tried to include only those topics that a typical new user—a manager, engineer or analyst, for example—would need. If it has been a while since you have studied statistics or dealt with its terminology, do not worry. We will present the key ideas and fill in the gaps as needed.

**Audience**

While this third edition of *JMP Essentials* is designed for new users, we have also focused on the most fundamental and commonly used features of JMP so that it may also serve as a valuable reference to the occasional user too. This focus is what we like to think of as the 20% of JMP that is used 80% of the time. Throughout the book, we have provided the necessary instruction to generate results quickly. Each key step in this process is illustrated with screenshots to help you see the result and develop your confidence in using JMP. We do not assume any formal background in statistics. Instead, we emphasize the intuition of concepts over statistical theory.
If you require deeper statistical understanding, we recommend the documentation included in JMP and some excellent textbooks in the Bibliography.

Most new users of JMP have one or more of the following distinct needs:

1. They need to get their data into an appropriate and structured format so it may be effectively analyzed or visualized. (See Chapter 2).
2. They have a good idea of what graph they need and recognize it by its illustration or name and simply want to create it. (See Chapter 3.)
3. They really do not know what the data will say, and need help with exploring or with summarizing it. (See Chapter 4.)
4. They need to interpret or answer some specific questions about the data they have. (See Chapters 5 and 6.)

We also believe that the complete book is well suited as a reference guide to the following groups of users:

- **Spreadsheet users** who are looking for a convenient way to produce nice visualizations of their data or to supplement a spreadsheet’s statistical capabilities. JMP reads and writes data from a variety of programs including Microsoft Excel. This book provides a quick and easy way to make your spreadsheet data come alive and enables you to fully and interactively explore that data.

- **Students enrolled in introductory statistics courses** who may need JMP instruction. JMP is the ideal tool for students because its navigation reinforces the basic assumptions taught in an introductory course. This book provides an overview of the JMP tools needed in most first-year courses.

- **SAS users** who want to take advantage of JMP’s data visualization tools. We have provided Appendix A to illustrate the features of how JMP integrates with SAS.

**Approach and Features**

We have found that the best way to learn JMP is by using it and getting value out of it quickly. Our goal is to present the materials in this book in the most user-oriented approach possible. So, we have made every effort to organize the presentation around the new user’s common needs and questions and the most direct and concise means to answer them. We also recognize that the most basic use of data is in generating graphs of data rather than performing more complex statistical analyses. The following features are included for this purpose:

- We present the material with a show-and-tell approach. In most cases, we show you what the results look like alongside the conditions and steps required to produce them. We think this approach is especially useful for JMP users who have a good idea of what they want from JMP and just need the steps to create it.
About the Book

- When appropriate, we provide an example-driven context for each JMP platform that explains its use, value, and general application to problems. We have tried to distill these contexts down to typical or easy-to-understand cases.
- We organize the contents into easily manageable chunks of information. While the entire book is designed to cover a fairly complete overview of the basics, each chapter represents one family of tasks (such as importing data, creating graphs, and sharing graphs).
- We hope you will keep this book near your computer. Within each chapter, we have designed each section to be self-contained enabling you to quickly find and execute the steps required to complete your task.
- No matter what your professional background, this book assumes only that you have a basic working knowledge of Microsoft Windows. Virtually all of the information in this book applies to using JMP on the Macintosh operating system, but only the Windows version of JMP is used in the examples.

Software Used to Develop This Content

This third edition of JMP Essentials was developed with JMP 15. Users of JMP Pro, JMP Student Edition or earlier releases of JMP will find nearly all of the instructions in this book suitable for their needs.

Organization

This book is designed like a cookbook. Find what you need and follow the steps. We have organized the contents of this book to reflect both the process of analyzing data (getting data, analyzing it, and sharing the results) and the progression from the very basic features in JMP to more specialized ones. We hope this organization offers the most value to the reader. Much of our judgment in this regard comes from our experience working one-on-one with new JMP users.

- Chapter 1 covers the preliminary material you will need for the rest of the book. The chapter identifies the conventions we use and introduces you to JMP menus, windows, and preferences.
- Chapter 2 covers the first step in any analysis: getting your data into JMP. With the exception of some material in Chapter 2, other chapters are self-contained, and you can read them in any order.
Chapters 3 through 6 cover graphing and analysis:

- Chapter 3 is for the user who knows what graph he or she wants.
- Chapter 4 is for the user who does not know what the data says and needs to explore it to find an appropriate graph or summary. This chapter introduces maps.
- Chapters 5 and 6 are for the user who needs to solve a problem and answer questions using analytics and graphs.

Chapter 7 covers topics related to sharing your graphs or results in a presentation, document, or through a browser.

Chapter 8 covers additional resources that are available within JMP, online, and from outside resources, such as training, books, and user groups.

**Figure 1 Chapter Organization**

---

**New to the Third Edition**

It is gratifying to hear that previous editions have been useful to many new users of JMP. Our goal in writing this third edition is two-fold; first, to improve upon the core features and to that end, we have made many refinements, corrections and additions throughout the book based on feedback from users, colleagues, and reviewers. Secondly, in the five years since the second edition was published, JMP has added several important new features that we believe are
Essential to the new user and we thought should be included. While there are many changes throughout the book, here is our Top Ten:

- Getting data out of database is a common task. **Query Builder** provides an easy, point and click interface to extract needed data. It also automatically creates SQL code that you can reuse on new data.
- An example of **Join by matching columns** is included. This is imperative when combining data tables where data in the tables to be joined is not in the same row order or does not have a one-to-one match.
- New graphs including **Packed Bars**, **Parallel Plots**, and **Dot plots**. JMP has been an innovator in visualization for many years. This continues with Packed Bar charts that are useful to summarize categorical variables with many (hundreds) of levels. Parallel plots are a useful way to express multivariate data. Finally, dot plots have been added. These plots commonly used in introductory statistics courses are simple but useful alternatives to histograms.
- Using **Text Explorer to create a Word Cloud** to visualize un-structured text that might arise as a result of customer comments, product reviews, or warranty claims for example.
- A new section, **Comparing Two Continuous Columns**, presents an introduction to simple linear regression analysis, which provides an equation for a line fit to the data. This equation provides a slope that defines the magnitude of the increase (or decrease) in a response column as the predictor column increases.
- Expansion of the discussion of the **Fit Model** platform and Prediction Profiler to include both continuous and categorical inputs.
- Revised information about the JMP **Dashboard Builder**. Combining multiple graphs and even filters into a single window, or dashboard, has been greatly improved and illustrated in this section.
- **JMP Public or JMP Live** for use in publishing reports. This edition introduces these new products and ways to share interactive graphics and results with those who may not have JMP.
- Recording **animated graphs for exporting to PowerPoint** for presentation. This is an alternative to flash objects that appeared in the previous edition but will no longer be supported by Adobe.
- A more detailed look at the **JMP website** and the myriad of tools available for obtaining more information about the software from the JMP team and other JMP users like yourself.
We Want to Hear from You

SAS Press books are written by SAS Users for SAS Users. We welcome your participation in their development and your feedback on SAS Press books that you are using. Please visit sas.com/books to do the following:

- Sign up to review a book
- Recommend a topic
- Request information about how to become a SAS Press author
- Provide feedback on a book

Do you have questions about a SAS Press book that you are reading? Contact the author through saspress@sas.com or https://support.sas.com/author_feedback.

SAS has many resources to help you find answers and expand your knowledge. If you need additional help, see our list of resources: sas.com/books.

Learn more about these authors by visiting their author pages, where you can download free book excerpts, access example code and data, read the latest reviews, get updates, and more:
http://support.sas.com/hinrichs
http://support.sas.com/boiler
http://support.sas.com/walsh
About the Authors

CURT HINRICHS joined SAS in 2006 to develop and launch the JMP Academic Program that provides faculty, researchers, and students with easy access to JMP software and learning resources. Curt and his team are charged with developing JMP users among the next generation of data analytics professionals. They work directly with faculty, authors, and administrators and partner with leading academic societies, publishers, and service providers to support the effective use of JMP software in the classroom. Prior to joining SAS, Curt worked as an editor and publisher for Thomson Learning, and its Mathematics and Statistics Publishing Group. He holds a degree in economics from San Diego State University.

CHUCK BOILER is a US Systems Engineer Manager for JMP, a business unit of SAS. Since joining SAS, Chuck has held management roles with JMP and helped develop solutions for conducting many types of analysis, including design of experiments for the semiconductor industry, quality control for pharmaceutical manufacturing, and marketing applications for survey analysis using JMP software. He now works with field engineering staff and customers to help them solve problems and discover hidden opportunities in the data. Prior to joining SAS, Chuck worked as technical services manager and software quality assurance manager for Abacus Concepts. A member of the American Society of Quality, Chuck received a bachelor's degree in education from the University of Oregon and has done graduate work in ancient philosophy at the Graduate Theological Union in Berkeley, California. He is a graduate of Gallup University's Great Manager Program.

SUE WALSH worked for 10 years as a SAS Technical Support Statistician supporting JMP. Prior to working in Technical Support, she worked at SAS as a Statistical Training Specialist, teaching both SAS and JMP to users, and as an Analytic Consultant, supporting the use of SAS in colleges and universities across the country. Sue has over 10 years experience teaching mathematics and statistics at community colleges. She was the first woman commissioned from the Air Force ROTC program at Manhattan College. She retired with a total of 23 years of service in the US Air Force and Reserve. Sue holds a master of business administration from Rensselaer Polytechnic Institute in Troy, New York and a master of science in applied statistics from Wright State University in Dayton, OH.
Learn more about these authors by visiting their author pages, where you can download free book excerpts, access example code and data, read the latest reviews, get updates, and more:

http://support.sas.com/hinrichs
http://support.sas.com/boiler
http://support.sas.com/walsh
Chapter 4: Finding the Right Graph or Summary

4.1 Using Graph Builder to Produce Graphs of Data
4.2 Using Graph Builder to Produce Maps
4.3 Using Control Chart Builder
4.4 Using Tabulate
4.5 Summary

In the last chapter, we presented an overview of the commonly used graphs in JMP with accompanying recipes. This works well when you know what you want your graph to look like. However, at other times, and particularly when you are exploring your data for the first time, it makes sense to take a different approach for several important reasons. First and foremost, you probably don’t know what your data is going to tell you. Second, you can learn a great deal about your data when you explore it both visually and numerically. Reviewing your data in both ways can lead you to find the best way to display information.

In this chapter, we take advantage of a key feature of JMP: its ability to create graphs, maps, and summaries interactively and intuitively. While all platforms in JMP promote exploration, two features in particular — Graph Builder and Tabulate — are especially designed for this purpose. Because the former is geared toward interactively creating maps and graphs and the latter at numerical summaries, we cover them separately. Let us begin with finding the right picture of your data.

4.1 Using Graph Builder to Produce Graphs of Data

Graph Builder is a great tool to quickly see your data expressed in many different forms. In many ways, Graph Builder is like a blank canvas waiting for your artistic direction. With Graph Builder, it is helpful to begin thinking about your problem and the columns that are central to your questions at hand. Graph Builder is found under the Graph menu when you select Graph ► Graph Builder. (See Figure 4.1.)

As described in Chapter 3, Graph Builder works in a drag-and-drop manner. Simply click a column in the Columns box and drag it (without letting go) to one of the zones located around the canvas. You can hold the column in a zone (without letting go) to get a preview of the graph, then move it to another zone to see an alternative display. Once you release the mouse button, Graph Builder keeps that selection and enables you to customize the display or select another column to begin exploring relationships. You can repeat this process by adding more columns to view more complex displays.
Example 4.1: TechStock

You can find the data set at Help ▶ Sample Data ▶ Business and Demographic ▶ TechStock.jmp.

We will be working with one of the sample data files to illustrate the steps in this section. The file that we will use, TechStock.jmp, contains closing price data from selected technology stocks. The columns include:

- **Date**: the date expressed as dd/mm/yyyy
- **Open**: the opening price of the stock
- **High**: the highest price of the stock on that date
- **Low**: the lowest price of the stock on that date
- **Close**: the closing price of the stock on that date
- **Volume**: the number of shares traded on that date
- **Adj. Close**: the adjusted price of the closing price
- **YearWeek**: the week of the year expressed as yyyy/week#

1. First, open the sample data table TechStock.jmp, as indicated previously.
2. Open Graph Builder. Select Graph ▶ Graph Builder. (See Figure 4.1.)

**Figure 4.1 Open Graph Builder**

3. Notice the columns in your data table appear on the left in the Columns box of the Control Panel. (See Figure 4.2.)
4. Drag the **Adj. Close*** column from the **Columns** box to one of the labeled zones located around the graph canvas. You will notice that as soon as the column is dragged into the zone, a graph of that data is immediately displayed. Keeping the mouse button depressed, experiment by dragging the column into different drop zones to see what happens. If you let go of the mouse button, you can always click the **Undo** or **Start Over** button to begin again.

5. Click, hold, and drag the **Adj. Close*** column to the **Y** drop zone and release the mouse button. You should see a point graph. (See Figure 4.3.) Your graph might appear different depending on the default size of the graph area.

Figure 4.3 Drag Adjusted Close to Y Drop Zone
Note

If you change the Jitter setting on the graph from Auto to Positive Grid, you will see a familiar Dot Plot, but oriented vertically.

6. Now click and drag the Date column to the X drop zone. This action immediately produces a scatter plot with dates on the X axis. (See Figure 4.4.) Notice that the trend for the close prices is downward, and a smoothing line is fit to the data.

Figure 4.4 Drag Date to X Drop Zone

7. Right-click in the graph region to change the look of the graph. (See Figure 4.5.) A menu appears, containing options to make graph changes. Make no changes at this time. Additional visualization changes can be accomplished by choosing from the palette of icons across the top of the graph. (See Figure 4.6.) These are the Element Type Icons.
8. Select the icon that is second from the left on the palette of icons at the top (circled in Figure 4.6). This toggles the smooth curve on and off. Highlighted choices are enabled. Grayed out choices are disabled. Leave the smooth curve enabled.
9. Now double-click the **Date** axis. You see a window box of choices. (See Figure 4.7.) Change the **Tick Label Orientation** to **Vertical**. In **Grid Lines**, add a check for grid lines for the **Major** and **Minor** axes and click **OK**.

**Figure 4.7 Change Tick Orientation and Gridlines**

![Screen capture showing X-Axis Settings with Tick Mark Orientation and Grid Lines options selected.](image-url)
10. You should now see a graph with vertical dates and gridlines at the major tick date intervals. Now drag the Volume column to the area just above the Y axis label for Adj. Close* (Figure 4.8).

Figure 4.8 Drag Volume to Y Drop Zone
11. You will see a graph rendered (Figure 4.9).

**Figure 4.9 Graph Rendered**

![Graph Builder](image)

**Note**

You might want to experiment with dropping the new column in different places in the Graph Builder drop zones. For example, if you drop the new column, Volume, closer to the center of the Y drop zone, Volume will replace Adj. Close* on the axis. If you drop the new column at the center of the drop zone just inside Adj. Close*, it will graph the values of the two columns on the same axis. This would only be appropriate if the magnitude of the two columns is similar.

12. Right-click the **Volume** graph points (see Figure 4.10) and select **Points ➤ Change to ➤ Bar**.
Chapter 4: Finding the Right Graph or Summary

Figure 4.10 Change Points to Bars

Note
The Element Type Icons at the top of the chart give an iconographic indication of what parts of the graph elements are currently enabled. (See Figure 4.11.)

Figure 4.11 Element Type Icons

Elements of the graph’s rendering can be controlled from this panel. Reading the icons for the current graph from left to right, points are enabled for the Adj. Close* Y axis only (indicated by the lower half of the icon being highlighted and corresponding to the lower half of the graph in Figure 4.12). Smoother is enabled for both Adj. Close* and for Volume. Bars are enabled for Volume only (the upper half of the graph).
13. This renders a graph showing trading volume and adjusted closing prices for the time period. (See Figure 4.12.)

**Figure 4.12 Enable Smoother for Volume and Adjusted Close**

14. Now let’s include the daily high and low prices in the graph. Drag the High column to the location just to the right of the Y axis for Adj. Close* (Figure 4.13).

**Figure 4.13 Include Daily High and Low Prices**
15. A red **High** line is now rendered that represents the maximum price of the stock portfolio by day. If you did not get the picture to match Figure 4.13 the first time, you can always click undo and try again. Now do the same with the Low column by clicking and dragging the **Low** column to the same location. A green Low line is now rendered that represents the minimum price for each day.

16. To complete the graph, edit the last few items. Double-click inside the legend. (See Figure 4.14.)

**Figure 4.14 Edit the Legend**

17. A **Legend Settings** window appears (Figure 4.15).

**Figure 4.15 Legend Settings Window**
18. Click on the purple **Volume** line and remove the check mark for that item. Then look at in the **Preview** area of the dialog box. The dialog box should look like Figure 4.16. Click **OK**.

**Figure 4.16 Volume Line and Preview**

![Legend Settings dialog box](image)

19. Now let’s add a few last details. We will change the graph title. Click on the graph title and change it to **Tech Stock Sell-Off Fall 2000 to Winter 2001**. Then click **Done**. You should see a graph like the one shown in Figure 4.17.
4.2 Using Graph Builder to Produce Maps

The Graph Builder platform also enables you to visualize data on a map, even at the street level. In JMP, maps can be created two ways: using shape files (which are data tables containing the boundaries and names of the shapes such as states or counties of the USA) or background maps (which are background images that recognize latitude and longitude and enable you to plot points accordingly).

Today, mapping data is abundant. JMP provides an easy and flexible environment in which to convey your data on maps. The example in the next section will illustrate how to create a map using the background map service called OpenStreetMaps. An Internet connection is required to use OpenStreetMaps, and you must be using JMP 11 or later.

To make maps in Graph Builder, simply use the same drag and drop methods that you practiced in the previous section. The key step is dragging a shape column to the Map Shape drop zone (to use a Shape file) or in using latitude and longitude data columns in the X and Y drop zones respectively (to use a background map). This action enables maps to be visualized with your data.

If you are unfamiliar with the special conditions of how map data is handled in JMP, see Section 2.7.
Example 4.2: San Francisco Crime

We will be working with one of the sample data files to illustrate the steps in this section. The file that we will use, San Francisco Crime.jmp, contains data on individual crime incidents in San Francisco from April 2012. You can find the data set at Help ► Sample Data ► Graph Builder ► San Francisco Crime.jmp.

The columns include:

- **Incident Number**: identifier represented as an integer
- **Date**: the date expressed as dd/mm/yyyy
- **Time**: hour and minute expressed as HH:MM: AM/PM
- **Day of Week**: day of the week expressed as a word
- **Category**: 32 offense categories, expressed as words
- **Incident Description**: 336 standardized sub categories of the Category column, expressed as words
- **Traffic Incident**: two categories standardized for indicators of traffic incident, expressed as words
- **Resolution**: 16 categories of standardized indicators of incident resolution, expressed as words
- **Police District**: 10 categories of geographic police district names in the city of San Francisco
- **Incident Address**: nearest cross-street
- **Longitude**: longitude expressed in degrees and directions east and west
- **Latitude**: latitude expressed in degrees and directions north and south
- **Reference**: a compact set of four hidden columns that automatically performs recoding
- **Police Department Color**: a row state column indicating a color marker indexed to each police district

1. First, open the sample data table by selecting Help ► Sample Data ► Graph Builder ► San Francisco Crime.
2. Open Graph Builder. Select Graph ► Graph Builder. (See Figure 4.18.)
3. Notice the columns in your data table appear on the left in the **Columns** list in the Control Panel. (See Figure 4.19.)

**Figure 4.19 San Francisco Crime Variables**

![Graph Builder](image)

4. Now drag the **Latitude** column from the **Variables** list to the **Y** drop zone located on the left side of the graph canvas. Then drag the **Longitude** column from the **Variables** list to the **X** drop zone located at the bottom of the graph canvas. You should see a point graph with a smoother line. (See Figure 4.20.)
5. Let’s deselect the second icon on the element type palette by clicking on the icon to remove the smoother line from the graph (Figure 4.21).

Figure 4.21 Remove Smoother Line

6. Now right-click in the middle of the graph area and choose **Graph ➤ Background Map...** from the submenu. (See Figure 4.22.)
7. Select **Street Map Service** and click **OK**. (See Figure 4.23.)
8. The addition of San Francisco streets now appears as a background to the color-coded crime locations. (See Figure 4.24.)

Figure 4.24 Background Street Map Overlay – Color-Coded Crimes

9. You are now finished with the Control Panel. Click the **Done** button in the control panel to close the panel. (See Figure 4.25.)

Figure 4.25 Close the Variables Control Panel
10. Now let’s focus on assaults in one particular police district. To do this, we will use a powerful feature called the **Local Data Filter**. From the red triangle for Graph Builder, choose **Local Data Filter**. (See Figure 4.26.)

**Figure 4.26 Select Local Data Filter**
11. A **Local Data Filter** panel appears to the left and inside the Graph Builder window. (See Figure 4.27.)

![Figure 4.27 Local Data Filter Panel](image)

12. Hold down the **Ctrl** key, select **Category** and **Police District** and then click the **Add** button. (See Figure 4.28.)

![Figure 4.28 Data Filter Category and Police District](image)
13. A list of crimes and police districts appears in the local data filter. Select **ASSAULT** from the **Category** list, hold down the **Ctrl** key and select **MISSION** from the **Police District** list. The map automatically zooms to the Mission District and maps assault crimes as blue dots. (See Figure 4.29.)

**Figure 4.29 Data Filter Assault and Mission**

14. Move your mouse pointer to hover over any of the blue dots. Labeling information for the crime is automatically displayed (Figure 4.30).

**Figure 4.30 Display Label Information**
15. Let’s add contours to this map. Contours will help plot the density of assaults for the Mission District in San Francisco during this time period. From the red triangle for Graph Builder, select **Graph Builder ➤ Show Control Panel**. Hold the **Shift** key and select the contour icon (circled in Figure 4.31).

**Figure 4.31 Add Contours for Density of Assaults**

16. Many additional visualizations are possible. Feel free to experiment. You can always click the **Undo** button if you want to go back. Click the **Done** button when you are finished.

### 4.3 Using Control Chart Builder

As you are aware by now, the approach taken in JMP is one of discovery. There are two graph platforms that are specifically aimed at discovering the nature of your data as you create the graph. Graph Builder was introduced earlier. Control Chart Builder is more focused, as it is used
to examine data from a process to assist in identifying unexpected variations or changes in the process.

To open Control Chart Builder select Analyze ▶ Quality and Process ▶ Control Chart Builder. As with other platforms, you see a list of your data table columns on the left side. Similar to Graph Builder, there are drop zones in which to place columns, but there is no dialog box to assign columns to roles in the graph.

Examine the drop zones in Control Chart Builder:

- The Y drop zone on the left of the graph area is the only required element for a control chart. This is for the process variable to be examined.
- The Subgroup drop zone at the bottom of the graph area is for a variable that naturally divides the data into groups.
- The Phase drop zone is at the top of the graph. A phase is most often used to identify known changes in the process during the period graphed.

![Figure 4.32 Control Chart Builder showing Drop Zones](image)

In addition to the drop zones, two buttons can optionally be used to create multiple charts:

- The By button is used for data with a single process column using multiple levels of another column. For example, to create separate charts for each location where data is collected.
- The New Y Chart button is to select another column to graph in a different chart using the same properties of the first chart.

Example 4.3: Diameters

We will use Diameters.jmp to demonstrate using Control Chart Builder with the drop zones. The data table contains measurements of the diameter of tubing used for medical applications. For
each diameter measured, the date and operator were recorded. Initial measurements were taken from May 1 to May 20, after which some adjustments were made to the manufacturing process. Additional measurements were then taken from May 21 to June 9. These two time periods are indicated as Phase 1 and 2.

You can find the data set at Help ► Sample Data ► Control Charts ► Diameter.jmp.

To begin, create a chart by dragging a continuous process variable into the Y drop zone. For this data table, click on the column Diameter and drag it to the Y drop zone. By default, this creates an Individual Measurements chart to examine the data values as well as a Moving Range chart to examine the variability in the data. (See Figure 4.33.)

Once you have examined these charts, you determine there are multiple measurements taken on the same day and you would like to look at the means of these values by day. Select Day in the column list and drag it to the bottom of the graph for it to be used as a Subgroup variable. This changes the charts to an XBar chart with a Range chart. (See Figure 3.34.)
Finally, if you want to examine each of the operators across the days, you can select **Operator** in the columns list and drag it to the outside of the horizontal axis to get Day in Operator as your subgroups. (See Figure 4.35.)

**Figure 4.35 XBar and Range Charts with Nested Subgroups**
Instead of using Operator as a second subgroup variable, you could choose to use it as a By variable to create a separate control chart for each operator. To do so, instead of dragging Operator to the X drop zone, select Operator in the Columns list, then click the By button.

4.4 Using Tabulate

Now that you are familiar with using drop zones to generate a graph, we introduce the Tabulate platform. Tabulate is used in a similar fashion to Graph Builder, but instead of creating graphs, your objective is to create numerical summaries for their own sake or for the development of new data tables based on summarized data for further analysis.

Example 4.4: Movies

We will use Movies.jmp to demonstrate Tabulate. This data table is a listing of popular US movies that were released from 1937 through 2003. The movies are categorized by type, rating, and director and contain earned gross dollar amounts for both the US domestic market and the worldwide market.

Dollar amounts are expressed in millions of dollars for both domestic and worldwide markets.

You can find the data set at Help ▶ Sample Data ▶ Business and Demographic ▶ Movies.

The columns include:

- **Movie**: name of movie
- **Director**: director of movie
- **Type**: genre/category of movie (for example: comedy, family)
- **Rating**: US movie rating system (for example: general audience [G], adult [R])
- **Year**: year of movie release (for example: 1937)
- **Domestic $**: US domestic revenue in $ earned by the movie in that year
- **Worldwide $**: Worldwide revenue in $ earned by the movie in that year
1. After opening the data table, open Tabulate (select Analyze ▶ Tabulate). (See Figure 4.36.)

**Figure 4.36 Open Tabulate Platform**

![Open Tabulate Platform](image)

2. The Tabulate platform presents a control panel with your columns, a statistics list, and drop zones for rows and columns (see Figure 4.37)

**Figure 4.37 Tabulate with Domestic and Worldwide Columns**

![Tabulate with Domestic and Worldwide Columns](image)

3. Click on both the Domestic $ and Worldwide $ columns and drag them to the part of the table labeled Drop zone for columns. (See Figure 4.37.)

4. A sum of movie revenue by domestic $ and worldwide $ appears. (See Figure 4.38.)

**Figure 4.38 Sum of Domestic and Worldwide Movie Revenue**

![Sum of Domestic and Worldwide Movie Revenue](image)
5. Now drag the **Type** column to the row area. (See Figure 4.39.)

**Figure 4.39 Drag Type Column to Row Area**

6. Release the mouse button. The table now sums the revenue by type for both domestic and worldwide (Figure 4.40).

**Figure 4.40 Sum of Domestic and Worldwide Movie Revenue by type of movie**

7. We would like to add a Rating subgroup within the **Type** column. Drag the **Rating** column to the area just to the left of the **Domestic Sum** column. (See Figure 4.41.)

**Figure 4.41 Add Rating Subgroup Within Type Column**
8. Release the mouse button and a **Rating** column appears. (See Figure 4.42.)

**Figure 4.42 Table with Rating Column Added**

<table>
<thead>
<tr>
<th>Type</th>
<th>Rating</th>
<th>Domestic $</th>
<th>Worldwide $</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>G</td>
<td>$100.50</td>
<td>$100.50</td>
</tr>
<tr>
<td></td>
<td>PG</td>
<td>$899.00</td>
<td>$1,482.40</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$5,732.60</td>
<td>$12,269.00</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$2,492.10</td>
<td>$5,758.20</td>
</tr>
<tr>
<td>Comedy</td>
<td>PG</td>
<td>$2,825.70</td>
<td>$4,409.70</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$4,634.50</td>
<td>$7,498.60</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$2,357.80</td>
<td>$3,837.80</td>
</tr>
<tr>
<td>Drama</td>
<td>G</td>
<td>$198.70</td>
<td>$390.50</td>
</tr>
<tr>
<td></td>
<td>PG</td>
<td>$5,662.10</td>
<td>$9,579.10</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$3,719.90</td>
<td>$8,897.50</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$3,209.10</td>
<td>$5,989.60</td>
</tr>
<tr>
<td>Family</td>
<td>G</td>
<td>$3,640.10</td>
<td>$7,091.10</td>
</tr>
<tr>
<td></td>
<td>PG</td>
<td>$3,791.10</td>
<td>$7,658.30</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$144.20</td>
<td>$293.40</td>
</tr>
<tr>
<td>Mystery-Suspense</td>
<td>PG-13</td>
<td>$1,965.20</td>
<td>$4,342.80</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$2,066.40</td>
<td>$4,005.80</td>
</tr>
</tbody>
</table>

**Note**

You can click the **Undo** button at any time to undo the last action, or you can click **Start Over** to start over again.

9. Drag the Mean from the **Statistics** column and drop it onto one of the **Sum** column headings. (See Figure 4.43.)

**Figure 4.43 Drag Mean Column to Sum Column**
10. Release the mouse button. The **Sum** columns have been transformed to **Mean** columns. (See Figure 4.44.)

**Figure 4.44 Sum Columns Changed to Mean Columns**

<table>
<thead>
<tr>
<th>Type</th>
<th>Rating</th>
<th>Domestic $</th>
<th>Worldwide $</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Mean</td>
<td>Mean</td>
</tr>
<tr>
<td>Action</td>
<td>G</td>
<td>$100.50</td>
<td>$100.50</td>
</tr>
<tr>
<td></td>
<td>PG</td>
<td>$149.83</td>
<td>$247.07</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$184.92</td>
<td>$395.77</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$138.45</td>
<td>$319.90</td>
</tr>
<tr>
<td>Comedy</td>
<td>PG</td>
<td>$141.29</td>
<td>$220.49</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$144.83</td>
<td>$234.33</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$138.69</td>
<td>$225.75</td>
</tr>
<tr>
<td>Drama</td>
<td>G</td>
<td>$198.70</td>
<td>$390.50</td>
</tr>
<tr>
<td></td>
<td>PG</td>
<td>$161.77</td>
<td>$273.69</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$232.49</td>
<td>$556.09</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$128.36</td>
<td>$239.58</td>
</tr>
<tr>
<td>Family</td>
<td>G</td>
<td>$158.27</td>
<td>$308.31</td>
</tr>
<tr>
<td></td>
<td>PG</td>
<td>$180.53</td>
<td>$364.68</td>
</tr>
<tr>
<td></td>
<td>PG-13</td>
<td>$144.20</td>
<td>$293.40</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$129.15</td>
<td>$250.36</td>
</tr>
<tr>
<td>Mystery-Suspense</td>
<td>PG-13</td>
<td>$151.17</td>
<td>$334.06</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>$129.15</td>
<td>$250.36</td>
</tr>
</tbody>
</table>

11. Now drag the **Sum** statistic to the right of the **Domestic $**, **Mean** column. (See Figure 4.45.) Release the mouse button. **Sum** columns then reappear in the table (Figure 4.46).

**Figure 4.45 Drag Sum Column to the Right of Domestic $ Column**
12. The decimal and display formats can be changed. In the previous example, there are values displayed to the right of the decimal point for the Mean column. We would like to eliminate these values in the table. To adjust the display of decimals, click Change Format. (See Figure 4.47a.)
13. An additional format panel appears. In the Format pane, select \textbf{Use the same decimal format}. (See Figure 4.47b.)

\textbf{Figure 4.47b Change Decimal Display}

![Format pane with options](image)

14. In the revised Format panel, click \textbf{Fixed Dec} and enter a 0 for \textbf{Number of Decimals}. (See Figure 4.47c.) Then, click \textbf{Set Format} and \textbf{OK}.

\textbf{Figure 4.47c Specify Fixed Decimal Width}

![Format pane with options](image)
15. The table is now complete. Click **Done**. (See Figure 4.48.)

**Figure 4.48 Finalize Changes**

Recall that additional options are available on the red triangle. Click the red triangle next to Tabulate and select **Make Into Data Table** (see Figure 4.49), which will produce a JMP data table of the Tabulate results (Figure 4.50). **Make Into Data Table** will accomplish two tasks simultaneously; you will have a summary table for reporting and a data table of summarized data ready for further analysis or visualization.

Tabulate, therefore, is a useful tool for reshaping and reorganizing data for further analysis or graphing in addition to producing tabular reports.

**Figure 4.49 Make Data Table from Tabulate Results**
What do you think you can do with the new table in Figure 4.50? Try putting your new skills to work.

16. Use Graph Builder to make a graph out of the data table you just produced (select **Graph ➤ Graph Builder**).

17. Now, press **Ctrl** and select the columns **Sum (Domestic $)** and **Sum (Worldwide $)** so that they are both highlighted (see Figure 4.51).
18. Drag the two selected columns to the Y drop zone. (See Figure 4.52.)

**Figure 4.52 Drag Sum Columns to Y Drop Zone**

A point chart initially appears with blue and red dots.

19. Select the Bar element type icon. (See Figure 4.53.)

**Note**

Of course, you could right-click in the graph as you learned earlier in the chapter.

**Figure 4.53 Convert Point Chart to Bar Chart**
A bar chart appears, showing the worldwide and domestic revenue comparisons. (See Figure 4.54.)

**Figure 4.54 Bar Chart**

20. Now, drag **Type** to the **Group X** drop zone. (See Figure 4.55.)

**Figure 4.55 Drag Type to Group X Drop Zone**

21. Now, drag **Rating** to the **Group Y** drop zone. (See Figure 4.56.)

**Figure 4.56 Drag Rating to Group Y Drop Zone**
The nearly finished graph appears (Figure 4.57).

Figure 4.57 Nearly Finished Graph

22. Click **Done**, and the finished graph appears. (See Figures 4.58 and 4.59.)

Figure 4.58 Click Done to Finalize
4.4 Summary

In this chapter, we examined a key feature of JMP, which is its ability to create graphs and summaries interactively and intuitively in an environment that enables quick exploration and discovery. This chapter introduced you to two tools, Graph Builder and Tabulate.

Graph Builder shows you quick previews of graphs and maps as you drag columns to drop zones, enabling you to flip through choices until you find just the right one to tell the graphical story in your data. With a local data filter, Graph Builder enables you to drill down to the right level in your data. In contrast, the methods used in Chapter 3 assume that you have a specific graph in mind and need directions to reproduce it.

Tabulate shows you quick previews of numerical table summaries as you drag columns to drop zones. Tabulate enables you to flip through choices until you find the right numerical table summary of your data.
Ready to take your SAS® and JMP® skills up a notch?

Be among the first to know about new books, special events, and exclusive discounts.

support.sas.com/newbooks

Share your expertise. Write a book with SAS.

support.sas.com/publish

sas.com/books for additional books and resources.