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Introduction

The growth of the amount of data available in digital form has been increasing exponentially.
Bernard Marr, in his September 30, 2015, Forbes Magazine Tech post listed several “mind-
boggling” facts (Marr):

e “The data volumes are exploding, [and] more data has been created in the past two years
than in the entire previous history of the human race.”

e “Data is growing faster than ever before and by the year 2020, about 1.7 megabytes of
new information will be created every second for every human being on the planet.”

e “By then, our accumulated digital universe of data will grow from 4.4 zettabytes today to
around 44 zettabytes, or 44 trillion gigabytes.”


http://www.sintef.no/home/Press-Room/Research-News/Big-Data--for-better-or-worse/
http://www.whizpr.be/upload/medialab/21/company/Media_Presentation_2012_DigiUniverseFINAL1.pdf
http://www.emc.com/leadership/digital-universe/2014iview/executive-summary.htm
http://www.sas.com/store/prodBK_68711_en.html
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Historical Perspective

To put this 44 trillion gigabytes forecast into perspective, in 2011 the entire print collection of the
Library of Congress was estimated to be 10 terabytes (Ashefelder). The projected 44 trillion
gigabytes is approximately 4.4 billion Libraries of Congress.

Historically, because of high costs and storage, memory, and processing limitations, most of the
data stored in databases were structured data. Structured data were organized in rows and columns
so that they could be loadable into a spreadsheet and could be easily entered, stored, queried and
analyzed. Other data that could not fit into this organized structure were stored on paper and put in
a file cabinet.

Today, with the cost and the limitation barriers pretty much removed, this other “file cabinet”
data, in addition to more departments and more different types of databases within an
organization, are being stored digitally. Further, so as to provide a bigger picture, organizations
are also accessing and storing external data.

A significant portion of this digitally stored data is unstructured data. Unstructured data are not
organized in a predefined matter. Some examples of types of unstructured data include responses
to open-ended survey questions, comments and notes, social media, email, Word, PDF and other
text files, HTML web pages, and messages. In 2015, IDC Research estimated that unstructured
data account for 90% of all digital data (Vijayan).

Unstructured Data

With so much data being stored as unstructured data or as text (unstructured data will be
considered to be synonymous with fext), why not leverage the text, as you do with structured data,
to improve decisions and predictions? This is where text mining comes in. Text mining and data
mining are quite similar processes in that their goal is to extract useful information so as to
improve decisions and predictions. The main difference is that text mining extracts information
from text while data mining extracts information from structured data.

Both text mining and data mining initially rely on preprocessing routines. Since the data have
already been stored in a structured format, the preprocessing routines in a data mining project
focus on cleaning, normalizing the data, finding outliers, imputing missing values, and so on. Text
mining projects also first require the data to be cleaned. However, differently, text mining projects
use natural language processes (a field of study related to human-computer interaction) to
transform the unstructured data into a more structured format. Subsequently, both text mining and
data mining processes use visualization and descriptive tools to better understand the data and
apply predictive techniques to develop models to improve decisions and provide predictions.

Text mining is categorized, as shown in our multivariate analysis framework in Figure 15.1, as
one of the interdependence techniques, although text mining also includes the elements of
discovery and possibly dependence techniques.
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Figure 15.1: A Framework for Multivariate Analysis
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Text mining and the process of text mining have several definitions, extensions, and approaches.
The text mining process consists of three major steps:

1.

Developing the document term matrix. The document term matrix (DTM) is a set of
zero and 1 variables (also called indicator variables) that represent the words in the text.
Natural language processing techniques are used to initially develop the DTM.
Subsequently, you explore the set of variables and curate the DTM, by grouping words
or removing infrequent words, until you are satisfied.

Using multivariate techniques. Text visualization and the text multivariate techniques
of clustering, principal components, and factor analysis (PCA/FA) (similar to the
continuous multivariate techniques discussed in Chapters 4, 7, and 9) are used to
understand the composition of the DTM.

Using predictive techniques. If a dependent variable exists, you can use the text
multivariate analysis results (along with other structured data) as independent variables
in a predictive technique.

More and more of today’s digital data are unstructured data. In this chapter, how the text mining
process can leverage information from this unstructured data or text to enhance your
understanding of the text, as well as to improve your decisions and predictions, will be discussed.

Developing the Document Term Matrix

The Text Explorer platform in JMP uses a bag of words approach.! The order of words is ignored
except for phrases, and the analysis is based on the count of words and phrases. The words are
processed in three stages to develop the DTM as shown in Figure 15.2:

1.
2.
3.

tokenizing
phrasing
terming
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Figure 15.2: Flowchart of the Stages of Text Processing

~,
rd

\
For each word and phrase, do as follows:
s Convert text to lowercase.
» Satisfy length requirements.
¢ Determine tokenizing method.
e Apply stemming rules.

Tokenizing Stage
N

!

Recod Do you need to
ecode recode?
N
Phrasing Stage
Add phrases you want to be terms.
Terming Stage

For each word and phrase, do as follows:
» Determine whether it is qualified to be a term.
* Remove it if it is a stop word.

To understand this process of transforming the text into a structured format, open a small data set
called toytext.jmp, which contains just one column of text in 14 rows as shown in Figure 15.3.



Figure 15.3: Data Table of toytext.jmp File
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[} toytext - IMP Pro (=] B
File Edit Tables Rows Cols DOE Analyze Graph Tools View Window Help
RN 53 2 B
- | toytext N E =
I+ Source > text

1 |woman
2 |Men
3 |man
4 'women
= Colurnns (1/0) 5 'woman dress
W text 6 'women DRESSES
7 | men cars
8 | mancar
9 'women shoes
10 | men beer
11 | women dresses
12 men cars
13 'mn

» |Rows 14 wn

All rows 14
Selected 0
Excluded 0
Hidden 0
Labelled 0

@& O

Each row of words in the variable text column is called a document. Hence, the toytext.jmp file
has 14 documents. The entire set of these 14 documents is called a corpus.

Understand the Tokenizing Stage

To access the Text Explorer platform in JMP, complete the following steps:

1. Select Analyze » Text Explorer. The Text Explorer dialog box appears as shown in

Figure 15.4.

2. Under 1 Columns, click text and click the box Text Columns, and the variable text will

be listed.
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Figure 15.4: Text Explorer Dialog Box

%1 Text Explorer - JMP Pro = | (5 -
Select Columns Cast Selected Columns into Roles Action
Lz i o |

i :

E| optional @l
Language [English - | W| optional
Maximum Words per Phrase 4 @l
Mlax.imum MNumber of Phrases 5000 [El
Minimum Characters per Word 1

Maximum Characters per Werd 50 Help |

Stemming

[No Stemming v|

Tokenizing [Regex - |

[7] Customize Regex
Treat Numbers as Words

Select Options in the Text Explorer Dialog Box
The list of options offered in Figure 15.4 include the following:

e Maximum Words per Phrase, Maximum Number of Phrases and Maximum
Characters per Word. As you progress down the flowchart and curate the DTM, you
will decide what these limits of words and phrases will be.

e Stemming. Stemming combines related terms with common suffixes, essentially
combining words with identical beginnings (called stems), but different endings. The
stemming process in JMP uses the Snowball string processing language, which is
described at http://snowballstem.org. The drop-down arrow provides three options:

©  No Stemming. No terms are combined.

©  Stem for Combining. Terms are stemmed when two or more terms stem to the same
term. For example, in your toytext.jmp data set, dress, Dress, and dresses would be
stemmed to dress-. JMP uses a dot (+) to denote a word’s being stemmed.

o Stem All Terms. All terms are stemmed.

o Tokenizing. This is the method used to parse the body of text into terms or tokens. The
drop-down arrow provides two options:

©  Basic Words. Text is parsed into terms by using a set of delimiters (such as white
space, money, time, URLs, or phone numbers) that typically surround words. To
view the default set of delimiters, click the red triangle, select Display Options »
Show Delimiters, and click OK after Text Explorer has been run.

©  Regex (which is short for reqular expression). Text is decomposed using a set of
built-in regular expressions. Regex is an advanced feature (beyond the scope of this
book) and a very powerful tool for using regular expressions to identify patterns in
the text. The Regex option is a superset of the Basic Words option. That is, when
Regex is selected, in addition to the default regular expressions provided by the


http://snowballstem.org/
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Regex option, the default delimiters included by the Basic Words option are also
included. Furthermore, if Regex is selected and you want to add, delete, or edit this
set of regular expressions, click the Customize Regex check box. Once you click
OK, the Regular Expression Editor dialog box will appear. For more information
about building your own Regex, see www.regular-expressions.info.

For this example, use the following options:

1. 1Interms of Minimum Characters per Word, to avoid words such as “a,” “an,” and so
on, you would normally use at least 2 (and usually 2); but in this small example leave it
at the default value of 1.

2. Stem for Combining is recommended; but, initially, with this small example, use No
Stemming.

3. Select Regex.
4. Click OK.

These Text Explorer dialog box selections are the components in the dashed box within the
Tokenizing Stage box in Figure 15.2.

The Text Explorer output box will appear as shown in Figure 15.5.

Figure 15.5: Text Explorer Output Box

=] toytext - Text Explorer of text - IMP Pro (= | B [t
A = Text Explorer for text
NMumber Mumber Total Tokerns Mumber of Non- Portion Non-
of Terms ofCases Tokens per Case emptyCases empty per Case
12 14 22 157143 14 1.0000
4 Term and Phrase Lists
Term Count Phrase Count N
men 4 men cars 2 2
Women 4 women dresses 2 2
cars 2
dresses 2
man 2
woman 2 I
beer l:l
car 1
dress 1
mn 1
shoes 1 :
wn 1
20 O

At the top of Text Explorer output (Figure 15.5), some summary statistics are provided.

Each document is broken into initial units of text called fokens. Usually, a token is a word, but it

can be any sequence of non-whitespace characters. As shown in Figure 15.5, there are 22 total
tokens.


http://www.regular-expressions.info/
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The basic unit of analysis for text mining is a term. Initially, the Text Explorer examines each of
the tokens to determine a possible set of useful terms for analysis. As shown in Figure 15.5, the
number of initial terms is 12; they are listed below on the left side and sorted by frequency. This
number of terms will change as you transform the text.

On the right side of Figure 15.5, there is a list of phrases common to the corpus—the phrases
“men cars” and “women dresses” occurred twice. A phrase is defined as a sequence of tokens that
appear more than once. Each phrase will be considered as to whether it should be a term.

Terms are the units of analysis for text mining. Presently, since you have yet to do anything to the
data set and if you want to analyze it, complete the following steps:

1. Click the Text Explorer for text red triangle, and select Save Document Term Matrix;
accept all the default values.

2. Click OK.

The data table now has 12 new indicator variables, one for each term as shown in Figure 15.6. As
you can see in Figure 15.6, one of the first steps that the Text Explorer module does is to convert
all the terms to lowercase. In particular, note that dresses and DRESSES are considered as the
same term. By default, the Text Explorer also treats the plural of terms, such as dress and dresses
or men and man, as different terms or units.

Figure 15.6: Toytext.jmp Data Table with Initial Document Terms

q S women dresses ‘woman
= text men Binary Binary cars Binary Binary man Binary Binary beerBinary | carBinary | dressBinary  mnBinary | shoesBinary  wn Binary
1 woman
2 Men
3 man
4 women
5 woman dress
6 | women DRESSES
7 men cars
8 mencar
9 women shoes
10 men beer
11 women dresses
12 mencars
13 mn
14 wn

cororoorooooro

The current number of 14 terms, or indicator variables, is probably more than what you want to
work with. You most likely want to combine some of these terms as well as clean up the data
before you proceed. (For now, to delete all 12 indicator variables, select all the indicator variable
columns, right-click, and click Delete Columns.)

Recode to Correct Misspellings and Group Terms

Examining Figure 15.5 and 15.6 further, you can see that women and woman as well as men and
man were not combined. You can also see that there are two misspellings: mn and wn.

To correct the misspelling of mn, click mn in the Text Explorer output, Figure 15.5:

1. Right-click the term mn in the Text Explorer output box and click Recode.
2. As shown in Figure 15.7, in the New Values box, enter men.
3. Click Done.

This misspelling is now included with the term men. The count for men should have increased
from 1 to 5. Also, check the data table. Although mn is now included with men within the Text
Explorer platform, it is still coded as mn in the data table.



Figure 15.7: Recode Dialog Box
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To group together the terms men and man, complete the following steps:

1. Click the term men in the Text Explorer output box, hold down the Ctrl key, and click

man.
2.
3.
4.

Figure 15.8: The Recode Dialog Box

Right-click and click Recode. The Recode dialog box appears.
As shown in Figure 15.8, highlight man and men, and right-click.
Click Group To men and click Done. The count for men has increased from 2 to 7.

. A
[# Recode
A= Term ol Bape |
S ST W S | Cancel |

[T] Show enly Grouped
[T] Show only Ungrouped

[ Group ]

|

Help l

b

A

Similarly, recode wn to women, and group women and woman. The Text Explorer output box

will look like Figure 15.9.
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Figure 15.9: Text Explorer Output Box

$51 toytext - Text Explorer of text - JMP Pro
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Phrase Count N
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The process of combining related terms is called stemming. Stemming combines related terms
with common suffixes—combining words with identical beginnings (called stems), but different

endings. To accomplish this, complete the following steps:

1. Click the Text Explorer for text red triangle.

2. Select Term Options » Stemming » Stem for Combining.

The Text Explorer output should look similar to Figure 15.10.

Figure 15.10: Text Explorer Output Box after Stemming

i1 toytext - Text Explorer of text - JMP Pro

—

Bl [

A |=|Text Explorer for text
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Term Count
men 7
women 7
car 3 .
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beer 1
shoes 1

Number of Non- Portion Non-

emptyCases empty per Case
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Phrase Count N
MMEen Cars 2 2
women dresses 2 2

2~ O
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As shown in Figure 15.10, the terms car and cars have been combined into the one new term car-
and similarly for dress and dresses. You can check this by clicking one of the stemmed terms
car- or dress-, right-clicking, and then clicking Show Text.

The recoding of terms thus far completed applies only within the Text Explorer platform; that is,
the data is not changed in the data table. To verify, click to open the data table and observe that
mn, man, wn, and woman are still listed.

Recoding does affect stemming and should occur before stemming. Hence, it is important that you
should try to recode all misspelling and synonyms before executing the Text Explorer platform.
Use the Recode procedure under the Cols option. The terms woman dress and man car will also
need to be recoded.

Understand the Phrasing Stage

If you want any of the phrases to be analyzed as individual concepts and separated from their
individual terms, then you can add these phrases to your term list. For example, to add the phrases
men cars and women dresses to your term list, complete the following steps:

1. Click men cars, hold down the Shift key, and click women dresses under the list of
Phrases.

2. Right-click, and then click Add Phrase.

The two phrases are now added to the list of terms. They were both stemmed with the plural
phrase that appeared only once as shown in Figure 15.11. They are also dimmed in the phrase list,
indicating that they are being treated as terms.

Figure 15.11: Text Explorer Output Box after Phrasing
toytext - Text Explorer of text - JMP Pro | = | B et

£ = | Text Explorer for text

Number Number  Total Tokens MNumber of Non- Portion Non-
of Terms of Cases Tokens per Case emptyCases empty per Case
6 14 22 1.57143 14 1.0000

ATerm and Phrase Lists

Term Count Phrase Count N
men 4 mMen Cars 2 2
Women 4 women dresses 2 2
men car I

women dress: 3 I

beer 1

choes 1

28 O
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Examining Figure 15.11 further, you can see that the instances of the term men that were in the
term men car- have been removed from the count of men and similarly for the term women. To
clearly see what you have done so far, complete the following steps:

1. Click the Text Explorer for text red triangle.
2. Select Save Document Term Matrix.
3. Click OK.

Added to the data table are 6 indicator variables, down from your initial 12, one for each term in
Figure 15.11, as shown in Figure 15.12.

Figure 15.12: Document Text Matrix
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Understand the Terming Stage
Stop words are words that can be characterized in one or more of the following ways:

[T L I3

e too common, such as “a,”, “an,” or “the”;
e infrequent (their counts are low); or
e ignorable (not relevant to the analysis).

Create Stop Words

As shown in Figure 15.11, you have 2 terms with counts of 1. To make them into stop words,
complete the following steps:

1. Click beer under the list of Terms.
2. Hold down the Shift key and click shoes.
3. Right-click and then click Add Stop Word.

The list of terms now excludes the terms beer and shoes as shown in Figure 15.13. To see the list
of stop words, click the Text Explorer for text red triangle, and select Display Options » Show
Stop Words.



Figure 15.13: Text Explorer Output Box after Terming
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Generate a Word Cloud

A visualization of the list of terms is called a Word Cloud. To produce the Word Cloud as shown
in Figure 15.13, complete the following steps:

A e

Click the Text Explorer for text red triangle.
Select Display Options » Show Word Cloud.
Click the red triangle next to Word Cloud.
Select Layout » Centered.

Again, click the red triangle next to Word Cloud.

6. Click Coloring » Arbitrary Colors.

The Word Cloud is added to the Text Explorer output as in Figure 15.13. The size of each term in
the Word Cloud is relative to its frequency.

Observe the Order of Operations

The list of terms, on the left side of Figure 15.13, shows the list of indicator variables that are used
in creating the DTM. As you have worked your way through the flowchart (see Figure 15.2), your
objective has been to examine and explore the list of terms and phrases to produce a final list of
terms that you are satisfied with. There are no definitive approaches to take, particular words to
focus on (depending on the objective of the study and domain expertise), nor a definitive measure
to say that you have a good list of terms. This is also an iterative process. However, you should be
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aware that the order of operation in the creation of a list of terms can affect the resulting list of
terms.

The following general steps are suggested:

1. Before executing the Text Explorer, recode all misspellings and synonyms in the data
table.

2. Inthe Text Explorer dialog box, select these options:
a.  Minimum number of characters (use 2)
b. Stemming (select Stem for Combining)
c. Tokenizing (select Regex unless you have some custom regexs that you want to
add)
3. In the Phrasing Stage, do the following:
a. Examine the phrases.

b. Specify which phrases you want to be included as terms; in particular, select the
most frequent sequence of phrases.

4. 1Inthe Terming stage, do the following:
a. Remove stop words.
b. Remove least frequent terms.
c. Remove too frequent terms (if any).

Developing the Document Term Matrix with a Larger Data Set

Now you will examine a larger and more realistic data set. The data set

traffic_violations dec2014.jmp contains all the electronic traffic violations that occurred in
Montgomery County, Maryland, during December 2014 (dataMontgomery: “All electronic traffic
violations”). The file contains 16,446 records and 35 columns. The 35 variables are as follows;
their dictionary can be found at (dataMontgomery: “Variable dictionary”):

Date of Stop
Time of Stop
Agency
SubAgency
Description
Location
Latitude
Longitude
Accident

Belts

Personal Injury
Property Damage
Fatal
Commercial License
Hazmat

Commercial Vehicle
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Alcohol

Work Zone
State

Vehicle Type
Year

Make

Model

Color
Violation Type
Charge

Article
Contributed to Accident
Race

Gender

Driver City
Driver State
DL State
Arrest Type
Geolocation

Generate a Word Cloud and Examine the Text
Examine the text in the variable field Description:

Select Analyze » Text Explorer.

In the Text Explorer dialog box under 1 Columns, click Description.

Click the box Text Columns; change the Minimum Characters per Word to 2.
Click the drop-down arrow for Stemming, and choose Stem for Combining.
Click OK.

In the Text Explorer output, click the Text Explorer for Description red triangle.
Click Display Options » Show Word Cloud.

Click the red triangle next to Word Cloud,

Click Layout » Centered, and again click the red triangle next to Word Cloud.

0. Click Coloring » Arbitrary Colors. The Text Explorer output box with the Word
Cloud will appear as shown in Figure 15.14.

= 0 0Nk W=
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Figure 15.14: Text Explorer Output Box

T traffic-violations_dec2014 - Text Explorer of Description - JIMP Pro =REN X
4 [=|Text Explorer for Description
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4 Term and Phrase Lists
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Examine and Group Terms
Under the list of phrases, find the phrase motor vehicle and complete the following steps:

1. Click the phrase motor vehicle.

2. Right-click and then click Select Contains. This option selects bigger phrases that
contain this phrase. Scroll down the list of phrases on the right side of the Text Explorer
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output and you can see highlighted the other phrases that contain the phrase motor
vehicle.

Similarly, under the list of phrases, scroll down until you find the phrase driving vehicle on
highway and complete the following steps:

1. Click the phrase driving vehicle on highway.

2. Right-click and this time click Select Contained. Scroll up and down the list of phrases;
highlighted are all the phrases that contain one or more of the terms in driving vehicle
on highway.

As you can see in Figure 15.14, you initially have 741 terms with the terms failure and drive:
appearing in a little more than one-third of the documents. (Sometimes, if a term occurs too often,
it might not be that usefull; you can make that term a stop word. This will not be considered to be
the case here.) Continue with the following steps:

1. Right-click the term failure, and click Show Text. A new window appears, with all the
text that contains failure, which appears to be only the term failure.

2. Right-click the term failure, but this time click Containing Phrases. This option selects
small phrases that this phrase contains. All the phrases on the right side of Text Explorer
output that contain the term failure (which you found to be just the term failure) will be
highlighted.

Now examine the term drive- as follows:

1. Click the Text Explorer for Description red triangle.

2. Click Display Options » Show Stem Report. Added to the Text Explorer output are
two lists—on the left, a list of stemmed terms and their terms used in the stem and, on
the right, the list of terms and the term that they are stemmed with.

3. Scroll down the left, until you come to drive- (stemmed terms are in alphabetic order).
You can see the terms associated with the stemmed term drive- are drive and driving.

(Note that if there is one or more stemmings that you do not like, it is probably best to exit the
Text Explorer. Recode those undesired stemmings, and restart the Text Explorer.)

Add Frequent Phrases to List of Terms

Next add the most frequent phrases to your list of terms. Arbitrarily, you decide to include all the
phrases occurring more than 500 times.

1. Click the first phrase under the list of phrases, which is driver failure.

2. Hold down the Shift key, scroll down, and click the phrase influence of alcohol. Notice
that all the phrases above are now highlighted.

3. Right-click and click Add Phrase.

Several changes occur, and the Text Explorer output will look as shown in Figure 15.15.
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Figure 15.15: Text Explorer Output Box
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Parse the List of Terms
Lastly, parse your list of terms:

1. Right-click anywhere under the list of terms and, in the list of options, click Alphabetic

Order.
2. Click the first term 1; hold down the Shift key, and scroll down to and click 99.

3. Right-click and click Add Stop Word. All these number terms are now deleted from

your list of terms.
4. Again, right-click under the list of terms, and deselect Alphabetic Order. As before, the

terms are now sorted by frequency.
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Now delete all the terms that occur fewer than 100 times:

1. Scroll down the list of terms until you come to the term secur-, which occurs 97 times.
2. Click secur-; hold down the Shift key, scroll down to the end, and click vehicle on

highway without.
3. Right-click and click Add Stop Word.

The Text Explorer output will now look similar to Figure 15.16.

Figure 15.16: Text Explorer Output Box
rﬁ traffic-violations_dec2014 - Text Explorer of Description - JMP Pro E@Iﬂw
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Using Multivariate Techniques
After you have curated the DTM to your satisfaction, you are ready to apply multivariate
techniques to understand the underlying structure of the DTM.

These techniques are similar to principal components, factor analysis, and clustering techniques
that are applied to continuous data.

Perform Latent Semantic Analysis

Latent Semantic Analysis (LSA) is a family of mathematical and statistical techniques for
extracting and representing the terms and phrases from a corpus. The DTM is reduced
dimensionally to a manageable size, which makes the analyses go much faster. And the DTM is
amenable to using other multivariate techniques, by applying singular value decomposition
(SVD).

Understanding SVD Matrices
SVD produces a set of orthogonal columns that are linear combinations of the rows and explains
as much of the variation of the data as possible. SVD is an efficient approach to use with large,

very sparse matrices, which the DTM typically tends to have. SVD decomposes the DTM into
three other matrices:

DIM=D*S*T
These matrices are defined as follows:

e D is an orthogonal document-document matrix of eigenvectors.
e T is an orthogonal term-term matrix of eigenvectors.
e Sis a diagonal matrix of singular values.

The singular vectors in D and T reveal document-document, document-term, and term-term
similarities and other semantic relationships, which otherwise might be hidden.

Many of the singular values in the S matrix are “too small” and can be ignored. So they are
assigned values of 0, leaving k nonzero singular values. The representation of the conceptual
space of any large corpus requires more than a handful of underlying independent concepts. As a
result, the number of orthogonal vectors that is needed is likely to be fairly large. So, k is often
several hundred.

Similarities and relationships are now approximated by this reduced model. This process is
analogous to using principal components in multivariate analysis. While principal components
provide components for the columns, SVD simultaneously provides principal components for
both the columns and rows (that is, for the documents and terms).

Plot the Documents or Terms

A common practice is to plot the documents or terms, these singular vectors, and especially the
first two vectors, that result from the SVD. Similar documents or terms tend to be plotted closely
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together, and a rough interpretation can be assigned to the dimensions that appear in the plot.
Complete the following steps:

1. Click the Text Explorer for Description red triangle, and click Latent Semantic
Analysis, SVD. The Latent Semantic Analysis Specifications dialog box will appear as
shown in Figure 15.17.

2. Change the Minimum Term Frequency to 100.

W

Click the drop-down arrow for Weighting.

4. The TF_IDF weighting results are usually more interpretable than the Binary, so click
that option.

Regarding weighting options, various methods of the term-frequency counts have been found to
be useful, with the Binary and TF_IDF being the most popular:

o The Binary weighting option is the easiest to understand in that it assigns a zero or a 1 to
indicate whether the term exists in the document. A disadvantage of the Binary option is
that it does not consider how often the term occurs in the document.

e The TF_IDF weighting option, which is short for term frequency—inverse document

frequency, does consider the tradeoff between the frequency of the term throughout the
corpus and the frequency of the term in the document.

Next you will select one of three SVD approaches:

e Uncentered
e Centered
e Centered and Scaled

The benefits and drawbacks of each are as follows:

e Traditional latent semantic analysis uses an Uncentered approach. This approach can be
problematic because frequent terms that do not contribute much meaning tend to score
high in the singular vectors.

e The Centered approach reduces the impact of these frequent terms and reduces the need
to use many stop words.

e The Centered and Scaling approach is essentially equivalent to doing principal
components on the correlation matrix of the DTM. This option explains the variation in
the data (not just the variation in the mean). Therefore, it tends to produce more useful
results, whereas using just the Centered approach is comparable to doing principal
components on the covariance matrix of the DTM.

Continue with the example as follows:

1. Click the drop-down arrow for Centering and Scaling. Select the Centered and
Scaling approach.

2. Click OK.
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Figure 15.17: Latent Semantic Analysis Specifications Dialog Box
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The Latent Semantic Analysis output should look similar to Figure 15.18 (except for the
highlighted regions).

Figure 15.18: SVD Plots
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The plot on the left displays the first two document singular vectors in matrix D. The plot on the
right displays the first term singular vectors in T as shown in Figure 15.18. In each graph, the
singular vectors have three branches or tendrils. In the document singular vector graph, the three
tendrils are highlighted and labeled. To examine the text, complete the following steps:

1. Left-click the document singular vector graph, hold down the mouse button, and move to
highlight the area labelled 1 in Figure 15.18.

2. Just below SVD plots, click Show Text. A window appears with a list of documents.

Examining the document list, you see that major themes are the drive use handheld and failure
of vehicle on highway to display lighted lamps.
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Similarly, highlight, the documents in the tendril labeled 2 and click Show Text. These
documents appear to have several themes of driving vehicle, person drive motor vehicle, and
negligent driving. Lastly, highlight the documents in Tendril 3, and you see the terms driving
vehicle on highway without current registration and failure of licensee to notify. (Keep these
documents in the third tendril highlighted.)

As you did with the document singular vectors, you can explore the term three tendrils in the term
singular vector plot. In general, the document singular vector plot provides more insight than the
term singular vector plot.

To examine more SVD plots, complete the following steps:

Click the Text Explorer for Description red triangle.
Click SVD Scatterplot Matrix.

Enter 10 for the Number of singular vectors to plot.
Click OK.

Sl

Added to the Text Explorer output are scatterplots of the first 10 singular vectors for the
documents and terms. Figure 15.19 shows the top part of this scatterplot.

Figure 15.19: Top Portion of SVD Scatterplots of SVD Plots of 10 Singular Vectors
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The bottom diagonal plots are graphs of the document singular vectors. The upper diagonal plots
are graphs of the term singular vectors. Highlighted in Figure 15.19 is the SVD plot of the first
two document singular vectors, which is similar to the plot on the left in Figure 15.18. The
highlighted documents in the third tendril are highlighted. And these documents are highlighted in
the other document singular vector plots. The term singular vector plot directly above the
highlighted document singular vector plot in Figure 15.19 is the plot of the first two-term singular
vectors, which is similar to the plot in Figure 15.18 but rotated 270°.
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Perform Topic Analysis

Another way of observing these term themes in the documents is to perform topic analysis. Topic
analysis performs a VARIMAX rotation, essentially a factor analysis, on the SVD of the DTM.
Complete the following steps:

1. Click the red triangle next to Text Explorer for Description.
2. From the list options click Topic Analysis, Rotated SVD.
3. Click OK.

The Topic Analysis results are added to the Text Explorer output as shown Figure 15.20.

Figure 15.20: Topic Analysis Output

4 Topic Words
Topicl Topic2 Topic3 Topicd Topich

Term Score Term Score  Term Score  Term Score  Term Score

careless 0.34159  whilemotor 0.2965  visibl- 0.2882 person: drive: motor vehicle -0.2920  red 0.3268

life 0.34159  motion 0.2965 uninsured  -0.2500  highway or public use- -0.2867  signal 0.2245

imprudent 0.24159  telephone 0.2057  knowingly -0.2403  privilege -0.2408  speed 0.2237

endangering 0.34159  handheld 0.2957  devic: 0.2327  suspended -0.2334  knowingly 0.2180

manner 0.34064  use 0.2841 cond 0.2135  yield 0.2296  uninsured 0.1911

negligent 0.23845  hand. 02025  unfavorable 0.2135  property -0.2067  mph -0.1852

perscn. 0.31183  address -0.1980  illumin. 0.1821  police 0.1838 flashing 0.1788

drive: vehicle 0.23446 days -0.1959  intersect: 0.1740  uniformed 01811 steady 0.1779

property 0.21685 notify -0.1897  red 0.1702  turn- 0.1792  traffic 0.1711
wvehicle 0.1879  display- 0.1657  highway 0.1779  highway 0.1629
within -0.1837  line 0.1353  tab- -0.1561 exceeding the posted speed  -0.1628
administration -0.1664  stop- 0.1323  approach- 0.1529  limit -0.1628
chang. -0.1652  flashing 0.1287  right 0.1520  seatbelt. -0.1569
licensee -0.1617 way 0.1487 stop 0.1382

Topich Topic? TopicB Topic Topicl0

Term Score  Term Score  Term Score Term Score  Term Score

failure to stop  -0.2232  drive: 03205 failure 0.2706  current 0.3328  author 0.3214

hwry -0.2119  lic -0.2518 fail- 0.2652 display- 0.2407  drive- motor vehicle -0.2146

motor 0.2114  within 0.2417 speed -0.2402  wvalid. -0.2287  wvehicle on highway -0.2144

direct 0.2056 motor -0.2373  signal 0.2370  speed 0.2021  visibl- 0.2125

uninsured 0.1949 right 0.2327  light 0.2355 stop sign 0.1874  safety -0.2033

accident 0.1864  privilege -0.2196  traffic 0.2254  issued -0.1820  impaired 0.1768

drive: motor 0.1855 possess: 0.2108 demand 0.2051 maintain -0.1805 notify -0.1739

turn: -0.1803  equip- 01936  wisibl -0.1977  stop 0.1802  alcohol- -0.1716

emerg: -0.1768  obstruct: -0.1933  reason- 0.1779  highway -0.1596  registration plate. 0.1682

possess. -0.1750  hwy 0.1881 circular 0.1650 suspended 0.1403  stop. 0.1597

designated 0.1677 unauthorized 0.1708 motorvehicle -0.1266  permit 0.13%6  within 0.1530

half 0.1642 reg -0.1588  safety 0.1264 cbstruct  -0.1387 child 0.1491

oper -0.1619 view 0.1381 person. -0.1490

knowingly 0.1538 reascn: -0.1371  licensee 0.1467

display- 0.1434 adm 0.1436

The scores represent the loading of the term in that topic. The larger a term’s score, the stronger
its contribution to the topic. Each topic can be examined for major themes or terms that contribute
to that topic. In particular, when you examine the first topic in Figure 15.20, it appears that this
topic deals with careless and negligent, somewhat like Tendril 2, which you identified in the SVD
plots. And topic 2 seems to have similar terms as Tendril 1. If you choose to consider too few
topics, then there can be significant overlap between competing information. But if you choose
too many topics, then you will have some topics covering the same topics. Use trial and error to
decide how many to consider.

Perform Cluster Analysis

Cluster analysis is used to further understand the singular vectors. The Text Explorer platform in
JMP uses a customized latent class analysis methodology for cluster analysis. This is built just for
text. This latent class analysis procedure is good for finding interesting patterns in the text, and
because it is sparse matrix based, it is very fast.
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Begin the Analysis
To begin, complete the following steps:

1. Click the red triangle next to Text Explorer for Description and click Latent Class
Analysis.

2. Inthe Specifications dialog box, change the Minimum Term Frequency to 4 and the
Number of Clusters to 10.

3. Click OK.
4. Click the red triangle labelled Latent Class Analysis for 10 Clusters and click Color by
Cluster.

The cluster analysis results are shown in Figures 15.21 and 15.22. Because the latent class
analysis procedure uses a random seed, your results will be slightly different.

Examine the Results

Scroll back up to the SVD scatterplots. The document SVD plots are now colored by cluster.
Documents that tend to cluster together will appear near each other in their SVD plots. (You can
increase the size of a plot by grabbing the border with the mouse while holding down the mouse
key and dragging out wider.) For example, in Figure 15.23 the upper left portion of the SVD
scatterplot is shown.

Look at the group of documents highlighted in Doc Vec3. All these documents are in the same
cluster and in other plots. You can see that they are close to each other. Match up the color of
these documents with cluster colors as shown in Figure 15.21. Click that cluster number; in our
case it was Cluster 6. Now all the documents in Cluster 6 are highlighted in the SVD scatterplots.

Scroll further up to SVD Plots. In the left document singular vector plot, the Cluster 6 documents
are highlighted, which are mostly those documents in Tendril 3 (as shown in Figure 15.18). Click
Show Text. You see phrases or terms similar to those that you found in Tendril 3. Similarly, you
can highlight other clusters of the same colored documents and view the text.
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Figure 15.21: Top Portion of Latent Class Analysis for 10 Clusters Output Box

4 | Latent Class Analysis for 10 Clusters
BIC 42476556 Show Tedt
4 Cluster Mixture Probabilities
Mixture

Clusters
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4 Term Probabilities by Cluster

Cluster Most  Cluster
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drive: Cluster6 Cluster2 0.0000 0.0001 0.2852 |71 0.0001 0.5202 550 | | 0.0001
license Cluster? Cluster6 0.0000 0.0001 0.0061 0.0001 0.78%
veh Clusterd Clusterd 0.0088 00330 0.5351 [EN) 0.0001 0.0506
driver. Cluster8 Cluster8 0.0000 0.0058 0255 0.1448 1 0.0001 00036
stop. Clusters Clusters 0.1408 [ 0.0001 00342 012411 0.0000 00001
driver. failure to obey Cluster Cluster 0.0000 0.0000 06878 0.0000 0.0001 0.0001
proper. placed traffic control:  Cluster3 Cluster3 0.0000 0.0000 0.6406 0.0000 0.0000 00001
devic. instructions Cluster Cluster 0.0000 0.0000 06406 10 0.0000 0.0000 00001
display: ClusterL0 Cluster6 0.0000 0.0000 0.0000 0.0088 0.0000 00408
light Clusterd Clusterl 021327 0.0000 0.0000 00223 0.0000 00001
requir Cluster6 Cluster6 00523 0.0000 0.0000 0.2182 7] 0.0000 0.0001
drive: vehicle ClusterL0 Cluster10 0.0000 01377 0.0000 0.0603 01468 00001
vehicle Clusterd Clusterd 0.0020 0.0724 014271 02083 0.0000 00001
drive: vehicle on highway Clusterd Clusterl 02141 7] 0.0000 0.0000 0.0000 0.0000 00382
suspended Cluster? Cluster? 0.0000 0.0000 0.0000 0.0071 0.0000 08550
registration plate Clusterld Clusterld 0.0000 0.0000 00000 0.0689 0.0000 00001
property Cluster? Cluster? 0.0000 0.0000 0.0000 0.0280 0.0000 04658
sigal Clusters Clusters 0.0845 0.0000 0.0000 00377 0.0000 0.0000
highway Cluster6 Cluster6 0.0000 0.0127 0.0000 0.0821 014711 0.0000
lamp- Clusterd Clusterd 0.0740 0.0000 0.0000 0.1176 1 0.0000 0.0000
person: drive: motorvehicle  Cluster? Cluster? 0.0000 0.0000 00000 0.0000 0.0000 [ Ja—
police officer Clusterl Clusterl 02578 1 0.0000 0.0000 0.0015 0.0000 0.0000
card upon demand Clusterl Clusterl 0.2578 1 0.0000 0.0000 0.0000 0.0000 00000
failure to display registration _ Clusterl Clusterl 0.2578 1 0.0000 0.0000 0.0000 0.0000 0.0000 <
o i v

4 Top Terms per Cluster

Clusterl Cluster2 Cluster3 Clusterd Cluster5 Cluster Cluster? Clusters

Term Score Term Score Term Score Term  Score Term Score Term Score Term Score Term  Score Terr
light 23,7776 |drive: 6.5603 |driver failure to obey  6.9936 failure  7.8168 |mph zone 4,404 license 10.92|license 11024 driver. 9.3514 |disp
drive: vehicle on highway 3.2381 |influence of slcohol: 22117 |devic. instructions 64097 \veh  6.9250 |excesding maximum sp... 4.3513 |failure  8.3841 |suspended 8.592|stop.  6.9448 |light
police officer 2.5886 drive. vehicle 19635 | proper. placed traffic c.. 64097 drive- 44022 |mph in 3 posted 4.3513 | drive 81985 person. drive motor ve.. 74799 signal- 60867 | failu
failure to display regist.. 2.5802 |oper- 16644 |driver. 3.9843 requir 3485 |mph 4.2367 | display 6,177 |property 6.3919 |fail 5.5054 | regic
card upon demand 2.5802 alcohol. 14989 |lane: 2.293|vehicle 31598 |exceeding the posteds..  4.084 |requin  5.4715 | highway or public use: ~ 4.6583 |red 5.2647 |lamg
driver. failure to stop- 2.2326 | impaired 14817 |chang 22761 |rear  2.3275 [limit 4,004 |highway ~ 4.9751 privilege 4.259|traffic 40582 |veh
suspended registration 21708 stop. sign 13296 |vehicle 22752 |equip: 19813 |highway 23147 |police  4.2202lic 2194 tumn. 3.8847 with
line 1.9075 [failure to stop- 1104 use 1.8093 |speed  1.9681 |drive: vehicle 2.1726 | uniformed  3.9332 | possess- 1.0249 right  3.4923 |drive
stop. 18522 | headlight 0.9937 | hand 14467 lamp- 1.7281 |speed 2.0619 |demand  3.9212 revoked 0.9611 flashing  2.2621 |illun
stop sign 17605 | per 0.9028 telephone 14264 reg 14531 |reason. 1.7474 |individu.  3.8707 |drive: motor 0.6305 |intersect: 2.5552|tabe
< m ] B
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Figure 15.22: Lower Portion of Latent Class Analysis for 10 Clusters Output Box
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Figure 15.23: Upper Leftmost Portion of SVD Scatterplots
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Identify Dominant Terms

The Term Probabilities by Cluster report in Figure 15.21 has the term frequency in each cluster.
You can examine the terms horizontally or the clusters vertically, focusing on the large
frequencies. For example, look at the term license, which occurs most often in Clusters 6 and 7.
Since you previously have looked at Cluster 6, look at Cluster 7:

Right-click anywhere inside the report.
Select Sort Column.

In the new window, select Cluster 7.
Click OK.

bl o e

The most frequent terms in Cluster 7 are toward the top of the report. It seems that the Cluster 7
theme addresses drivers who were driving with suspended licenses.

A scoring algorithm for identifying which terms are most dominant within a cluster is shown in
the Top Terms per Cluster report (see Figure 15.21). The score is based on the term cluster
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frequency relative to its corpus frequency. Larger scores tend to occur more often in the cluster.
Look at Cluster 6 and 7. You see the most frequent terms are the terms you have identified earlier.

Occasionally terms score negative numbers, which implies that those terms are less frequent (you
do not have any negative scores in our example). Many times when several terms have negative
numbers, they occur in the same cluster. This is called a junk cluster. Most likely in this junk
cluster are blank documents or simply documents that do not fit nicely in other clusters and just
are adding noise to the analysis. If a junk cluster occurs, then it may be useful to identify those
documents in this cluster and rerun latent class analysis to exclude these junk documents.

The multiple dimensional scaling (MDS) plot of the clusters in Figure 15.22 is produced by
calculating the Kullback-Leibler distance between clusters. In natural language processing (NLP),
a document is viewed as a probability distribution of terms. The Kullback-Leibler distance is a
widely used measure for calculating the distance between two documents or probability
distributions (Bigi). An MDS is applied to these Kullback-Leibler distances to create coordinates
for the clustering in two dimensions. You can explore the MDS plot to examine clusters that are
near one another, as well as clusters that are far away from one another.

The clusters in your MDS plot are fairly well dispersed. Nonetheless, complete the following
steps:

1. Click Cluster 3. You can see in the Top Terms per Cluster report that the main terms
are driver- failure to obey, devic: instructions, and proper- placed traffic control..

2. Scroll back up to the output. You can see where the Cluster 3 documents occur in the
SVD plots.

3. Click Show text.

Most of the documents appear to have those terms that you detected.

Using Predictive Techniques

If the data set has a dependent variable and you want to do some predictive modeling instead of
using the large DTM matrix, you can use the document singular vectors. To determine how many
singular vectors to include, complete the following steps:

1. Scroll back up the output to find Singular Values. (It is just below the SVD plots and
before the SVD Scatterplots.)

2. Click the down-arrow next to Singular Values.

In general, as in principal components and factor analysis, you are looking for the elbow in the
data. Or another guideline is to include singular values until you reach a cumulative percentage of
80%. Many times with text data, the curve or percentages will only gradually decrease, so to reach
80% you may have to reach several hundred. As you will see, the default is 100. How many to
include is a judgment call.

Figure 15.24 shows the first 25 singular values. In this case, the percentages quickly exceed 80%,
and there is a sharp decrease. Six singular document vectors are chosen:

1. Click the Text Explorer for Description red triangle.
2. Click Save Document Singular Vectors.
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3. In the input box in the new dialog box next to Number of Singular Vectors to Save,
enter 6.

4. Click OK.

Check the data table, and you can see six new singular vector variables.

Figure 15.24: Singular Values

A Singular Values
Singular

Number Value Percent Cum Percent
1 35157 254519 254519
2 32275 21.4496 46,9016
3 29485 179134 ] ¢ 54,8149
4 27383 154305 | 50,2545
5 22422 10,3518 ! i 90,6063
6 12454 37275 1 1 94,2237
7 7521 11e49fl | i 95,4986
g8 3424 0244 | | | 95.7400
9 3308 02253 - i 95,9053
10 3203 0.2113 96,1766
11 2096 0197 96.2740
12 30684 01933 | ! 96,5673
13 2953 0.179% i ! ! i 96.7409
14 2915 0.1750 46,9219
15 2878 01705 | 97.0925
16 2757 0565 | | | i 97,2489
17 2731 0.1535 i ! ! i 97.402%
18 2621 0.1415 97,5440
19 2558 01347 | 0 97,6787
20 254 01333 | 97.8120
21 2483 0.12009 i ! ! i 097.9389
22 2387 01173 98,0562
23 2336 o112 0 98.1686
24 2314 o102 | 98,2788
25 2266 0.1057 i : : i 08.3845

Perform Primary Analysis
Before you perform any predictive modeling, do some primary analysis:

1. Click Analyze » Distribution. The distribution dialog box will appear.
2. Click Violation Type; click Y, Columns.
3. Click OK.

As shown in the distribution output in Figure 15.25, you can see that most of the violations are
equally distributed between Warning and Citation.



Figure 15.25: Distribution Output for Violation Type

E= traffic-violations_... l = | B [
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ESERC
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A4 Frequencies
Level Count

N Missing 305
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Prob

Citation 7773 0.48157
ESERC 1062 0.06580
Warning 7306 0.45264
Total 16141 1.00000

~E O
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Perform Logistic Regressions

Now run a logistic regression, predicting Violation Type and using Property Damage, Race, and
Belts as independent variables. The results are shown in Figures 15.26 and 15.27. You can see
that the three variables are significant in predicting Violation Type. However, as the Confusion
matrix in Figure 15.27 shows, the misclassification is rather high at 47.6%.
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Figure 15.26: Top Portion of Initial Logistic Regression Output

1 (*| Nominal Logistic Fit for Violation Type
£ Effect Summary
Source LogWorth PValue
Property Damage 85.637 [ ] 0.00000
Race 47,208 [ | | 0.00000
Belts gg3sl® | 0 0 T [ T T |oo0001
Remove Add Edit [C] FDR
Converged in Gradient, 8 iterations
P Iterations
4 Whole Model Test
Model -Loglikelihood DF Chisquare Prob>Chi5q
Difference 344,045 14 688.0895 <.0001*
Full 14016.883
Reduced 14360928
R5quare (L) 0.0240
AlCc 280658
BIC 281888
Observations (or Sum Wagts) 16141
P Fit Details
4 Lack Of Fit
Source DF -Loglikelihood ChiSquare
Lack Cf Fit 28 19,553 39,1055
Saturated 42 13997330 Prob>ChiSq
Fitted 14 14016.883 0.0792
4 Parameter Estimates
Term Estimate Std Error ChiSquare Prob>ChiSq
Intercept 140528364 01110242 160.21 <,0001*
Belts[Mc] -0.2153893  0.050695 18.05 < 17
Property Damage[Mo] -1.2401923  0.091338 184.26
Race[ASIAN] -0.3726647 0.0742235 2521
Race[BLACK] 0.08013957 0.0544066 217
Race[HISPANIC] 0.4818682 0.0571633 71.06
Race[MATIVE AMERICAN] 0.14474842 0.2260262 0.41
Race[OTHER] -0.207343  0.0765283 7.34
Intercept -2.8567254 05291313 209.15
Belts[Mc] 0.08996375 0.1196845 0.56
Property Damage[MNa] 07796021 0.5079254 2.36
Race[ASIAN] -0.0178041 0.1496136 0.01
Race[BLACK] 0.01292935 0.118979 0.01
Race[HISPANIC] 047869221 0.1213624 15.56
Race[MATIVE AMERICAN] -0.1677705 0.5095209 0.11
Race[CTHER] -0.2368692 0.1656815 2.04
For log odds of Citation/Warning, ESERQ/Warning
P> Covariance of Estimates
4 Effect Likelihood Ratio Tests
L-R
Source MNparm DF ChiSquare Prob>ChiSq
Belts 2 2 2227772 <,0001*
Property Damage 2 2 384372124 < ]
Race 10 10 24907271
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Figure 15.27: Lower Portion of Initial Logistic Regression Output

£ Confusion Matrix
Training
Actual
Violation Predicted Count
Type Citation ESERO Warning
Citation 4812 ] 2061
ESERO 596 0 466
Warning 3657 ] 3640

Rerun the logistic regression, now also including the six singular vectors. Figures 15.28 and 15.29

display the output. The model significantly improved and now has a misclassification rate of
40.7% (not great, but almost 7% better).
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Figure 15.28: Top Portion with Singular Values Logistic Regression Output

1 | Neminal Logistic Fit for Violation Type
4Whole Model Test
Observations (or Sum Wagts) 1614l
I Fit Details
4 Lack Of Fit
Source DF -Loglikelihood ChiSquare
Lack Of Fit 27304 12512447 25024809
Saturated 27420 933194 Prob>ChiSq
Fitted 26 13445641 1.0000
4 Parameter Estimates
Term Estimate Std Error ChiSquare Prob>ChiSq
Intercept 14586958 0.115175 160.40 <.0001*
Belts[MNeo] -0.2198381 0.052475 17.55 < 1#
Property Damage[Mo] -1.2562356 0.0944208 177.01
Race[ASIAN] -0.3301179 0.0767252 18,51
Race[BLACK] 0.056778%4 0.0562538 loz
Race[HISPANIC] 0.49413782 0.0590038 69.92
Race[MATIVE AMERICAN] 0.17876197 0.233575 0.59
Race[OTHER] -0.2498691 0.0793239 9.92
Singular Vector 1 0.14541267 0.0107277 183.73
Singular Vector 2 -0.0201244 0.0109278 3.39
Singular Vector 3 -0.0540743 0.0083803 41.55
Singular Vector 4 -0.04309174 0.0092166 2271
Singular Vector 5 0.24647847 0.0113655 47031
Singular Vector & -0.0e6414 0.0178543 13.84
Intercept -2.7400618 0.5298644 26,74
Belts[MNeo] 0.07974129 0.1199926 0.44
Property Damage[Mo] 0.70361008 0.508360 193
Race[ASIAN] 0.00333653 0.1500754 0.00
Race[BLACK] 0.00705221 0.1192p4 0.00
Race[HISPANIC] 0.48639561 0.1216659 15.98
Race[MATIVE AMERICAN] -0.1879668 0.5104457 0.14
Race[OTHER] -0.2277714  0.1660704 1.88
Singular Vector 1 0.0270551 0.0231478 137
Singular Vector 2 0.08472824 0.0250863 11.41
Singular Vector 3 -0.13405 0.0198855 4544 <.0001"
Singular Vector 4 -0.0131363 0.0175385 0.56 0.4539
Singular Vector 5 0.07425631 0.021% 11.45 0.0007*
Singular Vector & 0.05905383 0.0338605 304 0.0812
For log odds of Citation/Warning, ESERC/Warning
I Covariance of Estimates
4 Effect Likelihood Ratio Tests
L-R
Source Nparm DF ChiSquare Prob>ChiSq
Belts 2 2 21.3456469 <,0001"
Property Damage 2 2 352080134 < il
Race 10 10 248.627373
Singular Vector 1 2 2 348348504
Singular Vector 2 2 2 19.7940328
Singular Vector 3 2 2 75.2607129
Singular Vector 4 2 2 231297768
Singular Vector 3 2 2 514.561384
Singular Vector & 2 2 21.6591688
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Figure 15.29: Lower Portion with Singular Values Logistic Regression Output

£ Confusion Matrix

Violation Predicted Count

Type Citation ESERO Warning
Citation 4704 0 3069
ESERC 380 0 682
Warning 2445 ] 4860

Training
Actual

Exercises

1.

In the aircraft incidents.jmp file is data for airline incidents that were retrieved on
November 20th, 2015 from http://www.ntsb.gov/_layouts/ntsb.aviation/Index.aspx. For
the Final Narrative variable, use the Text Explorer to produce a DTM by phrasing and
terming.

Create a Word Cloud. As in problem 1, similarly produce a DTM by phrasing and
terming, and create a Word Cloud except for the variable Narrative Cause. In the file
Nicardipine.jmp is data from adverse events from this drug. For the Reported Term for
the Adverse Event variable, use the Text Explorer to produce a DTM by phrasing and
terming.

Create a Word Cloud. In the Airplane Crash Reports.jmp file is one variable, NTSB
Narrative, that summarizes the crash report. For this variable, use the Text Explorer to
produce a DTM by phrasing and terming.

Create a Word Cloud. In the FDA_Enforcement Actions.jmp file, the variable Citation
Description describes the violation. For this variable, use the Text Explorer to produce a
DTM by phrasing and terming.

Create a Word Cloud. The traffic-violation jun2015.jmp is similar to the file used in the
chapter except that the data is for June 2015 only. For the variable Description, use the
Text Explorer to produce a DTM by phrasing and terming.

Create a Word Cloud. How does this compare to data for December 2014? Perform
Latent Semantic Analytics, Topic Analysis, and Cluster Analysis on the DTM you
produced in Problem 1. Perform Latent Semantic Analytics, Topic Analysis, and Cluster
Analysis on the DTM you produced in Problem 2.

Perform Latent Semantic Analytics, Topic Analysis, and Cluster Analysis on the DTM
that you produced in Problem 3. Perform Latent Semantic Analytics, Topic Analysis, and
Cluster Analysis on the DTM you produced in Problem 4. Perform Latent Semantic
Analytics, Topic Analysis, and Cluster Analysis on the DTM you produced in Problem 5.
Perform Latent Semantic Analytics, Topic Analysis, and Cluster Analysis on the DTM
you produced in Problem 6. How does this compare to data for December 2014?

Similar to the predictive model that you did in the chapter, create a predictive model for
violation type. How does this compare to data for December 2014?


http://www.ntsb.gov/_layouts/ntsb.aviation/Index.aspx
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! The authors would like to thank Daniel Valente and Christopher Gotwalt for their guidance and
insight in writing this chapter.



About This Book

What Does This Book Cover?

This book focuses on the business statistics intelligence component of business analytics. It covers
processes to perform a statistical study that may include data mining or predictive analytics
techniques. Some real-world business examples of using these techniques are as follows:

target marketing

customer relation management
market basket analysis
cross-selling

market segmentation

customer retention

improved underwriting

quality control

competitive analysis

fraud detection and management

churn analysis

Specific applications can be found at http://www.jmp.com/software/success. The bottom line, as
reported by the KDNuggets poll (2008), is this: The median return on investment for data mining
projects is in the 125-150% range. (See http://www.kdnuggets.com/polls/2008/roi-data-

mining.htm.)

This book is not an introductory statistics book, although it does introduce basic data analysis,
data visualization, and analysis of multivariate data. For the most part, your introductory statistics
course has not completely prepared you to move on to real-world statistical analysis. The primary
objective of this book is, therefore, to provide a bridge from your introductory statistics course to
practical statistical analysis. This book is also not a highly technical book that dives deeply into
the theory or algorithms, but it will provide insight into the “black box™ of the methods covered.
Analytics techniques covered by this book include the following:

regression

ANOVA

logistic regression

principal component analysis
LASSO and Elastic Net
cluster analysis

decision trees

k-nearest neighbors

neural networks


http://www.jmp.com/software/success/
http://www.kdnuggets.com/polls/2008/roi-data-mining.htm
http://www.kdnuggets.com/polls/2008/roi-data-mining.htm
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e bootstrap forests and boosted trees
e text mining
e association rules

Is This Book for You?

This book is designed for the student who wants to prepare for his or her professional career and
who recognizes the need to understand both the concepts and the mechanics of predominant
analytic modeling tools for solving real-world business problems. This book is designed also for
the practitioner who wants to obtain a hands-on understanding of business analytics to make better
decisions from data and models, and to apply these concepts and tools to business analytics
projects.

This book is for you if you want to explore the use of analytics for making better business
decisions and have been either intimidated by books that focus on the technical details, or
discouraged by books that focus on the high-level importance of using data without including the
how-to of the methods and analysis.

Although not required, your completion of a basic course in statistics will prove helpful.
Experience with the book’s software, JMP Pro 13, is not required.

What’s New in This Edition?

This second edition includes six new chapters. The topics of these new chapters are dirty data,
LASSO and elastic net, k-nearest neighbors, bootstrap forests and boosted trees, text mining, and
association rules. All the old chapters from the first edition are updated to JMP 13. In addition,
more end-of-chapter exercises are provided.

What Should You Know about the Examples?

This book includes tutorials for you to follow to gain hands-on experience with SAS.

Software Used to Develop the Book's Content
JMP Pro 13 is the software used throughout this book.

Example Code and Data

You can access the example code and data for this book by linking to its author page at
http://support.sas.com/authors. Some resources, such as instructor resources and add-ins used in
the book, can be found on the JMP User Community file exchange at https://community.jmp.com.
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Where Are the Exercise Solutions?

We strongly believe that for you to obtain maximum benefit from this book you need to complete
the examples in each chapter. At the end of each chapter are suggested exercises so that you can
practice what has been discussed in the chapter. Professors and instructors can obtain the exercise
solutions by requesting them through the authors’ SAS Press webpages at
http://support.sas.com/authors.

We Want to Hear from You

SAS Press books are written by SAS Users for SAS Users. We welcome your participation in
their development and your feedback on SAS Press books that you are using. Please visit
http://support.sas.com/publishing to do the following:

e signup to review a book

e recommend a topic

e request authoring information
e provide feedback on a book

Do you have questions about a SAS Press book that you are reading? Contact the author through
saspress(@sas.com or http://support.sas.com/author_feedback.

SAS has many resources to help you find answers and expand your knowledge. If you need
additional help, see our list of resources: http://support.sas.com/publishing.
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