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    SAS Host Printing Interface Using  XPrinter drivers

The SAS Host Printing Interface under Unix allows you to print text and graphics using an interface
similar to that found in the Microsoft  Windows  environment.   The interface supports functions such
as a File⇒ Print Setup dialog, Print Preview and other features.   Most common printers, such as HP
LaserJet, HP DeskJet and PostScript printers, are supported.

 Online information about host printing is available.  To get online help for the Host Printing Interface in
6.12 do the following:

   1. Select View-->Preferences from the pulldown menu.
   2. Select the Display Manager tab.
   3. Click on the Help button at the bottom of the Display Manager page. This will bring up the
       Helplus window for the Preferences Dialog.
   4. Scroll down in the Help screen until you see the 'Use host printing' selection, and click on the
       Host Printing link (which should be a different color than the rest of the text).
   5. Then click on the 'Using Host Printing' link.

Note: - before you start!
Because printer definitions will be stored in your SASUSER.PROFILE catalog you cannot use profile
catalogs from previous releases of SAS; otherwise disastrous results will occur.   If you have been
running a previous release of SAS, you should rename the profile.sct01 file located in your SASUSER
directory before you start your release 6.12 SAS session the first time.
1.  Activating the XPrinter environment

The XPrinter environment is not available by default when the
SAS system is initialized.  You can activate the XPrinter
environment by selecting View⇒ Preferences.   If you click on
the Display Manager tab located at the top you will see the
screen shown on the left. To activate the XPrinter interface,
click on the Use host printing button.  This will activate the
host printing and the XPrinter interface in SAS until you
disable
it using the same method.   SAS Display Manager will refresh
itself and will have two new items under the File pulldown
(Print Preview and Print Setup).  Print Preview allows you to
view text and graphics on the screen before the output or
graphics is sent to the printer  (similar to a word processor’s
preview mode).



2.  Creating a Host Printer Definition
2.1 Creating a Printer Name
You can create a host printer definition by selecting
File⇒ Print Setup or entering DLGPRTSETUP on any
display manager command box or line.  (Note: If you wish
to create printer definitions for all your users, see section
2.5 before beginning here.) This will bring up a menu
similar to the one shown on the right in panel 1.  You
should select the New button to create a new host printer
definition (Panel 1).  The host printer system will build a list
of printers and then display the menu shown on the in Panel 2.  You can enter the
name you wish to use for your printer.  The printer name is
limited to 99 characters. Click on the Next button to bring
up the menu shown in Panel 3.

2.2 Selecting a Printer
 This selection window has numerous printers available.
 Use the scroll bar on the right side of the window to scroll
 up and down the list of printers that are available.   If your
 printer is not listed, it is very likely that it emulates one of
 the printers on the list.  Many laser printers emulate a
Hewlett
 Packard LaserJet or use PostScript.   If you cannot make
 a determination from the list, contact SAS Institute
 Technical Support for more information.  Once you have
 selected a printer, click on the Next button to go to the
 screen shown below.  Clicking on the Previous button
 takes you to the previous screen.

Panel 1

Panel 2

Panel 3

Printer Selection Window



2.3  Selecting the Output Destination
This window prompts you for the printer destination.
If you select the File button, enter the full path and the
filename where the output from the driver will be sent. If
you select the Printer button, enter the command that sends
output to the printer. If you are using a LaserJet printer in
PCL or HPGL mode, you will probably want to create two
entries, one for text and one for graphics. When you are
printing graphics in PCL or HPGL mode, you may need to
add the -oraw option to your lp or lpr command.  If the -
oraw option is not available on your system, contact SAS
Institute Technical Support for additional information.
PostScript driver entries can be used for text printing or
graphics printing.

2.4 Finishing Up and Generating a Test Page

Select the Next button to see the final screen. Click on the
Finish button to return to the initial menu.  Click on the
Previous button to return to the previous menu.

At this point, select your printer and then select Print Test
Page.  This will generate a sample test page of output to
your printer with a SAS logo and a font list set available
with the host printer driver.  Any messages that are issued
will appear in the  Xwindow that has launched the SAS
process
(not the SAS log).  Sample output is shown on the page
following Section 2.5.  Information on the test page includes
the printer name, the port or file that it is printing to, the
original driver, the resolution of the printer driver,  the fonts
available, paper trays allowed, and paper sizes allowed.
These can be selected with the Properties button which
is described in the next section.   The information that
you have entered for your XPrinter definition is stored in
your SASUSER.PROFILE.PRTINFO.XPRINTER catalog entry.



2.5  Setting Up Printers for All Users at Your Site

If you are a system administrator at your site, you can set up a catalog containing customized printer
entries for all your users by doing the following:

1.  Make sure you have write access to the $SASROOT/sashelp.directory. This often requires root access.
       See your system administrator for more details.
2.    Make sure no one else is using the SAS system.
3.    Check your own SASUSER.PROFILE for an entry named PRTINFO.XPRINTER.  If this entry
       is present, then delete it.
4.  Issue the command DLGPRTSETUP SASHELP.XPRINT.PRTINFO.   This command displays
       the Printer Setup dialog.  You can then add customized printers to the list.
5.  Exit the SAS system.
6.  Printers added by individual users will be stored in their personal

SASUSER.PROFILE.PRTINFO.XPRINTER catalog entries and will be displayed first
       in the File⇒ Print Setup dialog box.





3.  Generating Text Output using the SAS Host Printing Interface
3.1 Setting up your printer for output.
You can generate text output using the Host Printing Interface
by selecting File⇒ Print.   However, it is a good idea to take a
look at the File⇒ Print Setup menu before attempting to print
or even generate output to the output window.   This will allow
you to see what host printer is active, the default font used,  and
the maximum line size and page size settings when that printer
is selected.  When you select File⇒ Print Setup,  you will see a
list of printer definitions that you have created.   Select the
printer that you want to use  by clicking on that printer with
your left mouse button, and  then select Properties.

The Name field contains the name of the
host print definitions you have selected.
The Model field contains the type of
printer driver that you are using to
generate output to the printer.  This may
not match your printer model exactly;
but may instead be the emulation mode
for your printer. The Route Output to
field allows you to route your output to a
file or to a printer destination using your
system’s printing commands.
The Font field contains the default font
that the host printing device will
use to generate output.  The line size and
page size are the default line size and
page size used with this font.

Note: SAS printed output is formatted assuming the use of a monospace font.  Use of a proportionally
spaced font will produce improperly formatted reports.

If you select the Options button, you will see the menu below:

The Options menu allows you to
control the paper size,  orientation
of the output in landscape or portrait, etc.
The Resolution field is listed in dots
per inch (dpi).  Most printers are either
300 or 600 dpi (the higher the dpi, the
sharper the text and graphics).
The Paper Tray field shows the default
tray on your printer from which paper
is selected.   The Scale field
is a zoom value which instructs the
host printer device to change the size

of its output.   If you increase the scale value,  the line size and page size will decrease.   If
you decrease the scale value, the line size and page size will increase.  A scaling factor of 50 % will
print your document at half the original size.  After you have made your changes,
select OK to return to the Properties menu.

Printer Properties Menu



The Margins menu allows you to set the margins for your
printed output.   The arrow controls increase or
decrease the value of the margins by tenths of an inch.
You can also type your own values in each of the boxes.
Increasing the top and bottom margins will decrease
the page size values found on the Properties menu.
Increasing the left and right margins will decrease
the line size values found on the Properties menu.
Clicking on OK will return you to the Properties menu
where you can select the Fonts button to go to the Fonts
Menu.

The Fonts menu allows you to select the default hardware font
used with your output.  The number of fonts and types
available will vary depending on the printer model. The larger
the font size you select, the smaller the line size and page size
will be.   If you are printing output where the columns must be
aligned, you should select a monospace font such as Courier to
print the output. A monospaced font is a font where each
character takes up the same amount of space.  Other fonts,
such as Times, are proportional fonts. A proportional font is a
font where each letter takes up a different amount of space
(for example, the letter I takes up less space than the letter
W).
A proportional font will generally take up less space than a
monospace font of the same size. An example of a monospace
font versus a proportional font is shown below.

The quick brown fox jumps over the dog
The quick brown fox jumps jumps over the dog

The weight option allows you to select whether the output text
will be bold or a lighter weight.  The slant option allows you
to print in italics.     If you select a proportional font, you will
receive the warning message shown below:

After you have set your printer options, you should make sure the LINESIZE and PAGESIZE options
specified in your program are the same or smaller than the line size and page size specified for your
printer.



3.2  Previewing Your Output

After you have set up your printer for output, you can start generating SAS output to your output
window.   After you generate output, you can select File⇒ Print Preview to see how your output will
look before it is sent to the printer.  An example of the Print Preview window is below.

The Page control allows you to view your
pages in order or to select the specific page
that you wish to view.   The Zoom
pulldown allows you to have different
magnifications of the page you are viewing.
The Zoom settings are 100%, 66%, and
33% of the page.  If you select the Show
two pages box, you will see two pages in
the preview screen with a scroll bar to
scroll from the first page to the second
page.   The Close button returns you to the
window from where you selected File
⇒ Print Preview.   The Print... button
activates the print dialog box. This will be
covered in section 3.3,  “Printing Your
Output Interactively”.

The Export... dialog allows you to
generate output to several graphical
formats such as GIF or TIFF.  Generally
you will not use this feature for text.   See
the “Printing Graphics” section for more
details on exporting.



3.3 Printing Text Output Interactively
Once you have viewed your output you will probably want to
print your output.  The Print dialog box allows you to print
your output directly to the device. You can also activate this
menu by selecting File⇒ Print or use the DLGPRT
command from a window. The Print Dialog also allows you to
print individual pages to your printer. The print method box
allows you activate printer forms or not.  If you select Use
Forms, you disable the host printing option and activate
FSFORMS subsystem printing.  The Default Printer is the
current host printer.   If this is not the desired printer, you can
select the Setup... button to activate the Print Setup menu
shown at the top of this section. The Copies dialog box allows
you to specify the number of copies of output that you desire.

The Page range box allows you to specify the pages of the output that you wish to print.  If you select All
pages, all of the information stored in that particular window will print.  The Current Page button will
print the page showing in the Print Preview window. The Pages: dialog allows you to enter the specific
pages that you wish to print.   You can enter multiple page numbers or page ranges (separated by
commas).  Some examples are shown in the table below.   After you select the pages you wish to print,
select the Print button to generate output.

Page Selection Criteria

-5 Print all pages up to page 5
6 Print page 6
9-12 Print pages 9-12
15- Print all pages including page 15 and beyond

If you select the Print to File button and then
the Print button, a dialog box similar to the
one on the left will appear.  This allows you
to enter the name of a file to store the output
instead of directing the output to a printer.



3.4 Printing Text Non-Interactively
While the Host Printing Option can make printing interactively a much more intuitive task, you can also
use this facility to print non-interactively.   You will still need to define your printer definitions first in an
interactive session of SAS in display manager as described in Section 2.   Once the printers are defined
then you can use the PROC PRINTTO procedure to route your output using Host Printing Option.

3.4.1 Setting your default printer

The SAS system checks these sources for the default printer settings (in order of precedence):

• the XPRINTNM system option
• the settings in the SASUSER.PROFILE.PRTINFO.XPRINTER catalog entry (which you can
   set through the DLGPRTSETUP dialog)
• the settings in the SASHELP.XPRINT.PRTINFO.XPRINTER catalog entry (which the system

                 administrator sets up through the DLGPRTSETUP dialog)

The XPRINTNM option allows you to specify the default host printer definition in your program for
example:

OPTIONS XPRINTNM=’HP LaserJet 3SI in R2235’;

Note that the printer definition in your OPTIONS statement must exactly match the printer definition
specified in the File ⇒ Print Setup dialog box, including upper and lower case characters.  If it is
specified incorrectly,  the following message will appear in the log:

WARNING: Unable to find printer ‘printername’ specified in the XPRINTNM option

Note:  If you change the default printer using the File⇒ Print Setup dialog box it will not
be reflected in the XPRINTNM option.   The value can only specify the default definition
for the Print Setup dialog box but cannot read the Print Setup dialog.

3.4.2 Routing your output non-interactively using the PRINTTO procedure

A simple way to route your output non interactively is to use the PRINTTO procedure.  Before using
PROC PRINTTO, you must first use a FILENAME statement to associate a FILEREF with the XPrinter.
For example:

FILENAME fileref  XPRINTER;

where the fileref is the name by which you reference the XPrinter throughout the SAS session.  There
are no options for this statement.

You can then use that fileref in a PROC PRINTTO statement to print the log or procedure output.   The
following example directs any log and procedure output to the default XPrinter:

FILENAME MYXPRT XPRINTER;
PROC PRINTTO LOG=MYXPRT PRINT=MYXPRT; RUN;



IMPORTANT NOTES

• If you are in Display Manager and you redirect any output to an XPrinter, you must
                 close the XPrinter device to print output.  You can do this by submitting another

   PROC PRINTTO without any parameters.

  PROC PRINTTO; RUN;

• You are limited to one open XPrinter device at a time.  You will receive an error
   if you try opening more than one active XPrinter device at a time during a session.

• If no default XPrinter has been selected, the SAS system will use the Generic PostScript driver
   with a Courier font, and Generic PostScript margins will be used to format your
   output to a file called prn in your current working directory.

3.5 Using the PRTFILE command with XPrinter

The PRTFILE command can also be used with a XPrinter device, and is a useful way to switch from
forms based printing to XPrinter printing on the fly.   The syntax for the PRTFILE command, which
specifies where your output is sent to, appears below:

PRTFILE [file-spec] CLEAR | APPEND | REPLACE;

Here  file-spec can be a fileref previously associated with a FILENAME statement or an
external file name.   If an external file name is specified, forms formatted printing will be used.

 In order to use the XPrinter interface, you must use a fileref that has been referenced in a FILENAME
statement pointing to XPRINTER.   To direct your output to the XPrinter, do the following:

• set up a fileref to an XPRINTER device using a FILENAME statement as follows:
   FILENAME fileref  XPRINTER;
• issue the ‘PRTFILE  fileref’ command.
• issue the ‘PRINT’ command; this will start to generate output to the XPrinter.
• each time the PRINT command is executed, the print file will be replaced.
   The APPEND option does not work with XPrinter.
• issue the ‘PRTFILE CLEAR’ command to re-enable forms-based printing.



4.  Printing Graphics using XPrinter Host Printing

4.1 Printing Graphics Interactively
You can print the contents of a GRAPH window by making that window active and selecting
File⇒ Print from the pulldown menu.  By default, the Print Preview and the Print Setup selections
will be grayed out.   To access host printing and activate these selections, select File⇒ Print.  The
following menu will appear:

By default, the SAS/GRAPH Drivers checkbox
will be selected and the Default Printer field
will be grayed out.  If you want to use the
default SAS/GRAPH device drivers, you need to
make sure that your printer destination has been
set inside the device using the GDEVICE
procedure or with appropriate GOPTIONS.  See
Technical Support Note TS246 for more
information.

To activate the Host Drivers XPrinter system, you must check the Use Host Drivers checkbox.  This will
change the menu to appear as shown below.  Once you select the Use Host Drivers checkbox,  the Print
Preview and Print Setup selections will be active in the File⇒ Print pulldown menu.

You can use the XPRINTC driver for
color output,  XPRINTG driver for
gray scale output and the XPRINTM
driver for monochrome output.
Note: Most laser printers can produce
gray scale output (including PostScript
and
HP LaserJet printers).    You can select
the Print button to send your graphics
directly to the device.   When printing
graphics using the XPrinter interface,
you will see notes in the SAS log similar

to the following:

Note: The window system or device has set the XMAX value of the device
      XPRINTG to 7.99 inches.
Note: The window system or device has set the YMAX value of the device
      XPRINTG to 10.61 inches

You can ignore these notes



You can also select the File⇒ Print Preview pulldown to see how the graph will appear before sending it
to the printer.   This is shown in the panel below:

 If you select the Print button, the output will be sent
directly to the device.   The Export button allows you
to export to several file formats.  The export menu is
shown below:

You can export the output to the bitmap
formats shown in the table on the right.
SAS/GRAPH output can also be exported
in CGM format for better control of the
graph after it is exported.  See Technical
Support Note TS-252 for more information.

GIF Graphics Interchange Format
XPM X11 Pixmap
XBM X11 Bitmap
PPM Portable Pixmap
PS Adobe PostScript
EPS Encapsulated PostScript
BMP Microsoft Windows Bitmap
TIF Tagged Image File Format
JPEG Joint Photographic Experts Group



4.2  Using Hardware Fonts with XPrinter

In order to use hardware fonts with the XPRINTC, XPRINTG, and XPRINTM device drivers you must
use the undocumented GETFNT procedure.   There are advantages and disadvantages in using
hardware fonts with the XPrinter system.

Advantages of using Hardware fonts
1.  Smoother looking fonts  in your graphics.
2.  Faster printing response on the printer.
3.  Special characters are available, particularly with PostScript based printers.

Disadvantages of using Hardware fonts
1.  The output can only be viewed on the printer itself, or if the driver is generating PostScript output,

 with a PostScript viewer such as Ghostview or Adobe Distiller.
2.  The hardware font set will change depending on the printer that you have selected in the
        File ⇒ Print Setup window.   Each time you change your printer you must rerun
        the GETFNT procedure to load the correct fonts in the driver.
4.2.1 The GETFNT Procedure
The GETFNT procedure analyzes the driver selected in your FILE⇒ PRINT SETUP pulldown
and loads the appropriate hardware fonts into the XPRINTG, XPRINTC, or XPRINTM graphics
driver entry.   In order to do this, you need to have a separate device driver catalog.  This is created
using the GDEVICE procedure.   Normally a LIBNAME statement with the libref GDEVICE0
is also required to tell the GDEVICE procedure where to create this catalog.  The following program will
load hardware fonts to your new device driver catalog.  You can download this program from
ftp.sas.com/techsup/download/graph/getfnt.sas.

dm 'clear log';
dm 'clear output';
********************************************************;
* Make sure host printing is enabled                   *;
* To do this                                           *;
* 1. select the view pulldown                          *;
* 2. select preferences                                *;
* 3. select the display manager tab                    *;
* 4. click on the "use host printing" button           *;
* 5. click on the driver you wish to use in the        *;
*    file=>print setup pulldown                        *;
********************************************************;
libname gdevice0 'your.device.driver.catalog.directory';
libname gfont0 'your.device.driver.catalog.directory';
goptions reset=global;
********************************************************;
* This step deletes any previous xprintg entry in the  *;
* catalog so we can update the fonts appropriate for   *;
* the new device that has been selected in the         *;
* file=>print setup window.                            *;
********************************************************;

********************************************************;
* In all of these steps you can substitute xprintc or  *;
* xprintm depending on the printer you have selected   *;
* the file=>print setup window.  I would only use      *;
* the xprintm device driver if monochrome output was   *;
* was desired.                                         *;
********************************************************;

proc gdevice c=gdevice0.devices nofs;
delete xprintg;
copy xprintg from=sashelp.devices newname=xprintg;
run;



quit;

********************************************************;
* This step loads the fonts in the chartype screen     *;
********************************************************;
proc getfnt device=xprintg; run; quit;

********************************************************;
* This step generates a listing to the output window   *;
* of the device drivers involved                       *;
* The chartype section will have a listing of the      *;
* fonts and the font number associated with the printer*;
********************************************************;

proc gdevice c=gdevice0.devices nofs;
list xprintg;
run;

*******************************************************;
* Now to generate some output to see how the fonts    *;
* on the printer.  Depending on the device driver     *;
* selected in the FILE=>PRINT SETUP window            *;
* you may have anywhere from 12 to 30 fonts loaded    *;
*******************************************************;

goptions device=xprintg;
proc gslide;
title    f=hwdmx001  H=2 'This  is hwdmx001';
title2   f=hwdmx002  H=2 'This  is hwdmx002';
title3   f=hwdmx003  H=2 'This  is hwdmx003';
title4   f=hwdmx004  H=2 'This  is hwdmx004';
title5   f=hwdmx005  H=2 'This  is hwdmx005';

title6   f=hwdmx006  H=2 'This  is hwdmx006';
title7   f=hwdmx007  H=2 'This  is hwdmx007';
title8   f=hwdmx008  H=2 'This  is hwdmx008';
title9   f=hwdmx009  H=2 'This  is hwdmx009';
title10  f=hwdmx010  H=2 'This  is hwdmx010';
note j=c f=hwdmx011 H=2 'This  is hwdmx011';
note j=c f=hwdmx012 H=2 'This  is hwdmx012';
note j=c f=hwdmx013 H=2 'This  is hwdmx013';
note j=c f=hwdmx014 H=2 'This  is hwdmx014';
note j=c f=hwdmx015 H=2 'This  is hwdmx015';
note j=c f=hwdmx016 H=2 'This  is hwdmx016';
note j=c f=hwdmx017 H=2 'This  is hwdmx017';
note j=c f=hwdmx018 H=2 'This  is hwdmx018';
note j=c f=hwdmx019 H=2 'This  is hwdmx019';
note j=c f=hwdmx020 H=2 'This  is hwdmx020';
footnote1  j=c f=hwdmx021 H=2 'This is hwdmx021';
footnote2  j=c f=hwdmx022 H=2 'This is hwdmx022';
footnote3  j=c f=hwdmx023 H=2 'This is hwdmx023';
footnote4  j=c f=hwdmx024 H=2 'This is hwdmx024';
footnote5  j=c f=hwdmx025 H=2 'This is hwdmx025';
footnote6  j=c f=hwdmx026 H=2 'This is hwdmx026';
footnote7  j=c f=hwdmx027 H=2 'This is hwdmx027';
footnote8  j=c f=hwdmx028 H=2 'This is hwdmx028';
footnote9  j=c f=hwdmx029 H=2 'This is hwdmx029';
footnote10 j=c f=hwdmx030 H=2 'This is hwdmx030';
run;
quit;

4.2.2 Results in the SAS Log and Output Windows from Running the Program



Several messages from the log and information in the output window are useful when using SAS/GRAPH
with the XPrinter drivers.  The output window contents should be saved for later reference.
The SAS Log will often contain the message described below:

WARNING: A character was defined in the character position normally
         reserved for a blank.
NOTE: Font HWDMX001 will use 4935 bytes of memory when loaded.

This means that the font name that was loaded had a space in the middle of its description.  It will
not affect the performance of the driver in any way.

In the output window, you will see a listing with a title similar to the following:

                             GDEVICE procedure
               Listing from GDEVICE0.DEVICES - Entry XPRINTG

This listing is the contents of the new XPrinter device driver catalog entry that you have created.
The most important section of the listing is the CHARTYPE section similar to the listing below:

CHARTYPE RECORDS

    Chartype Rows  Cols                  Font Name                 Scalable
       0      1     1   DMS Font                                     N
       1      1     1   -adobe-courier-medium-r-normal--0-0-300*     Y
       2      1     1   -adobe-courier-medium-o-normal--0-0-300*     Y
       3      1     1   -adobe-courier-bold-r-normal--0-0-300-3*     Y
       4      1     1   -adobe-courier-bold-o-normal--0-0-300-3*     Y
       5      1     1   -adobe-times-medium-r-normal--0-0-300-3*     Y
       6      1     1   -adobe-times-medium-i-normal--0-0-300-3*     Y
       7      1     1   -adobe-times-bold-r-normal--0-0-300-300*     Y
       8      1     1   -adobe-times-bold-i-normal--0-0-300-300*     Y
       9      1     1   -adobe-avant garde-medium-r-normal--0-0*     Y
      10      1     1   -adobe-avant garde-medium-o-normal--0-0*     Y
      11      1     1   -adobe-avant garde-bold-r-normal--0-0-3*     Y
      12      1     1   -adobe-avant garde-bold-o-normal--0-0-3*     Y
      13      1     1   -adobe-bookman light-medium-r-normal--0*     Y
      14      1     1   -adobe-bookman light-demibold-r-normal-*     Y
      15      1     1   -adobe-bookman light-demibold-i-normal-*     Y
      16      1     1   -adobe-helvetica-medium-r-normal--0-0-3*     Y
      17      1     1   -adobe-helvetica-medium-o-normal--0-0-3*     Y
      18      1     1   -adobe-helvetica-bold-r-normal--0-0-300*     Y
      19      1     1   -adobe-helvetica-bold-o-normal--0-0-300*     Y
      20      1     1   -adobe-new century schoolbook-medium-r-*     Y
      21      1     1   -adobe-new century schoolbook-medium-i-*     Y
      22      1     1   -adobe-new century schoolbook-bold-r-no*     Y
      23      1     1   -adobe-new century schoolbook-bold-i-no*     Y
      24      1     1   -adobe-palatino-medium-r-normal--0-0-30*     Y
      25      1     1   -adobe-palatino-medium-i-normal--0-0-30*     Y
      26      1     1   -adobe-palatino-bold-r-normal--0-0-300-*     Y
      27      1     1   -adobe-palatino-bold-i-normal--0-0-300-*     Y
      28      1     1   -adobe-symbol-medium-r-normal--0-0-300-*     Y
      29      1     1   -adobe-zapf chancery-medium-i-normal--0*     Y
      30      1     1   -adobe-zapf dingbats-medium-r-normal--0*     Y

This is the listing of the hardware character sets available for the device driver selected
in your File⇒ Print Setup window.  This listing can change depending on the
device driver selected.  The listing above is for a PostScript printer.

The following listing is for a  HP LaserJet 3 printer.

   Chartype Rows  Cols                  Font Name                 Scalable
       0      1     1   DMS Font                                     N
       1      1     1   -adobe-times-medium-r-normal--0-0-300-3*     Y
       2      1     1   -adobe-times-medium-i-normal--0-0-300-3*     Y
       3      1     1   -adobe-times-bold-r-normal--0-0-300-300*     Y



       4      1     1   -adobe-times-bold-i-normal--0-0-300-300*     Y
       5      1     1   -agfa-cg times-medium-r-normal--0-0-300*     Y
       6      1     1   -agfa-cg times-medium-i-normal--0-0-300*     Y
       7      1     1   -agfa-cg times-bold-r-normal--0-0-300-3*     Y
       8      1     1   -agfa-cg times-bold-i-normal--0-0-300-3*     Y
       9      1     1   -agfa-univers-medium-r-normal--0-0-300-*     Y
      10      1     1   -agfa-univers-medium-i-normal--0-0-300-*     Y
      11      1     1   -agfa-univers-bold-r-normal--0-0-300-30*     Y
      12      1     1   -agfa-univers-bold-i-normal--0-0-300-30*     Y

While you can always look up your character sets using the GDEVICE procedure, keeping
a printout of this section is often easier to use.    You can use any of the hardware
fonts in your SAS/GRAPH output by specifying F=HWDMXzzz in your program where zzz
is the chartype number. For example, if you want to use the -adobe-zapf chancery-medium-i-normal—0
font with a PostScript driver, specify F=HWDMX029 in your program.

4.2.3 Output from the GSLIDE program
The output from the GSLIDE program in section 4.3.1  will generate a listing of the hardware fonts to
your printer so you can see how the fonts will appear when printed.   Sample output from a PostScript
driver is listed below.   Note that the output here is not nearly as sharp as the actual printed output will
look.



5. Questions and Answers

5.1 Can hardware fonts be used with the XPrinter drivers?

       The GETFNT procedure loads fonts into the XPrinter drivers.  See section 4 for information.



5.2 Can I control sizing of the graphics output?

       Yes,  the  HSIZE and VSIZE graphics options work with the XPRINT drivers.

5.3 Can I do page selections non-interactively?

       Not yet, but this has been suggested for a future release of the SAS system.

5.4 Can I change the file destination that an XPrinter device writes to dynamically?

       No, you would have to create several XPrinter device drivers  (each of which
       would write to a different file).  You can switch from printer to printer using
       the XPRINTNM option.

5.5 Can you duplicate drivers in the Print Setup Menu?

       Not currently, but a duplicate button has been suggested and hopefully will be implemented
       for a future release of the SAS system.

6.  Common Problems and Solutions with XPrinter

To get complete information on problems with XPrinter, you can search  the SAS Institute Technical
Support usage note database at the following site:

 http://www.sas.com/service/techsup/find_answer.html.

The following is a listing of the more common messages you may receive when using the XPrinter
interface:

6.1  Invalid messages when selecting certain fonts.    

You may receive the following message when selecting the adobe-courier, agfa-courier,
or agfa-letter gothic fonts:

"You have chosen a proportional font.  Proportional fonts can cause unpredictable results and can lead to
column misalignment in the printed output.  Select a mono-spaced font such as Courier to remedy this
problem."

Since those fonts are all monospaced, you can ignore the warning message that is being issued.  Your SAS
output will not be misaligned as the warning implies.

 6.2 Printing from Helplus fails when printing to Non-PostScript devices

 When printing help topics from Helplus, you will only be able to successfully get output only when
printing to a PostScript device. Currently, if you choose a PCL device (such as the generic PCL5 or any of
the HP PCL cartridge printers), you will not receive an error when you attempt to print, but your output
will not print.



6.3  Output from PROC TABULATE and PROC FREQ does not have solid lines:

When using host printing (Xprinter) to print Procedure output, you will be unable to obtain solid lines on
your output. This is because the third party package used for host printing uses a symbol set that does not
contain solid line characters.

The only way to get solid lines on your output at this time is to go back to using forms for printing. If your
printer does not use the correct symbol set by default, you can add the following section to the Printer
Control Language page of your form:

PRINT INIT
~(10U
PRINT TERM
~E

In order to switch from host printing to forms, select View⇒ Preferences...then click on the
Display Manager tab and deselect the Host Printing option.

6.4  ERROR: Segmentation Violation captured in task 'PROGRAM' with Xprinter on AIX Platforms

When using host printing on AIX, you may intermittently get segmentation violations. A typical scenario
that demonstrates this problem is when you turn on host printing and issue the DLGPRTSETUP
command or attempt to access the ‘File ⇒ Print Setup’ dialog. The error you may receive is:

ERROR:  Segmentation Violation captured in task 'PROGRAM'

To correct this problem, terminate your current SAS session and set the environment variable XPHOME
to $SASROOT/X11 (where $SASROOT is the directory where you have SAS installed). An example of
the syntax would be:

for bsh and ksh:   export XPHOME=/usr/local/sas612/X11
for csh:  setenv XPHOME /usr/local/sas612/X11

Once you have the environment variable set, reinvoke SAS.  Host printing will then work correctly.


