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ABSTRACT  

Whether you manage computer systems in a small-to-medium environment (for example, in labs, 
workshops, or corporate training groups) or in a large-scale deployment, the ability to automate SAS® 9.4 
installations is important to the efficiency and success of your software deployments. For large-scale 
deployments, you can automate the installation process by using third-party provisioning software such 
as Microsoft System Center Configuration Manager (SCCM) or Symantec Altiris. But what if you have a 
small-to-medium environment and you do not have provisioning software to package deployment jobs? 

No worries! There is a solution. This paper presents a case study of just such a situation where a process 
was developed for SAS regional users groups (RUGs). Along with the case study, the paper offers a 
process for automating SAS 9.4 installations in workshop, lab, and corporate training (small-to-medium 
sized) environments. This process incorporates the new –srwonly option with the SAS® Deployment 
Wizard, deployment-wizard commands that use response files, and batch-file implementation. This 
combination results in easy automation of an installation, even without provisioning software. 

INTRODUCTION  

This paper shows you how to develop an automated installation for SAS® 9.4 without using provisioning 
software. Through a series of steps that include light preparation, you can accomplish a working, effective 
SAS® installation. You can use the techniques in this paper in a variety of settings from lab environments 
to training and workshop environments. 

This paper provides methods, techniques, and steps that enable you to perform an automated SAS 9.4 
deployment without using provisioning software. You do not need advanced IT skills to take advantage of 
this process. The techniques that are discussed can be used by anyone with basic-to-intermediate IT 
skills. After reading this paper, you should understand how to automate a SAS 9.4 installation and gain 
the time-savings benefit of using an uncomplicated, quiet deployment. 

PREREQUISITES 

HARDWARE  

The following hardware specifications are required in order to use the techniques that are discussed in 
this paper. 

 System processor: Processors that are either Intel 64 or that are compatible with Intel 64 that 
have a minimum of four cores. 

 Random-access memory (RAM): - 8 GB of RAM. 

 Swap space: Swap space (or paging space) should be 1.5 times the amount of physical RAM. 

 Monitor: For a monitor, the case study used a minimum standard of SVGA or better. 

Note: Be sure to observe these hardware requirements in order to obtain the expected results. 
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SOFTWARE 

The software requirements that are used in the RUG case study include the following SAS® software 
products: 

 Base SAS® software 

 SAS® BI Server 

 SAS® Enterprise Guide 

 SAS/ACCESS® Interface to PC Files 

 SAS/STAT® software 

These software products are detailed in the sections that follow. 

Note: Be sure to observe these software requirements in order to obtain the expected results. 

FILENAME CONVENTION 

At the time of this writing, SAS® 9.4 requires the 8.3 filename convention (also known as the short-name 
convention) as a system requirement.  If the short-name convention is not present (that is, only the long-
name convention is available), problems can occur in later use of the software. Both short-name and 
long-name conventions are used in the case-study. 

Note: The 8.3 filename convention might be phased out in a future SAS® release. 

ANTI-VIRUS SOFTWARE  

SAS Technical Support recommends that you stop you anti-virus software and any related services 
during installation time. If you do not stop your anti-virus software during the installation, problems can 
occur that might prevent a successful installation. You can restart the antivirus software after the 
installation is complete. Antivirus software and its services are stopped during installation time on the 
case study machines. 

USER ACCOUNT CONTROL  

SAS Technical Support recommends that you disable user account control (UAC) during the installation 
time. You can restart UAC after the installation is complete. UAC is disabled during installation in the case 
study. 

OPERATING SYSTEM 

The case study uses the Windows 7 x64 operating environment.  In particular, all RUG environment 
machines are under Windows 7 Enterprise x64 with Service Pack 1. 

MICROSOFT OFFICE  

The RUG environment requires either 64-bit Microsoft Office 2010 or 64-bit Microsoft Office 2013. 

SAS® SYSTEM REQUIREMENTS 

There are particular system software requisites that must be present on a machine in order for SAS 
software to function properly. The specific requirements for SAS can vary from machine to machine, and 
they also depend on the particular product mix of SAS software that you install. In the case study, all 
machines are in the same operating environment. Therefore, the SAS system requirements are the same 
for each machine. If the SAS System requirements are not present, functionality problems will occur in the 
resulting installation. 
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SAS® 9.4 -SRWONLY COMMAND-LINE OPTION 

The first maintenance release for SAS 9.4 (TS1M1), Rev. 940_14w11 introduced a new command-line 
option, -srwonly, which enables you to install only the SAS system requirements or to create a batch 
(BAT) file for later use. The basic -srwonly command is as follows: 

setup.exe –srwonly 

The BAT file that is created installs the system requirements for the installation, based on the SAS 
software that you select. After you create the BAT file, a portion of it is used later to modify and construct 
another BAT file that executes the full installation. 

For detailed instructions about using the -srwonly command, see the section "Checking System 
Requirements (Windows only)" in "Chapter 3 – SAS Deployment Wizard: Command Line Options" of the 
SAS® Deployment Wizard and SAS® Deployment Manager 9.4: User's Guide. 
(support.sas.com/documentation/installcenter/en/ikdeploywizug/66034/PDF/de
fault/user.pdf) 

CERTIFIED ENVIRONMENT FOR THE CASE STUDY 

The certified environment for the case study includes the following: 

 Windows 7 Enterprise x64, Service Pack 1

 Microsoft Office 2013, 64-bit

 Internet Explorer 9, 32-bit

 SAS 9.4 TS1M1, Rev. 940_14w14

For this particular case, this environment was required. Without these specific components, functionality 
is not guaranteed based on the process described in this paper. 

PREPARING FOR THE SAS® INSTALLATION 

The ultimate goal for the case study was the successful automation of the SAS installation on RUG 
conference machines. As mentioned earlier, this same process can be used for machine setups in small-
to-medium sized lab, training, or workshop environments. 

For this particular project, the author created multiple files that automate many of the 
steps in the process.  All of the associated files (BAT, TXT, and DOCX) were placed in 
a folder named RUG. This folder was then converted to a ZIP file named RUG.zip.  

 The RUG.zip file and a set of instructions were provided to the installers responsible for setting up the  
RUG machines.  

The instructions provided the following general steps for setting up a SAS 9.4 installation for a hands-on 
conference workshop: 

1. Download the RUG.zip file from
ftp://ftp.sas.com/techsup/download/blind/RUG.zip.

2. Extract the ZIP file to C:\, which results in a C:\Rug folder.

3. Review the READMEFIRST.txt file and then continue.

Note: If you want to run your own setup process, you can follow these same instructions and access the 
RUG.zip file from the FTP link above. 

ftp://ftp.sas.com/techsup/download/blind/RUG.zip
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The C:\RUG folder provides easy-to-use files (all in one location) that handle a lot of the manual work, 
without human interaction, for a quiet installation on multiple machines. The C:\RUG folder contains the 
following files, which are referenced later in this paper: 

 createsasaccount.bat

 doit.bat

 installdotnet.bat

 installsas - Copy.txt

 installsas.txt

 plan.xml

 READMEFIRST.txt

 resetsasaccounts01.bat

 resetsasaccounts02.bat

 RUG Instructions for Setting Up Workshop Machines.docx

 undoit.bat

 uninstallsas.txt

 Using Workshop Machines at RUG Conferences.docx

The steps in the process that follows were derived to work for multiple RUG events since each event uses 
its own set of hands-on workshop machines. With this mind, it is necessary for one of the steps (step 2 in 
the section "Step 2: SAS Software Installation") to require additional preparation work because each 
respective RUG event owns an individual SAS 9.4 software order and license. Because you might do 
work specifically for a single event or lab environment (rather than multiple events or environments), there 
is one step that you can modify to facilitate less preparation work. This step will be pointed out later in the 
paper. 

STEP 1: SETTING UP PREDEPLOYMENT COMPONENTS 

The following steps help you to set up required accounts, a SAS Software Depot, and the Microsoft .NET 
Framework that are required for SAS software installation.  

Note: The steps in this section might be accomplished by your own install team or by a third-party vendor, 
depending on your particular situation. As such, vendor-related notes are made throughout the section 
where they are applicable. 

1. Create a local account called sas and add it to the Administrators group, as follows:

a. Run the createsasaccount.bat (located in C:\RUG), as follows:

1. Log on to your Windows environment with an administrative account.

2. Right-click the createsaccount.bat file in C:\RUG and select Run as
administrator.

b. Log off. Then log on again with the sas account. The password for the account is
Password1.

You should perform all of the remaining steps with the local sas account. 

Note: All local accounts that are created use the same password: Password1. 

(list continued) 
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2. Create a SAS Software Depot, as follows:

a. Download the SAS® Download Manager from support.sas.com/downloadmgr.
You need a SAS web profile (logon profile) to access and use the SAS Download
Manager. If you do not have a web profile, create one from the form that is presented.

b. After you log on, select either of the Microsoft Windows SAS Download Managers
(Windows or Windows for x64).

c. Run SAS Download Manager to begin downloading the order. You can run the
executable file directly from the web site. Or you can save the executable file to your
machine and then run it.

1. When you are prompted by the download manager, enter the order number and
SAS installation key that you have been provided with in your Software Order E-
mail (SOE)

2. Then click OK to begin the download.

Note: The download process can take more than an hour. So be patient, and let the process 
finish. Download the complete order. Do not subset anything in the order during the download. 

3. Copy the plan file (C:\RUG\plan.xml) to an appropriate location (for example, C:\SAS
Software Depot\plan_files).

A plan file was created by SAS for the particular SAS product mix for the RUG 
event in this case study. A plan file is not always necessary. However, the RUG 
environment installation in the case study was enhanced by the use of a plan 
file. 

4. Copy your software depot to other machines, as necessary. For multiple machines, you can copy
the C:\SAS Software Depot directory to other workshop machines so that you do not have to
repeat the actual downloading process on each machine.

Note: The RUG workshop environments do not typically have internet connections. As a result, a
SAS Software Depot must reside on each machine. However, if your environment has a network
drive on which to house the depot, then each machine does not require a local depot.

Whether you download the initial depot to a network drive, a local computer, or a portable USB
flash drive, you should use the SAS Deployment Wizard native tooling, as explained in the
following steps, to copy or duplicate the depot to other machines. Do not use either the copy-and-
paste or drag-and-drop methods.

a. Execute the setup.exe file that resides in the C:\SAS Software Depot\ directory.
This command opens the Select Deployment Task page in the wizard.

b. On the Select Deployment Task page, select the option Create or Add to a SAS
Software Depot to duplicate a SAS Software Depot.

This method of duplication is less time consuming than downloading the depot again. 

Important Notes:  

 Each machine should have a local C:\SAS Software Depot folder, which contains the
plan.xml file in the plan_files subfolder.

(list continued) 

http://support.sas.com/downloadmgr
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 Each machine should have a local C:\RUG folder.

 If you have the plan.xml file in the plan_files folder of the original depot, the plan.xml
file is not carried over in the duplication process. Therefore, you must copy
C:\RUG\plan.xml to the C:\SAS Software Depot\plan_files directory.

Vendor Note: Read this note only if you use imaging software where you create a master 
Microsoft Windows image that is then propagated to multiple machines. You can save depot-
creation time by including the C:\SAS Software Depot folder (which contains the plan.xml file 
in the plan_files subfolder) and also the C:\RUG folder in the master image. The 
Installing SAS Software section of the wizard must be performed on each machine, not on 
the master image. 

5. Install the Microsoft .NET Framework by right-clicking C:\RUG\installdotnet.bat and
selecting Run as administrator. This step ensures that both Microsoft .NET Framework 3.5
Service Pack 1 and Microsoft .NET Framework 4.0 are installed. Run this step even if you think
both are already installed. Be aware that the .NET Framework installation can take a while to
complete. When this step is finished, reboot the machine.

Vendor Note: Read this note only if you use imaging software where you create a master
Microsoft Windows image that is then propagated to multiple machines. You should include the
Microsoft .NET Framework installation in the master image. The Installing SAS Software
section of the wizard must be performed on each machine, not on the master image.

STEP 2: INSTALLING SAS® SOFTWARE  

The steps in this section install your SAS software. Perform all of the remaining steps using the local sas 

account. As mentioned earlier, all local accounts that are created have the same password: Password1. 

1. Prepare the installsas.txt file by ensuring that the value for the computername parameter is
correct.

For the case study, the –record option was used to create a prerecorded 
response file, installsas.txt, that was provided to the Regional User Group. 
Details about the –record option are available in "Chapter 3—SAS 
Deployment Wizard: Command-Line Options" of the SAS® Deployment Wizard 

and SAS® Deployment Manager 9.4: User's Guide.  

Preparing the installsas.txt file with the correct computer name entries is necessary in order to set 
up the external accounts properly for installation and use. The external accounts are created later 
in another step. 

Note: Because each machine has a unique computer name, you must perform steps a – f below 
for each individual machine.  

In the installsas.txt file, locate and replace computername with the actual computer name, as 
follows: 

1. Open C:\RUG\installsas.txt in the Windows Notepad application.

2. Select Edit ► Replace to open the Replace dialog box.

3. In the Find what text box, enter the term computername.

(list continued) 
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4. In the Replace with text box, enter the short computer name. This value is the actual
computer short name. For example, if the long name is trc124.trc.sas.com, then the short
name is trc124.

5. Click Replace All and exit the Replace dialog box.

6. Select File ► Save.  Then select File ► Exit. This final step modifies the information for
external accounts: the SAS installer account, the SAS Spawned Servers account, and
the First User account.

2. Ensure that the value for the SAS_INSTALLATION_DATA= parameter is correct.

The SAS Installation Data (SID) file, often referred to as the license file, must be correct. You
need to replace a file named licensefile.txt (from the RUG.zip file) with the appropriate SID
filename, as follows:

a. Re-open installsas.txt in Notepad.

b. Select Edit ► Replace to open the Replace dialog box.

c. In the Find what text box, enter licensefile.txt.

d. In the Replace with text box, enter the actual license filename (for example,
SAS94_999999_99999999_Win_X64_Wrkstn_Srv.txt) that appears in the
sid_files folder of your SAS Software Depot.

e. Click Replace All and exit the Replace dialog box.

f. Select File ► Save.  Then select File ► Exit.

Note: This entire step (step 2) is the step mentioned earlier (in the section Preparing for the 
SAS® Installation) as a step that must be done at least once and that can reduce the 
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preparatory work for your own homogeneous environment. After you include the correct 
license file in the installsas.txt file, you can use that same license file on subsequent 
machines for which you have correctly modified the computer name in installsas.txt. 

3. Verify the changes you made to the installsas.txt file.

Open installsas.txt with Notepad one final time to verify that there is no instance of
computername or of the filename licensefile.txt. It is important to make sure these
modifications are correct. Once you verify the file, close installsas.txt.

Important: As noted previously, you only have to perform the licensing modification once.
Then you can use that modified file for all of your machines. However, the step for updating
the computer name has to be performed on each individual machine because the name is
different for each machine.

4. Deploy the installation by right-clicking the doit.bat file and selecting Run as administrator to
execute the file.

Important: Do not close the CMD window of the BAT file. It closes automatically and the silent-
status dialog box appears. The installation is complete when the silent-status dialog box
disappears.

A brief pause occurs before the installation begins. Then a silent-status dialog box appears. The
silent-status display below shows a process of 206 steps. Your installation might have more steps
or fewer steps than the example. The process can contain as many as 200+ steps during the
installation, so be patient and let the installation complete.

 In the case study, a pre-built BAT file named doit.bat was provided to the RUG 
 group. This BAT file comprises four main functions: 

 The doit.bat file creates necessary users and groups that are required for the
installation process. The users and groups are created by the following code module: 

echo on 

net user sasdemo Password1 /add /expires:never /passwordchg:no 
/fullname:"SAS Demo User" /comment:"pw=Password1"  

net user sassrv Password1 /add /expires:never /passwordchg:no 
/fullname:"SAS Spawned Servers" 
/comment:"pw=Password1"  

net localgroup "SAS Server Users" /add 

net localgroup "SAS Server Users" sasdemo /add 

net localgroup "SAS Server Users" sassrv /add 

(list continued) 
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 The doit.bat file installs system requirements. This function of the BAT file is derived by using the
–srwonly option that is mentioned previously in the section SAS® 9.4 -srwonly Command-
Line Option.

Note: The Microsoft .Net Framework installation command is omitted in the following commands
because it was performed in a previous step.

:: 
set DEPOT_HOME=C:\SAS Software Depot\products 
:: 
:: ------------------------------------------------------ 
:: Microsoft Office Access Database Engine 2010 (REQUIRED) 
"%DEPOT_HOME%\ace__99120__prt__xx__sp0__1\w32\native\AccessDatabaseEngine.exe" 
/quiet 
"%DEPOT_HOME%\ace__99120__prt__xx__sp0__1\wx6\native\AccessDatabaseEngine_X64.exe
" /quiet 
:: ---------------------------------------------------------- 
:: Microsoft Runtime Components 8.0 Service Pack 1 (REQUIRED) 
"%DEPOT_HOME%\vcredist8__99110__prt__xx__sp0__1\w32\native\vcredist_x86.exe" /q:a 
/c:"msiexec /i vcredist.msi /qn" 
"%DEPOT_HOME%\vcredist8__99110__prt__xx__sp0__1\wx6\native\vcredist_x64.exe" /q:a 
/c:"msiexec /i vcredist.msi /qn" 
:: ---------------------------------------------------------- 
:: Microsoft Runtime Components 9.0 Service Pack 1 (REQUIRED) 
"%DEPOT_HOME%\vcredist9__99110__prt__xx__sp0__1\w32\native\vcredist_x86.exe" /q 
"%DEPOT_HOME%\vcredist9__99110__prt__xx__sp0__1\wx6\native\vcredist_x64.exe" /q 
:: ---------------------------------------------------------- 
:: Microsoft Runtime Components 10 (REQUIRED) 
"%DEPOT_HOME%\vcredist10__99110__prt__xx__sp0__1\w32\native\vcredist_x86.exe" /q 
/norestart 
"%DEPOT_HOME%\vcredist10__99110__prt__xx__sp0__1\wx6\native\vcredist_x64.exe" /q 
/norestart 
:: ---------------------------------------------------------- 
:: Microsoft Runtime Components 2013 (REQUIRED) 
"%DEPOT_HOME%\vcredist2013__99110__prt__xx__sp0__1\w32\native\vcredist_x86.exe" 
/q /norestart 
"%DEPOT_HOME%\vcredist2013__99110__prt__xx__sp0__1\wx6\native\vcredist_x64.exe" 
/q /norestart 
:: ---------------------------------------------------------- 
:: Microsoft Visual Studio Tools for Office 10.0 (REQUIRED) 
"%DEPOT_HOME%\vsto10__99110__prt__xx__sp0__1\wx6\native\vstor40_x64.exe" /q 
:: ---------------------------------------------------------- 

 The BAT file checks and removes potential registry entries (if they exist) that can cause a reboot
during installation. The following code segment accomplishes this task:

rem CurrentControlSet 

reg delete "HKLM\SYSTEM\CurrentControlSet\Control\Session 
Manager" /v PendingFileRenameOperations /f 

(code continued) 
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rem CurrentControlSet 

reg delete "HKLM\SYSTEM\CurrentControlSet\Control\Session 
Manager\FileRenameOperations" /f 

cls  

 
 The doit.bat file quietly deploys the installation with silent status. The following code 

segment accomplishes this task: 

rem Install SAS 9.4 quietly with silent status 

@echo off 

echo Installing SAS!  

"C:\SAS Software Depot\setup.exe" -quiet -nomsupdate        
-silentstatus -responsefile c:\rug\installsas.txt 

In this code, the –nomsupdate option prevents the system-requirements check. The 
system requirements are already installed, so there is no need to run the check again. 

STEP 3: VERIFYING ACCESS TO CLIENT APPLICATIONS 

The silent-status dialog disappears when the installation steps are completed. Open the following client 
applications to ensure that you can perform the steps that are listed for each one. This verification is 
necessary to ensure that you have a working installation. 

1. Invoke SAS® Enterprise Guide® and sign in, as follows: 

a. Select Start ► All Programs ► SAS ► SAS Enterprise Guide 6.1 (64-bit). 

b. When you are prompted, enter the following credentials: 

 User ID: sasdemo 

 Password: Password1 

Note: All local accounts that you create use this same password. 

 

(list continued) 
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c. Click OK. A Welcome display appears, and you should close that display. 

Invoking SAS Enterprise Guide 6.1 and logging on with the user ID sasdemo creates a 
connection-configuration file for the sasdemo account. 

d. After SAS Enterprise Guide 6.1 opens and you are connected to the My Server 
connection profile, open the Server List dialog box and select Servers ►SASApp. When 
the connection is made, you should see a green check mark next to SASApp, as shown 
below. 

 

e. Close SAS Enterprise Guide 6.1. 

2. Invoke Microsoft Excel, as follows, to verify that the SAS tab and ribbon are present. 

a. Select Start ► All Programs ► Microsoft Office <version> ► Excel version-number. 
You should see the SAS tab and ribbon, as shown below. 

 

b. Close Excel. 

Note: As mentioned previously, using the sasdemo account in SAS Enterprise Guide 6.1 sets up 
a connection profile. This same connection file is used by the SAS® Add-In 6.1 for Microsoft 
Office when you open Excel. 

(list continued) 

 

 



12 

3. Invoke SAS® Studio and verify that the software is working by submitting a PRINT procedure, as
follows:

a. Select Start ► All Programs ► SAS ► SAS Studio 3.2 (64-bit).

b. Submit the following PRINT procedure from the CODE tab in the program window (in the
right pane of SAS Studio), as shown below:

This PRINT procedure results in the following output: 

c. Exit SAS Studio by clicking the Sign Out button.

4. Invoke SAS 9.4.

a. Select Start ► All Programs ► SAS ► SAS 9.4 (English). When SAS opens, you
should see the Enhanced Editor (labeled Editor – Untitled1), as shown below:

b. Close SAS 9.4.

If you can open the applications that are discussed in the previous steps, the installation is ready to use. 
End users should continue to use the local sas account and password (Password1) that are already set 
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up. In the C:\RUG directory, you will find a Word document to assist end users in getting started with 
using the workshop machines. The Word document is named Using Workshop Machines at RUG 
Conferences.doc. 

STEP 4: REMOVING SAS® SOFTWARE (IF NECESSARY) 

You might find it necessary to remove SAS software from your machines. For example, the machines in 
your environment might need to be used for another purpose, or you might need to remove the software if 
the machines belong to a third-party vendor. 

To remove the SAS installation, follow these steps:  

1. Log on to your Windows environment using the local sas account. 

2. Right-click the undoit.bat file in C:\RUG and select Run as administrator to remove the 
software. 

Warning: Running the undoit.bat file uninstalls SAS services, the SAS installation, the SAS 
Software Depot\sid_files directory, and any leftover installation directories. As a result, 
the SAS Software Depot is rendered unusable. Therefore, do not follow these steps unless 
you are absolutely sure that you want to remove these items from your machine. 

In the case study, a pre-built BAT file called undoit.bat was provided to the RUG 
group. This file was customized to function for the case study environment. For 
details about using the SAS Deployment Manager to record and playback an 
uninstall file, see "Chapter 7—SAS Deployment Manager: Command Line 

Options" in the SAS® Deployment Wizard and SAS® Deployment Manager 9.4: User's Guide. 
(support.sas.com/documentation/installcenter/en/ikdeploywizug 
/66034/PDF/default/user.pdf)   

 Although it was not used in the case study, you can use the –uninstallall option   
to remove your software without creating a response file. The –uninstallall option, 

new in SAS 9.4, is explained in the section "Uninstall All Products" in "Chapter 7—SAS 
Deployment Manager: Command Line Options" of the SAS® Deployment Wizard and SAS® 
Deployment Manager 9.4: User's Guide.  

Similar to the doit.bat file, undoit.bat comprises four main functions:   

 The undoit.bat file removes SAS services with the following code module:  
 

echo on 

rem This step stops and deletes SAS Services. 

rem pause 

sc stop "SAS [Config-Lev1] Object Spawner" 

timeout /t 5 /nobreak 

sc delete "SAS [Config-Lev1] Object Spawner" 

timeout /t 5 /nobreak 

(code continued) 

 

http://support.sas.com/documentation/installcenter/en/ikdeploywizug/66034/PDF/default/user.pdf
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sc stop "SAS [Config-Lev1] SASMeta - Metadata Server" 

timeout /t 5 /nobreak 

 

sc delete "SAS [Config-Lev1] SASMeta - Metadata Server" 

rem Kill the sasstudio process, if it exists. 

taskkill /IM SASStudioHost.exe /F 

timeout /t 2 /nobreak 

 
 The undoit.bat file removes SAS with the following command: 

 
rem This step removes SAS.DO NOT CLOSE THIS               

CMD WINDOW!  
 

"C:\Program Files\SASHome\SASDeploymentManager 

\9.4\sasdm.exe" -quiet –responsefile 

c:\rug\uninstallsas.txt -silentstatus 

 The undoit.bat file removes leftover folders that you no longer need with the following 
commands: 

rem The next step removes leftover directories for the   
SAS configuration, installation, Add/Remove entry, and  
the SAS Software Depot\sid_files directory.  

rem Be aware that if you proceed, the SAS Software Depot 
will be rendered unusable! 

pause 

rem Clean Up 

rd "C:\SAS\" /s /q 

rd "C:\Program Files\SASHome" /s /q 

rd "C:\ProgramData\SAS" /s /q 

rd "C:\ProgramData\Microsoft\Windows\Start 
Menu\Programs\SAS\Configuration" /s /q 

rd "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\SAS"  
/s /q 

(code continued) 
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:: 

rem Appdata Area - sas account 

rd "C:\users\sas\documents\my sas files\" /s /q 

rd "C:\users\sas\appdata\local\sas" /s /q 

rd "C:\Users\sas\appData\local\temp\SAS Temporary Files" /s /q 

rd "C:\users\sas\appdata\roaming\sas" /s /q 

:: 

rem SAS Studio files - sas account 

rd "C:\users\sas\.images" /s /q 

rd "C:\users\sas\.mysnippets" /s /q 

rd "C:\users\sas\.mytasks" /s /q 

rd "C:\users\sas\.sasstudiohost_3.2" /s /q 

rd "C:\users\sas\.webwork" /s /q 

rd "C:\users\sas\.wepreferences" /s /q 

rd "C:\Users\sas\appData\local\temp\SASStudioTemp" /s /q 

:: 

rem Appdata Area - sasdemo account 

rd "C:\users\sasdemo\documents\my sas files\" /s /q 

rd "C:\users\sasdemo\appdata\local\sas" /s /q 

rd "C:\Users\sasdemo\appData\local\temp\SAS Temporary Files"   
/s /q 

rd "C:\users\sasdemo\appdata\roaming\sas" /s /q 

:: 

rem Appdata Area - sassrv account 

rd "C:\users\sassrv\documents\my sas files\" /s /q 

rd "C:\users\sassrv\appdata\local\sas" /s /q 

rd "C:\Users\sassrv\appData\local\temp\SAS Temporary Files"  
/s /q 

rd "C:\users\sassrv\appdata\roaming\sas" /s /q 

(list continued) 
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 The undoit.bat file removes the sid_files folder from the SAS Software Depot with   
the following commands: 

 
rem Remove the sid_files folder. 

rd "C:\SAS Software Depot\sid_files" /s /q 

:: 

:: 

cls 

TROUBLESHOOTING THE INSTALLATION PROCESS 

In the beginning stages of testing the installation process, it is likely something might fail or might not 
work properly. For example, it might be difficult to determine if something goes wrong with a quiet 
installation. This section provides a list of common problems you might encounter as well as the best 
method for troubleshooting such problems. 

COMMON PROBLEMS 

Any of the following issues will cause a quiet installation to fail, which, in turn, causes the silent-status 
dialog box to disappear prematurely.  

 an invalid path to the SID file in the response file  

 an invalid SID file name in the response file 

 an invalid computer name in the response file 

 an invalid path to the plan file in the response file 

 a missing plan file  

 an improper hyphen for a command-line option command line (see SAS Note 37418, "You must 
use a hyphen with command-line options in the SAS Deployment Wizard" - 
support.sas.com/kb/37/418.html) 

You should keep in mind that the response file dictates the installation. If entries in the response file are 
incorrect, the installation fails. 

In the case-study environment, some test machines were not used for an extended time. Because 
of the extended time, the SAS accounts became disabled. If this happens, you can reset those 

accounts by running the two BAT files resetsasaccounts01.bat and resetsasaccounts02.bat that are in the 
C:\RUG directory. Be sure to run the files in the order shown here.  The code modules for these files are 
shown below. 

The resetsasaccounts01.bat File: 
 

echo on 

net user sas /logonpasswordchg:no /passwordchg:yes 

net user sasdemo /logonpasswordchg:no /passwordchg:yes 

net user sassrv /logonpasswordchg:no /passwordchg:yes 

pause 

http://support.sas.com/kb/37/418.html
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The resetsasaccounts02.bat File: 

echo on 

net user sas Password1 

net user sasdemo Password1 

net user sassrv Password1 

pause 

BEST METHOD FOR TROUBLESHOOTING 

For troubleshooting purposes, the best solution is to make the installation process manual and visually 
examine the process. To do that, you need to remove the –quiet option from the installation command 
so that you can run the installation manually against the same response file. By using this method, you 
can typically determine where the problems are. Then you can modify those areas to correct the 
installation. 

Example of an Installation Command with the –quiet Option: 

"C:\SAS Software Depot\setup.exe" -quiet -nomsupdate -silentstatus     
-responsefile C:\rug\installsas.txt 

Example of an Installation Command without the –quiet Option: 

 
"C:\SAS Software Depot\setup.exe" -nomsupdate -responsefile 

C:\rug\installsas.txt 
 

In this command, the -silentstatus option is removed also because it does not take effect 
without the presence of the –quiet option is not present. 

 
The following examples are all run without the –quiet option so you can see the error or warning that is 
generated for each problem. 

Example of an Installation Command with a Misspelled Option 

In the following example, the –responsefile option is misspelled: 

"C:\SAS Software Depot\setup.exe" -nomsupdate -responcefile 
C:\rug\installsas.txt 

When you submit this command, the following error is generated: 

 

Example of an Installation Command with an Expired SAS Installation Data File 

"C:\SAS Software Depot\setup.exe" -nomsupdate -responsefile 
C:\rug\installsas.txt 
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When you submit a command that contains an expired SID file, the following warning is generated: 

 

Example of an Installation Command Where the plan.xml File Is Missing from the SAS® 

Software Depot 

"C:\SAS Software Depot\setup.exe" -nomsupdate -responsefile 
C:\rug\installsas.txt 

When you submit a command that contains an expired SID file, the following warning is generated: 

 

CONCLUSION 

This paper provides a case study about setting up machines for SAS Regional Users Groups. Steps, 
methods, and examples illustrate how you can automate installations without the use of provisioning 
software. You can use the guidelines discussed in this paper in your own lab, training, and workshop 
environments. Once the preparation work is performed, you can deploy the installation across many 
machines with relative ease and success. 

 ACKNOWLEDGMENTS 

The author recognizes Eugene Whitlock and Lee Bumgarner from SAS for their time and efforts to make 
SAS software and this paper better for our customers. 

RECOMMENDED READING 

 SAS Institute Inc. 2013. "Automating the SAS® Installation on Multiple Machines" in "Chapter 6: 
Installing and Configuring Your SAS® Software." SAS 9.4 Intelligence Platform: Installation and 
Configuration Guide. Cary, NC: SAS Institute Inc. Available at 
support.sas.com/documentation/cdl/en/biig/63852/PDF/default/biig.pdf.  

 SAS Institute Inc. 2014. System Requirements for SAS® 9.4 Foundation for Microsoft Windows for 
x64. Cary, NC: SAS Institute Inc. Available at 
support.sas.com/documentation/installcenter/en/ikfdtnwx6sr/66390/PDF/de
fault/sreq.pdf. 

 

(list continued) 

http://support.sas.com/documentation/cdl/en/biig/63852/PDF/default/biig.pdf
http://support.sas.com/documentation/installcenter/en/ikfdtnwx6sr/66390/PDF/default/sreq.pdf


19 

 SAS Institute Inc. 2015. "Chapter 3 – SAS Deployment Wizard: Command Line Options" in SAS® and 
"Chapter 7 – SAS Deployment Manager: Command Line Options" in the Deployment Wizard and 
SAS® Deployment Manager 9.4: User's Guide. Cary, NC: SAS Institute Inc. Available at 
support.sas.com/documentation/installcenter/en/ikdeploywizug/66034/PDF/
default/user.pdf. 

 SAS Institute Inc. 2015. Supported Operating Systems. SAS Knowledge Base/System Requirements. 
Available at support.sas.com/supportos/list. Accessed on February 12, 2015. 

 Schneider, Mark. 2014. "So Much Software, So Little Time: Deploying SAS® onto Oodles of 
Machines." Proceedings of the SAS Global Forum 2014 Conference. Cary, NC: SAS Institute Inc. 
Available at support.sas.com/resources/papers/proceedings14/SAS105-2014.pdf.  

 SAS Institute Inc. 2013. "Appendix 6: Provisioning SAS on Windows" in the SAS® 9.4 Intelligence 
Platform: Installation and Configuration Guide. Cary, NC: SAS Institute Inc. Available at 
support.sas.com/documentation/cdl/en/biig/63852/PDF/default/biig.pdf. 

CONTACT INFORMATION 

Your comments and questions are valued and encouraged. Contact the author at: 

Max Blake  
SAS Institute, Inc.  
Cary, NC 27513 
E-mail: support@sas.com 
Web: support.sas.com   
   

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of 
SAS Institute Inc. in the USA and other countries. ® indicates USA registration.  

Other brand and product names are trademarks of their respective companies.  

http://support.sas.com/documentation/installcenter/en/ikdeploywizug/66034/PDF/default/user.pdf
http://support.sas.com/supportos/list
http://support.sas.com/resources/papers/proceedings14/SAS105-2014.pdf
http://support.sas.com/documentation/cdl/en/biig/63852/PDF/default/biig.pdf
mailto: support@sas.com
http://support.sas.com



