Technical Paper

Implementing a SAS® Metadata Server Configuration for Use with SAS® Enterprise Guide®
Release Information

Content Version: 1.1 August 2017

(This paper replaces TS-775 released in 2007.)

Trademarks and Patents


SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. © indicates USA registration.

Other brand and product names are registered trademarks or trademarks of their respective companies.
Contents

Introduction .......................................................................................................................... 3

Step 1: Setting Up Required Users and Groups ............................................................... 3
  Windows Operating Systems Only ................................................................................. 3

Step 2: Installing Software Using the SAS® Software Navigator ............................... 6

Step 3: Configuring Software Using the SAS Configuration Wizard ....................... 9

Step 4: Using Scripts to Complete Configuration ......................................................... 12

Step 5: Adding Users to the System ............................................................................. 12

Step 6: Configuring Servers for SAS® Enterprise Guide® on Any Client Machines 13
  Configuring SAS® Enterprise Guide® 4.1 ................................................................. 13
  Configuring SAS® Enterprise Guide® 3.0 ................................................................. 16
Introduction

SAS Enterprise Guide can access two types of backend SAS servers:

- a server administered by a SAS Enterprise Guide repository. This server uses an Object Spawner and a SAS Workspace Server. The server itself is used for all administrative tasks (for example, defining libraries, users, and servers) that are performed in the SAS Enterprise Guide Administrator.

- a server administered by a SAS® Metadata Repository. This server uses a SAS Metadata Server to define and configure supporting servers, users, and libraries.

This document explains how to install a server administered by a SAS Metadata Repository as a backend server for your SAS Enterprise Guide client machines. The installation information in this document is taken from the *SAS® 9.1.3 Intelligence Platform: Installation Guide, Fifth Edition*.

Step 1: Setting Up Required Users and Groups

Before you install and configure your software, you must create a set of required user accounts. These accounts perform specialized functions and help maintain the server. The user accounts (Table 1) are normally local to the server, although domain accounts are allowed in a Windows environment.

<table>
<thead>
<tr>
<th>Required Accounts</th>
<th>Recommended Account ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAS Administrator</td>
<td>SASADM</td>
</tr>
<tr>
<td>SAS Trusted User</td>
<td>SASTRUST</td>
</tr>
<tr>
<td>SAS Demo User</td>
<td>SASDEMO</td>
</tr>
<tr>
<td>SAS General Server</td>
<td>SASSRV</td>
</tr>
<tr>
<td>SAS Guest User</td>
<td>SASGUEST</td>
</tr>
<tr>
<td>SAS installer (for UNIX hosts only)</td>
<td>SAS</td>
</tr>
</tbody>
</table>

*Table 1. User Accounts Required for Installing and Configuring the Software*

**Windows Operating Systems Only**

You need to create a group called SAS Server Users and add the accounts listed previously in Table 1. Then follow these steps to assign the user right Log on as a batch job to that group:

2. In the Local Security Settings window, expand Local Policies in the left pane and click User Rights Assignment.

![Display 1. Selecting User Rights Assignment in the Local Security Settings Window](image)

3. Click Log on as a batch job in the right pane to display the Log on as a batch job Properties dialog box.
4. On the Local Security Setting tab, click Add User or Group to display the Select Users or Groups dialog box. Enter your information in the fields and click OK to return to the Log on as a batch job Properties dialog box.

5. Make sure your new group appears in the box on the Local Security Setting tab and click OK.
Step 2: Installing Software Using the SAS® Software Navigator

To install your software, you must have your SAS Installation Data (SID) file. The SID was sent in an email to your site representative. Once you have the SID, you can begin installation, as follows.

1. Log on to the machine as a member of the Administrators group if you are working on a Windows machine and as the SAS Installer (SAS) if you are working on a UNIX machine. **(Note: We strongly recommend that you do not log on as ROOT in order to install platform components on a UNIX system.)**

2. Start the SAS® Software Navigator from the CD in the Deployment Tools chapter of your binder or from the highest-level directory in your software depot. (A depot is a network location of CD copies that you may have instead of physical CDs.) Invoke SETUP.EXE in Windows and ./SETUP.SH in UNIX.

3. Select the language that you want SAS Software Navigator to use to display text.

4. Select **Personal** for the type of installation you want to perform.
5. Specify the location of the SID file that contains information about the software that you have licensed for the current machine.
6. Click **Next** to accept the SID information.

7. Select the SAS Enterprise Guide sample plan by
   
   a. choosing the **Select a standard plan** radio button.
   
   b. selecting the plan named **SAS Foundation and Enterprise Guide – one machine**. Then click **Next**.

   **Display 8. Selecting the SAS Enterprise Guide Sample Plan**

Continue with the rest of the installation prompts (pages 56-60 in *SAS® 9.1.3 Intelligence Platform: Installation Guide, Fifth Edition*; default options are sufficient) until you get to the SAS Configuration Wizard.
Step 3: Configuring Software Using the SAS Configuration Wizard

Before you continue, see the following table for the default ports that are used by your SAS servers. You need to verify that these default ports are free for use on your system.

<table>
<thead>
<tr>
<th>Server or Spawner</th>
<th>Default Port</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAS Metadata Server</td>
<td>8561</td>
</tr>
<tr>
<td>SAS Object Spawner: operator port</td>
<td>8581</td>
</tr>
<tr>
<td>SAS Object Spawner: load balancing port</td>
<td>8571</td>
</tr>
<tr>
<td>SAS Workspace Server</td>
<td>8591</td>
</tr>
<tr>
<td>SAS Stored Process Server: connection</td>
<td>8601</td>
</tr>
<tr>
<td>SAS Stored Process Server: load balancing connection 1</td>
<td>8611</td>
</tr>
<tr>
<td>SAS Stored Process Server: load balancing connection 2</td>
<td>8621</td>
</tr>
<tr>
<td>SAS Stored Process Server: load balancing connection 3</td>
<td>8631</td>
</tr>
</tbody>
</table>

Table 2. Default Port Numbers Used by SAS Servers

Then you can continue with the configuration, as follows. Note: If the wizard prompts you with a choice between Single Account and Multiple Accounts, choose Multiple Accounts.

1. The SAS Configuration Wizard first prompts you for the location of a configuration directory. As the wizard explains, in the location that you specify, the wizard will create a set of directories and files that you will use in the management of the system. The default value, C:\SAS\EGSERVERS, is fine.

2. On Windows systems, you must specify whether you want to run servers such as the Metadata Server and Object Spawner as Windows services. In the SAS Server Configuration Options dialog box, select Run as services (recommended).
3. Then click **Next** to display the Enter SAS Metadata Server Information dialog box (Display 10). In the **SAS Metadata Server Host Name** field, enter the **full name** of the machine that is hosting the Metadata Server and the port on which the server will listen for requests.

4. The default value **should** be the machine on which you are installing. Keep this default value and click **Next**, which displays a screen where you enter the SAS Application Server name. In general, it is best to use the default name **SASMain**.
5. The next set of dialog boxes that appear prompts you for the credentials for the accounts that you created in Step 1. (You get a new screen for each account that you created.) Please type carefully to ensure proper account name and password values because it is difficult to change them after they are entered and the installation is complete. For Windows, supply the name as `domain\userid` if the account is on a domain server or `machinename\userid` if the account is local. The wizard provides default values and descriptions to help you understand which account is needed for each prompt.

6. Click **Next** in the Advanced Properties dialog box and complete the Configuration Wizard interview.
Step 4: Using Scripts to Complete Configuration

The fastest (and safest) way to finish your configuration of the system is to run the scripts referred to in the INSTRUCTIONS.HTML file.

Note: Be sure to follow any instructions that precede the first reference to a script. For example, on your Metadata Server machine, you need to define your metadata repository manually before running the first script.

Perform the following steps until you reach the end of the file:

1. Execute the script referred to in the instructions. On Windows systems, you execute each script by clicking on a link. The following display shows a portion of the INSTRUCTIONS.HTML document with a script link:

![Figure 1. A Portion of the INSTRUCTIONS.HTML File that Contains the Configuration Scripts](image)

2. Immediately following the reference to the script is a link that says proceed to the next step (see Figure 1). Click this link, which takes you to the step that follows the last step performed by the script.

3. If the next item in the instructions is a script, return to Step 1. Otherwise, manually perform any instructions that precede the next script; then return to Step 1.

SAS® Management Console is invoked at the same time that INSTRUCTIONS.HTML is displayed in your Web browser. Use SAS Management Console to verify the work you performed with the scripts from INSTRUCTIONS.HTML. Expand User Manager, Server Manager, SASMain, and so on to make sure that the metadata was created. Also be sure to test your SAS Workspace Server and the Stored Process Server using the steps described at the end of the INSTRUCTIONS.HTML file.

Step 5: Adding Users to the System

Next, add to the system any other users from your site who will be using SAS Enterprise Guide.

1. If the user does not already have an operating system account that will enable the SAS Metadata Server host to authenticate that person, you must create an account. This account enables the user to connect to the Metadata Server. On Windows, add these accounts to the SAS Server Users group that you created in the operating
13

system. Adding these accounts automatically assigns the required user right (Logon as a batch job).

2. If the user needs a metadata identity so that the Metadata Server can grant or deny the user access to metadata objects, you must create a metadata object that represents this user. One required piece of information that you store is the user ID that this person will use to connect to the Metadata Server.

Note: If a user needs to access servers other than the Metadata Server, you might want to specify both a user ID and a password in the metadata so the user will not be prompted every time a server session is needed.

Step 6: Configuring Servers for SAS® Enterprise Guide® on Any Client Machines

If your machine runs a Windows operating system, the previous steps installed SAS Enterprise Guide on that machine. In that case, you can use this installation as your first client and then configure it to ensure proper connectivity. The following sections explain how to configure your servers for connectivity with SAS Enterprise Guide on any client Windows machine.

Configuring SAS® Enterprise Guide® 4.1

Follow these steps to configure your servers for SAS Enterprise Guide 4.1:

1. Open SAS Enterprise Guide.
2. Select Tools ► Options ► Administration ► Repository and Server.

Display 13. Selecting the Repository and Server Screen from the Options Dialog Box
In the Repository and Server dialog box (Display 13), click **Manage** to display the Repository Manager.

3. In the Repository Manager, select the **ITConfig Metadata Repository** listing.

![Display 14. Selecting the ITConfig Metadata Repository Listing](image)

Then click **Modify** to display the Modify Repository dialog box.

4. In the Modify Repository dialog box, verify that the repository is defined as follows:

   - **Machine**: The **Remote** radio button is checked and the Metadata Server’s machine name has been typed in.
   - **Port**: 8561
   - **User ID**: Use **SASDEMO** for testing or the valid user ID of a production client.
   - **Password**: Use the password for the user ID (**SASDEMO** or a valid production client user ID) that you use.
Then click **Browse** to connect to the Select Repository dialog box.

5. In the Select Repository dialog box, select **Foundation** and click **OK** to return to the Modify Repository dialog box.

6. In the Modify Repository dialog box, click **Save**, which takes you back to the Repository Manager dialog box.

7. In the Repository Manager, click **Set Active**. Then close both the Repository Manager and the Options dialog boxes.

Now you can test your connection in SAS Enterprise Guide by selecting **View ► Servers** and attempting to expand the **SASMain** Server list. You can also test it by opening a new code node and submitting a simple program, such as the following PRINT procedure:
proc print data=sashelp.class;
run;

Then, run the code on the SASMMain Server. If there is a problem with the connection, you will receive an error message.

### Configuring SAS® Enterprise Guide® 3.0

Follow these steps to configure your servers for SAS Enterprise Guide 3.0:

1. Open the SAS Enterprise Guide Administrator.

2. Select **File ► Manage Repositories** to display the Repository Manager.

3. In the Repository Manager, select the **ITConfig Metadata Repository** listing.

---

**Display 17: Opening the SAS Enterprise Guide Administrator**

**Display 18: Selecting the IT Config Metadata Repository Listing**
Then click **Modify** to display the Modify Repository dialog box.

4. In the Modify Repository dialog box, verify that the repository is defined as follows:
   - **Machine**: The *Remote* radio button is checked and the Metadata Server’s machine name has been typed in.
   - **Port**: 8561
   - **User ID**: Use **SASDEMO** for testing or the valid user ID of a production client.
   - **Password**: Use the password for the user ID (**SASDEMO** or a valid production client user ID) that you use.

![Display 19: Verifying Information in the Modify Repository](image)

Then click **Browse** to connect to the Select Repository dialog box.

5. In the Select Repository dialog box, select **Foundation** and click **OK** to return to the Modify Repository dialog box.

![Display 20: Selecting the Foundation Repository](image)
6. In the Modify Repository dialog box, click `Save`, which takes you back to the Repository Manager dialog box.

7. In the Repository Manager, click `Set Active`. Then close both the Repository Manager and the SAS Enterprise Guide Administrator dialog boxes.

Now you can test your connection in SAS Enterprise Guide by selecting `View ▶ Servers` and attempting to expand the `SASMain` Server list. You can also test it by opening a new code node and submitting a simple program, such as the following `PRINT` procedure:

```sas
proc print data=sashelp.class;
run;
```

Then, run the code on the SASMain Server. If there is a problem with the connection, you will receive an error message.