## Contents

**Chapter 1 • Introduction** ................................................................. 1  
Introduction .............................................................................. 1  
Client Software ........................................................................ 2  
Server Software - SAS Studio .................................................. 2  
Server Software - SAS Enterprise Guide .................................. 3  
Server Software - SAS Enterprise Miner .................................. 4  
Server Software - SAS Forecast Studio .................................... 4  

**Chapter 2 • Set Up Your SAS OnDemand for Academics Account** ................................................. 7  
Introduction .............................................................................. 7  
Important Information Before You Begin ............................... 7  
Register for SAS OnDemand for Academics ......................... 8  
About the SAS OnDemand for Academics Control Center ....... 9  

**Chapter 3 • Setting Up a Course** ........................................................................ 11  
Create a Course ....................................................................... 12  
Prepare Course Data .................................................................. 13  
Review and Test Course Materials ......................................... 23  
Share Course Information with Students ............................... 26  

**Chapter 4 • Enrolling in a Course** ........................................................................ 31  
Enterroll in a Course .................................................................. 31  
SAS Enterprise Miner: Sharing Homework Assignments .......... 32  

**Chapter 5 • SAS OnDemand for Academics: SAS Studio** ................................................. 37  
SAS OnDemand for Academics: SAS Studio ............................ 38  
Confirm System Requirements .................................................. 38  
Access and Use the Software .................................................... 40  
Review the Basics for Working with Data and Results .......... 42  
Finding Help for Common Problems ....................................... 47  

**Chapter 6 • SAS OnDemand for Academics: Enterprise Guide** ........................................... 55  
SAS OnDemand for Academics: Enterprise Guide ................. 56  
Confirm System Requirements .................................................. 56
Statistics Information ......................................................... 135
SAS Studio Resources ......................................................... 135
SAS Enterprise Guide Resources ........................................... 136
SAS Enterprise Miner Resources ........................................... 137
SAS Forecast Studio Resources ............................................. 138
JMP Resources ................................................................. 138

Recommended Reading .......................................................... 141
Introduction

SAS OnDemand for Academics provides an online delivery model for teaching and learning data management and analytics. By connecting to a SAS server over the web, users access the analytical power of SAS software through a user-friendly, point-and-click interface.

SAS OnDemand for Academics: SAS Studio by default is available to anyone who registers. This includes adult learners, instructors, students, researchers – as long as you are not using the offering for commercial purposes.

All other clients (Enterprise Guide, Enterprise Miner, Forecast Studio, and access from JMP) are available to instructors who register a course and choose to use one of these clients for their course.
The following are some of the advantages of using SAS OnDemand for Academics:

- Users gain immediate online access to SAS software – with no configuration or support concerns.
- Students, including both on-site and distance learners, can use SAS whenever or wherever they please—no more waiting for a seat in a campus computer lab or having to buy and install software.
- SAS allows professors to teach data management and analytics, providing multiple software applications without maintenance or IT overhead.
- SAS has been used in colleges and universities for more than 30 years.
- With quick access to award-winning software for data management and analytics, students gain valuable SAS skills that are highly sought after in the job market.

**Client Software**

Instructors can choose to use one of the following software applications when they register a course with SAS OnDemand for Academics:

- SAS Studio
- SAS Enterprise Guide
- SAS Enterprise Miner
- SAS Forecast Studio

When students register for the course, they must select the same software application that their instructor has chosen to use.

**Server Software - SAS Studio**

The following products are available on the hosted SAS server that supports SAS OnDemand for Academics: SAS Studio:
The following products are available on the hosted SAS server that supports SAS OnDemand for Academics: Enterprise Guide:

- Base SAS
- SAS/STAT software
- SAS/GRAPH software
- SAS/ETS software
- SAS/OR software, including OPT, PRS, IVS, and LSO
- SAS/IML software
- SAS/CONNECT
- SAS High-Performance Forecasting
- SAS/ACCESS Interface to PC Files
- SAS/QC software
Server Software - SAS Enterprise Miner

The following products are available on the hosted SAS server that supports SAS OnDemand for Academics: Enterprise Miner:

- Base SAS
- SAS/STAT software
- SAS/GRAPH software
- SAS/ETS software
- SAS/OR software, including OPT, PRS, IVS, and LSO
- SAS/IML software
- SAS/CONNECT
- SAS Enterprise Miner
- SAS Credit Scoring
- SAS Text Miner
- SAS High-Performance Forecasting
- SAS/ACCESS Interface to PC Files

Server Software - SAS Forecast Studio

The following products are available on the hosted SAS server that supports SAS OnDemand for Academics: Forecast Studio:

- Base SAS
- SAS/STAT software
- SAS/GRAPH software
- SAS/ETS software
- SAS/OR software, including OPT, PRS, IVS, and LSO
- SAS/IML software
- SAS/CONNECT
- SAS Enterprise Miner
- SAS Credit Scoring
- SAS Text Miner
- SAS High-Performance Forecasting
- SAS/ACCESS Interface to PC Files
- SAS/ACCESS Interface to MYSQL
- SAS Forecast Studio
- SAS/IML Studio
Set Up Your SAS OnDemand for Academics Account

Introduction

There are several important steps that you must follow to set up a SAS OnDemand for Academics account, such as creating a SAS profile. The online process uses a series of windows to guide you.

Important Information Before You Begin

As you begin setting up your account, it is helpful to keep the following in mind:

- You need access to your email account. When you begin registration, you are prompted to enter an email address. Enter the email address of an account that you can access easily while completing your registration.
You will receive an email during the initial registration process that you must open and act upon to continue. The email prompts you to click a link to verify your email address. Its primary purpose is to confirm that you are using a valid email address and that someone else is not attempting to register you without your knowledge.

If you do not receive the email, then check your junk email folder.

---

**Register for SAS OnDemand for Academics**

If you are a new user, then you need to register for SAS OnDemand for Academics. When you register, a SAS profile is created for you. If you are a current SAS user, then you might already have a SAS profile.

To register for SAS OnDemand for Academics, complete these steps:

An important part of your SAS profile account is a SAS profile password that you are prompted to enter each time you access the SAS OnDemand for Academics Control Center.

**Note:** Your SAS profile password must be changed every 6 months for security purposes. You will receive an email when your password is approaching expiration. To reset your SAS profile, visit My SAS Profile page.

1. Go to the **SAS OnDemand for Academics registration page**.
   - The Create an Account window is displayed.

2. Enter your **First Name**, **Last Name**, and **Email Address** in the form. Select the **Country** in which you reside. Click **Submit**.
   - A message is displayed that acknowledges your registration.

3. One of two following scenarios occur:
a If you are a returning user, then a window is displayed that says that you have a SAS profile. You already have a user ID and a SAS profile (and corresponding SAS profile password). Accept the license agreement. Click **Continue**.

b If you are a new user, then enter your **Email address** and password information. The page includes the password rules that you need to follow. Accept the license agreement and then click **Create Account**.

You are presented with a window that identifies your user ID. Record this user ID. You will need it to sign in to the SAS OnDemand for Academics Control Center and your software application or applications.

4 Click the **Sign in** link to log on to the SAS OnDemand for Academics Control Center. You are prompted to sign in using your user ID and your SAS profile password. You are now logged in to the SAS OnDemand for Academics Control Center.

---

**About the SAS OnDemand for Academics Control Center**

Your starting point for accessing SAS OnDemand for Academics is the **SAS OnDemand for Academics Control Center**.

You use the Control Center to manage your account and access resources that are currently available to you, such as applications. If you are an instructor, you use it to create courses, view course information, and start SAS applications such as SAS Studio, SAS Enterprise Miner, and SAS Forecast Studio. If you are a student, you use it to enroll in a course, view course information, and start SAS applications such as SAS Studio, SAS Enterprise Miner, and SAS Forecast Studio.

Your SAS OnDemand for Academics Dashboard is created during the registration process and is part of the SAS OnDemand for Academics Control Center. You are taken to your Dashboard once you have set up an account. You access your Dashboard to view information that is associated with courses.
Setting Up a Course

Create a Course ........................................................................................................ 12

Prepare Course Data .................................................................................................. 13
  Introduction ............................................................................................................. 13
  Sample Data on the Hosted SAS Server ............................................................ 13
  Custom Course Data on the SAS Server ............................................................ 15
  Accessing Course Files Stored on the SAS Server ........................................ 18
  SAS Data Sets from SAS Enterprise Miner Courses ....................................... 23

Review and Test Course Materials ............................................................................. 23
  Reviewing the Software ....................................................................................... 23
  Teaching Materials Provided by SAS ................................................................. 24
  Accessing Teaching Material and Data
    Specifically for SAS Enterprise Miner ............................................................... 25
  Books, Training, and Other Reference Materials .............................................. 26

Share Course Information with Students ................................................................... 26
  Introduction ............................................................................................................. 26
  Ask Students to Register for SAS OnDemand for Academics ................. 27
  Provide Students with Information about the System ........................................ 28
  Suggested Information to Share with Students .................................................. 28
Create a Course

You must create a course before you can do the following:

- select and gain access to the SAS software that you plan to use (except for SAS Studio, which is automatically made available to all users)
- create course information that you can share with potential students
- create an area where you can store data for the course (should you choose to store data on SAS servers)

**Note:** To avoid confusion and unnecessary support calls, it is important to complete this step before you invite people to register for SAS OnDemand for Academics.

1. Log on to the **SAS OnDemand for Academics Control Center** using your SAS profile user ID and password. Click **Sign In**.
   The SAS OnDemand for Academics Dashboard is displayed.

2. Click **create a new course**.
   The Register Course page is displayed.

3. Enter the **Course Name** and **Description**.

4. Select the **Level**, **Country**, **Region**, and **School/Institution** in which this course is affiliated.

5. If your school or institution is not listed, then click the **my institution is not listed** check box.
   An area opens in which you can enter your institution’s **Region**, **City**, and **Institution Name**.

6. Select the SAS software that your course uses. While SAS Studio is available for all users automatically, it should be selected here when you plan to use it for your course.
7 Click **Register this course**.

When you return to your Dashboard, your course is listed under the **Courses I teach** area.

---

## Prepare Course Data

### Introduction

The following information can help you determine the most suitable option for providing students with data and exercises that meet their course objectives and computing environment.

With SAS OnDemand for Academics, you have many options for providing data for course exercises and teaching examples:

- use SAS sample data on the hosted SAS server
- upload your own custom course data to the SAS server
- provide course data on local file systems
- use SAS data sets from publicly offered SAS Enterprise Miner courses

Due to its architecture, both local data, and data uploaded by instructors are unavailable for use with SAS OnDemand for Academics: Forecast Studio. Please use the default SAS data sets provided on the SAS server when using this offering. To view the available SAS libraries, use the appropriate method to browse data within SAS OnDemand for Academics: Forecast Studio.

### Sample Data on the Hosted SAS Server

#### SAS Studio

The SAS server includes various SAS libraries (and their corresponding SAS data sets). You might want to use one or more of the SAS data sets from SASHELP, MAPS, or
other libraries that are provided by SAS to ensure that all your students have access to the data.

To access sample data libraries on the SAS server in SAS Studio, complete these steps:

1. Log on to SAS Studio using your user ID and password.

2. Open or create a new project.

3. Select **Libraries** in the navigation pane.

4. Expand the library that you would like to use to view the data set for which you are searching.

5. Double-click the SAS data set to open it.

**Enterprise Guide**

The SAS server includes various SAS libraries (and their corresponding SAS data sets). You might want to use one or more of the SAS data sets from SASHELP, MAPS, or other libraries that are provided by SAS to ensure that all your students have access to the data.

To access sample data libraries on the SAS server in SAS Enterprise Guide, complete these steps:

1. Log on to SAS OnDemand for Academics: Enterprise Guide with your user name and password.

2. Open an existing project or create a new project.

3. Navigate to the **Server List** on the lower left-hand side of the screen.

4. Select the ‘+’ icon to expand the server list.

5. Expand **SASApp**.

7 Expand the library that you would like to use to view the data set for which you are searching.

8 Double-click the SAS data set to open it.

**Enterprise Miner**

The SAS server includes various SAS libraries (and their corresponding SAS data sets). You might want to use one or more of the SAS data sets from SASHELP, MAPS, or other libraries that are provided by SAS to ensure that all your students have access to the data.

To access sample data libraries on the SAS server in SAS Enterprise Miner, complete these steps:

1 Start SAS OnDemand for Academics: Enterprise Miner.

2 Create a new project or open an existing project.

3 In the tree on the left, right-click **Data Source ▶ Create Data Source**.

4 The **Source** menu defaults to SAS Table. Click **Next** to accept the default value and move to the next step in the wizard.

5 Next to the **Table** field (which will be blank), click **Browse**.

6 Use the **Library** menu to select the appropriate library.

7 Select the SAS data set that you want to use and then continue with the wizard.

**Custom Course Data on the SAS Server**

**Introduction**

For courses that use SAS Studio, SAS Enterprise Guide, and SAS Enterprise Miner, data files that are customized specifically to a course can be uploaded to hosted SAS servers.
The SAS server is UNIX based. You should be aware of naming conventions and how SAS OnDemand for Academics might handle filenames. There are additional requirements if your course uses third-party data.

**Filenames and Types**

The following are the requirements for filenames and types:

- Only data files can be stored on the SAS server (no program files, course notes, slides, and so on). Instructors can store SAS data sets (file type extension of .sas7bdat) as well as SAS data set index files (file type extension of .sas7bndx) on the SAS server.

- Avoid using this space to store data files from individual students. This space is intended to store the data files that an instructor wants all students to be able to access to complete a course.

- Avoid using special characters (such as parentheses or ampersands) in data filenames.

- You should keep a master copy of your data files in another location.

**Third-Party Data Sources**

Some universities purchase third-party data sources or use open source third-party data sources. Often, these data sources are protected by specific license agreements or terms of use. Review the license agreement or terms of use for the third-party data sources in question before uploading this type of data to the SAS server. It is your responsibility to do the following:

- ensure that you have the right to upload third-party data sources to the SAS server

- verify that use of the third-party data sources does not violate any third-party rights or any applicable laws or regulations

**Uploading Other Data Formats on the SAS Server**

Some SAS software applications, such as SAS OnDemand for Academics: Enterprise Guide and Enterprise Miner, are designed to use data other than SAS data sets. The following types of data files can be stored on the SAS server:

- .asc (text file)
- .csv (comma delimited)
- .dat (flat data file)
- .db (Paradox)
- .dbf (dBASE)
- .mdb (MS Access)
- .tab (text file)
- .txt (text file)
- .wk? (Lotus 123)

You are encouraged to print a copy of SAS OnDemand for Academics: Storing and Accessing Non SAS Files on the SAS Server (Instructors Only).

**Uploading Course Files to the SAS Server**

To upload course data files to the SAS server, complete these steps:

**Note:** There is a limit of 2 GB of course data storage space per user account.

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click **Sign In**.

   The SAS OnDemand for Academics Dashboard is displayed.

2. Make a note of the directory information in the **Course data directory** area. This path can be used as the LIBNAME or FILENAME statement to access data that you upload for your course.

   **Note:** If you have not already registered a course, then see “Create a Course” on page 12. Complete the course registration process before continuing.

3. Click the **SAS Studio** link located under **Applications** to start SAS Studio.

4. From within SAS Studio, expand **My Folders** and then select the **my_content** folder, which is an alias for the course data location listed in **Step 2**.

5. Click 🝈.
The Upload Files dialog box is displayed.

6. Click **Choose Files**.

7. Select the file or files that you want to upload and then click **Open**.

8. Click **Upload**.

   Your file or files are listed under the **my_content** folder.

   **Note:** You can refresh your course data by uploading the data again. Your existing, uploaded data is overwritten.

9. Share the **Course data directory** path that you found in Step 2 with the students in your course. This path can be used as the LIBNAME or FILENAME statement in order to access the data that you have uploaded.

   The LIBNAME or FILENAME statements can be used within SAS programs in software applications other than SAS Studio if you are teaching with them, such as SAS Enterprise Guide or SAS Enterprise Miner.

### Accessing Course Files Stored on the SAS Server

**Introduction**

The following are instructions for accessing your custom course data once it has been uploaded.

**Accessing Data with LIBNAME or FILENAME Statements**

Once a SAS data set or a data file has been uploaded to the SAS server, you can access the data using the appropriate LIBNAME statement or a FILENAME statement. The LIBNAME or FILENAME statement to use is provided to you during the course creation process. To access this information at any time:

1. Log on to the **SAS OnDemand for Academics Control Center** using your SAS profile user ID and password. Click **Sign In**.

   The SAS OnDemand for Academics Dashboard is displayed.
2 Make a note of the directory information in the **Course data directory** area.

3 Review the section called Working with SAS Data Sets (for the appropriate LIBNAME statement) or “Uploading Other Data Formats on the SAS Server” on page 16 (for the appropriate FILENAME statement).

4 Start or log on to the appropriate SAS OnDemand for Academics software (for example, SAS Studio or SAS Enterprise Guide).

5 Create or open a SAS program.

6 Assign the LIBNAME or FILENAME statement in your code in order to access your data. Remember LIBNAME and FILENAME statements are case sensitive.

7 If appropriate, share the LIBNAME or FILENAME statement with your students so that they will know which statement to use to access your data.

**Note:** If you have created and uploaded a directory, then you must append the directory name to the generated LIBNAME or FILENAME statement.

**Accessing Sample Data Using SAS OnDemand for Academics: SAS Studio**

You can access SAS sample data sets using the following procedure. Once you have submitted a LIBNAME or FILENAME statement, you can access your uploaded course data using the same method.

To access SAS sample data sets, complete these steps:

1 Log on to SAS Studio using your user ID and password.

2 Open or create a new project.

3 Select **Libraries** in the navigation pane.

4 Expand the appropriate library to list SAS data sets (such as MAPS or SASHELP or the library that you have assigned using a LIBNAME statement).

5 Double-click the SAS data set to open it.
Accessing Sample Data Using SAS OnDemand for Academics: Enterprise Guide

You can access SAS sample data sets using the following procedure. Once you have submitted a LIBNAME or FILENAME statement, you can access your uploaded course data using the same method.

To access SAS sample data sets, complete these steps:

1. Log on to SAS Enterprise Guide using your user ID and password.
2. Open or create a new project.
3. Navigate to the Server List on the lower left side of the screen.
4. Select the ‘+’ icon to expand the server list.
7. Expand the appropriate library to list SAS data sets (such as MAPS or SASHELP or the library that you have assigned using a LIBNAME statement).
8. Double-click the SAS data set to open it.

Using Project Start Code to Assign a SAS Library to a Project: Enterprise Miner

SAS OnDemand for Academics: Enterprise Miner enables you to include start code for your projects. After you have specified this code, it is run anytime that the project is started and can save you time and effort. For example, you might want to assign a LIBNAME statement through start code so that a project can always access specific SAS data sets.

To use project start code with a new project, complete these steps:

2. Select New Project. From the New Project wizard page, select a name for your project, select the default values on the remaining pages, and then select Finish.
3 From the **Property** tree on the left, locate the project start code property.

4 Click the ellipsis ... button.

5 Enter the appropriate start code and then click either **Run Now** or **OK**.

**Note:** If you want to use project start code to access SAS data sets that use a format file, then you must also specify the FMTSEARCH option in your start code. For more information about this option, search for FMTSEARCH in the **SAS Online Documentation**.

To use project start code with an existing project, complete these steps:

1 Start SAS OnDemand for Academics: Enterprise Miner.

2 Open the appropriate project.

3 From the **Property** tree on the left, locate the project start code property.

4 Click the ellipsis ... button.

5 Enter the appropriate start code and then click either **Run Now** or **OK**.

**Note:** If you want to use project start code to access SAS data sets that use a format file, then you must also specify the FMTSEARCH option in your start code. For more information about this option, search for FMTSEARCH in the **SAS Online Documentation**.

### Listing SAS Data Sets Stored on the SAS Server

If you uploaded SAS data sets to the SAS server and you want to see the names and information associated with those SAS data sets, then complete these steps:

1 Identify the LIBNAME statement that is associated with the uploaded data.

2 Start or log on to the appropriate SAS OnDemand for Academics software (SAS Studio, SAS Enterprise Guide, or SAS Studio).

3 Open a Program Editor window from within the application.
4 Enter and run code similar to the example below. Replace the LIBNAME statement in the example with the LIBNAME statement that you identified in Step 1.

```sas
libname mydata "/courses/xxxxxxxxxxxxxxxx/saslib" access=readonly;
proc contents data = mydata._all_; run;
```

5 Use the Output window to review the results. The results identify the SAS data sets that you have uploaded.

**Note:** If you have created and uploaded a directory, then you must append the directory name to the LIBNAME statement.

### Deleting SAS Data Sets Stored on the SAS Server

If you uploaded data that you no longer want to make available on the SAS server (or you have exceeded your data storage quota), then you can delete the data.

To delete SAS data sets that are stored on the SAS server, complete these steps:

1 Log on to the [SAS OnDemand for Academics Control Center](#) using your SAS profile user ID and password. Click **Sign In**.
   
   The SAS OnDemand for Academics Dashboard is displayed.

2 Identify the location of your data.

3 Click the [SAS Studio](#) link located under **Applications** to start SAS Studio.

4 From within SAS Studio, expand **My Folders** and then expand the **my_content** folder.

5 Select the data set or data sets that you want to delete in the **my_content** folder.

6 Click **Trash Can**.

7 A dialog box prompts you to verify the deletion.

8 Click **Delete**.
   
   The data set is removed.
SAS Data Sets from SAS Enterprise Miner Courses

In addition, SAS OnDemand for Academics stores SAS data sets that are associated with the teaching materials from SAS Enterprise Miner courses on the SAS server.

To view these data sets, complete these steps:

2. Create a new project or open an existing project.
3. In the tree on the left, click Data Source and then select Create Data Source.
4. Select Source ➤ Metadata Repository and then click Next.
5. Next to the Table field, click Browse.
6. Use the Library menu to select the appropriate library.
7. Select the SAS data set that you want to use and then continue with the wizard.

Review and Test Course Materials

Reviewing the Software

Importance of Reviewing the Software

You should review the software and course materials before your course begins.

In some cases, the steps needed to complete certain tasks might be different when using SAS OnDemand for Academics software applications (versus traditional SAS software applications). By reviewing and testing your course materials before class, you can prepare yourself and your students for any minor differences.
Note: Although it might take 30 minutes or less to review available course information and test the information against SAS OnDemand for Academics, you might have to register, request course materials, or both from SAS. This process could take a few days. Plan accordingly.

Specific to Enterprise Miner

There are a few differences between traditional SAS Enterprise Miner and SAS OnDemand for Academics: Enterprise Miner:

- You must accept the default project storage location when creating new projects. For more information, see "Creating New Projects" on page 94.

- Your projects are stored within the My Folder folder. For more information, see "Opening Existing Projects" on page 95.

- Certain nodes are unavailable, might not function properly, or are experimental. For example, the File Import node is unavailable. SAS Text Miner nodes are available, but are considered experimental.

For more information, see the SAS Text Miner documentation.

Specific to Forecast Studio

This offering of SAS Forecast Studio is designed for teaching purposes only. Although SAS Forecast Studio is capable of generating forecasts and reconciling estimates across very large SAS data sets with deep hierarchical structures, for the purpose of teaching SAS has limited the number of levels of a hierarchy to three (for example: state, store, product). Three levels are sufficient to demonstrate top-down, middle-out, and bottom-up reconciliation of forecasts for students. Instructors are further cautioned that SAS data sets with a significant number of categories within a hierarchy might require a longer processing time than what is appropriate for the typical live classroom setting.

Teaching Materials Provided by SAS

You might choose to use training materials provided by SAS, or you might choose to refer to course materials from previous SAS courses.
SAS Education provides certain teaching materials free of charge to instructors at degree-granting academic institutions. These materials include an electronic copy of course notes, slides, and in some cases, code and data. The materials are not available for use by students. For more information, visit the SAS Global Academic Program link.

**Note:** Before downloading the course materials, an instructor must register for SAS OnDemand for Academics. In addition, instructors are required to accept a license agreement that specifies the terms and conditions of usage.

The training materials were developed for users who are running SAS locally. Certain SAS code examples might not work or might need to be modified for use with SAS OnDemand for Academics. For example, any referenced SAS data sets would need to be uploaded to the SAS server and any LIBNAME statements would have to be modified to reflect the LIBNAME statement for an instructor's SAS OnDemand for Academics course.

### Accessing Teaching Material and Data Specifically for SAS Enterprise Miner

In some cases, SAS has already uploaded the SAS data sets that are used by popular teaching materials.

To use SAS data sets that are associated with the teaching materials from specific SAS Enterprise Miner courses, complete these steps:

2. Create a new project or open an existing project.
3. In the tree on the left, right-click **Data Source ▶ Create Data Source**.
4. Select **Source ▶ Metadata Repository** and then click **Next**.
5. Next to the **Table** field, click **Browse**.
6. Use the **Library** menu to select the appropriate library.
7. Select the SAS data set that you want to use and then continue with the wizard.
Books, Training, and Other Reference Materials

You can find SAS publications: books, review portions of each book, and place orders at the SAS Books store.

SAS Publishing offers products to qualified college faculty who are interested in teaching SAS. For more information, see the Academic Evaluation Copy Program.

Other publications are available for download from the SAS OnDemand for Academics website.

For SAS OnDemand for Academics: Enterprise Guide users, you might find the “Implementing SAS and Enterprise Guide to Enhance a Graduate Biostatistics Curriculum” white paper useful in preparing for your course.

Share Course Information with Students

Introduction

After you create your course, prepare your data, and become familiar with the software, you should do the following:

- Invite your students to register for your SAS OnDemand for Academics course.
- Provide important information about how to access the course software and data.

We recommend that you ask your students to complete these steps before the beginning of your course (if possible) or during the first week of your course. Some instructors choose to use the first class of a course to review how to perform these steps.
Ask Students to Register for SAS OnDemand for Academics

When you create a course within SAS OnDemand for Academics, you are presented with text that you can copy and paste into an email to send to your students. This text provides the information that your students need to register for SAS OnDemand for Academics and download the appropriate software application.

If you do not copy and paste the text when you initially create a course, you can access the information again at any time:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   The SAS OnDemand for Academics Dashboard is displayed.

2. Under the Courses I teach area, click the Details link next to the appropriate course.

3. Click Inviting Students to Register for Your Course.
   A generic version of the email text is provided below as an example. You can copy, paste, and customize this text if needed. For example, if you have a coupon code that students need to use, you can include that code in your email.

   Dear User:

   I’d like to invite you to enroll in my SAS OnDemand for Academics course. I plan to teach using the following software: Software Application Name.

   For the best experience, please register for SAS OnDemand for Academics first. To register, visit the following site: https://odamid.oda.sas.com/SASODARegistration/.

   After you have registered, please click the following course enrollment link to enroll in my course: Course enrollment link.

   I have also uploaded data for us to use in our course. You will be able to access that data using the following LIBNAME or FILENAME statement: Course data path.

   For more information about SAS OnDemand for Academics, including step-by-step registration instructions, visit the following site: http://support.sas.com/ondemand/.
Provide Students with Information about the System

You determine how you want to invite your students to participate yourself, but we recommend that you send email to the students on your course roster. In the email, it might be useful to do the following:

- Highlight system requirements, especially if you think the requirements could be an issue for some students.
- Include step-by-step installation instructions.

Suggested Information to Share with Students

How to register for SAS OnDemand for Academics. A printable step-by-step guide is available for the following solutions:

- SAS OnDemand for Academics: SAS Studio Registration Instructions
- SAS OnDemand for Academics: Enterprise Guide Student Registration Instructions
- SAS OnDemand for Academics: Enterprise Miner Student Registration Instructions
- SAS OnDemand for Academics: Forecast Studio Student Registration Instructions

As an instructor, you might want to share copies of the guide or links to the appropriate guide with your students.

How to access course data on the SAS server. If you choose to store data on the SAS server, then you must share the LIBNAME or FILENAME statement associated with that data with your students. For example, you might include the information in course notes or through email.
Connection time-outs. An open connection to the SAS server will likely expire after an hour of idle time (or less). Firewalls and other security measures often perform these types of time-outs after one hour (or less). Remind your students that they should save their work or exit SAS OnDemand for Academics or both before leaving their computers.

Software order e-mails. Each instructor and each student receives a software order email (SOE) from SAS when they choose to download SAS OnDemand for Academics: Enterprise Guide. Each SOE contains a unique order number that is associated with only one user. The SOE includes the information necessary to download and install the software, which is done through the SAS Download Manager.

Note: Users should not share their SOEs with other users.
Enrolling in a Course

You must enroll in and gain access to the SAS software being used for the course.

To enroll in a course, complete these steps:

1. Locate the course enrollment link that your instructor sent to you. Click the link.

2. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   
   The SAS OnDemand for Academics Dashboard is displayed.

3. Verify that the course that you are about to enroll in is the appropriate course. If it is, then click Yes, please enroll me in this course. Otherwise, do not enroll in the course.
Verify that you are registered for the appropriate course. You can find this information in the Dashboard under **Courses I am enrolled in**.

4. For all software except for SAS Studio, you need to download the appropriate course software. The following links provide instructions.

- To print step-by-step instructions to register for a course that uses SAS Enterprise Guide, see [SAS OnDemand for Academics: Enterprise Guide Student Registration Instructions](#).
- To print step-by-step instructions to register for a course that uses SAS Enterprise Miner, see [SAS OnDemand for Academics: Enterprise Miner Student Registration Instructions](#).
- To print step-by-step instructions to register for a course that uses SAS Forecast Studio, see [SAS OnDemand for Academics: Forecast Studio Student Registration Instructions](#).
- To print step-by-step instructions to register for a course that uses SAS Studio, see [SAS OnDemand for Academics: SAS Studio Registration Instructions](#).

---

**SAS Enterprise Miner: Sharing Homework Assignments**

**Introduction**

There are three ways that you can share homework assignments: either by creating and registering a project model package, by sharing a project model package, or by sharing a project diagram.

Ultimately, the choice is up to the instructor. The decision might be made based on whether the instructor needs access to project results or diagram files.

**Submit a Project Model Package**

To submit a project model package, complete these steps:
1 Create a project or open an existing project within SAS OnDemand for Academics: Enterprise Miner.

2 Highlight the appropriate node within a diagram.

3 Select **Actions ▶ Create Model Package**.

4 In the Input dialog box, enter a name for the model package. To ensure that you choose a unique filename, you might want to include your name or initials as part of the filename. This ensures that an instructor can distinguish one submitted model package from another.

5 From the Project Panel on the left side of SAS OnDemand for Academics: Enterprise Miner, expand the **Model Packages** folder.

6 Right-click on the appropriate model and then click **Save As**. You are prompted to save the model as a SAS Package File (.spk).

7 Share the appropriate .spk file with your instructor (through email or through a shared network directory).

---

**Submit an Exported Project Diagram**

To submit an exported project diagram to an Instructor, complete these steps:

1 Create a project or open an existing project within SAS OnDemand for Academics: Enterprise Miner. Ensure that your project includes a diagram.

2 From the Project Panel on the left side of SAS OnDemand for Academics: Enterprise Miner, expand the **Diagrams** folder.

3 Right-click on the appropriate diagram and then select **Save As**. Save the diagram as an XML file. To ensure that you choose a unique filename, you might want to include your name or initials as part of the filename. This ensures that an instructor can distinguish one submitted diagram from another.
Collaborating

Introduction

Students can collaborate with each other while using SAS OnDemand for Academics: Enterprise Miner in one of two ways:

- by saving an entire project as a model package and then sharing the model package
- by exporting project diagrams as XML files and then sharing those files with each other

The choice might be determined by whether the students need to share the results of a project. Exported diagrams do not contain results while model packages do.

Note: Neither model packages nor exported diagrams include the actual data that is referenced. To rerun the project, you must have access to the original data or have the LIBNAME that points to the original data if that data is stored on the SAS server.

Share a Project Model Package

To share a project model package, complete these steps:

1. Create a project or open an existing project within SAS OnDemand for Academics: Enterprise Miner.

2. Highlight the appropriate node within a diagram.

3. Select **Actions ➤ Create Model Package**.

4. In the Input dialog box, enter a name for the model package. To ensure that you choose a unique filename, you might want to include your name or initials as part of the filename. This ensures that your peers can distinguish one model package from another.

Share the XML file with your instructor (through email or through a shared network directory).
5 From the Project Panel on the left side of SAS OnDemand for Academics: Enterprise Miner, expand the Model Packages folder.

6 Right-click on the appropriate model package and then select Save As. Save the model package as an .spk file.

7 Share the .spk file as needed (through email or through a shared network directory).

Note: The user who receives the model package can start SAS OnDemand for Academics: Enterprise Miner and choose File ▶ Open Model Package to open the package and view the diagram and results. The user cannot make any changes or rerun the diagram nodes. However, the user can choose Action ▶ Recreate Diagram to re-create the diagram within the current project. Once the diagram is re-created, the user has a working copy of the diagram, just as if they imported the appropriate diagram.xml. The user must run a diagram path to produce any results.

Share a Project Diagram
To share a project diagram, complete these steps:

1 Create a project or open an existing project within SAS OnDemand for Academics: Enterprise Miner. Ensure that your project includes a diagram.

2 From the Project Panel on the left side of SAS OnDemand for Academics: Enterprise Miner, expand the Diagrams folder.

3 Right-click on the appropriate diagram and then select Save As. Save the diagram as an XML file. To ensure that you choose a unique filename, you might want to include your name or initials as part of the filename. This ensures that your peers can distinguish one diagram from another.

4 Share the XML file as needed (through email or through a shared network directory).

Use a Shared Project Diagram
To use a shared project diagram, complete these steps:

1 Start SAS OnDemand for Academics: Enterprise Miner.

2 Create a new project or open an existing project.
3 Select File ➤ Import Diagram from XML.

4 Import the appropriate diagram XML file.
SAS OnDemand for Academics: SAS Studio

SAS OnDemand for Academics: SAS Studio ........................................ 38

Confirm System Requirements .......................................................... 38
  Introduction ................................................................................. 38
  Connectivity ................................................................................ 38
  Verify Network Performance ......................................................... 39

Access and Use the Software .......................................................... 40
  Introduction ................................................................................. 40
  Access the SAS Servers ............................................................... 40
  Avoid Connection Time-outs ......................................................... 40
  SAS Servers Maintenance and Availability ...................................... 40
  Requesting SAS Servers Availability Notification ........................... 41

Review the Basics for Working with Data and Results ....................... 42
  Introduction ................................................................................. 42
  About Project Storage .................................................................... 42

Finding Help for Common Problems ................................................ 47
  Where to Go for Assistance? ......................................................... 47
  Commonly Asked Questions: SAS OnDemand for Academics: SAS Studio ........................................ 48
SAS OnDemand for Academics: SAS Studio

This chapter guides you through recommended steps for using SAS OnDemand for Academics: SAS Studio.

Confirm System Requirements

Introduction

A web browser is required to use SAS OnDemand for Academics: SAS Studio. SAS Studio currently supports Microsoft Internet Explorer 9+ (Microsoft Internet Explorer 10+ is recommended for certain features, such as the ability to drag and drop files), Google Chrome 21, Mozilla Firefox 14 on Windows 7, Mozilla Firefox 15 on Mac OS X, Apple Safari 5.1 on Windows 7, and Apple Safari 6.0 on Mac OS X. The use of both cookies and javascript must be enabled for the software to function properly. Both should be enabled by default in all modern browsers.

These versions were tested at the time of publication and newer versions of these web browsers might not work.

Various mobile devices might work with SAS Studio such as tablets and readers. SAS Studio supports iOS6 and above for Apple devices such as the iPad. The minimum display size (resolution) required to run SAS Studio is 1024 x 768 pixels (in either portrait or landscape mode).

Connectivity

If your wireless connection is lost, then a message is displayed stating that your network connection is no longer available. When the connection is available, the application attempts to reconnect automatically.
Avoid refreshing your web browser. This results in a loss of any work that has not been saved. Most web browsers provide a warning to let you know that your work will be lost if you choose to proceed with a page refresh or reload.

**Verify Network Performance**

If you plan to use SAS OnDemand for Academics where many people will use it at the same time, then you should verify the performance of the network that you plan to use (Internet bandwidth, wireless router capacity, and so on).

If the network performance is not sufficient, then you could experience slow or dropped connections to the hosted SAS servers that are used to perform SAS processing.

You can contact the appropriate network or IT department personnel to request additional information. Share the following information with them to ensure they gather accurate data:

- type of network connection that you plan to use (wireless, LAN, or other). In particular, wireless networks can be problematic as there are sometimes stricter limits to the capacity of concurrent users that they can support.
- number of people that will use SAS OnDemand for Academics concurrently.
- location of the lab or seminar.
- location of the hosted SAS servers (the answer is Cary, North Carolina at SAS Institute).

There are also a number of tools available through the Internet that you or the appropriate network personnel can use to check network performance. SAS also offers a tool that might help. To access this tool:

1  Go to the following website: http://netcheck.sas.com/ookla.

2  Select **Begin Test**.

**Note:** If you are not teaching in a lab or seminar setting, then each student must connect to the hosted SAS servers to perform processing using their own high-speed Internet connection. If individual students have network connection issues, they can try to use a computer on a different network or contact their Internet Service Provider.
Access and Use the Software

Introduction

Ideally, you should access and use the software ahead of time as SAS OnDemand for Academics software applications function slightly differently than their traditional SAS software counterparts. There are a number of resources available to help you.

Access the SAS Servers

You are prompted to connect to the SAS servers each time you start SAS OnDemand for Academics. The servers remotely process any submitted SAS files or projects and returns results to your computer.

If you are unable to use a SAS OnDemand for Academics software application to perform processing, make sure that you have a working Internet connection.

Avoid Connection Time-outs

Avoid leaving open connections on the servers. An open connection to the SAS servers will likely disconnect (time out) after one hour (or less) if the connection is idle (that is, you have not performed any processing). Many firewalls disconnect open sessions after an hour of idle time (or less). It is a best practice to complete your work, save it, and then exit all SAS OnDemand for Academics applications (including the Control Center) before you leave the computer.

SAS Servers Maintenance and Availability

SAS makes its best efforts to make the hosted servers available as much as possible and to keep unexpected downtime to a minimum. There could be limited times when the servers are unavailable because SAS is performing maintenance, testing, or performance enhancement tasks.
If server maintenance is needed, then SAS tries to perform this work during nontraditional usage hours to lessen any impact to users.

SAS uses the third Saturday of each month to perform scheduled maintenance on its systems (if needed). Therefore, the servers might be unavailable for a portion of time on the third Saturday of each month.

**Requesting SAS Servers Availability Notification**

If you would like to be notified when the SAS servers are unavailable due to extended maintenance or due to unforeseen circumstances, then subscribe to the SASONDEMANDSERVER-L mailing list. To subscribe, complete these steps:

1. Send email to LISTSERV@LISTSERV.SAS.COM.
2. In the body of the email, type `subscribe SASONDEMANDSERVER-L`.
3. Send the email (no subject line is needed). Follow any instructions that you receive via email.

To unsubscribe from SASONDEMANDSERVER-L, complete these steps:

1. Send email to LISTSERV@LISTSERV.SAS.COM.
2. In the body of the email, type `unsubscribe SASONDEMANDSERVER-L`.
3. Send the email (no subject line is needed).
Review the Basics for Working with Data and Results

Introduction

During the first week of class, you should review the basics of working with SAS data sets and results in SAS OnDemand for Academics: SAS Studio.

About Project Storage

Storing Data

By default, all SAS OnDemand for Academics: SAS Studio projects are stored on SAS servers. Due to the architecture of this offering, there is no way to save your projects locally.

There are two ways to store data for use with SAS OnDemand for Academics:

- If you are an instructor, then you can store data on the SAS servers. After you have stored this data, students can access the data using a LIBNAME or FILENAME statement that you provide to them.
- Instructors or students can store the data that they want to use on a data source that can connect to their PC. Sources could include a local file system, university space (such as AFS or NFS space), or even portable disk drives.

The following types of data files can be used in SAS Studio:

- .csv (comma delimited)
- .log
- .sas
- .txt (text file)

If other file types are opened in SAS Studio, then those file types might also be displayed. If other file types are displayed, they are Read only.
Accessing Data Using SAS OnDemand for Academics: SAS Studio

The SAS servers include sample SAS data sets that you might choose to use. In addition, if course files and SAS data sets have been uploaded to the SAS servers, then you can access these SAS data sets as well. To access the SAS data sets, complete these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.

   The SAS OnDemand for Academics Dashboard is displayed.


3. Open or create a new project.

4. Select Libraries in the navigation pane.

5. Double-click on the appropriate library (such as MAPS, SASHELP, or the library that you have assigned using a LIBNAME statement).

6. Double-click the SAS data set that you want to use.

Note: Remember that if you modify a SAS data set that exists on the SAS servers and you want to save that SAS data set, you must download the data set to a local drive. If you do not download the data set to a local drive, then your modifications are lost when you end your session.

In addition, some of the SAS data sets available from the SAS servers might be too large to download locally unless you have modified them to make them smaller. In this case, it is recommended that you work with the original SAS data sets only while connected to the SAS servers.

To easily reference your project, use the predefined macro &PROJECTS_DIR. Here is an example:

```sas
ods html path="&PROJECTS_DIR" file="test.html" sge=on;
proc sgplot data=sashelp.class;
vbar age;
run;
ods html close;
```
Working with Compressed SAS Data Sets

SAS does not recommend that you work with compressed SAS data sets when using SAS OnDemand for Academics: SAS Studio. If you have a compressed SAS data set, you can use the COMPRESS=NO option to remove compression.

Assigning LIBNAME and FILENAME Statements

The SAS servers are unable to recognize or access the local drives of your PC. Therefore, if your SAS program includes a LIBNAME or FILENAME statement that refers to a local path (such as a location on your C: drive), then you receive processing errors.

Instructors have the ability to store SAS data sets and other data files on the SAS servers.

Note: LIBNAME or FILENAME statements are case sensitive. Copy them or enter them in exactly as they are shown to avoid errors.

If you do have local SAS data sets that you want to use, it is recommended that you upload them. You can then refer to the uploaded SAS data sets in your code or in your projects. In addition, if you modify the SAS data sets that you upload and you want to use them again, you should download the SAS data sets from the SAS servers before exiting SAS OnDemand for Academics.

Accessing Data with LIBNAME or FILENAME Statements

Once a SAS data set or a data file has been uploaded to the SAS servers, users can access the data using the appropriate LIBNAME or a FILENAME statement. The LIBNAME or FILENAME statement to use is provided to you on your Dashboard.

To access this information at any time, complete these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   
   The SAS OnDemand for Academics Dashboard is displayed.


3. Create or open a SAS program.
4 Assign the LIBNAME or FILENAME statement in your code in order to access your data. Remember LIBNAME and FILENAME statements are case sensitive.

**Working with INFILE Statements**

An INFILE statement identifies an external data file to read with an INPUT statement. If you plan to use an INFILE statement or are asked to use an INFILE statement to access data, then you must use a fully qualified path in your statement.

For example, if country.dat exists in a course directory called `/courses/xxxxxxxxxxxxxxx`, then the INFILE statement to access this data file would be:

```
infile '/courses/xxxxxxxxxxxxxxx/country.dat';
```

However, if you specified a path that is not fully qualified (such as the following), then an error would be produced:

```
infile 'country.dat';
```

If you are an instructor and you uploaded data to the SAS servers for a specific class, then you can find the fully qualified path to your uploaded data by completing these steps:

1 Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click **Sign In**.

   The SAS OnDemand for Academics Dashboard is displayed.

2 Review the information in the **Course data directory** area to identify the LIBNAME or FILENAME statement.

   This information also identifies the fully qualified path for your course data. For example, a FILENAME statement for a specific course might look like the following:

   ```
   filename sample "'/courses/xxxxxxxxxxxxxxx/sample.csv";
   ```

   From this FILENAME statement, we can determine that the fully qualified path is the following:

   ```
   courses/xxxxxxxxxxxxxxx
   ```

3 If appropriate, share the fully qualified path with your students so that they know which path to use in their INFILE statement. INFILE statements are case sensitive.
Working with INFILE Statements and Microsoft Windows Data Files

If you import or upload a raw data file (such as a text file or a comma-separated-value file) from a PC using the Microsoft Windows operating system, the file might contain carriage-return characters. These carriage-return characters cause errors when you attempt to read the file on the UNIX version of SAS used by SAS OnDemand for Academics servers.

For example, using the following INFILE statement could cause data processing or data display errors:

```
infile newemps dlm=',';
```

These errors can be avoided by using the following INFILE statement:

```
infile newemps dlm=',' TERMSTR=CRLF;
```

For more information about the TERMSTR option, search for TERMSTR in SAS Product Documentation.

Saving Data

SAS OnDemand for Academics provides instructors with the ability to store data (if they choose to use this feature). This stored data can be used during subsequent sessions. However, if you created or modified a SAS data set that you want to be able to use in future SAS OnDemand for Academics: SAS Studio sessions, then you must save that SAS data set locally before ending your session.

Working with Results

You can download your results in the following file types from SAS Studio:

- .html
- .pdf
- .rtf

To download your results, select the Results tab and click either:

- Download as an HTML file
Finding Help for Common Problems

Where to Go for Assistance?

Review Commonly Asked Questions, SAS Notes, and SAS Documentation

Use the keyword “ondemand academics” to search for issues specific to SAS OnDemand for Academics from these sources:

- “Commonly Asked Questions: SAS OnDemand for Academics: SAS Studio” on page 48
- SAS Notes, a database of common technical issues
- SAS Product Documentation

SAS Analytics U Community

The SAS Analytics U Community is a social community where you can collaborate with SAS users in academia. This community is open to professors, students, and academic researchers who are using SAS OnDemand for Academics. Software usage issues are addressed in the community through resources such as discussion forums, e-Learning, video tutorials, and FAQs.

For issues that are related to registering software, deploying software, and connecting to the SAS cloud, send email to SASAnalyticsU@sas.com, call 800-727-0025 (option 2), or chat with us online during regular business hours.

Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for Academics, then contact your instructor. Instructors can point students toward educational resources and help ensure that offerings are used correctly.
Contact Your SAS Site Representative (If Applicable)

If you are an instructor at a university that already uses SAS software, then you might have a SAS Site Representative who can provide SAS support.

If you are unsure about whether you have a SAS Site Representative, contact the person or department that supports your university's software purchases and installation.

Commonly Asked Questions: SAS OnDemand for Academics: SAS Studio

- What Happened to SAS Web Editor?
  
  SAS Web Editor has been renamed as SAS Studio. If you previously used SAS Web Editor, then you can use SAS Studio.

- Does SAS OnDemand for Academics: SAS Studio have all the same features as SAS?
  
  Certain features of SAS OnDemand for Academics: SAS Studio have been disabled because they are not practical in this setting. For example, the ability to schedule projects is not available. Note that the online Help system documents all SAS Studio features, including those that might be unavailable in this offering.

- How do I log on to SAS OnDemand for Academics: SAS Studio?
  
  To log on to SAS OnDemand for Academics: SAS Studio, log on to the SAS OnDemand for Academics Control Center. At the top of the Dashboard, click **SAS Studio**.

- How do I find out more information about using SAS OnDemand for Academics: SAS Studio?
  
  After you log on to SAS Studio, you can refer to the options in its **Help** menu. You can also refer to Appendix 2, “Learning Resources for SAS OnDemand for Academics,” on page 133.

- Can I access the Program Editor, Log, and Output windows using SAS OnDemand for Academics: SAS Studio?
Yes. Select the **Code** tab to access the Program Editor. Select the **Log** tab to see the SAS log. Select the **Results** tab to see the results.

- **How do I work with data in SAS OnDemand for Academics: SAS Studio?**
  SAS OnDemand for Academics: SAS Studio works in conjunction with the SAS servers. The easiest way to work with data is to ensure that the SAS servers have access to that data. You can do this by using existing sample data sets on the SAS servers, uploading data files to the SAS servers, or accessing data that an instructor has chosen to store on the SAS servers.

- **Does SAS Studio save my files when I sign out or close my browser?**
  No, SAS Studio cannot automatically save files. This action must be taken manually. Unless you are using the Apple Safari browser, you are prompted by the application to save your files if they contain unsaved changes.

  Apple Safari prompts you only when you sign out. If you exit the browser, close the browser tab, refresh the browser page, or navigate to a different browser page, Safari does not prompt you, and your unsaved changes are lost.

- **How do I share data with other users who are using SAS OnDemand for Academics: SAS Studio?**
  Instructors also have the ability to store data on the SAS servers. Once the data is stored, instructors can share a LIBNAME or FILENAME statement with users so that they can access the data.

- **How do I upload local data files from my PC to the SAS servers?**
  You can upload local SAS data sets to the SAS servers for processing. For more information, see “Uploading Course Files to the SAS Server” on page 17.

- **I have uploaded a file using SAS Studio, but am receiving errors when using the file in my code. What is the issue?**
  If the file (or files) that you uploaded were created using Microsoft Windows or Macintosh operating systems, then the issue could be related to the file format. SAS Studio processes files using UNIX.

  To resolve the file format compatibility issues between Windows, Macintosh, and UNIX, you need to include a FILENAME statement that uses the TERMSTR option.
If you are using a file created with the Microsoft Windows operating system, use the TERMSTR=CRLF option, such as in the following example:

FILENAME cars "\home/<username>/Projects/data/cars.txt" TERMSTR=CRLF

If you are using a file created with the Macintosh operating system, use the TERMSTR=CR option, such as in the following example:

FILENAME cars "\home/<username>/Projects/data/cars.txt" TERMSTR=CR;

The filenames and paths listed above are for example purposes only. Your values might vary.

- Can I use data other than SAS data sets?
  Yes. If you want to work with data other than SAS data sets (such as comma-delimited files or text files), you can import the files in to SAS OnDemand for Academics: SAS Studio. For more information about importing data, see “Uploading Other Data Formats on the SAS Server” on page 16.

- I am an instructor. Should I store Microsoft Excel files (.xls) on the SAS servers?
  No. If you need to store data that exists within a Microsoft Excel file (.xls) and then access it using a FILENAME statement, we suggest you first save the Microsoft Excel file as a comma-separated-value (.csv) file. You can then store the .csv file on the SAS servers. For more information, see “Accessing Data with LIBNAME or FILENAME Statements” on page 18 and “Uploading Other Data Formats on the SAS Server” on page 16.

- My code is not producing any graphs. What am I doing wrong?
  SAS Studio supports only the default device of PNG for HTML. If you specify devices such as GIF, JPEG, ACTXIMG, ACTIVEX, and so on, then your graphs are not produced and there are no warnings or errors.

- Does SAS Studio provide support for Java, ActiveX, and SVG device types?
  SAS Studio does not provide support for Java or ActiveX device types. SVG should be supported on all web browsers.

- I am trying to use an INFILE statement to access data, but it is causing errors. How should I use an INFILE statement?
You must use a fully qualified path when using an INFILE statement within SAS OnDemand for Academics: SAS Studio. In addition, INFILE statements are case sensitive. Ensure that you are entering the INFILE statement appropriately. Refer to “Working with INFILE Statements” on page 45.

- I uploaded a file and am referring to the file using an INFILE statement, but not all of the fields are being read correctly. What is happening?

This could be the result of uploading a text file or a comma-separated-value file from a PC that uses the Microsoft Windows operating system. Adding the TERMSTR option to your INFILE statement might correct the issue.

- I have copied code in to the code (Program) window, but I am getting errors when I try to run the code. What is happening?

This could be the result of hidden or special characters in the code that you copied in to the code window. One way to resolve this issue is to simply enter the code instead of copying the code. If the amount of code is too much to enter, then you could try saving the code as a text file to remove any special characters or formatting and then copying the code in to the code window. For more information and options, search for SAS Note 16658 on http://support.sas.com/notes.

- How do I save my projects or files from within SAS OnDemand for Academics: SAS Studio?

Save your work to a project file within SAS Studio. You can then click Projects Download from the Projects that are in the navigation pane to save your work to your Downloads directory on your PC.

- I have to create my file shortcuts every time I log on to SAS Studio. Is there a way that they can be saved once and be available for each session?

You can add your file shortcut to your Autoexec file when you either create a new file shortcut or by selecting Edit Autoexec File from in the banner. The $, @, &, and # characters cannot be used in file shortcuts. To validate the syntax that you entered in the autoexec file, click Run.

- I cannot seem to print anything from SAS Studio.
In order for printing to work in SAS Studio, any pop-up blockers must be disabled for the site.

- I would like to save my HTML output as one file. How do I do that?
  To save your plots in your results in one file for sharing, submitting for review, printing, and so on, open an ODS PDF destination in your code and write the results directly into the projects space. For more information about the ODS PDF destination, see the *SAS Output Delivery System: User’s Guide*.

You can change the options for a default SAS Studio destination by specifying its ID. For example, to change the style that is displayed in the default results of SAS Studio, use the following code:

```bash
ods html (id=web) style=sasweb;
ods pdf (id=web) style=sasweb;
ods rtf (id=web) style=sasweb;
```

- I cannot view my results or log after I click **Download as an HTML file**.
  If you click **Download as an HTML file** in the Results or Log tab and open the HTML that is produced in a browser other than the browser in which you are using for your active session, then you receive a 404 (file not found) error. Make sure that the browser that you have set as your default browser is the same one in which you are using SAS Studio. You can also download your results as a PDF or RTF file in order to preserve the images.

- I cannot view my file shortcuts on my tablet. Why not?
  File shortcuts are not supported for the mobile version of SAS Studio.

- When using the Apple Safari browser, can I upload multiple files to a project all at once?
  Yes, if you are using Apple Safari 6 or greater. If you are using an older version of Apple Safari, then you can upload only one file to a project at a time.

- After generating a large amount of output (such as HTML), my browser seems to crash. What is happening?
  SAS Studio is not currently designed to support large amounts of output. The browser runs out of memory. This is more apparent with mobile browsers, which typically have less memory.
Are there any search capability limitations within SAS OnDemand for Academics: SAS Studio?

Yes. Currently, search strings are not case sensitive and spaces are treated as part of the string, not as AND or OR variables.

Can I edit my ODS graphics in SAS Studio?

You can download the ODS Graphics Editor directly from SAS Studio. The SAS ODS Graphics Editor is an interactive graphical application used to edit and annotate ODS graphics that are created by a wide variety of SAS procedures. You can save the results as an image for inclusion in a report or as an SGE file that you can edit in the future.

To download the stand-alone ODS Graphics Editor, complete these steps:

1. Select **Tools ▶ Install ODS Graphics Editor** from in the banner. The ODS Graphics Editor Download Packages page is displayed.

2. Follow the instructions in the section named “Using a Stand-Alone ODS Graphics Editor” in the *SAS ODS Graphics Editor: User's Guide* to complete the installation and start using the stand-alone ODS Graphics Editor.

Can I create ODS graphics in SAS Studio?

You can download the ODS Graphics Designer directly from SAS Studio. The ODS Graphics Designer is an interactive graphical application that you can use to create and design custom graphs. The designer creates graphs that are based on the Graph Template Language (GTL), which is the same language that is used by SAS analytical procedures and SAS ODS Graphics procedures. The ODS Graphics Designer provides a graphical user interface so that you can design graphs easily without knowing the details of templates and the GTL.

To install the ODS Graphics Designer, complete these steps:

1. Select **Tools ▶ Install ODS Graphics Designer** from in the banner. The ODS Graphics Editor Download Packages page is displayed.
2 After the ODS Graphics Designer is installed, select **Tools ➤ ODS Graphics Designer** from in the banner. For more information about the ODS Graphics Designer, see the *SAS ODS Graphics Designer: User's Guide*.

**Note:** The ODS Graphics Designer is available only in Windows environments. It is not available on the Mac or iPad.
SAS OnDemand for Academics: Enterprise Guide

SAS OnDemand for Academics: Enterprise Guide ........................................... 56

Confirm System Requirements ................................................................. 56
  Confirm Requirements for Full Support .............................................. 56
  Verify Network Performance .............................................................. 57

Access and Use the Software ................................................................. 58
  Introduction ....................................................................................... 58
  Install SAS Enterprise Guide ............................................................ 58
  Access the SAS Servers ..................................................................... 59
  Avoid Connection Time-outs .............................................................. 60
  SAS Servers Maintenance and Availability ....................................... 60
  Requesting SAS Servers Availability Notification ............................ 60

Review the Basics for Working with Data and Results .......................... 61
  Working with Data ........................................................................... 61
  Working with Results ....................................................................... 69

Finding Help for Common Problems ...................................................... 71
  Where to Go for Assistance? .............................................................. 71
  Commonly Asked Questions: SAS OnDemand for Academics: Enterprise Guide .......................... 72
SAS OnDemand for Academics: Enterprise Guide

This chapter guides you through recommended steps for registering for SAS OnDemand for Academics, preparing to teach courses, and supporting students while using SAS software.

Confirm System Requirements

Confirm Requirements for Full Support

In order for SAS OnDemand for Academics: Enterprise Guide to be fully supported, your system must meet the following requirements.

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating systems</td>
<td>Microsoft Windows 7 Home Premium and above (32-bit or 64-bit) (with Service Pack 1) or Microsoft Windows 8 (32-bit or 64-bit) (including Microsoft Windows 8.1). Macintosh operating systems are not supported. Microsoft Windows Media Center is not supported. Microsoft Windows XP is not supported.</td>
</tr>
<tr>
<td>Internet browser</td>
<td>Microsoft Internet Explorer 8 and above. Other Internet browsers might work but have not been fully tested and are not supported by SAS.</td>
</tr>
<tr>
<td>Hard disk space</td>
<td>Approximately 80 MB of free hard disk space. You are prompted to install Microsoft .NET if it is not on your machine. This requires additional disk space.</td>
</tr>
</tbody>
</table>
Only one version of SAS Enterprise Guide can be installed on a machine at one time. For example, if traditional SAS Enterprise Guide is installed, then installing SAS OnDemand for Academics: Enterprise Guide on the same machine is not recommended.

**Verify Network Performance**

If you plan to teach in a lab setting or a seminar setting in which many students will access and use SAS OnDemand for Academics software applications at the same time, then you should verify the performance of the network that you plan to use (Internet bandwidth, wireless router capacity, and so on). If the network performance is not sufficient, then your students could experience slow or dropped connections to the hosted SAS servers that are used to perform SAS processing.

You can contact the appropriate network or IT department personnel to request additional information. Share the following information with them to ensure they gather accurate data:

- type of network connection that you plan to use (wireless, LAN, or other). In particular, wireless networks can be problematic as there are sometimes stricter limits to the capacity of concurrent users that they can support.

- number of students that will use SAS OnDemand for Academics concurrently.
location of the lab or seminar.

- location of the hosted SAS servers (the answer is Cary, North Carolina at SAS Institute).

There are also a number of tools available through the Internet that you or the appropriate network personnel can use to check network performance. SAS also offers a tool that might help. To access this tool:

1. Go to the following website: http://netcheck.sas.com/ookla.

2. Select **Begin Test**.

**Note:** If you are not teaching in a lab or seminar setting, then each student must connect to the hosted SAS servers to perform processing using their own high-speed Internet connection. If individual students have network connection issues, they can try to use a computer on a different network or contact their Internet Service Provider.

---

**Access and Use the Software**

**Introduction**

Ideally, you should access and use the software ahead of time as SAS OnDemand for Academics software applications function slightly differently than their traditional SAS software counterparts. There are a number of resources available to help you.

**Install SAS Enterprise Guide**

To use SAS Enterprise Guide from your SAS OnDemand for Academics account, you must first install a copy of the software on your computer. To install SAS Enterprise Guide software, complete these steps:

**Note:** You should install only one version of SAS Enterprise Guide on your computer (either a local installation of SAS Enterprise Guide or SAS Enterprise Guide from your OnDemand for Academics account).
1 Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.

   The SAS OnDemand for Academics Dashboard is displayed.

2 Scroll to the bottom of your Dashboard to see a table that lists the courses that you have registered for.

3 Locate SAS Enterprise Guide under Applications. Click the Download Required link.

4 Click Request Download in the table.

   Note: If you are not already logged on to your SAS Profile, then you need to log on.

5 Click Download and then save the .exe file to a location on your computer.

   After the software client is downloaded and installed, you can begin using the software and accessing the SAS servers.

   For step-by-step guidance including graphics, you can view the following items:

   - SAS OnDemand for Academics: Enterprise Guide Instructor Registration Instructions
   - SAS OnDemand for Academics: Enterprise Guide Student Registration Instructions
   - SAS OnDemand for Academics website

Access the SAS Servers

You are prompted to connect to the SAS servers each time you start SAS OnDemand for Academics: Enterprise Guide. The servers remotely process any submitted SAS files or projects and returns results to your computer.

If you are unable to use a SAS OnDemand for Academics software application to perform processing, make sure that you have a working Internet connection.
Avoid Connection Time-outs

Avoid leaving open connections on the servers. An open connection to the SAS servers will likely disconnect (time out) after one hour (or less) if the connection is idle (that is, you have not performed any processing). Many firewalls disconnect open sessions after an hour of idle time (or less). It is a best practice to complete your work, save it, and then exit all SAS OnDemand for Academics applications (including the Control Center) before you leave the computer.

SAS Servers Maintenance and Availability

SAS makes its best efforts to make the hosted servers available as much as possible and to keep unexpected downtime to a minimum. There could be limited times when the servers are unavailable because SAS is performing maintenance, testing, or performance enhancement tasks.

- If server maintenance is needed, then SAS tries to perform this work during nontraditional usage hours to lessen any impact to users.
- SAS uses the third Saturday of each month to perform scheduled maintenance on its systems (if needed). Therefore, the servers might be unavailable for a portion of time on the third Saturday of each month.

Requesting SAS Servers Availability Notification

If you would like to be notified when the SAS servers are unavailable due to extended maintenance or due to unforeseen circumstances, then subscribe to the SASONDEMANDSERVER-L mailing list:

- Send email to LISTSERV@LISTSERV.SAS.COM.
- In the body of the email, type subscribe SASONDEMANDSERVER-L.
- Send the email (no subject line is needed). Follow any instructions that you receive via email.
To unsubscribe from SASONDEMANDSERVER-L, complete these steps:

- Send email to LISTSERV@LISTSERV.SAS.COM.
- In the body of the email, type unsubscribe SASONDEMANDSERVER-L.
- Send the email (no subject line is needed).

---

**Review the Basics for Working with Data and Results**

**Working with Data**

**Introduction**

Before a course begins, you should review the basics of uploading and downloading files from the SAS servers.

**Storing Data**

There are two ways to store data for use with SAS OnDemand for Academics:

- You can store data on the SAS servers. After you have stored this data, students can access the data using a LIBNAME or FILENAME statement that is provided to them.
- You can store the data that you want to use on a data source that can connect to your PC. Sources could include a local file system, university space (such as AFS or NFS space), or even portable disk drives.

**Uploading Data Files to the SAS Servers**

If the data that you want to use is not already available from the SAS servers, then you can use the **Upload Data Files to Server** task available within SAS OnDemand for Academics: Enterprise Guide.

The **Upload Data Files to Server** task enables you to select one or more SAS data sets (*.sas7bdat) from your local Microsoft Windows file system and copy them to the
SAS servers for processing. You must perform this step in order to work with any local SAS data sets because the SAS servers cannot access any data on your local drives.

The task generates a log that summarizes the data files that were copied, the byte size, timings for each file and for all of the files as a group, and any errors that occurred during the transfer. By default, all data files are added as output data in your SAS Enterprise Guide project so that they can be used in the project.

**Note:** Because any modifications that you make to the data will not be saved once you end your session, you might want to download any data files that you have changed from the SAS servers to your local PC after you have finished your work.

To upload a data set, complete these steps:

1. Select the SAS data sets to upload.
2. Specify the upload options.

To select the SAS data sets to upload, complete these steps:

1. Select **Tasks ▶ Data ▶ Upload Data Files to Server**.
   
   The Upload Data Files to Server window is displayed.

2. Select **Add** to select the SAS data sets that you want to copy. The Open dialog box is displayed.

3. Select the name of the file that you want to copy. To select more than one file, hold down the Ctrl key while selecting the files that you want to add. Files must be SAS7BDAT files.

4. Select **Open** to add the files to the list of data sets that you want to copy. Note that all files that are copied are given lowercase names on the target servers.

5. Select **Next** to specify the upload options.

   The Upload Data Files to Server window is displayed. This window specifies the name of the SAS server and the destination SAS library for your project. To specify the upload options:
If you want to overwrite any existing files on the SAS servers that have the same name as the files that you are copying, select the **Overwrite existing files with the same name** check box. By default, existing files are not overwritten.

If you do not want to add the data sets that you are copying to your current SAS Enterprise Guide project, clear the **Add data files to your current project** check box. By default, the copied data sets are added to the current project.

**Note:** The SAS Server for SAS OnDemand for Academics is selected by default, and cannot be changed.

**Note:** The WORK library is the destination SAS library by default and should not be changed. The WORK library is specified because it is the only location on the SAS server that you have the ability to temporarily store data for processing. Selecting any library other than WORK results in an error.

6 Select **Finish** to copy the data sets to the SAS servers. A log is created and is displayed in the SAS Enterprise Guide Project Explorer.

**Downloading Data Files from the SAS Servers**

The Download Data Files to PC task enables you to select one or more SAS data sets (*.sas7bdat) from the SAS servers and copy them to your local Microsoft Windows file system. It is important to complete this step if you have modified any SAS data sets that you want to use again in the future.

The task generates a log that summarizes the data files that were copied, the byte size, timings for each file and for all of the files as a group, and any errors that occurred during the transfer.

To download a data set, complete these steps:

1 Select the SAS data sets to download.

2 Specify the download options.

To select the SAS data sets to download, complete these steps:

1 Select **Tasks** ▶ **Data** ▶ **Download Data Files to PC**.

The Download Data Files to PC window is displayed.
2 Select Add to select the SAS data sets that you want to copy. The Open dialog box is displayed.

3 Select the name of the file that you want to copy. To select more than one file, hold down the Ctrl key while selecting the files that you want to add. Files must be SAS7BDAT files. All files that are copied are given lowercase names in the target folder.

4 Select Open to add the files to the list of data sets that you want to copy.

5 Select Next. The Download Data Files to PC window is displayed. To specify the download options, follow these steps:
   - Enter the path of the folder to which you want to copy the files or select Browse to select a folder. The default location is your My Documents folder.
   - If you want to overwrite any existing files in your PC folder that have the same name as the files that you are copying, select the Overwrite existing files with the same name check box. By default, existing files are not overwritten.

6 Select Finish to copy the data sets. A log is created and is displayed in the SAS Enterprise Guide Project Explorer.

Accessing Data Using SAS OnDemand for Academics: Enterprise Guide

The SAS servers include sample SAS data sets that you might choose to use. In addition, if course files and SAS data sets have been uploaded to the SAS servers, then you can access these SAS data sets as well. To access the SAS data sets, complete these steps:

1 Start SAS OnDemand for Academics: Enterprise Guide and log on.

2 Select File ➤ Open ➤ Data.

3 Select Servers.

4 Double-click SAS Apps.

5 Double-click Libraries.
6 Double-click on the appropriate library (such as MAPS, SASHELP, or the library that you have assigned using a LIBNAME statement).

7 Double-click the SAS data set that you want to use.

Note: Remember that if you modify a SAS data set that exists on the SAS servers and you want to save that SAS data set, you must download the data set to a local drive. If you do not, your modifications are lost when you end your session.

In addition, some of the SAS data sets available from the SAS servers might be too large to download locally unless you have modified them to make them smaller. In this case, it is recommended that you work with the original SAS data sets only while connected to the SAS servers.

Accessing Grayed-out SAS Libraries from the SAS Servers
The SAS servers include sample SAS data sets that you might choose to use. Some of the sample SAS libraries might appear to be grayed out, but they are still available for use.

Typically, grayed-out SAS libraries appear for users in Europe and were originally intended for use with another SAS software application, such as SAS Enterprise Miner.

1 Start SAS OnDemand for Academics: Enterprise Guide and log on.

2 Select File ➔ Open ➔ Data.

3 Select Servers.

4 Double-click SAS Apps.

5 Double-click Libraries.

6 Right-click on the grayed-out SAS library that you would like to access and then click Assign.

7 Double-click the SAS data set that you want to use.
Uploading Data Files to the SAS Servers versus Opening SAS Data Sets

If you have access to a local SAS data set, you can choose File ▶ Open ▶ Data and select the appropriate SAS data set. However, this is not the preferred method. Instead, the preferred method is to upload the SAS data set to the SAS servers. This improves data transfer speed and ensures that the step is recorded as part of your project.

Working with Data Files Other Than SAS Data Sets

If you want to work with data other than SAS data sets (such as comma-delimited files or text files), you can import the files into SAS OnDemand for Academics: Enterprise Guide. To import files that are not SAS data sets, complete these steps:

1. Select File ▶ Import Data.
2. Select Local Computer.
3. Find and select the data file that you want to use.

Working with Compressed SAS Data Sets

SAS does not recommend that you work with compressed SAS data sets when using SAS OnDemand for Academics: Enterprise Guide. If you have a compressed SAS data set, you can use the COMPRESS=NO option to remove compression.

Assigning LIBNAME and FILENAME Statements

The SAS servers are unable to recognize or access the local drives of your PC. Therefore, if your SAS program includes a LIBNAME or FILENAME statement that refers to a local path (such as a location on your C: drive), then you receive processing errors.

Note: LIBNAME or FILENAME statements are case sensitive. Copy them or enter them in exactly as they are shown to avoid errors.

If you do have local SAS data sets that you want to use, it is recommended that you upload them. You can then refer to the uploaded SAS data sets in your code or in your projects. In addition, if you modify the SAS data sets that you upload and you want to use them again, you should download the SAS data sets from the SAS servers before exiting SAS OnDemand for Academics.
Accessing Data with LIBNAME or FILENAME Statements

Once a SAS data set or a data file has been uploaded to the SAS servers, you can access the data using the appropriate LIBNAME or a FILENAME statement. The LIBNAME or FILENAME statement to use is provided on your Dashboard.

To access this information at any time, complete these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   
   The SAS OnDemand for Academics Dashboard is displayed.


3. Create or open a SAS program.

4. Assign the LIBNAME or FILENAME statement in your code in order to access your data. Remember LIBNAME and FILENAME statements are case sensitive.

Working with INFILE Statements

An INFILE statement identifies an external data file to read with an INPUT statement. If you plan to use an INFILE statement or are asked to use an INFILE statement to access data, then you must use a fully qualified path in your statement.

For example, if country.dat exists in a course directory called /courses/xxxxxxxxxxxxxxx, then the INFILE statement to access this data file would be:

   infile '/courses/xxxxxxxxxxxxxxx/country.dat';

However, if you specified a path that is not fully qualified (such as the following), then an error would be produced:

   infile 'country.dat';

If you are an instructor and you uploaded data to the SAS servers for a specific class, then you can find the fully qualified path to your uploaded data by completing these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
The SAS OnDemand for Academics Dashboard is displayed.

2 From the Course table, locate the appropriate course.

3 Click the Info link.

4 Review the information to identify the LIBNAME or FILENAME statement for your course. This information also identifies the fully qualified path for your course data. For example, a FILENAME statement for a specific course might look like the following:

```plaintext
filename sample "/courses/xxxxxxxxxxxxx/sample.csv";
```

From this FILENAME statement, we can determine that the fully qualified path is `courses/xxxxxxxxxxxxxx`

5 If appropriate, share the fully qualified path with your students so that they will know which path to use in their INFILE statement. INFILE statements are case sensitive.

If you are a student, then you must use the INFILE statement (with the fully qualified path) that your instructor provides. Only instructors have the ability to upload data files to the SAS servers.

**Working with INFILE Statements and Microsoft Windows Data Files**

If you import or upload a raw data file (such as a text file or a comma-separated-value file) from a PC using the Microsoft Windows operating system, the file might contain carriage-return characters. These carriage-return characters cause errors when you attempt to read the file on the UNIX version of SAS used by SAS OnDemand for Academics servers.

For example, using the following INFILE statement could cause data processing or data display errors:

```plaintext
infile newemps dlm=',';
```

These errors can be avoided by using the following INFILE statement:

```plaintext
infile newemps dlm=',' TERMSTR=CRLF;
```
For more information about the TERMSTR option, search for TERMSTR in SAS Online Documentation.

**Saving Data**

SAS OnDemand for Academics provides instructors with the ability to store data (if they choose to use this feature). This stored data can be used during subsequent sessions. However, if you created or modified a SAS data set that you want to be able to use in future SAS OnDemand for Academics: Enterprise Guide sessions, then you must save that SAS data set locally before ending your session.

**Saving Work**

SAS OnDemand for Academics: Enterprise Guide is unable to store your work on the SAS servers. Instead, you must save any work (SAS Enterprise Guide projects, SAS files, output files, and so on) to a hard disk drive that you can access before ending your session.

To save any work within SAS OnDemand for Academics: Enterprise Guide, start by selecting one of the following options:

- To save a file, choose File ▶️ Save or File ▶️ Save As.
- To save a project, choose File ▶️ Save Project or File ▶️ Save Project As.

**Working with Results**

**Introduction**

With SAS OnDemand for Academics: Enterprise Guide, you have the ability to select the type of result format that you want to produce. By default, the result format is set to HTML.

**Working with the PDF Result Format**

If you choose to use the PDF result format, then certain graphics appear distorted unless you also change the default graph format to GIF or JPEG.

To use the PDF result format and ensure that graphs render appropriately, complete these steps:
Open SAS OnDemand for Academics: Enterprise Guide.

Select Tools ▶ Options.

From the left side of the screen, select Results General from the tree.

Select PDF.

From the left side of the screen, select Graph from the tree.

From the Graph Format menu, select GIF or JPEG.

**Result Formats and Associated Graph Formats**

The default graph format is ActiveX, which typically provides the best results for HTML and SAS Report result formats. If you need to use a result format such as PDF, which does not support interactive graphics types, you must also change the graph format to a static device type such as GIF or JPEG. The following table references result formats and the graph formats that each supports.

**Table 6.1 Result Formats**

<table>
<thead>
<tr>
<th>Result Format</th>
<th>Supported Graph Formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML</td>
<td>ActiveX, Java, GIF, JPEG, SAS EMF</td>
</tr>
<tr>
<td>SAS Report</td>
<td>ActiveX, GIF, JPEG</td>
</tr>
<tr>
<td>PDF</td>
<td>GIF, JPEG, SAS EMF</td>
</tr>
<tr>
<td>RTF</td>
<td>ActiveX, GIF, JPEG, SAS EMF</td>
</tr>
<tr>
<td>Text (Listing)</td>
<td>None</td>
</tr>
</tbody>
</table>
Finding Help for Common Problems

Where to Go for Assistance?

Review Commonly Asked Questions, SAS Notes, and SAS Documentation

Use the keyword “ondemand academics” to search for issues specific to SAS OnDemand for Academics from these sources:

- “Commonly Asked Questions: SAS OnDemand for Academics: Enterprise Guide” on page 72
- SAS Notes, a database of common technical issues
- SAS Product Documentation

SAS Analytics U Community

The SAS Analytics U Community is a social community where you can collaborate with SAS users in academia. This community is open to professors, students, and academic researchers who are using SAS OnDemand for Academics. Software usage issues are addressed in the community through resources such as discussion forums, e-Learning, video tutorials, and FAQs.

For issues that are related to registering software, deploying software, and connecting to the SAS cloud, send email to SASAnalyticsU@sas.com, call 800-727-0025 (option 2), or chat with us online during regular business hours.

Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for Academics, then contact your instructor. Instructors can point students toward educational resources and help ensure that offerings are used correctly.
Contact Your SAS Site Representative (If Applicable)

If you are an instructor at a university that already uses SAS software, then you might have a SAS Site Representative who can provide SAS support.

If you are unsure about whether you have a SAS Site Representative, contact the person or department that supports your university's software purchases and installation.

Commonly Asked Questions: SAS OnDemand for Academics: Enterprise Guide

- Does SAS OnDemand for Academics: Enterprise Guide have all the same features as SAS Enterprise Guide?

  Certain features of SAS OnDemand for Academics: Enterprise Guide have been disabled because they are not practical in this setting. For example, the ability to schedule projects is not available. Note that the online Help system documents all SAS Enterprise Guide features, including those that might be unavailable in this offering.

- Can I download SAS OnDemand for Academics clients on to more than one machine?

  Yes. For example, you might download a client on to a personal computer at home as well as a laptop if you use both machines to complete assignments.

- I am using the keyboard to install SAS OnDemand for Academics: Enterprise Guide. How do I change focus on the initial installation window?

  - When the initial installation window is displayed, the focus is on Step 1: Verify System Requirements. To select this option, press Enter.
  
  - After Step 1 has completed, you must press Tab to move focus to Step 2 (Install SAS Enterprise Guide).
  
  - After you have moved the focus to Step 2, press Enter to begin the SAS Enterprise Guide installation process.

- I have installed SAS OnDemand for Academics: Enterprise Guide, but I am not being prompted to log on to it when I start the application. What should I do?
Make sure that you ran the System Requirements Wizard during installation. When you start the process of installing SAS OnDemand for Academics: Enterprise Guide, an initial installation window provides you with two choices:

1. Verify System Requirements

2. Install SAS Enterprise Guide

If you did not perform Step 1 (Verify System Requirements), then Microsoft .NET is not installed and will likely cause the error that you are experiencing.

To correct the situation, simply start the setup.exe file that you downloaded from the SAS Download Manager. When the installation window is displayed, choose Step 1. After the System Requirements Wizard runs and installs Microsoft .NET on your machine, you should be able to use SAS OnDemand for Academics: Enterprise Guide.

Note: If Microsoft .NET stops responding during the installation process, then follow the instructions in SAS Note 16884 at http://support.sas.com/notes/.

For more information and possible answers to your issue, review the following SAS Usage Notes:

- SAS Note 34715
- SAS Note 20939
- SAS Note 20437

How do I log on to SAS OnDemand for Academics: Enterprise Guide?

To log on to SAS OnDemand for Academics: Enterprise Guide, complete these steps:

1. From your desktop, double-click the SAS Enterprise Guide icon.
   
   The Credentials Required dialog box is displayed.
   
   You must use this window to log on to the SAS servers (the SAS Metadata Repository) so that you can perform SAS processing.
2 In the **User** field, enter your SAS profile user ID. This user ID is also displayed under your name on your SAS OnDemand for Academics Dashboard.

3 In the **Password** field, enter your SAS profile password. There are two times when you might have supplied a SAS profile password: either when you originally created a SAS profile or when you registered for SAS OnDemand for Academics.

4 Click **OK**.

- **How do I find out more information about using SAS OnDemand for Academics: Enterprise Guide?**

  After you have downloaded and installed the client software application that you plan to use, you can refer to the options on its **Help** menu. You can also refer to **Appendix 2**, “Learning Resources for SAS OnDemand for Academics,” on page 133.

- **Can I access the Program Editor, Log, and Output windows using SAS OnDemand for Academics: Enterprise Guide?**

  Yes. You can access and use traditional SAS Programming windows. For example, select **File** ▶ **New** ▶ **Program**, **File** ▶ **New** ▶ **File**, or **File** ▶ **Open** ▶ **Program** to access the Program Editor. After you run a SAS program, the Log and Output windows appear (if appropriate).

- **How do I work with data in SAS OnDemand for Academics: Enterprise Guide?**
SAS OnDemand for Academics: Enterprise Guide works in conjunction with the SAS servers. The easiest way to work with data is to ensure that the SAS servers have access to that data. You can do this by using existing sample data sets on the SAS servers, uploading data files to the SAS servers, or accessing data that an instructor has chosen to store on the SAS servers.

How do I share data with other users who are using SAS OnDemand for Academics: Enterprise Guide?

If you have data that you want to share with other users, then you must place it in a location that others can access, such as a shared network drive. Users can then access the data in one of two ways:

- Users can select **File ▶ Open**, and then choose **Project, Data**, or **Program**. A user can then select the **Local Computer** source and navigate to the drive and directory path that contains the data that you want them to use.

- Users can select **Tasks ▶ Data ▶ Upload Data Files to Server**. The user is given the option of navigating to the appropriate drive and directory to find the SAS data set that you want them to use. This data is then uploaded to the SAS servers and made available for processing.

**Note:** This is the preferred method for sharing SAS data sets because it is faster than opening a SAS data set. Instructors also have the ability to store data on the SAS servers. Once the data is stored, instructors can share a LIBNAME or FILENAME statement with users so that they can access the data.

How do I upload local data files from my PC to the SAS servers?

You can use SAS OnDemand for Academics: Enterprise Guide to upload local SAS data sets to the SAS servers for processing. From SAS Enterprise Guide, select **Tasks ▶ Data ▶ Upload Data Files to Server**. Then follow the steps in the wizard that is displayed. See “Uploading Course Files to the SAS Server” on page 17.

How do I download data files from the SAS servers to my PC?

You can use SAS OnDemand for Academics: Enterprise Guide to download SAS data sets from the SAS servers to your PC. From SAS Enterprise Guide, select **Tasks ▶ Data ▶ Download Data Files to PC**. Then follow the steps in the wizard
that is displayed. See “Accessing Course Files Stored on the SAS Server” on page 18.

- I am an instructor. I do not see the SAS data sets that I am storing on the SAS servers from within SAS OnDemand for Academics: Enterprise Guide. What's wrong?

  If you uploaded SAS data sets to the SAS servers that has mixed case or uppercase names, then these SAS data sets might not be visible (even though you could still refer to them using SAS code). You can rename the appropriate SAS data sets and upload them to the SAS servers again to correct the issue.

- Can I use data other than SAS data sets?

  Yes. If you want to work with data other than SAS data sets (such as comma-delimited files or text files), you can import the files in to SAS OnDemand for Academics: Enterprise Guide. To import other data, complete these steps:

  1. Select **File ▶ Import Data**.

  2. Select **Local Computer**.

  3. Find and select the data file that you want to use.

- I am an instructor. Can I store Microsoft Excel files (.xls) on the SAS servers?

  No. If you need to store data that exists within a Microsoft Excel file (.xls) and then access it using a FILENAME statement, we suggest you first save the Microsoft Excel file as a comma-separated-value (.csv) file. You can then store the .csv file on the SAS servers. For more information, see “Accessing Data with LIBNAME or FILENAME Statements” on page 18 and “Uploading Other Data Formats on the SAS Server” on page 16.

- I am trying to use an INFILE statement to access data, but it is causing errors. How should I use an INFILE statement?

  You must use a fully qualified path when using an INFILE statement within SAS OnDemand for Academics: Enterprise Guide. In addition, INFILE statements are case sensitive. Ensure that you are entering the INFILE statement appropriately. See “Working with INFILE Statements” on page 67.
I uploaded a file and am referring to the file using an INFILE statement, but not all of the fields are being read correctly. What is happening?

This could be the result of uploading a text file or a comma-separated-value file from a PC that uses the Microsoft Windows operating system. Adding the TERMSTR option to your INFILE statement might correct the issue.

I have copied code into the code (Program) window, but I am getting errors when I try to run the code. What is happening?

This could be the result of hidden or special characters in the code that you copied into the code window. One way to resolve this issue is to simply enter the code instead of copying the code. If the amount of code is too much to enter, then you could try saving the code as a text file to remove any special characters or formatting and then copying the code into the code window. For more information and options, search for SAS Note 16658 on http://support.sas.com/notes.

How do I save my projects or files from within SAS OnDemand for Academics: Enterprise Guide?

You must save all your work to your local computer because any work that you have completed (and any data that you have uploaded to the SAS servers, if applicable) is lost when you end your SAS OnDemand for Academics session.

When you choose to save your work or if you are prompted to save your work, select Local Computer instead of SAS Servers, and then proceed to save your work to the appropriate local directory.

I received an error message when trying to save work using SAS OnDemand for Academics: Enterprise Guide. What is wrong?

You might receive an error message such as this:

“An error occurred saving the file. Location must be configured as a WebDAV URI.”

In this case, it is likely that you were trying to save your work to the SAS servers instead of to your local computer. To avoid this error when you save your work, select Local Computer instead of SAS Servers. You can then select the local directory to which you want to save your work.
I am using Output Delivery System (ODS) statements in SAS OnDemand for Academics: Enterprise Guide in order to write results files (PDF, RTF). How do I save these files locally?

With SAS OnDemand for Academics: Enterprise Guide, you are unable to write ODS statements that direct files to your local directories. All SAS statements run on the SAS servers only. However, you can enable different output results formats:

1. Select **Tools ▶ Options**.

2. From the tree on the left side of the window, select **Results**.

3. Select the results format or formats that you want to produce, such as **PDF** or **RTF**.

Your SAS code now produces the output results that you selected and download them from the SAS servers. To save these results permanently, right-click on each results file and then select **Export**.

**Note:** Due to graph device restrictions on the SAS servers, if your PDF output contains any charts, then you must specify GIF or JPG as the graph device format.

Can I convert the HTML or SAS Report output that I produce with SAS OnDemand for Academics: Enterprise Guide into PDF files?

There is no way to accomplish this from within SAS OnDemand for Academics: Enterprise Guide. However, you could export the output files and then use a freeware PDF printer driver to accomplish this goal. To export your output, right-click on the appropriate file and then select **Export**.

How do I view or print multiple output files at the same time using SAS OnDemand for Academics: Enterprise Guide?

There are two ways to combine results to make one viewable and printable document:

- Select **Tools ▶ Create HTML Document**. This option lets you take the HTML output files that you have created in your project and combine them into a single HTML document, which you can save and print.
Select File ➤ New ➤ Report. This option works only when you use SAS Report instead of HTML as your output format. SAS Report output looks like HTML on the screen, but it is printed like a PDF (page-oriented). The report builder interface enables you to combine output from various tasks, arrange the output the way you like, add headers and footers and images, and control aspects of page layout and margins.
SAS OnDemand for Academics: Enterprise Miner

SAS OnDemand for Academics: Enterprise Miner ............................................. 82

Confirm System Requirements ................................................................. 82
  Confirm Requirements for Full Support .............................................. 82
  Verify Network Performance .............................................................. 83
  Verify and Install a Java Runtime Environment ....................................... 85

Access and Use the Software ................................................................. 88
  Introduction .......................................................................................... 88
  Access SAS Enterprise Miner .............................................................. 88
  Access the SAS Servers ........................................................................ 89
  SAS Servers Maintenance and Availability ............................................. 89
  Requesting SAS Servers Availability Notification .................................... 90

Review the Basics for Working with Data, Results, and Projects .......... 90
  Working with Data ................................................................................ 90
  Working with Projects .......................................................................... 94

Finding Help for Common Problems ...................................................... 96
  Introduction ....................................................................................... 96
  Where to Go for Assistance? ............................................................... 96
  Commonly Asked Questions: SAS OnDemand for Academics: Enterprise Miner .................................................. 97
SAS OnDemand for Academics: Enterprise Miner

This chapter guides instructors through recommended steps for registering for SAS OnDemand for Academics, preparing to teach courses, and supporting students while using SAS software.

Confirm System Requirements

Confirm Requirements for Full Support

In order for SAS OnDemand for Academics: Enterprise Miner to be fully supported, your system must meet the following requirements.

<table>
<thead>
<tr>
<th>Supported</th>
<th>Not Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating systems</td>
<td>Macintosh operating systems are not supported.</td>
</tr>
<tr>
<td>Any system that supports the Sun Microsystems (Oracle) Java Runtime Environment (JRE). Typically, this includes UNIX, Linux, and various Microsoft Windows operating systems, such as Microsoft Windows 7, XP and Microsoft Windows Vista.</td>
<td>Note: Virtualized environments might not work. It is recommended that supported operating systems run on a physical CPU.</td>
</tr>
<tr>
<td>Java Runtime Environment (JRE) from the 1.7 or 1.8 series, such as 1.8.0_45.</td>
<td>JRE 1.6.0_20 is not compatible.</td>
</tr>
</tbody>
</table>

Note: You are prompted to check for this JRE and install it when you access SAS Enterprise Miner.
### Supported System Requirements

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Supported</th>
<th>Not Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hard disk space</td>
<td>At least 50 MB of free hard disk space.</td>
<td></td>
</tr>
<tr>
<td>Internet browser</td>
<td>Any browser that supports a JRE from the 1.7 or 1.8 series.</td>
<td></td>
</tr>
<tr>
<td>Internet connection</td>
<td>High speed, including broadband (cable), DSL (phone), and wireless connections.</td>
<td>Note: Individual usage experience depends on speed and reliability of connection.</td>
</tr>
<tr>
<td>Network bandwidth</td>
<td>For best performance, at least 1000 Kbit/sec is recommended.</td>
<td></td>
</tr>
<tr>
<td>Memory</td>
<td>At least 2 GB; 4 GB recommended.</td>
<td></td>
</tr>
</tbody>
</table>

### Verify Network Performance

If you plan to teach in a lab or in a seminar setting in which many students will access and use SAS OnDemand for Academics software applications at the same time, then you should verify the performance of the network that you plan to use (Internet bandwidth, wireless router capacity, and so on). If the network performance is not sufficient, then your students could experience slow or dropped connections to the hosted SAS servers that are used to perform SAS processing.

You can contact the appropriate network or IT department personnel to request additional information. Share the following information with them to ensure they gather accurate data:
- type of network connection that you plan to use (wireless, LAN, or other). In particular, wireless networks can be problematic as there are sometimes stricter limits to the capacity of concurrent users that they can support.

- number of students that will use SAS OnDemand for Academics concurrently.

- location of the lab or seminar.

- location of the hosted SAS servers (the answer is Cary, North Carolina at SAS Institute).

There are also a number of tools available through the Internet that you or the appropriate network personnel can use to check network performance. SAS also offers a tool that might help.

To access this tool, complete these steps:

1. Go to the following website: http://netcheck.sas.com/ookla.

2. Click **Begin Test**.

   A speed test is run and gives your download and upload speed.

   To run SAS OnDemand for Academics: Enterprise Miner, it is best if your bandwidth is close to 1000 Kbit/sec or more. If you have less than 1000 Kbit/sec, then the software should still work, but will likely run slowly.

   **Note:** If you are not teaching in a lab or seminar setting, then each student must connect to the hosted SAS servers to perform processing using their own high-speed Internet connection. If individual students have network connection issues, then they can try to use a computer on a different network or contact their Internet Service Provider.
Verify and Install a Java Runtime Environment

Introduction
Before you can use SAS OnDemand for Academics: Enterprise Miner, you must verify that you have an appropriate Java Runtime Environment (JRE) installed or install an appropriate JRE. This process needs to be completed only once.

Note: Consider printing these instructions before you begin as some of the steps might require you to move to other websites.

Step 1: Verify Whether a JRE (and Java Web Start) Is Installed
To verify whether you installed a JRE, complete these steps:

1. Open a Command Prompt window. Select Start ➤ Run.
2. Type CMD in the Run window.
3. In the Command Prompt window, type start javaws.
4. If the above command opens a Java Web Start window similar to the following, then you have a JRE (and Java Web Start) installed.
If you have installed a JRE, then continue to “Step 2: Ensure That You Are Using Only the Recommended Java Runtime Environment”.

If the above command did not work, then you likely have not installed a JRE. Continue to “Step 3: Install the Recommended Java Runtime Environment and Java Web Start”.

**Step 2: Ensure That You Are Using Only the Recommended Java Runtime Environment**

You can use a JRE from the 1.7 or 1.8 series, such as 1.8.0_45. Only JREs with U.S. Export Control Classification Numbers of 5D992 are approved for use with SAS products. For more information, see SAS 9.4 Support for Java Runtime Environments.

1. From a Command Prompt window, start Java Web Start. Type `start javaws -viewer` and then press Enter.

2. If the Java Cache Viewer window is displayed, then close it so that you can see the Java Control Panel window. The Java Control Panel window often opens behind the Java Cache Viewer window.

3. From the Java Control Panel window, select the Java tab.

4. From the **Java Runtime Environment Settings** area, click **View**.
5 In the Enabled column, check only one JRE (clear any other JREs that are checked).

If JRE 1.8.0_45 (or greater) is unavailable, then you can test SAS OnDemand for Academics: Enterprise Miner with your current JRE. To do so, you can start it from your SAS OnDemand for Academics Dashboard.

If your current JRE does not work, then continue to “Step 3: Install the Recommended Java Runtime Environment and Java Web Start”. Otherwise, your configuration is complete.

Step 3: Install the Recommended Java Runtime Environment and Java Web Start

Installing the recommended JRE also installs Java Web Start on your system.

1 Access the Java SE Downloads website and then download the latest JRE.

   For example, to download JR 1.8.0_45, complete these steps:

   a Open the Java SE Runtime Environment 8 Downloads site.

   b Click the Accept License Agreement radio button to accept the Oracle Binary Code License Agreement for Java SE.

   c Select jre-8u45-windows-i586.exe from the Download column.

       You might be prompted to sign in to your Oracle web account. If you do not have an account, then you are prompted to create one.

   d Launch the download and select Run to begin the installation process.

2 (Optional) If you completed “Step 2: Ensure That You Are Using Only the Recommended Java Runtime Environment”, then repeat this step to ensure that only the newest JRE is selected.
Access and Use the Software

Introduction

Ideally, you should access and use the software ahead of time as SAS OnDemand for Academics software applications function slightly differently than their traditional SAS software counterparts. There are a number of resources available to help you.

Access SAS Enterprise Miner

After you have installed the recommended JRE (or if you want to test with a JRE that is already installed), you can start SAS OnDemand for Academics: Enterprise Miner by completing these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.

   The SAS OnDemand for Academics Dashboard is displayed.

2. From the Dashboard, click the SAS Enterprise Miner link to start the application.

3. If you are presented with a security warning, then select Run.

   The Enterprise Miner Log On dialog box is displayed.

4. In the User ID field, enter your SAS profile user ID. This user ID is also displayed under your name on your SAS OnDemand for Academics Dashboard.

   Note: Your SAS profile user ID is case sensitive and should be entered in all lowercase. If you enter your SAS profile user ID using uppercase or mixed case letters, then you might be able to log on, but certain tasks might not perform properly.

5. In the Password field, enter your SAS profile password. There are two times when you might have supplied a SAS profile password: when you originally created a SAS profile or when you registered for SAS OnDemand for Academics.
Click Log On.

Access the SAS Servers

You are prompted to connect to the SAS servers each time you start SAS OnDemand for Academics: Enterprise Miner. The servers (which are hosted at SAS Institute Inc.) remotely processes any submitted SAS files or projects and returns results to your computer.

Make sure that you have a working Internet connection if you are unable to use a SAS OnDemand for Academics software application to perform processing. If your Internet connection is working normally, then it is likely that the SAS servers are temporarily unavailable. Try to use the servers again later. You can also log on to the SAS OnDemand for Academics Control Center. The SAS OnDemand for Academics Control Center typically provides a message if the SAS servers are unavailable or is expected to be unavailable in the near future.

SAS Servers Maintenance and Availability

SAS makes its best efforts to make the hosted servers available as much as possible and to keep unexpected downtime to a minimum. There could be limited times when the servers are unavailable because SAS is performing maintenance, testing, or performance enhancement tasks.

- If server maintenance is needed, then SAS tries to perform this work during nontraditional usage hours to lessen any impact to users.
- SAS uses the third Saturday of each month to perform scheduled maintenance on its systems (if needed). Therefore, the servers might be unavailable for a portion of time on the third Saturday of each month.
Requesting SAS Servers Availability Notification

If you would like to be notified when the SAS servers are unavailable due to extended maintenance or due to unforeseen circumstances, then subscribe to the SASONDEMANDSERVER-L mailing list:

- Send email to LISTSERV@LISTSERV.SAS.COM.
- In the body of the email, type subscribe SASONDEMANDSERVER-L.
- Send the email (no subject line is needed). Follow any instructions that you receive via email.

To unsubscribe from SASONDEMANDSERVER-L, complete these steps:

- Send email to LISTSERV@LISTSERV.SAS.COM.
- In the body of the email, type unsubscribe SASONDEMANDSERVER-L.
- Send the email (no subject line is needed).

Review the Basics for Working with Data, Results, and Projects

Working with Data

Introduction

Before a course begins, you should review the basics of accessing and using data from the SAS servers. SAS OnDemand for Academics: Enterprise Miner uses the SEMMA project model to organize work and options for accessing data are specific to this product. You should also review the basics of working with SAS data sets, models, and results in SAS OnDemand for Academics: Enterprise Miner.
Before you access the appropriate data sets, you must assign a SAS library to your projects using one of the following methods.

**Assigning a SAS Library to a Project Using Start Code**

SAS OnDemand for Academics: Enterprise Miner enables you to include Start Code for your projects. After you have specified this code, it will be run anytime that the project is started and can save you time and effort. For example, you might want to assign a LIBNAME statement through Start Code so that a project can always access specific SAS data sets.

To use a start code with a new project, complete these steps:

2. Select **New Project**. From the New Project wizard page, select a name for your project, select the default values on the remaining wizard pages, and then select **Finish**.
3. From the Property tree on the left, locate the project Start Code property.
4. Click the ellipsis ... button.
5. Enter the appropriate Start Code and then click either **Run Now** or **OK**.

**Note:** If you want to use a project Start Code to access SAS data sets that use a format file, then you must also specify the FMTSEARCH option in your Start Code.

To use a start code with an existing project, complete these steps:

2. Open the appropriate project.
3. From the Property tree on the left, locate the Property Code property.
4. Click the ellipsis ... button.
5. Enter the appropriate Start Code and then click either **Run Now** or **OK**.
Note: If you want to use project Start Code to access SAS data sets that use a format file, then you must also specify the FMTSEARCH option in your start-up code.

Assigning a SAS Library Using LIBNAME Statements

You can access the Program Editor by selecting View ➤ Program Editor from within SAS OnDemand for Academics: Enterprise Miner.

Instructors have the ability to store SAS data sets and other files on the SAS servers. The LIBNAME statement to use is available on your Dashboard.

Note: LIBNAME statements are case sensitive. Copy them or enter them exactly as they are to avoid errors.

Accessing Data Using SAS OnDemand for Academics: Enterprise Miner

The SAS servers include various SAS libraries (and their corresponding SAS data sets). As an instructor, you might want to use one or more of the SAS data sets from SASHELP, MAPS, or other libraries that are provided by SAS to ensure that all your students have access to the data.

To access sample data sets on the SAS servers, complete these steps:

2. Create a new project or open an existing project.
3. In the tree on the left, right-click Data Source and then select Create Data Source.
4. The Source menu defaults to SAS Table. Click Next to accept the default value and move to the next step in the wizard.
5. Next to the Table field (which will be blank), click Browse.
6. Use the Library menu to select the appropriate library.
7. Select the SAS data set that you want to use and then continue with the wizard.
Accessing SAS Enterprise Miner Course Data on the SAS Servers

In addition, SAS OnDemand for Academics stores SAS data sets that are associated with the teaching materials from SAS Enterprise Miner courses on the SAS servers.

To view these data sets, complete these steps:

2. Create a new project or open an existing project.
3. In the tree on the left, right-click Data Source and then select Create Data Source.
4. Select Source ➤ Metadata Repository. Click Next.
5. Next to the Table field, click Browse.
6. Use the Library menu to select the appropriate library.
7. Select the SAS data set that you want to use and then continue with the wizard or data files to the SAS servers for use in specific courses.

Accessing Grayed-out SAS Libraries from the SAS Servers

The SAS servers include sample SAS data sets that you might choose to use. Some of the sample SAS libraries might appear to be grayed out, but they are still available for use.

Typically, grayed-out SAS libraries appear for users in Europe and were originally intended for use with SAS Enterprise Miner.

2. Select File ➤ Open ➤ Data.
6 Right-click on the grayed-out SAS library that you would like to access and then click Assign.

7 Double-click the SAS data set that you want to use.

Working with Projects

Introduction
SAS OnDemand for Academics: Enterprise Miner uses the SEMMA model to organize data mining projects. It is helpful if you share the following information with your students so that they can use the interface most effectively.

Understanding Project Storage Quotas
Each SAS OnDemand for Academics: Enterprise Miner user has a large project storage quota. An email message is sent to any user who has used 75% of their storage quota.

If the project storage quota is reached, then SAS OnDemand for Academics: Enterprise Miner stops functioning properly. To avoid this, consider deleting any unnecessary projects before reaching your quota to ensure that SAS OnDemand for Academics: Enterprise Miner continues to work properly.

If you do reach your quota and then delete unnecessary projects to create more project storage space, then the last project that you were working with could be affected. If the project runs incorrectly after removing unnecessary projects, then you might need to rebuild the diagrams for this project.

Creating New Projects
When you create a new project, you use the Create New Project wizard. Step 3 of this wizard enables you to select a SAS folder in which to store your project. Even though you have the ability to browse in this step, accept the default project storage location:

/Users/your-user-id/My Folder

Accepting the default project storage location ensures that your projects can be accessed appropriately by SAS OnDemand for Academics servers.
If you select **Browse** and attempt to store your project in a location other than the default, the following error occurs:

**Figure 7.2  Error Message**

![Error Message](image)

To correct this error, change the location where your project will be stored back to the default location: `/Users/your-user-id/My Folder`.

**Opening Existing Projects**
To find and open an existing project, complete these steps:

2. Click **Open Project**.
3. From the Open Project window, open the **My Folder** folder.
4. Select the project that you want to open.
5. Click **OK**.

**Creating Model Packages**
With SAS OnDemand for Academics: Enterprise Miner, users can create model packages (also known as SAS Package Files or .spk files). Model packages can be created from any node in a diagram. Typically, you create a model package when you are satisfied with your model and you want to preserve it or share it with someone else.

In most cases, you create the model package from the last node of a process in a diagram. This ensures that the model package will include the entire process flow.
Differences between Project Model Packages and Exported Project Diagrams

With SAS OnDemand for Academics: Enterprise Miner, a user can create a model package and send it as a SAS Package File (.spk), or export a diagram as an XML file (.xml). If a specific project takes a long time to run, having the model package (with the associated results) can be advantageous.

Exported diagrams contain no results. After a project’s diagram has been exported as an XML file, it can be shared as an attachment in an email message or by placing the file on a shared network directory. To use the shared file, it must be imported in to SAS OnDemand for Academics: Enterprise Miner and then the appropriate path of the diagram would have to be run to produce results.

Note that neither model packages nor exported diagrams include the actual data that is referenced. To rerun the project, you must have access to the original data or use the LIBNAME statement that points to the original data if that data is stored on the SAS servers.

Finding Help for Common Problems

Introduction

Check the commonly asked questions about SAS OnDemand for Academics: Enterprise Miner in this section and follow the procedures below for additional help.

Where to Go for Assistance?

Review Commonly Asked Questions, SAS Notes, and SAS Documentation

Use the keyword “ondemand academics” to search for issues specific to SAS OnDemand for Academics from these sources:

- “Commonly Asked Questions: SAS OnDemand for Academics: Enterprise Miner” on page 97
SAS Notes, a database of common technical issues

SAS Product Documentation

SAS Analytics U Community

The SAS Analytics U Community is a social community where you can collaborate with SAS users in academia. This community is open to professors, students, and academic researchers who are using SAS OnDemand for Academics. Software usage issues are addressed in the community through resources such as discussion forums, e-Learning, video tutorials, and FAQs.

For issues that are related to registering software, deploying software, and connecting to the SAS cloud, send email to SASAnalyticsU@sas.com, call 800-727-0025 (option 2), or chat with us online during regular business hours.

Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for Academics, then contact your instructor. Instructors can point students toward educational resources and help ensure that offerings are used correctly.

Contact Your SAS Site Representative (If Applicable)

If you are an instructor at a university that already uses SAS software, then you might have a SAS Site Representative who can provide SAS support.

If you are unsure about whether you have a SAS Site Representative, then contact the person or department that supports your university’s software purchases and installation.

Commonly Asked Questions: SAS OnDemand for Academics: Enterprise Miner

Does SAS OnDemand for Academics: Enterprise Miner have all the same features as SAS Enterprise Miner?

The version of SAS Enterprise Miner that is available through SAS OnDemand for Academics does have a few differences.

☐ You must accept the default project storage location when creating new projects.
Your projects are stored within the My Folder folder.

Certain nodes are unavailable, might not function properly, or are experimental. For example, the File Import node is unavailable.

SAS Text Miner nodes are available, but are considered experimental.

Can I use SAS OnDemand for Academics: Enterprise Miner if I already have SAS Enterprise Miner on my PC?

Yes. SAS OnDemand for Academics: Enterprise Miner is mutually exclusive from any other version of SAS Enterprise Miner and should not cause any conflicts or reset any file type associations. Note that the projects that you create with each version of SAS Enterprise Miner are also mutually exclusive. If necessary, you can save a project diagram XML file created in one version of SAS Enterprise Miner and import it in to another version. However, for this to work, you must have access to the necessary data on the appropriate PC as well.

How do I configure my PC to use SAS OnDemand for Academics: Enterprise Miner?

In order to use SAS OnDemand for Academics: Enterprise Miner, you must first ensure that your PC is properly configured. It is especially important that the appropriate version of the Java Runtime Environment is installed on your machine. For more information, see “Verify and Install a Java Runtime Environment” on page 85.

How do I start SAS OnDemand for Academics: Enterprise Miner?

After you have configured your system to support SAS OnDemand for Academics: Enterprise Miner, you can start the application by completing these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   The SAS OnDemand for Academics Dashboard is displayed.

2. From the Dashboard, click the SAS Enterprise Miner link to start the application.

3. If you are presented with a security warning, then click Run.
   The Enterprise Miner Log On dialog box is displayed.
4 In the **User ID** field, enter your SAS profile user ID. This user ID is also displayed under your name on your SAS OnDemand for Academics Dashboard.

**Note:** Your SAS profile user ID is case sensitive and should be entered in all lowercase. If you enter your SAS profile user ID using uppercase or mixed case letters, then you might be able to log on, but certain tasks might not perform properly.

5 In the **Password** field, enter your SAS profile password. There are two times when you might have supplied a SAS profile password: when you originally created a SAS profile or when you registered for SAS OnDemand for Academics.

6 **Click Log On.**

- I receive the following error in my SAS log when trying to use a SAS catalog file that I have uploaded to the SAS servers: “ERROR: File LIBRARY NAME.CATALOG NAME.CATALOG was created for a different operating system.” What is wrong?

This error message typically occurs if you have tried to use a SAS catalog file that was created using an operating system other than UNIX. To resolve the issue, see “Storing SAS Catalog Files on the SAS Server.” This topic includes usage information and sample code.

- How do I save my work in SAS OnDemand for Academics: Enterprise Miner?

  There is no Save button in this application. Your project is automatically saved on the SAS servers for you while you work. When you are finished working, select File ▶ **Close this Project** to ensure that your project saves properly.

- How do I submit homework using SAS OnDemand for Academics: Enterprise Miner?

  There are three ways that you can share homework assignments: either by creating and registering a project model package, by sharing a project model package, or by sharing a project diagram. Your instructor will tell you the method that he or she would like you to use. For more information, see “SAS Enterprise Miner: Sharing Homework Assignments” on page 32.

- How do I collaborate using SAS OnDemand for Academics: Enterprise Miner?
You can collaborate by sharing an entire project model package or a project diagram. For more information, see these topics: “Differences between Project Model Packages and Exported Project Diagrams” on page 96 and “Collaborating.”

- Can I use a project model package or project diagram from older versions of SAS Enterprise Miner?

Some project model packages and project diagrams created in older versions of SAS Enterprise Miner work fine while others do not. If you try to use a project or diagram created with an older version of SAS Enterprise Miner and the application becomes unresponsive, then close the application and avoid using the project model package or project diagram in the future.

- My project or diagram is unresponsive or no longer opens. What is wrong?

If you have lost a connection to the SAS servers while working on your project or diagram or if you did not properly close SAS OnDemand for Academics: Enterprise Miner, then a lock file might have been created. This lock file could cause your diagram or project to appear unresponsive or it could prevent your diagram or project from opening at all. Try the following to correct the issue:

- If the lock has just happened, then try waiting about five minutes. In many cases, locked files correct themselves.

- If you are unsure of when the lock occurred or if it has been longer than five minutes, then close the project, log off from SAS OnDemand for Academics: Enterprise Miner, and then log on again.

**Note:** It is best to close your diagrams and projects before exiting SAS OnDemand for Academics: Enterprise Miner or before disconnecting from your Internet connection.

**Note:** An open connection to the SAS servers will likely disconnect (time out) after one hour if the connection is idle (that is, you have not performed any processing). Many firewalls disconnect open sessions after an hour of idle time, and this could lead to locked files. It is a best practice to complete your work, save it, and then exit SAS OnDemand for Academics: Enterprise Miner before you leave your computer.

- When I open SAS OnDemand for Academics: Enterprise Miner, I no longer see my projects. What is wrong?
This behavior can occur if you log on to SAS OnDemand for Academics: Enterprise Miner using a mixed case or uppercase SAS profile user ID. Close SAS OnDemand for Academics: Enterprise Miner and log on again. Make sure that you use all lowercase letters for your SAS profile user ID.

- Can I create a SAS library using SAS OnDemand for Academics: Enterprise Miner?
  No. However, you can work with available SAS libraries or assign LIBNAME statements.

- I have been provided with a LIBNAME statement for my course. How do I assign it?
  If you have a LIBNAME statement for your course (either because you are an instructor and you uploaded data to the SAS servers or because you are a student and your instructor has provided you with a LIBNAME statement to use), you can assign it in one of two ways:
    - Assign the LIBNAME statement as part of your project Start Code to ensure that the SAS library is available throughout your project; this LIBNAME statement also executes each time you start your project.
    - Assign the LIBNAME statement within a project using the SAS OnDemand for Academics: Enterprise Miner Program Editor window.

- I am using a SAS data set that requires a format file. How do I define the path to the format file?
  You can define a path to a format file using project Start Code.

- I either have or might reach my project storage quota. What do I do?
  If you exceed your project storage space quota, then SAS OnDemand for Academics: Enterprise Miner stops processing nodes properly. To resolve this situation, delete existing projects that you no longer need in order to free up project storage space.
  
The last project that you created or were working with when you met your project storage space quota could be impacted (even after you delete existing projects to create more space). If such a project seems to run incorrectly, then you might need to rebuild the diagrams for this project.
# SAS OnDemand for Academics: Forecast Studio

**SAS OnDemand for Academics: Forecast Studio**  
104

**Confirm System Requirements**  
104
- Confirm Requirements for Full Support  
- Verify Network Performance  
- Verify and Install a Java Runtime Environment  

**Access and Use the Software**  
109
- Introduction  
- About SAS Forecast Studio Environments  
- Locate the Name of Your SAS Forecast Studio Environment  
- Access SAS Forecast Studio  
- Access the SAS Servers  
- SAS Servers Maintenance and Availability  
- Requesting SAS Servers Availability Notification  

**Review the Basics for Working with Data and Results**  
112

**Help for Common Problems**  
113
- Introduction  
- Where to Go for Assistance?  
- Commonly Asked Questions for SAS OnDemand for Academics: Forecast Studio  

SAS OnDemand for Academics: Forecast Studio

This chapter guides instructors and students through recommended steps for registering for SAS OnDemand for Academics, preparing to teach courses, and supporting students while using SAS software.

Confirm System Requirements

Confirm Requirements for Full Support

In order for SAS OnDemand for Academics: Forecast Studio to be fully supported, your system must meet the following requirements.

<table>
<thead>
<tr>
<th>Supported</th>
<th>Not Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating systems</td>
<td>Any system that supports the Sun Microsystems (Oracle) Java Runtime Environment (JRE). Typically, this includes UNIX, Linux, and various Microsoft Windows operating systems, such as Microsoft Windows 7, XP and Microsoft Windows Vista.</td>
</tr>
<tr>
<td>Java Runtime Environment</td>
<td>Java Runtime Environment (JRE) from the 1.7 or 1.8 series, such as 1.8.0_45. Note: You are prompted to check for this JRE and install it when you install SAS Forecast Studio.</td>
</tr>
<tr>
<td>Supported</td>
<td>Not Supported</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Hard disk space</td>
<td>At least 50 MB of free hard disk space.</td>
</tr>
<tr>
<td>Internet browser</td>
<td>Any browser that supports JRE from the 1.7 or 1.8 series.</td>
</tr>
<tr>
<td>Internet connection</td>
<td>High speed, including broadband (cable), DSL (phone), and wireless connections.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Individual usage experience depends on speed and reliability of connection.</td>
</tr>
<tr>
<td>Network bandwidth</td>
<td>For best performance, at least 1000 Kbit/sec is recommended.</td>
</tr>
</tbody>
</table>

**Verify Network Performance**

If you plan to teach in a lab setting or a seminar setting in which many students will access and use SAS OnDemand for Academics software applications at the same time, then you should verify the performance of the network that you plan to use (Internet bandwidth, wireless router capacity, and so on).

If the network performance is not sufficient, then your students could experience slow or dropped connections to the hosted SAS servers that are used to perform SAS processing.

You can contact the appropriate network or IT department personnel to request additional information. Share the following information with them to ensure they gather accurate data:
type of network connection that you plan to use (wireless, LAN, or other). In particular, wireless networks can be problematic as there are sometimes stricter limits to the capacity of concurrent users that they can support.

number of students that will use SAS OnDemand for Academics concurrently.

location of the lab or seminar.

location of the hosted SAS servers (the answer is Cary, North Carolina at SAS Institute).

There are also a number of tools available through the Internet that you or the appropriate network personnel can use to check network performance. SAS also offers a tool that might help.

To access this tool, complete these steps:

1 Go to the following website: http://netcheck.sas.com/ookla.

2 Click Begin Test.

Note: If you are not teaching in a lab or seminar setting, then each student must connect to the hosted SAS servers to perform processing using their own high-speed Internet connection. If individual students have network connection issues, then they can try to use a computer on a different network or contact their Internet Service Provider.

Verify and Install a Java Runtime Environment

Introduction

Before you can use SAS OnDemand for Academics: Forecast Studio, you must verify that you have an appropriate Java Runtime Environment (JRE) installed or install an appropriate JRE. This process needs to be completed only once.

Note: Consider printing these instructions before you begin as some of the steps might require you to move to other websites.
**Step 1: Verify Whether a JRE (and Java Web Start) Is Installed**

To verify whether you installed a JRE, complete these steps:

1. Open a Command Prompt window. Select **Start ➤ Run**. Type `CMD` in the Run window.

2. In the Command Prompt window, type `start javaws`.

3. If the above command opens a Java Web Start window similar to the following, then you have a JRE (and Java Web Start) installed.

   ![Figure 8.1 Java Web Start Window](image)

   If you installed a JRE, then continue to “**Step 2: Ensure That You Are Using Only the Recommended Java Runtime Environment**”. If the above command did not work, then you likely have not installed a JRE. Continue to “**Step 3: Install the Recommended Java Runtime Environment and Java Web Start**”.

**Step 2: Ensure That You Are Using Only the Recommended Java Runtime Environment**

You can use a Java Runtime Environment (JRE) from the 1.7 or 1.8 series, such as 1.8.0_45. Only JREs with U.S. Export Control Classification Numbers of 5D992 are
108  Chapter 8 / SAS OnDemand for Academics: Forecast Studio

approved for use with SAS products. For more information, see SAS 9.4 Support for Java Runtime Environments.

1  From a Command Prompt window, start Java Web Start. Type `start javaws -viewer` and then press Enter.

2  If the Java Cache Viewer window is displayed, then close it so that you can see the Java Control Panel window. The Java Control Panel window often opens behind the Java Cache Viewer window.

3  From the Java Control Panel window, select the **Java** tab.

4  From the **Java Application Runtime Settings** area, click **View**.

5  In the **Enabled** column, select only one JRE (clear the check boxes of any other JREs that are selected).

If JRE 1.8.0_45 (or greater) is unavailable, then you can test SAS OnDemand for Academics: Forecast Studio with your current JRE. To do so, you can start from your SAS OnDemand for Academics Dashboard.

If your current JRE does not work or if you want to install the recommended JRE, then continue to "Step 3: Install the Recommended Java Runtime Environment and Java Web Start". Otherwise, configuration is complete.

**Step 3: Install the Recommended Java Runtime Environment and Java Web Start**

Installing the recommended JRE also installs Java Web Start on your system.

1  Access the **Java SE Downloads** website and then download the latest JRE.
   
   For example, to download JR 1.8.0_45, complete these steps:

   a  Open the **Java SE Runtime Environment 8 Downloads** site.

   b  Select the **Accept License Agreement** radio button to accept the Oracle Binary Code License Agreement for Java SE.

   c  Select `jre-8u45-windows-i586.exe` from the **Download** column.
You might be prompted to sign in to your Oracle web account. If you do not have an account, then you are prompted to create one.

d) Launch the download and select Run to begin the installation process.

2 (Optional) If you completed “Step 2: Ensure That You Are Using Only the Recommended Java Runtime Environment”, then repeat this step to ensure that only the newest JRE is selected.

Access and Use the Software

Introduction

Ideally, you should access and use the software ahead of time as SAS OnDemand for Academics software applications function slightly differently than their traditional SAS software counterparts. There are a number of resources available to help you.

About SAS Forecast Studio Environments

SAS Forecast Studio requires that an environment be established and that projects exist within an environment. With SAS OnDemand for Academics: Forecast Studio, each course is set up to be its own environment by default. Any user within that course is automatically a part of that environment and can create and work with projects within that environment.

SAS Forecast Studio is also a collaborative tool. This means that all users within a specific course can view and work with the projects in that course's environment.

Locate the Name of Your SAS Forecast Studio Environment

Each course that is registered using SAS Forecast Studio has a unique course environment.
To locate the name of the course environment, instructors can complete these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   The SAS OnDemand for Academics Dashboard is displayed.

2. From the Courses I teach section, locate the appropriate course and click Details.

3. Locate the Forecast Studio Environment field.

Access SAS Forecast Studio

After you have reconfigured your system to support SAS OnDemand for Academics: Forecast Studio, you can start the application.

To start the application, complete these steps:

1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   The SAS OnDemand for Academics Dashboard is displayed.

2. From your Dashboard, click the SAS Forecast Studio link to start the application.

3. If you are presented with a security warning, click Run.

4. After SAS Forecast Studio starts, you are prompted to select the appropriate environment. You must select the appropriate course environment to continue.

   The instructor of the course provides the name of the SAS Forecast Studio Environment to use for the course. On the Dashboard under Courses I teach, locate the appropriate course and then click Details. Locate the Forecast Studio Environment field.
Access the SAS Servers

You are prompted to connect to the SAS servers each time you start SAS OnDemand for Academics: Forecast Studio. The servers (which are hosted at SAS Institute Inc.) remotely processes any submitted SAS files or projects and returns results to your computer.

Make sure that you have a working Internet connection if you are unable to use a SAS OnDemand for Academics software application to perform processing. If your Internet connection is working normally, then it is likely that the SAS servers are temporarily unavailable. Please try to use the servers again later. You can also log on to the SAS OnDemand for Academics Control Center. The SAS OnDemand for Academics Control Center typically provides a message if the SAS servers are unavailable or expected to be unavailable in the near future.

SAS Servers Maintenance and Availability

SAS makes its best efforts to make the hosted servers available as much as possible and to keep unexpected downtime to a minimum. There could be limited times when the servers are unavailable because SAS is performing maintenance, testing, or performance enhancement tasks.

- If server maintenance is needed, then SAS tries to perform this work during nontraditional usage hours to lessen any impact to users.
- SAS uses the third Saturday of each month to perform scheduled maintenance on its systems (if needed). Therefore, the servers might be unavailable for a portion of time on the third Saturday of each month.

Requesting SAS Servers Availability Notification

If you would like to be notified when the SAS servers are unavailable due to extended maintenance or due to unforeseen circumstances, then subscribe to the SASONDEMANDSERVER-L mailing list. To subscribe, complete these steps:
1 Send email to LISTSERV@LISTSERV.SAS.COM.

2 In the body of the email, type subscribe SASONDEMANDSERVER-L.

3 Send the email (no subject line is needed). Follow any instructions that you receive via email.

To unsubscribe from SASONDEMANDSERVER-L, complete these steps:

1 Send email to LISTSERV@LISTSERV.SAS.COM.

2 In the body of the email, type unsubscribe SASONDEMANDSERVER-L.

3 Send the email (no subject line is needed).

---

**Review the Basics for Working with Data and Results**

During the first week of class, we recommend that you review the basics of working with SAS data sets, models, and results in SAS OnDemand for Academics: Forecast Studio.

By default, all SAS OnDemand for Academics: Forecast Studio projects are stored on the SAS servers. Due to the architecture of this offering, there is no way to save your projects locally.

The large size of projects and their forecasts might also prove to be problematic to save locally. In a teaching setting, sharing the results of your forecasting projects should be sufficient.
Help for Common Problems

Introduction
Check the commonly asked questions about SAS OnDemand for Academics: Forecast Studio in this section and follow the procedures below for additional help.

Where to Go for Assistance?

Review Commonly Asked Questions, SAS Notes, and SAS Documentation
Use the keyword “ondemand academics” to search for issues specific to SAS OnDemand for Academics from these sources:

- “Commonly Asked Questions for SAS OnDemand for Academics: Forecast Studio” on page 114
- SAS Notes, a database of common technical issues
- SAS Product Documentation

SAS Analytics U Community
The SAS Analytics U Community is a social community where you can collaborate with SAS users in academia. This community is open to professors, students, and academic researchers who are using SAS OnDemand for Academics. Software usage issues are addressed in the community through resources such as discussion forums, e-Learning, video tutorials, and FAQs.

For issues that are related to registering software, deploying software, and connecting to the SAS cloud, send email to SASAnalyticsU@sas.com, call 800-727-0025 (option 2), or chat with us online during regular business hours.
Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for Academics, then contact your instructor. Instructors can point students toward educational resources and help ensure that offerings are used correctly.

Contact Your SAS Site Representative (If Applicable)

If you are an instructor at a university that already uses SAS software, then you might have a SAS Site Representative who can provide SAS support.

If you are unsure about whether you have a SAS Site Representative, then contact the person or department that supports your university’s software purchases and installation.

Commonly Asked Questions for SAS OnDemand for Academics: Forecast Studio

- How do I configure my PC to use SAS OnDemand for Academics: Forecast Studio?

  In order to use SAS OnDemand for Academics: Forecast Studio, you must first ensure that your PC is properly configured and that you installed the appropriate Java Runtime Environment. For step-by-step instructions, see “Confirm System Requirements” on page 104.

- How do I start SAS OnDemand for Academics: Forecast Studio?

  After you have configured your system to support SAS OnDemand for Academics: Forecast Studio, you can start the application by completing these steps:

  1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.

     The SAS OnDemand for Academics Dashboard is displayed.

  2. From your Dashboard, click SAS Forecast Studio to start the application.

  3. If you are presented with a security warning when you attempt to start SAS OnDemand for Academics: Forecast Studio, click Run.
4 After SAS Forecast Studio starts, you are prompted to select the appropriate environment. You must select the appropriate course environment to continue.

The instructor of the course provides the name of the SAS Forecast Studio Environment to use for the course. On the Dashboard under **Courses I teach**, locate the appropriate course and then click **Details**. Locate the **Forecast Studio Environment** field.

I am an instructor. Can I upload data files to use with SAS Forecast Studio?

Unlike some of the other software applications available through SAS OnDemand for Academics, the data that an instructor uploads for their course or courses is unavailable for use with SAS Forecast Studio. Instead, both instructors and students must use the default SAS data sets provided with SAS OnDemand for Academics.

What is the name of my SAS Forecast Studio Environment?

Each course registered using SAS Forecast Studio has a unique course environment. Instructors can locate the name of their course environment by completing these steps:

1 Log on to the **SAS OnDemand for Academics Control Center** using your SAS profile user ID and password. Click **Sign In**.

   The SAS OnDemand for Academics Dashboard is displayed.

2 On the Dashboard under **Courses I teach**, locate the appropriate course.

3 Click **Details**. Locate the **Forecast Studio Environment** field.

   **Note:** Students must contact their instructor if they do not know which environment to select.

How do I select a SAS Forecast Studio Environment?

Instructors and students can select their course environments by completing these steps:

1 Log on to SAS Forecast Studio.

2 From the Project window, select your course environment from the **Environment** menu.
Note: SAS OnDemand for Academics creates a dedicated environment for each course using SAS Forecast Studio.

Note: Students must contact their instructors if they do not know which environment to select.
SAS OnDemand for Academics with JMP Software

**SAS OnDemand for Academics with JMP Software** 117

**Register to Use SAS OnDemand for Academics** 118  
- Instructor Registration 118  
- Student Registration 118

**Install the Appropriate JAR Files** 119

**Create a SAS Servers Profile within JMP** 119

**Connecting to the SAS Servers Using JMP** 120  
- Connect Using JMP 11 120

---

**SAS OnDemand for Academics with JMP Software**

If you have purchased and installed JMP software (version 11 or greater) in the United States, then you can use JMP to connect to the hosted SAS servers that are used by SAS OnDemand for Academics. This enables you to integrate JMP and SAS together.

To integrate with SAS using this method, you must do the following:

- register to use SAS OnDemand for Academics
install the appropriate JAR files
create a SAS server profile within JMP
connect to the SAS servers from JMP

---

Register to Use SAS OnDemand for Academics

**Instructor Registration**

If you are an instructor, then complete these steps:

**Note:** This step needs to be performed only once.

2. Complete the registration steps. During the registration process, a user ID and password are created for you.
3. After you have registered, log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
   The SAS OnDemand for Academics Dashboard is displayed.
4. Create a course. When prompted to select a client, choose Access to JMP.
5. Invite your students to register for your course. Share the SAS server profile information with them.

**Student Registration**

If you are a student, then complete these steps. Note that your instructor must invite you to register with a special email before you can complete these steps.

2 Complete the registration steps. During the registration process, a user ID and password are created for you.

3 Click the Course Enrollment link that your instructor provided and then follow the steps to complete your registration. If you have not received a Course Enrollment link, then contact your instructor.

---

Install the Appropriate JAR Files

For JMP to work properly with the SAS OnDemand for Academics hosted servers, you must have three specific JAR files. These files are export controlled. They can be used only within the United States by United States citizens or legal residents of the United States. The file cannot be shared with any party to whom the United States prohibits access to the files.

1 From the JAR File Download Page, locate the appropriate file based on your version of JMP as well as your operating system.

2 Click Request Download.

3 Follow the instructions to complete the download for either Microsoft Windows or Apple Macintosh.

   Note: If the downloaded file does not start a program by default, then locate the file on your computer and double-click it. A program runs and installs the necessary JAR files in the appropriate directory. It might take a moment for the program to begin to run.

---

Create a SAS Servers Profile within JMP

This step needs to be performed only once.
1 Start JMP.

2 Select File ➤ SAS ➤ Server Connections.

3 In the SAS Server Connections window, select SAS Server Version ➤ 9.4.

4 In the SAS Server Connections window, click Manage Profiles to open the Manage Metadata Server Profiles window.

5 Click Add. Enter a profile name and description.

6 In the Machine field, enter odaomr.oda.sas.com.

7 In the Port field, enter 8561.

8 In the User name field, enter your SAS server user ID. This user ID is also displayed on your SAS OnDemand for Academics Dashboard.

9 In the Password field, enter your SAS profile password.

10 In the Authentication Domain field, enter DefaultAuth.

11 Click Save.

---

Connecting to the SAS Servers Using JMP

Connect Using JMP 11

This step should be performed anytime you want to connect to hosted SAS servers.

To connect using JMP 11, complete these steps:

1 Start JMP.

2 Select File ➤ SAS ➤ Server Connections.
3 Under Profile, select the name of the profile that you created for the SAS servers. For more information, see “Create a SAS Servers Profile within JMP” on page 119.

4 Click Connect.

   Note: To disconnect from the SAS servers, click Disconnect.

5 Under Establish New Workspace Server Connection, select Connect to metadata-defined SAS server and then click Connect.
This appendix answers questions that apply to all SAS OnDemand for Academics software products. For help with specific products, see “Commonly Asked Questions” for the SAS OnDemand for Academics software that you are using.
General, Cost, and License

For how long is my account active?
If you do not use your account for a period of one year, then your account might expire. In addition, you might be required to access new versions of the available software, accept an updated license agreement, or both to keep your account current.

What is the cost of the software?
The software is free for professors and free to students in active classes.

What is the difference between the EAS license and the SAS OnDemand for Academics license for students and professors?
Your SAS account representative can help you understand the differences and decide what is the best option for you to use to teach with SAS software. Contact your SAS academic account representative by calling 800-727-0025, and then select option two.

Is SAS OnDemand for Academics accessible to users with disabilities?
SAS is aware that academic and other institutions are required to satisfy the accessibility standards contained in Sections 504 and 508 of the Rehabilitation Act (29 U.S.C. 794d) with respect to their use of electronic and information technology. SAS has tested SAS OnDemand for Academics against relevant standards with the assistance of students who use assistive technologies.

Availability and Installation

Who can use SAS OnDemand for Academics?
SAS OnDemand for Academics: SAS Studio is available by default to anyone who registers. This includes adult learners, instructors, students, and researchers – as long as you are not using the offering for commercial purposes.
All other clients (Enterprise Guide, Enterprise Miner, Forecast Studio, and access from JMP) are available to instructors who register a course and choose to use one of these clients for their course.

SAS OnDemand for Academics is available for international usage in English only. We recommend that instructors test the use of this offering before including it in a course to ensure that performance is acceptable.

What can I expect during the registration process? Whether you are an instructor or a student, there are several parts to the registration process, so it is helpful to keep the following in mind:

- The registration process uses a series of windows to guide you.
- You will need access to your email account during the registration process. When you begin registration, you are prompted to enter an email address. Enter the email address of an account that you can access easily while completing your registration.
- A SAS profile is needed to use SAS OnDemand for Academics, but the registration process automatically creates one for you, if needed.
- You will receive an email during the initial registration process that you must open and act upon to continue. The email prompts you to click a link to verify your email address. Its primary purpose is to confirm that you are using a valid email address and that someone else is not attempting to register you without your knowledge.

Which Internet browsers can I use with SAS OnDemand for Academics?

An Internet browser is required to use the SAS OnDemand for Academics Control Center, to download SAS OnDemand for Academics software, and to use the SAS Studio client. We recommend Microsoft Internet Explorer 9 (or greater) for Microsoft Windows systems. Microsoft Internet Explorer 10 and above is recommended. Microsoft Internet Explorer Compatibility View is not supported and should be disabled. Apple Safari and Mozilla Firefox might be appropriate for Macintosh systems. Other browsers might work with the offering, but they have not been fully tested.

Why do I seem not to have access to expected updates or features?
You should occasionally clear your browser’s cache to receive updates and for possible performance improvements.

What is a SAS profile?
A SAS profile is an account that you can create to access specific information and resources from the SAS website. If you are a current SAS user, then you might already have a SAS profile. If you are a new SAS user, then a SAS profile is created for you when you register for SAS OnDemand for Academics.

Can SAS OnDemand for Academics software be installed on university lab machines?
An employee of a university can download SAS OnDemand for Academics software with the intent of installing it on university lab machines (per the legal click license that must be accepted when registering for SAS OnDemand for Academics).

After the software is installed on the lab machines, only registered users of SAS OnDemand for Academics have the right to use it. These users must log on to the SAS servers using the credentials that were provided to them when they registered for the service.

General Usage

How do I log on to my SAS OnDemand for Academics Dashboard?
Your SAS OnDemand for Academics Dashboard is part of the SAS OnDemand for Academics Control Center. It includes reference information about your account as well as information about how to access software or register courses (if you are an instructor).

To log on to the SAS OnDemand for Academics Control Center, see “Access Your SAS OnDemand for Academics Account” for the SAS OnDemand for Academics software that you are using.

I have used the correct logon values and I still cannot connect to the SAS servers to perform processing using my software. What is wrong?
There are a few common reasons why you might not be able to connect:
- The SAS servers might be down at certain times for maintenance, testing, or enhancements. If you are unable to connect, then make sure that you have a working Internet connection. If you have a working connection and you still cannot connect, then try again at a later time. For more information, see SAS Server Availability.

- You might need to reset your SAS profile password. For more information, see How do I reset my SAS Profile Password.

- Your SAS profile password might be too weak. For more information, see What is a SAS Profile? and Resetting Your SAS Profile Password.

- Your account might have expired. Student accounts are valid only for the duration of a course (plus a grace period to ensure that assignments can be completed).

- My connection to the SAS servers failed after I left my machine. What happened?
  An open connection to the SAS servers will likely disconnect (time out) after one hour (or less) if the connection is idle (that is, you have not performed any processing). Many firewalls disconnect open sessions after an hour of idle time (or less). SAS recommends that you complete your work, save it, and then exit SAS OnDemand for Academics before you leave the computer.

- How do I create a course?
  To create a course, complete these steps:

  1. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click Sign In.
     The SAS OnDemand for Academics Dashboard is displayed.

  2. Click create a new course.
     The Courses page is displayed.

- Can I collaborate with other users?
  Currently, there are a few ways that you can collaborate:

  - You can share files through network storage space that both parties can access (such as AFS or NFS mounted drives).
If an instructor chooses to store data on the SAS servers for a course, then the students in that course can all share the same data by using the LIBNAME or FILENAME statement that the instructor provides.

You could consider using third-party tools, such as www.blackboard.com.

I am a professor. Can I add students to my class from other countries?

When you create a course, that course (as well as any data that you upload for your students) is connected to the set of hosted academic servers that are in your geographical region (for example, Europe or the United States).

When a user registers for SAS OnDemand for Academics, they are automatically associated with the set of hosted academic servers that are in their geographic region. If an instructor and a student are not associated with the same hosted academic servers, then the student can still use the offering, but they will not have access to any data that the professor has uploaded for the class. For example, if a professor in France has a student in the United States, then that student will not have access to any data that the professor has uploaded. The student could still use all of the other features of the offering.

Can I point to local SAS data sets or files using a LIBNAME statement or a FILENAME statement?

No. The SAS servers are unable to access or recognize the local drives of your PC. If you write a LIBNAME statement or a FILENAME statement that references a local directory path, then you receive processing errors. To determine which data storage option is available for your course, see “Options for Providing Course Data to Students” for the SAS OnDemand for Academics software that you are using.

Can I store files on the SAS servers?

Instructors have the ability to store data files on the SAS servers. Other types of files (such as program files, course notes, or directories) are not allowed. The course data can then be accessed using an appropriate LIBNAME or FILENAME statement. Instructors are provided with a unique LIBNAME and FILENAME statement for each course that they create.

I have uploaded a SAS data set, but I cannot see or access it. What is wrong?
Make sure that the SAS data set that you uploaded is named using all lowercase letters. Our hosted servers use UNIX. They do not recognize mixed case or uppercase letters. If you have uploaded a SAS data set that uses mixed case or uppercase letters, then rename the SAS data set to use all lowercase letters (with no spaces in the name) and then upload the SAS data set again.

I am an instructor. Can I upload data from third-party sources to the SAS servers?
Some universities purchase third-party data sources or use open source third-party data sources. Often, these data sources are protected by specific license agreements or terms of use. It is your responsibility to do the following:

- ensure that you have the right to upload third-party data sources to the SAS servers
- verify that usage of the third-party data sources does not violate any third-party rights or any applicable laws or regulations
- review the license agreement or terms of use for the third-party data sources in question before uploading this type of data to the SAS servers

Is there a limit to the number of times I can submit SAS jobs to the SAS servers?
No. There is no limit.

Can I use the SAS servers with other SAS software that I have licensed?
No. The SAS servers have been configured to support only software client applications associated with SAS OnDemand for Academics.

I received an error message when trying to create a folder on the SAS servers. What is wrong?
You might receive an error message such as this:

“A call to the metadata repository failed. See details for more information.”

In this case, it is likely that you were trying to create a folder on the SAS servers. This behavior is not currently supported because it is not possible to save your work on the SAS servers. Instead, save any work to a local folder. When prompted to save your work, select **Local Computer** instead of **SAS Servers** and then select the appropriate local directory.
What should I do if I forget my password?

You need to use a password to log on to SAS OnDemand for Academics or to connect to the SAS servers (SAS Cloud) when prompted by SAS OnDemand for Academics: Enterprise Guide. In all cases, your password is the same as your SAS profile password. If you have forgotten your SAS profile password, then follow these steps:

1. Use the My Profile page to update your SAS profile password.

   **Note:** Your password must meet the following criteria:

   a. It cannot be the name that you used to register or exceed two consecutive characters from that name. For example, if you registered as “Jonathan Smith,” you could not use either “Jonathan” or “Smith” and you could not include three consecutive characters such as “jon” or “ith.”

   b. It must be at least eight characters in length.

   c. It must contain characters from three of the following four categories:
      - English uppercase characters (A through Z)
      - English lowercase characters (a through z)
      - base 10 digits (0 through 9)
      - non-alphabetic characters (for example, !, $, #, %)

2. Log on to the SAS OnDemand for Academics Control Center using your SAS profile user ID and password. Click **Sign In**.

   The SAS OnDemand for Academics Dashboard is displayed.

3. Log on to a SAS OnDemand for Academics software application.
If I have trouble with my software, how do I get support?

Refer to the information in this manual under “Finding Help for Common Problems” for the software being used in your course.

How do students find out about SAS OnDemand for Academics?

Instructors are responsible for communicating their intent to use SAS OnDemand for Academics to their students. When an instructor creates a course with SAS OnDemand for Academics, the instructor can view an example “student message” text. This text can be copied and pasted into an email message that can then be sent to students. In addition, the example “student message” text can also be accessed again. Instructors can also choose to compose their own student message, if desired.

Does my SAS OnDemand for Academics account expire?

If you do not use your account for a period of one year, then your account might expire. In addition, you might be required to access new versions of the available software, accept an updated license agreement, or both to keep your account current.
Appendix 1 / Commonly Asked Questions for SAS OnDemand for Academics
## Learning Resources for SAS OnDemand for Academics

**Learning Resources for SAS OnDemand for Academics** ........................................... 134

**Training and Usage Videos** ................................................................................. 134
- Introduction ............................................................................................................ 134
- Professors ............................................................................................................... 134
- Students ................................................................................................................. 135

**e-Learning Courses** ............................................................................................ 135

**Statistics Information** ............................................................................................ 135

**SAS Studio Resources** .......................................................................................... 135
- Tutorial ..................................................................................................................... 135
- Product Documentation ............................................................................................ 136

**SAS Enterprise Guide Resources** ........................................................................ 136
- Tutorial ..................................................................................................................... 136
- Online SAS Enterprise Guide Demonstration ......................................................... 137
- Product Documentation ............................................................................................ 137
- Books ....................................................................................................................... 137
- White Papers ........................................................................................................... 137

**SAS Enterprise Miner Resources** ......................................................................... 137
- Product Documentation ............................................................................................ 137
- Books ....................................................................................................................... 138
Learning Resources for SAS OnDemand for Academics

This appendix lists resources that are available for instructors and students on http://support.sas.com. Some resources are offered at no cost. Others are available for purchase only.

Note: If any of the supporting materials identified in this appendix are not inherently accessible and you require an accessible format, then send an email to ondemandacademics@sas.com. SAS will work with you to provide an accessible format.

Training and Usage Videos

Introduction

The following videos have been designed to help you learn more about SAS OnDemand for Academics or to help you learn how to perform tasks quickly. The titles listed below are available at no cost at http://support.sas.com/ondemand/videos.html.

Professors

- Registering for SAS OnDemand for Academics: For Professors
- Creating a Course for SAS OnDemand for Academics: For Professors
Students

- Registering for SAS OnDemand for Academics: For Students
- How to Use a LIBNAME Statement: For Students
- How to Use a FILENAME Statement: For Students

e-Learning Courses

SAS provides many e-Learning courses (E-courses) to help you learn how to use SAS software. After registering, you receive an email with details about the e-Learning courses that are available to you. For more information about e-Learning, see http://support.sas.com/training/elearn/index.html.

Statistics Information

For information about basic statistics, the following tutorials and courses are available:

- SAS Tutorials
- Introduction to Statistical Concepts
- Statistics 1: Introduction to ANOVA, Regression, and Logistic Regression

SAS Studio Resources

Tutorial

A Getting Started with SAS Studio tutorial is available online.
Product Documentation

SAS Studio online documentation is available from the Product Documentation area at http://support.sas.com/documentation/onlinedoc/sasstudio/index.html.

SAS Enterprise Guide Resources

Tutorial

If you are not familiar with SAS Enterprise Guide or want to learn more about using SAS Enterprise Guide, then you might find the free Getting Started tutorial helpful. As you complete the topics in this tutorial, you learn to use the main features of SAS Enterprise Guide.

After you have completed your registration and downloaded the software, you can access this online tutorial by doing the following:

1. Select Start ➤ Programs ➤ SAS ➤ Enterprise Guide 4.2 OnDemand. The Credentials Required window is displayed.

2. Enter your SAS server user ID. You can find this user ID on your SAS OnDemand for Academics Dashboard.

3. Enter the password that is associated with your SAS profile account.

4. Select OK. The SAS Enterprise Guide window is displayed. You are now logged on to the SAS server.

Online SAS Enterprise Guide Demonstration

To see SAS Enterprise Guide in action, visit the following website: http://www.sas.com/govedu/edu/egdemo/itour_flash.html.

Product Documentation


Books

A number of books from SAS Publishing are available for SAS Enterprise Guide. You can use the SAS Bookstore website to find the books, review portions of each book, and place orders. Use the site’s search feature to locate topics or products of interest such as for SAS Enterprise Guide or Base SAS.

White Papers

You can access the following titles by visiting the following locations:

- Dynamic Projects in SAS Enterprise Guide - How to Create and Use Parameters
- Introduction to SAS Enterprise Guide 4.1 for Statistical Analysis

SAS Enterprise Miner Resources

Product Documentation

To access product documentation, sample data, and more, go to http://support.sas.com/documentation/onlinedoc/miner/index.html.
Books
A number of books from SAS Publishing are available for SAS Enterprise Miner. You can use the SAS Bookstore website to find the books, review portions of each book, and place orders. Use the site’s search feature to locate topics or products of interest such as for SAS Enterprise Miner or data mining.

SAS Forecast Studio Resources

Product Documentation
To access product documentation, sample data, and more, go to http://support.sas.com/documentation/onlinedoc/forecast/index.html.

Books
A number of books from SAS Publishing are available for SAS Forecast Studio. You can use the SAS Bookstore website to find the books, review portions of each book, and place orders. Use the site’s search feature to locate topics or products of interest such as for SAS Forecast Studio or forecasting.

JMP Resources

Product Documentation
To access JMP product documentation go to http://support.sas.com/documentation/onlinedoc/jmp/index.html.
Academic Resources

Academic resources for JMP such as videos, cases studies, and so on, are available at http://www.jmp.com/academic/academic-resources.shtml.
Here is the recommended reading list for this title:

- *SAS Studio: User’s Guide*
- *Getting Started with SAS Enterprise Miner*
- *SAS Forecast Studio: User’s Guide*

For a complete list of SAS publications, go to [sas.com/store/books](http://sas.com/store/books). If you have questions about which titles you need, please contact a SAS Representative:

SAS Books
SAS Campus Drive
Cary, NC 27513-2414
Phone: 1-800-727-0025
Fax: 1-919-677-4444
Email: sasbook@sas.com
Web address: [sas.com/store/books](http://sas.com/store/books)
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.

support.sas.com/bookstore
for additional books and resources.