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Goals
m Integrate SAS output w/ Excel

m Give you something you can use TODAY

SAS.GLOBALFORUM
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Agenda

m Review sample data
m ODS basics
Generating XML for Excel

Open output in Excel

Fix formatting issues
Using SAS server technology

AT
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Software Requirements

m Base SAS, any operating system
m SAS 9.1.3 Service Pack 4 or later
m Microsoft Excel 2002 or later (a.k.a. Excel XP)

NN
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AS Output Viewed with Excel
ri, = = LabResultsxml - Microsoft Excel s B =
Home Insert Page layout  Formulas Data Review  View Developer  SAS v@od@ =
ca - S | 12/26/2013 2:45:00 PM q
| A B B [ o E F G n 5
1 Lab Results for Subject 01-701-1015
[2
Visit Collection
| 3 Visit Name Date/Time Test Result Units Range
4 1 LAB BASELINE 12262013 2:45 PM ALB 38 g/dl 33-49)
|5 ALP 34) UL 35-15| L
| & ALT 7] UL 6-34)
|7 AST 40 UL 9-3% H
| 8 BLLI 0.6) mg/d] 02-12]
| s BUN 10} mg/dl 4-24
| 10 ca 838 mg/dl 84-103
|1 cHOL 230) mg/dl 156 - 300)
|12 CK. 70) UL 21-169)
13 cL 106) mEqL 94-112]
|14 CREAT 09 mg/dl 07-14)
15 GGT 15| UL 5-50
:16 GLUC 85) mg/dl 50 - 250)
|17 K 45) mEq/L] 34-54)
18 NA 140) mEqL 135- 145
|19 PHOS 38 mg/dl 22-51
| 20 PROT 61 g/dl 6-8
|21 URATE 43] mg/dl 25-75)
|2
|2 4 | WEEK 2 1162014 1:17 PM Jais | 39) gl 33-49] | =
M 4 » M| CHEMISTRY . HEMATOLOGY . OTHER , URINALYSIS %3 [4 b |
| Reagy | 73 | |[EE|D@ E 100% (= U o
5

The workbook includes four worksheets containing fictional lab results data
over time for a single patient. A SAS title replaces standard BY line text, and
an Excel format, not a SAS format, is used to control the appearance of the
datetime values in the "Collection Date/Time" column. SAS datetime values
are automatically converted to Excel datetime values.
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Representative Values in Sample Data

Column Column Column Tvpical Values
Name Label Type yp
Category CHEMISTRY, HEMATOLOGY, OTHER,
Ll for Lab Test CNaracter joiNALysis
VISITNUM Visit Numeric 1,4, 8, 10,13
. LAB BASELINE, WEEK 2, WEEK 4,
VISIT Visit*Name Character WEEK 26
VISIT_DATETIME COllection™ -\ i meric 1703688300, 1707828960, 1719920700
= Date/Time
LBTESTCD Test Character BILI, CHOL, EOS, WBC
LBORRES Result Character 0.05, 0.9, 1.013, 8.8, 15, 140
LBORRESU Units Character %, MILL/uL, NO UNITS, g/dL, pg/ml
RANGE Range Character 1.096 -1.03, 21 - 169, 156 - 300, not
available
LBNRIND <blank> Character A, H, L, N

Here is an abbreviated list of column properties for the LabResults SAS table
that is used to create the Excel workbook.

An asterisk (*) is used as a split character in some variable labels to control
text wrapping in the column headings, and the values in the VISIT_DATETIME
column are SAS datetime values.
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General Steps

1. Run SAS code to create output

2. Store output where Excel can access it

3. Open output with Excel

4. Modify SAS code to correct formatting problems

TR
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We use ODS to create an XML file that is stored in a location that Excel can
access. In your production system, SAS and Excel may reside on two
different systems. Thus, you may have to make use of network drives, FTP, or
some other means to move the SAS output to a location that Excel can
access.

Then the ODS output is opened using Excel. If you have ever done this
before, you have probably encountered formatting problems. We fix those
problems, and then explore techniques to instruct ODS to create output that is
more attractive.
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ODS Basics

m Part of Base SAS

Easily generate multiple output types (HTML, RTF, PDF,
XML, etc.)

m A "destination" creates the actual output

A "style" controls the appearance
‘ HTML Or RTF Or PDF ...

Usage:
ods DestName style=StyleName file=... ;

* Your SAS procedure code here;

ods DestName close;

ODS is the part of Base SAS software that enables you to generate different
types of output from your procedure code. An ODS destination controls the
type of output that is generated (HTML, RTF, PDF, etc.). An ODS style
controls the appearance of the output (colors, fonts, border lines, etc.).

Both a destination and a style are needed to generate output. If you do not
specify a style, a default style is used.

We use a special type of ODS destination called a "tagset". ODS tagsets can
be modified to meet your specific needs using the TEMPLATE procedure,
which is part of the Base SAS product. And you can use the TEMPLATE
procedure to create your own tagsets.

TEMPLATE Procedure Overview

SAS 9.3: http://tinyurl.com/mnzeok3
SAS 9.4: http:/ltinyurl.com/pz6zqgr4
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ODS Basics - Output for Excel

m Excel can open specially made XML files as multi-sheet
workbooks (graphics not supported)
m Use the ExcelXP tagset and Printer style:
ods listing close;
ods tagsets.ExcelXP style=Printer file=...
* Your SAS procedure code here;

ods tagsets.ExcelXP close;

VAN
SAS.GLOBALFORUM
/7%

We use the ODS tagset named ExcelXP to create XML output that can be
opened using Microsoft Excel 2002 and later. When opened with Excel, the
XML file is rendered as a multi-sheet Excel workbook. Additionally, we use an
ODS style named Printer, supplied by SAS, to control the appearance of the
output.

Because the ExcelXP ODS tagset creates files that conform to the Microsoft
XML Spreadsheet Specification, you can create multi-sheet Excel workbooks
containing the output from almost any SAS procedure. The exception is that
the Microsoft XML Spreadsheet Specification does not support images, so the
output from graphics procedures cannot be used.

Microsoft XML Spreadsheet Reference

http://tinyurl.com/3p6sked
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Basic SAS Code

title 'Lab Results for Subject 01-701-1015';

proc report data=sample.LabResults nowd split='*"';
by lbcat;

column ... ;
define ... ;

compute range / char length=13;
* Create Low-High range (Ex. 3.3 - 4.9);
endcomp ;

compute lbnrind; ’9

if (upcase(lbnrind) eq 'N') then lbnrind = '';
endcomp ;

compute after wvisitnum;

line '';
endcomp ; AT
run; quit; SAS.GILOBALFORUM

10

The COLUMN statement specifies the order to display the columns, and the
column roles, justification, labels, and formats are specified in the DEFINE
statements.

The first COMPUTE block constructs the range if both low and high values are
available for the test, otherwise "not available" is used for the value.

The second block suppresses the display of the LBNRIND value for tests with
normal results, and the third block inserts a blank line between office visits.

A complete listing of the SAS code is in the accompanying paper.

Copyright © 2014, SAS Institute Inc. All rights reserved. 10



Using ODS and the ExcelXP Tagset

ods tagsets.ExcelXP file='LabResults.xml' style=Printer;
title 'Lab Results for Subject 01-701-1015';

proc report data=sample.LabResults nowd split='*';
by lbcat;

column

define

compute ... ;
run; quit;

ods tagsets.ExcelXP close;

SAS.GLOBALFORUM

"

The ExcelXP tagset generates the output, and the PRINTER style controls the
appearance of the output.

By default, the ExcelXP tagset creates a new worksheet when a SAS
procedure creates new tabular output. PROC REPORT is run with a BY
statement and creates four tables, one for each distinct value of the LBCAT
variable. Each table is created in a separate worksheet.

The last ODS statement closes the ExcelXP destination and releases the XML
file so that it can be opened with Excel.

Copyright © 2014, SAS Institute Inc. All rights reserved.

11



Open LabResults.xml with Excel

m Open Excel: Start> Programs > ...

File > Open

Navigate to ...\LabResults.xml
and click Open

~0OR ~

Navigate to output directory and é]ﬂ
double-click LabResults.xml

SAS.GILOBALFORUM

/7%

12

The XML file created by ODS can now be opened with Microsoft Excel.

Excel reads and converts the XML file to the Excel format. After the
conversion, you can perform any Excel function on the data.

To save a copy of the file in Excel binary (xIs) format using Excel 2002, 2003
or 2010, select File = Save As and then, from the Save as type drop-down
list, select Microsoft Excel Workbook (*.xIs). If you're using Excel 2007,
click the Microsoft Office Button, and then select Save As =» Excel 97-2003
Workbook.

If you're using Excel 2007 or 2010 and want to save the document in the
Microsoft Office Open XML format, choose Excel Workbook (*.xIsx) from the
Save as type drop-down list.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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LabResult | Viewed with Excel
abresults.xmi viewea wi Xce
@ d - LabResultexm - Microsoft Excel o B B
Home  Insert  Pagelayout  Formulas Data  Review  View  Developer  SAS v @od@ =
=) - £ | 2013-12-26T14:45:00 ;l
A B [ & D E F G H =
1 Category for Lab Test=CHEMISTRY
Visit Collection
2 Visit Name Date/Time Test Result Units Range
3 1 LAB BASELINE 2013-12-26T1:45:00 [ar8 38 gl 33-49)
4 [aL? 34 1] 35-15] L
5 aLT 7] 1] 6-34
6 asT P 1] 9-1| ®
7 Bt 06, mg/dl 02-12
8 BUN 10 mg/dl 4-24
9 ca 55| mg/dl 8.4-103
10 croL 230 mg/dl 156 - 300
1n cx 70 i 21-169
2 = 106 mEq/L 94-112]
13 cREAT 09 mg/dl 07-14
14 coT 15 ] 5-50
15 oLuc 5 mgdl 50- 250
16 B 45 WEQL 34-54
17 NA 140 WEQL 135145
18 rOS 38 mg/dl 22-51
19 rrOT 61 gl 6-5)
20 vRaTE 45 mg/dl 25-75
21
2 4 | WEEK 2 [2014-01-16T13:700 Jas I 39] gl] 33-49] ]
2 [ | [are 0] v 35-113) >
i 4+ | Table 1 - Category for Lab Test __ Table 2 - Category for Lab Test __ Table 3 - Category for Lab Test _~_Table 4 - Category for Lab Test _ 3 []4 #[] |
Ready | 7 |0 100% (=) 'y +)
13

Here are the results of executing the basic SAS code, and then opening the
resulting LabResults.xml file with Excel. This output resembles the desired
format, but has the following problems:

1. Unattractive, default worksheet names are used.
2. Title text is missing.

3. Standard BY line text ("Category for Lab Test=CHEMISTRY") precedes the
table.

4. The collection date and time values are displayed differently.

We can now change the basic SAS code to correct these problems.

Copyright © 2014, SAS Institute Inc. All rights reserved.



Run Setup.sas

1. Start SAS Q"

2. File > Open Program g
3. Select Setup.sas and then click Open

4. Review code and then submit

SAS.GLOBALFORUM
A4
R 14

The SAMPDIR global macro variable specifies the directory containing our
sample code and data, as well as the ODS-generated XML output.

The program assigns a SAS library (SAMPLE) for the input data, using the
SAMPDIR macro variable.

Copyright © 2014, SAS Institute Inc. All rights reserved.



Ex. 1 - Creating the Initial Workbook

Go to SAS @

File > Open Program > Exercise1.sas g
Review code and then submit

Start Excel, and then File > Open

Navigate to C:\HOW\DelGobbo\

Double click LabResults.xml

NOo Ok 0N =2

Close document; keep Excel open

SASGILOBALFORUM
s 15
TO DO:
Review and submit the code, and then view the resulting XML file using
Excel.

Copyright © 2014, SAS Institute Inc. All rights reserved.



Understanding and Using
the ExcelXP Tagset Options

The following techniques apply to all SAS procedure output.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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9 o-s LabResultexm - Microsoft Excel o B =B
Home  Insert  Pagelayout  Formulas Data  Review  View  Developer  SAS v @od@ =
=) - e | 2013-12-26T14:45:00 o

A | B [ [ E | F | G H &

1 Category for Lab Test=CHEMISTRY M

Visit Collection

2 Visit Name Date/Time Test Result Units Range

3 1 LAB BASELINE 2013-12-26T1:45:00 [ar8 38 gl 33-49

4 [are 34 1 315 L

5 aLT 7] 1] 6-34

6 asT P ] 9-3 ®

7 Bt 06, mg/dl 02-12]

8 BUN 10 mg/dl 4-24)

9 ca 55| mg/dl 84-103

10 croL 230 mg/dl 156 - 300

1 cx 70 ] 21-169

2 = 106 mEq/L 94-112]

13 cREAT 09 mg/dl 07-14)

18 coT 15 i 5-50)

15 oLuc 5 mgdl 50-250

16 B 43 WEQL 34-54

17 NA 140 WEQL 135185

18 oS 38 mg/dl 22-51

19 rrOT 61 gl 6-5

20 vRaTE 45 mg/dl 25-73)

2

22 fl | WEEK 2 “16T1317:00 Jas I 39] gl 33-49] ]

2 [ Jare | 0] v 35-113) >

i< v %] Table 1 - Category for Lab Test _Table 2 - Category for Lab Test __Table 3 - Category for Lab Test _~_ Table 4 - Category for Lsb Test €3 []4 #[]

Ready | ] |[FEOm 00 ) U o

17

ODS generates a unique name for each worksheet, as required by Excel.

However, the names are generally not very attractive. There are several
tagset options that you can use to alter the names of the worksheets.

Copyright © 2014, SAS Institute Inc. All rights reserved.



ExcelXP Tagset Options

[ ] Syntax: options (option-name="'option-value')

Example: Hard-coding worksheet name

options (sheet name='worksheet-name') ;

Option values must be quoted

m Can have multiple ODS statements

Options remain in effect until changed

SAS.GILOBALFORUM

/7%
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The ExcelXP tagset supports many options that control both the appearance
and functionality of the Excel workbook. Many of these tagset options are
simply tied directly to existing Excel options or features. Tagset options are
specified in an ODS statement using the OPTIONS keyword, as shown above.

For example, ODS automatically generates unique worksheet names, but we
can use the SHEET_NAME option to explicitly specify a worksheet name. In
our case we don't want to hard code the names, so a different set of options
are used.

IMPORTANT NOTE: Tagset options remain in effect until they are set to
another value, or until the ODS destination is closed.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Change the Worksheet Names

®m SHEET INTERVAL — When to create worksheets
m SHEET LABEL — Prefix for worksheet name

CHEMISTRY, HEMATOLOGY, OTHER, URINALYSIS

ods tagsets.ExcelXP options(sheet interval='bygroup'
sheet label=' ');

SAS.GLOBALFORUM
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ODS generates a unique name for each worksheet, as required by Excel.
There are, however, several tagset options that you can use to alter the names
of the worksheets.

The SHEET_INTERVAL option controls the interval at which SAS output is
placed into worksheets, and SHEET_LABEL is used to specify the prefix for
the worksheet names.

When used together as shown here, the current value of the first BY variable,
without any prefix, is used in the worksheet name.

Copyright © 2014, SAS Institute Inc. All rights reserved. 19



Change the Worksheet Names

ods tagsets.ExcelXP file='LabResults.xml' style=Printer;
title 'Lab Results for Subject 01-701-1015';

ods tagsets.ExcelXP options(sheet interval='bygroup'
sheet label=' ');

proc report data=sample.LabResults nowd split='*"';
by lbcat;

column ... ;
define ... ;
compute ... ;

run; quit;
ods tagsets.ExcelXP close;

AT
SAS.GLOBALFORUM
)/ ”

The additional ODS statement to handle the tagset options.

NOTE: When specifying additional ODS statements, do not specify the FILE,
STYLE, or any other keyword or option that is supported by ODS. Those
options should be specified only in the initial ODS statement.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Change the Worksheet Names

M 4 » M| CHEMISTRY ~HEMATOLOGY . OTHER . URINALYSIS ¥J

SAS.GLOBALFORUM
L 21

The worksheet names now match the desired output.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Ex. 2 - Change the Worksheet Names

Go to SAS @

File > Open Program > Exercise2.sas g
Follow TO DO instructions and then submit

Go to Excel

File > Recent, and then select LabResults.xml

Note worksheet names

N o o bk~ b=

Close document; keep Excel open

AT
SAS.GLOBALFORUM
N7

TO DO:

Line 13: Specify the value for the SHEET _INTERVAL option to create a
separate worksheet for each unique value of the BY variable LBCAT.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Display Title in Worksheet

m Title text — Excel print header

m Can control location of title text:

embedded titles='yes'

VAN
SAS.GLOBALFORUM
/7% 2

By default, SAS titles and footnotes appear as Excel print headers and print
footers, respectively, which are displayed when the Excel document is printed.
You can confirm this by viewing the Excel Header/Footer tab of the Page
Setup dialog box.

To include title text on-screen, in the worksheet body, use the
EMBEDDED_TITLES option.

Copyright © 2014, SAS Institute Inc. All rights reserved.



Display Title in Worksheet

ods tagsets.ExcelXP file='LabResults.xml' style=Printer;
title 'Lab Results for Subject 01-701-1015';
ods tagsets.ExcelXP options(sheet interval='bygroup'

sheet label=' '
embedded titles='yes');

proc report data=sample.LabResults nowd split='*"';
by lbcat;

column ... ;
define ... ;
compute ... ;
run; quit;
ods tagsets.ExcelXP close;
SAS.GLOBALFORUM
L 24

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Display Title in Worksheet
@d .= LabResults.xmi - Microsoft Excel e ® =
Home Inset  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@c@ =
cs - Jfe | 2013-12-26T14:45:00 *|

[ A B [ 5 [ E F G RS
1 Lab Results for Subject 01-701-1015

2 ,

3 Category for Lab Test=CHEMISTRY

Visit Collection

|4 Visit Name Date/Time Test Result Units Range
[s 1 LAB BASELINE 2013-12.26T14:45:00 ALB 38| gdl 33-49

6 ALP 34 uL 3515 L

7 ALT E UL 6-34

8 AST 40 [ 9-3 H

9 BILI 06 ng/d]| 02-12

10 BUN 10 mg/d]| 4-24

1 cA 83| mg/d]| 84-103

12 CcHOL 230 mg/d]| 156 - 300)

13 K 70 UL 21-160

14 cL 106 mEqL] 93-112

15 CREAT 09 mg/dl| 07-14

16 GeT 15 UL 5-50

17 cLuc 8 ng/d]| 50-250

18 K 45 mEq/L] 34-54

19 NA 140 mEq/L] 135 - 145

20 PHOS 38 mg/d]| 22-51

2 PROT 6.1 5d| 6-3|

2 URATE 45 mg/d] 25-75

2

2 4 [ WEEK 2 2014-01-16T1317:00 Jas [ 39] g/d] 33-49] | B
W 4+ M| CHEMISTRY _HEMATOLOGY _ OTHER , URINALYSIS _ 3. e »
| Ready | 3 | |[EE D 100% (=) { +)

25

BY line text appears in the worksheets because the REPORT procedure is
executed with a BY statement. However, this text is redundant because the
BY value is displayed in the worksheet name.

Copyright © 2014, SAS Institute Inc. All rights reserved.



Suppress BY Line Text

m Do not use NOBYLINE system option
m Use SUPPRESS_ BYLINES tagset option:

suppress_bylines='yes'

VAN
SAS.GLOBALFORUM
/7%

26

To omit the BY line text, specify the SUPPRESS_BYLINES option in the ODS
statement.

Do not use the NOBYLINE system option, because this disables BY group
processing in the ExcelXP tagset, even though the SHEET INTERVAL tagset
option is set to "bygroup".

Copyright © 2014, SAS Institute Inc. All rights reserved.



Suppress BY Line Text

ods tagsets.ExcelXP file='LabResults.xml' style=Printer;
title 'Lab Results for Subject 01-701-1015';

ods tagsets.ExcelXP options(sheet interval='bygroup'
sheet label=' '
embedded titles='yes'
suppress_bylines='yes') ;

proc report data=sample.LabResults nowd split='*';
by lbcat;

column ... ;
define ... ;
compute ... ;

run; quit;
ods tagsets.ExcelXP close; TR
SAS.GLOBALFORUM
g 27
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Suppress BY Line & Display Title

=] - LabResultsxml - Microsoft Excel - @ =
Home  Inset  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@o @ n
ca hd x| 2013-12-26T14:45:00 ;j
A B C D E F G H s
1 Lab Results for Subject 01-701-1015
2
o . Nave |_____ _Date/Time_ _ Tt Qarett Units __ . Rapre

545.GILOBAILFORUM

28

Only the title text precedes the table.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Ex. 3 - Suppress BY Line & Display Title

1. Goto SAS @

2. File > Open Program > Exercise3.sas g
3. Follow TO DO instructions and then submit

4. Go to Excel

5. File > Recent, and then select LabResults.xml

6. Note title in worksheets

7

. Close document; keep Excel open

AT
SAS.GLOBALFORUM
N7

TO DO:

Line 15: Specify the value for the EMBEDDED_TITLES option to display
title text within the worksheets.

Line 16: Specify the option to suppress BY line text.

Copyright © 2014, SAS Institute Inc. All rights reserved.



Understanding and Using
ODS Style Overrides

AN

SAs!\ZlLbﬁA;. FORUM
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30

The techniques described in this section only work only with the PRINT,
REPORT, and TABULATE procedures.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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SAS Datetime — Excel Datetime, Pt. 1

Collection
Date/Time

2014-01-16T13:17:00

m SAS & Excel use different date/time systems
m Excel prefers ISO 8601 datetime (SAS E8601DT format)
m But ... ODS specifies String for data type in XML

<Cell ss:StyleID="data__1" ss:Index="3">
<Data ss:Type="String">2014-01-16T13:17:00</Data>

</Cell> \
Needs to be DateTime
TR

SAS :G::l;bMLFORUM

/7%
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SAS and Microsoft Excel use different date and time systems. Consequently,
you often encounter problems when Excel reads SAS output containing
datetime values.

One way to correct this behavior is to write SAS code to convert numeric SAS
datetime values to numeric Excel datetime values, but this approach is
problematic because you must alter your original SAS data.

A better solution is to allow automatic datetime conversion to take place
between SAS and Excel.

Because Excel expects datetime values to be represented using the 1ISO 8601
format (yyyy-mm-ddThh:mm:ss), SAS datetime values should be formatted
using the 1S8601DT format. However, open the LabResults.xml file using a
text editor and you will see that the datetime cells are specified to be String
type. You cannot apply Excel formats or perform mathematical operations on
the data in these cells.

We use an ODS style override to fix this problem.

Copyright © 2014, SAS Institute Inc. All rights reserved. 31



ODS Style Overrides

m Supported by PRINT, REPORT, and TABULATE
m Change any ODS style attribute via STYLE=

m Example:
Location Attributes
define visit /
style(column) = [font_style = italic
background = orange]

m Refer to the ODS documentation for a list of supported
attributes

m Referto PRINT, REPORT, and TABULATE doc for
sample usage

AR
SAS.GLOBALFORUM
g a2

Style overrides are supported by the PRINT, REPORT, and TABULATE
procedures, and can be specified in several ways, with the most common
shown here.

This example overrides the font style and the cell background color attributes
for the data values in the VISIT column.

Copyright © 2014, SAS Institute Inc. All rights reserved.



.
ODS Style Overrides — Example Output
@d - LebResults.em - Microsoft Excel - B =
Home Insert Page Layout Formulas Data Review View Developer SAS @ 0 o @ 8
ca - fe| 2013-12-26T14:45:00 -
A B C D E F G H ?
1 Lab Results for Subject 01-701-1015
2
Visit Collection
3 Visit Name Date/Time Test Result Units Range
4 1 LAB BASELINE 2013-12-26T14:45:00 ALB 38 gdl 33-49
5 ALP 34 UL 35- 115/ L
6 aLT 27 U 6-3
7 AST 40 U/L| 9-34 H
8 BILI 08 mg/dl 02-12)
9 BUN 10 mg/dl| 4-24
10 ca 53| mg/dl 84-103
1 cHoL 230 mg/dl 156 300)
12 [ 7 vl 21-169
13 = 106 mEqL 94-112
14 CcREAT 09) mg/dl 07-14
15 6T, 15 Ul 5-50
16 GLuc 55, mgdl 50-250
17 K 43| mEqL 5454
18 NA 140 mEqL 135- 145
19 PHOS 38 mg/dl 22-51
20 PROT 61 gl 5-5
21 URATE 43] mg/dl 25-75
22
2 4 | WEEK 2 2014-01-16T13:1700 [as [ 39) g 33-49] | B
H M | CHEMISTRY ~HEMATOLOGY . OTHER . URINALYSIS p=] ] 4 » :
Ready | 73 E|0 & 100% (= {+
33

Style Attributes

SAS 9.3: http://tinyurl.com/nufsw4o
SAS 9.4: http://tinyurl.com/kj5zqy3

PRINT Procedure Examples

SAS 9.3: http://tinyurl.com/ct3j7t4
SAS 9.4: http://tinyurl.com/I74t9rr

REPORT Procedure Examples

SAS 9.3: http://tinyurl.com/axngrd4
SAS 9.4: http://tinyurl.com/mv8hzuu

TABULATE Procedure Examples

SAS 9.3: http://tinyurl.com/bdqgl4c
SAS 9.4: http://tinyurl.com/o4ojttr

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Location Values for PROC REPORT

header header header

column column

column column column
summary summary summary

column column column
column column column
summary summary summary

34

Style overrides are applied to specific parts of your SAS output. These
specific parts of your SAS output are called locations.

The COLUMN location of PROC REPORT controls the appearance of data
cells.

SAS® 9 Reporting Procedure Styles Tip Sheet

http://tinyurl.com/3cfqdv9

Copyright © 2014, SAS Institute Inc. All rights reserved.



SAS Datetime — Excel Datetime, Pt. 1
m Current DEFINE statement:

define visit datetime / order left 'Collection*Date/Time’
format=e8601dt. ; /

m Apply style override to specify data type:

define visit_datetime / order left 'Collection*Date/Time’
format=e8601dt.
style (column)=[tagattr='type:DateTime'] ;

AT
SAS.GLOBALFORUM
W,

Because Excel does not recognize the value as a datetime value, you cannot
apply Excel formats or perform mathematical operations on the data.

To fix this problem, use the TAGATTR attribute in a style override to specify
that the value is an Excel DateTime type.

NOTE: The value specified in the style override, DateTime, is case-sensitive.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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SAS Datetime — Excel Datetime, Pt. 1

ods tagsets.ExcelXP file='LabResults.xml' style=Printer;
title 'Lab Results for Subject 01-701-1015';
ods tagsets.ExcelXP options(...);

proc report data=sample.LabResults nowd split='*"';
by lbcat;

column ... ;
define visit datetime / order left 'Collection*Date/Time'
format=e8601dt.
style (column) =[tagattr='type:DateTime'];
compute ... ;
run; quit;

ods tagsets.ExcelXP close; SASGILOBALFORUM

36
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u .
SAS Datetime — Excel Datetime, Pt. 1
9= LabResults.xml - Microsoft Excel e @ =
Home Insert  Pagelayout  Formulas  Data  Review  View  Developer SAS v@od@ =
ca - J | 41634.6145833333 v
A B I c [ o E F G H O[5
1 Lab Results for Subject 01-701-1015 M
2 J
Visit J
3 Visit Name W Test Result Units. Range
4 1 LAB BASELINE 41634 61458 |ALB 38 g/dl 33-49)
5 ALP 34 UL B-15[ L
6 ALT Fij UL 6-34)
7 AST 40| UL 9-4 H
8 BILI 06 mg/dl 02-12)
] BUN 10) mg/d| -4
10 ca 83| mg/dl 84-103)
1 CHOL 230 mg/dl 156 - 300
12 K 0| UL 21-169
13 cL 106 mEqL 94-112)
14 CREAT 09 mg/d| 07-14]
15 GGT 15 UL 5-50)
16 GLUC 85 mg/dl 50- 250
17 X 45 mEqL 34-54
18 NA 140 mEqL 135 - 145|
19 PHOS 38 mg/dl 22-51
20 PROT 61 g/d 6-8
21 URATE 45 mg/d] 25-75]
2
2 4 [ WEEK 2 41655.55347 Jae [ 3] gd] 33-49] | B
W 4+ M| CHEMISTRY ~HEMATOLOGY . OTHER . URINALYSIS %3 el ] » [l
Ready | 7 | |[ED@ 0% ) O ®
37

After the automatic conversion, the cells now contain unformatted Excel
datetime values.
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1
2
3
4.
5
6
7

. Goto SAS

. File > Open Program > Exercise4.sas

. Follow TO DO instructions and then submit

Go to Excel

. File > Recent, and then select LabResults.xml
. Note datetime value in cells; apply Excel format

. Close document; keep Excel open

Ex. 4 - SAS Datetime — Excel Datetime

.
I

AT
SAS.GLOBALFORUM

38

TO DO:

Line 26: Specify the Excel data type DateTime for the value of the
TAGATTR style attribute.

Optional:

1. Click a cell containing a datetime value to select it.
2. Click the Home tab on the Excel ribbon.
3. Choose an Excel format from the Number group.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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SAS Datetime — Excel Datetime, Pt. 2

Have Want
Collection Collection
Date/Time —) Date/Time

41655.5534722222 1/16/2014 1:17 PM

m SAS datetime automatically converted to Excel datetime
m Excel applies General format
m Need to apply Excel m/d/yyyy h:mm AM/PM format

AT
SAS.GLOBALFORUM
N7

The SAS datetime value is automatically converted to an Excel datetime value,
and Excel applies the "General" format.

We use an Excel format, specified in a style override, to control the display
values in Excel.
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Some Excel Datetime Formats

Excel Format

m/d/yyyy h:mm AM/PM

mm/dd/yy hh:mm AM/PM
ddmmmyyy:hh:mm:ss
mm/dd/yy

hh:mm AM/PM

m/d/e
yyyy-mm-ddThh:mm:ss
mmm d, yyyy \@ h:mm AM/PM
mmmm d, yyyy \@ h:mm a/p
ddd mmmmm d, yyyy

dddd mmm d, yyyy

General

# ##H.0000

Display Value

* 1/16/2014 1:17 PM

01/16/14 01:17 PM
16Jan2014:13:17:00
01/16/14

01:17 PM

1/16/2014
2014-01-16T13:17:00

Jan 16, 2014 @ 1:17 PM
January 16, 2014 @ 1:17 p
Thu J 16, 2014

Thursday January 16, 2014
41655.55347

41,655.5535

VAN

SAS ﬁ:l;rbMLFORUM

N2

40

This table shows how the Excel datetime value for January 16, 2014 at 1:17
pm is displayed in Excel using different formats.

Excel assigns the "General" format by default, and we use an ODS style
override to specify the "m/d/yyyy h.mm AM/PM" format.
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SAS Datetime — Excel Datetime, Pt. 2

Apply style override to specify Excel format:

define visit datetime / order left 'Collection*Date/Time’
format=e8601dt.
style(column)=[tagattr='type:DateTime
format:m/d/yyyy h:mm AM/PM'] ;

SAS.GLOBALFORUM
A\

a1

Copyright © 2014, SAS Institute Inc. All rights reserved.
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. "
SAS Datetime — Excel Datetime, Pt. 2
@9~z LabResults.xml - Microsoft Excel e B =
n Home  Insert  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@o@ =
il Je | 12/26/2013 2:45:00 PM v
A 8 [ c [ o £ G G IR
1 Lab Results for Subject 01-701-1015 7
2 “
m (-
3 Visit Name Test | Result |  Units Range
4 1 LAB BASELINE 12262013285 PM 35 gl 33-49
5 [ALP 34 UL 35- 115/ L
6 ALT 27] UL 6-34)
7 asT 0 i 93 ®
s BILI 06 mg/dl 02-12)
s BUN 10 mg/dl 42
10 ca 88 mgdl 84-103
1 (CHOL 230) mg/dl| 156 - 300|
12 cx 70 i 21169
13 cL 106 mEqL 94-112)
14 cREAT 09) mg/dl 07-14
15 66T 15 1] 5-50
16 (GLUC 85| mg/dl| 50 - 250|
17 K 45 mEqL 34-54
13 Na 140 mEqL 135 145)
13 PHOS 35 mgdl 22-51
20 PROT 61 gl 6-8
21 URATE 45| mg/dl| 25-75,
2
) 4 | WEEK 2 1162014 1:17PM Jais | 39] gl 33-49] | =
4 4> M| CHEMISTRY . HEMATOLOGY _ OTHER , URINALYSIS . ©J iF] 1 ] > [
Ready | 7] | | 8|0 M 100% (=) ) )
42

With all the code modifications in place, the resulting workbook matches the
desired output.
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Ex. 5 - SAS Datetime — Excel Datetime

1. Goto SAS @

2. File > Open Program > Exercise5.sas g
3. Follow TO DO instructions and then submit

4. Go to Excel

5. File > Recent, and then select LabResults.xml

6. Note Excel-formatted datetime values

7

. Close document; keep Excel open

AT
SAS.GLOBALFORUM
)/ s

TO DO:

Line 26: Specify the Excel format m/d/yyyy h:mm AM/PM for the value of
the TAGATTR style attribute.
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Open-Ended Exercise: Excel Formats
Go to SAS

Go to Exerciseb.sas g
Specify a different Excel format and then submit

Go to Excel

File > Recent, and then select LabResults.xml

Note Excel-formatted datetime values

NOo Ok 0N =2

Close document; keep Excel open

AT
SAS.GLOBALFORUM
)/ »

TO DO:

Line 26: Specify various Excel formats, using the sample values shown on
an earlier slide as a guide.
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Using SAS/IntrNet®
and
SAS Stored Processes

SAS GLOBALFORUM
A

45
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SAS/IntrNet® and SAS Stored Processes

m SAS code is run from non-SAS client
m SAS is on any platform
m Client needs only a Web browser

SAS output is delivered in real-time

Web-enable the code we've been using

VAN
SAS.GLOBALFORUM
/7%

46

The purpose of the SAS/IntrNet® Application Dispatcher or SAS Stored
Processes are to allow you to execute SAS programs from a client machine
that does not have SAS installed. The client machine may have SAS installed,
but that is not required.

A typical client-server model is followed. The SAS server can reside on any
hardware platform (Windows, UNIX, z/OS, etc.) and is standing by, waiting to
execute a SAS program. The most common client is a Web browser, again,
running on any platform.

When the "OK" button of the Web page is clicked, input parameters, if any, are
sent to the SAS server. Your SAS code executes, and the output is delivered
in real-time to the Web browser.

The following slides illustrate this process, using a Web-enabled version of the
SAS code we have been working on.
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Dynamically Generated XML

[E=8 EoR ==
=1 £ - B¢ X || @ Sample: Lab Results Data
File Edit View Favorites Tools Help
i v B v ) m v Pagev Sefety~ Took+ @~

SAS/IntrNet® Application Dispatcher

Sample: Lab Results Data

This sample is based on the code used in the Hands-on Workshop entitled, "Creating Multi-Sheet Microsoft Excel
Workbooks with SAS: The Basics and Beyond Part 1"

Clicking the "Download to Excel" button causes SAS to dynamically generate a multi-sheet Excel workbook that is
automatically opened by Excel

Download to Excel Show SAS Log

#®100% ~

a7

Here is a simple Web page that is used to execute SAS code stored on a
server using the SAS/IntrNet Application Dispatcher.

The code that is executed is substantially similar to the final version of the

code that we used to generate XML file, with a few changes to "Web-enable"
it.

Refer to the accompanying paper for instructions on how to Web-enable your
code.

Clicking Download to Excel executes the SAS program on the server.

Copyright © 2014, SAS Institute Inc. All rights reserved.
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Dynamically Generated XML

Do you want to open or save LabResults.xml (286 KB) from localhost? Open Save > Cancel

48

Once the SAS program executes, the results are sent back to the Web
browser.

Instead of the results being displayed in the Web browser, you are presented
with a File Download dialog box.

You can click Open to immediately open your SAS output using Excel, or click
Save to save a copy for later use.
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Dynamically Generated XML
(I._jl =] = LabResultsxml - Microsoft Excel o B =
Home Insert Page layout  Formulas Data  Review  View Developer  SAS v@od@ =
ca - Je | 12/26/2013 2:45:00 PM q
| A B [ c [ o E F G n [
|1 Lab Results for Subject 01-701-1015
Visit Collection
L3 Visit Name Date/Time Test Result Units. Range
4 1 LAB BASELINE 12/26/2013 2:45 PM ALB 38 g/dl 33-49
|'s ALP 3 UL 3-115| L
| 6 ALT 7 UL 6-34
|7 AST 40 UL 9-34 H
| 8 BLLI 06 mg/dl 02-12)
| 9 BUN 10 mg/d] 4-24)
| 10 ca 88 mg/dl 84-103
|12 CcHOL 230 mg/dl 156 - 300)
|12 cK 70 UL 21-169
|13 cL 106 mEgL 94-112)
|18 CREAT LE] mg/dl 07-14)
15 GGT 15 UL 5-50
:15 GLUC 85 mg/dl 50 - 250
|17 K 45 mEqL 34-54
|18 NA 140 mEgL 135 - 145,
|19 PHOS 38 mg/dl 22-51
| 20 PROT 61 g/dl 6-8
|21 URATE 45 mg/dl 25-75,
|22
|23 4 | WEEK 2 1/162014 1:17 PM Jais | 39 | 33-49] | =
H 4 » M| CHEMISTRY /HEMATOLOGY . OTHER . URINALYSIS %3 [4 b |
| Reagy | &3 | |[EDME 100% U o
49

Here is the SAS output, created in real-time, and delivered to the client. Refer
to the accompanying paper for more information about this topic.

SAS/IntrNet Application Dispatcher

SAS 9.3: http://tinyurl.com/3qpxzlg
SAS 9.4: http://tinyurl.com/n8uqq92

SAS Stored Processes

SAS 9.3: http://tinyurl.com/3wyw6fk
SAS 9.4: http://tinyurl.com/q99jov6
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Conclusion
m Use ExcelXP tagset to create XML file

Resulting XML file can be viewed with Excel

m Make use of tagset options

Apply ODS style overrides

Use Excel formats instead of SAS formats

7R
SAS.GLOBALFORUM

50

Using ODS to generate specially formatted XML output is an effective method
of incorporating SAS output into Excel documents.

The SAS®9 ExcelXP ODS tagset provides an easy way to export your SAS
data to Excel workbooks that contain multiple worksheets. By using ODS
styles, style overrides, and a tagset that complies with the Microsoft XML
Spreadsheet Specification, you can customize the output to achieve your
design goals.

SAS Institute continues to work toward better Microsoft Office integration, and
future releases of SAS software will provide even more robust means of using
SAS content with Microsoft Office applications.
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Resources
m Paper & Download Package

support.sas.com/rnd/papers/index.html#excel2014

m Vince's ExcelXP Resources

www.sas.com/reg/gen/corp/8672267page=Resources

SAS»GILG%LFORUM

N\~
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Contact Information

Please send questions, comments and feedback to:

Vince DelGobbo
sasvcd@SAS.com

If your registered in-house or local SAS users group would like
to request this presentation as your annual SAS presentation
(as a seminar, talk or workshop) at an upcoming meeting,
please submit an online User Group Request Form
(support.sas.com/usergroups/namerica/lug-form.html) at least
eight weeks in advance.
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