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Goals

m Integrate SAS output w/ Excel
m Compare 3 different techniques

m Give you something you can use TODAY
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Agenda

m Review sample data

m Technique #1: EXPORT procedure
m ODS basics

m Technique #2: ODS CSVALL
Technique #3: ODS ExcelXP
Using SAS server technology

/ SASGLOBALFORUM
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We discuss three techniques for using Base SAS® to get data into Excel.

Technique #1 produces a comma-separated value (CSV) file that contains only
data and no formatting of any kind.

Technique #2 produces a CSV file with data and some grouping, but still no
formatting and color.

Technique #3 produces the desired workbook, complete with formats, colors,
and correct groupings.

We conclude with a discussion of how to drive dynamic data to Excel using SAS
server technology.
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Software Requirements

m Base SAS, any operating system
m SAS 9.1.3 Service Pack 4 or above
m Microsoft Excel 2002 or above (a.k.a. Excel XP)
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SAS Output Viewed with Excel
@ - VitalSigns-ExcelXP.xml - Microsoft Excel o B =
“ Home  Insert  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@ocd@ R
A B c D E &l
1 Subject ID: 1
2
3 Vital Signs: Time| R Rate (/min) Heart Rate (bpm)| _SBP (mmHg)| DBP (mmHg)|
4 -2.00 16 105| 135 84
5 0 9 59) 128 73
6 002 9 64 126 83
7 0.08 9| 64 133 91
8 0.17] 12 72 136 90
9 025 14 ) 130 82
10 100 16, 73 135 73
11 2.00 12 72 124 65
12 3.00 12 81 132 77
13 400 2 80 120 0
14 5.00 19) 80 120 0
15 8.00 16, 9% 150 9%
16 24.00] 20 80| 120 70
17
18 Subject ID: 2
19
20 Vital Signs: Time R Rate (/min) Heart Rate (bpm)|  SBP (mmHg)[ DBP (mmHg)
2 200 13 7| 9 56
22 -1.00 12 35 135 8
3 00 1) 50) 177 7
24 0.08 14 58] 104 7
b1 017 13 54 123 9
26 0.25 18 55 12 5|
27 1.00 24 60| 116 '8 -
4 4 » W] Trial ABC 123  Trial XYZ 987 %3 okl 20
Reagy | 1 5|00 . 100% (=) + 5

The worksheets contain fictional vital signs data for clinical trials "ABC 123" and
"XYZ 987". The worksheets contain one table for each patient enrolled in the
trial, resulting in multiple tables in each worksheet.

An Excel format, not a SAS format, is used to control the appearance of the Vital
Signs: Time column, and a TITLE statement is used to display the patient's ID
number.
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Sample Data — Column Definitions

Ej Sample.Phcvital Properties

Find column name: [

Column Name Type

Sorted {APROTOCOL Text

- PATIENT Number
by W VITTIME Number
W VITRRATE  Number
'W.VITHRATE  Number
7. VITSYSBP Number
7. VITDIABP Number

7

00 0w o 0

.W!”.“".\‘e

=3 el =

General | Detas | Cohams | inderes | ety | Passwords |

Length Format Informat Label

Protocol Identifier
Patient Identifier

Vital Signs: Time
Respiratory Rate (/min)
Heart Rate (bpm)

SBP (mmHg)

DBP (mmHg)

0K Cancel

The code uses the PHCVital SAS table, available in the download package of

this workshop.

The PROTOCOL column indicates whether the patient was enrolled in clinical

trial "ABC 123" or "XYZ 987".

The data values in VITTIME column are displayed with 2 decimal places.

The table is sorted by the PROTOCOL column, then PATIENT, and then

VITTIME.
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-
Sample Data - Typical Values
4 VIEWTABLE: Sample Phcvital ol e =
Protocol Patient Respiratory ‘ Veal Signs: | HeatRate | SBP DBP &
identfier | Identfier | Rate (/min) Time bpm) | (omHg) | (mmHg)
1_|ABC13 1 16 200 105 135 8
2 |aBc123 1 9 -1.00 59 128 7
3 |aBC123 1 9 002 64 126 83
4 |aBC123 1 9 008 64 123 91
5 |ABC123 1 12 017 ” 136 %
6 |ABC123 1 14 025 60 130 )
7 |aBC123 1 16 100 7 135 7
8 |ABC123 1 12 200 n 124 65
9 |ABC123 1 12 3.00 81 132 7
10 |ABC123 1 21 400 80 120 70
11 |ABC123 1 19 5.00 80 120 70
12 |ABC123 1 16 800 % 150 %0
13 |ABC123 1 2 24.00 80 120 70
14 |ABC123 2 15 200 7 % 56
15 |ABC123 2 12 -1.00 55 135 78
16 |ABC123 2 12 002 50 127 7
17__|ABC123 2 14 008 58 104 7
18 |ABC123 2 13 017 54 123 7
19 |ABC123 2 18 025 55 12 75
20 _|ABC13 2 2% 1.00 60 116 7
> 5 B
3240 |xvzse 10 10 02 6e 154 %
3241 _|XvZ987 110 10 008 66 154 98
3242 | XYz 987 110 8 017 64 148 %
3243 | XYz 987 110 2 025 66 148 91
3244 |XYZ 987 110 12 1.00 5% 148 )
3245_|XYZ 987 110 18 200 58 115 59
3246_|XvZ 987 110 16 300 67 13 58
3247 | XYz 987 110 16 400 7 123 56
3248 |XvZ 987 110 20 500 7 110 7
3249 | XYz 987 110 2 8.00 88 125 80
3250 XYz 987 110 2 2400 76 110 0T
1 ;

SBP = Systolic Blood Pressure

DBP = Diastolic Blood Pressure
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Technique #1:
The EXPORT Procedure

AT
/ NS

sas LA orum
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Creating CSV Files w/ PROC EXPORT

m Creates only delimited files w/ Base SAS®9

m CSV = Comma Separated Values

m SAS/ACCESSP® required for native Excel files

m Not available on z/OS

m Procedure output not supported

m Good for exchanging data; limited/no formatting

m Multi-sheet workbooks require manual steps
(Excel Text Import Wizard)

/ SASGLOBALFORUM
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The first technique for getting SAS data into Excel uses the EXPORT procedure
to read the data from a SAS table and write it to two CSV files.

The procedure is available only for Windows and UNIX operating systems, and

is limited to creating delimited files if only Base SAS® software is licensed. The
SAS/ACCESS® Interface to PC Files software must be licensed to create native
Microsoft Excel workbooks.

"Export Procedure”. Base SAS® 9.3 Procedures Guide.
http://tinyurl.com/clthmza

SAS/ACCESS® 9.3 Interface to PC Files: Reference.
http://tinyurl.com/ccpe790
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Creating CSV Files w/ PROC EXPORT

title 'Subject ID: #BYVAL(patient)';

proc export data=sample.PHCVital (where=(protocol='ABC 123'))
outfile='VitalSigns-ExportABC.csv'
dbms=csv label replace;

run; quit;

proc export data=sample.PHCVital (where=(protocol='XYZ 987'))
outfile='VitalSigns-ExportXYZ.csv'
dbms=csv label replace;

run; gquit;

The EXPORT procedure is run twice using the WHERE data set option because
the WHERE and BY statements are not supported in that procedure.

The DBMS and LABEL options specify that a CSV file is created that contains
column labels when available, instead of column names.

If the output file exists, it will be overwritten because the REPLACE option is
specified.
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Creating CSV Files w/ PROC EXPORT

| VitalSigns-ExportABC.csv - Notepad =5 EoH ==
File Edit Format View Help

['‘Protocol Identifier"”,"Patient Identifier"”,"vital Signs: Time","Respirat .
ABC 123,1,-2.00,16,105,135,84

ABC 123,1,-1.00,9,59,128,73

ABC 123,1,0.02,9,64,126,83

ABC 123,1,0.08,9,64,133,91

ABC 123,1,0.17,12 72 136 90

ABC 123,1,0.25,1( = 5 o
ABC 123.1,1.00,1| | VitalSigns-ExportXYZ.csv - Notepad [l 0=
ABC 123,1,2.00,1) File Edit Format View Help

ABC 123,1,3.00,1] = g : Yoy o P :
ABC 123,1,4.00,2| ['Protocol Identifier”,"Patient Identifier”,"vital signs: Time","Respirat .

ABC 123,1,5.00,1| Xvz 987,1,-2.00,18,85,183,112
ABC 123,1,8.00,1| X¥Z 987,1,-1.00,10,94,110,63
ABC 123,1,24.00,| X¥Z 987,1,0.02,10,61,110,63
ABC 123,2,-2.00,[ X¥Z 987,1,0.08,10,59,126,84
ABC 123,2,-1.00,| XYz 987,1,0.17,16,83,163,124
ABC 123,2,0.02,1| XvZz 987,1,0.25,24,75,157,95

ABC 123,2,0.08,1| XYZ 987,1,1.00,18,74,160,95
ABC 123,2,0.17,1| X¥Z 987,1,2.00,12,78,140,90
ABC 123,2,0.25,1| X¥Z 987,1,3.00,20,76,165,100
ABC 123,2,1.00,2| XYZ 987,1,4.00,20,88,170,120
ABC 123,2,2.00,2| XYZ 987,1,5.00,20,76,150,110

Xyz 987,1,8.00,20,80,160,100

Xyz 987,1,24.00,,,,

Xyz 987,2,-2.00,18,100,125,75

Xyz 987,2,-1.00,9,75,140,80

Xyz 987,2,0.02,9,76,135,85

Xyz 987,2,0.08,9,81,136,87

Xvyz 987,2,0.17,9,92,139,87

Xyz 987,2,0.25,9,98,140,80

Xyz 987,2,1.00,17,98,127,79

Xyz 987,2,2.00,16,93,136,88 v

« m »

<

11

CSV is a plain-text format consisting of data fields separated by commas.

Because the exported files only contain the data values, no Excel features such
as formats, formulas, and colors, can be supported.
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Creating Multi-Sheet Workbooks from CSV

1. Start Excel

2. Data — Get External Data — From Text

xﬂ d s - Microsoft Excel o B =8
“ Home Insert Page Layout Formulas Data Review View Developer SAS o@o@ R
3 5 ﬂ 3] connections Al vl ( ¢ % - N (2 Data validation + 9 Group ~ -
| Zv |z|a X e »
= i3 > = S Fia Consolidate & Ungroup = ==
GetExternal|  Existing | Refresh %) sot | Fitter o Textto Remove 2
Data ~ Connections  All~ = Edtt O Advanced | Columns Duplicates =2 WhatIf Analysis ~ | & Subtotal
Open SAS Data Connections Sort & Filter Data Tools Outline

From Web
From Text

=
=
) From Access
.y From Other Sou%es »

Because Excel cannot automatically create a multi-sheet workbook from

delimited files, we must manually import the data from each CSV file into its own
worksheet.
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Creating Multi-Sheet Workbooks from CSV
3. Choose VitalSigns-ExportABC.csv

%] Import Text File
OO: 1 0] ET—
Organize »  New folder - 00 @

%) ViatSigns-ExportABC.csv Fi 1) VeatSigns-ExportXVZ.csv
=) M ft Excel Comma Separate __Ja M ft Excel Comma Separate.
‘ ) 541 k8 ] 422 k8

File pame: v [TetFiles Combtrcs) |

4. Continue with the Text Import Wizard
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Creating Multi-Sheet Workbooks from CSV

Text Import Wizard - Step 1 of 3 (-5 |[a)

==

The Text Wizard has determined that your data is Delimited.
If this is correct, choose Next, or choose the data type that best describes your data.
Original data type

Choose the file type that best describes your data:
- - Characters such as commas or tabs separate each field.

Fixed width - Fields are aligned in columns with spaces between each field.

Startimportatrow: |1 % File origin: 437 : OEM United States E]

Preview of file C:\HOW\DelGobbo \VitalSigns-ExportABC.csv.

otocel Identifier”,"Patient Identifier”,"Vital Signs: Time", "Respirat{ +
BC 123,1,-2.00,16,105,135,84
123,1,-1.00,9,59,128,73
123,1,0.02,9, 64,126,863
123,1,0.08,9, 64,133,91

1

In Step 1 of the wizard, select Delimited in the Original data type group, and
then click Next >.
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Creating Multi-Sheet Workbooks from CSV

Text Import Wizard - Step 2 of 3

below.

Delimiters

Data preview

This screen lets you set the delimiters your data contains. You can see how your text is affected in the preview

[7] Treat consecutive delimiters as one

Text gualifier: |~

2]

C 123
C 123
C 123
C 123
< m

rotocol Identifier Patient Identifier [ital Signs: Time Respiratory Rate |4

2.00 Le
1.00 ]
.02 <]
.08 P -

AN
SAS.GLOBALFORUM

N\

15

Select Comma in the Delimiters group and then click Next >.
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Creating Multi-Sheet Workbooks from CSV

Text Import Wizard - Step 3 of 3
This screen lets you select each column and set the Data Format.
Column data format
9 General
‘General' converts numeric values to numbers, date values to dates, and all
Text remaining values to text.
pe: oo 7]
Do not import column (skip)
Data preview
nezal nezal
ital Signs: Time Respiratory Rate |4
F2.00 he
F1.00 2]
p.oz B
p.os 2] -

(o ) (o)

Accept the default values and then click Finish.
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Creating Multi-Sheet Workbooks from CSV

Import Data (7)==
Where do you want to put the data?
©) Existing worksheet:

[=sas1] 3
New worksheet
(poperes..) [0 [ cons

Choose cell Al for the location to place the data, and then click OK to complete
the import process.
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. .
Creating Multi-Sheet Workbooks from CSV
#d = Bookl - Microsoft Excel o B ®
m Home  Inset  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@oF@ =

A B C D E F G H =
1 Protocol identifier Patient Identifier Vital Signs: Time Respiratory Rate (/min) Heart Rate (bpm) SBP (mmHg) DBP (mmHg)
2 |ABC123 1 -2 16 105 135 8
3 ABC123 1 -1 s 59 128 7
4 ABC123 1 0.02 9 64 126 83
5 ABC123 1 0.08 s 64 133 91
6 ABC123 1 017 12 72 136 %0
7 ABC123 1 0.25 1 60 130 82
8 ABC123 1 1 16 73 135 7
9 ABC123 1 2 12 72 124 65
10 ABC123 1 3 12 81 132 77
11 ABC123 1 4 21 80 120 70
12 ABC123 1 5 19 80 120 70
13 ABC123 1 8 16 96 150 30
14 ABC123 1 24 20 80 120 7
15 ABC123 2 -2 15 72 94 56
16 ABC123 2 -1 12 55 135 78
17 ABC123 2 0.02 12 50 127 77
18 ABC123 2 0.08 14 58 104 7B
19 ABC123 2 017 13 54 123 79
20 ABC123 2 0.25 18 55 122 75
21 ABC123 2 1 4 60 116 78
22 ABC123 2 2 24 66 133 68
23 ABC123 2 3 2% 7 115 64
24 ABC123 2 4 23 76 130 70
25 ABC123 2 5 20 72 130 70
26 ABC123 2 s 4 80 120 30
27 ABC123 2 2 32 9% 160 100
28 ABC123 3 -2 20 9% 157 104
29 ABC123 3 -1 12 86 100 68 L
4 4> W] Sheetl Sheet2 Sheet3  ©J ‘ »
Ready | 7 - 5|01 [ 100% (= ¥) 18

Repeat the import process for the "VitalSigns-ExportXYZ.csv" file.

The EXPORT procedure cannot be used to create the workbook that we want.
Because CSV files are limited to data values, PROC EXPORT is limited to
exporting only data values to Excel.

If you're only interested in moving data values from SAS to Excel, then PROC
EXPORT is a quick and easy way to accomplish the task.

To save a copy of the file in Excel binary (xIs) format using Excel 2002, 2003, or
2010, select File — Save As and then, from the Save as type drop-down list,
select Microsoft Excel Workbook (*.xIs). If you're using Excel 2007, click the
Microsoft Office Button, and then select Save As — Excel 97-2003
Workbook.

If you're using Excel 2007 or 2010 and want to save the document in the
Microsoft Office Open XML format, choose Excel Workbook (*.xlsx) from the
Save as type drop-down list.

SASGF13
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Run Setup.sas
Start SAS

ol.l—
File > Open Program Q

Navigate to C:\HOW\DelGobbo\
Select Setup.sas and click Open

CUEE ol A

Review code and submit

l L >MLFORUM

NV~ 19

sAS.G

The SAMPDIR global macro variable specifies the directory containing our
sample code and data, as well as the SAS output.

The program assigns a SAS library (SAMPLE) for the input SAS data set.

SASGF13
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Ex. 1 - PROC EXPORT
Go to SAS

File > Open Program > Exercise1.sas
Review code and submit
Start Excel

Use Data > Get External Data ... to import
"VitalSigns-ExportABC.csv"

o M 0N =

7. Close document; keep Excel open

SASGF13
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6. Optional: Repeat import for "VitalSigns-ExportXYZ.csv"

SAS.GILOBALFORUM
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ODS Basics

The Output Delivery System (ODS) is capable of creating files that can be
opened by Excel, and is used in the next two techniques.

SASGF13
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ODS Basics

m Part of Base SAS

Easily generate multiple output types (HTML, RTF, PDF,
XML, etc.)

m A "destination" creates the actual output

A "style" controls the appearance
‘ HTML Or RTF Or PDF ...

Usage:
ods DestName style=StyleName file=... ;

* Your SAS procedure code here;

ods DestName close;

22

ODS is the part of Base SAS that enables you to generate different types of
output from your procedure code. An ODS destination controls the type of
output that is generated (HTML, RTF, PDF, etc.). An ODS style controls the
appearance of the output (colors, fonts, border lines, etc.).

Both a destination and a style are needed to generate output. If you do not
specify a style, a default style is used.

SASGF13
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Technique #2:

ODS CSVALL Destination
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Creating CSV Files w/ ODS CSVALL

m Creates only delimited (CSV) files

m Multi-sheet workbooks require manual steps
(Excel Text Import Wizard)

Good for exchanging data; limited/no formatting
Layout different than PROC EXPORT

Available on all operating systems

Non-graphic procedure output supported

3 6§ALFORUM

24

SAS.

Like PROC EXPORT, we can use the ODS CSVALL destination to create CSV
files containing our SAS data, and manually import the files into Excel.

Unlike PROC EXPORT, the CSVALL destination is supported on all operating
systems, and you can use it to export non-graphic procedure output to Excel.

SASGF13
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Creating CSV Files w/ ODS CSVALL

options nobyline;
title 'Subject ID: #BYVAL(patient)';

ods csvall file='VitalSigns-ODSABC.csv';
proc print data=sample.PHCVital noobs label;
by protocol patient;

pageby patient;
where (protocol eq 'ABC 123');
run; quit;
ods esvall close;

ods csvall file='VitalSigns-ODSXYZ.csv';
proc print data=...;

by ...; wvar ...; pageby ...;
where (protocol eq 'XYZ 987');
run; quit;

ods csvall close;

options byline;

var vittime vitrrate vithrate wvitsysbp vitdiabp;

25

The ODS CSVALL destination and the PRINT procedure export the PHCVital
table to CSV files "VitalSigns-ODSABC.csv" and "VitalSigns-ODSXYZ.csv".

We use #BYVAL to display the current value of the PATIENT BY-variable in the
document title, and the NOBYLINE system option prevents showing the same

information in the document.

Because CSV files contain only data values, the ODS STYLE option is not used.

"ODS CSVALL Statement". SAS ® 9.3 Output Delivery System: User's Guide.

http://tinyurl.com/b86s846

"TITLE Statement". SAS® 9.3 Statements: Reference.
http://tinyurl.com/acp9kah
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Excel Text Import Wizard
) ¥ e @ =
m Home  Inset  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@ao@ R
A B c D E F G H i 5

1 SubjectiD:1

2

3 |vital Signs: Time Respiratory Rate (/min) Heart Rate (bpm) SBP (mmHg) DBP (mmHg)

4 - 16 105 135 84

5 1 9 59 128 73

6 0.02 9 64 126 83

7 0.08 9 64 133 91

3 017 12 72 136 %0

9 0.25 14 60 130 82

10 1 16 73 135 73

n 2 12 72 124 65

12 a 12 81 132 7

13 4 21 80 120 70

14 5 19 80 120 70

15 8 16 %6 150 %0

16 2 20 80 120 70

17

18 Subject ID: 2

19

20 Vital Signs: Time Respiratory Rate (/min) Heart Rate (bpm) SBP (mmHg) DBP (mmHg)

21 2 15 72 94 56

2 1 12 55 135 78

2 0.02 12 50 127 77

2 0.08 14 58 104 7

P 017 13 54 123 79

26 0.25 18 55 122 75

27 1 2 60 116 78

28 2 2 66 133 68

2 3 2 n 115 6 i
44 » M| Sheet1 Sheet2 ~'Sheets ./ %J .~ - N« w1
Ready | 7] 3|0 0 100% (=) +) 26

The result of importing the CSV files using the Excel Text Import Wizard is closer
to what's desired, but lacks colors and formatting.
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Ex.2-ODS CSVALL

Go to SAS &

File > Open Program > Exercise2.sas g
Follow TO DO instructions & submit code

Start Windows Explorer

Navigate to C:\HOW\DelGobbo\

Double click VitalSigns-ODSABC.csv

Note insufficient column widths

0 @ B e e A

Close document; keep Excel open

SAS.GLOBALFORUM

N\” 27

TO DO:

Line 11: Add the SAS System Option to suppress BY-line text, submit the code,
and then view a CSV file in Excel by double-clicking the file.

Note that when opening the CSV file with Excel by double-clicking, the column
widths are different that when importing the file using the Excel Text Import
Wizard.

SASGF13
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Technique #3:

ODS ExcelXP Tagset
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Creating an XML File w/ ODS ExcelXP

Available on all operating systems

Non-graphic procedure output supported

Procedure output layout retained

Creates Microsoft-supported XML file

m Rich formatting and Excel features supported

Multi-sheet workbook created automatically

While the two previous techniques produced CSV files, those files don’t support
the output and styling options that we want. To get those we need to use the
ExcelXP tagset, a type of ODS destination that creates XML output that can be
opened with Excel.

Unlike the delimited (CSV) files generated by the prior technigues, using the
ODS ExcelXP tagset allows you to take advantage of rich Excel features, such
as multiple worksheets, formats, and colors. All formatting and layout are
performed by SAS; there is no need to hand-edit the Excel workbook. You
simply use Excel to open the file created by ODS.

Because the ExcelXP ODS tagset creates files that conform to the Microsoft
XML Spreadsheet Specification, you can create multi-sheet Excel workbooks
containing the output from almost any SAS procedure. The exception is that the
Microsoft XML Spreadsheet Specification does not support images, so the
output from SAS/GRAPH® software procedures cannot be used.

"XML Spreadsheet Reference".

http://tinyurl.com/3p6sked

SASGF13
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Creating an XML File w/ ODS ExcelXP

title 'Subject ID: #BYVAL(patient)';

ods tagsets.ExcelXP file='VitalSigns-ExcelXP.xml'
style=Printer;

proc print data=sample.PHCVital noobs label;
by protocol patient;
var vittime vitrrate vithrate vitsysbp vitdiabp;
pageby patient;
* No WHERE statement needed;
run; quit;

ods tagsets.ExcelXP close;

/ SAS.GL 0 #@LFORUM

N\ /2 30

The ExcelXP tagset generates the output, and the Printer style controls the
appearance of the output.

Unlike the previous techniques, the PRINT procedure is run only once to create
a single file ("VitalSigns-ExcelXP.xml") with data from both trials.

You should use the .xml extension instead of .xls or .xlsx, because Excel 2007
and 2010 display a warning if the .xml extension is not used.

"When you open a file in Excel 2007, you receive a warning that the file format
differs from the format that the file name extension specifies".

http://support.microsoft.com/kb/948615

SASGF13
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Opening the XML File with Excel

Start Excel
File > Open
Navigate to ...\VitalSigns-ExcelXP.xml

and click Open
~OR~

Navigate to output directory and
double-click VitalSigns-ExcelXP.xml

Excel reads and converts the XML file to the Excel format. After the conversion,

you can perform any Excel function on the data.

SASGF13
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Opening the XML File with Excel
X d = o B =®
m Home  Inset  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@eo@ R
A B c D £ =
1 Protocol Identifier=ABC 123 Patient 1
2 Vital Signs: Time| R Rate (/min) Heart Rate (bpm)]  SBP (mmHg)] DBP (mmHg)
3 2| 16/ 105) 135 84
4 1 9 59) 128 73
5 002 9 6 126 83
6 008 9 64 133 o1,
7 017 12 7] 136 %)
8 025 14 6 130 82
9 1 16, 73 135 73
10 2 12 72 124 65
1 3 12 81 132 77
12 4 2 80| 120 70)
13 5 19 20 120 70|
14 8 16/ % 150 90)
15 24 20 80) 120 70)
16
17
18
19
20
21
2
2
2
2
2%
27
28 v
4 4% ¥ Table 1 - Protocol Identifier=A .~ Table 2 - Protocol Identfier=A Table 3 - Protocol 1d{]] 4 3|
Reay | 7 0@ 100% +

32

The "VitalSigns-ExcelXP.xml" file resembles our desired layout, but has the

following differences:

1. Each trial-patient combination appears in its own worksheet, resulting in 250
worksheets. Patient information should be grouped by trial (PROTOCOL

variable), resulting in only 2 worksheets.

2. Unattractive, default worksheet names are used.

3. Standard BY-group text (Protocol Identifier=ABC 123 Patient Identifier=1)
precedes the table, instead of the TITLE statement text.

4. Not all of the data values in column A are displayed with two decimal places.

We can now change the SAS code to correct these problems.

SASGF13

Copyright © 2013, SAS Institute Inc. All rights reserved.

32



Ex. 3 - Creating the Initial Workbook
Go to SAS

File > Open Program > Exercise3.sas
Review code and submit

Go to Windows Explorer

Navigate to C:\HOW\DelGobbo\
Double click VitalSigns-ExcelXP.xml

o1 BT 0 e A

Close document; keep Excel open

SAS.GIL(
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ExcelXP Tagset Options

O Swﬂax:options(option-name='qption-valueW

Example: Hard-coding worksheet name

options (sheet name='worksheet-name’) ;

Option values must be quoted

m Can have multiple ODS statements

Options remain in effect until changed

The ExcelXP tagset supports many options that control both the appearance
and functionality of the Excel workbook. Most of these tagset options are simply
tied directly to existing Excel options or features. Tagset options are specified in
an ODS statement using the OPTIONS keyword, as shown above.

ODS automatically generated unique worksheet names, but we can use the
SHEET _NAME option to explicitly specify a worksheet name.

IMPORTANT NOTE: Tagset options remain in effect until they are set to another
value, or until the ODS destination is closed.
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Grouping & Naming Worksheets by Trial

m SHEET_ INTERVAL - When to create worksheets
m SHEET LABEL - Prefix for worksheet name

Trial ABC 123

Trial XYZ 987

ods tagsets.ExcelXP options(sheet_ interval='bygroup'

sheet label='Trial');

By default, the ExcelXP tagset creates a new worksheet when a SAS procedure
creates new tabular output. Because a new table is created for each of the 250
combinations of PROTOCOL and PATIENT, the initial workbook contains 250
worksheets, each with a unique name as required by Excel.

We can fix this by setting the SHEET _LABEL option to specify the prefix to use
for the worksheet names, and setting the value of the SHEET _INTERVAL option
to bygroup. This combination generates 2 worksheets, one for each distinct

value of the PROTOCOL BY-variable.
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Grouping & Naming Worksheets by Trial

title :::;

ods tagsets.ExcelXP file='VitalSigns-ExcelXP.xml'
style=Printer;

ods tagsets.ExcelXP options (sheet interval='bygroup'
sheet label='Trial') ;

proc print data=...;

.

run; quit;

ods tagsets.ExcelXP close;

sasq ﬁ&:\dLFORUM
/24 36

The additional ODS statement to handle the tagset options.

NOTE: When specifying additional ODS statements, do not specify the FILE,
STYLE, or any other keyword or option that is supported by ODS. Those
options should be specified only on the initial ODS statement.
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Grouping & Naming Worksheets by Trial

@

Developer SAS

o @ =
vc@o@ =

Home  Inset  Pagelayout  Formulas  Data  Review  View
A B

(=

D

. <]

Protocol Identifier=ABC 123 Patient
q Vital Signs: Time R Rate (/min) Heart Rate (bpm)| _ SBP (umHg)| DBP (mmHg)
| 2 16 105 135 8
| a 1 9 59 128 73
5 002 9 64 126, 8
| 6 0.0 9 [ 133 91
|7 017 12 72| 136 50
8 025 14 60| 130 8
9 1 16 73 135 73
| 10 2 12 72| 124 65
|1 3 12 81 13 7
12 4 2 0| 120 70
|13 5 19 0| 120) 70
|14 8 16 %| 150) %
15 %) 2 0| 120) 70
16
Protocol Identifier=ABC 123 Patient Identifier=2
# Vital Signs: Time| Rate (/min) Heart Rate SBP DBP.
|19 2 15 72 % 56
| 20 1 12 55 135 8
|21 002 12 50 127 7
2 008 14 58 104 73
|23 017 13 54 123 bl
|24 025 18 55 122 75
|25 1 24 60| 116 78
2% 2 % 66| 133 68
27 3 % 7 115 [
|4 4> W Trial ABC 123 Tral XvZ 587 _ ngl (30
[Reaoy |3 | | [EBD @ 100% (= 0 +) 37

We now have 2 worksheets with multiple tables in each worksheet.
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Ex. 4 — Group & Name Worksheets by Trial

Go to SAS &

File > Open Program > Exercise4.sas g
Follow TO DO instructions & submit code

Go to Excel

File > Recent

Select VitalSigns-ExcelXP.xml

Note worksheet names and groupings

0 @ B e e A

Close document; keep Excel open

TO DO:

Lines 18 and 19: Supply values for the ExcelXP tagset options to control the
worksheet names, submit the code, and then view the XML file
in Excel from the Recent Workbooks panel.
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Replacing BY-Line Text w/ TITLE Text

m SUPPRESS_BYLINES — Omit BY line text
= EMBEDDED_TITLES - Include TITLE statement text

ods tagsets.ExcelXP options(sheet interval='bygroup'
sheet label='Trial'
suppress bylines='yes'
embedded titles='yes');

BY-line text appears in the worksheets because the PRINT procedure is
executed with a BY statement. Some of the text is redundant because the value
of Protocol Identifier is displayed in the worksheet name.

To omit the BY-line text, specify the SUPPRESS BYLINES tagset option. Do
not attempt to use the NOBYLINE system option, like we did with the CSVALL
destination. Doing so would disable BY-group processing in the ExcelXP tagset
when SHEET_INTERVAL is set to bygroup.

By default, SAS titles and footnotes appear as Excel print headers and print
footers, respectively, and are displayed when the Excel document is printed. To
include title text on-screen, in the worksheet body, use the EMBEDDED_TITLES
option.
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Replacing BY-Line Text w/ TITLE Text

ods tagsets.ExcelXP file=... style=...;

ods tagsets.ExcelXP options (sheet interval='bygroup'
sheet label='Trial'
suppress_bylines='yes'
embedded titles='yes') ;

proc print data=...; run; quit;

ods tagsets.ExcelXP close;

sASGILOBALFORM
A\ 40
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The new options are shown in context.
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#SASGF13

Replacing BY-Line Text w/ TITLE Text

@9 ~-|s VitalSigns-ExcelXP.xml - Microsoft Excel o B =
Home  Inset  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@o@ R
| 4| A 8 c D E =
}L | Subject 1D: 1 4 r
2
3 Vital Signs: Time) R Rate (/min) Heart Rate (bpm)| _SBP (mmHg)| DBP (mmHg)
4 -2 16) 105 135 84
5 1 9 59 128 73|
‘ 6 002 9 64 126 8
5 008 9 61 133 91
v RV S ol YV S IV RIS T S Y Y W e

N\
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Ex. 5 - Replacing BY-Line Text w/ TITLE Text

Go to SAS &

File > Open Program > Exercise5.sas g
Follow TO DO instructions & submit code

Go to Excel

File > Recent

Select VitalSigns-ExcelXP.xml

Note TITLE text in worksheet body

Close document; keep Excel open

0 @ B e e A

TO DO:

Lines 21 and 22: Add the 2 ExcelXP tagset options to suppress BY-line text and
embed title text into the document, submit the code, and then
view the XML file in Excel from the Recent Workbooks panel.
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ODS Style Overrides

m Supported by PRINT, REPORT, and TABULATE
m Change any ODS style attribute via STYLE=

m Example:
Location Attributes
var vittime /
style (column) = [font style = italic
background = orange]

m Refer to the ODS documentation for a list of supported
attributes

m Refer to PRINT, REPORT, and TABULATE doc for
sample usage

/ SASGLOBALFORUM

Z 43

Style overrides are supported by the PRINT, REPORT, and TABULATE procedures,
and can be specified in several ways, with the most common shown here.

This example overrides the font style and the cell background color attributes for the
data values in the VITTIME column.

"Style Attributes Tables". SAS® 9.3 Output Delivery System User: User's Guide.
http://tinyurl.com/a6vo5yq

"PRINT Procedure: Examples". Base SAS ® 9.3 Procedures Guide, Second Edition.
http:/tinyurl.com/ct3j7t4

"REPORT Procedure: Examples". Base SAS ® 9.3 Procedures Guide, Second Edition.
http:/tinyurl.com/axnqrd4

"TABULATE Procedure: Examples". Base SAS ® 9.3 Procedures Guide, Second
Edition.

http:/tinyurl.com/bdqgl4c
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ODS Style Overrides — Example Output

@E9--|= VitalSigns-ExcelXPxml - Microsoft Excel e @ =
- Home Insert Page Layout Formulas Data Review View Developer SAS o e =] =
4| A I B I c ) E |
1 Subject ID: 1 (=]
2
3
L
5
6
7
&
B
10
1
12

M 4 v M| Trial ABC 123 . Trial XYZ 987 %0 14

Reaty | 7 |
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Location Values for PROC PRINT
[ ave

obsheader header header
obs column
obs column column
obs column column
obs column column
obs column column
bylabel total total

45

Style overrides are applied to specific parts of your SAS output. These specific
parts of your SAS output are called locations.

The COLUMN location of PROC PRINT controls the appearance of data cells.

Two decimal places are not always used for the time values in our workbook.
We use a style override to apply an Excel number format to these values.

"SAS® 9 Reporting Procedure Styles Tip Sheet".
http://tinyurl.com/3cfqdv9
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Excel Number Formats

office.microsoft.com/assistance/hfws.aspx?AssetiD=HP051995001033

Positive numbers Zeroes
1 1
#,##0.00; [Red] (#,##0.00); 0.00; "sales "@
I
Negative numbers Text

# — numeric digit, excluding insignificant zero

0 — numeric digit, including insignificant zero

sasGLOBALFORM
/24 46

The general structure of Excel number formats is shown here.

The pound sign (#) in an Excel format is used to represent a numeric digit,
excluding insignificant zeroes, and a zero (0) displays a numeric digit, including
insignificant zeroes.

Use zeros in Excel formats when you want to retain leading or trailing zeroes.
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Excel Number Format Examples

Positive numbers Zeroes
_ 1
#,##0.00; [Red] (#,##0.00); 0.00; "sales "@
{
Negative numbers Text
Raw Formatted
Value Value Features
5 0.50 . .
Leading & Trailing O's
5 5.00
123 123.00 Trailing 0's
1234 1,234.00 Trailing 0’s , Comma
-1234 (1,234.00) | Leading/Trailing 0's, Comma, Red ()
0 0.00 Special Zero Handling
data sales data Special Text Handling

47

This table shows the results of applying the Excel format shown to several data
values. Because negative values do not need to be considered differently than
positive values, we only use the "Positive numbers" section of the format.

Excel 2003 Help. "Create or delete a custom number format".
http://office.microsoft.com/assistance/hfws.aspx?AssetiID=HP005199500

Excel 2007 Help. "Create or delete a custom number format".
http://office.microsoft.com/assistance/hfws.aspx?AssetID=HP001216503

Excel 2010 Help. "Create a custom number format".
http://office.microsoft.com/assistance/hfws.aspx?AssetID=HP010342372

"Number Format Codes".
http://office.microsoft.com/assistance/hfws.aspx?AssetID=HP005198679
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Apply Excel Format to Time Values

proc print data=sample.PHCVital noobs label;
by protocol patient;

var vittime /
style (column)=[tagattr='format:0.00'];

var vitrrate vithrate vitsysbp vitdiabp;

pageby patient;
run; quit;

sasq ﬁ&:\dLFORUM
/24 48

We use the Excel format 0. 00 with the ODS TAGATTR attribute to specify an

Excel format. Be sure to quote the entire attribute value and include the
format: keyword.

To apply the style override to only the VITTIME column, we split the single VAR
statement into two separate statements.
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Ex. 6 — Apply Excel Format to Time Values

Go to SAS &

File > Open Program > Exercise6.sas g
Follow TO DO instructions & submit code

Go to Excel

File > Recent

Select VitalSigns-ExcelXP.xml

Note formatted time values

0 @ B e e A

Close document; keep Excel open

TO DO:

Line 25: Supply the value of the Excel format needed to display 2 decimal
places, submit the code, and then view the XML file in Excel from the
Recent Workbooks panel.
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Using SAS/IntrNet®
and
SAS Stored Processes
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SAS/IntrNet® and SAS Stored Processes

m SAS code is run from non-SAS client
m SAS is on any platform

m Client needs only a Web browser

m SAS output is delivered in real-time

m \Web-enable the code we've been using

/ SASGLOBALFORUM

NV~ 51

The purpose of the SAS/IntrNet® Application Dispatcher or SAS Stored
Processes are to allow you to execute SAS programs from a client machine that
does not have SAS installed. The client machine may have SAS installed, but
that is not required.

A typical client-server model is followed. The SAS server can reside on any
hardware platform (Windows, UNIX, z/OS, etc.) and is standing by, waiting to
execute a SAS program. The most common client is a Web browser, again,
running on any platform.

When the "OK" button of the Web page is clicked, input parameters, if any, are
sent to the SAS server. Your SAS code executes, and the output is delivered in
real-time to the Web browser.

The following slides illustrate this process, using a Web-enabled version of the
SAS code we have been working on.
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Dynamically-Generated XML

(o] o s
GQ @ £~ B¢ X || @ sample: Patient Vital Signs |
File Edit View Favortes Tools Help
3 v B v~ 0 @ v Pagev Safety~v Toolsv @~
S SAS/IntrNet® Application Dispatcher

Sample: Patient Vital Signs

This sample is based on the code used in the Hands-on Workshop entitied, "Some Techniques for Integrating SAS
Output with Microsoft Excel Using Base SAS"

Clicking the "Download to Excel" button causes SAS to dynamically generate a multi-sheet Excel workbook that is
automatically opened by Excel

Download to Excel Show SAS Log

#®100% ~

52

Here is a simple Web page that is used to execute SAS code stored on a server

using the SAS/IntrNet Application Dispatcher.

The code that is executed is substantially similar to the final version of the code

that we used to generate XML file, with a few changes to "Web-enable" it.

Refer to the accompanying paper for instructions on how to Web-enable your

code.

Clicking Download to Excel executes the SAS program on the server.
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Dynamically-Generated XML

Do you want to open or save VitalSigns.xml (1.68 MB) from localhost? Open Save v Cancel

sAsGLOBALFORUM

\VZ 53

Once the SAS program executes, the results are sent back to the Web browser.

Instead of the results being displayed in the Web browser, you are presented
with a "File Download" dialog box.

You can click Open to immediately open your SAS output using Excel, or click
Save to save a copy for later use.
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.
Dynamically-Generated XML
@d = VitalSigns-ExcelP.aml - Microsoft Excel e @ =
Home  Insert  Pagelayout  Formulas  Data  Review  View  Developer  SAS v@ocd@ R
[ A B C D E &l
1 Subject ID: 1
2
3 Vital Signs: Time| R Rate (/min) Heart Rate (bpm)]  SBP (mmHg)| DBP (mmHg)|
4 2,00 16 105 135 8
5 00 9 59) 128 73
6 0.02 9 64 126 83
7 0.8 9 64 133 91,
8 0.7 12 7 136 9
9 025 14 60) 130 2
10 100 16 73] 133 7
1 200 12 7 124 65
12 300 12 81 1322 7
13 400 2 80) 120 0
14 5.00 19 80) 120 0
15 800 16 0 150 %)
16 24.00 20 80 120 0
17
18 Subject ID: 2
19
20 Vital Signs: Time| R Rate (/min) Heart Rate (bpm)|  SBP (mmHg)| DBP (mmHg)|
21 200 15 7| 9 56
2 100 12 55 135 8
2 002 12] 50) 127 7
2 0.8 1 58 104 3
25 017 13 54 123 79
26 025 18 55 122 5
27 100 2| 60) 116 B -
W < M| Tral ABC 123 TralXYZ 967 _ %d [+ 10
Ready | 7 | 5|00 B 100% (= o+ 54

Here is the SAS output, created in real-time, and delivered to the client. Refer to
the accompanying paper for more information about this topic.

SAS/IntrNet® 9.3: Application Dispatcher.
http://tinyurl.com/3qgpxzlg

SAS® 9.3 Stored Processes: Developer's Guide.
http://tinyurl.com/3wyw6fk
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Conclusion

PROC
Feature EXPORT
Supported on all operating systems o
Multiple worksheets o2
BY value in worksheet name o?
Suppress BY line text .

Variable labels in column headings
Support title, footnote & BY text
Title text contains subject ID
Multiple tables in a worksheet
Formatted column headings
Support for Excel number formats
Style formatting support

Little or no manual intervention

TExcept z/0OS 2Requires manual steps

oDs
CSVALL

OoDS
ExcelXP
Tagset

55

This table lists the features supported by the 3 techniques.
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Conclusion

m Delimited files best for data exchange
m Limited/no formatting w/ delimited files

m Use ExcelXP tagset to create richly-formatted XML
file

m Resulting XML file can be viewed with Excel
m Make use of tagset options

m Apply ODS style overrides

m Use Excel formats instead of SAS formats

/ SASGLOBALFORUM

NV~ 56

The EXPORT procedure creates delimited files that are useful for exporting only
data values to Excel - style formatting is not supported. The ODS CSVALL
destination also creates delimited files, but supports some additional features,
such as title, BY-line, and footnote text.

The SAS 9 ExcelXP ODS tagset provides an easy way to export your SAS data
to Excel workbooks that contain multiple worksheets. By using ODS styles,
style overrides, and a tagset that complies with the Microsoft XML Spreadsheet
Specification, you can customize the output to achieve your design goals.

SAS Institute continues to work toward better Microsoft Office integration, and
future releases of SAS software will provide even more robust means of using
SAS content with Microsoft Office applications.
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Resources
m Paper & Download Package

support.sas.com/rnd/papers/index.html#excel2013

m Vince's ExcelXP Resources

www.sas.com/reg/gen/corp/8672267page=Resources

SAs.éLp LFORUM
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Contact Information

Please send questions, comments and feedback to:

Vince DelGobbo
sasvcd@SAS.com

If your registered in-house or local SAS users group would like
to request this presentation as your annual SAS presentation
(as a seminar, talk or workshop) at an upcoming meeting,
please submit an online User Group Request Form
(support.sas.com/usergroups/namerica/lug-form.html) at least
eight weeks in advance.
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