FOCUS AREAS

Resources for Intelligence Platform Migration

Quick Links

SAS Migration Utility

Migration

Moving to SAS® 9.3 or SAS® 9.2

In the Analysis Report that is generated by the SAS Migration Utility, you can find warnings about products or components that do not meet these baseline requirements.

A copy of the SAS Migration Utility is available to download for a preliminary analysis of your SAS environment before migration. When you are ready to proceed with your migration, use the SAS Migration Utility that is included in your order to perform your analysis, assess requirements, and create the migration package. If you use a SAS Migration Utility other than the version included in your order, it might support a different set of products and components than your order, and the migration package could produce inaccurate results.

Other useful tools are the ViewRegistry Report, the PRODUCT_STATUS procedure, and the SAS Installation Reporter (see SAS Note 35968). See also How to document your SAS environment.


Migrating from SAS 9.2 to SAS 9.3

If you are migrating from SAS 9.2 to SAS 9.3, you are required to be running SAS 9.2 (TS2M0) or later. You are not required to apply a SAS 9.2 maintenance release before migrating.

SAS OpRisk VaR

The previous deployment must be at SAS OpRisk VaR 4.2 or later.

SAS 9.3 Documents


Migrating from SAS 9.1.3

If you are migrating to SAS 9.2 or to SAS 9.3, the topics below cover SAS 9.1.3 updates or hot fixes that are required before a deployment can be migrated.

SAS 9.1.3 SP4

For most products, you are required to be running SAS 9.1.3 SP4. You can determine the SAS version and service pack level by running some SAS code and viewing the SAS log. The service pack level is displayed at the top of the SAS log when you run a job. If SP4 is not installed, then you must upgrade before you create a migration package with the SAS Migration Utility. Contact SAS and request SAS 9.1.3 SP4, or download it from the support site.

SAS BI Report Services

If you have Query and Reporting Services 3.1 in your SAS 9.1.3 deployment, you meet the baseline requirements for SAS Migration Utility. If you have a version prior to Query and Reporting Services 3.1, then you must upgrade before you create a migration package with the SAS Migration Utility. Contact SAS and request Upgrading the SAS BI Applications and Applying SAS Service Pack 4.

SAS Data Integration Studio

Here are the requirements in SAS 9.1.3 SP4:

To upgrade Data Integration Studio and its metadata to the baseline, contact SAS and request an upgrade package, and follow these instructions (which are also provided in the upgrade package):

  1. If you are currently running SAS/Warehouse Administrator, contact your SAS Representative. A SAS consultant can convert metadata from SAS/Warehouse Administrator to metadata for any version of SAS Data Integration Studio. For more information about the conversion, see a topic about SAS/Warehouse Administrator.

  2. If you are currently running Data Integration Studio or ETL Studio, an administrative user at your site can upgrade the metadata. Here are some important notes:
    • Upgrading the metadata is not necessary for all clients, just one client per metadata server. If you have more than one metadata server, then perform this iterative upgrade with one client on each metadata server.
    • This upgrade must be performed by an administrative user.
    • Uninstall one client and reinstall the next version in this list. Do not skip directly to version 3.4. For example, if you are currently running ETL Studio 9.1.3, you must upgrade metadata at version 3.2, then at version 3.3, and finally at version 3.4.
    • Do not go backward in the list. For example, if you are currently running version 3.3, you only need to upgrade metadata at version 3.4.
    • You must uninstall before you reinstall.

    Here are the version numbers in order. If you are currently running:

    ETL Studio 9.1, 9.1.2, or 9.1.3: Start the client, and the client's update metadata tool runs automatically. If you are currently running version 9.1, you must upgrade to version 9.1.2 before you can upgrade to version 9.1.3.

    ETL Studio 3.2: Copy the file sas.dbuilder.update.jar from the installation directory to the plugins directory. Then, in ETL Studio, log on to the Foundation repository as the unrestricted user. From the Tools menu, select Update Prototypes.

    ETL Studio 3.3 or Data Integration Studio 3.3: If SAS Management Console is not already installed on the machine, then when you install ETL Studio or Data Integration Studio, the installation prompts you for the location of the file sas.dbuilder.update.jar. Copy the jar file to the plugins directory of a SAS Management Console deployment. To perform the upgrade, start SAS Management Console and log on to the metadata server as the unrestricted user. From the Tools menu, select Update SAS ETL Studio Prototypes (or Update SAS Data Integration Studio Prototypes).

    Data Integration Studio 3.4: Apply hot fix E9BA20 (actually, its most recent replacement) to the metadata server. The hot fix is supported for Data Integration Studio 3.4 only. Do not apply the hot fix if you are running a previous version of Data Integration Studio. After you apply the hot fix, in SAS Management Console select the appropriate Foundation repository. From the Tools menu, select Update Metadata for SAS Data Integration Studio.

  3. After the administrative user has upgraded one client of Data Integration Studio iteratively to version 3.4, then any user can upgrade individual clients to version 3.4. Users do not need to install interim releases; they can upgrade directly to version 3.4. The analysis report does not indicate the clients that need upgrade to baseline. You must check all clients in your deployment.

SAS Grid Manager

Here are the requirements in SAS 9.1.3 SP4:

SAS IT Management Solutions Core Components Data Tier

Apply hot fix 311IS04 or its most recent replacement. Be aware that hot fixes can be replaced by more recent hot fixes. Install the most recent hot fix bundle for SAS IT Resource Management 3.1.1.

SAS Web OLAP Viewer for JAVA

SAS Web OLAP Viewer 3.1 and SAS 9.1.3 SP4 are the baseline requirements for migration. If you have a version of SAS Web OLAP Viewer prior to 3.1, then you must upgrade before you create a migration package with the SAS Migration Utility. Contact SAS and request Upgrading the SAS BI Applications and Applying SAS Service Pack 4.

SAS Web Report Studio

SAS Web Report Studio 3.1 and SAS 9.1.3 SP4 are the baseline requirements for migration. If you have a version of Web Report Studio prior to 3.1, then you must upgrade before you create a migration package with the SAS Migration Utility. Contact SAS and request Upgrading the SAS BI Applications and Applying SAS Service Pack 4.

Third-Party Products

WebDAV Content

WebDAV Content from any SAS 9.1.3 supported WebDAV environment meets the SAS Migration Utility baseline requirements, and will be moved to the SAS Content Server in the new deployment. Refer to the Install Center for SAS 9.1.3 supported WebDAV versions.

SAS 9.2 Documents


Contributing to Migration

The migration team appreciates your feedback. Send e-mail to Migration.Feedback@sas.com with questions and comments for our developers, testers, and writers.